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Intel@ Math Kernel Library, http://www.intel.com/software/products/mkl

SuperLU_MT version 2.0 - Copyright © 2003, The Regents of the University of California,
through Lawrence Berkeley National Laboratory (subject to receipt of any required
approvals from U.S. Dept. of Energy). All rights reserved. SuperLU Disclaimer: THIS
SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
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INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

7-zip - 7-Zip Copyright: Copyright (C) 1999-2009 Igor Pavlov. Licenses for files are:
7z.dll: GNU LGPL + unRAR restriction, All other files: GNU LGPL. 7-zip License: This library
is free software; you can redistribute it and/or modify it under the terms of the GNU
Lesser General Public License as published by the Free Software Foundation; either
version 2.1 of the License, or (at your option) any later version. This library is distributed
in the hope that it will be useful,but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details. You should have received a copy of the
GNU Lesser General Public License along with this library; if not, write to the Free
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
unRAR copyright: The decompression engine for RAR archives was developed using source
code of unRAR program.All copyrights to original unRAR code are owned by Alexander
Roshal. unRAR License: The unRAR sources cannot be used to re-create the RAR
compression algorithm, which is proprietary. Distribution of modified unRAR sources in
separate form or as a part of other software is permitted, provided that it is clearly stated
in the documentation and source comments that the code may not be used to develop a
RAR (WinRAR) compatible archiver. 7-zip Availability: http://www.7-zip.org/

AMD Version 2.2 - AMD Notice: The AMD code was modified. Used by permission. AMD
copyright: AMD Version 2.2, Copyright © 2007 by Timothy A. Davis, Patrick R. Amestoy,
and Iain S. Duff. All Rights Reserved. AMD License: Your use or distribution of AMD or any
modified version of AMD implies that you agree to this License. This library is free
software; you can redistribute it and/or modify it under the terms of the GNU Lesser
General Public License as published by the Free Software Foundation; either version 2.1 of
the License, or (at your option) any later version. This library is distributed in the hope
that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
General Public License for more details. You should have received a copy of the GNU
Lesser General Public License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA Permission is
hereby granted to use or copy this program under the terms of the GNU LGPL, provided
that the Copyright, this License, and the Availability of the original version is retained on
all copies.User documentation of any code that uses this code or any modified version of
this code must cite the Copyright, this License, the Availability note, and "Used by
permission." Permission to modify the code and to distribute modified code is granted,
provided the Copyright, this License, and the Availability note are retained, and a notice
that the code was modified is included. AMD Availability:
http://www.cise.ufl.edu/research/sparse/amd

UMFPACK 5.0.2 - UMFPACK Notice: The UMFPACK code was modified. Used by permission.
UMFPACK Copyright: UMFPACK Copyright © 1995-2006 by Timothy A. Davis. All Rights
Reserved. UMFPACK License: Your use or distribution of UMFPACK or any modified version
of UMFPACK implies that you agree to this License. This library is free software; you can
redistribute it and/or modify it under the terms of the GNU Lesser General Public License
as published by the Free Software Foundation; either version 2.1 of the License, or (at

http://www.7-zip.org/
http://www.7-zip.org/
http://www.cise.ufl.edu/research/sparse/amd
http://www.cise.ufl.edu/research/sparse/amd
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your option) any later version. This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies. User documentation of any
code that uses this code or any modified version of this code must cite the Copyright, this
License, the Availability note, and "Used by permission." Permission to modify the code
and to distribute modified code is granted, provided the Copyright, this License, and the
Availability note are retained, and a notice that the code was modified is included.
UMFPACK Availability: http://www.cise.ufl.edu/research/sparse/umfpack  UMFPACK
(including versions 2.2.1 and earlier, in FORTRAN) is available at
http://www.cise.ufl.edu/research/sparse . MA38 is available in the Harwell Subroutine
Library. This version of UMFPACK includes a modified form of COLAMD Version 2.0,
originally released on Jan. 31, 2000, also available at
http://www.cise.ufl.edu/research/sparse . COLAMD V2.0 is also incorporated as a built-in
function in MATLAB version 6.1, by The MathWorks, Inc. http://www.mathworks.com .
COLAMD V1.0 appears as a column-preordering in SuperLU (SuperLU is available at
http://www.netlib.org ). UMFPACK v4.0 is a built-in routine in MATLAB 6.5. UMFPACK v4.3
is a built-in routine in MATLAB 7.1.

Qt Version 4.6.3 - Qt Notice: The Qt code was modified. Used by permission. Qt copyright:
Qt Version 4.6.3, Copyright (c) 2010 by Nokia Corporation. All Rights Reserved. Qt
License: Your use or distribution of Qt or any modified version of Qt implies that you agree
to this License. This library is free software; you can redistribute it and/or modify it under
the
terms of the GNU Lesser General Public License as published by the Free Software
Foundation; either version 2.1 of the License, or (at your option) any later version. This
library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies.User
documentation of any code that uses this code or any modified version of this code must
cite the Copyright, this License, the Availability note, and "Used by permission."
Permission to modify the code and to distribute modified code is granted, provided the
Copyright, this License, and the Availability note are retained, and a notice that the code
was modified is included. Qt Availability: http://www.qtsoftware.com/downloads  Patches
Applied to Qt can be found in the installation at:
$HPEESOF_DIR/prod/licenses/thirdparty/qt/patches. You may also contact Brian
Buchanan at Agilent Inc. at brian_buchanan@agilent.com for more information.

The HiSIM_HV source code, and all copyrights, trade secrets or other intellectual property
rights in and to the source code, is owned by Hiroshima University and/or STARC.

http://www.cise.ufl.edu/research/sparse/umfpack
http://www.cise.ufl.edu/research/sparse/umfpack
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.mathworks.com
http://www.mathworks.com
http://www.netlib.org
http://www.netlib.org
http://www.qtsoftware.com/downloads
http://www.qtsoftware.com/downloads
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Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file
names and directory names. The business entity formerly known as "HP EEsof" is now part
of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and
to maintain backward compatibility for our customers, we did not change all the names
and labels that contain "HP" or "HPEESOF" references.

Warranty The material contained in this document is provided "as is", and is subject to
being changed, without notice, in future editions. Further, to the maximum extent
permitted by applicable law, Agilent disclaims all warranties, either express or implied,
with regard to this documentation and any information contained herein, including but not
limited to the implied warranties of merchantability and fitness for a particular purpose.
Agilent shall not be liable for errors or for incidental or consequential damages in
connection with the furnishing, use, or performance of this document or of any
information contained herein. Should Agilent and the user have a separate written
agreement with warranty terms covering the material in this document that conflict with
these terms, the warranty terms in the separate agreement shall control.

Technology Licenses The hardware and/or software described in this document are
furnished under a license and may be used or copied only in accordance with the terms of
such license. Portions of this product include the SystemC software licensed under Open
Source terms, which are available for download at http://systemc.org/ . This software is
redistributed by Agilent. The Contributors of the SystemC software provide this software
"as is" and offer no warranty of any kind, express or implied, including without limitation
warranties or conditions or title and non-infringement, and implied warranties or
conditions merchantability and fitness for a particular purpose. Contributors shall not be
liable for any damages of any kind including without limitation direct, indirect, special,
incidental and consequential damages, such as lost profits. Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily
provided to end user customers. Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212
(Computer Software) and, for the Department of Defense, DFARS 252.227-7015
(Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial
Computer Software or Computer Software Documentation).

http://systemc.org/
http://systemc.org/
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 About Broadband Spice Model
Generator
The Broadband SPICE Model Generator tool converts the frequency domain network
parameter data of passive components obtained by measurements and/or simulations into
equivalent circuit models for direct use with commercially available circuit simulators.

The Broadband SPICE Model Generation tool supports input model data available in a
number of different file formats. This includes measured data, as well as, data generated
by EM and frequency-domain simulators for ease of use. It also supports the output model
data in several different file formats, so that the data can be easily used with a number of
different circuit simulators. For example, transient, frequency domain, envelope, and
harmonic balance.

 

 Supported Operating Systems

Broadband Spice Model Generator is supported on all operating systems supported by
ADS. See the installation documentation for more details.

 

 Accessing the Documentation

To access the documentation for Broadband SPICE Model Generator, from any ADS
window select Help > Topics and Index > Simulation > Model Creation >
Broadband SPICE Model Generator, or from the Broadband SPICE Model Generator
main menu select Help > Topics and Index.

 

 Broadband SPICE Model Generator Use Model

 The following diagram outlines the process flow for the Broadband SPICE Model
Generator engine:
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 Using Broadband SPICE Model Generator

  

 Broadband Spice State File

Broadband SPICE uses ASCII state files (.stf) to save and recall tool dialog settings. A
default state file is provided with Broadband Spice, which is used to initialize the
Broadband Spice tool with the default values. The default state file, named bbs_default.stf
is located in the $HPEESOF_DIR/bbspice/config directory.

The default Broadband Spice state file is configurable on a <workspace>/<user>/<site>
basis like other ADS tools.

Following is an example of a Broadband SPICE application state file:

input.performSmoothing 0;

input.smoothingSize 1;

input.isMeasuredData 0;

model.dataSampling All;

model.targetAccuracy 5.000000e-3;

model.autoGenerate 1;

fitting.globalPolesImposed 1;

fitting.minDeltaPolesZeros -1;
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fitting.maxDeltaPolesZeros 0;

fitting.maxVFIterations 5;

fitting.leastSquareMode NORMAL;

fitting.normalizeMatrix 1;

fitting.useRelaxation 0;

passivity.mirrorPolesIntoLHP 1;

passivity.enabled 1;

passivity.maxPreDataTruncation 9.999000e-001

passivity.maxNrIterations 5;

passivity.maxPostModelScaling 9.950000e-001;

output.spice2g6 0;

output.spice3 1;

output.agilentModel 1;

output.useInputDir 0;

output.path networks/;

dataset.generate 2;

dataset.path data/;

dataset.opendds 1;

datadisplay.name S_Nport_BBSMG;

 

 Starting Broadband SPICE

To start the Broadband SPICE tool, select Tools > Spice Model Generator > Start
Broad Band Generator from a Schematic window. The Broadband Spice Model
Generator window is displayed, as shown below:

 

In the simplest operation, it is only necessary to specify the input file name and file type
before generating a model. In this case, the engine generates and uses the values for the
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advanced options based on its processing of the input data and the information contained
in the default Broadband SPICE state file. The output file types and directory placement
have been selected to easily facilitate the use of these models in ADS.

The Broadband Spice Model Generator window provides three tabs: Standard, Advanced
Input, and Advanced Output. These tabs are described in the following sections.

 Standard Options Tab

The following selections are available under the Standard Options tab:

 

 Providing the Input Data

 The input data used by Broadband Spice must contain S-parameter information with a
reference impedance of 50 Ω.

Note
If only other network parameters are available (such as, Y, Z, H, and ABCD), only S-data transformation is
required.

 

 Selecting a File Type

 The following figure displays the input files supported by Broadband Spice:

Dataset: ADS binary format
Citifile:
Touchstone:
Momentum RAT: Momentum rational ( .rat ) files are the output result of a
Momentum AFS simulation. These files contain information about the rational fitting
model of a single Momentum simulation and are located under the <mom_dsn> /<
layout_name> directory of your workspace. When using this file type, you must
provide the .rat filename (generally <proj>.rat). It is preferred, but not required,
that the .sam file is in the same directory as the .rat file.

Note
The .sam file contains information about the frequency samples chosen by the Momentum AFS algorithm.
It is recommended that you use the name of your layout as a prefix for the output model files.

Input parameter data must have a reference impedance of 50 ohms.

Default: None specified

 

 Input File Name

Enables you to select your input file. This can be done by typing the path and filename, or
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by selecting the Browse button.

  

 Output Dialog

This dialog enables you to select the type of models that are generated by the Broadband
SPICE Model Generator tool.

 

 Specifying a File type

Two model files, <filename>.ckt and <filename>.bbn, are created when you select the
ADS check box. These file types specifies two different versions of the Broadband Spice
model represented by ADS netlists. The <filename>.bbn netlist describes a polynomial
representation, while the <filename>.ckt netlist is an ADS version of the spice3 format.

In some cases, the generation of the rational polynomial model will fail due to numerical
representation inaccuracies. In this case a warning is issued and only the <filename>.ckt
model file is created.

Note
The <filename>.bbn and <filename>.ckt files are used with BBSnP circuit components in ADS schematics.
For more information on using these files in ADS, refer to Using Broadband SPICE Models in ADS (bbspice)

 The preferred input file type for simulations in a schematic layout using a Broadband
SPICE component is <filename>.bbn.

If HSPICE is selected, a <filename>.hsp is created By default, a description using a
pole/zero representation is used. An alternative representation using pole/residues can
also be dumped. In order to do this, you must add a line " output.hspicePoleRes 1; " in
the state file. This will generate a <filename_Foster>. hsp file. Hspice versions from 2007
on will be able to process the pole/residue representation.

If SPECTRE is selected, a <filename>. scs file is created.

If SPICE3 is selected, a <filename>. sp3 file is created. This file can also be used in
hspice simulations.

If SPICE2 is selected, a <filename>.sp2 file is created. This format is not recommended,
since it requires the engine to perform extra transformations which could diminish the
accuracy of the output.

If the .s2p file is used, it is possible that a number of warnings will be issued with regard
to the magnitude of the lumped elements. These warnings can be ignored.

Caution
Noise behavior of the models Noise is suppressed in the generated models.
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Note
If you require a SPICE output, we recommended that you use the SPICE3 or HSPICE format and not the
SPICE2 format.

Default: ADS , SPICE3 and HSPICE

 

 Output Log

This window displays status messages regarding various Broadband SPICE operations, for
example, model generation.

 Output Log

To empty the contents of this window, select Clear.

The Advanced input options located directly above the Output log indicates the status of
the advanced options. It will either read automatic or specified.

If automatic, the input data-dependent advanced option values are automatically
calculated during model generation. If specified, the input data-dependent advanced
option values specified in the dialog will be used.
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 Advanced Input Options Tab

Note
The Advance Input Options tab page can be accessed only after a valid file name and type is specified on
the Standard Options tab.

 Advanced Input Options Tab

The following selections are available under the Advanced Input Options tab:

 

 Input File-dependent Options Dialog

Certain advanced input options are highly dependent on the input data. These values are
initially disabled in the dialog and cannot be modified. It is possible that model generation
will fail, or will produce inaccurate results if these option values are not consistent with the
input data. Because of this it is recommended that you let the engine calculate these
values automatically during model generation. However, if desired, these option values
can be specified manually in the dialog. The next section describes how this can be done.

 

 Use auto-generated values determined at run-time

When this checkbox is checked the Broadband SPICE engine determines the optimum
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values to be used, during model generation run-time, based on the values present in the
input file. When this checkbox is checked, only Amplitude threshold and Fitting tolerance
values are editable.

When un-checked, the values shown in the dialog will be used during model generation,
and all fields are enabled for editing. If the current values are un-initialized (as indicated
by Number of frequencies set to " -1" or "unspecified") un-checking this checkbox will
cause all dependent option values to be generated and initialized in the dialog with the
recommended values.

 

 Re-generate values

Clicking this button causes all of the input file-dependent options to be re-generated and
set back to their recommended values. This button is enabled only when the Use auto-
generated values determined at run-time checkbox is un-checked.

Default: Checked

Note
The engine is run to initialize or re-generate the option values. This operation normally takes only a few
seconds. When the operation has finished the values in the dialog are updated automatically.

 

 Data (S-Parameter) dialog

 

 Number of frequencies

This is the number of frequency points of the original input data. This value cannot be
changed manually. A value of "-1" or "unspecified " indicates that the values shown in the
dialog are un-initialized, and that they will be re-calculated and updated the next time
either the Use auto-generated values determined at run-time checkbox is un-checked, or
the Re-generate values button is pressed. A data file with too few frequency points will
result in "Underdetermined set of equations" error. Lower the maximum number of poles
in such case.

  

 Minimum frequency and maximum frequency

These values specify the minimum and maximum frequency of the input data to be used
when the output models are generated. The recommended, initial values correspond to
the minimum and maximum frequencies specified in the input data. When modifying these
fields the following rules must be followed:

The new minimum frequency may not be less than the minimum frequency of the
input data.
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The new maximum frequency may not be greater than the maximum frequency of
the input data.
The minimum frequency may not be greater than the specified maximum frequency.

Note
Changing these fields is not recommended.

 

 Data sample

This dropdown box specifies the number of data samples used when generating the output
model, relative to the Number of frequencies (defined above) in the input data.

A distinction should be made between the different types of input files when using this
option. Different file types provide better results if the following rules are applied.

Momentum RAT : The recommended setting is AllX2
Momentum saves a limited number of data points in the .rat and .sam files.
Therefore, the preferred setting is AllX2. However, All or AllX5 may also be used.
Dataset, Citifile and Touchstone : The recommended setting is ReducedX20

The fields All , ReducedX2 , ReducedX5 , ReducedX10 , ReducedX20 and ReducedX50 can
all be selected. Reducing the number of data points may be helpful, especially if there are
a large number of frequencies in the input data and the number of poles is limited. This
can provide a large time gain without any loss of accuracy. If a chosen reduction removes
too many data points, a warning is issued and an automatic switch to a less coarse
reduction scheme is executed.

 

 Amplitude threshold

To facilitate passivity later on, the singular values of the S-parameters are upper limited
to the amplitude threshold. If the singular values of the S-parameters are greater than 1,
by definition, the input data is not passive (this may be caused by measurement noise or
numerical simulation inaccuracies).

 Limiting the max value of the input data to the specified Amplitude threshold value is a
preprocess passivity enforcement step which is applied on all discrete data samples. The
recommended value is 1 or slightly less than 1 (e.g., 0.9999).

If you wish to skip this preprocess step, you can specify a very large value (e.g., 100 or
so). This is not recommended.

Default Value: 0.9995

 Moving Average for Data Smoothing

This applies a moving average to the original input data which is used to smooth it out
and prevent unnecessary noise from being modeled. As a rule, data containing
unnecessary noise leads to a larger circuit size. This functionality is especially useful when
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applied to measurement data, as it generally contains more noise than simulation data.

Default: Un-checked

 Number of Points to be Averaged Together

You can specify the number of points to be averaged together. This must be a positive odd
number.

  

 Data sparsification

This dialog enables you to do a selection of S-parameters to be modeled dependent on
their RMS or maximum value. By default, all S-parameters are selected. The sparsification
threshold sets the Limit to decide whether a scattering parameter is taken into account. In
the generated model the unselected S-parameters are set to zero, independent of the
frequency. In order to see which input data is selected, test file <filename>.sle is
generated.

 

 Default:

RMS-based selected and Sparsification set to 0.

  

 Model

The input data is used to generate a rational model. This model has the form of a series
expansion in partial fractions:

The factors rn are the residues, while pn are the poles. In total, there are N such terms:

Depending on the dynamics of the input data, the number of terms (N) varies.

So, the number of poles (and thus terms) is dependent on the input data. The
recommended range for the number of poles is based on the analysis of the dynamics of
the input data. You are free to modify this number if desired.

  

 Number of poles: Minimum, maximum and step

The recommended, initialized values are calculated based on the dynamic behavior of the
input data.
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If the fitting process does not converge, or if passivity enforcement fails, changing the
number of poles may lead to convergence and passivity. This is especially true for noisy
data, when it can be difficult to estimate the Minimum and Maximum number of poles of
the system.

Step defines the sweep step within the interval [Minimum, Maximum] number of poles. It
is by definition larger or equal to zero and smaller than |Maximum - Minimum| number of
poles.

  

 Fitting tolerance

This is the allowed root mean square (RMS) fitting error. It is the criterion to decide if the
rational fit will be successful or not. If the RMS value of the rational model fitted data is
less than the fitting tolerance, the model is considered to be converged.

The recommended setting for this value ranges between 0.001 to 0.02.

Default Value: 0.005

 

 Fitting

  

 Use relaxed fitting

A s lightly different rational fitting algorithm (using relaxation) is used in the model
generation when this box is checked. If the default fitting procedure does not converge,
this option can be switched on or off.

Default: Checked

 

 Use global poles

Checking this box causes all S-parameters to share a common set of poles. This setting is
advised if the number of ports is limited. If the number of ports is higher (typically above
4), un-checking this box may increase the speed of the fitting process, but significantly
decrease the speed of the passivity enforcement process.

Default: Checked

  

 Strictly proper

If the Strictly proper box is checked, the following properties are valid:
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N = D - 1, with N the polynomial degree of the numerator and D the polynomial degree
of the denominator of the rational model.

If the box is un-checked, the rational model is called proper and (D - 1) ≤ N ≤ D.

Note
If passivity for very high frequencies is desired, selecting Strictly proper is recommended.

Default: Un-checked

  

 Mirror poles into left-half plane

This parameter forces the non-physical poles to be mirrored into the left half complex
plane. Note that poles must be in the left half plane in order to obtain a passive model. If
fitting convergence fails, modifying this field can lead to convergence.

Default: Checked

  

 Matrix solver

This field enables you to control the speed versus accuracy of the model generation. If
there are many ports and data samples, Normal equations is the preferred setting. If
accuracy is the most important criterion and speed is not essential, then Singular value
decomposition should be selected. If none of these factors are important, and if the
number of poles and ports are limited, QR factorization may be used.

Default: Normal equations

 

 Maximum number of iterations (Fitting)

This is the number of pole relocation steps (≥1). The higher this value, the more time it
can take for model generation. Values between 4 and 7 are recommended.

Default: 5

 

 Passivity
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 Enforce passivity

This enables you to select whether the passivity of the rational model will be checked or
imposed.

If passivity enforcement is not selected, the output files are generated based on the
rational fitting model. If passivity enforcement is selected, an additional post-processing
step is performed, which can modify the coefficients of the fitting model to ensure
passivity. After this step is executed, the output files are generated based on the
(passivity enforced) rational fitting model.

Default: Selected

  

 Maximum model scaling

This is an optional scaling factor, only meant to suppress minor (remaining) passivity
violations. For example, if a maximum passivity violation of 1.0001 remains after passivity
enforcement, a scaling of the broadband model by 0.9999 will resolve all remaining
passivity issues.

It is the very last step in a series of passivity enforcement actions and equally affects all
frequencies (from DC to infinity). The Maximum model scaling is the lower end of the
scaling factor allowed to be used to enforce passivity.

If the you want to skip this post processing step, specify an input a value ≥ 1 in this field.
The recommended setting is slightly less than 1 (e.g., 0.999).

Default Value: 0.995

  

 Maximum number of iterations (Passivity)

This is the number of passivity enforcement steps.

If the value is set to 0, passivity is not enforced, although a passivity check is performed
on the rational fit model.

Default: 5

Note
If passivity enforcement is not selected, all output files will contain the rational fitting model of the input
data. If passivity enforcement is selected, all output files contain the passive rational fitting model of the
input data.

 

 Advanced Output Options Tab

 Advanced Output Options Tab
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 Advanced Output Options Tab

Note
The Advanced Output Options tab can only be accessed once a valid file name and file type have been
specified on the Standard Options tab page.

The following selections are available under the Advanced Output Options tab.

 

 Verification Dataset

 Open data display when simulation completes

This dialog enables you to automatically open a data display and a data display template
after the model generation finished. Using this you can easily compare your original data
to the modeled data in the display.

Checking this box enables this functionality.
Default: Checked

 Template

This enables you to choose the template name that will be shown in the data display.
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Default: _S_Nport_BBSMG_

 

 Data directory selector

This dialog enables you to select whether or not to save a dataset of the rational model,
select a prefix name for this dataset and choose a directory in which to save it.
Using this dialog you can choose to:

Not save a data set
Save the dataset in the input file directory
Use a specified directory

If you select the Use directory specified below radial button, you can supply a directory
path directly, or use the Browse... button to find the desired location. This path defaults to
the current workspaces data directory.

 

 Dataset name prefix

This enables you to choose a unique name for the output dataset.

 

 Dataset name

Lists the current path and dataset name to be used for the output file. When a new path is
selected the current path and dataset name are automatically updated.

 

 Broadband SPICE Model Generation
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Once the model generation options have been specified, you may begin model generation
by either selecting Model Generation > Start from menu bar on the main Broadband
Spice Model Generator window, or by choosing the Start Model Generation icon from the
main toolbar.
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 Creating Broadband SPICE Models
This section illustrates how to use the Broadband Spice Model Generator tool to create
broadband spice models for use in ADS and other circuit simulators.

 

 Creating Models with Broadband Spice Model Generator

 The Broadband SPICE Model Generator enables you to easily create broadband SPICE
models for use in ADS and other simulators. The following section offers an example of
model creation using a single via passive component (based on full-wave EM field
simulation data) and another example of coupled microstrip lines (with input from
measurements).

 

 Broadband Spice Model Generation Examples

 

 Overview

The following examples display how to use the Broadband SPICE Model Generator tool to
create broadband SPICE models for 2 passive circuit components based on S-Parameter
data (obtained through either measurements or simulations). For using the broadband
SPICE models in an ADS frequency-domain and time-domain circuit simulation, see Using
Broadband SPICE Models (bbspice). The initial S-Parameter data is compared with the
generated broadband SPICE models. It displays that the Broadband SPICE Model
Generator tool successfully produced accurate, broadband models of the S-Parameter
data, and that these broadband SPICE models can be easily used in ADS circuit
simulators.

 Input Data

The SPICE Model Generator tool can use S-Parameter data files, in several standard file
formats, as inputs.

Note
The input data can be either measured or simulated.

 

 Model Creation Using a Package Via Structure

This example uses S-Parameter data obtained from passive circuit elements as the input
data for the broadband SPICE model generation.

The following section illustrates how to use the ADS Broadband SPICE Model Generator
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tool to create an accurate SPICE model from the input S-Parameter data.

Start ADS.1.
Select File > Unarchive Workspace or Project and unarchive the required file.2.
Open a Schematic window.3.
From the Schematic window main menu bar, select Tools > Spice Model4.
Generator > Start Broad Band Generator to open the Broadband SPICE Model
Generator window, as shown below:

 

 

 Setting up the Broadband SPICE Model Generation Tool

This section explains how to set up the tool to generate broadband SPICE models.

In the Input section of Broadband SPICE Model Generation Tool Standard Options1.
tab, select the file from the File type drop-down list.

Note
You must select a File type from in the Input section to access the Advanced Input and Advanced
Output options tab.

Click the Browse button associated with Input File Name dialog box and select the2.
required file from the Browse window.
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In the Output section, select ADS as the Output File Type.3.
Type Model_ in the Output file name prefix text box.4.

Select the Advanced Input Options tab.5.
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Remove the selection from the Use auto-generated values, determined at run-6.
time option. It generates the recommended initial values for the input data-
dependent options, and activates the deactivated selections in the Independent file-
dependent options section.

Note
The engine is run to initialize or re-generate the option values. This operation normally takes only a
few seconds. When the operation has finished the values in the dialog are updated automatically.

In the Data Sample section of this window, select the required value from the drop-7.
down list.
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Select the Advanced Output Options tab.8.
Ensure that the Dataset name prefix is set to Model.9.

Note
The only Advanced Option setting having an affect on the output model calculation, changed from its
recommended value for this example, was Data sample.

 

 Broadband SPICE Model Generation

Once the Standard, Advanced Input and Advanced Output options have been set, you are
ready to begin the model generation process.

To begin model generation, select Model Generation > Start from the Broadband1.
SPICE Model Generation main menu.
Note that once the model generation has started, the tab automatically switches to
the Standard Options page. This enables you to review the model generation status
and view other information available in the Output log dialog box.
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Model creation is now complete. To exit the Broadband SPICE Model Generation Tool,2.
select File > Exit.
Click No, if the Save Changes dialog box appears.3.
Exit ADS.4.

For information on how to use and verify these models in ADS, refer to Using Broadband
SPICE Models in ADS (bbspice).

 

 Model Creation Using an FR4 Coupled-Microstrip Lines Circuit

This example uses S-Parameter data obtained from passive circuit elements as the input
data for the broadband SPICE model generation.

The following section illustrates how to use the ADS Broadband SPICE Model Generator
tool to create an accurate SPICE model from the input S-Parameter data.

Start ADS.1.
Open the required workspace.2.
Open a Schematic window.3.
From the Schematic window main menu bar, select Tools > Spice Model4.
Generator > Start Broad Band Generator to open the Broadband SPICE Model
Generator tool.

 Broadband SPICE Model Generator Main Window
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 Setting up the Broadband SPICE Model Generation Tool

This section explains how to set up the tool to generate broadband SPICE models.

From the Input section of Broadband SPICE Model Generation Tool Standard Options1.
tab, select the required file in the File type drop-down list.

Note
You must select a File type from in the Input section to access the Advanced Input and Advanced
Output options tab.

Click the Browse button associated with Input File Name dialog and select the2.
required file from the Browse window.
In the Output section, select ADS as the Output File Type.3.
Type " Model_ " in the Output file name prefix dialog box.4.
Click the Advanced Input Options tab.5.
Remove selection from the Use auto-generated values, determined at run-time6.
option. It causes the engine to generate recommended initial values for the input
data-dependent options, and activates the deactivated selections in the Independent
file-dependent options section.
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Note
The engine is run to initialize or re-generate the option values. This operation normally takes only a
few seconds. When the operation has finished the values in the dialog are updated automatically.

In the Data Sample section of this window, select ReducedX50 from the dropdown7.
menu

Click the Advanced Output Options tab.8.
Ensure that the Dataset name prefix is set to Model_.9.

Note
The only Advanced Option setting having an affect on the output model calculation, changed from its
recommended value for this example, was Data sample.

 

 Model Generation for the FR4 Coupled-Microstrip Lines Circuit

Once the Standard, Advanced Input and Advanced Output options have been set, you are
ready to begin the model generation process.

To begin model generation, select Model Generation > Start from the Broadband1.
SPICE Model Generation main menu.
Note that once the model generation has started, the tab automatically switches to
the Standard Options page. This enables you to review the model generation status
and view other information available in the Output log dialog.
Check the Output log.2.

 Output Log



Broadband SPICE Model Generator

31

 

Note
If the accuracy of the rational model is insufficient, it is possible that selecting the Use Relaxed
fitting option will improve the accuracy.

For this specific simulation, the model generation time took much longer than in the
first example. This is due to the higher number of ports and the strong dynamical
behavior of the input data, which leads directly to a high number of poles. If the
passivity of the model is of minor importance, the execution time of the engine can
be decreased importantly by not checking the Enforce passivity parameter in the
Passivity box of the second tab Advanced Input Options.
 If passivity is not important, but if you'd like to know whether the rational fitted
model is passive, you can select the Enforce passivity parameter and set the
Maximum number of iterations to zero. In this example the rational fitting model was
already passive.
If passivity of the model is not important, the fastest way to obtain a model is to
uncheck the Use global poles option in the Fitting box of the Advanced Input Options
tab.
This completes the Model creation. Select File > Exit to exit the Broadband SPICE3.
Model Generation tool.
Click No, if the Save Changes dialog that appears.4.
Exit ADS.5.

For information on how to use and verify these models in ADS, refer to, Using Broadband
SPICE Models in ADS (bbspice).
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 Using Broadband Spice Models
This section explains how to use the models created with the Broadband Spice Model
Generator in ADS.

  

 

 Verifying the Rational Fitting Model Data for the SingleVia Structure

To verify the Broadband SPICE rational model data:

Start ADS.1.
Open a Schematic window.2.
From the ADS Main window, choose Window > New Data Display to open a Data3.
Display window.
From Data Display, select Tools > Data File Tool.4.
From the dftool main window, select the Read data file into data set option.5.
Select the required file from the File format to read and provide the dataset name.6.
Click the Read File button to finish the process.7.
Close the dftool window.8.

From the Data Display window, click the Smith Chart icon from the left toolbar to9.
insert a Smith Chart plot in the Data Display window.
Insert the following traces on the Smith Chart:10.

REF_SingleVia.S
Model_SingleVia.S_50

Note
Model_SingleVia.ds is the dataset containing the rational fitting model of the SingleVia data
created and saved during the model generation in the first example.

The following plot appears in the Data Display window:

 

 
The red trace plots the input data, and the blue trace plots the generated,
rational model data. This plot demonstrates that there is no noticeable
difference between the two and that the generated rational model is an accurate
representation of the input model data.

Close the Data Display window.11.
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 Verifying the Output Model for the SingleVia Structure

Start ADS.1.
Open a Schematic window, select File > Open.2.
Locate and open the design SingleViaFreqdomain. The following circuit should appear3.
in the Schematic window.

 SingleViaFreqdomain

 
Double-click the SNP data item to open the Edit Parameter window.4.

Click Browse with the required file type.5.
Select the required file, click Open6.
Click OK.7.
Double-click the BBS2P component BBS_BBN to open the Edit Parameter window.8.
Click Browse with the ModelFile parameter selected.9.
Select the file Model_SingleVia.bbn, click Open in the Select File window.10.
Click OK in the Edit Parameter window.11.

Note
Model_SingleVia.bbn is the ADS broadband SPICE output model file that was created and saved
during the Broadband SPICE Model Generation. The BBS2P component in the schematic now
represents this model, which will be used when the frequency circuit simulation is run.

Double-click the BBS2P component BBS_CKT to bring up the Edit Parameter window.12.
Click the Browse button with the ModelFile parameter selected.13.
In the Select File window, set the filter to All Files (.). Then, select the14.
Model_SingleVia.ckt file.
Select Simulate > Simulate from the Schematic window main menubar to perform15.
the simulation. When the simulation finishes, a Data Display window is opened:
SingleVia_FreqDomain.dds.

From the schematic representation in SingleViaFreqdomain, it is clear, for example,
that S(1,1) should be equal to S(3,3) and S(5,5). This confirms the correctness of
the ADS models and shows that the broadband SPICE generated output models are
an accurate representation of the input model.

 

 Using the SingleVia Structure Model in the Time Domain

In a Schematic window, select File > Open. Locate and open the design1.
SingleVia_TimeDomain.
The following circuit appears in the schematic window.2.

 Transient Simulation of a Broadband SPICE component
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A transient simulation of the model represented by the BBS2P component has been
set-up in this schematic. The following steps will ensure that the BBS2P component is
set-up to correctly represent the Broadband SPICE model generated in Creating
Broadband SPICE Models (bbspice).
Double-click the BBS2P component to open the Edit Parameter window.3.
Click Browse button with the ModelFile parameter selected.4.
Select the file Model_SingleVia.bbn, click Open.5.

Note
Model_SingleVia.bbn is the ADS broadband SPICE output model file created and saved during the
Broadband SPICE Model Generation.

Click OK.6.
Select Simulate > Simulate from the main Schematic window to perform the7.
transient simulation.
When the simulation is complete, select Window > Open New Data Display.8.
From the Data Display main menu, select File > Open.9.
Select the file SingleVia_sharp_pulse_response.dds and click Open.10.
The following plot appears in the Data Display window.

 Transient Simulation Plot of BBS2P

 

Note
This plot shows the results of the transient analysis of the generated SPICE model. It is the voltage
at nodes Vin and Vout vs. time.

To verify that the other ADS model (which makes use of controlled sources) of the11.
broadband SPICE output model works as well as the rational polynomial model in
ADS transient simulation, change the BBS2P ModelFile parameter value from
Model_SingleVia.bbn to Model_SingleVia.ckt and re-run the simulation. The results
are illustrated in the following plots:
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This demonstrates how easily Broadband SPICE generated output can be used in ADS
transient circuit simulations.

 

 Verifying the Rational Fitting Model for the CoupledMicrostrip Lines

You can verify the rational model data and output ADS models for the CoupledMicrostrip
lines example by following the same procedures outlined in, Verifying the Rational Fitting
Model Data for the SingleVia Structure and Verifying the Output Model for the SingleVia
Structure.

 

 Using the CoupledMicrostrip Lines Model in the Time Domain

In a Schematic window, select File > Open. Locate and open the design1.
Coupledmicrostrip_TimeDomain. The following circuit appears in the schematic
window.

 Transient Simulation of the Broadband SPICE Component

 
A transient simulation of the model represented by the BBS4P component has been
set-up in this schematic. The following steps will ensure that the BBS4P component is
set-up to correctly represent the Broadband SPICE model generated in the example
Model Creation Using an FR4 Coupled-Microstrip Lines Circuit (bbspice).
Double-click the BBS4P component to open the Edit Parameter window.2.
Click Browse with the ModelFile parameter selected. Since the .bbn file was not3.
created for this model (refer to Model Generation for the FR4 Coupled-Microstrip
Lines Circuit (bbspice)), you will use the.ckt file instead. Because of this, All Files
need to be selected in order to be make the .ckt file to selectable.
Select the file Model_Coupledmicrostrip.ckt, click Open.4.
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Note
Model_Coupledmicrostrip.ckt is the ADS broadband SPICE output model file created and saved
during the Broadband SPICE Model Generation.

Click OK.5.
Select Simulate > Simulate from the main Schematic window to perform the6.
transient simulation.
When the simulation has completed the Data Display window will open and display:7.
Model_Coupledmicrostrip_sharp_pulse_response.dds
The following plot should appear in the Data Display window:

 Transient Simulation Plot of BBS4P

 

Note
This plot shows the results of the transient analysis of the generated SPICE model. It is the voltage
at nodes Vin and Vout vs. time.

It is clear that in this example, that there is a significant delay due to the length of
the line. As you can see on the figure, the delay is about 0.9 ns. You can also see the
ringing effect, which confirms the 0.9 ns travel time.

 

 Recommendations and Tips

While using the Broadband SPICE Model Generation tool, refer to the following guidelines

If you have problem in obtaining the required convergence accuracy or passivity
level, you should select the Use relaxed fitting option in the Advanced Input Options
tab.
If the number of poles are too high, the .bbn ADS model file will not be created, in
most cases. In such cases, you should use the .ckt file instead of the .bbn file.
However, if the .bbn file is available, you should use that file.
Unless absolutely necessary, do not select .sp2 type as an your output file. The
generation of this file demands extra calculation efforts and has lower numerical
accuracy than the ADS model files and the .sp3 type.
When using Advanced Input Options, it is recommended to select the ReducedX50
value in the Data sample section, especially if the number of frequencies is high. The
engine automatically switches to a lower reduction scheme if more data samples are
needed to determine a correct model. Note that the ReducedX field can not be
applied to examples where the input file is a Momentum rational file type. For
Momentum rational files, the AllX field should be used.
The number of poles indicated in the Model section of the Advanced Input Options tab
is an estimation based on the input data. This value can be changed, if you wish, to
view the effect on the generated model. Generally, the estimated range of poles is
adequate, however, you can adjust these ranges in order to obtain better results.
This is especially the case when:
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The input data is noisy, making it hard to estimate the dynamical behavior.
You have significantly modified the minimum and maximum frequencies. In this
case, the number of poles will have to be adapted to the reduced frequency
range. It is generally acceptable to set a wide range for the Minimum and
Maximum number of poles if the correct number is not known.

If there are too many ports and poles, simulation time can grow significantly. Unless
required, skipping the passivity enforcement step can reduce the overall simulation
time.
Since the passivity enforcement calculation step can take a large portion of the total
model generation time, consider the following:

If passivity enforcement is not needed and the a passive rational fitted model in
not required, it is best to uncheck the Use global poles option in the Fitting
section of the Advanced Input Options tab.
If passivity enforcement is not needed, but you want to know whether the fitted
model is passive (without modifying the model to obtain passivity), you can
check the Enforce passivity option, but set the Maximum number of iterations in
the Passivity section to 0.
If passivity enforcement is needed, you must set Enforce passivity option and
select a number for the Maximum number of iterations, typically 5.

If the input data contains a large and dynamical system with many ports (and thus a
large simulation time), it is a good practice to run several simulations using all of the
above settings (and any other combination, as you prefer). Then, save the output
files with a different file name prefix to compare the results by using the Data Display.
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 Passive Broadband SPICE Model
Reference
This section covers Passive Broadband SPICE model symbols, parameters and notes.

 

 Overview

The Passive Broadband SPICE built-in components are available in the Schematic view of
ADS under Passive-Broadband Spice Models section.

 BBS1P (1-Port Broadband SPICE Model)

 

 Symbol

 

 Parameters
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Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model.
The directory path is optional. The default directory is <prj>/ where <prj> is your
current workspace directory

None None

 

 Notes and Equations

 

The BBSnP component is used to represent an 1-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename> .bbn (rational-polynomial formulation)
and <filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (2) is the common terminal; it is normally grounded, but can be used in non-
grounded mode.
This component has no default artwork associated with it.

 BBS2P (2-Port Broadband SPICE Model)

 

 Symbol

 

 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None

 

 Notes and Equations
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The BBSnP component is used to represent an 2-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename>.bbn (rational-polynomial formulation) and
<filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (3) is the common terminal; it is normally grounded, but can be used in non-
grounded mode.
This component has no default artwork associated with it.

 BBS3P (3-Port Broadband SPICE Model)

 

 Symbol

 

 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None

 

 Notes and Equations

 

The BBSnP component is used to represent an 3-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename>.bbn (rational-polynomial formulation) and
<filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
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Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (4) is the common terminal; it is normally grounded, but can be used in non-
grounded mode.
This component has no default artwork associated with it.

 BBS4P (4-Port Broadband SPICE Model)

 

 Symbol

 

 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None

 

 Notes and Equations

 

The BBSnP component is used to represent an 4-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename> .bbn (rational-polynomial formulation)
and <filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (5) is the common terminal; it is normally grounded, but can be used in non-
grounded mode.
This component has no default artwork associated with it.

 BBS5P (5-Port Broadband SPICE Model)
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 Symbol

 

 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None

 

 Notes and Equations

 

The BBSnP component is used to represent an 5-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename> .bbn (rational-polynomial formulation)
and <filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (6) is the common terminal; it is normally grounded, but can be used in non-
grounded mode.
This component has no default artwork associated with it.

 BBS6P (6-Port Broadband SPICE Model)

 

 Symbol
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 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None

 

 Notes and Equations

 

The BBSnP component is used to represent an 6-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename>.bbn (rational-polynomial formulation) and
<filename> .ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (7) is the common terminal; it is normally grounded, but can be used in non-
grounded mode.
This component has no default artwork associated with it.

 BBS7P (7-Port Broadband SPICE Model)

 

 Symbol
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 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None

 

 Notes and Equations

 

The BBSnP component is used to represent an 7-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename>.bbn (rational-polynomial formulation) and
<filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn ) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (8) is the common terminal; it is normally grounded, but can be used in non-
grounded mode.
This component has no default artwork associated with it.

 BBS8P (8-Port Broadband SPICE Model)

 

 Symbol

 

 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None
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 Notes and Equations

 

The BBSnP component is used to represent an 8-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename>.bbn (rational-polynomial formulation) and
<filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn ) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (9) is the common terminal; it is normally grounded, but can be used in non-
grounded mode.
This component has no default artwork associated with it.

 BBS9P (9-Port Broadband SPICE Model)

 

 Symbol

 

 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None

 

 Notes and Equations

 

The BBSnP component is used to represent an 9-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer toUsing Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename> .bbn (rational-polynomial formulation)
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and <filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn ) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (10) is the common terminal; it is normally grounded, but can be used in
non-grounded mode.
This component has no default artwork associated with it.

 BBS10P (10-Port Broadband SPICE Model)

 

 Symbol

 

 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None

 

 Notes and Equations

 

The BBSnP component is used to represent an 1-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename> .bbn (rational-polynomial formulation)
and <filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn ) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
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BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (11) is the common terminal; it is normally grounded, but can be used in
non-grounded mode.
This component has no default artwork associated with it.

   

 BBSnP (Port Broadband SPICE Model n<=99)  

 

 Symbol

 

 Parameters

Name Description Units Default

ModelFile Name of data file containing n-port Broadband SPICE ADS model. None None

 

 Notes and Equations

 

The BBSnP component is used to represent an n-Port ADS model generated by the
Broadband SPICE Model Generator tool. For information on Broadband SPICE model
files, refer to Using Broadband SPICE Models in ADS (bbspice).
Valid model file extensions are <filename>.bbn (rational-polynomial formulation) and
<filename>.ckt (controlled sources formulation).
In general, the rational polynomial model (with the extension .bbn) is recommended
over the controlled sources model. If the number of ports and/or the number of poles
associated with the model is large, though, the controlled sources (.ckt) model may
provide better results.
Broadband SPICE models are implemented as subcircuits, defined in hpeesofsim
netlist fragments. The name of the model's top-level subcircuit is displayed in the
BBSnP component's Edit Parameters dialog when a valid ModelFile is specified.
Ref pin (n+1) is the common terminal; it is normally grounded, but can be used in
non-grounded mode.
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This component has no default artwork associated with it.
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