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POSSIBILITY OF SUCH DAMAGE.
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Lesser General Public License as published by the Free Software Foundation; either
version 2.1 of the License, or (at your option) any later version. This library is distributed
in the hope that it will be useful,but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details. You should have received a copy of the
GNU Lesser General Public License along with this library; if not, write to the Free
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that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
General Public License for more details. You should have received a copy of the GNU
Lesser General Public License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA Permission is
hereby granted to use or copy this program under the terms of the GNU LGPL, provided
that the Copyright, this License, and the Availability of the original version is retained on
all copies.User documentation of any code that uses this code or any modified version of
this code must cite the Copyright, this License, the Availability note, and "Used by
permission." Permission to modify the code and to distribute modified code is granted,
provided the Copyright, this License, and the Availability note are retained, and a notice
that the code was modified is included. AMD Availability:
http://www.cise.ufl.edu/research/sparse/amd

UMFPACK 5.0.2 - UMFPACK Notice: The UMFPACK code was modified. Used by permission.
UMFPACK Copyright: UMFPACK Copyright © 1995-2006 by Timothy A. Davis. All Rights
Reserved. UMFPACK License: Your use or distribution of UMFPACK or any modified version
of UMFPACK implies that you agree to this License. This library is free software; you can
redistribute it and/or modify it under the terms of the GNU Lesser General Public License
as published by the Free Software Foundation; either version 2.1 of the License, or (at
your option) any later version. This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,

http://www.7-zip.org/
http://www.7-zip.org/
http://www.cise.ufl.edu/research/sparse/amd
http://www.cise.ufl.edu/research/sparse/amd


Schematic Capture and Layout

4

Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies. User documentation of any
code that uses this code or any modified version of this code must cite the Copyright, this
License, the Availability note, and "Used by permission." Permission to modify the code
and to distribute modified code is granted, provided the Copyright, this License, and the
Availability note are retained, and a notice that the code was modified is included.
UMFPACK Availability: http://www.cise.ufl.edu/research/sparse/umfpack  UMFPACK
(including versions 2.2.1 and earlier, in FORTRAN) is available at
http://www.cise.ufl.edu/research/sparse . MA38 is available in the Harwell Subroutine
Library. This version of UMFPACK includes a modified form of COLAMD Version 2.0,
originally released on Jan. 31, 2000, also available at
http://www.cise.ufl.edu/research/sparse . COLAMD V2.0 is also incorporated as a built-in
function in MATLAB version 6.1, by The MathWorks, Inc. http://www.mathworks.com .
COLAMD V1.0 appears as a column-preordering in SuperLU (SuperLU is available at
http://www.netlib.org ). UMFPACK v4.0 is a built-in routine in MATLAB 6.5. UMFPACK v4.3
is a built-in routine in MATLAB 7.1.

Qt Version 4.6.3 - Qt Notice: The Qt code was modified. Used by permission. Qt copyright:
Qt Version 4.6.3, Copyright (c) 2010 by Nokia Corporation. All Rights Reserved. Qt
License: Your use or distribution of Qt or any modified version of Qt implies that you agree
to this License. This library is free software; you can redistribute it and/or modify it under
the
terms of the GNU Lesser General Public License as published by the Free Software
Foundation; either version 2.1 of the License, or (at your option) any later version. This
library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies.User
documentation of any code that uses this code or any modified version of this code must
cite the Copyright, this License, the Availability note, and "Used by permission."
Permission to modify the code and to distribute modified code is granted, provided the
Copyright, this License, and the Availability note are retained, and a notice that the code
was modified is included. Qt Availability: http://www.qtsoftware.com/downloads  Patches
Applied to Qt can be found in the installation at:
$HPEESOF_DIR/prod/licenses/thirdparty/qt/patches. You may also contact Brian
Buchanan at Agilent Inc. at brian_buchanan@agilent.com for more information.

The HiSIM_HV source code, and all copyrights, trade secrets or other intellectual property
rights in and to the source code, is owned by Hiroshima University and/or STARC.

Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file
names and directory names. The business entity formerly known as "HP EEsof" is now part
of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and
to maintain backward compatibility for our customers, we did not change all the names
and labels that contain "HP" or "HPEESOF" references.

Warranty The material contained in this document is provided "as is", and is subject to
being changed, without notice, in future editions. Further, to the maximum extent
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permitted by applicable law, Agilent disclaims all warranties, either express or implied,
with regard to this documentation and any information contained herein, including but not
limited to the implied warranties of merchantability and fitness for a particular purpose.
Agilent shall not be liable for errors or for incidental or consequential damages in
connection with the furnishing, use, or performance of this document or of any
information contained herein. Should Agilent and the user have a separate written
agreement with warranty terms covering the material in this document that conflict with
these terms, the warranty terms in the separate agreement shall control.

Technology Licenses The hardware and/or software described in this document are
furnished under a license and may be used or copied only in accordance with the terms of
such license. Portions of this product include the SystemC software licensed under Open
Source terms, which are available for download at http://systemc.org/ . This software is
redistributed by Agilent. The Contributors of the SystemC software provide this software
"as is" and offer no warranty of any kind, express or implied, including without limitation
warranties or conditions or title and non-infringement, and implied warranties or
conditions merchantability and fitness for a particular purpose. Contributors shall not be
liable for any damages of any kind including without limitation direct, indirect, special,
incidental and consequential damages, such as lost profits. Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily
provided to end user customers. Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212
(Computer Software) and, for the Department of Defense, DFARS 252.227-7015
(Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial
Computer Software or Computer Software Documentation).

http://systemc.org/
http://systemc.org/
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 Program Basics
The ADS design environment is made up of multiple windows. All operations take place
within the framework of windows.

Note
Before reading this section, see Advanced Design System Quick Start (adstour) and ADS Design
Environment (adstour).

As you work with multiple windows, you may find it helpful to minimize the simulation
status window to clear additional space on your screen. To quickly restore it to the screen,
choose Window > Simulation Status from any program window.

 Design Windows

A design window is where you create and edit all of your designs. You can resize and
move these windows in the workspace. You can enlarge one window to fill the entire
workspace and you can shrink each window to an icon. ADS supports following design
windows:

Schematic Window1.
Symbol Window2.
Layout Window3.

 
 

 Schematic Window

The Schematic window is where you create your schematic designs. You can create your
design by placing components, ports, data items, units, variables, equations, etc.
To create a new Schematic, follow the steps below:

Start ADS and open an existing workspace or create a new workspace.1.
From the ADS Main Window, use any of the three options to open the New Schematic2.
dialog box:

Select File > New > Schematic.

Click New Schematic button ( )from the toolbar.
Right click on the workspace name and select New Schematic option.

In New Schematic dialog box, select the library name from the Library drop down3.
list where the new schematic will be stored.
Enter the new cell name or click the Browse Cells button to select cell from the4.
existing cells of the selected library.
Click Edit View Name to create a new schematic view with the default name i.e.5.
schematic or a new view name in View Name Editor dialog.
To start the Schematic Wizard, check the Enable the Schematic Wizard option. The6.
Schematic Wizard helps you create a design and prepares it for a simulation as if you
are working directly in the design environment. The Schematic Wizard follows the
standard ADS use-model. For more details about simulation, see Simulation Basics
(cktsim).
You can choose a template from Schematic Design Templates drop down list.7.
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These templates help you in creating your designs more quickly. You can also save
your design as template. For more details on templates, see Simulation Templates
(usrguide).
Click OK to start the Schematic window and create a new Schematic View with:8.

Schematic Wizard Window, if you checked the Enable the Schematic Wizard
option.
Design Template in drawing area of the Schematic Window, if you have chosen
the Design Template.
A blank Schematic window, if you have not selected any of the above options.

Notes

At a given point of time you can choose either Enable the Schematic Wizard or Schematic
Design Templates simultaneously.
Setup must be configured before starting any design. There are many ways to configure the
program defaults. The best configuration depends on the type of designs created, the available
options, and the type of final output required.

The following figure displays the parts of a Schematic design window:

The Title bar displays the window type, design type, filename, and a number
identifying the type of window.
The Menu bar displays the menus available in that window.
The Toolbar contains buttons for frequently used commands and for choosing the
appropriate orientation for components. The collection of buttons on the toolbar is
configurable (Tools > Hot Key/Toolbar Configuration) and can be toggled on and
off (View > Toolbar).
The Palette List enables you to choose a category of components to place on the
Component Palette.
The Component History drop-down list is continuously updated to reflect the
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components you have placed in your design. It provides a quick method of placing
another instance of a component in your design and can be used as a starting point
for creating a custom palette.
The Drawing area is where you create your designs.
The Component Palette contains buttons for placing components.
The Prompt panel provides messages to assist you during the execution of most
commands, as well as various pieces of information to assist you in creating a design.
The Pop-up menu enables you to access many common commands with a minimum
of mouse movement. You access the pop-up menu by pressing the right mouse
button in the drawing area of any design window. The context-sensitive commands
appear on the pop-up menu when the pointer is positioned over certain shapes or
text and on right click.

 
 

 Symbol Window

To create a new Symbol, follow the steps below:

Start ADS and open an existing workspace or create a new workspace.1.
From the main ADS Window, use any of the three options to open the New Symbol2.
dialog box:

Select File > New > Symbol.

Click New Symbol button ( )from the toolbar.
Right click on the workspace name and select New Symbol option.

From the Library drop down list, select the library name where the new Symbol will3.
be stored.
Enter the new cell name or click the Browse Cells button to select cell from the4.
existing cells of the selected library.
Click Edit View Name to create a new symbol view with the default name, i.e.,5.
Symbol or a new view name in View Name Editor window.
Click OK to open the symbol window where you create a Symbol View.6.
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 Layout Window

To create a new Layout, follow the steps below:

Start ADS and open an existing workspace or create a new workspace.1.
From the main ADS Window, use either of the three options to open the New Layout2.
dialog box:

Select File > New > Layout.

Click New Layout button ( )from the toolbar.
Right click on the workspace name and select New Layout option.

From the Library drop down list, select the library name where the new layout will3.
be stored.
Enter the cell name or click the Browse Cells button to select cell from the existing4.
cells of the selected library.
Click Edit View Name to create a new layout view with the default name, i.e.,5.
Layout or a new view name in View Name Editor window.
Click OK and the layout window opens where you create the Layout View.6.

 

 Insertion Layers

In a Layout window, objects are placed on a layer. The name of the current insertion layer
is displayed in the toolbar and in the status bar (see The Layout Window). You can change
the insertion layer and copy shapes from one layer to another.
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To change the insertion layer, choose either of the following options:

On the Layout window toolbar, choose the name of the layer from the drop-down list
next to the layer name.
Select Options > Layers Preferences and select a layer from the list of defined
layers in the Layer Editor dialog box.
From the layout window, select Insert > Change Entry Layer To and click an
object whose layer you want to make the current insertion layer.
Use the keyboard shortcut Ctrl+Shift+C and click an object whose layer you want to
make the current insertion layer.

To copy a shape from one layer to another:

From the Layout menu, choose Edit > Advanced Copy/Paste > Copy To Layer.
The copied shape is placed at exactly the same coordinates as the original.

When you experiment with placing shapes on different layers, remember to click OK to
accept a change in a dialog box.

 

 Inserting Components and Shapes

To create a layout, you insert components and shapes on the Drawing Area.

To insert components:

Choose a category of components to display on the Component Palette.
Click the component in the palette, then click in the Layout window to place it.

To insert a connector, ground, or trace:

Click a the item on the toolbar, then click in the Layout window to place it.

 

 Inserting Shapes

To insert shapes, choose one:

Click the shape on the toolbar, then click in the Layout window to place it.
Choose Insert > Coordinate Entry. In the dialog, enter the X and Y Increments to
place the shape.
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The two types of coordinates are: positional and differential.

Positional displays the X,Y coordinates of the cursor position in relation to the total
window. By default, the large + in the center of the drawing area is 0,0.
Differential displays the distance in X,Y the cursor has traveled since the last click.
Set the starting point to 0,0 by clicking anywhere in the drawing area.

Choose Insert, then choose a listed shape. The program provides instructions (in the
Prompt panel at the bottom of the window) as you insert the shape.

For example, when you choose Insert > Rectangle, the program displays this prompt:
Rectangle: Enter the first corner
Click in the Layout window to define one corner of the rectangle. The prompt changes to:
Rectangle: Enter the second corner
As you drag the pointer, you can see the rectangle. When the rectangle is the size you
want, click to insert it. See the example.

Example

Select the rectangle icon on the toolbar.1.
Click in the Drawing window to define the first point on the rectangle. Note that the2.
Differential X,Y coordinate display reads 0.00, 0.00.
Move the cursor until the coordinate display reads 200.0, 100.0 .3.
Click a second time. A rectangle 200 × 100 mil is inserted in the window.4.

 

 Rotating a Component

You can save time and mouse-clicks by rotating components as you insert them so that
they are properly oriented when you place them.
If you find that a component is not oriented properly as you drag it into position, before
you click in the window to place it, either press Control + R or click the Rotate By
Increment icon in the toolbar.



Schematic Capture and Layout

13

The component rotates -90° each time. When the component is oriented properly, click to
insert it.

 

 Editing Objects in a Layout Window

The two ways to edit objects in a Layout window are:

Using a menu command ( Edit > <command> )
Using a command on the toolbar.

 

 Creating Artwork

In addition to the components supplied with the program that have layout footprints, you
can create custom layout components by using either of the following methods:

Using the Graphical Cell Compiler (GCC). For more details on GCC, see Graphical Cell
Compiler (gcc) documentation.
Writing scripts in the Application Extension Language (AEL). For more details, see
AEL (ael) documentation.
Drawing your own shapes and adding the necessary pins/ports.

 

 Releasing a Layout License

When you complete layout related work, release the Layout license so that the license
becomes available to another user. To release the license choose File > Release Layout
License in the Layout window.

 

 Using the Design Rule Checker

The Design Rule Checker (DRC) is used to verify that a physical design complies with
predefined rules or operations. DRC requires a separate license and is accessed through
the Verify menu. For more details, see ADS Desktop Design Rule Checker (drc)
documentation.

 

 

 Opening Design Windows

There are several ways to open a design window. The method you can use is determined
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by the type of action you want to perform in that window.

New design - To open a Schematic or Layout window for creating a new design or
editing an existing design not currently in memory, click the New Schematic or New
Layout button or choose the command (by the same name) from the Window menu
in the Main window.
Selecting New Schematic will launch the Schematic Wizard, which guides you through
a sequence of steps gathering information about the type of schematic you want to
create. Based on your inputs, the wizard automatically creates the specified
schematic components. The wizard then provides you with instructions for completing
the schematic manually, and for invoking the simulator when applicable. The
simulations are set up to automatically display the results after successful
simulations. For more details on the Schematic Wizard, see Using the Schematic
Wizard (cktsim).
Additional window - To open an additional Schematic or Layout window for a
design that is already open, choose the Schematic or Layout command from the
Window menu in that window.

Hint
You can also open a new Data Display window from the Main ADS window.

Note
Schematic and Layout windows are numbered sequentially as they are opened throughout a session. If
Schematic window number three is open (the title bar reflects (Schematic):3) and you open a dialog box
from that window, the title bar of the dialog box will also reflect :3. This is to assist you in identifying
which design window you are about to make changes to.

 

 Opening Multiple Design Windows for the Same Design

The design environment enables you to use multiple Schematic and Layout windows at the
same time. For example, you can open two Schematic windows with different designs
making it easy to copy and paste parts from one design to another. Or the windows can
contain the same design making it easier to accomplish certain design tasks.

Hint
When you want to open a window for creating a new design or editing an existing design, use the Window
menu in the Main window; when you want to open an additional window for the current design, use the
Window menu in that window (Schematic or Layout).

 Closing Design Windows

To close an individual design window, but still keeping the design in memory: From the
Window menu in the design window (which you want to close), choose Close.

 Status Message Window

The Simulation/Synthesis Message window appears whenever a simulator is launched and
displays messages about the status of the current process, as well as warning and error
messages. Each simulation generates its own set of messages which are stored in memory
during the current session. These sets of messages can be distinguished from one another
by the number displayed in the title bar of the window as shown in the following examples
(Windows above, UNIX below).
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The window contains two information panels:

Simulation/Synthesis Messages
Status/Summary
The Simulation/Synthesis Messages portion of the window displays detailed messages
about problems encountered during a simulation or synthesis, and, where possible,
what you can do to solve the problem.

There are two tools available to help you learn more about a reported problem.
For some issues, clicking the message highlights relevant components in a schematic
window.
For all issues, the ? button to the right of the Simulation/Synthesis Messages panel
initiates a search in the Agilent EEsof Knowledge Center. Select the message of
interest in the panel, then click the ? button. A web browser opens with a disclosure
page showing the exact information that will be sent over the network to the
Knowledge Center. Though it can be helpful to view the information in the disclosure
page before submitting the information, you can bypass this page in the future.
To bypass the disclosure page, select the Don't show again option. This sets a cookie,
preventing the disclosure page from opening.
If the Don't show again option was selected, and you want to undo this setting to
display the disclosure page again, you will need to delete the information for this
stored cookie.

On Windows

Find the folder Temporary Internet Files. Under Windows XP, for example, this folder
is often at
C:\Documents and Settings\username\Local Settings\Temporary Internet Files

Within this folder, look for a cookie file named doc\, and delete it.

On UNIX

The following instructions are for the default web browser installed with ADS:
Close all Netscape windows.1.
Using a text editor, open the file $HOME/.netscape/cookies.2.
Find the line containing eesof_weblinked_error_skip_disclaimer, and remove the3.
entire line.
Save and close the file.4.

The Status/Summary portion of the window displays a Simulation finished message,
statistics such as how long the simulation or synthesis took, and the system resources
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used.

 

 Viewing Simulation Status and Error Messages

When the simulation/synthesis is finished, you can save the displayed information to file,
send it directly to the printer, or search for related information.

To save the currently displayed information to file with a default filename:
Choose File > Save Text and click OK. The default filename consists of the simulation
process number (from the title bar of the window), with a prefix of the string
sessloghpeesofsim and a file extension of .txt. The file is saved to the current workspace
directory.

To save the currently displayed information to file with a filename of your choosing:
Choose File > Save As. Enter a filename and click OK. The file is saved to the current
workspace directory.

Note
If you have changed workspaces during the current session, the file may be written to the initial
workspace opened in this session.

Because each simulation generates a set of messages identified by unique names, you can
view any messages generated during the current session. You can view these one at a
time in the same window, or you can open multiple windows and display different ones all
at the same time.

To view messages generated by another simulation:

Choose Window > New Window.1.
From the Window menu, select the simulation information you want to view, as2.
identified by the unique number displayed in the title bar associated with each
simulation. The display changes to reflect your selection.

To close any individual status window:
Choose Window > Close Window.

 

 Reading and Writing Data Files
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You can transfer data from a file into a dataset, or vice versa. One application is to
transfer data from a dataset to an MDIF file, for use with a specific type of component. For
example, a file in P2D format (P2D is one of several MDIF formats) containing S-
parameters can then be used by the P2D amplifier. Using the Data File Tool, you can write
S-parameters from a dataset to a file in P2D format. Another application is reading Agilent
IC-CAP data into a dataset to be used in conjunction with a component, such as a source,
that can read data from a dataset.
You can start the Data File Tool from a Schematic window or a Data Display Window by
choosing Tools > Data File Tool. For more information on the Data File Tool, refer to the
section on Reading and Writing Data Files (cktsim).

 

 Naming Conventions

It is recommended to provide a unique name to each item (though you can have same
name for two different identities).

Note
The names of supplied components cannot be used as design names. If you receive an error message
stating the supplied design name is reserved for Advanced Design System, you have most likely used a
name that is reserved for a component. To review these names, see the component libraries or the
component documentation.

The following illustration shows how these terms are used.

User-supplied names that were previously restricted to alphanumeric and underscore ( _ )
characters (hereafter referred to as the standard character set), can now take advantage
of an extended character set that incorporates additional special characters. The extended
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character set (a superset) consists of the following characters:

alphanumeric _ + - = ^ ` @ # & $ %

In addition, you can now use a numeral as the first character in many names.
The following table denotes where the extended set and numeric prefixes can be used, as
well as several exceptions:

Name Character
Set

Exceptions Numeric
Prefix

Variable
(VarEqn,
MeasEqn)

Standard  No

Node/wire label Extended  Yes

Instance Extended An underscore ( _ ) cannot be used as the first character. The
following components are restricted to the standard character set
for their Instance Name:
SweepPlan, ParamSweep, DC, AC, S_Param, HB, LSSP, P2D, XDB,
Envelope, Transient, Options, YieldSpec, Goal, Yield, Optim,
YieldOptim, MeasEqn, VarEqn, DataAccessComponent

Yes

Design
(Cell, Library,
and View
Names)

Extended Design names may not contain $ or %. These characters are
reserved for ADS environment variable substitution.
Note: If a design name includes special characters or starts with a
numeral (such as "00a" or "@"), optimization results are not
updated.
Note: If a design name consists solely of numerals, The transistor
device operating points dialog box cannot be displayed.

Yes

Workspace Standard  Yes

 

 Limitations

When the extended character set is used to define a name, and that name becomes
part of a variable name in a dataset, the data cannot be accessed directly with
respect to either data displays or measurement equations. A special access function
called var(), must be used. For example, if you name a node V++ then to display its
magnitude you must use the expression:
mag(var("V++"))
where var() is passed the name of the variable as a string. The var() function
interprets the passed string as the name of a variable, which prevents any expression
processing of the string. Note that using this function limits you to accessing datasets
in the data directory of the current workspace. Data Display automatically adds var()
when required to access names defined using the extended character set.
Substrate Instance Names - If a leading number is used as a substrate ID, then that
substrate cannot be referenced by its corresponding set of distributed models.
Model Instance Names - Currently, the characters $ and % are not allowed in
Instance Names for model items, such as BJT_Model, R_Model, etc.
Dataset Names - Special characters from the extended set are not allowed in dataset
names (standard set, with non-numeric first character, is required). Thus, if you have
two or more designs whose names are distinguishable from one another only with
respect to the use of special characters, you should supply unique dataset names
prior to simulating. If you do not, and you perform successive simulations of these
designs, the dataset resulting from the first simulation will be overwritten by the next
(because the special characters will be dropped from the automatically derived
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dataset names).

Note
If your design name begins with a number, the default dataset name will be the design name with an
underscore ( _ ) character added to the front.

Optimization Goals - Special characters currently cannot be referenced by an
Optimization Goal or Yield spec. If a design name includes special characters or starts
with a numeral (such as "00a" or "@"), optimization results are not updated.
Operating Point Annotation - The transistor device operating points dialog box does
not come up when a design has a numeric name such as "0000" or "1234".
Spaces are not allowed in workspace names.

Note
An invalid character is changed to underscore ( _ ).

 

 Global Node Naming Conventions

If you use an exclamation point ( ! ) as the last character in a node name, it denotes that
the node is a global node.
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 Managing Designs
This section describes various options related to managing, importing and exporting
design files. For information on these topics, refer to following sections:

Importing and Exporting
Managing Design Files

 
 

 Importing and Exporting

The Import and Export commands enable you to import and export IFF files, as well as
files in a variety of formats produced by other software. You can import files through the
Main, Schematic, and Layout windows; exporting is done from Schematic and Layout.

For details on available formats and descriptions of the options associated with each,
refer to Available File Formats (trans) under About Importing and Exporting Designs
(trans) in the Importing and Exporting Designs (trans) documentation.
For details on importing and exporting SPICE or Cadence, Spectre files, refer to the
Netlist Translator for SPICE and Spectre (netlist) documentation.

 

 Importing a Design

Use the following steps to import a design. A workspace needs to be open before a design
can be imported.

Choose File > Import in design window.1.
Select the appropriate file format from the File Type drop-down list in the dialog box2.
that appears.
To define options for the imported file, click More Options which launches a dialog3.
box.

Note
The program translators are controlled by translator options files. A system-wide options file exists
for each translator. These files can be found in the $HPEESOF_DIR/config directory. The default
system file is automatically read when you click More Options in the Import dialog box (unless a
local options file already exists in the current workspace directory). When you make changes in the
options dialog box and click OK, a local copy of the options file is written to the current workspace
directory.

To specify the path and filename of the file you want to import, click Browse.4.
Double-click as needed to locate the directory containing the design. By default, all5.
files are listed that have the file suffix appropriate for the chosen file format.
Select the design you want to import and click Open. You are returned to the Import6.
dialog box and the selected filename appears in the field labeled Import File Name
(Source).
Where applicable, type a new name for your imported design in the New Design7.
Name (Destination) field.



Schematic Capture and Layout

21

Note
For certain file types, the translator uses the existing filename to determine the new design name.

Click OK to import the design and dismiss the Import dialog box.8.

 

 Exporting a Design

To export a file:

Choose File > Export.1.
In the dialog box that appears, select a file format from the File Type drop-down list.2.
To set export options, click More Options and a dialog box appears.3.

Note
The program translators are controlled by translator options files. A system-wide options file exists
for each translator. These files can be found in the $HPEESOF_DIR/config directory. The default
system file is automatically read when you click More Options in the Export dialog box (unless a
local options file already exists in the current workspace directory). When you make changes in the
options dialog box and click OK, a local copy of the options file is written to the current workspace
directory.

Change options as needed and click OK.4.
To specify a path for the exported file, click Browse.5.
Double-click as needed to locate the directory for the exported design. By default, all6.
files are listed that have the file suffix appropriate for the chosen file format.
Click Open.7.
Type a new filename in the Export dialog box, following the path, and click OK. The8.
file is written to the specified directory.

 

 Managing Design Files

Before you begin your design work, you should understand the basics of design
management within the design environment.

 

 Creating a Design

After creating a workspace, you may begin your work by creating and naming a new
design.

Refer to Creating Designs (adstour)

 

 Using a Template

Several simulation templates are provided as a convenience to help you in creating
designs more quickly. You can turn any of your own designs into a template using the
Save Design As Template command.
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To start a new design with an existing template:
Choose File > New, provide library name, cell name and view name then select a
template from the drop-down list in New Design dialog box, and click OK.

To add an existing template to an existing design:
Choose Insert > Template, select a template from the list, and click OK.

To create a new design for use as a template:

Create the design.1.
Choose File > Save Design As Template (The program automatically adds the2.
extension .tpl to your filename.) The design is saved to your local templates directory
and will now appear in the list of available templates (File > New Design and
Insert > Template) when you choose to use one.

To modify a supplied template or one you have created:

Choose Insert > Template, select that template from the list, and click OK.1.
Make the desired changes and choose File > Save Design As Template.2.

Click here for more details on Simulation Templates (usrguide).

Note
To associate an AEL macro file with a template, give it the same name as the template file, add
underscore tpl, and an .ael extension. Example: For a template filename of my_amp.tpl, name the AEL
macro file my_amp_tpl.ael. Place this file in $HOME/hpeesof/circuit/templates (or
$HOME/hpeesof/adsptolemy/templates), along with the template file, and it will be loaded when you insert
the template in another design.

 

 Saving a Design

There are four commands related to saving files: Save, Save As, Save a Copy As and Save
Design As Template.

The Save command enables you to save changes to an existing design (If you choose
Save in an untitled window, the Save Design As dialog box appears.)
The Save As command enables you to save an existing design with a new name.
Library name, cell name and view name can be changed. Type represents the type of
cell to identify whether it is a schematic, layout or symbol view. cell Type can not be
changed.



Schematic Capture and Layout

23

If Save the entire cell option is checked, all views of the selected cell are saved,
otherwise only current view is saved.
Save a Copy As command enables you to save a copy of an existing design with a
new cell name in new library and in new view.You can save a copy of current design
as File > Save a Copy As, provide the desired library name, cell name and view and
click OK . When pushed into a design, use Save a Copy As instead of Save As. 

If Open in new window is checked, the saved copy is opened in a new window.
Use the Save Design As Template command to save a design, at any stage, for use
as a template (Select a template for use through File > New ,in the New Design
dialog box or Insert > Template.) The program automatically adds the extension
.tpl to your filename. If you have made changes to a design and want to discard
those changes, but continue working with the previously saved version of the design,
choose File > Revert to Saved.

Note
The Save As command names or renames all files associated with the design and is therefore the
preferred method for saving a design to a new name. Therefore, it is recommended that you use the
design environment for all file management operations.

 

 Saving All Designs in Memory

To save any design currently in memory (including data displays) that have not been
saved since changes were made:
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In the Main window, choose File > Save All.

 Save Modified Designs

If you are closing ADS Main window without saving changes to your designs, a Save
Modified Designs dialog appears. You are given an option to save or discard any changes
made to the design with its associated library name, cell name and cell view. Click Yes or
No to save or discard any changes made to the design.

 

 Opening an Existing Design

There are several ways to open an existing design:

Double-click it in the Main window (from the Design Information pane).
Double-click it from the Design Hierarchy dialog box (View > Design Hierarchies).
Use the File > Open command in the appropriate design window.
If it is one of the last four designs opened, it appears on the file list at the bottom of
the File menu and you can click there to open it.
If the design is currently open in a window, it appears on the list at the bottom of the
Window menu and you can click there to open it.

To open an existing design from the browser in the Main window:

In the Folder or Workspace View pane, navigate to a cell.1.
Double-click to expand the cell.2.
Double-click the view name to open it.3.

To open an existing design from the File menu in a design window:

Choose File > Open and a dialog box appears.1.
Select the design you want to open from the dialog box, and click OK. The design2.
appears in a new window.

To view a design currently open in a window from the Window menu:
Choose Window (in the Schematic or Layout window) and select the design from:

The list of files at the bottom of the Window menu
Note that when the number of open designs grows too large, an additional menu
choice, More, appears. Choose More to see a complete list of designs open in a
window.

Hint
The number of designs displayed on the Window menu (by default, nine) can be customized by
setting the variable DESIGN_LIST_COUNT equal to the desired value. For details, refer to
Customizing the ADS Environment (custom) in the Customization and Configuration (custom)
documentation.

 

 Copying a Design
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The Copy command copies all files associated with the design and is therefore the
preferred method for copying designs.

Note
Copying designs should only be done through the program, as described here. Copying designs outside
the program may result in invalid designs.

To copy a design:

Open the workspace (with library) from where design is to be copied.1.

Note
In you want to copy the design or cell in other library, you must also open the library where design
is to copied.

From the Folder View, right click on the cell to be copied and choose Copy Cell.2.

Note
If you choose Copy option, Copy Files dialog box gets opened when you choose Paste.

In the Copy Files dialog box check the Include hierarchy (sub-networks of selected3.
designs) check box.
In the Destination cell, select the destination library name (if different from current4.
library) from the drop-down list.
Choose Auto Rename Rule for the cell to be copied from drop-down list.5.
Click OK.6.

Note
To copy a single view (Schematic, layout and symbol), right click the view icon and click Copy View.
A Copy Design dialog box appears.Enter your library name and cell name and click OK to finish.

 

 Deleting a Design

To delete a design:

Right click the cell icon that you want to delete.1.

Note
Deleting designs should only be done through the program, as described here.

Click Delete,a dialog box appears.2.
You are prompted to confirm that you want to delete that cell. Click Yes to delete it;3.
click No to keep it.

Important If you delete a design that serves as a subnetwork in other designs, you will receive a
warning. If you choose to delete the design anyways, , remember to delete all occurrences of that
subnetwork in those designs.

 

 

 Clearing All Design and Data Display windows

To clear all designs, including data displays, currently open in a window:
In the Main window, choose File > Close All.
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If any files with unsaved changes exist, a dialog box appears listing one of the files and
offering the following choices:

Yes - Saves changes to the named file and prompts you individually for any
additional files with unsaved changes.
No - Discards changes to the named file and prompts you individually for any
additional files with unsaved changes.
Yes To All - Saves changes to all files without prompting you for each one.
No To All - Discards changes to all files without prompting you for each one.
Cancel - Stops the Close All command.
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 Creating Designs
This section provides information related to creation of designs in the Advanced Design
System environment. Before reading this section, familiarize yourself with Using
Workspace (adstour) and Using Designs (adstour).

Although you can perform a wide variety of editing operations on your design as you
create it or once the design is complete, you can set numerous options before you begin
your design work to minimize the need for editing. These options can be set through the
Preferences dialog box (Options > Preferences) from the design window. For more
information, refer to Setting Design Environment Preferences (custom).

For details on adding a drawing sheet to the design window, refer to the section on Adding
a Drawing Sheet (usrguide) under Annotating Designs (usrguide).

 

 Defining Units for a Design

For storing shape and instance coordinates, all designs use the units setup in the design
technology. For more information, see Layout Units (usrguide).

The scale factors shown in the Units/Scale tab of the Preferences dialog box serves as
defaults in a limited number of situations. For details, refer to the Units/Scale Factors
section.

 

 Placing Components

You create designs by placing items (such as components, data items, measurements,
sources, simulation controls, etc.) in a design window. There are several ways to access
these items:

Browsing - in the Folder View window
Browsing and Searching - in the Component Library window
Component Palette - on the left side of the design window
Component History - on the toolbar or as a dialog box
Hot Keys - once you have added components to the Component sub-menu

Although there are several methods available, the basic steps for placing a component are
the same.

To place a component in the design window:

Locate the component.1.
From the Folder View or Component Library, locate the component and drag and
drop it onto a design window drawing area.
From the Component Palette, Component History or Hot Keys, locate and select
the component.

Move the pointer into the drawing area and click the orientation button to rotate the2.
symbol as necessary.
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Click to place the symbol in the desired location.3.

Note
If you click more than once, in a single spot in a design, ADS will cycle through selecting items that
are selectable from the original clicked spot. Once you click away from that spot, cycle select will
stop.

 

 Browsing the Folder View

You can view and place workspace designs as components from the Folder View tab of the
ADS Main Window.

From the ADS Main window,

Select the Folder View tab.1.
Locate, left click and drag the design that you want to place in your schematic or2.
layout window.
Release the mouse over the schematic or layout window. A ghost image of the design3.
will appear as you move your mouse.
Move your cursor to the location on the schematic or layout window where you want4.
to place your design.
Click to place your design.5.

 Browsing and Searching the Component Library

To browse the components included within an individual library, select library name in the
Component Library window. The libraries listed vary with the current design type -
Analog/RF versus Digital Signal Processing.

In the following figure, the left side shows the top-level libraries (for the Analog/RF design
type) with the Analog/RF library expanded. The Data Items sub library is selected and the
right-side shows the components in the Data Items library.
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To browse and search for a component:

From any design window, click the Component Library button  on the toolbar1.
(or choose Insert > Component > Component Library).
You may select All Libraries or any library below it. Click the plus sign (+) in front of2.
a library name to expand it and view its sub-libraries. If the selected library has sub-
libraries below it, they are automatically selected also. The components in the
selected libraries are displayed in the right-side of the window.
Optionally, you may search the text in any component column by typing the text into3.
the Search field above any column. The list of components matching the text will
change as you type each character of the text into the Search field.

To place components from any library (drag and drop) :

With the cursor on component name, press and hold the left mouse button and drag1.
the component name until it is over the drawing area of a schematic or layout
window.
Release the mouse and you will see the component outline in the drawing area.2.
Move or rotate it and the click the mouse to place it.3.

To place components from any library (Place Component menu) :

With the cursor on component name, right click and select the Place Component1.
menu. The component will be ready to insert into the last active design windows.
Move you mouse into the last active design window. Move or rotate the component2.
and the click the mouse to place it.

 Exiting the Component Library

To exit the component library, click the "X" button in Component Library window.

 Customizing the Component Library Display

Several features are provided to enable you to customize the Component Library display.
You can:

Position the Component Library window
Resize the Component Library window
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Show or hide any column of component information
Set the widths of any column of component information
Rearrange any column to appear in a different order
Move the divider between the left and right sides of the window
Enable/Disable tooltips

Whenever these configurations are changed, the settings are saved and used in future
ADS sessions. These items (other than the window position and size) are customized
independently for the Analog Library view and the DSP Library view.

The component names are sorted alphabetically and you can sort by any component
column by selecting the column heading with a left mouse click. This sorting is not saved
for future ADS sessions.

Note
Several aspects of the Component Library window display can be set for all workspaces (user) or on a
site-wide basis. For details, refer to the Variables in the File hpeesofbrowser.cfg (custom).

 Using the Component Palette

The palette on the left side of each design window is a quick method of placing
components if you know the name of the library containing the component. To change the
library of components on the palette, select a new one from the drop-down Palette List.

Hint
You can also bring the palette selection list up as a dialog box by selecting View > Component > Select
Component Palette. Keep it on the screen if you want to change the palette frequently.

To use the Palette to place items:

Display the desired library on the palette by selecting it from the drop-down list (in1.
this example, TLines-Printed Circuit Board).

If necessary, scroll the new palette to locate the button representing the component2.
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you want to place.

 

 Using Component History

As you place components in your design, a history of these components is created. This
dynamically-created history enables you to quickly place additional instances of
components placed in the current session.

Hint
This history serves as the starting point for creating a custom component palette. For more information,
refer to Creating a Custom Component Palette (custom).

To place items from Component History:

Click to access the drop-down Component History list or bring up the dialog box (1.
View > Component > Component History).

If necessary, scroll the list to locate the component you want to place.2.

Hint
Once vendor components are placed, they are part of Component History which can be used to
create a custom palette containing these vendor parts.

 

 Using Hot Keys to Place Components

You can place frequently used components via hot keys, by adding them to the
Component submenu (Insert > Component) and then assigning hot keys to them.
Components added to the menu in this manner apply to all workspaces. Customization of
this Component menu is done separately for the Schematic and Layout windows.

To add components to the Component submenu:

Choose Tools > Hot Key/Toolbar Configuration and in the dialog box that1.
appears, select the Component Menu/Hot Key tab.
Select the components you want to add to the Component submenu from any of the2.
following lists:

Available Components displays all the components contained in the current
design.
Select any of the standard component libraries from the drop-down list.
Select History (for a list of components placed in the current session) or
Selected Design Components (for a list of all currently selected components in
the active design).
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Hint
You can use the PC method of Shift_click to select a contiguous group of components, or
Ctrl_click to select components that are not contiguous.

Click Add to add the selected component(s) to the Component Menu/Hot Key list3.
box.
Alternatively, you can select one or more components currently placed in the drawing
area of the desired (Schematic or Layout) window and choose Insert > Component
> Edit Component Menu. All selected components are added to the Component
submenu.

To create hot keys for the menu-based components:

Choose Tools > Hot Key/Toolbar Configuration and in the dialog box that1.
appears, select the Component Menu/Hot Key tab.
Select a component from the Component Menu/Hot Key list box.2.
Select the modifier key(s)-Ctrl, Alt, Shift-and type the letter(s) you want to use in3.
the Key field (UNIX environment is case-sensitive; WIN environment is not). If the
combination you choose is currently assigned to another command sequence or
component, a warning will be displayed and you will be given a choice to proceed or
to select another key sequence.

Note
If you use Alt as the modifier key, and a letter that is already assigned as an accelerator for a menu
(see the underscored letters on the menu bar), the menu accelerator is replaced by your custom
shortcut (with no warning).

Click Apply. The shortcut appears next to the component.4.
Repeat as needed for each component.5.

To remove components from the Component submenu:

Choose Tools > Hot Key/Toolbar Configuration.1.
Select the Component Menu/Hot Key tab in the dialog box that appears.2.
Select any component you want to delete from the Component submenu and click3.
Delete. To delete all but the standard components - Port, GROUND, VAR - click
Delete All.

Hint
To remove a shortcut for a given component, select that component and de-select the modifier
key(s) and erase the letter(s), then click Apply.

 

 Placing Components at Specific Coordinates

The Coordinate Entry command enables you to place a component at specific coordinates
using Cartesian or Polar coordinates specified in absolute or relative numbers.
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To use the coordinate entry method for placing components:

Choose Insert > Coordinate Entry and a dialog box appears. Move the dialog box1.
so that the desired design window is visible.
Select the component you want to place.2.
Select the desired orientation for this component.3.
Select the coordinate type: Cartesian or Polar and Absolute or Relative.4.
Enter the desired X and Y coordinates by typing them in the fields labeled X and Y.5.
The coordinate values you enter are plotted in the Coordinate Plotted field.
Coordinate entry will modify the coordinates entered ignoring the current snapping6.
rules if the Use Snapping checkbox is inactive. To apply the current snapping rules to
snap your entered coordinates, activate the Use Snapping checkbox.
Click Apply and the component appears in the drawing area at the specified location.7.

 

 Rotating Components

You can specify the orientation, or rotation, of components in a number of ways. To
change the orientation during or after placing it in the drawing area, use any of the
following methods.

Click the Rotate By Increment button on the toolbar.

First select the component and press Ctrl+R.
Choose Edit > Rotate. Each of these actions rotates the component n degrees
clockwise, where n is the increment specified in Options > Preferences >
Entry/Edit > Rotation Increment (angle). The default is 90 degrees.

In addition to the above methods of rotation, you can rotate a component during the
insertion process using any of the following commands:

Choose Insert > Component > Set Component Orientation UP
Choose Insert > Component > Set Component Orientation DOWN
Choose Insert > Component > Set Component Orientation LEFT
Choose Insert > Component > Set Component Orientation RIGHT
These directions refer to the direction the symbol is drawn relative to pin 1.

Hint
Place these individual commands on the toolbar to have individual toolbar buttons for each
orientation. For more information, refer to Configuring Toolbars (custom).
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 Defining Parameters

As you place components in the drawing area, you will notice that some parameters have
default values and that other parameters are followed by an equal sign (=) and nothing
else. The lone equal sign indicates that a default value is defined elsewhere for this
parameter. Some of these parameter values are defined by the simulator, while others are
defined in various Simulation Control items. For details on where the default value is
defined and to review the guidelines for choosing other values for that parameter, refer to
the Introduction to Circuit Components (ccsim) documentation or the Signal Processing
Components documentation.

Note
The at symbol (@) must be used to suppress quotes when specifying a variable as a parameter value, for
example, use @freq1, where freq1 is a variable declared in a VAR item.

You can change parameter values using the on-screen editor or through the Component
Parameters dialog box. To display the Component Parameters dialog box for editing
parameters after placing components:

Position the pointer over the component you want to edit and double-click
or
Select the component and choose Edit > Component > Edit Component
Parameters

Alternatively, you can specify parameters for each component as you create your design.
By default, the option controlling the automatic display of the Component Parameters
dialog box is turned off (in the Schematic window). To display the dialog box automatically
when you select a component, select the option Show Component Parameter Dialog Box
through Options > Preferences > Placement.

Hint
To keep the dialog box on your screen for editing parameters of many components, use the Apply button
to effect changes for each component.

For details on the Component Parameters dialog box and using the on-screen editor, refer
to Editing Component Parameters (usrguide). 

 Units/Scale Factors

The fundamental units for ADS are shown in the table below. An ADS parameter with a
given dimension is evaluated based on the corresponding units. For example, for a
resistance R=10, 10 is assumed to be 10 Ohms.

 Fundamental units in ADS



Schematic Capture and Layout

35

Dimension Fundamental unit

Frequency Hertz

Resistance Ohms

Conductance Siemens

Capacitance Farads

Inductance Henries

Length meters

Time seconds

Voltage Volts

Current Amperes

Power Watts

Distance meters

Temperature Celsius

Variations on these fundamental units are referred to as scale factors. A scale factor is a
single word/abbreviation that begins with a letter or an underscore character ( _ ). The
remaining characters, if any, consist of letters, digits, and underscores. The value of a
given scale factor is resolved using the following rules, in the order shown:

If the scale factor exactly matches one of the predefined scale-factor words (see1.
Predefined scale-factor words), then use its numerical equivalent
else
If a scale factor exactly matches one of the scale-factor units (see Scale-factor units)2.
with the exception of m, then use its numerical equivalent
else
If the first character of the scale factor is one of the scale-factor prefixes (see ADS3.
scale-factor prefixes), then use its numerical equivalent
else
The scale factor is not recognized. When ADS does not recognize a scale factor it4.
issues a warning and uses a scale-factor value of 1.0.

The table below list the ADS scale-factor words and their numerical equivalents.

 Predefined scale-factor words

Scale Factor Words Numerical Equivalent

mil 2.54e-5

mils 2.54e-5

cm 1.0e-2

in 2.54e-2

ft 12*2.54e-2

mi 5280*12*2.54e-2

nmi 1852

PHz 1.0e15

dB 1.0

The table below lists the ADS scale-factor units and their numerical equivalents.

 Scale-factor units
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Scale Factor Unit Meaning Numerical Equivalent

A Amperes 1.0

F Farads 1.0

H Henries 1.0

Hz Hertz 1.0

meter meters 1.0

meters

metre

metres

Ohm Ohms 1.0

Ohms

S Siemens 1.0

sec seconds 1.0

V Volts 1.0

W Watts 1.0

The table below lists the ADS scale-factor prefixes and their numerical equivalents.

 ADS scale-factor prefixes

Scale Factor Prefixes Meaning Numerical Equivalent

a atto 1e-18

f femto 1e-15

p pico 1e-12

n nano 1e-9

u micro 1e-6

m milli 1e-3

_ (underscore) no scale 1

k, K kilo 1e3

M Mega 1e6

G Giga 1e9

T Tera 1e12

Notes

Scale factors are case sensitive. Note the different meanings for f and F, and a and A in the
preceding tables.
The imperial units (mils, in, ft, mi, nmi) do not accept prefixes.
Scale factors can be used anywhere in an expression (e.g., 1 GHz + 1 MHz).

The table below lists the available scale factors for parameters with which a fundamental
unit is associated.

 Available Scale Factors
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Frequency none Hz kHz MHz GHz THz

Resistance none mOhm Ohm kOhm MOhm GOhm TOhm

Conductance none pS nS uS mS S

Capacitance none fF pF nF uF mF F

Inductance none fH pH nH uH mH H

Voltage none fV pV nV uV mV V kV

Current none fA pA nA uA mA A kA

Time none fsec psec nsec usec msec sec

Length none um mm cm meter mil in ft

Distance none meter km ft mi nmi

Power none pW nW uW mW W kW dBm dBW

When you select a parameter-with which a fundamental unit is associated-in the
Component Parameter dialog box, a drop-down list appears containing all available scale
factors for that particular parameter.

Notes

The option none means no scale factor is applied to the value.
Although dBm and dBW appear on the drop-down lists, they are not valid scale factors; built-in
functions convert these values to Watts and Celsius.
There is no scale-factor option for temperature.

This same set of scale factors (with the exception of none) appears in the Preferences
dialog box (Options > Preferences > Units/Scale). Note that these default settings are
only used in the following situations:

When a parameter of a supplied component does not have a default unit and you do
not assign one (in the component parameter dialog box)
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When you supply a default parameter value without units while creating a parametric
sub-network (File > Design Parameters)

Hint
You will see both Length and Distance scale factors in the Preferences dialog box. Length typically
applies to parameters such as transmission line length, and Distance is a much larger scale factor
that applies to things like antenna path length.

 

 Measuring Distance and Angle

The Measure command produces a dialog box that displays the cumulative distance
between points you specify in the design window. In addition, it displays the angle from
the first point to the current point.

To use the Measure command:

Choose Measure from the Insert menu or the pop-up menu and a dialog box1.
appears.
Click on the desired points in the design window and observe the information2.
displayed in the dialog box.

To clear the information but keep the command active, click Clear or double
click in the design window.
To stop the command and dismiss the dialog box, click Cancel.

Notes

The Clear command can also be activated by pressing the space bar.
On Solaris, if the Measure window does not remain on top when you open a Layout window, you
may need to change the setting in the Solaris Window Style Manager. See Solaris Window Style
Manager (install).

 

 Connecting Components

When you place a component in the design area, you will notice that each of the pins is
highlighted by a diamond-shaped outline. This shape identifies unconnected pins, and
disappears when a connection is made.

There are three ways to connect components:

Directly, pin-to-pin
With wires
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Without wires (with names)

Hint
When a connection is made, the pin color changes to the color designated as the Connected Pin
color (Options > Preferences > Pins/Tees). The color of the pin and the diamond-shaped outline
prior to connection is the color designated as the Highlight color (Options > Preferences >
Display).

 

 Connecting Components Directly

To connect components directly:

Select the desired rotation for the component you are about to connect.1.
Position the pointer directly over the pin of the component you are connecting to, and2.
click.

 

 Connecting Components with Wires

To connect components with wires:

Click the Insert Wire button or choose Wire from the Insert menu. You are1.
prompted to enter the starting point.
Position the pointer at the desired location and click. You are prompted to enter the2.
next point.
Position the pointer at the desired location and click. A wire is drawn between the3.
specified points.

Tips
To specify an endpoint of an unconnected wire, double-click or press the space bar.
To move an unconnected endpoint of a wire, use Edit > Move > Move Wire Endpoint.
Wires are always routed on the grid unless items connected to them were placed or moved off
the grid. In this case, the shortest wire segment needed to make the connection is drawn off
the grid as required. This means the maximum number of wires that connect to a single point
is four.
This is especially important to understand when using multiple input components (such as Add
and Mpy) in Signal Processing designs, because to connect more than four wires to the input,
you will need to connect additional wires to one of the existing wires rather than to the input
pin itself.
Context-sensitive editing is available for wires with respect to changing the layer on which the
wire is drawn. Position the pointer over the wire, right click, and select Wire Layer from the
pop-up menu.
If moving a component causes wires to be re-routed incorrectly, undo the move, deselect the
re-route entire wire option (Options > Reroute entire wire attached to moved
component), and try the move again.

If the wire is still rerouted incorrectly, undo the move, disconnect the wire ( Edit >
Move > Move and Disconnect), move the component, and reroute the wire
manually. 

 Connecting Components Without Wires

Connecting components without wires is accomplished by adding wire labels. Adding wire
labels to your schematic enables you to:
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Indicate connectivity without wires. Two or more pins in the same network, with the
same wire label, are connected as if they were wired.
Identify node voltages - in an Analog/RF network - that you want output to the
dataset after simulation. Note that if you assign a wire label to a pin that is
connected to a wire, all pins connected to that wire will display that name.
Create buses and bundles. For details, refer to the section below on, Creating Buses.

For information on naming conventions, refer to Naming Conventions (usrguide).

Hint
Using the same node name in nodes across sub-networks does not result in connectivity unless a Global
Node data item is placed in the design declaring that node name global. A Global Node data item with the
specified node name will connect all nodes with that name across all subnetworks. This is useful for
distribution of signals such as supply voltages and clocks.

To connect without wires or identify a node voltage for output:

Choose Insert > Wire/Pin Label and a dialog box appears.1.
Enter a name and click all pins you want to connect with this name. As you click each2.
pin, the name you have supplied appears near the pin.
To produce output from a single pin, assign a unique node name to that pin.
To name another node, supply a different name, and click each pin, as described3.
above. To dismiss the dialog box, click Close.
To clear a node name:4.
Choose Edit > Wire/Pin Label > Remove Wire/Pin Label.
Click each pin or wire whose name you want to remove.5.
Alternatively, you can use the on-screen editor and the Backspace key.

Note
To clear a node name you may also select Insert > Wire/Pin Label, leaving the label field blank in
the dialog box. Select a named node, and the node name will vanish.

 

 Creating Buses

Using buses and iterated instances can greatly simplify the schematic representation of
your design. The following terms are used in describing how to create buses in ADS:

Net - In the broadest sense, any connection between the pins of different electrical
components
Bus - A set of wires or a single wire carrying a set of signals. A bus is a kind of net or
collection of nets where all members share the same base name
(Data<1:4>=>Data<1>, Data<2>, Data<3>, Data<4>).
Wire Label - An identifying label used to name a net that enables referencing that net
by name. A simple wire label (A) merely labels a wire for identification or connection
purposes; a vectorized wire label (A<1:4>) identifies that wire as a bus and enables
connection by tapping, using the base name and an index (A<2>). The vectors
identify the bus width.
Bundle - A collection of wires (or buses) that do not share the same base name
(Data<1>,A,B).
Iterated Instance - A single instance on the schematic that represents multiple
instances. To iterate an instance you modify the Instance Name to include a
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vectorized label (InstanceName<1:4>).

Note
See the example workspace, Examples/Tutorials/wire_bus_wrk.

To represent a bus on an ADS schematic, add a vectorized wire label by supplying a base
name and vectors that identify the bus width.

Note
If an invalid connection is made to an instance, (such as connecting a 4 bit bus to a 5 bit instance) then
an X will be drawn on the instance pin which is not connected.

To tap the individual bus wires, use the bus base name and an index.

To iterate an instance (connected to the bus), modify the Instance Name by adding the
vectorized portion of the bus wire label.

In the following illustration, the bus and iterated instance on the right are equivalent to
the four grounded sources connected to individual wires on the left.

The labels you use to identify the bus and everything connected to it must be added using
the appropriate syntax. The terminology shown in the following illustration identifies the
terms used to define this syntax.
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 Syntax:

Bus
base name<start:stop>
Example: InBus<1:4>
or
base name<start:stop:increment> for an increment other than 1. Use this to create
patterns such as {2,4,6,8} and {1,3,5,7}.
Example: InBus<2:8:2>

Tapped Wires
base name<index>
Example: InBus<1>

Iterated Instance
instance_name<start:stop>
where instance_name is the actual instance name you are using for this component, and
the vector information tracks with the bus vectors, including an increment, where
applicable.
Example: SRC1<1:4>
Note that pins and ports can be iterated in the same manner. For details refer to, Bus Pins
and Iterated Ports.

Important
Be sure to use the correct syntax for all related parts of a bus; syntax errors produce connectivity errors.

The following illustration is a simple example using input and output buses consisting of
four wires each.
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The basic steps to include this type of bus in your schematic are as follows:

Designate the desired wire as a bus by adding a vectorized wire label, for example,
InBus<1:4>.
Label the tapped wires of the bus by using the same base name you used for the bus
(in this example, InBus), and supplying an index to indicate which bus wire it is.
Add vectors (in this example, <1:4>) to the instance name of the component
connected to the bus (in this example, V_DC) to signify that it represents multiple
instances or an iterated instance.
Notes:
Occasionally the visual rendering of a bus wire might not appear as expected. But as
long as it is named correctly, connectivity will be correct.
Setting the value of a parameter of an iterated instance sets that parameter to that
value for all instances created by the iteration.
Iterated instances cannot be tuned, swept, or optimized directly. To perform any of
these operations on an iterated instance, you must create an intermediate variable
representing the parameter of interest. You can then set the instance parameter to
this variable, and sweep/tune/optimize the variable, indirectly
sweeping/tuning/optimizing the instance parameter.
It is not necessary to create a bus on the schematic that includes all of the array
indices. The simulator will collect all bus references with the same base name into a
single array (vector) with the required range of indices. For example a schematic with
A<0>, A<1>, A<2>, A<3> and A<4:15> will create a vector A<0:15>.
Negative indices are not allowed, although a negative increment is. You can effect a
countdown using indices such as A<4:1> which contains the nets A<4>, A<3>,
A<2>, A<1>, or use a negative increment if the increment is other than 1, such as
<8:2:-2> which contains the nets A<8>, A<6>, A<4>, A<2>.
When choosing a bus base name, keep in mind that the name must adhere to the
same rules as node names. For details, refer to Naming Conventions (usrguide).

To create a bus or bundle:

Draw the wire and choose Insert > Wire/Pin Label and a dialog box appears.1.
Bus - Enter the bus base name using the appropriate syntax and click the wire
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that you want to designate as a bus.
Bundle - Enter the names of the wires (or buses) that should be part of the
bundle and click the wire that you want to designate as a bundle.

The label appears and the rendering of the wire changes to a thicker line indicating2.
that the wire now represents a bus/bundle. Click Close.

To tap wires off the bus:

Draw the bus tap wire, choose Insert > Wire/Pin Label and a dialog box appears.1.
Enter the bus base name and the index for the bus wire you want to tap, and click2.
that wire. Increment the index in the dialog box as needed and click the next wire.
Continue in the same manner until you have tapped all desired wires of the bus, then
click Close.

To iterate an instance of a component/port or a symbol pin:

Double-click the instance or pin to display the dialog box for editing that item.1.
Add the appropriate iteration syntax to the instance name and click OK.2.
For components and ports, you can add labels using the on-screen editor; for pins
you must use the Edit > Pin dialog box.

Wire labels can be edited in the following ways:

To move a wire label-Position the pointer over the bus/bundle label you want to
move. Press the left mouse button, drag the label (you will see a ghosted image) to
the desired location, and release. Note that moving a label a very small amount is
affected by whether the Snap Enabled option is on or off (Options menu toggle), and
the size of the Drag and Move threshold option ( Options > Preferences >
Entry/Edit). You can also use Edit > Move > Move Wire/Pin Label.
To set the color, size, and font of wire labels in advance - Use Options >
Preferences > Component Text/Wire Label.
To change the color, size, and font of existing wire labels - Choose one of the
following methods:

Use Edit > Wire/Pin Label > Wire/Pin Label Attributes
Double-click the wire label to display the dialog box
Right-click and select Wire/Pin Label Attributes from the pop-up menu

To delete a wire label, use one of the following methods:
Invoke the on-screen editor and use the Backspace key (followed by Esc)
Choose Edit > Wire/Pin Label > Remove Wire Label and click the wire
whose label you want to delete.

To modify the label itself:
Double-click the wire to display the Wire/Pin Label dialog box

 

 Creating Bundles

A bundle is a collection of wires or buses that do not share the same base name. To
indicate a bundle on your schematic, add a wire label consisting of a list of the wire labels
and/or buses to be included in the bundle, separated by commas.

Syntax:
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<wire_label/bus>, <wire_label/bus>, ...

Any wire/bus in the bundle can be accessed by name. In the following example, if you
want to access A<4:5>, you can name a net A<4:5>.

 

 Bus Pins and Iterated Ports

A bus pin enables you to connect a bus or bundle to it. If you generate a symbol for a
design containing iterated ports, the symbol generator will create bus pins for you. If you
create a custom symbol for a design containing iterated ports, you must explicitly assign
an iteration to the symbol pins on your custom symbol. If you opt to use a supplied
symbol for a design containing iterated ports, you must explicitly assign an iteration to the
symbol pins on the supplied symbol. Note that you will be warned when you select a
supplied symbol if the number of pins on the symbol does not match the number of
(iterated) ports. Default symbols (which appear when you place an instance of a design
with no symbol assigned to it) are not allowed because they do not contain iterated pins.

 

 Creating a Bus Pin via Iterated Ports and a Generated Symbol

When you iterate one or more ports on your schematic (by modifying the Instance Name),
then generate a symbol for it, the generated symbol is created with bus pins.

 

 Creating a Bus Pin on a Custom Symbol

To explicitly create bus pins for a custom symbol representing a design containing iterated
ports, modify the pin name (Edit > Pin), using the same syntax as for a bus or bundle
(e.g., P1<1:4> or A,B) in symbol view . The number of iterated ports in the schematic
must always equal the number of symbol pins. This equivalence can be checked using
Tools > Check Design Report > Pin mismatches (Schematic vs Symbol).
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 Buses in ADS Ptolemy

ADS Ptolemy provides a different use model for buses, and there are two types:
MultiPortHoles and the fixed-point data type (which uses components-not wires-for bus
manipulations).
A MultiPortHole is an ordered set of PortHoles that can be expanded dynamically. A
PortHole is equivalent to a pin in ADS. Pins that have double arrows are MultiPortHoles
that initially have zero PortHoles. As each connection is made on the bus, a new PortHole
is added to the MultiPortHole. Thus in this configuration, the MultiPortHole pin represents
a bus input.
A MultiPortHole can also be expanded (using netlist syntax) to a predefined size. These
MultiPortHoles are represented in the design environment as n separate pins where n is
the number of PortHoles in the MultiPortHole. All of the current PortHoles and
MultiPortHoles are directional, in contrast to the non-directional pins of analog
components. The following illustration shows the ADS Ptolemy multiplier components.

A MultiPortHole that is represented as a double arrow is equivalent to a bus pin with
unspecified size. To fix the size, add wire labels (in the schematic) just as you would for
an Analog/RF design, generate a symbol for it, and place it as a subnetwork, as shown
next.

 

 Checking Connectivity

Although a number of operations automatically perform a connection check, you can
explicitly test the bus-to-instance connections in a schematic through Tools > Check
Design Report > Bus Connectivity. The connection check attempts to resolve all bus-
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instance connections, and highlights (on the schematic) any connections it is unable to
resolve. Connections that are part of a bus or bundle are verified using a set of rules. The
following terms are used in describing these rules:

Connection Width - The total number of pins at a given port of an iterated instance.
Computed by multiplying the pin width at the port by the instance width.
Instance Width - The number of instances in an iterated instance (I<0:3> represents
4 instances)
Net Width - The number of individual wires in a bus/bundle (N<0:7> represents 8
wires)
Pin Width - The number of pins at the given port of a component

 

 Resolving Connections Related to Names

When a net includes both named and unnamed wire segments, the unnamed segments
are considered to include every name that appears on all named segments. In other
words, the name implicitly assigned to an unnamed segment is the intersection of all
names on named segments.
In the following illustration, the segments 3, 5, and 7 are unnamed. A, B, C, D is the
union of all names on this net, and this is the name that is used for all three unnamed
segments.

In an unnamed net (one with no named wires at all):

If all instances to which this wire network is connected have a connection width of N,
then each wire in the network is given width N.

If any instance to which this wire network is connected has a connection width of 1,
then the entire wire network is given width 1. Instances with connection widths
greater than 1 will be shorted together.
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If the instances to which this wire network are connected have mismatched
connection widths, and none of them have a connection width of 1, then there is a
connectivity error.

 

 Resolving Connections Related to Widths

To verify a connection, the net width of the bus is checked against the pin width of the
component, the instance width, and the connection width (where the connection width
represents the total number of pins: connection width = pin width × instance width).
ADS Ptolemy incorporates the concept of pins that can accept buses as inputs. These pins
are of arbitrary size and are annotated by double arrows on the pin stem. For the ADS
Ptolemy MultiPortHole examples:

Wires without names - connected to MultiPortHole pins - have unspecified width.
MultiPortHoles without a pin width have an unspecified pin width.
Instances without an explicit width have an instance width of 1 (in other words, the
instance width can never be unspecified because it defaults to 1).
In the following descriptions of how various connection types are resolved, some
connection types apply only to Digital Signal Processing (DSP) designs while others
apply to both Analog/RF (A/RF) and DSP designs:
Unspecified net width, multiple input or multiple output connections (DSP only)
Unspecified input or output pin width, specified net width (DSP only)
Unspecified pin width, unspecified net width, specified instance width
Unspecified net width, pin width specified, instance width specified
Net width = connection width
Net width = pin width
Net width = 1

If none of the conditions above apply, then the connection is not valid, and will be flagged
as an error. When an invalid connection is found during connection checking, that invalid
connection will be highlighted on the schematic.

 Unspecified net width, multiple input or multiple output connections (DSP only)

ADS Ptolemy currently supports this connection type for instance widths equal to one.
Only the following two cases are supported: multiple outputs feeding a multiport input and
a single output feeding multiple inputs.

Multiple outputs feeding a multiport input
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Net width = number of outputs
Pin width of input = net width
Pin width of any unspecified output pin = 1
This connection only works for commutative operators because it does not
guarantee the ordering of the bus.

To specify the exact ordering of the net, you must add wire labels or use the BusSplit or
BusMerge operators.

Output feeding multiple inputs:
Net width = 1
Pin width of output = 1
Pin width of any unspecified input pin = 1
The problem with named nodes seen in the previous example does not occur in
the next example because the net width is resolved to 1. ADS Ptolemy interprets
this as a single wire and replicates the output. The output here can be either a
uniport or multiport pin.

 Unspecified input or output pin width, specified net width (DSP only)

If the pin width is unspecified and the net width is an integer multiple of the instance
width then:

Pin width = net width/instance width
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For the Add example above, the ADS Ptolemy post-processor will need to recognize
that the input/output pin is connected to N<0>,N<1>,N<2> for I<0>,
N<3>,N<4>,N<5> for I<1> and N<6>,N<7>,N<8> for I<2>. An example netlist
follows:

Options ResourceUsage=yes

UseNutmegFormat=no

TopDesignName="C:\test_wrk\networks\buses"

_vAgilentEEsof_dSDF_nAdd_lsdfstars:I<0>  N<0>,N<1>,N<2>  _net1

_vAgilentEEsof_dSDF_nAdd_lsdfstars:I<1>  N<3>,N<4>,N<5>  _net2

_vAgilentEEsof_dSDF_nAdd_lsdfstars:I<2>  N<6>,N<7>,N<8>  _net3

 Unspecified pin width, unspecified net width, specified instance width

Pin width is set to 1 and net width is set to the instance width.

 Unspecified net width, pin width specified, instance width specified

Net width inherits connection width (pin width × instance width).

For the next three cases, everything (pin, instance and net width) is specified. The first
case that applies (based on the order shown next) is the correct case.

Net width = connection width
Net width = pin width
Net width = 1

 Net width = connection width

The net width of the bus/bundle is the same as the connection width. This connection is
resolved and verified because the total number of pins (connection width) matches the
individual wires available.



Schematic Capture and Layout

51

 Net width = pin width

If the net width and the pin width are the same, but the connection width is different, then
the connection is valid, but the wires making up the bus/bundle must be repeated M
times, where M is the instance width.

 Net width = 1

If the net width is 1, and does not satisfy the previous two conditions, then the bus (really
a single wire) is repeated M times, where M is the connection width. Thus this is the case
when the pin width is greater than 1 and the net width is 1. This case will issue a warning
because although this is valid, we assume that a pin with width connected to a single wire
(shorted) may not be what the user intended.

The following figure illustrates how the connections of a six-bit bus are mapped to which
pin of which instance, where there are-in essence-two instances, each with three pins.
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The next figure illustrates how the connections are made if you connect the
aforementioned instance to a three-bit bus instead, which is allowed because the iterated
instance has a three-bit pin.

 

 Adding Pins to a Design
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Note
In previous versions of ADS, these objects were called ports.

Click the pin symbol on the toolbar (or choose Insert > Pin).1.
Select the appropriate rotation by clicking the toolbar button (Rotate By -90) as2.
needed.
Move the pointer into the drawing area, position the symbol as needed, and click to3.
place it there.

Hint
Use the Move To Layer command to move pins to a different layer, or double-click the pin and use
the edit/property dialog box.

 

 Using Special Components

There are a number of commonly used components in ADS whose special features must
be understood for their effective utilisation.

Using Substrates
Using Nonlinear Models
Components that Allow File-Based Parameters

 

 Using Substrates

Substrates (such as microstrip, stripline, etc.) are specified by placing the required
substrate component in your design and then setting the substrate parameter (Subst) of
the associated circuit component(s) equal to the instance name of the substrate
component.
In the following example, the substrate parameters of the MSub1 instance are associated
with the Bend1 instance by assigning the instance name "MSub1" (of the MSUB substrate
component) to the Subst parameter of the MBEND2 component.

Note that the default value of the substrate parameter Subst, as well as the default
substrate instance name (in this example, MSub1), can be edited.

 

 Using Nonlinear Models

A nonlinear model can be associated with a nonlinear device instance by placing the
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required nonlinear model item in your design and then setting the parameter Model of the
nonlinear device equal to the instance name of the nonlinear model item. This is especially
useful in a hierarchical design that contains multiple subnetworks, each of which should
reference the same model. In this case, place the _Model item in the top-level design, and
place an instance of the device in each of the subnetworks, setting their Model parameter
equal to the Instance Name of the _Model item.
In the following example, the model parameters of the BJTM1 instance are associated with
the BJT1 instance by assigning the instance name "BJTM1" (of the BJT_Model item) to the
parameter Model of the BJT4_PNP device.

Note
The default value of the Model parameter - for any given device - is the same as the default Instance
Name of the related model (in this example, BJTM1). The Instance Name of the model can be changed,
like any other Instance Name. If you do, be sure to change the Model parameter (of instances referencing
that model) accordingly.

 

 Components that Allow File-Based Parameters

Several components, such as DataAccessComponent (DAC), Deembed, and the SnP
components, enable you to set a parameter to reference a file-based set of values. For
details on the file formats of the data file types, refer to Working with Data Files (cktsim).

To specify file-based parameters for these components:

Select the File parameter.1.
Select the appropriate Parameter Entry Mode: Data filename (DAC) or Network2.
parameter filename (SnP, Deembed1, Deembed2).
Type the data filename, or Browse to select it. By default, only the files listed in the3.
current /data directory are displayed.
Alternatively, click Data files list to select a data file. The files listed are the files
found in the set of search paths assigned to the DATA_FILES variable (in de_sim.cfg
). The data directory of the current workspace is usually the first path. For more
information on setting variables, see Variables in de.cfg, de_sim.cfg (custom).
Optionally, click Edit to display the file (in your default text editor) for modification.4.
Optionally, click Copy Template to copy a data file of a specific format for use as a5.
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template. This template can be a supplied template or one you have created. By
default, the program looks in the following location:

$HPEESOF_DIR/circuit/templates (Analog/RF designs)

or

$HPEESOF_DIR/adsptolemy/templates (Digital Signal Processing designs)

 

 Using the DataAccessComponent

Many component parameters, as well as variables, can be assigned a value from a data
file by using the DataAccessComponent (DAC). The basics of accessing file-based
parameters are as follows:

Add a DAC component to your design
Set the File parameter of the DAC equal to the data file of interest
Set the parameter of the component of interest to reference the DAC (by its Instance
Name)
For details on setting the DAC's parameters and some basic examples, refer to the
DataAccessComponent (Data Access Component) (ccsim).

 

 Using Macros to Automate Tasks

You can record a macro (a series of AEL (ael) commands) by performing a sequence of
commands using the mouse, and then play it back later to repeat the sequence.

Note
Not all commands/actions are supported in macro recording; therefore, Agilent Technologies does not
recommend relying on this for recording complicated command sequences, but rather as a tool for
learning how to use AEL (ael).

To record a macro:

From the Main window, choose Tools > Start Recording Macro and a dialog box1.
appears.
Enter a name for your macro - the file extension .dem will be added automatically -2.
and click OK.
Perform the desired sequence of commands.3.
When you are finished with the desired sequence, choose Tools > Stop Recording4.
Macro. The file is saved to your current workspace directory.

To play back a macro:

Choose Tools > Playback Macro and a dialog box appears displaying the macro1.
files in the current workspace directory (that match the filter).
Select the desired macro and click OK (To run a macro stored in another workspace2.
directory, adjust the path as necessary, select the macro from the list, and click OK).
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The selected macro is executed.

 

 Viewing and Entering AEL Commands

The AEL (ael) commands that are issued in response to your activity in the Main window
and the design windows are displayed in the Command Line dialog box. This command
summary is updated continuously as you work. You can view this summary any time and
you can issue previously executed commands from this list.

To view the command summary:
Choose Tools > Command Line in the Main window and the dialog box appears. As you
execute commands, the corresponding AEL functions are displayed.

To execute AEL commands from this command summary:

Type the command(s) in the Command >> field and press Enter or click Apply after
each to execute.

Note
All commands entered in the Command >> field must be in AEL format.

or
Select a previously typed command from the list and press Enter or click Apply to
execute.
or
Double click any command in the list and the command is executed.
Click Cancel to dismiss the dialog box.

Note
For configuration details on using AEL, refer to the AEL (ael) documentation. For layout artwork and
usage, refer to the Layout Library (layout) documentation.

 

 Creating a Netlist

By default, every time you simulate a design, you generate a netlist file, netlist.log, in the
current workspace directory, but it is possible to generate the netlist file without
simulating the design.

To generate a netlist without simulating:

Open the desired Schematic .1.
Choose Tools > Command Line in the Main window and the Command Line dialog2.
box appears.

Hint
Replace the number 1, shown in parentheses in the next step, with the number of the window from
which you want to generate a netlist. The number of the window is displayed in the title bar.

Click in the Command >> field and type de_set_window(1); and click Apply.3.
Notice that what you type is reflected in the list above.
Click in the Command >> field and type de_netlist( ); and press Enter or click4.
Apply. After a short time, the netlist.log file is written to the workspace directory.
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To use a different filename for any given workspace, you can insert the following line in
the de_sim.cfg file in that workspace directory and specify a filename other than
netlist.log.

NETLIST_FILE_NAME=netlist.log

Important
If you edit your schematic after generating a netlist, you will need to generate the netlist again, since
nodes may be renumbered as you edit.

 

 Generating Bill of Materials and Parts List

The Reports command enables you to generate a Bill of Materials (BOM) and a Parts List.
Examples of a BOM and a Parts List are shown below.

Note
By default, Only one format for the BOM and two for the Parts List are provided, but these formats can be
customized, and additional formats can be added, through AEL. For details, refer to the AEL (ael)
documentation.

To generate a Bill of Materials:

Choose File > Reports > Bill of Materials.1.
By default, the design name and a {{.bom}}extension appear as the filename for the2.
generated file. Accept this name or type another and click OK. The file is displayed in
a new window on the screen.

 Bill of Materials Example  

To save it to file with the default filename, click OK; to save it to file with a filename3.
of your choice, click Print. Type a filename and click OK.
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Note
Components included in the Bill of Materials are physical parts only (concrete items that can be
touched). Examples of physical parts are vendor parts, SMT components, and packaged
components. Components that are not physical parts, like distributed components, are not included
in the Bill of Materials.
The ITEM_BOM_ITEM attribute in create_item() is what triggers a component to be listed in the Bill
of Materials. If you have created a library part, representing a physical part, then you can set the
ITEM_BOM_ITEM attribute by selecting File > Design Parameters > Parameters tab > Include
in BOM checkbox.

To generate a Parts List:

Choose File > Reports > Parts List.1.
Choose the desired Report Type.2.

EEsof (EEsof PL format) - component name, ID, coordinates, angle, and side
EEsof (netlist format) - component names and parameters

By default, a .pl (parts list) or .net (netlist) extension is automatically added to the3.
filename. Accept this name or supply another and click OK. The file is displayed in a
window on the screen. The box below shows an example of the parts list format.

 Parts List Format Example  

The box below shows an example of the netlist format.

 Netlist Format Example  
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Click OK to save it to file with the default filename.4.

Note
Click Print to print to file or to the printer, based on your current Print Setup. If the current Print
Setup is set to print to file, a dialog box appears prompting you for a filename. Supply a filename
and click OK.
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 Rotating Symbols
By default, all symbols in ADS schematics can only be rotated in 90 degree increment. It
is strongly recommended that ADS users follow this model and only use 90 degree
rotations. Non-90 degree rotation can be enabled for any single symbol by opening the
symbol, choosing File > Design Parameters..., selecting the View-Specific Configuration
tab and checking the check-box.

Using non-90 degree rotation has the following disadvantages:

Memory consumption will be increased and program speed will decrease. (The
symbol will be changed to a "pcell" meaning that the drawn artwork is generated
programmatically when needed instead of simply loaded from the symbol view.)
Any designs using the symbol will not be compatible with any other OpenAccess
based tools in the future. (This is true even if the symbol is not rotated on the
design.)

It is possible to modify all of the symbols in built-in ADS libraries to allow non-90 degree
rotation. This has the following disadvantages:

A significant reduction in the speed of operation of ADS as all symbols will become
pcells.
Loss of compatibility with other ADS users. Designs with non-90 degree symbols will
have their symbols moved to the nearest 90 degree (if any) loaded in a standard
ADS installation.

Only the ADS analogRF symbols can be made to rotate to arbitrary angles.

You should make a backup of $HPEESOF_DIR/oalibs/rf prior to running the AEL to change
the symbols.

To make all of the analogRF symbols rotate arbitrarily, first open a command window
using Tools > Command Line...

In the command window, type the following command:
deutil_make_all_analogRF_symbols_rotatable();

This will convert any symbol that can be made rotatable into a parametrized symbol that
can be rotated to an arbitrary angle.

If you only want to convert one library to use rotatable symbols, type the command:
deutil_make_symbols_rotatable( libName, oaLibPath );

Where;

libName is the name of the OpenAccess library
oaLibPath is the file system path to that library.

Note
This command can be used to convert vendor design kit symbol libraries to use arbitrary rotations.

There are two prerequisites before this operation:
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You must have write access to directories containing the library.
You must have a lib.defs file that gives you shared access to the library.
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 Creating Hierarchical Designs
You can use any network as a subnetwork, within another network, to create a
hierarchical design. There are two ways to create a subnetwork:

Use the Create Hierarchy command (Edit > Component > Create Hierarchy) and1.
specify a portion of an existing design to be copied to its own design file for use as a
subnetwork.
Create a new design consisting of a network you want to use as a subnetwork.2.

Hint
To view design hierarchy in the current workspace, choose View > Design Hierarchies from the
Main window.

To access a design in one workspace for use as a subnetwork in a design in another
workspace, create a hierarchical workspace (File > Include/Remove, in the Main
window).

Note
The Update Component Definitions command (Edit > Component) enables you to explicitly update
component definitions (that you have changed) throughout the current design. If you select the Update
Component Definitions in Subnetwork option, the design hierarchy will be traversed (downward) and
components will be updated throughout the hierarchy.)

 

 Creating a Subnetwork from an Existing Design

The Create Hierarchy command copies the selected portion of your design to another file,
saves that new file, deletes the selected items in the original file and replaces them with a
default symbol representing the deleted items.

Hint
You can create a custom symbol to use in place of the default symbol. For details on symbols, refer to
Working with Symbols (usrguide).

The example used to illustrate this command is based on a simple, 3-resistor attenuator
that is part of a larger design. In this example, the main design is named main_design
and the file created using the Create Hierarchy command (containing the 3-resistor
attenuator) is named my_atten.

To create a subnetwork from an existing design:

Select the items you want to include in the subnetwork (represented here inside the1.
box drawn with a dashed line).
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Choose Edit > Component > Create Hierarchy and a dialog box appears.2.
Type a name for the new file, in this example, my_atten, and click OK (The name3.
you provide is the filename for the subnetwork as well as part of the annotation for
the symbol when you place it in a design-however, no annotation is displayed in this
example.)
The selected items disappear from your original design and are replaced by a default
symbol (in this example, a 2-port symbol). Wires are redrawn to reconnect the
remainder of the design to the symbol.
Save the file. The design used in this example appears as shown next.4.

If you want to use this network as a parametric subnetwork in a hierarchical design, you
must open this newly created file (my_atten) and define the parameters that you want to
be passed from the subnetwork to the network.

To define parameters for an existing subnetwork:

Open the file containing the subnetwork design.1.
Choose File > Design Parameters and a dialog box appears.2.
Type a parameter name (not to exceed 8 characters), and select the appropriate3.
characteristics for that parameter.
When you are through assigning characteristics to that parameter, click Add and the4.
newly defined parameter is added to the Parameters list box.
Continue in this manner until you have assigned all the desired parameters for this5.
network and click OK.
For a more information on defining parameters, see Defining Parameters (usrguide).
 

 Creating a Parametric Subnetwork
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Any network can serve as a parametric subnetwork. A parametric subnetwork is any
network for which you define the control parameters that pass through to the network into
which you place the subnetwork. Once you have defined the parameters, your subnetwork
can serve as a template enabling you to assign parameter values each time you place it in
a cellView. You can construct whole libraries of re-usable subnetworks in this manner.

The steps for this process are:

The details of this process are presented using this example of a simple design consisting
of a capacitor and a resistor in series and two ports. This subnetwork is called series_r_c
and is represented by the default 2-port symbol.

After you have placed the subnetwork within another design, you can assign values to any
defined parameter.
 

 Creating the Subnetwork

You can create the subnetwork first, or define parameters and then create the
subnetwork. In this example, the subnetwork is created first.

To create the subnetwork:

Choose File > New in the Schematic window and assign a name, in this example,1.
series_r_c. This name becomes part of the annotation for the symbol representing
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the subnetwork when you place it within another design.
Select Analog/RF Network as the Type of Network and click OK.2.
Click the Library button and select a category, in this example, Lumped3.
Components.
Select a component, in this example, C (Capacitor).4.
Place the capacitor in the Schematic window. Note the component parameter C is set5.

equal to the default value of 1.0 pF. Click  .
Click the capacitance value to invoke the on-screen editor and use the Back Space6.
key to erase the 1.0 pF.
Type C and press Return. The parameter now reads C=C (This C parameter will be7.
defined in the Design Parameters dialog box in a later step and serves as a variable
here.) The parameter C (capacitance) of this component will now pass through to the
network in which it is placed.
Place the next element, in this example, R (Resistor), accepting the default values.8.
Connect it to pin 2 of the capacitor symbol.
Add ports and click the End Command button. The subnetwork should resemble the9.
following illustration.

 

 Defining Design Characteristics and Parameters

Design characteristics include elements such as the description and the Simulation Model
that have default values. These design characteristics can be redefined.

In addition, the cell may or may not have design parameters associated with it. You may
define new parameters or redefine existing parameters for the network. When you define
parameters for a network, the network serves as a template, enabling you to assign new
parameter values each time you use the network. This is useful when a portion of the
network is used several times in a design with certain element value differences, or in
constructing libraries of reusable networks. Parameters of the network are generally
referenced as variables by the elements of the network. You can define the parameters
before or after creating these variable references.

Finally, you can select the appropriate a artwork type only for Analog/RF layout cellViews.

If the default design characteristics, parameters, and artwork configuration are
acceptable, then proceed to the next session. In this example, however, these changes
concerning the defaults will be made.

Description will be set to cap and res1.
Component Instance Name will be set to para_sub2.
Simulation Model will be set to Subnetwork3.
The parameter C will be defined.4.
The Multiplicity Factor M_ will be added.5.
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The Artwork Type will be set to Use This Layout6.

To make the above changes, choose File > Design Parameters and complete the
necessary information in dialog box. For more details, see Defining Parametric Subnetwork
(usrguide).

 

 Placing the Subnetwork in a Design

Now you can place the subnetwork you just created into another network. The parameter
you assigned (capacitance in this example) will pass through to the network.

To place a subnetwork:

Open the file containing the network in which you want to place the subnetwork (in1.
this example, main_network - not shown).
Click the Library button (or choose Insert > Component > Component Library).2.
In the Component Library window, locate and select the library containing the3.
subnetwork, in this example, my_subnetworks.
Select the subnetwork, in this example, series_r_c, and place it in the drawing area.4.
Click End Command.
Notice that C = 5 F. This 5 is the value from the Default Value field (for the
parameter C) in the Design Definition dialog box. Because we did not specify a scale
factor, the default F (Farads), from the Preferences dialog box is used (Options >
Preference > Unit/Scale).
Using the on-screen editor, change the default capacitance value to the desired value5.
for the current design, in this example, 2. Press Return.

 

 Modifying a Subnetwork Design

If you make changes to a subnetwork that affect the component definition (any changes in
the Design Parameters dialog box-information that is saved in the .ael file), that serves as
a subnetwork in a higher-level design, you need to explicitly update the higher-level
design to recognize those changes.

To update a higher-level design that contains a modified subnetwork:

From the higher-level design, choose Edit > Component > Update Component1.
Definitions.
To traverse the hierarchy (downward) in search of any subnetwork designs whose2.
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component definitions have been changed, select the option Update Component
Definitions in Subnetwork and click OK. Changes to any subnetwork designs are
now reflected in the instance(s) in the main design.

 

 Viewing the Network Represented by a Symbol

Whenever your design contains a symbol that represents a network, you can view the
actual network being represented by the symbol by using the Push Into Hierarchy
command.

To push into and then pop out of an item:

Select the item.1.
Choose View > Push Into Hierarchy. The network represented by the symbol is2.
displayed.
The Pop Out of Hierarchy command is the reverse of pushing, and only works if a
design has been pushed into.
Choose Pop Out of Hierarchy to get back to the item (or design containing the3.
item).

 

 Editing a Hierarchical Design

In the Layout window, you can edit the actual artwork represented by a component
without pushing down into the hierarchy. This feature is particularly helpful is some cases
such as when you need to position items in the subnetwork to align with items in the main
design. For details on pushing into a hierarchical design to edit it, refer to Pushing Into or
Popping Out of Hierarchy (usrguide) under the section on Creating a Layout (usrguide).

Use the following steps to edit a hierarchical design without pushing into the hierarchy.

Select the component representing the design.1.
Choose Edit > Edit In Place > Push Into to enter the edit mode for the network2.
represented by the symbol.
Use the editing commands and tools to make the desired modifications. The few3.
commands that are disabled when you edit a hierarchical design are as follows:
Main Window > File
Menu

ALL COMMANDS DISABLED. EXCEPT: New Design, Open Design, and Copy
Design

Main Window > Tools
Menu

Playback Macro

Layout Window > File
Menu

Close Design, Revert to Saved Design, Save Design As, Delete Design,
Import, Export, Exit Advanced Design System

Layout Window > Edit
Menu

Component > Create Hierarchy

Layout Window > Tools
Menu

DRC: Width Spacing, DRC: Custom Rules

Layout Window >
Schematic Menu

All commands in menu
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Note
The Schematic window excludes the same commands as the Layout window. Schematic window
commands that don't have an equivalent command in the Layout window are not disabled.

 

 Edit in Place Hints/Tips

You cannot use Push Into after you use Edit in Place, but you can use Edit in
Place after you use Push Into.
Edit in Place does not edit AEL (ael) artwork macros.
Edit in Place does not work if Layout Units/Precision is different from the top level.
Parametric subnetworks use default values defined in Design Parameters.
You can snap to pin of ports but not to edges/vertices using Edit in Place.
Edit > Edit In Place > Push Into will not work if the design is open in multiple
windows or if it is being Edited in Place in another window.

 Creating Polymorphic Hierarchical Designs

ADS 2011 allows you to make multiple layout and schematic views for your design. To
create alternate layout or schematic views, follow the
instructions for creating a hierarchical design (usrguide), and specify a new name for the
view (e.g. schematic_behavioral).
Each view can represent a different data aspect of the design.

Note
For your designs to simulate properly, you should make sure to use the same number of terminal pins for
each view.

You can specifically make a view representing EM simulation data by following the
instructions for making an EM Model .

The design used during simulation is controlled via a hierarchy policy. It is possible to view
the design that will be used for simulation and to
modify the hierarchy policy using the Hierarchy Explorer .
 

http://edocs.soco.agilent.com/display/ads201101/Using+an+EM+Model
http://edocs.soco.agilent.com/display/ads201101/Using+an+EM+Model
http://edocs.soco.agilent.com/display/ads201101/Dynamic+Model+Selection
http://edocs.soco.agilent.com/display/ads201101/Dynamic+Model+Selection
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 Viewing Designs
The View menu command (in layout or schematic window) enables you to change the
current view of the drawing area to aid you in working with the image in the design
window. Additionally, there are a number of commands on the Options menu that display
various aspects of design information.

Zooming In and Out
Panning and Zooming
Repositioning a Design to Fit the Window
Moving the Center Point of a Window
Saving and Restoring Views
Viewing Layers by Name
Viewing Layers by Location in a Substrate
Viewing in 3D
Viewing Design Information
Checking Connectivity Information in Schematic

 

 Zooming In and Out

The Zoom commands(View > Zoom) enable you to enlarge or shrink the area being
viewed. Zoom By window (View > Zoom > Zoom By Factor > Zoom In By...) enables
you to specify your own view window for zooming, if the other zoom commands do not
meet your needs.

To zoom in on a specified point in the window:

Choose Zoom In Point.1.
Click to specify a point and the current view is magnified by a factor of two, moving2.
the point you specify to the center of the window.

To zoom out from a specified point in the window:

Choose Zoom Out Point.1.
Click to specify a point and the current view is decreased by a factor of two, moving2.
the point you specify to the center of the window.

To specify a particular factor by which to zoom, choose Zoom By Factor and choose the
appropriate command.

Zoom In x2 (zooms in by a factor of 2)
Zoom Out x2 (zooms out by a factor of 2)
Zoom in x5 (zooms in by a factor of 5)
Zoom Out x5 (zooms out by a factor of 5)
Zoom In By ... (and specify the desired factor)
Zoom Out By ... (and specify the desired factor)

To specify a particular portion of the view for zooming:

Choose Zoom Area. You are prompted to enter the first corner.1.
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Move the cursor to the point representing the upper-left corner of the desired view2.
window and click left. You are prompted to enter the second corner. As you move the
mouse, a flexible box, representing the view window, moves with it.
Move the cursor to the point representing the lower-right corner of the desired view3.
window and click left. The portion of your drawing enclosed by the view window is
magnified (The magnification amount is determined by the size of the view window
you specified.)

To zoom to a selected object(s):
Select the object(s) and choose View > Zoom > Zoom To Selected.

See also: Panning and Zooming.

 Panning and Zooming

The pan and zoom features in ADS enable you to display an area of interest from a
different perspective or resolution. Using the keyboard arrows to pan, or the mouse
features to pan and/or zoom, you can quickly change your perspective while working with
your design.

To pan vertically or horizontally:

Click in the window and use the arrow keys on your keyboard to pan a design left,
right, up or down.

To pan vertically, horizontally, or diagonally:

Right-click a point on your design, holding the right mouse button down, and drag
the mouse to pan the point in any direction.
Left-click, holding the left mouse button down, and drag the mouse to dynamically
pan the design to a new location. This may be as you are inserting a shape or during
area selection.

To zoom on a particular point in your design, move your cursor above a point in your
design and:

Roll the mouse-scroll wheel forward (away from you) to zoom in on that point.
Roll the mouse-scroll wheel in reverse (toward you) to zoom out from that point.

Your design will automatically re-center itself and zoom in/out at the location of your
cursor.

See also: Zooming In and Out.

 

 Repositioning a Design to Fit the Window

Choose View > View All to rescale and reposition your design so that it all fits in the
window. Your design is scaled as needed and repositioned to fit it all, plus a five-percent
border, in the viewing area.
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 Moving the Center Point of a Window

The Pan command moves a point you specify, to the center of your window. Alternatively,
you can use the scroll bars to move a different part of the window to the center.

To change the center point:

Choose Pan View from the View menu or the pop-up menu. You are prompted to1.
enter the new window center.
Click once and the selected point becomes the new center point of the window. Your2.
design is redrawn accordingly.

 

 

 Saving and Restoring Views

It is possible to save multiple views of your design at various zoom settings. Different sub-
menu options in View menu are:

Restore Last View enables you to restore the view that was in the window the last
time you issued a Pan or Zoom command.
Save View enables you to save the current zoomed or panned view with a name.
Restore View enables you to retrieve a saved view.
Delete View enables you to delete a saved view.

To restore the view that was in the window the last time you issued a Pan or Zoom
command:
Choose View > Restore Last View.

To save the current view:

Choose View > Save View. A dialog box appears.1.
Type a name for the view and click OK.2.

To restore a view that has been saved:

Choose View > Restore View. A dialog box appears.1.

To delete a view that has been saved:

Choose View > Delete View. A dialog box appears.1.
Type the name of the view or select from the available list and click OK or Apply to2.
delete.

 Viewing Layers by Name

Choose View > Layer View > By Name to Layout Layers dialog box listing all layout
layers in the Layout Window. Select a layer in the dialog box and only that layer will be
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visible. All other layers are made invisible. Click OK to close the dialog box.

 Viewing Layers by Location in a Substrate

The other Layer View commands allow changing layer attributes based on how they are
mapped in a Momentum/FEM substrate. A valid substrate setup is a prerequisite. See
Assigning Substrates (em).

Choose Layer View > Show Substrate Layers and then Outline, Filled, or Both to
make all layout layers mapped in the substrate visible and selectable. The shape display
will be Outline, Filled, or Both based on the choice made. Attributes for other layout layers
are not changed.

Choose Layer View > Hide(Show) Non-Substrate Layers to make all layout layers
that are not mapped in the substrate invisible(visible) and non-selectable(selectable).

The remaining commands change layer attributes based on their position in the substrate
stack. Attributes of layout layers that are not mapped in the Momentum substrate stack
are not changed. Layout layers sharing the same z-coordinate are grouped and the groups
are sorted according to the z-coordinate.

The Top/Up/Down/Bottom menus allow you to walk up and down the substrate stack, and
while doing that, changes the visibility, selectability, and shape display of the layout
layers.

Enable Show Current and Previous Layers to make two layer groups visible at a time:
a current (shape display = 'Filled + Outline' and Selectable) and previous (shape display =
'Outline', Non-Selectable) group. All other layers become invisible and non-selectable.

Disable Show Current and Previous Layers to show the current group of layers only
(shape display is not changed). All other layers become invisible and non-selectable.

Layer View > Top makes the highest interface in the substrate stack the current
position.
Layer View > Up moves up the substrate stack from the current position.
Layer View > Down moves down the substrate stack from the current position.
Layer View > Bottom makes the lowest interface in the substrate stack the current
position.

Choose Tools > Hot Key/Toolbar Configuration to assign hot keys to these menu
commands. Hot keys greatly simplify walking up and down the substrate stack.

 Viewing in 3D

The 3D Viewer allows you to validate that your three dimensional design has been
properly constructed. A valid Momentum/FEM substrate setup is required for these
commands.

In Layout Window:

View > 3D View > All loads the complete layout into the viewer.
View > 3D View > Selection only loads the items selected in the design. Make the
selection before invoking this command.
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See also, Visualizing an EM Simulation (em).

 

 Viewing Design Information

You can display a variety of design information using commands found on the Tools
menu:

Hierarchy displays a listing of the hierarchical information of the current design in
the Schematic and Layout windows.
Info displays a detailed listing of design information including current units,
preference and layer file associated with design, instances by name and ID, mask
layer information, and a summary.
Identify lists detailed data for selected instances, shapes, or text.
Check Design provides information on unconnected pins, port verses pin mismatch,
and nodal mismatch.

 

 Viewing Detailed Design Information

The details on closed shapes include area, perimeter, and layer; for text, it includes the
string and font attributes; for polylines it includes length. For components, the Name, ID,
X, Y location, fixed/free status and equivalent element are displayed. A short summary is
included that shows the number of items and shapes, the layers used, and the total
selected area, length and perimeter.

To display detailed information for selected items:

Choose Tools > Info and the Information dialog box appears.1.
To view details on items not selected initially, select and click Refresh. The2.
information is updated to display details of the newly selected item(s).
Optionally, click Print to send the information to your default printer.3.
Click Close to dismiss the Information dialog box.4.

 

 Viewing Detailed Instance Information

To display detailed information for selected instances:

Choose Tools > Identify and a dialog box appears.1.
To print the information, click Print and it is sent to the default printer.2.
Click Close to dismiss the dialog box.3.

 

 Viewing Hierarchical Design Information

There are two different ways to view hierarchical design information:
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At the design level, for the current workspace (View > Design Hierarchies, in the
Main window)
At the component level, for the current design (Tools > Hierarchy, in the Schematic
and Layout windows)

To view design hierarchies for the current workspace:

In the Main window, choose View > Design Hierarchies.1.

If the workspace contains more top-level designs than can be displayed at one time,
the arrows on either side of the tabs enable you to cycle through the remaining top-
level designs to select the one you want.
Double-click any design to open it.2.

To view the component hierarchy information for the current design:

Choose Tools > Hierarchy and the Hierarchy dialog box appears.1.
Hierarchical levels are indicated by the level of indentation in the list. Top level items
are not indented; each nested level is indented with two spaces.
Click Print to send the information to your default printer.2.
Click OK to dismiss the Hierarchy dialog box.3.

 

 Checking Connectivity Information in Schematic

In the Schematic view, the Check Design and Check Design Report commands allow you
to check connectivity and to compare to layout. See Comparing Designs (usrguide) for
more information.

 

 Cross-Probing

To see the layout representation of a specific node in your schematic, from the Schematic
and Layout window choose Layout > Show Equivalent Node and click the pin or wire
that you would like to see in the layout. When you view the layout, the objects that belong
to the node of the wire or pin that you selected in the schematic will be highlighted.
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 Editing Designs
Most of the edit commands available in ADS enables you to select the item(s) before you
select the edit command, or vice versa. Several editing commands are repeating
commands; that is, once the command is chosen, it remains active until another
command is chosen or until it is explicitly canceled (Edit > End Command).

You will find it easier to edit your designs if you understand some of the features provided
to assist you in selecting the item(s) you want to edit. Design entry and display
preferences are described in the Setting Design Environment Preferences (custom).

 

 Using the Undo and Redo Commands

Selecting Undo (Ctrl+z) undoes the last editing command.

Selecting Redo (Ctrl+y) redoes the last Undo command. Redo cannot be used if any other
command is performed after the undo operation.

Note
Selecting is considered an operation. If the selection is changed, redo will not be available.

A stack of edit commands is created enabling you to choose Undo or Redo repeatedly to
return to an earlier state of your design. A stack is maintained for each window, thus the
Undo and Redo commands work independently from window to window. To specify the
number of commands you want the stack to hold, click Options > Preferences >
Entry/Edit in any of the design windows, enter a value in the Undo edit count field, and
click OK.

 

 Deleting Items

To delete selected items, click the Delete button on the toolbar, or press the Delete key
on the keyboard, or choose Delete from the Edit menu. Deleted items can be restored
using the Undo command.

 

 Activating, Deactivating, and Shorting Components

Use the following information to modify a design to include or exclude components without
deleting them. ADS provides two ways to exclude items from a simulation: deactivating,
and deactivating and shorting.

 

 Activating and Deactivating Components

A deactivated component is excluded from the design during simulation. When a
component is deactivated, a box with an X drawn through it is displayed over the
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component. The deactivated component text also appears in a gray color (default). The
color of the deactivated component text can be changed using the Deactivated Component
Text color defined through Options > Preferences > Display.

Note
When a component is deactivated, it cannot be on-screen edited. However, you can still edit a deactivated
component using the component parameter dialog box.

To deactivate or activate components:

Choose Edit > Component > Deactivate/Activate.1.
Select a component to switch its current state.2.
Clicking an active component deactivates it and a box with an X drawn through it is
displayed over the item. A deactivated item is excluded from a subsequent
simulation.
Clicking a deactivated component (shorted or not) reactivates it. The item is included
in a subsequent simulation.

Hint
The color of the deactivation box is the Highlight color defined through Options > Preferences >
Display.

If you select more than one component and then invoke the Deactivate/Activate
command, one of the following occurs:

If all components were active, they get deactivated, and vice versa.
If some of the selected components were activated while others were deactivated, all
components get deactivated.

Note
When using the Generate/Update Layout command, instances that have been deactivated will not
appear in layout. This includes instances that have been deactivated and shorted. To work around
this problem it may be necessary to run Generate/Update Layout more than once, and select a
starting instance on either side of the deactivated and shorted instance. The short will have to be
manually added in layout if it is desired to simulate from layout.

 

 Deactivating and Shorting Components

A deactivated and shorted component is interpreted as a short during simulation. When a
component is deactivated and shorted a box with an X and a solid bar drawn through it is
displayed over the component.

To deactivate and short components, or to activate components:

Choose Edit > Component > Deactivate and Short/Activate.1.
Click one or more components to switch their current states.2.
Clicking an active component deactivates and shorts it. A box with an X and a solid
bar drawn through it is displayed over the item. The item is interpreted as a short in
a subsequent simulation.
Clicking a deactivated component (shorted or not) reactivates it. The item is included
in a subsequent simulation.
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Note
If the component you have selected cannot be shorted, a message is displayed to let you know and
the component is only deactivated.

If you select more than one component and then invoke the Deactivate and
Short/Activate command, one of the following occurs:

If all components were active, they get deactivated and shorted, and vice versa.
If some of the selected components were activated while others were deactivated, all
components get deactivated and shorted.

Note
In Analog/RF designs, generally only components with two pins can be deactivated and shorted;
other components are just deactivated (Exceptions to this two-pin rule are: S2P, S2P_Conn,
S2P_Pad3, S2P_Spac, and Deembed2. When these components are deactivated and shorted, the
short is created between pins 1 and 2.) The Deactivate and Short or Activate Components command
is disabled for DSP designs. To be able to deactivate and short a custom component with more than
two pins, refer to the instructions for the create_item() (ael) function in the AEL (ael)
documentation.

 

 Editing Component Parameters

There are several methods for changing component parameters. The simplest methods
involve editing parameters for individual components:

Using the on-screen editor.
Using the component parameter dialog box.
Additional methods that accommodate editing parameters in specific situations are:
Searching for a particular parameter - a parameter whose value is stated as a
reference to another component (Search/Replace Reference) - and then replacing
that parameter throughout the design.
Changing the value of a particular parameter common to components throughout the
design (Group Edit Parameter Value).

Note
The at symbol (@) must be used to suppress quotes when specifying a variable, for example,
@freq1, where freq1 is a variable declared in a VAR item.

 

 Editing Component Parameters On-screen

You can use on-screen parameter editing to change parameter values. In addition, you
can change the Value Type from nominal to variable, and vice-versa. If you need to
change a parameter's Value Type to anything other than nominal or variable, refer to the
next section, Editing Component Parameters Through the Dialog Box.

Hint
When you click the component name, you initiate the Swap Components command.

To edit one or more parameters for a component using the on-screen method:

Position the pointer over the parameter you want to change and click. The editable1.
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portion of the parameter takes on the current Highlight color (Options >
Preferences > Display). You will also see that a vertical bar (|), representing a text
insertion cursor, appears in the parameter line.
Use the mouse, arrow keys, and backspace key as necessary, to change the2.
parameters.
To end the parameter editing command, move the pointer away from the component3.
and click once (If the parameter is the last one in a list of parameters or is the only
parameter for this component, pressing Return also ends the command.)

Hint
When editing several parameters for one component, you can click each individual parameter you
want to edit, or you can press Return as many times as needed to get to the next parameter you
want to edit. Pressing Return for the last parameter in the list ends the parameter editing command.

Note
when you are on-screen editing component text that has tune, opt, stat or doe syntax in Short or None
format, it will appear in Full format while on-screen editing. After editing is complete, the component text
will continue to be in the format specified by the preference. For more information, refer to Setting
Component Text/Wire Label Options (in Advance) (custom) under the Setting Design Environment
Preferences (custom) section of the Customization and Configuration (custom) documentation.

 

 Editing Component Parameters Through the Dialog Box

Despite variations for some components, certain basic guidelines apply to completing the
component parameters dialog box for most components. The following features of this
dialog box are:

The input fields change based on the individual parameter selected. For more
information, refer to Understanding Standard Parameter Entry Mode.
All variable entries are available by selecting the Equation Editor from the Edit
Component dialog. For more information refer to Using the Equation Editor.
A default ID for a given instance of a given component appears in the Instance Name
field. This ID is unique for every component in the design. You can use the default
name or supply any name of your choosing.
Some parameters offer the ability to use data from a referenced data file. For details,
refer to Components that Allow File-Based Parameters (usrguide) under the section
on Creating Designs (usrguide).
You can turn the display of individual parameters on or off. You can also use
Component Options to set or clear the display of all parameters for the component at
once. For details, refer to the section on Changing the Visibility of Component
Parameters on a Schematic.
For details on Optimization/Statistics Setup, refer to Specifying Component
Parameters for Optimization (optstat) under the section on Nominal Optimization
(optstat) in the Tuning, Optimization, and Statistical Design (optstat) documentation.
For the majority of ADS internal simulator components that are placed in a
schematic, a simulation will automatically use the internal simulator defaults for
component parameters with no value in their field. These parameters are not
typically netlisted.

To edit one or more parameters for a component through the dialog box:

Choose one of the following methods for displaying the dialog box:1.
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Choose Edit > Component > Edit Component Parameters and click the
component symbol
Click the Edit Component Parameters button on the toolbar and click the
component symbol

Double-click the component symbol

Hint
Use the following shortcut to edit parameters for most or all components: select everything in
the drawing area (Select > Select All) and choose Edit > Component > Edit Component
Parameters. Click Apply to accept parameter changes for one component, and another
component is displayed for editing.

Select the parameter you want to change from the Select Parameter list box.2.
Type the new value in the parameter value editing field.3.
Press Return. The Parameters list box is updated to reflect the new value and the4.
value of the next parameter is displayed for editing.
When you are through editing parameters, click OK to dismiss the dialog box.5.

Note
This dialog box will always display parameter values of tune, opt, stat or doe syntax in Full format
even if the component text is displayed as Short or None on the schematic. After editing is
complete, the component text will continue to be in the format specified by the preference. For
more information, refer to Setting Component Text/Wire Label Options (in Advance) (custom) under
the Setting Design Environment Preferences (custom) section of the Customization and
Configuration (custom) documentation.
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 Changing the Visibility of Component Parameters on a Schematic

You can change the visibility status of all parameters of a given component through the
Component Options dialog box (accessed through the component parameters dialog box).

Set All - Displays all parameters for this component on the schematic. Use this option
to display all, or almost all, parameters for this component. To display most - but not
all - parameters, select Set All and then go back and turn off the display of individual
parameters as desired.
Clear All - Clears the display of all parameters for this component from the
schematic. Use this option to turn off the display of all, or almost all, parameters for
this component. To display a small subset of parameters, select Clear All and then go
back and turn on the display of individual parameters as desired.

 

 Referencing VAR Data Items and Model Items in Hierarchical Designs

The Scope option applies to the VAR (Variables and Equations) data item and most model
items (such as R_Model, BJT_Model, BSIM3_Model). Exception: it does not apply to multi-
layer models. Scope indicates the levels, from a hierarchical standpoint, that recognize the
expressions defined in the VAR data item or model item.

Nested-VAR or model item expressions are recognized within the design containing
the VAR or model item, as well as within any subnetworks (designs at lower levels)
referenced by the design containing the VAR or model item.
Global-VAR or model item expressions are recognized throughout the entire design,
no matter what level in the design hierarchy the VAR or model item is placed.

 

 Editing Common Parameters for a Group of Items

The Group Edit Parameter Value command enables you to select a group of components
with one or more common parameters, select a parameter that applies to them all, and
change that parameter's value for all selected components.

To edit every occurrence of a parameter for selected components:

Select all components containing the parameter you want to edit.1.
Choose Edit > Component > Group Edit Parameter Value and a dialog box2.
appears.
Click Name Options and a dialog box appears listing all parameters in your design3.
by name.
Select the desired parameter from this list and click OK. The selected parameter4.
appears in the Parameter Name field.
If the value type of the selected parameter is numeric, type the new value in the5.
Parameter Value field; otherwise, click Value Options and a dialog box appears. The
contents of the dialog box vary depending on the value type of the chosen
parameter.
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Note
You can only change the nominal value of the parameter, not the Value Type.

Select the desired parameter value and click OK.6.
Click Apply in the Group Edit Parameter Value dialog box (or click OK if you are7.
through with this dialog box) and the design is updated accordingly.

 

 Using the Equation Editor

The Equation Editor is a general purpose dialog box that enables you to access all of the
variables defined in a particular design. You can access the Equation Editor from any
standard component dialog box when the Standard Parameter Entry Mode is selected. For
more information, refer to Understanding Standard Parameter Entry Mode.

Note
For a list of available simulator functions, refer to the Simulator Expressions (expsim) documentation.

To edit a variable equation:

Click a parameter to edit in the Select Parameter list box.1.
If available, set the Parameter Entry Mode to Standard in the component dialog box.2.

Note
The Standard Parameter Entry Mode is not available for all component parameters. If the Standard
Parameter Entry Mode is not available, the Equation Editor is not available for that particular
parameter. For more information, refer to Understanding Standard Parameter Entry Mode.

Click the Equation Editor button. The Equation Editor dialog box appears with the3.
component parameter displayed on the left.
Select a variable from the Variables list box and then click the Insert button to add4.
the variable to the component parameter entry field on the left. The variable selected
appears in the parameter entry field. This field can be edited directly to use the
selected variable in an equation.
Click OK to add the new equation to the component parameter.5.
Click OK or Apply in the component dialog box to initiate the change in the6.
component.

 

 Understanding Standard Parameter Entry Mode

A parameter defined to use a form set that includes a form of type StdForm will include
the ability to use the Standard Parameter Entry Mode in the standard component dialog
box. For more information on form sets, refer to Form Sets (ael) under the section on
Creating New Component Definitions (ael) in the AEL (ael) documentation.

The Standard Parameter Entry Mode enables you to interact with the options shown below
in Standard Parameter Entry Mode Options. These options can be used to set up the
parameter's value.
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 Standard Parameter Entry Mode Options

The parameter value field enables you to hand edit the value of the parameter. If the
parameter's attribute value is set for this parameter to be not editable, then you will
only be able to view the current value of the parameter in this field. For more
information, refer to the create_parm() (ael) function's attribute choices in the AEL
(ael) documentation.
The parameter units drop-down list displays the current unit type selected for the
parameter's value. This list of options is dependent on the parameter's unit type
setting. For more information, refer to the create_parm() (ael) function in the AEL
(ael) documentation.
You can click the Equation Editor button to launch the Equation Editor dialog box.
For more information, refer to Using the Equation Editor.
You can click the Tune/Opt/Stat/DOE Setup button to launch the setup dialog box
for Tuning, Optimization, Statistics, or Design of Experiments (DOE) settings. For
more information, refer to the Tuning, Optimization, and Statistical Design (optstat)
documentation.

Note
The Standard Parameter Entry Mode features described above are enabled or disabled uniquely for
each parameter, depending on the parameter's attributes. For more information, refer to the
create_parm() (ael) function's attribute choices in the AEL (ael) documentation.

 

 Component Name Visibility in Schematic

Component names can become very long and can sometimes obstruct the view of other
parts of your design. You can easily turn off your component's design name visibility in
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order to reduce the amount of clutter on your schematic. The visibility of a component's
design name in a schematic window can be controlled through the following ways:

Changing Component Name Visibility through the Edit Component Dialog Box
Changing Component Name Visibility through the Edit Menu

 

 Changing Component Name Visibility through the Edit Component Dialog Box

To change component name visibility through the Edit Component dialog box,

During component placement:

If the component dialog box is available during component placement, click the1.
Component Options button and set the Display component name toggle.
Click OK to set the value to hide or display the component name.2.
Place the component in the schematic window.3.

During component editing:

Choose Edit > Component > Edit Component Parameters and click the1.
component you would like to edit.
Click the Component Options button and set the Display component name2.
toggle.
Click OK to set the value to hide or display the component name.3.
Click Apply in the Edit Component Parameter dialog box (or click OK if you are4.
through with this dialog box) and the component should be updated.

 

 Changing Component Name Visibility through the Edit Menu

To change component name visibility through the Edit menu:

Select the components whose component name you would like to hide or display.1.
Choose Edit > Component > Hide/Display Component Name.2.

 Editing Custom Parameter Properties

Properties once displayed in the Edit > Properties dialog in previous versions of ADS are
included in the Custom tab. All values in the Name, Type, and Value columns are editable.
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 Breaking Wire Connections Between Components

To break the wire connections between components:

Select the component(s) with connections you want to break.1.
Choose Edit > Move > Move and Disconnect to disconnect the component. Place2.
the cursor on component and drag it to desired place. Alternatively, press the control
key and drag the selected component to disconnect.

New in ADS 2011
Press the control key and drag to disconnect the selected component.

 

 Swapping Components

The Swap Components command enables you to select any number of components, with
any number of ports, and replace them all with another component.
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To swap components:

Select all components you want to replace.1.

Hint
Use the Select > Select By Name command to quickly select every component of a particular
type.

Choose Edit > Component > Swap Components and a dialog box appears.2.
Click Select and the Component Library window appears.3.
Select the appropriate library and desired component. The component name appears4.
in the New Component Name field of the dialog box.
Click Edit Parameters and the component parameters dialog box appears.5.
Change any parameters as desired and click OK.6.
To keep the IDs of the original components, select the option Keep the original7.
component ID(s); to let the program replace the IDs with new ones, deselect this
option. Click OK. All selected components in the design window are replaced by the
new component with the specified parameters.

To switch components to use a different view:

Note
The components you choose must have multiple symbol or layout views to effectively use this feature.
Most built in ADS components only have a single view of each type.

Select all components you want to change views. Generally, these components1.
should be of the same type.
Choose Edit > Component > Swap Views and a dialog box appears.2.
Choose the View you want to use.3.
Click OK.4.

 

 Searching and Replacing References

The Search/Replace Reference command enables you to replace every occurrence of a
parameter value where that parameter value is a reference, such as a reference to a data
item. For example, if your design contains two MSUB data items (MSUB1 and MSUB2),
then you can replace every reference to MSUB1 with a reference to MSUB2 instead. You
can also replace references to data items or variables.

To search and replace references to data items or variables in your design:

Choose Edit > Component > Search/Replace Reference and a dialog box1.
appears.
Select the desired Reference Type, Instance Name or Variable.2.
Under the heading Search For, click Select and a dialog box appears. The listing3.
varies according to the selected reference type.

Hint
To highlight these references prior to replacing any, use the Search Only option and click Apply.

Select the Instance Name or Variable name representing the item you want to search4.
for and click OK. The selected reference appears in the Search For field.
Under the heading Replace With, click Select.5.
Select the Instance Name or Variable name representing the desired replacement6.
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and click OK. The Replace With field is updated.
Click Apply (or OK if you are through with the Search/Replace dialog box). All7.
occurrences of the selected reference are updated in your design.

 

 Moving Component Text

You can reposition the component text, collectively, of any component with the Move
Component Text command. In addition, you can change the layer assignment of individual
pieces (Name, ID, Parameters) with the Change Component Text Layer command.

To move component text:

Choose Edit > Move > Move Component Text. You are prompted to enter a1.
reference location.
Click the component whose component text you want to move. You are prompted to2.
enter an offset location.
As you move the pointer, a ghost image representing the component text moves with3.
it. Click again to reposition the component text in the new location.

Hint
Select a component and use the blue diamond handle to move component text. Or, to move text on
many components a little more quickly, press F5, click the component symbol, move the pointer and
a ghost image of the component text moves with it. Position the image in the desired location and
click again to place it there.

To change the component text layer:

Choose Insert > Change Entry Layer To and select the desired destination layer1.
from the list.
Choose Edit > Component > Change Component Text Layer.2.
Click any individual piece (Name, ID, Parameters) of component text. Its layer is3.
changed to the current entry layer and the component text immediately takes on the
characteristics of the current entry layer.

Note
To change the layer on which component text is placed in advance of placing components, use
Options > Preferences > Component Text/Wire Label to specify the desired layer for each
type of component text.

 

 Changing Component Text Attributes

You can change the attributes of existing component text through the Edit menu. Select
one or more components, then choose Edit > Properties.... This command only affects
existing component text. To establish attributes for all subsequent component text,
specify the desired settings through Options > Preferences > Component Text/Wire
Label. For details on changing text you have added to your design, refer to Editing
Existing Text and Text Attributes.

To change component text attributes:
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Select the components whose component text you want to edit.1.
Choose Edit > Properties.2.
Make any desired changes to the text attributes.3.

Font Type - All True Type fonts (Schematic only) installed on your system are
available. Select the desired font from the drop-down list.

Note
On UNIX, if you want to add additional True Type fonts that were not supplied with ADS, copy
them to $HPEESOF_DIR/lib/fonts.

Point - Represents the size of text in traditional units used in printing.
Parameter Rows - The maximum number of rows of parameters before another
column is created.

Click OK and the component text is immediately updated to reflect the changes.4.

 

 Editing Pins

The Edit > Properties... command enables you to change the name, number, and
orientation angle of existing pins. This works in schematic, layout, and symbol designs.

To edit characteristics of existing pins:

Select a pin for editing and choose Edit > Properties.... A dialog box appears. (Or,1.
double-click on the pin.)
Change any of the characteristics as desired and click Apply (or click OK to accept2.
the changes and dismiss the dialog box).
For details on pin characteristics, refer to, Adding Pins to Your Symbol (usrguide)
under the section on Working with Symbols (usrguide).

 

 Selecting and Deselecting Items

While you can always use the mouse to select and deselect items, several commands
found on the Select menu can assist you in selecting and deselecting items more quickly.
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Note
Only objects on selectable layers can be selected for editing. If the select status (Sel) of a given layer is
disabled (through the Layer Editor dialog box), the select commands have no effect on items on that
layer.

 

 Selecting/Deselecting All Items in the Drawing Area

To select all items in the drawing area:
Choose Select > Select All. Boxes are drawn around all items (that match the filter
selection) showing that they are currently selected.

To deselect all selected items that match the filter selection:
Choose Select > Deselect All or click anywhere inside the window, away from the
selected objects.

 

 Selecting/Deselecting Items by Name

The commands Select By Name and Deselect By Name ignore the selection filters.

To select items by name:

Choose Select > Select By Name. A dialog box appears. By default, a list of each1.
type of item in the design is displayed by Component Name. You can also view a list
of individual items by selecting by Instance Name. The following illustration shows
the listings of a simple network.

Select the desired list type and click the item(s) from the list that you want to select.2.
Click Apply. The specified items are selected in the design window.

To deselect items by name:

Choose Select > Deselect By Name and a dialog box appears. By default, a list of1.
each type of item selected in the design is displayed by Component Name. You can
also view a list of individual selected items by selecting by Instance Name.
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Select the desired list type and click the item(s) from the list that you want to2.
deselect. Click Apply. The specified items are deselected in the design window.

Hint
Alternatively, you can use the wildcard field to filter the list for selected items of the same type. For
example, to list all selected transmission lines in the design, type TLIN (for a listing by Component
Name) or TL* (for a listing by Component ID), and click Apply.

 

 Selecting/Deselecting With a Selection Window

You can include several objects at once for selection/deselection by enclosing them in a
selection window.

To select items using a selection window:

Position the pointer at one corner of a window that will enclose the desired items,1.
and press the left mouse button.
As you move the mouse, keeping the button depressed, a ghost image of the2.
selection window is drawn. Release the button to specify the opposite corner of the
window. All items totally enclosed within the selection window, that match the filter
selection, are now selected and are identified by taking on the Select color chosen
under Option > Preferences.

To deselect items using a selection window:

Choose Select > Deselect Area.1.
Draw a selection window enclosing the items you want to deselect. All items in the2.
selection window (that match the filter selection) are deselected.

 

 Using the Vertices Filter

By default, the Vertices filter is turned on. This means that when you use a selection
window to encompass a portion of a given shape, the shape itself is not selected, but
rather only the vertices that fall within the selection window. To modify this behavior so
that individual vertices are not selected when you click an individual vertex or use a
selection window, turn off the Vertices filter through Options > Preferences > Select.
The illustration that follows shows what happens when the Vertices filter is on, you draw a
selection window enclosing parts of shapes on two different layers, and then choose Edit
> Move > Move Using Reference.
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Hint
When the Vertices filter is turned on, all selected vertices are identified by a marker. You can change the
size of this marker with the Selected Vertex option through Options > Preferences > Select.

 

 Copying and Pasting Items

There are several Copy commands that enable you to copy and paste items in different
ways:

Cut - Enables you to delete one or more items from one window, and paste in
another window.
Copy - Enables you to copy items in a given design window and then paste those
items within the same design window or another design window. On the PC only, it
also copies the items to the Windows clipboard enabling you to paste the item(s) as a
graphic in a Windows application.

Hint
To enable pasting the item using coordinates as the reference point, choose Options >
Preferences > Entry/Edit and select the option Show Set Paste Origin Dialog for Copy command.

Paste - Enables you to paste items that you previously cut or copied

Advanced Copy/Paste

Copy Using Reference - Enables you to copy selected items, prompting for a
reference point and a destination point. The copied items can then be placed
anywhere within the same design window.
Copy Relative - Enables you to copy items a specified distance from the original
items.
Copy To Layer - Enables you to copy items from one layer to another, within the
same design window.
Step And Repeat - Enables you to create a copy in the form of an array, with the
number of rows and columns you specify.
Make Array Instance - Enables indicate that an instance should be repeated in the
form of an array, with the number of rows and columns you specify.

To copy an item and paste it on the same layer:

Select the item(s).1.
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Choose Edit > Copy (or click the Copy button on the toolbar).2.
If you enabled the aforementioned option, Show Set Paste Origin Dialog for Copy
command, a dialog box appears enabling you to specify a reference point for pasting
(The default reference point for pasting a component, or group of components, is the
first unconnected pin; when pasting shapes, the default reference point is the lower
left corner.) Specify the X and Y coordinates (These are the positional coordinates
identifying the position of the pointer in relation to the total window.) Click OK.
Choose Edit > Paste from the desired design window. As you move the pointer, a3.
ghost image of the copied item moves with it.
Click again to specify the destination point.4.

To copy items using a reference point:

Select the item(s).1.
Choose Edit > Advanced Copy/Paste > Copy Using Reference.2.
You are prompted to enter a reference point. Click the point on the item (or group of3.
items) you want to use as a reference point for positioning the copy.
You are prompted to enter the offset location. Click to place the item(s) in the4.
desired location.

To create a copy in a specific position, relative to the selected item:

Select the item you want to copy.1.
Choose Edit > Advanced Copy/Paste > Copy Relative. A dialog box appears2.
enabling you to specify the distance from the original that the copy should be placed.
The values you specify here are with respect to the units of the window, schem or lay
. For example, using the default inches of the Schematic window, if you supply 1.0
for both X and Y, the reference point of the copied item will be placed 1 inch in the
direction of X and 1 inch in the direction of Y from the reference point of the original
item.

Hint
The reference point on symbols is the first unconnected pin; the reference point on shapes is the
lower left corner.

Specify the desired units in X and Y and click Apply. A copy appears at the specified3.
location.

To copy from one layer and paste to another:

Select the item(s).1.
Choose Edit > Advanced Copy/Paste > Copy To Layer.2.
Select the desired destination layer from the dialog box that appears and click Apply.3.
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Important
Clicking Apply enables you to continue copying items from the current layer to any other layer. If
this is the only layer you want to copy the selected shape to, then click Cancel; if you click OK, you
will paste an additional copy on the last layer selected.

The Step and Repeat command enables you to select an item or items you would like
multiple copies of and then specify how many copies and how many rows and/or columns.
This command also enables you to specify the distance between the items in X and Y
coordinates.

To copy items using the Step and Repeat command:

Select the item or items you want to copy.1.
Choose Edit > Advanced Copy/Paste > Step and Repeat. A dialog box appears.2.
By default, the current snap spacing is displayed as the X and Y spacing in this dialog3.
box. You can either accept the default spacing or change these numbers by typing or
clicking the up and down arrows.
Specify the number of rows and columns by typing or by clicking the up and down4.
arrows.
To automatically connect the pins of these items with one another, select the option5.
Connect overlapping pins and change the X or Y spacing field to 0, based upon the
component and the desired configuration.
Click Apply. As you move the pointer into the drawing area, a ghost image of the6.
items moves with it. The lower left corner of the group serves as the reference point
for placement.

Hint
The Step and Repeat command is a repeating command; you can place this same configuration as
many times as you like. Or you can change the configuration each time and click Apply before
placing.

To repeat an instance in the form of an array using the Make Array Instance command
(for layout only):

Select the instance or instances you want to repeat.1.
Choose Edit > Advanced Copy/Paste > Make Array Instance. Array Instance2.
dialog box appears.

By default, the current snap spacing is displayed as the X and Y spacing in this dialog3.
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box. You can either accept the default spacing or change these numbers by typing or
clicking the up and down arrows.
Specify the number of rows and columns by typing or by clicking the up and down4.
arrows.
Click Apply.5.

An array instance does not make copies of the instance shapes. It is a special command to
tell the instance to draw repeated copies. Any change to the instance will automatically be
reflected in repeats. For purposes of connectivity and simulation, only one instance exists.
Connection pins will only be drawn on the first instance in the array (generally on the
lower left unless the instance has been rotated or negative offsets were used.

 

 Moving Items

The quickest way to move objects is with the mouse:

Position the pointer over the object(s) you want to move.1.

Hint
To move several items at once, select them using a selection window. To add additional items to (or
delete items from) a selected group, use Shift+Click.

Press the left mouse button, drag to the new location, and release. When moving2.
items using the drag method, the move must be more than the distance specified as
the Threshold for it to be recognized as a move.

This option (Options > Preferences > Entry/Edit) protects you from moving an
item unintentionally if you click to select it and accidentally move the pointer. Some
users prefer to not allow mouse drag at all. New for ADS 2011, move handles can be
enabled. These are especially useful for customers who want the added safety of
preventing mouse drag. When activated, this option gives a red diamond on the
screen whenever a single object of any type is selected.

There are several additional Move commands(Edit > Move) that enable you to move
components and shapes in specific ways:

Move Using Reference - Enables you to move selected items, prompting for a
reference point and a destination point.
Move Edge - Enables you to stretch the edge (between two vertices) of an existing
shape.

Hint
This movement can be restricted by setting the option Maintain adjacent angles for Move Edge
command.

Move Relative - Enables you to move items by specifying coordinates, relative to
0,0.
Move and Disconnect - Breaks connections as you move selected components.
Move To Layer - Enables you to move items from one layer to another.
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Move Wire Endpoint - Enables you to manipulate an unconnected end of a wire.

To move items specifying the reference and destination locations:

Select the item(s) you want to move.1.
Choose Edit > Move > Move Using Reference. You are prompted to enter a2.
reference location.
Specify a reference point by clicking the point on the item (or group of items) you3.
want to use when specifying the destination. If you are moving component symbols,
clicking a pin as a reference point will help you align and connect the items.
As you move the mouse, a ghost image of the selected objects follows. You are
prompted to enter an offset location.
Click again to place the items in the new location. Where applicable, wires are4.
redrawn maintaining connections.

Hint
The manner in which wires are redrawn is controlled by the option Reroute entire wire attached to
moved component.

To move an item a specific amount, relative to the coordinates 0,0:

Select the item you want to move.1.
Choose Edit > Move > Move Relative.2.
Specify the amount in X and the amount in Y (in inches) you want to move the3.
selected object and click Apply. The item is moved, using the default reference
point, by the specified amount.

Hint
The default reference point of an item varies depending on the nature of the item - for a component,
it is pin 1; for a shape, it is the lower left corner.

To move and disconnect:

Hint
New in ADS 2011, you can press control before using a regular Drag and Move to move and disconnect..

Select the items you want to move.1.
Choose Edit > Move > Move and Disconnect. You are prompted to enter a2.
reference location.
Specify a reference point by clicking on or near the selected items. If you are moving3.
component symbols, clicking on a pin as the reference point will help you align and
connect the items.
As you move the mouse, a ghost image of the selected items follows. You are
prompted to enter an offset location.
Click again to place the items in the new location. The connections of the items4.
moved and the items left behind, are deleted. The interconnections among the items
moved, remain intact.

To move shapes or text to another layer:

Select the object you want to move.1.
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Note
Do not use the Move To Layer command to move ports to a different layer; set the Layer parameter
of the port to the desired layer.

Choose Edit > Move > Move To Layer. A dialog box appears with a list of currently2.
defined layers. Select the desired layer and click OK. The selected object
immediately takes on the color and other display characteristics of the selected layer.

Note
The following items can be moved to another layer using the context-sensitive menu that appears
when you right-click with the pointer positioned over any of these items: Polygon, Polyline,
Rectangle, Circle, Arc, Text, Arrow, Wire, Construction Line, Path, Trace.

 

 Object Handles

Handles are the little square boxes that appear on the edges when an object is selected
around an on-screen object. These handles allow you to:

resize an object.
move or rotate an object.

Following are the three types of handles supported in this release:

Stretch Handle
Rotate Handle
Move Handle

 Stretch Handle

The Stretch Handle can be used to resize or stretch an object, i.e., change the height or
width of the object.

Note
The length parameters are updated automatically when you stretch the JBOND, SBOND, and MLIN
components.

 Rotate Handle

The Rotate handle (green circle) can be used to rotate the Object. In the following image,
the rotate handle is rectangle.
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 Move Handle

The Move handle can be used to move the object. This handle can be enabled/disable in
Entry/Edit tab of the Preferences window.

 Move Component Text

You can also move the component text using the object handle (Blue Diamond) in the
upper left of the component annotation (see image below).

 

 Rotating Items

There are several commands to assist you in rotating components and shapes. The
Advanced Rotate commands are more often used for shapes than components, but they
do operate on components. For details on basic component rotation, refer to Rotating
Components (usrguide) under the section on Creating Designs (usrguide).

Use any of the following methods to rotate components and shapes by a specified
increment:

Click the Rotate By Increment button on the toolbar.

Press Ctrl+r.
Choose Edit > Rotate.

Each of these actions rotates the component n degrees clockwise, where n is the
increment specified in Options > Preferences > Entry/Edit > Rotation Increment
(angle). The default is 90 degrees.
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The Mirror About X and Mirror About Y commands enable you to rotate objects across an
axis you specify.

 

 Advanced Rotate

Rotate Around Reference enables you to rotate components and shapes using the
mouse, specifying the reference point and the destination point.
Rotate Relative enables you to rotate components and shapes by a specific number of
degrees, relative to the 0,0 coordinates of the drawing area.
Set Rotation Angle rotates the selected item by the number of degrees specified, in
conjunction with the Rotate command. Note that setting this angle resets the
Rotation Increment (angle) in Options > Preferences > Entry/Edit.

Hint
The Rotate and Rotate Around Reference commands can both be used on either components or
shapes, but the Rotate command is typically better for working with components (the reference
point is specified by the program) whereas the Rotate Around Reference command is typically better
for working with shapes (you are prompted to specify the reference point around which to rotate).

 

 Rotating Items Around a Specified Point

To rotate a selected object around a specified point:

Select the object.1.
Choose Edit > Advanced Rotate > Rotate Around Reference. You are prompted2.
to enter a reference location.
Click once on the object at the point around which you want to rotate it. You are3.
prompted to enter the offset location. As you move the mouse, a ghost image of the
object moves with it. The pointer snaps in increments of the number of degrees
specified in the Rotation Increment (angle) field in the Preferences dialog box (
Options > Preferences > Entry/Edit).
Move the pointer until you are satisfied with the angle of rotation and click to place it.4.

 

 Rotating Items in Degrees, Relative to 0,0

To rotate a selected object by a specific number of degrees, relative to 0,0:

Select the object.1.
Choose Edit > Advanced Rotate > Rotate Relative.2.
In the dialog box that appears, enter the number of degrees by which you want the3.
object rotated.
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Hint
Positive values rotate the object in a counterclockwise direction; negative values rotate the
object clockwise.
The reference point for rotating shapes is the lower left corner.
The reference point for rotating components is the left-most pin 1.
Values entered here are rounded up or down to the nearest incremental value in accordance
with the number of degrees specified in the Rotation Increment (angle) field in the
Preferences dialog box (Options > Preferences > Entry/Edit).

 

 Rotating Objects Across a Specified X- or Y-axis

To rotate selected objects across a specified X-axis (mirror):

Select the object.1.
Choose Edit > Mirror About X. You are prompted to enter a point on the X-axis.2.
Click to specify the X-axis over which you want the object rotated. The selected3.
object is rotated.

To rotate selected objects across a specified Y-axis:

Select the object.1.
Choose Edit > Mirror About Y. You are prompted to enter a point on the Y-axis.2.
Click to specify the Y-axis over which you want the object rotated. The selected3.
object is rotated.

 

 Rotating Objects Using an Absolute Angle

You can specify an absolute angle of rotation using the Set Rotation Angle command. This
command is used in conjunction with the Rotate command.
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Note
The angle you specify here becomes the new Rotation Increment (angle) in Options > Preferences >
Entry/Edit.

To rotate an object using an absolute rotation angle:

Select the object you want to rotate.1.
Choose Edit > Advanced Rotate > Set Rotation Angle. The Set Rotation Angle2.
dialog box appears.
Specify the desired rotation angle in degrees.3.
Click Apply and click the Rotate button. The object is rotated by that amount.4.

 

 Editing Shapes

There are several ways you can edit or manipulate various shapes after you have added
them to your design:

Converting Shapes to Simple Polygons
Editing Polygons and Polylines
Adding a New Vertex
Moving a Vertex
Deleting a Vertex
Converting a Vertex to an Arc
Converting a Vertex to a Mitered Edge
Stretching a Wire or an Edge of a Shape
Scaling an Object Using a Scaling Factor
Oversizing an Object

 

 Converting shapes to Simple Polygons

All non-text, closed shapes can be converted to simple polygons allowing vertex editing.
This includes circles, paths, traces, and rectangles. For a circle, the smoothness of the
converted circle or arc is determined globally by the setting Arc/Circle Resolution in Edit >
Properties... for the selected circles.

To convert a selected circle to a polygon:
Choose Edit > Modify > Convert To Polygon.

To edit the characteristics of a selected circle:
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Choose Edit > Properties.1.
Specify a new center point, if desired.2.
Select the desired mode to change the radius:3.

Absolute Radius - Select this option to scale a circle by an absolute amount. For
example, if your circle has a radius of .75 inches and you specify a Radius of 1,
the circle is scaled such that the radius is 1 inch.
Delta Radius - Select this option to scale a circle by a relative amount. For
example, if your circle has a radius of .75 inches and you specify a Radius of 1,
the circle is scaled such that the radius is 1.75 inches.

Specify the Radius, the amount by which you want the circle scaled.4.
Specify a new number for resolution, if desired (See the illustration at the beginning5.
of this section.)

Note
This changes the resolution for the selected circle only, independent of the global setting made
through the Preferences dialog box, Options > Preferences > Entry/Edit.

Specify a different layer for the circle, if desired.6.
Click Apply (or OK if you are done editing circles).7.

To edit the characteristics of a selected arc:

Specify a new number for resolution, if desired (See the illustration at the beginning1.
of this section.)

Note
This changes the resolution for the selected arc only, independent of the global setting made
through the Preferences dialog box, Options > Preferences > Entry/Edit.

Specify a different layer for the arc, if desired.2.
Click Apply (or OK if you are done editing arcs).3.

 

 Editing Polygons and Polylines

Several commands found on the Edit > Modify menu can assist you in editing polygons
and polylines.

The Join command allows selected polylines with coincident endpoints to be joined
into a single polyline. If a closed shape results, the joined polylines are converted to
a polygon.
The Break command converts a selected polygon into a single polyline.
The Explode command converts selected polygons or polylines into two-point
polylines.

To join multiple polylines into a single polyline:

Select the individual polylines you want to join.1.
Choose Edit > Modify > Join. All coincident endpoints are joined. You can verify2.
what has been joined by clicking on the shape to select it and observing whether or
not the entire shape is selected.

To convert a polygon into a single polyline:

Select the polygon.1.
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Choose Edit > Modify > Break. The starting and ending points of the polygon are2.
broken, identified by a marker, and you can now manipulate the shape as a polyline.

To convert a polygon or polyline to individual, two-point line segments:

Select the polygon or polyline.1.
Choose Edit > Modify > Explode. All vertices are disconnected leaving you with2.
individual line segments that you can edit as needed.

 

 Adding a New Vertex

To add a new vertex to a polygon or polyline:

Choose Edit > Vertex > Add.1.
Click a point between two existing vertices, and move the pointer. A flexible line is2.
drawn between the vertices and the pointer.
Click again to specify the new vertex and the shape is redrawn.3.

 

 Moving a Vertex

To move a vertex on a polygon or polyline to change its shape:

Click to select the vertex and drag the pointer in the desired direction. A flexible line1.
is drawn from the affected vertex to the pointer.
Click again to specify the new location of the vertex and the shape is redrawn.2.
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 Deleting a Vertex

To delete a vertex on a shape you have drawn, be sure the Vertices filter is turned on (
Options > Preferences > Select) and draw a selection window enclosing all vertices
you want to delete. Click the Delete button on the toolbar and the shape is redrawn
without those vertices.

Clicking anywhere on an arc deletes the arc and connects the former endpoints of the arc
with a straight line.

 

 Converting a Vertex to an Arc

You can convert any vertex to an arc and specify the desired radius of the arc, with
respect to the units of the window.

To convert a vertex to an arc:

Choose Edit > Vertex > To Arc. You are prompted enter location of the vertex and1.
a dialog box appears.
Change the radius as desired and click Apply.2.
Click any vertex you want to convert to an arc. The vertex is redrawn accordingly.3.
You can continue converting vertices in this manner using a different radius each
time if desired, but you must click Apply each time you change the radius. When you
are through making these changes, click OK to dismiss the dialog box.
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 Converting a Vertex to a Mitered Edge

You can convert any vertex to a mitered edge and specify the desired length of the
mitered edge, with respect to the units of the window.

To convert a vertex to a mitered edge:

Choose Edit > Vertex > Miter. You are prompted enter location of the vertex and a1.
dialog box appears.
Change the miter length as desired and click Apply.2.
Click any vertex you want to convert to a mitered edge. The vertex is redrawn3.
accordingly.

You can continue converting vertices in this manner using a different miter length each
time if desired, but you must click Apply each time you change the length. When you are
through making these changes, click OK to dismiss the dialog box.

 

 Stretching a Wire or an Edge of a Shape

The Move > Move Edge command enables you to change the shape of an existing wire,
or to redefine a shape by stretching an edge (a segment between two vertices).

To stretch an edge:

Choose Edit > Move > Move Edge. You are prompted to enter the location of the1.
line.
Click the edge you want to stretch. As you move the pointer, a ghost image moves2.
with it and showing how the shape will be redrawn.
Click again to define the new shape.3.
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 Scaling an Object Using a Scaling Factor

To scale an object using a scaling factor:

Choose Edit > Scale/Oversize > Scale and the Scale dialog box appears.1.
Enter scaling factors for both X and Y.2.
Scaling factors must be positive. Scaling factors greater than 1.0 increase the size of
objects, while factors less than 1.0 decrease the size of objects. To scale the objects
uniformly, enter the same scaling factor for both X and Y.
Click OK and you are prompted to enter a reference point on the object around which3.
to scale.
Click to specify the reference point and the object is scaled.4.

 

 Oversizing an Object

Oversize and Copy & Oversize enable you to expand circles, paths, rectangles, and
polygon shapes. The Oversize command replaces the original shape with an oversized
shape. The Copy & Oversize command adds an oversize copy of the selected object to the
design while preserving the original object. Paths are oversized by changing their width.
For a precise geometrical oversize, first convert the selected shapes to polygons.

To scale the object itself, in Schem or Layout units:

Select the object.1.
Choose Edit > Scale/Oversize > Oversize and a dialog box appears.2.

This field enables you to specify an amount by which the selected object should be
oversized. A positive number increases the size of the object; a negative number
decreases the size of the object. If a negative number is used that results in an
object whose area is less than or equal to zero, then the object will be deleted.
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This field enables you to specify a cutoff angle for mitering corners (mitering only
occurs when the oversize distance value is a positive number). Any angle of a
polygon smaller than the specified cutoff angle is mitered. The default cutoff angle is
0 degrees. The valid range for this field is [0, 90].
Make any necessary changes in the dialog box, and click OK.3.

To make a scaled copy of an object, in Schem or Layout units:

Select the object.1.
Choose Edit > Scale/Oversize > Copy & Oversize and a dialog box appears.2.
Specify the desired angle and click OK.3.

 

 Editing Existing Text and Text Attributes

There are two methods of editing text you have added to your design: you can use the
on-screen editor or edit through a dialog box.

Note
To edit text attributes, you must use the dialog box method.

To edit text using the on-screen method:

Position the pointer over the text you want to edit and click. Notice the following1.
changes:

The text takes on the color currently defined for Highlight in the Preferences
dialog box (Options > Preferences > Display).
The status panel prompt changes to read, On-screen Text Editor: in progress
A vertical bar (|) representing a text insertion cursor appears in the line of text.

Use the arrow keys or the mouse to reposition the cursor, as needed, near the text2.
you want to change. Use the backspace key, as necessary, to make your changes.
When you are through, move the pointer away from the text and click once to end3.
the text editing command.

To edit text using the dialog box method:

Choose Edit > Properties. The Properties dialog box appears and click to select the1.
text you want to edit. Alternatively, you may double-click on the text or right-click
and select Properties.
The selected text and its attributes appear in the dialog box for editing. If you type2.
multiple lines as a block of text, click  to view a multi-line editor.)
Make any desired changes to the text.3.
Make any desired changes to the text attributes.4.

Layer - Enables you to select a different layer for the text.
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Font Type - Schematic only - All True Type fonts installed on your system are
available. Select the desired font from the drop-down list.

Note
On UNIX, if you want to add additional True Type fonts that were not provided with ADS, copy
them to $HPEESOF_DIR/lib/fonts.

Point - Represents the size of text in traditional units used in printing.
Location - x, y coordinate location of the text.
Justification, Horizontal - This setting represents two types of justification: one
is how individual lines of text in a block of text are aligned with one another; the
second is how an individual line of text or block of text is positioned horizontally,
relative to the reference point you specified to begin typing the text.
Justification, Vertical - This setting aligns a string or block of text vertically,
relative to the reference point you specified to begin typing the text.
Placement Angle - Enables you to rotate existing text by specifying an angle in
degrees. Positive values rotate the text counterclockwise. Negative values rotate
it clockwise.
Non-rotating (when in hierarchy) - Select this option to prevent text on a
symbol or design from being rotated when the symbol is rotated.

Click Apply. Changes to the selected text are reflected immediately in the drawing5.
area.
You can continue to select text and make changes, but you must click Apply for each
set of changes for those changes to take effect.
When you are through making changes to text, click OK to dismiss the dialog box.6.

 

 Editing Wire/Pin Label Attributes

To change the color, size, and font of existing wire labels, choose one of the following
methods:

Use Edit > Wire/Pin Label > Wire/Pin Label Attributes.
Double-click the wire label to display the dialog box.
Right-click and select Wire/Pin Label Attributes from the pop-up menu.

 

 Forcing Objects Back onto the Grid

If an object is offset from the current grid spacing, you can force it back to the nearest
grid point with the Modify > Force to Grid command. If the selected object is an item
with pins, pin 1 is forced to the nearest grid point.

To force an object back onto the grid:

Select the object.1.
Choose Edit > Modify > Force to Grid. The selected object snaps to the grid.2.
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 Comparing Designs
This section provide information only on handling the synchronized Designs. For
information on how to handle and compare the designs that are not synchronized,see ADS
Desktop LVS (lvs).

 Handling Synchronized Designs

 

 Checking Connectivity Information in Layout

In the Layout view, the Check Design command provides access to information about the
characteristics of your design. To access it, select Tools > Check Design. The Check
Designs dialog will appear and list any warnings found in the Description field. These
warnings are based on the selected items under the Check Design Options menu. The
Location field shows the x and y coordinates that refer to a specific warning message
location. Selecting either the location number or description will highlight the instance on
the layout. Checking the Auto Zoom box will zoom the layout in on the location of the
warning.

To see the details of any of the warnings listed, select the warning and click the Details
button. An information window will list exact coordinates, instances, etc.

To access the Check Design Options menu click the Options button or Tools > Check
Design Report.

Check options are explained in the following section:

Open connections displays the total number of unconnected pins and wires. For each
item with an unconnected pin, it lists the component name and ID, and the pin
number. For each wire with an open end, it displays the coordinates of the wire
segment. The affected items are highlighted in the design window (default is turned
on).
Nodal mismatches (layout vs schematic) reports components that are connected
differently in one representation than they are in the other. The report lists the name
of the component, the pin that is connected differently and what the pin is connected
to. The affected components are highlighted in the design window (default is turned
on).
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Wires in layout displays all components connected to pins that are interconnected
with a wire, or a zero-width trace (default is turned on).
Parameter value mismatches (layout vs schematic) reports items that have different
parameter values in one representation than they have in the other. The report lists
the name of the item and the parameters that have different values. The affected
items are highlighted in the design window (default is turned on).
Overlaid Components reports the IDs of any overlapping components where the
components contain the same number of pins and pin 1 of each component is placed
in the same location (default is turned on).
Shape overlaps component without overlapping a pin reports cases where a shape
overlaps a component, and the area of overlap does not contain a pin (default is
turned on).
Components overlap without any pin connection reports cases where two components
overlap but no pins are connected (default is turned on).
Connection is not pin-to-pin reports cases where two components are not touching
but are connected by a shape (including a trace). Useful when trying to confirm that
all interconnects use transmission line elements (default is turned off).

 

 Highlighting Interconnects

There are two choices for viewing the connectivity between objects on your layout:

Show Nodal Interconnect (usrguide)
Show Physical Interconnect (usrguide)

Note
Enabling or disabling the physical connectivity engine will affect the operation of interconnect
highlighting.

 Show Nodal Interconnect

Choosing Tools > Check Connectivity > Show Nodal Interconnect and clicking on a
pin, instance pin, or shape in your layout highlights all objects at the current level that are
connected to the same logical node. Nodal highlighting is used to highlight the
interconnect metal between components.
 

Note
Show Nodal Interconnect does not highlight the components.
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 Show Physical Interconnect

Choosing Tools > Check Connectivity > Show Physical Interconnect and clicking on
a pin, instance pin, or shape in your layout highlights all objects that are physically
connected to the object you selected, throughout the hierarchy. Physical highlighting is
used to highlight all metals including those that are part of components. Physical
highlighting will follow connections through vias onto another metal layer. Objects are
physically connected when shapes on the same layer or on two layers that bind touch or
overlap.
 

Note
The red metal in the inductor is highlighted because it is connected to the green metal layer by a via at its
center. Also, the highlighting extends to the dual gates of the FET at bottom right.
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 Non-Pin Connection

Any two objects with no direct pin-to-pin connection, but physically connected in a layout,
are the non-pin connections of a layout. From ADS 2011.10 release onwards, the non-pin
connections are highlighted in a different color than pin connections as displayed in the
following figure. In this example TL4 is a non-pin connection to (TL1-TL2-TL3) and is
displayed in a different color (i.e. yellow) while pin connections TL1-TL2-TL3 are displayed
in blue.

 



Schematic Capture and Layout

111

 Cross-Probing

To see the schematic representation of a specific node in your layout, choose Schematic
> Show Equivalent Node and click an pin, instance pin, or shape which are on a node
that you would like to see in the schematic. When you view the schematic, the entire
equivalent node that you selected in the layout will be highlighted.

 

 The Physical Connectivity Engine

In layout, the physical connectivity engine will put two pins or instance pins on the same
net whenever any shapes on the same design make connections between them. If the
physical connectivity engine is disabled, then only wires and traces will be considered for
making connections. Regardless of the physical connectivity engine setting, all edge and
area pin shapes will be considered for connections.

Disabling the physical connectivity engine is only meant to be used when there are specific
performance problems with large designs such as reticles. The physical connectivity
engine can be enabled or disabled for a specific design. To do so, choose the Tools > Use
Physical Connectivity Engine menu option from the Layout window.

Note
Some of the ADS layout artwork importers which do not import connectivity information will disable the
physical connectivity engine on imported designs.

The physical connectivity engine can be enabled or disabled by default for all new designs.
To change this setting:

Choose the Options > Preferences menu option from the Main window.1.
Select or deselect the Enable Physical Connectivity Engine (PCE) in new layouts2.
option in the Main Preference dialog box.

Note
Unlike earlier versions of ADS, disabling the Physical Connectivity Engine does not turn off any features. It
only affects which shapes make connections. If the engine is off, edge and area ports are still honored, but
only other instances, wires, and traces will make connections to them. Layer ordered drawing in layout will
be used even if the engine is disabled.

The following functionality will show different results in layout if the physical connectivity
engine is disabled:

Tools > Check Connectivity > Show Nodal Interconnect
Tools > Check Connectivity > Show Physical Interconnect
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Since instance pins will often no longer be on the same node, all commands which
operate on nodes (such as Schematic > Show Equivalent Node and Tools >
Check Design) will be affected.
Connections using polygons, circles, paths, rectangles, polylines, and arcs are not
recognized (only connections with wires and traces will be recognized).

 
See Design Synchronization (usrguide) for information about synchronizing the differences
between schematic and layout views.
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 Annotating Designs 
You can annotate schematic by adding a drawing sheet, inserting a variety of shapes, and
adding text (including system variables such as date, time, etc.) as described in the
sections below.

 

 Adding a Drawing Sheet

If you want to use a drawing sheet that contains any constant information or graphics,
such as a company logo, you will probably want to save it as a template enabling you to
insert it in any design where it is needed.
To create a drawing sheet:

Choose File > New > Schematic.1.
Type a name for the cell.2.
Select the Drawing Formats palette pulldown.3.
Select the appropriate drawing sheet size, for example, FORMATA.4.
Click OK and move the pointer into the drawing area.5.
Note that the lower left corner serves as the reference point. Position the image of6.
the drawing sheet as required and click to place it there.
To move the drawing sheet after placing it, you must be able to select it, and by
default, the Drawing Format filter is turned off. To turn it on, choose Options >
Preferences > Select and enable the Drawing Format option. If you do enable this
filter, you will probably want to disable it again after moving the drawing sheet,
before beginning your design work.

Hint
If you want to reposition the lower left corner of the drawing sheet at the coordinates 0,0 (to assist
in placing items using exact measurements), you can use the Set Origin command. Choose Edit >
Modify > Set Origin and click the lower left corner of the drawing sheet. Use View All if necessary
to bring the entire sheet into view.

Add all desired information.7.
Choose File > Save Design As Template to make it available for insertion in any8.
design.

 

 Adding Text

Once you have established the desired text attributes, you can add text to your design
using the Text command on the Insert menu or the Text button on the toolbar. Prior to
adding text, you may want the current entry layer (or a text layer you have created) and
place all text on that layer.

To change the current entry layer:
Choose Options > Layer Preferences and click on a layer name from the layer
preferences window.

Any text you add, or object you draw, will now be placed on the text1 layer until you
change to another entry layer. Text will take on the characteristics defined in the
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Preferences dialog box (except for color, which is defined through the Layer Editor). For
details on changing attributes of text:

Prior to adding it to the drawing area, refer to Setting Text Options (in Advance)
(custom) documentation.
After adding it to the drawing area, refer to the section, Editing Existing Text and
Text Attributes (usrguide) documentation.

To add text to your design:

Choose Insert > Text. The status panel prompt changes to read, New_Text: Enter1.
location for new text.
Position your cursor in the desired location, click once, and begin typing.2.
If necessary, use the arrow keys, the backspace and spacebar to make changes (You
can drag the mouse across text to highlight it and type over it or use the spacebar or
backspace to delete it.) To continue the text on the next line, press Enter and
continue typing.

To type text in another location, click in that location and begin typing.
To stop the text command, press Esc or move the pointer away from the new
text and click once-to signify the end of that text block-then click the End
Command button.

Hint
Context-sensitive editing is available for text. Position the pointer over the text, right click,
and select Edit Text from the pop-up menu.

 

 Using Variables to Display Design and System Information

You can add the following design information to your design:

Library Name1.
Cell Name2.
View Name3.
Last Time and Date Saved4.

For example, to add Library Name to your design:

Open the design and select Insert > Text Display > Library Name.1.

You can also select Cell Name, View Name, or Last Time and Date Saved.

Click on the design to place the information at desired place and press escape (Esc)2.
key.

To see or change the properties associated with the variable, right click on the variable name and select
Properties from the pop-up menu.

 

 Drawing Shapes

The Insert menu contains commands that enable you to draw a variety of shapes and
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lines to help annotate your schematic. Select End Command from the pop-up menu (or
click the End Command toolbar button, or press Esc) during execution of any draw
command, to terminate the command and remove the partial shape.

 

Hint

Several shapes that require you to specify multiple points (such as polygons, polylines, arcs) allow
you to specify the last point by pressing the space bar.
Editing is available for shapes using the Properties dialog which can be invoked by double-clicking
on the object, the context-sensitive menu Properties, or with Edit > Properties.

Shapes and text can change the layer on which the object is drawn with this dialog.
The thickness of the lines of the following shapes drawn in the Schematic window (schematic
view) can be modified with this dialog: polygons, polylines, rectangles, circles, arrows, and all
arcs.

You can set (in advance) the thickness of the lines of the following shapes drawn in the Schematic
window (symbol view): polygon, polyline, rectangle, circle.

 
To draw a rectangle (or square):

Choose Insert > Shape > Rectangle (or click the Rectangle button). You are1.
prompted to enter the first corner.
Click to specify the first corner. You are prompted to enter the second corner.2.
As you move the mouse, a flexible box stretches from the anchor point to the3.
position of the mouse, expanding and contracting as you move. When you are
satisfied with the size, click to finish.

 
To draw a polygon:

Choose Insert > Shape > Polygon (or click on the Polygon button). You are1.
prompted to enter a vertex.
Click to anchor the starting point of the polygon.2.
Move the cursor to the position where you want the first line segment to end, and3.
click. A line appears between the two points.

At any time during entry of a polygon, you can choose one of the Arc commands
to include an arc in your polygon.
You can use the Undo Vertex command to backtrack to the previous point
anytime you want to erase the segment or arc you have just drawn.

Hint
If you want all line segments to be drawn perfectly horizontal or vertical, choose Options >
Preferences > Entry/Edit and check 90 degree angle only.

Continue in this manner until you are ready to draw the final line segment(s)4.
completing your polygon.

To draw all but the last line segment, double-click or press the space bar while
the pointer is still positioned over the last vertex.
To draw all but the last two line segments, move the pointer so that it is
positioned over the next vertex, and double-click or press the space bar.
The polygon is automatically closed. The illustration below demonstrates the
latter method.



Schematic Capture and Layout

116

 
To draw a polyline (a series of connected line segments):

Choose Insert > Shape > Polyline (or click on the Polyline button). You are1.
prompted to enter a vertex.
Click to anchor the starting point of the polyline.2.
Move the cursor to the position where you want the first line segment to end, and3.
click. A line appears between the two points.

At any time during entry of a polyline, you can choose one of the Arc commands
to include an arc in your polyline.
You can use the Undo Vertex command to backtrack to the previous point
anytime you want to erase the segment or arc you have just drawn.

When you have drawn the final line segment, double-click or press the space bar to4.
end the Polyline command.

To draw an Arc:

Choose Insert > Shape > Arc (clockwise or counterclockwise). You are1.
prompted Enter the start point of the arc.
Move the cursor into the drawing area and click left to specify the start point of the2.
arc. You are prompted Enter the arc center.
Click to specify the center point of the arc. A flexible arc appears as you move your3.
cursor. You are prompted Enter the ending point of the arc.
Click to specify the end point. If you are through drawing arcs, click End Command.4.

You can also draw an arc by specifying the start point, end point, and circumference.

To draw an arc in this manner:

Choose Insert > Shape > Arc (start, end, circumference). You are prompted1.
Start pt of arc.
Move the pointer into the drawing area and click left to specify the start point of the2.
arc. You are prompted End pt of arc.
Click to specify the end point of the arc. You are prompted Circ point of arc. A flexible3.
arc appears as you move the pointer.
Click to specify the final size of the arc.4.
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To draw a circle:

Choose Circle from the toolbar or from the Insert menu. You are prompted to enter1.
the circle center.
Click to specify the center point.2.
Drag the mouse until the circle is the desired size and click.3.

 

To draw an arrow:

Choose Insert > Arrow. You are prompted to enter the first point. In the dialog box1.
that appears, set the following options as needed:

Hint
To restore the default values/options, click Default.

Click Apply.2.
Click to specify the first point of the arrow. You are prompted to enter the second3.
point.
Move the pointer as needed to identify the endpoint of the line segment and click.4.

To change the line thickness of an existing shape:

Select the shape.1.
Choose Edit > Properties and select Standard tab (if not selected).2.
From Line Thickness drop down list, select the desired thickness and click Apply or3.
OK.

 

 Drawing Shapes Using Specific Coordinates

Coordinate Entry enables you to draw a variety of shapes by specifying coordinates for
each vertex.

To use the coordinate entry method for drawing:
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Choose Insert > Coordinate Entry and a dialog box appears. Move the dialog box1.
so that the desired design window is visible.
Choose the required drawing or editing command.2.
In the Coordinate Entry dialog box,3.

Specify Cartesian to enter points in X, Y format or Polar to enter points in
Radius, Theta (degrees) format.
Specify Absolute to enter the absolute x,y location or Relative to enter a
coordinate which is relative to the last location inserted.
Check Use Snapping to modify the coordinates entered according to the current
snapping rules.
Specify the desired X and Y coordinates for the first point and press Enter (or
click Apply).

Continue specifying all desired points, clicking Apply for each.4.
For the final coordinate of multisegment shapes (e.g. polygon, polyline),5.

when using Absolute mode, click Apply > Apply to end the series of coordinate
entries. Clicking Apply twice enters the ending point twice signaling an end to
the shape just as a double-click does.
when using Relative mode, enter 0 for both the X and Y coordinate and click
Apply to end the series of coordinate entries.

Hint
If using the Rectangle command, specify coordinates for two corners opposite each other.
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 Simulation Templates
ADS provides several simulation templates to reduce the design creation time. You can
also create your own templates with designs created by you by using the Save Design As
Template command.

Note
User templates will be listed under user_templates. The Simulation templates described below are present
under ads_templates. Additionally, designs and templates from the smart simulation wizard are available
using this command but are not documented below.

To create a new design with an existing template:

Select File > New to open New Schematic dialog box, enter the necessary
information regarding library name, cell, and view for the design.
Select a template from the drop-down list, and click OK.

To add an existing template to an existing design:

Select Insert > Template, select a template from the list, and click OK.

To create a new design for use as a template:

Create a new design (just like any other design that you create.)1.
Select File > Save Design As Template. The design is saved to your local2.
templates directory with .tpl extension and will now appear in the list of available
templates (Insert > Template).

To modify a provided template or one you have created:

Select Insert > Template, select that template from the list, and click OK.1.
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Make the desired changes in template.2.
Select File > Save Design As Template.3.

Note
To associate an AEL macro file with a template, give it the same name as the template file, add
underscore tpl, and an .ael extension. Example: For a template filename of my_amp.tpl, name the AEL
macro file my_amp_tpl.ael. Place this file in C:\Agilent\ADS2011_XX\adsptolemy\templates (for windows
version, where XX is release number) $HOME/hpeesof/circuit/templates or
$HOME/hpeesof/adsptolemy/templates (for Unix version), along with the template file, and it will be
loaded when you insert the template in another design.

 Schematic Template categories

Following are the main template categories supported by ADS:

 3GPPFDD

3GPPFDD_BS_RX_test1.
3GPPFDD_BS_TX_test2.
3GPPFDD_RF_PAE_test3.
3GPPFDD_UE_RX_test4.
3GPPFDD_UE_TX_test5.

 Curve Tracers

BJT_curve_tracer1.
FET_curve_tracer2.
DC_BJT_T3.
DC_FET_T4.

 S-Parameter simulations

S_Params1.
S_Params_DC2.
S_ParamsLargeSignal3.
SP_BJT_T4.
SP_DiffT5.
SP_FET_T6.
SP_NWA_4PortBiasLogT7.
SP_NWA_4PortBiasT8.
SP_NWA_4PortLogT9.
SP_NWA_4PortT10.
SP_NWA_LogT11.
SP_NWA_T12.
Sparams_wNoise13.
SProbePairT14.
SProbeT15.

 Harmonic Balance (nonlinear) simulations

HB1Tone1.
HB1ToneSwptFreq2.
HB1ToneSwptPwr3.
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HB2Tone4.
HB2ToneSwptPwr5.
MixConvGainNF6.
MixTOI7.

 Transient Responses

ConvPulseRespT1.
ConvStepRespT2.
LinearPulseRespT3.
LinearStepRespT4.

 TDSCDMA

TDSCDMA_DnLnk_MultiCarrier_TX_test1.
TDSCDMA_DnLnk_RX_ACS_test2.
TDSCDMA_DnLnk_TX_test3.
TDSCDMA_UpLnk_RX_Sensitivity_test4.
TDSCDMA_UpLnk_TX_test5.

 UWB

UWB_RX_Sensitivity_test1.
UWB_RX_with_WLAN_11a_Interferer_test2.
UWB_TX_test3.

 WLAN (802.11a, 802.11b)

WLAN_802_11a_RX_ACR_test1.
WLAN_802_11a_RX_Sensitivity_test2.
WLAN_802_11a_TX_test3.
WLAN_802_11b_RX_Sensitivity_test4.
WLAN_802_11b_TX_test5.

 WMAN (802.16e)

WMAN_DL_802_16e_RF_PAE_test1.
WMAN_DL_802_16e_RX_Sensitivity_test2.
WMAN_DL_802_16e_TX_test3.
WMAN_UL_802_16e_RF_PAE_test4.
WMAN_UL_802_16e_RX_Sensitivity_test5.
WMAN_UL_802_16e_TX_test6.

 Uncategorized

EDGE_RF_PAE_test1.
RF_PAE_EVM_ACLR_test2.
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 Working with Symbols
Symbols are used to represent individual components in a schematic and subnetworks in
hierarchical designs. Symbols are stored in symbol views and must be created before they
can be used. Many commands (such as placing one schematic on another) automatically
prompts to create a symbol. You can use this ADS-generated symbol, but you might want
to draw your own symbol for any of the following reasons:

A symbol that better represents the schematic.
Replace the default symbol of a simulator component with one of your own.
Create a new simulator component (using the model builder) and need to create a
schematic symbol for it.

Schematic symbols consist of a symbol body and, optionally, pins (iokterconnect points).
If you are drawing a symbol to represent an electrical component or a subnetwork for a
hierarchical design, you must add pins to the symbol body.

The default symbols are created in a uniform manner. Custom symbols must be created in
a similar manner, that is, their overall length, from pin to pin, should be a multiple of
0.125 inch. This ensures the custom symbol will connect easily to the set of provided
symbols. In addition, pin 1 should be located at the coordinates 0,0 which, serve as the
reference point when you place the symbol in a design.

 

 Opening a Symbol View

A symbol view is stored in the same cell containing the schematic, layout, or other
component information which it represents. When you are creating a schematic or layout,
you may choose Window > Symbol to open the cell's symbol view. If no symbol views
exist, you it prompts to create one. The symbol opens in its own window and is saved,
copied, and edited independently of the schematic and layout views.

Refer to the following sections for details:

Generating a Symbol
Using One of the Supplied Symbols
Drawing a Custom Symbol

 

 Creating a Symbol View from the Main Window

To create a symbol View:

Choose File > New > Symbol....
Or, right-click on an existing cell in the Folder or Library Views and select New
Symbol.
Or, click the New Symbol icon on the toolbar.
 

 Generating a Symbol
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You can generate a symbol for your completed schematic or layout by providing minimal
specifications.

To generate a symbol:

From the completed schematic, choose Window > Symbol....1.
Select the Auto-Generate tab and specify the desired symbol characteristics (or2.
accept the defaults). The symbol characteristics are defined as follows:
Symbol Type Description

Dual Restricts pins to two sides of symbol body

Quad Allows pins on all four sides of symbol body

Order Pins by Description

Location Numbers pins in the same relative order as the ports on the schematic

Number Numbers pins sequentially in a left-right, top-down order

Replace existing symbol - Replaces the current symbol, if one exists, with the one
you are about to generate.
Lead Length - The length of any line drawn between the symbol body and a pin.
Distance Between Pins - Distance between pins drawn on the same side of the
symbol body.
Click OK. A symbol is drawn consisting of a symbol body, connecting lines, and pins.3.

Hint
To regenerate the symbol specifying different symbol characteristics, choose Insert > Generate Symbol
from the symbol view.

You can edit the generated symbol as desired at any time.
For details on drawing and editing shapes, refer to:

Drawing Shapes (usrguide)
Editing Shapes (usrguide)

For details on symbol-specific editing, see Establishing Pin Characteristics.

 

 Using One of the Supplied Symbols

You can use any of the symbols we supply and modify them or use them as is.

To associate a supplied symbol with your network:

After completing the schematic design, choose File > New > Symbol.1.
In the dialog box that appears, select the Copy/Modify tab.2.
Select the desired symbol category from the Symbol Category drop-down list and the3.
icons for that category are displayed. These categories represent the basic
component libraries, but note that not all individual components will be displayed; if
multiple components share the same symbol, only one of those components is
displayed.
Click the desired symbol icon and its name is displayed in the Symbol name field.4.
Alternatively, you can type a name directly in the Symbol name field:

Type an actual component name whose symbol you want to use
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Type the name of a design file containing a symbol (or select it using the
browser)

Click Apply to view the symbol in the design window and click OK when you are5.
satisfied with your symbol selection. The program compares the number of pins on
the symbol with the number of ports in the schematic view and reports any
discrepancies.

You can edit the supplied symbol as desired at any time.

For details on drawing and editing shapes, refer to:

Drawing Shapes (usrguide) under the section on Annotating Designs (usrguide)
Editing Shapes (usrguide) under the section on Editing Designs (usrguide)

 

 Drawing a Custom Symbol

When you draw a custom symbol, you can draw it in a file containing a schematic, where
it will be dedicated to that schematic, or you can draw it in an empty file and use it to
represent any schematic.

 

 Drawing Setup

Before you begin, you may find it helpful to review a number of the program's defaults,
and you may need to make few changes.

 

 Setting Snap and Grid Spacing

By displaying a grid and drawing with snap enabled, you can quickly draw objects with
great accuracy. To view or change these settings, use Options > Preferences >
Grid/Snap. Snap mode offers options for snapping to many different types of objects.
When drawing a custom symbol, the most important option will probably be Grid, however
if you are drawing complex shapes, several other options may be helpful.

The display grid can be made visible or invisible. When you turn on the grid display, you
should specify a sufficiently large factor of the snap spacing so that a grid is displayed
even when the snap spacing is very fine. For example, the default snap spacing (in the
Schematic window) is 0.125 which means the cursor snaps every 1/8 inch. The default
display factor is 2 which means that the dots appear every 1/4 inch (0.125 × 2).

Before you begin drawing, check to see if the current grid spacing is set to something
other than the default of 0.125 inch; and if it is, change it back to the default and make
sure Enable Snap is turned on. This step ensures that your custom symbol will easily
connect to the set of provided symbols.
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Hint
Once you have drawn the symbol body and pins, you can change these settings if desired. For example,
you might want to turn snap off before adding text to your design to give you more flexibility in the
positioning of the text.

 

 Specifying the Drawing Layer

All shapes and text are entered on a combination of a layer and a purpose. The color and
visibility of any shape is controlled by the layer/purpose on which it is drawn. Before you
begin drawing any part of the symbol, change the current entry layer/purpose in
accordance with the part you are about to draw.

For example, if you are creating a custom symbol, you should draw the symbol body, pins,
and lead lines on the ads_device:drawing layer so that it will be on the same layer as the
provided symbols, and subject to changes you make to that layer.

To change layers:

Choose Options > Layer Preferences and a window appears listing all the currently1.
defined layer/purposes.
Select a layer/purpose that is appropriate for the task at hand.2.
The name of the layer/purpose is displayed in the Current Entry Layer at the top of3.
the Layer Preferences window.

ADS schematics and symbols are normally drawn on layers reserved for this. They have
layer numbers in the range of 200 to 255. There are also purposes with numbers between
200 and 255 for use with schematics and symbols. The specific layers/purposes used for
drawing schematics were chosen for compatibility with other OpenAccess tools so that
schematics could be interchanged between the tools.

The table below lists the schematic/symbol layer/purposes and the types of items placed
on those layers (by default).

 

 Layer Names, Numbers, and Descriptions



Schematic Capture and Layout

126

Layer/Purpose Description

ads_device:default Objects drawn on an undefined layer are plotted on this layer.

ads_text:drawing text

ads_device:drawing Schematic symbol body outline

ads_device:ads_drawing4 Portion of schematic symbol contained within symbol body

ads_wire:drawing Wires

ads_device:ads_drawing1 User-created schematic symbol body and text

ads_device:ads_drawing3 User-created schematic symbol

ads_device:ads_annotate Component or item names

ads_annotate:ads_drawing7 Unique ID of components or items

ads_annotate:drawing Parameters of components or items

ads_annotate:ads_drawing2 Pin numbers and names for symbols †

ads_annotate:ads_drawing3 Any additional descriptive information you want to add

ads_y9:ads_drawing1 Signal Processing integer data ††

ads_y9:ads_drawing2 Signal Processing fixed point data ††

ads_y9:ads_drawing3 Signal Processing floating point data ††

ads_y9:ads_drawing4 Signal Processing complex data ††

ads_y9:ads_drawing5 Signal Processing timed data ††

ads_y9:ads_drawing6 Signal Processing any data type ††

ads_y9:ads_drawing7 Signal Processing user-defined data ††

ads_annotate:ads_drawing4 Text contained within schematic symbol body

ads_device:ads_drawing5 Schematic symbol body with fill pattern

ads_device:ads_drawing6 The slash that identifies pin 1

ads_device:ads_drawing7 Signal Processing

† The pin_num layer is visible by default, but you must turn on Pin Numbers and/or Pin Names in the Visibility
(on/off) section of the Pin/Tee tab of the Preferences dialog box to make pin numbers and names appear.††

For details, refer to the information on Data Types, under the section on Data Types, Controllers, Sinks, and
Components in the ADS Ptolemy Simulation documentation.

 

 Drawing the Symbol Body

The commands you need to draw your symbol can be found on the Insert menu. In
addition, many of them are available on the default toolbar. For details on using these
commands, refer to Drawing Shapes (usrguide) under the section on Annotating Designs
(usrguide).

Note
The Technology Editor Layer Definitions dialog box enables you to determine the color and fill pattern,
shape display, and line style for objects drawn on custom layers added to your library.

 

 Adding Pins to Your Symbol
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There are two kinds of pins:

Pin - A pin that represents a port of a network, that is needed to connect that
network as a subnetwork in another design.
Power Pin - A pin that also represents a port of a network, but does not appear in the
schematic. The connection created via a power pin is an implied connection.

 

 Pins

Remember that pins should be located at 0.125-inch intervals so that your custom symbol
will connect easily to the set of provided symbols. In addition, pin 1 should be placed at
the coordinates 0,0. Choose any of the methods shown below to accomplish this.

To specify 0,0 in the process of drawing pin 1:

Choose Insert > Coordinate Entry and a dialog box appears.1.
Choose Insert > Pin2.
Enter the coordinates 0,0 in the Coordinate Entry dialog box and click Apply. Pin 1 is3.
placed at 0,0. You can now use the View All command to reposition the image in your
design window.

To move 0,0 to the center of the window before you begin:

Choose Pan from the View menu or the pop-up menu.1.
Click the small cross identifying the 0,0 coordinates (lower left corner of the drawing2.
area). The 0,0 coordinates move to the center of your design window.
Choose Insert > Pin. Define the pin characteristics as described in the section on3.
Establishing Pin Characteristics.

To move pin 1 to 0,0 after you have placed it:

Choose Insert > Pin and a dialog box appears. Define the pin characteristics as1.
described in the section on Establishing Pin Characteristics, and click Apply.
Choose Edit > Modify > Set Origin.2.
Click the pin. The pin moves to 0,0. You can now use the View All command to3.
reposition the image in your design window.

 

 Power Pins

Power pins, also called inherited pins, are added in symbol view, but do not appear in the
schematic. They create an implied connection. This connection is inherited from
subnetworks throughout the hierarchy.

Note
There is no support for power pins in the IFF translator in the current release.

To add a power pin to your symbol:

Delete the pin you want to replace with a power pin.1.
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Choose Insert > Power Pin.2.

Note
The numbering sequence for all pins of a given design must follow this rule: the pin numbering
sequence comes first, and the power pin numbering sequence follows.

In the Power Pin dialog box, set the pin characteristics as needed (refer to3.
Establishing Pin Characteristics), including renumbering, where applicable, and click
OK.

Position the pointer in the drawing area and click to position the power pin.4.
Define additional power pins for this design as needed, and click Cancel to close the5.
dialog box.

To override the default value of a power pin for a given instance:

Select the instance and choose Edit > Properties.1.
If the instance has more than one property, select the desired property. All power2.
properties are inherited from instances throughout the hierarchy. All properties of
this type will be identified as inherited.
Enter the desired Value (the name of the node or pin to which the invisible power pin3.
should be connected).
Retain the default Value Type setting of String and click OK.4.

 

 Establishing Pin Characteristics

The pin characteristics are defined as follows:

Name - Optional. The pin name is not displayed on your schematic unless you select
the Pin Names option in Options > Preferences > Pin/Tee.
Number - Optional. A default pin number is displayed. This number is automatically
incremented as each pin is added. To display pin numbers on the schematic, select
Pin Numbers in Options > Preferences > Pin/Tee.
Type

Input - Identifies the pin as an input port
Output - Identifies the pin as an output port
Input/Output - Identifies the pin as an input or output port

Power (<property>:<value>) - Power pins only. Enter a property or name (a unique
identifier) and a default value, such as the name of a global node contained in the
hierarchy, separated by a colon.

To edit existing pin characteristics:

From symbol view (View > Create/Edit Schematic Symbol), choose Edit >1.
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Properties... or for power pins, Edit > Power Pin.
Click the pin of interest.2.
Change the settings as desired and click OK.3.

Note
When you create a symbol for use with any design, it is only available in the workspace directory in
which you create it, unless you modify certain configuration files (and for model builder usage,
modify AEL files according to stated guidelines).

 

 

 Copying a Symbol from a Different Cell

Symbol views are stored in cells. To reuse a symbol from a different cell, you must make
a copy of it. Open the symbol that you want to copy, then select File > Save As... and
choose the cell into which you want to save the copy of the symbol.

 

 

 Modifying Search Paths

Search paths that control the order of directories searched are defined by certain program
variables. These variables should be modified in a local copy of the de_sim.cfg file. This
file is written to the /config directory during installation and should not be modified there.
But you can open this file and copy the default variable definition (where applicable), then
paste it in your own local copy and modify it (This simplifies typing a lengthy search path.)

The program creates a de_sim.cfg file automatically in $HOME/hpeesof/config. Settings
modified here apply to all workspaces.

To modify the variable search path:

Using any text editor, open the de_sim.cfg file in $HPEESOF_DIR/config.1.
Locate the variable definition, copy it, and close the file.2.
Open the de_sim.cfg file in your $HOME/hpeesof/config directory and paste the3.
variable definition.
Edit the variable definition as needed.4.
Save the file.5.
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 Creating a Layout
Whether you create a layout directly as a layout, generate it from an existing schematic,
or create it simultaneously as you create a schematic, there are only three basic steps to
the process:

Set up the layout environment. Customize the environment for the design you wish
to create, as described in Defining Layers (custom).
Create the layout, as described here in Creating a Layout (usrguide).
Edit and complete the layout, as described in Layout Basics (usrguide) under
Program Basics (usrguide).

Although you can perform a wide variety of editing operations on your design as you
create it or once the design is complete, you can set numerous options before you begin
your design work to minimize the need for editing. These options can be set through the
Preferences dialog box (Options > Preferences) from a design window. For more
information, refer to Setting Design Environment Preferences (custom) in the
Customization and Configuration (custom) documentation.
 

 The Layout Environment

The following settings are especially important when you will be drawing shapes in the
Layout window, but you should familiarize yourself with these setup features even if you
will be generating your layout from a schematic.

Set snap and grid spacing (for more detail, see Customization and Configuration
(custom)). By making the grid visible, then drawing in snap mode, you can draw
shapes with exact size and spacing. Keep in mind that, while it does not always cause
performance problems, the intersection snap mode is the slowest of all snap modes
so you should use this mode only when necessary.
Set up your layer definitions (for more detail, see Customization and Configuration
(custom)).
Specify the drawing layer (for more detail, see Customization and Configuration
(custom)). All shapes are entered on layers. The color and visibility of any shape is
controlled by the layer on which it is drawn. Before you begin drawing, specify the
current entry layer according to the intended purpose.

  

 Using the Layout Ruler

You can place a ruler on a layout and use it to size objects you draw. Use the following
steps to place and configure a ruler on a layout.

Choose Insert > Ruler in a Layout window.1.
Click within the layout to mark the start and end points for placing the ruler. Press2.
Esc to exit from the ruler placement mode.
Double-click the placed ruler or choose Edit > Component > Edit Component3.
Parameters to display the Ruler dialog box where you can edit the parameters to
customize the ruler you have placed.
Edit the parameter settings.4.
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Select the parameter that you want to change from the Select Parameter list. You
can either enter a value for it directly or you can click the Equation Editor button to
display the Equation Editor dialog box where you can choose from a list of variable to
define an expression to calculate the value. The parameters are:
LineLength - Length of the ruler
MajorTick - Length of the major tick on the ruler
MinorTick - Length of the minor tick on the ruler
MajorUnits - Units used for the major ticks on the ruler
MinorUnits - Units used for the minor ticks on the ruler
Layer - Layer on which the ruler is placed
TextHeight - The text height used to display units on the ruler
Units - Default unit of measure used by the ruler. You can override this default by
specifying a different unit for an individual parameter
TextPrecision - Precision used to display length text on the ruler
TextPOrientation - Orientation used to display length text. The choices are horizontal,
vertical-left, and vertical-right.
TextOrder - Order (ascending or descending) used to display length text
Click OK to save the change and close the dialog box.5.

 

 Creating a Layout Manually

When you create a layout directly, you place components or shapes in the Layout window.
You can select components from either the palette or the library list. You can draw shapes
with the cursor or by designating coordinates.

To Insert a Shape or Polyline:

Select an icon (or Insert command).1.
Follow the instructions in the lower, left corner of the window.2.

To Insert a Component from the Palette or Library List:

Select the desired component.1.
Drag to the desired location in the Layout window.2.
Click to place the component in the desired location.3.

 

 Using Coordinate Entry

Every command that requires clicking somewhere in the window is a potential application
for Coordinate Entry. Entering coordinates this way, in effect, takes the place of clicking in
a schematic or layout. You can use Coordinate Entry when:

placing components or text in schematic or layout.
copying or moving using a reference point.
drawing lines, shapes, paths and traces.

 Inserting Components
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You can insert components using any of the following methods:

A component palette.
The component library.
Typing a component name in the Component History field (then press Enter).
Creating a hot key for it.

 

 Using Construction Lines

Construction lines can help you align parts, shapes, and text. The lines are infinitely long,
so you can place components in one area, scroll the view of the window, and know that
you are lining up objects correctly.

To add a construction line:

Choose Insert > Construction Line.1.
Click any two points along the line you want drawn.2.

 

 Placing Components at Specific Coordinates

Use the following steps to place a component at specific coordinates:

Select a component.1.
Choose the menu command Insert > Coordinate Entry.2.

In the Coordinate Entry dialog box, enter a value for X and a value for Y.3.
Coordinate entry will modify the coordinates entered according to the current
snapping rules if the Use Snapping checkbox is activated.
Click Apply. The component is placed in the Layout window, with pin 1 at the4.
specified coordinates.

 

 Identifying Unconnected and Connected Pins

When you place a component in the Layout window, note that each pin is outlined, and
that when you connect two pins, the outline disappears. As described in the Customization
and Configuration (custom) documentation, you can modify the highlight color of pins as
well as the color of connections.
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 Adding Bondwires

Adding a JEDEC Bondwire
Adding Shape Bondwire

 Adding a JEDEC Bondwire

The JEDEC Bondwire feature enables you to draw parameterized JEDEC style bondwires in
Layout window.

To add a parameterized JEDEC bondwire to your design:

In the ADS Layout window, choose Insert > JEDEC Bondwire. This enables the1.
JEDEC bondwire feature.
Draw the bondwire on your design.2.
To edit JEDEC parameters, such as height and angles, double-click the bondwire. This3.
opens the JEDEC Bondwire Model properties dialog.

After specifying the required parameters, click OK.4.

Click the 3D EM Preview icon  in the EM toolbar to view the 3D image.5.
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 Adding Shape Bondwire

The Shape Bondwire feature provides a 3-dimensional bondwire model,for use in EM
simulations. The Shape Bondwire feature enables you to draw parameterized bondwires in
Layout window.

 Input Parameters of the Model

In a layout, the Shape Bondwire is shown as a straight line joining pin1 and pin2. Initially,
the Shape Bondwire is modeled by up to seven straight segments: up to 6 are specified by
default when the Shape bondwire is inserted, with parameter pairs L1, Z1 through L6, Z6;
the last segment connects the last specified segment to pin2 of the bondwire.

You need to specify the following input parameters for inserting Shape Bondwire:

Radius of the wire (meters)
Conductivity of the wire (siemens/meter)
Mesh interior of the wire? (yes or no)
Layers for pin1, pin2, and the body of the bondwire (substrate layer name)
Total length refers to the projected distances in the XY plane
Number of Li, Zi pairs (line segments) specified (1-6)
Li, Zi for i=1 to 6 (Li refers to the projected distances in the XY plane)
Wire angle

Adding a Shape Bondwire

To add a parameterized Shape Bondwire to your design:

In the ADS Layout window, click Insert > Add Shape Bondwire. This enables the1.
Shape Bondwire feature.
Draw the bondwire on your design.2.
To edit Shape Bondwire parameters, such as lengths and distances, double-click the3.
bondwire. This opens the Shape Bondwire Model properties dialog.
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After specifying the required parameters, click OK.4.

Click the 3D EM Preview icon  in the EM toolbar to view 3D image.5.

 

 Drawing Shapes

In the Layout window, you can use the following geometric forms when creating layout
shapes:
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Polygons
Polylines
Rectangles
Circles
Text
Paths
Dimension Lines
Arcs

Shapes can be stretched and merged, and you can move or delete their vertex points. The
Insert menu contains commands that enable you to draw a variety of shapes and lines.
Many of the Insert menu commands are also found as icons on the toolbar.

Note
Selecting the cursor on the toolbar during execution of any Insert command terminates the command and
removes the incomplete shape.

To draw a shape:

Either click the shape icon on the toolbar, or choose Insert > <desired_shape>.1.
Follow the tips shown in the status panel.2.
Click to place the shape.3.

Drawing a Polygon: Enter line segments, and double-click to automatically create the
closing segment.

Including an Arc in a Polygon - Any time during the creation of the polygon, choose
Insert > Arc (<desired direction>).
Erasing a Newly Drawn Segment or Arc - To backtrack to the previous point choose
Insert > Undo Vertex.

Drawing a Polyline: Enter line segments, and double-click to end the final segment.

Including an Arc in a Polyline - Any time during the creation of a polyline, choose
either Insert > Arc (<desired direction>).
Erasing a Newly Drawn Segment or Arc - To backtrack to the previous point, choose
Insert > Undo Vertex.

Drawing a Rectangle: Enter two corners.

Drawing a Circle: Enter the center point, then a point on the perimeter.

Drawing a Dimension Line: Enter the end points.

Drawing an Arc: Enter the point where the arc begins, the center of the arc, and the point
where the arc ends. You can draw an arc clockwise or counter-clockwise.
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Note
Only closed shapes (polygons, circles, rectangles) can be displayed filled; shapes created with polylines
(such as arcs) cannot.

 

 Undoing a Vertex

To remove the last arc or vertex entered while creating a polygon, polyline, wire, trace, or
path, choose the menu command Insert > Undo Vertex.

 

 Drawing Shapes by Entering Coordinates

Just as you can place a component by specifying coordinates (see Placing Components at
Specific Coordinates), you can draw a shape by specifying the coordinates required for
that shape.

Select the desired drawing command.1.
Choose the menu command Insert > Coordinate Entry.2.
In the Coordinate Entry dialog box,3.

Specify Cartesian to enter points in X, Y format or Polar to enter points in
Radius, Theta (degrees) format.
Specify Absolute to enter the absolute X, Y location or Relative to enter a
coordinate which is relative to the last location inserted.
Check Use Snapping to modify the coordinates entered according to the current
snapping rules.
Specify the desired X and Y coordinates for the first point and press Enter (or
click Apply).

Continue specifying all desired points, clicking Apply for each.4.
For the final coordinate of multisegment shapes (e.g. polygon, polyline, path),5.

when using Absolute mode, click Apply > Apply to end the series of coordinate
entries. Clicking Apply twice enters the ending point twice signaling an end to
the shape just as a double-click does.
when using Relative mode, enter 0 for both the X and Y coordinate and click
Apply to end the series of coordinate entries.
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Hint
If using the Rectangle command, specify coordinates for two corners opposite each other.

  

 Adding Pins and Grounds

Use the following steps to add a pin or ground to a layout.

Click the pin or ground symbol on the toolbar (or choose Insert > Pin or Insert >1.
Ground).
Select the appropriate rotation by clicking the toolbar button (Rotate By -90) as2.
needed.
Move the pointer into the drawing area, position the symbol as needed, and click to3.
place it there.

Use one of the following methods to edit the size of the pins and grounds in your layout.

Set the value in the Placement tab in the Preferences dialog box (Options >
Preferences).
Use the Pin/Ground Size dialog box (Edit > Components Pin/Ground Size).

Both methods have the same effect. Any changes you make to the size are applied to all
pins and grounds. Use this method to experiment with and arrive at an optimal size for
the items in your layout.

The size you specify is will use the units of the library (technology) containing the layout.

 

 Designating Edge and Area Ports

An edge port is created by placing a polyline or arc into your layout and then designating
that this shape is associated with a specific terminal. An area port is created by placing a
polygon, circle, rectangle, or path into your layout and then designating that this shape is
associated with a specific pin. You can have multiple shapes associated with one pin and
they may be on multiple layers. For additional information, see Edge and Area Ports
(usrguide) and Using Edge and Area Ports (usrguide)).

 

 Working with Traces
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Traces are wires with width and a bend type, and are used to represent physical
transmission lines. Like wires, they can be used to connect components. For simulation
purposes, there is no difference between a trace connection and a wire connection. Traces
are normally simulated as simple connections (shorts). However they can be converted to
or simulated as transmission lines, to allow for more accurate simulation. You can:

Explicitly convert them to transmission lines (Edit > Path/Trace/Wire > Convert
Traces). In this case, the selected traces are actually removed and replaced by an
equivalent transmission line component in the layout itself. For details, refer to
Explicitly Converting Traces to Transmission Lines.
Simulate them as transmission lines without actually converting them. In this case,
the traces are not replaced, but an underlying subnetwork is created for each one,
and that subnetwork contains the equivalent transmission line. The subnetwork
creation occurs during the Design Synchronization process (Generate/Update). For
details, refer to Simulating Traces as Transmission Lines.

 

 Trace Routing

Once components are placed, they can be interconnected. Parts can be connected either
by abutting their pins or by drawing a wire or trace between them. If pins are abutted,
moving the parts does not disconnect the pins. Instead, a wire is drawn between them.
Wires and traces are stored in the same way in the program. Wires are traces with a zero
width. Thus, wires can be converted to traces and back again by changing their width (
Edit > Properties).

Traces can be entered on any layer; though by default, traces that you want to simulate
should be placed on specific layers. For traces that will be simulated as microstrip or
stripline, the trace should be entered on layer 1 (cond); for traces that will be simulated
as PCB transmission line components, you should use layers 16-25 (pcb1-9). To change
the current entry layer before inserting a trace, choose Insert > Change Entry Layer To
and select the appropriate layer.

An individual trace can only exist on a single layer, though the trace insertion command
enables you to insert multiple traces on different layers with vias to connect the traces.
For more information see Multilayer Trace Routing.

You can extend a path by clicking Edit > Vertex > Add, or create another path abutting
exactly to the end of the existing path and clicking Edit > Modify > Join to create a
single path. The path can then be converted back to a trace if both ends of the path are
exactly abutting to connecting pins. You can use the Snap to Pin mode in the Grid dialog
box to make sure the end points are exactly coincident with the pins.

When moving parts connected with traces, the traces will be re-routed. By default, in
layout, traces and wires will be re-routed from their end-points to maintain connectivity.
You can have the whole connection re-routed using the Re-route entire trace attached to
moved component preference in the Entry/Edit tab of the Preferences dialog box (Options
> Preferences). Traces and wires are re-routed to remain orthogonal with the fewest
corner jogs introduced. To check for overlapping components, use the option by that
name under Tools > Check Design.
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 Inserting Traces

Traces have the same restriction as wires do in schematic: they cannot form a short
(connect back on themselves). Also, each trace has a uniform width and corner type
(curved, mitered, square). To introduce a step, taper, or gap you must add a step, taper,
or gap component, and connect the trace to it. Some limitations of using traces can be
overcome by converting traces to paths. For more information, refer to Working with
Paths.

Note
If a trace contains a bend, the shortest segment that is part of that vertex cannot be shorter than 3 × w
/4, where w is the width of the trace.

To insert a trace:

Choose Insert > Trace.1.
In the dialog box that appears, set the trace characteristics as desired.2.

Corner Type - Select from Mitered, Square, Curve

Width - The desired width for the trace
Mitered Corner Cutoff Ratio (%) - The desired cutoff ratio for the corner type
Mitered
Curve Radius - The desired curve radius for the corner type Curve

Click Apply to insert a trace using the current settings.3.
Move the pointer into the Layout window and click to specify the first endpoint of the4.
trace.
Move the pointer to the desired endpoint (or vertex) for this segment. Notice that the5.
Trace dialog box Line Length region is dynamically updated as you move the pointer
so that you can easily make the trace the exact length you want it.

Click to specify the endpoint (or vertex) for this segment.
You can modify the trace settings including the width, corner type, layer, miter width6.
or curve radius at any point. The changes will apply from the last vertex that you
have placed. Any changes to the trace settings will terminate the trace up to the last
vertex with the old trace settings and a new trace with the new trace settings will
start at the last vertex.

Hint
Make changes to trace settings on straight trace segments if possible so that trace corners are
properly shaped.

Continue in this manner until the trace is complete, and signify the final endpoint by7.
double-clicking or pressing the Spacebar.

 Multilayer Trace Routing
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Sometimes traces need to run across different layers to avoid other components or
connect to interconnects on different layers. Routing a trace with parts of the trace on
different layers is called multilayer trace routing or trace stitching. When changing the
trace layer from one layer to another during multilayer trace routing, a via can be
automatically inserted to maintain the connectivity of traces if a via configuration file has
been created. For more information on defining vias, refer to Trace Route Via
Configuration.

Note that there are multiple ways to change the drawing layer of the current trace
segment during multilayer trace routing. Select the new entry layer from one of the
following locations:

Hotkeys:
Pressing the comma (",") key during trace insertion will change the entry layer
to the next lower layer in the routing layer stack.
Pressing the period (".") key during trace insertion will change the entry layer to
the next higher routing layer.

Context menu:
In the layout window, right-click the mouse inside the layout window while trace
insertion is active, and select a layer from the sub-menu "Routing Layer >".
A routing layer is a layer where a via connection has been defined. If no vias
have been defined then the "Routing Layer >" sub-menu will be empty.
For more information on defining vias, refer to Trace Route Via Configuration.

Pull-down menus:
Use the Entry Layer pull-down menu from the toolbar.
Use the Entry Layer pull-down menu in the Trace Insertion dialog box.

Layers dialogs:
Use the Entry Layers dialog. This can be invoked from Insert > Entry Layer...
Use the Layer Editor dialog. This can be invoked from Options > Layers...

When changing the entry layer from one of the locations above during trace insertion, the
following happens automatically:

The trace route using the previous entry layer is terminated at the last vertex
entered.
A via is inserted at the last vertex to connect the previous entry layer and the new
entry layer, assuming that a via has been defined in a via configuration file to
connect the two layers.
A new trace is started from the last vertex on the new entry layer.

If multiple vias are defined to connect the previous and current trace entry layer, then you
can select the appropriate via or vias. This is done either by pressing the "v" key (use
Shift + "v" to reverse the cycle), or by right-clicking the mouse in the layout window and
selecting the via or via combination from the "Change Via >" sub-menu. For more
information on defining vias, refer to Trace Route Via Configuration.

It is important to note that traces are only allowed to exist on a single layer. A trace route
that uses multilayer trace routing will contain a trace for each section of the trace route on
a continuous single layer. Therefore multilayer trace routing will result in multiple traces
inserted in the design. Editing operations on the traces will not apply to the entire trace
route – only to the selected trace(s).
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 Trace Route Via Configuration

To simplify the multilayer trace routing process, vias can be defined to connect different
layers of the trace interconnect. The Via Configuration dialog can be accessed by choosing
Options > Via Configuration.

A via definition includes the following information: the name of the via component, an
indication of whether or not the via is stackable, the layers that the via connects together,
and the associated trace width for the automatic via selection. The via name is an ADS
component name for a component that contains fixed artwork. The via component can be
a design in the current workspace or a component in design kits. Macro based vias and
vias with offset pins are not supported with the current release of ADS.

The layers defined for the via are the metallization layers to which the via will connect.
Typically only the metal layers will be defined for the via. Note that the layers defined for
vias are by definition called routing layers, which make the layers available from hotkeys
during trace insertion. Note also that a via must connect at least two layers, and may
connect more.

In cases where a via is needed to span multiple layers, vias may be stacked. On vias
where stacking is allowed, two or more vias can be stacked to connect the two layers. For
two vias to stack, each must contain the same connecting layer, with the connecting layer
as the top-most layer in one via, and the bottom-most layer in the other via. Vias will not
stack if the connecting layer is an intermediate layer in one of the vias.

The associated trace maximum and minimum width can be specified for automatic via
selection where multiple vias exist for the same layer stack-up. This allows an appropriate
default via selection when changing routing layers based on the given trace width.

If the associated trace maximum and minimum width are not specified, the order of the
vias in the Via Configuration dialog determines the order that vias will be presented when
inserting the trace route. To re-order the vias in the list, select a via and use the arrow
buttons on the left side of the dialog to move the via up or down the list.
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The settings should be stored in a via configuration file for future use. To save the via
configuration, click the Save button and save the file in one of the following directories:

The workspace directory
$HOME/hpeesof/de/defaults/
<Design Kit>/de/defaults/

The via configuration files can be stored in and/or loaded from other directories, though
only via configuration files in the directories listed will be available during trace insertion.

The current via configuration is saved for each workspace and can be set through the
Trace Insertion dialog during trace insertion.

 

 Explicitly Converting Traces to Transmission Lines

You can explicitly convert traces to transmission lines for more accurate simulation
results.

Important
When you explicitly convert a trace to a transmission line, it is a one-way conversion; you cannot change
a transmission line back into a trace.

To explicitly convert traces to transmission lines:

Select the traces you want to convert.1.

Hint
To select all transmission lines on a given layer, make that layer the current entry layer and choose
Select > Select All On Layer.

Choose Edit > Path/Trace/Wire > Convert Traces.2.
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In the Trace Control dialog box, select the type to convert trace to:3.
Transmission line elements
Single transmission line element - With this choice, you must also provide the
name for that element. A default is provided, based on the selected Element
Set.
Nodal connection (short)

Select the desired Element Set.4.
Provide the appropriate Substrate Reference. The asterisk (*) indicates the default5.
Instance Name of the first instance of this type placed in your design.
Click OK.6.

The following illustration shows traces converted to microstrip with square corners. The
parameters for each element are derived from the physical dimensions of the trace
segments.

 

 Simulating Traces as Transmission Lines

This method enables you to include transmission line effects in simulation without
cluttering your schematic or layout with numerous transmission line components.

During the design synchronization process, a subnetwork is created for each trace. This
subnetwork is a transmission line equivalent based on the selected Element Set in the
Trace Control dialog box (accessed through the Generate/Update dialog box, available
from the Schematic and Layout menus). When simulating, the transmission line
subnetworks are passed to the simulator for analysis.

Once you run through the design synchronization process, you will find you can use the
View > Push Into Hierarchy command to view (in either the Schematic or Layout
window) the actual transmission line equivalent generated by the design synchronization
process. If you are working from the layout and you modify the traces, you must run the
design synchronization process again for the subnetworks to be updated. Tee components
are automatically created and accounted for.

The following illustration shows the MLIN subnetwork that is created during the design
synchronization process, from a single trace and two pins (pins are required).
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For details on the design synchronization process, refer to Design Synchronization
(usrguide).

 

 Inserting Meander Traces

Meander traces enable you to quickly insert traces with specific characteristics including
length, spacing, and orientation.

Corner Type - Select from Mitered, Square, Curve (see Working with Traces for an
illustration of corner types).
Starting Direction - The direction (clockwise or counterclockwise) in which the first
two segments connected to the starting lead are drawn.
Ending Direction - The direction (clockwise or counterclockwise) in which the last two
segments connected to the ending lead are drawn.
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Width - The desired width for the trace.
Minimum Spacing - The minimum spacing between the parallel trace segments.
Line Length - The total length of the trace, including the lead length segments.
Mitered Corner Cutoff Ratio (%) - The desired cutoff ratio for the corner type Mitered.
Curve Radius - The desired curve radius for the corner type Curve.
Lead Length - The length of the starting and ending segments.
Meander Line Orientation - Select Vertical if you want the trace to meander vertically
between the specified starting and ending leads; select Horizontal if you want the
trace to meander horizontally between the specified starting and ending leads.

To insert a meander trace:

Choose Insert > Meander Trace. In the dialog box that appears, set the options as1.
desired and click Apply.
Move the pointer into the drawing area and click to specify the endpoint of the2.
starting lead.
Move the pointer as needed in both the direction of X and Y until you see the ghost3.
image of the meander trace.
Adjust as needed and click to specify the endpoint of the ending lead.4.

 

 Working with Paths

Paths are polylines with width. Paths have no connectivity information associated with
them, but can start and end at any point and can be converted to traces.

Note
If a trace or path contains a bend, the shortest segment that is part of that vertex cannot be shorter than
3 × w/4, where w is the width of the trace.

To draw a path between two points:
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Choose Insert > Path. The Path dialog box appears.1.
Specify a corner type and width.2.

Corner Type lists the available options for corner types.
Width sets the width of the path, with respect to the current design unit.

Set the path attributes and click Apply.3.
Position the pointer at the start point and click.4.
Position the pointer at the end point and click. A path is drawn between the specified5.
points.

To make certain the corner of a curved path is exactly where you want it, try one of the
following methods:

Draw a square path and then use the command Edit > Properties to change it to a
curved path.
Specify the vertices observing the coordinate readouts in the status panel and draw
as though you were drawing a square path.

 

 Differences Between Paths and Traces

Paths and traces are very similar in the way that they are created and edited. They both
are represented in layout as lines with a width and can contain chamfered or curved
corners. Paths and traces can both make connections in a layout design, though there are
some subtle differences in how they can be used.

Traces Paths

Are intended to make connections at pins (point pins from other items
can also make a connection to a trace along the centerline of the trace
if the point pin is placed on the center of the trace)

Are intended to make connections
anywhere on the path

Behave line wires, automatically joining and splitting Behave like polygons, only changing
when edited by the user.

Using design synchronization, can be synchronized in a schematic as a
wire (short) or as transmission line components

Using design synchronization, can be
synchronized in a schematic as a
wire (short)

joining two traces at their endpoints will merge the traces into a single
trace

can be joined using Edit > Merge >
Union

trace insertion command allows multilayer trace routing and
automatically inserts vias as defined with the Via Configuration

paths on different layers and via can
be inserted separately

Are used for connections at their pins even if the physical connectivity
engine is off.

Have no effect on connectivity if the
physical connectivity engine is off
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Note
Traces can be converted to paths by choosing Edit > Path/Trace/Wire > Convert Trace to Path.
Paths can be converted to traces by choosing Edit > Path/Trace/Wire > Convert Path to Trace.

 

 Creating Interconnects with Shapes

If the physical connectivty engine is enabled, connections can be created by contact
with/between polygons, circles, arcs, rectangles, and paths. In order to correctly calculate,
the layer connections must be specified correctly in the Layer Binding dialog. For more
information on contact between different layers, refer to Defining Port Connections (Layer
Binding) (custom) under the section on Setting Layout Options (custom) in the
Customization and Configuration (custom) documentation.

For information on associating polygons with ports, refer to Adding pins/ports to artwork
(usrguide) under the section on Artwork (usrguide).

Note
Starting in ADS 2011, polylines and arcs will create connections when physical connectivty is enabled.

 

 Working with Wires

You can use a temporary wire to create an electrical connection between layout
components. Wires make it easy to move components within a layout without breaking
connectivity. Wires also make it easy to simulate the performance of a circuit before you
insert the lines that will actually be used. The simulator treats wires as short circuits (as
though the connected components are physically touching). Later you can connect
components directly, or replace the wires with traces and repeat the simulation to verify
circuit performance.

At times, unintentional gaps can be generated in a layout. When this happens, a wire
appears to indicate an electrical connection between elements that are not abutting. Note
that moving artwork can introduce new wires (disconnect components). You can often
adjust the layout parameters to close gaps, or introduce new elements, rather than
manually moving objects.

 

 Inserting Wires
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When you draw wires, they must start and end at either a pin or another wire.

Choose Insert > Wire.1.
Click on the pin (or wire) at one end.2.
Click on the pin (or wire) at the other end. A wire is drawn between the specified3.
points.

 

 Inserting Text

You can add text to a design using either the Text command from the Insert menu or the
Text icon on the toolbar.

Choose Insert > Text. The status panel prompt displays the following message:1.
New Text: Enter location for new text
Click the pointer at the desired location and begin typing.2.
You can use the arrow keys, the backspace and delete keys to make changes; you
can also drag across text to highlight it, then re-type or delete it.
To continue the text on the next line, press Enter and continue typing.
When you are through with this text, move the pointer away from the text and click.3.
To type text in another location, click in that location and begin typing.
When you are through adding text, choose Insert > End Command or click the4.
cursor on the toolbar.

Note
To establish default attributes for new text, choose Options > Preferences > Text. To edit
existing text and text attributes, choose Edit > Properties.

 

 Layout Block Text Fonts

When creating physical designs for output to a production process, you can provide text
that displays on the produced parts. Often this means that the text must be composed of
primitives shapes that have thickness to them, not a simple stroke font.

The Advanced Design System has a palette of polygon-based text fonts, called Block Text
Fonts, to satisfy this need.
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The program supports a total of 14 fonts. The first eight are the same as the fonts that
are provided in the Microwave Development System (MDS).

The supported fonts are:
din17 - An industrial standard font.
iso3098 - Another industrial standard font.
roman - A font similar to the Times Roman font.
smooth - A font with the characters more round and smooth.
italic - An italic font.
standard - The original font provided in MDS.
gothic - A font that's more for fun than practical use.
math - A font of special math characters.
sans - A basic sans serif style font.
sansbold - A bolder version of sans.
filled - A font with no holes in the characters.
filledbold - A bolder version of filled.
straight - A font with no curves.
straightfilled - A filled (no holes) version of straight.

These are not simple stroke fonts that are put through a translation process, but are
actually implemented as polygon definitions for each letter in the font. The fonts are
implemented as components (built using the Graphical Cell Compiler) and, therefore, have
a wide range of attributes available in the component edit dialog.
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The attributes are:
Text String - The actual text string to be displayed. The text string should not be
enclosed in quotes (") but may contain quotes that displays in the placed component. The
text can have multiple lines with the characters backslash-n (\n) representing a new line.
The parameter can be a reference using the "@" prefix, so you can specify a variable
name. The contents of the variable is the text string displayed (see Example).
Character Height - The height of the characters. This is actually the height of the
standard character size for the specific font. Lower-case characters are not as large and
characters with descenders (for example: g, j, p, q, and y) extend below the standard
size.
Character Spacing - A multiplier for the horizontal space used for the standard character
size. When set to 1.0, large characters like W or M can touch. If set to a value smaller
than 1.0, characters can overlap.
Line Spacing - A multiplier for the space vertical space used for the standard character
size. The default value of 1.2 leaves enough room between lines so that characters with
descenders do not overlap the characters of the next line.
Insertion Layer - The numeric layer ID where the polygons for the text string are
placed.

The polygon definitions for each font are not loaded unless a font component is being
inserted or edited, so that startup speed or memory usage is not impacted. When a font is
used for the first time in a session, a small dialog informs you that the font is being
loaded. When the loading is complete, the dialog closes.
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After a font is loaded, you do not need to load it again for the duration of the current
session of ADS. In addition, you do not need to load the font to view a previously-inserted
text component since the component is simply a set of polygons. You only need to load
the font if you edit the component (causing it to be re-created) or if you insert a new text
component in that font.

After you insert a text component, you can modify all component attributes using
Edit/Component/Edit Component Parameters. You can edit the text string, change any of
the physical-size attributes, or change the layer the component is inserted on-you can
adjust the text easily so it can fit within any physical constraints in the design.

If you need to change the font on a text component, you can use Edit/Component/Swap
Components. Since the component name is the font name, changing the component name
to a different font causes the component to be re-created in that new font.

 

 Example

This example shows how a block font text component can reference a schematic variable
and display its contents.

First, open a Schematic window and place a Var component. Then edit the component and
add a name/value pair to be used in Layout.

Next, open a Layout window. Confirm that the Layout window is for the same design as
the Schematic window. Select a font to insert. In the text field use the "@" syntax to
specify the variable name defined in the Schematic in the Var component.
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Insert the component and notice that the contents of the variable, not the variable name,
is displayed.

 

 Creating a Layout from a Schematic

You can ensure that a schematic and layout are equivalent by using the design
synchronization process (Generate/Update) whether you are creating a schematic from a
layout, or a layout from a schematic. When you do either, the program examines each
element in the source representation and modifies or creates an equivalent element in the
target representation.

For details on automatically generating a layout or schematic, refer to Design
Synchronization (usrguide).
For details on creating the two representations simultaneously, refer to the section,
Creating a Layout as You Create a Schematic

 

 Creating a Layout as You Create a Schematic
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Creating a layout as you create a schematic is similar to creating a layout from a finished
schematic, except that you place components simultaneously in both the source and
target representations.

From either window, choose Options > Preferences > Placement.1.
Enable either Dual Representation or Always Design Synchronize.2.

Dual Representation enables you to place equivalent components in the other
representation quickly, because the component is already selected in the second
window.
Always Design Synchronize causes the program to fully synchronize both
representations after each part is placed.

 

 Common Potential Problems

There are several design aspects that can be problematic if you are not aware of how to
handle them:

Junctions (See Using TEE Junctions in a Schematic (usrguide) under the section on
Design Synchronization (usrguide))
Steps and tapers (See Using Steps and Tapers in a Schematic (usrguide)under the
section on Design Synchronization (usrguide))
Flipping versus rotation

 

 Flipping versus Rotating Components

Flipping and rotating components in the schematic window may appear to have the same
effect, but they are actually handled differently during layout generation. If a component
was flipped in the schematic window, it will be flipped in the layout. However, if a
component is rotated in the schematic window, the rotation is not carried through to the
layout.

 

 Hierarchical Layouts

Hierarchy is the relationship between different parts of a layout. A layout with hierarchy
contains one or more artwork elements that exist in separate design files. You can create
a hierarchical design by placing an existing design within the current design. This creates
an instance or reference to the design.

In the program, the term component is often used interchangeably with instance. In this
case, instance refers something that is referenced by another layout. Creating an instance
is different than copying the contents of one layout into another layout. Creating an
instance does not copy any data; instead, a reference to the desired layout is created.

There is no limit to the level of hierarchy that can be created. Designs can reference
designs that, in turn, reference other designs. Parameters can be passed to all levels of
hierarchy. The only limitation is that a design cannot reference itself at any level of the
hierarchy (for example, design A referencing design B that, in turn, references design A).
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 Advantages of a Hierarchical Design

The primary advantage to creating a hierarchical design is that it saves you time. You can
use one layout in many places. Making a change in the referenced layout is automatically
reflected in all layouts that use that instance. In Layout you can build up libraries of
reusable designs that can be referenced by any workspace.

 

 Schematic Considerations

If you want to simulate a design containing a layout, there must be a schematic. In
general, the hierarchies of the schematic and layout should match. That is, if there is a
subnetwork in the schematic, there should be a corresponding subnetwork in the layout.

Although the system can create the hierarchy of one representation automatically from
the other, it is flexible in how it generates and updates schematic and layout. You can,
when creating a subnetwork layout, specify any design or AEL macro as its layout
equivalent (File > Design Parameters View-Specific Settings in the layout).

To affect the layout view settings, you must select the File > Design Parameters
command from Layout window. Starting in ADS 2011, this dialog will control the
implementation (such as AEL macro and parameterized artwork) used when an instance of
the layout is placed on another design.

 

 Parametric Subnetworks

Unlike most CAD systems, instances can be modified on a per-instance basis; each
instance of a referenced design does not have to be identical. You can add parameters to
a schematic component that modify one or more of its attributes, so that when you use
that schematic in another design, you can define the parameters as required. This type of
design is called a parameterized design. For example, you can create a schematic with a
parameter that modifies the length of a microstrip line; when the design is placed in
another design, you can define that parameter as any length.

When you generate the layout, the artwork elements reflect the parameters you defined.
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 Creating a Hierarchical Layout

This section describes the various aspects of creating a hierarchical layout.

 

 Creating Hierarchy Using Design Generation

Create a first-level design in the Schematic (or Layout) window.1.
Use the Generate/Update command from the Layout (or Schematic) menu so that2.
you have both representations available.
The following schematic and layout examples are called lpf. The mlength parameter
was created using the File > Design/Parameters command, which creates a
parameterized design.

Save the design.3.
Create the top-level design by choosing File > New Design.4.
Click the Library button. From the Subnetworks library, select the newly created5.
design file, lpf.
As you move the pointer into the Schematic window, a ghost image of the design6.
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moves with it to aid you in positioning. Click to position the design.
Complete your top-level design.7.
Save your design.8.

The following examples show lpf, placed twice. The top-level design is called lpf2.

 

 Creating Hierarchy Manually

Create a design, in the Layout window, that you want to reference in your top-level1.
design.
Add pins if the layout is to be used with a schematic design for simulation.2.
Create the top-level design by choosing File > New Design.3.
Click the Library button. From the Subnetworks library, select the newly created4.
design.
As you move the pointer into the Schematic window, a ghost image of the design5.
moves with it to aid you in positioning. Click to position the design.
Complete your top-level design.6.
Save your design.7.

 

 Viewing Hierarchical Design Information

You can view or print a list of the hierarchy levels of your design. Hierarchy levels are
indicated by the indentation of the list. Top level instances are not indented, each nested
level is indented with one space.

Choose Tools > Hierarchy and the Hierarchy dialog box appears.1.
To save the information to file, choose Print. The information is sent to the default2.
printer.
Click OK to dismiss the Hierarchy dialog box.3.
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 Flattening Hierarchy

When you are ready to generate final artwork, you might want to use the Flatten
command to remove all levels of hierarchy. This process copies all data from the
referenced design to the current representation. See Editing Layout Hierarchy (Flatten)
(usrguide).

 

 Breaking the Connection Between Layout and Schematic

The Flatten command works on components like MLIN. You can use it to break the
connection between the layout and the schematic so that you can change a layer or edit
the shape in the layout.

Select the microstrip(s).1.
Choose Edit > Component > Flatten.2.
Repeat this procedure for each instance you want to flatten.3.

 

 Creating a Hierarchical Design for Repeated Use

The Create Hierarchy command copies selected artwork elements to another file, saves
that new file, deletes the selected components in the original file and replaces them with a
reference to the new design. In addition, you can parameterize the design in the newly
created file, and use it as a subnetwork in any design.

 

 Assigning a Symbol to a Subnetwork

To use a custom symbol to represent the design, you can do one of following:

Create a symbol to represent only this particular design. This method requires
drawing the symbol in the design file containing the design.
Create a symbol that can be used to represent any design. This method requires
drawing a symbol in a file that contains only the symbol.
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 Pushing Into or Popping Out of Hierarchy

In the Layout window, you can push into a component to view and edit the actual artwork
represented by the component. This feature is particularly helpful is some cases such as
when you need to work on a specific subnetwork without needing to see the overhead and
details of the rest of the design. For details on editing a hierarchical design without
pushing into it, refer to Editing a Hierarchical Design (usrguide).

Use the following steps to push into or pop out of a hierarchical design either to view it or
to edit.

Select the component.1.
Choose View > Push Into Hierarchy to display the network represented by the2.
symbol.
When you are through viewing the network, choose Pop Out of Hierarchy to return3.
to the component (or design containing the component).

Note that the Pop Out of Hierarchy command is the reverse of pushing and only works if a
design has been pushed into.

 

 Libraries and Search Paths

Many designs use a hierarchical approach. A top-level design is built from reusable, lower-
level, subnetworks. Layout stores all each design in a separate library/cell/view. The top
level network is maintained in a view that refers to the lower-level, subnetwork views.

When a hierarchical design file is read in, each reference to a subnetwork is read in as
needed. Starting in ADS 2011, the each reference knows the library, cell, and view name
of the subnetwork. The library must be loaded into the current workspace to be used.
From the main menu, select DesignKits > Manage Libraries....

The library mechanism allows the construction of any number of reusable layout libraries
that can be shared among different designs. Creating design libraries of tested and
commonly used layout components can save a great deal of time, while ensuring reliable
designs.
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 Creating Elements
This topic provides detail on how to create new items (elements) in ADS.

 Types of Items

There are two categories of items that can be placed in a cellView:

Simulated
Non-simulated (Objects)

 Objects

Non-simulated items are termed objects. Typical objects are alignment markers,
schematic sheet borders, mechanical fasteners, etc. Objects can be selected from palettes
and libraries like any other item, but are not included in simulation, nor are they normally
included in design synchronization between layout and schematic.

 Simulation Items

Simulation items, as the name implies, are included in simulation. Simulated items include
all the program-provided items in the libraries and palettes and all user-defined networks.
Each simulation item has one of two types of simulation models associated with it: models
represented as schematics and built-in simulation models. Either type can be used when
creating a new item. Built-in models can be user-defined items or any item for which the
simulator has an intrinsic representation. For more information on creating user-defined
elements, refer to the User-Defined Models (modbuild) or ADS Ptolemy Simulation
(ptolemy).

Creating a new item using a built-in simulation model can be used to assign artwork to
items with no default artwork assignment such as lumped components or device models.
An example application would be to create a new item for a FET that is modeled with an
S-parameter file using the S2P item.

Creating a new item modeled with a schematic network allows a greater degree of
freedom. An example would be creating a network that models the parasitic effects of the
solder pads for a Surface Mount Technology (SMT) lumped component. The ability to pass
parameters into custom networks increases the flexibility of this approach by allowing any
network to be parameterized in the same manner as built-in simulation models.

 

 Defining a New Item

Select File > Design Parameters from the Schematic or Layout window to define a new
item. Enter the fields of the Design Parameters dialog box to create a custom item
definition located at a particular cell in a particular library. The Library and Cell name
appears at the top of the Design Parameters dialog box. These are not editable fields.

Save AEL File - Enables you to incrementally save definitions (which are contained in the
.ael file). By turning this on and choosing OK, rather than waiting until you save the
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design file itself, the AEL definition for the new item is saved.

The Save AEL file and OK buttons saves the custom item definition into an AEL file. The
Save AEL file enables you to incrementally save definitions (which are contained in the
.ael file). By turning this on and choosing OK, rather than waiting until you save the
cellView itself, the AEL definition for the new item is saved.

When the cellView is saved, an AEL definition is created in the <current
workspace>/<current library>/<current cell> directory. This file is named itemdef.ael
. This file contains a number of AEL function statements. These functions register the new
item with the Design Environment. This registration includes the following:

Palettes and libraries that an item includes
Procedure to simulate an item (if at all)
Item's parameters, artwork, and other details

It is possible to view and edit this AEL file using a text editor (the syntax for these
functions is defined in AEL (ael)). However, the syntax is complex and using the dialog
box eliminates many possible errors in defining a new item.

This file (along with the schematic and/or layout cell view) can then be moved to other
directories for use as library parts, either for personal use or site-wide use. For details,
refer to Creating Custom Libraries (custom) under the section on Customization Examples
(custom) in the Customization and Configuration (custom) documentation.
For details on adding items to a palette, see the de_define_palette_group() (ael) function
in the AEL (ael) documentation.

If you are creating an item with a schematic network model or an item using custom
artwork, you should create the network or artwork before creating the new item definition.
For items using a schematic network, the item definition is usually done with the
completed schematic network open in the Schematic window. For any other type of item
definition, the Schematic and Layout windows are usually empty. The artwork and models
are in other cellViews or AEL files and are referenced by name.

 Defining Design Characteristics

While the default design characteristics may be acceptable in many cases, the Design
Parameters dialog box allows you to alter the default characteristics of the network. You
may want to modify any or all of the following default characteristics found on the
General Cell Definition tab.
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Name - This field is informational only and displays the current cell name.

Description - Provide any descriptive phrase for clarification. This description appears in
the Component Parameters dialog box when placing the item or network.

Component Instance Name - The default is X, but the text in this field is used as a
prefix in building a unique name (ID) for every item. This prefix becomes part of the
annotation displayed with the symbol when you place it in a cellView.

Allow only one instance - This enables you to specify whether or not the item or
network can be placed in a cellView more than once. The default is off, meaning the item
or network is not unique and can appear more than once in a cellView. Change to on if
you want to restrict placement to once per cellView.

Include in BOM - Turn this on if you want the details of the subnetwork design to be
included in a generated Bill of Materials (BOM). When this is turned off, only the top level
design information is included.

Layout Object - Turn this on if the item you are defining is an object used with the
Layout option (Layout objects are not simulated or synchronized but typically contain
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items such as alignment markers.) This attribute controls whether or not they will show up
in layout palettes and libraries or schematic palettes and libraries.

Simulate From Layout (SimLay) - Analog/RF designs only. The netlist required for
simulation is generated from either the Schematic or the Layout. Select this option to
generate the netlist from the Layout.

Simulation

Model - Enables you to assign a netlist choice:
Built-in Component - A built-in simulator item (such as CAP or RES), enables
Simulate As and Copy Component's Parameters.
Subnetwork - The subnetwork used will be determined by the Hierarchy Policy,
which will choose a cellView within the current cell.
Not Simulated - Create layout or schematic only non-simulated items

Simulate As - This field is enabled ONLY when the Simulation Model is set to Built-in
Component. In this case, it should be set to a value in the drop down list, or the cell
name of another built-in item may be typed in. Values of the drop down list are:

Copy Component's Parameters - This is enabled when the Model is set to Built-in
Component. If checked, the parameters of the selected built-in component in
Simulate As are copied into your item, and they can be viewed in the Cell Parameters
tab.

 
 

 Defining Parameters

Most new items you define need parameters. Each parameter has characteristics that
determine how it is handled when the item is used. These include the name and label
displayed in the Component Parameters dialog box, the unit type for the parameter, the
type of value assigned to the parameter, the default value, and certain control attributes.

Parameters can be defined in the Cell Parameters tab. If you checked Copy Component's
Parameters in the General tab, then there will be a list of defined parameters in the Cell
Parameters tab. These parameters may be modified here. In addition, you can add or cut
parameters.
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Select Parameter - This is a list of defined parameters for this item. When a parameter
is selected, the appropriate values are filled in Edit Parameter area.

Edit Parameter

Parameter Name - The name of the parameter. By default, it is set to the
parameter selected in Select Parameter list. However, you can type in the name of a
new parameter as well.
Value Type - The type of value for this paremeter. Possible values are:

Default Value - The default value for this parameter.
Parameter Type - The parameter type of this parameter. Possible values:
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Parameter Description - Contains the description of this parameter.
Display parameter on schematic- Select this option to display, on the schematic,
this paremeter.
Optimizable - Select this option to allow this paremeter to be optimized.
Allow Statstical Distribution - Select this option to allow post-production tuning
for this parameter during yield analysis.
Not edited - Select this option to prevent this parameter from appearing in the
Component Parameters dialog box for editing and always use the default value
assigned here instead.
Not netlisted - Select this option to prevent this parameter from being considered in
simulation, but still be recognized for artwork generation. (In general, layout-only
parameters - not used for simulation - are assigned the Not Netlisted attribute.)

Add - Adds the parameter defined in the Edit Parameter section. If that parameter
already exists in the Select Parameter list, it will not be duplicated, but it will make
modifications to the existing parameter.
Cut - Removes the selected parameter in the Select Parameter list.
Paste - Pastes the last parameter that was cut from the Select Parameter list.

Hint
You can assign attributes for each parameter as you define it, or you can define all parameters and then
go back and assign attributes. You can also position these user-defined parameters to display somewhere
other than the default location of provided parameters. For details refer to Positioning Parameters for Your
Symbol (usrguide) under the section on Working with Symbols (usrguide).

Important
For AEL generated artwork, entering your parameters in the correct order is critical. The order you specify
in this dialog box must match the order given in the function. For example, in the AEL function for an
MLIN, width comes before length. If you enter the length parameter first, it is still read by the function as
width (ignoring the Name identifier).
Also, artwork parameters must precede those used for simulation, and must be marked Not Netlisted. For
items with artwork, add any artwork parameters first, then use copy parameters or add the simulation
parameters.

Add Multiplicity Factor(_M) - The multiplicity feature provides a way to scale
components or entire sub-circuits containing many components and sub-circuits. For
details refer to Multiplicity Parameter _M (ccsim). Once it is added as a parameter, this
button becomes disabled.

Copy Parameters From... - Allows you to copy the parameters from any component to
your new item. First, it opens the library browser and allows you to select a component
and click OK. Then it will copy the parameters of that component to your item.
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 View-Specific Configuration

The View-Specific Configuration tab appears only when the *File > Design
Parameters..." is invoked from a layout window. It allows you to select the appropriate
artwork type for the Analog/RF layout designs. When you design a network, you need to
determine what type of artwork should represent your network when it is placed in
another network. For creating most elements, either Fixed or AEL Macro should be used.

Type - The artwork type for the layout design. The possible values are:

Use Original Layout - This is the default artwork type setting for new designs. No
Pcell will be used. The original layout will be used directly with no rotation, unit
conversion or layer mapping.
AEL Macro - Select AEL Macro for components that use an AEL artwork macro
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function. Enter the name of the artwork macro below in the Name field or select the
pre-defined artwork macro. The original layout is unused unless the AEL function
explicitly loads or flattens it.
Parameterized - Select Parameterized when the original layout is used as template.
The parameters will be evaluated and the new layout will be adjusted based on the
values.
Nested Technology - Select Nested Technology if you want to use instances of the
original layout to be used inside a different technology.
Referenced Fixed - Select Referenced Artwork when the instance of the original
layout can refer to another layout design. The artwork will be copied from this cell. If
no design is referenced, artwork will be generated based on the number of pins.

Name - This is enabled only when the Type is "AEL Macro" or "Referenced Fixed".

All of the check boxes have default values that are set appropriate for the artwork
specified in Type. You may change them.

 

 Creating a Simulation Item Using a Built-in Simulator Model

The details of this process are presented using a simple capacitor C as the simulation
model, with predefined artwork representing a chip capacitor footprint CHPCAP.

 Create New Layout

Open a workspace and select File > New > Layout from the Main window.1.
Name the cell "mycap".2.

Note
You do not need to place anything in the Schematic or Layout windows for this example-the entire
item definition is done through the Design Parameters dialog box.

 Define Design Characteristics

In the new Layout, select File > Design Parameters. The Design Parameters dialog1.
box appears.
Optionally, enter a Component Instance Name of C.2.
Select the appropriate Simulation Model, as described earlier. In this example, use3.
Built-in Component.
Specify how you want the item (or network) simulated. Select C for this example.4.
Check Copy Component's Parameters in order to have C's parameters as part of yout5.
item definition.
Click Save AEL file to save this portion of the item definition, and continue to the6.
next section.

Your dialog box should now look like the following example.
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 Define Parameters

In the Design Parameter" dialog, press the _Cell Parameters tab.1.
Since parameters of a provided component were copied, the Edit Parameter fields are2.
filled in with defaults.

For parameter "C", the Value Type is set to Real and the Default Value is set to
1.0 pF. Note that this value serves only as a default. You can change the value
each time you place the item subsequently.
The Parameter Type is set to Capacitance.
The Parameter Description (optional) reads Capacitance (This is used only to
document the meaning of the parameter.)

Add a new parameter.3.
Now type in "Style" under Parameter Name.
Select Value Type to be String
Type in "Narrow" under Default Value
Select String under Parameter Type
Type "graphics style" under Parameter Description
Press "Add". Notice the new parameter shows up in the Select Parameter list.

Enable or disable the following options, based on your design needs:4.
Display parameter on schematic - Select this option to display, on the
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schematic, the parameter being defined.
Optimizable - Select this option to allow this parameter to be optimized.
Allow Statistical Distribution - Select this option to allow post-production tuning
for this parameter during yield analysis.
Not edited - Select this option to prevent this parameter from appearing in the
Component Parameters dialog box for editing and always use the default value
assigned here instead.
Not netlisted - Select this option to prevent a parameter from being considered
in simulation, but still be recognized for artwork generation. (In general, layout-
only parameters - not used for simulation - are assigned the Not Netlisted
attribute.)

Click Save AEL file to save this portion of the item definition, and continue to the5.
next section.

Your dialog box should now look like the following example.

 Define View-Specific configuration

Specify an Artwork Type, for example Referenced/Fixed.1.
Specify a name in the Artwork Name field (for fixed artwork, enter the same name2.
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that appears in the Label field; for a macro, enter the name of the AEL function). For
this example, select CHPCAP as the artwork for a chip capacitor.
Enable or disable the following options, based on your design needs:3.

Support non-90 degree rotation - Select this option to allow non-90 degree
rotation.
Support unit and database resolution conversion - Select this option to allow
resolution conversion.

Your dialog box should now look like the following example.

 Save the item definition

Click OK to save this portion of the item definition.1.
Go the directory <current workspace>/<current library>/myCap directory and notice
that the file itemdef.ael has been created and contains the new item definition.

 

 Creating a Simulation Item Using a Schematic Parametric Subnetwork
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 Create a network on schematic window that will be used as a subnetwork.

A subnetwork can be created in 2 ways:

Create a cell with 2 cellViews: a schematic cellView that contains a network and a1.
symbol cellView that contains a symbol that represents the network, or
Create a subnetwork from an existing design.2.

Go to Creating Hierarchical Designs (usrguide) documentation for details.

For the following topics discussed in this section, the cell name series_r_c located in the
library myModels_lib will be used. The cell series_r_c contains a schematic cellView that
contains a network on it and a symbol cellView that contains the symbol that represents
that network. The network has 2 ports and contains a capacitor and resistor.

 Define Design Characteristics

Choose File > Design Parameters. The current library and cell names are reflected1.
at the top of the dialog box. Go to the General Cell Definition tab.
In the General Cell Definition tab, the Description field displays the current cell name2.
by default. You can change this to a more helpful label defining the purpose of the
network design. The label you provide here will be displayed, together with the cell
name, as a component to place from the designated library (Library field at the top of
the dialog). Optionally, add a description, in this example, cap and res.
The Component Instance Name default is X. The text in this field is used as a prefix3.
in building a unique name (ID) for every item. This prefix becomes part of the
annotation displayed with the symbol representing the parametric subnetwork when
you place it in a cellView. Optionally, assign a unique name, in this example,
para_sub.
Turn on or off the following options, as required by your design.4.

Allow Only One Instance - Specifies whether or not the subnetwork can be
placed more than once in a cellView. The default is off, meaning the subnetwork
can appear more than once in a cellView. Change to on if you want to restrict
placement of the subnetwork to once per cellView (seldom done).
Include in BOM - Specifies whether or not the details of this design are included
when a Bill Of Materials (BOM) is generated. Without this option, only the top
level design information is included in the BOM.
Layout Object - Analog/RF designs only. Defines the item as an object. Layout
objects have no parameters and are used to assign artwork to new items or
items with no default artwork. For details, refer to the Layout Library (layout)
documentation.
Simulate from Layout (SimLay) - Analog/RF designs only. The netlist required
for simulation is generated from either the Schematic or the Layout. Select this
option to generate the netlist from the Layout. The SimLay portion of this label
will appear in the Status panel of the Schematic and Layout windows if you
select this option; the default is to simulate from the Schematic, and the Status
panel reflects SimSchem.

Set the Simulation Model field. Select the appropriate Simultation Model.5.
Select Subnetwork, to use a schematic symbol you have created in the current



Schematic Capture and Layout

172

cell
Select Built-in Component, to use provided simulator item.

Simulate As - Select a component name from the drop-down list, or type
the name of any component.
Copy Component's Parameters - Select this option to copy the parameters
of the selected component to use as a starting point.

Select Not Simulated, to create layout-or schematic-only non-simulated items
In this case, select Subnetwork because we are going to use the symbol found
in the current cell series_r_c.

Click Save AEL file to save the information defined so far.6.

Your dialog box should now look like the following example.

 Define Parameters

When you define parameters for a network, the network serves as a template, enabling
you to assign new parameter values each time you use the network. This is useful when a
portion of the network is used several times in a design with certain element value
differences, or in constructing libraries of reusable networks.
Parameters of the network are generally referenced as variables by the elements of the
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network. You can define the parameters before or after creating these variable references.
Each parameter has characteristics that determine how it is handled when the network is
reused. These include the name and label displayed in the Item Parameters dialog box,
the unit of the parameter, the type of value assigned to the parameter, the default value,
and certain control attributes.

Press the Cell Parameters tab.1.
Define a new parameter called C2.

Now type in C under Parameter Name.
Select Value Type to be Real
Type in 5 under Default Value

Hint
If you do not specify a scale factor along with the default value, the current setting in the
Preferences dialog box is used (Options > Preferences > Unit/Scale), based on the
Parameter Type.

Optionally, select Capacitance under Parameter Type. This can be a
dimensional unit or a string for the parameter, if one is needed (String is used
for assigning SMT artwork in layout.)
Optionally, type "cap" under Parameter Description
Press "Add". Notice the new parameter shows up in the Select Parameter list.

Hint
You can position these user-defined parameters to display somewhere other than the default
location of provided parameters. For details refer to Positioning Parameters for Your Symbol
(usrguide) under the section on Working with Symbols (usrguide).

Enable or disable the following options, based on your design needs:3.
Display parameter on schematic - Select this option to display, on the
schematic, the parameter being defined.
Optimizable - Select this option to allow this parameter to be optimized.
Allow Statistical Distribution - Select this option to allow post-production tuning
for this parameter during yield analysis.
Not edited - Select this option to prevent this parameter from appearing in the
Component Parameters dialog box for editing and always use the default value
assigned here instead.
Not netlisted - Select this option to prevent a parameter from being considered
in simulation, but still be recognized for artwork generation. (In general, layout-
only parameters - not used for simulation - are assigned the Not Netlisted
attribute.)

Optionally (Analog/RF designs only), you can click Add Multiplicity Factor (M) to4.
enable simulation of this subnetwork as though it were _x number of these
subnetworks - connected in parallel - where x is the value you assign to the
parameter _M.
Your dialog box should now look like the following example.
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Click OK to dismiss the dialog box and choose File > Save Design.5.

 Specify View-Specific configuration

View Specific Configuration tab is part of Design Parameters dialog. To open this window,
choose File > Design Parameters from the Layout window. Select the View Specific
Configuration tab. You can select the appropriate artwork type only for Analog/RF layout
cellViews only.

Specify an Artwork Type, for example Use Original Layout. Your dialog box should1.
now look like the following example.
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Click Save AEL file to save the information defined so far.2.

 Save the item definition

Click OK to save this portion of the item definition.1.

Go the directory <current workspace>/my_atten/my_atten directory and notice that the
file itemdef.ael has been created and contains the new item definition.
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 Editing a Layout
Most of the edit commands enable you to select one or more components either before or
after you select the edit command. The most commonly used editing commands, Copy,
Delete, Move, Rotate, and Undo are performed in a layout. You can edit text, and can
change either the attributes of existing text, or define the attributes of all subsequent
text.

An electrically complete layout circuit has all components connected. This section provides
information on editing and connecting layout circuit components.

 

 Using Selection Filters

Selection Filters enable you to specify the types of components you want to include or
exclude in sections. Any component that is turned off is not selected when you click on it
individually, attempt to enclose it in a selection window, or choose the Select All
command. Only the Select By Name and Deselect By Name commands ignore the
selection filters.

By default, all types of components are turned on except Drawing Format.

Choose Options > Preferences > Select.

 

 Editing Primitives Using the Properties Dialog Box

To edit single or multiple shapes (including text), select the shape(s) and click Edit >
Properties, or alternatively, double-click on the selected object(s), or right-click and
select Properties. This opens the Properties dialog box.
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Note
The features enabled by the Properties dialog box apply to both Layout and Schematic windows, except
where noted.

To apply the modifications made in the Properties dialog box, click Apply or OK. For
example, if the origin of a rectangle is modified, click Apply to see the change. Click OK
to apply the changes and close the Properties dialog box.

Note
Polygons, polylines, rectangles, circles, and arcs have a Thickness attribute available only in schematic.
This attribute will only be visible in the Properties dialog box when invoked from a schematic window.

While the Properties dialog box is open, any type of object can be selected. 0 items
selected. appears at the top of the Properties dialog box when no object is selected while
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the dialog box is open. Without an object selected in the layout, both the Standard and
Custom tabs do not display values in their tables.

 All Shapes

Use this section to modify the Layer value for the currently selected shape(s).

 Pin

This section can be used to update any of the following parameters of a pin:

Parameter
Name

Description

Name To change the default pin name.

Number The pin number is supplied by the program and automatically incremented each time a pin is
placed. However, you can change the program-supplied value by typing in an integer value of
your choice in this location.

Forced Net
Name

Here you can change the default value of the net name provided by the software.

Orientation
Angle

To change the orientation angle of a pin.

Type Here you can define the pin type to be Input, Output, OR Input/Output both.

Impedance To change the impedance value of a pin.

Reference
Plane Shift

To change the distance of the reference place from a pin.

 Path/Trace/Wires

Use this section to modify the Width, Corner type (Mitered, Square, or Curve), Miter, and
Curve radius of the selected path, trace, or wire. Length is not editable, shown for
information only.

 Text
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Use this section to modify the Text (click on the Text in the Value column to edit or click
 to invoke the Text dialog where it may be more convenient to edit multi-line text),

Font (HersheyRoman or HersheyRomanNarrow), Size, X and Y locations, Horizontal (Left,
Center, or Right) and Vertical (Top, Middle, or Bottom) justification, Placement angle, and
rotation -when in hierarchy- (True or False).

 Rectangles

Use this section to modify the geometry of a rectangle by defining either:

the lower-left X and Y coordinates and the width and height, or
the lower-left X and Y coordinates and the upper-right X and Y coordinates.

 Circles

Use this section to modify the geometry of a circle by defining the Center Point X and Y
coordinates, Radius, and Edit Mode (Absolute radius or Delta radius).

 Arcs and Circles

Use this section to modify the arc Resolution in degrees.

 Arcs

Use this section to modify the geometry of an arc by defining the Center point X and Y
coordinates, Start point X and Y coordinates, and Angle. Radius is not editable, shown for
information only.

 Construction Lines

Use this section to modify the geometry of a construction line by defining the two points
that define it. Slope is not editable, shown for information only.

 Custom Tab

Properties once displayed in the Edit > Properties dialog in previous versions of ADS are
included in the Custom tab. All values in the Name, Type, and Value columns are editable.
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 Multiple Selection of Like Objects in the Standard Tab

When you make multiple selections of like objects with differing values, (multiple values)
is displayed in the Value column. As long as the (multiple values) value is not changed,
clicking Apply or OK will not modify those values on selected objects. Only the fields that
have like values (not differing) will be modified.

For example, if  is clicked, an empty text entry box appears. Any text entered applies
to all selected text when Apply is clicked. Also, if all selected text have same Font,
Justification, Placement angle, Non-rotating value and Layer, the selected text will show
the common values.

 Multiple Selection of Different Objects in the Standard Tab

If multiple selections of different objects occurs, the complete set of attributes shown are:

Standard tab - The union of all attributes for all selected primitive shapes. For
example, if a rectangle and a circle are selected at the same time, the tab will display
all the rectangle and circle attributes.
Custom tab - All custom properties for all selected objects.

 Multiple Selection of Objects in the Custom Tab

All custom properties of all selected objects are listed. If the objects have different values
(or no value at all) for a given parameter, (multiple values) is displayed in the Value
column. Only modified values are applied.

In the Type field, (multiple types) is displayed for multiple selected objects with different
property types of the same name.

To view the specific set of custom properties for an object, click the object to select it.
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 Editing Primitives Using Object Handles

 To increase or decrease the size in one or more directions, drag the sizing handle away
from or towards the center. The sizing handle is one of the small circles or squares that
appears at the corners and sides of a selected object. You can drag these handles to
change the size of the object.

 Editing Shapes

There are a variety of editing operations you can perform on common layout shapes. For
details on these editing operations, refer to the following:

Manipulating Polygons and Polylines (usrguide)
Manipulating Vertices (usrguide)
Stretching the Edge of a Shape (usrguide)
Scaling Shapes (usrguide)
Adding Ports and Grounds (usrguide) under the section on Creating a Layout
(usrguide)

 

 Selecting Shapes

In addition to the selection features provided by the selection filters, you can quickly
select all items on a layer you specify or you can select all items in a nodal interconnect.

To select all items on a given layer:

Choose Select > Select All On Layer.1.
In the dialog box that appears, select the layer containing the items you want to2.
select for editing. To select all items on multiple layers, click Apply after selecting
each layer, then click OK. The items on the chosen layers are selected for editing.

To select all items in a nodal interconnect:
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Choose Select > Select Interconnect > Nodal to select the polygons, paths,1.
rectangles, wires and traces that make a nodal interconnect. Choose Select > Select
Interconnect > Nodal With Components to select shapes and component
instances that are interconnected.
Use the mouse to select a shape. All shapes in the same interconnect is also selected.2.

 

 Manipulating Polygons and Polylines

There are several ways to modify polygons and polylines after drawing them:

Edit > Merge > Union - Merges the selected shapes of a layer. Defined as the set of
points in all selected shapes. This command is performed separately for each layer.
This operation applies to the following shapes: polygons, rectangles, circles, and
paths. See also Changing Entry/Edit Attributes (custom) (Merge/Boolean
Logical/Create Clearance) under the section on Setting Layout Options (custom)
in the Customization and Configuration (custom) documentation.
Edit > Merge > Intersection - Finds the intersection of each pair of selected
shapes of a layer. Defined as the set of points that exist in at least two selected
shapes. This command is performed separately for each layer. This operation applies
to the following shapes: polygons, rectangles, circles, and paths. See also Changing
Entry/Edit Attributes (custom) (Merge/Boolean Logical/Create Clearance) under
the section on Setting Layout Options (custom) in the Customization and
Configuration (custom) documentation.
Edit > Merge > Union Minus Intersection - Subtracts the intersection from the
union of the selected shapes of a layer. Defined as the set of points that are in at
most one selected shape. This command is performed separately for each layer. This
operation applies to the following shapes: polygons, rectangles, circles, and paths.
This command can be used to create holes in polygons and/or to find the difference
between a set of shapes. See also Changing Entry/Edit Attributes (custom)
(Merge/Boolean Logical/Create Clearance) under the section on Setting Layout
Options (custom) in the Customization and Configuration (custom) documentation.
Edit > Modify > Convert To Polygon - Used to convert circles, as well as polygons
containing arcs, to simple polygons where all curves are converted to line segments
that approximate their original shape.
Edit > Modify > Join - Enables you to join selected polylines with coincident
endpoints into a single polyline. If a closed shape results, the joined polylines are
converted to a polygon.
Edit > Modify > Explode - Enables you to convert a polygon into individual line
segments that are disconnected at each vertex.
Edit > Modify > Break - Converts a polygon into a single polyline.
Edit > Modify > Chop - Removes the defined rectangular region from selected
polygons, rectangles, circles, or paths. This command will fail and will display an
error if traces or instances are selected. All other types are silently ignored.
Edit > Modify > Extend - Enables you to extend the selected endpoint of a polyline
to a designated reference line segment.
Edit > Modify > Crop - Preserves the defined rectangular region from selected
polygons, rectangles, circles, or paths while removing all areas outside of the region.
This command will fail and will display an error if traces or instances are selected. All
other types are silently ignored.
Edit > Modify > Split - Divides selected polygons, rectangles, circles, or paths into



Schematic Capture and Layout

183

multiple shapes using a defined rectangular region. This command will fail and will
display an error if traces or instances are selected. All other types are silently
ignored.

 

 Creating a Polygon from Intersections or Polylines

To create a polygon from the union of two intersecting closed shapes:

Select the two shapes.1.
Choose Edit > Merge > Union.2.

To create a polygon from the intersection of two closed shapes:

Select the two shapes.1.
Choose Edit > Merge > Intersection.2.

To create a polygon from two intersecting closed shapes, with the intersection removed:

Select the two shapes.1.
Choose Edit > Merge > Union Minus Intersection.2.

 

 Converting a Shape to a Polygon
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To convert a shape to a polygon:

Select the shape, where the shape can be a circle or polygon containing an arc.1.
Choose Edit > Modify > Convert To Polygon. All curves are converted to line2.
segments that approximate their original shape. The number of line segments used in
this conversion is determined by the setting Arc/Circle Resolution (degrees) in
Options > Preferences > Entry/Edit.

 

 Joining Multiple Polylines

To join selected polylines (with coincident endpoints) into a single polyline:

Select the individual polylines you want to join.1.
Choose Edit > Modify > Join. All coincident endpoints are joined. You can verify2.
what has been joined by clicking on the shape to select it and observing whether or
not the entire shape is selected.

To verify what has been joined, click the shape to select it and observe whether or not the
entire shape is selected.

 

 Converting a Polygon into Individual Two-point Line Segments

To convert a polygon into individual, two-point line segments:

Select the polygon.1.
Choose the command Edit > Modify > Explode. All vertices are disconnected2.
leaving individual line segments that you can edit as needed.
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 Converting a Polygon into a Single Polyline

To convert a polygon into a single polyline:

Select the polygon.1.
Choose Edit > Modify > Break. The marker identifies the broken start and end2.
points of the polygon, and allows you to manipulate the shape as a polyline.

Edit > Modify > Extend - Enables you to extend the selected endpoint of a polyline
to a designated reference line segment.
Edit > Modify > Crop - Specifies an area of a polygon, rectangle, circle, or
wires/trace; save the selected area; and delete the remainder.
Edit > Modify > Split - Enables you to split a polygon, rectangle, circle, or
path/trace into multiple objects.

 

 Chopping a Selected Region Off of a Shape

To chop a selected region off of a polygon, rectangle, circle, or wire/trace, do the
following:

Select the shape.1.
Choose Edit > Modify > Chop.2.
Use the mouse to draw the rectangular region to be chopped over the object.3.

 

 Extending the Endpoint of a Polyline

To extend the endpoint of a polyline to a designated reference line segment:

Choose Edit > Modify > Extend.1.
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Click on the line that you want to extend.2.
Click on the reference line.3.

 

 Cropping a Shape

To save the specified area of a polygon, rectangle, circle, or wires/trace and delete the
remainder, do the following:

Select the shape.1.
Choose Edit > Modify > Crop.2.
Use the mouse to draw the rectangular region to be saved over the object.3.

 

 Splitting a Shape

To split a polygon, rectangle, circle, or path/trace into multiple objects:

Select the shape.1.
Choose Edit > Modify > Split.2.
Use the mouse to draw the rectangular region to be split away from the rest of the3.
object.

 

 Stretching the Edge of a Shape

You can redefine a shape by stretching an edge (a segment between two vertices).

Choose Edit > Move > Move Edge. You are prompted to enter the location of the1.
line.
Click once on the edge you want to stretch. A ghost image moves and changes as2.
you move the cursor, showing how the shape will be redrawn.
Click again to define the new shape.3.

 

 Scaling Shapes

To scale an object or text by a percentage:

Select the object or objects to be scaled.1.
Choose Edit > Scale/Oversize > Scale and the Scale dialog box appears.2.
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Enter scaling factors for both X and Y.3.
Scaling factors must be positive. Scaling factors greater than 1.0 increase the size of
objects, while factors less than 1.0 decrease the size of objects. To scale the objects
uniformly, enter the same scaling factor for both X and Y. For text, only the X scale is
used.
Click OK and you are prompted to enter a reference point on the object around which4.
to scale.
Click to specify the reference point, and the object is scaled.5.

To scale an object relative to the design units:

Select the object.1.
To replace the original object with a scaled image, choose the command Edit >2.
Scale/Oversize > Oversize.
To place a copy of the selected object (using the size you specify) on the current
entry layer, preserving the original object, choose the command Edit >
Scale/Oversize > Copy & Oversize.
When you select either of these commands, a dialog box appears.
Enter the sizing amount. A positive number increases the size of the object; a3.
negative number decreases the size.

Enter a cutoff angle for mitering corners. Any angle of a polygon smaller than the4.
specified cutoff angle is mitered. Default = 45°.

Make any changes in the dialog box, and click OK.5.

If you choose Oversize in step 2 above, the object is scaled to the specified size.

If you choose Copy & Oversize in step 2 above, a copy of the selected object is drawn on
the current entry layer, at the specified size.

 

 Manipulating Vertices
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Note
To select, move, or delete a vertex, the Vertices select filter must be on (see Using Selection Filters
(usrguide)).

To add a vertex to a polygon or polyline:

Choose Edit > Vertex > Add.1.
Click on a point between two existing vertices, and move the mouse. A flexible line is2.
drawn between the vertices and the cursor.
Click again to specify the new point and the shape is re-drawn.3.

To move a vertex:

Select Edit > Move > Move, click on the vertex, and move the mouse. A flexible1.
line is drawn from the affected vertices to the cursor.
Click again to specify the new location, and the shape is redrawn.2.

To delete a vertex:

Draw a selection window enclosing all vertices that you want to delete.1.
On the toolbar, click the delete button. The shape is re-drawn without those vertices.2.

To delete an arc from a polyline

On the toolbar, click the delete button.1.
Click anywhere on an arc. The arc is deleted and the former endpoints of the arc are2.
connected with a straight line.

 

 Converting a Vertex to an Arc

You can convert any vertex to an arc and specify the desired radius of the arc, with
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respect to the units of the window.

Choose Edit > Vertex > To Arc. You are prompted enter location of the vertex, and1.
a dialog box appears.
Set the radius as desired and click Apply.2.
Click on any vertex that you want to convert to an arc. The vertex is redrawn3.
accordingly.

You can continue converting vertices in this manner using a different radius each
time if desired, but you must click Apply each time you change the radius.
When you are through making these changes, click OK to close the dialog box.4.

 

 Converting a Vertex to a Mitered Edge

You can convert any vertex to a mitered edge and specify the desired length of the
mitered edge, with respect to the units of the window.

Choose Edit > Vertex > Miter. You are prompted enter location of the vertex, and a1.
dialog box appears.
Set the miter length as desired and click Apply.2.
Click on any vertex that you want to convert to a mitered edge. The vertex is3.
redrawn accordingly.

You can continue converting vertices in this manner using a different miter length
each time if desired, but you must click Apply each time you change the length.
When you are through making these changes, click OK to close the dialog box.4.

 

 Moving Shapes or Text to a Different Layer

To move shapes or text to another layer:
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Select the object you want to move.1.

Note
Do not use the Move To Layer command to move ports to a different layer; set the Layer parameter
of the port to the desired layer.

Choose Edit > Move > Move To Layer. A dialog box appears with a list of currently2.
defined layers. Select the desired layer and click OK. The selected object
immediately takes on the color and other display characteristics of the selected layer.

Note
Shapes and text can also be moved to another layer using the Properties dialog box which, can be invoked
by double-clicking on the object, the context-sensitive menu Properties, or with Edit > Properties.

 

 Manipulating Dimension Lines

Dimension lines can be moved and modified.

 

 Moving Endlines

A dimension line can be stretched using the Edit > Move > Dimension Line Endline
command. This is done as follows:

Choose Edit > Move > Move Dimension Line Endline.1.
Move the cross-hairs over the dimension line end that you want to stretch and click.2.

Note
If you have trouble selecting the end of the dimension line, see if the dimension line arrowhead is
visible. If it is not, zoom in and try selecting the end of the dimension line again.

Move the cross-hairs to the desired position and click.3.

 

 Modifying Dimension Lines

To modify the attributes of a dimension line, do the following:

Double-click on the dimension line.1.
The Dimension Line dialog box appears.2.
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Choose the parameter that you want to change from the Select Parameter list.3.
The choices are:
LineLength - The length of the dimension line.
LineOffset - The dimension line vertical offset from the x-axis.
Endline - The height of the end line from the dimension line.
ArrowLength - The length of the arrow.
ArrowWidth - The width of the arrow.
ArrowDirection - The arrow direction. The possible values are inward and outward.
TailLength - If ArrowDir is inward, this represents the length of the arrows' tails.
Layer - The dimension line layer.
TextOffset - The text offset from the dimension line.
TextHeight - The text height.
TextPrecision - The displayed length precision.
TextPosition - The text position in relation to the dimension line. Available choices are
above, below, left, or right.
TextUnits - The unit to use to display distance.
Edit the parameter settings4.
Click OK to save the change and close the dialog box.5.

 Move Ruler Endline

A Ruler can be stretched by moving the endline. To move the endline, follow the steps
below:

From the Layout window, choose Edit > Move > Move Ruler Endline.1.
Select the end of the Ruler.2.
Move the cross-hairs over the Ruler end that you want to stretch and click.3.

 



Schematic Capture and Layout

192

 Moving an Object to the Coordinates 0,0

By default, the coordinates 0,0 are located in the center of the Layout window. You can
reposition an object that you have placed or drawn elsewhere, at the origin.

Choose Edit > Modify > Set Origin. You are prompted, enter origin location.1.
Click the point of the object (for example, pin 1) that you want to position at 0,0 and2.
the object is moved; the specified point is now located at 0,0.

Note
You can use the View All command to bring the object back into view.

 

 Forcing an Object onto the Grid

If an object is offset from the current grid spacing, you can force it to the nearest grid
point. If the selected object is an component with pins, pin 1 is forced to the nearest grid
point.

Select the object.1.
Choose Edit > Modify > Force to Grid. The selected object snaps to the grid.2.

 

 Editing Layout Hierarchy (Flatten)

When you are ready to generate final artwork, you can remove levels of hierarchy. This
process copies all data from the referenced design to the current representation, resulting
in the removal of one level of hierarchy. Repeat this process for each level of hierarchy
you want to delete. When you finish, the design will be intact, but contain no references
that could affect the final design.

Open the top-level hierarchical design.1.
Select an instance.2.
Choose Edit > Component > Flatten.3.
This copies all data from the component to the current representation and deletes the
reference to the subdesign. Note that one level of hierarchy is removed.
Repeat this procedure for each instance you want to flatten.4.
To check that all hierarchy levels have been removed choose Tools > Hierarchy.5.
This should produce an empty report.
Save the design.6.

Note
If you want to remove all levels of hierarchy with one command, choose File > Generate artwork.

 

 Physical Connectivity Engine

The ADS Physical Connectivity Engine enables you to establish electrical interconnects
based on polygon shaped layout artwork and performs interconnect information extraction
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on the fly.
Key features include:

Shape-Based Layout Connectivity (usrguide)
Simplified Vertical Interconnects (usrguide)
Edge and Area Ports (usrguide)
Nodal and Physical Interconnect Verification (usrguide)

 

 Shape-based Layout Connectivity

Shape-based layout connectivity removes the interconnect constraints of wires and traces
and provides the ability to establish electrical connections with polygon based layout
artwork. It also enables the use of custom tailored native interconnect configurations
exhibiting electrical connectivity.

This functionality gives you the flexibility to start a design either in schematic or layout,
implement custom tailored layout interconnects (beyond simple traces), perform on the fly
layout interconnect information extraction, and back annotate custom tailored
interconnects to the schematic.

Other benefits include more robust design crosschecks between layout and schematic;
open connections, nodal and components' values mismatches, zero width wires in layout,
overlaid components, layout shapes touching but belonging to different nodes,
polygon/component overlapping, and non pin to pin connections. Significant
improvements to design connectivity validation include polygonal shapes touching or
overlapping but belonging to different nodes or not making a pin to pin connection.

The physical connectivity engine now takes care of potential connectivity problems that
went unchecked previously, mainly due to the lack of arbitrary layout artwork connectivity
information. For more information, refer to Creating Interconnects with Shapes (usrguide).

 

 Simplified Vertical Interconnects

As polygon shapes now exhibit electrical connectivity characteristics resembling real world
conditions, vertical electrical connections are possible without requiring pre-built via
components. Designers are no longer limited to the availability of pre-built via
components in design kits (for MMIC designs) or component libraries (for PC board and
module design) to establish vertical electrical connections. You can also use a component
with a single edge area pin. See Creating Interconnects with Shapes (usrguide) for more
information.

 

 Edge and Area Ports

Another enhancement to ADS Layout connectivity is the expansion of pins beyond the
point pin concept to include edge and area ports. This capability is most useful for design
kit and component library developers, because it allows them to define unique edge and
area ports to their layout components, however simple or complex they may be.
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Edge and area ports allow artwork connectivity using an edge (polyline or arc) or area
(polygon, rectangle, circle, or path) as the target. They are mainly used for ensuring
electrical connectivity in a layout. The layout can then be used to generate a schematic.

Edge and area ports support schematic/layout synchronization. They would be used in a
layout footprint for a component that has both a schematic and a layout representation.
When such a component is used in a hierarchical design, there is now added flexibility
because contact can be achieved anywhere on the edge or area.

For information on using edge and area ports, see Designating Edge and Area Ports
(usrguide).

 

 Nodal and Physical Interconnect Verification

The physical connectivity engine also enhances the ability to perform robust interconnect
verification. Because all polygonal shapes in layout carry electrical connectivity
information, you can perform a significant number of verification checks, including nodal
and physical connectivity checks, at any point in the design process. For more
information, refer to Checking Connectivity Information in Layout (usrguide).

Nodal interconnect check enables you to check the design's nodes in schematic and layout
(the definition of node is understood as a pin/port and all touching interconnects,
excluding design components, whether they are active or passive.) This feature is very
useful for performing schematic/layout nodal cross-probing to verify the accuracy of their
designs as simple wires in schematic transform into elaborate physical interconnects. For
more information, refer to Highlighting Interconnects (usrguide) and Cross-Probing
(usrguide).

Physical interconnect check provides the ability to highlight all shorted (touching) metal in
multi layer hierarchical designs. This enables an easy to perform interconnect integrity
check for a design's physical layout, which identifies what a given metal trace, path,
polygon, or transmission line touches. For more information, refer to Highlighting
Interconnects (usrguide).

These capabilities can help microwave designers check the validity of their designs'
physical as well as nodal connectivity without overlooking important high frequency
attributes. The physical connectivity engine accomplishes this by extracting physical and
nodal connectivity information upon opening a design (i.e. during design loading into
layout environment) as well as while editing a design layout (i.e. on the fly extraction).
Because connectivity extraction is performed in real time, large design files may take
significantly longer to load into the layout environment. The amount of time required
depends on hardware configuration, and upon available memory (where connectivity
information is stored).

 

 Usage Notes

The Physical Connectivity Engine requires a proper definition of the shape and pin1.
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layer binding. Otherwise unwanted connections and false connectivity warning
messages may be generated.
When loading a large layout (i.e. reticle layout), you might observe a delay. This2.
delay is caused by the real-time extraction of the layout connectivity information.
For these reasons, you may need to disable the Physical Connectivity Engine. For
more information and step-by-step instructions, refer to Disabling Layout
Connectivity Features (usrguide).

 

 Connecting Layout Components

Regardless of how you connect components, you should turn pin snapping on before you
begin (Options > Preferences > Grid/Snap > Pin). Keep in mind that while it doesn't
always cause performance problems, the intersection snap mode is the slowest of all snap
modes so you should use this mode only when necessary. For more information, refer to
Changing Grid and Snap Settings (custom) under the section on Setting Layout Options
(custom) in the Customization and Configuration (custom) documentation.

 

 Checking Connectivity Information in Layout

For details on how to handle synchronized designs, see Handling Synchronized
Designs (usrguide)
For details on how to handle Unsynchronized designs, see Handling Unsynchronized
Designs (usrguide)

 Working with Transmission Lines

For some types of design work, designing from the layout can save considerable time. This
is especially true in designs with complex transmission lines. In layout, transmission lines
can be created either by placing transmission line elements manually or by inserting
traces and converting them to transmission lines later. Regardless of how you create
them, there are a number of ways you can edit them.

 

 Splitting a Transmission Line

You can replace one transmission line element with two identical elements.

Choose Edit > Transmission Line > Split Transmission Line.1.
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On the transmission line, and click on a reference point.2.

 

 Replacing a Transmission Line Element

You can replace one transmission line element with two identical elements and a tee.

Select Edit > Transmission Line > Tap Transmission Line. A Tap Length dialog1.
box appears where you specify the length of the tee element.
Type a number for the tap length, and click OK.2.
Either an MTEE or STEE is inserted, depending on whether an MLIN or SLIN was
tapped.
On the transmission line, click on a reference point where you want the tee element3.
inserted.

Hint
The third pin of the tee will be placed on the transmission line edge closest to the cursor.

 

 Stretching a Transmission Line

Choose Edit > Transmission Line > Stretch Transmission Line.1.
Click on a node of the transmission line, and move the pointer away from the2.
element. A flexible dashed line appears and moves with the pointer.
Click on a second reference point (where you want the element to stretch to). The3.
element is now changed to the new length.

 

 Squeezing a Transmission Line While Maintaining its Length

You can modify an existing transmission line to squeeze it into a smaller space, specifying
several characteristics in the process, such as corner type, lead length and minimum
spacing.
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You can adjust any or all of the following characteristics as needed:

Corner Type - Select from Mitered, Square, Curve

Ending Direction - The direction (clockwise or counterclockwise) in which the last two
segments connected to the ending lead are drawn

Minimum Spacing - The minimum spacing between the parallel trace segments
Mitered Corner Cutoff Ratio (%) - The desired cutoff ratio for the corner type Mitered
Curve Radius - The desired curve radius for the corner type Curve
Lead Length - The length of the starting and ending segments

To squeeze a transmission line into a smaller space while maintaining its length:

Choose Edit > Transmission Line > Squeeze Transmission Line Keeping1.
Length. In the dialog box that appears, set the options as desired and click Apply.
You are prompted to enter the reference location. Click the pin at one end of the2.
transmission line and you are prompted to enter the offset location.
Move the pointer toward the other end of the transmission line. When the ghost3.
image of the transmission line represents what you want, click to draw the modified
transmission line.
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 Editing Paths, Traces and Wires

This section covers the following topics:

Converting Traces to Paths (usrguide)
Converting Paths to Traces (usrguide)
Changing Attributes of an Existing Path/Trace/Wire (usrguide)
Stretching a Wire (usrguide)
Converting a Wire to a Trace (usrguide)

 Converting Traces to Paths

Unlike converting traces to transmission line elements, where the conversion is one-way,
you can change paths back into traces. Use the following steps to change a trace into a
path:

Select the desired trace.1.
Choose Edit > Path/Trace/Wire > Convert Trace to Path.2.

 

 Converting Paths to a Traces

Unlike converting traces to transmission line elements, where the conversion is one-way,
you can change traces back into paths, as follows:

Select the desired path.1.
Select Edit > Path/Trace > Convert Path to Trace.2.

 

 Changing the Attributes of an Existing Path/Trace/Wire

Select the desired path/trace/wire.1.
Choose Edit > Properties. The information about the selected path/trace/wire2.
appears in the Properties dialog box.

Width - Specify the width (in layout units).
Corner Type - Select Mitered, Square, or Curve.
Miter - Mitered corner cutoff ratio (%). Set a percentage of cutoff; the larger the
number the more of the corner is cut off.
Curve Radius - Specify a curve radius.
Fill in the appropriate fields, and click OK.3.
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 Stretching a Wire

You can change the shape of an existing wire by stretching an edge (a segment between
two vertices).

Choose Edit > Move > Move Edge.1.
Click once on the edge you wish to stretch. A ghost image moves and changes as you2.
move the cursor, showing how the shape will be redrawn.
Click again to define the new shape.3.

 

 Converting a Wire to a Trace

If the separation between components is intentional, you can convert a wire to a trace.

Select the wire and choose Edit > Properties.1.
In the dialog box that appears, change the characteristics as desired, and click OK.2.

Hint
Because traces have width, if the wire you are converting to a trace has a bend, the shortest
segment that is part of that vertex cannot be shorter than 3 × w/4, where w is the width for the
trace, as specified by Path Width.

 

 Editing Component Text

By default, when you place a component in layout, its Instance Name (a unique ID) is
automatically placed with it on the silk_screen layer (The Component Name is placed on
the silk_screen2 layer, which is not visible by default.) Instance Names are automatically
assigned but you can change them as long as you maintain unique IDs for each instance.

To change the Instance Name for a given component, use either of the following methods:

Change it using the on-screen editor
Change it in the Component Parameters dialog box (double-click the component or
choose Edit > Component > Edit Component Parameters )

To change component text attributes (font and size):
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Select the component and choose Edit > Component > Component Text1.
Attributes.
Change the attributes as desired and click OK.2.

 

 Using Boolean Logical Operations

In the Layout window, you can insert onto any destination layer polygons that are the
result of comparing the contents of two layers. In effect, the material you select on the
source layers is copied to a destination layer according to logical rules.

Use the following steps for any of the logical operations described in this section:

Ensure that the source layers and the destination layer are not protected (Options >1.
Layers).
Choose the command Edit > Boolean Logical.2.
In the dialog box that appears, use the drop-down lists to indicate the two source3.
layers, the operation you want performed, and the destination layer. Except for DIFF
, it makes no difference which source layer you identify first. See Edit > Boolean
Logical > DIFF (usrguide).

Select whether you want the logical operation to apply to shapes that you select, or4.
to all shapes on the two source layers.
If you choose Selected Shapes, you must select at least one object on each of the
two source layers.
For Boolean operations across the hierarchy, when an instance is selected, all objects
in it will also be selected.
Select whether you want the original shapes deleted.5.
In a hierarchical design, only the shapes at the top level of the design will be deleted.
Traces are not deleted from the design but are used to generate boolean results.
Click OK to perform the selected operation on the shapes.6.

Hint
To exclude a shape from a Boolean operation, select the shape, open its Properties dialog box (Edit
> Properties), and add the following property in the Custom tab.
Name=DB_NO_BOOL, Value= 1, Value Type= Integer

 

 Edit > Boolean Logical > DIFF

Use DIFF to create (on the destination layer) one or more polygons that are a copy of
everything that you select on the first source layer minus the material you select on the
second source layer that is in the same x, y location. In effect, the system copies the
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material that you select on the first source layer, and then subtracts from it the material
that you select on the second layer.

In the following examples, the result on the destination layer appears to the right, beside
the source layers. This does not happen in the program, where objects on the destination
layer appear in the same x,y location as in the source layers.

 

 Example 1

In this example, the cond layer is specified as the first source layer. The program first
copies the rectangle on that layer. Then (in effect) the circles on the cond2 layer (the
second source layer) are subtracted from it. The result is a polygon, as shown.

 

 Example 2

In this example, the cond2 layer is specified first. The system first copies the circles on
that layer. Then (in effect) the rectangle on the cond layer is subtracted from them. Only
parts of the two circles at the top of the cond2 layer appear on the destination layer.
Everything else on that layer lies within the boundaries defined by the rectangle on the
cond layer.

A practical application of the DIFF option would be to create holes on a layer. This would
be done as follows:

Place all shapes on the Cond layer.1.
Place all holes on the Hole layer.2.
Choose Edit > Boolean Logical > DIFF.3.
In the Boolean dialog box, go from left to right and make the following menu4.
selections: Cond, DIFF, Hole, and Cond.
In the Apply To section, select All Shapes.5.
Select the Delete Original button.6.
Click the OK button.7.
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 Edit > Boolean Logical > AND

Use AND to create (on the destination layer) one or more polygons that are a copy of only
those things selected that are in the same x,y location on both source layers. The system
deletes material that appears on only one source layer. In the following example, the
destination layer contains only the parts of the circles on the cond2 layer that are inside
the boundaries defined by the rectangle on the cond layer. The upper parts of the top
circles are in a region where there is nothing on the cond layer, so they do not appear on
the destination layer.

 

 Edit > Boolean Logical > OR

Use OR to create (on the destination layer) one or more polygons that are a merged copy
of everything selected on either source layer. In the following example, the destination
layer includes (in a single, merged polygon) the rectangle on the cond layer and all of the
circles on the cond2 layer. This includes the two circles at the top of the cond2 layer, even
though parts of them are outside the boundaries defined by the rectangle on the cond
layer.

 

 Edit > Boolean Logical > XOR

Use XOR to create (on the destination layer) one or more polygons that are a merged
copy of everything selected that appears in any x,y location on only one source layer.
Anything that appears on both source layers is, in effect, deleted.

In the following example, the destination layer is similar to the first DIFF example, except
that the polygon includes the parts of the two circles at the top of the cond2 layer that are
outside the boundary defined by the rectangle on the cond layer. These are included
because they appear only on the cond2 layer.
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 Creating Clearance

Choose Edit > Create Clearance and use the Create Clearance dialog to define clearance
between ground planes and shapes on multiple mask layers.

In a layout window, with shapes on different layers, choose Edit > Create1.
Clearance

Note
To display shapes as outlines, select Edit from the Layers menu, then select Outline from the
Shape Display drop down menu.

The Select Planes dialog will prompt you to select the ground plane shapes. Hold2.
down Ctrl to select more than one object. Click OK to continue, the Create Clearance
menu will appear. If no objects were highlighted, an error dialog will be displayed.

In the Create Clearance menu select the Clearance Layers using the arrow buttons,3.
select which shapes to Apply to using the radio buttons, and enter the Clearance
Value in layout units. Click OK.
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The resulting layout will reflect the clearance value selected.4.

 

 Layout Command Line Editor

Note
This is a beta-level feature subject to change in future versions of ADS.

Layout Command Line Editor can be used to edit the designs by running command in this
window. Layout command Line Editor is an add-on tool of Layout window. It must be
enabled before you can see this menu option in the Layout Window. Follow below steps to
enable it:

From the ADS Main window, choose Tools > Manage ADS AEL Addons.1.
Select the checkbox Layout Command Line Editor.2.
Click Close and restart ADS. After restarting ADS, open the Layout window. Layout3.
Command Line Editor menu can be seen under the Add-Ons menu.

There are two versions of this window:
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Layout Command Line1.

Layout Command Line Lite2.

Note
Click the Help button to see the list of commands that you can in this command line editor.

This tool also has following utility menu items which can be used to perform an operation
with the simple mouse clicks:

Pin Numbers: Toggle the display of pin numbers in the design.
Edge Select Mode
Inside Select Mode
Vertex Select Filter
Cycle Custom Toolbars
Show All Toolbars
Reset Toolbars
Show Origin
Print All
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 Setting Layer Preferences
Layers and its Display Properties are defined at the Library level. For more information on
layer definitions, see Layer Definitions (usrguide).

If you want to make temporary changes to the Display Properties such as turning on or off
the visibility of a layer or changing its color, you can do this with the Layer Preferences
window. Any changes made using the Layer Preferences window are saved in your
workspace. This allows you to make changes even if the layers you change which are
defined in a read-only library. If you are sharing a library with other workspaces this
allows you to make changes that only affect your current workspace.

 Layers Preferences Window

Choose Options > Layer Preferences... from a Schematic or Layout window to open the
Layers Preferences window, . The window includes the layers obtained from the library
associated with the current design. If you select a different schematic or layout window,
the layers shown in the Layer Preferences window will change to reflect the new current
design.

The Current Entry Layer is displayed in top left corner of this window.
The current library name (from which the window obtain its information) is displayed
in the bottom left corner of the window.
Each layer is displayed as a row in the table. Each layer has several attributes that
can be modified as per need basis. When Layer Preferences window is opened for
first time it displays first four columns only. These represent the four most common
attributes. You can expand the window to display other columns.
There are several buttons that perform different actions on the layers or window.

First four table columns:

Name - This shows a layer and purpose name. Click on this column and the
layer/purpose selected becomes the Current Entry Layer.
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Fill - This shows how a shape is drawn that uses the layer/purpose. Click on this
column and the layer/purpose selected becomes the Current Entry Layer.
Sel - Check or uncheck the select box to determine if shapes using a given display
property are selectable in a layout, schematic, or symbol view.
Vis - Check or uncheck the visibility box to determine if shapes using a given display
property are visible when draw in a layout, schematic, or symbol view.

To view rest of the columns, click More>>.

Additional table columns:

Shape Display - Choose if the shapes are drawn using an outline, filled, or both
filled and outlined.
Line Style - Choose the line style that will be used to draw the outline of a shape.
Color - Click the color cell to define a 24 bit color.
Trans - Click the trans cell to define a transparency ranging from zero (completely
transparent) to 255 (completely opaque).
Pattern - Click the pattern cell to select one of many predefined patterns.

List of buttons and the action associated with them:

All Selectable - Sets all layers to be selectable.
All Visible - Sets all layers to be visible.
All Shapes - Sets the Shape Display of all layers.
All Trans - Sets the transparency of all layers.
All LineStyles - Sets the Line Style of all layers.
None Selectable - Sets all layers to be not selectable.
None Visible -Sets all layers to be not visible.
Reset - Changes all Display Properties back to the values defined in their library.
Options - Enables you to select the following:

Open With Layout Window—If selected, the Layers window always opens with
the layout window unless the Layers window is already open. This menu item is
selected by default.
Open With Schematic Window—If selected, the Layers window always opens
with a schematic window unless the Layers window is already open. This menu
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item is deselected by default.
Auto Redraw Design Window—If selected, refreshes the current layout or
schematic window each time the visibility or selectability of any layer is changed
within the Layers window. This menu item is selected by default.

Help - Displays this page.
More>> - Makes the window wider to see all the columns.
<<Less - Makes the window narrower to see only first four columns.

 How Layer Preferences are Stored

The changes made through the Layers Preferences window are stored in the workspace
file named:

<library name>.layerprf

Where,

library name is the library name that a layer's Display Property was defined in. This
file contains deltas that the current workspace enforces against the layer definitions
that are contained in the library that defined the Display Property.
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 Design Synchronization
Since the schematic and layout information is contained in different views of the same
cell, they are referred as schematic view or layout view of a cell. ADS can maintain
equivalent views (representations) of a cell. You can make changes to one view and then
synchronize the other view with it, ensuring that these views are equivalent. The cell view
you issue the synchronization command (Generate/Update) from is referred to as the
source view, and the cell view that is automatically modified to match the source view is
the target view.

The Layout menu (in the Schematic window) contains different commands that enable you
to generate a layout from the schematic and to troubleshoot and modify your approach
with respect to components that did not generate in the expected manner. An equivalent
set of commands can be found on the Schematic menu (in the Layout window) for
generating a schematic from a layout, because the synchronization process is bi-
directional.

 The Synchronization Process 

When you synchronize two cellviews, the program starts with a component in the source
view and modifies or creates an equivalent component in the target view. The process
continues by visiting each component connected to the component in the source view and
then processing each connected component in the same manner. The process continues
until there are no more connected components in the source view. The synchronization
process can be fully automatic or incremental. If artwork exists for all schematic
components, a layout of all connected components can be generated in one step.
However, if any components do not have artwork associated with them (these can be
represented by a generic artwork placeholder), or the layout has components that do not
connect by abutment (typical in RF designs), the layout can be created incrementally. This
is done by interactively placing components one at a time or a group at a time, then
connecting them using traces. In addition, there is a dual placement mode that allows
interconnected components to be automatically placed in the other view during insertion
mode.

Hint
If you select a starting component, you can specify its initial position and orientation in the target view. In
this case, only the components connected to the starting component will be processed. If you do not
specify a starting component, each set of connected components in the source view will be processed. In
this case, the initial positions of the components in the target view will be determined either by their
connections (in the case of Update) or arbitrarily (when generating new components).

Important
Design Sync does not support more than two components connected to a node. In some cases, there may
be many instances where a capacitor or resistor are in parallel with the microstrip. These cases need to be
ignored to achieve the correct layout. In cases where more than two components connect to a node,
either deactivate the components or select the components and choose Edit > Component > Edit
Component Artwork and set the Artwork Type to Generic or Null Artwork.

Although this process is bidirectional, the first part of this section describes the process
from the perspective of generating a layout from a schematic. Details related to using this
process in the other direction are covered under the section, Generating a Schematic
(Layout-driven Design).
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In general, your layout generation will be far more successful if you perform a prescribed
series of checks prior to generating the layout:

Identify schematic components without artwork and create/assign it.
Verify that schematic tee junction components are used where necessary.
Verify that schematic step or taper components are used where necessary.
Ensure schematic components are oriented correctly.
Establish preferences for: pin/ground size, layer for generic artwork, wire extensions
and component text, and the size and font for component text.

Hint
You can select an item in the Layout or Schematic window at any time and highlight its equivalent
item in the other view. Choose Layout (or Schematic) > Show Equivalent Component. Click an
item. The corresponding item in the other cellview is highlighted.

 

 Synchronization Modes

The synchronization can be complete or incremental and can be done to and from a
schematic or layout.

Generate Update Place Component

Place all activated components, including those
with no artwork, connected to the starting
component.

Update a previously
generated design by
placing components that
have been modified.

Place the items that don't yet
have counterparts in the target
view.

Components with fixed location status are not
moved.

Components with fixed
location status are not
moved.

Use the "Single Representation"
component placement mode.

Components that are not placed in the other
view are highlighted.

 "Wire guides" show connectivity
in the other view.

Any component can serve as the starting point
for which the location and orientation can be
specified. Leave the starting component
unspecified to generate/update the entire view.

 Use the "Options > Variables";
command to override the default
resolution path for parameter
references.

 

 Working with Hierarchical Designs

When working with hierarchical designs, the best approach is to start with the subnetwork
that represents the lowest level in the hierarchical design and go through the checklist
just mentioned, then generate the layout for that particular subnetwork. Once you are
satisfied with the results, move up to the next level in the hierarchy and repeat the
process. When you are finished with all the subnetworks, repeat the process for the top-
level design.

When generating artwork for a subnetwork that has one or more parameters that refer to
variables or instances defined in a higher level design, you must identify the top design in
the hierarchy. If you want to generate artwork that corresponds to a particular path in the
hierarchy you can also specify the path from the top design down through the hierarchy
(via Instance Name) to the subnetwork.

To specify the location of the actual variable values, choose Options > Variables from



Schematic Capture and Layout

211

Schematic or Layout window.

Top Design in Hierarchy - Type the name of the top-level design in the hierarchy
of the current design.

If the top design is in a different library from the current design, specify its
name in the form libraryName:cellName.

Component Path (Instance Names) to Variable Values - Use the following
guidelines to determine the appropriate path:

Normally leave this field blank. The layout of the top design will be correct. The
layouts of the subdesigns are used as templates to make the parent designs.
If you need to make a particular subnetwork look exactly like the subnetwork of
a given instance path then specify a path starting with the Instance Name
(appearing in the top design) that must be pushed into to find the current
design, followed by the name of the next instance that must be pushed into to
find the current design, etc. The Instance Names must be separated by periods
(for example, X1.X2).
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 Identifying Components Without Artwork

Before you generate the layout, you should check for any components without pre-defined
artwork and either create it or associate an existing artwork with the component.

To identify components without artwork:

From the Schematic window, choose Layout > Show Components With No1.
Artwork. All components that have no artwork associated with them are highlighted
and a confirmation dialog box appears asking if you want to choose artwork for the
highlighted items.
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Click Yes and a dialog box appears displaying the Instance Name of one of the2.
components without artwork and offering a choice of artwork types.

Hint
To go back later and change the artwork association for a given component, select the component
and choose Edit > Component > Edit Component Artwork.

Select the desired Artwork Type and Name and click Apply to make the artwork3.
association.
Choose Default to display in the dialog box, the default artwork specified in the
create_item() definition for the component.
Choose Fixed to specify and use another design file to represent the artwork for the
component.
Choose Generic to create a component with pins and a box with a red X as an
artwork placeholder.
Choose Null Artwork to create a component with just pins and no artwork.

Hint
If you do not want a lumped component to occupy layout space, use the Null Artwork type. If you
want a lumped component to have pads, choose a component from the Lumped With Artwork
component palette.

Repeat this process until all artwork associations are made.4.

 

 Using TEE Junctions in a Schematic

When multiple transmission lines form a tee junction, one of the TEE components is
required.
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If three layout components are joined without the use of a tee component, as in the
incorrect diagram, they will be connected with wires in the generated layout. The length of
these wires is determined by the setting in the Preferences dialog accessed through the
Generate/Update dialog box. The use of tee components is not only important for layout,
but is also important for proper simulation of interconnected transmission lines.

 

 Using Steps and Tapers in a Schematic

You must use step or taper components to introduce changes in transmission line widths.
A common error in microstrip and stripline layout is to put two different width
transmission lines together without a transition component, as shown in the illustration
that follows.

To account for the discontinuity, you must insert either a taper or step component
between the two components.

Step components do not introduce additional length, but do ensure that the
discontinuity is accounted for in simulation.
Taper components do have length. They should be used to describe any gradual
change in transmission line widths.
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There are a number of other discontinuities that can be included in simulation such as
gaps and end effects. For a list of components relevant to your design, refer to the
Introduction to Circuit Components (ccsim) documentation.

 

 Checking Schematic Component Orientation

The correct orientation of all schematic components is required to successfully generate a
layout. Notice the difference in the resulting layout when the orientation of Taper2 (lower
illustration) is incorrect.

Pin 1 is always identified by a small tick mark, but you can see all pin numbers by turning
on Pin Numbers through Options > Preferences > Pin/Tee.

 

 Establishing Preferences
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There are a number of miscellaneous settings you can control for the generation of a
layout:

The size for pins/grounds
The layer on which generic artwork, wire extensions and component text should be
drawn
Component text font and size

To adjust these options for the design you are about to generate or update:

From the Schematic window, choose Layout > Generate/Update Layout >1.
Preferences (The remaining fields in this dialog box are described in the section,
Generating a Layout).
Change any or all options as desired and click OK.2.

 

 Generating a Layout

After performing the preliminary checks, and taking the recommended action based on the
results, you are ready to generate a layout. The transmission line shown next is used to
illustrate the process.

To automatically generate a layout from a schematic:
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Open a Layout window, and from the Schematic window choose Layout >1.
Generate/Update Layout.
In this example, the Starting Component field shows P1 (port 1). This field is initially
empty, but can be changed by clicking on a component in the Schematic window. In
this case, we already clicked on P1. The Equivalent Component field is empty,
indicating that the equivalent has not yet been created (in the layout). In addition, all
of the components in the schematic are highlighted, indicating that they all need to
be generated.

Hint
If choosing Generate/Update Layout causes an item to be highlighted, the highlighting indicates that
the item needs to be generated, regenerated, or reconnected.

Click OK and the layout is generated, as shown in the initial illustration.2.

The details of the Generate/Update dialog box are as follows:

Starting Component - The program starts with this item, moving through each pin to
the next connected component, until all interconnected components with artwork are
generated or updated. Click an item in your design to designate it as the starting
point for the design synchronization process. If you leave this field empty, the
program will pick an appropriate starting component and continue until the entire
design has been processed.
Equivalent Component - Informational only. The counterpart of the item in the other
view appears in this field (when one exists).
Status - Informational only.

not created - The equivalent of the starting component has not yet been created
in the target view.
positioned - The starting component has been positioned in the layout.

X-Coordinate, Y-Coordinate, Angle - If you select a component in the Schematic, and
the equivalent has been generated, these fields show the coordinates for the
equivalent item, including angle. If the equivalent has not been generated, accept the
default location (0,0) to allow the program to place it or type the desired coordinates.
The angle of rotation in the source view is displayed by default. Accept this or change
it as needed.
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In the example above, the pin angles are for the schematic view, not the layout view.
The program generates a layout by creating artwork for each component in the
schematic. If you start the process from a schematic, an artwork component is
placed at the given X,Y location with the given angle. Each subsequent component is
placed at an angle that is determined by the angle of the connecting component, plus
the angle specified for that pin.

In Example A above, the angle of M1 is 0, and the angle of its pin 2 (on the
right) is 0, so M2 is placed to the right of M1 at 0 degrees.
In Example B, for M3, pin 2 (on top) is at 90 degrees, so M4 is connected at 90
degrees.
In Example C, M3 is placed at a 20 degree angle, so M4 is placed at 110 degrees
(90 + 20).

For all artwork supplied in ADS, the angle of each pin is preset to generate a reasonable
topology. However, it may be necessary to flip and rotate components to get a better
layout; this will have no effect on your schematic.

Options
Delete equivalent components in Layout that have been deleted/deactivated in
Schematic - Select this option to force the design synchronization process to
automatically delete items in the target view that do not appear in both views.
This forces one view to match the current view.
Show status report - Select this option to display a status report after design
synchronization. This report includes the number of items modified, how many
items processed, and the name of any trace subnetworks created, if automatic
trace conversion was specified.
Fix starting component's position in Layout - When you select this option, the
starting component's position is set to fixed so that it will not be changed
automatically during subsequent synchronizations (however, you can still
manually move it).
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Fix all components in Layout during Generate/Update - Select this option to
keep any existing components in the Layout (Schematic) in their current
locations. If you do not select this option, the synchronization process will move
existing components to ensure they are adjacent to any newly placed
components. This option is most useful when you have adjusted the position of
components to meet your layout or schematic goals and would now like to
synchronize other changes without disturbing the existing layout or schematic.

Hint
Use the Display tab in the Preferences dialog box (Options > Preferences) to define the
display color for a fixed component to help you identify quickly any components with fixed
positions.

Preferences - Provides access to a variety of settings to assist you in generating the
desired schematic or layout.

From Layout to Schematic
Length in X-Direction - The length of horizontal wires drawn between schematic
components when their layout equivalents connect by abutment.
Length in Y-Direction - The length of vertical wires drawn between schematic
components when their layout equivalents connect by abutment.
Component Text Font/Size - Font and size used for the component text.

Variables - Used for identifying a design/instance that contains the actual values of
variables being referenced by the subnetwork (for which you want to generate a
layout), when the design containing those variables is either not related
hierarchically, or is related hierarchically, but is found at a lower level (than the
subnetwork) in the hierarchy.
Trace Control - Provides access to a dialog box for specifying details for interpreting
traces in layout.

Simulate As - Select one of the following: Transmission line elements, Single
transmission line element (then specify that element in the field provided, MLIN
by default), Nodal connection (short).
Element Set - Select one of the following: Microstrip, Stripline, Printed circuit
board.
Substrate References - The Instance Name of the substrate item to be
referenced when simulating traces as transmission lines.
Element Set Substrate Reference

Microstrip MSUB

Stripline SSUB

Printed circuit board PCSUB

From Schematic to Layout
Length in X-Direction - The x-direction length for connecting wires.
Length in Y-Direction - The y-direction length for connecting wires.
Component Text Font/Size - Font and size used for the component text.
Generic Artwork Size - The length of the box (with an X drawn through it) drawn
in layout when there is no artwork associated with the schematic component.
Pin/Ground Size - The size of the pin/ground symbol (an arrow) drawn in the
layout view.
Entry Layer - The entry layer on which generic artwork and wire extensions
should be drawn.
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 Placing Unplaced Components

Unplaced components are items that do not have counterparts in the other view. When a
component without artwork, such as a series capacitor, is encountered during the
synchronization process, the synchronizer places a generic artwork box in its place. Once
you create/assign artwork to these components, you can initiate the synchronization
process again or you can individually place these remaining components one at a time,
interactively, in the other view:

By selecting Layout > Generate/Update Layout again and using either the first
unplaced item as the starting item, or selecting any other component that already
exists in the layout. This mode automatically positions artwork by pin abutment.
By using the Layout > Place Components From Schem To Layout command (this
is the preferred method for RF designs). This mode allows any distance between
components.

The Place Components From Schem To Layout command enables you to interactively
place items from one view to the other. When you place items in this fashion you don't
have to worry about setting the parameters. The instance placed in the target view will
have the same parameters as the source instance.

To locate unplaced items:
Choose Layout > Show Unplaced Components. The unplaced components are
highlighted.

To place an unplaced component:

Choose Layout > Place Components From Schem To Layout and click any of the1.
highlighted components you want to place.
Move the pointer to the Layout window. A ghost image of the item, as well as wire2.
guides identifying the connectivity point(s), tracks with the pointer. Position the item
and click.

In the illustration that follows, one of dotted lines represents the wire guides that track
with the artwork and the pointer.

 Using the Design Differences Dialog Box

The Design Differences dialog box enables you to better manage components between
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ADS Schematic and Layout. Using the Design Differences dialog box, you can select a
design and quickly identify differences between the schematic and layout in your design.
Upon identifying these differences, the dialog includes an action-oriented list which
enables you to manage:

Components not in layout
Components not in schematic
Parameter Differences
Nodal Mismatches

To access the Design Differences dialog box from a Schematic window,

Choose Layout > Place Components From Schem to Layout or choose Layout >
Design Differences. The Design Differences dialog box appears.

To access the Design Differences dialog box from a Layout window,

Choose Schematic > Place Components From Layout to Schem or choose
Schematic > Design Differences. The Design Differences dialog box appears.

Components not in layout
Components that are in your schematic, but not in your layout, are identified in the Design
Difference, Components not in layout expandable list. Clicking a component in this list will
highlight the component and enable you to quickly identify the component in the
schematic. Once selected, the component is in placement mode which enables you to
move the cursor over the layout and place the component by clicking your mouse in the
desired location on your layout.

If you right click your mouse, a popup menu appears with the following options:

Place Unplaced Component - Similar to placement mode described above
Delete Component - Deletes the component from the schematic
Details - Provides more detailed information about the missing component

Components not in schematic
Components that are in your layout, but not in your schematic, are identified in the Design
Difference, Components not in schematic expandable list. Clicking a component in this list
will highlight the component and enable you to quickly identify the component in the
layout. Once selected, the component is in placement mode which enables you to move
the cursor over the schematic and place the component by clicking your mouse in the
desired location on your schematic.

If you right click your mouse, a popup menu appears with the following options:

Place Unplaced Component - Similar to the placement mode described above
Delete Component - Deletes the component from the layout
Details - Provides more detailed information about the missing component

Parameter Differences
Click this option to highlight the component in both the layout and schematic and enable
you to quickly identify the component in question and correct the parameter differences.

If you right click your mouse, a popup menu appears with the following options:
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Use Schematic Value <parm name> = <value> - Assign the schematic value to the
layout component parameter
Use Layout Value <parm name> = <value> - Assign the layout value to the
schematic component parameter
Details - Provides more detailed information on the parameter mismatch

Nodal Mismatch
Click this option to highlight the unconnected components in both schematic and layout
enabling you to quickly identify the components in question and correct the mismatch.

If you right click your mouse, a popup menu appears with the following option:

Details - Provides more detailed information on the nodal mismatches

Note
Due to system limitations, layout components that refer to items on schematic could possibly be out-of-
sync with respect to the schematic and not be in the Design Difference list (includes components
referencing MSUBs, SMT_Art and variables).

Auto Zoom

Component placement (not in layout or schematic) - Center the component in the
window; zoom out if necessary. No change for the schematic/layout window without
the component.
Parameter mismatch - Center the component with parameter mismatch in the
schematic/layout windows; zoom out if necessary.
Nodal mismatch - Center the components with nodal mismatch in the
schematic/layout windows; zoom out if necessary.

Auto Update

If Auto update is active - The Design Differences dialog box will automatically update
as the designs are edited.
If Auto update is disabled - The Design Differences dialog box will mark the fixed
items in the list. Click Update to clear corrected items from the list.

 

 Fixing and Freeing Component Positions

All items in the Schematic and Layout windows have either a fixed or free status
associated with their position. If an item's position is fixed (in the target view), then it
cannot be repositioned automatically by the program during the design synchronization
process. If an item's position is free, then the program may reposition that item.
Understanding the basic behaviors involved will help you in manually creating designs, as
well as generating one view from another:

Items manually placed in the Schematic window are fixed. If you make changes to
the layout and update a schematic containing fixed items, the fixed items retain their
positions but may be rewired to maintain connectivity.
Items generated in the Schematic window during the design synchronization process
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are free. However, if you manually move an item in the schematic, the program
automatically sees that item's position as fixed and will not reposition it on
subsequent synchronizations.
Items placed in the Layout window, either manually or during the design
synchronization process, are free and should remain that way. However, occasionally
you may have critical sections or completed sections of your layout that you do not
want repositioned by the program. In this case, you can explicitly set these items as
fixed. Unlike moving items in the Schematic window, moving items in the Layout
window does not change their free status.
Items placed with the Place Components From command are fixed components and
maintain the orientation angle of the source view when you place them in the target
view.
Items placed in either view during the design synchronization process, maintain the
orientation angle of the source view if the item is fixed in the source view.

The following commands (found on the Layout and Schematic menus) can help you
identify and change the fixed versus free status of a component, relative to the window
from which you issue the command:

Show Fixed Components - Highlights all components whose status is fixed.
Fix Component Position - Prevents a component from being repositioned
automatically by the design synchronization process.
Free Component Position - Allows a component to be repositioned automatically by
the design synchronization process.

 

 Component Highlighting

After choosing Layout > Generate/Update Schematic, all components that will be
generated or regenerated during the design synchronization process will be highlighted.
Components that meet one or more of the following conditions will be highlighted at this
point:

Schematic components without a layout equivalent.
Components where one or more parameter values have been updated since the last
time the components were synchronized.
If the component is hierarchical, components where the sub-design has been
modified since the last synchronization.
Components connected to a component that has been modified since the last
synchronization.
Components which use variables or expressions for one or more parameters.
If the component is hierarchical, components where one or more components of the
sub-design contains a variable or expression.
Components that contain SMT artwork.

If a component, or component sub-design (if hierarchical), contains a variable or
expression in a parameter, or if the component contains SMT artwork, the component will
always be regenerated during design synchronization. Therefore, these components will
always be highlighted.
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 Dual Representation Mode

When working from either schematic or layout, it is sometimes desirable to have items
placed in both views simultaneously. This is accomplished using the dual placement or
synchronization modes found in Options > Preferences > Placement.

Single Representation (schematic OR layout)
When you place an item in one view, nothing is placed automatically in the other
view.
Dual Representation (schematic AND layout)
When you place an item in one view and move the pointer into the window for the
other view, the equivalent component is already selected. Position the pointer as
desired and click to place it (If a window for the other view-containing the same
design-is not open, one will be opened automatically.)
Always Design Synchronize (schematic AND layout)
Causes the program to fully synchronize both views after each part is placed,
ensuring all parts are fully interconnected. This takes more time than the Dual
Representation mode and may move or rearrange the layout of the schematic to
preserve connectivity.

Note
The second (Dual) and third (Always) modes are designed to work in insert mode (while placing
components). If you need to edit as you insert components, these two modes are not
recommended.

 

 Generating a Schematic (Layout-driven Design)

Generating a schematic from a layout involves steps similar to those used in generating a
layout from a schematic. When you modify the layout, its modified parameter values can
be back-annotated to the schematic in a similar fashion.

Layout items can be picked from a palette or library list and placed and interconnected in
the Layout window. If a library of layout components has been created and associated
with schematic and simulator items, they can be added to existing palettes or new custom
palettes. For detailed information, refer to Creating Elements (usrguide).

To generate a schematic from layout:

Open a Layout window.1.
Create your layout design in the Layout window (by placing items from the library2.
and palette) and interconnecting them by abutting their pins or connecting them with
traces, as shown in the following example.
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Note
Before you can place an item (such as SLIN) in the Layout window that references a substrate item,
you must place that substrate item in the Schematic window.

From the Layout window choose Schematic > Generate/Update Schematic. The3.
dialog box appears, and all items in your layout are highlighted, indicating that they
need to be generated, updated, or moved in the other view.
If you want the program to use a specific component (e.g. C_Pad1) as the starting4.
point for generating your schematic, click on it. Otherwise leave the Starting
Component field empty.
Click Preferences and specify the horizontal and vertical spacing that you want5.
between the items in your schematic, then click OK.

If you specified a Starting Component, then you should also specify the location and6.
angle of the equivalent item in the Schematic window.
Click OK or Apply. The equivalent schematic appears in the Schematic window.7.

 

 RF PCB Design Considerations

Many RF PCB applications require an interactive approach to layout. Typically, a schematic
is created and simulated before layout begins. The Design Environment supports creating
layout at any time, before during or after a schematic is created. A large 90,000 part
library is provided; many parts are available with their packaged-part outlines and
mounting footprints.

The layout tool contains a number of features specially designed to support PCB layout.
These include:

Large, comprehensive parts library
Complete integration with system and circuit level simulation
Interactive placement mode
Automatic component parameter forward and back annotation
Rat's nest connectivity display
Layout vs. schematic checking
Trace routing and layered transmission line simulation
Simplified library parts creation
Configurable BOM, Parts Lists, pick and place output
Optional Gerber, DXF, IGES output
Optional integration with Mentor's Board and Hybrid Station
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 Creating the Board, System Setup

You will need to draw or import a board outline for the PCB you are designing. A number
of layers have been pre-defined for PCB board layout. The silk-screen layers are defined to
place text and other silk-screen information. The pcb1-9 layers are designators for trace
routing using traces or the PCB transmission line components. Other layers can be used or
defined as needed. There are no limits to the number of layers that can be defined,
though the multi-layer PCB transmission line components have a limit of nine conductor
layers.

 

 Interactive Layout, Manual Layout

Components can be placed in layout at any point in the design. As in the schematic, parts
can be placed in the layout by selecting them from a palette or library and positioning
them on the board. Most of the standard SMT parts and other packaged parts are selected
from library lists.

Parts can be moved to the bottom side of the board, or placed on the bottom by mirroring
them. When creating a schematic for a PCB design, make sure every part has a layout
equivalent. For ideal components, such a CAP, RES, etc., use the Lumped-With Artwork
version of these components to account for them in layout.

Parts can also be placed directly from the schematic. The advantage is that the schematic
and layout can then be kept synchronized. It is important to note that if you place items in
the schematic with the library or palette lists, and then place equivalents in the layout in
the same manner, the two will not be synchronized. To keep the layout and schematic
synchronized, you must either use the Generate/Update feature to automatically create
one view from the other, or use interactive placement to incrementally create one view
from the other.

 

 Automatic Design Synchronization

A layout can be automatically created from an interconnected schematic using the design
synchronization feature (Generate/Update). This command will take each component in
the schematic and place it in the layout so that the interconnected pins abut. While this
works very well for microwave designs that have every transmission line discontinuity
accounted for in the schematic, it does not usually produce acceptable results for PCB
layouts that have extensive interconnections using traces. It will, however, give you an
initial placement of components that can then be moved into a correct position.

 

 Interactive Placement

Placing parts interactively from the schematic to the layout, or vice-versa, is usually the
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most practical method of creating a PCB layout. The Place Components From Schem To
Layout (or Layout to Schem) command is used to select a part in one view and place it in
the other.

The command prompts you to pick a component in the source view and place it in the
target. If initiated from the Schematic window, you are prompted to click a schematic
component and then move the cursor into the Layout window. A ghosted image of the
part can then be seen moving with the cursor. You can use the arrow buttons on the
palette to rotate the part before placing it. Clicking the left mouse button places the part,
with the same parameter values used in the schematic.

Wire guides are displayed that indicate where each component should be connected.
These lines can be re-displayed by using the Schematic > Show Connected
Components command, which will draw a connection (rat's nest) depicting the
interconnection of each unconnected pin using the source view as the reference. Use Clear
Highlighted Components to remove these lines.

The Schematic > Place Components From Schem To Layout (or Layout to Schem)
command highlights all the components in the reference view not yet placed in the target.
Use the Clear Highlighted Components command to remove highlighting.

 

 Fixing Part Placement and Back Annotation

When parts are placed in the layout, they are placed as free components. That is, if design
synchronization is run, the part will be repositioned to abut at least one of its pins with an
interconnected component. While this is the preferable method of synchronizing
microwave designs, it is usually not the desirable method for PCB components.

If the parts were placed with the Place Components From Schem To Layout (or Layout to
Schem) command, they will be placed as fixed components. That is, they will not be
repositioned when design synchronization is run. However, if they were placed in some
other manner, they will be placed as free components and will need to be set to fixed. To
check the status of the placed components in layout, choose Schematic > Show Fixed
Components. This highlights each fixed component. For non-highlighted components,
select these and use the Schematic > Fix Component Position to fix these
components' positions.

Once the components are placed, you can use the design synchronization feature of the
program to maintain parameter changes in one view with the other. Thus, if you change
the value of a capacitor in layout, you can back-annotate this change by running design
synchronization from the Layout window. Each component that is not yet placed or that
has a changed value will be highlighted. Click OK or Apply to update the highlighted parts
in the target view.

 

 Trace Routing

You can use traces (or wires) to parts when you do not want to connect them merely by
abutment.
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 Layout Versus Schematic Nodal Mismatches

You can compare the layout and schematic any time during the design process using
Tools > Check Design and selecting the Nodal mismatches (layout vs. schematic)
option. This will generate a report that compares the connectivity of the target view
against the source. Missing components, or pins connected differently in one view from
the other are reported.

Note
This option works on designs where the layout is composed of layout items that have schematic
equivalents. It does not work on arbitrary geometry, nor does it do any device extraction. For complex
layouts that are mis-connected in more than one area, running the command from both views can help
better pin-point the source of the mismatch. Using this command in conjunction with Layout > Show
Unplaced Components, Show Equivalent Component, Show Connected Components commands
can usually solve most discrepancy problems.

 

 Trace Simulation

For many high-frequency PCB designs, transmission line effects become significant and
need to be accounted for in simulation. In Layout, you can explicitly convert traces to
transmission line components for simulation, or globally simulate traces as transmission
lines without explicitly converting them. For more information, refer to Working with
Traces (usrguide) under the section on Creating a Layout (usrguide).

 

 Meander Trace Simulation

MEANDER components are simulated using the MLIN electrical model. In order to account
for the effect of bends, use Traces (which can be broken down to lines, bends, and tees),
or MLIN, MBEND, MTEE directly.

 

 Generating a Report

To generate a Bill of Materials (BOM) or Parts List with pick and place information, choose
File > Reports. These reports are created using the de_bom and de_parts AEL functions
and can be customized. For more information, refer to Pick and Place Report (custom)
under the section on Setting Layout Options (custom) in the Customization and
Configuration (custom) documentation.

 

 Exporting the PCB layout

Most PCB layouts are manufactured via Gerber output. Gerber is supported via the
optional MTOOLS Gerber translator. The design environment interfaces with the Gerber
translator via mask files. A mask file can contain one or more layers. All design exporting
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is done through File > Export in the Layout window. For general information, refer to
Importing and Exporting Layouts (usrguide). For detailed information, refer to the
Importing and Exporting Designs (trans) documentation.

 

 Part and Library Creation

Though a large library of PCB discrete components is available, you may not find the
components and their layout footprints you are looking for. But you can define new items
in a number of ways. For details refer to Creating Elements (usrguide). Note, that a large
number of layout objects are also available. For non-electrical items, these can be placed
directly in the layout without concern for the schematic. For electrical items, you can
create a new item that uses a pre-defined layout object for layout, or you can use an ideal
component such as a CAP or S2P with a gap artwork equivalent. The gap can be specified
to allow the layout object to then be inserted.
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 Technology Setup
The Technology Setup dialog box is used to set the referenced libraries, layout units, and
database units. These parameters are set at the time of workspace creation. In a typical
flow, you need not change these parameters.

Choose Options > Technology > Technology Setup from ADS Main window, to open
the Technology Setup dialog box.

The Technology Setup dialog box allows you to edit information about one library at a
time. You need to change the library that you are viewing to edit or see information about
other libraries that are being used (View Technology for this library).

Click Show Other Technology Tabs to show other related technology settings tabs such
as Layer Display Properties and Nested Technonology.

 

 Referenced Libraries

An important concept is that the technology of one library can refer the technology of
other libraries. The technology defined in this library and the other libraries are effectively
combined into one technology for this library. Typically referenced libraries are read-only
and contain the design components that are used in writeable libraries. If a library is
ready-only a status message is printed on the dialog box next to the View Technology
for this library.

 Adding Referenced Library

To add a referenced library:
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Select Referenced Libraries tab and click Add Referenced Library, from the1.
Technology Setup dialog box.
A dialog box appears containing a list of libraries you might want to reference. It will2.
show if a library has Layout Units, Layout Resolution, Layout Layers, and Schematic
Layers.
Select a library from the libraries list.3.
Click OK to add library.4.

 Remove Referenced Library

To remove already referenced library:

Select Referenced Libraries tab from the Technology Setup dialog box.1.
Select the library name from the "Reference Libraries" list.2.
Click Remove Referenced Library to remove the referenced library.3.

 Examples of using multiple libraries to define a technology

A typical use model in ADS is to use the "Standard ADS Layers" with "0.0001 mil layout
resolution" when creating a new workspace or library. This creates the technology of the
new library so that it "has its own technology" and references the technology in the
"ads_standard_layers" and "ads_schematic_layers" libraries.

The library itself defines the units to be "mil" and the database resolution to be
"0.0001".
The "ads_standard_layers" library defines the layers and display properties to be
used for layouts.
The "ads_schematic_layers" library defines the layers and display properties to be
used for schematics.
You may still add more layers, purposes, and display properties if needed. You can
also add materials and substrates for EM simulation.

 

Another typical use model is used when creating a workspace library that will contain
designs using components from a design kit.

A library in a design kit will typically define the units, database resolution, layers,
purposes, and display properties. It may also define materials and substrates for EM
simulations.

The workspace library will specify "has its own library" and reference the library of
the design kit.
The workspace library will not set the units, database resolution.
The workspace library could have additional layers, purposes, display properties,
materials, and substrates.

When a library references other libraries the combined technology may not specify
conflicting information. You may not do this:

One library specifies units of "cm" and another specifies units of "mil".
One library specifies a database resolution that is different that a another library.
One library specifies a layer name or number and a another library uses the same
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name or number.
One library specifies the display properties for a layer and purpose and a another
library specifies these for the same layer and purpose.
Two libraries specify the same material names.

Click Show Advanced Option for more options.

 

 Layout Units

The Layout Units tab is used to change the library's layout unit and the data-base to
user resolution factor. Choosing your layout unit and resolution is very important and
should be done before you create layouts in this library.

Note
Schematic and symbol units are preset to a resolution of 1/160 (0.00625) inch and cannot be modified.

The layout unit and resolution determine the smallest coordinate change you can make in
layout, and also the largest coordinate usable in layout. The largest coordinate usable is
approximately 1 x 10^9 larger than resolution (i.e. a resolution of .01 um would have a
maximum size of 10 meters).

Enable Units - Enable layout unit specification in this library.
Enable Resolution - Enable layout data-base to user resolution specification in this
library.

If you don't need to specify layout units or resolution because another referenced library
provides this, you should not enable them.

 Show Advanced Option

 Has technology

You can define part or all of the technology in this library. It can also optionally reference
the technology in one or more other libraries. The technology defined in this library and
the other libraries are effectively combined into one technology. This is the recommended
choice because it has the most flexibility in defining a technology.
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 Attached

This allows you to point at one technology library that should define the units, database
resolution, display properties,layers, and purposes. The current library may still define
new display properties, display order, substrates, and defaults designs.

 No technology

This may be of use for libraries containing layout component defined with artwork macros
where they are designed to use the layer defined in the library that the component
instance is placed.
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 Layer Definitions
The Layer Definitions dialog box is used to define the layers, purposes, and layer display
properties in the library. Choose Options > Technology > Layer Definitions from the
ADS Main window (Schematic or Layout window), to open the Layer Definitions dialog box.

Following are the main components of the Layer Definitions dialog box:

View Technology for this library: Allows selection of the library that this dialog
box is viewing or editing.
Show Other Technology Tabs: Displays other technology settings options such as,
Layout Units, Reference Libraries, and Nested Technology.
Layer Display Properties tab: Allows editing of the display properties for a
specified layer and purpose combination.
Layers tab: Provides options to edit the layers.
Purposes tab: Allows editing of purposes.
Display Order tab: Allows editing the order that layer/purpose combinations are
displayed.

 

 Layer Display Properties

The Layer Display Properties allows you to edit the Display Properties that are defined in
this library. It also shows the Display Properties that are defined by other referenced
libraries. For more information about referencing libraries, see Technology Setup
(usrguide).
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Layer - Choose a specific layer from a list of layers defined in this library or from
libraries referenced (usrguide) by this library.
Number - Layer number defined for this layer name on the Layer tab. This is a non-
editable field.
Purpose - Choose a specific purpose from a list of purposes defined in this library or
from libraries referenced (usrguide) by this library. Typically you will use the
"drawing" purpose.
Number - Purpose number defined for this purpose name on the Purpose tab. This is
a non-editable field.
Library - Library name in which the Layer Display Property is defined. Non-editable.
Color - Click on the color cell to define a 24 bit color.
Trans - Click on the trans cell to define a transparency ranging from zero
(completely transparent) to 255 (completely opaque).
Pattern - Click on the pattern cell to select one of many predefined patterns.
Sel - Check or uncheck the select box to determine if shapes using a given display
property are selectable in a layout, schematic, or symbol view.
Vis - Check or uncheck the visibility box to determine if shapes using a given display
property are visible when draw in a layout, schematic, or symbol view.
Shape Display - Choose if the shapes are drawn using an outline, filled, or both
filled and outlined.
Line Style - Choose the line style that will be used to draw the outline of a shape.

 Add Display Property

To add a new Display Property with a new or existing layer, click Add Layer / Display
property to open the Add Layer / Display Properties dialog box.
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Select either of the two radio buttons:

Add new layer - Adds a new layer to the library and adds display properties for the
new layer.
Use existing layer - Adds display properties for an existing layer. If you select an
existing layer from the table, it automatically specifies the Layer Name, Layer
Number, Layer Process Role, and Layer Binding fields.

Other fields in this dialog box are:

Layer Name: Enter the desired layer name. By default layer_<N> is displayed,
where <N> is the next available layer number.
Layer Number: Enter the desired layer number. By default lowest number that is
not used will be displayed. Any number in the range 0 to 4294967295 is valid except
layer numbers in range 200 to 255 which are reserved for schematics.
Layer Process Role: Specify the role that the layer represents in a design. For more
details on Process Role, see Process Role
Layer Binding: Enter the layer binding information. For more details on Layer
Binding, see Layer Binding
Purpose Name: Specify the purpose of the layer among the list of available
purposes. By default drawing is the purpose.

 Remove Display property

To remove the display property of the selected layer, click Remove Display Properties
(after selecting the layer). Only the Display Property is removed from the library. Use the
Layer tab for removing layers from the library. The blank column on the left allows easier
multiple selection of Display Properties if you want to remove several of them.
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Note
To select multiple layers, press <ctrl> button and select the layers to be deleted. You can also use
<Shift> button to select continuous layer names.

 

 Layers

The Layers tab provide options to edit layers in the given library. You can automatically
update the layer binding information if layer binding is already defined in a substrate.

Three buttons in this dialog box are:

Add Layer: Adds a new layer to the library. A default layer gets added on each click.1.
You can modify the layer name and number. Each layer of the library (or referenced
library) must have a unique name and number. For more information on referencing
libraries, see Technology Setup (usrguide).

Add Derived Layer: Allows you to add a derived layer. You can specify the Layer2.
Name and Layer Number in the Add Derived Layer dialog box along with the
operation. For more details on using and adding a derived layer, see Adding Derived
Layers.



Schematic Capture and Layout

239

Remove Layers: Removes an existing layer from the library. To remove multiple3.
layers, you can select them using <ctrl> or <shift> button.
Update Layer Binding: Allows you to select a substrate in which the layer binding is4.
already defined. This may update the layer bindings in this library and referenced
libraries if necessary.

 

 Process Role

The Process Role is used to specify the role that the layer represents in a design. The
Substrate Editor also uses several of these roles to determine which layers appear first in
combo boxes when editing mapped layers and vias. Other important roles are shown
below:

Not defined
Conductor - Must be defined for conductor layers that that will be used by the
Physical Connectivity Engine in layout.
Semiconductor
Dielectric
Conductor Via - Must be defined for via layers that that will be used by the Physical
Connectivity Engine in layout.
Semiconductor Via
Dielectric Via
Conductor Slot
Semiconductor Slot
Dielectric Slot
DRC - Used to display drc errors.
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Boundary Outline - Used only to show the outline that defined the physical extent of
a layout. This is used for 3D EM simulations.

 

 Layer Binding

Layer  Binding enables you to control which layers will make a connection to other layers
when pins and shapes overlap. Shapes (polygons, circles, paths, and rectangles) can also
make connections between components. Also, components can have area and edge ports
in addition to their point pins. Because of this, it is important to have your layer binding
specified correctly.

In a design process, interconnects are made on metal layers or by holes in a via layer. To
represent this in ADS, the Layer Binding should have values on metal or via layers and
other layers should have empty Layer Bindings.

The layer binding field is a list of words separated by spaces. The words typically are layer
names, but this is not required. When pins or shapes overlap but are on two different
layers, they will connect if a word in the layer binding list of the first layer matches the
same word in the layer binding list for the second layer.

A layer binding of "*" will match any word or "*" in another pin's layer binding list. Agilent
Technologies recommends you not to use "*" because it can cause layers to be connected
when you did not expect a connection. Connections with shapes will ignore the layer
binding "*" and treat the Layer Binding as if it were empty.

 

 Examples

Layer Name Layer Binding List

Metal1 Metal1

Metal2 Metal2

Since neither layer has the same word in their layer binding list, they will not connect to
each other.

Layer Name Layer Binding List

Metal1 Metal1

Metal2 Metal1

Since both layers have the same word (Metal1 ) in their layer binding list, overlapping pins
and shapes on these layers will connect to each other.

Layer Name Layer Binding List

Metal1 Metal1 Metal3

Metal2 Metal2

Metal3 Metal3 Metal1

The pins and shapes on layers Metal1 and Metal3 will connect, but those on the Metal2
layer will not connect.
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Layer Name Layer Binding List

Metal1 Metal1

Via1 Via1 Metal1 Metal2

Metal2 Metal2

Via2 Via2 Metal2 Metal3

Metal3 Metal3

This is a typical way to setup metal and via layers. Pins and shapes will connect from
Metal1 to Metal2 if they overlay shapes on the Via1 layer. The same situation occurs for
pins and shapes on Metal2 and Metal3 layers.

Layer Name Layer Binding List

Metal1 conductors

Metal2 conductors

Metal3 conductors

The three layers have a common word, conductors, in their list and each will connect to
the others. Using "conductors" this way enables you to refer to a group of layers that will
all connect to each other.

 

 Purposes

The Purposes dialog box is used to edit the purposes in a given library.

Purposes can be used to differentiate shapes that are on the same layer. Unless you have
a specific reason for doing this, you probably don't need to define any new purposes.
Typically, you will draw shapes using the "drawing" purpose.

Purpose Name - This must be a unique name in this library and any other libraries
referenced (usrguide) by this technology.
Purpose Number - This must be a unique number in this library and any other
libraries referenced (usrguide) by this technology. The number can range between 0
and 4294967296 (2^32). Purpose numbers between 200 and 255 are reserved for
use by schematic layers.

You can use a purpose, such as "gate_metal", to draw the gate of a FET. Other shapes on
the same layer might have the "drawing" purpose. This allows you to write a different DRC
rule for the gate shape versus other shapes on the same layer.

 



Schematic Capture and Layout

242

 Display Order

The Display Order option provides options to edit the default entry layer and the layer
drawing order.

Main components of this dialog box are:

Default entry layer:purpose - When a layout window with a design from this library is
first opened, this setting determines the initial value of the current layer combo box
in the toolbar.

Layer/Purpose Drawing Order - This list determines the order that layers will be
presented in various combo boxes in the user interface and on the Layer Preferences
window. It also determines the drawing order of shapes when a layout window is
drawn.

Display layers in reverse order- The radio buttons allow you to reverse the drawing
order of shapes in a layout window.
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 Material Definitions
From the ADS Main Window (or from Schematic or Layout window), choose Options >
Technology > Material Definitions to open the Material Definitions dialog box. You can
also open it from Substrate Window by selecting Technology > Material Definitions or
by clicking any of the buttons in the right panel of the Substrate window.

The View Technology for this library drop-down list lists the libraries loaded using the
lib.defs file in the current workspace. You may need to change the library that you are
viewing to edit or see information about other libraries that are used.

The material definitions are divided into three types (Conductors, Dielectrics, and
Semiconductors) that have different electrical and magnetic parameters. There is one
more tab that defines the surface roughness models. In each of these tabs you can Add or
Remove material definitions from a table and edit their parameters. You can also add
materials from a predefined database of materials.

 Conductors

Conductors are divided in two main sections:

Materials1.
Loss Parameter2.

The left two columns define:

Material Name: A material name that is unique within this library and any libraries
referenced (usrguide) by this library.
Library: The library name in which the material is defined. You can edit the library
name.

The next three columns define:

Parameter Type - Click on the parameter type to choose the type of loss parameters.
Conductance - Allows the specification of real and imaginary loss parameters in
Siemens/Meter.
Resistance - Allows the specification of real and imaginary loss parameters in
Ohm/Sq.
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Resistivity - Allows the specification of a real resistivity loss parameter in
Ohm.cm.

Real - The real loss parameter.
Imaginary - The imaginary loss parameter. This should be a negative value.

 Add Conductor

Click Add Conductor to add a new conductor material to the library.

 Remove Conductor

Select any of the existing conductors click Remove Conductor to remove from the
library.

 Add From Database

Click Add From Database to add materials with predefined parameters to your library.
For more details, see Add From Database.

 Dielectrics

The left two columns define:

Name - A material name that is unique within this library and any libraries referenced
(usrguide) by this library.
Library - Library name in which the material is defined. Non-editable.

The Permittivity(Er) and Permeability(MUr) columns define:

Real - The real loss parameter.
Imaginary - The imaginary loss parameter. This should be a negative value.
TanD - The loss tangent (Don't specify both TanD and Imaginary)
Real - The real loss parameter.
Imaginary - The imaginary loss parameter. This should be a negative value.
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These columns define the Djordjevic Loss.

Type - Choose either Frequency Independent or Svensson/Djordjevic loss model. If
the model is frequency independent the loss parameters are not used.

For more information about dielectric loss models, see About Dielectric Loss Models
(ccdist).

 Add Dielectric

Click Add Dielectric to add a new dielectric material to the library.

 Remove Dielectric

Select some field in a row and click Remove Dielectric to remove a dielectric material
from the library.

 Add From Database

Click Add From Database to bring up a dialog that allows you to add materials with
predefined parameters to your library. See the dialog below.

 Semiconductors

The left two columns define:

Name - A material name that is unique within this library and any libraries referenced
(usrguide) by this library.
Library - Library name in which the material is defined. Non-editable.
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The remaining columns define:

Permittivity(Er)
Real - The real loss parameter.

Permeability(MUr)
Real - The real loss parameter.
Imaginary - The imaginary loss parameter. This should be a negative value.

Resistivity - Allows the specification of a real resistivity loss parameter in Ohm.cm.

 Add Semiconductor

Click Add Semiconductor to add a new semiconductor material to the library.

 Remove Semiconductor

Select some field in a row and click Remove Semiconductor to remove a semiconductor
material from the library.

 

 Add From Database

Click Add From Database to bring up a dialog that allows you to add materials with
predefined parameters to your library.
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 Surface Roughness Models

Surface roughness models can be used with Conductors and Conductor Vias when editing
a substrate in the Substrate window.

The left three columns define:

Name - A roughness model name that is unique within this library and any libraries
referenced (usrguide) by this library.
Library - Library name in which the material is defined. Non-editable.
Model - This specifies the model used for simulation

Smooth - No roughness will be modeled.
Hammerstad - Use the Hammerstad model.
Hemispherical - Use the multi-level hemispherical model.

For more information on surface roughness models and parameters, see MSUB component
(ccdist).
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 Nested Technology
Nesting a technology allows you to place a layout from another technology into a layout
from this technology. This could be used to place surface mount components on the top or
bottom of a printed circuit board. It could also be used to place a flip-chip integrated
circuit into a module. This will work even if the two technologies involved have layers
defined that have some of the same layer names or numbers.

A Nested Technology can be used in follows ways:

By creating Nested Technologies you can place a component from one library onto
the top or bottom of a layout from another library. For details, see example.
By creating a Nested Technology and using it when creating a substrate in the
Substrate window, you can use the 3D viewer and/or EM Simulation on a layout. For
more information on how to do this, see Multi-Technology Design in ADS2011.

To open Nested Technology dialog box, choose Options > Technology > Nested
Technology from the ADS Main window, Schematic window, or Layout window. You can
also open it from Substrate Window by selecting Technology > Nested Technology or
by clicking various buttons on the right of the Substrate window.

The View Technology for this library drop-down list lists the libraries loaded using the
lib.defs file in the current workspace. You may need to change the library that you are
viewing to edit or see information about other libraries that are being used.

See the Layer Definitions (usrguide) dialog for information about other tabs available in
this dialog box.

 

 Example

This example describe how a surface mounted component (SMT) from a smt_lib library
can be placed onto the top and bottom of a layout of a printed circuit board (PCB) that is
in the board_lib library.

 Adding Nested Technologies

From the Nested Technology dialog box, and select the board_lib library. Click the Add
button twice to add two nested technologies that represent placing a SMT component on
the top and on the bottom of the PCB layout. Click the Rename button and rename them
as smt_top and smt_bottom respectively.

file:/display/ads2011overview/Setting+up+Multi-Technology+Designs#SettingupMulti-TechnologyDesigns-CreatingMultiTechnologyDefinitionfromBaseTechnology
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 Editing Nested Technologies

Select the smt_top Nested Technology and click the Open button to edit the Nested
Technology.

 Nested Technology Library

Select the library name from Nested Technology Library drop-down list to display the
library name of SMT component. In this example the library name is smt_lib.

 Orientation and Vertical Position



Schematic Capture and Layout

250

The red arrow here indicates the top side of the SMT component. You can select any of the
the following orientation and vertical position:

The SMT component is above the board.
The SMT component is below the board and it has been flipped upside down.
The SMT component is above the board and it has been flipped upside down. (Flip
Chip)
The SMT component is below the board,but its orientation is up. (Flip Chip)

In this example, first option is selected for the smt_top and second option for smt_bottom.

 Equivalent Layers

For any layer in the Nested Technology Library smt_lib having pins for external
connections, there must be ab equivalent layer in the current library board_lib.

To add equivalent layer:

From Nested Technology dialog-box, click Add Equivalent Layer.1.
From the Add Equivalent Layers, select the Layer (from the drop-down list) for which2.
equivalent layer is to created, for example, smb_pad layer.
Select Create a new layer option if you want to create a new layer. Otherwise, select3.
Choose an existing layer from the drop-down list.

Note
The default layer name is a combination of the Nested Technology name and the layer selected.

Click OK to add the equivalent layer.4.

Note
Repeat the steps if more equivalent layers are to be add to this Nested Technology.

In this example,

"smt_top_smt_lib_smt_pad" equivalent layer is created when editing the "smt_top"
Nested Technology.
"smt_bottom_smt_lib_smt_pad" equivalent layer is created when editing the
"smt_bottom" Nested Technology.
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Repeat the process while editing the smt_bottom Nested Technology.

After editing the Nested Technologies in the board_lib library, click the Layer Display
Properties tab (from Nested Technology dialog-box) to see the display properties for
each equivalent layer have been automatically added to the library. These properties
should be the same as the display properties for the original layer in the "smt_lib" library.

 

 Inserting Components Using Nested Technology

To insert a component that uses Nested Technology, insert it just like any other layout
component. After insertion, select the component instance and right click it to see the
context menu. Look for "Nested Technology" on the menu and select the desired Nested
Technology. This will place the component on top or below the PCB design and flip the
component if necessary.

If you did not see the Nested Technology menu, you probably need to use the File >
Design Parameters menu on the component you were inserting. Go to the View-
Specific Configuration tab and choose the Artwork type to be "Nested Technology". If
you do change the Artwork Type to be "Nested Technology", you should delete and re-
insert the component, and again try to set the Nested Technology using the context menu.

See Creating Elements (usrguide) for more information about this.
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 Defaults Designs
To open Default Designs dialog box, choose Options > Technology > Defaults Designs
from the ADS Main window, schematic window, or layout window.

The View Technology for this library drop-down list lists the libraries loaded using the
lib.defs file in the current workspace. You may need to change the library that you are
viewing to edit or see information about other libraries that are being used.

The Defaults Designs dialog box allows you to select one or more cell or views. The
components in each cell or view will automatically be placed on the top level of your
netlist if a component from this library is used in the netlist. The selected cell or view must
be pin-less components such as:

Netlist Include
Circuit Substrate
Model
VAR

The selected components do not have to be from the same library that you are setting the
Defaults Designs on. If you select a cell or view containing VAR component, you must
name your variables with a unique name.
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 Artwork
Any item can have an artwork representation. There are several ways to define artwork
for any given item you want to represent in layout, but in general, the artwork is
categorized in one of two ways:

Fixed artwork
AEL artwork macros

For both types of artwork, a large number of artworks are provided, but you can also
create custom artwork of either type.

 

 Fixed Artwork

The simplest artwork is fixed artwork and over 100 fixed artwork shapes are provided.
Fixed artwork can be thought of as a layout object. These objects are saved in design files
and may or may not have connection pins. This type of artwork is often used for layout
items that do not change size or shape based on parameter settings. For example, an
SOT23 package outline is the same for any device with that package, regardless of the
device operating parameters.

The provided fixed artwork objects are documented in Layout Library (layout). For
details on associating one of these fixed artworks with an item, refer to View-Specific
Configuration (usrguide).
For details on creating your own fixed artwork, refer to Creating Fixed Artwork.

 

 AEL Artwork Macros

A more flexible approach is to use the AEL artwork creation functions to define the artwork
for an item. The artwork for the built-in transmission line elements (microstrip, stripline,
etc.) is defined in this fashion, and over 200 AEL artwork macros are provided. These
macros include functions for creating solder pads, space artwork and no artwork.

The AEL macro is versatile because it can accept parameters that are used to determine
the shape, size, layer, and connection points of the layout artwork. Every reference to an
item defined with an AEL macro can be different, depending on the parameters passed to
it.

The provided AEL macros for layout-only components are documented in Standard
AEL Macros (usrguide).
AEL macros are provided for additional components that are documented (as
components) in the Circuit Components documentation.
AEL macros are provided for over 100 standard SMT packages and are documented
in Layout Library (layout).
For details on creating on your own AEL artwork macros, refer to Creating Artwork
Using an AEL Macro.
For details on creating AEL artwork macros using the Graphical Cell Compiler, refer to
the Graphical Cell Compiler (gcc) documentation.
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 Special Types of Artwork

The following special types of artwork are also available: space artwork, connection
artwork, and SMT package artwork.

 

 Space Artwork

Space artwork refers to leaving a space or gap in layout. No actual artwork is created with
the space macro. Instead, it instructs the program to view items connected through an
item with space artwork as connected. In the layout, a gap is created separating items
connected to the item with space artwork.

Using this artwork type is common for layouts where the artwork representing a
simulation item may frequently change. For example, you may have an S-parameter
device model (S2P) in your design and wish to swap out the referenced S-parameter file
to test different devices.

If each device has a different artwork representation, there is no one package outline to
assign to this element. However, by assigning space as the artwork (SPAC), you can leave
a gap, whose size is a parameter of the item, and insert a layout package outline later.

Built-in item definitions have been provided for the most common cases of simulation
items that could benefit from using SPAC as artwork. These include many lumped
elements as well as the S2P element, and can be found in the Lumped Components (with
artwork) and the Linear Data File Items (with artwork) palette and library groups. Any
item from the library of packaged parts provided with the program, or layout object you
define, can then be used to insert into the space for layout.

 

 Connection Artwork

Connection artwork is a special case of space artwork. However, rather than leaving a gap
in layout, it simply connects items that are connected through it together (a space of 0).
In other words, items with connection artwork are simulated and included in your
schematic, but are ignored in layout. For example, you may have included parasitic
capacitors or resistors in your network that have no artwork. By assigning connection
artwork to these items, you can include them in simulation and have the layout ignore
them.

It is important to use items with connection artwork, rather than items without any
artwork assigned at all, to ensure that the layout can be automatically synchronized with
the schematic.

Like items with space artwork, the most commonly used items with connection artwork
have been pre-defined and included in the program. These are also listed in the Lumped-
With Artwork and the Linear Data File Items (with artwork) palette and library groups.
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 SMT Package Artwork

SMT package artwork is available for over one hundred parts. These artwork macros are
versatile because the dimensions of the land pattern can be varied by changing the width
and length of the package. The position of the land pattern, with respect to the
component package, can be varied by changing the OFFSET parameter. For details on
available SMT package artwork and an example, refer to the Layout Library (layout)
documentation.

 

 Supplied Artwork

Default artwork exists for all microstrip and stripline components, as well as many other
components. Artwork also exists for a large number of component libraries. This artwork
is in the form of AEL artwork macros.

Default artwork also exists for a number of optional libraries. This artwork is usually in the
form of fixed part outlines. For packaged part libraries, it is the component footprint or
outline; for other parts it is the actual part geometry.

For other parts, there is no default artwork. To include these components in layout, you
need to create special component equivalents with artwork specific to your requirements.
For details refer to Custom Artwork below.

 

 Custom Artwork

Custom artwork for a design can be created before or after the simulation model.
Depending on what the artwork represents, you may want to create the artwork using an
AEL function, or simply create it by drawing a fixed set of shapes. Two examples are given
to demonstrate how to create artwork using either method.

Depending on the type of layout you are creating, you can create the artwork as a library
of fixed artwork components, as parameterized artwork macros, or a combination of both.
For some layouts, capacitors come in a set of fixed, discrete capacitance values, so it may
be better to create a fixed layout for each unique capacitance value. In other layouts, the
capacitors can take a range of values. If implemented as an artwork macro, the macro can
accept a parameter value and adjust shape dimensions to produce the corresponding
artwork. Microstrip transmission lines (MLIN) are another example of a component that is
best implemented as an AEL macro, because the width and length of the line are passed
into the macro (using the length unit set for the design), which controls the size of the
rectangle used to represent it.

To simplify creating new items with artwork, AEL functions and a library of fixed artwork
are provided. The AEL functions include: functions that generate a space or gap in layout
(this allows an artwork to be inserted later), macros for pad placement (for 2-, 3-, and 4-
pin components), routines to create different types of PCB pads, a predefined set of
commonly used components with space, connection, or pad artwork, and a way to provide
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a simple electrical connection between items. The fixed library contains artwork for most
popular packaged parts outlines, including a large SMT library (For lists of the provided
fixed and AEL macro artwork items, choose File > Design Parameters and view the
drop-down list associated with each artwork type.)

 

 Creating a Layout Object

To create a layout object:

For a layout object, open the Layout window and draw the shapes representing the1.
object.
Optionally, you can add connection points or pins (Adding Pins/Ports to Artwork). You
do not need to add pins if the object is going to be used as artwork to be inserted
into a layout gap (refer to Space Artwork).
When the artwork is drawn, choose File > Design Parameters in the Layout2.
window for layout objects, or from the Schematic window for schematic objects.
Select Fixed as the Artwork Type if it is to be included in a schematic, otherwise3.
select Not Synchronized.
Type the name of the currently open design file in the Name field.4.
Type (or select if it already exists) the name of the library in which you want the item5.
stored.
From the Model list in the Simulation field, select Not Simulated.6.
Check the Layout Object box and click OK.7.
Save the design.8.

 

 Adding Pins/Ports to Artwork

For any artwork item you create that will be connected electrically, you will need to add
pins. Pins represent an electrical connection point to which a trace, wire, polygon or the
pin of another item can be connected. When a port (point port) is placed into a layout and
this layout is placed as an instance into another layout, you will see a corresponding pin at
a single x,y point.

You can also place edge and area ports in a layout and these will become edge and area
pins when the layout is placed as an instance into another layout. Edge and area ports
must always be associated with a single (point) port. The point port defines where
automatic connections will be made when using design synchronization. If you need to
have multiple connection points that represent a single electrical connection to the
component, it is suggested that you use multiple edge or area pins. For more information
on edge and area ports, refer to Edge and Area Ports (usrguide) and Designating Edge
and Area Ports (usrguide).

When creating artwork using AEL, non-preferred ports enable you to place multiple
physical connection points that represent a single electrical port. Connecting to any same
numbered ports creates the connection. Any component may use non-preferred ports, and
have as many as required. Each non-preferred port representing a single connection
shares the same port number. The only special requirement when using non-preferred
ports is that one of the ports in the set be a preferred port. A preferred port is a
connection point that the design synchronization facility uses to connect to. In a set of
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multiple ports sharing the same port number, there can be only one preferred port. Non-
preferred ports are created using the de_define_npport() (ael) and preferred ports are
created using de_define_port() (ael) or de_draw_port() (ael) AEL functions.

 

 Creating Fixed Artwork

The artwork for this example is a fixed pattern representing the mounting pads for the
chip capacitor. The only parameter for the subnetwork is C, the nominal capacitance. A
resistor is added to the schematic to account for loss. An equation is used to calculate the
resistance from the nominal capacitance.

The following schematic describes the simulation model.

To create the fixed artwork for the chip capacitor:

Open the Layout window.1.
Select an entry layer for your artwork (select Options > Layer Preferences and2.
use this window or use the layout window toolbar combobox).
Draw the shapes representing the capacitor pads. Be sure your dimensions and3.
layers are appropriate for your design.
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Add ports to your artwork. The orientation of the ports determines how components4.
will be connected to your artwork when design synchronization is run. Place port 1 on
the left side of the left rectangle with the coordinates at node 1 set to 0,0. Port 1
looks like an arrow pointing into the artwork.
Place Port 2, rotating it to point in to the right rectangle.5.
When your capacitor is placed during synchronization, it will have connecting items
placed to the right and left of it, at the same angle the capacitor is placed.
Save your design.6.

 

 Using Edge and Area Ports

For additional on edge and area ports, see Edge and Area Ports (usrguide).

Ensure that you have already placed the port that the edge or area port will be1.
associated with.
Add a polyline or arc where the edge port will be located. This will typically be along2.
the edge of some other polygon, rectangle, circle or path.
OR
Add a polygon, rectangle, circle, or path where the area port will be located. If your
artwork already has a polygon, rectangle, circle or path where you want the area
port, you do not need to add another.
Use the Edit > Edge/Area Pin menu in Layout window. Select the polyline, arc,3.
polygon, rectangle, circle, or path and the port number it will be associated with.
Click OK. Objects that are associated with a port number are highlighted with a light
blue outline by default.

Selecting shapes in your layout will change the Port Number value in the dialog,
depending on which port the object is associated with. Objects that are not associated
with a port will display Not a port as the Port Number value. Objects that are associated
with multiple ports will display Multiple as the Port Number value. In this example, the
object on the left was selected and is associated with Port Number 1.
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The Select Port dialog enables you to select all shapes already associated with a specific
port. In this example, Port Number 2 was selected and the Apply button was clicked. This
selected the highlighted shape.

 

 Creating Artwork Using an AEL Macro

The artwork for this example is programmable artwork generated using an AEL function
for creating a thin film (MMIC) capacitor. The capacitor area is calculated from the
parameters passed into the network. You can create the network first, and then the AEL
function, or vice versa. Once the artwork function is complete, you need to associate it
with the view. See (View-Specific Configuration (usrguide)).

Note
Pins can be created using the following AEL functions: de_draw_port() (ael) (using simulator units),
de_define_port() (ael) (using user units), and de_define_edge_area_port() (ael). For details on these
functions, refer to the AEL (ael) documentation.

The following schematic describes the simulation model.
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To create an artwork function:

Using any text editor, create the macro functions in an AEL file (the file must use an1.
.ael extension). For details on the structure of an AEL function, refer to the AEL (ael)
documentation.
The following annotated example is for a thin film capacitor (TFC), tfc.ael:

----------------------------------------------------------------------------

/* layout artwork generation function for MIMCAP element

This example assumes a MMIC process, with two metal layers, and a via layer.

The processing steps required are:  

1) deposit first metal and etch to layer 1  

2) deposit dielectric and etch vias to layer 4  

3) deposit second metal and etch to layer 2

Global technology parameters are provided to show how standard constants

could be applied to all artwork functions

*/

//load("stdart");      // make sure we have standard definitions

// define technology parameters, all in MKS

decl lpad, lab, lpost, wpost, vu, lol, cpua;

lab = 6e-6;           // length of air bridge

lpost = 6e-6;         // length of post/via

wpost = 10e-6;        // width of post/via

vu = 0.5e-6;          // via undersize

lpad = 4e-6;          // bottom plate pad length

lol = 2e-6;           // bottom plate overlap

cpua = 300e-6;        // capacitance per unit area

// actual artwork generation function

defun mimart(c, ar)

{

decl c_mks, netu, wcap, lcap;

decl lbot, wvia, w, l;

netu = mks_factor(5); //get length conversion factor from mks

c_mks = c*mks_factor(4); // get capacitance in farads

lcap = sqrt(c_mks/cpua*ar)/netu; // get length in meters

wcap = lcap/ar; // get width in network units

// compute some useful values

lbot=(2.0*lol+lpad)/netu+lcap;// compute length of bottom plate

wvia = (wpost-2.0*vu)/netu;   // compute width of via

w = (2.0*lol)/netu + wcap; // compute overall width

l = (lab+lpost)/netu + lbot;// compute overall length

// draw lower plate and output contact

de_set_layer(1);                      // set the first metal layer

de_draw_rect(0.0, -w/2.0, lbot, w/2.0);

de_draw_rect(l-lpost/netu, -wpost/netu/2.0, l, wpost/netu/2.0);

// cut via hole

de_set_layer(4);                 // set via (dielectric) layer
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de_draw_rect(l-(lpost-vu)/netu, -wvia/2.0, l-vu/netu, wvia/2.0);

// draw air bridge metal

de_set_layer(2);// set the second metal layer

de_draw_rect((lpad+lol)/netu, -wcap/2.0, lbot-lol/netu,wcap/2.0);

de_draw_rect(lbot-lol/netu, -wpost/netu/2.0, l, wpost/netu/2.0);

// add ports

de_draw_port(0.0, 0.0, -90.0);

de_draw_port(l, 0.0, 0.0);

}

----------------------------------------------------------------------------

Save the file in top directory of the library that the component is in. See Adding2.
Artwork Macros to a Library for more information.

To associate this artwork with your subnetwork:

Open the network design and choose File > Design Parameters.1.
From the General Cell Definition tab, set the Simulation Model to Subnetwork.2.
From the View-Specific Configuration tab, Select AEL Macro as the Artwork Type.3.
In the Name field, type the name of the function you just created. In this example,4.
mimart. This is defined in the example by the line:

defun mimart(c, ar)

From the Cell Parameters tab, create the parameters C and AR, as defined in the5.
artwork function. Both should be set to Netlisted. You can optionally set them as
optimizable.

The following illustration shows the MMIC capacitor in layout with C=20 and AR=1.

Note that rather than writing the functions from scratch, you may find it helpful to copy
AEL macro code from one or more of the following files and modify it in your own AEL file:
destdart.ael - Artwork macros available from the Design Parameters dialog box, located in
$HPEESOF_DIR/de/ael
ckt_linear_art.ael - Existing artwork for circuit simulators, located in
$HPEESOF_DIR/circuit/ael

 Adding Artwork Macros to a Library

If you have artwork macros in an ael file and want the ael file to be automatically loaded
when the library is in use, you must create an entry in a eesof_lib.cfg file that can be put
into the directory of a library.
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First determine where the artwork macro ael file will be relative to the library.

If you have a design kit the library directory is usually inside the design kit's
directory. The ael file that is started when the design kit is used is normally put into
the <design kit directory>/de/ael/boot.ael. The relative path from the library
directory to the ael file will be "../de/ael/boot.ael". This boot.ael file could contain the
artwork macro functions or it could load another ael file with the artwork macro.
If you have only a library (no design kit directory), the ael file artwork.ael must be
placed in the directory of the library. This file have a relative path from the library of
./artwork.ael.

Using a text editor, create eesof_lib.cfg file inside the library directory (not the design
kit directory). This file must any of the following statements (depending on the location of
the ael file relative to the library):

BOOT_AEL=../de/ael/boot.ael

OR
BOOT_AEL=./artwork.ael

When the library or design kit is opened with an ADS Workspace, the ael file specified by
BOOT_AEL is automatically loaded.

 

 Overriding the Default Artwork Assignment

You can override the default artwork assignment for any given component.

To change the artwork for a given component:

Select the component and choose Edit > Component > Edit Component Artwork.1.
Choose from one of the following Artwork Types:2.

Default - Uses the artwork specified in the component's create_item definition.
The artwork type and artwork function name are displayed.
Fixed - Any provided or custom fixed artwork. Select or type the design filename
containing the artwork from the Artwork Name drop-down list, or use the
browser to select one.
Null Artwork - Draws a generic box (with an X through it).

Click Apply for this component and select another and repeat as needed.3.
Click OK when you are finished.4.
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 Importing and Exporting Layouts
The import/export translators in the ADS are highly configurable. Each translator has an
associated options file that controls how the translator works. Default options files are
included with the program and are automatically used unless you specify otherwise.

This section provides an overview of importing and exporting layouts.

Note
For details on available formats and descriptions of the options associated with each, refer to Available File
Formats (trans).

 

 Importing a Layout

To import a layout, follow the steps below:

In the Layout window, choose File > Import. The Import dialog box appears.1.
From the Import dialog box, select the desired File Type from the drop-down list or2.
click More Options after specifying the Import file name.
Click Browse or Preview, choose a Import file name, and click Open.3.
Define New design name or destination name.4.
Click OK. The file is translated into the program. One or more design files can be5.
created.

For all translators, one or more designs can be created. The top level design for IGES or
GDSII is displayed in the Layout window (no schematics are created using any of the
translators).

Note
Errors or warnings generated during translation are written to a write<translator>.log file, such as
writegds.log (GDSII), writeigs.log (IGES), or writeegs.log (EGS).

 

 Opening and Viewing a Translated Layout

Use either the design tree in the Main window, or the File menu in the Layout window to
open an imported layout.

 

 Saving a Translated Layout

You must explicitly save a translated design. It is not automatically saved. Use the
following step to save one or more translated designs (individual designs created during
the translation of a hierarchical design):
In the Main window, choose the command File > Save All.
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 Listing the Hierarchy of a Translated Layout

In the Layout window, choose the command Tools > Hierarchy.

 

 Exporting a Layout

This section provides information on exporting layouts. For details on available formats
and descriptions of the options associated with each, refer to Available File Formats
(trans) in the Importing and Exporting Designs (trans) documentation.

 

 Preparing a Layout for Translation

Preparing a layout for translation consists of some or all of the following steps:

Remove (flatten) any hierarchy that exists in the layout. This is necessary if you want
to make changes that would affect all levels of the hierarchy, such as merging
shapes.
Edit the shapes that make up the graphical representations of the circuit components
in the layout. The most common editing steps are to:

Merge graphics shapes that are on the same layer and touching (to eliminates
boundaries between components so that the layout consist of graphics only).
Apply process offsets.
Create reverse images.
Change colors.

Layouts are sometimes edited to reverse the arrangement of colors: to replace white with
black, for example.

Change the visibility or arrangement of layers.

The steps you must use depend on the type of translation, and on what must appear in
the finished file.

 

 Flattening Instances to Eliminate Hierarchy and Connectivity

When you flatten components, you turn each component in the layout into a set of
unrelated shapes. Component grouping is lost, and the shapes no longer behave as an
electrical entity for simulation. Use the following steps:

In the Layout window, choose File > Generate Artwork.1.
When the program prompts you for a new cell name, enter the desired name and2.
click OK.

Hierarchy is removed so that all primitives are contained in the copied top-level layout
icon.
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 Adding a Process Offset

It is sometimes necessary to have two layers that are almost the same except that one
has a process offset. A process offset is a fixed amount of space (width) that is added to
or subtracted from all dimensions of an object to compensate for production tolerances.
Process offsets are used to create objects that overlap or underlie other objects, and to fix
the actual amount of the overlap. If the object is a polyline or an arc, the object must
have width to use a process offset. In addition, when process offsets are used with these
primitives, only width is affected; process offsets do not change the endpoints of polylines
or arcs. To create a process offset in your layout, copy the shapes from one layer to an
empty layer, merge the shapes on the new layer, and then oversize (or undersize) the
merged shapes.

 

 Copying Shapes to a New Layer

To copy shapes from one layer to another:

The layer to which you want to copy the shapes must already exist.1.
In the Layout window, select the shapes that you want to copy.2.
Choose Edit > Advanced Copy/Paste > Copy to Layer.3.
In the Copy to Layer dialog box, select the destination layer and click OK.4.

Note
The program places a copy of the selected shapes on the destination layer, in exactly the same
place as they appear on the source layer. Because of this, you cannot see the copied shapes. When
you click OK, a copy is placed on the destination layer; click Apply only if you want to select an
additional layer to copy shapes to.

 

 Merging Shapes

Merging replaces all shapes on the same layer and touching with combined shapes. This
step is especially necessary before doing process offsets with negative values, but should
follow the elimination of hierarchy, as described in Flattening Instances to Eliminate
Hierarchy and Connectivity.

To merge shapes:

Select the shapes that you want to merge.1.
Choose Edit > Merge > Union/Intersection/ Union Minus Intersection, based2.
on your requirement.

 

 Resizing Shapes

You can increases or decreases the outline size of a shape, which is sometimes needed to
compensate for a manufacturing process.
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To resize shapes:

Select the shapes that you want to resize.1.
Choose Edit > Scale/Oversize > Oversize.2.
In the Oversize dialog box, enter (in layout units) how much you want added to or3.
removed from the selected shapes. A positive number increases the size of a shape,
a negative number decreases it.
Click OK.4.

 

 Creating a Reverse Image of a Layer

You can create a ground plane or a solder mask that includes the area between shapes, as
follows:

Copy the desired shapes to a an empty layer.1.
Place a rectangle (that represents the ground plane) over the shapes.2.
Choose Edit > Create Clearance in Layout Window.3.
When prompted, select the rectangle that represents the ground plane, then click OK.4.
In the Create Clearance dialog box that appears, enter any clearance you want for a5.
ground plane (or offset you want added to the final shapes when creating a solder
mask).
Select the shapes and click OK.6.
Select and delete the shapes to leave the ground plane/solder mask.7.

 

 Translating a Layout

To export a layout:

In the Layout window, choose the command File > Export. The Export dialog box1.
appears.
From the Export dialog box, select the desired format.2.
Only one format can be specified at a time. The format you choose determines which
options are available for translation. The options control the program translator.
If desired, specify a file name. If no file name is given, the name of the translated3.
design is used. You do not need to specify the file extension.
Define any preferences or layer attributes (both in the Options menu).4.
To specify the GDSII layer number or IGES level number to be used in exporting a
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design, choose Options > Layers Preferences to access the Layer Editor. Valid
GDSII layer numbers are 0 through 255.
To start the translation process, click OK. If no path is specified, the file is written to5.
the current workspace directory.
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 Standard AEL Macros
The AEL macros described here are for layout-only components.

conn
cpad2
cpad3
cpad4
pad1
pad3
pad4
padn
rpad2
rpad3
rpad4
spac
spad2
spad3
spad4
tar1

Additional components for which AEL macros are provided are documented in the Circuit
Components documentation.

 

 conn

Port Connection

 

 Illustration:

 

 Parameters:

None

 

 cpad2

Circular Two Pads with Non-Preferred Ports
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 Illustration:

 

 Parameters:

R = Radius of the pads
S = Center-to-center spacing
LAYER = Layer number

 

 cpad3

Circular Three Pads with Non-Preferred Ports

 

 Illustration:

 

 Parameters:

R1 = Radius of pads 1 and 2
S1 = Center-to-center spacing between pad 1 and 2
R2 = Radius of pad 3
S2 = Vertical distance between pad 2 and 3
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LAYER = Layer number

 

 cpad4

Circular Four Pads with Non-Preferred Ports

 

 Illustration:

 

 Parameters:

R1 = Radius of pads 1 and 2
S1 = Center-to-center spacing between pad 1 and 2
R2 = Radius of pads 3 and 4
S2 = Center-to-center spacing between pads 3 and 4
LAYER = Layer number

 

 pad1

Rectangular Two Pads with preferred ports

 

 Illustration:
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 Parameters:

W = Width
S = Spacing
L = Pin 1 to Pin 2
LAYER = Layer number

 

 pad3

Rectangular Three Pads with preferred ports

 

 Illustration:



Schematic Capture and Layout

272

 

 Parameters:

W1 = Width of pad at pins 1 and 2
W2 = Width of pad at pin 3
S = Spacing
L1 = Total horizontal length
L2 = Vertical length from pin 1 to pin 3
LAYER = Layer number

 

 pad4

Rectangular Four Pads with preferred ports

 

 Illustration:

 

 Parameters:

W1 = Width of pad at pins 1 and 2
W2 = Width of pad at pins 3 and 4
S = Spacing (length of pads)
L1 = Total horizontal length + space
L2 = Total vertical length from top of pin 4 to bottom of pin 3 + space
LAYER = Layer number
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 padn

N Pads for a dip

 

 Illustration:

 

 Parameters:

PW = Pad width
XS = X-axis spacing between recurrent pads
YS = Y-axis spacing between recurrent pads
NUM = Total number of pads
LAYER = Layer number

 

 rpad2

Rectangular Two Pads with Non-Preferred Ports

 

 Illustration:
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 Parameters:

W = Width
S = Spacing
L = Total length of the pads + space
LAYER = Layer number

 

 rpad3

Rectangular Three Pads with Non-Preferred Ports

 

 Illustration:
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 Parameters:

W1 = Width of pad at pins 1 and 2
W2 = Width of pad at pin 3
S = Spacing between pad 1 and pad 2
L1 = Total horizontal length + space
L2 = Vertical length from pin 1 to pin 3 + space
LAYER = Layer number

 

 rpad4

Rectangular Four Pads with Non-Preferred Ports

 

 Illustration:

 

 Parameters:

W1 = Width of pad at pins 1 and 2
W2 = Width of pad at pins 3 and 4
S = Space between pad 1 and pad 2
L1 = Pin 1 to pin 2
L2 = Length from pin 4 to pin 3
LAYER = Layer number
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 spac

Space

 

 Illustration:

 

 Parameter:

L = Length

 

 spad2

Square Two Pads with Non-Preferred Ports

 

 Illustration:

 

 Parameters:

W = Width
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L = Pin 1 to Pin 2
LAYER = Layer number

 

 spad3

Square Three Pads with Non-Preferred Ports

 

 Illustration:

 

 Parameters:

W = Width
L = Pin 1 to Pin 2
LAYER = Layer number

 

 spad4

Square Four Pads with Non-Preferred Ports

 

 Illustration:
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 Parameters:

W = Width
L = Pin 1 to Pin 2
LAYER = Layer number

 

 tar1

Square Pad

 

 Illustration:

 

 Parameter:
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W = Width
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 Printing
This section describes the printing options available in ADS (supported from ADS 2011.05
release onwards). You can direct the output to a:

Supported Printer
File in PDF or Postscript Format

You can connect to any printer supported by the operating system and select print option
from different ADS windows, such as, Schematic, Layout, Symbol, Substrate, and Data
Display window.

Following are the two print options available in most of the ADS Windows:

File > Print menu option to print the contents of the drawing area of the current
window.
File > Print Area menu option to print a specific region of the drawing area. The
specific region can be defined in Schematic, Layout, or Symbol Window only.

 The Print Dialog

The Print dialog box enable you to:

Select a printer (if not printing on a file)
Print to a file in PDF or Postscript format
Select the orientation
Select the paper size

Notes

All printers supported by your OS can be used to print the data.
For Windows OS, printers can be setup using the standard Windows dialogs while for linux and
Solaris, the printers can be setup using the CUPS (Common Unix Printing System) setup procedures.
Click the Advanced Printer Setup button to set up other printing options. These options may differ
depending on the printer and the operating system.

To send the output to a file, check the Create File check-box and click the Create button.
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 Using the Text Editor
ADS supports different text editors for Windows and Unix based systems.

For Windows based system, ADS uses windows WordPad as text editor.
For Unix based systen, ADS provide Hpeesofeedit text editor. It is a general-purpose
ASCII text editor capable of editing one file at a time. It enables you to cut and
paste, search for text, replace text, and go to a specific line of text.

 

 Starting the Text Editor

To start the text editor, choose Tools > Text Editor in the ADS Main window.

For Unix based system, you can also start the text editor by typing hpeesofeedit in any
command shell, and press Enter. The Hpeesofeedit window appears.

The status bar displays warnings, status of the search/replace operation, and the current
line number and character position. The copyright message is displayed in the status bar
until you begin typing. The text entry portion of the edit window displays the text you type
or paste in the window.

Basic operation of Hpeesofeedit text editor is explained in the below sections.

 Hpeesofeedit Text Editor

Hpeesofeedit text editor is part of ADS Unix version and not supported in Windows
version. The basic operation of this editor is explained in section below.

 

 Command Line Options
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The Hpeesofeedit program accepts most standard X/Xt command line options. These
options are listed in the table below. For more information on these options, refer to your
UNIX documentation.

 Command Line Options

Option Argument Example

-background, -bg color_name -bg white

-foreground, -fg color_name -fg blue

-display display_name -display unix:0

-geometry geometry string -geometry 300×400+10+30

-iconic

-xrm X-resource -xrm "*background:blue"

To start the Hpeesofeedit program with a command line option from any command shell,
type hpeesofeedit <desired option> and press Enter.

Alternatively, any of these resources can be specified in your resource file using
Hpeesofeedit as the class name. Hpeesofeedit is also the resource filename for the
program.

Note
Any option not preceded by a dash (-) is treated as a filename and the program will attempt to open a file
by this name. If a file by this name does not exist, a new file is created.

 

 Text File Management

The basic file operations include creating new files, opening existing files, inserting
existing files into other files, and printing and saving files. The file management
operations are performed through Text Editor (Tools > Text Editor in Main window).

 

 Creating a Text File

To create a new text file:

Choose File > New. A New dialog box appears .1.
Choose the type for the New Document and click Ok.2.
If there is any text in the current window, you are prompted to Save your Document
.

Click Yes to save the existing text.
To clear it and start a new file, click No.

When a window is empty and labeled untitled, type the desired text (you can assign a3.
name to the file when you save it.)

 

 Opening an Existing File
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To open an existing file:

Choose File > Open.1.
Select the desired file and click Open. If there is any text in the current window, you2.
are prompted to Save your Document .

Click Yes to save the existing text.
To clear it and open an existing file, click No.
The default file filter is an asterisk (*) so all the files in the current directory are
listed.
The file appears in the Hpeesofeedit window for editing.

 

 Inserting One Text File into Another

The Insert command enables you to insert a text file, in its entirety, into another text file.

To insert a text file into the currently open file:

Select File > Insert. A dialog box appears.1.
Select the desired file and click Insert. The selected file is inserted at the current2.
cursor position in the currently open file.

 

 Saving Text Files

The File menu contains two commands related to saving files: Save and Save As.

The Save command enables you to save changes to an existing file.
The Save As command enables you save a new file, and name it in the process, or
save an existing file with a new name. For example, if you would like a copy of an
existing file so that you can make changes to it while preserving the original, you can
use the Save As command to create a copy of the file with another name.

To save an existing file, choose File > Save. The file is saved and the number of bytes
and path/filename are displayed in the status bar.

To save a new file or to save an existing file with a new name:

Choose File > Save As and a dialog box appears.1.
Change the path, if required.2.
Enter a name for the file in the Selection field.3.
Choose Save As. The file is saved.4.

 

 Printing Text Files

To print a text file, choose File > Print. The file is sent to the printer and a status window
appears briefly displaying the status of the print request and noting which printer was
used.
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Note
The setting of the environment variable PRINTER determines which printer is used. If this variable is not
set, the default printer is used.

 

 Exiting the Text Editor

To exit the program, choose File > Quit. If the file has been modified since the last save,
you are prompted, File Modified, exit anyway?

To exit without saving the file, click Yes.
To cancel so that you can save the file, click No.

 

 Editing Text Files

The Edit menu enables you to copy, cut, paste, and delete text.

To copy text from one location to another:

Select the text you want to copy.1.
Choose Edit > Copy. The selected text is copied to the buffer.2.
Position the cursor in the desired location (in any window) and select Paste.3.

To move text from one location to another:

Select the text you want to move.1.
Choose Edit > Cut. The selected text is removed from that location and placed in the2.
buffer.
Position the cursor in the desired location (in any window) and select Paste.3.

To paste text currently being held in the buffer:

Position the cursor in the desired location (in any window).1.
Choose Edit > Paste. The contents of the buffer appear at the current cursor2.
location.

To delete text:

Select the text you want to delete.1.
Choose Edit > Delete. The selected text disappears.2.

 

 Performing Search and Replace Operations

The Search menu contains commands to enable you to jump to a specified line number in
the text file and to search for and replace specified text strings.

To jump to a specific line number in the file:
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Choose Search > Go To and a dialog box appears.1.
Type the desired line number and click OK. The cursor jumps to that line number in2.
the file.

To perform the search and replace operation:

Choose Search > Search/Replace and a dialog box appears. In the Search String1.
field, type the string of characters you want to search for, including wildcard
characters, if desired (If you use wildcard characters, you must check the box labeled
Regular Expression.)

In the Replace String field, type the string of characters you want to use to replace2.
the Search String characters.

Optionally, check this box if you want to search backward from the current cursor3.
position.

Optionally, check this box if you want to include wildcard characters in your search.4.

Note
For details on including Regular Expressions in your search, refer to your UNIX documentation.

Click Search. If the requested text is found, it is highlighted; if it is not found, a pop-5.
up appears and displays the message String not found.
If you want to replace the highlighted occurrence with the contents of the Replace6.
String field, click Replace. The highlighted text is replaced.

Hint
To clear the highlight from text at any time, simply click somewhere inside the text editor window.

If you want to replace every occurrence of the specified search string at once, click7.
Replace All. Every occurrence is replaced.
When you are through using the Search and Replace function, click Cancel to clear8.
any remaining highlights from text and dismiss the dialog box.

 

 Keyboard Mappings

The text entry area in the editor supports the complete Motif set of keyboard mappings.
These mappings are primarily controlled by the XKeysymDB file (or its equivalent), which
is typically found in /usr/lib/X11. The table below on Keyboard Mappings describes the
mapping of the Sun keyboard (The mappings for the HP platform follows the Sun's
mappings with few exceptions.) Note that the Meta keys are labeled differently on
different keyboards, but are always the keys on either side of the space bar.

 Keyboard Mappings
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Keyboard or Mouse Operation Action

Copy Copies selected text to the clipboard

Paste Pastes text from the clipboard to current insertion point

Cut Cuts selected text to the clipboard

Arrow Keys Moves the insertion point cursor/scrolls window

Shift Arrow Keys Moves insertion point, selects text

Page Up/Down Moves the window up/down by the number of visible lines

Home/End Moves cursor to beginning/ending of current line

Ctrl Home/End Moves cursor to first/last visible line in window

Back Space Deletes text to left of the insertion cursor

Meta Ctrl left arrow Moves cursor backward one word

Meta Ctrl right arrow Moves cursor forward one word

Meta Ctrl down arrow Moves cursor down one paragraph

Meta Ctrl up arrow Moves cursor up one paragraph

Left mouse button down/move Selects text range

Shift left mouse button down/move Extends selected text range
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 Using Advanced Design System Across
Platforms
A device library or design workspace stored on a shared volume can be accessed and
modified from either a PC or a UNIX workstation. In addition, files created on one platform
can be transferred and used on another.

When creating and modifying a file on a shared volume, keep in mind the following:

You need read and write access to modify a file on a shared volume.
Only one user can access a file at a time.

Files can be transferred electronically via FTP or they can be moved physically using a
medium such as floppy disks. When transferring libraries and workspaces from one
platform to another, keep in mind the following:

Use a Binary (image) file transfer method.
Maintain the original file and directory structure at all times.
Copy all hidden files.
Archive your workspace before copying a workspace to a CD (DVD) or transferring it
via FTP. For details, see Archiving Workspace (adstour).

Note
If a workspace created on UNIX contains two or more designs whose names are only distinguishable from
one another by differences in case, do not archive and transfer this workspace to a PC without renaming
the designs such that they all have unique names. This requirement is due to the fact that the PC is case
insensitive.

 

 Guidelines for Cross-platform Use

Use the following guidelines when creating libraries or workspaces for cross-platform use:

Use filename characters and conventions that are legal on both platforms. For
example, Windows does not recognize case-sensitive differences in filenames.
Use only the standard ASCII character set for text.
Use fonts that are standard on both platforms.
Use colors that are standard on both platforms.
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