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but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
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Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file
names and directory names. The business entity formerly known as "HP EEsof" is now part
of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and
to maintain backward compatibility for our customers, we did not change all the names
and labels that contain "HP" or "HPEESOF" references.

Warranty The material contained in this document is provided "as is", and is subject to
being changed, without notice, in future editions. Further, to the maximum extent
permitted by applicable law, Agilent disclaims all warranties, either express or implied,
with regard to this documentation and any information contained herein, including but not
limited to the implied warranties of merchantability and fitness for a particular purpose.
Agilent shall not be liable for errors or for incidental or consequential damages in
connection with the furnishing, use, or performance of this document or of any
information contained herein. Should Agilent and the user have a separate written
agreement with warranty terms covering the material in this document that conflict with
these terms, the warranty terms in the separate agreement shall control.

Technology Licenses The hardware and/or software described in this document are
furnished under a license and may be used or copied only in accordance with the terms of
such license. Portions of this product include the SystemC software licensed under Open
Source terms, which are available for download at http://systemc.org/ . This software is
redistributed by Agilent. The Contributors of the SystemC software provide this software
"as is" and offer no warranty of any kind, express or implied, including without limitation
warranties or conditions or title and non-infringement, and implied warranties or
conditions merchantability and fitness for a particular purpose. Contributors shall not be
liable for any damages of any kind including without limitation direct, indirect, special,
incidental and consequential damages, such as lost profits. Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily
provided to end user customers. Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212
(Computer Software) and, for the Department of Defense, DFARS 252.227-7015
(Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial
Computer Software or Computer Software Documentation).

http://systemc.org/
http://systemc.org/
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 Introducing the Impedance Matching
Utility 
The Impedance Matching documentation provides an introduction to the Impedance
Matching Utility. The complexity of the Advanced Design System (ADS) is made easily
accessible through the automated capability. A first-time or casual ADS user can begin
using the capability of ADS quickly, while experienced ADS users can perform tasks faster
than ever before. The Step-by-Step Example describes how a singly terminated bandstop
elliptical filter can be designed and verified, and a layout generated, in a few minutes.

The Impedance Matching Utility provides SmartComponents and automated-assistants for
the design and simulation. All SmartComponents can be modified. You simply select a
SmartComponent and, with little effort, redesign or verify their performance. The Using
SmartComponents (dgfilter) section answers many common questions relating to Utility
use and the SmartComponent Reference (dgfilter) describes each SmartComponent in
detail. The section Automated Design and Analysis (dgfilter) introduces Automated
Assistants.

  

 Step-by-Step Example
The step-by-step example takes you through the design, analysis and sensitivity
simulation of a bandpass lumped element matching network. After completing this
example, you should have a basic understanding of the Utility and be ready to begin using
the tool. Follow these steps to begin:

Setting Up the Design Environment

Designing and Analyzing a Network

Note
You should already be familiar with the basic features of Advanced Design System. For help with ADS
basic features, refer to the Schematic Capture and Layout (usrguide) documentation.

  

 Setting Up the Design Environment
Before you can use the Impedance Matching Utility, you must set up the design
environment by using these steps:

Setting DesignGuide Preferences

Opening a Workspace,

Opening a Schematic Window,
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Opening the Impedance Matching Utility,

Displaying the SmartComponent Palette.

Note
Before beginning, you must install the DesignGuide with appropriate licensing codewords.

  

 Setting DesignGuide Preferences

All DesignGuides can be accessed through either cascading menus or dialog boxes. You
can configure your preferred method in the ADS Main window or from the Schematic
window.
To configure access through menus or dialog boxes:

From the Main or Schematic window, choose DesignGuide > Preferences .1.
In the DesignGuide Menu Style group box, choose either Use a selection dialog2.
box or Use cascade menus .

Close and restart the program for your preference changes to take effect.3.

Note
On PC systems, Windows resource issues might limit the use of cascading menus. When multiple
windows are open, your system could become destabilized. Therefore, the dialog box menu style
might be best for these situations.

The ADS Main window DesignGuide menu contains these choices:

DesignGuide Developer Studio > Start DesignGuide Studio is only available on
this menu if you have installed the DesignGuide Developer Studio to open the initial
Developer Studio dialog box.
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DesignGuide Developer Studio > Developer Studio Documentation is only
available on this menu if you have installed the DesignGuide Developer Studio to
open the DesignGuide Developer Studio documentation.

Note
Another way to access the DesignGuide Developer Studio documentation is by selecting Help >
Topics and Index > DesignGuides > DesignGuide Developer Studio from any ADS program window.

Add DesignGuide opens a directory browser in which you can add a DesignGuide to
your installation. This is primarily intended for use with DesignGuides that are
custom-built through the Developer Studio.
List/Remove DesignGuide opens a list of your installed DesignGuides. Select any
that you would like to uninstall and choose the Remove button.
Preferences opens a dialog box that enables you to:

Disable the DesignGuide menu commands (all except Preferences) in the Main
window by unchecking this box. In the Schematic and Layout windows, the
complete DesignGuide menu and all of its commands are removed if this box is
unchecked.
Select your preferred interface method, either cascading menus or dialog boxes.

  

 Opening a Workspace

The ADS design environment is set up within a workspace.
To create a new workspace:

From the ADS Main window, choose File > New > Workspace or click Create a1.
New Workspace on the toolbar.
In the dialog, define the location of the workspace and assign a workspace name.2.

  

 Opening a Schematic Window

A new schematic design is needed to contain the lowpass component for this example.

To open a Schematic window:

From the ADS Main window, click Window > New Schematic or click New1.
Schematic Window on the toolbar. A New Schematic window appears.
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Select library from the Library drop-down box.2.
Enter cell name in the Cell field or Click Browse cells to browse and select the3.
existing cells.
Click OK to open the new schematic window.4.

Note
Depending on how your ADS preferences are set, a Schematic window appears automatically when
you create or open a workspace.

  

 Opening the Impedance Matching Utility

The Impedance Matching Utility is accessed from the Tools menu or the DesignGuide
menu in the Schematic window.

To open the Impedence Matching Utility window, you can select one of the following
options:

DesignGuide > Amplifier > Tools > Matching Utility
DesignGuide > Filter > Impedance Matching
DesignGuide > Mixers > Tools > Matching Utility
DesignGuide > Oscillator > Tools > Impedance Matching

  

 Using the Impedence Matching Utility Window

All Utility features are available in the Impedence Matching Utility window that includes
menus, a toolbar, and SmartComponent manipulation controls. The menus and toolbar
performs the basic functions of design, delete, and display the SmartComponent palette.
Each tab with in the window includes a specific Utility feature. Click on the tab to explore
and understand the utility features. Explore the window menus as well to familiarize
yourself with the basic Utility capabilities.

The drop-down lists at the top of the utility window are designed to help you navigate
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multiple schematic windows and SmartComponents. The Current Schematic drop-down
list box is used to select any of the currently opened schematic windows. This field is
updated any time Impedance Matching Utility Window is selected from the Tools menu.
From the SmartComponent drop-down list box, you can select any of the
SmartComponents on the currently selected schematic window.

To close the Utility window:

Select File > Exit Utility from the utility window menubar.
Continue the step-by-step example by Designing and Analyzing a Network.

  

 Designing and Analyzing a Network
In this step-by-step example, you design and analyze a bandpass matching network. A
bandpass matching network can be designed easily by using the default component
parameter settings. Using the Utility follows a normal design flow procedure:
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Select a component needed for your design from the component palette (Displaying
the SmartComponent Palette) and placing the component in your design (Placing
Example Component in the Design).

Provide specifications (Changing SmartComponent Parameters).

Design and analyze the component (Designing the Matching Component) and
Analyzing Yield of the Matching Network).

Note
Before starting this section of the step-by-step example, confirm your setup (Setting Up the Design
Environment).

  

 Displaying the SmartComponent Palette

The program contains a SmartComponent palette, Impedance Matching Networks , that
provides quick and easy access to the SmartComponents. A blue accent in the upper-left
corner of a palette button indicates the component is a SmartComponent.

You can display the SmartComponent palettes in one of these ways:

Click Component Palette on the Utility window toolbar
Choose View > Component Palette from the Utility window menu
Select the Impedance Matching palette from the Component Palette drop-down list
box in the Schematic window toolbar (directly above the palette).
Continue the example by selecting the Impedance Matching palette. The palette
displays in the Schematic window.

  

 Placing Example Component in the Schematic Window

To place the SmartComponent in the Schematic window:

Click LCBandpassMatch on the component palette to select the component.1.
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Click within the schematic window to place the component.2.
You can change the orientation of the SmartComponent before placement by
selecting from the Insert > Component > Component Orientation commands or
by selecting Rotate by -90 repeatedly from the schematic toolbar.
The place component mode remains active until you choose End Command from
the schematic toolbar.

Note
When a SmartComponent is placed initially, a temporary component is used to place and
specify the parameters for the SmartComponent. This component does not contain a
subnetwork design. After the utility has been used to design the SmartComponent, the
temporary component is replaced with a permanent component. The SmartComponent is
renamed to DA_ComponentName_DesignName and an autogenerated design is placed inside
the SmartComponent's subnetwork design file. Subsequently, if the SmartComponent
parameters are edited, the utility must be used again to update the subnetwork design file.

  

 Changing SmartComponent Parameters

Parameters can be changed directly from the Control window.

To edit the LCBandpassMatch component parameters:

In the Control window, select the LCBandpassMatch component from the1.
SmartComponent drop-down list. This ensures all changes are referenced to this
component.
Select the Matching Assistant tab. Leave all parameters at default.2.

Note
See Placing and Editing SmartComponents (dgfilter) for details on changing parameters in the
design window or component dialog box.

  

 Designing the Matching Component

You can design and analyze the SmartComponent from the Control Window.

To start the simulation:

On the Matching Assistant tab, click Design to start a simulation and generate the1.
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design for the SmartComponent. When the simulation has finished, a Impedance
Matching Utility dialog box appears.
Click Select to complete the process.2.

To analyze (simulate) the network:

Select the Simulation Assistant tab on the Impedance Matching Utility window.1.
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Click Automatically Set Frequencies followed by Simulate to start the Simulation2.
Assistant and analyze the SmartComponent. Part of the analysis results are shown
below.
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 Closing the Matching Component Results Window

To close the display window, choose File > Close Window from the menu.

  

 Examining the Matching Component Design

You can look at the details of the autogenerated design inside the SmartComponent's
subnetwork.
To examine the component's subnetwork:

Select the component LCBandpassMatch .1.
Click Push Into Hierarchy on the schematic toolbar.2.
After examining the design, click Pop Out on the schematic toolbar to close the view.3.

  

 Analyzing Yield of the Matching Network

After the design process, the component sensitivities of the matching network can be
checked using the Yield Assistant .
To find components to analyze:

Click the Yield Assistant tab on the Impedance Matching Utility window.1.
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Click View Components > Modify Statistics/Optimization . The matching2.
network displays in the schematic along with a dialog box.

To choose components:

Choose Enabled from the Statistics Status drop-down menu.1.
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Select Next to move on to the next component. Repeat this until all 3 components in2.
the network are enabled, and then click Done .
Click Close in the Statistical Component Values dialog box.3.

To analyze yield sensitivity of the network:

In the Yield Assistant tab, select Automatically Set Frequencies .1.
Select by Simulate to start the Yield Assistant and analyze the yield sensitivity to2.
the selected component values. The results display automatically. The sensitivity
histogram for component C1 is shown here.

To close the display window, choose File > Close from the menu.3.
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 Deleting the Matching SmartComponent

To delete the LCBandpassMatch SmartComponent, choose Tools > Delete
SmartComponent from the Control window.

Note
The Delete button on the Control window is different from the Delete button on the ADS schematic
window toolbar.

This completes the step-by-step example.
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 SmartComponent Reference for
Impedance Matching Utility
This section contains detailed information for each Impedance Matching Utility
SmartComponents.

LCLowpassMatch (Lowpass Match) (impmatchutil)

LCHighpassMatch (Highpass Match) (impmatchutil)

LCBandpassMatch (Bandpass Match) (impmatchutil)

LCBandpassTransformer (Bandpass Transformer) (impmatchutil)

SingleStubMatch (Single-Stub Match) (impmatchutil)

QuarterWaveMatch (Quarter Wave Match) (impmatchutil)

TaperedLineMatch (Tapered Line Match) (impmatchutil)

LCEllMatch (Two-Element Ell Narrowband Match) (impmatchutil)
  

 LCBandpassMatch (Bandpass Match) 
 

 Symbol

 

 Summary

A bandpass matching network provides a bandpass frequency response between the input
(pin 1) and output (pin 2) ports. The source or load terminations can be specified using
either a lumped component approximation, a frequency independent complex impedance,
or a Touchstone format S-parameter file. Analytic and Real Frequency synthesis methods
are both possible. The number of reactive components (N) is approximate due to potential
component absorption.
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 Parameters

Name Description Unit Default

Fp1 Frequency at lower passband edge GHz 1

Fp2 Frequency at upper passband edge GHz 2

SynthesisType Synthesis procedure, Analytic or Real Frequency (impmatchutil) None Analytic

GainChange Linear gain change over passband (can be negative) dB 0

N Network order None 3

SourceType Type of source impedance None Resistive

Rg Source resistance Ohms 50

Lg Source inductance nH 1

Cg Source capacitance pF 1

Zg Source impedance Ohms 50+j×50

SourceFile Source S-parameter file name None ZSource.s1p

SourceFileSparm Source S-parameter None "S(1,1)"

SourceImpType Complex source impedance interpretation None Source Impedance

LoadType Type of load impedance None Series RLC

RL Load resistance Ohms 50

LL Load inductance nH 1

CL Load capacitance pF 1

ZL Load impedance Ohms 100-j*100

LoadFile Load S-parameter file name None ZLoad.s1p

LoadFileSparm Load S-parameter None "S(1,1)"

LoadImpType Complex load impedance interpretation None Load Impedance

 

 Palette

Filter DG - All Networks

 

 Available Automated-Assistants

Matching Assistant, Simulation Assistant, Yield Assistant, Display Assistant

 

 Matching Assistant Usage

For general information, refer to Matching Assistant (dgfilter).Network order results in
approximately 2×N elements, although this varies due to component absorption as well as
required network transformations.

 

 Simulation Assistant Usage
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For general information, refer to Simulation Assistant (dgfilter).

 

 Yield Assistant Usage

For general information, refer to Yield Assistant (dgfilter).

 

 Display Assistant Usage

For general information, refer to Display Assistant (dgfilter).

 

 Example

A bandpass matching network (N=2) was designed for a passband between 1 GHz and 2
GHz with a complex source termination (Zg=20 + j×50 Ohms) and a Series RLC load
termination (RL=50 Ohms, LL=1 nH, CL=1 pF). 20 choices are offered for the network.
Choosing the first network results in a match realized using five reactive components. See
Bandpass Matching Network.

 

 Bandpass Matching Network

  

 LCBandpassTransformer (Bandpass Transformer) 
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 Symbol

 

 Summary

A bandpass transformer provides a bandpass (pseudo-lowpass) frequency response
between the input (pin 1) and output (pin 2) ports. The source or load terminations must
be real and unequal.

 

 Parameters

Name Description Unit Default

Fp1 Frequency at left passband edge GHz 1

Fp2 Frequency at right passband edge GHz 2

N Network order None 3

ResponseType Type of frequency response None Maximally Flat

Rg Source resistance Ohms 50

RL Load resistance Ohms 25

 

 Palette

Filter DG - All Networks

 

 Available Automated-Assistants

Matching Assistant, Simulation Assistant, Yield Assistant, Display Assistant

 

 Matching Assistant Usage

For general information, refer to Matching Assistant (dgfilter). The terminations must be
unequal or no network is synthesized. For equal terminations, use a doubly-terminated
filter topology. Network order results in 2×N components.

 

 Simulation Assistant Usage
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 Simulation Assistant Usage

For general information, refer to Simulation Assistant (dgfilter).

 

 Yield Assistant Usage

For general information, refer to Yield Assistant (dgfilter).

 

 Display Assistant Usage

For general information, refer to Display Assistant (dgfilter).

 

 Example

A bandpass transformer (N=3) was designed for a passband between 1 GHz and 2 GHz
with a source resistance of Rg=50 Ohms and a load resistance of Rl=20 Ohms. See
Bandpass Transformer.

 

 Bandpass Transformer

  

 LCEllMatch (Two-Element "Ell" Narrowband Match) 
 

 Symbol
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 Summary

An Ell matching network provides a narrowband bandpass frequency response between
the input (pin 1) and output (pin 2) ports. The source or load terminations can be
specified using either a lumped component approximation, a frequency independent
complex impedance, or a Touchstone format S-parameter file.

 

 Parameters

Name Description Unit Default

F Frequency at center GHz 1

SourceType Type of source impedance None Resistive

Rg Source resistance Ohms 50

Lg Source inductance nH 1

Cg Source capacitance pF 1

Zg Source impedance Ohms 50+j×50

SourceFile Source S-parameter file name None ZSource.s1p

SourceFileSparm Source S-parameter None "S(1,1)"

SourceImpType Complex source impedance interpretation None Source Impedance

LoadType Type of load impedance None Series RL

RL Load resistance Ohms 100

LL Load inductance nH 1

CL Load capacitance pF 1

ZL Load impedance Ohms 100-j*100

LoadFile Load S-parameter file name None ZLoad.s1p

LoadFileSparm Load S-parameter None "S(1,1)"

LoadImpType Complex load impedance interpretation None Load Impedance

 

 Palette

Impedance Matching

 

 Available Automated-Assistants
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Matching Assistant, Simulation Assistant, Yield Assistant, Display Assistant,
Transformation Assistant

 

 Matching Assistant Usage

For general information, refer to Matching Assistant (dgfilter).

 

 Simulation Assistant Usage

For general information, refer to Simulation Assistant (dgfilter).

 

 Yield Assistant Usage

For general information, refer to Yield Assistant (dgfilter).

 

 Display Assistant Usage

For general information, refer to Display Assistant (dgfilter).

 

 Example

An Ell matching network was designed for a center frequency of 1 GHz with a 50 Ohm
source resistance and a Series RLC load termination (RL=50 Ohms, LL=1 nH, C =1 pF).
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 Ell Matching Network

  

 LCHighpassMatch (Highpass Match) 
 

 Symbol

 

 Summary

A highpass matching network provides a highpass frequency response between the input
(pin 1) and output (pin 2) ports. The source or load terminations can be specified using
either a lumped component approximation, a frequency independent complex impedance,
or a Touchstone format S-parameter file. Analytic and Real Frequency synthesis methods
are both possible. The network order (N) is approximate due to potential component
absorption.

 

 Parameters
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Name Description Unit Default

Fp Frequency at passband edge GHz 1

SynthesisType Synthesis procedure, Analytic or Real Frequency (impmatchutil) None Analytic

GainChange Linear gain change over passband (can be negative) dB 0

N Network order None 3

SourceType Type of source impedance None Resistive

Rg Source resistance Ohms 50

Lg Source inductance nH 1

Cg Source capacitance pF 1

Zg Source impedance Ohms 50+j×50

SourceFile Source S-parameter file name None ZSource.s1p

SourceFileSparm Source S-parameter None "S(1,1)"

SourceImpType Complex source impedance interpretation None Source Impedance

LoadType Type of load impedance None Series RC

RL Load resistance Ohms 50

LL Load inductance nH 1

CL Load capacitance pF 2

ZL Load impedance Ohms 100-j*100

LoadFile Load S-parameter file name None ZLoad.s1p

LoadFileSparm Load S-parameter None "S(1,1)"

LoadImpType Load impedance None Load Impedance

 

 Palette

Filter DG - All Networks

 

 Available Automated-Assistants

Matching Assistant, Simulation Assistant, Yield Assistant, Display Assistant

 

 Matching Assistant Usage

For general information, refer to Matching Assistant (dgfilter). When representing the
source and/or load using lumped components, only lowpass type networks are allowed.
Arbitrary terminations can be implemented using S-parameter files. However, if the
specified termination impedance is not of lowpass form, the resulting matching network
response approximates a lowpass form but typically rolls off at the low end of the band.

 

 Simulation Assistant Usage

For general information, refer to Simulation Assistant (dgfilter).
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 Yield Assistant Usage

For general information, refer to Yield Assistant (dgfilter).

 

 Display Assistant Usage

For general information, refer to Display Assistant (dgfilter).

 

 Example

A highpass matching network (N=4) was designed for 1 GHz with a Parallel RL source
termination (Rg=20 Ohms, Lg=8 nH) and a Series RC load termination (RL= 50 Ohms,
CL=1 pF). The match is realized using three reactive components, since the load
capacitance is absorbed by the designed network.

 

 Highpass Matching Network

  

 LCLowpassMatch (Lowpass Match) 
 

 Symbol
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 Summary

A lowpass matching network provides a lowpass frequency response between the input
(pin 1) and output (pin 2) ports. The source or load terminations can be specified using
either a lumped component approximation, a frequency independent complex impedance,
or a Touchstone format S-parameter file. Analytic and Real Frequency synthesis methods
are both possible. The network order (N) is approximate due to potential component
absorption.

 

 Parameters

Name Description Unit Default

Fp Frequency at passband edge GHz 1

SynthesisType Synthesis procedure, Analytic or Real Frequency (impmatchutil) None Analytic

GainChange Linear gain change over passband (can be negative) dB 0

N Network order None 3

SourceType Type of source impedance None Resistive

Rg Source resistance Ohms 50

Lg Source inductance nH 1

Cg Source capacitance pF 1

Zg Source impedance Ohms 50+j×50

SourceFile Source S-parameter file name None ZSource.s1p

SourceFileSparm Source S-parameter None "S(1,1)"

SourceImpType Complex source impedance interpretation None Source Impedance

LoadType Type of load impedance None Series RL

RL Load resistance Ohms 50

LL Load inductance nH 1

CL Load capacitance pF 1

ZL Load impedance Ohms 100-j*100

LoadFile Load S-parameter file name None ZLoad.s1p

LoadFileSparm Load S-parameter None "S(1,1)"

LoadImpType Complex load impedance interpretation None Load Impedance

 

 Palette

Filter DG - All Networks
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 Available Automated-Assistants

Matching Assistant, Simulation Assistant, Yield Assistant, Display Assistant

 

 Matching Assistant Usage

For general information, refer to Matching Assistant (dgfilter). When representing the
source and/or load using lumped components only lowpass type networks are allowed.
Arbitrary terminations can be implemented using S-parameter files. However, if the
specified termination impedance is not of lowpass form, the resulting matching network
response approximates a lowpass form but typically rolls off at the low end of the band.

 

 Simulation Assistant Usage

For general information, refer to Simulation Assistant (dgfilter).

 

 Yield Assistant Usage

For general information, refer to Yield Assistant (dgfilter).

 

 Display Assistant Usage

For general information, refer to Display Assistant (dgfilter).

 

 Example

A lowpass matching network (N=3) was designed for 1 GHz with a resistive source
termination (Rg=50 Ohms) and a Series RL load termination (RL=50 Ohms, LL=1 nH).
The match is realized using two reactive components, since the load inductance is
absorbed by the designed network.
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 Lowpass Matching Network

  

 QuarterWaveMatch (Quarter Wave Match) 
 

 Symbol

 

 Summary

A quarter wave transformer network provides a broadband bandpass frequency response
between the input (pin 1) and output (pin 2) ports. The source or load terminations must
be unequal resistances. The matching network consists of multiple quarter wavelength
transmission line elements with carefully computed characteristic impedances to provide
the specified frequency response.

 

 Parameters
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Name Description Unit Default

Fp1 Frequency at lower passband edge GHz 1

Fp2 Frequency at upper passband edge GHz 2

Rg Input impedance Ohms 50

RL Load impedance Ohms 100

ResponseType Type of frequency response None Uniform

N Number of Quarter-Wave Sections (set N=0 to compute N) None 0

Rmax Maximum voltage reflection coefficient dB 20

 

 Palette

Impedance Matching

 

 Available Automated-Assistants

Matching Assistant, Simulation Assistant, Yield Assistant, Display Assistant,
Transformation Assistant

 

 Matching Assistant Usage

For general information, refer to Matching Assistant (dgfilter).

 

 Simulation Assistant Usage

For general information, refer to Simulation Assistant (dgfilter).

 

 Yield Assistant Usage

For general information, refer to Yield Assistant (dgfilter).

 

 Display Assistant Usage

For general information, refer to Display Assistant (dgfilter).

 

 Example

A quarter wave transformer was designed to match a 100 Ohm load impedance to a 50
ohm source impedance from 1GHz to 2 GHz. The maximum reflection coefficient was -20
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dB, with a uniform distribution of the section reflection coefficients. The design resulted in
N=3 sections.

 

 Quarter Wave Transformer

  

 SingleStubMatch (Single-Stub Match) 
 

 Symbol

 

 Summary

A single-stub matching network provides a narrowband bandpass frequency response
between the input (pin 1) and output (pin 2) ports. The source or load terminations can be
specified using either a lumped component approximation, a frequency independent
complex impedance, or a Touchstone format S-parameter file.

 

 Parameters
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Name Description Unit Default

F Frequency at center GHz 1

Zstub Characteristic Impedance of stub line Ohm 50

Zline Characteristic Impedance of line between load and stub Ohm 50

SourceType Type of source impedance None Resistive

Rg Source resistance Ohms 50

Lg Source inductance nH 1

Cg Source capacitance pF 1

Zg Source impedance Ohms 50+j×50

SourceFile Source S-parameter file name None ZSource.s1p

SourceFileSparm Source S-parameter None "S(1,1)"

SourceImpType Complex source impedance interpretation None Source Impedance

LoadType Type of load impedance None Series RL

RL Load resistance Ohms 100

LL Load inductance nH 1

CL Load capacitance pF 1

ZL Load impedance Ohms 100-j*100

LoadFile Load S-parameter file name None ZLoad.s1p

LoadFileSparm Load S-parameter None "S(1,1)"

LoadImpType Complex load impedance interpretation None Load Impedance

 

 Palette

Impedance Matching

 

 Available Automated-Assistants

Matching Assistant, Simulation Assistant, Yield Assistant, Display Assistant,
Transformation Assistant

 

 Matching Assistant Usage

For general information, refer to Matching Assistant (dgfilter).

 

 Simulation Assistant Usage

For general information, refer to Simulation Assistant (dgfilter).

 

 Yield Assistant Usage
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For general information, refer to Yield Assistant (dgfilter).

 

 Display Assistant Usage

For general information, refer to Display Assistant (dgfilter).

 

 Example

A single-stub matching network was designed to match a Series RL (R=100 Ohms, L =1
nH) load impedance to a 50 ohm source impedance at a center frequency of 1 GHz.
Choosing the configuration with an open-circuit stub yielded a design offering the results
shown in the illustration below, Single-stub Matching Network.

 

 Single-stub Matching Network

  

 TaperedLineMatch (Tapered Line Match) 
 

 Symbol
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 Summary

A tapered line transformer network provides a broadband highpass frequency response
between the input (pin 1) and output (pin 2) ports. The source or load terminations must
be unequal resistances. The network consists of multiple transmission line sections to
approximate a tapered line.

 

 Parameters

Name Description Unit Default

Fp Frequency at lower passband edge (Response is Highpass) GHz 1

Rg Input impedance Ohms 50

RL Load impedance Ohms 100

ResponseType Type of frequency response None Exponential Taper

Rmax Maximum voltage reflection coefficient dB -20

N Number of TLine Sections per wavelength None 0

 

 Palette

Impedance Matching

 

 Available Automated-Assistants

Matching Assistant, Simulation Assistant, Yield Assistant, Display Assistant,
Transformation Assistant

 

 Matching Assistant Usage

For general information, refer to Matching Assistant (dgfilter).

 

 Simulation Assistant Usage

For general information, refer to Simulation Assistant (dgfilter).

 

 Yield Assistant Usage

For general information, refer to Yield Assistant (dgfilter).
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 Display Assistant Usage

For general information, refer to Display Assistant (dgfilter).

 

 Example

A tapered transformer was designed to match a 100 Ohm load impedance to a 50 ohm
source impedance with a lower passband edge of 1GHz. The maximum reflection
coefficient was -20 dB, with an exponential taper. The design used N=20 sections per
wavelength.

 

 Tapered Transformer

 

 References
Thomas R. Cuthbert, Jr., Circuit Design Using Personal Computers , John Wiley &1.
Sons, New York, 1983.
R. Levy, "Explicit formulas for Chebyshev impedance-matching networks," Proc. IEEE2.
, pp. 1099-1106, June 1964.
R. M. Cottee and W. T. Joines, "Synthesis of lumped and distributed networks for3.
impedance matching of complex loads," IEEE Trans. Circuits Syst. , pp. 316-329, May
1979.
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 Using Automated Assistants in
Impedance Matching Utility
This section describes the Automated Assistants available in this Utility.

  

 Automated Design and Analysis
The Automated Assistants provide quick design, simulation, yield analysis, and
performance display for SmartComponents and enable transformation of lumped elements
to transmission line elements. Five Automated Assistants are available in this Utility:

Matching Assistant (dgfilter) is used to generate and update the design contained
within a matching or transformer SmartComponent from the given specifications.

Simulation Assistant (dgfilter) is used to analyze the design contained within a
SmartComponent.

Yield Assistant (dgfilter) is used to analyze the design sensitivities contained within a
SmartComponent.

Display Assistant (dgfilter) is used to easily and quickly display the performance of a
SmartComponent.

Transformation Assistant (dgfilter) is used to transform an ideal filter topology to a
form that is realizable for high-frequency systems.

Explore each tab page by selecting the associated tab on the control window.

  

 Matching Assistant 
The Matching Assistant is used to generate and update the design contained within a
matching or transformer SmartComponent from the given specifications. This tool is
accessed using the Matching Utility window. From the utility window, full design control is
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enabled from the Matching Assistant tab. Component design operations can also be
accomplished using the utility window menu and toolbar. Any parameter change made
from the Matching Assistant tab is reflected on the SmartComponent in the schematic.

To view a SmartComponent, select the SmartComponent from the SmartComponent drop-
down list box in the upper right corner of the utility window. The SmartComponent
parameters are shown inside the Matching Assistant tab.

 

 Matching Assistant SmartComponents

The Matching Assistant SmartComponents include lumped and distributed element
matching networks and transformers.

 

 Matching Networks

Matching networks provide a match between two real or complex impedances over a given
frequency range. The response can be lowpass, highpass, or bandpass if allowed by the
specified impedance termination.

 

 Transformers

Transformers provide a bandpass match between two unequal but real impedances using
a special transform of a lowpass filter network.

  

 Specifications
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ResponseType - frequency response type for transformer networks. Choices consist
of Maximally Flat , Chebyshev , Bessel-Thompson , and Gaussian . This menu is used
for transformers only.
Synthesis Technique - Method used to synthesize the matching network - Analytic or
Real Frequency . This menu is used for matching networks only.
Order - The network order. This is approximately the number of reactive components
for lowpass and highpass matching networks. For bandpass matching networks or
transformers, the number of reactive components is approximately twice the order
(exactly twice for transformers). For matching networks, absorption of source and
load reactances as well as component transformations can change this number.
Gain Change - Gain Change in dB over the band for matching networks. During
synthesis, this parameter is ignored. However, if optimization is selected, this slope
will be applied as part of the optimization goal. This parameter must be positive. The
target gain will start at the left passband edge at -(Gain Change) and ramp linearly
(in dB) to 0. This field is used for matching networks only.
Fp1, Fp2 - Lower and upper passband edge frequencies in Hertz. For lowpass and
highpass networks, Fp2 is not used and Fp1 is changed to Fp to represent the
passband edge frequency. Frequency values are changed by entering new values in
the edit box. Units are changed by selecting a new unit identifier from the drop-down
menu.
Line Impedance, Stub Impedance - Characteristic impedance of transmission lines
and stubs used in distributed element matching networks.
Max Reflection Coeff - Maximum reflection coefficient in the passband for certain
distributed element matching networks.
# Sections/Wavelength - Number of transmission line segments per wavelength to
use to approximate linear taper with transmission line elements.

  

 Terminations

For transformers, the terminations must be resistive with unequal values. As such, only
the R input boxes are available for transformers. For other matching networks, the
terminations can be input using lumped components networks, complex impedances, and
S-parameter files. Usage for these different types is:

Lumped Component - Choices include Resistive, Series RL, Series RC, Parallel RL,
Parallel RC, Series RLC, Parallel RLC, where R = resistance, L = inductance, and C =
capacitance. Component values must be specified by the user. For lowpass networks,
choices are limited to Resistive, Series RL, and Parallel RC. For highpass networks,
choices are limited to Resistive, Series RC, and Parallel RL.
Complex Impedance - The impedance is interpreted as frequency independent,
expressed in the form 50 + j×10 Ohms. This input approach is useful for narrowband
matching. If the true impedance varies significantly with frequency, better accuracy
is obtained by specifying the termination using an S-parameter file or manually
entering the data using the spreadsheet data entry capability.
S-Parameter File - Any termination can be represented using a file in Touchstone
format representing 1-port parameters ( *.s1p ). The impedance can be specified in
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S, Z, or Y parameters. For details on data file format, refer to the Circuit Simulation
manual under SnP format . The Browse button launches a window to enable selection
of the file.
Manual Data Entry - The complex impedance - specified as an impedance,
admittance, or reflection coefficient - can be entered as a function of frequency
manually. When the source or load impedance is specified as Manual Entry, the Edit
button can be used to open a spreadsheet useful for entering frequency/impedance
pairs.

Interpret as Input/Output Impedance - These options are available for three cases of
source and load impedance; complex load, S-parameter file, and Manual entry. Use
the Interpret as Input Impedance option to specify that the value you have entered is
of impedance looking into the device (S-parameters of the measured device, for
instance). Use the Interpret as Output Impedance option to specify that the value
you have entered is of impedance looking out from the device (impedance you want
to see). For more information, see Designing with an S2P File (dgfilter).

  

 Design

The design is accomplished using one of the these methods.

Click Design on the Matching Assistant tab.
Click Design on the utility window toolbar.
Choose Tools > Auto-Design from the utility window menu.
After completion of the synthesis, a dialog box appears.
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 Optimization range

All networks can be viewed using the spin box. Each network can be viewed in two places:

Dialog Box - Shows a text based description of the current network.
Schematic Window - Shows the actual drawing of the current network.

For each network, the maximum error in the passband response in dB (taken with respect
to the ideal flat or sloped response) appears in the dialog box. The response over the
specified passband is also shown in an interactive graph. The scale on this graph can be
changed manually using the spin box immediately below the graph. Checking the
Autoscale box will automatically choose the scale to fit the response within the graph area.

The response of the matching network can be optimized from this dialog by clicking the
Optimize button. The vertical lines on the graph, which by default lie at the edges of the
band, are markers used for specification of the optimization frequencies. These markers
can be moved by clicking and dragging them with the mouse, with the marker frequency
being displayed in the corresponding text box to the right of the plot (the markers and
labels for the text boxes are color coordinated). If the radio box for Frequency Range is
selected, the optimization will be performed to minimize the Maximum Error over the
range of frequencies between the two markers. If the radio box for Discrete Frequencies is
selected, initially only a single marker is present. Up to three additional markers can be
added by clicking the appropriate Activate button. Each added marker can also be
removed by clicking the corresponding Deactivate button. Under this option, the
optimization will be performed to minimize the Maximum Error at the frequencies
indicated by the markers. Clicking the Optimize All button sequentially optimizes all
networks found using the optimization parameters displayed. This optimization process
can be canceled from the progress indicator that appears after the optimizer is launched.
After the optimization is complete, the updated network appears in the dialog box and on
the schematic.
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 Discrete optimization points

  

 Synthesis Technique

Two different techniques are available for lumped element matching network synthesis:
Analytic and Real Frequency.

Analytic - For this method, a Chebyshev filter is chosen that can completely or
partially absorb the source and load reactances, as outlined in [1], [2]. If the
specified network order generates reactance topologies at the ends of the network
that cannot absorb the specified terminations, the Utility informs the user that the
network order is increased by one. This synthesis procedure is very robust,
particularly for terminations that are modeled as lumped components. For
terminations specified as a complex impedance, the Utility computes the simplest
lumped component topology that produces this impedance at the band edge or
center frequency. For terminations specified using an S-parameter file or manual
entry, the Utility generates a lumped component model for the specified impedance
variation with frequency.
Real Frequency - This method uses the basic Chebyshev matching capability of the
Analytic approach. However, application of the technique is modified by breaking the
frequency band into small pieces, performing the match over this small band by
finding a lumped component fit to the impedance given, and retaining the networks
with the lowest insertion loss. Typically, optimization is required to obtain a good
match over the entire passband. This approach is useful for loads that are not well
modeled using the simple lumped component network choices given. For lowpass or
highpass networks with N = 2 or bandpass networks with N = 1, this method
synthesizes narrowband 2 component matching networks (L networks), retaining
those that provide the best match over the band.
Transformers - Lumped element transformers provide a pseudo-bandpass response
to match two real and unequal resistances over a specified frequency band. The
approach uses a transformation of a lowpass filter network to achieve the match [1],
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[3]. The quality of the match in terms of passband error depends upon the frequency
bandwidth chosen as well as the ratio of the terminating impedances. Distributed
element transformers create a true bandpass response over the band.
Narrow Band Matching Networks - The lumped two element (Ell) matching network
as well as the single stub matching network provide exact matching at a single
frequency.

  

 Designing with an S2P File

Use these steps for designing with an S2P file:

For input match, start with a resistive source of 50 Ohms, load pointing to S11 of the1.
S2P file. Design optimize "input match." You need to optimize repeatedly to improve
the performance, until you see not much change.
For output match, start with S22 of the S2P file as source, load set to 50 Ohms.2.
Design and optimize.

Note
You do not have to set the interpret as input/output, so DO NOT choose those buttons at all while
designing with S2P files. This button essentially toggles whether the program takes the conjugate of
the data you enter or not. Sometimes you collect impedance data for the device you have, or
sometimes it is for the impedance you want. So, effectively, it changes the perspective of whether
you are looking into the DUT or looking into the matching circuit. This is used mostly while using the
Manual entry mode for Impedances.

You can try using analytical or higher order to see whether you can improve the3.
performance further.

  

 Simulation Assistant 
The Simulation Assistant is used to analyze the design contained within a
SmartComponent. The Assistant creates a simulation circuit around the SmartComponent,
then automatically performs the appropriate simulation. If set, the Assistant automatically
displays the simulation results.

The Simulation Assistant is accessed using the Matching Utility window, where full
simulation control is enabled from the Simulation Assistant tab. Basic simulation can also
be accomplished using the utility window menu and toolbar.
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For all simulation operations, the selected SmartComponent is designed if necessary, a
simulation schematic is created, the simulation is performed, and the results are
displayed. The simulation frequency sweep must be specified on the Simulation Assistant
tab in the utility window as described in detail below.

  

 Simulation Frequency Sweep

The simulation frequency sweep is specified on the Matching Utility window. While
performing the simulation from the utility window, select the Simulation Assistant tab and
specify the sweep by entering the start frequency, stop frequency, and either frequency
step size or number of points. The values entered are stored in the selected
SmartComponent (as displayed in the SmartComponent drop-down list box) and are
recalled each time this SmartComponent is selected.

  

 Displaying Results Automatically

If you click the Automatically Display Results button on the utility window Simulation
Assistant tab, the simulation results are displayed automatically after completion of the
analysis.

  

 Starting the Simulation

The simulation can accomplished using one of these methods.

Click Simulate on the Simulation Assistant tab.
Click Simulate on the utility window toolbar.
Choose Tools > Auto-Simulate from the utility window menu.
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 Simulation Templates

In some cases, you can simulate the SmartComponent manually.
To generate a simulation schematic around the selected SmartComponent:

Click Create Template on the Simulation Assistant tab.1.
You can examine or modify the simulation schematic, then manually start the2.
simulation by choosing Simulate > Simulate from the Schematic window.
When you are finished, click Update from Template on the Simulation Assistant tab3.
to transfer any changes you have made to the SmartComponent on the simulation
schematic to the original SmartComponent and redesign if necessary.
Close the simulation schematic by choosing File > Close Design from the Schematic4.
window menu, although this results in loss of any changes you have made to the
SmartComponent.

   

 Yield Assistant 
The Yield Assistant is used to analyze the design sensitivities contained within a
SmartComponent. The Assistant creates a yield analysis circuit containing the
SmartComponent, then performs a simulation. By sweeping the component values for a
selected set of components in the network, this analysis generates a probability density
function of the performance given statistical variations of the component values. The
probability that the performance remains within the specified bounds is the yield of the
network.

The Yield Assistant is accessed using the Matching Utility window, where full control is
enabled from the Yield Assistant tab. Basic yield analysis can also be accomplished using
the utility window menu and toolbar.
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The selected SmartComponent must be designed before yield analysis can be performed.
The analysis proceeds by statistically sweeping the value of each selected component and
analyzing the impact of this component value variation on the frequency response of the
network.

  

 Simulation Frequency Sweep

The simulation frequency sweep is specified on the Yield Assistant tab of the Matching
Utility window. From this tab, specify the sweep by entering the start frequency, stop
frequency, and either frequency step size or number of points. The values entered are
stored in the selected SmartComponent (as displayed in the SmartComponent drop-down
list box) and are recalled each time this SmartComponent is selected.

  

 Statistical Components

The Statistical Components list-box displays all components that are statistically varied
during simulation. Clicking Update opens the dialog box (shown below) to simplify the
process of selecting components.

The matching network is shown in the schematic with the currently selected component
highlighted. If you want this component value to be swept statistically during the analysis,
select Enabled in the Statistics Status box. You can then specify the parameters of the
statistical sweep. After you have specified all parameters for a component, clicking Next
takes you to the next component in the network. The analysis allows for a maximum of 4
components to be selected at one time. After you have finished specification, you can click
Done from the dialog box to return to the Yield Assistant tab. Clicking View under the
Statistical Components box opens a dialog box from which you can view a summary of the
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statistical parameters for each selected component. There are also buttons to take you
directly to the Modify Component Parameters dialog from this summary dialog to facilitate
editing of the statistical sweep parameters.

The # Simulations parameter specifies the number of Monte Carlo simulations that are
used to estimate the statistical behavior of the network. Increasing the number of
simulations increases the statistical sample size and therefore provide a better estimate of
the performance at the expense of increased computational time.

  

 Yield Optimization

The network component values can also be optimized so that the performance is less
sensitive to component value variations. This can be accomplished by selecting the Yield
Optimization check box. In this case, the optimization requires that a set of performance
goals be specified for the network. The yield is defined as the probability that the network
frequency response satisfies these performance specifications given the statistical
properties of the individual components. Each component has a default set of goals
depending on the type of response (lowpass, bandpass, etc.). Each goal specifies the
insertion loss performance of the network in dB and can represent a specification that the
value stay above or below the stated level. The specification can be at a single point, or
over a given frequency band. For a single frequency point, set the pulldown to "at", and
set the frequency parameter. For a range of frequencies, set the pulldown to "from",
which will activate both frequency parameters in order to specify the frequency range.
To modify the default goals:

Press Set Yield Spec/Goals button on the Yield Assistant tab to open the dialog.1.
Add or delete goals:2.

Use the Add Goal button to add new goals.
Use the Del button to the right of the goal to delete individual goals
Use the Delete All Goals button to delete all goals. The goals can be reset to
their default values using the Default button.
A goal is used in the analysis only if the Active box at the left of the goal line is
checked.
The # Iterations parameter available for Yield Optimization specifies the
maximum number of optimization iterations that the simulation performs to try
to find the appropriate network component values.

  

 Displaying Results Automatically
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If the Automatically Display Results box on the utility window Yield Assistant tab is
selected, the simulation results is displayed automatically after completion of the analysis.

  

 Starting the Simulation

The yield analysis can accomplished using one of these methods.

Click the Simulate button on the Yield Assistant tab.
Click the Simulate Yield button on the utility window toolbar.
Choose Tools > Auto-Simulate Yield from the utility window menu.

  

 Yield Results

For each component (up to a maximum of 4) chosen for yield analysis, a yield sensitivity
histogram is displayed. The yield definition can be changed on the first page of the display
by setting passband frequencies Fp_1 and Fp_2 as well as the maximum insertion loss at
these frequencies, and stopband frequencies Fs_1 and Fs_2 as well as the minimum
insertion loss at these frequencies. Other pages in the display show the overall statistics of
the yield as well as the frequency response for each of the Monte Carlo simulations.

  

 Yield Templates

In some cases, you can simulate the SmartComponent manually.
To generate a simulation schematic around the selected SmartComponent:

Click Create Template on the Yield Assistant tab.1.
After examining or modifying the simulation schematic, manually start the simulation2.
by choosing Simulate > Simulate from the Schematic window.
When you are finished, click the Close Template button on the Yield Assistant tab to3.
return to the original design. You can also manually close the simulation schematic
by choosing File > Close Design from the Schematic window menu.

  

 Display Assistant 
The Display Assistant is used to easily and quickly display the performance of a
SmartComponent. The display templates are preconfigured display files that provide a
comprehensive look at the performance of the component. You can create your own
displays or modify the included display templates using the built in features of Advanced
Design System, but in most situations, the included display templates provides all the
information you need.
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The Display Assistant is accessed using the Matching Utility window, where full display
control is enabled from the Display Assistant tab. Basic display selection can also be
accomplished using the utility window menu and toolbar

Before using the Display Assistant, a valid dataset from a simulation of the selected
SmartComponent must exist in the current workspace data directory. This simulation can
be conveniently accomplished using the Simulation Assistant. Refer to Simulation
Assistant (dgfilter) for details on this step.

  

 Opening a Display

To display results from a SmartComponent simulation using the utility window, select the
SmartComponent from the SmartComponent drop-down list box in the upper right corner
of the utility window. The display is then launched using one of the these methods.

Click Display on the Display Assistant tab.
Click Automatically Display Simulation Results on the utility window toolbar.
Choose Tools > Auto-Display from the utility window menu.
If no valid dataset exists for the selected SmartComponent, the Display button on the
Display Assistant tab is de-activated. If the toolbar or menu are used to try to display
the results, a message appears indicating that no dataset exists.

  

 Display Template Features

The display templates opened by the Display Assistant have common features that are
discussed here. For features unique to the display templates of some SmartComponents,
refer to SmartComponent Reference (dgfilter).
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 Basic Layout

Basic Layout of Display Templates (dgfilter) shows the basic layout of the display
templates. Area one of the display template contains a graph of the most important
parameters of the SmartComponent. Area two contains several graphs that give a
comprehensive look at the component's performance. Area three contains a table listing
the basic specifications and performance of the component.

 

 Basic Layout of Display Templates

  

 Typical Area One Graph

The following figure shows a typical graph from area one of a display template.

  

 Basic Layout

Basic Layout of Display Templates (dgfilter) shows the basic layout of the display
templates. Area one of the display template contains a graph of the most important
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parameters of the SmartComponent. Area two contains several graphs that give a
comprehensive look at the component's performance. Area three contains a table listing
the basic specifications and performance of the component.

 

 Basic Layout of Display Templates

The frequency range of the graph is determined by the Simulation Assistant. As you
change the frequency range in the Simulation Assistant, this graph updates automatically.
The markers A and B are used to define the frequency range of the graphs in area two.
This feature is used to zero in on the region of interest and obtain a comprehensive look
at the component's performance. The marker M1 can be moved by dragging the marker
with the mouse. The performance at the frequency given by M1 is shown in the table in
area three.

  

 Typical Area Two Graphs

Typical Graphs from Area Two (dgfilter) shows typical graphs from area 2 of a display
template.

 

 Typical Graphs from Area Two

These graphs provide a quick, comprehensive look at the component's performance. Their
frequency range is determined by the location of the "A" and "B" markers found in the
main graph. Any markers such as M2 shown here can be moved by dragging them with
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the mouse. Performance criteria at the marker frequency displays in the table in area
three.

  

 Typical Area Three Templates

Typical Table from Area Three (dgfilter) shows a typical table from area three of a display
template.

 

 Typical Table from Area Three

The white rows show the specifications and important performance criteria for the
component. The gray rows show the performance criteria at the user defined marker
frequencies. The box below the table provides explanatory information for the table.

  

 Using Display Templates in Other Applications

In some cases, you can use one of the display templates provided with the Impedance
Matching Utility for other applications.
To gain access to one of the templates:

Select the template from the Available Templates field and click the Open Display1.
Template button on the utility window Display Assistant tab.
Insert a dataset of your choice using the dataset pull-down list box in the upper left2.
corner of the display. If some parameters in the display template are not defined in
the selected dataset, you can make appropriate modifications to the display. These
changes can be saved using the commands in the display File menu.
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Transformation Assistant 
After a Matching Utility SmartComponent has been designed, the lumped inductors and
capacitors can be transformed into equivalent distributed element counterparts using the
Transformation Assistant . This feature enables you to quickly and easily transform an
ideal filter topology to a form that is realizable for high-frequency systems.

  

 Opening the Transformation Assistant

The Transformation Assistant dialog box is accessed from the Matching Utility window,
either by selecting Tools > Distributed Element Transformations from the Tools menu
or from the Toolbar.

When the Transformation Assistant is opened, the SmartComponent subnetwork appears
in the schematic window and a dialog box is opened. The transformations are
accomplished using the controls on the dialog.
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 Selecting a Transformation Type

The type of transformation to be applied is selected from three options:

LC to TLine - Transforms lumped inductors and capacitors to ideal transmission line
elements. Eight different inductor/capacitor combinations can be transformed to
different series lines, series stubs, or shunt stubs.
TLine to TLine (Kuroda) - Apply Kuroda's identities in order to transform series short
circuited stubs to shunt stubs that are realizable in microstrip and other printed
transmission line technologies.
LC, TLine to Microstrip - Transforms lumped inductors and capacitors as well as ideal
transmission line structures to microstrip equivalent components. Application of this
transformation requires a valid license for the Passive Circuit DesignGuide.
After a transform has been selected, the graphical area displays the components that
can be transformed using the current selection. Black components represent
elements included in the original circuit available for transformation, while gray
components represent elements not included in the original circuit. From this
graphical area, use the left mouse button to select one of the available component
types. The graphical area changes to reveal the different distributed element
equivalents available for substitution. Transformations Available for Series Inductor
Circuit (dgfilter) shows the transformations available when a series inductor circuit
has been selected.

 

 Transformations Available for Series Inductor Circuit
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From this point, the type of equivalent network can be selected using the left mouse
button from the available structures at the right of the graphics area. A box highlights the
currently selected structure. Text at the bottom of the window changes as different
selections are made, providing some help concerning the particular transform selected.

  

 Component Selection

After the type of circuit component to be transformed is selected, the actual circuit
elements to apply the transform to can be selected using the Component Selection tools.
As the left and right arrows within this area are clicked, valid components within the
original circuit are highlighted, and their instance names (i.e., L1, C4) appears in the text
box on the Transformation Assistant dialog. The three buttons are used to select which
specific components should be subject to the current transformation:

Add - Add the currently selected component(s) to the transformation list.
Add All - Add all circuit components of the appropriate type to the transformation
list.
Cut - Remove the currently selected (highlighted) item in the transformation list from
the list.

  

 Transformation Buttons

The buttons across the bottom of the dialog box are used to accomplish the
transformation on the selected components.

Transform - Apply the selected transform to the component in the transformation
list.
Undo - Undo the last performed transform. This button can be used repeatedly to
undo all previous transformations.
OK - Accept the current transformed circuit and close the dialog box. After the
transformed circuit has been accepted, transformations cannot be undone.
Cancel - Close the dialog box and revert to the original, untransformed circuit.

  

 Changing Component Type

After all transformations have been made on a specific component type (such as series
inductor), use the left mouse button to click the red return arrow in the upper left hand
corner of the graphic area (or use the right mouse button to click anywhere on the graphic
area) to return to the main component selection page. Then you can select another
component type and repeat the transformation steps for this new selection.
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 Transmission Line Types

Five basic transmission line elements can be produced using the Transformation Assistant
are:

  

 Additional Transformation Functions
 

 Unit Element

For certain transformations, either the electrical length or characteristic impedance of the
resulting transmission line must be specified by the user. If the Unit Element box is
checked, the resulting transmission line has an electrical length of 45 degrees and the
characteristic impedance is computed appropriately. If the Unit Element box is unchecked,
then the Characteristic Impedance (Z0) box becomes active and the computation uses this
characteristic impedance to compute the appropriate length.

  

 Characteristic Impedance

The Characteristic Impedance (Z0) box is used to specify the transmission line
characteristic impedance for certain transformations. In cases where either the electrical
length or the characteristic impedance can be specified, this box works in conjunction with
the Unit Element box as discussed above. In certain other cases, this Characteristic
Impedance (Z0) box is used alone. For example, when adding lines to the front or end of
a network as part of Kuroda's identities, the characteristic impedance of the
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transformation can be specified using this box.

  

 Adding Transmission Lines

As part of the TLine to TLine transformation, unit element (45 degree electrical length)
transmission lines can be added to the front or end of the network. The characteristic
impedance of these lines is specified using the Characteristic Impedance (Z0) box. Such
lines can be added as needed during the transformation process. Addition of these lines
changes the phase response and, if the characteristic impedance is not equal to the
network terminal impedance, the magnitude response of the network.

  

 Microstrip Substrate

When performing LC, TLine to MLine transformations, the microstrip substrate thickness
(h) and relative permittivity (Er) must be specified. All microstrip elements within a design
must share the same substrate parameters. The substrate parameters used in the final
design are the values that appear in the boxes after the final transformation step.

  

 TLine to TLine Transforms (Kuroda Identities)

The TLine to TLine transforms are typically used to transform series short circuited stubs
to parallel open circuited stubs in preparation for implementation in planar transmission
line technologies. However, these operations only work on Unit Element lines with
electrical lengths of 45 degrees. Therefore, when performing lumped to ideal distributed
transformations, you must perform substitutions that conform to this Unit Element
specification. Preferred stubs (highlighted in blue on the graphical area) as well as series
transmission lines (transformed with the Unit Element box checked) can be transformed in
this way. When adding transmission line elements before or after the network, the
electrical length is 45 degrees and only the characteristic impedance must be specified.

  

 Microstrip Transforms

The LC, TLine to MLine transformations form a somewhat unique class of operations. This
set of transformations takes lumped inductor/capacitor combinations as well as ideal
series transmission lines and shunt transmission line stubs (obtained from the LC to TLine
transformations), and converts them to microstrip. Note that series stubs cannot be used
in this transformation since these cannot be realized in microstrip.

Note
This set of transforms is only available if a valid license for the Passive Circuit DesignGuide exists.
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In addition to the standard transmission line topologies, certain lumped elements can be
replaced with SmartComponents from the Passive Circuit DesignGuide. The available
SmartComponents are:

When making such substitutions, the design capabilities of the Passive Circuit DesignGuide
are used to realize the topologies. In this case, however, the design procedure is
approximate, and some tuning of the elements is required before the substituted device
offers the correct performance. In such cases, after completion of the transformation,
push into the SmartComponent on the schematic window and open the Passive Circuit
DesignGuide control window. The Simulation and Optimization Assistants in the Passive
Circuit DesignGuide SmartComponent can then be used to quickly and efficiently tune the
performance of each individual element.
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 Using SmartComponents in Impedance
Matching Utility
This Utility provides several SmartComponents representing matching networks.
SmartComponents are smart sub-network designs that provide the container for
specification parameters and a schematic representation of the design when placed into a
design. The utility provides automated design and analysis for these SmartComponents.

  

 Placing and Editing SmartComponents
SmartComponents are placed, copied, edited, and deleted like other components in ADS.
The basics of placement, copying, editing, and deleting are described briefly in this
section.

Note
For more information on ADS basic features see Schematic Capture and Layout (usrguide).

The components are placed in the schematic window by selecting the SmartComponent
from the palette and clicking at the point where you want to place the component in the
schematic.
You can display the SmartComponent palette in one of these ways:

Select Tools > Impedance Matching to open the Impedance Matching Utility. Display
the SmartComponent palette by selecting the Component Palette - All button from
the utility window toolbar or click View > Component Palette - All from the utility
window menu. All contains all of the SmartComponents.
Select the Impedance Matching palette from the Component Palette drop-down list
box in the Schematic window toolbar (directly above the palette).

  

 Placing SmartComponents

To place a SmartComponent in the Schematic window:

In the Schematic window, select the component from the SmartComponent palette.1.
Click within the schematic window at the location where you want to place the2.
SmartComponent.

You can change the orientation of the SmartComponent before placement by
selecting from the Insert > Component > Component Orientation commands or
by selecting Rotate by -90 repeatedly from the schematic toolbar.
The place component mode remains active until you choose End Command from
the schematic toolbar.
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 Changing Position and Orientation

A SmartComponent is moved by dragging it to any location in the Schematic window.
To change the component's orientation:

Select Edit > Advanced Rotate > Rotate Around Reference from the Schematic1.
window or select Rotate Items from the toolbar.
Click the SmartComponent you want to use.2.
Rotate the component. The rotate mode remains active until you select End3.
Command from the toolbar.

  

 Editing SmartComponents

Specifications of the SmartComponent are entered directly on the Matching Assistant tab
on the Control window. You can also modify the specifications in one of these ways:

Click the SmartComponent parameters in the schematic window and change them
(see The LC Bandpass Matching Network Component (dgfilter).)

Double-click the SmartComponent to open a dialog box containing all parameters

 

 The LC Bandpass Matching Network Component

The SmartComponent design (schematic) can be viewed by pushing into the
SmartComponent's subnetwork. See Examining the Matching Component Design
(impmatchutil).

A SmartComponent subnetwork is empty until schematic is generated (see the note in the
section Placing and Editing SmartComponents (dgfilter)).



Advanced Design System 2011.01 - Impedance Matching Utility

63

  

 Copying SmartComponents
SmartComponents can be copied within a Schematic or to another Schematic window.

  

 Copying Within a Schematic

To copy a SmartComponent to the same schematic:

Click the SmartComponent to be copied.1.
Select Edit > Copy and then Edit > Paste from the schematic window.2.
Click where you want the copy placed.3.

  

 Copying Between Schematic Windows

To copy a SmartComponent to another Schematic:

Click the SmartComponent to be copied.1.
Select Edit > Copy from the Schematic window.2.
Display the schematic window you want to copy the SmartComponent to.3.
Select Edit > Paste to copy the SmartComponent to the schematic.4.
Click where you want the component placed.5.

  

 Copying a SmartComponent as a Unique Design

Initially, all copied SmartComponents refer to the same SmartComponent design. When
the Design Assistant is used to perform a design operation, the Design Assistant
transforms each copied SmartComponent into a unique SmartComponent design. A design
operation is accomplished from the Utility Control Window.

  

 Deleting SmartComponents
SmartComponents can be deleted from a design like other components, but completely
removing a SmartComponent's files requires the actions described here.

  

 Deleting from Current Schematic Window
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Following are the ways to delete a SmartComponent from the schematic window:

Select the component and press the Delete key.
Select Delete from the toolbar.
Click Edit > Delete from the schematic window.

Note
This procedure does not remove the SmartComponent files from the workspace directory. To delete
files from the workspace directory, see Deleting from Current Workspace (dgfilter).

  

 Deleting from Current Workspace

To delete a SmartComponent and all associated files from your workspace:

In the Schematic window, select the SmartComponent.1.
In the utility window, select Tools > Delete SmartComponent. or on the toolbar,2.
click Delete . This deletes the SmartComponent from the current schematic and
removes all of its files from your workspace. The SmartComponent delete mode
remains active until you select End Command from the schematic toolbar.

  

 Deleting Manually Using File System

You can use your computer's file system to delete a SmartComponent by deleting the
appropriate files in the network subdirectory of a workspace. Delete files that start with
DA_ or SA_ , contain the SmartComponent title, and end with . ael, .atf, or .wrk.

  

 Using SmartComponents as Standalone Components
After SmartComponents are designed and tested, they can be used as standalone
components. The Matching Utility is not needed to use them in new schematic unless you
wish to modify or analyze them. When using the SmartComponent in a schematic,
however, the power supply pins (Vdd, Vcc, Vp, Vm) must be connected to a DC voltage
source whose voltage level corresponds the parameter setting.

  

 Using an Existing SmartComponent Within the Same Workspace

To use an existing SmartComponent within the same workspace:

Open the Component Library window by selecting Insert > Component >1.
Component Library from the Schematic window or Display Component Library
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List on the toolbar.
Select the Library name under All Libraries list at the left of the Component Library2.
window. Available components are listed in the Components list at the right of the
Component Library window.
Select the SmartComponent in the Components list.3.
Place the SmartComponent into your schematic by clicking in the Schematic window4.
at the location you wish to place. The insert mode remains active until you click End
Command.

  

 Using an Existing SmartComponent in Any Workspace

A library of predesigned reusable SmartComponents can be created by placing the
reusable SmartComponents in a workspace. This workspace can be included in any
workspace and its SmartComponents can be accessed using the Component Library.

To use an existing SmartComponent in any workspace:

Open the Workspace where the SmartComponent needs to be inserted.1.
Open the Library in the Workspace by selecting File > Open > Library.2.
Open the Component Library window by selecting Insert > Component >3.
Component Library from the Schematic window or Display Component Library
List from the toolbar.
Select the Library name under All Libraries list at the left of the Component Library4.
window. Available components are listed in the Components list at the right of the
Component Library window.
Select the SmartComponent in the Components list.5.
Place the SmartComponent into your schematic by clicking in the Schematic window6.
at the location where you wish to place the component. The insert mode remains
active until you click End Command.
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