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http://www.cs.umn.edu/~metis
http://www.cs.umn.edu/~metis
http://www.intel.com/software/products/mkl
http://www.intel.com/software/products/mkl


EMPro 2011.01 - EMPro Examples

3

MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
General Public License for more details. You should have received a copy of the GNU
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http://www.cise.ufl.edu/research/sparse/amd
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of UMFPACK implies that you agree to this License. This library is free software; you can
redistribute it and/or modify it under the terms of the GNU Lesser General Public License
as published by the Free Software Foundation; either version 2.1 of the License, or (at
your option) any later version. This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies. User documentation of any
code that uses this code or any modified version of this code must cite the Copyright, this
License, the Availability note, and "Used by permission." Permission to modify the code
and to distribute modified code is granted, provided the Copyright, this License, and the
Availability note are retained, and a notice that the code was modified is included.
UMFPACK Availability: http://www.cise.ufl.edu/research/sparse/umfpack  UMFPACK
(including versions 2.2.1 and earlier, in FORTRAN) is available at
http://www.cise.ufl.edu/research/sparse . MA38 is available in the Harwell Subroutine
Library. This version of UMFPACK includes a modified form of COLAMD Version 2.0,
originally released on Jan. 31, 2000, also available at
http://www.cise.ufl.edu/research/sparse . COLAMD V2.0 is also incorporated as a built-in
function in MATLAB version 6.1, by The MathWorks, Inc. http://www.mathworks.com .
COLAMD V1.0 appears as a column-preordering in SuperLU (SuperLU is available at
http://www.netlib.org ). UMFPACK v4.0 is a built-in routine in MATLAB 6.5. UMFPACK v4.3
is a built-in routine in MATLAB 7.1.

Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file
names and directory names. The business entity formerly known as "HP EEsof" is now part
of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and
to maintain backward compatibility for our customers, we did not change all the names
and labels that contain "HP" or "HPEESOF" references.

Warranty The material contained in this document is provided "as is", and is subject to
being changed, without notice, in future editions. Further, to the maximum extent
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http://www.cise.ufl.edu/research/sparse
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permitted by applicable law, Agilent disclaims all warranties, either express or implied,
with regard to this documentation and any information contained herein, including but not
limited to the implied warranties of merchantability and fitness for a particular purpose.
Agilent shall not be liable for errors or for incidental or consequential damages in
connection with the furnishing, use, or performance of this document or of any
information contained herein. Should Agilent and the user have a separate written
agreement with warranty terms covering the material in this document that conflict with
these terms, the warranty terms in the separate agreement shall control.

Technology Licenses The hardware and/or software described in this document are
furnished under a license and may be used or copied only in accordance with the terms of
such license. Portions of this product include the SystemC software licensed under Open
Source terms, which are available for download at http://systemc.org/ . This software is
redistributed by Agilent. The Contributors of the SystemC software provide this software
"as is" and offer no warranty of any kind, express or implied, including without limitation
warranties or conditions or title and non-infringement, and implied warranties or
conditions merchantability and fitness for a particular purpose. Contributors shall not be
liable for any damages of any kind including without limitation direct, indirect, special,
incidental and consequential damages, such as lost profits. Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily
provided to end user customers. Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212
(Computer Software) and, for the Department of Defense, DFARS 252.227-7015
(Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial
Computer Software or Computer Software Documentation).

http://systemc.org/
http://systemc.org/
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 Agilent Phone
Location: In EMPro, choose Help > Examples > Agilent Phone or Help > Examples >
Agilent Phone with Phantom to open the projects.

 Objective
This example illustrates the capability of EMPro in designing Mobile phone antenna system
and qualify it for SAR and HAC standards. Antenna used in a mobile phones operates in
mobile phone casing with many associated materials of different dielectric constant around
it. Therefore, antennas like GSM or Bluetooth should be designed and analyzed in the
within mobile phone casing in presence of different types of materials. EMPro has
advanced CAD import facility that allows the import of CAD files in almost all the industry
used CAD files formats such as sat, sab, iges, dxf, stp, ProE, solidworks, aunigraphics, and
inventor.

In this example, the mobile phone CAD file is imported in the sat format. The project is
configured by assigning different materials to different components. In this example, two
antennas, one operating at the GSM band and another operating at Bluetooth are
analyzed. The mobile phone structure is also analyzed in the presence of a human head
structure to calculate the SAR maximum and average data. The Agilent phone is shown in
the following figure where both GSM and Bluetooth antennas are placed.

 Agilent Phone
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 Setup
A CAD file having the mobile phone structure with both antennas is imported in EMPro.
The project is set up in EMPro by assigning materials to different components, defining
ports for both GSM and Bluetooth antenna and defining mesh. To analyze the performance
of antennas in the presence of human head structure, a CAD file human head structure is
also imported and material for inner and outer shell is assigned. Use the following archive
files:
Archive files: AGILENT_PHONE.zep, AGILENT_PHONE_HEAD.zep

 Analysis
The return loss performance of both GSM and Bluetooth antenna are shown in the
following figure.
The GSM antenna has -15dB and -7dB return loss in GSM bands.
The Bluetooth antenna gives -25dB return loss.

 Return Loss Perfomance
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The GSM antenna is located at the bottom of the phone. The radiation pattern of the GSM
antenna in presence of complete mobile phone structure is shown in the following figure:

 Radiation Pattern for a GSM Antenna
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Similarly, the radiation pattern of Bluetooth antenna is shown in the following figure:

 Radiation Pattern for a Bluetooth Antenna
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The analysis of a GSM antenna for S parameter and radiation pattern along with SAR
calculation is done in separate project AGILENT_PHONE_HEAD.ep. The pattern of the
antenna gets distorted in the presence of a human head structure. The following figure
shows the radiation pattern of a GSM antenna in the presence of a human head structure:

 Radiation Pattern in the Presence of a Human Head Structure
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In the project, the result for SAR 10g, 1g, and RAW data is also shown. These results
show the SAR maximum value and its location for 1.8 GHz. In addition, the SAR average
1g and 10g at different location of the geometry can also be seen in results.
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 Antenna With Radome
Location: In EMPro, choose Help > Examples > Antenna With Radome to open the
project.

 Objective
This example describes the application of EMPro and ADS integration. EMPro provides a
strong linkage to ADS. Any 3D geometry or EMPro solved project can be exported to ADS
in the form of design kits for further analysis. In this example, a radome is generated in
EMPro and integrated to planar antenna in the ADS environment. Radome is used as a
protective shield to Antenna structure and placed around the antenna geometry. The
presence of Radome affects the antenna S parameter and radiation pattern. The radome
affect analysis is normally avoided because modeling 3D geometries of radome is difficult.
However, EMPro provides easy to use modeling tools facilitating modeling of any
complicated 3D structures. The robust CAD import feature of EMPro also provides an
alternative where any complicated radome structure can be imported to EMPro and further
project or kit can be build and exported to ADS. Planar antennas that are designed in ADS
environment can be analyzed in presence of radome by importing radome structure from
EMPro and carrying out complete analysis in ADS environment using FEM simulator. The
planar microstrip antenna used for this analysis is shown in the following figure within a
radome structure. This antenna is operating at C band.

 Setup
The radome structure is designed in EMPro and brought as a design kit into ADS. The
analysis of the complete structure is performed in ADS by using the FEM simulator.
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Semicircular radome structure along with its stand is generated in EMPro using geometry
modeling tools. The 3D EM Component design kit is generated using ADS link tab of
EMPro. This kit is installed in ADS by following the installation process of the design kit.
Next, the footprint of radome is positioned over the microstrip patch antenna array. The
radome is placed at 10mm distance from antenna surface. The complete geometry is then
subjected to FEM simulation for calculating the S parameter and radiation pattern. The
following figure illustrates the design flow:

Use the following archive file:
Archive file: Radome.zep

 Analysis
The S parameter of antenna with and without radome is shown in the following figure. The
S parameter changes in presence of radome.
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The 2D radiation pattern with and without radome is shown in Figure 4 in phi angle cut
plane of 0 degree. The antenna radiation pattern with radome shows increase in side lobe
level and a small dip at the peak of main beam. The gain value of the antenna is also
reduced in presence of radome.

Note:
You need to install the Radome Kit in ADS to perform the analysis. Within this project,
EMProRadome_DesignKit.zip and ADS project Antenna_with_radome.zip are also placed.
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 Low Pass Filter
Location: In EMPro, choose Help > Examples > Low Pass Filter to open the project.

 Objective
This example illustrates the application of EMPro for the design of planar microstrip
passive components such as filter using FEM and FDTD simulations. A stepped impedance
low pass filter is displayed in the following figure. In this figure, low pass filter is designed
on a substrate of dielectric constant 3 having thickness of 0.64 mm. EMPro provides
various types of Near Field sensors through which several field quantities like E, H, B,
poynting vector S and surface currents on the surface of the component can be evaluated.
In this example, the Surface sensor that is located at port 1 is used to evaluate E,H,B field
quantities along with Surface current Jc and poynting vector S.

 Setup
FDTD:
A Broadband pulse is used as the source waveform to provide a wide bandwidth frequency
response from a single simulation. The 0.3 mm base cell size is used. Adaptive mesh is
used along the thickness of the Substrate. The waveform and mesh setup can provide
results up to the 100 GHz frequency. The useful frequency range for this device is 0 to 8
GHz.
FEM:
For FEM simulation same geometry, port and boundary setup as of FDTD is used. FEM
padding of 30 mm is used in all the directions except Z. For Z on lower padding is 0 mm
on lower side and 20 mm on upper side.
Use the following archive file:
Archive file: Low_pass_filter.zep
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 Analysis
The return loss (S11) performance of the filter is shown in the following figures:

 S21 parameter Response

Using the Surface Sensor, different fields E, H, and B poynting vector S and surface
current Jc are defined. The progress of these fields with respect to time stepping can be
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seen in results by choosing Surface Sensor in the output objects. The surface current Jc at
one particular time step is shown in the following figure. The field reader tool of EMPro can
be used to read the values of quantity which is being plotted over the surface of the low
pass filter.

 Surface Current Jc

Note
Simulate the project to view the results. For more information about how to create a low pass filter
design, refer to Low Pass Filter (emprosim).
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 Magic Tee
Location: In EMPro, choose Help > Examples > Magic Tee to open the project.

 Objective
This example shows the application of waveguide ports in EMPro. A magic tee is a four-
port, 180 degree hybrid splitter, realized in waveguide. Like all of the coupler and splitter
structures, the magic tee can be used as a power combiner, or a divider. It is ideally
lossless, so that all power into one port can be assumed to exit the remaining ports. Port 1
is the (sum) port, and is called the H-plane port. A signal incident on port 1 equally splits
between ports 2 and 3, and the resulting signals are in phase. Ports 2 and 3 are called the
co-linear ports, because they are the only two that are in line with each other. Port 4 is
the (difference or delta) port, and is called the E-plane port. A signal incident on the
difference port splits equally between ports 2 and 3, but the resulting signals are 180
degrees out of phase.

This example also helps to visualize how the E-field of a signal entering the sum port
remains in the same up-and-down direction and polarity as it splits to ports 2 and 3, while
the E-field of a signal entering the delta port wraps around in two opposing polarities as it
splits between ports 2 and 3. The interior dimensions of the waveguide are 4 inch by 2
inch.

 Setup
Magic Tee has been simulated with four waveguide ports each having one mode. Hollow
waveguide has been modeled using shell operation. Waveguide walls are 0.1 inch thick
metallic wall and it is filled with air. Simulation frequency range in from 1.4 GHz to 2.4
GHz.
Archive file: MagicTee.zep
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 Analysis
The return loss performance of Magic Tee is shown in the following figure. 

 S Parameter Performance

 E Field  and Phase Plot of Sum and Delta Ports

The below picture show the E-field vectors for signals entering the sum port and diving in
two collinear ports. The sum port excites in same phases in the collinear arms.

The next picture show the E-field vectors for signals entering the delta port and diving in
two collinear ports. The delta port excites in opposite phases in the collinear arms.
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Note
To generate the results for all the ports, simulate the project again by making all the ports active.
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 Microstrip Dipole Antenna
Location: In EMPro, choose Help > Examples > Microstrip Dipole Antenna to open the
project.

 Objective
This example describes the design of a Microstrip Dipole Antenna using both FDTD ad FEM
simulations in EMPro. The Microstrip Dipole Antenna is designed by Orban Microwave
Products, Leuven, Belgium. This antenna in planar microstrip configuration is designed on
FR4 substrate of thickness 1.6 mm. The dipole antenna is fed through a via from 50ohm
microstrip line. The geometry modeling tools of EMPro are used to model two dimensional
planar dipole and three dimensional via structure. The far field sensor is used to get far
field radiation pattern in 2D and 3D. The antenna geometry is shown in the following
figure:

 Setup
FDTD:
The Broadband Gaussian Waveform is used to activate the source to achieve a broadband
response for the antenna. The base cell size of 1mm is used to mesh the structure. It does
not generate sufficient mesh along the Z direction, where the thickness of the substrate
exists. To achieve accuracy, at least 3 cells should exist along the thickness of the
substrate. To accommodate this, an adaptive mesh of 0.4mm is used in the Z direction
within the thickness of the substrate. In addition, for all the objects of the geometry,
automatic fixed points is used for gridding properties. This ensures that the meshes are
falling on the edges of the objects. The generated mesh provides results up to 30GHz in a
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single simulation.
FEM:
For FEM simulation same geometry, port and boundary setup as of FDTD is used. FEM
padding of 60 mm is used in all the directions.
Use the following archive file:
Archive file: microstrip_dipole.zep

 Analysis
The return loss ( S11 ) for the antenna is shown in the following figure:

Comparison of S parameter between FDTD and FEM is shown in following figure:
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The radiation pattern of Microstrip Dipole Antenna in Phi at 0 degree and Phi at 90 degree
cut planes in polar plot for 2.6 GHz from FDTD simulation is shown in the following figure.
The pattern is omni-directional (doublet) and is circular in phi at degree plane. In phi at
90 degree, the pattern lobes are not circular. They are flattened and the radiation
intensity is greater than 0dB.The patterns from FEM are similar to FDTD.
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 Microstrip Line
Location: In EMPro, choose Help > Examples > Microstrip Line 50 ohm to open the
project.

 Objective
This example describes the design of a Microstrip Line using EMPro using both FEM and
FDTD simulations. The line is designed using substrate of dielectric constant 9.9. The
thickness of the substrate is 2mm. The width of 50ohm line is 2mm. The Microstrip Line is
shown in the following figure:

 Setup
FDTD:
The broadband pulse is used to excite the two port microstrip line. The base cell size of 1
mm is used in X and Y directions and 0.5 mm is used in Z directions. In addition, for all
the objects of the geometry, automatic fixed points is used in gridding properties. Both 2
port simulation is carried out.
FEM:
For FEM simulation same geometry, port and boundary setup as of FDTD is used. FEM
padding of 20 mm is used in all the directions except lower Z. For lower Z 0 mm padding
is used
Use the following archive files:
Archive files: Microstrip_50_Ohm.zep
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 Analysis
The return loss S11 and S21 performance of the line is shown in the following figure:

 S11 and S21 Performance of Microstrip Line
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 Microstrip Patch Antenna
Location: In EMPro, choose Help > Examples > Microstrip Patch Antenna or Help >
Examples > Microstrip Patch Antenna with parameters to open the projects.

 Objective

These examples illustrates the design of Microstrip patch antenna using both FDTD and
FEM simulations. This example is based on the paper "Applications of the Three
Dimensional Finite Difference Time Domain Method to the Analysis of Planar Microstrip
Circuits " by Sheen et al in the July 1990 issue of IEEE Transactions on Microwave Theory
and Techniques. In this issue of MTT, you can refer to page numbers from 849 to 856 for
more information. In this example, the Surface sensor that is located at port 1 is used to
evaluate E,H,B field quantities along with Surface current Jc and poynting vector S. The
far field sensor is used to get far field radiation pattern in 2D cut planes and 3D. The
geometry of the microstrip patch antenna is shown in the following figure:

 Microstrip Patch Antenna

 Setup

FDTD:
A Gaussian pulse is used as the source waveform for wideband frequency response. The
base cell size of 0.3 mm is used for mesh in x and y directions. The base cell size 0.1mm
is used along the thickness of the substrate. In addition, for all the objects of the
geometry automatic fixed points is used in gridding properties. This ensures that meshes
are falling on the edges of the objects. The absorbing boundary condition is used in all the
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sides with finite ground plane on the back of the substrate.

FEM:
For FEM simulation same geometry, port and boundary setup as of FDTD is used. FEM
padding of 20 mm is used in all the directions.
Use the following archive files:
Archive files: Microstrip_patch.zep and Microstrip_patch_par.zep

 Analysis

Microstrip_patch.ep is the initial patch with fixed input stub length. The Gaussian
waveform is used with the steady state data collected at 7.23GHz, 17.68GHz, 19.45GHz,
24.7GHz and 28.61GHz. The S parameter results over the band and at discreet frequency
points are calculated. The S parameter plot over the frequency band is shown in the
following figure:

 S Parameter Plot for FDTD

 Comparing S Parameter Plot for FDTD & FEM
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There is close matching between S parameter result obtained from FEM and FDTD. These
results also match closely with paper reported results.

The radiation plots between FDTD and FEM are close. The Gain figure at discreet
frequency points are also very close. For example at 7.47 GHz ( where S parameter are
almost same from both FEM and FDTD) the Gain from FDTD is 7.99 dBi & from FEM is 8
dBi.

In addition, the E,H,B fields as well as the surface current J with time steps are visible
from the Near field sensor for FDTD. For FEM E and H plots can be seen from Advanced
Visualization.
In Microstrip_patch_par.ep, the input stub length is specified as a parameter(X). The
value of this parameter is varied from 6.9 mm to 7.3 mm in the steps 0.1 mm to vary the
length of the stub.

The following figure displays the result of varying length on the S parameter.

 Varying Length on the S Parameter
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Note:
Simulate the project Microstrip_patch.ep to see the results. FDTD S parameter result for
Microstrip_patch_par.ep vary slightly from Microstrip_patch.zep, this is because of different gridding used
in Microstrip_patch_par.ep. For more information about how to create a Microstrip patch antenna design,
refer to Microstrip Patch Antenna (emprosim).
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 Pyramidal Horn
Location: In EMPro, choose Installation Folder > Examples > Pyramidal_Horn.zep
and unarchieve the project.

 Objective
This example describes the analysis of a pyramidal horn waveguide antenna at 7.56 GHz
with EMPro. The pyramidal horn aperture dimensions are 18.46cm by 14.55 cm with
33.98 cm path length of the horn apex. In this example, the horn is fed by a WR-90
waveguide with operating frequency of 7.56 GHz. The theoretical gain for this antenna is
21.3 dBi with half-power beam widths of 12 degrees in the E-plane and 13.6 degrees in
the H-plane. Also, the horn geometry is an optimum gain pyramidal horn antenna. For
more information, you can refer page numbers from 413 to 415 in Antenna Theory and
Design by W. Stutzman and G. Thiele, John Wiley & Sons, New York, 1981.

 Setup
A broadband pulse is used as the source waveform to calculate broadband response.
Steady state data has been collected at 7.56 GHz to calculate gain of the horn antenna
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and near-zone E-field plot. A suitable cell size should be determined for this model. The
frequency of interest is 7.56 GHz and a cell size less than 1/10 of the excitation
wavelength is recommended. A near-field point can be saved so that the fields behind the
horn antenna may be viewed (with respect to time). This provides observation points to
verify that the solution has converged. Convergence is assumed when the fields at these
points vary with a sinusoidal waveform of constant amplitude. Use the following archive
file:
Archive file: Pyramidal_Horn.zep

 Analysis
The Gain plot and gain value of Horn simulated in EMPro is shown in the following figure.
Gain is 21.3 dBi at 7.56 GHz.
Direction of the main lobe of radiation pattern is theta at 0 degrees and phi at 0 degrees.

The following figure displays a comparison of the gain plot and gain values of a Pyramidal
Horn:
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The EMPro simulated near-zone data is displayed in the following figure:
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 RCS of Aircraft
Location: In EMPro, choose Help > Examples > Example Projects > RCS of Aircraft
to open the project.

 Objective
This example describes the application of EMPro for evaluating the Radar Cross Section
(RCS) of an Aircraft. EMPro provides the facility to excite different surfaces and structures
by an external source. Both Plane wave and Gaussian beam type of external source are
available in EMPro. The external source also provides the facility to excite in either of Ephi
or Etheta polarization in any incident phi or theta directions. The aircraft that is used in
this example is is 9m in length and is imported in EMPro through robust CAD import
facility. EMPro consists of the advanced CAD import facility that supports all standard CAD
files formats such as: sat, sab, iges, dxf, stp, ProE, solidworks, unigraphics, and inventor.
The following figure displays the aircraft model:

 Setup
The RCS is evaluated at 1GHZ. The geometry is 30 lambda in length at this frequency and
EMPro is able to calculate RCS of the aircraft. The broadband pulse is used in waveform.
The base cell size of 25mm is used with 20 padding in all the directions. The plane wave
source is used for external excitation. Two simulations were carried out for different
incident directions and polarizations. In the first simulation, E phi Polarization is used from
Phi at 0 degrees and Theta at 90 degrees incident direction. In the second simulation, the
ETheta polarization is used from Phi at 90 degrees and Theta at 0 degrees incident
direction. In both of these simulations, the total/Scattered field formulation is used and
without computing the dissipated power. These settings makes easy convergence and fast
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simulation. Use the following archive files:
Archive files: RCS_Aircraft.zep

 Analysis
The RCS plot in Phi at 0 degrees plane cut for both simulations is shown in the following
figure:

The RCS plot in Phi at 90 degrees plane cut for both the simulation is shown in the
following figure:
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The 3D RCS plot for simulation 1 is shown in the following figure. The RCS value is
54.32dBsm.
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The 3D RCS plot for simulation 2 is shown in the following figure. The RCS value is
51.89dBsm.



EMPro 2011.01 - EMPro Examples

38



EMPro 2011.01 - EMPro Examples

39

 SATA Connector
Location: In EMPro, choose Help > Examples > SATA Connector to open the project.

 Objective
This illustrates the application of EMPro for the simulation of high speed SATA connector.
Serial ATA (SATA) interconnect is replacing Parallel ATA (PATA) interface for faster data
rate, smaller form factor, and probably lower cost design. Due to the faster data transfer
rate, a successful interconnect design such as SATA to PCB interface is crucial to the
successful design wins. At Gigabits speed, the high speed interconnects must be
characterized by S parameters. The demand for high-speed and high-density
interconnects in digital interface designs for PCs, peripherals, and portable devices is
rapidly increasing ever than before. Therefore, maintaining the signal quality throughout
high-density and high-speed interconnects is crucial due to ever increasing demands for
cleaner signal transmission. Nowadays, early design changes based on accurate
simulations are indispensable and worthy investments for connector design houses.
Therefore, an accurate EM model is highly desirable during the design and implementation
stage of high-speed connectors.

 Setup
A SATA signal connector is analyzed with EMPro. SATA connector is simulated with both
FDTD and FEM solvers. The EMPro simulation file can be exported as a design kit in ADS
so that the connector data can be used for signal integrity analysis along with other board
traces in ADS. The SATA connector consists of four conductors in two differential pairs.
The 7 pins and 3 pins are ground pins, while 4 pins are used for signal pins. Two pins are
for transmitting and the other two for receiving, but both are differential pairs. The
housing material for the connector is LCP( Liquid Crystalline Polymer) that has 2.9
dielectric constant.  
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Archive file: SATA_connector.zep

 Analysis
The S parameter performance of SATA Connector is shown in the following figure. Return
loss is better than -10 dB up to 2 GHz. Ports 1, 3, 5, and 7 are input ports while ports 2,
4, 6, and 8 are output ports.

 S Parameter Performance for FDTD Simulation Result

The following figure shows the EMPro simulated data of isolation between adjacent ports
(Port 1 and 3, Port 2 and 4, Port 5 and 6 , Port 6 and 8). Port isolations are better than -
12dB upto 2GHz.

FEM Simulation Result
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 EMPro Simulated Data

EMPro users can export EMPro designs along with simulated data in a form of design kit to
ADS. The S parameters of the connector model were exported as ADS design kit and used
in ADS circuit simulators for further SI analysis. This design kit can be installed in ADS
and EMPro project can be placed in schematic as a component. Here, the SATA connector
simulation model (along with small portion of board trace) is imported in ADS to perform
signal integrity on board traces along with connector effect.

 Meshing on SATA connector
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 Flow Diagram

Note:
To generate the results for all the ports, simulate the project again by making all the ports active.
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 Waveguide Power Divider
Location: In EMPro, choose Help > Examples > Waveguide Power Divider

 Waveguide Power Divider

 Setup
This example shows the design of waveguide power divider with waveguide ports using
FEM engine of EMPro . The waveguide used in power divider is WR159. This is equal power
divider with input arm power divided into two output arm each having equal -3dB power.
The design band is C band and a matching section is used to get return loss( S11) better
than -10 dB between 4.5 Ghz and 7.5 GHz.
Archive files: Waveguide_power_divider.zep

 Analysis
The waveguide power divider is analyzed for dominant mode( TE01 ) propagation. The S
parameter plot over the frequency band is shown in the following figure:

 S11 Parameter Plot
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 S21 & S31 Parameter Plot

 Field Plot
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The field plot can be seen from Advanced visualization. Field plot for one cut plane in input
and output section is shown below:

Note:
Simulate the project Waveguide_power_divider.ep to see the field plots in Advanced visualization
results.
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 Waveguide to Coaxial Transition
Location: In EMPro, choose Help > Examples > Waveguide to Coax.

 Waveguide to Coaxial line transition

 Setup
This example shows the design of waveguide to coaxial line transition with waveguide
ports using FEM engine of EMPro . The waveguide used in transition design is WR159. The
coaxial section is of 50 Ohm with air dielectric. The design band is C band and probe depth
in waveguide section and short plane location is used to get return loss( S11 & S22)
better than -10dB between 5 Ghz and 8 GHz.
Archive files: Waveguide_to_Coaxial_line_transition.zep

 Analysis
The waveguide to coaxial line transition is analyzed for dominant mode( TE01 )
propagation in waveguide section and TEM mode coaxial section. The S parameter plot
over the frequency band is shown in the following figure:

 S11 & S22 Parameter Plot



EMPro 2011.01 - EMPro Examples

47

 S21 Parameter Plot

 Field Plot

The field plot can be seen from Advanced visualization. Field plot for one cut plane which
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shows the coupling from waveguide to coaxial section is shown below:

Note:
Simulate the project Waveguide_to_Coaxial_line_transition.ep to see the field plots in Advanced
visualization results.
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 Differential Vias
Location: In EMPro, choose Help > Examples > Differential Vias to open the project.

 Objective
This examples illustrates the design of Differential Via using FEM simulator of EMPro.
Differential Via model is scalable in multilayer structure.

The Differential Via model is shown is following figure:

 Setup
Absorbing boundary condition is used in all directions. FEM padding of 25 mil is used in
upper X and Y direction and 50 mil is used in Z direction.
Use the following archive files:
Archive files: Diff_via.zep

 Analysis
The frequency sweep is carried from 1 GHz to 10 GHz with mesh refinement carried at
highest frequency of frequency range.

The return loss plot over the frequency range is shown below:
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The Insertion Loss plot is shown below:

Note
In Create FEM Simulation > Frequency Plan > Field Storage > User defined frequency is used. So
the field data is available at 1,5 and 10 GHz. If field data is required at any other frequency, re-simulate
the project using reuse option in FEM simulation.
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 LTCC Balun
Location: In EMPro, choose Help > Examples > LTCC Balun to open the project.

 Objective
This example illustrates the design of LTCC Balun using FEM simulator of EMPro. LTCC
Balun is designed using finite size dielectric brick. The complete 3D EM analysis takes into
account the effect of parasitic close to substrate edges.
The LTCC balun is shown is following figure:

 Setup
Absorbing boundary condition is used in all directions except lower Z. Lower Z uses PEC
boundary condition. FEM padding of 2 mm is used in upper Z direction. Waveguide port is
used with 50 Ohm voltage source.
Use the following archive files:
Archive files: LTCC_Balun.zep

 Analysis
The frequency sweep is carried from 1 GHz to 4 GHz with mesh refinement carried at
highest frequency of frequency range.
The S11 plot over the frequency range is shown below:
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The S21 and S31 plot is shown below:

The following figure shows the phase of S21 and S31 to see phase balance performance:
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Note
In Create FEM Simulation > Frequency Plans > Field Storage > No field Data is used. Therefore,
the field data is not available. If field data is required re-simulate the project using reuse option in FEM
simulation.
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 Patch Antenna with TNC Connector
Location: In EMPro, choose Help > Examples > Patch Antenna with TNC

 Objective
This example illustrates the application of EMPro in designing a microstrip patch antenna
with a TNC connector using FEM simulator. The TNC connector feeds the antenna from
back-side of the antenna. The design band is C band. The patch antenna is designed on a
substrate of 2.47 dielectric constant having thickness of 3.2 mm. The far field sensor is
used to get far field radiation pattern in 2D cut planes and 3D.

The geometry of the microstrip patch antenna with TNC connector is shown in the
following figure:

Microstrip Patch Antenna with TNC Connector

 Setup
FEM:
FEM padding of 20 mm in upper Z, 0 mm in lower z and 30 mm in x and y directions are
used. Absorbing boundary condition is used in all the directions.
Waveguide port is used at the input of TNC connector.
Use the following archive files:
Archive files: Patch_with_TNC.zep

 Analysis
The frequency sweep is used from 3.7 GHz to 4.5 GHz. The FEM mesh refinement is
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carried out at the highest frequency of range.
The S parameter plot over the frequency band is shown in the following figure:

S Parameter Plot

The resonance frequency of the antenna is 4 GHz.
The 2D gain pattern in Phi=0deg and 90 deg cut plane is shown below:
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The 3D gain pattern is also shown in following figure:
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Note
In FEM Simulation > Frequency Plans > Field Storage > User Defined Frequency is used. So the
field data and radiation data is available at 3.7,4 and 4.5 GHz. If field and radiation data is required at any
other frequency,then re-simulate the project using reuse option in FEM simulation.
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 QFN Package
Location: In EMPro, choose Help > Examples > QFN Package

 Setup
This example shows the FEM simulation of a QFN Package. The QFN package model is
imported in EMPro from CAD model. The FEM simulation is carried out from 0-30 GHz. The
boundary condition is absorbing on all the sides except lower Z. In lower Z side the PEC
boundary condition is applied. This is a two port structure. Internal ports are used for the
simulation
Archive files: QFN_Package.zep

 Analysis
The QFN package is analyzed at mesh frequency of 30 GHz, which is the highest
frequency of the band. The S parameter plot over the frequency band is shown in the
following figure:

 S11 & S22 Parameter Plot
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 S21 Parameter Plot

 Field Plot

The field plot can be seen from Advanced visualization. Field plot for one cut plane in the
structure is shown below:
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Note:
Simulate the project Waveguide_power_divider.ep to see the field plots in Advanced visualization
results.
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 Waveguide Power Divider with
Symmetric Plane
Location: In EMPro, choose Help > Examples > Waveguide Power Divider Using
Symmetry.

 Objective
This example illustrates the application of Symmetric Plane in EMPro in designing a
waveguide power divider using FEM simulator. This is same as waveguide power divider
example ( Help > Examples > Waveguide Power Divider) where half of the section is
in Y direction is removed and a E Symmetric Plane Boundary Condition is applied. Since
physical size is reduced to half, the memory requirement reduces giving same result.

Waveguide Power Divider with Symmetric plane

 Setup
FEM:
Boundary conditions applied to the structure are as shown below:
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The structure in symmetric in Y direction. E Symmetric plane is applies in Upper Y. FEM
padding of 0 mm is used in all the directions. Waveguide port with 1 W modal power feed
is used for three ports.
Use the following archive files:
Archive files: Waveguide_power_divider_SymmY.zep

 Analysis
The frequency sweep is carried out from 4 GHz to 8 GHz. The FEM mesh refinement is
carried out at the highest frequency of range. The S11 parameter plot over the frequency
band is shown in the following figure:

S Parameter Plot
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The S11 plot( blue color) is compared with S11 plot of Original Waveguide power divider
and there is exact match. Hence using symmetric plane boundary condition, the physical
size and hence memory requirement can be reduced achieving same S parameter result.

The S21 and S31 plot is shown below:

 Symmetric Plane in Advance Visualization
The Symmetric plane can be seen in advance Visualization as shown below:
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