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The following third-party libraries are used by the NlogN Momentum solver:

"This program includes Metis 4.0, Copyright © 1998, Regents of the University of
Minnesota", http://www.cs.umn.edu/~metis , METIS was written by George Karypis
(karypis@cs.umn.edu).

Intel@ Math Kernel Library, http://www.intel.com/software/products/mkl

SuperLU_MT version 2.0 - Copyright © 2003, The Regents of the University of California,
through Lawrence Berkeley National Laboratory (subject to receipt of any required
approvals from U.S. Dept. of Energy). All rights reserved. SuperLU Disclaimer: THIS
SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

AMD Version 2.2 - AMD Notice: The AMD code was modified. Used by permission. AMD
copyright: AMD Version 2.2, Copyright © 2007 by Timothy A. Davis, Patrick R. Amestoy,
and Iain S. Duff. All Rights Reserved. AMD License: Your use or distribution of AMD or any
modified version of AMD implies that you agree to this License. This library is free
software; you can redistribute it and/or modify it under the terms of the GNU Lesser
General Public License as published by the Free Software Foundation; either version 2.1 of
the License, or (at your option) any later version. This library is distributed in the hope
that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
General Public License for more details. You should have received a copy of the GNU
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Lesser General Public License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA Permission is
hereby granted to use or copy this program under the terms of the GNU LGPL, provided
that the Copyright, this License, and the Availability of the original version is retained on
all copies.User documentation of any code that uses this code or any modified version of
this code must cite the Copyright, this License, the Availability note, and "Used by
permission." Permission to modify the code and to distribute modified code is granted,
provided the Copyright, this License, and the Availability note are retained, and a notice
that the code was modified is included. AMD Availability:
http://www.cise.ufl.edu/research/sparse/amd

UMFPACK 5.0.2 - UMFPACK Notice: The UMFPACK code was modified. Used by permission.
UMFPACK Copyright: UMFPACK Copyright © 1995-2006 by Timothy A. Davis. All Rights
Reserved. UMFPACK License: Your use or distribution of UMFPACK or any modified version
of UMFPACK implies that you agree to this License. This library is free software; you can
redistribute it and/or modify it under the terms of the GNU Lesser General Public License
as published by the Free Software Foundation; either version 2.1 of the License, or (at
your option) any later version. This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies. User documentation of any
code that uses this code or any modified version of this code must cite the Copyright, this
License, the Availability note, and "Used by permission." Permission to modify the code
and to distribute modified code is granted, provided the Copyright, this License, and the
Availability note are retained, and a notice that the code was modified is included.
UMFPACK Availability: http://www.cise.ufl.edu/research/sparse/umfpack  UMFPACK
(including versions 2.2.1 and earlier, in FORTRAN) is available at
http://www.cise.ufl.edu/research/sparse . MA38 is available in the Harwell Subroutine
Library. This version of UMFPACK includes a modified form of COLAMD Version 2.0,
originally released on Jan. 31, 2000, also available at
http://www.cise.ufl.edu/research/sparse . COLAMD V2.0 is also incorporated as a built-in
function in MATLAB version 6.1, by The MathWorks, Inc. http://www.mathworks.com .
COLAMD V1.0 appears as a column-preordering in SuperLU (SuperLU is available at
http://www.netlib.org ). UMFPACK v4.0 is a built-in routine in MATLAB 6.5. UMFPACK v4.3
is a built-in routine in MATLAB 7.1.

Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file
names and directory names. The business entity formerly known as "HP EEsof" is now part
of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and
to maintain backward compatibility for our customers, we did not change all the names
and labels that contain "HP" or "HPEESOF" references.

Warranty The material contained in this document is provided "as is", and is subject to
being changed, without notice, in future editions. Further, to the maximum extent
permitted by applicable law, Agilent disclaims all warranties, either express or implied,
with regard to this documentation and any information contained herein, including but not
limited to the implied warranties of merchantability and fitness for a particular purpose.
Agilent shall not be liable for errors or for incidental or consequential damages in

http://www.cise.ufl.edu/research/sparse/amd
http://www.cise.ufl.edu/research/sparse/amd
http://www.cise.ufl.edu/research/sparse/umfpack
http://www.cise.ufl.edu/research/sparse/umfpack
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.mathworks.com
http://www.mathworks.com
http://www.netlib.org
http://www.netlib.org
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connection with the furnishing, use, or performance of this document or of any
information contained herein. Should Agilent and the user have a separate written
agreement with warranty terms covering the material in this document that conflict with
these terms, the warranty terms in the separate agreement shall control.

Technology Licenses The hardware and/or software described in this document are
furnished under a license and may be used or copied only in accordance with the terms of
such license. Portions of this product include the SystemC software licensed under Open
Source terms, which are available for download at http://systemc.org/ . This software is
redistributed by Agilent. The Contributors of the SystemC software provide this software
"as is" and offer no warranty of any kind, express or implied, including without limitation
warranties or conditions or title and non-infringement, and implied warranties or
conditions merchantability and fitness for a particular purpose. Contributors shall not be
liable for any damages of any kind including without limitation direct, indirect, special,
incidental and consequential damages, such as lost profits. Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily
provided to end user customers. Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212
(Computer Software) and, for the Department of Defense, DFARS 252.227-7015
(Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial
Computer Software or Computer Software Documentation).

http://systemc.org/
http://systemc.org/
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 EMPro Quick Installation
Download the EMPro installation files from the EMPro download page .

EMPro can be installed on a PC running Windows and Linux operating systems.

The following flowchart illustrates quick installation steps that will help you to install
EMPro quickly and create a complete license setup.

Click on the respective box in the flowchart below for further details on the selected topic.

 

 EMPro Installation Flowchart

http://www.home.agilent.com/agilent/product.jspx?cc=US&amp;lc=eng&amp;ckey=1638526&amp;nid=-34278.892747.00&amp;id=1638526&amp;cmpid=21441
http://www.home.agilent.com/agilent/product.jspx?cc=US&amp;lc=eng&amp;ckey=1638526&amp;nid=-34278.892747.00&amp;id=1638526&amp;cmpid=21441
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 Obtaining EMPro License
You can place EMPro license request for any of the following requirements:

New Sale License Request
New Release License Request
Renew Expired License Early Access
License Request Change / Transfer
Evaluation License / Token Redemption / Renewal Request

Click here  to place your EMPro License request.

https://edasupportweb.soco.agilent.com/license/faces/licensehome.jsp
https://edasupportweb.soco.agilent.com/license/faces/licensehome.jsp
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Back to Installation Flowchart

 

 Supported Platforms
EMPro supports the following Windows and Linux platforms:

Operating System 32-bit 64-bit

Windows/VISTA/Windows
7

Microsoft Windows XP
Professional SP3
Microsoft Windows Vista
Enterprise SP1

Microsoft Windows XP Professional x64
Microsoft Windows Vista Enterprise SP1 64-bit
edition

LINUX Redhat RHEL WS 4.x
Novell SUSE SLES 10

Redhat RHEL WS 4.0
Novell SUSE SLES 10 (64-bit AMD Opteron and
Intel EM64T processors)

Back to Installation Flowchart Troubleshoot - Supported Platforms

 

 System Requirements
The system requirements for EMPro are as follows:

1 GB RAM (minimum), 2 GB or more (recommended)
1280 x 800 display resolution
ATI Radeon 7500 or NVidia GeForce 4 or a newer video card
3 GB or more hard disk space for complete installation of software and all the
example files

Back to Installation Flowchart

 

 Download EMPro Software
Click here  to download EMPro installation file of Windows/Vista and Linux.

You can also use Agilent Download Manager  to download EMPro installation file.

Make sure your download is successful by comparing the downloaded file size with the one on the
Download page. In case there is any size difference, you need to download the file again.

Back to Installation Flowchart Troubleshoot - EMPro Download

 Installation
 

 Windows Quick Installation

http://edocs.soco.agilent.com/display/eesofkc/Platform+Support+and+EMPro+System+Requirements
http://edocs.soco.agilent.com/display/eesofkc/Platform+Support+and+EMPro+System+Requirements
http://www.home.agilent.com/agilent/product.jspx?nid=-34278.0.00&amp;cc=IN&amp;lc=eng
http://www.home.agilent.com/agilent/product.jspx?nid=-34278.0.00&amp;cc=IN&amp;lc=eng
http://edocs.soco.agilent.com/display/public/Download+Instructions+-+Using+The+Download+Manager
http://edocs.soco.agilent.com/display/public/Download+Instructions+-+Using+The+Download+Manager
http://edocs.soco.agilent.com/display/eesofkc/EMPro+Download
http://edocs.soco.agilent.com/display/eesofkc/EMPro+Download
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Note
Use this condensed installation procedure if you are experienced in the installation of Agilent EEsof
products. If you have installed an Early Access version of EMPro, you should uninstall it before installing
this version.

To install EMPro on a Windows PC:

After downloading the EMPro windows installation image from the EMPro download1.
page , unzip the file contents to the local hard disk.
Navigate to the directory where you saved the downloaded image file and unzip it.2.
Exit all Windows programs and run setup.exe from the extracted files.3.
When the installation wizard appears, follow the on screen instructions to start the4.
installation. When the installation is complete, click Finish.

Install your Licenses. For instructions on installing the Licenses, refer to
Installing Your Licenses (license).
Install the Acresso FLEXid software-security hardware key to your PC's parallel
port, or use your PC LAN card's Ethernet ID. For instructions and more
information, refer to Installing Your Licenses (license).

Launch EMPro. Do this by selecting EMPro > EMPro 2011.01 > EMPro 2011.015.
(32-bit GUI) (for 32-bit systems, replace 32 by 64 on 64-bit systems) from
the_Start_ menu. If you are using license bundles, select a bundle using the Agilent
License Preference Tool prior to running EMPro. This tool is described in Licensing
EMPro (license) in the EMPro documentation. The licensing tool is available from the
start menu by selecting EMPro > EMPro 2011.01 > EMPro Tools > License
Preference Tool.

Note
Before launching EMPro, click here for EMPro License Setup (license).

Back to Installation Flowchart Troubleshoot - Installation

 

 Linux Quick Installation

Note
Use this quick installation procedure if you are experienced in installing Agilent EEsof products. If you have
installed an Early Access version of EMPro, you should uninstall it before installing this version.

To install EMPro on a Linux PC:

Log on to the system where you want to install EMPro.1.
Download and untar the EMPro installation image from the EMPro download page .2.
Change directories to the directory where the extracted tar files are located.3.
To start the Setup program use the following command:4.
./SETUP.SH

When the EMPro Installation window appears, you can begin the installation. Details5.
about each window are available in Detailed Installation (install). When the
installation is complete, note the License ID (hostid) then click Done to exit the
program.
Use the FLEXnet security licenses supplied by Agilent EEsof to set up a license.lic file.6.
For more information, refer to Installing Your Licenses (license).

http://www.home.agilent.com/agilent/product.jspx?cc=US&amp;lc=eng&amp;ckey=1638526&amp;nid=-34278.892747.00&amp;id=1638526&amp;cmpid=21441
http://www.home.agilent.com/agilent/product.jspx?cc=US&amp;lc=eng&amp;ckey=1638526&amp;nid=-34278.892747.00&amp;id=1638526&amp;cmpid=21441
http://www.home.agilent.com/agilent/product.jspx?cc=US&amp;lc=eng&amp;ckey=1638526&amp;nid=-34278.892747.00&amp;id=1638526&amp;cmpid=21441
http://edocs.soco.agilent.com/display/eesofkc/Installation+for+EMPro
http://edocs.soco.agilent.com/display/eesofkc/Installation+for+EMPro
http://www.home.agilent.com/agilent/product.jspx?cc=US&amp;lc=eng&amp;ckey=1638526&amp;nid=-34278.892747.00&amp;id=1638526&amp;cmpid=21441
http://www.home.agilent.com/agilent/product.jspx?cc=US&amp;lc=eng&amp;ckey=1638526&amp;nid=-34278.892747.00&amp;id=1638526&amp;cmpid=21441
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Place the license.lic file in the licenses sub-directory of your EMPro installation7.
directory and start FLEXnet. For more information, refer to Licensing EMPro (license).
If you are using license bundles, select a bundle using the Agilent License Preference8.
Tool prior to running EMPro . This tool is described in Using the Agilent License
Preference Tool (license).
Launch EMPro. To do this, navigate to the directory in which EMPro is installed and9.
select bin/Linux-i686RHEL4 (for 32-bit systems) or bin/Linux-x86_64 (for 64-bit
systems) and use the command:

./startempro --driver=x11

 Windows License setup

To setup the licenses for Windows Installation, visit Windows License Setup (license).

Back to Installation Flowchart

 

 Linux License setup

To setup the licenses for Linux Installation, see Linux License Setup (license).

Back to Installation Flowchart

 

 Setting the Display

If you want to run EMPro from a remote computer and you want the display to appear on
your local machine, you will need to set the DISPLAY environment variable:

setenv DISPLAY : 0.0 (C-Shell)

DISPLAY = : 0.0 (Korn Shell, Bourne Shell)

export DISPLAY

For a Sun Ray file server and diskless terminals using Solaris 8, you will need to set the
DISPLAY environment variable:

setenv DISPLAY $Display (C-Shell)

set DISPLAY = $Display (Korn Shell, Bourne Shell)

export DISPLAY

For details on using the Sun Ray appliance, refer to the Sun Microsystem website at:
http://wwws.sun.com/sunray/index.html

Back to Installation Flowchart Troubleshoot - Installation

 

 Launch EMPro

http://wwws.sun.com/sunray/index.html
http://wwws.sun.com/sunray/index.html
http://edocs.soco.agilent.com/display/eesofkc/Installation+for+EMPro
http://edocs.soco.agilent.com/display/eesofkc/Installation+for+EMPro
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 Launching EMPro in Windows

Your FLEXnet license file must be properly configured and installed before you can run
EMPro. To set up your license file, follow the instructions in Windows License Setup
(license).

To run EMPro from the Start menu, select Programs > EMPro > EMPro 2011.01 >
EMPro 2011.01 (32/64 bit GUI).

The choices available are:

EMPro Documentation: Brings up your Web browser and the starting point for
accessing EMPro documentation. The documentation files are accessed from the
location in which they are installed (if you chose to install documentation).
Launch EMPro in Windows: Launches the EMPro Main window, enables the 32-bit
simulators, and the use of the various EMPro Suites, features and modules you have
licensed. (If EMPro is installed on a 64-bit operating system and you want to use the
64-bit simulator, choose EMPro (64-bit GUI).
If you are not familiar with EMPro, choose Help > Topics and Index > Quick Start for
help on getting started with EMPro.
Uninstall EMPro 2011.01: Launches the Uninstall Program.

 Launching EMPro in Linux

Environment variables must be set before you can run EMPro.Your FLEXnet license file
must be properly configured and installed before you can run EMPro. To set up your
license file, follow the instructions in Linux License Setup (license).

Choose Help > Topics and Index > Quick Start for help on getting started with EMPro.
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 Managing EMPro Projects
EMPro uses projects to organize and store the data generated when you create, simulate,
and analyze designs to accomplish your design goals.

A project includes circuit, layout, simulation, analysis, and output information on the
designs that you create, along with any links you add to other designs and projects.

Use the File menu in the EMPro Main window to create and open projects.

 Creating Projects
Use the Main window to create a project and organize your designs.

Choose File > New Project to create a new project in EMPro.

 Creating Projects from a Template

Choose File > New Project From Template to open the following dialog box:1.
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Click OK to open the project.2.

 Opening Existing Projects
Use the Main window to reuse and load the existing projects without the requirement to
include all the individual parts manually to make a project.

Note
You can open only one project at a time.

When you begin to open a project, you are prompted to save any changes you have made
in the currently open project before it is closed automatically.

Choose File > Open Existing Projects to open the following dialog box:1.
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Select the project you wish to open and click Open to open the project.2.

 Saving a Project
To save a new project to a specified directory:

Choose File > Save Project As to save the project. The following dialog box is1.
displayed:

Type the name of the project and click Save to save the project.2.



EMPro 2011.01 - EMPro Quick Start

15

 Saving a Copy of the Project

Copying a project directory and its contents to a new project directory allows you to save
time and effort by using an existing project as a template.

Choose File > Save Project Copy As to save the project. The following dialog box is1.
displayed:

Type the name of the project and click Save to save the project.2.

 Archiving Projects

Archive/Unarchive projects to transfer a compact project archive. Creating a single file for
a project simplifies transferring projects to another file system or to another location on
the same file system.

Choose File > Archive Project and use the Archive a project dialog box to locate and
archive the project.
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 Managing Project Templates
EMPro allows you to create a new template or to assign a default template to be loaded
whenever a new project is opened. You can delete, replace, and modify projects, as well
as create a new template from the current project.

Choose File > Manage Project Templates and use the following dialog box to manage a
project.
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 Using the Project Tree
The EMPro Project Tree provides a tree-structured representation of the active project, as
shown in the following figure:

It is organized into the following branches:

Parts
Circuit Components/Ports
External Excitations
Static Voltage Points
Sensors
Definitions
Simulation Domain
Scripts
Graphs
Groups

The EMPro Project Tree is easy to manipulate by means of branch and object toggle
buttons.

 Branches of the Project Tree
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 Parts

The Parts branch organizes the physical parts of a project. It also lists material definitions
and modeling operations applied to any parts object in the tree.
It is possible to organize similar parts objects in groups with an Assembly by right-clicking
and selecting Create New: Assembly, as shown in the below illustration.

 Circuit Components/Ports

The Circuit Components/Ports branch organizes discrete circuit components in a project.

 External Excitations

The External Excitations branch organizes the external excitations applied to a project.

 Sensors

The Sensors branch organizes the sensors defined in a project. Sensors are responsible for
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saving the data collected during a calculation.
They are added by right-clicking on Sensors branch of the Project Tree and choosing the
required sensor.

 Definitions

The Definitions branch stores definitions that can be applied to or shared with other
objects within the project.
To add a new definition object, right-click on the Definitions branch and select the desired
definition.

 Simulation Domain

The Simulation Domain branch stores definitions associated with the outer boundaries of
the project, as well as the grid and mesh. It also includes information about the FEM
Padding Editor.

Double-clicking the Boundary Conditions icon will bring up the Boundary Conditions
Editor.
Double-clicking the FDTD Grid icon will bring up the FDTD Grid Tools dialog box,
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used to specify the characteristics of the grid.
Double-clicking the FDTD Mesh icon will enable Mesh View.
Double-clicking the FEM Padding icon will bring up the FEM Padding Editor.

 Scripts

The Scripts branch stores user-defined scripts.
Right-click this branch to add a new script or to import an existing macro or function script
to the project.
You can execute or edit the script in the Scripting workspace window.

 Graphs

The Graphs branch organizes the graphical output associated with data collected during a
calculation

 Groups

The Groups branch allows you to create fully customizable short-cut groups that may
include any grouping of objects (for example, Parts objects, Sensor objects, Definition
objects, etc.).
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 Importing Files
In order to enhance the geometric modeling process, EMPro has the ability to load both
CAD drawings, voxel objects and mesh objects.

 CAD Files
EMPro allows you to import various industry standard CAD formats. This includes existing
design geometries in the EMPro simulation space.

CAD Files can be imported and exported in various file formats in EMPro, as shown in the
following figure:

 Figure: Supported CAD Formats

Note
EMPro 2011.01 does not support SolidWorks files.

 CAD Import Options

The CAD Importer is used to import CAD files from many popular modeling packages into
EMPro for use in simulations. To import a CAD file, select File > Import > CAD File(s)
and load the desired file.

After the you select the CAD file to load, a dialog box will pop-up with several important
options. This is shown in the following figure.

 CAD import options
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The Interpret Units As drop-down list assigns the units to the CAD file after it is
imported.
The Heal check-box will check imported files for errors and correct them as needed.
In particular, objects imported from IGES files and STEP files may have errors. For
more complex objects, this can be a time consuming process and pop-up window will
display the progress of the operation.
The Automatically Assign Materials check-box appears after the external CAD files
have been read. When this option is selected, color information will be extracted from
the imported parts if it is available. If a material exists in the project that has the
color of the imported part, that material is assigned to the part. If no material is
found, and a color is available, a new material is created and assigned.
The Refresh And Merge Existing Parts check-box should be checked when the user
has already loaded a CAD file into an EMPro project and desires to update it with a
newer (external) version of the source file. When this option is selected,

parts that are used within your EMPro project will be updated with any
geometrical changes present in the newly imported CAD file.
parts that are new to the imported CAD file are added to the project.
parts that have been deleted in the imported CAD file, but are still present in the
EMPro project, will remain in the project without change.
parts that have been deleted in the EMPro project, but are still present in the
CAD file, will be added to the EMPro project with Meshing Disabled and its
Visible property unchecked.

Note
In each of the above four cases, all changes from the original files will be documented in a shortcut group
in the Groups branch of the Project Tree.

 Exporting a CAD File
Create a 2D or 3D geometry in EMPro.1.
Right-click the object and select Export to CAD File. This opens the Export to CAD2.
File dialog box.
Specify a file name and save it as a SAT File. You can also export as an IGES or STEP3.
file.
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Click Save.4.
Specify the ACIS version.5.

 Importing CAD Files
Select File > Import > CAD File(s).1.
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Point to the directory where the required files are located and select the required2.
files.
Click Open. This opens the Import Options dialog box.3.
Set the Interpret units as millimeters. Do not select the Heal, Automatically4.
assign materials, and Refresh and merge existing parts options.

Click OK.5.

Note
Imported objects are assembled to an assembly part with a name Multi-file import and do not have
materials assigned to them. You need to rename the imported objects for a better readability of object
names and assign them to certain materials.
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 Modifying a CAD File

Once imported, an assembly containing all of the parts of the CAD file is added to Parts
branch of the Project Tree. Since every part of the CAD file is treated as its own separate
object, all available modeling operations can be applied to any individual object imported
from the file. Selecting an operation in the Modify drop-down box within Geometry Tools
will enable you to select any part to modify.

Below, the first figure shows an imported CAD object before a modification operation is
applied. the second figure shows the CAD object after an Offset Faces operation is applied
to one of its parts, and the resulting Modeling Sequence object that is added to the tree.

 CAD file before modification

 CAD file after modification
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 Voxels
Voxel objects are volumetric pixel points in space with specific volume characteristics.
Voxels are a similar to CAD objects in that they are linked to an external voxel data file,
and are loaded through selecting the select File > Import > CAD File(s) option. The
external voxel data file follows the format specified from the VariPose .mmf file. The
illustration below displays an imported *.mmf file.

 The head of an imported human body mesh comprised of 5-mm voxel objects
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The following illustration shows the Project Tree after the the *.mmf file seen above was
imported. Note that an object has been added to the Parts branch that contains the voxel
object and a list of all the materials contained in the object have been added to the
Definitions: Materials branch.

 The Project Tree with imported voxel object
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 Meshing a Voxel object

To set the meshing parameters for the voxel object, right-click the object in the Project
Tree and select Meshing Properties to open the Meshing Parameters Editor.

Note
For more on configuring the settings of the Meshing Parameters Editor, refer to Volume Meshing Options
(using) located in "Defining the Grid and Creating a Mesh".

 Mesh Objects
A mesh object is essentially a collection of edges (of various sizes) with applied materials.
It is a subsection of the EMPro grid from a previous version. Mesh objects, like voxel
objects, are linked to an external mesh object data file, and are loaded through the File >
Import > AMDS Version 2007.6 File... option. The following figure displays an imported
*.mesh file.

 The head of an imported human body mesh object
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The next figure shows the Project Tree after the the *.mesh file seen above was imported.
Note that an object has been added to the Parts branch that contains the mesh object and
a list of all the materials contained in the object have been added to the Definitions:
Materials branch.

 The Project Tree with imported mesh object

Like a voxel object, to set the meshing parameters for a mesh object, right-click the
object in the Project Tree and select Meshing Properties to open the Meshing Parameters
Editor.
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Note
For more information on configuring the settings of the Meshing Parameters Editor, refer to Volume
Meshing Method (using).

 Importing ODB++ Files
The FDTD simulation method can be used to simulate the way energy propagates through
and around Printed Circuit Boards (PCBs). To create complex PCB designs, geometry can
be imported from another application.
The ODB++ format is used to import complex geometry as it is a standardized format
which facilitates data exchange between many applications in the PCB industry.
EMPro reads the ODB++ database and constructs a three dimensional representation of
the data.

To import ODB++ files:

Choose File > Import > PCB. The Modeling Unit Range Warning dialog box may1.
appear.

Note
To successfully construct the solid model, the New Part Modeling Units must be in mils or
micrometers. If the Project Properties Editor is not set to one of these two units, EMPro will prompt
to change the unit.

Click Yes to convert New Part Modeling Units to mils or micrometers else Click No.2.
After the unit conversion is complete, the Import PCB dialog box appears.
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Select the ODB++ file to be imported and click Choose. A Status window will display3.
the reading status information of the ODB++ file.

Once the ODB++ file is completely read, the EMPro-ODB++ Import dialog box is
displayed.
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In the EMPro-ODB++ Import dialog box,

The Layers tab displays a list of all the layers in ODB++ file. By default, all the
layers are imported. Layers of the types signal, power ground, drill and mixed are
checked by default, but each layer can be changed by clicking the check box next to
the layer name. To import selective layers, un-check the layers from Import column
under Layers tab. The Layer Type is a non-editable field and is displayed only for
information purpose. You can modify the Layer Thickness and Substrate Thickness
fields. Each thickness can be modified by clicking on the value in the table and
entering a different value.

Note
You can check or un-check all the layers using Check All and Uncheck All buttons, respectively.

The Nets tab is available if the ODB++ database contains EDA data. If there is no
EDA data or no nets are chosen, the geometry for each layer is separated into pads,
traces, surfaces and polarity. If nets are chosen, the geometry for each net is
separated in its own part, and then the remaining geometry is separated into layers.

The Logs tab provides the feedback generated when the data is read from the
ODB++ database. The contents of this log indicates any errors encountered. The
messages provided in the log do not include the status of converting the data to the
solid models. After you chooses OK, the data is converted into parts. In the event of
an error during this conversion, a window will appear after conversion has finished
indicating the problems encountered.
Once you are done with layer selection, click OK to import ODB++ file into EMPro4.
else click Cancel.
A Status window opens displaying the import information.

Once the file import is complete, the output data is displayed in the Geometry5.
workspace window.
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 Modifying Existing 2D and 3D Objects
The modeling operations applied to the object are stored in EMPro. This enables you to
change the operations according to your requirements. You can modify existing
geometries which include imported objects, for example, move, copy, rotate, and Boolean
operations. This section describes how to modify 2D and 3D objects.

 Creating 3D Objects from 2D Objects
Perform the following steps for creating 3D objects from 2D objects:

Select Create > Extrude.1.
Specify the Name of the object.2.
Set the orientation of the drawing plane. By default, XY plane is the drawing plane3.
orientation.
Draw 2D objects such as circle, rectangle, or polygons.4.
Select (0,0) from the lower-left corner of the object or press Tab to activate the5.
coordinate entry dialog box.

Extrude it to create a 3D object. Select the required coordinates or press Tab to open6.
the Specify Position dialog box.
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Note
When you move the the mouse over the drawing plane, the dX and dY (or U and V) values are
displayed.

Click Ok.7.
Select the Extrude tab.8.

Enter a value in the in the Extrude Distance text box. You can also move the arrow9.
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in the geometry space to change the distance.
Click Done. The green check mark means that there is no problem with this object10.
creation, as shown below:

 Resizing Existing 3D Objects
Perform the following steps for resizing the height of an object:

Open a EMPro project.1.
Expand the Parts menu and double-click Extrude.2.

Open the Extrude tab and change the Extrude Distance.3.

Click Done.4.

 Editing Existing Extruded 2D Object
Click Extrude to open the 2D drawing space.1.

Click Select/Manipulate from Tools menu . Place the mouse over the edges or2.
corners of rectangle, and right-click to open the Edit/Delete menu:
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Delete the edges or select the vertices to edit or lock the positions.3.

 Moving (Translating)/Rotating Objects
Use "Specify Orientation" menu or tab from either the Geometry modeling menu or object
created

Moving objects is also referred as Translating objects in EMPro. Translation/rotation works
in the local coordinate system but it can be changed to other coordinate system in the
Context menu.
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 Copying/Deleting 2D/3D Objects
Perform the following steps for copying objects:

Select object and use Edit/Copy.1.

Select Edit/Paste in the Parts menu.2.

Note
Since the copy command copies onto the same position as the one being copied, you may need to
translate it to other position.

Follow the same procedure for deleting an object, or you can use Delete key.

 Boolean Operations
The following boolean operations are available in EMPro:

Two Parts
Extrude
Revolve

The Two Parts tool provides several boolean operations to subtract, intersect, or unite two
objects. For these operations, one object must be selected to be the Blank, and the other
the Tool which acts on the blank.

Holes may also be extruded or revolved through any part with its respective tool in this
menu. An object is selected in the Pick Blank tab and the cross section of the hole is
sketched and oriented in the Edit Profile and Feature Orientation tabs, as described in the
Edit Cross Section Tab (using) and Specify Orientation Tab (using), sections respectively.
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Then the shape of the removed section is specified in the Extrude Boolean tab, or Revolve
tab depending on which operation is selected. The Preview tab shows a preview of the
object before the changes are formally applied to the project. For more information on
defining extrusions or revolutions, refer to 3-D Solid Modeling Options (using) in the
Appendix of Geometric Modeling. An image of each boolean operation is available in
Boolean Operations (using) in the "Appendix of Geometric Modeling".

 Patterns
Patterns are created in EMPro by replicating a single selected object multiple times in one
of the organized arrangements listed below.

Linear/Rectangular
Circular/Elliptical
Linear/Rectangular or Circular/Elliptical patterns

 Figure: Elliptical Pattern
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 Advanced User Controlled Mesh Options
In EMPro 2010, following two advanced mesh control options are provided that allow the
finer control of the initial mesh used in the adaptive refinement process:

Initial target mesh size1.
Initial minimum mesh size2.

 Initial Target Mesh Size
For electrically large structures it is beneficial to seed the free space with a larger number
of tetrahedra than based on geometric features alone. To accomplish this, the maximum
size of the edges in the initial mesh can be set to an appropriate value. Using the
Advanced tab of the Mesh/Convergence Properties window (which is a part of the Create
FEM Simulation dialog box) a length can be given (as shown in Figure below). When
automatically determine is switched ON, EMPro provides a suggestion based on the
given Frequency Plan. The automatically determined value is the wavelength in free space
divided by 3.

To understand this better let us take a look at the Microstrip Dipole Antenna( from Help >
Examples):

Below is the mesh generated over freespace when Initial Target Mesh Size is not used:
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When the same volume is meshed using the Initial Target Mesh Size, the mesh looks
like:

This leads to a faster convergence of iterative solver and in less number of passes in the
Adaptive Frequency Sweep.

 Initial Minimum Mesh Size
Initial Minimum Mesh Size controls the smallest length present in the initial mesh. It can
be applied when there are geometric features present that are of less importance for the
EM simulation. The result is a lower number of tetrahedra necessary to converge to the
final solution. A typical use scenario for this feature is when a complex CAD model is
imported or drawn where the geometric detail exceeds the detail required for the EM
solution. The mesher is most effective in applying this constraint on curved surfaces.

Using the Advanced tab of the Mesh/Convergence Properties widget (which is a part
of the Create FEM Simulation dialog box) a length can be given (as shown in Figure
below).When the option Automatically determine is checked the EMPro GUI will provide
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a suggestion. The suggestion is based on the size of the geometry and the value of the
Initial Target Mesh Size. The ratio between the Initial Target Mesh Size and the
Initial Minimum Mesh Size cannot be lower than 10 to provide the mesher with enough
freedom to fill the solution space with tetrahedra.

The figures below illustrate the effect on a simple example when the setting minimum size
is not set.

The figures below illustrate the effect on a simple example when the setting minimum size
is set to 3 mm.
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