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Mismatch Modeling in MBP 
Application Note  

This application note introduces the basic components of Model Builder Program’s (MBP’s) mismatch 
module. The steps to run the built-in extraction flow and how to configure and plot an IMV graph in MBP 
are also demonstrated. Note: This document was originally released for MBP V2011.1.2 in December 
2011.  
 

Introduction 
 
Two devices in design that are the same (e.g., exactly the same property, geometry, etc.) may show 
different electrical behavior on the Silicon due to mismatch. The main reason for the difference is the local 
process variance across the wafer. Mismatch affects the yield and reliability of the final products. An 
accurate mismatch model is therefore, necessary to ensure the robust design of many analog and digital 
circuits. 
 
MBP supports mismatch modeling and simulation for all major semiconductor devices such as MOSFETs, 
bipolar transistors, resistors, and capacitors. In this document, we first introduce the data format 
supported, plot configuration and Monte Carlo (MC) simulation in MBP. Examples of running the built-in 
extraction flow, and configuring and plotting an IMV graph are also demonstrated. For more information 
go to www.agilent.com/find/eesof or contact your local Agilent office. The complete list is available at: 
www.agilent.com/find/contactus. 
 
 

Data, Plot and MC Simulation 

Data Format 
For mismatch, MBP supports two kinds of data formats. The first one is based on the actual measurement 
data, while the other allows you to input the mean and sigma value of the target.  
 
Data Format I 
Here is an example of the first data format supported in MBP: 
 
miscondition{date=,type=NMOS} 
Page (name=vth_gm,target=vth_gm,scale=1.0,p=(L,W)) 
{vds=0.1,Vgs=1,Vbs=0,icon=1E-7,T=25} 
{0.18,2.0} 
0.002604200182343308 0.015163779612074824 -0.0016386308204789923 
0.0012339958926110839 0.008895426625025848 -0.0048731228537369775 
.......................... 
{0.18,10.0} 
0.0011114374468496058 0.007055480752867993 -7.450025621094092E-4 
4.969414898894353E-4 0.003966458228031433 -0.0024213892738844667 
.......................... 
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The first line of the data file begins with the keyword “miscondition” and contains information like date 
and device type. The second line defines all page-related information. The information within the round 
bracket “( )” contains Page name, target, scale, and P variable. The information within the brace “{ }” 
declares Page constants, including the bias/current condition and temperature. 
 
The latter part is the data block information. Every curve block always begins with {L W}. All data 
information is then listed behind it. In this example, the data information is the threshold voltage 
difference (∆vth_gm) between two adjacent devices with the same geometry. 
 
Data Format II 
You can also choose the other format. As an example: 
 
condition{corner = tt,date = oct_20_02} 
Datatype{mismatch} 
Version{1.0} 
type{nmos} 
Delimiter{,} 
Instance{L, W, T} 
Input{vds=0.05, Vgs=1, Vbs=-1,icon=1e-7} 
Targets{Ids} 
Data{ L, W, T, vds, vgs, vbs, ids} 
40, 5, 25, 0.05, 3, 0, 0, 6.448e-4 
40, 2, 25, 0.05, 3, 0, 0, 9.836e-4 
30, 2, 25, 0.05, 3, 0, 0, 9.6235e-4 
20, 2, 25, 0.05, 3, 0, 0, 1.28e-3 
20, 1, 25, 0.05, 3, 0, 0, 1.889e-3 
20, 0.5, 25, 0.05, 3, 0, 0, 2.448e-3 
6, 1, 25, 0.05, 3, 0, 0, 3.4727e-3 
10, 0.5, 25, 0.05, 3, 0, 0, 3.503e-3 
6, 0.5, 25, 0.05, 3, 0, 0, 4.1108e-3 
............................... 
 
In this format, the first part of the data file contains general information such as corner type, date, data 
type, device type, instance, bias condition, and target. The second part of the data file includes the data 
block information. The first line begins with the keyword “Data” following the variables. All data is then 
listed from the second line. Note that the last two values in every line correspond to the mean and sigma 
of the target. For example:  
 
“40,5,25,0.05,3,0,0,6.448e-4” means “L=40um,W=5um, T=25C, Vds=0.05V, 
Vgs=3V, Vbs=0, ∆Ids(mean) =0, ∆Ids(sigma)=6.448e-4A” . 
 

Plot 
As shown in Figure 1, the plot shows the value of σ (∆Vth_gm) versus 1/sqrt (W*L), and the trend slope 
lines. The simulation point and trend line are plotted in blue and the measurement data and trend line are 
plotted in purple. 
 
By clicking on the legend “L, W” you can disable/enable the geometries to be plotted. Right click on the 
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plot and check the item “Fit Line through Origin” from the popup menu. MBP then forces the trend lines 
through the origin, as shown in Figure 2.   

                                   
                                                                         Figure 1. Mismatch plot 

                                
 
                                                                   Figure2. Fit Line through Origin 
 

MC Simulation 
MBP’s internal engine supports Monte Carlo analysis of mismatch models. You can right-click on the plot 
and select Set Monte Count, as shown in Figure 3. Then, set an appropriate number. A large number may 
lead to a more accurate result, but it can also cause a longer simulation time. 
 

                                                
                    
                                                                         Figure3. Set Monte Count 
 
You have an option to execute a fast MC simulation by choosing Simulation -> Fast-MC from the main 
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menu. 

 

Extraction Flow 
 
We can use a demo to describe the steps required to run a mismatch model extraction through the built-
in flow. 
 

Demo Files 
The demo folder is $MBPHOME\demo\Mismatch\mosfet\. Here, $MBPHOME is the MBP installation path. 
There are a total of three files in the folder: 
 
• demo_model: the initial model card. 
• param.txt: the parameter list used in the extraction flow. 
• mis_data.mea: the demo data. 
 
You can follow the steps below to complete the whole process. 
 

Step1. Set Model Type 
First, set the mode type. Choose Model -> Select Model from the main menu. In the popup Model Type 
window, choose Statistical as the Project Type. Then choose mosfet as the device type, as shown in Figure 
4. 
 
Click the OK button to close the window. 
 

                                        
 
                                                             Figure 4. Model type 
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Step 2. Load Data and Model 
Choose File -> Data -> Load from the main menu and load the data file “mis_data.mea,” as shown in 
Figure 5. 
 

 
 
                                                        Figure5. Data VS initial model 
 
Then, choose File -> Model -> Load from the main menu and load the model file “model_nmos.l.” Here, 
MBP supports the ability to load the model with or without mismatch information. 
 

Step 3. Extraction Flow 
Choose Extraction -> Extraction Flow from the main menu. The extraction panel is shown in Figure 6. 

                          
 
                                                           Figure6. Extraction Flow panel 
 
 
Double click the Mismatch Extraction button to expand the flow, as shown in Figure 7 
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                                                           Figure7. Global Extraction flow 
 
 
There are three steps in the flow: select_mismatch_params, select_mismatch_targets and 
mismatch_extraction. Click the run icon to run the mismatch extraction flow. The Select Parameters 
window pops up as shown in Figure 8 
 

                                   
 
                                                                     Figure8. Select Parameters window 
 
Click the Load button to load the parameter list file “param.txt.” The parameters used for mismatch 
extraction are shown in Figure 9. 
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                                                                             Figure 9. Load Parameter list 
 
Some comments on the column names in the figure above are as follows: 
 
• select: when it is checked, the parameter gets re-extracted. If it is unchecked, then the parameter 
depends on the sigma value. If the sigma value is given, the final value of the parameter is the sigma 
value. If sigma value is not given, the current value of the parameter remains as the final one. 
• name: mismatch parameter name. When select is unchecked, the parameter name can be blank. At the 
same time, both random and sigma must have correct values. 
• random: random variable name. If in the current model file there is a random variable for the parameter, 
then put the name of the random variable here. If in the current model file there is no random variable for 
the parameter, you can either input a new name here, or keep it blank. For the latter case, a new name is 
created automatically. Note that the names of random variables cannot be repeated. 
• sigma: sigma of the mismatch parameter. You can input the value here. The extraction flow then 
bypasses this parameter and uses the predefined value instead. 
• step: the step for BPV calculation. It is used to calculate the sensitivity of the parameter to the target. 
 
Click the OK button to continue. The Select Targets window pops up as shown in Figure 10 
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                                                             Figure 10. Select targets - slope 
In this window, you can select the data group for the following extraction and the corresponding weight.  
 
Click the “target” tab in the window as shown in Figure 11. 
 

                             
 
                                                          Figure 11. Select targets - target 
 
All the specific targets corresponding to the data group in Figure 10 are listed here. You can also change 
the weight values, which affects the final value of the slope. 
 
Close the window to continue. In the last step, the Save dialog window pops up. Input a file name to save 
the extracted model file. Then, the following mismatch parameters that have been extracted are found: 
 
.param 
+s_dtox_mis = 8.320052E-10 s_dvth_mis = 6.310913E-4 
s_ddl_mis = 9.80127E-2 
+s_ddw_mis = 6.175251E-3 
.param 
+random5 = agauss(0.0,1.0, 1) 
+random6 = agauss(0.0,1.0, 1) 
+random7 = agauss(0.0,1.0, 1) 
+random8 = agauss(0.0,1.0, 1) 
.param 
+dtox_mis = ‘0.0+s_dtox_mis*random5’ 
+dvth_mis = ‘0.0+s_dvth_mis*random6’ 
+ddl_mis = ‘0.0+s_ddl_mis*random7’ 
+ddw_mis = ‘0.0+s_ddw_mis*random8’ 
 
The fitting result is shown in Figure 12. 
 
You can continue to fine tune the parameters manually. They can also modify some settings and rerun the 
flow until a satisfying result is obtained. 
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                                                             Figure 12. Fitting result 
 

Mismatch IMV 
 
Lastly, we use a demo case to illustrate how to customize mismatch IMV and plot it in MBP. After loading 
the data and model, choose Script -> Script Project from the main menu to pop up the MBP Script 
interface. 
 
In the left “Project” tab window, click default -> imv -> imv -> mismatch to expand the folder, as shown in 
Figure 13. 

                                 
 
                                                                               Figure 13. MBP script 
 
 
Right-click the IMV “mis_sigma_ids” and choose New -> Graph (Figure 14). 
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                                                                       Figure 14. Create new graph 
 
Input “mis_sigma_ids_w_l” as the code name. In the “GRAPH_PROP” tab, choose “w” as “Axis[x],” 
“mis_sigma_ids” as “Axis[x]” and “l” as “Axis[x],” as shown in Figure 15. 
 

                                 
 
                                                                 Figure 15. Configure graph 
 
Click the icon to save the current code. In the main menu of MBP, choose Extraction -> IMV -> IMV Pages 
to open the IMV page. Click the icon to refresh. You can then view the customized IMV page 
(mis_sigma_ids_w_l) as shown in Figure 16. 
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                                                                              Figure 16. IMV pages 
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