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Statistical Modeling in Model Builder Program 
Application Note 
 

This application note introduces the statistical module in Model Builder Program (MBP). The module’s 
contents, including data format, plot configuration, Monte Carlo (MC) analysis, extraction flow, and 
IMV plot are covered. Note: This document was originally released for MBP V2011.1.2 in December 
2011. 

 

 
 
 
 
 
 
 
 
 

 
 
 

 

 

1. Introduction 

Incorporating process variability into models is critical for IC design. Moreover, statistical modeling is 
today playing an ever important role in ensuring high product yield in the design phase. MBP supports 
Monte Carlo simulation with statistical modeling.  

In this document, we first describe the data format supported, plot configuration and Monte Carlo 
simulation in MBP. Additionally, the built-in flow used to run statistical model extraction with the 
Backward Propagation of Variance (BPV) method is elaborated. Finally, we use a demo to introduce 
the steps to configure and plot statistical IMV. For more information go to www.agilent.com/find/eesof 
or contact your local Agilent office. The complete list is available at: www.agilent.com/find/contactus. 
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2. Data, Plot and Simulation 
2.1 Data Format 

MBP supports two kinds of data formats for statistical modeling. The first is based on actual 
measurement data, while the second allows the user to input the mean and sigma value of the target.   

2.1.1 Data Format I 

Below is an example of the first format (based on measurement data) supported in MBP: 

staccondition{mode=forward,type=nmos} 

Page (name=Ids,target={Ids(vds=0.05,vgs=1.1)},p=vbs){w=0.18,L=0.15,T=25} 

curve{0.0} 

site1  1.863622E-5 

site2  1.859326E-5 

site3  1.826478E-5 

site4  1.79857E-5 

site5  1.857634E-5 

site6  1.89573E-5 

site7  1.831234E-5 

site8  1.895472E-5 

site9  1.901374E-5 

site10 1.882349E-5 

......................... 

The first line of the data file begins with the keyword “staccondition” and contains working mode and 
device type information. From this example, we know that it's a NMOS device in forward working 
mode.  

The second line defines all page related information. The information within the round bracket "( )" 
contains page name, target and P variable. The information within the brace "{ }" declares the page 
constants, including geometry and temperature.  
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The latter part is the data block information. For every curve block, it always begins with the keyword 
“curve” and the corresponding P value (vbs, in this example). All data information is listed behind it.  
There are two values in every line: the site number and the target value (Ids, in this example).  

2.1.2 Data Format II 

The user can also choose the other format for the statistical data, allowing the user to input the mean 
and sigma value of the target. An example is as follows: 

condition{corner = tt,date = oct_20_02} 

Datatype{statistical} 

Version{1.0} 

type{nmos} 

Delimiter{,} 

Instance{L, W, T} 

Input{vds=0.05, Vgs=1, Vbs=-1,icon=1e-7} 

Targets{Vth_gm,Idsat} 

 

Data{ L, W, T, vds, vgs,vbs, ids} 

0.6, 0.27 , 25 , 5.5, 5.5 , 0, 1.94e-4, 2.44e-6 

0.6, 10 , 25 , 5.5, 5.5 , 0, 1.94e-4, 2.44e-6  

............................................ 

Data{ L, W, T, vds,vgs,vbs, vth_gm} 

0.6, 0.27 , 25 , 5.5, 5.5 , 0, 0.83, 8.95e-3 

0.6, 10 , 25 , 5.5, 5.5 , 0, 0.83, 8.95e-3  

............................................ 

In this format, the first part of the data file contains the general information such as corner type, time, 
data type, device type, instance, bias condition, and target.  

The latter part of the data file is the data block information. Every block begins with the keyword 
"Data" following the variables. All data is listed from the second line of each block. Note that the last 
two values in every line correspond to the mean and sigma of the target. In this example, line "0.6, 0.27, 
25, 5.5, 5.5, 0, 1.94e-4, 2.44e-6" means "L=0.6um, W=0.27um, T=25C, Vds=5.5V, Vgs=5.5V, Vbs=0, 
Ids(mean)=1.94e-4A, Ids(sigma)=2.44e-6A."  

2.2 Data Plot 

Depending on the number of targets, there are two kinds of plots: histogram and scatter. 

2.2.1 Histogram for Single Target 

Using the target Ids as an example, the data plot (histogram) is shown in Figure 1. 
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Figure 1. Histogram with fill style 

Two styles are available for the histogram: the fill style as shown in Figure 1 and the bias style as 
shown in Figure 2. For the Bias style, simply right-click the plot and in the popup menu choose Bar 
Styles -> Bias. 

 

Figure 2. Histogram with Bias style 

The user can also add a distribution line on the histogram. To do so, right-click on the plot and check 
the item Draw Distribution (Figure 3). 
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Figure 3. Histogram with distribution line 

2.2.2 Scatter Plot for a Pair of Targets 

The scatter plot is used for a pair of targets. In this example, the pair of targets are defined as ids and 
vth_con. A scatter plot can be configured by the user on MBP’s graphical user interface (GUI). Simply 
choose Tool -> GUI Options -> Statistical Graph Config from the main menu to open the Statistical 
Graph Configuration window as shown in Figure 4. 

MBP automatically parses the targets (e.g., ids, vth_con, vth_gm, Ion, and Ioff, etc.). These targets can 
be freely chosen as X- or Y-axis values on the scatter pages. In this example, we choose ids as X scale 
and vth_con as Y scale. Next, click the Add Page button. 
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Figure 4. Statistical graph configuration 

The contour of the scatter plot is also set in this window. Currently, MBP allows the user to set the 
contour number up to 5 (corresponding to the case of five sigma). There are three contour styles 
available to choose from: fill, null and outline. The corresponding scatter plots are shown in Figure 5. 

 

Figure 5. Scatter Plots: fill (left-most image), null (center) and outline (right-most image) 

2.3 MC Simulation 

MBP's internal engine is capable of performing Monte Carlo analysis. The user may also call an 
external simulator for verification purposes.  

2.3.1 Statistical Model 

To enable Monte Carlo analysis in MBP, the user first needs to build a statistical model. The model’s 
key parameters must be set to Gaussian distribution as follows: 

.param 

+p1=AGAUSS(0.37,0.01,1) 
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.param  

+p2=GAUSS(1.21038E-1,0.03,1) 

...... 

+vth0=p1 

+u0=p2 

...... 

To begin, the user may first load a compact model into the statistical module. Since no Monte Carlo 
analysis has yet been set, the user will get only one point as a simulation output on each plot. 

MBP supports the ability to load the statistical model with a global or binning core model, or a macro 
model. It also allows the statistical model to be loaded directly from the model library using Lib Parser. 

2.3.2 Set Monte Carlo Count 

The user can set the Monte Carlo simulation number by right-clicking on the plot and selecting Set 
Monte Count. The user must set an appropriate number here. Note that a large number may lead to a 
more accurate result, but will also require a longer simulation time.  

2.3.3 Fast MC Simulation 

MBP provides an option to run fast MC simulation. To achieve this, choose Simulation -> Fast-MC 
from the main menu. This method speeds up the simulation using a unique methodology to deal with 
the statistical model. 

3. BPV Extraction Flow 

A demo case is used here to describe the steps required to run a statistical model extraction 
through the built-in flow. 

3.1 Demo Files 

The demo folder is $MBPHOME\demo\Statistical\mosfet. Here, $MBPHOME is the installation path of 
MBP. There are a total of three files in this folder: 

 model_nmos.l, the initial model card; 
 param.txt, the parameter list used in the BPV extraction flow; and 
 sta_data.mea, the demo data. 

The user can follow the steps presented below to complete the extraction process. 

3.2 Set Model Type 

First, the user must set the mode type. Choose Model -> Select Model from the main menu. In the 
popup Model Type window, choose Statistical as the project type. Then choose mosfet as the device 
type, as shown in Figure 6. 
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Figure 6. Model type 

Click the OK button to close the window. 

3.3 Load Data and Model 

To load the data, choose File -> Data -> Load from the main menu. Load the data file “sta_data.mea.”   

To load the model, choose File -> Model -> Load from the main menu. Load the model file 
“model_nmos.l.” Since there is no statistical information in the initial model, only one blue column 
indicating the simulation result is visible (Figure 7). 

 

Figure 7. Initial model versus measurement data 

MBP also supports the ability to load a model with existing statistical information. The user can use the 
flow to optimize the previously tuned model. 
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3.4 Run Extraction Flow 

To run the extraction flow choose Extraction -> Extraction Flow from the main menu. The extraction 
panel shown in Figure 8 then becomes visible. 

 

Figure 8. Extraction flow panel 

Double click the GlobalExtraction button to expand the flow (Figure 9). 

 

Figure 9. Global extraction flow 

There are three steps in the flow: select_global_params, select_global_targets and global_extraction.  
Click the run icon  to automatically run the global extraction flow. The Select Parameters window 
will pop up as shown in Figure 10. 
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Figure 10. Select Parameters window 

Click the Load button to load the parameter list file “param.txt.” The parameters are arranged as shown 
in Figure 11. 

 

Figure 11. Load parameter list 

The parameter list window is now visible and can be used to select parameters for statistical calculation. 
Some comments on the column names are follows: 

 Select. When it is checked, the parameter will be re-extracted. If it is unchecked, the parameter 
will depend on the sigma value. If a sigma value is given, the final value of the parameter will 
be the sigma value; while if a sigma value is not given, the current value of the parameter will 
remain as the final one. 

 Name: parameter name. When “select” is unchecked, the parameter name may be blank. At 
the same time, both “random” and “sigma” must have correct values. 

 Random: random variable name. If there is a random variable for the parameter in the current 
model file, the user must enter the name of the random variable here. If there is no random 
variable for the parameter in the current model file, the user may either input a new name here 
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or keep it blank. In the latter case, a new name will be automatically created. Note that not all 
names of random variables can be repeated.  

 Sigma: sigma of the parameter. An example here is the dtox parameter. If the user knows the 
sigma of the TOX (normally the information can be obtained from fabrication), then the value 
can be input into it directly. The extraction flow then bypasses this parameter and uses the 
predefined value instead. 

 Step: the step for BPV calculation. The step is very important for the extraction flow and is 
used to calculate the sensitivity of the parameter to the target. The user must input a suitable 
value; one that is not too big or too small. Here, the user can carefully monitor the change in 
IdVd or IdVg plots while adjusting the step number. 

Click the OK button to continue. The Select Targets window will pop up as shown in Figure 12. The 
user must then select the targets for the BPV extraction. Normally, the user will select the targets that 
are important or that he/she cares most about. 

 
Figure 12. Select targets 

Next, the user can set different weights for different targets. The default value is 1. Close the window to 
continue. In the last step, the Save dialog window will pop up. Here, the user inputs a name to save the 
model file. The user will then find that the following statistical parameters have been extracted and 
added into the generated model file: 

.param 

+s_dtox = 4.759276E-14         s_dxl = 2.757199E-13          s_dxw = 3.874035E-9            

+s_dvth = 1.16912E-2           s_dlvth = 8.878411E-7         s_dwvth = 3.014865E-7          

+s_dpvth = 3.740674E-9         s_du0 = 1.47506E-3            s_dpu0 = 2.144652E-8           

+s_dvsat = 2.016329             

.param 

+dtox = '0.0+s_dtox*random1'   dxl = '0.0+s_dxl*random2'     dxw = '0.0+s_dxw*random3'      

+dvth = '0.0+s_dvth*random4'   dlvth = '0.0+s_dlvth*random5'  dwvth = '0.0+s_dwvth*random6'  

+dpvth = '0.0+s_dpvth*random7' du0 = '0.0+s_du0*random8'     dpu0 = '0.0+s_dpu0*random9'    

+dvsat = '0.0+s_dvsat*random10'  

.param 
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+random1 = agauss(0.0,1.0, 1) 

+random2 = agauss(0.0,1.0, 1) 

+random3 = agauss(0.0,1.0, 1) 

+random4 = agauss(0.0,1.0, 1) 

+random5 = agauss(0.0,1.0, 1) 

+random6 = agauss(0.0,1.0, 1) 

+random7 = agauss(0.0,1.0, 1) 

+random8 = agauss(0.0,1.0, 1) 

+random9 = agauss(0.0,1.0, 1) 

+random10 = agauss(0.0,1.0, 1) 

The fitting result is shown in Figure 13. 

 

Figure 13. Fitting result 

The user may continue to fine tune the parameters manually, or simply modify the step number as 
previously mentioned and rerun the flow until a satisfactory result is obtained. 

4. Statistical IMV 

Finally, we use a demo to illuminate how to customize statistical IMV and plot it in MBP. After loading 
the demo data, choose Script -> Script Project from the main menu to pop up the MBP Script interface.  
In the left Project tab window, click default -> imv -> imv -> statistical to expand the file structure, as 
shown in Figure 14. 
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Figure 14. MBP Script 

Right click the IMV “sta_sigma_ids” and choose New -> Graph (Figure 15). 

 

Figure 15. Create new graph 

Input “sta_sigma_ids_w_l” as the code name. In the GRAPH_PROP tab, choose “w” as “Axis[x],” 
“sta_sigma_ids” as “Axis[x]” and “l” as “Axis[x],”as shown in Figure 16. 
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Figure 16. Configure graph 

Click the icon  to save the current code. In the main menu of MBP, choose Extraction -> IMV -> 

IMV Pages to open the IMV page. Click the icon  to refresh. Then, the user can view the 

customized IMV page (sta_sigma_ids_w_l) as shown in Figure 17. 

 

Figure 17. IMV pages 
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