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terms in the separate agreement shall control.
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liable for any damages of any kind including without limitation direct,indirect,special,
incidental and consequential damages,such as lost profits.Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S.Government Restricted Rights.Software and technical
data rights granted to the federal government include only those rights customarily
provided to end user customers.Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data)and 12.212
(Computer Software)and,for the Department of Defense,DFARS 252.227-7015
(Technical Data -Commercial Items)and DFARS 227.7202-3 (Rights in Commercial
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Momentumの基本
MomentumはAdvanced Design Systemの一部であり、今日の通信システム製品の評価とデザインに必要なシミュレーション・ツールを提供します。
Momentumは電磁界シミュレータであり、マイクロストリップ、スロットライン、ストリップライン、コプレナ・ライン、その他のトポロジーの一般的な平面
回路のSパラメータを計算します。異なるレイヤ上のトポロジーをビアやエアブリッジで接続できるために、多層RF/マイクロ波プリント回路基板、ハイ
ブリッド、マルチチップ・モジュール、集積回路などのシミュレーションが可能です。Momentumは、高周波回路基板、アンテナ、ICの性能を予測するた
めに最適なツール・セットを提供します。

Momentum Optimizationは、Momentumの機能を拡張して、真のデザイン・オートメーション・ツールを実現したものです。Momentum Optimizationの
プロセスは、形状パラメータを自動的に変化させて、回路またはデバイスの性能ゴールを満たす最適なストラクチャを実現します。（パラメータ化され
た）レイアウト・コンポーネントを使用することで、スケマティック・ページからMomentum Optimizationを実行することもできます。

Momentum Visualizationは、シミュレーション結果を3次元で表示できるツールです。導体やスロット内の電流をアニメーション表示したり、遠方界放
射パターンの2次元／3次元表示ができます。
Advanced Design Systemを初めてお使いになる場合は、オンライン・ドキュメントのQuick Startと、Schematic Capture and Layoutをご覧ください。レ
イアウトとMomentumの相互作用については、ドローイングのヒントを参照してください。

Momentumの主な特長

Momentumでは以下のことができます。

回路モデルのレンジ外の場合、または回路モデルが存在しない場合でも、シミュレーションを実行できます。
コンポーネント間の寄生結合を発見できます。
単なる解析と検証だけでなく、回路性能のデザイン・オートメーションを実現できます。
電流や遠方界放射の3次元表示を視覚化できます。

Momentumの主な機能

Momentumの主な機能は以下の通りです。

モーメント法に基づく電磁界シミュレータ
高速で正確なシミュレーション結果が得られる適応周波数サンプリング
性能仕様を満たすように形状の寸法を変更する最適化ツール
結果表示のための豊富なデータ表示ツール
シミュレーション結果データに対して計算を行うための式機能
ADS回路シミュレーション環境への完全な統合による電磁界/回路コ・シミュレーションとコ・オプティマイゼーション

Momentumの概要

Momentumのコマンドは、Layoutウィンドウから実行できます。以下の手順では、Momentumによるデザイン作成とシミュレーションの代表的なプロセ
スを示します。

MomentumモードまたはMomentum RFモードの選択。 Momentumは、マイクロ波とRFの2つのシミュレーション・モードで動作します。モードはデザイン・ゴール1.
に基づいて選択できます。Momentum（マイクロ波）モードは、マイクロ波放射効果を考慮した全波電磁界シミュレーションが必要なデザインに対して使用しま
す。Momentum RFモードは、形状が複雑で、電気的に小さく、放射を伴わないデザインに対して使用します。また、Momentum RFモードは、放射効果が無視
できる新しいマイクロ波モデルに対して、コンピュータ・リソースを節約しながら簡単なシミュレーションを行うためにも使用できます。Momentumモードと
Momentum RFモードの詳細な比較については、シミュレーション・モードについてを参照してください。
レイアウト・デザインの作成。初めに、平面デザイン（パッチ・アンテナ、多層プリント基板上のトレースなど）の外形寸法を作成します。Advanced Design2.
Systemにデザインを入力する方法には、以下の3つがあります。

スケマティックをレイアウトに変換する。
Layoutウィンドウを使ってデザインをドローイングする。
他のシミュレータやデザイン・システムからレイアウトをインポートする。Advanced Design Systemでは、さまざまなフォーマットのファイルをインポートできます。
スケマティックの変換とLayoutウィンドウでのデザインのドローイングについては、『Schematic Capture and Layout』を参照してください。デザインのインポートについては、『Importing
and Exporting Designs』マニュアルを参照してください。

サブストレート属性の定義。 サブストレートとは、回路が作成される媒体のことです。例えば、多層プリント基板は、金属、絶縁体または誘電体、グランド・プレ3.
ーンなどの各層から構成されています。カバーを持つデザインもあれば、オープンで空中に電波を放射するものもあります。デザインをシミュレートするため
には、サブストレートを完全に定義する必要があります。サブストレート定義には、サブストレートのレイヤ数と、各レイヤの構成要素が含まれます。また、サ
ブストレート内のレイアウト・デザインの各レイヤの配置と、各レイヤの金属特性の指定も必要です。詳細については、サブストレートを参照してください。
サブストレートの計算。 Momentumは、サブストレートの特性を決めるグリーン関数を、指定された周波数レンジで計算します。この計算結果はデータベース4.
に記憶され、この後のシミュレーション・プロセスで用いられます。詳細については、サブストレートを参照してください。
ポートの属性の指定。 ポートは、回路の動作を解析するために必要になる、回路へのエネルギー注入を行うためのものです。回路を作成したら、それにポ5.
ートを適用し、Momentumでポートの属性を指定します。アプリケーションに応じて異なるタイプのポートが使用できます。詳細については、ポートを参照してく
ださい。
ボックスまたは導波管の追加。 これらのエレメントは、サブストレート上の水平面に沿った境界を指定するために使用できます。ボックスまたは導波管がない6.
場合は、サブストレートは水平方向に無限に長いと仮定されます。これで問題ないデザインもありますが、シミュレーション・プロセス中に境界を考慮しなけれ
ばならない場合もあります。ボックスは、サブストレートの四方に垂直の壁をボックス状に立てることにより境界を指定します。導波管は、サブストレートを2つ
に分割する2つの垂直の壁を指定します。詳細については、ボックスと導波管を参照してください。
回路メッシュの設定と生成。 メッシュとは、長方形と三角形からなるパターンで、デザインに適用することにより、デザインを小さいセルに分割（離散化）する7.
役割を果たします。メッシュはデザインのシミュレーションを効率化するために必要です。さまざまなメッシュ・パラメータを指定することにより、デザインに合わ
せてメッシュをカスタマイズできます。 また、デフォルト値を使って最適なメッシュをMomentumに自動的に生成させることもできます。詳細については、メッシ
ュを参照してください。
回路のシミュレーション。シミュレーションには、周波数プランのパラメータ（シミュレーションの周波数レンジ、掃引タイプなど）の指定が必要です。設定が終了8.
したら、シミュレーションを実行します。シミュレーション・プロセスでは、サブストレートに対して計算されたグリーン関数の値とメッシュ・パターンを使って、デ
ザイン内の電流が計算されます。その後、電流に基づいてSパラメータが計算されます。掃引タイプとして適応周波数サンプリングが選択されていると、有理
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フィッティング・モデルに基づいて、高速で正確なシミュレーションが行われます。詳細については、シミュレーションを参照してください。
Momentumコンポーネントの作成。 Momentumコンポーネントは、スケマティック・デザイン環境で標準のすべてのADSアクティブ/パッシブ・コンポーネントと組9.
み合わせて、寄生レイアウト効果を含む回路の作成とシミュレーションに使用できます。回路シミュレーションの際には、Momentumエンジンが自動的に起動
され、MomentumコンポーネントのSパラメータ・モデルを生成します。Momentumコンポーネントと電磁界/回路コ・シミュレーション機能の詳細については、レ
イアウト・コンポーネントを参照してください。
結果の表示。 Momentumのシミュレーションで得られたデータは、Sパラメータまたは電磁界として保存されます。データ・ディスプレイまたはビジュアリゼーシ10.
ョンを使って、Sパラメータと遠方界放射パターンを表示できます。詳細については、データ・ディスプレイを使用した結果の表示とMomentum Visualizationを参
照してください。
最適化。 Momentumと組み合わされたMomentum Optimizationは、平面回路の電磁界（EM）デザインを自動的に最適化する効果的なソフトウェア・ツールで11.
す。Momentum Optimizationは、デザイン・ゴールに基づいて回路性能を改善するためにレイアウトを自動的に調整するもので、Momentumマイクロ波モード
とMomentum RFモードで開発されたデザインをサポートします。Momentum Optimizationの詳細については、Momentum Optimizationを参照してください。
放射パターン。回路上の電流がわかれば、電磁界を計算できます。電磁界は、回路に固定された球座標系で表現できます。放射パターンの詳細について12.
は、放射パターンとアンテナ・パラメータを参照してください。
Momentum Visualization。 Momentum Visualizationを使うと、電流、遠方界、アンテナ・パラメータを表示できます。13.

シミュレーション・モードについて

ADSバージョン1.5より、Momentumに既存のマイクロ波モードに加えてRFシミュレーション・モードが追加されました。マイクロ波モードはMomentum、
RFモードはMomentum RFと呼ばれています。Momentum RFは、RF周波数で正確な電磁界シミュレーション性能を実現します。これより高い周波数
では、放射効果が増加するため、Momentum RFモデルの精度は周波数の増加とともに滑らかに低下します。Momentum RFは、コンピュータ・リソー
スを節約しながらDCまでの周波数でより高速で安定したシミュレーションを実現したいという要望に応えます。代表的なアプリケーションとしては、チ
ップ、モジュール、基板上のRFコンポーネント／回路や、デジタル/アナログRFインターコネクト／パッケージなどがあります。

Momentumモードと比べると、Momentum RFモードはいくつかの新しい技術を採用していて、RF周波数でのレイアウト・デザインのシミュレーションに
さまざまな利点を発揮します。RFモードは準静的電磁界関数に基づいたものなので、デザインのシミュレーションが高速になります。Momentum RF
はADSのMomentumと同じ使用モデルを採用し、Momentum VisualizationおよびOptimizationと組み合わせて使用できます。アプリケーションに適し
たモードの選択では、各モードがMomentum製品の機能をどのようにサポートするかを説明しています。2つのシミュレーション・モードの詳細な比較
については、<a_href="Theory_of_Operation_for_Momentum.html#TheoryofOperationforMomentum-1107072">マイクロ波シミュレーション・モードとRF
シミュレーション・モードの比較を参照してください。

正しいモードの選択

LayoutウィンドウのMomentumメニュー・ラベルに、現在のシミュレーション・モードが表示されています。モードを選択するには、モード設定を切り替
えます。

MomentumからMomentum RFにモードを切り替えるには、Momentum > Enable RF Modeを選択します。
Momentum RFからMomentumにモードを切り替えるには、Momentum RF > Disable RF Modeを選択します。

どちらの場合も、Layoutウィンドウのメニュー・ラベルが新しいモードに変わります。

どちらのモードを使用するかは、アプリケーションに応じて決まります。各モードにはそれぞれの利点があります。Momentum RFは、RFアプリケーシ
ョンだけでなく、マイクロ波回路もシミュレートできます。下のグラフは、さまざまなアプリケーションにどちらのモードが適しているかを示しています。こ
れからわかるように、いくつかのアプリケーションでは、必要に応じてどちらのモードも使用できます。必要に応じて、簡単にモードを切り替えて同じレ
イアウト・デザインをシミュレートできます。例えば、マイクロ波アプリケーションに対して、最初はMomentum RFでシミュレーションを行うことにより、簡
単な初期デザインと最適化の繰り返しを行い、その後でMomentumに切り替えて放射効果を考慮することにより、最終的なデザインと最適化を行うこ
とができます。

アプリケーションに適したモードの選択

回路が以下の条件を満たす場合には、Momentum RFの方が通常は効率的なモードです。

電気的に小さい
形状が複雑
放射を伴わない
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電気的に小さい回路と形状が複雑な回路の説明については、回路特性に適合するシミュレーション・モードを参照してください。

注記
損失伝導率が指定された無限大のグランド・プレーンに対しては、Momentumのマイクロ波モードはグランド・プレー
ンの高周波損失を考慮しますが、RFモードは高周波損失を無視します。

サンプル・プロジェクトの場所

MomentumおよびMomentum RFでシミュレートできるデザインのサンプルが、Exampleディレクトリにあります。
サンプル・プロジェクトをオープンする手順:

Mainウィンドウで、File > Example Projectを選択します。1.
Open Example Projectダイアログ・ボックスで、Directoriesフィールドにマウスを置き、Momentumをダブルクリックします。2.
Directoriesフィールドで、Antenna、emcktcosim、Microwave、Optimization、RFのいずれかのサンプル・ディレクトリをダブルクリックします。3.
Filesフィールドでプロジェクトを選択し、OKをクリックします。4.

これらのサンプルの内のいくつかは、Momentumの機能のアプリケーション例として、このマニュアルで紹介されています。

Momentum入門
この章は、Momentumを初めて使用する方を対象としています。内容は、Momentumによる基本的な作業の解説と練習です。この後の各章は、より
詳しいリファレンス情報と例です。

レイアウトの基本

レイアウトの作成には2つの基本的な方法があります。

スケマティックから(Schematicウィンドウで）
直接(Layoutウィンドウで）

どの方法でレイアウトを作成するのがよいかは、デザインとデザイナによって異なります。

このセクションでは、完成したスケマティックからレイアウトを自動的に作成する方法と、Layoutウィンドウの基本機能を使用してレイアウトを直接作
成する方法を説明します。

注記
レイアウトの作業が終了したら、レイアウト・ライセンスを解放して、他のユーザが使用できるようにしてください。こ
のためには、LayoutウィンドウでFile > Release Layout Licenseを選択します。

完成したスケマティックからのレイアウトの作成

スケマティックにすべてのデータが含まれている場合は、レイアウトの作成はきわめて簡単です。

Schematicウィンドウでここに示すスケマティックを作成し、メニュー・コマンドLayout > Generate/Update Layoutを選択します(スケマティックはソース表現で1.
す）。Generate/Update Layoutダイアログ・ボックスが表示されます。
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デフォルトでは、レイアウトはP1(0,0）から角度0°で始まります。既存のレイアウトは存在しないので、Equivalence(スケマティックの開始コンポーネントに対応
するレイアウト・コンポーネント）が作成されていないと表示されます。

この時点で、スケマティックのすべてのエレメントが強調表示され、すべて生成する必要があることを示しています。
OKをクリックします。2.
Status of Layout Generationダイアログ・ボックスが表示されます。これには、処理されたデザインの数、レイアウトで再生成(作成）されたアイテムの数、スケ
マティックとレイアウトで向きが異なるアイテムの数、レイアウトに配置されなかったスケマティック・コンポーネントの数が表示されます。

プログラムはLayoutウィンドウを自動的にオープンし、生成したレイアウトをその中に配置します。レイアウトの向きはスケマティックとは異なります。これは、
レイアウトがStarting Componentから始まってページの左から右へとドローイングされるからです。
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レイアウト・ディレクトリの作成

Advanced Design Systemを起動し、プロジェクトを作成します。Layoutウィンドウを表示するには、ADSメイン・ウィンドウでWindow > New Layoutを選
択するか、オープンしているSchematicウィンドウでWindow > Layoutを選択します。

以下の作業は、LayoutウィンドウでもSchematicウィンドウと同じ方法で実行できます。

コンポーネントの選択
コンポーネントの配置と選択解除
ビューの変更
コンポーネント・パラメータの非表示
コンポーネントのコピーと回転
名前付き接続の使用

トレースによるコンポーネントの接続

Schematicウィンドウと同様に、実際に接触していないコンポーネント同士を接続できます。Layoutウィンドウでは、このためにコンポーネントの間にト
レースを配置します(Schematicウィンドウでのワイヤの使用と同じ）。Component > Traceを選択するか、ツールバーのTraceボタンをクリックします。

Schematicウィンドウのワイヤと異なり、Layoutウィンドウのトレースは単独で挿入することもできます(2回クリックすると挿入が終了します）。

形状

レイアウトでは、Insertコマンドまたはツールバーのアイコンを使って形状を挿入できます。

各形状について、クリックしてドラッグして配置するか、座標を入力して点を定義します(形状を選択してInsert > Coordinate Entryを選択）。

パス :開始点、セグメント端点(クリック）、終了点(ダブルクリック）
多角形 :開始点、頂点(クリック）、終了点(ダブルクリック）で形状が閉じます。
ポリライン :開始点、セグメント端点(クリック）、終了点(ダブルクリック）
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長方形 :2つの対角コーナ
円 :中心と円周上の点
円弧 :(Insertコマンドのみ）中心と円周上の点

注記
多角形とポリラインの最後のセグメントを入力するには、マウスをダブルクリックする代わりにスペースバーを押す
方法もあります。

さまざまな形状をドローイングして、それぞれの作成方法を試してみてください。

レイヤ

Layoutウィンドウでは、アイテムはレイヤ上に配置されます。現在の挿入レイヤの名前は、ツールバーとステータス・バーに表示されます。

挿入レイヤの変更

挿入レイヤを変更するにはいくつかの方法があります。

ツールバーで、新しいレイヤの名前を入力し、Enterを押します。
ツールバーで、レイヤ名の隣の矢印をクリックします。現在定義されているレイヤのリストから名前を選択します。
コマンドInsert > Entry Layerを選択し、リストからレイヤを選択します。
コマンドOptions > Layersを選択し、Layer Editorダイアログ・ボックスで定義済みレイヤのリストからレイヤを選択します。
コマンドInsert > Change Entry Layer Toを選択し、現在の挿入レイヤにしたいレイヤ上に存在するオブジェクトをクリックします。
LayoutウィンドウをオープンしたときにオープンされるLayersウィンドウを使用して、現在定義されているレイヤのリストから名前を選択します。
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さまざまなレイヤ上に形状を配置してみてください。ダイアログ・ボックスで変更を確定するにはOKをクリックする必要があることに注意してください。

別のレイヤへのコピー

形状をあるレイヤから別のレイヤにコピーしてみてください。コマンドEdit > Advanced Copy/Paste > Copy to Layerを使用します。コピーした形状
は、元の形状と全く同じ座標に配置されます。両方が見えるようにするには一方を移動します。

デフォルト・レイヤ設定

コマンドOptions > Layersを選択して、レイヤ・エディタを表示します。ここから、定義済みのレイヤのパラメータを編集したり、レイヤを追加したり、既

存のレイヤを削除したりできます。

Applyをクリックすると、レイヤ定義が更新されますが、ダイアログ・ボックスはクローズされません。

レイヤ・パラメータを設定してみてください。レイヤ上のすべてのアイテムの表示／非表示を切り替えられることに注意してください。保護されているレ
イヤの場合は、その上のアイテムは選択できません。
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その他のレイヤ・デフォルト

Options > Preferencesコマンドは、Layoutダイアログ・ボックスのPreferencesを表示します。このダイアログ・ボックスには11個のタブがあり、タブをク
リックすると対応するパネルが前面に表示されます。

Grid/Snapタブをクリックします。

このパネルでは、スナップ・グリッドと表示グリッドのパラメータを設定します。

表示グリッドは、一連の垂直および水平の線または点として画面に表示され、ドローイング・エリア内のアイテムの整列や間隔指定に使用できます。

グリッドの表示/非表示とカラーの調整

Displayエリアで、Major、Minor、またはその両方を選択します。1.
Typeで表示のタイプ(Dots: 点またはLines: 線）を選択します。グリッド表示を確認するためにズーム・インが必要な場合があります。2.
Colorというラベルの隣のカラー表示の長方形をクリックし、グリッドのカラーを選択します。OKをクリックしてカラー・パレットをクローズします。3.
Applyをクリックします。さまざまな設定を試してみてください。4.

注記
ドローイング・エリアのカラーは、DisplayタブのBackgroundカラーです。

スナップおよびグリッド間隔の調整

いくつかのマイナー・グリッドごとにメジャー・グリッドを表示することで、レイアウトでの距離の測定やオブジェクトの整列が容易になります。

Spacingエリアで、マイナー・グリッドの表示係数をXとYに関して変更します。値が大きいほど、グリッドの間隔は広くなります。1.
Applyをクリックします。さまざまな設定を試してみてください。表示係数のためにグリッドの密度が高くなりすぎて表示できない場合は、ズーム・インすると見2.
えるようになります。
今度はメジャー・グリッドを試してみてください。3.

ピン／頂点スナップ距離の調整

ピン／頂点スナップ距離は、コンポーネントのピンや形状の頂点にどれだけ近ければカーソルがスナップするかを表します。

大きい値を指定すると、スナップ・ポイントの正確な位置がわからない場合でも、スナップ・ポイントにオブジェクトを配置するのが容易になります。小
さい値を指定すると、他のスナップ・ポイントが近くにいくつかある場合でも、特定のスナップ・ポイントを選択するのが容易になります。

ドローイング・エリアにコンポーネントや形状をいくつか配置して、ピン／頂点スナップのさまざまな設定を試してみてください。
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Screen pixは、画面のピクセル単位でサイズを指定します。例えば、15を選択すると、スナップ領域の直径は15ピクセルになります。

User Unitsは、ウィンドウの現在の単位でサイズを指定します。例えば、インチを使用していて0.1ユーザ単位を選択した場合は、スナッ
プ領域の直径は0.1インチです。

スナップ・モードの練習

スナップ・モードは、オブジェクトをページ上で挿入または移動する際に、プログラムがオブジェクトを配置する位置を制御します。コンポーネントの挿
入または移動、または形状のドローイングの際に、スナップ・モードを変更できます。スナップを有効にすると、アイテムはスナップ・グリッドに引き寄
せられます。

さまざまなスナップ・モードをオン／オフして、Layoutウィンドウのアイテムの配置にどのように影響するかを観察してみてください。

スナップ・モード 優先順位

スナップ・モードを任意の組合わせで選択することにより、
カーソルがスナップする方法を制限したり改良したり
できます。この表は、スナップ・モードと
その優先順位の一覧を示しています。

ピン 1

頂点
2

中点

交点

円弧／円の中心

エッジ 3

グリッド 4

角度スナッピングは、ピン・スナップだけがオンになっていて、カーソル位置のピンが既存のパーツに接続されるようにパーツを配置した場合に自動
的に発生します。パーツは、接続先のパーツとの位置関係が正しくなるように回転されて配置されます。

例えば、30°のマクロストリップ・カーブがあり、それに接続されるようにマイクロストリップ・ラインを配置した場合は、マイクロストリップ・ラインはカー
ブと正しく接するように30°にスナップします。

Enable Snapは、スナップ・モードのオンとオフを切り替えます。スナップ・モードはOptionsメニュー自体から切り替えることもでき、ツールバーにもスナ
ップ・モードのボタンがあります。

ピン・スナップを除いて、挿入されたオブジェクト上の選択されたポイントは、ポインタにより定義されます。

すべてのスナップ・モードをオフにした場合は、オブジェクトはページ上でオブジェクトを放したその位置に正確に配置されます。これは
ロー・スナップ・モードと呼ばれることもあります。他のスナップ・モードと同様に、ロー・スナップ・モードもオブジェクトを移動または伸縮
した場合に適用されます。

Pin 挿入、移動、または伸縮するオブジェクトのピンが既存のオブジェクトのピンからスナップ距離以内にある場合は、プログラムはそのオブジェクト
のピンが既存のオブジェクトのピンに接続されるようにオブジェクトを挿入します。ピン・スナップは、他のすべてのスナップ・モードよりも優先されま
す。

Vertex 挿入、移動、または伸縮するオブジェクトの選択した位置が既存のオブジェクトの頂点からスナップ距離以内にある場合は、プログラムはそ
のオブジェクトの選択した位置が既存のオブジェクトの頂点に一致するようにオブジェクトを挿入します。

頂点スナップ・モードでの頂点とは、プリミティブの制御ポイントまたは境界コーナ、または作図ラインの交点です。

Midpoint 挿入、移動、または伸縮するオブジェクトの選択した位置が既存のオブジェクトの中点からスナップ距離以内にある場合は、プログラムはそ
のオブジェクトの選択した位置が既存のオブジェクトの中点に一致するようにオブジェクトを挿入します。

Intersect 挿入、移動、または伸縮するオブジェクトの選択した位置が既存の2個のオブジェクトのエッジの交点からスナップ距離以内にある場合は、
プログラムはそのオブジェクトの選択した位置が既存のオブジェクトの交点に一致するようにオブジェクトを挿入します。

Arc/Circle Center 挿入、移動、または伸縮するオブジェクトの選択した位置が既存の円弧または円の中心からスナップ距離以内にある場合は、プ
ログラムはそのオブジェクトの選択した位置が既存の円弧または円の中点に一致するようにオブジェクトを挿入します。

Edge 挿入、移動、または伸縮するオブジェクトの選択した位置が既存のオブジェクトのエッジからスナップ距離以内にある場合は、プログラムはその
オブジェクトの選択した位置が既存のオブジェクトのエッジ上に来るようにオブジェクトを挿入します。点がエッジにスナップすると、その点はそのエッ
ジに捕捉され、ポインタをスナップ距離より遠くに移動しない限りエッジに沿ってスライドします。
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エッジ・スナップは優先順位3なので、エッジに沿ってスライドしている途中で、カーソルが優先順位1または2の対象からスナップ距離以
内に入った場合は、選択した位置は優先度1または2のアイテムにスナップします。

Grid 挿入、移動、または伸縮するオブジェクトの選択した位置がグリッド・ポイントからスナップ距離以内にある場合は、プログラムはそのオブジェク
トの選択した位置が既存のグリッド・ポイントに一致するようにオブジェクトを挿入します。

他のすべてのスナップ・モードはグリッド・スナップ・モードよりも優先されます。

ヒント
グリッド・スナップはできるだけオンにしておいてください。オブジェクトがグリッドから外れると、グリッド上に戻すの
が困難になります。

オブジェクトが均一に配置されることを保証し、丸め誤差による小さいレイアウト・ギャップの可能性を減らすためには、45°
または90°の角度を使用します。

ドローイングのヒント

この章では、Momentumでシミュレートするレイアウトのドローイングに関するヒントと例を紹介します。これらの例は、Momentumの要件を満たすため
にドローイング段階で必要なことを考慮して作られています。

グリッド・スナップ・モードの使用

レイアウトでは、すべての形状を精密に制御できます。形状のドローイングと配置には、さまざまなスナップ・モードが使用できます。例えば、形状同
士を接続する場合は、頂点スナップ・モードをオンにします。また、レイアウトにポートを追加する際には、スナップ・モード設定を確認すべきです。

スナップ・グリッド間隔も、形状の配置に役立ちます。一般にスナップ・グリッド間隔は、マイナー・グリッド・ポイントの値の1/2程度に設定します。例え
ば、マイナー・グリッド・ポイントが1.0の場合は、スナップ・グリッド間隔は0.5にします。これにより、形状がどのようにスナップするかを容易にわかりま
す。

スナップ・モードとスナップ・グリッド間隔の詳細については、『Layout』マニュアルの第2章を参照してください。

レイアウト・レイヤの選択

レイアウト・レイヤの標準セットは、defaultという名前のレイヤから始まります。このレイヤを回路のドローイングに使用しないでください。Momentum
で使用できる最初のレイヤはcondです。レイアウト・レイヤの詳細については、『Schematic Capture and Layout』マニュアルを参照してください。

単純な形状の使用

一般に、形状のドローイングにおいては、頂点の数をなるべく少なくします。 そのほうがメッシュの計算が簡単になるからです。曲線オブジェクトをド
ローイングする際には、Arc/Circle Radius（Options > Preferences > Entry/Editの下）を比較的大きい値にします。これにより頂点の数が減り、ファセ
ットを使って形状が表現されます。

形状のマージ

形状のマージは、形状の小さなオーバラップを除去するのに役立ち、場合によってはメッシュ・パターンの単純化につながることもあります。例えば、
複数の多角形を使ったレイアウトでオーバラップのおそれがある場合は、多角形をマージすればオーバラップ・エラーを避けられます。形状をマージ
するには、対象となる形状をすべて選択して、Edit > Mergeを選択します。

ポートとオブジェクトの属性の表示

ポート、形状、その他のコンポーネントなど、レイアウト内で選択されたすべてのアイテムには、対応する属性があります。属性を表示する1つの方法
は、オブジェクトを選択してEdit > Propertiesを選択する方法です。この方法では、属性を変更することもできます。Momentum用のオブジェクトの属
性を変更する場合は、必ずMomentumメニューのコマンドを使って変更します。

レイアウト全体の属性を表示するには、Options > Infoを選択します。

回路へのポートの追加

回路へのポートの追加は、SchematicウィンドウからでもLayoutウィンドウからでも可能です。以下の手順には、Momentumでシミュレートする回路に
ポートを追加する際の注意事項が含まれています。
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スケマティックへのポートの追加

メニュー項目Component > Portまたはツールバーのポート・アイコン（下記）を使用して、ポートを選択します。1.

ポートを配置する位置にマウスを置いてクリックします。接続が行われたことを確認します。2.

ポートを選択してEdit > Component > Edit Component Parametersを選択します。3.
パラメータlayer=は、ポートが適用されているレイヤを示します。スケマティックをレイアウトに変換すると、すべてのコンポーネントがレイアウト・レイヤに割り4.
当てられます。この時点で、ポートを特定のレイヤに割り当てることができます。レイヤを変更するには、Select Parameterリストでlayer=を選択し、Parameter
Entry Modeリストボックスで新しいレイヤを選択します。選択したレイヤは、ストリップまたはスロット・メタライゼーション・レイヤにマッピングする必要がありま
す。メタライゼーション・レイヤについては、サブストレートを参照してください。
OKをクリックして、新しいレイヤ指定を確定します。5.

スケマティックからレイアウトを作成する際には、ポートの配置が正しいことを確認してください。詳しくは、レイアウトへのポートの追加の手順と、注
意事項を参照してください。

レイアウトへのポートの追加

ポートを追加する手順:

ポートを配置する位置を決めます。ポートは以下の場所に適用できます。1.
コンポーネントのピン
コンポーネントまたはオブジェクト（長方形、多角形など）のエッジ、通常はその中点
オブジェクトの表面

注記
オブジェクトのコーナにポートを配置しないでください。エッジにポートを追加する場合は、適切なスナップ・モー
ドをオンにします。正確なシミュレーション結果を得るために、（Optionsメニューの）Midpoint ShapおよびEdge
Snapモードをオンにすることを習慣付けてください。

多角形の表面にポートを追加する場合は、以下のスナップ・モードを（Optionsメニューで）オフにした方がうまくいきます。2.
ピン・スナップ
エッジ・スナップ
中点スナップ

コンポーネントまたは形状が入力されているレイヤの名前を確認します。レイアウト・レイヤの名前がわからない場合は、Options > Layersを選択します。ダイ3.
アログ・ボックスに表示されたカラーを見ながら、各レイヤを選択します。Layoutウィンドウのレイヤのカラーと一致したら、レイアウト・レイヤの名前を記録しま
す。ダイアログ・ボックスをクローズします。
メニュー項目Component > Portまたはツールバーのポート・アイコン（下記）を使用して、ポートを選択します。4.

Port parametersダイアログ・ボックスが表示されます。パラメータlayerが、ポートが適用されるレイヤを表します。デフォルト値は現在アクティブなドローイング5.
・レイヤです。
このレイヤは、ステップ3で記録したレイヤと同じでなければなりません。 レイヤを変更するには、Select Parameterリストでlayer=を選択し、Parameter Entry6.
Modeリストボックスで新しいレイヤを選択します。選択したレイヤは、ストリップまたはスロット・メタライゼーション・レイヤでなければなりません。ビア・メタライ
ゼーション・レイヤにマッピングされたレイヤに存在する形状に、ポートを適用しないでください。メタライゼーション・レイヤについては、サブストレートを参照し
てください。

注記
レイヤ名が見つからない場合は、Options > Layersを選択し、目的のレイヤ名をLayersリストで選択します。
Numberフィールドのレイヤ番号を記録します。Portダイアログ・ボックスでlayer=パラメータを選択し、Parameter
Entry Modeの下でInteger Valueを選択します。レイヤ番号を入力して、Applyをクリックします。
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Applyをクリックして新しいレイヤ指定を確定します。7.
ポートを配置する位置にマウスを置いてクリックします。回路にポートが追加されます。8.

注記
エッジにポートを追加する場合は、矢印がオブジェクトの外側にあり、オブジェクトの内部をまっすぐに指している
必要があります。一般に、エッジにポートを追加した場合は自動的にこのようになります。これを確認するにはズ

ーム・インが必要な場合があります。 

別のポートを追加する場合は、Portダイアログ・ボックスのInstance Nameが増加します。layer=パラメータを確認し、マウスを使って以下のポートを追加しま9.
す。
ポートの追加が終わったら、OKをクリックしてダイアログ・ボックスをクローズします。10.

注意事項

Momentumでシミュレートする回路にポートを追加する際は、以下の点に注意してください。

ポートを接続するコンポーネントまたは形状が存在するレイアウト・レイヤは、ストリップまたはスロットとして定義されたメタライゼーション・レイヤにマッピング
する必要があります。ポートを直接ビアに接続することはできません。ストリップとスロットの定義方法については、メタライゼーション・レイヤの定義を参照し
てください。

エッジにポートを配置する場合は、矢印がオブジェクトの外側にあり、オブジェクトの内部をまっすぐに指している必要があります。
接続先のオブジェクトとポートとは、同じレイアウト・レイヤになければなりません。エントリ・レイヤをこのレイヤに設定すると便利です。 Layoutウィンドウのツ
ールバーにあるEntry Layerリストボックスを使います。
ポートはオブジェクトに適用する必要があります。ポートがオープン・スペースに適用され、オブジェクトに接続されていない場合は、最も近いオブジェクトのエ
ッジにMomentumが自動的にポートをスナップします。ただし、この場合でもポートの位置は変化しないため、レイアウトを見てもわからないことがあります。
エッジにスナップされるポートを追加した後でレイアウト分解能を変更した場合は、ポートを削除して追加し直す必要があります。分解能を変更するとポート
がスナップされるエッジが不明確になるため、メッシュ計算でエラーが生じます。

注記
Momentumでシミュレートする回路には、グランド・ポート・コンポーネント（Component > Groundまたはツールバー

のボタン ）を使用しないでください。サブストレートにグランド・プレーンを追加するか、この章の後の方で説
明するグランド基準ポートを使用します。

例

マイクロストリップ・ラインのデザイン

このセクションでは、スケマティックを作成し、レイアウト形式に変換し、レイアウトをシミュレーション用に準備し、シミュレーションを実行し、解析プロ
ットを生成する手順を練習します。

この練習では、多くのデフォルト設定と単純な回路（ステップ幅のマイクロストリップ）を使用して、デザインと解析を簡単に実行できることを示します。

この練習では、以下の作業を行います。

ステップ幅を持つ単純なマイクロストリップ・ラインをスケマティックとしてドローイングし、対応するレイアウトを生成します。
単純なサブストレートを作成します。
メッシュを定義します。
シミュレーションを実行します。
結果を観察します。

サブストレートやメッシュといった用語の意味は、練習の途中で説明します。

この練習とこの後の各練習を行うには、Advanced Design Systemでの作業に関する基礎知識（プロジェクトとは何か、など）と、Schematicウィンド
ウ/Layoutウィンドウとコンポーネントの配置方法についての知識が前提となります。

回路のドローイング

ステップ幅を持つマイクロストリップ・ラインを作成する基本手順は以下の通りです。

新規プロジェクトの作成
スケマティックへのマイクロストリップ・コンポーネントの追加
スケマティックからレイアウトへの変換

スケマティック表現とレイアウト表現を下に示します。以下の各セクションでは、これらの作成方法を説明します。
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新規プロジェクトの作成

この練習は新規プロジェクトで開始します。

Mainウィンドウで、Tools > Preferencesを選択します。Create Initial Schematic Windowがオンになっていることを確認します。OKをクリックします。1.
Mainウィンドウで、File > New Projectを選択します。New Projectダイアログ・ボックスが表示されます。2.
Nameフィールドにstep1と入力します。3.
Project Technology Filesセクションで、ADS Standard: length unit - milを選択します。4.
OKをクリックします。5.

Schematicウィンドウが表示されます。ここにデザインを入力します。

スケマティックへのマイクロストリップ・コンポーネントの追加

このセクションでは、コンポーネントを選択する手順を説明します。以下のセクションで、コンポーネントをSchematicウィンドウに配置します。
下の図を参照して、Microstrip Transmission Linesパレットからマイクロストリップ・ライン・コンポーネント（MLIN）を選択します。

コンポーネントの配置

このセクションでは、2個のマイクロストリップ・ラインをSchematicウィンドウに配置する手順を説明します。

十字線をSchematicウィンドウに移動して1回クリックし、コンポーネントを配置します。コンポーネントのスケマティック表現がSchematicウィンドウに配置され1.
ます。
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十字線が1個めのコンポーネントの右側のピンの真上に来るようにカーソルを移動し、1回クリックして2個めのコンポーネントを配置します。2.

コマンドのキャンセル

現在のコマンドを終了せずにクリックを続けると、クリックするたびに別のコンポーネントが追加されます。

矢印ボタンをクリックします。1.

十字線が消えます。
コマンドを終了するには、Escキーを押す方法もあります。2.
終了コマンドはこの練習でもこの後の練習でも頻繁に使用するので、よく覚えておいてください。

コンポーネント・パラメータの編集

各コンポーネントのスケマティック表現の下には、コンポーネントの編集可能パラメータの一部が表示されています。このセクションでは、ストリップの
1つの幅を変更する方法を説明します。その結果、ステップ幅マイクロストリップ伝送ラインができます。

2番目に配置したコンポーネントを2回クリックします。Libra Microstrip Lineダイアログ・ボックスがオープンします。1.

Select Parameterフィールドで、W（幅）パラメータを選択します。右側のフィールドに幅の値が表示されたら、このフィールドの値を35 milに変更します。Applyを2.
クリックします。
OKをクリックしてダイアログ・ボックスをクローズします。3.

注記
コンポーネントのパラメータがSchematicウィンドウに表示されている場合は、値をクリックして新しい値を入力して
も、そのパラメータを編集できます。
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左側のコンポーネントの幅が25 milに設定されていることを確認し、必要に応じて、このパラメータの値を変更します。4.

回路へのポートの追加

回路を完成するには、マイクロストリップのステップ幅の開始部と終了部にポートを追加する必要があります。Momentumでは、ポートは回路にエネ
ルギーが出入りする場所を示しています。このセクションでは、ポートを追加する方法を説明します。

メニュー・バーで、Portボタンをクリックします。1.

カーソルをSchematicウィンドウに移動し、ポートのゴースト・アイコンの向きを確認します。この手順が終了したときに、ポートは下のスケマティックに示すよう
に配置されている必要があります。
場合によっては、ポートを必要な向きに回転させる必要があります。このためには、Rotateボタンをクリックし、カーソルをSchematicウィンドウに戻します。ポ2.
ートの輪郭の回転を確認して、正しい状態になるまで繰り返します。

左のコンポーネントの左側にあるオープン・ピンの上にカーソルを移動して、クリックします。3.
ポートを挿入するコマンドはアクティブなままです。2番目のポートを挿入するために、向きを適切に変更してから、右のコンポーネントの右側にあるオープン・4.
ピンの上にカーソルを移動して、クリックします。
現在のコマンドを終了します。スケマティックは下の図のようになります。これはマイクロストリップ・ライン・ステップ幅です。ラインの最初の部分の幅は25 mil5.
で、幅35 milに増加します。全体の長さは200 milです。

注記
すべてのコンポーネントが接続されます。菱形のピンはそのピンが未接続であることを示し、コンポーネントを選
択して移動することにより接続を完成させる必要があります。

デザインの保存

作業は定期的に保存することをお勧めします。このセクションでは、スケマティックを保存する方法を説明します。

File > Save Designを選択します。Saveダイアログ・ボックスが表示されたら、プロジェクトの名前（この例ではstep1）を入力します。1.
OKをクリックします。2.

レイアウトの生成

Advanced Design Systemの強力な機能として、スケマティックのレイアウトへの自動変換があります。Momentumでは回路がレイアウト形式であるこ
とが必要なので、これにより回路をスケマティックとレイアウトのどちらの形式でも作成できます。Schematicウィンドウでのドローイングを選択した場
合は、使用するコンポーネントのフットプリントがレイアウトでも使用できる必要があります。レイアウトで使用可能なコンポーネントとしては、伝送ライ
ンやアートワーク付きの集中定数コンポーネントがあります。

このセクションでは、先ほど完成したステップ幅マイクロストリップ・ラインのスケマティックをレイアウトに変換する方法を説明します。

Schematicウィンドウで、Layout > Generate/Update Layoutを選択します。Generate/Update Layoutダイアログ・ボックスが表示されます。フィールドを編集す1.
る必要はありません。
OKをクリックします。2.
変換が終了したことを示すStatus of Layout Generationメッセージが表示されます。3.
OKをクリックします。4.
Layoutウィンドウが表示され、スケマティックのレイアウト表現を示します。このウィンドウはSchematicウィンドウの下に隠れていることがあるので、その場合5.
は他のウィンドウを移動してLayoutウィンドウが見えるようにします。

Layoutウィンドウで、File > Save Designを選択します。レイアウト名をstep1にします。これでプロジェクトにレイアウトとスケマティックができました。6.

単純なサブストレートの作成
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平面回路にはサブストレートが必要です。サブストレートとは、回路が存在する媒体を記述したものです。サブストレートの例として、以下から構成さ
れる多層回路基板のサブストレートがあります。

メタル・トレースのレイヤ
トレース間の絶縁材料のレイヤ
グランド・プレーン
異なるレイヤ上のトレースを接続するビア
回路基板を取り囲む空気
Momentumには定義済みのサブストレートがいくつか用意されていて、独自のサブストレートを作成することもできます。サブストレートに関する詳細（サブスト
レートが保存される場所など）については、サブストレートを参照してください。

このセクションでは、サブストレートを定義する手順を説明します。

ステップ幅マイクロストリップ・ラインの例では、以下のレイヤを持つサブストレートを使用します。

グランド・プレーン
アルミナなどの絶縁レイヤ
マイクロストリップ用のメタル・レイヤ
マイクロストリップの上の空気レイヤ

Layoutウィンドウで、Momentum > Substrate > Create/Modifyを選択します。Create/Modifyダイアログ・ボックスがオープンし、Substrate Layersオプションと1.
パラメータが表示されます。

Substrate Layersフィールドで、FreeSpaceを選択します。Substrate Layer Nameフィールドに移動し、Airに変更します。他のパラメータはデフォルト値のままに2.
して、Applyをクリックします。
デフォルト・レイヤのAluminaと///GND///は残しておき、それ以外のレイヤが表示されている場合は強調表示してCutを選択します。Applyをクリックします。3.
必要な4つのサブストレート・レイヤのうち3つが現在表示されています。4つめの（メタル）レイヤを見るには、Metallization Layersタブをクリックします。
メタル・レイヤは自動的にアルミナと空気のサブストレート・レイヤの間に配置されます。マイクロストリップ・ラインはこのレイヤ上にあると仮定されます。
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OKをクリックしてダイアログ・ボックスをクローズします。4.
サブストレートをプロジェクトとともに保存するには、Momentum > Substrate > Save Asを選択します。Selectionフィールドにstep1と入力してOKをクリックしま5.
す。サブストレートstep1.slmがプロジェクトのnetworksフォルダに保存されます。

サブストレートの保存に関するその他の情報:

LayoutウィンドウでFile > Saveを使用した場合は、サブストレート定義はデザインとともに自動的に保存されます。
コマンドSubstrate > Save Asを使用すると、サブストレート定義を任意の場所に
slmファイルとして保存して、他のデザインで使用できます。
デザインをオープンすると、デザインとともに保存されているサブストレート定義が自動的にロードされます。

サブストレートの事前計算

シミュレーションの実行には、サブストレートの動作を記述するグリーン関数の計算が必要です。Momentumに付属するサブストレートには、この計
算がすでに含まれています。以下のような場合:

サブストレートを再使用している場合
サブストレートのグリーン関数をすでに計算してある場合
既存のサブストレートと同一のサブストレートを作成した場合

このような場合は、計算がすでにデータベースに保存されているため、計算を実行しようとしても無視されます。計算の周波数レンジを拡大した場合
のみ、追加の計算が実行されます。

このセクションでは、サブストレートを事前計算する手順を説明します。ただし、この例では、計算は実行されません。前の例で定義したサブストレー
トは、実はMomentumに付属するものと同一だからです。

Momentum > Substrate > Precompute...を選択します。. Precompute Substrate Functionsダイアログ・ボックスが表示されます。Minimum Frequencyを1 GHz1.
に、Maximum Frequencyを4 GHzに設定します。これはシミュレーションの対象となるレンジです。シミュレーションを行うレンジ全体にわたって計算が存在す
る必要があります。計算が存在しない場合は、エラーが表示されます。
OKをクリックします。2.

サブストレートを計算するかどうかを尋ねるダイアログ・ボックスがオープンしたら、Yesをクリックします。計算が実行されます。
サブストレートの計算がすでに存在することを示すダイアログ・ボックスが表示されたら、OKをクリックします。計算は実行されません。

ステータス・ウィンドウもオープンします。このステータス・ウィンドウは、この練習を実行している間、画面に表示しておくことができます。

注記
上記の説明は、Momentumマイクロ波モードのみに当てはまります。Momentum RFモードの場合は、サブストレート
はすべての周波数に対して事前に計算されているので、最小／最大周波数を設定する必要はありません。

メッシュ・パラメータの設定

シミュレーションを実行するにはメッシュが必要です。メッシュを生成する最も簡単な方法は、Meshメニューを使用せずにMomentumにメッシュを完全
に自動生成させる方法ですが、メッシュ生成の方法を制御するパラメータを編集することもできます。

メッシュとは、回路の表面に適用される三角形と長方形からなる格子状のパターンです。シミュレーション中にメッシュを使用して、各三角形または長
方形領域内の電流が計算され、回路のカップリング効果も計算されます。この計算結果から、回路のSパラメータが求められます。
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メッシュの定義と生成の詳細については、メッシュを参照してください。

このセクションでは、メッシュ計算の周波数を設定する手順を説明します。他のすべてのオプションはデフォルト値のままにします。

Layoutウィンドウで、Momentum > Mesh > Setup...を選択します。. Mesh Setup Controlsダイアログ・ボックスが表示されます。1.

Mesh Frequencyフィールドに4 GHzと入力してOKをクリックします。2.

メッシュの事前計算

シミュレーションの前にメッシュを確認するために、メッシュの事前計算を実行できます。この練習ではメッシュの事前計算は行いません。

これで、メッシュ生成のプロセスは終了です。

シミュレーションの実行

Momentumのシミュレーション・プロセスは、サブストレートに対して計算されたグリーン関数とメッシュ情報とを組み合わせて、回路内の電流を計算し
ます。得られた電流値を用いて、回路のSパラメータが計算されます。
シミュレーションを設定するためには、さまざまなオプションが選択できます。詳細についてはシミュレーションを参照してください。このセクションで
は、シミュレーションを実行するための最小限の手順を説明します。

Layoutウィンドウで、Momentum > Simulation > S-parametersを選択します。Simulation Controlダイアログ・ボックスが表示されます。1.
Sweep TypeをLinearに設定し、以下のパラメータが設定されていることを確認します。2.

Start = 1 GHz
Stop = 4 GHz
Frequency Step = 1 GHz
この掃引タイプを選択することにより、1〜4 GHzの周波数レンジでリニア・シミュレーションが実行され、シミュレーション対象の周波数ポイントがステップ・サイズに基づいて選択されま
す。

Add to Frequency Plan Listをクリックします。ダイアログ・ボックスは下の図のようになります。3.
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フィールドOpen data display when simulation completesがオンになっていることを確認します。4.
Simulateをクリックします。シミュレーションが実行されます。シミュレーションの進捗度と終了は、Simulation Statusウィンドウに表示されます。5.
シミュレーションが終了すると:6.

シミュレーション・プロセスで生成され使用されたメッシュが、レイアウトに重ねて表示されます。

Sパラメータ・シミュレーション結果が、Data Displayウィンドウに直交座標プロットとスミス・チャートで自動的に表示されます。これは、シミュレーション設定でOpen data display when
simulation is completeフィールドがデフォルトでオンになっているからです。View > View Allを選択するか、View Allボタンをクリックして、すべてのプロットを表示し、個々のプロットにズ
ーム・インします。Sパラメータ結果の例を以下に示します。

これで1つめのMomentumデザインの練習は終わりです。

マイクロストリップ・フィルタのデザイン

このセクションでは、マイクロストリップ結合ライン・フィルタのデザインのプロセスを練習します。これは前の練習に似ていますが、デフォルトを使用
する数が少なくなり、以下を練習します。

より複雑なサブストレートを作成します。
ポートの属性を指定します。
ボックスを使用してメタルの筐体内のフィルタをシミュレートします。
メッシュ・パラメータを指定します。

回路のドローイング

このセクションは、前の練習のドローイング手順とよく似ています。回路をスケマティックとしてドローイングし、レイアウトに変換します。これらの手順
の詳細については、前の練習を参照してください。

新規プロジェクトのオープン
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前の練習と同様に、フィルタのデザインは新規プロジェクトで開始します。

Mainウィンドウで、File > New Projectを選択します。1.
Nameフィールドにfilterと入力します。2.
Project Technology Filesセクションで、ADS Standard: length unit - milを選択します。 .3.
New Projectダイアログ・ボックスでOKをクリックして、新規プロジェクトを作成します。4.

スケマティックへのコンポーネントの追加

このセクションでは、マイクロストリップ・フィルタ・コンポーネントを選択する手順を説明します。

Schematicウィンドウで、Palette Listの矢印をクリックします。Palette Listがドロップダウンします。1.
スクロールしてT-lines MicrostripをPalette Listから選択します。2.
コンポーネント・パレットでMcfilを見つけてクリックします。Libra Microstrip Coupled-Line Filter Sectionコンポーネントが選択されます。3.
カーソルをSchematicウィンドウの上に移動すると、十字線とコンポーネントのゴースト・アイコンを表示されます。カーソルの位置を決めて、クリックします。4.
Cancel Commandボタンをクリックするか、Insertまたはarrowボタンを選択して、コマンドを終了します。5.

コンポーネントの編集

このセクションでは、コンポーネントの長さや幅などのパラメータを編集する方法と、コンポーネントの下に表示されるパラメータを変更する方法を説
明します。

コンポーネントのパラメータを編集するには、コンポーネントをダブルクリックします。1.
表示されるダイアログ・ボックスで、下記のパラメータの1つを選択し、値を編集します。また、Display parameter on schematicをオンにして、Schematicウィン2.
ドウのコンポーネントの下にパラメータが表示されるようにします。引き続き別のパラメータを選択し、以下のパラメータの値を設定します。

W = ライン幅 = 0.25 mm
S = ライン間隔 = 0.044 mm
L = ライン長さ = 1.8 mm
W1 = ピン1に接続されるラインの幅 = 0.25 mm
W2 = ピン2に接続されるラインの幅 = 0.25 mm

OKをクリックして編集を確定し、ダイアログ・ボックスをクローズします。3.

もう1個のコンポーネントのコピーと配置

このセクションでは、フィルタ・セクションのコピーを作成してスケマティックに追加する方法を説明します。

スケマティック上のフィルタ・コンポーネントをクリックして選択します。黒の輪郭が周りに表示されます。1.
Schematicウィンドウで、Edit > Copyを選択します。2.
Edit > Pasteを選択します。十字線を動かして、1個めのコンポーネントの左側のコネクタの真上に来るようにし、クリックします。3.
現在のコマンドを終了します。4.

ポートの追加

回路にはポートが必要です。スケマティックにポートを追加するのを忘れた場合は、スケマティックをレイアウトに変換した後でも追加できます。この
練習では、レイアウトにポートを追加します。

Momentumでは、ポートに追加の特性を定義できます。これもこの練習の後の方で行います。

スケマティックは下の図のようになります。すべてのコンポーネントが正しく接続されていることを確認します。

デザインの保存

作業は定期的に保存することをお勧めします。
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File > Save Designを選択します。1.
ファイル名にfilterと入力します。2.
OKをクリックします。3.

レイアウトの生成

このセクションでは、先ほど完成したマイクロストリップ結合ライン・フィルタのスケマティックをレイアウトに変換する方法を説明します。

Schematicウィンドウで、Layout > Generate/Update Layoutを選択します。Generate/Update Layoutダイアログ・ボックスとLayoutウィンドウが表示されます。1.
Layoutウィンドウで、Options > Preferencesを選択します。Layout Unitsタブをクリックし、Resolutionを0.001 mmに設定します。OKをクリックします。2.
Generate/Update Layoutダイアログ・ボックスで、Xフィールドに-1.8、Yフィールドに0.294を入力します。このステップでは、レイアウト上のP1の位置を指定しま3.
す。このステップは通常はオプションですが、位置を指定しておくと、後でフィルタを取り囲むボックスを追加する際に便利です。OKをクリックします。
変換結果を示すウィンドウが表示されます。OKをクリックします。4.

スケマティックのレイアウト表現がLayoutウィンドウに表示されます。これは下の図のようになります。

Layoutウィンドウで、File > Save Designを選択します。レイアウト名はfilterです。これでプロジェクトにレイアウトとスケマティックができました。5.

サブストレートの作成

この回路は、比較的単純なサブストレートを使用します。この練習では、いくつかのレイヤの厚さを変更します。さらに重要な作業として、サブストレ
ートの上と下にグランド・プレーンを追加します。これらのグランド・プレーンは、フィルタを取り囲むメタル・ボックスのトップとボトムを構成します。サブ
ストレートには以下のレイヤがあります。

ボックスのトップを表すグランド・プレーン
空気レイヤ
マイクロストリップ・フィルタのトレース
アルミナ・レイヤ
ボックスのボトムを表すグランド・プレーン

Layoutウィンドウで、Momentum > Substrate > Create/Modifyを選択します。1.

Substrate Layersフィールドでいちばん上のレイヤを選択します。BoundaryリストでClosedを選択します。トップのグランド・プレーンがサブストレートに追加さ2.
れました。
Substrate Layersリストで、Free_Spaceを選択します。Thicknessを2846 umに変更します。これは空気レイヤの厚さを設定します。3.
Substrate Layersリストで、Aluminaを選択します。Thicknessを254 umに変更します。4.
ボトムのグランド・プレーンは残し、サブストレートに表示されているそれ以外のレイヤをすべて選択してCutを行います。5.
Applyをクリックします。6.

ボックス筐体のトップとボトムはグランド・プレーンで定義され、側面はこの練習の後の方で定義します。

必要な5つのサブストレート・レイヤのうち4つが現在表示されています。マイクロストリップ・フィルタのメタル・レイヤを見るには、Metallization Layersタブをクリックします。
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この例では、メタル・レイヤは自動的にアルミナと空気のレイヤの間に配置されます。

このレイヤについて以下の点に注意してください。

メタル・レイヤは破線で示されます。
condは、この位置にマッピングされているレイアウト・レイヤを示しています。Layoutウィンドウを見ると、変換プロセスにおいてマイクロストリップ回路がcondという名前のレイアウト・レ
イヤに自動的に適用されていることがわかります。
stripは、マイクロストリップがメタルであり、このレイヤ上のマイクロストリップを取り囲むのが空気または誘電体になるようにレイヤを定義します。他の選択肢としては、スロットとビア
があります。これらについては、以下の章の練習で説明します。

OKをクリックしてダイアログをクローズします。7.
Momentum > Substrate > Save Asを選択します。ファイル名filterを使用して、Saveをクリックします。サブストレート・ファイルfilter.slmがプロジェクトの一部とし8.
て保存されます。
Momentum > Substrate > Precompute...を選択します。Precompute Substrate Functionsダイアログが表示されます。Minimum Frequencyを1 GHzに、9.
Maximum Frequencyを40 GHzに設定します。OKをクリックします。サブストレートを計算するかどうかを尋ねるダイアログ・ボックスが表示されたら、Yesをクリ
ックします。

計算が実行されない場合もあります。これについては前の例で説明しました。計算が実行される場合は、計算のステータスと終了を示すウィンドウがオー
プンします。

Momentum > Substrate > Summary...を選択することにより、実行済みのサブストレート計算のサマリをいつでも表示できます。

レイアウトへのポートの追加

Momentumでは、回路のポートをいくつかのタイプの1つとして定義できます。選択したタイプに応じて、ポートの特性は異なる方法で記述されます。
シミュレーションではポートの特性が考慮されるので、これによりシミュレーションの結果が変化する場合があります。さまざまなポート・タイプの中か
ら、レイアウトの目的に最も適したポート・タイプを選択できます。

各ポート・タイプの詳細については、ポートを参照してください。

ポートの定義は2段階で行われます。まず、回路のドローイング時に回路にポートを追加します。次に、回路に合わせてポートを調整するために
Momentumでポート・タイプを指定します。ポート・コンポーネントは回路のドローイング中にいつでも追加できますが、ポート・タイプを指定するには、
回路にサブストレートが定義されている必要があります。

このセクションでは、レイアウトにポートを追加する方法と、ポートに対してポート・タイプを指定する方法を説明します。

Layoutウィンドウでポート・アイコンをクリックします。Portダイアログ・ボックスが表示されます。必要な場合は、layer = condに設定します。ポートはマイクロス1.
トリップ・フィルタと同じレイアウト・レイヤ上に存在する必要があります。OKをクリックします。
レイアウトの左側にあるオープン・ポートの上にカーソルを移動して、クリックします。レイアウトの右側にあるオープン・ポートの上にカーソルを移動して、クリ2.
ックします。コマンドを終了します。レイアウトは下の図のようになります。
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Layoutウィンドウで、Momentum > Port Editorを選択します。Port Properties Editorダイアログ・ボックスがオープンします。3.
必要な場合は、2個のポートが見えるように、ダイアログ・ボックスをLayoutウィンドウの上から別の場所に移動します。コネクタP1をクリックします。4.
Port Propertiesダイアログ・ボックスが変化し、P1に適用するポート・タイプを選択できます。5.

Port Typeドロップダウン・リストでInternalを選択し、Applyをクリックします。6.
コネクタP2をクリックします。Port Typeドロップダウン・リストでInternalを選択します。OKをクリックしてポート・タイプを確定し、ダイアログ・ボックスをクローズ7.
します。

内部ポート・タイプを選択する理由は、回路の内部に適用できるからです。フィルタ上のこのポートの配置は通常なら内部とは見なされ
ませんが、この例ではフィルタがボックスに囲まれているので内部と見なされます。各ポート・タイプの詳細については、ポートを参照し
てください。

フィルタの周囲のボックスの完成

ボックスおよび導波管筐体は、デザインに垂直方向の境界を導入する役割を果たします。ボックスを追加することにより、ボックス共振を観察できま
す。ボックス共振は、共振周波数近傍の狭い帯域で、Sパラメータに大きな影響を与えることがあります。ボックスと導波管、およびそれらの使用法
の詳細については、ボックスと導波管を参照してください。

サブストレートを定義したときに、フィルタを取り囲むメタル・ボックスのトップとボトムとしてグランド・プレーンを定義したことを思い出してください。こ
のセクションでは、ボックスの側面の寸法と位置を指定する方法を説明します。

Layoutウィンドウで、Momentum > Box & Waveguide > Add Boxを選択します。1.
ボックスの左端と右端のx、y座標を入力します。Insert > Coordinate Entryを選択します。Coordinate Entryダイアログ・ボックスのX、Yフィールドに-4.5、-4.5と2.
入力し、Applyをクリックします。
Coordinate Entryダイアログ・ボックスのX、Yフィールドに+4.5、+4.5と入力し、Applyをクリックします。下の図のようにボックスが表示されます（ボックスを見る3.
にはView Allをクリックする必要がある場合もあります）。Cancelをクリックしてダイアログ・ボックスをクローズします。
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メッシュの生成

このセクションでは、追加のメッシュ・パラメータを指定する方法を説明します。

Layoutウィンドウで、Momentum > Mesh > Setup...を選択します。1.
以下のオプションと値を設定します。2.

Mesh Frequency = 40.0 GHz。メッシュ周波数はシミュレーションの最高周波数に設定します。
Mesh Density- cells/wavelength = 20。これはメッシュの密度を決定するために用いられます。メッシュは小さいセルから構成される必要がありますが、回路全体にわたってメッシュの
密度が高すぎると、結果の精度はそれほど向上せず、シミュレーション時間が長くなるだけです。
Edge Meshがオン、Edge Width = 0.05 mm。エッジ・メッシュを使用すると、オブジェクトのエッジ部分に相対的に高密度のメッシュが用いられます。電流の大部分はオブジェクトのエッジ
に沿って流れるので、エッジ上だけに高密度のメッシュを使用することにより、シミュレーションの速度と精度を改善できる場合があります。
その他の設定は表示されているままにしておきます。

選択が終わったら、OKをクリックします。3.
Momentum > Mesh > Precompute...を選択します。4.
Precompute Meshダイアログにメッシュ周波数が40 GHzであることが示されたら、OKをクリックして確定します。メッシュが計算され、下の図のようにレイアウ5.
ト上に表示されます。メッシュがうまく見えない場合は、Options > Layersを選択して、condレイヤのカラーとパターンの値を設定し直します。

LayoutウィンドウとSchematicウィンドウの両方でFile > Save Designを選択して、作業を保存します。ファイル名は両方ともfilterとします。Advanced Design6.
Systemはレイアウトとスケマティックを区別し、一方が他方によって上書きされることはありません。

シミュレーションの実行

このセクションでは、シミュレーションをセットアップして実行する方法を説明します。この練習では、適応掃引タイプをシミュレーション・プロセスで使
用します。この掃引タイプを選択する理由は、高速かつ非常に正確な方法で、シミュレートされたデータ・ポイントが有理フィッティング・モデルと比較
されるからです。リニア掃引タイプではシミュレートされるデータ・ポイントがステップ・サイズに基づいてリニアに選択されるのに対して、適応掃引タイ
プのデータ・ポイントは最も変動が大きい部分に基づいて選択されます。Sパラメータが有理フィッティング・モデルから最も変化するところで、より多く
のサンプルが収集されます。

Layoutウィンドウで、Momentum > Simulation > S-parametersを選択します。1.
Sweep TypeをAdaptiveに設定し、これらのパラメータを下記の値に設定します。2.

Start = 1 GHz
Stop = 40 GHz
Sample Points Limit = 50

Add to Frequency Plan Listをクリックします。3.
Open data display when simulation completesがオンになっていることを確認します。シミュレーションの終了時にSパラメータが自動的にプロットされて表示さ4.
れます。
Simulateをクリックします。シミュレーションが実行され、シミュレーションの進捗度と終了がステータス・ウィンドウに表示されます。5.
Momentum > Simulation > Summary...をクリックすると、保存されたシミュレーションの詳細が表示されます。レポートは印刷することもできます。6.
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シミュレーション結果の表示

Sパラメータ・シミュレーション結果が、Data Displayウィンドウに直交座標プロットとスミス・チャートで自動的に表示されます。S12の直交座標プロット
の例を下に示します。

レイアウトでのコプレナ・ラインのドローイング

レイアウトでコプレナ・ラインを作成するには、以下の2つの基本的な方法があります。

ドローイングするオブジェクトは、グランド・プレーン上のスロットです。サブストレート定義では、スロットがドローイングされているレイアウト・レイヤはスロット・
メタライゼーション・レイヤにマッピングされます。この方法では、コプレナ面上に無限のグランドが得られます。例としては、下に示すコプレナ・ライン・ベンド

があります。 

ドローイングするオブジェクトはメタルを表します。例えば、間にギャップのあるストリップとグランドメタルをドローイングできます。このレイヤは、ストリップとし
て定義されたメタライゼーション・レイヤにマッピングされます。この方法では、コプレナ面上に有限のグランドが得られます。この方法は通常、最初にスケマ

ティック・エレメントとして結合マイクロストリップ・ラインを作成するときに用います。 

グランド・プレーンにスロットを作成する方法の方が、作成されるメッシュのエッジや未知数の数がストリップに比べて少なくなるため、好ましい方法で
す。ストリップのあるコプレナ・ラインのデザインを作成した場合は、境界ボックスを指定すれば、論理演算によりスロット・パターンに変換できます。

コプレナ・ライン・ベンドのデザイン

この練習では、前の練習と同様、Momentumでのデザインに必要なすべてのステップを説明します。すなわち、レイアウトの作成、サブストレートの定
義、回路へのポートの追加、メッシュの定義、シミュレーションの実行、結果の表示です。前の練習と異なり、この練習では以下のデザイン・トピックス
を扱います。

複数のレイヤ上にドローイングされるレイアウトの作成
ビアを使用したレイヤ間の接続
新しいポート・タイプの指定
新しいメッシュ・パラメータの指定
この練習でドローイングする回路は、コプレナ・ライン・ベンドです。一般的なコプレナ・ラインは、下図に示すように、誘電体または空気で満たされたスロットを
メタルで囲んだものです。
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.

レイアウトの作成

この例では、Layoutウィンドウだけで回路を作成し、スケマティック表現を使用しません。作業は定期的に保存してください。
レイアウトは以下の要素から構成されます。

コプレナ・ライン・スロット
2個のスロットをつなぐブリッジ
ブリッジとスロットを垂直に接続するビア
スロット、ブリッジ、ビアはそれぞれ異なるレイヤ上にドローイングされます。このことは、これらのレイヤをサブストレートにマッピングする際に重要になりま
す。回路の図を左側に、レイアウトを右側に示します。

Schematicウィンドウの代わりにLayoutウィンドウがオープンするように、プリファレンスを設定します。Mainウィンドウで、Tools > Preferencesを選択し、Create1.
Initial Layout Windowをオンにします。Create Initial Schematic Windowをオフにします。
Mainウィンドウで、File > New Projectを選択します。2.
Nameフィールドにcpw_bendと入力します。3.
Project Technology Filesセクションで、ADS Standard: length unit - millimeterを選択します。 .4.
OKをクリックします。5.
Layoutウィンドウで、Options > Preferencesを選択します。Layout Unitsタブまでスクロールします。レイアウト単位をum、分解能を0.001に設定します。OKをク6.
リックします。
新規プロジェクトを作成したときに選択した長さ単位と、今設定した単位とは異なっています。現在作業中のLayoutウィンドウの単位は、プロジェクトを作成し7.
たときに選択した単位になります。Options > Preferencesで選択した単位は、Layoutウィンドウでドローイングされるオブジェクトの単位になります。
コプレナ・ライン・ベンドのスロット、ブリッジ、ビアのドローイングに使用するレイアウト・レイヤの名前を変更します。意味のある名前を使用すると、回路の各8.
部分がどのレイヤにドローイングされているかがわかりやすくなります。Options > Layersを選択します。Advancedタブを選択します。Layersリストで、condを
選択します。NameフィールドとLayer Bindingフィールドの両方にslotと入力します。Apply（Layersリストのすぐ下）をクリックします。cond2を選択します。Nameフ
ィールドとLayer Bindingフィールドの両方にbridgeと入力します。Applyをクリックします。holeを選択します。Nameフィールドだけにviaと入力し、Applyをクリック
します。OKをクリックしてダイアログ・ボックスをクローズします。
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コプレナ・ライン・スロットのドローイング

このセクションでは、コプレナ・ライン・スロットをドローイングする方法を説明します。

slotが現在のレイヤであることを確認します。スロットはこのレイヤにドローイングされます。現在のレイヤの名前は、ツールバーとLayoutウィンドウのトップに1.
表示されます。slotが表示されていない場合は、リストから選択します。

Insert > Rectangleを選択し、Insert > Coordinate Entryを選択します。ツールバーの矢印がアクティブになり、Coordinate Entryダイアログ・ボックスがオープン2.
します。
4つの長方形を定義して、2個のコプレナ・ライン・ベンドを作成します。X、Y座標ウィンドウに以下の値を設定し、入力のたびにApplyをクリックします。3.

X、Y座標 定義

0, 0 1つめの長方形の1つめのコーナ

+45, +290 1つめの長方形の2つめのコーナ

0, +335 2つめの長方形の1つめのコーナ

+335, +290 2つめの長方形の2つめのコーナ

+110, 0 3つめの長方形の1つめのコーナ

+155, +180 3つめの長方形の2つめのコーナ

+110, +180 4つめの長方形の1つめのコーナ

+335, +225 4つめの長方形の2つめのコーナ

終わったらOKをクリックして、ダイアログ・ボックスをクローズします。4.
View > View Allを選択してドローイングを表示します。5.
コマンドを終了します。Layoutウィンドウのドローイングは下の図のようになります。6.
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ブリッジのドローイング

コプレナ・ラインを構成するスロットがレイヤslot上にドローイングされました。次に、2個のスロットをつなぐブリッジを別のレイヤ上にドローイングしま
す。このことが重要な理由は、Momentumではスロットとブリッジが異なる方法で処理されるからです。これは、この練習の後の方で回路にサブストレ
ートを適用するときに明確になります。

ツールバーのレイヤ・リストで、レイヤbridgeを選択し、OKをクリックします。1.

注記
slotレイヤは引き続き表示されています。ここでは行いませんが、このレイヤを非表示にするには、Layoutウィンド
ウでOptions > Layersを選択し、slotレイヤを選択し、Visを選択解除してVisibleをオフにします。同じ操作を行うの
に、LayersウィンドウでslotレイヤのVisを選択解除する方法もあります。

Insert > Rectangleを選択し、Insert > Coordinate Entryを選択します。2.
Coordinate Entryダイアログ・ボックスを使用して、ブリッジを構成する2個の長方形を定義します。X、Y座標ウィンドウに以下の値を設定し、入力のたびに3.
Applyをクリックします。

X、Y座標 定義

0, +170 1つめのブリッジの1つめのコーナ

+155, +180 1つめのブリッジの2つめのコーナ

+155, +180 2つめのブリッジの1つめのコーナ

+165, +335 2つめのブリッジの2つめのコーナ

終わったらOKをクリックして、ダイアログ・ボックスをクローズします。4.
現在のコマンドを終了します。Layoutウィンドウのドローイングは下の図のようになります。5.

ビアのドローイング

ビアは3つめのレイヤ上にドローイングされます。このことは、この練習の後の方でビアをサブストレートにマッピングするために必要です。

ビアの位置とサイズは非常に重要です。ここでは、レイアウトのさまざまなスナップ・モードを使用してビアをドローイングします。ビアのドローイング
方法やその他のドローイングのヒントについては、ドローイングのヒントを参照してください。

ツールバーのレイアウト・レイヤ・リストで、viaを選択します。1.
Options > Preferencesを選択します。Grid/Snapタブを選択します。Active Snap Modesの下で、Vertexをオンにし、Gridを選択解除します。OKをクリックしま2.
す。
頂点スナップ・モードを使用することにより、ドローイングするビアはグリッド・ポイントでなく近くのオブジェクト（ブリッジ）の頂点にスナップします。これにより、
ビアが長方形のエッジ上に正確に配置されることが保証されます。
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Insert > Polylineを選択します。下のドローイングに示された点を参照しながら、以下の手順でライン・セグメントを作成します。3.
A1で1回クリックし、A2で2回クリックします。
B1で1回クリックし、B2で2回クリックします。
C1で1回クリックし、C2で2回クリックし、C3で3回クリックします。その後、ツールバーの矢印をクリックします。コマンドを終了します。Layoutウィンドウのドローイングは下の図のように
なります。

サブストレートのオープン

この練習では、Momentumに付属するサブストレートを使用します。サブストレートを変更する必要はありませんが、レイアウト・レイヤがどのようにサ
ブストレートにマッピングされるかを理解するために、内容を確認します。

Layoutウィンドウで、Momentum > Substrate > Openを選択します。Open a supplied substrate?という質問に対してYesを選択します。1.
サブストレート・ファイルcpw_bend_example.slmを探して選択し、Openをクリックします。サブストレートがオープンされたことが通知されます。OKをクリックしま2.
す。
Momentum > Substrate > Create/Modifyを選択します。Metallization Layersタブを選択します。3.

メタライゼーション・レイヤは、ビアの場合を除いて、破線で示されます。ここで使用するメタライゼーション・レイヤでは、レイヤのタイプ（Strip、Via、Slotのどれ
か）と、このレイヤにマッピングされているレイアウト・レイヤの名前（bridge、via、slot）が表示されます。メタライゼーション／レイアウト・レイヤがFree_Space、
air、GaAsレイヤの間にどのようにマッピングされているかを見ることができます。

ブリッジとスロットの間には、薄い空気のレイヤがあります。
ビアは、空気サブストレート・レイヤにダイレクトにマッピングされています。ビアは線としてドローイングされていますが、Momentumによって引き伸ばされ、この空気のレイヤを垂直に
貫通して、スロットとブリッジのエッジ同士を接続します。
ここでは、メタライゼーション・レイヤの3つのタイプ（strip、slot、via）のすべてが使用されています。stripは、ブリッジがメタルであり、このレイヤ上のマイクロストリップを取り囲むのが
空気であるようにレイヤを定義します。slotはストリップの反対です。レイアウト・レイヤはグランド・プレーンとして扱われ、ドローイングしたベンドはグランド・プレーン中の開いた領域と
して扱われます。Viaは、他のレイヤを垂直に貫通する垂直のセクションを表現します。

ポートの追加

このセクションでは、レイアウトにポートを追加する方法と、ポートに対してコプレナ・ポート・タイプを適用する方法を説明します。

コプレナは、Momentumで使用できるポート・タイプの1つです。これは、コプレナ・ライン回路で、2個のポート間に電界が発生する可能性がある場合
に使用するものです。2個のポートは、極性が反対で絶対値が等しい電界で励振されます。電流は大きさが等しく、向きが逆になります。詳細につい
ては、ポートを参照してください。

ポートはコプレナ・ライン・スロットに追加されるので、スロットと同じレイヤ上にドローイングする必要があります。Layout Layersリスト・ボックスで、slotを選択1.
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します。
また、ポートは各スロット・エッジの中央に配置する必要があります。ポートの配置を容易にするために、以下のスナップ・モードを設定します。2.

Options > Midpoint Snapをオンにします。
Options > Edge Snapをオンにします。
Snap Enabled以外の他のすべてのスナップ・モードをオフにします。

Portアイコンをクリックします。Portダイアログ・ボックスが表示されます。3.
layer=slotがSelect Parameterフィールドに表示されていることを確認します。表示されていない場合は、layerをslotに設定します。Num=1であることを確認しま4.
す。異なる場合は、Numを選択して1に設定します。OKをクリックします。
ポートのゴースト・イメージを確認します。イメージが大きすぎる場合、または見えない場合は、コマンドをキャンセルします。システムのデフォルト値によって5.
は、ポートとラベルをこのレイアウトに適したサイズに設定するために、Port/Ground Size（Options > Preferences > Placement）とFont Definition Size（
Options > Preferences > Component Text）の値の変更が必要な場合があります。
ポートを追加する準備ができたら、下図に示す順序と向きでポートを適用し、ポート・コマンドを終了します。6.

Layoutウィンドウで、Momentum > Port Editorを選択します。Port Properties Editorダイアログ・ボックスが表示されます。レイアウト上のポートにアクセスでき7.
るように、必要ならダイアログ・ボックスをドラッグしてレイアウトの外に移動します。
Layoutウィンドウで、P1をクリックします。Port Editorで、Port TypeリストからCoplanarを選択します。PolarityをNormalに設定します。他の値は変更しません。8.
Applyをクリックします。
P2をクリックします。Coplanarを選択し、PolarityをReversedに設定します。フィールドAssociate with port numberに1と入力します。Applyをクリックします。9.
P3をクリックします。Coplanarを選択し、PolarityをNormalに設定します。Applyをクリックします。10.
P4をクリックします。Coplanarを選択し、PolarityをReverseに設定します。フィールドAssociate with port numberに3と入力します。Applyをクリックします。11.
OKをクリックします。12.

メッシュの生成

このセクションでは、追加のメッシュ・パラメータを使用する方法を説明します。この回路は複数のレイヤ上にあるため、各レイヤに対してメッシュ・パ
ラメータを設定できます。これにより、特定のレイヤに比較的高密度のメッシュを設定できます。この例では、ブリッジ・レイヤにはエッジ・メッシュを使
用しません。

Layoutウィンドウで、Momentum > Mesh > Setupを選択します。Setup Mesh Controlsダイアログ・ボックスがオープンします。1.
以下のグローバル・パラメータを設定します。2.

Mesh Frequency = 40 GHz
Number of Cells per Wavelength = 30
Enable Edge Mesh
グローバル・パラメータは、Layerタブで他の値を指定しない限り、すべてのレイヤに適用されます。

Layerタブを選択します。3.
Layout Layersリストで、bridgeを選択します。Number of Cells per Wavelengthを30に設定し、Edge Meshをオフにします。これらのメッシュ・パラメータは、4.
bridgeレイヤ上にドローイングされたオブジェクトだけに適用されます。
OKをクリックします。5.
Momentum > Mesh > Precompute...を選択します。OKをクリックすると計算が始まります。メッシュが計算され、下の図のようにレイアウト上に表示されます。6.
ズーム・インしてメッシュを観察します。
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ポートにズーム・インします。各ポートに矢印が追加されていることがわかります。新しい矢印は、スロット上の電圧の向きを示しています。7.

シミュレーションの実行

Layoutウィンドウで、Momentum > Simulation > S-parameters...を選択します。1.
Sweep TypeリストでAdaptiveを選択し、以下のパラメータを設定します。2.

Start = 1 GHz
Stop = 40 GHz
Sample Points Limit = 50

Add to Frequency Plan Listをクリックします。3.
Open data display when simulation completesがオンになっていることを確認します。4.
Simulateをクリックします。5.

シミュレーション結果の表示

下の図は、自動的にプロットされるシミュレーション結果の一部を示しています。

作業を保存するには、プロジェクトを閉じる際に作業を保存するかどうかを尋ねられたときに、Yes to Allを選択します。

これで3つめの練習は終わりです。

パラメータ化レイアウト・コンポーネントの例

このセクションでは、ユーザがレイアウト・パラメータを定義する方法を説明します。以下の手順を紹介します。

レイアウト・コンポーネントの使用モデルでの公称/摂動定義の使用
グラフィカル・セル・コンパイラの使用
既存のADSコンポーネント定義を使用した新しいレイアウト・コンポーネントの作成

平行板キャパシタの定義

この例では、公称/摂動レイアウト・パラメータ定義の使用モデルの使用法を説明します。垂直方向と水平方向のキャパシタのオーバラップ領域のサ
イズと、フィードラインの幅を、レイアウト・パラメータとして定義します。

出発点となるレイアウトは、lとwの定義を持つキャパシタの例に示されています。
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lとwの定義を持つキャパシタの例

最初に、公称/摂動の使用モデルを使用して、パラメータlをキャパシタのオーバラップ領域のサイズとしてセットアップします。このパラメータは、水平
方向と垂直方向のオーバラップ領域のサイズを示します。キャパシタ・エリアのサイズをすべての方向に同じ比率で設定するために、いくつかの頂
点摂動を定義する必要があります。以下の方針が使用できます。

可能な摂動指定の方針

頂点 デルタX（μm） デルタY（μm）

1 -5 5

2 5 5

3 5 0

4 5 0

5 5 -5

6 -5 -5

7 -5 0

8 -5 0

下の図は、"1"で示される頂点（キャパシタ・プレートの左上コーナを構成するレイアウト内の2つの頂点）の移動を示します。
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図11 - 選択した頂点の摂動

同様に、他の頂点も移動する必要があります（Edit/View Perturbationウィンドウはオープンしたままにできます）。

フィードラインの幅wも、公称/摂動の使用モデルで定義できます。

lとwの両方のパラメータをセットアップしたら、Momentum > Component > Create/Updateを使用してレイアウト・コンポーネントを作成できます。

下の図は、新たに作成したコンポーネントのいくつかの異なるインスタンスを示します。

キャパシタ・ストラクチャのインスタンス

エア・ブリッジの定義

この例は、グラフィカル・セル・コンパイラ・ツールを使用したレイアウト・パラメータの定義を示しています。ここではエア・ブリッジの例を使用します。
エア・ブリッジの長さlとフィードラインの幅wがレイアウト・パラメータとして定義されます。

出発点となるレイアウトは作図ラインがあるエア・ブリッジの例に示されていて、レイヤcond上の2個のフィードライン、レイヤcond2上のエア・ブリッ
ジ、エア・ブリッジとフィードラインを接続するレイヤres上の2つのビアから構成されます。このレイアウトの名前はAMC2MACROとします。
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作図ラインがあるエア・ブリッジの例

このレイアウトのパラメータ化に用いられる2本の作図ラインは、すでにレイアウト上にドローイングされています。

レイアウトのTools > Macroから利用できるグラフィカル・セル・コンパイラ・ツールを使用すると、エア・ブリッジのレイアウトを簡単にパラメータ化でき
ます。幅パラメータwidを定義するには、縦の作図ライン以外のレイアウトのすべてのオブジェクトを選択し、グラフィカル・セル・コンパイラの伸縮コマ
ンドを使用して、レイアウト・パラメータを定義します（Tools > Macro > Stretch）。長さパラメータlenも同様に、横の作図ライン以外のすべてのオブジ
ェクトを選択し、伸縮コマンドを使用することによって定義できます。伸縮操作を定義したら、Tools > Macro > Compileを使用してアートワークをコンパ
イルします。

これらのコマンドの詳細とコンパイルの方法については、Graphical Cell Compilerマニュアルを参照してください。

アートワーク・マクロがコンパイルされたら、それを使用して新しいレイアウト・コンポーネントを作成し、アートワーク・マクロで定義されたレイアウト・
パラメータを選択できます。このためには、まず新規レイアウト（例えばAMC2という名前の）を作成し、AMC2MACROを新規レイアウト・ウィンドウに配
置します。2個の新しいポート（p1とp2）を追加して、アートワーク・マクロのピンに接続する必要があります。

GCCマクロを使用したレイアウト・コンポーネントの作成

残りの作業は、レイアウト・コンポーネント・パラメータを定義し、これらをアートワーク・マクロのパラメータにマッピングすることです。このためには、
まず2つのサブ回路パラメータ（wとlなど）をLayout Component Parametersタブでセットアップします。
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サブ回路パラメータlとwの作成

2番目のステップでは、新しく定義したパラメータをアートワーク・マクロのパラメータlenとwidにマッピングします。このためには、レイアウト・アートワー
ク・コンポーネント（AMC2MACRO）をダブルクリックし、アートワーク・パラメータlenをlに、widをwに割り当てます。

サブ回路パラメータのマッピング

このステップが終了したら、Momentum > Component > Create/Update...を使用してレイアウト・コンポーネントを作成できます。

このコンポーネントは、他のレイアウト・コンポーネントと同様に使用できます。スケマティックで直接使用した場合は、EM/cktコ・シミュレーション機能
によりMomentumモデルがその場で作成されます。また、Advanced Model Composerツールの出発点としても使用できます。

スパイラル・インダクタ・コンポーネントの定義

この例では、MRINDELAおよびMLINレイアウト・アートワーク・コンポーネントをレイアウトで使用して、新しいレイアウト・コンポーネントを作成します。
最初に、下の図のように2個のコンポーネントを含むレイアウト（AMC3）を作成します。

スパイラル・コンポーネント

このレイアウトから作成したレイアウト・コンポーネントに対して、w（ラインの幅）とn（スパイラルのセグメント数）の2つのレイアウト・パラメータを定義
します。まず、これら2つのパラメータをMomentum > Component > Parametersダイアログでサブ回路パラメータとして定義します。
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スパイラルのサブ回路パラメータ

その後、これらのパラメータをMRINDELAおよびMLINコンポーネントの適切なパラメータに割り当てます（例: MRINDELAの場合）。

コンポーネントのパラメータの割り当て

以下のステップでは、Momentum > Component > Create/Updateを使用してレイアウト・コンポーネントを作成します。
下の図は、新たに作成したコンポーネントのいくつかの異なるインスタンスを示しています。これは、wを固定（10 um）してnの値を変えた（n=5、9、
13、17）ものです。
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スパイラル・コンポーネントのインスタンス

Momentumのサブストレート
サブストレート定義とは、回路が存在する媒体を記述したものです。例えば、多層回路基板のサブストレートは、メタル・トレース、絶縁体、グランド・
プレーン、トレース間を接続するビア、ボードの周りの空気などから構成されます。サブストレート定義では、サブストレートのレイヤ数、誘電率、各レ
イヤの高さなどの属性を指定できます。

サブストレート定義は、サブストレート・レイヤとメタライゼーション・レイヤから構成されます。サブストレート・レイヤは、誘電体、グランド・プレーン、カ
バー、空気などのレイヤ材料を定義します。メタライゼーション・レイヤは、サブストレート・レイヤ間にある伝導性のレイヤであり、レイアウト・レイヤと
組み合わせて用いられます。レイアウト・レイヤをメタライゼーション・レイヤにマッピングすることにより、回路がドローイングされているレイアウト・レ
イヤをサブストレート内に配置できます。サブストレートの例を以下に示します。これには4つのサブストレート・レイヤと、ビア付きの2つのマイクロスト
リップがあります。

サブストレート定義は、保存しておいて後で他の回路で使用することもできます。Advanced Design Systemにはさまざまな定義済みサブストレートが
付属していて、そのままで使用することも、デザイン仕様に合わせて変更することもできます。
サブストレートの定義には、以下のようなステップがあります。

サブストレート・レイヤの定義
レイアウト・レイヤからメタライゼーション・レイヤへのマッピング
メタライゼーション・レイヤの伝導率の指定
サブストレートの解の計算

既存のサブストレート定義を使う方法と、新しいサブストレート定義を作成する方法について、以下に説明します。

定義済みサブストレートの選択
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Momentumには定義済みのサブストレート定義が数多く付属しているので、サブストレートを全く新たに作成しなくても済む場合があります。サブスト
レート・ファイルの拡張子は.slmです。
定義済みサブストレートをオープンする手順:

Layoutウィンドウで、Momentum > Substrate > Open.を選択します。1.
付属のサブストレートをオープンする場合は、Yesをクリックします。付属のサブストレート・ファイルのリストが表示されます。2.
プロジェクトの一部として保存されているサブストレートをオープンする場合は、Noをクリックします。プロジェクトの一部として保存されているサブストレート・フ
ァイルのリストが表示されます。
サブストレート・ファイルを探す方法の詳細については、すでに名前の付いているファイルを保存するには、Momentum Substrate Saveを選択します。サブス
トレートの保存場所を参照してください。
サブストレート・ファイルを選択し、OKをクリックします。3.

サブストレートの作成／変更

このセクションでは、サブストレートの作成、変更、編集について説明します。メタライゼーション・レイヤの詳細については、メタライゼーション・レイヤ
の定義を参照してください。

サブストレート・レイヤの定義

サブストレートは、全く新たに作成することも、既存のものを編集することもできます。サブストレートには、最小限トップ・プレーンとボトム・プレーンが
必要です。

注記
レイアウト・コンポーネント・パレットに表示されるサブストレート・コンポーネントは使用できません。サブストレート定
義の作成と編集には、Momentum > Substrate > Create/Modifyで表示されるダイアログ・ボックスを使う必要があり
ます。

サブストレート・レイヤを定義する手順:

Momentum > Substrate > Create/Modifyを選択します。1.
新しい定義の場合は、Substrate Layersフィールドに3つのデフォルト・レイヤが表示されます。2.

Free_space（トップ・プレーン）
Alumina（誘電体）
GND（ボトム・プレーン）
これらのレイヤは、Momentumのサブストレート・レイヤの3つの基本タイプのサブストレート定義を表します。
Free_Spaceは、サブストレートのトップ・プレーンを表します。この定義では、開境界（open boundary）として定義されています。
Aluminaは、有限の厚さの誘電体レイヤを表します。この種のレイヤは、インタフェース・レイヤ（interface layers）とも呼ばれます。
GNDは、サブストレートのボトム・プレーンを表します。GNDは閉境界（closed boundary）を表します。

閉境界は、グランド・プレーンや、その他の閉境界（蓋、筐体容器の底など）を定義します。

既存のサブストレート定義の場合は、さまざまな名前を持つ多数のレイヤが表示されることがありますが、それらはすべてこの3つの基本タイプのどれかに属し、トップ・プレーンとボ
トム・プレーンが必ず存在します。サブストレートにはトップ・プレーンとボトム・プレーンが必要であり、これらのプレーンは開境界または閉境界として定義されます。

目的のレイヤを選択します。3.
サブストレートを作成するには、必要に応じてこれらのレイヤを編集、リネーム、追加する必要があります。これらの作業の詳細については、この後の各セク4.
ションで詳しく説明します。
サブストレートの定義が済んだら、OKをクリックしてダイアログ・ボックスをクローズします。5.

開境界の定義

開境界とは、空気など、無限の厚さのレイヤを表します。境界の比透磁率と比誘電率を編集することにより、他の気体または無限の厚さを持つ材料
を定義することもできます。
開境界を定義する手順:

Free_Spaceレイヤまたはその他の開境界レイヤを選択します。1.
BoundaryリストでOpenを選択します。2.
Permittivity (Er)リストボックスで、境界の比誘電率のフォーマットを選択します。比誘電率の各成分は以下のどれかの方法で入力できます。3.

実数と虚数
実数とロス・タンジェント
実数と伝導率（伝導率の単位はS/m）

比誘電率の実数部 は無次元の量であり、材料の比誘電率 に等しくなります。このパラメータの詳細については、誘電率を参照してください。

高周波電界のパワーを消費する誘電体を表すには、材料の誘電ロス・タンジェント をLoss Tangentフィールドに入力します。ロス・タンジェントが小さいほど、損失の少ない材
料を表します。このパラメータの詳細については、誘電ロス・タンジェントを参照してください。
比誘電率の各成分を、リストボックスの下のフィールドに入力します。

Permeability (MUr)リストボックスで、境界の比透磁率のフォーマットを選択します。比透磁率の各成分は以下のどれかの方法で入力できます。4.
実数と虚数
実数とロス・タンジェント

比透磁率の実数部 は無次元の量であり、材料の比透磁率に等しくなります。このパラメータの詳細については、比透磁率を参照してください。

高周波磁界のパワーを消費する誘電体を表すには、材料の磁気ロス・タンジェント をPermeability Loss Tangentフィールドに入力します。ロス・タンジェントが小さいほど、損
失の少ない材料を表します。このパラメータの詳細については、磁気ロス・タンジェントを参照してください。
比透磁率の各成分を、リストボックスの下のフィールドに入力します。
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Applyをクリックして、開境界の定義を確定します。5.

ヒント
開境界レイヤからグランド・プレーンを作成するには、レイヤを選択し、BoundaryリストでCloseを選択します。

インタフェース・レイヤの定義

インタフェース・レイヤは有限の厚さを持ち、比誘電率と比透磁率を使って特性を指定できます。レイヤの厚さは任意ですが、以下の点を考慮する必
要があります。

薄膜サブストレート（thinsubstrate）とは、厚さが1ミクロン未満のものであり、メッシングに関して特別な考慮が必要です。0.1ミクロンより薄いサブストレートは
避けるべきです。
厚膜サブストレート（thick substrate）の場合は、厚さは0.5波長未満にすべきです。厚膜サブストレートに関するこの推奨値は、代表的なデザイン値に基づい
ています。例えば、10 milのサブストレートでカバー高さ（空気）が300 milのものは、最高20 GHzの周波数（0.5波長にあたる）まで使用できます。
インタフェース・レイヤを編集する手順:

Aluminaまたは他のインタフェース・レイヤを選択します。1.
レイヤの厚さをThicknessフィールドに入力し、隣のリストボックスで単位を選択します。2.
Permittivity (Er)リストボックスで、境界の比誘電率のフォーマットを選択します。比誘電率の各成分は以下のどれかの方法で入力できます。3.

実数と虚数
実数とロス・タンジェント
実数と伝導率（伝導率の単位はS/m）

比誘電率の実数部 は無次元の量であり、材料の比誘電率 に等しくなります。このパラメータの詳細については、誘電率を参照してください。

高周波電界のパワーを消費する誘電体を表すには、材料の誘電ロス・タンジェント をLoss Tangentフィールドに入力します。ロス・タンジェントが小さいほど、損失の少ない材
料を表します。このパラメータの詳細については、誘電ロス・タンジェントを参照してください。
比誘電率の各成分を、リストボックスの下のフィールドに入力します。

Permeability (MUr)リストボックスで、境界の比透磁率のフォーマットを選択します。比透磁率の各成分は以下のどれかの方法で入力できます。4.
実数と虚数
実数とロス・タンジェント

比透磁率の実数部 は無次元の量です。このパラメータの詳細については、比透磁率を参照してください。

高周波磁界のパワーを消費する誘電体を表すには、材料の磁気ロス・タンジェント をPermeability Loss Tangentフィールドに入力します。ロス・タンジェントが小さいほど、損
失の少ない材料を表します。このパラメータの詳細については、磁気ロス・タンジェントを参照してください。
比透磁率の各成分を、リストボックスの下のフィールドに入力します。

Applyをクリックして、レイヤ定義を確定します。5.

閉境界レイヤの定義

閉境界とは、グランド・プレーンなどの面を表します。厚さが0のレイヤです。完全導体として定義することも、体積伝導率または面インピーダンスを指
定して損失のある導体と定義することもできます。
グランド・プレーンを編集する手順:

目的の///GND///レイヤを選択します。1.
BoundaryリストでClosedを選択します。2.
Planeリストボックスで、グランド・プレーンのフォーマットを選択します。グランド・プレーンは以下のパラメータを使って指定できます。3.

完全導体（Perfect conductor）
体積伝導率（S/m単位）
面インピーダンス（Ω/m2単位）
伝導率は実数で入力します。インピーダンスは実数部と虚数部からなる複素数として入力します。
グランド・プレーンのパラメータを、リストボックスの下のフィールドに入力します。

Applyをクリックして、閉境界の定義を確定します。4.

ヒント
グランド・プレーンから開境界レイヤを作成するには、グランド・プレーンを選択し、BoundaryリストでOpenを選択し
ます。

レイヤのリネーム

レイヤをリネームする手順:

Substrate Layersリストでサブストレートを選択します。1.
Substrate Layer Nameフィールドに名前が表示されます。名前を適当に変更します。2.
Applyをクリックします。3.

注記
グランド・プレーンは///GND///で表され、名前を変更することはできません。

レイヤの削除、追加、移動

サブストレート・レイヤを正しい順序に配置するために、レイヤの削除、追加、移動が可能です。
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サブストレート・レイヤを削除する手順:

Substrate Layersリストでサブストレート・レイヤを選択します。1.
Cutをクリックします。レイヤ定義が削除されます。2.
サブストレート・レイヤを追加する手順:
追加するレイヤと同じ基本属性（開境界、閉境界、有限厚さ）を持つサブストレート・レイヤを、Substrate Layersリストで選択します。3.
Addをクリックします。4.
新しいレイヤが強調表示されます。新しいレイヤをリネームするには、Substrate Layer Nameフィールドを編集します。5.
サブストレート・レイヤを移動する手順:
移動するサブストレート・レイヤをSubstrate Layersリストで選択します。6.
Cutをクリックします。7.
移動するサブストレートの下に配置したいサブストレート・レイヤを選択します。8.
Pasteをクリックします。9.

シリコン・サブストレート・レイヤの定義

シリコン材料の電気的挙動は、通常誘電率と抵抗率（または伝導率）を使って指定します。

誘電率については、 の値として11.8（11.9）が通常用いられます。

抵抗率（ ）の値は通常Ωcmで指定され、代表的な値は10です。

Momentumでは、伝導率（ ）をS/m（抵抗率の逆数）で指定できます。
詳細については、伝導率を参照してください。

抵抗率からの伝導率の計算

伝導率は単に抵抗率の逆数です。逆数を取る前に、抵抗率の値がΩmであることを確認してください。
例:

= 10 ohm cm1.

= 10 ohm cm = 0.1 ohm m2.

= 1/ρ = 10 S/m3.

伝導率の定義

シリコン・サブストレートの伝導率を定義する手順:

Momentum > Substrate > Create/Modifyを選択します。1.
Create/Modifyダイアログ・ボックスで、Permittivity (ER)の下のRE, Conductivityを選択します。2.
サブストレートの誘電率と伝導率（S/m）を指定します。3.
終了したら、OKをクリックしてダイアログ・ボックスをクローズします。4.

メタライゼーション・レイヤの定義

メタライゼーション・レイヤの働きは以下のとおりです。

サブストレート内でのレイアウト・レイヤの位置を定義する。
レイヤのどの部分が伝導性を持つかを指定する。
レイアウト・レイヤの伝導率を定義する。
レイアウト・レイヤのどの部分が伝導性を持つかを定義するために、レイヤを以下のように指定できます。
ストリップ-レイアウト・レイヤ上のオブジェクトは伝導性、それ以外のレイヤの部分は非伝導性です。

スロット-ストリップの逆で、スロット・レイアウト・レイヤ上にドローイングされたオブジェクトはメタルの逆イメージなので非伝導性であり、オブジェクトを囲むレ
イヤの他の部分は伝導性です。シミュレーション時に、Momentumはスロット内の電界分布（等価磁流）を考慮します。
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注記
スロット・メタライゼーションの伝導率は無視され、完全なメタライゼーションが仮定されます。

ビア-レイアウト・レイヤ上のオブジェクトは伝導性で、1つ以上のサブストレート・レイヤを垂直に貫通します。ビアのドローイングおよび適用方法の詳細につ
いては、Layoutウィンドウでのビアの適用と作成を参照してください。

ストリップとスロットを使用したサンプルとしては、以下のものがあります。

Double_Patchアンテナ・サンプルのパッチ。これらはtop_metという名前のレイアウト・レイヤ上にドローイングされており、伝導性です。このレイアウト・レイヤ
は、ストリップとして定義されたメタライゼーション・レイヤにマッピングされています。
Slot_dipoleアンテナ・サンプルのスロット。これらのスロットは、slotという名前のレイアウト・レイヤ上にドローイングされています。スロットは伝導性でなく、スロ
ットの周りの領域は伝導性です。このレイアウト・レイヤは、スロットとして定義されたメタライゼーション・レイヤにマッピングされています。

なお、レイアウトには実際の回路の一部でない多数のレイヤが存在します。 例えば、テキスト・レイヤやエラー報告レイヤなどです。Momentumのシ
ミュレーションにおいてはこれらは無視されます。回路の一部を含むレイアウト・レイヤがメタライゼーション・レイヤにマッピングされない場合は、これ
らも無視されます。
メタライゼーション・レイヤの定義には、以下のようなステップがあります。

レイアウト・レイヤからメタライゼーション・レイヤへのマッピング
レイヤの伝導率の定義
オーバラップ優先度の設定

これらの各ステップの詳細について、以下の各セクションで説明します。

Layoutウィンドウでのビアの適用と作成

Momentumは、ビアを作成する際に、ビアとしてマッピングされたオブジェクトを引き伸ばして、適用対象のサブストレート・レイヤを貫通させます。ビア
は、ラインまたは閉じた多角形としてドローイングされます。単純なライン・セグメント・ビアは、ビアをドローイングする最も単純で実用的な方法です。
ラインとして作成されたビアは、シート・ビアと呼ばれることがあります。 これは、ラインがサブストレートを貫通するときに、水平のメタル・シートとして
扱われるからです。他の形状のビアの場合は、閉じた多角形をドローイングしてください。例えば、円筒ビアの場合は円をドローイングします。
Momentumで形状がビア・メタライゼーション・レイヤにマッピングされるときに、オブジェクトは3次元となり、サブストレートを貫通します。これによって
ラインはシートとなり、円は円筒となります。

どの方法でビアをドローイングした場合でも、接続先のオブジェクトの端からビアがはみ出さないようにしてください。ビアはオブジェクトのエッジに接
するか、内部になければなりません。オブジェクト境界の外側にあるビアの部分は、シミュレーションで考慮されません。下の図は、2つのストリップを
接続する各種のビアを示します。
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ビアは以下のように扱われます。

ビアは無限に薄い垂直のメタル・シートとして扱われます。円筒をドローイングしてビアを作成した場合は、円筒の側壁を構成する別のメタル・シートの組とし
て扱われます。
ビアはオープンであると見なされ、シート上を流れる電流で覆われているとは見なされません。覆われた形でビアをドローイングするには、ビアの先端と同じ
サイズのキャップ（カバー）を使います。 これはメタル・ストリップ・レイアウト・レイヤによる終端です。
2つのビアが同じサブストレート・レイヤを貫通し、異なるレイアウト・レイヤにある場合は、これらは一致させることはできません。これに対して、同じレイアウト
・レイヤ上の2つのビアは一致させることができます。
ビアは、接続先のプリミティブの内部に完全に含まれなければなりません。
ビアの損失を指定することはできますが、厚さは0として扱われます。

複数のサブストレート・レイヤを貫通するビア

ビアを複数レイヤに適用して、1つ以上のレイヤを貫通させることができます。
複数のサブストレート・レイヤを貫通するビアをドローイングする場合は、各ビアは1つのレイアウト・レイヤ上に1回だけドローイングします。このレイ
アウト・レイヤを、ビアが貫通する各サブストレート・レイヤに（Metallizationタブを使って）Viaとしてマッピングすることにより、ビア・レイヤをすべての
サブストレート・レイヤに割り当てる必要があります。

レイアウト・レイヤのマッピング

回路の一部である任意の形状またはコンポーネントを含むレイアウト・レイヤは、メタライゼーション・レイヤにマッピングする必要があります。メタライ
ゼーション・レイヤにマッピングされないレイアウト・レイヤは、シミュレーションで考慮されません。

レイアウト・レイヤをマッピングする手順:

Momentum > Substrate > Create/Modifyを選択します。1.
Metallization Layersタブをクリックします。2.
Layout Layersリスト・ボックスでレイヤを選択します。なお、defaultレイアウト・レイヤはメタライゼーション・レイヤにマッピングできません。 マッピングできる最3.
初のレイヤはcondです。
レイヤをスロットまたはストリップにマッピングするには、Substrate Layersリストから破線を選択してスロットまたはストリップを2つのサブストレート・レイヤの4.
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間に配置した後、StripまたはSlotをクリックします。
間違った場合は、Unmapをクリックしてから、正しい方をクリックします。

Stripは、レイアウト・レイヤ上のオブジェクトを伝導性として、オブジェクトの周りの領域を非伝導性として定義します。
Slotはストリップの逆で、レイアウト・レイヤ上のオブジェクトを非伝導性として、オブジェクトの周りの領域を伝導性として定義します。シミュレーション時に、Momentumはスロット内の電
界分布（等価磁流）を考慮します。

注記
スロット・メタライゼーションの伝導率は無視され、完全なメタライゼーションが仮定されます。

レイヤをビアとしてマッピングするには、ビアが貫通するサブストレート・レイヤを選択し、Viaをクリックします。5.
ビアを2層以上のレイヤに貫通させたい場合は、次のレイヤを選択してから、もう一度Viaをクリックします。

Viaは、レイアウト・レイヤ上のオブジェクトを伝導性として定義します。 このオブジェクトは、1つ以上のサブストレート・レイヤを垂直に貫通します。

このレイヤの伝導率特性を定義するには、伝導率の定義を参照してください。6.
レイヤが重なっているか、その可能性がある場合は、オーバラップ優先度を指定する必要があります。オーバラップ優先度の設定を参照してください。7.
Applyボタンをクリックします。8.

レイヤのマッピング解除

レイヤの場所を変更したり、サブストレート定義からレイヤを削除したりするには、Unmapを使います。
レイヤのマッピングを解除する手順:

Momentum > Substrate > Create/Modifyを選択します。1.
Metallization Layersタブをクリックします。2.
Substrate Layersリストで、レイアウト・レイヤがマッピングされているサブストレート・レイヤまたはインタフェースを選択します。3.
Unmapをクリックします。この位置に割り当てられているレイアウト・レイヤがすべて削除されます。4.
レイヤを再マッピングする手順については、レイアウト・レイヤのマッピングを参照してください。5.

ビアのシミュレーション・モデル

ADS 2006AのMomentumでは、ビア・オブジェクトに使用できるシミュレーション・モデルが3種類あります。

2次元分布定数モデル
集中定数モデル
3次元分布定数モデル
この中で、集中定数モデルと3次元分布定数モデルは、ADS 2006Aで新たに使用可能になったものです。集中定数モデルは、コンタクト・ビア（主な目的が電
気的または機械的な接触）を効率的にシミュレートするために用いられます。3次元分布定数モデルは、ビア電流（水平ビア電流を含む）のすべての成分の3
次元モデリングが可能で、信号ビアの電気的挙動をより正確にシミュレートするために使用できます。

2次元分布定数モデル

デフォルトのビア・モデル（以前のリリースでも使用可能）です。
表面を長方形のセルでメッシングすることにより、ビア・オブジェクトの分布定数モデルが作成されます。
ビア電流の垂直成分だけが、垂直方向のRooftop関数を使ってモデリングされます。このため、モデリングされた垂直成分の電流分布は、断面と垂直方向（2
次元電流分布）の両方で変化します。
各ビア・オブジェクトは、長方形セル1個あたり2個の未知電流を行列方程式に追加します。
ビアの抵抗と表皮効果は、シート表面インピーダンスの式を使って考慮されます。
ビアの自己／相互インダクタンス（垂直電流のみ）およびキャパシタンスがシミュレーションで考慮されます。

集中定数モデル

ビア・オブジェクトはストラクチャから抽出され、集中定数モデルに置き換えられます。
分布定数ビア・ネットワーク・トポロジーのすべての分岐が除去され、ビア・オブジェクトの中央の下と上のセルをつなぐ1つの集中定数分岐に置き換えられま
す。
各ビア・オブジェクトは、行列方程式に1つの未知数だけを追加します。これは集中定数ビア電流で、一定振幅の垂直成分だけを持ちます。
ビアのシミュレーションには、集中定数の直列R、Lインピーダンスが電気モデルとして用いられます。
ビアの抵抗RとインダクタンスLは、形状と材料パラメータから自動的に計算されます。
相互インダクタンスは考慮されません。
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自己キャパシタンスと相互キャパシタンスは考慮されません。
ビア・セルは行列方程式のロード・プロセスには影響しません。

ビアの内部インピーダンス（抵抗と内部インダクタンス）は、ビア上の一様な垂直電流分布に対して表面インピーダンスの考え方を適用することで得られま
す。すなわち、以下のようになります。

伝導率によって指定されるビア・マスク・レイヤの場合は、表面インピーダンスZsは片側表皮効果の式によって計算されます。これにより、周波数依存の表皮
効果（周波数の上昇とともに抵抗が増加し、内部インダクタンスが減少）が、集中定数ビア・モデルで考慮されます。インピーダンスで指定されるビア・マスク・
レイヤの場合は、周波数依存の表皮効果は考慮されません。

3次元分布定数モデル

表面を長方形のセルでメッシングすることにより、ビア・オブジェクトの分布定数モデルが作成されます。
ビア電流の水平成分と垂直成分の両方が、水平方向と垂直方向のRooftop関数を使ってモデリングされます。これにより、ビア・オブジェクトの3次元電流モ
デルが得られます。
各ビア・オブジェクトは、長方形セル1個あたり4個の未知電流を行列方程式に追加します。
ビアの抵抗と表皮効果は、表面インピーダンスの式を使って考慮されます。
ビアのすべての自己／相互インダクタンスおよびキャパシタンスがシミュレーションで考慮されます。

Momentumのレイヤ・マッピングGUI

Momentumのレイヤ・マッピング・ダイアログが、新しいビア・モデルに対応して拡張されています。以下の変更が加えられています。

マッピングされていないレイヤのレイヤ・プロパティを定義するためには、先にレイヤをマッピングする必要があります。このため、マッピングされていないレイ
ヤのレイヤ・プロパティはすべて非表示になります。
VIAにマッピングされたレイヤの場合は、ユーザは3つのシミュレーション・モデル（Lumped、2D Distributed、3D Distributed）から1つを選択できます。
2D Distributed modelは、2006Aより前のすべてのサブストレート定義に用いられているデフォルトのビア・モデルです。
STRIPにマッピングされたレイヤの場合は、既存の以下の3つの形状モデルから1つを選択できます。
Sheet (No Expansion)
Thick (Expansion Up)
Thick (Expansion Down)
SLOTにマッピングされたレイヤの場合は、Modelコンボ・ボックスには"Ground Plane (Holes)"の1つのオプションしかありません。
選択したレイヤ・プロパティの詳細情報は、ダイアログの埋め込み情報に記載されています。
Thicknessフィールドは、STRIPにマッピングされたレイヤだけに表示されます。
Overlap Precedenceフィールドは、STRIPにマッピングされたレイヤだけに表示されます。

マッピングされていないレイヤ
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STRIPにマッピングされたレイヤ

SLOTにマッピングされたレイヤ
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VIAにマッピングされたレイヤ

ビア・モデルの選択

材料の選択
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新しいビア・シミュレーション・モデルの例

2つの結合RFボード・ビア

ビア形状

高さ = 20 μm
半径 = 9.744 μm
伝導率 = 5.0e7 S/m

DC抵抗 = 0.00141423 Ω

集中定数モデル（赤）
   未知数1個／ビア
   全行列サイズ = 348
   ユーザ時間（周波数ポイント11個） = 1分25秒
   メモリ = 5.09 MB

2次元分布定数（青）
   未知数24個／ビア
   全行列サイズ = 394
   ユーザ時間（周波数ポイント11個） = 1分35秒
   メモリ = 6.69 MB

3次元分布定数（紫）
   未知数32個／ビア
   全行列サイズ = 410
   ユーザ時間（周波数ポイント11個） = 1分36秒
   メモリ = 7.26 MB

シリコン・スパイラル・インダクタ
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集中定数モデル（赤）
   未知数1個／ビア
   ビア45個、ビア未知数合計45個
   全行列サイズ = 880
   ユーザ時間（周波数ポイント5個） = 59秒
   メモリ = 31.08 MB

2次元分布定数（青）
   未知数8個／ビア
   ビア45個、ビア未知数合計360個
   全行列サイズ = 1195
   ユーザ時間（周波数ポイント5個） = 1分14秒
   メモリ = 54.72 MB

伝導率の定義

レイアウト・レイヤは、導体または抵抗体として定義できます。レイアウト・レイヤをストリップまたはビアとして定義する場合は、ストリップまたはビア
の伝導率を定義します。しかし、レイアウト・レイヤをスロットとして定義する場合は、スロットの周囲にあるメタルの伝導率を定義することはできませ
ん。これは、スロットが完全導体で囲まれていると仮定されるからです。

伝導率を定義する手順:

Momentum > Substrate > Create/Modifyを選択します。1.
Metallization Layersタブを選択します。2.
Layout Mappingリストで、マッピングされているレイアウト・レイヤを選択します。3.
Layout LayersセクションのTypeリストから導体のタイプを選択します。Sheet Conductor（シート導体）、Thick Conductor (up)（厚膜導体（上））、Thick4.
Conductor (down)（厚膜導体（下））のいずれかを選択します。
Thicknessで厚さを設定します。5.
Conductivityリストで、伝導率の定義を以下のうちから選択します。6.

Perfect conductor
Sigma (Re, Im)
Impedance (Re, Im)
Perfect Conductorを選択すると、ストリップ、ビア、またはスロットの周囲のメタルが損失のない完全導体になります。これ以外の定義は不要です。
Sigma (Re, Im, thickness)を選択すると、バルク伝導率を複素数値で指定できます。Conductivityリストの下の各フィールドに、バルク伝導率の実数部と虚数部を、S/mまたはS/cm単
位で入力します。虚数値は超伝導アプリケーションで重要です。Thicknessフィールドにメタルの厚さを入力し、単位を選択します。等価表面インピーダンスを求める際に、これらの値を
使ってDCおよび高周波の損失メカニズムが計算されます。例えば、金の体積伝導率は41,000,410 S/mであり、任意の厚さを指定できます。伝導率と厚さを指定する場合に用いられ
る等価DC面インピーダンスは以下のようになります。

ここで、Ïƒ rは伝導率の実数部（S/m）、tは導体の厚さ（m）です。
高周波では、等価面インピーダンスは以下の式と同等になります。

ここで、Î´は表皮深さであり、以下の式で与えられます。

fは周波数（Hz）、µ0は自由空間の透磁率です。この高周波損失仕様は、単一シートの表皮効果損失モデルに対応します。すなわち、ここでは高周波の電流が有限厚さ導体の片側に
集中すると仮定されています。
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注記
2重シート表皮効果損失モデルをアクティブにするには、momentum.cfgファイルで以下の変数を設定します。

MOM3D_USE_SHEETLOSSMODEL=2

この変数のデフォルト値は1であり、片側表皮効果損失を示します。

この設定フラグは、有限厚さの導体がシミュレートされ、有限厚さ導体として展開されない場合のみ使用します。両側表
皮効果損失モデルは、片側表皮効果損失損失モデルと同じDC損失を与えます。しかし、高周波では、片側表皮効果損
失損失モデルは電流が導体の片側に集中すると仮定するのに対し、両側表皮効果モデルは導体の両側の電流分布が
等しいと仮定します。

Impedance (Re, Im,)を選択すると、伝導率を面インピーダンス（Ω/m2）で指定できます。実数部をRealフィールドに、虚数部をImaginaryフィールドに入力します。

注記
Momentumはこのようなメタル・レイヤ定義を、周波数に依存しない一定の損失モデルとして扱います。この場
合は、UIで入力された厚さは無視されます。

定義が終了したら、Applyをクリックします。7.
マッピングされたレイアウト・レイヤの残りに対して、上記の手順を繰り返します。8.
終了したら、OKをクリックしてダイアログ・ボックスをクローズします。9.

厚さのある導体の自動3次元展開

Momentumでは、有限厚さの導体を3次元メタル展開機能を使ってモデリングできます。この機能は、有限厚さの導体のマスクを、導体の指定された
厚さを使って、レイヤ媒体に垂直な方向に自動的に展開します。

自動3次元展開をアクティブにするには、Thick Conductor (up)またはThick Conductor (down)のいずれかの展開を選択します。どちらの場合も、内
部Momentumサブストレート・モデルに誘電体レイヤが1つ追加されます。これは、展開されるメタル・レイヤのそれぞれに対して行われます。メタル・
レイヤとメタル・レイヤの間の誘電体レイヤの厚さの値は変更されないので、サブストレート内で互いに重なり合う2つの導体の間のキャパシタンスの
値は変わりません。

自動3次元メタル展開のサブストレート項目を選択する手順:

Momentum > Substrate > Create/Modifyを選択します。1.
Metallization Layersタブをクリックします。2.
Substrate Layersリストで、レイアウト・レイヤがマッピングされているサブストレート・レイヤまたはインタフェースを選択します。3.
Layout Layerダイアログ・ボックスでTypeドロップダウン・リストを選択します。4.
Thick Conductor (up)またはThick Conductor (down)を選択します。5.

自動展開を使用すると、シミュレーションの時間と必要メモリが増加しますが、シミュレーション結果の精度は上がります。一般的に、高さ／厚さの比が5より
も小さい場合は、導体の有限の厚さの影響をMomentumシミュレーションで考慮する必要があるでしょう。

下の図は、導体に対して"up"と"down"の展開を使用した場合の内部サブストレート・モデルを示します。どちらの場合も、追加の誘電体レイヤが挿
入され（図では[new]と表示）、"up"展開の場合はメタル・レイヤの上にあるレイヤの誘電特性を持ちます。"down"展開の場合は、新しいレイヤはメタ
ル・レイヤの下にあるレイヤの材料特性を持ちます。
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注記
追加の内部メタライゼーション・レイヤは、有限厚さ導体の4サイドすべての電流をモデリングするために自動的に
Momentumに追加されます。

これとは別の「手動」展開の方法については、ビアによる有限厚さのモデリングを参照してください。

厚さのある導体の水平側面電流のモデリング

厚さのある導体の水平側面電流を自動的にモデリングするには、Momentum > Mesh > Setupを選択し、Mesh Setup Controlsダイアログ・ボックスの
GlobalタブにあるHorizontal side current (thick conductors)機能をオンにします。Mesh Setup Controlsの詳細については、回路全体に対するメッシュ
・パラメータの定義を参照してください。

この機能を選択した場合は、グリーン関数に対する新しい構成技術が使用され、サブストレート・データベースの再計算は不要です。Momentum >
Post-Processing > Visualizationを選択することでポスト・プロセッシングで視覚化できます。これは、3次元メッシュと電流ビジュアリゼーションの両方
に使用できます。

水平側面電流を考慮した厚さのある導体のUターンのビジュアリゼーション

Horizontal side currentをオンにした場合は、自動展開を指定されたすべての導体に水平電流成分が追加されます。これにより、下の図に示すよう
な電流のモデリングが行われます。
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注記
通常のビアの場合は、またはユーザが手動で有限厚さの導体を展開する場合は、水平電流成分は追加されませ
ん。

過去のバージョンとの互換性のために、新しい水平側面電流トグルはデフォルトではオフになっています。

側面メタライゼーションのメッシュに対して、いくつかのレベルの細かさを指定できます。

水平方向に1個のセル:エッジ・メッシュがオフで、伝送ライン・メッシュ指定が入力されていない場合。

注記
これは、導体が自動的に展開されるように指定されている場合に推奨される設定です。

水平方向に複数のメッシュ・セル:エッジ・メッシュがオフで、伝送ライン・メッシュ指定が入力されている場合。
水平方向にエッジ・メッシュ:グローバル・エッジ・メッシュ・トグルがオンで、自動展開される導体のすべての側（上下左右）にエッジ・メッシュが指定されている
場合。これを下の図に示します。

注記
側面メタライゼーションに複数のメッシュ・セグメントを使用した場合は、シミュレーション時間は大幅に増加しま
す。

オーバラップ優先度の設定

複数のレイアウト・レイヤが同じメタライゼーション・レイヤに割り当てられていて、メタライゼーション・レイヤ上のオブジェクトが重なる場合は、どのレ
イアウト・レイヤを優先するかをオーバラップ優先度によって指定できます。メッシュ・メーカは、レイヤ上のオブジェクトのうち優先度の値が最大のも
のにメッシュを割り当てます。 この際、レイヤ上にある優先度が低いオブジェクトが重なった部分は、回路から論理演算により取り除かれます。重な
るオブジェクトがある場合に優先度が設定されていないと、任意のメッシュが自動的に作成され、エラーは報告されません。スケマティックから生成さ
れた抵抗性レイヤは、最も高い優先度に自動的に設定されます。
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場合によっては、製造上のレイアウトの指針に従って、意図的に重なりのあるデザインを作成することがあります。この場合は、重なるレイアウト・レ
イヤに対して、優先度とは逆の順番で（すなわち、大きい方から小さい方へ）優先度を付けます。値が大きいレイヤのエッジにシステムが自動的に境
界をドローイングし、エラーは返されません。

優先度はメッシュの作成方法に影響するだけで、デザインのレイアウト・レイヤを変更することはありません。

オーバラップ優先度を指定する手順:

Momentum > Substrate > Create/Modifyを選択します。1.
Metallization Layersタブを選択します。2.
Layer MappingセクションのSubstrate Layersリストで、重なっているレイアウト・レイヤの1つを選択します。3.
Overlap Precedenceフィールドにこのレイヤの優先度を指定します。フィールドに直接値を入力するか、矢印キーで値を選択します。4.
Applyをクリックします。5.
重なっているレイヤの残りに対して、上記の手順を繰り返します。6.
終了したら、OKをクリックしてダイアログ・ボックスをクローズします。7.

誘電体のパラメータ

以下の各セクションでは、以下の誘電体パラメータについての詳細を説明します。

誘電率
誘電ロス・タンジェント
伝導率
比透磁率
磁気ロス・タンジェント

誘電率

すべての誘電体の比誘電率は、以下の複素数であると仮定されます。

これは以下のようにも表されます。

ここで、 は の実数部、
は誘電ロス・タンジェントです。

材料とその代表的な誘電率の例を下の表に示します。

材料 比誘電率

アルミナ 9.8

サファイア 9.3 - 11.7

ベリリア 6.0

ルチル 100.0

GaAs 12.9

注記
表の値は単なる参考用です。 実際の材料に対する測定値を使用してください。

誘電ロス・タンジェント

材料の誘電ロス・タンジェントは、周波数の関数です。10 GHz電界に対する誘電ロス・タンジェントの例を下の表に示します。
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材料 <th

アルミナ .0002

ガラス .002

ベリリア .0001

ルチル .0004

GaAs .0016

注記
この値は単なる参考用です。実際の材料に対する測定値を使用してください。

誘電体の伝導率

いくつかの材料（シリコンなど）の場合は、サブストレートの損失効果は（ ,  = 伝導率）で記述する方が（ 、ロス・タンジェント）で記述するよりも

適しています。複素誘電率は以下の式で（ 、伝導率）と関連付けられます。

ここで:

 = 2  周波数

 = 8.85e-12 F/m （自由空間の絶対誘電率）

場合によっては、伝導率の代わりに抵抗率（ ）が指定されることもあります。抵抗率と伝導率の関係は以下のとおりです。

抵抗率は通常  cmで、伝導率はS/mで指定されます。

例:
シリコン材料の代表的な抵抗率は以下のとおりです。

 = 10  cm
これは以下の伝導率に対応します。

 = 10 S/m

注記
Momentum > Substrate > Create/Modifyの下でSubstrate Layersタブを選択したときに、Permittivity (Er)をRe,
Conductivityに設定すると、データセットにGAMMAは示されず、Z0の値はデフォルトの50 Ωに設定されます。これ
は、Momentumのシミュレーション速度を改善するためにポート・ソルバがオフになるからです。
ポート・ソルバをオンに戻すには、HOME/hpeesof/config/momentum.cfgにある以下の構成変数を設定する必要が
あります。

MOM3D_USE_PORTSOLVER=2

これにより、ポート・ソルバが強制的に実行され、Z0とGAMMAのエントリがデータセットに正しく示されます。

誘電体の比透磁率

すべての誘電体の比透磁率は、以下の複素数であると仮定されます。

これは以下のようにも表されます。

ここで、 は の実数部、 は磁気ロス・タンジェントです。

比透磁率の例は、材料と比透磁率に示されています。

材料 比透磁率

金 .99996

空気 1

アルミニウム 1.00002

ニッケル 250
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鉄 4000

注記
上記の値は単なる参考用です。実際の材料に対する測定値を使用してください。

誘電体の磁気ロス・タンジェント

材料の磁気ロス・タンジェントは、周波数の関数です。磁気ロス・タンジェントを持つ材料の例としてはポリアイアンがあり、30 GHzで0.0208のロス・タ
ンジェントを持ちます。

スケマティックからのサブストレート定義の読み取り

以下の条件に当てはまる場合は、Momentum > Substrate > Update From Schematicを選択してサブストレートを更新してください。

スケマティック上でMSUBやSSUBなどのサブストレート・コンポーネントを使用している。
すでにLayout Generate/Update Layoutを使ってスケマティックからレイアウトを生成している。
その後、スケマティックのサブストレート定義を変更したため、レイアウトにそれを変換する必要がある。

新しいサブストレート情報を読み取るには、Momentum > Substrate > Update From Schematicを選択する必要があります。Layout >
Generate/Update Layoutを使っても、新しいサブストレート情報はレイアウトに変換されません。

スケマティックからサブストレート定義を更新する手順:

Momentum > Substrate > Update From Schematicを選択します。適切なスケマティック上のサブストレートが読み取られ、新しい情報がMomentumのサブスト1.
レート定義に入力されます。

サブストレートの保存

サブストレート定義はファイルに保存できます。これにより、現在のプロジェクトの外に定義を保存でき、他のデザインで容易にサブストレート定義を
使用できます。サブストレートを保存する手順:

Momentum > Substrate > Save Asを選択します。1.
ファイル名を入力してOKをクリックします。サブストレート・ファイルの拡張子は.slmです。2.
すでに名前の付いているファイルを保存するには、Momentum > Substrate > Saveを選択します。サブストレートの保存場所
サブストレートは以下の2つの場所のどちらかに保存されます:

付属のサブストレートを収めたディレクトリ（$HPEESOF_DIR/momentum/lib）。ユーザが作成または変更したサブストレートは、この場所に保存しないでくださ
い。
サブストレート情報は現在のプロジェクト・ディレクトリの/networksの下の<substrate_name>.slmという名前のファイルに保存されます。

サブストレートの事前計算

シミュレーションの実行とメッシュの計算には、サブストレートの動作を記述するグリーン関数の計算が必要です。

シミュレーション前にメッシュの計算を行う場合は、先にサブストレートの計算を行う必要があります。メッシュの事前計算の詳細については、メッシュの事前
計算を参照してください。
シミュレーション前にグリーン関数が計算されていない場合は、まずその計算が行われ、その後でシミュレーションが実行されます。

Advanced Design Systemに付属するサブストレートを使う場合は、サブストレート関数の事前計算は不要です。サブストレートを編集したか新しいサ
ブストレートを作成した場合は、サブストレート関数の事前計算が必要です。

グリーン関数の計算が終わると、データベースにデータが記憶され、このサブストレートを使用するすべてのデザインで用いられます。事前計算後に
サブストレートの変更がなければ、周波数レンジが拡張された場合を除いて、再計算は行われません。周波数レンジはMomentumモードでは設定で
きますが、Momentum RFモードでは設定できません。RFモードでは、周波数レンジ（スタート-ストップ）の指定は要求されません。RFモードでは準静
的グリーン関数が用いられるため、プログラムが自動的に選択した準静的周波数でグリーン関数が計算されます。Momentumモードで計算されたサ
ブストレート関数は、DCから一定の上限周波数まで計算されている場合には、RFモードで再利用できます。

事前計算の詳細については、動作理論を参照してください。

サブストレート関数を事前計算する手順:

Momentum > Substrate > Precomputeを計算します。1.
計算の周波数レンジを指定するには、Minimumフィールドに開始周波数を入力し、周波数単位を選択します。Maximumフィールドに終了周波数を入力し、周2.
波数単位を選択します（RFモードでは使用できません）。
シミュレートしたい周波数がすべて周波数レンジに含まれるように注意してください。
OKをクリックすると計算が始まります。3.
計算が終了したら、サブストレートを編集しない限りこの手順を繰り返す必要はありません。

注記
サブストレートのレイアウト・レイヤ数が多いほど、計算に時間がかかります。
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サブストレート計算のステータスの表示

サブストレート計算の開始後に、計算に関するメッセージがMomentum Statusウィンドウに表示されます。通常は、エラーが発見された場合と、計算
が終了したときにメッセージが出ます。

ステータス・ウィンドウをクローズした場合は、再オープンするには、Layoutメニュー・バーでWindow > Restore Statusを選択します。

サブストレート計算の停止

サブストレート計算を停止する手順:

Momentum Statusウィンドウで、Simulation/Synthesis > Stop Simulationを選択します。1.

計算が停止し、情報は保存されません。

サブストレート・サマリの表示

シミュレーションが成功したら、サブストレート、メッシュ、解に関する統計情報を表示できます。解を求めるのにかかった時間、使用リソース、セル情
報などが得られます。サマリを表示するには、Momentum > Substrate > Summaryを選択します。

サブストレート計算の再利用

サブストレート・データベースにアクセスできる場合は、サブストレート定義とサブストレート計算を他のデザインで再利用できます。データベースにア
クセスできるかどうかわからない場合は、システム管理者に確認してください。

計算が開始される前に、解が生成済みかどうかを確認するために、いくつかのフォルダが検索されます。以下のフォルダがこの順番で検索されま
す。

プロジェクトのsubstratesフォルダ
ホーム・サブストレート・ディレクトリまたはサイト・サブストレート・ディレクトリ（システム管理者が設定）
Momentumに付属するサブストレートがあるフォルダ（$HPEESOF_DIR/momentum/lib/substrates）

同一のサブストレート定義が見つかると、その名前とは無関係に、サブストレート計算プロセスは同じ情報を再計算するのを避け、見つかった情報を
使用します。

サブストレートの削除

このコマンドは、選択したサブストレート・ファイル（.slm）を削除します。サブストレートが事前に計算されている場合は、計算結果はデータベースに残
ります。

ファイルを削除する手順:

Momentum > Substrate > Deleteを選択します。1.
削除するファイルの名前を選択します。2.
OKをクリックします。3.

サブストレート定義サマリ

サブストレート定義に少しでも変更があると、全体の再計算が必要です。システムは重複する定義をチェックし、計算済みのデータが存在する場合
は、名前に関わらずそれを使用します。

サブストレート定義全体は、以下のものからなります。

ビア、製造プロセスの場合と同様
エア・ブリッジ、高さと対応するビアを含む
グランド・プレーンの穴、スロットの信号経路（スロットまたはコプレナ）に含まれる場合、またはグランド・プレーンを貫通するビアのリリーフ・ホールの場合は、
これも媒体の一部になります。
誘電体レイヤの属性（Er、MUr、損失）
グランド・プレーンの損失とカバーの属性（伝導率またはインピーダンス）
厚さのある導体のupとdown

以下のものはサブストレート定義に含まれません。

ストリップ・レイヤとビア・レイヤのメタル損失

サブストレート計算に用いられる数値計算プロセスは、ストリップライン回路に対しては1分程度しかかかりません。マイクロストリップに対しては数分
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程度、複数のビアがある任意の多層サブストレートに対しては数時間かかることもあります。

サブストレートの例

以下の例を参考にして、独自の回路を作成してください。

放射アンテナ用のサブストレート
377 Ω終端と放射パターン
エア・ブリッジのあるデザイン用のサブストレート

放射アンテナ用のサブストレート

空間に放射するアンテナ用のサブストレートを定義するには、以下のサブストレート定義を作成します。

2つのレイヤはどちらも空気の特性を持つ開境界として定義されています（誘電率と透磁率がReal = 1、Loss Tangent = 0）。アンテナのデザインは、2
つの空気レイヤの間にあるメタライゼーション・レイヤに配置します。

377 Ω終端と放射パターン

デザインのトップ・レイヤとボトム・レイヤを377 Ω終端として定義することにより、これらのストラクチャの放射パターンをシミュレーション後に計算で
きます。このアプリケーションでは、以下の点に注意してください。

実際の終端の値は、376 Ωから378 Ωの間の値になります。
トップまたはボトムのグランド・レイヤを377 Ω終端に置き換える場合は、無限のトップまたはボトム・レイヤに対するシミュレーション結果との整合を（Sパラメ
ータの結果と放射パターンの両方に対して）取るために、回路と377 Ω終端との間に厚い空気レイヤが必要です。一般には、サブストレートの厚さの10〜20
倍程度の空気レイヤで十分です。
放射パターンの計算前に、インピーダンス値のテストがあります。インピーダンス値は、（377 - 10）〜（377 + 10） Ωの範囲である必要があります。

エア・ブリッジのあるデザイン用のサブストレート

エア・ブリッジのあるデザイン用のサブストレート定義を作成するには、エア・ブリッジのコンポーネントと、レイアウト・レイヤ上でのコンポーネントの
配置をまず決定する必要があります。以下の説明を参照してください。

2個のコンポーネント間の基本的なエア・ブリッジは、以下のアイテムから構成されます。

ブリッジと最初のコンポーネントとを接続するビア
ブリッジ自体
2番目のコンポーネントと接続して経路を完成する2番目のビア
ブリッジの下の空気レイヤ

レイアウトは最低3つの独立したレイヤ上にドローイングします。

ビアを配置するレイヤが最低1つ必要です。
ブリッジは別のレイヤになければなりません。
コンポーネントはさらに別のレイヤになければなりません。

エア・ブリッジを構成するアイテムは（ビアを除いて）それぞれ別のレイヤになければなりません。この例では、エア・ブリッジで接続されるコンポーネ
ントはすべて同一のレイヤにあります。

サブストレート定義は以下のアイテムから構成されます。

空気の開境界
有限の厚さの空気のインタフェース・レイヤ。これはブリッジの下の空気レイヤに対応します。
誘電体のインタフェース・レイヤ

レイアウト・レイヤからサブストレートへのマッピングは以下のとおりです。

ブリッジは、「自由空間」のサブストレート・レイヤと「空気」サブストレート・レイヤとの間にあるメタライゼーション・レイヤにマッピングされます。
ビアは、有限の「空気」サブストレート・レイヤを貫通するようにマッピングされます。
コンポーネントは、空気サブストレート・レイヤと誘電体（"GaAs"）レイヤとの間にあるメタライゼーション・レイヤにマッピングされます。

ブリッジで接続されるコンポーネント同士は、同じレイアウト・レイヤになくてもよく、同じメタライゼーション・レイヤにマッピングする必要もありません。
ビア同士も同じレイアウト・レイヤに存在する必要はありません。重要なのは、必要な数のサブストレート・レイヤがサブストレート定義に存在し、コン
ポーネント、ビア、ブリッジがそれぞれ正しいメタライゼーション・レイヤにマッピングされることです。
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レイアウトでのエア・ブリッジのドローイング

エア・ブリッジのシミュレーションでは、その形状をサポートするレイアウトとサブストレート定義を作成する必要があります。このためには、空気レイ
ヤ（エア・ブリッジと同じ高さ）を作成してビアを貫通させます。例えば、誘電体レイヤ上に何らかの形状（スパイラルなど）があるとします。この場合
は、ビアは垂直に立ち上がり、空気レイヤを貫通して、メタル・ブリッジに接続します。そして、もう1個のビアがブリッジから下に延び、前のレイヤ上で
別のパスにつながります。

コプレナ・デザインのポートとエア・ブリッジ

コプレナ・ラインをグランド・プレーン上のスロットとしてドローイングする場合は、デフォルトでは2つの結合スロット・ラインから構成される4ポート・デ
バイスとして扱われます。コプレナ・ラインとしてシミュレートするには、回路のポートにコプレナ・ポート・タイプを設定します。このポート・タイプを使う
と、同じ基準面上の2個のポートが結合され、1個のポートとして扱われます。コプレナ・ポート・タイプの使い方については、コプレナ・ポートの定義を
参照してください。

コプレナ・ポート・タイプを使用しないと、コプレナ伝送ラインがスロット・モードも伝搬させる場合に、モードの問題が発生することがあります。コプレナ
・ポートを使うと、スロット・モードはポート・インタフェースで短絡されます。ところが、回路のどこかでスロット・モードが励振されると、ある周波数で共
振を起こす場合があります。このような場合には外部の境界条件が電気的挙動を左右するため、非物理的な結果が生じます。不連続部の近くにエ
ア・ブリッジ（ストラップ）を追加すれば、2つのグランドの電圧レベルが等しくなり、スロット・モードは排除されます。エア・ブリッジの例は、コプレナ・ラ
イン・ベンドのサンプルCPW_bend_prjにあります。

シリコン・サブストレート

以下に示すのは、Momentumシミュレーションで用いられるシリコン・サブストレートの例です（この例はexamples > Momentum > Microwave >
SPIRAL_prjから取ったものです）。

Free space
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---------------  strip2

Layer3 (Eps=3.9)    | via

--------------- spiral (strip)

Layer2 (Eps=3.9)

Layer1 (Eps=11.9 ; cond=12.5 S/m)

GND

3次元展開を伴うシリコン・サブストレート

以下に示すのは、厚さのある導体の自動展開で用いられるシリコン・サブストレートです。

Free space

-----------------Strip thick conductor up (thickness 4 mil conductivity
Sigma Re:5e+6 S/m)

Alumina  (Eps=9.6 ; Thickness=25 mil)

GND

Thick conductor upを選択した場合は、シミュレーションに使用されるサブストレートは以下のようになります。
Free space
-----------------Strip
air | via (substrate layer thickness 4 mil ; Eps =1 )
-----------------Strip
Alumina (Eps=9.6 ; Thickness=25 mil)

GND

厚さのある導体の自動3次元展開の詳細については、厚さのある導体の自動3次元展開を参照してください。

Momentumのポート
ポートにより、回路へのエネルギーの出入りが可能になります。シミュレーション・プロセスでは、回路にエネルギーを印加します。Momentumで回路
をシミュレートするには、最低1個のポートが必要です。
ポートの定義は2段階で行われます。まず、回路のドローイング時に回路にポートを追加します。次に、回路に合わせてポートを調整するために
Momentumでポートのタイプを指定します。これはシミュレーション・プロセスを容易にするためです。
この章では初めに、Momentumでシミュレートする回路にポートを追加する際の注意事項を述べます。その後、Momentumの各ポート・タイプについて
解説し、ポート・タイプを指定する方法を説明します。

回路へのポートの追加

回路にポートを追加するのは、SchematicウィンドウからでもLayoutウィンドウからでも可能です。回路にポートを追加する方法については、回路へ
のポートの追加を参照してください。この手順には、Momentumでシミュレートする回路にポートを追加する際の注意事項が記述されています。

注意事項

Momentumでシミュレートする回路にポートを追加する際は、以下の点に注意してください。

ポートを接続するコンポーネントまたは形状が存在するレイアウト・レイヤは、ストリップまたはスロットとして定義されたメタライゼーション・レイヤにマッピング
する必要があります。ポートを直接ビアに接続することはできません。ストリップとスロットの定義方法については、メタライゼーション・レイヤの定義を参照し
てください。

エッジにポートを配置する場合は、矢印がオブジェクトの外側にあり、オブジェクトの内部をまっすぐに指している必要があります。
接続先のオブジェクトとポートとは、同じレイアウト・レイヤになければなりません。エントリ・レイヤをこのレイヤに設定すると便利です。 Layoutウィンドウのツ
ールバーにあるEntry Layerリストボックスを使います。

ポートはオブジェクトに適用する必要があります。ポートがオープン・スペースに適用され、オブジェクトに接続されていない場合は、最も近いオブジェクトのエ
ッジにMomentumが自動的にポートをスナップします。ただし、この場合でもポートの位置は変化しないので、レイアウトを見てもわからないことがあります。
エッジにスナップされるポートを追加した後でレイアウト分解能を変更した場合は、ポートを削除して追加し直す必要があります。分解能を変更するとポート
がスナップされるエッジが不明確になるため、メッシュ計算でエラーが生じます。
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注記
Momentumでシミュレートする回路には、グランド・ポート・コンポーネント（Insert > Ground）を使用しないでくださ
い。レイアウトに配置されたグランド・コンポーネントは、Momentumに認識されません。サブストレートにグランド・
プレーンを追加するか、この章の後の方で説明するグランド基準ポートを使用します。

グランド・ポート・コンポーネントのツールバー・ボタン: 

ポート校正

Momentumでは、校正プロセスで校正ラインにより回路に信号を供給するために、グランド付き信号源とフローティング信号源の2種類の集中定数信
号源が用いられます。
グランド付き信号源は低周波に適していますが、高周波では、ポートとグランドの距離が電気的に大きくなるため、校正プロセスでの不要なサブスト
レート結合により結果の精度が低下します。
フローティング信号源は、不要なサブストレート結合が少ないため高周波に適していますが、低周波では、信号源の容量性の内部インピーダンスが
低周波電流を阻止するため、うまく動作しません。
Momentumのデフォルトの動作では、シミュレーションの周波数レンジに応じて、これら2つの信号源が自動的に切り替えられます。
信号源のタイプは以下の環境変数を使って明示的に制御できます。

MOM3D_USE_SOURCETYPE=0 （グランド付き低周波校正信号源）

MOM3D_USE_SOURCETYPE=1 （フローティング高周波校正信号源）

この変数は以下のいずれかの場所で指定できます。

$HPEESOF_DIR/config/momentum.cfg

$HOME/hpeesof/config/momentum.cfg

ポート・タイプの決定

Momentumには5種類のポート・タイプがあります。ポートの目的は、回路にエネルギーを注入し、回路に対してエネルギーが出入りできるようにする
ことです。ポート・タイプの役割は、回路のタイプと回路内でのポートの機能に基づいて、ポートを調整することです。一般的には、レイアウトの目的
に最も適したポート・タイプを選ぶ必要があります。
以下の表は、各ポート・タイプについて簡単に説明したものです。1つの回路で複数のポート・タイプを使用することもできますが、それぞれのポート・
タイプが適用できる場所には制限があります。ストリップまたはスロット・メタライゼーション・レイヤにあるオブジェクトに対しては、Singleポート・タイプ
だけが適用できます。オブジェクトの表面にあるポートに対しては、InternalタイプとGround Referenceタイプだけが適用できます。 これ以外のタイプ
は、オブジェクトのエッジに接続されたポートに対して適用できます。

注記
ストリップおよびスロットは、メタライゼーション・レイヤです。これらのレイヤの詳細については、メタライゼーション・
レイヤの定義を参照してください。

ポート・タイプを割り当てないと、シミュレーションでは回路内のすべてのポートがSingleタイプとして扱われます。

注記
ポート・タイプはすべて、Momentumの両方のシミュレーション・モード（マイクロ波とRF）で定義できます。ただし、ディ
エンベディング（基準オフセット）はRFモードでは使用できません。

ポート・タイプ 説明 ポート接続先 オブジェクトの
レイヤ

Single（単一）、デフォ
ルト

このポートは、ポート境界でのモード不整合を除去するように校正されています。スロット・レ
イヤにある単一ポートには極性があります。他のタイプを割り当てない限り、ポートはシング
ルポートとして扱われます。

オブジェクトの
エッジ

ストリップまた
はスロット・レ
イヤ

Internal（内部) ポートは校正されません。集中定数エレメントとの接続や、回路内のその他の接続を表すた
めに使用できます。

オブジェクトの
エッジまたは
表面

ストリップ・レ
イヤ

Differential（差動) 極性が反対の2個のポート。このポート対がシングルポートとしてシミュレートされます。 オブジェクトの
エッジ

ストリップ・レ
イヤ

Coplanar（コプレナ） 極性が反対の2個のポート。このポート対がシングルポートとしてシミュレートされます。 オブジェクトの
エッジ

スロット・レイ
ヤ

Common mode（コモ 同じ絶対電位と同じ極性で励振される複数のポート。これらのポートがシングルポートとして オブジェクトの ストリップ・レ
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ン・モード) シミュレートされます。 エッジ イヤ

Ground reference（グ
ランド基準)

シングル（ストリップ）、内部、コモン・モードのどれかのポートに対する明示的なグランドを使
用します。 明示的なグランド・ポートが存在しない場合は、最も近い無限メタルによって暗黙
のグランドが実現できます。

オブジェクトの
エッジまたは
表面

ストリップ・レ
イヤ

各ポート・タイプの詳細と定義方法について、以下の各セクションで説明します。

シングルポートの定義

Single（シングル）は、デフォルトのポート・タイプです。このポートは以下の属性を持っています。

ストリップまたはスロット・メタライゼーション・レイヤにあるオブジェクトに接続されます。
オブジェクトのエッジに対してのみ適用できます。
ポートは外部であり、校正されます。励振の際、ポート境界でのポート励振の不要なリアクティブ効果（モード不整合）を除去する校正プロセスが用いられま
す。すなわち、ポート境界が半波長の校正（伝送）ラインで延長されます。校正ラインの長さは、メッシュまたはシミュレーションのプロセスで選択された周波数
に対応する波長を使って計算されます。校正プロセスの詳細については、Sパラメータの校正とディエンベディングを参照してください。

基準オフセットを指定することにより、ポート境界を形状の内部または外部に移動できます。Sパラメータの計算では、この位置にポートがあるかのように扱わ
れます。詳細については、基準オフセットの適用を参照してください。

同じ基準面上に複数のシングルポートが存在する場合は、寄生成分から生じるカップリング効果によってSパラメータが影響されます。校正プロセスはこれら
のポートをグループ化し、校正アームにおけるカップリングがSパラメータの解に反映されるようにします。詳細については、カップリング効果の考慮を参照し
てください。

ストリップ・レイヤ上のオブジェクトにポートが接続されている場合は、サブストレート定義に最低1つの無限のメタル・レイヤが必要です。すなわち、ポートに加
えてトップ・カバー、グランド・プレーン、スロット・レイヤ、グランド基準のいずれかを使用する必要があります。グランド基準の詳細については、グランド基準
の定義を参照してください。

スロット・レイヤにあるオブジェクトにポートを接続すると、ポートは極性を持ちます。

ヒント
このポート・タイプを指定するためにPort Editorダイアログ・ボックスをオープンする必要はありません。ポート・タ
イプを指定しないポートはシングルポートと見なされます。

シングルポート・タイプを定義する手順:

Momentum > Port Editorを選択します。1.
このタイプを割り当てるポートを選択します。2.
Port Editorダイアログ・ボックスのPort Typeの下で、Singleを選択します。3.
ポート・インピーダンスの実数部をRealフィールドに、虚数部をImaginaryフィールドに入力し、単位を指定します。4.
ポート境界（ポート基準面とも呼ぶ）を移動することができます。境界を移動することにより、ポートの特性インピーダンスと伝搬特性に基づいて、回路に有効5.
電気長を加算または減算できます。 これはディエンベディング・プロセスの一種です。Reference Offsetフィールドにオフセットを入力し、単位を選択します。
正の値を指定するとポート境界が回路内部に移動し、負の値を指定すると回路外部に移動します。
Applyをクリックして、ポートに定義を追加します。6.

オーバラップの回避

シングルポートを使用する場合は、ポートに適用される校正アームが回路内の他のエレメントとオーバラップする場合があります。この場合は、ポー
トは内部ポート・タイプに変更され、校正は実行されなくなります。この変更を示すメッセージがシミュレーション中にStatusウィンドウに表示されます。
内部ポートの詳細については、内部ポートの定義を参照してください。

基準オフセットの適用
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基準オフセットを使うと、レイアウト内のシングルポートの位置を変更することにより、実際のドローイングを変更せずにレイアウト内の電気長を調整
できます。Sパラメータの計算では、基準オフセット位置にポートが存在するかのように扱われます。

基準オフセットを使用する理由

レイアウト内でポートの位置を調整することは、ハードウェア・プロトタイプを測定する際にプローブの影響を除去するのと似ています。ハードウェア・
プロトタイプを測定する場合は、被試験デバイス（DUT）の入力と出力にプローブが接続されます。プローブはDUTにエネルギーを供給し、回路の応
答を測定します。しかし、測定された応答が表すのは、セットアップ全体すなわちDUTとプローブを合わせたものの特性です。これは測定したい特性
ではありません。最終的な測定結果は、DUTだけの特性を反映するものでなければなりません。プローブの特性は既知なので、測定時にプローブの
影響を除去してDUTだけの正しい測定値を得ることができるのです。

Momentumの動作も、このハードウェア測定プロセスによく似ています。Momentumの場合は、プローブではなくポートが用いられ、シミュレーション中
に回路にエネルギーを供給して応答を測定する役割を果たします。Momentumのポートにも、やはり望ましくない影響があります。ポート境界での低
次モード不整合がそうであり、これを除去するために校正プロセスが用いられます。しかし、校正プロセスが機能するためには、基本モードの特性が
正確に評価される必要があります。これが可能なのは、ポート境界と最初の不連続部との距離が十分大きい場合、すなわち、この距離を実現する
十分な長さのフィードラインが存在する場合に限ります。

基本的な例として、以下のように回路の一部でライン幅が突然変化する場合を考えます。

厳密に言うと、特性を評価する必要があるのは、以下に示すようなステップ幅自体の変化だけです。

すでに述べたように、基本モードがセトリングするにはある程度の距離が必要なので、この「短い」ストラクチャでは十分正確なシミュレーションができ
ないおそれがあります。この場合は、フィード・ライン長を適当に取ります。

こうするとシミュレーション結果は正確になりますが、追加したライン長が結果に反映されてしまいます。これを修正するために基準オフセットを使用
します。回路の計算には長いラインが用いられますが、基準オフセットの移動によって、短いストラクチャをシミュレートした場合と同様のSパラメータ
が得られます。

余分のフィード・ラインの影響はSパラメータから数学的に除去されます。
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このように、ライン長を足したり引いたりすることを、一般にディエンベディングと呼びます。基本的なプロセスは以下のとおりです。

解を求める際に、回路内でのポートの物理的な位置に基づいて、ポートのインピーダンスと伝搬定数が計算されます。インピーダンス、伝搬定数、デ
ィエンベディングの距離が既知である場合は、ラインの損失と位相シフトを補正することで、余分のライン長の影響をSパラメータの結果から除去でき
ます。得られた結果は、余分のライン長がない場合のSパラメータと同じです。

ディエンベディングに関する注意事項

不連続部自体の位置までディエンベディングを行うことも可能です。しかし、最初の不連続部を超えて基準オフセットを移動すると、誤ったシミュレー
ション結果が得られます。これは、不連続部より先はライン幅が異なっているので、インピーダンスと伝搬定数の値も異なるからです。

注記
レイアウトのエッジより外に基準オフセットを設定すれば、回路外部へのディエンベッドが可能です。これにより、シミ
ュレートするストラクチャにドローイングされていない長いフィード・ラインの効果をシミュレートできます。

カップリング効果の考慮

複数のシングルポートが同じ基準面上に存在する場合は、これらのポート間に寄生成分によって自然に発生するカップリングが校正プロセスで考慮
されます。これにより、回路の実際の動作をより正確に反映したシミュレーション結果が得られます。

下の図は、ポート間のカップリングを考慮するために校正プロセスがポートをグループ化する方法を示します。このセットアップでは、最初の2個のポ
ートだけがグループ化されます。 3番目のポートは内部ポートであり、4番目のポートは別の基準面上にあるからです。なお、2番目のポートには基準
オフセットが指定されていますが、このプロセスではこれらのポートは同一面上にあると見なされ、基準オフセットは等しく設定されます。

ポートをグループ化したくない場合は、一方のポートが接続されているオブジェクトのエッジにメタルを追加します。これでポートは別の基準面上にあ
ることになり、グループ化されません。

内部ポートの定義

内部ポートは、デザイン内のオブジェクトの表面にポートを適用するために使います。内部ポートを使うことにより、回路内のすべての物理的な接続
を表現できるので、回路のポート間で発生するすべての電磁界結合の効果をシミュレーションで考慮できます。寄生成分から生じるカップリング効果
がシミュレーションで考慮されるのは、内部ポートが校正されないからです。不正確なSパラメータが得られるのを防ぐため、シングルポートと内部ポ
ートの間にカップリングが生じるような形状は避けてください。

内部ポートが役立つ例の1つとして、オブジェクト表面にあるボンド・ワイヤのシミュレーションがあります。もう1つの例として、回路を構成する伝送ラ
インがトランジスタやチップ・キャパシタなどのデバイスに接続されており、そのデバイスがシミュレート対象の回路に含まれない場合があります。内
部ポートは接続ポイントに配置できるので、デバイスがシミュレート対象の回路に含まれなくても、ポート間とデバイス周辺で発生するカップリング効
果をシミュレーションで考慮できます。

内部ポートは、グランド基準と組み合わせて多く用いられます。詳細については、グランド基準の定義と、
<a_href="Theory_of_Operation_for_Momentum.html#TheoryofOperationforMomentum-1104497">内部ポートとグランド基準を使ったシミュレーション
を参照してください。

内部ポート・タイプは以下の属性を持っています。

オブジェクトの表面に適用することで、回路の内部に適用できます。
オブジェクトのエッジに適用できます。
ストリップ・レイヤ上のオブジェクトだけに適用できます。
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オブジェクトの表面にポートがある場合は、ポートの向きは考慮されません（ポートの向きについては、レイアウトへのポートの追加を参照してください)。
ポートに対して校正は実行されません。

ポートに対して校正が実行されないため、シングルポートの場合に比べて結果の正確さは劣ります。ただし、精度の差はわずかです。

内部ポートを定義する手順:

Momentum > Port Editorを選択します。1.
このタイプを割り当てるポートをクリックして選択します。2.
Port Editorダイアログ・ボックスのPort Typeの下で、Internalを選択します。3.
Applyをクリックします。4.

差動ポートの定義

2個のポートの間に電界が発生する（奇数次モードが伝搬する）可能性がある場合は、差動ポートを使用する必要があります。これは以下のような場
合に起こります。

2個のポートが近接している。
回路にグランド・プレーンがないか、グランド・プレーンが比較的遠くにある。
一方のポートが（ある程度）他のポートに対するグランドとして動作し、ポート間に極性が生じる。
ストリップ・メタライゼーション・レイヤ上のオブジェクトにポートが接続されている。

2個のポート間に発生する電界は、回路に影響を及ぼすため、シミュレーションで考慮する必要があります。このために差動ポートを使います。

差動ポートは以下の属性を持っています。

ストリップ・レイヤ上のオブジェクトだけに適用できます。
2個1組で用いられ、この組に対して1つのポート番号が割り当てられます。
2個のポートは、極性が反対で絶対値が等しい電位で励振されます。電圧は逆になります（180°位相が異なる)。対称な2本のライン上にポートがある場合
は、電流の大きさが等しく向きが逆になります。 これ以外の構成の場合は、電流の向きは近似されます。
2個のポートは同じ基準面上になければなりません。

注記
差動ポートのポート番号は以下のように扱われます。

レイアウト上には、レイアウトにポートを追加したときに各ポートに割り当てられたポート番号（インスタンス名）が引き続き
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表示されます。MomentumのPort Editorダイアログ・ボックスを使えば、差動ポートとして扱われているポートの組がどれか
わかります。

Momentumが連続しないポート番号を持つデザインをシミュレートした場合は、結果のデータ・ファイルではポートは連続す
る番号に再マッピングされます。最少のポート番号が1に再マッピングされ、残りの番号は連続する番号に再マッピングさ
れます。デザイン自体のポート番号は変更されません。Statusウィンドウに変更を示すメッセージが表示され、マッピング
の一覧が示されます。

例えば、ポート番号1と3を持つデザインをシミュレートした場合は、以下のステータス・メッセージによって変更が示されま
す。

Layout has non-consecutive port numbers.
Output files will have consecutive port numbers.

layout port -> output port
1 -> 1
3 -> 2

また、結果を表示したときに、Sパラメータは差動ポート番号に対して表示されます。上の例の場合は、レイアウトにはp1、
p2、p3、p4が表示されます。Sパラメータの結果は、元のP1とP3に対してのみ表示されます。

差動ポートを定義する手順:

Momentum > Port Editorを選択します。1.
このタイプを割り当てるポートを選択します。ポート番号をメモしておきます。2.
Port Editorダイアログ・ボックスのPort Typeの下で、Differentialを選択します。3.
Polarityの下でNormalが選択されているのを確認します。4.
Applyをクリックします。5.
2番目のポートを選択します。6.
Port Editorダイアログ・ボックスのPort Typeの下で、Differentialを選択します。7.
Polarityの下で、Reversedを選択します。8.
Associate with port numberの下に、さきほど選択したポートの番号を入力します。9.
Applyをクリックします。10.
回路内の他の差動ポート対に対して、上記の手順を繰り返します。11.
OKをクリックしてダイアログ・ボックスをクローズします。12.

コプレナ・ポートの定義

このタイプのポートは、コプレナ・ライン（CPW）回路に用いられます。差動ポートに似ていますが、スロット・レイヤ上のオブジェクト（すなわち、デザイ
ンでスロットが用いられている部分）に適用されます。2個のポート間に電界が発生する（奇数次モードが伝搬する）可能性がある場合は、コプレナ・
ポートを使用する必要があります。これは以下のような場合に起こります。

2個のポートが近接している。
ポート間に極性が生じる。
スロット・メタライゼーション・レイヤ上のオブジェクトにポートが接続されている。

2個のポート間に発生する電界は、回路に影響を及ぼすため、シミュレーションで考慮する必要があります。このためにコプレナ・ポートを使います。

コプレナ・ポートは以下の属性を持っています。

スロット・レイヤ上のオブジェクトだけに適用できます。
2個1組で用いられます。
2個のポートは、極性が反対で絶対値が等しい電位で励振されます。電圧は逆になります（180°位相が異なる)。対称な2本のライン上にポートがある場合
は、電流の大きさが等しく向きが逆になります。 これ以外の構成の場合は、電流の向きは近似されます。
2個のポートは同じ基準面上になければなりません。

下の図は、コプレナ・ライン・スロットのレイアウトにポート対を適用したものです。デザイン内の各ポート対に対して、コプレナ・ポート・タイプが割り当
てられています。図の矢印は、各ポートの極性と、スロット内の電圧の向きを示します（矢印が電圧の向き）。
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注記
コプレナ・ポートのポート番号は以下のように扱われます。

レイアウト上には、レイアウトにポートを追加したときに各ポートに割り当てられたポート番号（インスタンス名）が引き続き表
示されます。MomentumのPort Editorダイアログ・ボックスを使えば、コプレナ・ポートとして扱われているポートの組がどれか
わかります。

Momentumが連続しないポート番号を持つデザインをシミュレートした場合は、結果のデータ・ファイルではポートは連続する
番号に再マッピングされます。最少のポート番号が1に再マッピングされ、残りの番号は連続する番号に再マッピングされま
す。デザイン自体のポート番号は変更されません。Statusウィンドウに変更を示すメッセージが表示され、マッピングの一覧
が示されます。

例えば、ポート番号1と3を持つデザインをシミュレートした場合は、以下のステータス・メッセージによって変更が示されます。

Layout has non-consecutive port numbers.
Output files will have consecutive port numbers.

layout port -> output port
1 -> 1
3 -> 2

また、結果を表示したときに、Sパラメータはコプレナ・ポート番号に対して表示されます。上の例の場合は、レイアウトには
p1、p2、p3、p4が表示されます。Sパラメータの結果は、元のP1とP3に対してのみ表示されます。

コプレナ・ポートの極性の指定には注意が必要です。極性の指定を誤ると、伝送タイプのSパラメータの位相が180°ずれるおそれがあります。極性
を確認するには、コプレナ・ポートを拡大表示します。2つの矢印がポートに表示されているはずです。1つ目はポート・コンポーネントを回路に追加し
たときに表示されます。2つ目はメッシュが計算された後に表示されます。これはスロット上の電圧の向きを示します。

コプレナ・ポートを定義する手順:

注記
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コプレナ・ポートはスロット・レイヤ上のオブジェクトにのみ適用できます。

Momentum > Port Editorを選択します。1.
このタイプを割り当てるポートを選択します。ポート番号をメモしておきます。2.
Port Editorダイアログ・ボックスのPort Typeの下で、Coplanarを選択します。3.
Polarityの下でNormalが選択されているのを確認します。4.
Applyをクリックします。5.
2番目のポートを選択します。6.
Port Editorダイアログ・ボックスのPort Typeの下で、Coplanarを選択します。7.
Polarityの下で、Reversedを選択します。8.
Associate with port numberの下に、さきほど選択したポートの番号を入力します。9.
Applyをクリックします。10.
回路内の他のコプレナ・ポート対に対して、上記の手順を繰り返します。11.
OKをクリックしてダイアログ・ボックスをクローズします。12.

コモン・モード・ポートの定義

コモン・モード・ポートは、複数のポートで電磁界の極性が同じ（偶数次モードが伝搬する）場合に使用します。これらのポートは同じ絶対電位で励振
され、同じポート番号が割り当てられます。
コモン・モード・ポートは以下の属性を持っています。

ストリップ・レイヤ上のオブジェクトだけに適用できます。
グランド・プレーンまたはその他の無限メタル（カバーなど）がデザインに必要です。
2個以上のポートを関連づけることができます。
関連づけられたポートは、同じ絶対電位（および同じ極性）で励振されます。
ポートは同じ基準面上になければなりません。

注記 コモン・モード・ポートのポート番号は以下のように扱われます。

レイアウト上には、レイアウトにポートを追加したときに各ポートに割り当てられたポート番号（インスタンス名）が引き続き
表示されます。MomentumのPort Editorダイアログ・ボックスを使えば、コモン・モード・ポートとして扱われているポートの
グループがどれかわかります。

また、結果を表示したときに、Sパラメータはコモン・モード・ポート番号に対して表示されます。上の例の場合は、レイアウ
トにはp1、p2、p3が表示されます。Sパラメータの結果は、P1に対してのみ表示されます。

コモン・モード・ポートを定義する手順:

Momentum > Port Editorを選択します。1.
このタイプを割り当てるポートを選択します。ポート番号をメモしておきます。2.
Port Editorダイアログ・ボックスのPort Typeの下で、Common Modeを選択します。3.
Applyをクリックします。4.
2番目のポートを選択します。5.
Port Editorダイアログ・ボックスのPort Typeの下で、Common Modeを選択します。6.
Associate with port numberの下に、最初に選択したポートの番号を入力します。7.
2番目以降のポートに対しては、Associate with port numberフィールドの値がすべて同じでなければなりません。例えば、3個のポートを関連づける場合は、
最初のポートがポート1なら、2番目と3番目のポートのAssociate with port numberフィールドには1を入力します（最初のポートに対しては、このフィールドに
何も入力しません)。
Applyをクリックします。8.
回路内の他のコモン・モード・ポートに対して、上記の手順を繰り返します。9.
OKをクリックしてダイアログ・ボックスをクローズします。10.

グランド基準の定義

グランド基準は、明示的なグランド基準を回路に追加するために使います。 これは、デザインに暗黙のグランドが存在しない場合に必要になること
があります。
暗黙のグランドとは無限遠の電位であり、回路においては、サブストレートの無限メタル・レイヤのうち最も近くにあるものによって実現されます。暗
黙のグランドは、内部ポートや、ストリップ・メタライゼーション・レイヤ上のオブジェクトに接続されたシングルポートと組み合わせて用いられます。
場合によっては、ポートとその暗黙のグランドとの間の電気的な距離が大きすぎるか、サブストレートに無限メタル・レイヤが定義されていない場合
があります。このような場合は、正確なシミュレーション結果を得るには、明示的なグランド基準を追加する必要があります。グランド基準の使用の詳
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細については、内部ポートとグランド基準を使ったシミュレーションを参照してください。

グランド基準は、オブジェクトの表面に適用できます。オブジェクトはストリップ・メタライゼーション・レイヤ上になければなりません。

注記
複数のグランド基準ポートを同じポートに関連付けることができます。シングルポートに関連付ける場合は、グランド
基準ポートはシングルポートと同じ基準面上にあるオブジェクトのエッジに接続されたポートでなければなりません。

グランド基準を追加する手順:

Momentum > Port Editorを選択します。1.
グランド基準として指定するポートを選択します。2.
Port Editorダイアログ・ボックスのPort Typeの下で、Ground Referenceを選択します。3.
Associate with port numberの下に、このグランド基準と対応づけるシングルポートまたは内部ポートの番号を入力します。ポートとグランド基準との電気的な4.
距離が大きすぎないように注意します。
Applyをクリックします。5.

Momentum Port Editor

サブストレートと誘電体レイヤを定義したら、Port Editor（Momentum > Port Editor...）を使用して、レイアウト上のポートのMomentum専用の特性を変
更できます。ポートを編集する手順は、最初の定義を入力したときと同じです。

注記
ポートを選択して、Layoutウィンドウのメニュー・バーからEdit > Propertiesを選択することによりポートの属性を編集
することもできます。 ただし、この方法は推奨しません。

ポート定義の設定の詳細については、以下の該当するセクションを参照してください。
シングルポートの定義

内部ポートの定義

差動ポートの定義

コプレナ・ポートの定義

コモン・モード・ポートの定義

ADS 2006Aでは、Momentum Port Editorにいくつかの新機能が追加されています。

ポート・タイプに関する埋込み情報
ポートの属性のグループ編集

ポート・タイプに関する埋込み情報

Port Editorを起動するには、レイアウトでポートを選択し、ADS LayoutツールバーからMomentum > Port Editorを選択します。下の図のようなPort
Editorツールがオープンします。

下の表は、Port EditorのInfoセクションに固有の情報を示します。

ポート選択 Port Info
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ポート選択なし No ports selected in the layout.

ストリップ・レイヤ上

シングルモード Single Mode strip port

内部 Internal strip port

差動モード Differential Mode strip port

コモン・モード Common Mode strip port

グランド基準 Ground Reference for accociated

スロット・レイヤ上

シングルモード Single Mode slot port

コプレナ・モード Common Mode strip port

ポートの属性のグループ編集

Momentum Port Editorを開始すると、レイアウトでのポート選択を制御するグラフィック・ハンドラがインストールされます。グラフィック・ハンドラは、マ
ウス・トラッキング・スタイルをウィンドウ幅の十字線に変更します。

ADS 2006Aリリースより前には、グラフィック・ハンドラはLayoutウィンドウでマウスを使ってポートを選択するために、シングル・クリック・イベントが実
行されたときだけ起動されていました。このポートは、新しいポートを選択するか、Port Editorダイアログをクローズするまで、編集対象としてアクティ
ブになっていました。このため、一度に選択できるポートは1つだけでした。

ADS 2006Aでは、以下のグラフィック・ハンドラ・オプションを使用することで、複数のポートを同時に選択して編集できるようになりました。

Shift + クリック
Ctrl + クリック
ボタンを押してドラッグ
Shift + ボタンを押してドラッグ
Ctrl + ボタンを押してドラッグ
Shift + クリックおよびCtrl + クリックイベントは、シングル・クリック・イベントに似ていますが、すでに選択されているポートが選択解除されない点が異なりま
す。このため、CtrlまたはShiftボタンを押したまま新しいポートをマウスでクリックし続けることで、複数のポートを選択できます。

ボタンを押してドラッグを使うと、1回のマウス操作で複数のポートを選択できます。ボタンを押してドラッグ操作の間は、マウス・トラッキング・スタイル
がウィンドウ幅の十字線からラバーバンド長方形に変わります。
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ボタンを押してドラッグ操作を終了すると、ラバーバンド長方形の内部にあるすべてのポートが属性編集の対象として選択されます。新たにボタンを
押してドラッグ操作を開始すると、前に選択したポートはすべて自動的に選択解除されます。

Shift + ボタンを押してドラッグおよびCtrl + ボタンを押してドラッグイベントは、ボタンを押してドラッグ・イベントに似ていますが、すでに選択されてい
るポートが選択解除されない点が異なります。このため、CtrlまたはShiftボタンを押したままマウスのプレス・アンド・ドラッグ・イベントを繰り返すこと
により、複数のポートを選択できます。

Port Editorダイアログには複数ポート選択に関するフィードバックが表示されます。

ユーザがグループ編集の対象として複数のポートを選択すると、選択した中で最もポート番号が大きいポートの属性がダイアログに表示されます。
ユーザはこれらの属性を編集してから、選択したすべてのポートに適用できます。ユーザがApplyボタンを選択すると、ダイアログで定義された属性
が選択したすべてのポートに適用されます。

ポートのグループ編集は、以下の場合を除くすべてのポート・タイプに対して実行できます。

ストリップ・レイヤ上の差動ポート
スロット・レイヤ上のコプレナ・ポート
差動ポートまたはコプレナ・ポートの各ピンは極性が異なる必要があるため、これらのポート・タイプは各ポートに対して個別に定義する必要があります。差
動モードまたはコプレナ・モードのポート・タイプを、選択した複数のポートに適用しようとした場合は、無効な操作であることを示す警告が表示されます。これ
らのポート・タイプの正しい使用モデルがWarningダイアログに表示されます。

ポートのグループ編集は、同じプロセス・レイヤ・タイプ（STRIPまたはSLOT）を持つポートに対してのみ使用できます。STRIPレイヤとSLOTレイヤ上のポート
を同時に選択した場合は、選択した中でポート番号が最も大きいポートと同じプロセス・レイヤ・タイプを持つポートに対してだけグループ編集を実行できま
す。
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STRIPレイヤとSLOTレイヤのポートを同時に選択しようとした場合は、互換性のあるプロセス・レイヤ・タイプのポートだけが選択できるという警告ダイアログ
が表示されます。

互換性のないプロセス・レイヤ・タイプのポートは自動的に選択解除されます。

ポート番号の再マッピング

デザインによっては、ポート番号が連続していないものがあります。このような場合は、作成されるシミュレーション・データ・ファイルが使いにくくなり
ます。Momentumが連続しないポート番号を持つデザインをシミュレートした場合は、結果のデータ・ファイルではポートは連続する番号に再マッピン
グされます。最小のポート番号が1に再マッピングされ、残りの番号は連続する番号に再マッピングされます。デザイン自体のポート番号は変更され
ません。Statusウィンドウに変更を示すメッセージが表示され、マッピングの一覧が示されます。

例えば、ポート番号37と101を持つデザインをシミュレートした場合は、以下のステータス・メッセージによって変更が示されます。

Layout has non-consecutive port numbers.

Output files will have consecutive port numbers.

layout port -> output port

37 -> 1

101 -> 2

ポート番号の再マッピングは、サンプルおよびAFS CITIfileとそれらに対応するSパラメータ・データセットに対してだけ行われます。Visualizationおよ
び遠方界ファイルに対しては行われません。再マッピングはCITIfileレベルで行われ、データセット・ファイルに伝搬します。再マッピングの後では、す
べてのデータセットが新しいポート番号に同期します。
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ボックスと導波管
回路のサブストレート定義を(Momentum > Substrateメニューで)指定した場合は、サブストレートの垂直方向の寸法だけを指定していて、水平方向
の寸法は指定していません。この定義では、サブストレート・レイヤは水平方向に無限に延びることになります。これがシミュレーション結果に影響し
ない回路デザインもあります。しかし、水平方向の境界を設定しなければならない場合も数多くあります。このような場合は、ボックスまたは導波管を
使います。

ボックスと導波管は、水平方向のサブストレート境界を指定するためのものです。ボックスを使うと、サブストレートの4辺に境界を指定できます。導
波管では2辺に境界を指定できます。

具体的には、ボックスの場合は、4つの垂直な完全メタルの平面をサブストレートの水平方向の境界として定義します。Z軸に沿って上から回路を見
ると、これら4つの垂直平面(壁)によって長方形が構成されています。ボックスが使用できるのは、サブストレート定義のトップ・レイヤとボトム・レイヤ
がグランド・プレーンかインピーダンス終端の場合に限られます。このため、4つの垂直のメタル壁と、トップとボトムのグランド・プレーンによって「ボッ
クス」が構成されています(壁がボックスの側面、トップとボトムのグランド・プレーンが蓋と底)。

導波管もこれに似ていますが、2つの平行な壁だけを指定します。したがって、これらの壁に垂直な方向にのみサブストレートの水平方向の境界が
設定されます。壁に平行な方向には、サブストレートは無限に延びています。サブストレートのトップ・レイヤとボトム・レイヤは、やはりグランド・プレ
ーンとして定義されている必要があります。2つの側面と上下のカバーによって導波管が構成されています。

以下のセクションでは、ボックスや導波管を回路に適用する方法を説明します。これらのアイテムのアプリケーションの詳細については、ボックスと導
波管についてを参照してください。

ボックスの追加

ボックスは、回路サブストレートの4辺の境界を定義します。1つの回路に同時に適用できるのは、ボックス1つまたは導波管1つだけです。ボックスが
回路に適用できるのは、サブストレート定義のトップ・レイヤとボトム・レイヤがグランド・プレーンかインピーダンス終端の場合に限られます。ボックス
の壁は完全メタルです。グランド・プレーンは、完全メタルとしても損失のあるメタルとしても定義できます。

回路にボックスを追加すると、回路をメタルで囲んだ場合の効果を解析できます。 例えば、ボックス共振の検査が可能です。ボックス共振は、共振
周波数近傍の狭い帯域で、Sパラメータに大きな影響を与えることがあります。シミュレーション実行時に、共振周波数と、なめらかなSパラメータが
計算できない周波数バンドがステータス・ウィンドウに表示されます。

シミュレーション中は、ボックスの側面のすべての電流の向きが考慮されます。

注記
回路内の校正済みポート（シングル、差動、コプレナ、コモン・モード・ポート）は、ボックスのエッジ上にエッジに垂直
に配置されている必要があります。そうでないと、エラーが発生します。内部（未校正）ポートは、回路内の任意の場
所に任意の向きで配置できます。

ボックスを追加する手順:
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Momentum > Box-Waveguide > Add Boxを選択します。1.
以下のどちらかの方法でボックスを挿入します。2.

ボックスの一方のコーナの位置にマウスを置いて、クリックします。反対側のコーナの位置にマウスを移動してクリックします。
Layoutウィドウのメニュー・バーでInsert > Coordinate Entryを選択し、Coordinate Entry XフィールドにボックスのコーナのX座標を、Coordinate Entry YフィールドにY座標を入力しま
す。Applyをクリックします。反対側のコーナの座標を入力してApplyをクリックします。Cancelをクリックしてダイアログ・ボックスをクローズします。

これで、レイアウトにボックスが表示されます。

ボックスの編集

ボックスを適用した後に寸法を変更することはできません。大きさを変えたい場合は、削除して新しいものを追加します。

ボックスの削除

ボックスを削除する手順:

Momentum > Box-Waveguide > Delete Boxを選択します。1.
レイアウトからボックスが削除されます。

ボックスのレイアウト・レイヤ設定の表示

ボックスは、momentum_boxという名前のレイアウト・レイヤとして定義されています。レイアウト・レイヤの設定を見ることはできますが、保護されたレ
イヤなので、設定を変更することは避けてください。
ボックスのレイヤ仕様を表示する手順:

Options > Layersを選択します。1.
Layersリストでmomentum_boxを選択します。レイヤ設定が表示されます。これらのパラメータの詳細については、『Schematic Capture and Layout』マニュア2.
ルを参照してください。
Cancelをクリックしてダイアログ・ボックスをクローズします。3.

導波管の追加

導波管は、回路サブストレートの平行な2辺の境界を定義します。1つの回路に同時に適用できるのは、ボックス1つまたは導波管1つだけです。導波
管が回路に適用できるのは、サブストレート定義のトップ・レイヤとボトム・レイヤがグランド・プレーンかインピーダンス終端の場合に限ります。導波
管の壁は完全メタルです。グランド・プレーンは、完全メタルとしても損失のあるメタルとしても定義できます。

シミュレーション中には、導波管の側面のすべての電流の向きが考慮されます。
導波管を追加する手順:

Momentum > Box-Waveguide > Add Waveguideを選択します。1.
導波管の向きを選択します。X軸に平行な導波管を挿入するには、X-axisをクリックします。Y軸に平行な導波管を挿入するには、Y-axisをクリックします。2.
以下のどちらかの方法で導波管を挿入します。3.

導波管の一方の壁の位置にマウスを置いて、クリックします。反対側の壁の位置にマウスを移動してクリックします。
Layoutウィドウのメニュー・バーでInsert > Coordinate Entryを選択し、Coordinate Entry Xフィールドにサブストレートのエッジ上のポイントのX座標を、Coordinate Entry YフィールドにY
座標を入力します。Applyをクリックします。反対側の平行エッジ上のポイントの座標を入力してApplyをクリックします。Cancelをクリックしてダイアログ・ボックスをクローズします。

これらの境界によって、サブストレートのエッジと、導波管の幅が決まります。

導波管の編集

導波管を適用した後に寸法を変更することはできません。大きさを変更したい場合、削除して新しいものを追加します。

導波管の削除

導波管を削除する手順:

Momentum > Box-Waveguide > Delete Waveguideを選択します。1.
レイアウトから導波管が削除されます。

導波管のレイアウト・レイヤ設定の表示

導波管は、momentum_boxという名前のレイアウト・レイヤとして定義されています。レイアウト・レイヤの設定を見ることはできますが、保護されたレ
イヤなので、設定を変更することは避けてください。

導波管のレイヤ仕様を表示する手順:

Options > Layersを選択します。1.
Layersリストでmomentum_boxを選択します。レイヤ設定が表示されます。これらのパラメータの詳細については、『Schematic Capture and Layout』マニュア2.
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ルを参照してください。
Cancelをクリックしてダイアログ・ボックスをクローズします。3.

ボックスと導波管について

ボックスや導波管で回路を囲んでシミュレートするのには、さまざまな理由があります。

実際の回路がメタルのボックスに囲まれている。
近くにあるメタルの側面が回路の動作に影響する可能性がある。
ボックスが共振する可能性がある。
伝搬モードが存在する可能性がある。
以下にこれらの場合について説明します。

メタルの筺体に囲まれた回路は数多く存在します。デザインにボックスを追加することにより、実際のストラクチャに存在するメタル側面をシミュレー
ションで考慮できます。回路の動作に側面が直接の影響を与えるおそれがある場合に便利です。例えば、「広結合フィルタ(broad-coupled filter)」は
メタルの筺体(ボックス)に入っていて、側面がフィルタ特性に大きな影響を与える可能性があります。

実際のストラクチャにメタル側面が存在し、これが回路の特性に影響を与える可能性がある場合は、ボックスまたは導波管を使います。この影響は
不要な寄生効果です。回路のデザインで側面の影響を考慮していない場合は、影響があるかどうかを検証できます。ほとんどの場合、側面が実際
の回路に非常に近くなければ、シミュレーション結果への影響はわずかです。ただし、一部の特殊な例では、側面のあるストラクチャに固有の重要な
現象が生じます。

ボックスの場合、ボックス共振が発生します。ボックス共振とは、ある周波数とボックス・サイズの組み合わせで、実際にボックスがある周波数で共
振を始める物理現象です。この現象が起きると、共振周波数近傍の狭い帯域で、Sパラメータに重大な影響が生じます。 この影響は、なめらかな関
数では表現できません。このため、この周波数帯域ではなめらかな適応Sパラメータが得られなくなります。このような回路をシミュレートする場合
は、Momentumは、ボックス共振周波数、なめらかなSパラメータが得られない周波数バンド、Q値(ボックス共振の鋭さの指標で、損失に依存)に関す
る情報を表示します。

導波管の場合は?、これにあたる現象は導波管モードの励起です。側面の近くに回路を配置する場合は、導波管を追加することにより、回路の動作
に側面が影響するかどうかを確認すべきです。

場合によっては、ストラクチャにメタルの側面はないが、他の材料による境界がサブストレート定義に存在する場合があります(例えば、有限サイズ
のサブストレートで、誘電体が突然途切れ、誘電体と空気の遷移が存在する場合)。Momentumのボックスと導波管は完全メタルとして定義され、誘
電体ではありませんが、メタル筺体を定義する方が何も筺体を定義しないよりも実際のストラクチャをより良く表現できる場合があります。

カバーの下に吸収レイヤを追加

カバーとレイアウトの間に吸収レイヤを持つようにボックスや導波管をモデリングしたい場合があります。この場合は、サブストレート・インタフェース・
レイヤを使い、厚さを定義し、吸収特性をεとμで指定します（εとμはこのレイヤの特性を正確に記述するものでなければなりません)。吸収レイヤ
をボックスに追加すると、ボックス共振が発生した場合に、共振を弱める効果があります。 すなわち、ボックス共振のQ値が大幅に小さくなります。

ボックス、導波管と放射パターン

ボックスや導波管に囲まれたストラクチャに対して、シミュレーション後に放射パターンを計算する場合は、トップ・プレーンとボトム・プレーンを376Ω
から378Ω間の値に設定する必要があります。 その他にも考慮すべき点があります。詳細については、377Ω終端と放射パターンを参照してくださ
い。

メッシュ
メッシュとは三角形と長方形からなる格子状のパターンであり、それぞれの三角形や長方形をセルと呼びます。セルのパターンは、回路の形状と、
ユーザ定義のパラメータによって決まります。 したがって、それぞれの回路に固有のメッシュが計算されます。メッシュの役割は、シミュレーション中
に各セルの電流を計算し、回路内に存在するカップリング効果を求めることです。この計算結果から、回路のSパラメータが求められます。次に示す

のは、ダブル・パッチのサンプルに対して計算されたメッシュです。 

メッシュの作成には、2つのステップがあります。

メッシュ・パラメータの定義
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メッシュの事前計算
メッシュ・パラメータの設定は必須ではありません。 設定しなければデフォルトのパラメータが用いられます。シミュレーションの前にメッシュを事前計算する
と、メッシュを確認できます。 事前計算しない場合、シミュレーション・プロセスの一部としてメッシュが計算されます。シミュレーションにはメッシュが必要で
す。

この章では、メッシュ・パラメータの定義とメッシュ計算の方法を説明します。メッシュ・ジェネレータの仕組みと、各種のアプリケーションに対するメッ
シュ・パラメータ設定の指針についても述べます。

メッシュの定義

メッシュ・パラメータを設定するには、Momentum > Mesh > Setupを選択します。 これにより、メッシュの作成に用いられるセル数を調整できます。セ
ル数が多いほどシミュレーションは正確になりますが、多すぎるとシミュレーション速度が低下し、精度の向上もほとんど見られなくなります。メッシュ
・パラメータを指定しなければ、デフォルト値を使ってメッシュが作成されます。

メッシュ・パラメータを設定する場合、以下の対象を選択できます。

回路全体
1つのレイアウト・レイヤ上のオブジェクト
1つのオブジェクト
すべてのレベルでパラメータを指定する必要はありません。例えば、1つのオブジェクトに対してだけメッシュ・パラメータを指定し、回路の残りの部分に対して
はデフォルト値を使うこともできます。

メッシュの生成方法の詳細については、メッシュ・ジェネレータを参照してください。メッシュ・パラメータの設定の際のヒントについては、メッシングの
指針を参照してください。

メッシュ・パラメータを設定する手順を以下に示します。

回路全体に対するメッシュ・パラメータの定義

グローバル・メッシュ・パラメータは、回路全体に影響します。グローバル・パラメータを設定する手順は以下のとおりです。

Momentum > Mesh > Setupを選択します。1.
グローバル・パラメータが表示されます。2.
Mesh Frequencyフィールドにメッシュ周波数を入力し、単位を選択します。この周波数の波長を使って、メッシュの密度が決められます。一般には、シミュレー3.
ションの最高周波数に設定します。詳細については、メッシュ密度の調整を参照してください。
Number of Cells per Wavelength(1波長あたりのセル数)を入力します。この値も、メッシュの密度を決めるために用いられます。この値と波長との関係を以下4.
の例で説明します。

回路の長さが3波長で、1波長あたりのセル数が20の場合は、回路の長さが60セルに分割されます。詳細については、メッシュ密度の調整を参照してくだ
さい。

回路内の曲線部分は、ファセットを使ってメッシュ化されます。Arc Facet Angle(円弧ファセット角)フィールドに、1つのファセットの度数を入力します。最大値は5.
1ファセットあたり45°です。値を小さくすると、分解能が上がり、メッシュの密度が高くなります。最小値は、オブジェクトのドローイング時に設定された
Arc/Circle Resolution(円弧/円分解能)と同じです。詳細については、オブジェクトのオーバラップの処理を参照してください。

Edge Meshをオンにすると、オブジェクトのエッジ部分に相対的に高密度のメッシュが用いられます。電流の大部分はオブジェクトのエッジに沿って流れるの6.
で、エッジ・メッシュを使うとシミュレーションの精度と速度を改善できることがあります。
エッジ・メッシュのサイズを自動的に決定するには、Edge Widthフィールドを空白にしておきます。サイズを設定するには、エッジ幅を指定し、単位を選択しま
す。エッジ・メッシュの詳細については、エッジ・メッシュについてを参照してください。

注記
wavelength/number_of_cells_wavelengthで設定されたセル・サイズよりも大きい幅に指定されたエッジ・メッシュは
無視されます。このようなエッジ・メッシュは非常に効率が悪いからです。ただし、そのエッジ・メッシュの値を使用
しなければならない場合は、Number of Cells per Wavelengthフィールドで指定するnumber_of_cells_wavelengthの
値を小さくしてください。

Transmission Line Meshをオンにすると、形状の幅方向のセル数を指定できます。直線形状の回路の場合に役立ちます。7.
幅方向のセル数を、Number of Cells Wideフィールドに入力します。回路の幅がこの数のセルに分割されます。伝送ライン・メッシュの詳細については、伝送
ライン・メッシュについてを参照してください。
Layout Healingをオンにすると、レイアウト内の不要な小さいエラーや小さいギャップを自動的に無視できます。これにより、メッシュの品質を改善できます。オ8.
ンにした場合、スナップ距離以内にある点やラインは結合されます。Snap Distanceフィールドに値が指定されていない場合、またはこの値が0の場合は、自
動設定が選択されていれば、安全な見積りが用いられます。
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注意
スナップ距離を指定する場合は、その値は関連するレイアウト特性の幅に比べて小さい必要があります。そうで
ないと、メッシュで特性が無視されてしまいます。

 

注記
レイアウト修復が実際のレイアウト変更を実行する場合は、ステータス・ウィンドウに警告が表示され、変更の詳
細がメッシュ・レポートに書き込まれます。変更を確認するにはメッシュ・レポートを参照してください。

Thin layer overlap extractionをオンにすると、以下の場合にオブジェクトを抽出できます。9.
異なるレイヤ上にある2個のオブジェクトが重なっている。
オブジェクトの間に薄いサブストレート・レイヤがある。
このオプションをオンにすると、重なった領域に対してより正確なモデルが生成できるように形状が変更されます。詳細については、オブジェクトのオーバラップの処理を参照してくださ
い。

注記
薄膜キャパシタのモデリングでは、このオプションを必ずオンにしてください。

最適なメッシュを実現して、セルの数を減らし、メモリ使用効率とシミュレーション時間を改善するには、Mesh reductionをオンにします。メッシュ・リダクション10.
の詳細については、シミュレーション精度に対するメッシュ・リダクションの影響を参照してください。
厚膜導体に対する側面電流の影響を考慮するには、*Horizontal side currents (thick conductors)*をオンにします。この機能をオンにすると、側面の水平電11.
流を使用することにより、厚膜導体のモデリングが改善されます。この機能には以下の特長があります。

グローバル・メッシュ・オプションがオンになっている場合は、側面のエッジ・メッシュを自動的に使用します(6を参照)。
幅/厚さのアスペクト比が1.0以下の厚膜導体に対して精度が向上します。
グリーン関数に対する新しい再構成テクノロジーを使用しているので、サブストレート・データベースの再計算が不要です。
Momentum > Post-Processing > Visualizationを選択すると、ポスト・プロセッシングで視覚化できます。

注記
最高のシミュレーション性能を得るためには、拡張されたレイヤにはエッジ・メッシュを使用しないことをお勧めし
ます。このためには、Globalタブで"Edge Mesh"ボックスのチェックを外します。個々のレイヤに対してエッジ・メッ
シュが必要な場合は、Layerタブで特定のレイヤに対してエッジ・メッシュを設定します。エッジ・メッシュと水平側
面電流の組合わせを使用する必要があるのは、きわめて高い周波数を使用するシミュレーションか、隣接する
導体の間に非常に大きな結合が存在する場合だけです。
Horizontal side currentオプションをオフにした場合は、メッシングは厚膜導体に対する前のモデル(側壁の垂直
電流だけを使用)に戻ります。

パラメータをデフォルト値に戻すには、Resetをクリックします。12.
OKをクリックして、グローバル・メッシュ・パラメータを確定します。13.

Global Mesh Controlダイアログ・ボックス
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レイアウト・レイヤに対するメッシュ・パラメータの定義

1つのレイアウト・レイヤ上のオブジェクトだけに影響するメッシュ・パラメータを定義できます。グローバル・パラメータが設定されていても、レイアウト
・レイヤに対してメッシュ・パラメータが定義されている部分には用いられません。

レイアウト・レイヤ・パラメータを設定する手順:

Momentum > Mesh > Setupを選択します。1.
Layerタブをクリックします。2.
Layout Layerリストで、メッシュ・パラメータを設定するメタライゼーション・レイヤを選択します。3.
Mesh Density - cells/wavelengthを入力します。この値は、Frequencyフィールドに指定された周波数の波長とともに、メッシュの密度を決めるために用いられ4.
ます(周波数はグローバル・パラメータ)。

この値と波長との関係を例を使って説明します。このレイヤ上にある回路の一部の長さが2波長で、1波長あたりのセル数が20の場合は、このレイヤ上の
回路の長さが40セルに分割されます。詳細については、メッシュ密度の調整を参照してください。

Edge Meshをオンにすると、このレイヤ上のオブジェクトのエッジ部分に相対的に高密度のメッシュが用いられます。電流の大部分はオブジェクトのエッジに沿5.
って流れるので、エッジ・メッシュを使うとシミュレーションの精度と速度を改善できる場合があります。

エッジ・メッシュのサイズを自動的に決定するには、Edge Widthフィールドを空白にしておきます。サイズを設定するには、エッジ幅を指定し、単位を選択し
ます。エッジ・メッシュの詳細については、エッジ・メッシュについてを参照してください。

Transmission Line Meshをオンにすると、このレイヤ上の形状の幅方向のセル数を指定できます。直線形状の回路の場合に役立ちます。6.

幅方向のセル数を、Number of Cells Wideフィールドに入力します。このレイヤ上の回路の幅がこの数のセルに分割されます。伝送ライン・メッシュの詳細
については、伝送ライン・メッシュについてを参照してください。

選択したレイヤの設定を変更したい場合は、Resetをクリックしてデフォルト値に戻すか、Clearをクリックして設定を消去します。7.
別のレイヤを選択して、同じ手順でメッシュ・パラメータを設定します。8.
OKをクリックして、選択したレイヤのメッシュ・パラメータを確定します。9.

オブジェクトに対するメッシュ・パラメータの定義

1個のオブジェクトだけに影響するメッシュ・パラメータを定義できます。グローバル・パラメータやレイアウト・レイヤ・パラメータが設定されていても、
オブジェクトに対してメッシュ・パラメータが定義されている部分には用いられません。
オブジェクト・パラメータを設定する手順:

Momentum > Mesh > Setupを選択します。1.
Primitiveタブをクリックします。2.
Layoutウィンドウで、メッシュ・パラメータを指定するオブジェクトを選択します。3.
Mesh Density - cells/wavelengthを入力します。この値は、Frequencyフィールドに指定された周波数の波長とともに、メッシュの密度を決めるために用いられ4.
ます(周波数はグローバル・パラメータ)。

この値と波長との関係を例を使って説明します。オブジェクトの長さが1/2波長で、1波長あたりのセル数が20の場合は、オブジェクトの長さが10セルに分
割されます。詳細については、メッシュ密度の調整を参照してください。

Edge Meshをオンにすると、オブジェクトのエッジ部分に相対的に高密度のメッシュが用いられます。電流の大部分はオブジェクトのエッジに沿って流れるの5.
で、エッジ・メッシュを使うとシミュレーションの精度と速度を改善できることがあります。

エッジ・メッシュのサイズを自動的に決定するには、Edge Widthフィールドを空白にしておきます。サイズを設定するには、エッジ幅を指定し、単位を選択し
ます。エッジ・メッシュの詳細については、エッジ・メッシュについてを参照してください。

Transmission Line Meshをオンにすると、オブジェクトの幅方向のセル数を指定できます。直線形状の回路の場合に役立ちます。6.

幅方向のセル数を、Number of Cells Wideフィールドに入力します。オブジェクトの幅がこの数のセルに分割されます。伝送ライン・メッシュの詳細について
は、伝送ライン・メッシュについてを参照してください。

選択したオブジェクトの設定を変更したい場合は、Resetをクリックしてデフォルト値に戻すか、Clearをクリックして設定を消去します。7.
別のオブジェクトを選択して、同じ手順でメッシュ・パラメータを設定します。8.
OKをクリックして、選択したオブジェクトのメッシュ・パラメータを確定します。9.

オブジェクトのシード設定

大部分の回路に対して、オブジェクトのシード設定は不要です。 また、シード設定をすると内部のメッシュ・プロセスがすべてスキップされるので、推
奨しません。オブジェクトに対して誤ったシード設定をすると、非効率なメッシュが生じ、シミュレーションの速度と精度が低下します。このメッシング機
能を効率的に使うには、電磁気学と計算幾何学に対する十分な理解が必要です。

プリミティブ・シードを使うと、形状に適用するセル数を厳密に指定できます。

OU軸に沿った水平方向
ポイントVからOU軸への垂直方向

以下の例は、OU軸の位置と、OUに対するポイントVの位置を、単純な形状について示したものです。オブジェクト・シード設定の有無に関わらず、正
しいメッシュ生成のためにはOVがOUに垂直でなければなりません。このメッシュは、OU軸方向に3セル、高さ方向に5セルと定義されています。
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プリミティブ・シードを設定する手順:

メッシュ座標の入力方法を決定します。以下の方法が使用できます。1.
Coordinate Entryダイアログ・ボックスに座標を直接入力します。
Layoutウィンドウでオブジェクトをクリックして座標を選択します。
オブジェクト上で座標を選択する場合は、頂点スナップ・モードがオンになっていることを確認し、他のスナップ・モードも確認して、メッシュを確実にストラクチャに合わせます。座標を
選択するときにスナップ・モードがオンになっていると、オンになっているスナップ・モードを満たす最も近いポイントにスナップします。このため、頂点スナップ以外のスナップ・モードが
オンになっていると、メッシュをオブジェクトに合わせるのが困難になるおそれがあります。スナップ・モードの設定は、LayoutウィンドウのOptionsメニューにあります。

レイアウトにメッシュが表示されている場合は、Momentum > Mesh > Clearを選択します。2.
Momentum > Mesh > Setupを選択します。3.
Primitive Seedタブをクリックします。4.
Layoutウィンドウで、シード設定するオブジェクトを選択します。必要ならズーム・インします。5.
OU軸を指定します。この軸がメッシュの向きを決定します。軸の選択には、次のどちらかの方法を使います。6.

OU軸の原点にマウスを置いてクリックします。軸の終点までマウスを動かしてもう一度クリックします。
Layoutウィドウのメニュー・バーでInsert > Coordinate Entryを選択し、Coordinate Entry XフィールドとCoordinate Entry YフィールドでOU軸の原点を指定します。Applyをクリックしま
す。軸の終点の座標を入力して、Applyをクリックします。

Primitive Mesh Controlダイアログ・ボックスが表示されます。OU軸方向のセル数を入力します。7.
ポイントVを指定します。 OVがOUに垂直になるように指定する必要があります。ポイントの選択には、以下のどちらかの方法を使います。8.

ポイントにマウスを置いてクリックします。
Layoutウィドウのメニュー・バーでInsert > Coordinate Entryを選択し、Coordinate Entry XフィールドとCoordinate Entry YフィールドでポイントVの座標を指定します。Applyをクリックし
ます。

Primitive Mesh Controlダイアログ・ボックスが表示されます。OVライン方向のセル数を入力します。9.
シード設定されたオブジェクトに対して次の情報が表示されます。10.

オブジェクトが存在するレイアウト・レイヤの番号と名前。
シード設定されたオブジェクトを記述するデータ。 オブジェクトのタイプ(パス、多角形など)や座標など。
OU軸とx軸との角度。
OU軸方向のセルの長さ(OUの距離をセル数で割ったもの)。
OV方向のセルの長さ(OVの距離をセル数で割ったもの)。
以下に例を示します。

選択したオブジェクトの設定を変更したい場合は、Clearをクリックして設定を消去します。11.
OKをクリックしてコマンドを終了します。12.
次の図では、OU軸が多角形の底辺に沿って配置され、長さは多角形の長さと同じです。軸方向のセル数は3に設定されています。OUからVまでのセル数は
5に設定されています。この設定から得られたメッシュが示されています。回路の他の部分に対しては、設定済みのメッシュ・パラメータが用いられます。



Advanced Design Systemドキュメント

92

メッシュの接続性

オブジェクトにシード設定した場合は、グローバル、レイアウト・レイヤ、オブジェクトのいずれかのメッシュ・パラメータが設定されていても、そのオブ
ジェクトに対してはこれらのパラメータは用いられません。また、正確な結果を得るには、回路全体にわたってメッシュ・セルが正しく接続されていな
ければなりません。これをメッシュの接続性といいます。メッシュの接続性を確保するために、シード設定された領域の境界が変形される場合があり
ます。これを修正するには、隣接するオブジェクトのシード設定を変更するしかありません。1つのオブジェクトにシード設定をすると、回路全体のシー
ド設定が必要になる場合があります。

接続性を確保するためにどのセルが変更されるかは、作成されるメッシュの未知数の数ができるだけ少なくなるように決定されます。

メッシュ・パラメータのリセットとクリア

メッシュ・パラメータの設定を変更するには、以下の方法があります。

個々のパラメータを変更する。
メッシュ・パラメータの値をまとめて消去する。
メッシュ・パラメータをデフォルト値にリセットする。
メッシュ・パラメータをリセットまたはクリアする手順:

Momentum > Mesh > Setupを選択します。1.
消去またはリセットするパラメータに応じて、Global、Layout、Primitive、Primitive Seedのどれかのタブを選択します。2.
以下のどちらかを実行します。3.

レイアウト・パラメータの場合は、レイアウト・レイヤ名を選択します。
オブジェクト・メッシュ・パラメータまたはシード設定の場合は、Layoutウィンドウでオブジェクトを選択します。
 

ヒント
レイアウトからメッシュをクリアするとオブジェクトが選択しやすくなります。

設定を消去するにはClearを、デフォルト値に戻すにはResetをクリックします。4.

注記
オブジェクトを選択するのが困難な場合は、ダイアログ・ボックスをクローズし、オブジェクトを選択してから、もう一
度ダイアログ・ボックスをオープンします。

メッシュの事前計算

注記
メッシュを計算するには、あらかじめサブストレートを事前計算し、回路にポートを適用しておく必要があります。サ
ブストレートを事前計算する方法については、サブストレートを参照してください。ポートを適用する方法について
は、回路へのポートの追加およびポートを参照してください。

Momentum > Mesh > Precomputeを選択すると、メッシュが計算されます。指定した周波数とユーザ定義のメッシュ・パラメータを使って、長方形と三
角形のパターンが計算され、回路に適用されます。シミュレーション中に、各セル内の表面電流が計算され、その結果を使ってストラクチャのSパラメ
ータが求められます。

メッシュを事前計算する手順:

Momentum > Mesh > Precomputeを選択します。1.
Precompute Meshダイアログ・ボックスで、メッシュの事前計算に使用する周波数を入力します。この周波数の波長が、メッシュ内のセル数を決定するために2.
用いられます。メッシュ計算の詳細については、メッシュ・ジェネレータを参照してください。
OKをクリックするとメッシュ計算が始まります。3.

計算が終了すると、レイアウトにメッシュが表示されます。

メッシュ・ステータスの表示

メッシュ計算開始後に、計算に関するメッセージがMomentum Statusウィンドウに表示されます。通常は、エラーまたは警告が生成された場合と、計
算が終了したときにメッセージが出ます。

ステータス・ウィンドウをクローズした場合は、再オープンするには、Layoutメニュー・バーでWindow > Restore Statusを選択します。

メッシュ計算の停止

メッシュ・プロセスを停止する手順:
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Momentum Statusウィンドウで、Simulation/Synthesis > Stop Simulationを選択します。1.
メッシュ計算が停止し、情報は保存されません。

メッシュ・サマリの表示

メッシュ計算が成功したら、メッシュ統計情報を表示することができます。以下のような情報が得られます。

ストラクチャ内の長方形セルの数
三角形セルの数
ビアのモデリングに用いられた垂直長方形セルの数
未知電流の数
使用リソースと計算時間
セル数と未知電流の数は、シミュレーション時間に影響します。セル数が多いほど、メッシュは高密度になり、シミュレーションに時間がかかります。未知電流
は、シミュレータが解くマトリクス方程式の変数に対応します。未知電流の数が多いほど、マトリクスは大きくなり、シミュレーション時間が長くなります。ストラ
クチャの計算に必要なメモリも増えます。
メッシュ統計の例を以下に示します。

メッシュ・レポートの表示

メッシュ・レポートは、Momentum Statusウィンドウに表示されるポートと分解能に関する一部の警告に関する詳細情報を提供します。また、未接続
のビア(両方で接続されていないビア)に関する情報も提供します。

メッシュ・レポートを表示する手順:

Momentum > Mesh > Show Reportを選択します。1.

メッシュのクリア

回路からメッシュの表示を削除できます。メッシュをクリアすると、Layoutウィンドウの表示だけがクリアされます。 メッシュ計算の結果は削除されま
せん。

画面からメッシュを削除する手順:

Momentum > Mesh > Clearを選択します。1.
メッシュを再表示したいときは、Edit > Undoを選択します。これ以外にメッシュを再表示する方法としては、再計算しかありません。2.

メッシュ・ジェネレータ

メッシュ・ジェネレータとは、回路形状をセル(長方形と三角形)に分割するアルゴリズムです。Mesh Reductionオプションが選択されている場合は、メ
ッシュが自動的に削減されて、低品質の小さいセルや電磁気学的に冗長なセルが削除され、多角形のセルから構成されるメッシュになります。表面
を離散化することにより、任意の変動する表面電流を線形近似で計算できます。線形近似とは、セルに対してRooftop関数を適用することです。線形
近似が実際の電流に近くなるほど、結果が正確になります。このため、メッシュの密度が高い方がマイクロ波周波数で一般に良い結果が得られま
す。

メッシュ・ジェネレータは、最少のセル数で正確なシミュレーション結果が得られるように、最適なセル・パターンを探索します。Momentumモードでは、
最少のセル数はかなり大きくなり、高密度のメッシュが生じます。メッシュ・リダクション・テクノロジーを使用すると、与えられたメッシュ密度に対して大
幅にセル数が少ない最適なメッシュが得られ、使用メモリとシミュレーション時間を削減して、シミュレーション性能を改善できます。シミュレーションで
はすべてのセルの電流が計算されるので、メッシュの密度が高すぎるとシミュレーション時間が長くなります。

指定したメッシュ・パラメータは、さまざまな形と大きさのセルに形状を分割するのに必要な情報をメッシュ・ジェネレータに伝える役割を果たします。
メッシュ・パラメータを設定しないと、デフォルト・パラメータが用いられます。Momentumモードでは、デフォルトのメッシュ設定は30セル/波長で、エッ
ジ・メッシュが使用されます。RFモードでは、デフォルトのメッシュ設定は20セル/波長で、エッジ・メッシュは使用されません。RFモードはMWモードに
比べると近似なので、RFモードでの小さい設定は、精度と効率のトレードオフを考慮したよりよいデフォルト値なのです。

メッシュ密度の調整
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メッシュ密度の決定には、Mesh Frequencyとcells/wavelengthの2つのメッシュ・パラメータの組み合わせが用いられます。

周波数に対応する波長を使って、Rooftop基底関数とも呼ばれるリニア関数が近似されます。周波数が高いほど、ストラクチャ全体に対して多くの波
長が適合します。cells/wavelengthは、各波長に対してフィッティングさせる最少のセル数を表します。セル数が多いほど、正弦波がより正しく表現さ
れ、シミュレーションが正確になります。例えば、1波長あたり30セルに指定した場合は、正弦波と線形近似との最大偏差は1%程度です。これらのパ
ラメータは、縦方向の電流に影響します。

高い周波数を指定すると、メッシュのセル数が増えます(密度が上がります)。同様に、1波長あたりの最少セル数を増やしても密度が上がります。一
般に、密度を最適化するには、メッシュ周波数を上げるよりも1波長あたりのセル数を増やす方が適しています。メッシュ周波数の最適値は、シミュレ
ーションの最高周波数です。これにより、サブストレートの周波数帯域が不足することによる再計算を避けられる可能性があります。

レイアウトにシード設定をした後でメッシュ周波数を入力した場合は、システムは入力した周波数を無視し、回路の残りの部分に対してメッシュを計
算するときにだけメッシュ周波数を使用します。

1波長あたりのセル数に入力する値は下限値であり、メッシュ・ジェネレータが使用する正確な値ではないことに注意してください。メッシュ・ジェネレ
ータが実際に使用するセル数がこれより大きくなる場合がある理由を以下で説明します。例えば、Cells per Wavelengthに20を入力したとします。一
般的に、形状が無限大のときに用いられるセル・サイズは、1波長あたりのセル数に対応します。しかし、他の細部、エッジ、ユーザ定義メッシュ設定

を考慮した場合は、 よりも小さいセルが生じ、1波長あたりのセル数が指定した20よりも多く使用される可能性があります。実際に1波長あた
りのセル数が大きくなる2つの場合を以下に示します。

レイアウトに よりも小さい細部が存在する場合は、メッシュは細部の形状に従います。メッシュは三角形と長方形だけから構成されるため、セルは

よりも小さくなります。
Mesh Setup Controlsダイアログ・ボックスのデフォルト設定を変更した場合、例えば伝送ラインの幅あたりのセル数を変更した場合などは、伝送ラインの幅方

向のセル数に直接影響します。これにより、 よりも小さいセルが生じる可能性があります。

シミュレーション精度に対するメッシュ・リダクションの影響

メッシュ・リダクションは、複雑な形状のメッシングから生じるメッシュの複雑性を除去することを目的としたテクノロジーです。通常の場合、ユーザは
特定の精度を実現するために、シミュレーションで使用するメッシュ密度(1波長あたりのセル数)を指定します。しかし、形状の制約のために、波長の
基準で厳密に必要とされるよりも多くのセルをメッシャが使用せざるを得ない場合があります。このような場合は、計算プロセスでメッシュに「冗長」な
自由度が生じます(「冗長」とは電磁気学的な挙動に対してという意味)。メッシュ・リダクションは、問題の計算に先立ってこのような冗長な自由度を
自動的に除去するテクノロジーです。このため、結果の精度に与える影響は無視できます。

エッジ・メッシュについて

エッジ・メッシュ機能を使うと、メタルまたはスロットのエッジに沿った領域に対して、小さいセルからなる相対的に高密度のメッシュ・パターンが自動
的に作成され、形状の他の部分に対しては、少数の大きいセルからなる低密度のメッシュ・パターンが作成されます。大部分の電流はスロットまた
はメタルのエッジに沿って流れるため、エッジ・メッシュを使うと正確な解をより効率的に得ることができます。

エッジ・メッシュがシミュレーション精度の改善に役立つのは、エッジ領域の電流のモデリングが解の計算に重要な役割を果たす回路の場合です。こ
のような例としては、特性インピーダンスまたは伝搬定数が電気モデルの計算に重要な役割を果たす回路、強い近接カップリングが発生する回路、
エッジ電流が動作を支配する回路などがあります。エッジ・メッシュを使用するアプリケーションとしては、以下のものがあります。

密結合ライン
パッチ・アンテナ
共振回路
遅延ライン
ヘアピン・フィルタ

エッジ・メッシュは、グローバル、レイアウト・レイヤ、オブジェクトのすべてのメッシング・レベルで使用できます。

エッジ・メッシュ幅の設定

エッジ・メッシュを使う場合は、エッジ・メッシュ幅を指定するか、空白にしておきます。空白にしておくと、適切な幅が計算され、メッシュの作成に用い
られます。近似値を視覚的に得る方法としては、マウスをプリミティブのエッジに置いてクリックし、内側にマウスを動かして、Layoutウィンドウの下部
に表示される差分値を読み取ります。

伝送ライン・メッシュについて
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伝送ライン・メッシュは、レイアウト内の平行ライン間のセル数を指定する場合に使います。この機能を使うと、直線形状に適したメッシュが作成さ
れ、計算時間とメモリの節約に役立ちます。

例えば、1本の伝送ラインの幅方向のセル数が1個でも2個でも、シミュレーション結果は同じです。結合ラインの場合は、結果は異なります。

エッジ・メッシュと伝送ライン・メッシュの組み合わせ

伝送ライン・メッシュとエッジ・メッシュを組み合わせて使うことができます。幅方向のセル数は、伝送ラインのセル数とエッジのセル数の合計になりま
す。この組み合わせを使う場合、セル数の最小値は3個です。

エッジ・メッシュと伝送ライン・メッシュは、回路内の横方向電流に影響します。エッジ・メッシュと伝送ライン・メッシュで指定されたセル数が多いほど、
横断電流が正確に近似されます。

下の図は、ヘアピン・フィルタのシミュレーションで、エッジ・メッシュを使った場合と使わない場合を比較したものです。エッジ・メッシュを使ったシミュレ
ーションは時間がかかりますが、結果はフィルタの実測結果により近くなっています。

円弧分解能の使用

Arc Resolution(円弧分解能)パラメータを使うと、メッシュ内の三角形セルの数を調整できます。三角形セルは、オブジェクトの曲線領域にメッシュを
生成するために用いられます。Arc Resolutionフィールドの値が大きいほど、曲線オブジェクトに用いられる三角形セグメントの数が減ります。

Arc Resolutionの最大値は45°です。最小値は、曲線オブジェクトのドローイング時に用いられたファセットに依存します。例えば、ダブル・パッチ・ア
ンテナのサンプルはArc/Circle Resolutionを30°としてドローイングされていて、Arc Resolutionは45°に設定されています。オブジェクトの角分割に
用いられる実際の値は、これらの値の間です。実際の角度は、ファセット長がセル・サイズ以下になるように選ばれます。 これは、メッシュ密度を決
めるために指定された1波長あたりのセル数に、角分割が影響しないようにするためです。
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注記
メッシュ・ジェネレータが正確なメッシュを生成するためには、多角形に変換された円弧を円弧と認識できなければ
なりません。このため、レイアウト分解能の指定が適切でないと、円弧と認識されず、角分割ができないことがあり
ます。レイアウト分解能の詳細については、メッシュ精度とギャップ分解能を参照してください。

以下に示すのは、VIASTUBの例です。 Arc Resolutionを、最も粗い設定である45°と、0.01°に設定します。 後者の場合、角分割は実質的に無効
になります。それぞれの角度設定でのスタブに対するメッシュが示されています。高密度のメッシュに対するシミュレーションは時間がかかり、多くの
メモリが必要ですが、結果はほとんど改善されていません。

Arc Resolution = 45 Arc Resolution = 0.01

プロセス・サイズ 6.18 MB 12.791 MB

ユーザ時間 12分 20分

経過時間 15分 24分

長方形セル数 96 80

三角形セル数 108 200

ビア・セル数 16 36

未知電流 337 453

メッシュ・パターンとシミュレーション時間

メッシュ・ジェネレータは、複雑なメッシュに対しても比較的高速に動作します。しかし、メッシュの複雑さはシミュレーション時間に大きな影響を与える
ことに注意してください。具体的には、メッシュのセル数(特に三角形セル)と未知電流の数がシミュレーション時間に影響します。

メッシュが主に長方形セルから構成されている場合は、シミュレーションは比較的高速です。単純なメッシュとは、大きさが同じくらいの少数の長方形
セルから構成されたものです。最も複雑なメッシュとは、それぞれ異なる大きさの多数の三角形から構成されるものです。メッシュ内の三角形セルの
数はなるべく少なくすべきです。

もう1つの変数である未知電流の数は、メッシュの密度(全セル数)に依存します。メッシュ内の全セル数はなるべく少なくすべきです。これにより未知
電流の数が減り、シミュレーション中に計算するマトリクスのサイズが小さくなります。マトリクスを計算するのに必要な時間は、Nを未知電流の数とし
て、N*N*Nになります。

例えば、グローバル・シード設定が30の場合に、50×50程度のマトリクスを生成するスルーラインがあるとします。マトリクスを計算する時間はマトリ
クスのサイズに比例するので、シード設定が60の場合、同じスルーラインが200×200のマトリクスを生成します。 これは、セル数がX方向とY方向に
それぞれ2倍になるからです。このため計算時間が長くなります。
メッシュ・パラメータを調整することにより、メッシュの複雑さを制御して、シミュレーション時間を短縮できる可能性があります。

単純なメッシュを使ってもかなりのシミュレーション時間を要するような複雑な回路の場合、メッシュの複雑さを減らすことで大幅に時間を節約できる
場合があります。

メッシュ・パターンと必要メモリ
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未知電流の数は、メッシュの事前計算のときに求められ、メッシュの複雑さに依存します。未知数が多いほど、シミュレーション中に計算するマトリク
スが大きくなります。計算に必要なメモリは、未知電流の数をNとして、N*Nに比例します。

オブジェクトのオーバラップの処理

薄膜レイヤ同士が近くにあって重なっているデザインでは、パラメータThin layer overlap extractionを使う必要があります。オーバラップ領域と交差
するメッシュ・セルが生成されると、望ましくない影響をもたらすからです。

例として、2つのレイヤが上下にあり、その距離が近いとします。これらがオーバラップした領域には大きな電荷密度があり、1/距離に比例して増加
します。レイヤの上にメタルがなければ、オーバラップのない領域では電荷密度はほぼ0であり、オーバラップするポイントで電荷密度は急激に(ステ
ップ状に)変化します。

オーバラップ抽出を行わないと、メッシュ計算時に、オーバラップ領域の境界と交差するセルが作成される可能性があります。実際の回路ではこの
セルは、オーバラップのある領域で電荷密度が部分的に高く、オーバラップのない場所で電荷密度が部分的に低くなります。ところが、Momentumは一
定の電荷密度でセルをシミュレートするので、大きく変化するセル内の電荷が一定値で近似され、不正確な表現になります。そこで、オーバラップ抽
出をオンにすると、オーバラップ領域に交差するセルが作成されません。

回路内のすべてのオーバラップに対してこの機能を使用すると、メッシュの密度が高くなりすぎるおそれがあるため、経験則によって、レイヤが近接
しない場合(h > 0.02×予測セル・サイズ)またはオーバラップ領域が小さい場合には、オーバラップ抽出がオフになります。予測セル・サイズを計算す
るには、メッシュ周波数、グローバルな波長あたりのセル数、サブストレートの実効屈折率の予測値が用いられます。

メッシュを計算する周波数が低い場合は、予測セル・サイズが大きくなり、薄膜レイヤのオーバラップ抽出をしてほしくないことがあります。この場合
は、オーバラップ抽出機能をオフにします。

メッシュ・ジェネレータのメッセージ

メッシュの生成時に、以下のようなメッセージが表示されることがあります。

On some layers, the mesher used the maximum allowable cell size for the given substrate.(一部のレイヤで、メッシャが与えられたサブストレートに
対する最大許容セル・サイズを使用しました)You will not be able to generate a coarser mesh on these layers.(これらのレイヤではこれより粗いメッ
シュを生成できません)

このメッセージの意味は、一部のレイヤ上のオブジェクトで、許容される最も粗いメッシュが作成されたということです。これは、サブストレートに対し
て計算されたグリーン関数の精度によって、最大セル・サイズが制限されるからです。

例えば、メッシュ周波数が10 GHzの場合に、20セルのメッシュを生成するレイアウトを考えます。一般に、メッシュ周波数を5 GHzに設定すれば、10セ
ルのメッシュが得られるはずです。しかし、メッシュ周波数を下げたときに、セル・サイズが許容最大値(サブストレートのグリーン関数の精度で決まる
上限値)よりも大きくなる場合は、メッシュのセル数は10よりも多くなります。

メッシング・レポートには以下のようなメッセージも表示される可能性があります。

"POLYLINE requires two unique points"(ポリラインには2個の相異なる点が必要です)
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これは、レイアウト分解能(Options > Preferences...のLayout Unitsタブで設定)がメッシング・ラインの傾斜に不十分である場合に発生します。分解能
を細かくすると、エラーは消えます。

メッシングの指針

多くの回路アプリケーションに対して、デフォルトのメッシュで十分に正確な結果が得られます。その他のものに対しても、グローバル・メッシュ・パラメ
ータを使えばほとんどの場合に十分な精度が得られます。レイヤまたはプリミティブに対するメッシュ制御が必要なのは、少数の特別な場合に限ら
れます。

きわめて正確な不連続部のモデリングや、密結合ラインを含む形状などのアプリケーションの場合は、デフォルトのメッシュでは特定の領域で密度
が不足し、十分な精度が得られないことがあります。このような場合は、エッジ・メッシュを使うか、メッシュ密度を上げます。例えば、ノイズ・フロアや
ダイナミック・レンジは一般に小さい値です。場合によっては、高密度のメッシュを使うと、形状の解から得られるS21の値が-60 dBといった小さい値
になります。デフォルトのメッシュではこの値が異なり、同じ回路に対して-40 dBといった結果になることがあります。

1つのデザインで、4つのタイプのメッシュ制御を任意に組み合わせて使用できます。一般的には、メッシュ密度を上げた方が精度は上がります。しか
し、密度が高いと計算時間が増えます(計算するセル数が増えるため)。また、三角形は長方形よりも常に計算に時間がかかります。

薄膜レイヤのメッシング

薄膜レイヤのメッシングでは、メッシュ・セルがオーバラップ領域に完全に含まれるか、オーバラップ領域の完全に外側にある必要があります。メッシ
ュ・セルとオブジェクト境界との位置関係が正しくないと、シミュレーション・データが不正確になるおそれがあります。

詳細については、オブジェクトのオーバラップの処理を参照してください。

狭いラインのメッシング

狭いライン(らせん形の狭い伝送路など)が形状に存在する場合は、デフォルトのグローバル・メッシュでは、幅方向に1セル以上のメッシュを得るの
が難しい場合があります。ラインを横断する方向の電流分布を捉えるために、必要ならエッジ・メッシュまたは伝送ライン・メッシュを使ってください。

スロットのメッシング

スロットのメッシングは、ストリップの場合と全く同じです。 違いはありません。例えば、スロットに対してもエッジ・メッシュが使用できます。 ストリップ
の場合と基本的に同じで、電流分布がエッジに集中するからです。

曲線オブジェクトのメッシュ密度の調整

ビアなどの曲線オブジェクトをレイアウト内でドローイングする場合は、使用するファセット数のデフォルト値が存在します。 これはコマンドOptions >
Preferences> Entry/Edit >Arc/Circle Resolution (degrees)で設定されます。この値が小さいと、円のドローイングに比較的多くのファセットが用いら
れ、メッシュ・プロセスにおいて曲線領域に多数の三角形セルが作成されることになります。すべての円弧と円に対してファセット数を変更するには、
上記のコマンドを使用します。1個のオブジェクトに対してだけ変更するには、オブジェクトを選択して、Edit > Modify > Arc/Circle Resolutionを選択し
ます。必要に応じて半径に対する度数を増やせば、三角形セルの数を減らすことができます。これは回路の形状自体を変更することに注意してくだ
さい。

メッシュ・パラメータArc Resolutionがメッシュに与える影響については、オブジェクトのオーバラップの処理を参照してください。

不連続部のモデリング

ベンド付きマイクロストリップ伝送ラインに対してデフォルトのメッシュを使用すると、セル・サイズがラインの幅に等しくなることがあります(ライン幅あ
たり1セル)。伝送ラインが長くてベンドが急でなければ、不連続部がライン長に比べて小さいので、デフォルト・メッシュで十分な場合もあります。これ
に対して、基準面を内側に移動した場合や、ベンドが急な場合、不連続部とそれから生じる寄生成分が、ラインの残りの部分に対して大きな割合を
占めます。この場合、デフォルト・メッシュではシミュレーション・データに誤差が生じるおそれがあります。

これに対処するには、メッシュの密度を上げ、エッジ・メッシュを使用します。不連続部の近くの領域で、セル・サイズがライン幅の1/3(ライン幅あたり
3セル)になるようにメッシュを作成すると、誤差が低減されます。高密度のメッシュを使えば、ベンドの内側コーナでの電流の集中(寄生直列インダク
タンス)や、ベンドの外側エッジでの電荷蓄積(寄生シャント・キャパシタンス)を考慮できます。

密結合ラインの計算

密結合ラインの例としては、25 milアルミナ・サブストレート(Er = 9.8)上のマイクロストリップ結合ライン・フィルタ(ライン幅が25 mil、ラインの間隔が2.5
mil)があります。フィルタの応答はライン間のカップリングに影響され、デフォルトのメッシュはライン幅あたり1セルです。この場合、反射係数データが
測定データに一致しません。このデザインを正しく扱うには、エッジ・メッシュを使用する必要があります。
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オブジェクトのシード設定の編集

プリミティブのシード設定のための推奨方法は、O,U,V座標系の使用です。

オブジェクトを選択します。1.
Momentum > Mesh > Setupを選択します。2.
Primitive Seedをクリックします。3.
Clearをクリックします。4.
新しいシード・パラメータを選択します。5.

これらの値を変更するには、オブジェクトの属性を編集する方法もあります。しかし、この方法はサポートされないか、あるいは推奨しません。オブジ
ェクトを選択して、Edit > Propertiesを選択します。シード値が表示され、変更可能になります。

メッシュ精度とギャップ分解能

このセクションは、Advanced Design Systemにインポートされたデザインが主な対象です。

メッシュ分解能は、レイアウト精度のdbu(データ・ベース単位)値に直接関連しています。ギャップやその他の未分解のレイアウトの頂点は、その距離
が2 dbuより小さい場合は、メッシュ・ジェネレータによって分解されます。

製造やレイアウト・プロセスのために単位を変更するには、LayoutウィンドウのコマンドOptions > Preferences > Layout Unitsを使用します。
 

Momentumのシミュレーション
シミュレーション・プロセスは、回路のサブストレートに対して計算されたグリーン関数と、回路に対して計算されたメッシュ情報とを組み合わせて、回
路内の電流を計算します。得られた電流値を用いて、回路のSパラメータが計算されます。

シミュレーションの実行前に、以下の基準が満たされる必要があります。

回路に対してサブストレート定義が指定されていること。
最低1個のポートが回路に存在すること。
シミュレーション実行時にメッシュが自動的に計算されること。
シミュレーション周波数プランが指定されていること。

上記の基準が1つでも満たされない場合、シミュレーションを実行しようとしたときにMomentumがエラーを報告します。

Momentumのプレーナ・ソルバは、サブストレート・データベースとメッシュ・ジェネレータから得られる情報を使って、回路シミュレーションを実行しま
す。サブストレート計算とメッシングをシミュレーション前に実行して、その妥当性をチェックすることもできます。サブストレートを事前計算しておくと、
シミュレーション時間を短縮できます。

シミュレーションを実行する手順は、以下の各ステップからなります。
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ローカル／リモート／分散シミュレーション・モードの選択（オプション）
行列ソルバの選択（オプション）
周波数プランの指定と編集
モード、ホスト、または待ち行列の選択
解ファイルの指定
データ表示の選択
シミュレーションの実行

以下の各セクションでは、Momentumシミュレーションの実行方法を説明します。

注記
Momentumはシミュレーション中にいくつかのファイルを作成します。これらのファイルのうち、
/mom_dsn/<design>/proj.cviは大きくなる場合があります（このファイルの内容は電流の計算結果です）。プロジェク
トが終了して、電流を表示したり遠方界計算を実行したりする必要がなくなった場合は、このファイルを削除してディ
スク空き容量を増やすことができます。

 
 

シミュレーション・モードの選択

Momentumシミュレーションをローカル・マシンで実行するか、リモート・シミュレーションを使用するか、サードパーティ製のロード・バランシング／待ち
行列システム（LSF、Sun Grid Engine、PBS Professionalなど）を利用するかを選択できます。

Momentum > Simulation > Setupを選択すると、Momentumのシミュレーション・セットアップ・ウィンドウがオープンします。このウィンドウには、2つのタ
ブ・ページがあります。Modeタブ・ページでは、以下の3つの主要なシミュレーション・モードの1つを選択できます。

Local

ローカル・モードを選択すると、シミュレーションはローカル・マシンで実行されます。
 

 

シミュレーション・セットアップ・ウィンドウで、ローカルで開始するシミュレーションのデフォルト処理モードを選択できます。ローカル処理モードは、フ
ォアグランド、バックグランド、待ち行列のいずれかです（処理モードの選択を参照）。これらのモードを使用して、シミュレーションをただちに開始する
か、ローカル待ち行列マネージャ（バッチ・モード・シミュレーションを参照）を使用して一連のシミュレーションを順次実行することができます。

Remote
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リモート・モードを選択すると、シミュレーションはPVMエグゼクティブ・システムを使用してリモート・マシンで実行されます（Momentumシミュレーション
・エグゼクティブ・システムおよびPVMを使ったリモート・シミュレーションの実行を参照）。
 

 
このモードのセットアップ・ウィンドウには、以下の機能があります。

リモート・シミュレーションに使用するリモート・シミュレーション・ディレクトリを定義するオプションのフィールド
PVMクラスタ構成の開始／停止

リモート・シミュレーション環境は、このページでStartを押すことによって開始する必要があります。これにより、PVMシミュレーション・クラスタ構成が
読み込まれ、定義されたクラスタがPVMシミュレーション・エグゼクティブによって開始されます。PVMクラスタ構成が定義されていない場合は、ロー
カルeesofpvmdデーモンが開始されます。

PVMクラスタが使用可能な場合は、'Get host list'ボタンを選択すると、使用可能なリモート・シミュレーション・マシンの一覧が表示され、デフォルトの
リモート・ホストをドロップダウン・リストから選択できます。

Distributed

分散モードでは、サードパーティ製のワークロード／待ち行列管理システムを使って、Momentumシミュレーションをマシンのクラスタに登録します。

分散モードで使用可能なロード管理システムとしては、LSF ™、PBS professional ™、Sun Grid Engine ™があります。

注意
リモート・シェル、セキュア・シェル、SGE/LSF/PBS環境が正しく設定されていることが非常に重要です。Agilentは、
お客様のローカル環境の構成に関して責任を負えません。分散モード・シミュレーションを実行する前に、ローカル・
システム管理者と協力して、環境が正しく設定されているかどうかを確認することを強くお勧めします。

重要

シングル・エンジンのMomentumは、ADSでサポートされるすべてのプラットフォーム上で動作します。分散Momentumエンジ
ンは、ADSでサポートされるLinuxマシン上でのみ動作します。また、一般的な要件として、「実際の」Momentumシミュレーショ
ン・ディレクトリがリモート／分散シミュレーションを実行するマシンの間で共有されていることが必要です。このクラスタは、同
等のマシンのセットから構成されることが望ましいです。

分散モードでは、サードパーティ製のワークロード管理システムが、ADS関連のタスクをコマンド・ライン環境から実行できる
ようにあらかじめ設定されていることを仮定しています。サードパーティ製ワークロード管理システムの設定方法について
は、お使いの環境のドキュメントを参照してください。サポートされるワークロード管理システムに関する情報は、以下のサイ
トで入手できます。

LSF:http://www.platform.com
PBS Professional:http://www.pbsgridworks.com/Default.aspx

http://www.platform.com
http://www.pbsgridworks.com/Default.aspx
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Sun Gridengine:http://gridengine.sunsource.net/

分散モードには以下のセットアップ・オプションがあります。

"Simulation type"では、シングルジョブまたは分散ジョブを選択できます。
"Number of parallel jobs"では、並列に計算される周波数ポイントの数を指定できます。
"Local directory"は、Momentumプロジェクト・ファイルが置かれているローカル・コンピュータ上のディレクトリを指します。
"Remote directory"は、シミュレーション実行中にMomentumプロジェクト・ファイルが置かれるリモート・コンピュータ上のディレクトリを指します。ホスト・モード
がリモートでホストがローカル・マシンに設定されている場合は、リモート・ディレクトリは<use setting of local directory>に設定します。リモート・ディレクトリを
リセットするには、エントリを空白にしてApplyをクリックします。
"Default submit user"は、ローカル・ユーザ名がクラスタ上のユーザ名と異なる場合に使用します。
オプションのメール通知およびメール・アドレス・フィールド
"Submit"フィールドでは、Simulateボタンを押したときにジョブをただちにワークロード・システムに登録するか（immediately）、ワークロード管理システム用の
高度なオプションを設定するウィンドウを表示した後に登録するか（after advanced job setup）を指定できます。
"Submit host"フィールドでは、ワークロード・システムの登録ホストとして、PVMリモート・シミュレーション・クラスタのホストを指定します（これはローカル・マシ
ンでもかまいません）。
Get queue listボタンを押すと、Default queueドロップダウン・リストに、登録ホストから参照できる使用可能な待ち行列が入ります。これにより、デフォルト待ち
行列をあらかじめ設定できます。
"Default resource string"には、サードパーティ製ワークロード管理システムのオプション・フラグやリソース指定構文を入力できます。これはワークロード・シ
ステムに直接渡されます。

EMXリモート

MOMENTUM_SIM_PATH環境変数が定義されている場合は、PVMエグゼクティブ・システム全体が無効になり、Momentumシミュレーションは強制的
にEMXリモート・シミュレーション・モードで実行されます（PVMまたはEMXエグゼクティブ・システムを使ったリモート・シミュレーションを参照）。
Momentumシミュレーション・セットアップ・ウィンドウはリモート専用になり、MOMENTUM_SIM_PATH変数で定義されたシミュレーション・ホストが用い
られます。

http://gridengine.sunsource.net/
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行列ソルバの選択

シミュレーション時にMomentumが使用する行列ソルバを選択できます。「自動選択モード」のほかに、Momentumには以下の3種類の行列ソルバが
用意されています。

Direct Dense
Iterative Dense
Direct Compressed

Momentum > Simulation > Setupを選択して、Momentum Simulation Setupウィンドウをオープンします。このウィンドウには2つのタブがあります。
Optionsタブ・ページで行列ソルバを選択できます。
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Auto-select

Auto-selectを選択すると、Momentumは扱う問題のサイズに応じて最適な行列ソルバを自動的に選択します。これはデフォルトの行列ソルバ選択オ
プションです。

Direct Dense

Direct denseを選択すると、Momentumは直接密行列ソルバをシミュレーション時に使用します。この場合は、行列は密行列形式（N^2のオーダのメモ
リが必要）で記憶され、直接行列分解法（N^3のオーダの計算時間が必要）で計算されます。Direct 密行列ソルバでは、あらかじめ決まった数の演
算で必ず解が見つかることが保証されています。最大の欠点は、必要な計算時間が行列のサイズNの3乗に応じて増加するため、問題のサイズが
大きいとシミュレーション時間が長くなることです。

Iterative Dense

Iterative denseを選択すると、Momentumは反復密行列ソルバをシミュレーション時に使用します。この場合は、行列は密行列形式（N^2のオーダのメ
モリが必要）で記憶され、反復行列計算法（N^2のオーダの計算時間が必要）で計算されます。計算時間は行列のサイズNの2乗に応じて増加するた
め、問題のサイズが大きい場合は直接密行列ソルバに比べてシミュレーション時間が短くなります。最大の欠点は、反復ソルバは高速に収束すると
いう保証がないことです。反復ソルバは収束速度をモニタしていて、収束が停滞するか、収束速度が遅すぎると判断した場合は、自動的にDirect
dense行列ソルバに切り替えます。

Direct Compressed

Direct compressedを選択すると、Momentumは直接圧縮行列ソルバをシミュレーション時に使用します。この場合は、行列は圧縮行列形式（NlogN
のオーダのメモリが必要）で記憶され、直接圧縮行列分解法（（NlogN）^1.5のオーダの計算時間が必要）で計算されます。直接圧縮行列ソルバで
は、あらかじめ決まった数の演算で必ず解が見つかることが保証されています。さらに、必要な計算時間は行列のサイズNに対してリニア対数的に
増加するため、問題のサイズが非常に大きい場合はこの行列ソルバが最適です。

周波数プランの作成

1つのシミュレーションに対して、複数の周波数プランを作成できます。各周波数プランには、解を1つの周波数ポイントで求めるか、ある周波数レン
ジで求めるかを指定します。また、プランに対する掃引タイプも選択できます。これらの周波数プランの集合が、1つのシミュレーションとして実行され
ます。

周波数プランを作成する手順:

Momentum > Simulation > S-parametersを選択します。1.
掃引タイプを選択します。以下の選択肢があります。 2.

Adaptive（適応）
Logarithmic（対数）
Linear（リニア）
Single point（シングル・ポイント）
 
Adaptive（適応）は望ましい掃引タイプです。これを使うと、高速かつ非常に正確な方法で、サンプリングされたSパラメータ・データ・ポイントが有理フィッティング・モデルと比較されま
す。Sample Points Limitフィールドに入力された値は、収束を達成するために用いられる最大サンプル数を表します。最後の試行で得られた解が保存されます。これより少ないサンプ
ル数で収束に達した場合は、解が保存され、シミュレーションは終了します。この掃引タイプの詳細については、適応周波数サンプリングを参照してください。
 
Logarithmic（対数）を使うと、ある周波数レンジで、対数的に増加する周波数ポイントを選んでシミュレーションが行われます。StartフィールドとStopフィールドに開始周波数と終了周
波数を入力し、それぞれの周波数単位を選択します。周波数のデケード（1桁）ごとの周波数ポイントの数をPoints/Decadeフィールドに入力し、単位を選択します。
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Linear（リニア）を選択すると、ある周波数レンジで、指定したステップ・サイズに基づいてリニアに増加する周波数ポイントを選んでシミュレーションが行われます。Startフィールドと
Stopフィールドに開始周波数と終了周波数を入力し、それぞれの周波数単位を選択します。Stepフィールドにステップ・サイズを入力し、単位を選択します。
 
Single（シングル）を選択すると、1個の周波数ポイントでシミュレーションが行われます。Frequencyフィールドに周波数を入力し、単位を選択します。
 

プランの設定が終わったら、Add to Frequency Plan Listをクリックします。3.

注記
シミュレーションでは、周波数プランはこのリストに記載された順番に実行されます。

上記の手順で他の周波数プランを追加します。4.
終わったら、Applyをクリックします。5.

注意事項

一般に、掃引タイプとしてはAdaptiveを推奨します。例外としては、特定の周波数ポイントを対象としたシミュレーション、例えばアンテナ・パターンの
表示などがあります。放射パターンの計算は、解が求められた周波数でのみ可能なので、Single掃引タイプで特定の周波数を指定するか、Linearま
たはLogarithmic掃引タイプでレンジを指定します。

複数の掃引タイプを使用する場合は、Adaptive掃引タイプを使用するプランがリストのいちばん上になるように、周波数プラン・リストを作成してくださ
い。他の掃引タイプを使用するプランは、Adaptive掃引タイプを使用するプランの後に配置します。

周波数プランの編集

Frequency Plansリストで、周波数プランの変更、削除、移動が可能です。

周波数プランを変更する手順:

Momentum > Simulation > S-parametersを選択します。1.
Frequency Plansリストで周波数プランを選択します。2.
Edit/Define Frequency Planの下に表示される掃引タイプと周波数のフィールドを使って、プランを編集します。これらのフィールドについては、前のセクション3.
で説明しています。
プランの編集が終わったら、Updateをクリックします。4.
Applyをクリックして変更を保存します。5.

周波数プランを削除する手順:

Momentum > Simulation > S-parametersを選択します。1.
Frequency Plansリストで周波数プランを選択します。2.
Cutをクリックします。3.
Applyをクリックして変更を保存します。4.

周波数プランを移動する手順:

Momentum > Simulation > S-parametersを選択します。1.
Frequency Plansリストで周波数プランを選択します。2.
Cutをクリックします。3.
切り取ったプランの下に配置したい周波数プランを選択します。4.
Pasteをクリックしてプランを再入力します。5.
Applyをクリックして変更を保存します。6.

ヒント
すべての編集作業を実行した後で、1回だけApplyをクリックしてからダイアログ・ボックスをクローズすることもでき
ます。

プロセス・モードの選択

Process mode:local

シミュレーションをフォアグランドで実行するかバックグランドで実行するか待ち行列に入れるかを選択できます。Foreground（フォアグランド）モードで
は、サブストレートが事前計算されていないとシミュレーションが一時停止します。この場合は、シミュレーションを終了することもでき、続行した場合
にはサブストレートの事前計算が行われてからシミュレーションが実行されます。Background（バックグランド）モードでは、サブストレートの事前計算
が必要な場合は、シミュレーションを終了するか続行するかをユーザに確認せずに、自動的に計算が行われ、その後にシミュレーションが実行され
ます。どちらのモードでも、Layoutウィンドウを使ってレイアウトの構築または編集を実行できます。サブストレートの事前計算の詳細については、サ
ブストレートの事前計算を参照してください。待ち行列については、バッチ・モード・シミュレーションを参照してください。

現在のローカル・プロセス・モードを設定する手順:

Momentum > Simulation > S-parametersを選択します。1.
処理モードを選択します。Foreground、Background、Queuedのいずれかをドロップダウン・リストから選択します。2.
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2.

Applyをクリックします。3.

Process mode:remote

シミュレーションに実際に使用されるホストをドロップダウン・リストから選択できます。

Process mode:distributed

セットアップ・ウィンドウでただちに登録することを指定した場合は、以下のシミュレーションに使用する待ち行列をプロセス・モードのドロップダウンで
選択できます。

高度なジョブ・セットアップの後で登録することを選択した場合は、プロセス・モードには選択はありません。

その代わりに、Simulateボタンを押した後で高度な分散シミュレーション・セットアップ・ウィンドウがオープンし、シミュレーションのより詳細な起動オプ
ションを指定できます。

高度なシミュレーション・セットアップ・ウィンドウでは、デフォルト・セットアップ・オプションをシミュレーション固有の設定で上書きできます。
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Simulation type（シミュレーション・タイプ）
Number of parallel jobs（並列ジョブ数）
Remote simulation directory（リモート・シミュレーション・ディレクトリ）
Queue（待ち行列）
Submit user（登録ユーザ）
Email notification（メール通知）
Resource string（リソース文字列）

分散シミュレーション・システムに対するその他の高度なオプションも指定できます。

Job name（ジョブ名）:ワークロード管理システムでのシミュレーションの識別文字列
シミュレーション・タイプ:現時点では、ワークロード管理システムに対して登録できるのはシングルジョブに限られています。
システムがいつ、あるいはどのジョブの後でシミュレーションを開始するかを指定します。これは、使用するワークロード管理システムの構文による時刻また
はジョブ指定です。
シミュレーションの期限を指定します。デフォルト設定は期限なしですが、ワークロード管理システムの構文で時刻を指定することもできます。

シミュレーション・データの再利用

現在のシミュレーションにかかる時間を短縮するため、前回のシミュレーションでサンプリングされたデータを使用できます。この機能が役立つのは、
周波数プランを拡張またはシフトしてシミュレーションをやり直す場合や、共振周波数の近くでサンプルを増やしたい場合などです。回路の形状、サ
ブストレート、ポート、メッシュ・パラメータを変更した場合は、シミュレーション・データの再利用は不可能です。

注記
Momentumは、デザインが変更されたかどうかをチェックしません。データを再利用する際は、周波数プラン以外の
変更がないことを必ず確認してください。

この機能をオンにすると、前回計算されたS-50パラメータが再利用されます。
前回のシミュレーションのデータを再利用する手順:

Momentum > Simulation > S-parametersを選択します。1.
前回のシミュレーションのデータを再利用したい場合は、Reuse files from previous simulationをオンにします。前回のシミュレーションでサンプリングされたデ2.
ータが現在のシミュレーションで用いられ、シミュレーション時間の短縮に役立ちます。

Applyをクリックします。3.

シミュレーション・データの保存

データセットに保存されるのは、1回のシミュレーションで得られた解だけです。複数のシミュレーションを実行するときに、前回のシミュレーションのデ
ータを保存したい場合は、それぞれのシミュレーションに対して一意のデータセット名を指定する必要があります。

1回のシミュレーションで、1個または2個のデータセットが生成されます。

シミュレータが計算した周波数ポイントのデータは、< project_name >.dsファイルに保存されます。これはすべてのシミュレーションで作成される標準のデータ
セットです。
Adaptive掃引タイプを使った場合は、サンプリングされた各周波数ポイントでAFS（適応周波数サンプリング）が計算したデータが、< project_name >_a.dsとい
うデータセットに保存されます。

Datasetフィールドに名前を指定すると、指定した名前がデフォルトのproject_nameの代わりにデータセットに用いられます。

データセットを指定する手順:

Momentum > Simulation > S-parametersを選択します。1.
Datasetフィールドにデフォルトのデータセット名が表示されます。このファイルにシミュレーション・データが保存されます。デフォルトの名前は、現在のプロジ2.
ェクトの名前に基づいたものです。
別のデータセットを使う場合は、新しいデータセット名をDatasetフィールドに入力するか、Browseをクリックして既存のデータセットを指定します。Browseを選
択すると、現在のプロジェクトのdataフォルダにあるデータセットのリストが表示されます。ファイル名を選択してOKをクリックします。
データセット・ファイルの拡張子は.dsであり、現在のプロジェクトのdataフォルダに保存されます。
Applyをクリックして変更を確定します。3.

エクスポートのためのデータの保存

Momentumのシミュレーション・データは、IC-CAP用のファイルに保存することができます。Momentumのデザイン形状およびセットアップ情報は、シミ
ュレーションを実行しなくても、3次元電磁界ツールにインポートできる形式で保存できます。詳細については、Momentumデータのエクスポートを参
照してください。
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結果の自動表示

シミュレーション・データはデータセットに保存されるので、好きなときに結果を見ることができます。シミュレーション直後に結果を表示したい場合は、
Open data display when simulation completesをオンにします。シミュレーションが終わると、デフォルトのプロット・タイプまたはユーザが選択したデー
タ・ディスプレイ・テンプレートを使って、データ・ディスプレイ・ウィンドウが自動的にオープンします。デフォルトでは、Sパラメータの振幅／位相プロッ
トと、Sパラメータのスミス・チャートが表示されます。

注記
分散シミュレーション・モードでは、シミュレーション結果はリモート・シミュレーション・ディレクトリからローカルに自動
的にはコピーされません。したがって、中間／最終シミュレーション結果やシミュレーション情報の自動表示も実行
できません。これには、メッシュ結果、進捗状況、ログ・ファイル、データセット、シミュレーション時のデータ・ディスプ
レイの更新の表示が含まれます。

適応掃引タイプを使用する場合は、標準データセットと適応データセットの両方のデータが比較のために表示されます。標準データセットのデータは
離散ポイントとして、適応掃引データはリニア・トレースとして表示されます。

シミュレーション終了時にデータ・ディスプレイ・ウィンドウをオープンする手順:

Momentum > Simulation > S-parametersを選択します。1.
Open data display when simulation completesをオンにします。2.
ウィンドウにテンプレートをロードしたい場合は、Templateフィールドにテンプレート名を入力するか、Browseをクリックします。現在のプロジェクトのdataフォル3.
ダにあるテンプレートのリストが表示されます。テンプレートを選択してOKをクリックします。

注記
他のプロジェクトや他の場所にあるテンプレートを使用する場合は、現在のプロジェクトのdataフォルダにテンプレ
ートをコピーします。

Applyをクリックして変更を確定します。4.

ローカル・シミュレーションの開始

このセクションでは、ローカル・シミュレーションを実行する方法を説明します。
シミュレーション・プロセスは、サブストレートに対して事前計算されたグリーン関数とメッシュ計算の結果を組み合わせて、電流を計算します。その
結果からSパラメータが求められ、データセットに保存されます。

シミュレーションを開始する手順:

Momentum > Simulation > S-parametersを選択します。1.
Frequency Plansリストに最低1個の周波数プランが存在することを確認します。2.
Process Mode、Solution Files、Data Displayの各オプションが適切に設定されていることを確認します。3.
シミュレーション・モードがローカル・マシンに設定されていることを確認します（シミュレーション・ホストの設定を参照）。4.
Simulateをクリックします。5.

注記
Simulationダイアログ・ボックスのProcess ModeセクションでForegroundまたはBackgroundを選択した場合は、シミ
ュレーションはただちに開始されます。Queuedを選択した場合は、シミュレーションは待ち行列に置かれ、待ち行
列マネージャから開始する必要があります。バッチ・モード・シミュレーションを参照してください。

メッセージやエラーがあれば、Momentum Statusウィンドウに表示されます。シミュレーションの未知数が500を超える場合は、Statusウィンドウにシミ
ュレーションの進捗度ライン（シミュレーションの進捗度の表示を参照）が表示されます。それ以外の場合は、周波数だけが表示されます。

セットアップに関連した理由でシミュレーションが失敗した場合は、これまでのデータが保存され、Statusウィンドウにメッセージが表示されます。

シミュレーション・ステータスの表示

シミュレーション開始後に、シミュレーションに関するメッセージはMomentum Statusウィンドウに表示されます。通常は、エラーが発見された場合と、
進捗の割合（"% Covered"ステータス・メッセージの意味を参照）、シミュレーション終了のメッセージが出ます。

ステータス・ウィンドウを最小化した場合は、再オープンするには、Layoutメニュー・バーでWindow > Simulation Statusを選択します。
 

注記
ステータス・ウィンドウはクローズしないでください。いったんステータス・ウィンドウをクローズすると、新しいステータ
ス・ウィンドウではシミュレーションを停止できなくなります。
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シミュレーションの進捗度の表示

大きいプロジェクトの場合は、status / summaryウィンドウに表示される点と縦線（点9個ごとに1個の"|"が存在）によって、シミュレーション実行の進
捗度が示されます。36個の点と4個の縦線が表示されると、タスクは終了します。1個の点は、タスクの2.5%が終了したことを示します。9個の点と1個
の縦線（.........|）は、タスクの25%が終了したことを示します。

"% Covered"ステータス・メッセージの意味

このメッセージは、適応掃引タイプの実行時に表示されます。全シミュレーション周波数レンジのうち、有理関数によって正確にモデリングされた部分
の割合を示します。適応掃引が開始されると、AFSプロセスはすべてのSパラメータをいくつかの有理関数で表現しようとします。新しいサンプル・ポ
イントは、適応するように（グローバル誤差基準を最小化するように）選択されます。周波数レンジが大きすぎる場合は、いくつかのセクションに分割
されます。サブレンジ内でフィッティング・モデルが正確で安定していれば、"% covered"メッセージが更新されます。このためこのメッセージは、全シミ
ュレーション周波数レンジのうち有理関数によって正確にモデリングされた部分の割合を示します。

AFSプロセスは、常に全周波数レンジを考慮して、フィッティング・エラーが最大になる場所にサンプルを追加します（グローバル誤差低減法）。周波
数レンジの1つのセクションでフィッティングが収束すれば、他のセクションでも収束する可能性が高く、サンプルをそれほど追加しなくてもすべての部
分で収束が達成できるはずです。このため、"% covered"メッセージは最初のうちゆっくりと更新され、プロセスの最後近くでは速く更新されます。

シミュレーションの停止

シミュレーションを停止する手順:

Momentum Statusウィンドウで、Simulation/Synthesis > Stop Simulationを選択します。1.
シミュレーションは停止し、これまでのデータが保存されます。
保存されたデータを再利用する手順:2.
Momentum > Simulation > S-parametersを選択し、Reuse files from previous simulationをオンにし、Applyをクリックし、Simulateをクリックします。

注記
待ち行列からシミュレーションを開始した場合は、シミュレーションを停止する前に、待ち行列マネージャから待ち
行列を切断する必要があります。

シミュレーション・サマリの表示

シミュレーションの進行に伴って、サブストレート、メッシュ、解に関する統計情報が表示されます。得られる情報としては、解を求めるのにかかった
時間、使用リソース、セル情報、およびステータス・ウィンドウに表示されたすべてのメッセージなどがあります。解の統計情報の例を以下に示しま
す。

ローカル・シミュレーションの場合は、シミュレーション実行の途中でシミュレーション・サマリ情報を表示できます。これに対して、PVMエグゼクティブ・
システムを使ってリモート・シミュレーションを実行する場合は、情報を表示できるのはシミュレーションが終了した後になります。

PVM使用時のシミュレーション・データの表示については、シミュレーションの開始を参照してください。

Momentum > Simulation > Summaryを選択してデータを表示します。Refreshをクリックすると統計情報が更新されます。シミュレーション進捗度はロ
ーカル・シミュレーションとリモートEMXシミュレーションの場合のみ動作します。下の例は、Momentumマイクロ波シミュレーション・モードで表示され
るサマリの一部です。
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以下の例は、Momentum RFモードの別のプロジェクトに対して表示されたサマリです。メッシュ低減後の行列サイズと、準静的計算の統計情報が記
載されています。

Momentumの64ビット・バージョンが用いられたかどうかも示されます（Momentumの代わりにMomentum_64が表示されます）。

注記
Summaryウィンドウでは、User Time（ユーザ時間）とElapsed Time（経過時間）が別々のエントリとして記載されてい
ます。これら2つの違いは、経過時間がシミュレーションにかかった全時間を表すのに対して、ユーザ時間はCPUが
計算を行うのにかかった時間だけを表します。すなわち、CPUがシミュレーションだけを実行し、他のプロセスに占
有されなかった場合は、ユーザ時間と経過時間は一致します。

サブストレートおよびメッシュ統計の例については、サブストレート計算のステータスの表示およびメッシュ・サマリの表示を参照してください。
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Momentumシミュレーション・エグゼクティブ・システム

ADS 2005Aより、Momentumのリモート・シミュレーションの実行に2つのシミュレーション・エグゼクティブ・システムが使用できるようになりました。こ
のリリースより前に使用されていたエグゼクティブ・システムは、EMXエグゼクティブ・モデルに基づくものです。新しいエグゼクティブ・システムは、
PVM（Parallel Virtual Machine）ネットワークを利用します。

EMXシミュレーション・システムとPVMシミュレーション・システムの間には、いくつかの違いがあります。以下にその例を示します。

セットアップ要件とステータス・ウィンドウの扱い

PVMエグゼクティブ・システムには、以下のような新機能があります。

UNIX/Linuxマシン上でのMomentumシミュレーションをWindows PCから実行
Momentumシミュレーションの並列実行
異なるリモート・ホスト上でのMomentumシミュレーションの実行

PVMシステムの完全な実装はまだ完成していません。現時点では、バックグランドMomentum Sパラメータ・シミュレーションでのみ使用できます。他
の種類のシミュレーションや、Momentumに関連するAdvanced Model ComposerやMomentum Optimizationなどの他の製品では、今のところ使用で
きません。EMXが提供する他の機能のうちまだ実現されていないものを以下に示します。

フォアグランド・シミュレーション
待ち行列シミュレーション
Windows PCからWindows PCへのリモート・シミュレーション

PVMまたはEMXエグゼクティブ・システムを使ったリモート・シミュレーション

リモート・シミュレーションでは、デフォルトでPVMエグゼクティブが選択されます。ローカル・シミュレーションでは引き続きEMXが用いられます。リモ
ート・シミュレーションで強制的にEMXエグゼクティブを使用させるには、hpeesof.cfgファイルでMOMENTUM_SIM_PATH=<host>変数を定義します。こ
のファイルは$HOMEと$HPEESOF_DIRのどちらにあってもかまいません。ファイルは以下の4つのディレクトリのいずれかに置かれている必要があり
ます。ディレクトリはここに記載されている順序でサーチされます。

現在の作業用ディレクトリ（Advanced Design Systemを起動したところ）
$HOME/hpeesof/config（主に個々のユーザが使用）
$HPEESOF_DIR/custom/config（サイト全体に対してMomentumをリモート・モードに設定）
$HPEESOF_DIR/config（プリインストールされた構成、サイト全体に対して有効）

注記
MOMENTUM_SIM_PATHでシミュレーション・ホストを定義した場合は、この変数の定義を削除しない限り、すべて
のシミュレーションが指定されたホストで実行されます。

PVMのこのディストリビューションは、PVM 3.4.5の修正版を使用しています。修正は主にPVMの実行方法に関わるものです。例えば、エグゼクティブが使用
したり作成したりするファイルの名前は、pvmでなくeesofpvmで始まります。使用される構成変数も、PVMでなくEESOFPVMで始まります。

注記
PVMマニュアルのオンライン版は以下の場所にあります。http://www.csm.ornl.gov/pvm/pvm_home.html

PVMの権利について

注意

このソフトウェアとそのドキュメントは、上記の著作権表示がすべてのコピーに含まれ、著作権表示とこの許諾条件の両方がサポート・ドキュメントに
記載されるという条件で、いかなる目的のためにも無料で使用、コピー、配布できます。

機関（エモリー大学、オークリッジ国立研究所、テネシー大学）と著作者は、いかなる目的に対してもこのソフトウェアが適合することを保証しません。
このソフトウェアは、明示暗示を問わずいかなる保証もなく「現状のまま」で提供されます。

PVMバージョン3の開発資金の一部は、米国エネルギー省、米国立科学財団、テネシー州から拠出されています。

権利の制限について

PVM version 3.4:Parallel Virtual Machine System University of Tennessee, Knoxville TN.Oak Ridge National Laboratory, Oak Ridge TN.Emory
University, Atlanta GA. Authors:J. J. Dongarra, G. E. Fagg, G. A. Geist, J. A. Kohl, R. J. Manchek, P. Mucci, P. M. Papadopoulos, S. L. Scott, and V.
S. Sunderam

Â© 1997 All Rights Reserved

http://www.csm.ornl.gov/pvm/pvm_home.html
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リモート・シミュレーションの実行

Momentumでのシミュレーションには、かなりのコンピュータ・リソースが必要になる場合があります。必要に応じて、大量のRAMを積んだ強力なコン
ピュータをシミュレーション専用に用意し、他の作業にはもっと安価なワークステーションを使う方法もあります。この構成では、デザインや設定手順
はローカルの安価なワークステーションで実行し、高い計算能力を必要とするシミュレーション作業は専用のリモート・マシンで実行します。
 

注記
他のシミュレータでリモート・シミュレーションを実行する方法については、該当するインストール・ガイドを参照してく
ださい。

Momentumのリモート・モードは、LSF（Load Sharing Facility）機能をサポートしていません。代わりに分散モードを使用してく
ださい。

 
Momentumはリモート動作をサポートします。リモート・シミュレーションの実行には2つの方法があります。これらの方法を使ってリモート・シミュレー
ションを実行する場合は、以下のハードウェア構成が使用できます。
 
 

UNIX/LinuxからUNIX/Linux
WindowsからWindows
WindowsからUNIX/Linux

未サポート:

UNIX/LinuxからWindows
これらの構成でリモート・シミュレーションを実行する手順を以下に示します。

EMXを使ったリモート・シミュレーションの実行

このセクションでは、EMXエグゼクティブ・システムを使ってリモート・シミュレーションを実行する方法を説明します。
 

注記
ADS 2005Aより、リモート・シミュレーションのデフォルトの方法はPVMエグゼクティブ・システムを使用します。
hpeesof構成環境で環境変数MOMENTUM_SIM_PATHを設定すると、PVMが無効になります。PVMを再び使用可能
にするには、この変数を削除するかコメント化します。MOMENTUM_SIM_PATHの設定の詳細については、ローカル・
コンピュータの設定を参照してください。

この方法は以下の構成でサポートされます。
 
 

WindowsからWindows
UNIX/LinuxからUNIX/Linux

以下の構成では使用できません。

WindowsからUNIX/Linux
UNIX/LinuxからWindows

注記
すべてのシミュレーションは同じホストで実行されます。

UNIXからUNIX

このセクションでは、UNIXワークステーションを使ってAdvanced Design Systemのリモート・シミュレーションを実行する方法を説明します。

リモート・コンピュータの設定

リモート・コンピュータの設定には、以下の手順を実行します。

リモート・コンピュータにログインします。1.
リモートEMXデーモンを起動するために、HPEESOF_DIR変数が設定されていなければ、設定します。2.
次に、PATH変数に$HPEESOF_DIR/binを追加します。必ずPATHの先頭に追加してください。
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最後に、bourneまたはkornシェルで以下のコマンドを入力してデーモンを開始します。
.bootscript.sh（プラットフォーム固有の環境変数を設定）

hpeesofemx（EMXデーモンを開始）

あるいは、確認のために診断メッセージをファイルに保存する場合は、以下のコマンドを実行します。
hpeesofemx -d < file_name > &

注記
このコマンドは、bourneシェルとkornだけで使用できます。別のユーザがすでにeedaemonを起動している場合は、
起動しないでください。後からのリモート・ユーザも実行中のデーモンに接続できます。

ローカル・コンピュータの設定

変数MOMENTUM_SIM_PATHをhpeesof構成環境に設定する（hpeesof.cfgファイルで変数を定義します）必要があります。このファイルを作成または
変更する手順を以下に示します。

Momentumをリモートで実行することを指定し、Advanced Design System環境にリモート・サーバ名を伝えるために、構成ファイルを作成または変更
する必要があります。

ファイルを作成または変更するには、以下の手順を実行します。

以下の名前の構成ファイルを探し、なければ作成します。1.
hpeesof.cfg
以下の行をファイルに追加します。2.
MOMENTUM_SIM_PATH=< remote_computer_name >
以下の4つのディレクトリのどこかにファイルを置きます。 ディレクトリはこの順序でサーチされます。3.

現在の作業用ディレクトリ（Advanced Design Systemを起動したところ）
$HOME/hpeesof/config（主に個々のユーザが使用）
$HPEESOF_DIR/custom/config（サイト全体に対してMomentumをリモート・モードに設定）
$HPEESOF_DIR/config（プリインストールされた構成、サイト全体に対して有効）

ADSを起動します。4.

シミュレーションの実行

Momentumのリモート・シミュレーションを開始する手順は、ローカル・シミュレーションの場合と変わりません。同じメニュー・コマンドが使用できます。

Momentum > Substrate > Precompute
Momentum > Mesh > Precompute
Momentum > Simulation > S-parameters
Momentum > Post-Processing > Radiation Pattern

ただし、ローカル・シミュレーションとリモート・シミュレーションではファイルの使い方に多少の違いがあります。ローカル・シミュレーションは、テンポラ
リ・ディレクトリで実行されるのが普通です。 リモート・シミュレーションはこれとは別のディレクトリで実行されます。テンポラリ・ディレクトリは、tmpnamユ
ーティリティを呼び出すことで一意の名前を持つことが保証されますが、常に/usr/tmpまたは/var/tmpの下に作られます。これらのディレクトリがリモ
ート・サーバからアクセスできるのは、非常に緊密に結合されたクラスタの場合だけです。これは不必要に厳しい制限です。このため、リモート・コン
ピュータは結果をローカルの$HOME/mom_tmp/< temporary_name >に書き込みます。

リモート動作の終了

リモート・シミュレーション設定を終了する手順:

ローカル・マシンでADSを終了します。1.
hpeesof.cfgファイルの変更を元に戻します。2.
リモート・サーバで実行されているhpeesofemxデーモンを停止します。3.
リモート・サーバからログアウトします。4.

次にADSを起動したときは、Momentumがローカルで実行されます。

制限事項

リモート・シミュレーションには以下の制限があります。

$HOME/mom_tmp/< temporary_name >ディレクトリは、広範囲のアクセス・パーミッションを持ちます（0777）。
ローカル・ファイル・システムにある$HOMEディレクトリは、リモート・サーバからも（NFS経由で）同じパスで見える必要があります。
サブストレート計算が必要な場合は、ユーザが$HOME/substratesのアクセス・パーミッションを0777に設定し、その下のファイルのパーミッションを0666に設
定する必要があります。 これを忘れた場合は、ユーザ・インタフェースがこれをチェックし、ユーザに警告します。
ADS 1.3以上の場合は、リモートMomentumシミュレーションはSeries IV 6.1リリース305の場合と全く同じ動作をします。
Momentumのリモート・シミュレーションは、LSF（Load Sharing Facility）機能をサポートしません。

WindowsからWindows

このセクションでは、Windowsを使ってMOMENTUM_SIM_PATHによるリモートMomentumシミュレーションを実行する方法を示します。

サポートされるWindowsプラットフォームは以下のとおりです。
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Windows ® 2000 Professional SP4
Windows XP Professional SP2

リモート・コンピュータの設定

リモート・コンピュータを準備するには、以下の手順でリモートEMXデーモンを起動する必要があります。

HPEESOF_DIR変数が設定されていなければ、設定します。1.
PATH変数に%HPEESOF_DIR%\binを追加します。必ずPATHの先頭に追加してください。2.

WindowsまたはMS-DOS®シェルから、以下のコマンドでデーモンを起動します。3.
hpeesofemx
あるいは、確認のために診断メッセージをファイルに保存する場合は、以下のコマンドを実行します。
hpeesofemx -v -d < file_name >

注意
表示されたMS-DOSウィンドウを終了させないでください。終了させると、デーモンもその場で終了します。

ローカル・コンピュータの設定

Momentumをリモートで実行することを指定し、ADS環境にリモート・サーバ名を伝えるために、構成ファイルを作成または変更する必要があります。
ファイルを作成または変更するには、以下の手順を実行します。

以下の名前の構成ファイルを探し、なければ作成します。1.
hpeesof.cfg
以下の行をファイルに追加します。
MOMENTUM_SIM_PATH=< remote_computer_name >
以下の4つのディレクトリのどこかにファイルを置きます。 ディレクトリはこの順序でサーチされます。2.

現在の作業用ディレクトリ（ADSを起動したところ）。
%HOME%\hpeesof\config（主に個々のユーザが使用）
%HPEESOF_DIR%\custom\config（サイト全体に対してMomentumをリモート・モードに設定）
%HPEESOF_DIR%\config（プリインストールされた構成、サイト全体に対して有効）

ADSを起動します。3.

Windowsを使ったリモート・シミュレーションの実行

Momentumのシミュレーションを開始する手順は、ローカル・シミュレーションの場合と変わりません。同じメニュー・コマンドが使用できます。

Momentum > Substrate > Precompute
Momentum > Mesh > Precompute
Momentum > Simulation > S-parameters
Momentum > Post-Processing > Radiation Pattern

ただし、ローカル・シミュレーションとリモート・シミュレーションではファイルの使い方に多少の違いがあります。ローカル・シミュレーションは、テンポラ
リ・ディレクトリで実行されるのが普通です。 リモート・シミュレーションはこれとは別のディレクトリで実行されます。テンポラリ・ディレクトリは、tmpnamユ
ーティリティを呼び出すことで一意の名前を持つことが保証されますが、常に\tempの下に作られます。UNIXの場合と同様に、リモート・コンピュータ
は結果をローカルの%HOME%\mom_tmp\< temporary_name >に書き込みます。

リモート動作の終了

リモート・シミュレーション設定を終了する手順:

ローカル・マシンでAdvanced Design Systemを終了します。1.
hpeesof.cfgファイルの変更を元に戻します。2.
リモート・サーバで実行されているhpeesofemxデーモンを停止します。3.
次にADSを起動したときは、Momentumがローカルで実行されます。

制限事項

リモート・シミュレーションには以下の制限があります。

ローカル・ファイル・システムにある$HOMEディレクトリは、リモート・サーバからも同じパスで見える必要があります。このために、ドライブ全体をPC間で共有
する必要があります。
サブストレート計算が必要な場合は、ユーザが$HOME\substratesディレクトリとその下のファイルを読み書き可能に設定する必要があります。これを忘れた
場合は、ユーザ・インタフェースがこれをチェックし、ユーザに警告します。

PVMを使ったリモート・シミュレーションの実行

このセクションでは、PVMを使ってリモート・シミュレーションを実行するために必要な設定を示します。

ローカル・コンピュータの設定

シミュレーションの前に、以下の手順を実行する必要があります。
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クラスタの作成と設定

最初に、使用するクラスタを指定するために構成ファイルを作成または変更する必要があります。

構成ファイルを作成または変更するには、以下の手順を実行します。

コマンド・プロンプトから、以下のクラスタ構成ファイルを作成または編集します。1.

mysimcluster.cfg

このファイルは通常$HOMEディレクトリの下にありますが、システムの他の場所に存在する場合もあります。

このファイルには以下の情報が含まれる必要があります。2.
各ホスト・タイプに対して:
<> dx=<eesofpvmd>

注記
このファイルでは変数置換はサポートされません。

例:

#configuration for mysimcluster
<linuxhost> dx=/<eesofroot>/pvm3/bin/eesofpvmd
<unixhost> dx=/<eesofroot>/pvm3/bin/eesofpvmd
<winhost> dx=D:\<eesofroot>\pvm3\bin\eesofpvmd

注記
<winhost>は1つしか存在できず、ADSを実行するホストに一致する必要があります。

ファイルを保存します。3.
次に、システム環境変数EESOFPVMHOSTFILEをmysimcluster.cfgを指すように設定します。4.
例えば、

EESOFPVMHOSTFILE=$HOME/hpeesof/config /mysimcluster.cfg

別の方法として、hpeesof構成環境でこの変数を設定する（hpeesof.cfgファイルで変数を定義する）こともできます。ここで変数を設定すると、システム環境での変数設定よ
りも優先されます。
このファイルを作成または変更するには、以下の手順を実行します。

以下の名前の構成ファイルを探し、なければ作成します。
hpeesof.cfg
以下の行をファイルに追加します。
EESOFPVMHOSTFILE=< 構成ファイルの場所と名前 >

注記
変数MOMENTUM_SIM_PATHが定義されている場合は、コメント化する必要があります。

以下の4つのディレクトリのどこかにファイルを置きます。 ディレクトリはこの順序でサーチされます。

現在の作業用ディレクトリ（ADSを起動したところ）。
$HOME/hpeesof/config（主に個々のユーザが使用）
$HPEESOF_DIR/custom/config（サイト全体に対してMomentumをリモート・モードに設定）
$HPEESOF_DIR/config（プリインストールされた構成、サイト全体に対して有効）

また、リモート・シミュレーションが動作するためには、リモート・ホストにユーザ名／パスワードを指定せずにログインできる必要があります。このためには、5.
remsh/rshまたはsshを使用できます。
rsh/remshが動作するかどうかを確認するには、以下の手順を実行します。

LinuxおよびSunシステムの場合は、コマンド・ウィンドウをオープンして以下のように入力します。

rsh <unix/linuxhost> pwd
HPUXの場合は、コマンド・ウィンドウをオープンして以下のように入力します。

remsh <unix/linuxhost> pwd
PCの場合は、コマンド・ウィンドウでbash shellをオープンして以下のように入力します。

rsh <unix/linuxhost> pwd

注記
PCでrshを使用するには、PATH環境変数に%HPEESOF_DIR%\tools\binを追加する必要があります。bash shellを
オープンするには、コマンド・プロンプト・ウィンドウをオープンして、"bash"と入力します。

これにより、そのマシン上のホーム・ディレクトリが返されます。返されない場合は、.rhostsファイルを編集して、マシン名とログイン名（例: <hostname> <login>）が記録されていることを確認するか、シス
テム管理者に問い合わせて、~/.rhosts、/etc/hosts.equiv、または/etc/pam.d/rshファイル（ローカル・システムのタイプによる）が正しく設定されているかどうかを確認します。

ADSを起動する前にEESOFPVM_RSH環境変数をssh実行ファイルに設定しておけば、sshを使ってPVM環境を開始できます。remsh/rshの場合と同様に、

ssh <host>
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を使ってパスワードなしでログインできる必要があります。sshの正しい設定については、sshマニュアル・ページを参照してください。

ADSを起動します。6.

クラスタはADS > Momentum > Setupリモート・セットアップ・ダイアログにより開始されます。

注記
クラスタ構成ファイルに多数のリモート・ホストが定義されている場合は、Momentum Simulation Setupからクラスタ
環境を起動するのに時間がかかることがあります。クラスタ・サーバの1つで起動時に問題が発生した場合は、セッ
トアップが終了するまでに数分かかったり、タイムアウト・エラーで終了したりする可能性があります。起動時の問題
については、以下を参照してください。
UNIX/Linuxの場合は、$EESOFPVM_TMP/ eesofpvml.<uid>
Windowsの場合は、%EESOFPVM_TMP%\ eesofpvml.<login name>。これらのファイルには、クラスタ管理関連のすべ
てのログ・メッセージが記録されます。EESOFPVM_TMPが設定されていない場合は、デフォルトで/ _tmp
（UNIX/Linux）および%TEMP%（Windows）になります。

リモート／分散のセットアップ

Momentum > Simulation > Setupを使ってMomentum Simulation Setup（MomSimSetup）ウィンドウをオープンします。

リモート・シミュレーションと分散シミュレーションのどちらの場合も、Momentum Simulation Setupウィンドウでラジオ・ボタンをremoteモードに設定し
て、PVMクラスタを起動する必要があります。

注記
サードパーティ製ワークロード管理システムによる分散シミュレーションで、ローカル・マシンが有効な登録ホストの
場合は、正式のPVMクラスタ構成は定義しないでください。ローカルPVMデーモンが起動し、ワークロード管理シス
テムに対する登録／モニタ機能を提供します。

注記
セットアップ・ダイアログにeesofdeamonによるリモートのみが表示されている場合は、hpeesof環境に
MOMENTUM_SIM_PATH変数が設定されているかどうかを確認してください。設定されている場合は、その設定をコ
メント化するとダイアログ全体が使用可能になります。

 
 

http://www.openssh.org/manual.html
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注記
リモートまたは分散シミュレーション構成を選択すると、アクティブなシミュレーション処理モードは自動的にバックグ
ランドに設定されます。すなわち、サブストレート・データベースの計算に関する確認は要求されず、メッシュはレイ
アウト・ウィンドウに表示されず、周波数ポイントに対する結果が使用可能になってもデータ・ディスプレイは自動的
に更新されません。

テンポラリ・リモート・シミュレーション・ディレクトリとしてローカル・テンポラリ・シミュレーション・ディレクトリ以外を使用したい場合は、そのディレクトリ
の場所をこのダイアログのTemporary Remote Simulation Directoryセクションに入力します（例: /var/tmp/<anyname>）。これは、リモート・シミュレー
ションを実行する際に、ローカル・テンポラリ・ディレクトリが作成されるディレクトリにリモート・マシンがアクセスできない場合に特に有効です。
 

注記
並列に実行されるシミュレーションは、異なるリモート・テンポラリ・ディレクトリを使用する必要があります。そうしな
いと、シミュレーション結果が相互に干渉し、間違った結果が生じます。リモート・ホスト上のテンポラリ・ディレクトリ
は、存在しない場合は作成され、不要になったとき（シミュレーションが成功したとき）に空になりますが、ディレクトリ
自体は削除されません。

 
リモート・ホストとローカル・ホストが一致する場合は、リモート・テンポラリ・ディレクトリはローカル・テンポラリ・ディレクトリと一致する必要がありま
す。リモート・テンポラリ・ディレクトリがローカル・テンポラリ・ディレクトリと同じ物理的位置を指す場合は、オペレーティング・システムのネイティブ・フ
ァイル転送プロトコル（nfsなど）が用いられます。この転送が成功するためには、プロジェクト・ディレクトリへのローカル・パスとリモート・パスが一致
する必要があります。リモート・テンポラリ・ディレクトリがローカル・テンポラリ・ディレクトリと異なる場合は、PVMを使ってホスト間のファイル転送が行
われます。この場合は、転送可能な最大ファイル・サイズは、ホスト上で可能な最大プロセス・サイズの半分より少し小さくなります。
 
 
ローカル・マシンがWindows PCで、UNIX/Linuxホスト上のリモート・ディレクトリを<drive>:/pathとして指定した場合は、実際にシミュレーションが実行
される場所はhost: <your LoginDirectory>/<drive>:/<path>ですが、ステータス・ウィンドウにはhost <drive>:/<path>と表示されます。

クラスタの開始／停止制御

Startボタンを選択すると、Simulation System startupダイアログが表示されます。このダイアログは、シミュレーション・システムが起動することを通
知し、クラスタ構成ファイルを確認するオプションを提供する役割を果たします。
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Show Cluster Configuration when Startedチェック・ボックスを選択すると、Simulation System Configurationダイアログが表示されます。Simulation
System Configurationダイアログは、PVMクラスタに関する以下の情報を提供します。

構成ファイル内のホスト数
ホスト名、アーキテクチャ、速度
 

 

注記
速度は、クラスタ構成ファイルで指定しない限り、デフォルトで1000になります。PVMドキュメントを参照してくださ
い。これはマシンの実際の速度を表すものではありません。

ここに表示された情報が期待したものと異なる場合（ホストがすべてリストされていない場合など）、Helpをクリックします。トラブルシューティング・ドキュメントのPVMトラブ
ルシューティングのセクションがオープンします。
 

注記
このダイアログをクローズすると、シミュレーションが実行された後で再オープンすることはできません。このダイ
アログを再オープンするには、シミュレーション・システムを終了してPVMクラスタを停止し、新たにシミュレーショ
ンを開始する必要があります。

 
クラスタが動作を開始したら、get host listボタンを使って、クラスタ環境からADS UIに使用可能なホストのリストを表示できます。
 
 

リモート・シミュレーションの開始

シミュレーション・プロセスは、サブストレートに対して事前計算されたグリーン関数とメッシュ計算の結果を組み合わせて、電流を計算します。その
結果からSパラメータが求められ、データセットに保存されます。

シミュレーションを開始する手順:

Momentum > Simulation > S-parametersを選択します。1.
Frequency Plansリストに最低1個の周波数プランが存在することを確認します。2.
Process Mode、Solution Files、Data Displayの各オプションが適切に設定されていることを確認します。3.
リモート・ホストまたはワークロード管理システムの待ち行列をドロップダウン・フィールドで選択します。4.
Simulation Controlダイアログで、Simulateをクリックします。5.
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分散セットアップ

サードパーティ製ワークロード管理システム（LSF、PBS Professional、Sun Grid Engineなど）を使用する場合は、Momentum Simulation Setupウィンド
ウでDistributedモードを使用します。

分散モードでは、サードパーティ製のワークロード管理システムが、ADS関連のタスクを登録ホスト（ワークロード管理システムに投入されるジョブの
追加／モニタを行うマシン）上のユーザのコマンド・ライン環境から実行できるようにあらかじめ設定されていることを仮定しています。サードパーティ
製ワークロード管理システムの設定方法については、お使いの環境のドキュメントを参照してください。ADSの構成情報は、インストール・ガイドに記
載されています。

Distributeモードが動作するためには、パーソナル・マシンと、ワークロード管理システムの登録ホストとして使用するマシンとの間に、リモート・シミュ
レーションPVMクラスタが設定されている必要があります。分散モードは、ADSのPVMベースのリモート・シミュレーション・システムの拡張です。

分散シミュレーションは、Momentum Simulation SetupウィンドウでDistributedラジオ・ボタンを選択した場合に用いられます。
 
 

 

Simulation Typeによって、ワークロード管理システム内でMomentumシミュレーションがどのように実行されるかを選択できます。

Single Job設定では、Momentumシミュレーション全体がワークロード管理システムの待ち行列に登録され、1つのマシン上の1つのジョブとして実行されます。
Distributed Jobを選択すると、Momentumシミュレーションがワークロード管理システム内の複数のマシンに分割されます。メイン・エンジンが周波数掃引を制
御し、いくつかのスレーブ・エンジンがマスタ・エンジンのために周波数ポイントを計算します。
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注記
ADS 2008アップデート1では、Distributed Job設定は均質なLinuxマシンのクラスタ内でのみサポートされます。す
なわち、クラスタの登録マシンとすべての計算クライアントがLinuxホストであることが必要です。

 
Number of parallel jobs設定により、周波数ポイントを並列に計算するためにクラスタ内で起動するスレーブ・シミュレータの数を選択できます。この数は、使用可能なライ
センス数や、管理者がクラスタに設けている制限のために、オーバライドされる可能性があります。

分散セットアップにおけるリモート・ディレクトリ指定の機能と動作は、リモートPVMシミュレーションの場合と同じです（上記のテンポラリ・ディレクトリ
へのリンクの説明を参照）。分散シミュレーションではさらに、ワークロード管理システムがこのリモート・テンポラリ・ディレクトリに対して適切なアクセ
ス権を持つことを仮定しています。

ローカル・ユーザ名がクラスタ上のユーザ名と異なる場合は、登録ユーザ名を指定します。

オプションのメール通知およびメール・アドレス・フィールドを指定できます。

Submitラジオ・ボタンでは、Simulateボタンを選択したときにジョブをただちにワークロード・システムに登録するか（immediately）、ワークロード管理シ
ステム用の高度なオプションを設定するウィンドウを表示した後に登録するか（after advanced job setup）を指定できます。

"Submit host"フィールドでは、登録ホストとして使用するPVMリモート・シミュレーション・クラスタのホストを指定します（これはローカル・マシンでもか
まいません）。 PVMがアクティブであることが必要です。Check setupは、PVM環境が正しく初期化されているかどうかを検証します。

Get queue listは、使用可能な待ち行列のリストをワークロード管理システムに問い合わせるようにPVMシステムに要求します。このボタンを最初に
押したときには、応答が表示されるまで時間がかかったり、タイムアウトが発生したりする場合があります。特に、リモート・マシンを登録ホストとして
使用している場合はこの傾向があります。これは通常、ワークロード・システムとの実際の通信を実行するpythonベースのクラスタ制御プログラムを
まだ起動していないPVMシステムが存在することが原因です。

ワークロード・システムとの通信が終了すると、default queueのドロップダウン・リストに、登録ホストから参照できる使用可能な待ち行列の一覧が表
示されます。その後、ワークロード管理システムでジョブを起動するためのデフォルトの待ち行列を指定できます。

"Default resource string"には、サードパーティ製ワークロード管理システムのオプション・フラグやリソース指定構文を入力できます。これはワーク
ロード・システムに直接渡されます。

 

注記
速度は、クラスタ構成ファイルで指定しない限り、デフォルトで1000になります。PVMドキュメントを参照してください。
これはマシンの実際の速度を表すものではありません。

 
ここに表示された情報が期待したものと異なる場合（ホストがすべてリストされていない場合など）、Helpをクリックします。トラブルシューティング・ドキ
ュメントのPVMトラブルシューティングのセクションがオープンします。

 

注記
このダイアログをクローズすると、シミュレーションが実行された後で再オープンすることはできません。このダイアロ
グを再オープンするには、シミュレーション・システムを終了してPVMクラスタを停止し、新たにシミュレーションを開
始する必要があります。

トラブルシューティング

リモート・シミュレーション

クラスタが起動しない。1.
eesofpvmd3デーモンがシステムで動作しているかどうか確認します。動作していない場合は、以下のいずれかのファイルが存在するなら、そのファイルを削
除します。

$EESOFPVM_TMP/ eesofpvmd.<uid>（UNIX/Linux）

または

$EESOFPVM_TMP/ eesofpvmd.<userName>（Windows）

再度試みるとクラスタが起動するはずです。

注記
EESOFPVM_TMPが設定されていない場合は、デフォルトで/tmp（UNIX/Linux）および%TEMP%（Windows）になりま
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す。上記のファイルは、以前にeesofpvmクラスタが異常終了した場合は、すなわちクラスタを終了せずにオペレー
ティング・システムをシャットダウンした場合に生じます（項目3クラスタ・デーモン（eesofpvmd3）が動作し続けるを
参照）。

 

クラスタが不完全。2.
以下のいずれかのファイルを参照することで、問題に関連する情報が得られる可能性があります。

$EESOFPVM_TMP/ eesofpvml.<uid>（UNIX/Linux）
$EESOFPVM_TMP/ eesofpvml.<userName>（Windows）

デーモンが動作しておらず、以下のいずれかのファイルが存在する場合は、そのファイルを削除します。

$EESOFPVM_TMP/ eesofpvmd.<uid>（UNIX/Linux）
$EESOFPVM_TMP/ eesofpvmd.<userName>（Windows）

パスワードを入力せずにリモート・ホストでremshまたはrshを実行する権限がない。
これを確認するには、以下の手順を実行します。
LinuxおよびSunの場合は、コマンド・ウィンドウに以下のように入力します。

rsh <unix/linuxhost> pwd

hpuxの場合は、コマンド・ウィンドウに以下のように入力します。

remsh <unix/linuxhost> pwd

Windowsの場合は、コマンド・ウィンドウでbash shellをオープンして以下のように入力します。

rsh <unix/linuxhost> pwd

注記
PCでrshを使用するには、PATH環境変数に%HPEESOF_DIR%\tools\binを追加する必要があります。bash shellを
オープンするには、コマンド・プロンプト・ウィンドウをオープンして、"bash"と入力します。

これにより、そのマシン上のホーム・ディレクトリが返されます。返されない場合は、.rhostsファイルを編集して、マシン名とログイン名（例: <hostname> <login>）が記録され
ていることを確認するか、システム管理者に問い合わせて、~/.rhosts、/etc/hosts.equiv、または/etc/pam.d/rshファイル（ローカル・システムのタイプによる）が正しく設定
されているかどうかを確認します。
 
これにより、ホーム・ディレクトリが返されます。返されない場合は、システム管理者に問い合わせて、~/.rhosts、/etc/hosts.equiv、/etc/pam.d/rshファイルが正しく設定さ
れているかどうか確認してください。
 

注記
Remote to Windowsは本リリースではサポートされていません。

 

クラスタ・デーモン（eesofpvmd3）が動作し続ける。3.
これは正常な動作モードです。eesofpvmクラスタを停止したい場合は、Momentum Remote Simulation Consoleで終了する前にhalt eesofpvm cluster when
exitingチェック・ボックスを選択するか、プログラム$HPEESOF_DIR/pvm3/bin/eesofpvmを実行してプロンプトにhaltと入力します。
 

 
クラスタ構成を知るには？4.
$HPEESOF_DIR/pvm3/bin/eesofpvmを実行し、プロンプトにconfと入力します。これにより、現在クラスタ中にあるすべてのホストが表示されます。クラスタを
停止せずにプログラムを終了するには、quitと入力します。
クラスタ上で実際に実行されているジョブを知るには？5.
$HPEESOF_DIR/pvm3/bin/eesofpvmを実行し、プロンプトにps -aと入力します。クラスタを停止せずにプログラムを終了するには、quitと入力します。
UNIX/Linuxホストを動的にクラスタに追加するには？6.
$HPEESOF_DIR/pvm3/bin/eesofpvmを実行し、プロンプトにadd "<hostname> dx=<path to pvmd on this host>"と入力します（引用符は必要）。クラスタを停
止せずにプログラムを終了するには、quitと入力します。
UNIX/Linuxホストを動的にクラスタから削除するには？7.
$HPEESOF_DIR/pvm3/bin/eesofpvmを実行し、delete "<hostname> dx=<path to pvmd on this host>"と入力します（引用符は必要）。クラスタを停止せずに
プログラムを終了するには、quitと入力します。
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分散シミュレーション

登録ホストとローカル・マシンの間のPVMクラスタがあらかじめ動作している必要があります。リモート・シミュレーションのPVMクラスタ・セットアップを
参照してください。

Get queue listが有効な待ち行列を返さない。

ワークロード管理システムへの手動登録が動作するかどうか、また登録ホスト上の自分のアカウントでジョブと待ち行列のチェック（LSFのbqueues、SGEの
qconf -sql）が動作するかどうかを確認します。
ADSのすべてのクラスタ管理プログラムが登録ホスト上でアクティブであることを確認する必要があります。UNIXの/tmpまたはWindowsの%TEMP%に、
eesofpvml.<uid>.log、eesofClmClient.log、eesofClmServer.logが存在するはずです。これらのファイルにエラーが記録されていないかどうか確認します。
eesofpvmdおよび2つのpythonプロセスが動作していることを確認します。

システムから待ち行列リストは得られるが、シミュレーションを登録した後、シミュレーション・サマリで登録したジョブがSubmitted状態で表示されな
い。

LinuxおよびSolarisでの64ビットMomentumシミュレーション

64ビットMomentumシミュレーションは、未知電流の数が多い大規模な問題の計算をサポートします。32ビット・アーキテクチャの本質的なメモリの制
限により、32ビット・マシンでは解くことができなかった複雑な問題が、64ビットMomentumでは解ける可能性があります。これは、64ビット・アーキテク
チャで増加したメモリ・オーバヘッドと処理能力を利用することで実現されます。

64ビットMomentumシミュレーションを実行するには、64ビット・マシンをリモート・ホストとして選択します。シミュレーションは他のリモート・シミュレーシ
ョンと同様に実行されます（PVMを使ったリモート・シミュレーションの実行を参照）。

バッチ・モード・シミュレーション

バッチ・モード・シミュレーションの設定と制御には、Queue Managerダイアログ・ボックスを使います。Queue Managerは、待ち行列ジョブを登録したと
きに自動的に開始されます。 また、ADSのMainウィンドウでTools > Queue Managerを選択して起動することもできます。ADSを終了すると、
Momentum待ち行列と実行中のすべてのジョブが終了します。

待ち行列が通常モードで動作している（待ち行列が接続されている）場合は、現在のジョブが終了すると待ち状態の最初のジョブが自動的に開始さ
れます。待ち行列がQueue Disconnected（切断）モードの場合は、現在のジョブが終了しても待ち状態の最初のジョブは自動的に開始されません。

接続状態では、Queue Managerを使って待ち行列中のジョブを表示できます。待ち行列が切断されているか、開始されていない場合は、Queue
Managerを使って待ち行列中のジョブを表示できるだけでなく、予定されているジョブの追加、変更、削除を行ったり、待ち行列中のジョブの順序を変
更したりできます。
 

注記
現在アクティブな（シミュレーション実行中の）ジョブは、Queue Managerを使って変更できません。このようなジョブを
変更するには、待ち行列を切断し、シミュレーションを停止し（シミュレーションの停止を参照）、変更を行った後、再
開します。

 
バッチ・モード・シミュレーションを実行する手順:
 

シミュレートしたいデザインを定義します。1.
Momentum > Simulation > S - parametersダイアログ・ボックスで、Process ModeのQueuedを選択し、simulateを選択します。2.
上記2つのステップを繰り返して、その他のシミュレーションを待ち行列に追加します。3.
すべてのシミュレーションが待ち行列に追加されたら、Queue ManagerでStart Simulationsを選択して、シミュレーションを開始します。4.

注記
シミュレーションが実行中でないのにQueue Managerが実行中と表示する場合は、command lineダイアログ・ボッ
クスでqueue_reset()と入力して問題を解決できます。

 

注意
同じADSセッションからMomentumシミュレーションを並列に（例えば、直接のMomentumシミュレーションと待ち行
列を使ったMomentumシミュレーション）実行した場合は、両方のシミュレーションが同時に終了すると、シミュレー
ション・データが失われるおそれがあります。
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注記
複数のMomentumバッチ・シミュレーションを異なるプロジェクトから実行した場合は、シミュレーション終了後に新
しいシミュレーションを別のプロジェクトからロードするために、アクティブ・プロジェクト・ディレクトリが変更されま
す。

適応周波数サンプリング

適応周波数サンプリング（AFS）は、サンプリングされたSパラメータ・データを有理フィッティング・モデルと比較する方法です。回路のスペクトル応答
を正確に表現するために、MomentumのAFS機能は、最小限の周波数サンプルを収集してそのアルゴリズムを適用します。Sパラメータの変化が大
きいところでは、多くのサンプルが収集されます。フィッティング・モデルとサンプル・データが収束すると、AFSアルゴリズムは終了し、Sパラメータ・デ
ータがデータセットに書き込まれます。このようにして、最小限のサンプリングで最大限の情報が得られます。

AFS機能を使うと、共振など検出が難しい急峻な応答を示す回路のシミュレーション時間を大幅に短縮できます。他のタイプの解析では見逃してしま
うデータを得ることができます。

ローパス・フィルタの場合でさえ、AFSを使うと離散データ・サンプリングよりも高速かつ正確にSパラメータを求められます。例えば、2 GHzのローパ
ス・フィルタを測定する場合は、AFS機能をオンにして、スタート周波数に500 MHz、ストップ周波数に4 GHzを指定します。AFSは両端の周波数ポイ
ントをサンプリングし、フィッティング・モデルを構築し、必要に応じて中間のポイントをサンプリングします。この過程で、モデルは自動的に改良され、
モデルとサンプル・データが収束するまで、適切なサンプル・ポイントが収集されます。収束すると、サンプル・データとAFSデータがそれぞれ異なる
データセットに書き込まれ、Sパラメータ・トレースとしてプロットに表示できます。収束より前に最大サンプル・サイズに達した場合は、途中までの結
果が保存され、回路を再びシミュレートするときに再利用できます。

 

注記
AFSデータが正確なのは、収束した場合に限ります。収束したかどうかは、Momentum Statusウィンドウのメッセー
ジでわかります。データが収束していない場合は、結果は不正確です。

 

AFSの収束

収束は、フィッティング・モデルがサンプル・データにどの程度近いかによって判定されます。収束と見なされるのは、サンプル・ポイントの精度が-75
dB、全体の精度が-60 dBの場合です。

AFSを使用する場合は、サンプル・データとフィッティング・モデルが収束していることを確認する必要があります。これはステータス・ウィンドウのメッ
セージでチェックできます。収束していれば、AFSが終了したというメッセージが表示されます。収束していなければ、警告が表示されます。警告メッ
セージの例を以下に示します。

Maximum number of adaptive frequency samples reached!
Fitting models not (completely) converged.
Consider - increasing maximum number of sample points.
- activating the reuse option.

エラーが発生した場合は、周波数プランの周波数レンジを小さくし、サンプル・ポイントの数を増やしてみてください。電気的に長い回路では、理論的
には数十個のポイントが収束に必要な場合があります。 これは、位相変化が大きいSパラメータの場合は、AFSプログラムがデータを（スミス・チャー
ト上で）約60°ごとにサンプリングするからです。

注記
シミュレーションが収束しない場合に、シミュレーションの品質を評価するには、データ・ディスプレイで収束結果を調
べます。

 

サンプル・ポイントの設定

シミュレーションで適応掃引タイプを使用する場合は、AFSプロセスに特定のサンプル・ポイントを使用させたいことがあります。一般にはこれは不要
であり、むしろ推奨しませんが、そうしたほうがよい場合もあります。これが有効なアプリケーションの例として、共振ストラクチャのように、周波数レン
ジのあるポイントで応答の急激な変化が発生するストラクチャのシミュレーションがあります。

シミュレーションを設定する手順:

Single掃引タイプを選択し、共振周波数またはそれに近い値をFrequencyフィールドに入力して、周波数プランのリストに追加します。1.
Adaptive掃引タイプを選択し、プランを作成し、周波数プランのリストに追加します。2.

この場合のサンプル・ポイントは、回路応答に明確な変化がある領域をAFSに示す役割を果たします。
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ビジュアリゼーションおるいは遠方界計算のためにはサンプル・ポイントの追加が必要となる場合があります。

他の目的でサンプル・ポイントを追加する場合、例えばあるポイントでスムージングを強制するなどの場合は、これらのポイントでの応答を考慮しな
ければうまくいきません。

例えば、

Linear掃引タイプを選択し、周波数レンジ全体にリニアに分布したサンプル・ポイントを追加し、周波数プランをリストに追加します。1.
Adaptive掃引タイプを追加し、同じ周波数レンジを選択し、リストに追加します。2.

この場合は、リニア・シミュレーションのサンプル・ポイントが適応シミュレーションで用いられます。このため、この周波数レンジで最適なサンプル分
布をAFSプロセスが選択できず、シミュレーション結果が悪化することがあります。

これを修正するには、適応掃引プランを先に実行するか、2つのプランの周波数レンジが重ならないようにします。

AFS Sパラメータの表示

AFSデータセットのSパラメータ表示を拡大してみると、予期しない小さなスプリアス・リップルまたは振動（振幅が0.0002以下のもの）が見られること
があります。この振動の振幅は、AFSの精度レベル（約-60 dB）よりも常に小さくなります。一般に、この種のリップルが見られるのは、Sパラメータの
ダイナミックな動作が限定されている場合（例えばシミュレーション周波数レンジ全体でほぼ1の場合など）です。この原因はおそらく、有理フィッティン
グ・モデルの自由度が大きすぎ、この条件に対して複雑すぎるということです。

Momentumソルバについて

Momentumには、電磁界の問題のモーメント法による記述から得られた連立一次方程式を解くための以下の3種類のソルバがあります。

従来の直接ソルバ。これは密なMoM方程式系が対象です。
反復Krylovソルバ
直接圧縮行列ソルバ

自動選択モードでは、Momentumは電磁界の問題に対して適切なソルバを自動的に選択します。判定に用いられる条件は、問題のサイズ（未知数
の個数）、問題のその他の特性（特に、反復ソルバのプリコンディショニングの容易さと有効性）、Momentumが動作しているプラットフォーム／マシン
です。

直接ソルバと反復ソルバ

従来の直接ソルバは、アルゴリズムとしてガウスの消去法を用いて、系の正方行列のLU分解を行い、下三角行列Lと上三角行列Uから構成される
三角行列に対して2ステップからなる単純な計算を行うことで、系全体を解きます。この計算方法はきわめて信頼性が高く、あらゆる問題に対して有
効ですが、LU分解の段階で系の未知数の個数の3乗に比例した時間がかかるため、計算時間が長くなる傾向があります。

（密な線形システムに対するガウス消去法は、未知数個数をNとして、N^3のオーダのプロセスです）。このため、未知数個数が多いMomentumの問
題に対して直接ソルバを使用すると、シミュレーションの解計算段階にかかる時間がシミュレーション時間全体を支配するようになります。これは、未
知数が5000個以上の場合に起こります。特に、Momentum RFモードの場合は、時間のかかるロード・ステップはすべての周波数ポイントに対して1
回だけなのに対して、解計算段階はすべての周波数ポイントに1回ずつ必要なので、この傾向が強くなります。

反復Krylov部分空間ソルバは、システム行列の分解という時間のかかる手順が必要なく、一連の行列ベクトル積を使って、線形システムの解の良
好な近似を反復的に計算します。Krylov部分空間法を使うと、多くの問題において、問題のサイズ（未知数の個数）に比べて非常に少ないステップ数
で線形システムの解を得ることができます。すなわち、この方法の計算時間は、与えられた問題に対して行列ベクトル積がどれだけ効率的に計算で
きるかによって基本的に決まります。密なシステム行列を持つ線形システムの場合は、行列ベクトル積の計算時間は、システムの未知数の個数の2
乗に比例して増加します。

ただし、システム行列一般に対する反復Krylovソルバの信頼性は、直接ソルバに比べてはるかに劣ります。単に直接ソルバより計算時間が短いこと
が保証されていないだけでなく、Momentumの問題で見られるあらゆる種類のシステム行列に対して反復ソルバが正しく収束することすら保証されて
いません。反復Krylovソルバの有効性は、連立一次式に適用されるプリコンディショニングに大きく依存します。プリコンディショニングとは、反復計
算法の収束性を改善するために線形システムに適用する変換のことです。プリコンディショニングの方法は経験的であり、問題によって異なる場合
が多く、非常に単純で高速なものから、多くの処理オーバヘッドを必要とする複雑なものまであります（後者の場合は速度の利点が相殺されます）。

反復ソルバの収束性の複雑さと、最適なソルバが問題によって異なることから、ユーザが手動でソルバを選択するには困難が伴います。この困難を
回避するために、Momentumは現在の問題に対して最適なソルバを自動的に選択します。このために、場合によってはMomentumが直接ソルバに
切り替えて再計算を行う必要がありますが、それでもAFSポイントを追加するのに比べれば計算コストは低くなります。

密行列ソルバと圧縮行列ソルバ

従来の直接ソルバと反復ソルバは、電磁界の問題のモーメント法による記述から得られる連立一次式の密行列表現を扱います。このため、行列の
記憶に必要なメモリは、行列のサイズをNとして、N^2のオーダで増加します。これに対して、Momentumの新しい独自の行列圧縮法では、行列の記
憶に必要なメモリを減らすことができます。圧縮状態では、行列に必要なメモリはNlogNのオーダでしか増加しないので、利用可能RAMが限られたコ
ンピュータではるかに大きいストラクチャをシミュレートできます。
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行列ソルバ選択の手動オーバライド

GUIで選択される行列ソルバをユーザがオーバライドするには、momentum.cfg構成ファイルの1つでMomentum構成変数
MOM3D_USE_MATRIXSOLVERを設定します。

この変数の有効な設定は以下の5種類です。

MOM3D_USE_MATRIXSOLVER=0では、デフォルトの自動ソルバ選択メカニズムが用いられます。
MOM3D_USE_MATRIXSOLVER=1では、最適化されたLAPACKおよびBLASライブラリを使用する2004A直接密行列ソルバが用いられます。
MOM3D_USE_MATRIXSOLVER=2では、2004Aより前の直接密ガウス消去法ソルバが用いられます。
MOM3D_USE_MATRIXSOLVER=3では、反復Krylov密行列ソルバが用いられます。
MOM3D_USE_MATRIXSOLVER=4では、直接圧縮行列ソルバが用いられます。

Momentumの計算速度のチューニング

今日のコンピュータでは、プロセッサのレジスタ、キャッシュ、メイン・メモリ、スワップ・メモリの間に、帯域幅とレイテンシの大幅な違いが存在します。
データにアクセスする際に、異なるメモリ・レベルへのアクセスをできるだけ減らすことにより、アルゴリズムの速度が大きく変化します。Momentumシ
ミュレーションの解計算段階で用いられる1次方程式ソルバは、方程式行列の要素ブロックを処理します。最高の性能を得るには、行列ブロックのサ
イズがマシンのメモリ階層に適合する必要があります。最適なブロック・サイズは、コンピュータのタイプに大きく依存し、Momentumの問題のサイズ
にも多少依存します。ブロックのサイズから生じるデータの局所性がマシンのメモリ／キャッシュ構成に適合する場合は、アルゴリズムのブロック演
算の高速化によって計算速度が大幅に改善されます。

UNIXプラットフォーム（HP-UX、Solaris、Linux）の場合は、整数構成変数MOM3D_USE_MATRIXSOLVERBLOCKSIZEの値をmomentum.cfgファイルで
設定することにより、Momentumを実行するコンピュータの性能と問題のサイズに応じて、Momentumの線形ソルバをチューニングできます。このブロ
ック・サイズのデフォルト値としては一般的に適切な値が選択されていますが、大規模なMomentumの問題の場合は、この設定を変えてみるとシミュ
レーション時間を短縮できる可能性があります。

設定の例:

MOM3D_USE_MATRIXSOLVERBLOCKSIZE = 16

8〜96の範囲の値をテストした結果、影響はマシンによって大きく異なります。さまざまなマシンで速度の改善に効果があった値の例を示します。

HP-UX PA-RISC 8K:16〜40
Solaris:32〜72
Red Hat Linux

Intel Pentium IV:16〜64
Intel Pentium III:8〜32

注記
カスタマイズしたmomentum.cfgファイルは、プロジェクト・ディレクトリ、$HOME/hpeesof/config、
$HPEESOF_DIR/custom/configに置くことができ、この順序で優先度が下がります。最も優先度の高い場所で
見つかった構成変数の値が用いられます。

行列ソルバの動作に影響するメモリ選択オプション

すべての32ビット・プラットフォーム（特にWindows XP）において、マシンにメモリが十分存在するにも関わらず、Momentumが早い段階で仮想メモリ
の不足というメッセージを発行する場合があります。この場合は、Momentumはまず、2003Cで用いられていた古い低速のインクリメンタル・メモリ割り
当て方式に切り替ることで、大規模なシミュレーションを行おうとしますが、これにより割り当てと行列計算の速度が低下します。この自動メモリ切り
替えが起きると、自動ソルバ選択は無効になり、Momentumは2004Aより前の直接ソルバ・モードにただちに移行します。

Momentum RFでは、この切り替えを避けるためにメモリの再利用を行う方法がありますが、このオプションを使うとそのメモリ・スペースが必要なソル
バの速度改善が無効になります。

メモリ割り当て動作は、momentum.cfgファイルでMomentum構成変数MOM3D_USE_MEMORYCONFIGを以下のように設定することで制御できます。

MOM3D_USE_MEMORYCONFIG=0は、Momentumのデフォルト動作です。
MOM3D_USE_MEMORYCONFIG=1は、インクリメンタル行列メモリ割り当てを使用し、2004Aより前の低速の直接ソルバを自動的に有効にします（この動作
は、他のモードで行列割り当ての問題が発生したときに自動的に選択されます）。
MOM3D_USE_MEMORYCONFIG=2は、RFモードで通常使用されないメモリ・ブロックを再利用し、それ以外は設定0と同様に動作しますが、この場合は、この
スペースが必要なソルバの反復計算速度の改善が無効になり、シミュレーション時に反復ソルバが失敗してデフォルトの直接ソルバが選択された場合には
行列の再ロードが必要となります。

Momentumのレイアウト・コンポーネント
レイアウト・コンポーネントは、ADSのレイアウト・ページから作成できるユーザ定義コンポーネントです。コンポーネントは、他のコンポーネントと同様
にスケマティック・ページに挿入でき、レイアウト・ページからの（パラメトリック）レイアウトを表わします。スケマティックでこのコンポーネントを表わす
シンボルは、ブラック・ボックスまたはレイアウト類似シンボルです。
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レイアウト・コンポーネントを定義したら、ユーザとして以下のいずれかの方法で使用できます。

レイアウト・コンポーネントをスケマティックに直接含めることができます。回路シミュレーションをスケマティック環境から実行している場合、回路シミ
ュレーション（電磁界/回路コ・シミュレーション）中、Momentumモデルをオンザフライで作成するため、Momentumプレーナ電磁界ソルバが自動的に
呼び出されます。ユーザ定義のレイアウト・パラメータと最重要のMomentumシミュレーション・パラメータ（モデル・タイプ、メッシュ密度など）をスケマ
ティック・ページから設定できます。また、コ・オプティマイゼーション機能を使用すると、レイアウト・コンポーネントの最適化された値を、レイアウトに
戻る必要なく決定できます。レイアウト・コンポーネントには、以前に計算したMomentumシミュレーション結果を記録しておくデータベース機構が内蔵
されています。すなわち、あるレイアウト・コンポーネントに対してMomentumシミュレーションを実行したら、コンポーネントのパラメータが変化しない
限り、新たな電磁界シミュレーションは不要です。

2番目の使用方法として、レイアウト・コンポーネントをAdvanced Model Composer（AMC）の開始ポイントとして使用できます。詳しくは、『Advanced
Model Composer』マニュアルを参照してください。AMCは、Model Composer（詳しくは、『Model Composer』マニュアルを参照）を一般化したもので、
Layoutウィンドウ内からレイアウト・コンポーネントのパラメータ化された電気モデルを作成できます。レイアウト・コンポーネントを定義し、作成した
ら、（連続および離散パラメータ範囲オプションで）パラメータの範囲を指定し、レイアウト環境内からAMCモデル作成ツールを起動できます。AMC
は、電磁界/回路コ・シミュレーション機能とは異なり、アップフロント・モデル作成ツールです。すなわち、コンポーネントをスケマティック・デザインで
使用する前に、バックグランドで実行された多数のMomentumシミュレーションに基づいて、パラメータ化された電気モデルが計算されます。コンポー
ネントをスケマティックで使用するときに電磁界シミュレーションを実行する必要がありません。スケマティックでAMCコンポーネントを使用する場合の
速度は、他のADS組み込みコンポーネントを使用する場合と同じです。AMCコンポーネントは標準ADSデザイン・キットに追加できるので、プロジェク
トやユーザ間で簡単に共有できます。

レイアウト・コンポーネントと回路コ・シミュレーション

電磁界-回路コ・シミュレーション機能を使用すると、スケマティックからの電磁界（Momentum）シミュレーションと回路シミュレーションを結合できま
す。Advanced Design Systemのレイアウトから、（パラメトリック）レイアウト・コンポーネントを作成してスケマティックに挿入できます。スケマティックで
このコンポーネントを表わすシンボルは、ブラック・ボックスまたはレイアウト類似シンボルです。

スケマティックから、モデル・タイプ、メッシュ密度などのレイアウトおよびMomentumシミュレーションのパラメータを設定できます。レイアウト・コンポー
ネントを含むスケマティックで回路シミュレーションを実行すると、Momentumシミュレーション・エンジンが回路シミュレーション・プロセスの一部として
自動的に呼び出されます。コ・オプティマイゼーション機能により、このシミュレーション中にコンポーネントを最適化できます。コ・オプティマイゼーショ
ンの詳細については、パラメータ化されたレイアウト・コンポーネントによるコ・オプティマイゼーションを参照してください。

レイアウト・コンポーネントには、以前に計算したMomentumシミュレーション結果を記録しておくデータベース機構が内蔵されています。あるレイアウ
ト・コンポーネントに対してMomentumシミュレーションを完了したら、コンポーネントのパラメータが変化しない限り、新たな電磁界シミュレーションは
不要です。

注記
電磁界/回路コ・シミュレーション・セッション中にレイアウト・コンポーネントをシミュレートすると、作業レイアウト・デ
ザイン__ < name >work （ここで、< _name >はレイアウト・コンポーネントの名前）が、レイアウト・コンポーネントのイン
スタンスが挿入された状態で作成されます。作業デザインは、次に電磁界シミュレーションのためMomentumに送ら
れます。シミュレーション結果が、元のレイアウト・コンポーネントに関連するモデル・データベースに保存されます。
この作業デザインは、一時的に使用されるもので、無視することができます。作業デザインは、Momentumシミュレ
ーション中に使用されたメッシュを表示できるよう、シミュレーション後に自動的に削除されません。メッシュは、作業
デザインの一番上に表示されます。

レイアウトの設定

レイアウトの作成方法には、2つの基本的な方法があります。固有のデザイン手法に最も適した、デザイン・ニーズに合った方法を使用してください。

レイアウトをスケマティックから同期化する
レイアウトを直接ドローイングするか、インポートする

レイアウトを作成したら、レイアウト・コンポーネントを作成する前に、以下の手順を使ってレイアウトをMomentumシミュレーション用に準備する必要
があります。

サブストレートおよびレイヤ・マッピングの設定1.
ポート・タイプ・マッピングを使用してポートを挿入し、ポート・タイプを設定します。2.



Advanced Design Systemドキュメント

127

メッシュ設定と周波数プランも指定できます(Schematicウィンドウでまだ実行していなかった場合)。

注記
レイアウト・コンポーネントでは、単一(校正済み)ポートと内部(未校正)ポートのみがサポートされます。その他の
ポート・タイプは、コンポーネントの作成中に単一ポート・タイプまたは内部ポート・タイプにマッピングされます。ポ
ート・マッピングの詳細については、ポート・タイプ・マッピングで説明します。

レイアウト・パラメータの追加

レイアウト・パラメータを持つレイアウト・コンポーネントを使用すると、平面レイアウト・オブジェクトの幾何学的（形状）変動の掃引、チューニング、最
適化が行えます。これには、以下が含まれます。

長さ、幅、ギャップ、スペース、直径などの典型的な寸法
長さと幅が同時に変化するような、相互依存しているレイアウトの変更
ポート位置の変動などの従来にないレイアウト変更

注記
1コンポーネントあたり100レイアウト・パラメータの制限があります。

パラメータ化されたレイアウトの作成には、2つの方法があります。

公称値/摂動値デザインの使用
サブ回路パラメータの使用

これらの方法を同時に使用することはできません。また、単一コンポーネントのパラメータを定義するときに、これらを組み合わせることはできませ
ん。公称値/摂動値パラメータは、レイアウトがフラットで、ポートとプリミティブ・アートワーク形状（多角形、長方形、円など）のみを含んでいる場合に
定義できます。既存の（組み込みまたはカスタム定義）レイアウト・コンポーネントとその他のタイプのアートワーク・プリミティブの組み合わせを使用
する場合、レイアウトは階層的で、サブ回路パラメータだけを使用することができます。詳しくは、レイアウト・パラメータを参照してください。

注記
レイアウト・パラメータなしのレイアウト・コンポーネントを使用してMomentumシミュレーションを実行するには、
Momentumライセンスが必要です。レイアウト・パラメータを持つレイアウト・コンポーネントを使用してMomentumシミ
ュレーションを実行するには、Momentum Optimizationライセンスが必要です。

公称値/摂動値デザインの使用

パラメータを定義するには、別のデザインを与えて、そのパラメータ値の一定の増分変化が元のレイアウトにどのように影響を与えるか確認する必
要があります。元のレイアウトを公称値デザインと呼び、新しいレイアウトは摂動値デザインと呼びます。プログラムは、このプロセスを通して、ユー
ザに指針を与えて行きます。新しいパラメータを追加すると、公称値デザインのコピーを含む別のデザインが作成されます。このデザインを変更する
ため、Edit/View perturbationダイアログで指定した摂動値を適用します。そして変更されたコピーは摂動値デザインとして保存されます。それぞれの
パラメータについて、個別の摂動値デザインを定義する必要があります。

注記
ADS 2008では、Component Parametersダイアログ・ボックスをオープンしたときに、Momentum > Optimizationコマ
ンドを使って定義されたパラメータがコンポーネント・パラメータに自動変換されていません。自動変換するには、
ADS 2006リリースを使用する必要があります。

Layout Componentダイアログ・ボックス(Momentum > Component > Parameters)を使用して、コンポーネント・パラメータを設定します。



Advanced Design Systemドキュメント

128

パラメータの公称値および摂動値と一緒にパラメータ名を入力します。公称値と摂動値は、これらのパラメータによって示唆されるレイアウト内の変
化に対応する必要はありませんが、実際には、物理的意味を持つ値を使用することが有用です。

Addをクリックしてパラメータを追加するか、Edit/View PerturbationをクリックしてEdit/View Perturbationダイアログ・ボックスを表示し、そこで指定さ
れたパラメータのLinear Stretch、Radial Stretch、Rotation摂動値を指定できます。

リニア・ストレッチ

パラメータに対してリニア・ストレッチを指定すると、deltaX, deltaY仕様を使って、選択した1個の頂点、または選択した頂点のグループをリニアに移
動できます。

放射状ストレッチ

パラメータに対して放射状ストレッチを指定すると、中心点のcenterX, centerY座標と係数を指定することにより、選択した1個の頂点、または選択し
た頂点のグループを放射状に移動できます。下図に、選択した頂点に対する係数の影響を示します。

回転
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パラメータに対して回転を指定すると、座標centerX, centerYによって指定された点を中心に指定した角度だけ回転することにより、選択した1個の頂
点、または選択した頂点のグループを移動できます。

注記
Momentum > Optimization > Parameterコマンドを使用して定義したパラメータが、公称値/摂動値パラメータとして
自動的にピックアップされます。

既存レイアウト・コンポーネントの使用

複数の組み込みマイクロストリップ・コンポーネントを組み合わせて、1つのパラメータ化されたレイアウトを作成できます。Layout Component
Parameterダイアログ・ボックス(Momentum > Component > Parameters)を使用して、レイアウト・コンポーネントのサブ回路パラメータを指定します。

サブ回路パラメータを定義したら、レイアウトで使用する1つまたは複数のコンポーネント・インスタンスのパラメータ値の設定に使用することができま
す。

この例では、サブ回路パラメータL1を使用してMLINインスタンスのパラメータ値Lを設定します。
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注記
下位レベルのインスタンス・パラメータの設定には、トップ・レベルのデザイン・パラメータのみを使用することができ
ます。その他の変数の使用は禁止されています。

レイアウト・コンポーネントの作成

Create Layout Componentダイアログ・ボックス(Momentum > Component > Create/Update)を使用して、レイアウト・コンポーネントを作成するための
適切な設定を指定します。

再結合されたポートが存在しないCreate layout Componentダイアログ・ボックス、

注記
Add Reference Pinチェック・ボックスにより、レイアウト・コンポーネントの作成中の、余分の基準ピンの追加をオン
またはオフにすることができます。「余分」のピンは、Momentumがレイアウト内のその他のすべてのピンに基準電圧
を供給するために使用します。このピンにより、グランドの影響(グランド・バウンス、不完全なグランド接続など)のモ
デリングが可能になります。

Add Reference Pinオプションは、レイアウト類似シンボルを選択した場合にのみ利用できます。ブラック・ボックスを選択する
と、このオプションは利用できなくなります（グレーで表示されます）。ただしブラック・ボックスは標準シンボルを使用するの
で、基準ピンがすべてのスケマティックのブラック・ボックス表現に表示されます。このため、有限のグランド・プレーンを持つ
ストラクチャを作成中で、スケマティック内で使用したい場合に、問題が生じる可能性があります。この場合、Add Reference
Pinをオフにした状態のレイアウト類似コンポーネントを選択することを推奨します。

コンポーネントをSchematic > Generate/Updateコマンドで使用する場合にも、このオプションをオフにして、レイアウト類似コ
ンポーネントを使用する必要があります。この余分のピンの存在により、デザイン同期中にエラーが発生する可能性があり
ます。

設定が終了したら、OKをクリックしてレイアウト・コンポーネントを作成します。このレイアウト・コンポーネントは、レイアウト・デザインと同じ名前にな
ります。以下のアクションが自動的に実行されます。

テクノロジ・データが保存されます。テクノロジ・データの詳細については、テクノロジ・ファイルを参照してください。

コンポーネント・シンボルが作成されます
コンポーネント定義が更新されます
モデル・データベースが初期化されます

作成または更新が正常に完了したことを確認するための情報ダイアログ・ボックスが表示されます。

注記
パラメータ、ポート、形状などのレイアウト属性を変更したときにはいつでも、レイアウト・コンポーネントを更新する
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必要があります。また、Edit > Component > Swap Componentsを使用して、スケマティック内のコンポーネントの既
存インスタンスを再挿入、または交換する必要があります。

シンボルの選択

2つのスケマティック・シンボル・タイプのどちらかを選択できます。

シンボル形状がレイアウト形状のスケーリングされたコピーである、レイアウト類似シンボル1.

一般的な方形形状を持つブラック・ボックス・シンボル2.

レイアウト類似シンボルのスケーリングには、3通りの設定方法があります。

最小ピン間距離をスケマティック単位で設定する。
1スケマティック単位は、抵抗、キャパシタ、インダクタなどの最も標準的な2ポート・コンポーネントのサイズに対応します。最小ピン間距離を1スケマティック単
位（1インチ）に設定すると、所定のシンボル・サイズを持つコンポーネントが2本のピン間に納まります。

最大ピン間距離をスケマティック単位で設定する。
下図に、最大ピン間距離を1スケマティック単位（1インチ）と等しくなるように設定したときのスケーリングを示します。
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レイアウト単位寸法をスケマティック単位寸法にマッピングする（同じスケマティック・ページにさまざまなコンポーネントを組み合わせるときに推奨）。

1つのスケマティックにさまざまなレイアウト・コンポーネントを組み合わせるときには、レイアウト・コンポーネントの相対サイズを保持するため、固定
の絶対スケール・ファクタを選択します。

モデル・パラメータのデフォルト

レイアウト・コンポーネントの新しいインスタンスがスケマティック・ページに挿入されるたびに、レイアウト・コンポーネントの作成中に指定したモデル・
パラメータ値が、インスタンスの初期設定として適用されます。これらのパラメータは、レイアウト環境のMomentumシミュレーション・コントロール・オ
プションのサブセットです。

以下のモデル・パラメータを指定できます。

Model Type 使用するMomentumのモードをMomentum MWまたはMomentum RFに設定します
Substrate Browseボタンを使用してサブストレート記述(*.slm)を指定します
Lowest Frequency 適応周波数掃引アルゴリズムに対するMomentumモデル生成中に使用される最低周波数
Highest Frequency 適応周波数掃引アルゴリズムに対するMomentumモデル生成中に使用される最高周波数
Mesh Density 波長あたりのセル数
Arc Resolution
Edge Mesh オン/オフの切り替え

注記
回路シミュレーションで指定範囲外の周波数ポイントが必要となった場合、外挿が使用されます。

注記
Momentum Simulation Controlオプションをスケマティックに設定すると、スケマティックのメッシュ周波数が、自動的
に最高シミュレーション周波数に設定されます。Simulation Controlオプションをレイアウトに設定すると、メッシュ周
波数が、LayoutウィンドウのMesh > Setupダイアログから取り込まれます。

モデル・データベースの設定

回路シミュレーションを実行するとき、レイアウト・コンポーネントのモデルを生成するためMomentumが起動されます。このモデルは、レイアウト・コン
ポーネントのモデル・データベースに保存されます。レイアウト・コンポーネントの作成または更新中、生成されたモデル・データベース情報の使用方
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法には、以下のオプションがあります。

Delete previous database toggle このコンポーネントの以前に計算したモデルをすべて削除します。
Add last simulation result レイアウトから起動された最後のMomentumシミュレーションで取得した結果をデータベースに追加します。

プリミティブおよび階層コンポーネント

パラメータ・タイプ コンポーネント・タイプ アートワーク・タイプ

なし プリミティブ AELマクロ

サブ回路 階層 同期化

公称値/摂動値 プリミティブ AELマクロ

レイアウト・コンポーネントのファイル構造

レイアウト・コンポーネントは、コンポーネントを定義するために結合されたファイルのグループから成ります。これらのファイルの1つまたは複数を手
動で変更または削除すると、コンポーネント定義が壊れ、予期しない挙動を示す可能性があります。

テクノロジ・ファイル

レイアウト・コンポーネントのCreate/Updateプロセス中、4つのテクノロジ関連ファイルが作成または変更されます。ファイルのうち3つは、サブストレ
ート・テクノロジを定義します。

<substrate>_layout.lay レイアウト（またはマスク）レイヤ定義ファイル1.
<substrate>_layout.prf レイアウト・プリファレンス・ファイル2.
<substrate>.slm Momentumサブストレート定義ファイル3.

これらのファイルの名前は、選択したMomentumサブストレート名から派生します。デフォルトの名前は、レイアウト・デザイン名です。

4番目のファイルは、スケマティック・レイヤ定義ファイル< schematic.lay >です。このファイルは、新しいSchematicウィンドウをオープンするたびにロ
ードされ、スケマティックのドローイング・レイヤを指定します。レイアウト類似シンボルの場合、レイアウト・コンポーネントのスケマティック・シンボル
をドローイングするため、このファイルに追加レイヤが付加されます。追加レイヤは、` _lay 'ポストフィックスで識別できます。すでにオープンされてい
るSchematicウィンドウは、レイヤ定義を動的に更新しないことに注意してください。変更されたschematic.layファイルを手動でロードする必要があり
ます。

モデル・データベースのファイル

Momentumモデル・データベースは、mom_dsn/<comp>ディレクトリの下に保存されています。ここで< comp >はコンポーネントのデザイン名です。
model.ndxファイルは、データベースに保存されたモデルを記録します。

モデルは、2レベル階層に保存されます。トップ・レベルは、モデル・パラメータ設定に基づいてエントリ(モデル)を区別します。ボトム・レベルは、レイ
アウト・パラメータ設定に基づいてエントリ(モデル・サンプル)を区別します。
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以下のモデル・パラメータ設定が同じであれば、2つのモデルは同じであるとみなされます。

モデル・タイプ(ModelType)
シミュレーション・コントロール(SimControl)
最低モデル周波数(LowFreq)
最高モデル周波数(HighFreq)
メッシュ密度(MeshDensity)
円弧分解能(ArcResolution)
エッジ・メッシュ(EdgeMesh)

与えられたモデルに対して、1つまたは複数(パラメータ化されたコンポーネントの場合)のサンプルを生成し、データベースに追加できます。

コンポーネントに対してすでに利用可能なモデルを表示するには、Momentum > Component > Model Databaseを選択します。これにより、Layout
Component Model Databaseダイアログ・ボックスがオープンします。

この例では、モデル・データベースで1つのモデルが利用できます。モデルを選択することにより、モデルを生成する際のパラメータ値がDescriptionボ
ックスに表示されます。

スケマティックでのレイアウト・コンポーネントの使用

Layoutウィンドウで作成されたレイアウト・コンポーネントをスケマティックに挿入できます。挿入するには、ライブラリ・ブラウザ（Insert > Component >
Component Libraryを選択）を使用してコンポーネントを選択するか、またはコンポーネント名入力フィールドにコンポーネントの名前を入力します。レ
イアウト・ポートが、その他のコンポーネントに接続可能なスケマティック・ピンになります。
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注記
レイアウト・パラメータなしのレイアウト・コンポーネントを使用してMomentumシミュレーションを実行するには、
Momentumライセンスが必要です。レイアウト・パラメータを持つレイアウト・コンポーネントを使用してMomentumシミ
ュレーションを実行するには、Momentum Optimizationライセンスが必要です。

レイアウト・コンポーネント・インスタンスのパラメータの指定

スケマティックのレイアウト・コンポーネントをダブルクリックして、Layout Componentダイアログ・ボックスを表示します。このダイアログ・ボックスに
は、レイアウト・コンポーネント・インスタンスのパラメータと表示を設定できる、3つのタブがあります。

モデルのパラメータ

モデル・タイプ選択
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Model Type選択リストには、以下の選択肢があります。

Momentum MW MWモードのMomentumによって生成されるSパラメータ・モデル
Momentum RF RFモードのMomentumによって生成されるSパラメータ・モデル
File Based Dataset、CITI、Touchstoneファイルで利用可能なSパラメータ・モデル、またはADSネットリスト・ファイルによって提供されるモデル
Subnetwork （階層コンポーネントの場合のみ）コンポーネントは、コンポーネント・デザインのスケマティック・ページにあるサブ回路トポロジーに基づいてネッ
トリストされ、組み込みモデルを使用します。

Momentumシミュレーション・コントロールの設定

最初の3つのオプションを使用して、最も重要なMomentum Simulation Controlパラメータの設定を変更できます。

Schematic - スケマティック設定は、コンポーネントを作成した対応するレイアウト・デザインに存在するスケマティック設定を上書きします。すべての
Momentum Controlパラメータのサブセットにのみアクセスでき、適応周波数掃引(AFS)がMomentumによって実行されます。適応周波数サンプリングの詳細
については、適応周波数サンプリングを参照してください。

Layout - レイアウト・デザインに存在するレイアウト設定は、layout Componentダイアログ・ボックスのエントリに表示されますが、グレーで表示されます。
Momentumシミュレーション中、レイアウト・デザインで指定されたパラメータが使用されます。これにより、Momentumが、layout Componentダイアログ・ボック
スから設定できないパラメータ設定を使用できます（離散周波数掃引の使用など）。

ほとんどのSimulation Controlパラメータ設定は、SchematicウィンドウとLayoutウィンドウの両方からアクセスできます。

Overlap、TML mesh、Frequency Sweep type、Sample Pointsなどのパラメータは、Layoutコントロールからしか設定できません。

Schematic Momentumコントロール・オプションは、これらのパラメータに対して以下のデフォルト値を使用します。

Overlap - On
TML mesh - Off
Frequency Sweep type - AFS
Sample Points - 50

Layer、Primitive、Primitive Seedなどのその他のパラメータは、レイアウト・コンポーネントを使用したMomentumシミュレーション用には設定できませ
ん。

モデル・データベースの設定

生成されたモデルはすべて、レイアウト・コンポーネントのモデル・データベースに自動的に保存されます。最適化を実行するときには、Reuse Modelオ
プションとInterpolate Modelオプションを選択して、電磁界シミュレーションの数を最小限に抑えます。

Reuse Model データベースを調べます。指定されたパラメータのモデルが利用可能な場合、それが再利用されます。このオプションを選択しないと、最初にデ
ータベースを調べることなく、新しいMomentumシミュレーションが起動されます。

Selectボタンをクリックして、現在利用可能なモデルを示したSelect Modelダイアログ・ボックスを表示します。

Interpolate Model 補間をオンまたはオフに切り替えます。このオプションを選択すると、リニア補間方式が使用されます。要求されたモデル・サンプルが、近
傍モデル・サンプル間の補間によって取得できない場合にだけ、回路シミュレータは、電磁界シミュレーション用にMomentumを起動します。近傍モデル・サン
プルは、要求されたサンプルからの距離より小さい正規化距離（L1指標）内に存在する必要があります。距離の正規化は、Set Interpolation Optionsダイアロ
グ・ボックスで指定された補間デルタ値を基準としています。

OptionsボタンをクリックしてSet Interpolation Optionsダイアログ・ボックスを表示します。ここには、現在のモデル・パラメータ設定のそれぞれのパラ
メータに対する、補間タイプと補間グリッド設定が示されます。補間グリッド値を変更できます。またはDefaultsボタンをクリックして、デフォルト（最高
モデル周波数とメッシュ密度に基づいて自動的に計算されます）にリセットできます。

モデル・データベースとモデル補間の詳細については、シミュレーション中のモデル・データベース・フローを参照してください。

レイアウト・パラメータ

Parametersタブで、ADSのその他のコンポーネントと同様に、レイアウト・パラメータ（公称値/摂動値またはサブ回路）を設定できます。
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Optimization Setupボタンをクリックし、選択したパラメータの最適化設定を指定します。

表示パラメータ

Displayタブで、スケマティック上に表示するパラメータを個別に選択できます。
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ポート・タイプ・マッピング

Layout Port Type Schematic Port Type

Strip（ストリップ） Single（単一） Single（単一）

Internal(内部) Internal(内部)

Differential（差動） Single（単一）

Common mode(コモン・モード) Single（単一）

Ground reference(グランド基準) Internal(内部)

slot（スロット） Single（単一） Single（単一）

Coplanar（コプレナ） Single（単一）

以下の例に、レイアウトでのシミュレーションと等しい方法で、スケマティックで差動ポート、グランド基準ポート、コモン・モード・ポートを使ったシミュレ
ーションを設定する方法を示します。

差動ポート

ポート1,3と2,4は、差動ポート結合です。このポート構成を持つレイアウトでのMomentumシミュレーションにより、差動励振を持つ2×2のSパラメータ
結果が得られます。スケマティックで、差動ポートが単一ポートにマッピングされます。すなわち、Momentumが4×4のSパラメータ結果を計算します。
次に、以下のSパラメータ・ポートのセットアップの図を使用して、これを差動励振に変換できます。
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コモン・モード・ポート

ポート1,3と2,4は、コモン・モード・ポート結合です。レイアウト・コンポーネントで、コモン・モード・ポートが単一ポートにマッピングされます。レイアウト
でコモン・モード・ポートを使用したときと同じ結果を取得するには、以下のスケマティックに示されたセットアップを使用します。

再結合されたグランド基準ポート

2006Aより前では、グランド基準ポートを持つレイアウトに対してMomentum Layout Componentを作成すると、グランド基準ポートが保持され、ピン
は、レイアウト類似シンボル内のグランド基準ポートの位置に作成されました。

ADS 2006A Update 3では、Momentum > Component > Create/Updateダイアログにチェック・ボックスが追加され、以下が可能となりました。

結合されたポート・タイプを無視し、すべてのピンを保持する（ADS 2006A Update 3での新機能）。

または

"Ignore combined port types and keep all pins"チェック・ボックスのチェックを解除して、再結合ポート・タイプを保持しない。
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すなわち、コプレナ・ポート、差動ポート、コモン・モード・ポートに対して1ピンだけ保持できるようになりました。この機能は、レイアウト・コンポーネント
がAdvanced Model Composerで使用されるときにも機能します。

注記
この選択は、「再結合ポート」タイプがデザインに存在する場合にのみ利用可能です。こうしたポート・タイプが存在
しないと、この選択はダイアログに表示されません。

グランド基準ピンを持つレイアウト・コンポーネント

6ポート（2つの単一と4つのグランド基準）を持つレイアウト

ポート3と5は、ポート1のグランド基準ポートで、ポート4と6は、ポート2のグランド基準ポートです。グランド基準ピンを持つレイアウト類似シンボルを
作成するための作業フローは、以下のとおりです。

Create Layout ComponentダイアログでIgnore combined port types and keep all pinsを選択します。プリファレンスを設定し、OKをクリックします。
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Momentumレイアウト・コンポーネントのグランド基準ピンは、下図に示すようにスケマティック・ビューで保持されます。

6つのピンを持つMomentumイアウト・コンポーネント類似シンボル

デザイン同期化の場合、シンボル・ピンの1対1マッピングがあります。これは回路シミュレーションに必須です。下図で、レイアウト・ポートが保持され
ています。
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グランド基準ピンのないレイアウト・コンポーネント

グランド基準ピンのないレイアウト類似シンボルを作成するための作業フローは、次のとおりです。

Create Layout ComponentダイアログでIgnore combined port types and keep all pinsの選択を解除します。プリファレンスを設定し、OKをクリックしま
す。

この場合、下図に示すようにMomentumレイアウト・コンポーネントでグランド基準ピンが保持されません。

グランド基準ピンのないMomentumレイアウト・コンポーネント

デザイン同期化の場合、シンボル・ピンの1対1マッピングがあります。これは回路シミュレーションに必須です。下図で、レイアウト・ポートが失われま
す。
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テスト手順の例

以下のスケマティックに、グローバル基準ピンなしとグランド基準ポートなしのレイアウト類似シンボルを示します。これを実行するには、Create
Layout ComponentダイアログのAdd Reference Pinチェック・ボックスとIgnore combined port types and keep all pinsチェック・ボックスの選択を解除し
ます。

Ignore combined port types and keep all pinsの選択を解除したままでAdd Reference Pinを選択すると、スケマティックで以下のレイアウト類似シンボ
ルが得られます。

以下の例で、グランド基準ポートが保持されます。ポート3と4は、ポート1のグランド基準ポートで、ポート5と6は、ポート2のグランド基準ポートです。
レイアウト・コンポーネントで、グランド基準ポートが内部ポートにマッピングされています。
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以下のスケマティックに、グローバル基準ピンなしで、グランド基準ポートを持つレイアウト類似シンボルを示します。これを実行するには、Create
Layout ComponentダイアログのAdd Reference Pinチェック・ボックスを選択解除し、Ignore combined port types and keep all pinsチェック・ボックスを
選択します。

Create Layout ComponentダイアログでAdd Reference Pinチェック・ボックスとIgnore combined port types and keep all pinsチェック・ボックスを選択
した状態の同じ類似シンボル

下図に示すように、4つの電磁界-回路コ・シミュレーションすべてが同じSパラメータ結果を示します。

最適化とチューニング

チューニング・セッション中は、モデルをオンザフライで生成できません。したがって、レイアウト・コンポーネントに影響を与えるパラメータのチューニ
ングは、要求されたレイアウト・コンポーネントのモデル・サンプルがすでにデータベースに存在するか、またはデータベースが補間結果を提供でき
る場合にのみ可能です。

データベースが有効なモデルを返せない場合は、チューニングが失敗し、モデル・データベースが不完全であることを示すエラー・メッセージが表示
されます。すなわち、チューニングは、十分な数のサンプルによってカバーされる特定の範囲内でのみ可能です。

シミュレーション中のモデル・データベース・フロー

下図に、モデル・データベースが、与えられたレイアウト・コンポーネントのモデル・サンプルに対する要求を処理する方法を示します。存在するコン
ポーネントのインスタンスが1つだけの場合でも、解析中に複数の要求が生成される可能性があります。これは、レイアウト・コンポーネントのパラメ
ータが掃引、最適化、またはチューニングされる場合に起こります。
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最初のモデル要求が、Reuse Model?ポイントまで伝播します。Reuse Modelオプションがオフの場合、モデルを(再)計算するためにMomentumが起動
されます。

Reuse Modelオプションがオンの場合、モデル・データベースが、要求されたサンプルがすでにデータベースに存在するかどうかを確認します。存在
する場合、既存モデルが再利用されます。

モデル・サンプルが利用できない場合、コンポーネント・インスタンスのInterpolate Modelオプションがチェックされます。このオプションがオフの場合、
新しいモデルを計算するためMomentumが起動されます。以下の警告メッセージがステータス・ウィンドウに表示されます。

The model for the Layout Component is not found in the Database, a new model is generated for the
requested parameter values.()

Interpolate Modelオプションがオンの場合、モデル・データベースが、近傍サンプルの位置を特定しようとします。サンプルは、補間デルタ距離（L1を
測定）内にある場合に近傍サンプルであるとみなされます。補間デルタ距離は、Set Interpolation Optionsダイアログ・ボックスで表示/指定できま
す。近傍サンプルが見つからない場合、新しいモデルを計算するためMomentumが起動されます。上記の警告メッセージと同じ警告メッセージが、ス
テータス・ウィンドウに表示されます。チューニング・セッションでは、以下のエラー・メッセージがステータス・ウィンドウに送られます。

Model Database for <instanceName> is not complete for tuning.(<instanceName>)Simulate the Layout
Component first to complete the Model Database.()

近傍に1個以上のサンプルが見つかると、データベースが、データベースでの補間を試みます。十分なサンプルが利用できない場合、指定された補
間デルタ（またはデフォルト設定）に基づいてサンプルが自動的に追加されます。計算時間を短縮するため、追加サンプルの数をできるだけ小さい
値に保ちます。これが発生すると、以下のメッセージがステータス・ウィンドウに表示されます。

There are not enough samples available to allow interpolation, a new sample is generated and added to
the Model Database.()

レイアウト・コンポーネントを使用するときの制限事項

レイアウト・パレットに用意されたコンポーネントには、いくつかの制限があります。

レイアウト・コンポーネント・パレットに表示されるサブストレート・コンポーネントは使用できません。サブストレート定義の作成と編集には、Momentum >
Substrates > Create/Modifyで表示されるダイアログ・ボックスを使う必要があります。
Momentumでシミュレートするレイアウトには、集中定数エレメントを含めることはできません。
Microstripパレットのコンポーネントを使う場合、以下の制限があります。

サブストレート名(Subst = MSub1など)は、Momentumでは用いられません。サブストレート定義はMomentum > Substratesメニューからロードする必要があります。
電気的な属性は定義されていても用いられません。例えば、MFTCのパラメータCPUA、RsT、RsBなどは無視されます。

レイアウト内の大部分のコンポーネントは、形状だけがMomentumに転送されます。電気的な属性はMomentumメニューで定義する必要があります。
Momentumでシミュレートするレイアウトには、Printed Circuit BoardパレットとWaveguideパレットのコンポーネントは使用できません。
ストリップライン・コンポーネントとサスペンデッド・サブストレート・コンポーネントは使用できますが、コンポーネントのサブストレート名パラメータは無視されま
す。
1コンポーネントあたり最大100個のレイアウト・パラメータを使用できます。

Momentumの結果の表示
この章では、Momentumの結果を表示する方法を説明します。
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データ・ディスプレイを使用した結果の表示

Momentumによるシミュレーション結果を表示するには、2つのツール(データ・ディスプレイとMomentum Visualization)があります。ビジュアリゼーショ
ン・ツールには、専用のコードワードが必要であり、以下の各章で説明します。この章では、データ・ディスプレイの使用方法について説明します。

Momentumシミュレーションでは、以下の結果を表示できます。

Sパラメータ
放射パターン(遠方界プロット)と導出されたアンテナ・パラメータ

シミュレーション中にはその他のデータも計算され、データセットに保存されます。 これらも表示したり、計算で使用したりできます。

回路の各ポートの伝搬定数(γ)
各ポートの特性インピーダンス
AFSの収束データ

データ・ディスプレイの使用法の詳細については、データ・ディスプレイを参照してください。

データ・ディスプレイ・ウィンドウのオープン

シミュレーション結果は、データ・ディスプレイで表示します。データ・ディスプレイ・ウィンドウをオープンするには、以下のようにいくつかの方法があり
ます。

シミュレーション終了時に自動的にデータ・ディスプレイ・ウィンドウをオープンする。このための手順については、結果の自動表示を参照してください。
Layoutウィンドウのメニュー・バーでWindow > New Data Displayを選択して新しいデータ・ディスプレイをオープンする。
現在のプロジェクトでWindow > Open Data Displayを選択し、データ・ディスプレイを選択することにより、保存されているデータ・ディスプレイをオープンする。
データ・ディスプレイ・ファイルの拡張子は.ddsです。

Momentumデータの表示

Momentumのシミュレーション結果は、1個以上のデータセットに保存されます。

シミュレータが計算した周波数ポイントのデータは、<design_name>.dsファイルに保存されます。これはすべてのシミュレーションで作成される標準のデータセ
ットです。
適応掃引タイプをシミュレーションに使った場合は、各周波数ポイントのサンプル・データを元にAFSが高密度に再サンプリングしたデータが、< design_name
>_a.dsというデータセットに保存されます。
放射パターンを計算し、選択したビジュアリゼーション・タイプが"2D Data
Display"の場合、結果は、データセット<design_name>_f.dsに保有されます。

現在のプロジェクトのデータセットは、データセット・リストボックスに表示されます。

Momentumのデータは、任意のプロット・タイプで表示できます。

Momentumデータを表示する手順:

プロット・アイコンをクリックしてプロット・タイプを選択し、マウスをウィンドウ内にドラッグし、クリックしてプロットを配置します。1.
デフォルト・データセットの変数が表示されます。必要なら、他のデータセットをリストから選択します。2.
プロットしたいデータを含む変数を選択し、Addをクリックします。3.
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注記
シミュレーション・データの大部分は複素数フォーマットです。直交座標プロットにデータを追加する場合は、どの
スカラ・フォーマットで表示するかを選択する必要があります。

同じプロットに、別のデータセットのデータを追加することもできます。ステップ2と3を繰り返して、プロットにデータを追加します。4.
OKをクリックするとデータが表示されます。5.

注記
同じビュー内の複数のグラフは、重ねて表示されます。複数のグラフを同時に表示するには、各グラフを個別のビュ
ーに割り当てます。

Sパラメータの表示

Sパラメータ・データセットで利用可能なデータに関する詳細は、以下のセクションを参照してください。

標準データセットとAFSデータセットの変数

変数 説明

freq 独立変数の周波数。 シミュレーション設定時に指定されたもの。データ・ポイントの数は、シミュレーション中に指定された掃引タイプと
周波数プランで決まります。

GAMMA n ポートnの(モード)伝搬定数。ディエンベディングに用いられ、シングル、差動、コプレナの各ポートに対してだけ計算されます。

PORTZ n ポートnのインピーダンス。 Port Editorダイアログ・ボックスのImpedanceフィールドで定義されたもの。インピーダンスが指定されていな
い場合は、50Ωが仮定されます。

S Sマトリクス。 PORTZnに正規化したもの。

S( i, j) 回路内の各ポート対のSパラメータ。 PORTZ nに正規化したもの。

S_50 Sマトリクス。 50Ωに正規化したもの。

S_50( i, j) 回路内の各ポート対のSパラメータ。 50Ωに正規化したもの。

S_Z0 Sマトリクス。 Z0に正規化したもの。

S_Z0( i, j) 回路内の各ポート対のSパラメータ。 各ポートのZ0に正規化したもの。

Z0 n ポートnに接続された伝送ラインの特性インピーダンスをレポートします。内部ポートまたは結合ポートの場合は計算されません。この場
合は50Ωが代わりに用いられます。

注記
同じ基準面で3個以上のポートが使用されている場合は、シングル・ポートに対するZ0値は計算されません。この場
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合、Z0値が50Ωに設定されます。各ポートのスカラZ0を取得するには、ポートを別の基準面に置く必要があります。

差動、コプレナ、コモン・モードの各ポートを使用しているレイアウトのSパラメータについては、ポートを参照してください。

標準データセットとAFSデータセット

適応掃引タイプを使ったシミュレーションでは、2つのデータセットにデータが保存されます。最初のデータセットには、シミュレーション中に決定された
周波数ポイントでシミュレータが計算したデータが記録されます(これは標準のデータセットであり、すべてのシミュレーションで生成されます)。2番目
のデータセットには、AFSが計算した、きわめて高密度の周波数分布で再サンプリングされたデータが記録されます。この「適応データセット」は、名
前の最後に_aがアペンドされています。適応データセットには標準データセットと同じ変数が含まれていますが、データが計算される周波数ポイント
の数が大幅に増えています。

通常、_aデータセットのデータを表示すると、きわめてなめらかな結果が見られます。 これは回路の動作をよく反映しています。同じプロットに標準の
データセットを表示すると、シミュレータが実行された周波数ポイントが、なめらかな曲線に重なって表示されます。これらの周波数ポイントはレンジ
全体に散らばっていて、Sパラメータの変化が大きい領域に相対的に多くのポイントが分布しています。2つのデータセットを同時に表示することで、
このシミュレーションでのAFSプロセスの品質がわかります。AFSの詳細については、適応周波数サンプリングを参照してください。

Momentum Visualizationを使用した結果の表示

Momentum Visualizationでは、Sパラメータを表形式やプロット形式で表示できます。この章では、Sパラメータの表示と操作方法を説明します。また、
Sパラメータに関する一般的な情報についても説明します。

Sパラメータの概要

Sパラメータの表示や処理を行う場合は、インピーダンスの指定方法と使用する命名規則に注意する必要があります。これらについては、以下のセ
クションで説明します。

正規化インピーダンス

表示できるSパラメータは、Port Editorダイアログ・ボックスのImpedanceフィールドで定義される正規化インピーダンスに基づいたSパラメータです。イ

ンピーダンスが指定されていない場合は、50
が仮定されます。

命名規則

Sパラメータの命名規則は、プロジェクトの名前に基づいてどのSパラメータの組を表示中あるいは処理中であるかを示すものです。1つのプロジェク
トで、利用可能なデータセットは2つしかありません。1つは、実際にシミュレートされた離散周波数を格納するdesign_nameと言う名前のものです。もう
1つは、シミュレーション設定で適応周波数掃引を指定したときにだけ利用できるdesign_name(afs)です。適応周波数掃引のデータセットには、シミュ
レートされた周波数を極−零点モデルでフィッティングした高分解能サンプリング・ポイントが含まれています。

表形式によるSパラメータの表示

Sパラメータを表形式で表示できます。表には、以下のフォーマットで各ポートのSパラメータの値を表示します。

大きさ
実数成分と虚数成分
振幅と位相
この表はデータを表示するためのものであり、この表からデータをプロットすることはできません。
Sパラメータは以下のように表示されます。
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Sパラメータを表示する手順:

Plot > Matrixを選択します。1.
S Parameterリストから表示したいデータを選択します。2.
Frequenciesリストから対象の周波数を選択します。Sマトリクスによっては、周波数が1つしかないものがあります。3.
以下からデータ・フォーマットを選択します。4.

Magnitude Sパラメータの振幅を表示します。
Real/Imag Sパラメータを複素数で表示します。
Mag/Phase Sパラメータの振幅と位相を表示します。

大きなマトリクスはスクロール・バーを使用して確認します。5.
OKをクリックしてダイアログ・ボックスを終了します。6.

Sパラメータの振幅のプロット

Sパラメータの振幅のプロットは、周波数に対して大きさをdB単位で表示します。

Sパラメータの振幅のプロットを表示する手順:

Plot > Mag Plotを選択します。1.
MatrixリストからSマトリクスを選択します。2.
Sパラメータを選択します。組み合わせは、ポートに基づいています。3.
プロットを表示したいビューを選択します。4.
Applyをクリックします。5.
他のSパラメータをプロットに追加するか、Doneをクリックしてダイアログ・ボックスを終了します。6.

Sパラメータの位相のプロット

Sパラメータの位相のプロットは、周波数に対して位相を度単位で表示します。Sパラメータの位相を表示すると、場合によっては位相遅延がプロット
されることがあることに注意してください。例えば、位相が60°の電気長のレイアウトでは、S

21
は位相遅延を表わし、-60°と表示されます。位相が
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180°より大きい場合は、γ(伝搬定数)から予測される位相がS
21

と比べて正しくないように思われますが、遅延を考慮すれば正しいことがわかりま

す。

Sパラメータの位相のプロットを表示する手順:

Plot > Phase Plotを選択します。1.
MatrixリストからSマトリクスを選択します。2.
Sパラメータを選択します。組み合わせは、ポートに基づいています。3.
プロットを表示したいビューを選択します。4.
Applyをクリックします。5.
他のSパラメータをプロットに追加するか、Doneをクリックしてダイアログ・ボックスを終了します。6.

スミス・チャート上のSパラメータのプロット

スミス・チャートは、Sパラメータの実数成分と虚数成分を表示します。

スミス・チャートを表示する手順:

Plot > Smith Plotを選択します。1.
MatrixリストからSマトリクスを選択します。2.
Sパラメータを選択します。3.
プロットを表示したいビューを選択します。4.
Applyをクリックします。5.
他のSパラメータをスミス・チャートに追加するか、Doneをクリックしてダイアログ・ボックスを終了します。6.

Sパラメータのエクスポート

Sパラメータは、TouchstoneフォーマットまたはCITIFileフォーマットでファイルにエクスポートできます。Sパラメータをエクスポートして、他のツールで
使用できます。
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Sパラメータをエクスポートする手順:

File > Export S Matrixを選択します。1.
MatrixリストからエクスポートするSマトリクスの組を選択します。2.
ファイル・フォーマットとして、CITIFileフォーマットまたはTouchstoneフォーマットを選択します。3.
File Nameフィールドにファイルのフルパスを入力するか、Browseをクリックしてファイル名を指定します。4.
OKをクリックしてコマンドを完了します。5.

Momentum Optimization
Momentumと組み合わせたMomentum Optimizationは、平面回路の電磁界(EM)デザインを自動的に最適化する効果的なソフトウェア・ツールです。
Momentumを使用して最適化を実行すると、デザイン・ゴールに従って回路性能を改善するためにレイアウトのパラメータを調整できます。
Momentumマイクロ波モードまたはMomentum RFモードを使って開発されたデザインをサポートしています。

Momentumを使用した最適化は、スケマティック環境内から、パラメータ化されたレイアウト・コンポーネントを使って実行します。このプロセスを例で
説明します。

Momentumは、結合や放射などのさまざまな電磁界効果を正確に考慮できる解析ツールです。デザインの検証には極めて価値あるものですが、そ
れ自体ではデザイン・ゴールを満足するレイアウトを決定できません。レイアウト・デザインは、通常は試行錯誤のプロセスで、Momentumを使用して
ゴールを達成します。パラメータ化されたレイアウト・コンポーネントを使ったMomentumによる最適化で、エンジニアの貴重な時間を節約できます。
デザイン・サイクルが劇的に短縮され、より早く製品を市場に投入することが可能になります。また、複雑なストラクチャに対しては、通常は手動での
デザインより良好なデザインを見つけることができます。

Momentumを使用して最適化できるもの

Momentum Optimizationにより、2次元レイアウト・オブジェクトの幾何学的寸法を最適化できます（形状最適化）。以下の最適化が含まれます。

長さ、幅、ギャップ、スペース、直径などの典型的な寸法
長さと幅が同時に変化するような、相互依存しているレイアウトの変更
従来にない多くのレイアウト修正

オブジェクトとなり得るものは、メタル・ストリップ、スロットまたはビアです。オブジェクトのパラメータ化に重点を置いているので非常に柔軟性の高い
レイアウト変更が可能です。パラメータ化のプロセスは、ADSのスケマティック・ドローイング環境内で実行します。

Momentumを使用して最適化できないもの

Momentumは、以下の最適化に対応しません。

誘電率などの材料パラメータ
サブストレートの厚みなど、レイアウトの断面パラメータ

Momentumを使用して最適化できる応答

スケマティック内の最適化ゴール・コンポーネントを使用して定義できる応答は、すべて最適化できます。詳細は、チューニング、最適化および統計
デザインを参照してください。通常、以下の形式のSパラメータのデザイン・ゴールです。

振幅(dB単位)
振幅
位相(°単位)
実数部
虚数部

Momentumを使用した最適化の典型的な手順

Momentum Optimizationの基本手順を以下に示します。

パラメータ化されたレイアウト・コンポーネントを使用して、ADSで経験に基づいてレイアウトを作成します。最終的なデザインに可能な限り近いデザインを作1.
図します。しかし、正確な寸法を決定するために、多くの時間をかける必要はありません。むしろ、簡単に作図して時間を節約してください。
サブストレート、メタライゼーション、ポート、メッシングなどの、Momentumシミュレーションを設定します。2.
Momentum > Simulationメニューのオプションを使用してデザインをシミュレートします。応答を確認します。回路性能が満足できるものであれば、デザインを3.
最適化する必要はありません。
レイアウトの寸法に何らかの調整を行えば回路性能を改善できるかどうか検討します。所望の改善を達成するにはレイアウトをどのように変更すべきかを検4.
討します。レイアウト・トポロジーの根本的な変更が必要である場合は、この段階で実行し、シミュレーションを繰り返します。
所望のレイアウト変更を容易にするために、概念的に独立したパラメータを定義します。5.
周波数ポイント、Sパラメータの上限、下限、等号、ウィンドウ(範囲)などのデザイン・ゴールにより回路性能を適切に表現できるか判断します。6.
デザインを保存します。7.
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最適化のプロセス

デザインからレイアウト・コンポーネントを作成し（レイアウト・コンポーネントの作成を参照）、識別したパラメータの定義を追加します。1.
レイアウト・コンポーネントを持つスケマティックを作成します。2.
最適化ゴールを定義します。3.
最適化パラメータを設定します。4.
最適化を実行します。5.
最適化パラメータ値がステータス・ウィンドウに表示されます。6.
必要に応じて、最適化パラメータ値を持つレイアウトからレイアウト・コンポーネントを再シミュレートします。7.

例

このセクションでは、コ・オプティマイゼーションの設定方法、実行方法、結果の表示方法の練習を行います。

サンプル・プロジェクトのコピー

まず、ADS Momentumサンプル・プロジェクトをローカル・ディレクトリにコピーします。

Mainウィンドウで、File > Copy Project...を選択します。1.
Copy ProjectダイアログのFrom Projectセクションで、Example Directoryを選択します。2.
Browse...を選択します。 .3.
ドロップ・ダウン・メニューで、Momentum > Microwave、次にCoupled_line_filter_prjを選択し、OKをクリックしてプロジェクトを選択します。4.
To Projectセクションで、プロジェクトのコピー先のディレクトリを選択します。5.
Copy Project HierarchyとOpen Project After Copyをアクティブにし、OKをクリックします。これにより、プロジェクトがオープンされ、新しいディレクトリに保存さ6.
れます。

コンポーネントの編集

このセクションでは、コ・オプティマイゼーション用のコンポーネントを準備し、パラメータ化する方法について説明します。

プロジェクトがオープンしたら、READMEウィンドウをクローズします。1.
Coupled_line_filterレイアウト・ウィンドウを選択します。2.
Layoutウィンドウ・ツールバーで、Momentum > Mesh > Clearを選択します。3.
次に、Momentum > Component > Parametersを選択します。これにより、Momentum Component Parametersダイアログがオープンします。4.
Create/Edit Parameterセクションで、パラメータ名としてL1を入力し、パラメータ・タイプとしてSubnetworkを選択します。Default Valueを300 umに設定します。5.

Addをクリックし、OKを選択します。6.
Layoutウィンドウで、Microstrip Line TL6をダブルクリックして選択します。これにより、新しいダイアログがオープンします。7.



Advanced Design Systemドキュメント

153

MLIN列でパラメータLを選択し、Parameter Entry Mode列でLine Length LをL1に設定します。8.

OKをクリックしてこのダイアログをクローズします。9.

パラメータ化されたコンポーネントの作成

このセクションでは、パラメータ化されたコンポーネントの作成方法について説明します。

Layoutウィンドウで、Momentum > Component > Create/Updateを選択します。これにより、Create Layout Componentダイアログがオープンします。1.
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このダイアログのSymbolセクションで、layout look-alikeを選択し、Add reference pinをオンにします。2.
Modelセクションで、Model TypeがMomentum RFに設定されていることを確認し、25 GHz〜50 GHzの周波数レンジを設定し、Edge Meshを選択解除します。3.
OKをクリックして、パラメータ化されたコンポーネントを作成します。4.
これにより、2つの新しいダイアログが表示されます。コンポーネントが正常に作成されたことを知らせるメッセージ・ウィンドウでOKを選択し、Add simulation5.
to Model DatabaseダイアログでNoを選択します。

スケマティックでのコンポーネントの追加と使用

このセクションでは、スケマティックでのパラメータ化されたレイアウト・コンポーネントの追加方法と使用方法について説明します。

新しいSchematicウィンドウをオープンします。ライブラリ・ブラウザをオープンし、Sub-networks > Coupled_line_filter_prj > Coupled_line_filterコンポーネントを選1.
択することで、新しく作成したコンポーネントを挿入します。Schematicウィンドウにレイアウト・コンポーネントを配置します。
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下図に示すように、2個のSパラメータ・ポートと3個のグランドをスケマティックに追加します。2.

Sパラメータ・シミュレーション・ブロックをスケマティックに追加します。Start周波数を25 GHzに、Stop周波数を50 GHzに、ステップ・サイズを0.1 GHzに設定し3.
ます。
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OKをクリックします。4.

スケマティックのパラメータ化されたレイアウト・コンポーネントの最適化設定

このセクションでは、スケマティック・シミュレーション中にパラメータ化されたレイアウト・コンポーネントを最適化するために必要な設定について説明
します。

Coupled_line_filterコンポーネントをダブルクリックします。これにより、Momentum Componentダイアログがオープンします。1.
Parametersタブを選択し、Optimization Setup...を選択し、Optimizationダイアログを表示します。2.

このダイアログで、Optimization StatusをEnabledに、Minimum Valueを200 umに、Maximum Valueを400 umに設定します。3.
OKをクリックします。4.
GoalとOptimizationブロックをスケマティックに追加します。5.
Goalブロックに対して、以下を設定します。6.

Expr = "dB(S11)"
SimInstanceName = "SP1"
Max = -10
Weight = 1
RangeVar[1] = "freq"
RangeMin[1] = 39 GHz
RangeMax[1] = 42 GHz

Optimizationブロックで、Optimization TypeをMinimaxに設定します。7.

スケマティック・デザインを" filter_opt "として保存します。File > Save Design As...を選択します。8.
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Schematicウィンドウで、Simulate > Simulateを選択してシミュレーションを開始します。9.
9回の反復後、最適化された値207.039e-6がステータス・ウィンドウに表示されます。10.

Momentumの放射パターンとアンテナ・パラメータ
この章では、放射電磁界の計算方法について説明します。また、放射電磁界から導くことができるアンテナの特性に関する一般的な情報について
説明します。

注記
Momentum RFモードでは、放射パターンとアンテナ・パラメータは利用できません。

放射パターンについて

回路上の電流がわかれば、電磁界を計算できます。水平偏波角のように、電磁界は、回路に固定された球座標系で表現できます。電界と磁界に

は、1/r、1/r2などで減衰する項が含まれています。 1/r2、1/r3で減衰する項は、回路近傍に蓄積されるエネルギーに対応していることを示すことが
できます。リアクティブ・フィールドまたは近傍界成分と呼ばれます。1/rに依存した項は、遠距離で支配的となる回路の放射パワーを表わすので、遠
方界成分(E

ff
、H

ff
)と呼ばれます。
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注記
サブストレートに平行な方向(θ=90度)では、1/sqrt(r)で減衰する平行プレート・モードや表面波モードも存在するこ
とがあります。これらはその方向では支配的であり、回路の放射パワーの一部として考慮されますが、遠方界の一
部とは見なされません。

放射パワーは、回路からの放射角度と動径方向の距離の関数です。放射角度によるパワー密度の変化は、回路のタイプとデザインにより決まりま
す。これは、放射パターンとしてグラフィック表示できます。

遠方界は、シミュレーションで計算された周波数でしか計算できません。遠方界は、特定の周波数と特定の励振状態について計算されます。これら
は、回路の上半分の開空間または下半分の開空間、あるいはその両方のすべての方向(θ、φ)で計算できます。遠方界以外に、利得、指向性、軸
比などのパターンから導出される諸量も計算できます。

注記
デザインによっては、開空間として定義されていないトップ・レイヤまたはボトム・レイヤのあるデザインに対しても遠
方界を計算することができます。これらのストラクチャの詳細については、377 Ω終端と放射パターンを参照してくだ
さい。

アンテナ・パラメータについて

放射電磁界から、偏波や利得、指向性、放射パワーなどのその他のアンテナ・パラメータを導出することができます。

偏波

遠方界は、いくつかの方法で成分に分解することができます。( 、 )の成分に分解して表わすことができます。しかし、リニア偏波アンテナでは、
基本的な遠方界をアンテナの測定セットアップに基づいて分解する、(E

co
、E

cross
)の方が便利なことがあります。円偏波アンテナでは、左旋回偏波と

右旋回偏波の電磁界成分(E
lhp

、E
rhp

)に分解するのが最も適しています。次に、各種成分表示の関係を示します。

は、考慮する開半球の特性インピーダンスです。

電磁界は、以下に対して正規化されます。

円偏波

右旋回偏波と左旋回偏波の電磁界成分の定義式を下に示します。これらによって、円偏波軸比(AR
cp

)を計算できます。軸比は、アンテナがどの程

度良好に円偏波されているかを示します。その値が1に等しいと、電磁界は完全に円偏波されています。電磁界がリニア偏波の場合は、無限大とな
ります。
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リニア偏波

遠方界を水平偏波成分と垂直偏波成分に分解する式を下に示します( は、水平偏波角です)。これからリニア偏波軸比(AR
lp
)を導くことができま

す。アンテナがどの程度良好にリニア偏波されているかを示します。その値が1に等しいと、電磁界は完全にリニア偏波されています。 完全に円偏
波のアンテナでは、無限大となります。

注記
Ecoは、コリニアとして定義され、Ecrossは、Ecoに直交する成分を表わします。リニア偏波アンテナの場合は、
Ecrossはゼロで、軸比AR=1です。Ecross = Ecoの場合は、リニア偏波ではなく円偏波になるので、AR = 無限となり
ます。

水平偏波角度

放射強度

特定の方向への放射強度は、W/sr(W/ステラジアン)単位で、次式で与えられます。

特定の方向で放射強度は最大となり、次式と等しくなります。

放射パワー

アンテナが放射する全パワーは、W単位で、次式で表わされます。
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実効角度

このパラメータは、ビーム領域の全方向で最大放射強度が一定であると仮定したときのアンテナから放射される全パワーが通過する立体角です。
単位はステラジアン(sr)で、次式で表わされます。

指向性

指向性は無次元量で、次式で表わされます。

最大指向性は、次式で与えられます。

利得

アンテナの利得は次式で表わされます。

ここで、P
inj

は、回路に注入される電力で、単位はWです。

最大利得は、次式で与えられます。

効率

効率は次式で与えられます。

実効面積

アンテナ回路の実効面積は、単位で、次式で与えられます。

放射パターンの計算

放射パターンを計算する手順:

Momentum > Post-Processing > Radiation Patternを選択します。1.
Generalタブを選択します。2.
Select Frequencyリスト・ボックスで周波数を選択します。放射パターンは、この周波数で計算されます。選択する周波数は、シミュレーション中に計算された3.
周波数です。
Available Portsのリストから、ポートを選択し、そのポートに(テブナン等価回路に基づいた)ステアリング回路を適用し、回路にエネルギーを注入します。ステ4.
アリング回路は、任意のポートに適用できます。
Port Excitationフィールドで、ポートに適用するステアリング回路の電圧の振幅(単位V)と位相(単位度)を入力します。5.
Port Termination Impedanceフィールドで、ポートに適用するステアリング回路のインピーダンスの実数成分と虚数成分を入力します。6.

注記
すべてのポートを終端として、回路へのエネルギーの注入用以外のポートが反射を起こさないようにすることがで
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きます。これらのポートについては、Port Excitation電圧をゼロにして、Port Impedanceをポートの特性インピーダ
ンスにします。

使用したい表示ツールを選択します。2D Data Displayまたは3D Visualizationのどちらかをオンにします。3D Momentum Visualizationツールでは、専用のコー7.
ドワードが必要です。このツールの使用法と詳細については、Momentum Visualizationを参照してください。
表示ツールが結果を自動的にオープンして表示するようにする場合は、Open display when computation completedをオンにします。8.
3次元ツールを使用するように選択した場合は、Computeをクリックします。Momentum Visualizationツールの詳細な使用法については、この後の各章で説明9.
します。
データ・ディスプレイを使用する場合は、2D Settingsタブをクリックし、この手順を継続します。
遠方界の結果を保存したいデータセット名を指定します。10.
結果をフォーマットするテンプレートを選択するか、デフォルトを受け入れます。11.
平面または円錐のCut Type Definitionのどちらかを選択します。12.

planarカット(垂直断面)は、回路のレイアウト平面に垂直な断面です。
conicalカット(水平断面)は、Z軸の周りの円錐の底面(回路のレイアウト)です。
Radiation Pattern Controlダイアログ・ボックスの図を参照してください。詳しくは、垂直断面と水平断面を参照してください。

Cutting Angleフィールドで、カット角度の値を度で入力します。13.
平面カットでは、カット角度φはX軸に対する角度です。θが-180度から180度まで掃引される間、φは一定に保たれます。
円錐カットでは、カット角度θは、Z軸に対する角度です。φが0度から360度まで掃引される間、θは一定に保たれます。

Co Polarization Angleフィールドに、水平偏波角の値を入力します。この角度は、遠方界を水平極座標成分と垂直極座標成分に分解するときに使用されます14.
（リニア偏波を参照してください）。
Lower Clipping Boundaryフィールドに、データを表示するしきい値を入力します。dBまたはmagの単位を選択します。この値を下回る放射パターン・データの15.
計算値は、ゼロと表示されるか(単位がmagの場合)、下側のクリップ境界として表示されます(単位がdBの場合)。
Computeをクリックして放射パターンを計算します。計算後に、遠方界と導出されたアンテナ・パラメータは、指定した名前でデータセットに保存されます。fが16.
データセット名に付加されます。_fは、そのデータセットが放射パターンを格納していることを示します。データセットは、現在のプロジェクトの/dataディレクトリ
に保存されます。

放射の計算を実行した後、上記で選択した表示ツールに基づいて保存されます。

2D Data Displayを選択した場合:すべてのデータは、指定した名前に_f.dsを付加して1つのデータセットに保存されます。_fは、そのデータセットが放射パターン
を格納していることを示します。データセットは、現在のプロジェクトの/dataディレクトリに保存されます。
3D Visualizationを選択した場合:遠方界と導出されたアンテナ・パラメータは、それぞれproj.fffとproj.antという名前で、プロジェクトのmom_dsn/<design_name>
ディレクトリに保存されます。

垂直断面

垂直断面の場合、X軸に対する角φ(Cut Angle)が、一定に保たれます。角θ(Z軸に対する角)が掃引されて、垂直断面が作成されます。θは0度か
ら360度まで掃引されます。これにより、回路のレイアウト平面に垂直なビューが生成されます。垂直断面に、垂直断面を示します。

垂直断面

注記
レイアウトには、モニタ画面がXY面になる1つの固定座標系があります。X軸は水平、Y軸は垂直、Z軸は画面に対し
て垂直です。放射パターンを調べる面を選択するには、カット角度を指定する必要があります。例えば、回路を90度
回転する場合は、ある向きから次の向きまで同じ放射パターンを得たいときには、カット角度も90度だけ変化させる
必要があります。

水平断面

水平断面の場合は、角θ(Z軸に対する角)が一定に保たれます。角φ(X軸に対する角)が掃引されて、水平断面が作成されます。φは0度から360度
まで掃引されます。これにより、回路のレイアウト平面に平行なビューが生成されます。水平断面に、水平断面を示します。
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水平断面

データ・ディスプレイによる結果の自動表示

遠方界の計算後直ちに結果を表示するためには、Open display when computation completedをオンにします。遠方界データの表示にデータ・ディス
プレイを使用する場合は、計算が完了すると、選択したデータ・ディスプレイ・テンプレートのデフォルトのプロット・タイプを格納したデータ・ディスプレ
イ・ウィンドウが自動的にオープンします。FarFieldsという名前のデフォルトのテンプレートには、4グループのプロットがあります。

E co、E cross、AR lpを表示するLinear Polarization

E lhp、E rhp、AR cpを表示するCircular Polarization

を表示するAbsolute Fields
利得、指向性、放射強度、効率を表示するPower
詳細は、アンテナ・パラメータについてを参照してください。

遠方界データのエクスポート

Radiation Patternダイアログで3D Visualizationを選択した場合は、完全な半球に対する遠方界の正規化電界成分が、次のようにファイル<
project_dir>/ mom_dsn /<design_name>/ proj.fffにASCII形式で保存されます。データは以下のフォーマットで保存されます。

#Frequency <f> GHz /* loop over <f> */
#Excitation #<i> /* loop over <i> */
#Begin cut /* loop over phi */
<theta> <phi_0> <real(E_theta)> <imag(E_theta)> <real(E_phi)>
<imag(E_phi)>

/* loop over <theta> */

#End cut
#Begin cut
<theta> <phi_1> <real(E_theta)> <imag(E_theta)> <real(E_phi)>
<imag(E_phi)>

/* loop over <theta> */

#End cut
:
:
#Begin cut
<theta> <phi_n> <real(E_theta)> <imag(E_theta)> <real(E_phi)>
<imag(E_phi)>

/* loop over <theta> */

#End cut

proj.fffファイル内のE_thetaとE_phiは、それぞれ電界の遠方界のθ成分とφ成分を表します。電界は球面座標系(r、θ、φ)で記述され、正規化され
ていることに注意してください。電界の正規化定数は、proj.antにある値から得られ、以下に等しくなります。

同じディレクトリに保存されるproj.antファイルには、アンテナ・パラメータが含まれています。データは以下のフォーマットで保存されます。

Excitation <i> /* loop over <i> */
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Frequency <f> GHz /* loop over <f> */

Maximum radiation intensity <U> /* in Watts/steradian */

Angle of U_max <theta> <phi> /* both in deg */

E_theta_max <mag(E_theta_max)> ; E_phi_max <mag(E_phi_max)>

E_theta_max <real(E_theta_max)> <imag(E_theta_max)>

E_phi_max <real(E_phi_max)> <imag(E_phi_max)>

Ex_max <real(Ex_max)> <imag(Ex_max)>

Ey_max <real(Ey_max)> <imag(Ey_max)>

Ez_max <real(Ez_max)> <imag(Ez_max)>

Power radiated <excitation #i> <prad> /* in Watts */

Effective angle <eff_angle_st> steradians <eff_angle_deg> degrees

Directivity <dir> dB /* in dB */

Gain <gain> dB /* in dB */

電界成分の最大値(E_theta_max、E_phi_maxなど)は、放射強度が最大になる角度にあります。単位はすべてVです。

放射データの表示

Momentum Visualizationでは、以下の放射データを表示できます。

各種偏波と軸比に対する電界を含めた遠方界を3次元または2次元フォーマットで表示
利得、指向性、主放射の方向などのアンテナ・パラメータを表形式で表示
このセクションでは、データの表示方法について説明します。Momentum RFモードでは、放射データは表示に利用できません。放射パターンとアンテナ・パラ
メータに関する一般的な情報については、放射パターンについてを参照してください。

放射データのロード

Momentumでは、放射データの計算がポスト・プロセッシングで行われます。放射データが利用できるときだけ、メニュー・バーにFar Fieldメニューが
表示されます。放射データ・ファイルが利用可能な場合は、自動的にロードされます。放射データ・ファイルには、単一周波数の放射データ(最後に計
算されたもの)だけが格納されています。このファイルは、Momentumの新しいプロジェクトをオープンしたときにだけロードされるので、別の周波数で
計算された放射データをロードするには、そのプロジェクトを再オープンする必要があります。

注記
(Currentメニューの)コマンドSet Port Solution Weightsは、放射データには影響しません。遠方界の励振状態は、計
算前に放射パターンのダイアログ・ボックスで指定します。

また、他のプロジェクトの遠方界データも読み込むことができます。表示したい遠方界データを格納しているプロジェクトを選択してから、データをロ
ードします。

Projects > Select Projectを選択します。1.
使用したいMomentumプロジェクトやAgilent EMDSプロジェクトの名前を選択します。2.
Select Agilent EMDSまたはSelect Momentumをクリックします。3.
Projects > Read Field Solutionを選択します。4.
データのロードが終了すると、遠方界プロットとアンテナ・パラメータを表示できます。5.

3次元での遠方界の表示

3次元遠方界プロットは、遠方界の結果を3次元で表示します。
3次元遠方界プロットを表示する手順:

Far Field > Far Field Plotを選択します。1.
プロットを挿入したいビューを選択します。2.
以下から電界のフォーマットを選択します。3.

E = sqrt(mag(E Theta)2 + mag(E Phi)2)
E Theta
E Phi
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E Left
E Right
Circular Axial Ratio
E Co
E Cross
Linear Axial Ratio

データを1に対して正規化したい場合は、Normalizeをオンにします。CircularやLinear Axial Ratioを選択した場合は、Minimum dBを設定します。また、E Co、E4.
Cross、Linear Axial Ratioの場合は、Polarization Angleを設定します。
デフォルトでは、プロットの表示にリニア・スケールを使用します。対数スケールを使用したい場合は、Log Scaleをオンにします。表示したい最小の振幅をdB5.
単位で設定します。
OKをクリックします。6.

遠方界表示オプションの選択

遠方界の半透明度を変更し、一定値となるφの角度を設定します。

Display Optionsをクリックします。1.
遠方界の縦方向に白い破線が表示されます。スクロール・バーを使用して、度単位でConstant Phi Valueを設定することにより、ラインの位置を調整できま2.
す。
Translucencyの下のスクロール・バーを使用して遠方界の半透明度を調整します。3.
Doneをクリックします。4.

遠方界の2次元断面の定義

遠方界から2次元断面を切り取り、極座標プロットや直交座標プロットで表示できます。断面タイプは、垂直断面(φ固定、θ掃引)または水平断面(θ
固定、φ掃引)のどちらかです。下図は、垂直断面(φ断面)と水平断面(θ断面)と極座標プロットで表示されるそれぞれの2次元断面を示します。

以下の手順で、2次元断面の定義方法について説明します。

3次元遠方界の断面を定義する手順:

Far Field > Cut 3D Far Fieldを選択します。1.
水平断面が必要な場合は、Theta Cutを選択します。垂直断面が必要な場合は、Phi Cutを選択します。2.
Constant Theta Valueスクロール・バーを使用して水平断面の角度を設定するか、Constant Phi Valueスクロール・バーを使用して垂直断面の角度を設定し3.
ます。
Applyをクリックして設定を確定します。断面がCut Plotsリストに追加されます。4.
これらの手順を繰り返して他の断面を定義します。5.
Doneをクリックして、ダイアログ・ボックスを終了します。6.

遠方界の2次元表示

3次元遠方界プロットの2次元断面を定義すると、以下のプロット・タイプのどれかで断面を表示できます。

極座標プロット
直交座標プロット、角度対大きさ
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下図では、断面を極座標と直交座標で表示しています。 

2次元遠方界プロットを表示する手順:

Far Field > Plot Far Field Cutを選択します。1.
2D Far Field Plotsリストから2次元断面を選択します。断面タイプ(φまたはθ)およびその角度で、それぞれの断面を区別します。2.
プロットを表示したいビューを選択します。3.
電界のフォーマットを選択します。4.
プロット・タイプを選択します。 Cartesian(直交座標)またはPolar(極座標)のどちらかです。5.
データを1に対して正規化したい場合は、Normalizeをオンにします。6.
デフォルトでは、プロットの表示にリニア・スケールを使用します。対数スケールを使用したい場合は、Log Scaleをオンにします。利用可能ならば表示したい7.
最小の大きさをdB単位で設定します。 また偏波角を設定します。
OKをクリックします。8.

アンテナ・パラメータの表示

Far Field > Antenna Parametersを選択して、利得、指向性、放射パワー、最大電界強度、主放射の方向を表示します。データは、放射パターン・ダ
イアログで指定された周波数と励振状態に基づいています。パラメータには以下があります。

放射パワー、W単位
実効角度、度単位
指向性、dB単位
利得、dB単位
最大放射強度、W/sr(ステラジアン)単位
最大放射強度の方向、θとφ、両方とも度単位
この方向でのE_theta、振幅と位相
この方向でのE_phi、振幅と位相
この方向でのE_x、振幅と位相
この方向でのE_y、振幅と位相
この方向でのE_z、振幅と位相

注記
アンテナ・パラメータでは、電界の振幅の単位はVです。

放射パターンの表示

遠方界データセットで利用するデータに関する詳細は、このセクションを参照してください。

遠方界データセットの変数

変数 説明

THETA 垂直断面(Planarカット)の掃引パラメータ。THETAを掃引する場合は、PHIはCutting Angleフィールドで指定され
た固定値であり、データセットには記録されません。

PHI 水平断面(conicalカット)の掃引パラメータ。PHIを掃引する場合は、THETAはCutting Angleフィールドで指定され
た固定値であり、データセットには記録されません。

EthetaおよびEphi thetaおよびphi方向の電界の遠方界成分の絶対電界強度(V単位)。

HthetaおよびHphi thetaおよびphi方向の磁界の遠方界成分の絶対磁界強度(A単位)。

ElhpおよびErhp 遠方界の左旋回、右旋回円偏波電界成分の正規化電界強度。

ARcp 左旋回、右旋回円偏波遠方界成分から導出される軸比。

EcoおよびEcross 遠方界の水平および垂直偏波電界成分の正規化電界強度。
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ARlp 水平および垂直偏波遠方界成分から導出されるリニア偏波軸比。

Gain、 Directivity、Efficiency、
Effective Area

利得、指向性、効率(%単位)、実効面積(m 2単位)。

Power 放射強度(W/sr単位)。

注記

正規化遠方界成分(Elhp、Erhp、Eco、Ecross)は で正規化されています。

Momentum Visualization
Momentum Visualizationにより、以下のシミュレーション・データを表示、解析できます。

Sパラメータ
電流
遠方界
アンテナ・パラメータ
伝送ライン・データ

データは、さまざまな2Dや3Dのプロット形式で解析できます。データのタイプによっては、表形式で表示されます。

任意のMomentumプロジェクトのシミュレーション結果を表示できます。

このセクションでは、Momentum Visualizationの使用法の概要について説明します。結果の表示で、Sパラメータや電流などの特定のタイプのデータ
を表示するためのMomentum Visualizationの使用法について説明します。

Momentum Visualizationの起動

Momentum Visualizationを起動するには、Momentum > Post-Processing > Visualizationを選択します。データを表示するには、現在のプロジェクトの
シミュレーションを完了させる必要があります。あるプロジェクトのシミュレーションがすでに完了していれば、Visualizationを直接起動して既存のデー
タを表示できます。

PCおよびLinuxマシン上のMomentum Visualization

PCおよびLinuxプラットフォーム上では、Momentum VisualizationはEMDSプレビュワーに基づいています。以下の図は、Momentum Visualizationを起
動したときに表示される基本ウィンドウを示しています。

  

起動時に表示されるウィンドウはEMDS 3次元プレビュワーとほぼ同じですが、いくつかの変更点があります。

EMDSポートの表面が表示されなくなりました。
オブジェクトの陰影がすべて除去されています。
最低周波数におけるポート1の陰影表示電流プロットが表示されます。
ウィンドウに、ビューを制御するためのタブがさらに2個追加されています。

初期ウィンドウのレイアウトは、EMDSプレビュワーのレイアウトとほぼ同じです。左側に、ドッキング・ウィジェット内のビューに対する基本コントロー
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ルがあります。Propertiesタブで、EMDSプレビュワーのPropertiesタブと同じ機能が得られます。

プロットのタイプ

Momentum Visualizationは、3つの基本プロット・タイプをサポートしています。以下があります。

Surface Current Plot - このプロットは、導体の表面上の電流密度を表示します。
Arrow Plot - このプロットは、導体の表面上の電流密度のベクトル表現を表示します。
Mesh Plot - このプロットは、表面電流値の計算に使用されるMomentumメッシュを表示します。

初期バージョンのMomentum Visualizationと異なり、1個の電流プロットと1個の矢印プロットしか表示できません。矢印プロットと電流プロットは、常に
選択した励振に対応します。励振が変化すると、プロットが、現在の位相の新しい励振値を使用して自動的に更新されます。

Solution Configurationタブ

 

Solution Configurationタブを使用してプロットの電流励振を選択します。すべてのプロットは、選択された電流解を自動的に反映します。ポートまた
は周波数を選択するだけで、励振が変化し、プロットが自動的に更新されます。

Maximum Value

励振が変化したときは、最大値を除いて、与えられたプロットのプロット・プロパティはすべて保持されます。この値
は、プロットが作成し直されたときにリセットされます。

 

Plot Propertiesタブ

Plot Propertiesタブで、3つの基本プロットとアニメーション設定を制御できます。
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Shaded Plot

陰影表示の電流プロットの表示は、プロット名の横のチェック・ボックスを使って制御します。選択すると、プロットが表示されます。プロット内に、以下
の基本コントロールがあります。

Log Scale - スケーリングとカラー表現で対数スケールとリニア・スケールのどちらを使用するかを制御します。
Transparency - 陰影表示プロットの透明度を制御します。

Arrow Plot

矢印プロットの表示は、プロット名の横のチェック・ボックスを使って制御します。選択すると、プロットが表示されます。プロット内に、以下の基本コン
トロールがあります。

Scale - デザインの電流密度の相対的な大きさに基づいて、矢印をスケーリングするかどうかを制御します。選択すると、矢印がスケーリングされ、電流密度
が低い領域の矢印が小さくなります。選択しないと、すべての矢印が同じサイズとなります。ただし、サイズはArrow Sizeを変更することで変更できます。
Log Scale - スケーリングとカラー表現で対数スケールとリニア・スケールのどちらを使用するかを制御します。スケーリングをオンにしない場合は、カラーの
重み関数のみが影響を受けます。
Arrow Size - 画面上の矢印の相対サイズを制御します。矢印がスケーリングされていない場合は、デフォルト・サイズの矢印が、スケーリング時の矢印よりも
大きく表示される可能性があることに注意してください。

Mesh Plot

このプロットをオンにすると、電流密度の計算に使用されるMomentumメッシュが表示されます。

Advanced Options

ShadedおよびArrowプロット領域から選択可能なAdvanced Optionsダイアログで、プロットのカラー・レンジと、それぞれのプロットの最大値/最小値
を制御できます。

Shaded Advanced Options Arrow Advanced Options
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Arrow Advanced Optionsでは、デフォルト倍率1を変更したときに矢印プロットのサンプリングも変更できます。

Arrow Sampling
arrow samplingを変更したときには、システムが表示を更新するまでに数秒かかる可能性があります。

Animation

矢印と陰影表示されたプロットのアニメーションは、アニメーション・セクションで制御されます。この領域には2つのコントロールがあります。

Display Update - このオプションは、表示更新の最小時間間隔をms単位で決定します。この設定よりも更新時間が長くなる場合があるので、値は最小値で、
絶対値ではありません。
Phase Increment- 更新が発生したときに現在の位相に追加される度数を制御します。

遠方界プロット

問題に遠方界データが含まれる場合は、Momentum Visualization内で2番目のウィンドウがオンになります。このウィンドウを使用して遠方界プロット
を3次元で表示します。デフォルトで、ウィンドウは、以下に示すように電界を表示するように初期化されています。

このウィジェットに、遠方界オプションを制御する新しいドッキング・ウィジェットも追加されています。
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以下のオプションがあります。

Plot - 表示されるプロットのタイプを制御します。プロットのタイプを選択すると、そのプロットを表示するようにウィンドウが更新されます。
Normalize - データの正規化に使用します。
Log Scale - データの対数スケーリングをオンにするために使用します。
Minimum dB - Log Scaleを使用してデータをプロットするときに使用される最小のdB値です。
Polarization Angle - °単位の偏波角度です。
Transparency - プロットの透明度を制御します。

遠方界のアンテナ・パラメータは、Antenna Parametersボタンを選択すると表示できます。

Solarisマシン上のMomentum Visualization

Momentum Visualizationウィンドウでの作業

下の図は、Momentum Visualizationのウィンドウの基本要素を示しています。

Momentumの概要については、Momentumの概要を参照してください。

ビューの数の選択

デフォルトで、ビュー画面には1つのビューが表示されます。必要に応じて4個のビューを表示できます。4個のビューを使用すると、最大4個の異なる
プロットを同時に表示できます。

4個のビューを表示する手順:

Window > Tileを選択します。
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ヒント
Hide Controlsをクリックすると、表示領域を拡大できます。

ビューを1つ表示する手順:

Window > Full Windowを選択します。現在選択されているビューが、ビュー画面いっぱいに表示されます。

作業用ビューの選択

4個のビューから作業用ビューを1つ選択する必要があります。 作業用ビューはいつでも切り換えられます。
ビューを選択する手順:

ビュー内にマウスを移動し、クリックします。1.
選択しているビューを確認するには、Plot Type - Viewリストのタイトルを見てください。このタイトルは、選択されたビューに応じて変わります。例えば、View 3
を選択すると、Plot Type - View_3と表示されます。
 

あるビューを選択して拡大し、単独で表示する手順:
Window > Select Viewを選択します。2.
Viewリストからビューを選択します。3.
OKをクリックします。ビュー画面に新しいビューが表示されます。4.

ビューのプリファレンスの設定

バックグランド、グリッド・ライン、プロットの軸に沿って現れるテキストなどの、ビューのカラー・プリファレンスを設定することができます。
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プリファレンスを設定する手順:

Window > Preferencesを選択します。1.
バックグランドのカラー、軸ラベルのテキスト、メジャー・グリッドとマイナー・グリッドのカラーを設定します。メジャー・グリッドは、数字の付いたグリッド・ライン2.
であり、マイナー・グリッドは、数字の付いたラインの間のグリッド・ラインから構成されます。
 

Doneをクリックして、ダイアログ・ボックスを終了します。3.

ビュー内の注釈表示の操作

Display > Annotationを選択することにより、ビューにテキストを追加したり、テキストの位置と色を編集できます。設定は保存して再利用できます。

テキストの追加

ビューにテキストを追加する手順:

テキストを追加したいビューを選択します。1.
Display > Annotationを選択します。Annotationダイアログ・ボックスをドラッグして、既存のテキストがすべてビュー内に表示されるようにします。2.
New Annotationをクリックします。3.
AnnotationLabelフィールドにテキストを入力します。このフィールドにすでにテキストが表示されている場合は、削除してからテキストを入力します。入力が終4.
ったらEnterキーを押します。
X LocationおよびY Locationスクロール・ツールを使用して、ディスプレイ上のテキストの位置を調整します。5.
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Doneをクリックして、ダイアログ・ボックスを終了し、新しいテキストを表示します。6.

変数の追加

注釈表示に追加できる変数として、%project%、%view%、%date%があります。Momentum Visualizationを使用しているときは、これらの変数を自動的に
表示できます。

テキストの編集

テキストを編集する手順:

編集したいテキストがあるビューを選択します。1.
Display > Annotationを選択します。Annotationダイアログ・ボックスをドラッグして、既存のテキストがすべてビュー内に表示されるようにします。2.
Annotationフィールドで編集したいテキストを選択します。3.
ビュー内のテキストの位置を調整するには、X LocationおよびY Locationスクロール・ツールを使用します。4.
テキストのサイズを変更するには、Annotation Sizeスクロール・ツールを使用して、フォント・サイズを増減します。5.
テキスト文字の太さを変更するには、Annotation Thicknessスクロール・ツールを使用して、細い、普通、太い文字を選択します。6.
テキストのカラーを変更するには、Annotation Colorの下のカラーの1つを選択します。7.
テキストの向きを変更するには、Orientationの下のHorizontalまたはVerticalを選択します。8.
テキストを変更するには、Annotation Labelフィールドで変更します。9.
テキストの他のラインを変更するには、Annotationフィールドからそのテキストを選択し、必要な編集を行います。10.
終了後、Doneをクリックして、ダイアログ・ボックスを終了します。11.

テキストの削除

テキストを削除する手順:

削除したいテキストがあるビューを選択します。1.
Display > Annotationを選択します。Annotationダイアログ・ボックスをドラッグして、既存のテキストがすべてビュー内に表示されるようにします。2.
Annotationフィールドから削除したいテキストを選択します。3.
Delete Annotationをクリックします。4.
Doneをクリックして、ダイアログ・ボックスを終了します。5.

ビュー内のプロットの復元

1個のビュー内に複数のプロット・タイプを格納できます。1個のビュー内には同時には1個のプロットしか表示できませんが、ビュー内で作業した他の
プロットはすべて保存され、再表示できます。
ビューからプロットを復元する手順:

ビューを選択してから、次のどちらかを実行します。
キーボードの矢印キーを使用して、プロットをスクロールします。
Plot Type - Viewリストで、作業したプロット・タイプを選択します。プロットおよびプロットに追加されたすべてのグラフィック情報が表示されます。
 

 

ウィンドウのリフレッシュ

Window > Refreshを選択して、表示されているビューをいつでも更新できます。通常は、コマンドが完了するとウィンドウは自動的にリフレッシュされ
ます。

データの概要

Momentum Visualizationでは、次のタイプのデータを表示できます。

Sパラメータ
電流
遠方界
アンテナ・パラメータ
伝送ライン・データ(伝搬定数と特性インピーダンス)

このデータを表示するために利用できるプロットとテーブルは、次のメニューにあります。
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プロットとデータによる作業

利用できるプロット・タイプと、表示できるデータ・タイプは数多く存在します。このセクションでは、ビューへのプロットの追加、プロットへのデータの追
加、プロットの編集などを扱います。

プロットの表示

Sパラメータや電流などの基本的なデータ・タイプの各々に対して、それらの表示用のプロットを利用できるように、Momentum Visualizationはデザイ
ンされています。各基本データ・タイプとプロットの詳しい操作方法については、後半の章で説明します。
 

Sパラメータの振幅プロットの表示手順の例:

Plot > Mag Plotを選択します。1.
Matrix and S-Parametersリストで、マトリクスとSパラメータの組を選択します。これらのリストの詳細は、Momentum Visualizationにあります。2.
Viewリストからビューを選択します。このビューにプロットが表示されます。3.
Applyをクリックします。4.

表示されたプロットへのデータの追加

プロットに複数のデータの組を追加できます。

ほとんどの直交座標のプロットに対しては、ビューにプロットを追加しダイアログ・ボックスから異なるデータを選択する手順を繰り返すだけで可能です。別の
プロジェクトのデータを使用したい場合は、まずProjectsメニューからそのプロジェクトを選択してから、この手順を繰り返します。
電流プロットについては、Displayメニューにリストされている項目を追加できます。

次のダイアログ・ボックスでは、Sパラメータの振幅プロットへ2番目のSパラメータを追加する方法を示しています。
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データ・コントロールの操作

以下の項目の外観を変更するためのデータ・コントロールがあります。

Sパラメータ
メッシュ
電流
遠方界

データ・コントロールを使用するには、Graphsリストでデータを選択します。Graphsリストの上に表示されているボタンをクリックします。下図は、直交
座標プロットに表示されるSパラメータ・データやその他のデータに対する例です。
 

データ・コントロールには以下のものがあります。

直交座標プロットでは、データ名、ライン・カラー、ライン・タイプを変更できます。
電流プロットでは、メッシュの外観の変更や、電流のアニメーション表示が可能です。
遠方界プロットでは、半透明度または一定値のφを設定できます。

別のプロジェクトのデータの表示

MomentumまたはAgilent EMDSプロジェクトのデータをプロットに追加することができます。新しいプロジェクトをロード後、データを表示する任意のプ
ロジェクトを選択できます。

Momentumプロジェクトをロードする手順:

Projects > Read Momentum Projectを選択します。1.
プロジェクトを保存したフォルダ(プロジェクト・フォルダ)へ移動し、フォルダをオープンします。2.
そのフォルダの下に、mom_dsnという名前のフォルダがあります。このフォルダをオープンします。3.
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特定のデザインを格納しているフォルダをオープンします。4.
このフォルダ内のファイルをどれかダブルクリックします。5.

新しいAgilent EMDSプロジェクトをロードする手順:

Projects > Read Agilent EMDS Projectを選択します。1.
プロジェクトが格納されているプロジェクト・ディレクトリを選択します。2.
Projectsリストでプロジェクトを選択します。リストの下の注釈表示は、選択されたプロジェクトが解を保存しているかどうかを示します。3.
OKをクリックします。4.

異なるプロジェクトに変更する手順:

Projects > Select Projectを選択します。1.
MomentumまたはAgilent EMDSプロジェクトのリストからプロジェクトを選択します。2.
Select MomentumまたはSelect Agilent EMDSをクリックします。3.

注記
Momentumウィンドウのタイトル・バーに、現在選択されているプロジェクトの名前が表示されます。データはこの
プロジェクトから読み取られます。

プロットのデータの削除

Window > Eraseを選択して、プロットから一部または全部のデータを削除します。データを削除すると、Graphリストからも削除されます。

削除したいデータを表示しているプロットを選択します。1.
Window > Erase Plotを選択します。2.
削除するデータを選択します。3.
Applyをクリックします。4.
必要に応じて他のデータを選択し、Applyをクリックします。5.
Doneをクリックして、ダイアログ・ボックスを終了します。6.

プロットからのデータ値の読み取り

任意のプロットから1個のデータ・ポイントを読み取ることができます。値は、Momentumウィンドウのボトム近くに表示されます。表示されるデータ・タ
イプは、プロット・タイプにより異なります。遠方界プロットからは、データは読み取られません。

1個のデータ・ポイントの値を読み取る手順:

対象のデータ・ポイントにマウスを合わせてクリックします。
直交座標プロットとスミス・チャートから読み取った値には、データ名、プロットのX軸とY軸の値が含まれています。値は丸められる場合があります。
 

 
電流プロットでは、Displayメニューから追加したObjectsに対して選択した値を読み取ることができます。それらはレイアウトの描画座標、x、y、zです。
 

 

プロット・コントロールによる操作

Momentumウィンドウの下にあるプロット編集コントロールを使用してプロットの回転、サイズ変更、移動を行うことで、データのビューを最適化できま
す。直交座標プロットで作業するときには、プロットのスケールを調整できます。

プロットの回転

Rotateコマンドは、3次元プロットをX、Y、またはZ方向に移動します。オブジェクトと3次元遠方界プロットだけを回転することができます。

プロットを回転させる手順:

Rotateをクリックします。1.
下記のいずれかの方法でプロットを回転します。2.
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プロットの任意の場所にマウスを合わせてから、マウスを上下や対角線方向にドラッグして回転します。マウスのボタンを離して、プロット位置を確定します。
Rotationをクリックして、スクロール・バーを使用して、X Rotation、Y Rotation、Z Rotationの値を設定します。値の範囲は、-180度から180度です。
Viewsをクリックして定義済みのビューを選択します。選択項目には、Front Angle、Back Angle、Top、Side、Frontがあります。

プロットのスケーリング

Scaleコマンドは、プロットのサイズを拡大または縮小します。

プロットをスケーリングする手順:

Scaleをクリックします。1.
プロットを拡大するには、プロットの任意の場所をクリックし、マウスを上または右にドラッグします。2.
プロットを縮小するには、マウスを下または左にドラッグします。3.

プロットの中心点の移動

Panコマンドは、プロットを水平または垂直方向に移動します。

プロットを移動する手順:

Panをクリックします。1.
プロットの任意の場所をクリックし、マウスをドラッグして、プロットを上下左右に移動します。2.

直交座標プロット編集コントロールによる作業

直交座標プロットには、上記の他に以下のプロット・コントロールがあります。

プロットのX軸とY軸の調整
プロットのデータ凡例の調整

プロットの軸の調整

Graph Propertiesダイアログ・ボックスにより、プロットに表示するデータの範囲の変更、プロットのグリッド・ライン数の増減、各軸に沿って表示される
テキストの変更が可能です。

プロットのデータ範囲を変更する手順:

Graph Propertiesをクリックします。1.
X AxisとY AxisのMinフィールドとMaxフィールドに現在の上下限値が表示されます。表示されるデータの範囲を変更するには、それぞれの軸のMinフィールド2.
とMaxフィールドに新しい値を入力します。
入力するたびにEnterを押し、プロットへの影響を確認します。3.

X軸とY軸を手動でスケーリングする手順:

Graph Propertiesをクリックします。1.
Divフィールドに1目盛りあたりの単位数を入力します。例えば、Divを20に設定し、Minを0、Maxを100に設定すると、軸に沿って5本のメジャー・グリッドが表示2.
されます。
 

 
Ticksフィールドに1目盛りあたりのグリッド・ライン数を入力します。上図では、Ticksは1に設定されているので、1目盛りあたり1本のラインが表示されていま3.
す。
入力するたびにEnterを押し、プロットへの影響を確認します。4.
 
プロットの軸を自動的にスケーリングする手順:
Graph Propertiesをクリックします。5.
Auto Scaleをクリックして、プロットのX軸とY軸を自動スケーリングします。6.
 
各軸のテキストを変更する手順:
Graph Propertiesをクリックします。7.
X LegendとY Legendフィールドに新しいテキストを入力します。8.
入力するたびにEnterを押し、プロットへの影響を確認します。9.

凡例の編集

1つのプロットに複数のデータがある場合、凡例でデータを区別できます。凡例は、データの表示に使用するカラーとデータ名を表示します。
凡例は、移動、サイズ変更、消去できます。またデータ名を変更することもできます。
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凡例を編集する手順:

Legend Propertiesをクリックします。1.
空のダイアログ・ボックスが表示された場合は、Visibleをオンにします。2.
X LocationとY Locationのスクロール・バーを使用して、ビュー内の凡例の位置を調整します。3.
Legend Title Sizeで、タイトル内のフォント・サイズを調整します。4.
Legend Entries Sizeで、データ名のフォント・サイズを調整します。5.
データ名の上のタイトルを変更するには、Legend Titleフィールドに異なるタイトルを入力します。6.
Doneをクリックして、ダイアログ・ボックスを終了します。7.
 
データの名前を編集する手順:
Graphsリストからデータを選択します。8.
Line Propertiesをクリックします。9.
Line Legendの下に、データの新しい名前を入力します。10.
Doneをクリックして、ダイアログ・ボックスを終了します。11.

プロットの保存

プロットしたデータとプロット・タイプをファイルに保存できます。データ・タイプには以下のものがあります。

Sパラメータの振幅と位相
インピーダンス
伝送データ
遠方界断面

ファイルはASCII形式なので、データは他のアプリケーションでも使用できます。
これらのファイルを直接Momentum Visualizationにインポートすることもできます。これにより、データを表示するために、プロジェクトを読み込んでからプロジ
ェクトを選択する必要はなくなります。
 
プロットされたSパラメータをエクスポートする手順:

File > Export Plot Dataを選択します。1.
エクスポートしたいプロットのタイプを選択します。2.
Plotsの下で、プロットに適用したいSパラメータを選択します。3.
Browseをクリックします。ファイルを保存するフォルダに移動して、ファイル名を入力します。ファイル名には、拡張子(.hfd)が自動的にアペンドされます。OKを4.
クリックします。
選択内容が正しければ、Applyをクリックします。計算されたSパラメータとプロット・タイプがファイルに書き込まれます。5.
必要に応じて、他のプロット・タイプの他のSパラメータの組を保存します。ファイルを生成するために、Applyを必ずクリックしてください。6.
終了後、Doneをクリックして、ダイアログ・ボックスを終了します。7.
ファイルはASCII形式で保存されます。テキスト・エディタでファイルの内容を表示できます。8.
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プロットのインポート

.hfdフォーマットでファイルに保存されたプロットは、インポートできます。これにより、データを表示するために、プロジェクトを読み込んでからプロジェ
クトを選択する必要はなくなります。
 
ファイルをインポートする手順:

File > Import Plot Dataを選択します。1.
Browseをクリックし、対象のファイルを選択します。2.
ダイアログ・ボックスに次の情報が表示されます。3.

File Name − ファイルのフル・パスとファイル名
Plot Type Label − ファイルに保存されているプロットのタイプ
Plot Name Label − ファイルに保存されているSパラメータ
Import Name − Sパラメータ・プロットに対してポスト・プロセッサが割り当てる名前。これは、プロットを表示するときに選択する名前です。

Applyをクリックします。必要に応じてSパラメータ・プロットのインポートを続けます。4.
プロット・ファイルのロードが終了したら、Doneをクリックします。5.
 
インポートされたプロットを表示する手順:
Plot > Plot Import Dataを選択します。6.
プロット・タイプを選択します。利用可能なプロットのリストが表示されます。7.
表示したいプロットの名前を選択します。8.
ビューを選択します。9.
Applyをクリックします。必要に応じてビューへのプロットの追加を続けます。10.
Doneをクリックして、ダイアログ・ボックスを終了します。11.

表面電流の表示

Momentum Visualizationでは、有限の導体上の電界による表面電流密度（A/m）と無限のグランド・プレーンの開口部の磁界による表面電流を表示
できます。この章では、電流の表示方法について説明します。
 

注記
実際の電流密度は、Visualizationがレポートする値の2倍です。

ポート解の重み付けの設定

電流プロットを表示する前に、周波数を選択し、その周波数に対するポート解の重みを設定します。ポート解を重み付けすると、与えられた周波数の
解に対する、1つのポート解の寄与量を指定できます。重み付けは、電流プロットに反映されます。

テブナンの等価電圧源(電圧源と信号源インピーダンスを直列にしたもの)が、回路の各ポートに接続されます。信号源インピーダンスは、単一ポー
ト、差動ポート、コプレナ・ポートに対しては特性インピーダンスであり、他のすべてのポート・タイプに対しては50Ωです。各ポートの電圧源の振幅
は、そのポート解の重み付け設定(振幅+位相)で決まります。

表示される電流は、この励振状態に対応する電流です。
ポート解の重み付けを設定する手順:

Current > Set Port Solution Weightsを選択します。1.
周波数を選択します。2.
ポートを選択し、Solution Weightフィールドに振幅の重み値を入力し、Solution Phaseフィールドに位相を入力します。3.
必要に応じて同じ周波数に対して、他のポートについて前の手順を繰り返します。4.
OKをクリックしてコマンドを完了します。5.
 

レイアウトの表示
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電流プロットが表示されると、レイアウトのアウトラインがビューにロードされます(ロードされていない場合)。レイアウトがロードされないか、削除され
ている場合は、Display > Objectsを選択してレイアウトを表示します。

電流プロットの表示

電流プロットは、シミュレートされたレイアウトのすべてのオブジェクト上の表面電流を表示します。回路を伝搬する電流をアニメーション表示すること
ができます。
 

注記
ビューにレイアウトがロードされていることを確認してください。ロードされていない場合は、Display > Objectsを選択
してレイアウトをロードしてください。

電流プロットを表示する手順:

Current > Plot Currentsを選択します。1.
以下のグラフ・フォーマットのどれかを選択します。2.

Arrow − 矢印でベクトル量の電流をプロットし、方向と振幅を表示します。
Contour − 電流の「等振幅」の等高線プロットを表示します。
Shaded − 電流の振幅の陰影表示プロットを表示します。プロットされる振幅は色分けされます。値の範囲を示すカラー・スケールも画面に表示されます。

プロットを表示したいビューを選択します。3.
OKをクリックします。4.

プロットされた電流のアニメーション表示

電流は、定常状態の正弦波または高調波で、時間に依存します。係数 で時間依存を表わします。時間領域で表面電流を視覚化でき、回路内で

の伝搬の様子をアニメーション表示できます。時間による変動は、係数 によって生じる位相変化に対応します。この位相を連続的に変化させた
り、手動で位相をステップ変化させることができます。

位相を手動で変化させる手順:

スクロール・バーを使用します。これでレイアウト内の位相を固定できます。
自動アニメーション表示を行う手順:

Display Propertiesをクリックします。1.
Animateをオンにします。2.
電流が時間領域でアニメーション表示されます。アニメーションは、Animateをオフにするまで続きます。Incrementフィールドを編集して、アニメーションの速さ3.
を変更できます。値を大きくすると速くなり、小さくすると遅くなります。
カラー・スケールの最大値を変更できます。選択したグラフィック・フォーマットによって、次のようなその他のオプションを変更できます。4.

陰影表示と等高線表示では、半透明度と電流のカラーを設定できます。
矢印プロットでは、矢印の長さを変更できます。

電流プロットのメッシュの表示

Display > Meshを選択して、電流プロットにメッシュを追加できます。

メッシュを表示する手順:

Display > Meshを選択します。1.
メッシュを追加したいプロットを表示しているビューを選択します。メッシュはオブジェクトだけに表示できます。2.
OKをクリックしてコマンドを完了します。3.
 

ヒント
描画順序によっては、メッシュが陰影表示の電流プロットの下になり、見えなくなることがあります。メッシュを表示
するには、陰影プロットの半透明度を下げてください。

Momentumデータのエクスポート
Momentumデータは、さらに解析を行うために3次元電磁界モデリング・ツールとIC-CAPにエクスポートできます。データのエクスポートに使用する方
法は、ターゲット・アプリケーションに依存します。

MomentumデータのIC-CAPへのエクスポート
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Momentumは、Sパラメータ出力ファイルをIC-CAP測定データ管理(MDM)ファイル形式で書き込むことができます。このASCIIデータ・ファイルは、IC-
CAP 5.xで簡単に読み込んで、モデル化のために使用できます。

IC-CAP MDMファイル出力の有効化

IC-CAP MDMファイルは、デフォルトでは作成されません。以下のMomentumの構成ファイルを作成または編集する必要があります。

($HOME)/hpeesof/config/momentum.cfg

そして以下の行を追加します。

MOM3D_GENERATE_MDMFILE = TRUE

この変数を設定すると、Momentumシミュレーションが完了すると、以下のIC-CAP MDMファイルが作成されます。

(current_ADS_project_name)/mom_dsn/(current_layout_name)/proj.mdm

このファイルは、1ポートと2ポート・ストラクチャに対してだけ利用可能です。

Momentumのシミュレーション中に、adaptiveシミュレーション・モードが使用された場合は、データが密に(周波数の関数として)サンプリングされま
す。使用されなかった場合は、proj.mdmファイルには、要求したサンプルリング・ポイントだけが記録されます。

IC-CAP MDMファイル出力の無効化

.mdmファイルで出力したくない場合は、MOM_GENERATE_MDMFILE変数を無効にする必要があります。

この場合以下のように設定する必要があります。

MOM3D_GENERATE_MDMFILE = FALSE

あるいは、Momentumの構成ファイルで、以下の行を削除します。

($HOME)/hpeesof/config/momentum.cfg

例

これは、Momentumで作成した.mdmファイルの中身の例です。

3次元電磁界シミュレーション用のMomentumデータのエクスポート

Momentumシミュレーションを最初に実行しなくても3次元電磁界シミュレーション用のMomentumデータをエクスポートできます。デザイン形状と、技
術情報、スティミュラス情報を含めたMomentum設定を記述したファイルの完全セットを、ADS Layoutウィンドウのメニュー・コマンドを使用して特殊な
ディレクトリに書き込むことができます。

ファイルを作成して3次元電磁界シミュレーションで使用する手順:

ADS Layoutウィンドウで、Momentum > 3D EM > Save Files for 3D EMを選択します。
ファイルが作成され、現在のプロジェクトの<project_name> /mom_dsn/ <design_name> /3DEMの下に保存されます。これには、デザイン形状と
Momentum設定が含まれます。
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Momentumファイルを3次元電磁界モデリング・ツールにインポートする方法の詳細については、ツールに付属のドキュメントを参照するか、ツールのメーカに
お問い合わせください。

MomentumサブストレートのRFDEへのエクスポート

RFDEで使用するためMomentumサブストレートをエクスポートするには、以下の手順を実行します。

サブストレートを定義します。1.
Momentumシミュレーションを実行します（例えば、Momentum > Substrate > Precompute... ).2.
プロジェクトを保存します。3.
RFDEで、<projectDir>/ mom_dsn /<designName>の下にあるproj.tchファイルを選択します。4.
RFDEとADSのマスク番号が一致しない場合は、proj.tchファイルを編集し、ADSのマスク番号をRFDEの番号に置き換えます。

注記
シミュレーションの終了前に、一時シミュレーション・ディレクトリからproj.tchファイルにアクセスできます。一時シミ
ュレーション・ディレクトリの場所は、オペレーティング・システムの設定に依存します。UNIXとLinuxの場合は通
常、/var/tmp/<somedirectory>の下にあります。PCでは、TEMPシステム環境変数の値に依存します。

Momentumの動作原理
Momentumは、モーメント法と呼ばれる数値離散化手法に基づいています。この方法を使って、多層誘電体サブストレートに埋め込まれた平面ストラ
クチャに対するマックスウェル方程式を解きます。Momentumで使用可能なシミュレーション・モード（マイクロ波とRF）は、どちらもこの手法に基づい
ていますが、結果を得るために同じテクノロジーの異なるバリエーションを使用しています。

Momentumには、マイクロ波(全波)モードとRF（準静的）モードの2つの動作モードがあります。これら2つのモードの主な違いは、用いられるグリーン
関数の定式化にあります。全波モードは、全波グリーン関数を使用します。これらは、マックスウェル方程式を簡略化せずにサブストレートを完全に
特性評価する、一般的な周波数依存のグリーン関数です。これにより、複素数で、周波数依存のL要素とC要素が得られます。準静的モードでは、
周波数に依存しないグリーン関数が使用され、実数で、周波数に依存しないL要素とC要素が得られます。準静的モードでは近似が行われるため、
行列のL要素とC要素は最初の周波数シミュレーション・ポイントに対してのみ計算すればよいので、RFシミュレーションの実行速度がはるかに高速
です。また、近似を行うために、準静的モードは通常、2分の1波長より小さいストラクチャに使用する必要があります。どちらのエンジン・モードもいわ
ゆるスター・ループ基底関数を使用していて、すべての周波数で安定した解が保証されます。両方のエンジンは、多角形メッシュを生成してシミュレ
ーションの未知数の数を減らす、メッシュ低減アルゴリズムも利用しています。このメッシュ低減アルゴリズムは、トグル・スイッチでオンまたはオフに
することができます。

回路のポートに適用された信号源が、等価回路モデルを励振します。等価回路の電流は、Rooftop展開関数の未知の振幅です。独立したいくつか
の励振状態に対して等価回路を解くことにより、未知の電流振幅が得られます。電流解から回路のSパラメータ・データを求めるには、ポート校正プ
ロセスが用いられます。

この章の各セクションでは、以下の項目について詳細を説明します。

モーメント法
Momentumの計算プロセス
特殊なシミュレーションの例
注意事項とソフトウェアの制限

モーメント法

モーメント法(MoM)は、R.F. Harringtonの業績に基づいたものです。Harringtonは電気技術者で、1960年代の初めにこの方法について詳細な研究を
行い、電磁界の問題に適用しました。 この方法は、重み付き残差法と変分解析を用いるそれ以前の方法を元にしたものです。モーメント法とグリー
ン定理の詳細については、Field Computation by Moment Methods (1)を参照してください。
モーメント法では、離散化の前にマックスウェル方程式を積分方程式に変換します。積分方程式は、多層サブストレートの適切な電界と磁界のグリ
ーン関数の定義から得られます。

Momentumでは、混合ポテンシャル積分方程式が用いられます。この方程式では、電界と磁界をベクトル・ポテンシャルとスカラ・ポテンシャルの組み
合わせで表現します。未知数は、平面回路に流れ込む表面電流と磁流です。

線形代数の表記法を使うと、混合ポテンシャル積分方程式を線形積分演算子式として非常に一般的な形で表現できます。

(1)

ここで、J(r)は未知の表面電流、E(r)は既知の励振を表わします。レイヤ媒体のグリーンのダイアディックが積分核として働きます。未知の表面電流
を離散化するために、平面メタラオぜーション・パターンをメッシュ化し、有限個の部分基底関数B1(r), ..., BN(r)で展開します。
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(2)

プレーナ電磁界シミュレータで用いられる標準基底関数は、メッシュの長方形／三角形／多角形セルに対して定義された部分Rooftop関数です。各
Rooftop関数がメッシュの辺に関連付けられていて、その辺を通って流れる一定密度の電流を表します(以下の図を参照)。基底関数展開の未知の
振幅Ij, j=1,..,Nにより、メッシュのすべての辺を通って流れる電流が決まります。

Rooftop基底関数を使った表面電流の離散化

積分方程式(1)を離散化するために、電流のRooftop展開(2)を代入します。Galerkin法、すなわち基底関数と同一の試験関数を使って積分方程式を
試験する方法を適用することにより、連続積分方程式(1)が次のような離散行列方程式に変換されます。

i=1,...,Nに対して

(3)

ここで

(4)

(5)

左辺の行列[Z]は、相互作用行列と呼ばれます。 これは、この行列の各要素が、2個のRooftop基底関数の間の電磁相互作用を記述するからです。
[Z]の次元Nは、基底関数の数に一致します。右辺のベクトル[V]は、回路の各ポートに適用される励振の寄与を離散化したものを表します。

表面電流は、レイヤ・スタックのグリーンのダイアディックを通して、回路の電磁界に寄与します。混合ポテンシャル積分方程式では、このグリーンの
ダイアディックが、ベクトル・ポテンシャルA(r)からの寄与とスカラ・ポテンシャルV(r)からの寄与に分解されます。

(6)

スカラ・ポテンシャルは、表面電流に起因する動的な表面電荷分布から生じ、ローレンツ・ゲージによってベクトル・ポテンシャルと関連づけられま
す。
式(6)のグリーンのダイアディックを式(4)の相互作用行列要素に代入すると、次の式が得られます。

(7)

ここで

(8)
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(9)

これらから、等価回路モデルを構築して、相互作用行列方程式に物理的解釈を与えることができます(図A-2を参照)。この回路では、ノードがメッシ
ュのセルに対応し、セルの電荷を保持しています。各セルはグランドに対するキャパシタに対応します。各ノードを接続する分岐には、セルの各辺を
通過する電流が流れます。各分岐にはインダクタが存在し、対応する電流基底関数の磁気的な自己結合を表します。回路内のすべてのキャパシタ
とインダクタは複素数で、周波数依存であり、相互結合しています。 これは、すべての基底関数が電気的および磁気的に相互作用するからです(図
A-3を参照)。この等価回路のグランドは、レイヤ・スタックにある無限のメタライゼーション・レイヤのポテンシャルに対応します。無限のメタライゼー
ション・レイヤがない場合は、グランドは無限大の球に対応します。モーメント法の相互作用行列方程式は、等価回路にキルヒホッフの電圧則を適用
することにより得られます。回路内の電流は、行列方程式の解から得られ、基底関数の振幅を表します。

図A-2. メッシュの各セルを、グランド基準に対するキャパシタと隣接セルに対するインダクタで置き換えることにより、等価回路が構成されます。

図A-3. モーメント法により離散化された等価回路表現

Momentumの計算プロセス

Momentumの計算プロセスは、以下のような手順と手法から構成されています。

サブストレートのグリーン関数の計算
平面信号レイヤ・パターンのメッシング
モーメント法の相互作用行列方程式のロードと計算
Sパラメータの校正とディエンベディング
適応周波数サンプリングによる縮約次元モデリング

サブストレートのグリーン関数の計算

サブストレートのグリーン関数とは、Diracのデルタ関数の励振に対するサブストレートの空間インパルス応答です。サブストレート・レベルにマッピン
グされた信号(ストリップ、スロット、ビア)レイヤの各ペアに対して、グリーン関数が計算されます。どの信号レイヤがサブストレート・レベルにマッピン
グされているかを知る必要はありますが、計算するのはインパルス応答だけなので、信号レイヤ上のパターンを知る必要はありません。このため、
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グリーン関数は事前に計算してサブストレートのデータベースに記憶しておくことができます。これにより、同じサブストレートで定義された他の回路
にグリーン関数を再利用できます。

高周波電磁界のグリーン関数は、動径距離と周波数に依存します。ユーザが指定した周波数帯域全体で、非常に大きい動径距離まで計算が行わ
れます。周波数に対して正確な補間が可能になるように、周波数ポイントは適応的に選択されます。非常に広い周波数レンジの計算を行うと、CPU
時間と、結果を記録するディスク領域を多量に消費します。速度を増加させるために、RFモードでは、低周波近似に基づいた準静的電磁界のグリー
ン関数を使用し、高周波では準静的グリーン関数をスケーリングします。

平面信号レイヤ・パターンのメッシング

マイクロ波シミュレーション・モードでは、信号レイヤ上に定義された平面メタライゼーション(ストリップ、ビア)パターンおよびアパーチャ(スロット)パタ
ーンは、長方形と三角形のセルを使ってメッシュ化されます。並進不変性を利用して相互作用行列のロード・プロセスを高速化できるので、メッシン
グ・アルゴリズムはなるべく一様な長方形のセルを使ってメッシュを作成しようとします。メッシング・アルゴリズムはきわめて柔軟であり、さまざまな
パラメータ(1波長あたりのセル数、幅方向のセル数、エッジ・メッシュ、メッシュ・シードなど)をユーザが指定して、異なる密度のメッシュを作成できま
す。メッシュ密度は、シミュレーションの効率と正確さに大きな影響を与えます。デフォルトのメッシュ・パラメータは、正確さと効率のトレード・オフを考
慮して最適な選択が行われます。RFモードもマイクロ波モードもメッシュ低減手法を使用して、長方形と三角形のセルを組み合わせて多角形セルの
メッシュを作成するので、コンピュータ・リソースの要求が減少します。メッシュ低減は、電気モデリングの観点からは、確度を高めることなくシミュレー
ション・プロセスを複雑化するだけの、小さい長方形と三角形を除去します。すでに説明したように、この機能は、トグル・スイッチでオンまたはオフに
することができます。

モーメント法の相互作用行列方程式のロードと計算

計算プロセスのロード段階では、基底関数の間のすべての電磁相互作用が計算され、相互作用行列と励振ベクトルが得られます。Rooftop基底で
定義された相互作用行列は密行列です。 すなわち、すべてのRooftop関数が他のすべてのRooftop関数と相互作用します。2つの基底関数の間の

電磁相互作用は、その位置関係と長さのスケールに応じて、強い場合も弱い場合もあります。行列を得るプロセスは、基本的には(N2)のオーダです
（すなわち、計算時間は未知数の2乗に比例します)。

計算段階では、相互作用行列方程式を解くことにより、未知電流の展開係数が求められます。この計算から、平面回路の表面電流を構成する
Rooftop基底関数の振幅が得られます。電磁界の問題ではすべての物理量が電流で表現できるので、電流がわかると問題を解くことができます。リ
リース2005Aで、Momentumに反復行列計算方式が導入されました。大きな問題サイズの場合は、反復行列計算が、オーダ（N2）プロセスとして実行
されます。Momentumは、ストラクチャが小さい場合、または反復行列計算プロセスで収束の問題が検出された場合は、直接行列計算プロセスを使
用します。

Sパラメータの校正とディエンベディング

あらゆる正確な測定システムと同様に、Momentumもシングル・ポート・タイプで校正プロセスを実行します。 その目的は、伝送ライン・ポートに接続さ
れた信号源の影響をSパラメータの結果から除去することです。有限長のフィードライン（通常、高周波では波長の半分、低周波ではショート・ライン
を使用）が、回路の伝送ライン・ポートに追加されます。集中定数信号源はフィードラインの末端に接続されます。信号源は伝送ラインの固有モード
を励振し、回路に影響を与えません。フィードラインの影響は、校正標準のシミュレーションから求められ、Sパラメータ・データから除去されます。内
蔵の断面ソルバが、伝送ラインの特性インピーダンスと伝搬定数を計算します。これにより、Sパラメータの位相基準面をずらすことができます。この
プロセスをディエンベディングと呼びます。校正プロセスの結果には、ポート境界での低次モード不整合の除去、高次モードの除去、すべてのポート
励振寄生成分の除去が含まれます。

伝送ライン・ポートのほかに、Momentumでは直接励振ポート(内部ポート)をユーザが定義できます。このポートは、平面メタライゼーション・パターン
の任意の位置に、ポイントまたはライン・フィードとして指定できます。このポートを使って、平面回路の分布定数モデルに、パッシブまたはアクティブ
の集中定数コンポーネントを接続できます。このポートのSパラメータは、内部ポート位置で等価回路モデルに接続された集中定数信号源による励
振を使って計算されます。集中定数信号源による寄生効果はSパラメータ結果から除去されません。

適応周波数サンプリングによる縮約次元モデリング

最小限のコンピュータ・リソースで正確な解を高速に得るための鍵となるテクノロジーが、適応周波数サンプリング(AFS)です。広い周波数レンジでシ
ミュレーションを行う場合は、オーバサンプリングと直線補間により、なめらかな曲線のSパラメータを得ることができます。しかし、オーバサンプリン
グでは大量のリソースが無駄に消費されます。Momentumでは、縮約次元モデリング法に基づく巧妙な補間方式により、Sパラメータ・データに対す
る有理極/ゼロ・モデルを生成できます。適応周波数サンプリング・アルゴリズムでは、周波数サンプルが自動的に選択され、適応的に構築された有
理極/ゼロ・モデルによってデータが補間されます。この機能を使えば、Sパラメータの変化が大きい部分でストラクチャの応答が高密度にサンプリン
グされるので、重要な細部のモデリングが可能となります。必要なサンプル数を最小化しながら、新しいサンプルの追加によって得られる情報を最
大化できます。実際には、あらゆるストラクチャに対してAFSモジュールは有効です。適応周波数サンプリングを使えば、Momentumで広い周波数レ
ンジのシミュレーションを行う際の計算時間を大幅に短縮できます。

特殊なシミュレーションの例

このセクションでは、いくつかの特殊なシミュレーションの例について説明します。

グランド・プレーン内にあるスロットのシミュレーション
メタライゼーション損失のシミュレーション
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内部ポートとグランド基準のシミュレーション

グランド・プレーン内にあるスロットのシミュレーション

グランド・プレーン内にあるスロットは、Momentumでは特別な扱いを受けます。等価原理と呼ばれる電磁気学の定理が用いられます。広いグランド・
プレーンを流れる電流をシミュレートするのではなく、スロット内の電界だけが考慮されます。この電界は、スロット内を流れる等価磁流としてモデリン
グされます。
Momentumは、メタライゼーション・グランド・プレーンの有限の厚さをモデリングしません。グランド・プレーンとその損失は、サブストレート定義に含ま
れます。

スロットにメタライゼーション定義を用いることにより、スロット・ラインやコプレナ・ラインなどのストラクチャ全体を構成できます。グランド・プレーン内
のスロットは、多層回路のグランド・プレーンを介したアパーチャ・カップリングをシミュレートするためにも使用できます。グランド・プレーンを挟んで反
対側にあるストラクチャ・コンポーネント同士は、スロットを介して発生する直接のカップリングを除いて、互いに隔離されています。スロットをこのよう
に扱うことで、スロット・ベースの回路やアパーチャ・カップリングをMomentumはきわめて効率的にシミュレートできます。

メタライゼーション損失のシミュレーション

Momentumでは、メタライゼーション・パターンの損失をシミュレーションで考慮できます。Momentumは、導体を厚さゼロとして処理するか、またはシミ
ュレーションに有限の厚さの影響を含めることができます。サブストレート定義では、すべてのレイヤに対して導体の有限厚さへの展開をオンまたは
オフにすることができます。詳細は、ビア・ストラクチャの制限を参照してください。

Momentumでは、すべての金属に対して複素表面インピーダンス・モデルを使用します。このインピーダンスは、導体の厚さ、伝導率、周波数の関数
です。低周波では、電流は金属の厚さ方向にほぼ均等に分布します。Momentumは、この最小抵抗値と、適切な内部インダクタンスを使って、複素
表面インピーダンスを構成します。高周波では、導体の表皮を流れる電流が支配的であり、この表皮効果をよく近似する複素表面インピーダンスが
用いられます。ADS 2005Aリリースでは、有限厚さ導体の側面メタライゼーションに水平方向の電流が導入され、Momentumによって任意の高さ/幅
比を持つ導体を正確にモデリングできます。厚みのある導体の表面インピーダンス・モデルには、厚みのある導体のトップ・プレーンとボトム・プレー
ンでの電流の相互内部カップリングが含まれます。

ストラクチャのシミュレーション結果にメッシュ密度が影響を与えることがあります。高密度のメッシュを使うと、電流がより正確に表現され、損失がわ
ずかに増える場合があります。これは、低密度のメッシュでは電流がより均一に分布するため抵抗が小さくなるからです。

損失を、サブストレート定義で定義されたグランド・プレーンに対して定義できます。これには、マイクロストリップの損失の場合と同じ方程式を使用し
ます（すなわち、表面インピーダンス近似を使用）。ただし、サブストレート定義のグランド・プレーンは、サイズが無限大として定義されているため、
事実上、含まれるのはHF損失のみであることに注意する必要があります。無限グランド・プレーンのDC損失は、定義によりゼロです。グランド・プレ
ーンのDCメタライゼーション損失を考慮するには、有限サイズのグランド・プレーンをストリップ・メタライゼーション・レベルとしてシミュレーションする
必要があります。

注記
損失のある伝導率仕様を持つ無限グランド・プレーンの場合は、マイクロ波モードのMomentumにはグランド・プレー
ンのHF損失が含まれますが、RFモードのMomentumは、これらのHF損失を省略します。

内部ポートとグランド基準を使ったシミュレーション

Momentumでは、ストラクチャに内部ポートを使用できます。内部ポートは平面メタライゼーション・パターンの任意の位置に指定でき、アクティブ/パ
ッシブ集中定数コンポーネントを平面回路の分布定数モデルに接続できます。図A-4を参照してください。

このポートのSパラメータは、図A-3のように、等価回路モデルに接続された集中定数電圧源による励振から計算されます。得られたSパラメータ・モ
デルのこれらのポートに対するグランド基準は、等価回路のグランドであり、物理的にはレイヤ・スタックにある無限のメタライゼーション・レイヤに対
応します。無限のメタライゼーション・レイヤがない場合は、グランドには物理的意味はなく、数学的には無限大の球に対応します。

この場合に重要なことは、対応するSパラメータも物理的意味を持たなくなることです。 これは、適用された電圧源が集中定数であり、グランドから回
路への電流を位相遅延なしで流すので、電気的に小さいと見なされるからです。この問題を解決するには、内部ポートから電気的に小さい距離の位
置にグランド基準を指定します。そうしないと、シミュレーション結果が不正確になる可能性があります。

図A-4.内部ポートと等価回路モデル
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図A-4.内部ポートと等価回路モデル

以下の各セクションでは、内部ポートとグランド・プレーンおよびグランド基準とを組み合わせて使う方法と、その結果について説明します。

PCBストラクチャ内の内部ポートとグランド・プレーン

図A-5に、2個の内部ポートを持つPCBアイランド・ストラクチャのレイアウトを示します。サブストレート・レイヤ・スタックに無限のグランド・プレーンが
存在し、内部ポートのグランド基準の役割を果たします。Momentumが計算したS21パラメータの振幅と位相を図A-6に示します。シミュレーション結
果を検証するために、S21の振幅と位相の測定データと比較します。

図A-5.PCBサブストレート・レイヤ・スタックとメタライゼーション・レイヤ

図A-6.S21の振幅と位相。

太線がMomentumの結果、細線が測定結果

有限のグランド・プレーン、グランド・ポートなし

同じストラクチャを、有限のグランド・プレーンを使って再度シミュレートしました(図A-7)。サブストレート・レイヤ・スタックには無限のメタライゼーション
・レイヤが存在しません。ポートに対してグランド基準が指定されていないので、内部ポートのグランド基準として無限大の球が用いられます。これら
のポートに対してシミュレーションで得られたSパラメータは、物理的な意味を持たなくなります。このようなポートをシミュレーションで使用すると、図
A-8のように誤った結果が得られます。
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図A-7.PCBサブストレート・レイヤ・スタックとメタライゼーション・レイヤ

図A-8.S21の振幅と位相。

太線がMomentumの結果、細線が測定結果

有限のグランド・プレーン、グランド・プレーン内に内部ポート

内部ポートに対してグランドを正しく定義する方法の1つは、グランド・プレーンに2個の内部ポートを追加することです(図A-9)。得られた4ポート・スト
ラクチャをMomentumでシミュレートします。内部ポートに対してグランド基準が指定されていないため、4ポート・ストラクチャに対して得られたSパラメ
ータには物理的意味がありません。しかし、4個のポートを適切に再結合することで、各ポートに対して正しいグランド基準を持つ2ポート・ストラクチャ
が得られます。この再結合では、4個のポートそれぞれに対するグランド基準が、再結合された2個のポートに対するグランド基準として働くわけでは
ないので、注意が必要です。したがって、図A-10の上に示す再結合の方法は正しくありません。正しい再結合の方法は図A-10の下に示すもので
す。
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図A-9.PCBサブストレート・レイヤ・スタックとメタライゼーション・レイヤ

図A-10.シミュレーション結果。

下の図が正しいポートの再結合

有限のグランド・プレーン、グランド基準

2個の内部ポートをグランド・プレーンに追加し、ポートを正しく再結合するプロセスは、Momentumに自動的に実行させることができます。このために
は、2個のグランド基準ポートを定義します(図A-11)。Momentumで得られたSパラメータは、前のセクションで得られた正しい再結合の2ポートのSパ
ラメータと同じです(図A-12)。
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図A-11.サブストレート・レイヤ・スタックとメタライゼーション・レイヤ

図A-12.S21の振幅と位相。

太線がMomentumの結果、細線が測定結果

CPWストラクチャを持つ内部ポート

図A-13と図A-14は、CPWステップ幅ストラクチャとシート抵抗(45  m x 50  m, 50 )のレイアウトです。6個の内部ポートがメタライゼーション・
レイヤに追加されています。6ポートSパラメータ・モデルが2ポート・モデルに再結合されることにより、CPWモードのSパラメータが記述されます。再
結合の方法はいくつかあり、それぞれ異なるシミュレーション結果が得られます。正しい方法は(c)です。内部ポートに対するグランド基準が無限大の
球であり、これはCPWポートに対するグランド基準にはなり得ないからです。



Advanced Design Systemドキュメント

191

図A-13.CPWステップ幅とシート抵抗

図A-14.シート抵抗付きCPWステップ幅ストラクチャとポート構成、結果

内部ポートをグランド・メタライゼーション・パターンに追加し、ポートを正しく再結合するプロセスは、Momentumに自動的に実行させることができま
す。このためには、グランド基準ポートを定義します(図A-15)。Momentumで得られたSパラメータは、正しい再結合方式の2ポートのSパラメータと同
じです(図A-14 (c))。
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図A-15.CPWステップ幅ストラクチャ、内部ポートに対してグランド基準を定義

制限と注意事項

このセクションでは、Momentumの使用にあたって注意すべきソフトウェア的な制限と物理的な注意事項について説明します。

マイクロ波シミュレーション・モードとRFシミュレーション・モードの比較
シミュレーション・モードの回路特性への整合
高次モードと周波数の上限
サブストレート波とサブストレート厚さの制限
平行板モードと周波数の上限
スロットライン・ストラクチャと周波数の上限
ビア・ストラクチャとメタライゼーションの厚さの制限
ビア・ストラクチャとサブストレート厚さの制限
CPU時間とメモリの必要量

マイクロ波シミュレーション・モードとRFシミュレーション・モードの比較

Momentumには、マイクロ波モードとRFモードの2つのシミュレーション・モードがあります。マイクロ波モードは全波方程式を使用し、RFモードは準静
的方程式を使用します。準静的方程式では、グリーン関数は、より一般的な全波グリーン関数の低周波近似です。RFモードでは近似が行われるの
で、シミュレーションがより効率的です。近似は、波長と比較して小さい（回路のサイズが波長の半分より小さい）ストラクチャに有効です。

注記
損失のある伝導率仕様を持つ無限グランド・プレーンの場合は、マイクロ波モードのMomentumにはグランド・プレー
ンの高周波損失が含まれますが、RFモードのMomentumは、これらの高周波損失を省略します。

シミュレーション・モードの回路特性への整合

MomentumのRFモードは、要件に応じて、RF/マイクロ波回路のシミュレーションに使用できます。ただしMomentum RFは、通常、回路が電気的に小
さく、幾何学的に複雑で、放射がない場合に、より有効なモードです。このセクションでは、これらの特性について説明します。

放射

Momentum RFは、RF周波数で正確な電磁界シミュレーション性能が得られます。ただし、RF周波数の上限値は、レイアウト・デザインのサイズに依
存します。高周波では放射効果が増加するので、Momentum RFモデルの精度は、周波数の増加と共に低下します。

同様に、サブストレートで表面波（サブストレート・レイヤを伝搬する誘導波）の伝搬が可能な場合は、表面波がRF計算に含まれないため、RFモード
の精度がしだいに低下します。

電気的に小さい回路

Momentum RFは、電気的に小さい回路に最も有効です。与えられた周波数に対して電気的なサイズを増加すると、その精度がしだいに低下するか
らです。回路の物理的な寸法が与えられた周波数の波長の半分よりも小さい場合は、回路はその周波数に対して電気的に小さいと見なされます。
最大回路寸法または最大シミュレーション周波数のどちらか既知の値に応じて、回路の電気的サイズの定性的近似を決定できます。以下の図に示
すように、寸法Dの回路を仮定します。
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空間波放射の場合は、以下の2つの式のどちらかを指針として使用すると、シミュレーションの最大周波数を基準とした回路の電気的なサイズがわ
かります。値Dが既知の場合は、最初の式を使用して、回路が電気的に小さいときの最大周波数を近似します。最大シミュレーション周波数が既知
の場合は、2番目の式を使用して、最大許容寸法を近似します。

または

ここで、
D = 回路の最大対角長（mm）
F = 最大周波数（GHz）
表面波放射の場合は、以下の式により、サブストレートが電気的に小さいときの最大周波数の指針が得られます。

シミュレーション中、Momentum RFが、回路が電気的に小さいと見なされる最大周波数を計算し、その値をステータス・ディスプレイに表示します。レ
イアウトの寸法と厚さは通常一定であるため上記の式を使用する場合とほぼ同じで、シミュレーション周波数が掃引されます。

形状が複雑な回路

シミュレーション用に生成されるメッシュが、回路の形状が複雑化します。回路は、形状が一様の長方形メッシュに適合せず、メッシュ作成機能により
多数の三角形が作成された場合に形状的に複雑であるとみなされます。円、円弧、長方形以外の多角形などの形状を含むレイアウトのメッシュは、
通常、多数の三角形を持つメッシュになります。幾何学的な複雑さの増加は、長方形セルに対する三角形セルの比率の増加で示されます。



Advanced Design Systemドキュメント

194

Momentum RFおよびMicrowaveによって提供されるメッシュ低減技術により、電磁界的に冗長な方形セルと三角形セルを除去できます。これにより、
シミュレーション時間が短縮するため、効率が高まります。このメッシュ低減アルゴリズムは、トグル・スイッチでオンまたはオフにすることができま
す。

高次モードと周波数の上限

Momentumは校正およびディエンベディングのプロセスで高次モードを考慮しないため、校正およびディエンベディングされたSパラメータが正しい結
果を与える周波数の上限は、ポート伝送ラインの高次モードのカットオフ周波数で決まります。マイクロストリップ伝送ラインに関する経験則として、
最初の高次モードのカットオフ周波数(GHz単位)は次の式で求められます。

カットオフ周波数fc = 0.4 Z0 / 高さ、ここでZ0は、伝送ラインの特性インピーダンスです。10 milのアルミナ・サブストレート上の50Ωマイクロストリップ
伝送ラインの場合、周波数の上限はfc = 約80GHzです。

平行板モード

2つの無限平行板やグランド・プレーンの間の領域には、平行板モードが存在します。回路を流れるすべての電流は、これらのすべてのモードを励
振します。このモードの強度は、電流源によって生成された電磁界が、どの程度平行板モードの電磁界分布に整合しているかに依存しています。

基本モードと高次モードで違いがあります。カットオフ周波数のない基本モードは、任意の周波数で伝搬します。高次モードには、必ずカットオフ周波
数があります。この周波数未満では、高次モードは指数関数的に減衰し、信号源周辺の局所的な(リアクティブな)電磁界にしか影響を与えません。
この周波数を越えると、基本モードと同様に伝搬し、信号源からエネルギーを取り出せます。

Momentumは、基本モードの影響を考慮します。高次モードは、周波数がカットオフ周波数よりかなり低い場合に限り考慮されます。カットオフ周波数
近傍では、警告を発して、カットオフ周波数近傍で高次の平行板モードが検出されたことを報告します。シミュレーション結果は、その周波数以上で
精度が低下し始めます。

平行板モードの影響

基本モードは常に存在するので、このモードに的を絞ります。基本モードは、上部プレートから下部プレートへのZ軸に沿って、支配的な電界を持ち
ます。つまり、このモードは、両方のプレート間に電位差を作り出すということを意味しています。このモードは、ストリップまたはビア上の電流やスロ
ット上の磁流など、回路内の任意の電磁流によって励振されます。これは、無限遠まで伝搬して短絡する(両方のプレートは無限遠で接続されている
と考えるため)円筒波のように振る舞います。しかし、無限遠は非常に遠いので、反射波は決して戻ってきません。

対称ストリップ・ラインでは、対称であるためにストリップ上の電流は基本モードを励振しません。しかし、一方のプレートにスロットなどがあれば、非
対称になるので、スロットは基本モードを励振します。

校正済みのポートに対するMomentumの結果の精度は、平行板モードが支配的になるに従い劣化します。校正済みポートでは、伝送ラインの基本
モードで回路を励振すると仮定されます。しかし、この励振は純粋なものではありません。信号源は、平行板モードでも回路を励振します。両方のモ
ードの成分は直交していないので、平行板モードの効果を校正して取り除くことはできません。結論として、この励振は、伝送ラインの純粋な基本モ
ードによる励振には該当しないことになります。

平行板モードの回避

平行板モードの電磁界の向きはわかっているので、ストラクチャ内の平行板モードが励振されるところにビアを追加してそれらを短絡すれば簡単に
回避できることがわかります。

測定に対しても同様の問題があります。両方のプレートをしっかりと互いに接続しなければならないということです。この短絡は無限遠ではなく、ボー
ドの側面のどこかになります。実際のストラクチャでビアを使用しなければ、基本モードが励振される可能性があります。このモードは境界まで伝搬
して反射します。したがって、反射は無限遠でしか生じないので、反射が生じないシミュレーションでのストラクチャと、実際のストラクチャは異なりま
す。

実際の測定とシミュレーションとの間の差に対する対策の1つは、ストラクチャの周りにパッケージ(ボックス)を作成することです。もう1つ考えられるこ
とは、実物とシミュレーションの両方のストラクチャにビアを追加することです。回路のレイアウト表現を、現実に可能な限り近づけるようにしてくださ
い。しかし、ビアの実際の形状は、それほど重要でないはずです。実際のストラクチャで実現されている小さな円形のビアを小さなシートを用いて、表
現できます。

表面波モード

サブストレートが閉じてなく(全開または半開)、均質でない場合は、表面波モードが存在します。平行板モードは、表面波モードの特別な場合と見る
ことができます。これらの挙動は同一です。両方とも、信号源から動径方向に伝搬する円筒波です。これらは、サブストレートに沿って伝搬します。基
本および高次の表面波モードが存在します。このモードの影響などについては、平行板モードと同様の結論が導かれます。
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スロットライン・ストラクチャと周波数の上限

校正プロセスでの表面波の精度の低下は、スロットライン伝送ラインの方がマイクロストリップ伝送ラインの場合よりも顕著です。このため、
Momentumでスロットライン・ストラクチャをシミュレートすると、マイクロストリップ・ストラクチャよりもいくぶん(10〜20dB程度)高いノイズ・フロアを示し
ます。最善の結果を得るには、スロットライン・ストラクチャに対する最高シミュレーション周波数が次の条件を満たす必要があります。

サブストレートの厚さ < 0.15 × 実効波長

細いスロット・ラインの場合は、この不等式で決まる周波数の上限より多少高い周波数でも正確なシミュレーションが可能です。これに対して幅広の
スロットラインの場合、この周波数上限より上では精度の低下が見られます。

ビア・ストラクチャの制限

Momentumでは、ビア・ストラクチャの電流は垂直方向だけに流れることができます。水平方向の電流や循環電流はモデリングされません。ビア・スト
ラクチャはメタライゼーション・パターンなので、ビアのメタライゼーション損失のモデリングは、マイクロストリップ・ストラクチャやスロットライン・ストラ
クチャの場合と同一です。

ビア・ストラクチャとサブストレート厚さの制限

ビア・ストラクチャの垂直方向の電流は、Rooftop基底関数でモデリングされます。このモデリングでは、垂直のビア・ストラクチャが1個のセルとして
扱われます。正確なシミュレーション結果を得るには、セルの大きさが波長の1/20を超えないようにする必要があるため、サブストレート・レイヤの厚
さに上限が生じます。電気的に厚いサブストレート・レイヤをビア・ストラクチャが貫通している場合、Momentumのシミュレーション結果は高周波でい
くぶん不正確になります。厚いサブストレート・レイヤを複数のレイヤに分割すれば、複数のビア・セルが作成されるため、より正確な解が得られま
す。

CPU時間とメモリの使用量

Momentumのシミュレーションに必要なCPU時間とメモリは、回路の複雑さとメッシュの密度に応じて増加します。相互作用行列の大きさNは、メッシュ
内のエッジ数と等しくなります。校正されるポートの場合、伝送ライン・ポートに付加されるフィードラインのエッジに応じて未知数が増加します。

CPU時間

Momentumシミュレーションに必要なCPU時間は、次のように表されます。

CPU時間 = A + B N + C N2 + D N 3

ここで、

N = 未知数

A, B, C, D = Nと無関係な定数

定数項Aは、シミュレーションのセットアップ時間を表します。線形項BNはストラクチャのメッシングにかかる時間です。相互作用行列のローディング
にかかる時間は2次の項で表され、行列方程式を解くための時間は以下で表されます。

2次の項の一部（反復ソルバを使用する場合）
3次の項（直接ソルバを使用する場合）

定数A、B、C、Dの値は問題に依存するので、予測は困難です。

メモリ使用量

Momentumシミュレーションのメモリ使用量は、次のように表されます。

メモリ = X + Y N + Z N2

ここで、

N = 未知数の数

X, Y, Z = Nと無関係な定数

CPU時間の場合と同様に、与えられたストラクチャに対して定数X、Y、Zを予測するのは困難です。

小〜中規模の問題では、相互作用行列の記憶領域を表す2次の項が常に支配的です。小さいストラクチャの場合は、メモリ使用量がサブストレート
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に依存することもあります。サブストレート・データベースの読み取りと補間にある程度のメモリが必要だからです。シミュレータには、時間とメモリの
トレード・オフを考慮するアルゴリズムが組み込まれています。このアルゴリズムのために、行列を解くのに必要な量よりも多くのメモリが消費されま
す。大きな行列の場合は、一般に消費されるメモリは行列の記憶に必要な量の1.5倍以下です。

参考文献

R. F. Harrington, Field Computation by Moment Methods .Maxillan, New York (1968)1.

ビアによる有限厚さのモデリング
以下の方法で、ビアを使って有限厚さの金属ストラクチャをモデリングできます。

ストラクチャの上表面をドローイングします。
形状を他のレイアウト・レイヤにコピーし、最初の形状と正確に同じ場所に重ねて配置します。形状は完全に一致する必要があります。
一方の形状の周囲にシート・ビアをドローイングします。ビアは3番目のレイアウト・レイヤに配置します。
サブストレート定義の一部として、1つのレイヤをインタフェース・レイヤとし、有限の厚さとモデリングする金属の特性を指定します。
このレイアウトをサブストレート定義に適用する際に、上記のインタフェース・レイヤにビアをマッピングし、このサブストレート・レイヤの上下にあるメタライゼ
ーション・レイヤに形状をマッピングします。メタライゼーション・レイヤは必ず2つのサブストレート・レイヤの間にあるので、インタフェース・レイヤの上下に他
のレイヤ(空気など)を追加しなければならない場合があります。次の図は、金属ストラクチャのドローイング方法を示します。

注記
この方法は有限厚さのモデリングには推奨しません。有限厚さの自動モデリングについては、厚みのある導体の自
動3次元展開を参照してください。

Momentumのコマンド・リファレンス

Momentumメニュー

Layoutウィンドウ
_____________________________________________________________________________

Simulation Mode

Enable RF Mode / Disable RF Mode

Momentumのシミュレーション・モード設定を、RFモードとマイクロ波モードで切り替えます。どちらの場合も、LayoutウィンドウのMomentumメニュー・
ラベルに現在のモードが示されます。

Substrateメニュー

Open...

定義済みで提供されているサブストレート(YES)またはプロジェクト固有のユーザ定義サブストレート(No)のどちらをオープンするか選択します。

Save

オープンしているデザインのサブストレートと定義されたメタライゼーションを保存します。

Save As...



Advanced Design Systemドキュメント

197

名前を変えて、オープンしているデザインのサブストレートと定義されたメタライゼーションを保存します。

Delete...

選択したサブストレートを削除します。

Create/Modify...

サブストレート／メタライゼーションの定義を作成したり、既存の定義を修正します。

Update From Schematic

Momentumレイアウトで使用されるサブストレートがスケマティック(例えば、MSUBコンポーネントで定義)で定義されていて、サブストレートが変更さ
れる場合は、Momentum > Substrate > Update From Schematicを選択し、レイアウトのサブストレートの情報を更新する必要があります。

Precompute...

Substrate > Precompute - 指定された範囲全体でサブストレート関数を計算します。
Mesh > Precompute - メッシュの事前計算に使用する周波数を指定します。ここで値が定義されていなければ、Global Mesh Setup Panelダイアログ・ボックス
またはPrecompute Substrateダイアログ・ボックスのデフォルト値が使用されます。この周波数はサブストレート定義の範囲内のいかなる値にも設定できま
す。

Summary...

Momentumプロセスのサマリを表示します。

Substrate > Summary - サブストレート・プロセスのサマリを表示します。
Mesh > Summary - 各セル・タイプの数を表示します。メッシュの計算に使用されるリソースの数も表示されます。完了したすべてのメッシュ計算がレポートさ
れます。
Simulation > Summary - シミュレーション・データのサマリを表示します。RFモードを使用するときには、メッシュ低減計算と準静的計算に関する詳細も含まれ
ます。
Optimization > Summary - Optimizationウィンドウのデータのコピーを表示します。

Port Editor...

レイアウト内のポートのMomentum固有の属性を定義します。サブストレートの誘電体レイヤとスケマティックのメタライゼーションを定義してからでな
いと、ポート・エディタはアクティブにできません。

Box-Waveguideメニュー

Add Box...

上側と下側のグランド・プレーンの間にあるサブストレート上にボックスを追加できます。

Delete Box

クリックすると前に定義したボックスが削除されます。

Add Waveguide...

上側部と下側のグランド・プレーンの間にあるサブストレート上に導波管を追加できます。導波管は、X軸またはY軸に平行に定義できます。

Delete Waveguide

クリックすると前に定義した導波管が削除されます。

Component

Parameters...

レイアウト・パラメータを変更して、そのパラメータ値の一定のステップ変化が元のレイアウトにどのような影響を与えるかを確認できます。
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Create/Modify...

レイアウト・コンポーネントを作成または更新するために設定を指定します。

Model Database...

コンポーネントにすでに利用可能なモデルを表示します。すべての利用可能なモデルのパラメータ設定を表示でき、モデルを削除することができま
す。

Meshメニュー

Setup...

メッシュの計算に使用されるパラメータを定義します。

Precompute...

メッシュの事前計算に使用する周波数を指定します。ここで値が定義されていなければ、Global Mesh Setup Panelダイアログ・ボックスまたは
Precompute Substrateダイアログ・ボックスのデフォルト値が使用されます。この周波数はサブストレート定義の範囲内の任意の値にも設定できま
す。

Summary...

各セル・タイプの数を表示します。メッシュの計算に使用されるリソースの数も表示されます。完了したすべてのメッシュ計算がレポートされます。

Clear

メッシュ計算後、ストラクチャ上に表示されるメッシュを消去します。

Simulationメニュー

S-parameters...

パラメータを定義し、シミュレーションを実行します。

Summary...

シミュレーション・データのサマリを表示します。RFモードを使用するときには、メッシュ還元計算と準静的計算に関する詳細も含まれます。

Optimizationメニュー

Parameters...

最適化するレイアウト・パラメータを指定します。最適化に関連するデザインをオープンします。指定したパラメータの最適値を表示します。

Goals...

最適化のゴールを指定します。

Run...

最適化を実行します。使用する最適化の方法のタイプを指定します。

Summary...

Optimizationウィンドウのデータのコピーを表示します。

Post-Processingメニュー
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Radiation Pattern...

放射パターンを計算するための属性を定義し、計算を実行します。

Visualization...

Momentum Visualizationツールをオープンし、シミュレーション結果を3次元で表示します。

3D EMメニュー

Save Files for 3D EM

3次元電磁モデリング・ツールへのインポート用に、3次元電磁プロジェクト・ファイルにMomentumデータを書き込みます。
ファイルは、現在のプロジェクトの<project_name>/ mom_dsn /<design_name>/ 3DEMに保存され、デザインの形状とMomentumの設定も格納されま
す。

Momentumの導体損失モデル
 

表面インピーダンス・モデル

シート導体

momentum.cfgファイルで:

MOM3D_USE_SHEETLOSSMODEL=0,1,2

モデル0: DC抵抗       

モデル1: 片面表皮効果              注記:これはADSのデフォルトです。

モデル2: 両面表皮効果       
 

      

厚みのある導体

momentum.cfgファイルで:

MOM3D_USE_THICKLOSSMODEL=0,1,2

モデル0: 2レイヤ・シート導体
 

各レイヤの厚さは導体の厚さの半分です。
各レイヤはDC抵抗でモデリングされます。
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モデル1:2レイヤ・シート導体       注記:これはADS 2003Cのデフォルトです。
各レイヤの厚さは導体の厚さの半分です。
各レイヤは、片面表皮効果でモデリングされます。
 
モデル2:2レイヤ・シート導体       注記:これはADS 2004Aのデフォルトです。
上部と下部に2つの表面電流レイヤ
両方とも結合した表皮効果でモデリング

       

媒体1 = バックグランド・レイヤ、媒体2 = 導体
 
 

例:自由空間のシングル・トレース

 

Nレイヤ・シート導体モデルを使用した収束
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シート導体モデルを使用した結果

厚みのある導体モデルを使用した結果
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例:自由空間の折り畳みトレース

厚みのある導体モデルを使用した結果
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