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agreement and written consent from Agilent Technologies, Inc. as governed by United
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SuperLU Copyright:
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AMD Version 2.2

AMD Notice:
The AMD code was modified. Used by permission.
AMD copyright:
AMD Version 2.2, Copyright (c) 2007 by Timothy A. Davis, Patrick R. Amestoy,
and Iain S. Duff. All Rights Reserved.
AMD License:
Your use or distribution of AMD or any modified version of AMD implies that
you agree to this License.
This library is free software; you can redistribute it and/or modify it under the
terms of the GNU Lesser General Public License as published by the
Free Software Foundation; either version 2.1 of the License, or (at your
option) any later version.
This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
General Public License for more details.
You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc.,
51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
Permission is hereby granted to use or copy this program under the terms of
the GNU LGPL, provided that the Copyright, this License, and the
Availability of the original version is retained on all copies.User
documentation of any code that uses this code or any modified version of
this code must cite the Copyright, this License, the Availability note,
and "Used by permission." Permission to modify the code and to distribute
modified code is granted, provided the Copyright, this License, and the
Availability note are retained, and a notice that the code was modified is included.
AMD Availability: http://www.cise.ufl.edu/research/sparse/amd

UMFPACK 5.0.2

UMFPACK Notice:
The UMFPACK code was modified. Used by permission.
UMFPACK Copyright:
UMFPACK Copyright (c) 1995-2006 by Timothy A. Davis. All Rights Reserved.
UMFPACK License:
Your use or distribution of UMFPACK or any modified version of UMFPACK
implies that you agree to this License.
This library is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License as published by the
Free Software Foundation; either version 2.1 of the License, or (at your
option) any later version.
This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public
License for more details.
You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc.,
51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
Permission is hereby granted to use or copy this program under the terms of

http://www.cise.ufl.edu/research/sparse/amd
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the GNU LGPL, provided that the Copyright, this License, and the
Availability of the original version is retained on all copies. User
documentation of any code that uses this code or any modified version of
this code must cite the Copyright, this License, the Availability note,
and "Used by permission." Permission to modify the code and to distribute
modified code is granted, provided the Copyright, this License, and the
Availability note are retained, and a notice that the code was modified is included.
UMFPACK Availability:
http://www.cise.ufl.edu/research/sparse/umfpack
UMFPACK (including versions 2.2.1 and earlier, in FORTRAN) is available at
http://www.cise.ufl.edu/research/sparse. MA38 is available in the
Harwell Subroutine Library. This version of UMFPACK includes a modified
form of COLAMD Version 2.0, originally released on Jan. 31, 2000, also
available at http://www.cise.ufl.edu/research/sparse . COLAMD V2.0 is also
incorporated as a built-in function in MATLAB version 6.1, by
The MathWorks, Inc. (http://www.mathworks.com ). COLAMD V1.0 appears as
a column-preordering in SuperLU (SuperLU is available at
http://www.netlib.org). UMFPACK v4.0 is a built-in routine in MATLAB 6.5.
UMFPACK v4.3 is a built-in routine in MATLAB 7.1.

Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file
names and directory names. The business entity formerly known as "HP EEsof" is now part
of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and
to maintain backward compatibility for our customers, we did not change all the names
and labels that contain "HP" or "HPEESOF" references.

Warranty The material contained in this document is provided "as is", and is subject to
being changed, without notice, in future editions. Further, to the maximum extent
permitted by applicable law, Agilent disclaims all warranties, either express or implied,
with regard to this manual and any information contained herein, including but not limited
to the implied warranties of merchantability and fitness for a particular purpose. Agilent
shall not be liable for errors or for incidental or consequential damages in connection with
the furnishing, use, or performance of this document or of any information contained
herein. Should Agilent and the user have a separate written agreement with warranty
terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.
Technology Licenses The hardware and/or software described in this document are
furnished under a license and may be used or copied only in accordance with the terms of
such license. Portions of this product include the SystemC software licensed under Open
Source terms, which are available for download at <a href-"http://systemc.org/">http://systemc.org/. This software is
redistributed by Agilent. The Contributors of the SystemC software provide this software
"as is" and offer no warranty of any kind, express or implied, including without limitation
warranties or conditions or title and non-infringement, and implied warranties or
conditions merchantability and fitness for a particular purpose. Contributors shall not be
liable for any damages of any kind including without limitation direct, indirect, special,
incidental and consequential damages, such as lost profits. Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily

http://www.cise.ufl.edu/research/sparse/umfpack
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.mathworks.com
http://www.netlib.org
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provided to end user customers. Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212
(Computer Software) and, for the Department of Defense, DFARS 252.227-7015
(Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial
Computer Software or Computer Software Documentation).
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レイアウトの作成
レイアウトをレイアウトとして直接作成するか、既存のスケマティックから生成するか、スケマティックを作成するときに同時に作成するかに関係なく、
プロセスの基本ステップは、以下の3つだけです。

レイアウト環境を設定します。レイヤの定義の説明に従って、作成したいデザインの環境をカスタマイズします。
レイアウトの作成の説明に従って、レイアウトを作成します。
プログラムの基本のレイアウトの基本の説明に従って、レイアウトを編集し、完成させます。

デザインを作成する際、またはデザインが完成したら、デザインに対してさまざまな編集操作を実行できますが、デザイン作業の開始前に多数のオ
プションを設定することで、編集の必要性 を低減できます。これらのオプションは、デザイン・ウィンドウのPreferencesダイアログ・ボックス（Options >
Preferences）で設定できます。詳細については、『Customization and Configuration』マニュアルのSetting Design Environment Preferencesを参照し
てください。

レイアウト環境

以下の設定は、特にLayoutウィンドウで形状をドローイングするときに重要となりますが、レイアウトをスケマティックから生成する場合にも、これらの
設定機能を理解しておく必要があります。

スナップとグリッド間隔を設定します（『Customization and Configuration』マニュアルを参照）。グリッドを表示した後、スナップ・モードでドローイングすると、形
状を正確なサイズと間隔でドローイングできます。性能問題が常に発生するわけではありませんが、交点スナップ・モードはスナップ・モードの中で一番低速
なので、必要な場合にのみ使用するようにしてください。
レイヤ定義を設定します（『Customization and Configuration』マニュアルを参照）。
ドローイング・レイヤを指定します（『Customization and Configuration』マニュアルを参照）。レイヤ上ですべての形状が入力されます。形状のカラーとヴィジビ
リティ（表示/非表示）は、形状をドローイングしたレイヤによって制御されます。ドローイングを開始する前に、使用目的に従って現在のエントリ・レイヤを指定
します。

レイアウト・ルーラの使用

レイアウトにルーラを配置し、ルーラを使用してドローイングするオブジェクトのサイズを指定できます。以下の手順を使用して、ルーラをレイアウトに
配置し、設定します。

LayoutウィンドウでInsert > Rulerを選択します。1.
レイアウト内をクリックして、ルーラを配置するための開始点と終了点をマークします。Escを押して、ルーラ配置モードを終了します。2.
配置したルーラをダブルクリックするか、Edit > Component > Edit Component Parametersを選択して、Rulerダイアログ・ボックスを表示します。ここで、配置し3.
たルーラをカスタマイズするためパラメータを編集できます。
パラメータ設定を編集します。4.
Select Parameterリストから、変更したいパラメータを選択します。パラメータの値を直接入力するか、Equation EditorボタンをクリックしてEquation Editorダイ
アログ・ボックスを表示し、変数のリストから選択することで、値を計算するための式を定義できます。以下のパラメータがあります。
LineLength - ルーラの長さ
MajorTick - ルーラ上の大目盛りの長さ
MinorTick - ルーラ上の小目盛りの長さ
MajorUnits - ルーラ上の大目盛りの単位
MinorUnits - ルーラ上の小目盛りの単位
Layer - ルーラが配置されたレイヤ
TextHeight - ルーラ上に単位を表示する際のテキストの高さ
Units - ルーラが使用する指標のデフォルト単位。個々のパラメータに異なる単位を指定することで、このデフォルトを無効にすることができます。
TextPrecision - ルーラ上に長さテキストを表示する際の精度
TextPOrientation - 長さテキストを表示する際の方向。選択肢は、horizontal、vertical-left、vertical-rightです。
TextOrder - 長さテキストを表示する際の順番（昇順または降順）
OKをクリックして変更を保存し、ダイアログ・ボックスをクローズします。5.

レイアウトの手動作成

レイアウトを直接作成する場合は、Layoutウィンドウにコンポーネントまたは形状を配置します。パレットまたはライブラリ・リストからコンポーネントを
選択できます。形状をドローイングするには、カーソルを使用するか、座標を指定します。

形状またはポリラインを挿入する手順：

アイコン（またはInsertコマンド）を選択します。1.
ウィンドウの左下コーナの手順に従います。2.

パレットまたはライブラリ・リストからコンポーネントを挿入する手順：

目的のコンポーネントを選択します。1.
Layoutウィンドウで目的の位置までドラッグします。2.
クリックして目的の位置にコンポーネントを配置します。3.

コンポーネントの挿入

コンポーネントの挿入には、以下の方法が使用できます。
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コンポーネント・パレット
コンポーネント・ライブラリ
Component Historyフィールドにコンポーネント名を入力する（次にEnterを押す）
ホット・キーを作成する

作図ラインの使用

作図ラインは、パーツ、形状、テキストの整列に有効です。ラインの長さは無限であるため、コンポーネントをある領域に配置したら、ウィンドウのビュ
ーをスクロールして、オブジェクトが正しく整列していることを確認できます。

作図ラインを追加する手順：

Insert > Construction Lineを選択します。1.
ドローイングしたいラインに沿って2個のポイントをクリックします。2.

コンポーネントの特定の座標への配置

以下の手順を使用して、特定の座標にコンポーネントを配置します。

コンポーネントを選択します。1.
メニュー・コマンドInsert > Coordinate Entryを選択します。2.

Coordinate Entryダイアログ・ボックスで、Xの値とYの値を入力します。3.
Use Snappingチェック・ボックスをアクティブにしている場合は、座標エントリで、入力した座標が現在のスナッピング規則に従って変化します。
Applyをクリックします。指定した座標にピン1が来た状態で、コンポーネントがLayoutウィンドウに配置されます。4.

未接続ピンと接続ピンの特定

Layoutウィンドウにコンポーネントを配置すると、各ピンがアウトライン表示され、2本のピンを接続すると、アウトラインが消えます。『Customization
and Configuration』マニュアルで説明するように、ピンの強調表示カラー、および接続のカラーを変更できます。

形状のドローイング

Layoutウィンドウでレイアウト形状を作成するときには、以下の形状フォームを使用できます。

多角形
ポリライン
長方形
円
テキスト
パス
寸法ライン
円弧

形状は伸縮とマージが可能で、形状の頂点を移動または削除できます。Insertメニューには、さまざまな形状とラインをドローイングするためのコマン
ドがあります。Insertメニュー・コマンドの多くは、ツールバー上にもアイコンとして表示されています。

注記
Insertコマンドの実行中にツールバー上のカーソルを選択すると、コマンドが終了し、未完成の形状が削除されま
す。

形状をドローイングする手順：
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ツールバーの形状アイコンをクリックするか、Insert > <desired_shape>を選択します。1.
ステータス・パネルに表示されたヒントに従います。2.
クリックして形状を配置します。3.

多角形をドローイングする：ライン・セグメントを入力し、ダブルクリックしてクロージング・セグメントを自動的に作成します。

多角形に円弧を含める - 多角形の作成中に、Insert > Arc (<desired direction>)を選択します。
新しくドローイングしたセグメントまたは円弧を削除する - 前のポイントまで引き返すには、Insert > Undo Vertexを選択します。

ポリラインをドローイングする：ライン・セグメントを入力し、ダブルクリックして最終セグメントを終了します。

ポリラインに円弧を含める - ポリラインの作成中に、Insert > Arc (<desired direction>)を選択します。
新しくドローイングしたセグメントまたは円弧を削除する - 前のポイントまで引き返すには、Insert > Undo Vertexを選択します。

長方形をドローイングする：2個のコーナを入力します。

円をドローイングする：中心点を入力してから、円周上のポイントを入力します。

寸法ラインをドローイングする：終端点を入力します。

円弧をドローイングする：円弧の開始点、円弧の中心、円弧の終了点を入力します。円弧を時計回りまたは反時計回りにドローイングできます。

注記
中塗りで表示できるのは、閉じた形状（多角形、円、長方形）だけです。ポリラインで作成された形状（円弧など）は
中塗りで表示できません。

頂点を元に戻す

多角形、ポリライン、ワイヤ、トレース、パスの作成中に最後に入力した円弧または頂点を削除するには、メニュー・コマンドInsert > Undo Vertexを選
択します。

座標の入力による形状のドローイング

座標の指定によるコンポーネントの配置（コンポーネントの特定の座標への配置を参照）と同様に、形状に必要な座標の指定により、形状をドローイ
ングできます。

目的のドローイング・コマンドを選択します。1.
メニュー・コマンドInsert > Coordinate Entryを選択します。2.
Coordinate Entryダイアログ・ボックスで、アンカー・ポイントのX座標とY座標を指定し、Enterを押します（またはApplyをクリックします）。3.
選択した形状に必要な、すべてのポイントの指定を続けます。4.
デフォルトで、X IncrementフィールドとY Incrementフィールドは現在のスナップ間隔に設定されますが、デザインのニーズに適合する任意のインクリメントを
使用できます。

ポートとグランドの追加

以下の手順を使用して、ポートまたはグランドをレイアウトに追加します。

ツールバーのポートまたはグランド・シンボルをクリックします（またはInsert > PortまたはInsert > Groundを選択します）。1.
必要に応じてツールバーのボタン（Rotate By -90）をクリックして、適切な回転を選択します。2.
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ポインタをドローイング領域に移動し、必要に応じてシンボルを置き、クリックしてそこに配置します。3.

以下のいずれかの方法で、レイアウト内のポートとグランドのサイズを編集します。

Preferencesダイアログ・ボックスのPlacementタブのデフォルト・サイズ（Options > Preferences）。予め決められた規格がある場合は、この方法を使用してサ
イズを設定します。
Port/Ground Sizeダイアログ・ボックスを使用する、すべての配置されたアイテムのサイズ（Edit > Components Port/Ground Size）。ここで行ったサイズ変更
は、すべてのポートとグランドに適用されます。この方法でサイズを変更すると、Preferenceダイアログ・ボックスのプリファレンスも更新されます。この方法を
使用して、レイアウト内のアイテムに対してさまざまなサイズを試し、最適なサイズを見つけます。

指定するアイテムのサイズは、以下の単位のいずかに基づいています。

Layoutウィンドウ用に指定されたレイアウト単位。プリファレンスが、ウィンドウの右下コーナに表示されます。これは、矛盾のないサイズを実現するより簡単
な方法です。
アイテムが配置された瞬間の画面ピクセル。この方法で一様なアイテム・サイズを実現するには、アイテムを配置するときに毎回同じズーム・ファクタを使用
する必要があることに注意してください。

エッジ・ポートとエリア・ポートの指定

エッジ・ポートを作成するには、ポリラインまたは円弧をレイアウトに配置し、指定によってこの形状を特定のポイント・ポートと関連付けます。エリア・
ポートを作成するには、多角形、円、長方形、またはパスをレイアウトに配置し、指定によってこの形状を特定のポイント・ポートと関連付けます。1つ
のポートに複数のエッジ・ポートとエリア・ポートを関連付けることができ、これらのポートを複数のレイヤに配置できます（アートワークのセクションの
エッジ・ポートとエリア・ポートの使用を参照）。

トレースの処理

トレースは、幅とベンド・タイプを持つワイヤで、物理的な伝送ラインを表わすために使用されます。ワイヤと同様、コンポーネントの接続に使用でき
ます。シミュレーション目的の場合は、トレース接続とワイヤ接続に違いはありません。トレースは通常、単純な接続（ショート）としてシミュレートされ
ます。ただし、トレースを伝送ラインに変換するか、伝送ラインとしてシミュレートすると、シミュレーションの確度が向上します。以下が可能です。

明示的に伝送ラインに変換する（Edit > Path/Trace/Wire > Convert Traces）。この場合は、レイアウトで、選択したトレースが実際に削除され、等価の伝送ラ
イン・コンポーネントに置換されます。詳細については、トレースから伝送ラインへの明示的な変換を参照してください。
実際に変換しないで伝送ラインとしてシミュレートする。この場合は、トレースは置換されませんが、各トレースに対して基礎となるサブ回路が作成され、その
サブ回路に等価の伝送ラインが含まれます。サブ回路の作成は、デザイン同期プロセス中に起こります（Generate/Update）。詳細については、トレースの伝
送ラインとしてのシミュレーションを参照してください。

トレース・ルーティング

コンポーネントを配置したら、それらを相互接続できます。パーツを接続するには、ピンを隣接させるか、ピン間にワイヤまたはトレースをドローイン
グします。ピンを隣接させた場合は、パーツを移動してもピンは切断されません。代わりに、ピン間にワイヤがドローイングされます。ワイヤとトレース
は、プログラムに同じ方法で保存されます。ワイヤは、幅ゼロのトレースです。したがって、幅を変更することで、ワイヤをトレースに変換し、再びワイ
ヤに戻すことができます（Edit > Properties）。

トレースは任意のレイヤに入力できますが、デフォルトで、シミュレートしたいトレースは、特定のレイヤに配置する必要があります。マイクロストリッ
プまたはストリップラインとしてシミュレートするトレースの場合は、トレースをレイヤ1（cond）に入力する必要があります。PCB伝送ライン・コンポーネ
ントとしてシミュレートするトレースの場合は、レイヤ16〜25（pcb1〜9）を使用する必要があります。トレースの挿入前に現在のエントリ・レイヤを変更
するには、Insert > Entry Layerを選択し、適切なレイヤを選択します。

個々のトレースは、1つのレイヤにしか存在できませんが、トレース挿入コマンドにより、トレースを接続するためのビアを持つさまざまなレイヤに複数
のトレースを挿入できます。詳細については、マルチレイヤ・トレース・ルーティングを参照してください。

パスを拡張するには、Edit > Vertex > Addをクリックするか、または既存のパスの端に正確に隣接する別のパスを作成し、Edit > Modify > Joinをクリ
ックして1本のパスを作成します。パスの両端が接続ピンに正確に隣接している場合は、パスをトレースに戻すことができます。Gridダイアログ・ボッ
クスのSnap to Pinモードを使用すると、終端点がピンと正確に一致していることを確認できます。

トレースと接続されたパーツを移動すると、トレースが再ルーティングされます。デフォルトで、レイアウトでは、トレースとワイヤが、接続を保持するた
め終端点から再ルーティングされます。Preferencesダイアログ・ボックスのEntry/EditタブのRe-route entire trace attached to moved componentプ
リファレンスを使用すると、接続全体を再ルーティングできます（Options > Preferences）。トレースとワイヤの再ルーティングでは、コーナの湾曲が少
ない、直交が保持されます。重なっているコンポーネントをチェックするには、Tools > Check Designの下でその名前によってオプションを使用しま
す。

トレースの挿入

スケマティックでは、トレースにはワイヤと同じく、ショートを形成（自分自身に再接続）できないという制限があります。また、各トレースは、一様の幅
とコーナ・タイプ（カーブ、マイタ、直角）を持ちます。ステップ、テーパー、ギャップを導入するには、ステップ、テーパー、ギャップ・コンポーネントを追
加し、トレースをそれに接続する必要があります。トレースを使用する際のいくつかの制限は、トレースをパスに変換することで解決できます。詳細に
ついては、パスの処理を参照してください。

注記
トレースにベンドが含まれている場合は、その頂点の一部である一番短いセグメントを3×w/4より短くすることはで
きません。ここで、wはトレースの幅です。
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トレースを挿入する手順：

Insert > Traceを選択します。1.
表示されたダイアログ・ボックスで、必要に応じてトレースの特性を設定します。2.

Corner Type - Mitered、Square、Curveから選択します

Width - トレースの目的の幅
Mitered Corner Cutoff Ratio (%) - コーナ・タイプMiteredの目的のカットオフ比
Curve Radius - コーナ・タイプCurveの目的のカーブ半径

Applyをクリックして、現在の設定を使用してトレースを挿入します。3.
ポインタをLayoutウィンドウに移動し、クリックしてトレースの最初の終端点を指定します。4.
ポインタを、このセグメントの目的の終端点（または頂点）に移動します。ポインタを移動するとTraceダイアログ・ボックスのLine Length領域が動的に更新さ5.
れるので、トレースを簡単に正確な目的の長さにすることができます。

クリックして、このセグメントの終端点（または頂点）を指定します。
任意のポイントにおける幅、コーナ・タイプ、レイヤ、マイタ幅、カーブの半径を含む、トレース設定を変更できます。変更は、配置した最後の頂点から適用さ6.
れます。トレース設定を変更すると、旧いトレース設定を持つトレースは最後の頂点までで終了し、新しいトレース設定を持つ新しいトレースが、最後の頂点
からスタートします。

ヒント
トレースのコーナが正しく形成されるよう、できるだけまっすぐなトレース・セグメントでトレース設定を変更します。

トレースが完成するまでこの方法で操作を続け、ダブルクリックするか、スペースバーを押して、最後の終端点を知らせます。7.

マルチレイヤ・トレース・ルーティング

他のコンポーネントを回避するため、または別のレイヤ上のインターコネクトに接続するため、場合によっては異なるレイヤに渡ってトレースをルーテ
ィングする必要があります。トレースの一部が別のレイヤに存在する場合のトレースのルーティングは、マルチレイヤ・トレース・ルーティングまたはト
レース・スティッチングと呼ばれます。マルチレイヤ・トレース・ルーティング中にトレース・レイヤをあるレイヤから別のレイヤに変更すると、ビア構成
ファイルが作成されている場合は、トレースの接続を保持するためビアが自動的に挿入される可能性があります。ビアの定義の詳細については、ト
レース・ルートのビア構成を参照してください。

マルチレイヤ・トレース・ルーティング中に現在のトレース・セグメントのドローイング・レイヤを変更する方法は、複数あります。以下のいずれかの位
置から新しいエントリ・レイヤを選択します。

ホットキー：
トレース挿入中にコンマ（","）キーを押すと、エントリ・レイヤが、ルーティング・レイヤ・スタック内の次に低いレイヤに変わります。
トレース挿入中にピリオド（"."）キーを押すと、エントリ・レイヤが、次に高いルーティング・レイヤに変わります。

コンテキスト・メニュー：
Layoutウィンドウで、トレース挿入がアクティブのあいだにLayoutウィンドウの内部をマウスで右クリックし、サブメニュー"Routing Layer >"からレイヤを選択します。
ルーティング・レイヤは、ビア接続が定義されているレイヤです。ビアが定義されていない場合は、"Routing Layer >"サブメニューが空白になります。
ビアの定義の詳細については、トレース・ルートのビア構成を参照してください。

プルダウン・メニュー：
ツールバーからEntry Layerプルダウン・メニューを使用します。
Trace Insertionダイアログ・ボックスのEntry Layerプルダウン・メニューを使用します。

Layersダイアログ：
Entry Layersダイアログを使用します。これは、Insert > Entry Layer...から起動できます。
Layer Editorダイアログを使用します。これは、Options > Layers...から起動できます。

トレース挿入中、上記のいずれかの位置からエントリ・レイヤを変更すると、以下が自動的に起こります。

前のエントリ・レイヤを使用したトレース・ルートが、入力された最後の頂点で終了します。
2つのレイヤを接続するためビア構成ファイルにビアが定義されているとすると、前のエントリ・レイヤと新しいエントリ・レイヤを接続するため、最後の頂点で
ビアが挿入されます。
新しいトレースが、新しいエントリ・レイヤ上の最後の頂点からスタートします。

前のトレース・エントリ・レイヤと現在のトレース・エントリ・レイヤを接続するため複数のビアが定義されている場合は、適切なビア（複数も可）を選択
できます。これを実行するには、"v"キーを押す（サイクルを反転するにはShift + "v"を使用）か、Layoutウィンドウでマウスを右クリックして"Change
Via >"サブメニューからビアまたはビアの組み合わせを選択します。ビアの定義の詳細については、トレース・ルートのビア構成を参照してください。

トレースは1つのレイヤにしか存在できないことに注意することが重要です。マルチレイヤ・トレース・ルーティングを使用するトレース・ルートには、連
続する1つのレイヤ上の各トレース・ルート・セクションに対するトレースが含まれます。このためマルチレイヤ・トレース・ルーティングでは、デザイン
に複数のトレースが挿入されます。トレースでの編集操作は、選択したトレースにのみ適用され、トレース・ルート全体には適用されません。

トレース・ルートのビア構成
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マルチレイヤ・トレース・ルーティング・プロセスを簡素化するには、さまざまなレイヤのトレース・インターコネクトを接続するためビアを定義できます。
Via Configurationダイアログにアクセスするには、Options > Via Configurationを選択します。

ビア定義には、ビア・コンポーネントの名前、ビアが積み重ね可能かどうかの指示、ビアが相互接続するレイヤ、自動ビア選択用の関連トレース幅な
どの情報が含まれます。ビア名は、固定アートワークを含むコンポーネントのADSコンポーネント名です。ビア・コンポーネントは、現在のプロジェクト
内のデザインか、またはデザイン・キット内のコンポーネントです。オフセット・ピンを持つマクロ・ベースのビアは、ADSの現在のリリースではサポート
されません。

ビアに対して定義されるレイヤは、ビアが接続されるメタライゼーション・レイヤです。通常、ビアにはメタル・レイヤのみが定義されます。ビア用に定
義されたレイヤは、定義によりルーティング・レイヤと呼ばれます。これにより、レイヤがトレース挿入中にホットキーから使用可能になります。ビア
は、2つ以上のレイヤを接続する必要があり、さらに多くを接続できます。

複数のレイヤに渡るためビアが必要な場合は、複数のビアを積み重ねることができます。積み重ねが可能なビアでは、2つのレイヤを接続するため
2個以上のビアを積み重ねることができます。2個のビアを積み重ねる場合は、それぞれに同じ接続レイヤが含まれている必要があります。接続レイ
ヤは、1つのビアでは最上位レイヤ、別のビアでは最下位レイヤとなります。接続レイヤがいずれかのビアの中間レイヤである場合は、ビアの積み
重ねはありません。

関連トレースの最大／最小幅が、同じレイヤの積み重ねに対して複数のビアが存在する場合の自動ビア選択用に指定できます。所定のトレース幅
を基にルーティング・レイヤを変更するときには、これにより、適切なデフォルト・ビア選択が可能です。

関連トレースの最大／最小幅が指定されていない場合は、Via Configurationダイアログのビアの順番によって、トレース・ルートを挿入するときにビ
アが表示される順番が決まります。リストでビアの順番を変更するには、ビアを選択し、ダイアログの左側の矢印ボタンを使用して、ビアをリストの上
または下方向に移動します。

設定を、後から使用するためビア構成ファイルに保存する必要があります。ビア設定を保存するには、Saveボタンをクリックし、ファイルを以下のい
ずれかのディレクトリに保存します。

プロジェクト・ディレクトリ
$HOME/hpeesof/de/defaults/
<Design Kit>/de/defaults/

ビア構成ファイルは別のディレクトリに保存して、そこからロードできますが、トレース挿入中に利用できるのは、リストに示したディレクトリ内のビア構
成ファイルだけです。

現在のビア設定を各プロジェクト用に保存し、トレース挿入中にTrace Insertionダイアログを使って設定できます。

トレースから伝送ラインへの明示的な変換

より正確なシミュレーション結果を得るため、トレースを伝送ラインに明示的に変換できます。

重要
トレースを伝送ラインに明示的に変換する場合は、変換は一方向で、伝送ラインをトレースに戻すことはできませ
ん。

トレースを伝送ラインに明示的に変換する手順：

変換したいトレースを選択します。1.

ヒント
与えられたレイヤ上のすべての伝送ラインを選択するには、そのレイヤを現在のエントリ・レイヤにして、Select >
Select All On Layerを選択します。

Edit > Path/Trace/Wire > Convert Tracesを選択します。2.
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Trace Controlダイアログ・ボックスで、以下のトレース変換タイプを選択します。3.
Transmission line elements
Single transmission line element - これを選択すると、エレメントの名前も指定する必要があります。デフォルトは、選択したElement Setに基づいて提供されます。
Nodal connection (short)

目的のElement Setを選択します。4.
適切なSubstrate Referenceを指定します。アスタリスク（*）は、デザインに配置されたこのタイプの最初のインスタンスの、デフォルトのインスタンス名を示し5.
ます。
OKをクリックします。6.

下図に、直角コーナを持つマイクロストリップに変換されたトレースを示します。各エレメントのパラメータは、トレース・セグメントの寸法から導出され
ています。

トレースの伝送ラインとしてのシミュレーション

この方法を使用すると、シミュレーションに伝送ラインの影響を含める際、スケマティックやレイアウトが多数の伝送ライン・コンポーネントで混雑する
ことがありません。

デザイン同期プロセス中、各トレースに対してサブ回路が作成されます。このサブ回路は、Trace Controlダイアログ・ボックスで選択したElement Setに
基づいた、伝送ラインの等価エレメントです（Trace Controlダイアログ・ボックスには、SchematicメニューとLayoutメニューから使用可能な
Generate/Updateダイアログ・ボックスからアクセスします）。シミュレート時、伝送ラインのサブ回路が解析のためシミュレータに渡されます。

デザイン同期プロセスを実行すると、View > Push Into Hierarchyコマンドを使用して、デザイン同期プロセスによって生成された実際の伝送ラインの
等価エレメントを（SchematicウィンドウまたはLayoutウィンドウに）表示できることがわかります。レイアウトからの作業中にトレースを変更する場合
は、デザイン同期プロセスを再度実行してサブ回路を更新する必要があります。ティー・コンポーネントが自動的に作成され、考慮されます。

下図に、デザイン同期プロセス中に1本のトレースと2個のポート（ポートは必須です）から作成されるMLIN回路を示します。
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デザイン同期プロセスの詳細については、デザイン同期を参照してください。

ミアンダ・トレースの挿入

ミアンダ・トレースを使用すると、長さ、間隔、方向を含む特定の特性を持つトレースをすばやく挿入できます。

Corner Type - Mitered、Square、Curveから選択します（コーナ・タイプの図については、トレースの処理を参照してください）。
Starting Direction - 開始リードに接続されている最初の2個のセグメントをドローイングする方向（時計回りまたは反時計回り）
Ending Direction - 終了リードに接続されている最後の2個のセグメントをドローイングする方向（時計回りまたは反時計回り）

Width - トレースの目的の幅
Minimum Spacing - 平行なトレース・セグメント間の最小間隔
Line Length - リード長セグメントを含むトレースの全長
Mitered Corner Cutoff Ratio (%) - コーナ・タイプMiteredの目的のカットオフ比
Curve Radius - コーナ・タイプCurveの目的のカーブ半径
Lead Length - 開始セグメントと終了セグメントの長さ
Meander Line Orientation - 指定された開始リードと終了リード間でトレースを垂直に蛇行させたい場合は、Verticalを選択します。指定された開始リードと終
了リード間でトレースを水平に蛇行させたい場合は、Horizontalを選択します。

ミアンダ・トレースを挿入する手順：

Insert > Meander Traceを選択します。表示されたダイアログ・ボックスで、必要に応じてオプションを設定し、Applyをクリックします。1.
ポインタをドローイング領域に移動し、クリックして開始リードの終端点を指定します。2.
ミアンダ・トレースのゴースト・イメージが表示されるまで、必要に応じてポインタをX方向とY方向に移動します。3.
必要に応じて調整し、クリックして終了リードの終端点を指定します。4.

パスの処理

パスは、幅を持つポリラインです。パスには関連付けられた接続情報はありませんが、任意のポイントで開始／終了でき、トレースに変換できます。
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注記
トレースまたはパスにベンドが含まれている場合は、その頂点の一部である一番短いセグメントを3×w/4より短くす
ることはできません。ここで、wはトレースの幅です。

2個のポイント間にパスをドローイングする手順：

Insert > Pathを選択します。Pathダイアログ・ボックスが現れます。1.
コーナ・タイプと幅を指定します。2.

Corner Typeに、使用可能なコーナ・タイプのオプションが示されます。
Widthで、現在のデザイン単位を基準に、パスの幅を設定します。

パス属性を設定し、Applyをクリックします。3.
開始点にポインタを合わせてクリックします。4.
終了点にポインタを合わせてクリックします。指定したポイント間にパスがドローイングされます。5.

カーブ・パスのコーナが目的の場所にあることを確認するには、以下のいずれかの方法を試します。

直角パスをドローイングし、コマンドEdit > Propertiesを使用してそれをカーブ・パスに変更します。
ステータス・パネルに座標表示値を保持する頂点を指定し、直角パスのドローイングと同様にドローイングします。

パスとトレースの違い

パスとトレースは、作成方法と編集方法が非常に類似しています。どちらもレイアウトでは幅のあるラインとして表わされ、面取りコーナまたはカーブ
・コーナを含めることができます。パスもトレースも、レイアウト・デザインで接続を行えますが、使用法にわずかな違いがあります。

トレース パス

ピンでのみ接続できます（ポイント・ピンがトレースの中心に配置されている場合は、他のアイテ
ムからのポイント・ピンも、トレースの中心線に沿ってトレースに接続できます）

接続は、パスに沿った任意の場所で行えます

デザイン同期を使用して、スケマティック内でワイヤ（ショート）または伝送ライン・コンポーネントと
して同期できます

デザイン同期を使用して、スケマティック内でワ
イヤ（ショート）として同期できます

2本のトレースを終端点で接合すると、トレースが1つのトレースにマージされます Edit > Merge > Intersectionを使用して接合でき
ます

トレース挿入コマンドにより、マルチレイヤ・トレース・ルーティングが可能になり、ビアをVia
Configurationで定義したとおりに自動的に挿入します

さまざまなレイヤ上のパスとビアを別々に挿入で
きます

注記
トレースをパスに変換するには、Edit > Path/Trace/Wire > Convert Trace to Pathを選択します。パスをトレースに
変換するには、Edit > Path/Trace/Wire > Convert Path to Traceを選択します。

形状とのインターコネクトの作成
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ADS 2004Aから、接続は、多角形、円、円弧、長方形、パス間の接触によって作成できます。正しく計算するには、レイヤ接続は、Layer Bindingダイ
アログで正確に指定する必要があります。異なるレイヤ間の接触の詳細については、『Customization and Configuration』マニュアルのSetting
Layout Optionsに関するセクションのDefining Port Connections (Layer Binding)を参照してください。

多角形のポートへの関連付けについては、アートワークに関するセクションのピン／ポートのアートワークへの追加を参照してください。

注記
ポリラインは接続を作成しません。

ワイヤの処理

一時的なワイヤを使用してレイアウト・コンポーネント間に電気的な接続を作成できます。ワイヤにより、レイアウト内でコンポーネントを、接続を切断
せずに簡単に移動できます。ワイヤを使用すると、実際に用いるラインを挿入する前に回路の性能を簡単にシミュレートすることもできます。シミュレ
ータは、（接続されたコンポーネントが物理的に接触しているかのように、）ワイヤをショート回路として処理します。後からコンポーネントを直接接続
できます。または、ワイヤをトレースと置換し、シミュレーションを繰り返して回路性能を確認することができます。

時々、レイアウトに意図しないギャップが生成される場合があります。これが発生すると、隣接していないエレメント間の電気的な接続を示すため、ワ
イヤが現れます。アートワークを移動すると新しいワイヤ（未接続のコンポーネント）が導入される可能性があることに注意してください。レイアウトの
パラメータの調整によってギャップをクローズできる場合がよくあります。または、手動でオブジェクトを移動せずに、新しいエレメントを導入します。

ワイヤの挿入

ワイヤをドローイングするときは、ピンまたは別のワイヤで開始／終了する必要があります。

Insert > Wireを選択します。1.
ピン（またはワイヤ）を一端でクリックします。2.
ピン（またはワイヤ）をもう一端でクリックします。指定したポイント間にワイヤがドローイングされます。3.

テキストの挿入

InsertメニューのTextコマンドまたはツールバーのTextアイコンを使用して、デザインにテキストを追加できます。

Insert > Textを選択します。ステータス・パネルのプロンプトに以下のメッセージが表示されます。New Text:Enter location for new text1.
目的の位置でポインタをクリックして、入力を開始します。2.
変更には、矢印キー、バックスペース、削除キーを使用できます。マウスのドラッグでテキストを強調表示し、入力し直すか、削除することもできます。
テキストを次の行に続けるには、Enterを押し、入力を続けます。
このテキストの入力作業を終了するには、ポインタをテキストから離れた場所に移動して、クリックします。3.
別の位置にテキストを入力するには、その位置をクリックして入力を開始します。
テキストの追加が終了したときには、Insert > End Commandを選択するか、ツールバーのカーソルをクリックします。4.

注記
新しいテキストのデフォルト属性を設定するには、Options > Preferences > Textを選択します。既存のテキストと
テキスト属性を編集するには、Edit > Propertiesを選択します。

レイアウトのブロック・テキスト・フォント

生産プロセスへの出力用に物理的なデザインを作成している場合は、生産されたパーツで表示するテキストを提供できます。これは通常、テキスト
が、単純なストローク・フォントではなく、太さを持つプリミティブ形状から構成されていなければならないことを示します。
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Advanced Design Systemには、このニーズに対応するため、ブロック・テキスト・フォントと呼ばれる多角形ベースのテキスト・フォントのパレットがあり
ます。

プログラムでは、全部で14のフォントをサポートします。最初の8つは、Microwave Development System（MDS）で供給されたフォントと同じです。

以下のフォントがサポートされます。
din17 - 業界標準フォント。
iso3098 - もう1つの業界標準フォント。
roman - Times Romanフォントと類似のフォント。
smooth - より丸みを帯びた滑らかな活字のフォント。
italic - イタリック・フォント。
standard - MDSで供給されるオリジナル・フォント。
gothic - 実用よりもおもしろさを重視したフォント。
math - 特殊な数学記号のフォント。.
sans - 基本のサンセリフ体フォント。
sansbold - 太字のサンセリフ体。
filled - 活字に穴のないフォント。
filledbold - 太字のfilled。
straight - 曲線のないフォント。
straightfilled - 中塗り（穴なし）のstraight。

これらは、変換プロセスを通過した単純なストローク・フォントではなく、フォントの各文字に対して実際に多角形定義として実現されています。フォン
トは（Graphical Cell Compilerを使用して作成された）コンポーネントとして実現されるため、コンポーネント編集ダイアログで使用可能なさまざまな属
性を備えています。

以下の属性があります。
Text String - 表示される実際のテキスト文字列。テキスト文字列はクォーテーション（"）で囲みませんが、配置されたコンポーネント内で表示するク
ォーテーションが含まれる場合があります。テキストには、改行を表わす文字\n（バックスラッシュ＋n）を持つ複数の行を含めることができます。パラ
メータとして"@"プレフィックスを使用した参照が可能であるため、変数名を指定できます。変数の内容は、表示されるテキスト文字列です（例を参
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照）。
Character Height - 文字の高さ。これは、実際には指定フォントの標準文字サイズの高さです。小文字はこれより小さく、ディセンダを持つ文字
（例：g、j、p、q、y）は、標準サイズの下に伸びます。
Character Spacing - 標準文字サイズに使用する水平スペースの倍率です。1.0に設定すると、W、Mなどの大きな文字が接触する可能性がありま
す。1.0未満の値に設定すると、文字が重なる可能性があります。
Line Spacing - 標準文字サイズに使用する垂直スペースの倍率です。デフォルト値1.2によって十分な行間スペースが得られるので、ディセンダを持
つ文字が次の行の文字と重なりません。
Insertion Layer - テキスト文字列用の多角形が配置されるレイヤの数値IDです。

各フォントの多角形定義は、フォント・コンポーネントが挿入中または編集中でないとロードされないため、起動速度やメモリ使用量には影響しませ
ん。フォントをセッションで初めて使用するときには、フォントをロード中であることを知らせる小さいダイアログが表示されます。ローディングが完了す
ると、ダイアログがクローズします。

フォントがロードされたら、ADSの現在のセッション中に再度ロードする必要はありません。また、テキスト・コンポーネントは単なる多角形のセットで
あるため、前に挿入されたテキスト・コンポーネントを表示するためにフォントをロードする必要はありません。フォントをロードする必要があるのは、
コンポーネントを編集する（再作成が発生する）場合、またはそのフォントで新しいテキスト・コンポーネントを挿入する場合だけです。

テキスト・コンポーネントを挿入後、Edit/Component/Edit Component Parametersを使用してすべてのコンポーネント属性を変更できます。テキスト
文字列の編集、物理的なサイズ属性の変更、コンポーネントを挿入するレイヤの変更が可能です。テキストは簡単に調整できるので、デザイン内の
任意の物理的な拘束条件に適合できます。

テキスト・コンポーネントのフォントを変更する必要がある場合は、Edit/Component/Swap Componentsを使用できます。コンポーネント名はフォント
名であるため、コンポーネント名を別のフォントに変更すると、新しいフォントでコンポーネントが再作成されます。

例

この例では、ブロック・フォント・テキスト・コンポーネントがいかにスケマティック変数を参照し、その内容を表示できるかを示します。

最初に、Schematicウィンドウをオープンし、Varコンポーネントを配置します。次にコンポーネントを編集し、使用する名前/値ペアをレイアウトに追加
します。

次に、Layoutウィンドウをオープンします。Layoutウィンドウが、Schematicウィンドウと同じデザインのものであることを確認します。挿入するフォント
を選択します。textフィールドで、"@"シンタックスを使用してVarコンポーネントにSchematicで定義された変数名を指定します。
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コンポーネントを挿入します。変数名ではなく、変数の内容が表示されています。

スケマティックからのレイアウトの作成

レイアウトからスケマティックを作成しているか、スケマティックからレイアウトを作成しているかに関係なく、デザイン同期プロセス
（Generate/Update）を使用することで、スケマティックとレイアウトが等価であることを確認できます。どちらかを実行する場合は、プログラムがソース
表現の各エレメントを調べて、ターゲット表現で等価のエレメントを変更または作成します。

レイアウトまたはスケマティックの自動生成の詳細については、デザイン同期を参照してください。
2つの表現を同時に作成する方法の詳細については、スケマティック作成時のレイアウトの作成を参照してください。

スケマティック作成時のレイアウトの作成

スケマティックを作成するときのレイアウトの作成は、終了したスケマティックからのレイアウトの作成とほぼ同じですが、ソース表現とターゲット表現
にコンポーネントを同時に配置する点が異なります。

いずれかのウィンドウからOptions > Preferences > Placementを選択します。1.
Dual RepresentationまたはAlways Design Synchronizeを有効にします。 2.

Dual Representationを使用すると、コンポーネントが2番目のウィンドウですでに選択されているので、他の表現に等価コンポーネントをすばやく配置できます。
Always Design Synchronizeにより、各パーツが配置された後、プログラムが両方の表現を完全に同期します。

一般的な問題

処理方法がわからないと解決の難しい、いくつかのデザイン問題があります。

接合部（デザイン同期に関するセクションでスケマティックでのTEE接合の使用を参照）
ステップとテーパー（デザイン同期に関するセクションでスケマティックでのステップとテーパーの使用を参照）
フリップ対回転

コンポーネントのフリップ対回転

Schematicウィンドウでのコンポーネントのフリップと回転は、同じ効果を持つように見えますが、実際にはレイアウト生成中に異なる処理が行われま
す。コンポーネントをSchematicウィンドウでフリップした場合は、コンポーネントがレイアウトでフリップされます。ただし、コンポーネントをSchematicウ
ィンドウで回転した場合は、レイアウトでの回転が行われません。

階層レイアウト

階層は、レイアウトの異なるパーツ間の関係です。階層を持つレイアウトには、別々のデザイン・ファイルに存在する1つ以上のアートワーク・エレメン
トが含まれます。現在のデザイン内に既存のデザインを配置することで、階層デザインを作成できます。これにより、インスタンスまたはデザインへ
の参照が作成されます。

プログラムではしばしば、コンポーネントという用語が、インスタンスと同じ意味で使用されています。この場合のインスタンスは、別のレイアウトによ
って参照されるものを表わします。インスタンスの作成は、あるレイアウトの内容を別のレイアウトにコピーすることとは異なります。インスタンスを作
成しても、データはコピーされません。代わりに、目的のレイアウトに対する参照が作成されます。

作成できる階層のレベルに制限はありません。デザインの参照先のデザインが、次に別のデザインを参照できます。パラメータをすべての階層レベ
ルに渡すことができます。唯一の制限は、デザインがどの階層レベルにあっても自分自身を参照（例えば、デザインAがデザインBを参照し、デザイ
ンBが次にデザインAを参照）できないことです。

階層デザインの利点

階層デザインを作成する第1の利点として、時間の節約が挙げられます。1個のレイアウトを多くの場所で使用できます。参照されるレイアウトで行っ
た変更は、そのインスタンスを使用するすべてのレイアウトに自動的に反映されます。Layoutで、任意のプロジェクトで参照できる再利用可能なデザ
インのライブラリを作成できます。

スケマティックの注意事項

レイアウトを含むデザインをシミュレートしたい場合は、スケマティックが必要です。通常、スケマティックとレイアウトの階層は一致している必要があ
ります。すなわち、スケマティックにサブ回路がある場合は、レイアウトにも対応するサブ回路が存在する必要があります。
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システムはある表現の階層を他の表現から自動的に作成できますが、スケマティックとレイアウトの生成方法と更新方法には柔軟性があります。サ
ブ回路を作成するとき、任意のデザインまたはAELマクロをレイアウトの等価エレメントとして指定できます（File > Design Parameters）。

File > Design ParametersコマンドをSchematicウィンドウから選択したか、Layoutウィンドウから選択したかに関係なく、どちらもデザインを保存すると
きには、説明を同じファイルに書き込みます。

パラメトリック・サブ回路

ほとんどのCADシステムと異なり、インスタンスは、インスタンスごとに変更できます。参照されるデザインの各インスタンスが同じである必要はありま
せん。スケマティック・コンポーネントに1つ以上の属性を変更するパラメータを追加できるので、そのスケマティックを別のデザインで使用するとき、
必要に応じてパラメータを定義できます。このタイプのデザインは、パラメータ化されたデザインと呼ばれます。例えば、マイクロストリップ・ラインの長
さを変更するパラメータを持つスケマティックを作成できます。デザインを別のデザインに配置するとき、パラメータを任意の長さとして定義できます。

レイアウトを生成するとき、アートワーク・エレメントは、定義したパラメータを反映します。

階層レイアウトの作成

このセクションでは、階層レイアウトの作成のさまざまな問題について説明します。

デザイン生成を使用した階層の作成

Schematic（またはLayout）ウィンドウで第1レベルのデザインを作成します。1.
Layout（またはSchematic）メニューからGenerate/Updateコマンドを使用して、両方の表現が使用できるようにします。2.
以下のスケマティックとレイアウトの例をlpfと呼びます。mlengthパラメータは、File > Design/Parametersコマンドを使って作成されています。これにより、パラ
メータ化されたデザインが作成されます。
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デザインを保存します。3.
File > New Designを選択してトップ・レベル・デザインを作成します。4.
Libraryボタンをクリックします。Subnetworksライブラリから、新しく作成したデザイン・ファイルlpfを選択します。5.
ポインタをSchematicウィンドウに移動すると、ポインタと一緒にデザインのゴースト・イメージが移動するので、簡単に配置できます。クリックしてデザインを配6.
置します。
トップ・レベル・デザインを完成します。7.
デザインを保存します。8.

以下の例は、2回配置されたlpfを示したものです。トップ・レベル・デザインをlpf2と呼びます。

階層の手動での作成

Layoutウィンドウで、トップ・レベル・デザインで参照したいデザインを作成します。1.
シミュレーションでレイアウトをスケマティック・デザインと一緒に使用する場合は、ポートを追加します。2.
File > New Designを選択してトップ・レベル・デザインを作成します。3.
Libraryボタンをクリックします。Subnetworksライブラリから、新しく作成したデザインを選択します。4.
ポインタをSchematicウィンドウに移動すると、ポインタと一緒にデザインのゴースト・イメージが移動するので、簡単に配置できます。クリックしてデザインを配5.
置します。
トップ・レベル・デザインを完成します。6.
デザインを保存します。7.

階層デザイン情報の表示

デザインの階層レベルのリストを表示または印刷できます。階層レベルは、リストのインデントによって示されます。トップ・レベルのインスタンスはイ
ンデントされていません。ネスト・レベルごとに、1スペースだけインデントされます。

Tools > Hierarchyを選択します。Hierarchyダイアログ・ボックスが表示されます。1.
情報をファイルに保存するには、Printを選択します。情報がデフォルト・プリンタに送信されます。2.
OKをクリックしてHierarchyダイアログ・ボックスを終了します。3.

階層のフラット

最終アートワークの生成準備が整ったら、Flattenコマンドを使用してすべての階層レベルを除去できます。このプロセスは、参照されるデザインから
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のすべてのデータを現在の表現にコピーします。レイアウト階層の編集（フラット）を参照してください。

レイアウトとスケマティック間の接続の切断

Flattenコマンドは、MLINなどのコンポーネントに作用します。これを使用してレイアウトとスケマティック間の接続を切断すると、レイヤの変更または
レイアウト内の形状の編集が可能になります。

マイクロストリップを選択します。1.
Edit > Component > Flattenを選択します。2.
フラットにしたい各インスタンスに対してこの手順を繰り返します。3.

繰り返し使用するための階層デザインの作成

Create Hierarchyコマンドは、選択したアートワーク・エレメントを別のファイルにコピーし、その新しいファイルを保存したら、元のファイルの選択した
コンポーネントを削除し、新しいデザインへの参照に置き換えます。さらに、新しく作成したファイルでデザインをパラメータ化し、任意のデザインでサ
ブ回路として使用できます。

シンボルのサブ回路への割り当て

デザインを表わすためカスタム・シンボルを使用するには、以下のいずれかを実行できます。

この特定のデザインのみを表わすシンボルを作成します。この方法では、デザインを含むデザイン・ファイルのシンボルをドローイングする必要があります。
任意のデザインを表わすために使用できるシンボルを作成します。この方法では、シンボルだけを含むファイルのシンボルをドローイングする必要がありま
す。

Push Into HierarchyまたはPop Out of Hierarchy機能

Layoutウィンドウで、コンポーネントまで階層を下がって、コンポーネントによって表現される実際のアートワークを表示／編集できます。この機能
は、特定のサブ回路で作業を行う必要があり、オーバヘッドやデザインの残りの詳細を表示する必要がない場合などに、特に有効です。階層を下が
らずに階層デザインを編集する方法の詳細については、階層デザインの編集を参照してください。

以下の手順を使用して、表示または編集のため、階層デザインの階層を下がるか、または階層を上がります。

コンポーネントを選択します。1.
View > Push Into Hierarchyを選択して、シンボルによって表現される回路を表示します。2.
回路の表示を終了するときは、Pop Out of Hierarchyを選択してコンポーネント（またはコンポーネントを含むデザイン）に戻ります。3.

Pop Out of Hierarchyコマンドは、Pushコマンドとは逆で、デザインの階層を下がった場合にだけ機能します。

ライブラリとサーチ・パス

多くのデザインが、階層方法を使用しています。トップ・レベル・デザインは、再利用可能な下位レベルのサブ回路から構成されます。レイアウトは、
すべての回路を別々のデザイン・ファイルに保存します。トップ・レベル回路は、下位レベルのサブ回路ファイルを参照する別個のファイルに保持さ
れます。

階層デザイン・ファイルの読み取り中、サブ回路への各参照も自動的に読み取られます。ほとんどの場合、すべてのサブ回路はトップ・レベル・デザ
インと同じディレクトリにありますが、これは必須ではありません。デザイン・ファイルは、ファイル・システムの任意の場所に置くことができます。デザ
インをプログラムに読み取るときには、ライブラリ・サーチ・パスを使用して、参照するデザイン・ファイルを探します。

ライブラリ・サーチ・パスは、参照するデザイン・ファイルを検索するときにプログラムが使用するディレクトリのリストです。リスト内のディレクトリは、フ
ァイルが見つかるまで順番にチェックされます。通常、現在のプロジェクトの回路、テスト、デフォルト・ディレクトリがサーチ・パスの最初のディレクトリ
で、次にシステム・サンプル・ディレクトリとシンボル・ディレクトリが来ます。ファイルが見つかると、検索が終了し、ファイルが読み取られます。

ライブラリ・サーチ・パス機構により、異なるデザイン間で共有可能な、任意の数の再利用可能なレイアウト・ライブラリを構築できます。テスト対象お
よび通常使用するレイアウト・コンポーネントのデザイン・ライブラリを作成すると、大幅な時間の節約となり、信頼できるデザインが得られます。

環境変数SIMULATOR_AELが、プログラムの検索対象となるAELファイルをリストします。この変数を変更すると、デフォルトのファイル名の後にAEL
ファイルの名前が追加されます。関連変数AEL_PATHは、これらのAELファイルのサーチ・パスを定義します。

AEL_PATH変数のパスにリストされたディレクトリが、左から右の順番で検索されます。検索は、デザインが見つかると終了します。

再利用可能なエレメントのライブラリを作成した場合は、ライブラリを含むディレクトリをサーチ・パスに追加する必要があります。

サーチ・パスと環境変数の変更



Advanced Design Systemドキュメント

26

プログラムによって検索するディレクトリとロードするファイルの順番を制御するサーチ・パスは、特定の環境変数によって定義されます。これらの変
数については、『Customization and Configuration』マニュアルを参照してください。

エレメントの作成
このトピックでは、Advanced Design System (ADS) で新しいアイテムを作成するための詳細を説明します。

新しいアイテムの作成

デザインに配置できるアイテムの基本的なカテゴリとしては、シミュレート可能なアイテムとシミュレート不可能なアイテムの2つがあります。シミュレー
ション・アイテムには、ライブラリ／パレット内のすべてのプログラム提供のアイテムと、すべてのユーザ定義の回路が含まれます。非シミュレーショ
ン・アイテムは、オブジェクトと呼ばれます。代表的なオブジェクトとしては、アライメント・マーカ、スケマティック・シート・ボーダ、機械式留め金具など
があります。他のアイテムと同様に、オブジェクトはパレットやライブラリから選択できますが、シミュレーションでも、レイアウトとスケマティックの間の
デザイン同期でも通常は含まれません。

シミュレーション・アイテム

シミュレーション・アイテムは、名前が示すとおりシミュレーションに含まれています。各シミュレーション・アイテムには、次のいずれかのシミュレーシ
ョン・モデルが関連付けられます。スケマティックとして表されるモデルと内蔵シミュレーション・モデル。いずれのタイプも、新しいアイテムを作成する
場合に使用できます。内蔵モデルは、ユーザ定義のアイテムか、シミュレータが内部表現を持つアイテムです。ユーザ定義のエレメントの作成の詳
細については、『User-Defined Models』マニュアルまたは『ADS Ptolemy Simulation』マニュアルを参照してください。

内蔵のシミュレーション・モデルを使用した新しいアイテムの作成方法は、集中定数コンポーネントやデバイス・モデルなどのデフォルトのアートワー
ク割り当てがないアイテムにアートワークを割り当てるのに使用できます。サンプル・アプリケーションの1つは、S2Pアイテムを使用するSパラメータ・
ファイルを用いてモデル化されたFET用の新しいアイテムを作成することです。

スケマティック回路を用いてモデル化された新しいアイテムを作成することにより、自由度が向上します。一例が、表面実装技術 (SMT) 採用の集中
定数コンポーネント用のはんだ付けパッドの寄生効果をモデル化する回路の作成です。パラメータをカスタム回路に渡すことができるので、どのよう
な回路でも内蔵のシミュレーション・モデルと同じ方法でパラメータ化でき、この方法の柔軟性が高まります。

新しいアイテムの定義

SchematicウィンドウまたはLayoutウィンドウからFile > Design Parametersを選択することにより、任意のタイプの新しいアイテムを定義できます。こ
のダイアログ・ボックスの各フィールドに入力することにより、カスタム・アイテム定義が作成されます。

カスタム・アイテムの定義は、AELファイルに記録されます。このファイルには<design>.aelと名前が付けられます。ここで、designはオープンしている
デザイン・ファイルの名前です。このファイルには、多くのAEL関数ステートメントが含まれています。これらの関数は、新しいアイテムをデザイン環境
に登録します。この登録には、アイテムを表示するパレット／ライブラリ、アイテムのシミュレーション方法（ある場合）、アイテムのパラメータ、アイテ
ムのアートワークやその他の詳細が含まれます。テキスト・エディタを使用して、AELファイルを表示／編集することができます（これらの関数の構文
は、AELマニュアルに定義されています）。ただし、構文が複雑なので、ダイアログ・ボックスを使用することにより、新しいアイテムの定義で多くのエ
ラーが発生する可能性がなくなります。

アイテムの定義が完了したら、プログラムによって提供されるアイテムと同じ方法で、そのアイテムをデザインに配置／使用することができます。デフ
ォルトでは、カスタム・アイテムが現在のプロジェクトのSubnetworksディレクトリに割り当てられますが、新しいライブラリ名を指定することにより、選
択したライブラリに記録することができます。

スケマティック回路モデルを使用して、またはカスタム・アートワークを使用してアイテムを作成する場合は、新しいアイテムの定義を作成する前に、
回路またはアートワークを作成する必要があります。スケマティック回路を使用するアイテムの場合は、アイテムの定義は通常、完成したスケマティ
ック回路をSchematicウィンドウでオープンして行います。他のタイプのアイテムの定義では、SchematicウィンドウとLayoutウィンドウは通常は空白で
す。アートワークおよびモデルは、他のデザイン・ファイルまたはAELファイルにあり、名前によって参照されます。

デザイン特性の定義

多くの場合、デフォルトのデザイン特性で十分ですが、Design Parametersダイアログ・ボックスで回路のデフォルト特性を変更することができます。
必要に応じて、Generalタブの以下のデフォルト特性を変更することもできます。

Name：このフィールドは参考に過ぎず、現在のデザイン名が表示されます。

Description：説明するための語句を記述します。この記述は、アイテムまたは回路を配置した場合に、Component Parametersダイアログ・ボックスに
表示されます。

Component Instance Name：デフォルトはXですが、このフィールドのテキストはすべてのアイテムに一意の名前 (ID) を付ける場合にプレフィックスと
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して使用されます。このプレフィックスは、シンボルをデザインに配置する場合に、シンボルと一緒に表示される注釈表示の一部に含まれます。

Symbol Name：このフィールドに指定したファイル名は、アイテムをデザインに配置する場合に使用されるシンボルを指定します。以下のいずれかの
方法で、シンボル名を指定することができます。

ここに所望の名前を入力できます。ファイル名を入力する場合は、シンボルしか入っていないファイルの名前を（拡張子.dsnを付けずに）正確に入力する必要
があります。
ドロップダウン・リストで、シンボルのリストからシンボルを選択することができます。このリストには、デフォルトで使用可能な一般的なシンボルが複数含まれ
ています。AELによってファイル名をリストに追加することにより、作成したシンボルの名前をこのリストに追加することができます。この方法の詳細について
は、『Customization and Configuration』マニュアルのCustomization ExamplesのセクションのModifying the List of Available Symbol Namesを参照してくださ
い。
More Symbolsをクリックすると、ダイアログ・ボックスが現れ、すべての付属のシンボルのアイコンが表示されます。
シンボルを指定する場合は、必要な数のポートがあることを確認します。

Library Name：デフォルトでは、このフィールドにはアスタリスク (*) が表示されています。このデフォルトをそのまま使用した場合、アイテムは現在の
プロジェクトのSubnetworksディレクトリに保存されます。この名前をカスタム定義のライブラリ名に変更することができます。

Allow only one instance：アイテムまたは回路をデザインに複数回配置できるかどうかを指定できます。デフォルトはオフです。アイテムまたは回路は
一意ではなく、デザインに複数回使用できます。配置をデザイン当たり1回に制限する場合は、オンに変更します。

Include in BOM：サブ回路デザインの詳細を生成した部品表 (BOM) に含める場合は、オンにします。オフにした場合は、トップ・レベルのデザインの
情報だけが含まれます。

Layout Object定義しているデザインがLayoutオプションで使用されるオブジェクトの場合は、オンにします（レイアウト・オブジェクトはシミュレート／
同期されませんが、通常は、アライメント・マーカなどのアイテムが含まれます）。この属性は、レイアウト・パレット／ライブラリまたはスケマティック・
パレット／ライブラリにそれらのオブジェクトを表示するかどうかを制御します。

Simulate From Layout (SimLay)：アナログ/RFデザインのみ。シミュレーションに必要なネットリストがスケマティックまたはレイアウトから生成されま
す。レイアウトからネットリストを生成するには、このオプションを選択します。

Simulation

Model：ネットリストの選択を割り当てることができます。
Built-in Component：内蔵シミュレータ・アイテム（CAPやRESなど）
Sbnetwork：定義したスケマティック回路
Not Simulated：レイアウトまたはスケマティック専用の非シミュレーション・アイテムの作成

Simulate As：このフィールドには、内蔵シミュレータ・アイテムの名前またはスケマティックの名前（通常は、現在のデザインの名前）を指定します。Simulation
ModelをSubnetworkに設定している場合は、デザイン名を入力します。Built-in Componentに設定している場合は、内蔵シミュレータ・アイテムの名前を入力
するか、ドロップダウン・リストから名前を選択します。アイテムに対してNot Simulatedを選択した場合は、このフィールドは使用されません。

Artwork

Type：アートワーク・タイプを割り当てることができます。Synchronized、Fixed、AEL MacroまたはNone。
Name：適切なアートワーク名を付けて、マクロ・アイテムまたはデザイン・アイテムを割り当てることができます。

Save AEL File：定義（.aelファイル内）をインクリメンタルに保存できます。デザイン・ファイル自体を保存するまで待つのではなく、これをオンにしてOKを
選択することにより、新しいアイテムのAEL定義が保存されます。

デフォルトのデザイン特性がニーズに合っている場合は、パラメータの定義のセクションに直接進むことができます。

内蔵のシミュレータ・モデルを使用した新しいアイテムの作成

シミュレーション・モデルを定義するにはまず、SchematicウィンドウでFile > New Designを使用して、空白のデザインを新たに作成します。デザイン
特性を定義し、アイテムに渡す必要のあるパラメータを追加します (File > Design Parameters)。パラメータを定義したら、アイテムの定義を保存しま
す。

このセクションで説明する以下のトピックスでは、簡単なコンデンサCAPをシミュレーション・モデルとして使用し、チップ・コンデンサ・フットプリント
CHPCAPを表す既定義のアートワークを使用します。

内蔵のモデルを使用してアイテムを定義する手順：

新しいプロジェクトを作成するか、既存のプロジェクトをオープンします。1.
Schematicウィンドウをオープンし、File > New Designを選択します。2.
ファイルに名前を付けます（この例では、mycap）。3.

注記
この例では、SchematicウィンドウまたはLayoutウィンドウに何も配置する必要はありません。アイテムの定義は
すべて、Design Parametersダイアログ・ボックスから行います。

File > Design Parametersを選択します。Design Parametersダイアログ・ボックスが表示されます。4.
アイテムに対して新しいアイテムIDプレフィックスを入力することもできます（この例では、C）。5.
前述のいずれかの方法を使用して、シンボル名を指定します。この例では、付属のコンデンサ・シンボルSYM_Cが使用されています。6.
Layout Objectオプションをオンにします。7.
アートワーク・タイプ（例えば、Fixed）を指定します。8.
回路をデザインする場合は、その回路を別の回路に配置する場合にその回路を表すアートワークのタイプを決定する必要があります。エレメントの作成には
通常、FixedかAEL Macroを使用します。
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Artwork Nameフィールドに名前を指定します（固定アートワークの場合は、Labelフィールドに表示されているのと同じ名前を入力します。マクロの場合は、9.
AEL関数の名前を入力します）。この例では、チップ・コンデンサのアートワークとしてCHPCAPを選択します。
前述のように、適切なシミュレーション・モデルを選択します。この例では、Built-in Componentを使用します。10.
アイテム（または回路）のシミュレーション方法を指定します。この例では、Cを選択します。以下の例のようなダイアログ・ボックスが表示されているはずで11.
す。

Save AELをクリックして、アイテム定義のこの部分を保存し、次のセクションパラメータの定義に進みます。12.

パラメータの定義

定義する新しいアイテムのほとんどが、パラメータを必要とします。この例では、新しいアイテムのパラメータはSimulation ModelのCAP、すなわち
C（キャパシタンス）のパラメータと同じです。AELアートワークを持つアイテムには、場合によっては、レイアウト用に別のパラメータを追加する必要が
あります（パラメータ・リストの先頭）。

この例では、最初のアートワークCHPCAPにはレイアウト用の追加パラメータがないので、このアイテムに対して定義する必要があるのはパラメータ
Cだけです。モデル・タイプとしてBuilt-in Componentを選択したら、Parametersタブをクリックしてパラメータを定義することができます。

ヒント
Copy Component's Parametersをクリックすることもできます。Simulate Asフィールドで名前を付けたアイテムのパラ
メータ・セットが新しいアイテムに自動的に割り当てられます。この例では、追加のレイアウト・パラメータがないの
で、パラメータの定義に必要な手順はこれだけです。

より複雑な定義では、各パラメータは、アイテムが使用されている場合のパラメータの処理方法を決定する特性を持ちます。その例としては、
Component Parametersダイアログ・ボックスに表示される名前／ラベル、パラメータの単位タイプ、パラメータに割り当てられている値のタイプ、デフ
ォルト値、特定の制御属性があります。

パラメータを定義する手順：

この例では、Copy Component's Parametersをクリックし、Parametersタブをクリックします。付属のコンデンサ・コンポーネントのパラメータがリストされます。1.

重要
AELで生成されたアートワークに対しては、パラメータを正しい順序で入力することが重要です。このダイアログ・
ボックスで指定する順序は、関数で指定される順序と一致していなければなりません。例えば、MLINのAEL関数
では、長さの前に幅があります。長さパラメータを最初に入力した場合は、関数は長さを幅と読み取ります（Name
識別子は無視されます）。
また、アートワーク・パラメータはシミュレーション用のパラメータの前になければなりません。Not Netlistedマーク
を付ける必要もあります。アートワークを持つアイテムに対しては、アートワーク・パラメータをまず追加し、copy
parametersを使用するか、シミュレーション・パラメータを追加します。
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この例では、付属のコンポーネントのパラメータがコピーされたため、Edit Parameterフィールドにはデフォルトが表示されています。2.
Value TypeがRealに設定されます。
Default Valueが1.0 pFに設定されます。この値にはデフォルトとしての役割しかありません。以後、アイテムを配置するたびに、値を変更できます。
Parameter TｙpeがCapacitanceに設定されます。
Parameter Description（オプション）がCapacitanceになります（パラメータの意味を記述する場合にだけ使用します）。

必要なデザインに基づいて、以下のオプションをオン／オフします。3.
Display parameter on schematic：スケマティックに定義されているパラメータを表示するには、このオプションを選択します。
Optimizable：このパラメータを最適化するには、このオプションを選択します。
Allow Statistical Distribution：歩留まり解析中のこのパラメータのポスト・プロダクション・チューニングを可能にするには、このオプションを選択します。
Not edited：編集用のComponent Parametersダイアログ・ボックスにこのパラメータが表示されないようにし、その代わりに割り当てられているデフォルト値を常に使用するには、この
オプションを選択します。
Not netlisted：パラメータがシミュレーションでは考慮されないようにし、アートワークの再生では認識されるようにするには、このオプションを選択します。（一般に、レイアウト専用パラ
メータは、シミュレーションには使用されず、Not Netlisted属性が割り当てられます）。

新しいパラメータを定義する場合は（この例の場合の簡単なパラメータのコピーではなく）、新しいパラメータをそれぞれパラメータ・リストに追加するには、4.
Addをクリックする必要があります。

ヒント
各パラメータに対して定義したとおりに属性を割り当てたり、すべてのパラメータを定義してから戻って属性を割り
当てることができます。

デザインを保存します。5.
デザイン・ファイルを保存すると、AEL定義が現在のプロジェクトの/networksディレクトリに作成されます。このファイルを（スケマティック／レイアウトがあるデ
ザイン・ファイルと一緒に）他のディレクトリに移動して、個人用またはサイト全体用のライブラリ・パーツとして使用することができます。詳細については、
『Customization and Configuration』マニュアルのCustomization ExamplesのセクションのCreating Custom Librariesを参照してください。
アイテムのパレットへの追加方法の詳細については、『AEL』マニュアルのde_define_palette_group()関数を参照してください。

レイアウトの編集
プログラムの他の部分と同様に、ほとんどの編集コマンドでは、編集コマンドの選択前または選択後に1つ以上のコンポーネントを選択できます。最
もよく使用される編集コマンド、Copy、Delete、Move、Rotate、Undoは、プログラムの他の部分にある場合とまったく同じように、レイアウトで実行され
ます。プログラムの他の部分と同様に、テキストを編集して、既存のテキストの属性を変更するか、すべての後続のテキストの属性を定義することが
できます。

電気的に完全なレイアウト回路は、すべてのコンポーネントが接続されています。この章では、レイアウト回路コンポーネントの編集方法と接続方法
について説明します。

選択フィルタの使用法

選択フィルタを使用すれば、セクションに含める／含めないコンポーネントのタイプを指定できます。オフになっているコンポーネントは、個別にクリッ
クしたり、選択ウィンドウで囲もうとしたり、Select Allコマンドを選択しても選択されません。選択フィルタが無視されるのは、Select By Nameコマンドと
Deselct By Nameコマンドだけです。

デフォルトでは、Drawing Formatを除くすべてのタイプのコンポーネントがオンになっています。

Options > Preferences > Selectを選択します。
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Propertiesダイアログを使用したプリミティブの編集

1つまたは複数の形状（テキストを含む）を編集するには、形状を選択してEdit > Propertiesをクリックするか、選択したオブジェクトをダブルクリックす
るか、右クリックしてPropertiesを選択します。これにより、次のようなPropertiesダイアログがオープンします。

注記
Propertiesダイアログでオンにした機能は、明記されていない限り、LayoutとSchematicの両方のウィンドウに適用さ
れます。

Propertiesダイアログで行った変更を適用するには、ApplyまたはOKをクリックします。例えば、長方形の原点を変更した場合は、Applyをクリックして
変更を確認します。OKをクリックした場合は、変更が適用され、Propertiesダイアログがクローズします。

注記
多角形、ポリライン、長方形、円、円弧のThickness属性は、スケマティックにのみ使用できます。Schematicウィンド
ウから起動した場合にだけ、Propertiesダイアログにこの属性が表示されます。

Propertiesダイアログがオープンしている間は、任意のタイプのオブジェクトを選択できます。ダイアログがオープンしている間にオブジェクトを選択し
ないと、Propertiesダイアログ・ボックスの上部に0 items selected.と表示されます。レイアウトに選択されているオブジェクトがなければ、Standardタ
ブのテーブルにもCustomタブのテーブルにも、値は表示されません。

All Shapes

このセクションを使用して、現在選択されている形状のLayer値を変更します。
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Path/Trace/Wires

このセクションを使用して、選択した経路、トレースまたはワイヤの幅、コーナ・タイプ（マイタ、直角、カーブ）、マイタ、カーブ半径を変更します。長さ
は編集できません。参考のためだけに示されています。

Text

このセクションを使用して、テキスト（Value列のTextをクリックして編集するか、 をクリックしてマルチライン・テキストを編集するのにより便利な
Textダイアログを起動します）、フォント（HersheyRomanmまたはHersheyRomanNarrow）、サイズ、X/Y位置、横（Left、Center、Right）および縦（Top、
Middle、Bottom）の行端位置合わせ、配置角度、階層構造の場合の回転（TopまたはFalse）を変更します。

Rectangles

このセクションを使用して、次のいずれかを定義することにより、長方形の形状を変更します。

左下のX/Y座標、幅、高さ、または
左下のX/Y座標と右上のX/Y座標。

Circles

このセクションを使用して、中心点のX/Y座標、半径、編集モード（Absolute radiusまたはDelta radius）を定義することにより、円の形状を変更しま
す。

Arcs and Circles

このセクションを使用して、円弧分解能（度単位）を変更します。

Arcs

このセクションを使用して、中心点のX/Y座標、開始点のX/Y座標、角度を定義することにより、円弧の形状を変更します。半径は編集できません。
参考のためだけに示されています。

Construction Lines

このセクションを使用して、作図ラインを定義する2つのポイントを定義することにより、作図ラインの形状を変更します。傾きは編集できません。参考
のためだけに示されています。

Customタブ

以前のバージョンのADSのEdit > Propertiesダイアログに表示されていたプロパティは、Customタブに含まれています。Name、Type、Value列は編集
可能です。

Standardタブでの同じオブジェクトの複数選択
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異なる値を持つ同じオブジェクトを複数選択すると、Value列に(multiple values)と表示されます。(multiple values)の値が変更されない限り、Applyまた
はOKをクリックしても、選択したオブジェクトのそれらの値は変更されません。等しい（すなわち、異ならない）値を持つフィールドだけが変更されま
す。

例えば、 をクリックした場合は、空のテキスト・エントリ・ボックスが表示されます。Applyをクリックすると、入力したテキストが選択したすべてのテ
キストに適用されます。また、選択したすべてのテキストのフォント、行端位置合わせ、配置角度、非回転値、レイヤが偶然にも同じ場合、すべてに
それらの共通値が示されます。

Standardタブでの異なるオブジェクトの複数選択

異なるオブジェクトを複数選択した場合、次の属性がすべて表示されます。

Standardタブ：選択したすべてのプリミティブ形状のすべての属性の結合。例えば、長方形と円を同時に選択した場合、このタブには、すべての長方形属性と
円属性が表示されます。
Customタブ：選択したすべてのオブジェクトのすべてのカスタム・プロパティ。

Customタブでのオブジェクトの複数選択

選択したすべてのオブジェクトのカスタム・プロパティがすべてリストされます。それらのオブジェクトが与えられたパラメータに対して異なる値を持つ
（または値をまったく持たない）場合、Value列に(multiple values)と表示されます。変更された値だけが適用されます。

Typeフィールドに、同じ名前のプロパティ・タイプの異なる複数の選択したオブジェクトに対して、(multiple types)と表示されます。

オブジェクトのカスタム・プロパティを表示するには、オブジェクトを1回クリックして選択します。

形状の編集

一般的なレイアウト形状に対しては、さまざまな編集操作を実行できます。これらの編集操作の詳細については、対象のセクションを参照してくださ
い。

多角形およびポリラインの処理
頂点の処理
形状のエッジの伸張
形状のスケーリング
「レイアウトの作成」のセクションの「ポートおよびグランドの追加」

形状の選択

選択フィルタによって提供される選択機能以外にも、指定するレイヤ上のすべてのアイテムをすばやく選択したり、ノード間インターコネクト内のアイ
テムをすべて選択することができます。

特定のレイヤ上のアイテムをすべて選択する手順：

Select > Select All On Layerを選択します。1.
表示されたダイアログ・ボックスで、編集対象として選択したいアイテムがあるレイヤを選択します。複数のレイヤ上の全アイテムを選択するには、各レイヤを2.
選択してからApplyをクリックし、OKをクリックします。選択したレイヤ上のアイテムが編集対象として選択されます。

ノード間インターコネクト内のアイテムをすべて選択する手順：

Select > Select Interconnect > Nodalを選択し、ノード間インターコネクトを実行する多角形、経路、長方形、ワイヤ、トレースを選択します。Select > Select1.
Interconnect > Nodal With Componentsを選択し、相互接続されている形状およびコンポーネント・インスタンスを選択します。
マウスを使って形状を選択します。同じインターコネクト内の形状もすべて選択されます。2.

多角形およびポリラインの処理

多角形やポリラインをドローイング後に変更するには、以下のようにいくつかの方法があります。

Edit > Merge > Union：レイヤの選択した形状をマージします。選択したすべての形状のポイントのセットとして定義されます。このコマンドは、各レイヤに対し
て個別に実行されます。この操作は次の形状に適用されます：多角形、長方形、円、経路。『Customization and Configuration』ドキュメントの「Setting Layout
Options」のセクションの「Changing Entry/Edit Attributes (Merge/Boolean Logical/Create Clearance)」も参照してください。
Edit > Merge > Intersection：レイヤの選択した形状の各ペアの交点を検出します。2つ以上の選択した形状に存在するポイントのセットとして定義されます。
このコマンドは、各レイヤに対して個別に実行されます。この操作は次の形状に適用されます：多角形、長方形、円、経路。『Customization and
Configuration』ドキュメントの「Setting Layout Options」のセクションの「Changing Entry/Edit Attributes (Merge/Boolean Logical/Create Clearance)」も参照し
てください。
Edit > Merge > Union Minus Intersection：レイヤの選択した形状の結合から交点を取り除きます。せいぜい1つの選択した形状に存在するポイントのセットと
して定義されます。このコマンドは、各レイヤに対して個別に実行されます。この操作は次の形状に適用されます：多角形、長方形、円、経路。このコマンド
は、多角形にホールを作成したり、形状セット間の違いを検出するのに使用できます。『Customization and Configuration』ドキュメントの「Setting Layout
Options」のセクションの「Changing Entry/Edit Attributes (Merge/Boolean Logical/Create Clearance)」も参照してください。
Edit > Modify > Convert To Polygon：円および円弧を含む多角形を単純な多角形に変換するのに使用します。単純な多角形では、すべての曲線が元の形
状に近いライン・セグメントに変換されます。
Edit > Modify > Join：選択した終点が一致する複数のポリラインを1本のポリラインに結合することができます。閉じた形状になった場合は、結合されたポリラ
インが多角形に変換されます。
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Edit > Modify > Explode：多角形を各頂点に接続されていない個々のライン・セグメントに変換することができます。
Edit > Modify > Break：多角形を1本のポリラインに変換するのに使用します。
Edit > Modify > Chop：選択した多角形、長方形、円または経路から定義した長方形領域を除去します。トレースまたはインスタンスを選択した場合は、このコ
マンドは失敗し、エラーが表示されます。他のタイプはすべて黙って無視されます。
Edit > Modify > Extend：ポリラインの選択した終点を、指定した基準ライン・セグメントまで延長できます。
Edit > Modify > Corp：選択した多角形、長方形、円または経路から定義した長方形領域を保護すると同時に、その領域外のエリアをすべて除去します。トレ
ースまたはインスタンスを選択した場合は、このコマンドは失敗し、エラーが表示されます。他のタイプはすべて黙って無視されます。
Edit > Modify > Split：選択した多角形、長方形、円または経路を、定義した長方形領域を使用して複数の形状に分割します。トレースまたはインスタンスを選
択した場合は、このコマンドは失敗し、エラーが表示されます。他のタイプはすべて黙って無視されます。

交点またはポリラインからの多角形の作成

2個の交差する閉じた形状の結合から多角形を作成する手順：

2個の形状を選択します。1.
Edit > Merge > Unionを選択します。2.

2個の閉じた形状の交点から多角形を作成する手順：

2個の形状を選択します。1.
Edit > Merge > Intersectionを選択します。2.

2個の交差する閉じた形状から多角形を作成し、交点を削除する手順：

2個の形状を選択します。1.
Edit > Merge > Union Minus Intersectionを選択します。2.

多角形への形状の変換

形状を多角形に変換する手順：

形状（円または円弧を含む多角形）を選択します。1.
Edit > Modify > Convert To Polygonを選択します。曲線はすべて、元の形状に近いライン・セグメントに変換されます。この変換に使用されるライン・セグメン2.
トの数を決定するには、Options > Preferences > Entry/EditでArc/Circle Resolution (degrees)を設定します。
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複数のポリラインの結合

選択した複数のポリライン（終点が一致する）を1本のポリラインに結合する手順：

結合する個々のポリラインを選択します。1.
Edit > Modify > Joinを選択します。一致する終点はすべて結合されます。形状をクリックして選択し、形状全体が選択されたかどうかをモニタすることにより、2.
何が結合されたかを確認できます。

何が結合されたかを確認するには、形状をクリックして選択し、形状全体が選択されたかどうかをモニタします。

個別の2ポイント・ライン・セグメントへの多角形の変換

多角形を個別の2ポイント・ライン・セグメントに変換する手順：

多角形を選択します。1.
Edit > Modify > Explodeコマンドを選択します。必要に応じて編集可能な個々のライン・セグメントを残して、すべての頂点が切り離されます。2.

1本のポリラインへの多角形の変換

多角形を1本のポリラインに変換する方法：

多角形を選択します。1.
Edit > Modify > Breakを選択します。多角形の開始点と終点が切断され、マーカによって識別されるため、形状をポリラインとして処理できます。2.

Edit > Modify > Extend：ポリラインの選択した終点を、指定した基準ライン・セグメントまで延長できます。
Edit > Modify > Corp：多角形、長方形、円またはワイヤ／トレースのエリアの指定、選択したエリアの保存、残りの削除に使用します。
Edit > Modify > Split：多角形、長方形、円または経路／トレースを複数のオブジェクトに分割できます。

選択した領域の形状からの切り取り

選択した領域を多角形、長方形、円またはワイヤ／トレースから切り取るには、以下の手順を実行します。
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形状を選択します。1.
Edit > Modify > Chopを選択します。2.
マウスを使用して、切り取る長方形領域をオブジェクト上に移動します。3.

ポリラインの終点の延長

ポリラインの終点を指定した基準ライン・セグメントまで延長する手順：

Edit > Modify > Extendを選択します。1.
延長するラインをクリックします。2.
基準ラインをクリックします。3.

形状のクロッピング

多角形、長方形、円またはワイヤ／トレースの指定したエリアを保存し、残りを削除するには、以下の手順を実行します。

形状を選択します。1.
Edit > Modify > Cropを選択します。2.
マウスを使用して、保存する長方形領域をオブジェクト上に移動します。3.

形状の分割

多角形、長方形、円または経路／トレースを複数のオブジェクトに分割する手順：

形状を選択します。1.
Edit > Modify > Splitを選択します。2.
マウスを使用して、分割する長方形領域をオブジェクトの残りの部分から離れたところに移動します。3.

形状のエッジの伸張

エッジ（2つの頂点の間のセグメント）の伸張により、形状を再定義することができます。

Edit > Move > Move Edgeを選択します。ラインの位置を入力するように促すプロンプトが表示されます。1.
伸張するエッジを1回クリックします。カーソルを動かすとゴースト・イメージが移動／変化し、形状がどのようにドローイングし直されるか示されます。2.
再度クリックして、新しい形状を定義します。3.

形状のスケーリング

オブジェクト／テキストを%単位でスケーリングする手順：

Edit > Scale/Oversize > Scaleを選択すると、Scaleダイアログ・ボックスが表示されます。1.
XとYの両方のスケーリング係数を入力します。2.
スケーリング係数は整数でなければなりません。1.0より大きなスケーリング係数ではオブジェクトのサイズが大きくなるのに対して、1.0より小さなスケーリン
グ係数ではオブジェクトのサイズが小さくなります。複数のオブジェクトを一様にスケーリングするには、XとYの両方に同じスケーリング係数を入力します。テ
キストには、Xスケールだけが使用されます。
OKをクリックすると、スケーリングするオブジェクトの周囲に基準点を入力するように促すプロンプトが表示されます。3.
クリックして基準点を指定すると、オブジェクトがスケーリングされます。4.

デザインの単位を基準にしてオブジェクトをスケーリングする手順：

オブジェクトを選択します。1.
元のオブジェクトをスケーリングしたイメージに置き換えるには、Edit > Scale/Oversize > Oversizeコマンドを選択します。2.
選択したオブジェクトのコピー（指定のサイズを使用）を現在のエントリ・レイヤ上に置き、元のオブジェクトを維持するには、Edit > Scale/Oversize > Copy &
Oversizeコマンドを選択します。
これらのいずれかのコマンドを選択すると、ダイアログ・ボックスが表示されます。
サイズ決め値を入力します。正の数を入力するとオブジェクトのサイズが大きくなります。負の数を入力するとサイズが小さくなります。3.

マイタ・コーナのカットオフ角度を入力します。指定したカットオフ角度より小さい多角形の角度はすべてマイタです。デフォルト＝45°。4.
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ダイアログ・ボックス内の変更を行い、OKをクリックします。5.

上のステップ2でOversizeを選択した場合は、オブジェクトは指定したサイズにスケーリングされます。

上のステップ2でCopy & Oversizeを選択した場合は、選択したオブジェクトのコピーが現在のエントリ・レイヤ上に指定したサイズでドローイングされ
ます。

頂点の処理

注記
頂点を選択、移動または削除するには、頂点選択フィルタがオンになっていなければなりません（「選択フィルタの
使用法」を参照）。

多角形またはポリラインに頂点を追加する手順：

Edit > Vertex > Addを選択します。1.
2つの既存の頂点の間のポイントをクリックし、マウスを移動します。頂点とカーソルの間にフレキシブルなラインが描かれます。2.
再度クリックして新しいポイントを指定すると、形状がドローイングし直されます。3.

頂点を移動する手順：

Edit > Move > Moveを選択し、頂点をクリックして、マウスを移動します。影響を受けた頂点とカーソルの間にフレキシブルなラインが描かれます。1.
再度クリックして新しい位置を指定すると、形状がドローイングし直されます。2.

頂点を削除する手順：

削除する頂点をすべて囲むように選択ウィンドウを描きます。1.
ツールバーの削除ボタンをクリックします。形状がドローイングし直されます。頂点は削除されています。2.

ポリラインから円弧を削除する手順：

ツールバーの削除ボタンをクリックします。1.
円弧の任意の場所をクリックします。円弧が削除され、円弧の元の終点が直線で結ばれます。2.



Advanced Design Systemドキュメント

37

円弧への頂点の変換

ウィンドウの単位を基準にして、頂点を円弧に変換し、目的の円弧の半径を指定することができます。

Edit > Vertex > To Arcを選択します。頂点の位置を入力するように促すプロンプトが表示され、ダイアログ・ボックスが表示されます。1.
半径を必要に応じて設定し、Applyをクリックします。2.
円弧に変換する頂点をクリックします。それに応じて頂点がドローイングし直されます。3.

必要に応じて別の半径を使用して、この方法で頂点を変換し続けることができますが、半径を変更するたびにApplyをクリックする必要があります。
変更が終わったら、OKをクリックしてダイアログ・ボックスをクローズします。4.

マイタ・エッジへの頂点の変換

ウィンドウの単位を基準にして、頂点をマイタ・エッジに変換し、目的のマイタ・エッジの長さを指定することができます。

Edit > Vertex > Miterを選択します。頂点の位置を入力するように促すプロンプトが表示され、ダイアログ・ボックスが表示されます。1.
マイタ長を必要に応じて設定し、Applyをクリックします。2.
マイタ・エッジに変換する頂点をクリックします。それに応じて頂点がドローイングし直されます。3.

必要に応じて別のマイタ長を使用して、この方法で頂点を変換し続けることができますが、長さを変更するたびにApplyをクリックする必要があります。
変更が終わったら、OKをクリックしてダイアログ・ボックスをクローズします。4.

別のレイヤへの形状／テキストの移動

形状またはテキストを別のレイヤに移動する手順：

移動するオブジェクトを選択します。1.

注記
ポートを別のレイヤに移動するのに、Move To Layerコマンドを使用しないでください。ポートのLayerパラメータを
目的のレイヤに設定します。

Edit > Move > Move To Layerを選択します。ダイアログ・ボックスが表示され、現在定義されているレイヤがリストされます。目的のレイヤを選択し、OKをクリ2.
ックします。選択したオブジェクトがすぐに、選択したレイヤの色およびその他の表示属性を有するようになります。

注記
オブジェクト、コンテキスト依存メニューPropertiesをダブルクリックするか、Edit > Propertiesを選択することによって
起動されるPropertiesダイアログを使用して、形状やテキストを別のレイヤに移動することもできます。

寸法ラインの処理
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寸法ラインは移動／変更できます。

エンドラインの移動

寸法ラインは、Edit > Move > Dimension Line Endlineコマンドを使って伸張できます。この手順は以下のとおりです。

Edit > Move > Move Dimension Line Endlineを選択します。1.
十字線を伸張する寸法ラインの終わりに移動して、クリックします。2.

注記
寸法ラインの終わりを選択できない場合は、寸法ラインの矢印が表示されているか確認します。表示されていな
い場合は、ズームインして、寸法ラインの終わりを再度選択します。

十字線を目的の位置に移動して、クリックします。3.

寸法ラインの変更

寸法ラインの属性を変更するには、以下の手順を実行します。

寸法ラインをダブルクリックします。1.
Dimension Lineダイアログ・ボックスが表示されます。2.

Select Parameterリストから、変更するパラメータを選択します。3.
以下の選択肢があります。
LineLength：寸法ラインの長さ。
LineOffset：寸法ラインのX軸からの垂直方向のオフセット。
Endline：エンドラインの寸法ラインからの高さ。
ArrowLength：矢印の長さ。
ArrowWidth：矢印の幅。
ArrowDir：矢印の向き。指定できるのは、inwardとoutwardです。
TailLength：ArrowDirがinwardの場合は、矢印の尾部の長さを表します。
Layer：寸法ライン・レイヤ。
TextOffset：寸法ラインからのテキストのオフセット。
TextHeight：テキストの高さ。
Precision：表示長さの精度。
TextPosition：寸法ラインに対するテキストの位置。使用可能な選択肢は、above、below、left、rightです。
TextUnits：距離の表示に使用する単位。
パラメータ設定を編集します。4.
OKをクリックして変更を保存し、ダイアログ・ボックスをクローズします。5.
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座標0,0へのオブジェクトの移動

デフォルトでは、座標0,0はLayoutウィンドウの中央に位置します。どこか他の場所に配置またはドローイングしたオブジェクトの位置を原点に変更す
ることができます。

Edit > Modify > Set Originを選択します。原点の位置を入力するように促すプロンプトが表示されます。1.
0.0に位置付けるオブジェクトのポイント（例えば、ピン1）をクリックすると、オブジェクトが移動します。指定したポイントが0.0に位置付けられます。2.

注記
View Allコマンドを使用して、オブジェクトをビューに戻すことができます。

オブジェクトのグリッド上への位置付け

オブジェクトが現在のグリッド間隔からオフセットされている場合は、最も近いグリッド・ポイントに位置付けることができます。選択したオブジェクトが
複数のピンを有するコンポーネントの場合、ピン1が最も近いグリッド・ポイントに位置付けられます。

オブジェクトを選択します。1.
Edit > Modify > Force to Gridを選択します。選択したオブジェクトがグリッドにスナップします。2.

レイアウト階層の編集 (Flatten)

最終アートワークを作成する準備ができたら、階層レベルを削除することができます。このプロセスでは、すべてのデータが基準デザインから現在の
表現にコピーされるため、1つの階層レベルが削除されます。削除する各階層レベルに対してこのプロセスを繰り返します。完了してもデザインはそ
のままですが、最終デザインに影響を及ぼす可能性のある参照は含まれません。

トップ・レベルの階層デザインをオープンします。1.
インスタンスを選択します。2.
Edit > Component > Flattenを選択します。3.
これにより、すべてのデータがコンポーネントから現在の表現にコピーされ、サブデザインへの参照が削除されます。1つの階層レベルが削除されることに注
意してください。
フラットにする各インスタンスに対してこの手順を繰り返します。4.
すべての階層レベルが削除されたことを確認するには、Tools > Hierarchyを選択します。これにより、空のレポートが作成されるはずです。5.
デザインを保存します。6.

注記
1つのコマンドですべての階層レベルを除去するには、File > Generate artworkを選択します。

Physical Connectivity Engine

ADS Physical Connectivity Engineを使用すれば、多角形形状のレイアウト・アートワークに基づいて電気的な相互接続を確立し、インターコネクト情
報の抽出をオンザフライに実行することができます。
主な特長：

多角形ベースのレイアウト接続
簡略化された垂直方向のインターコネクト
エッジ／エリア・ピン
ノード間／物理的インターコネクトの検証

多角形ベースのレイアウト接続

多角形ベースのレイアウト接続では、ワイヤやトレースの相互接続上の制約がなく、多角形ベースのレイアウト・アートワークとの電気的な接続を確
立できます。また、カスタム・ネイティブ・インターコネクト構成を使用して、電気的な接続を示すことができます。

この機能を用いることにより、スケマティックまたはレイアウトでデザインを開始し、簡単なトレースではなくカスタム・レイアウト・インターコネクトを実
装し、レイアウトのインターコネクト情報の抽出をオンザフライで実行し、カスタム・インターコネクトをスケマティックにバックアノテートすることができ
ます。

この他の利点としては、レイアウトとスケマティックの間のより信頼性の高いデザイン照合があります（オープン接続、ノード／コンポーネント値の不
一致、レイアウトのゼロ幅ワイヤ、コンポーネントの重ね合わせ、接触しているものの異なるノードに属するレイアウト形状、多角形／コンポーネント
の重なり合い、ピン以外とピンの接続）。デザインの接続の検証が著しく向上した点としては、接触または重なり合っているものの異なるノードに属し
ている多角形形状、またはピン間接続されていない多角形形状の検証があります。

Physical Connectivity Engineは、主に任意のレイアウト・アートワークの接続情報の不足が原因で、これまでチェックされていなかった潜在的な接続
上の問題に対処しています。詳細については、「形状とのインターコネクトの作成」を参照してください。
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簡略化された垂直方向のインターコネクト

多角形形状が実環境下に近い電気的接続特性を有するようになり、プレビルドされたビア・コンポーネントがなくても、垂直方向の電気的な接続が
可能です。デザイナは、垂直方向の電気的な接続を確立するために、デザイン・キット（MMICのデザイン用）またはコンポーネント・ライブラリ（プリン
ト基板／モジュールのデザイン用）のプレビルドされたビア・コンポーネントの可用性に制限されることはもうありません。ビア・マクロで、またはレイア
ウト・アートワークを多層スタック上に重ねることにより、ピンのないビアを定義することもできます。この新しいピンのないビアの利点は、垂直方向の
接続が簡単で、レイアウトはもちろん、スケマティックにもビア・コンポーネントを配置する必要がないことです。詳細については、「形状とのインターコ
ネクトの作成」を参照してください。

エッジ／エリア・ピン

ADSのレイアウトの接続性が向上したもう1つの点は、ポイント-ピンの概念を超えたピンの拡張で、エッジ・ピンやエリア・ピンが挙げられます。この
機能は、レイアウト・コンポーネントが単純でも複雑でも、固有のエッジ・ピンやエリア・ピンを定義できるので、デザイン・キットやコンポーネント・ライ
ブラリの開発者に非常に有用です。詳細については、「エッジ・ポートとエリア・ポートの指定」を参照してください。

ノード間／物理的インターコネクトの検証

Physical Connectivity Engineによって、信頼性の高いインターコネクトの検証機能も向上します。レイアウトのすべての多角形形状が電気的接続情
報を伝達するため、デザイン・プロセスのどの時点でも、ノード／物理的接続の検査など、多くの検証チェックを実行できます。詳細については、「レ
イアウトの接続情報の確認」を参照してください。

ノード間インターコネクト・チェックでは、デザインのスケマティック／レイアウト内のノードを検査できます（ノードの定義は、ピン／ポート、およびアク
ティブかパッシブかに関わらず、デザイン・コンポーネントを除くすべての接触インターコネクトと理解されています）。この機能では、スケマティックの
単純な配線が複雑な物理的な相互接続に変換されるので、スケマティック／レイアウトのノードのクロスプローブ（相互参照）を実行して、デザインの
精度を検証するのに非常に有用です。詳細については、「インターコネクトの強調表示」および「クロスプローブ」を参照してください。

物理的インターコネクト・チェックでは、多層階層デザインのすべての短絡（接触）金属を強調表示できます。これにより、デザインのレイアウトの相互
接続品質を簡単に検査できます。また、与えられた金属トレース、経路、多角形または伝送ラインが何と接触しているか確認できます。詳細について
は、「インターコネクトの強調表示」を参照してください。

これらの機能により、マイクロ波デザイナは、重要な高周波属性を見落とすことなく、物理的接続やノード接続の妥当性を簡単に確認できます。
Physical Connectivity Engineは、デザインのレイアウトの編集中（すなわち、オンザフライでの抽出）はもちろん、デザインのオープン時（すなわち、デ
ザインのレイアウト環境へのロード中）に、物理／ノード接続情報を抽出することにより、これを実現します。接続情報の抽出はリアルタイムで実行さ
れるため、大きなデザイン・ファイルをレイアウト環境にロードするには、かなりの時間がかかる場合があります。要する時間はハードウェアの構成
や、利用可能なメモリ（接続情報の保存場所）によって異なります。

使用上の注意

Physical Connectivity Engineでは、形状およびピン・レイヤ・バインディングを適切に定義する必要があります。定義しないと、不必要な接続や間違った接続1.
を警告するメッセージが出される場合があります。
大きなレイアウト（すなわち、レティクル・レイアウト）をロードする場合は、遅延が生じる可能性があります。こうした遅延は、レイアウト接続情報のリアルタイ2.
ムでの抽出に起因します。
これらの理由から、場合によっては、Physical Connectivity Engineをオフにする必要があります。詳細および詳細な手順については、「レイアウト接続機能の
無効化」を参照してください。

レイアウト・コンポーネントの接続

コンポーネントの接続方法に関係なく、開始前にピン・スナップをオンにしてください (Options > Preferences > Grid/Snap > Pin)。性能上の問題を引
き起こすとは限りませんが、交点スナップ・モードはスナップ・モードの中でも最も低速なので、必要な場合にだけ使用してください。詳細については、
『Customization and Configuration』ドキュメントの「Setting Layout Options」のセクションの「Changing Grid and Snap Settings」を参照してください。

レイアウトの接続情報の確認

LayoutビューでCheck Designコマンドを実行することにより、デザインの特性に関する情報にアクセスできます。情報にアクセスするには、Tools >
Check Designを選択します。Check Designsダイアログが表示され、Descriptionフィールドに表示されている警告がリストされます。これらの警告は、
Check Design Optionsメニューで選択したアイテムに基づいています。Locationフィールドには、特定の警告メッセージの位置を参照するX座標とY座
標が示されます。位置番号または記述を選択すると、レイアウト上のインスタンスが強調表示されます。Auto Zoomボックスをチェックすると、警告の
位置にあるレイアウトが拡大されます。
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リストされている警告の詳細を確認するには、警告を選択してDetailsボタンをクリックします。情報ウィンドウに正確な座標、インスタンスなどがリスト
されます。

Check Design Optionsメニューにアクセスするには、Optionsボタンをクリックします。
以下のチェック・オプションがあります。

Open connectionsは、未接続のピンやワイヤの総数を表示します。未接続のピンがある各アイテムに対しては、コンポーネントの名前とID、ピン番号がリスト
されます。オープン・エンドがある各ワイヤに対しては、ワイヤ・セグメントの座標が表示されます。デザイン・ウィンドウの影響を受けたアイテムが強調表示さ
れます（デフォルトはオン）。
Nodal mismatches (layout vs schematic)は、一方の表現の他方の表現と接続の異なるコンポーネントをレポートします。レポートには、コンポーネントの名
前、接続の異なるピン、ピンの接続先がリストされます。デザイン・ウィンドウの影響を受けたコンポーネントが強調表示されます（デフォルトはオン）。
Wires in layoutは、ワイヤまたはゼロ幅トレースで相互接続されているピンに接続されているコンポーネントをすべて表示します（デフォルトはオン）。
Parameter value mismatches (layout vs schematic)は、一方の表現の他方の表現と異なるパラメータ値を持つアイテムをレポートします。レポートには、アイ
テムの名前と異なる値を持つパラメータがリストされます。デザイン・ウィンドウの影響を受けたアイテムが強調表示されます（デフォルトはオン）。
Overlaid Componentsは、コンポーネントに同数のピンが含まれ、各コンポーネントのピン1が同じ位置に配置されている、重なり合うコンポーネントのIDをレポ
ートします（デフォルトはオン）。
Shapes touch but belong to different nodesは、2つ以上の形状が重なり合っているか接触しているものの、同じノードに接続されていないケースをレポートし
ます（デフォルトはオン）。
Polygon overlaps component without overlapping a pinは、多角形またはトレースがコンポーネントに重なっているか接触しており、重なり合っているエリアに
ピンがないケースをレポートします（デフォルトはオン）。
Connection is not pin-to-pinは、コンポーネント・ピンが接続されているものの、それらのピンが同じ位置にないケースをレポートします（デフォルトはオン）。

インターコネクトの強調表示

レイアウト上のオブジェクト間の接続を表示するには、次の2つの選択肢があります。

ノード間インターコネクトの表示
物理的インターコネクトの表示

ノード間インターコネクトの表示

Tools > Check Connectivity > Show Nodal Interconnectを選択し、レイアウト内のピン、ワイヤ、トレースまたは多角形をクリックすると、同じ論理ノー
ドに接続されている現在のレベルのオブジェクトがすべて強調表示されます。ノード強調表示は、コンポーネント間のインターコネクト金属を強調表
示するのに使用します。

ノード間インターコネクトの表示ではコンポーネントは強調表示されません。
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物理的インターコネクトの表示

Tools > Check Connectivity > Show Physical Interconnectを選択し、レイアウト内のピン、トレースまたは多角形をクリックすると、階層全体の選択し
たオブジェクトに物理的に接続されているオブジェクトがすべて表示されます。物理的強調表示は、コンポーネントの一部である金属を含め、すべて
の金属を強調表示するのに使用します。物理的強調表示は、ビアを通って別のメタル・レイヤに至る接続をたどります。同じレイヤ上の形状が接触
または重なり合っている場合、または別のレイヤにビアによって接続されている場合は、オブジェクトが物理的に接続されています。

インダクタの赤い金属が、緑のメタル・レイヤの中央にビアによって接続されているため、強調表示されていることに注意してください。また、強調表示が右下のFETのデュアル・ゲートまで及んでいます。
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クロスプローブ

レイアウト内の特定のノードのスケマティック表現を表示するには、Schematic > Show Equivalent Nodeを選択し、スケマティックに表示するピン、ワ
イヤ、トレースまたは多角形をクリックします。スケマティックを表示すると、レイアウトの選択したオブジェクトのノードを表すワイヤまたはピンが強調
表示されます。

レイアウト接続機能の無効化

レイアウト接続機能の無効化は、レイヤ・バインディングが正しく設定されない場合、またはレティクルなどの大きなデザインに具体的な性能上の問
題がある場合にだけ使用します。

レイアウト接続機能を無効化するには、

ADS Main ウィンドウから、Tools > Preferenceメニュー・オプションを選択します。1.
Main Preferenceダイアログ・ボックスのEnable Physical Connectivity Engineオプションのチェックを解除します。2.

プロジェクトがオープンしている場合は、ADSは変更を保存するように求めた後で、そのプロジェクトをクローズします。オブジェクトが自動的に再びオ
ープンされます。

次の機能がスケマティックでは無効になります。

Layout > Show Equivalent Node

次の機能がレイアウトでは無効になります。

Tools > Check Connectivity > Show Nodal Interconnect
Tools > Check Connectivity > Show Physical Interconnect
Schematic > Show Equivalent Node
エッジ・ピンとエリア・ピンは無効になります（ピンとの接続だけが認識されます）。
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多角形と経路を使用した接続は認識されません（トレースとの接続だけが認識されます）。
Tools > Check Designは、次のように機能するTools > Check Representationに置き換えられます。

Tools > Check Representationを選択します。Check Representationダイアログ・ボックスで、目的の情報カテゴリを選択します。
Unconnected pinsは、未接続のピンの総数を表示します。また、未接続のピンがある各コンポーネントに対しては、コンポーネントの名前とID、未接続ピンのピン番号と座標をリストし
ます。デザイン・ウィンドウの影響を受けたコンポーネントが強調表示されます。
Nodal mismatch (layout vs schematic)は、一方の表現の他方の表現と接続の異なるコンポーネントをレポートします。レポートには、コンポーネントの名前、接続の異なるピン、ピンの
接続先がリストされます。デザイン・ウィンドウの影響を受けたコンポーネントが強調表示されます。
Wires in layoutは、ワイヤ（またはゼロ幅トレース）で相互接続されているピンに接続されているコンポーネントをすべて表示します。
Overlaid Componentsは、コンポーネントに同数のピンが含まれ、各コンポーネントのピン1が同じ位置に配置されている、重なり合うコンポーネントのIDをレポートします。
OKをクリックします。Check Representation Reportが表示され、要求した情報が表示されます。必要に応じて、Printをクリックしてレポートをプリントします。レポートをクローズするに
は、OKをクリックします。

レイアウト接続機能を再びオンにするには、Main Preferenceダイアログ・ボックスのEnable Physical Connectivity Engineオプションをチェックします。

伝送ラインの処理

デザイン作業のタイプによっては、レイアウトからデザインすることによって、かなりの時間を節約できます。これは特に、複雑な伝送ラインを含むデ
ザインに当てはまります。レイアウトに伝送ラインを作成するには、伝送ライン・エレメントを手動で配置するか、トレースを挿入して後で伝送ラインに
変換します。作成方法に関係なく、多くの編集方法があります。

伝送ラインの分割

1つの伝送ライン・エレメントを2つの等しいエレメントに置き換えることができます。

Edit > Transmission Line > Split Transmission Lineを選択します。1.
伝送ラインの基準点をクリックします。2.

伝送ライン・エレメントの置き換え

1つの伝送ライン・エレメントを2つの等しいエレメントとティーに置き換えることができます。

Edit > Transmission Line > Tap Transmission Lineを選択します。Tap Lengthダイアログ・ボックスが表示されるので、ティー・エレメントの長さを指定します。1.
タップ長を入力し、OKをクリックします。2.
MLINがタップされたかSLINがタップされたかに応じて、MTEEかSTEEが挿入されます。
伝送ラインのティー・エレメントを挿入する基準点をクリックします。3.

ヒント
ティーの3番目のピンは、カーソルに最も近い伝送ラインのエッジに配置されます。

伝送ラインの伸張

Edit > Transmission Line > Stretch Transmission Lineを選択します。1.
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伝送ラインのノードをクリックし、ポインタをエレメントから離れたところに移動します。フレキシブルな破線が表示されます。破線はポインタと一緒に動きます。2.
2番目の基準点（エレメントの伸張先）をクリックします。エレメントが新しい長さに変更されています。3.

伝送ラインの長さを保ちながらの押し込み

既存の伝送ラインを変更して、より小さなスペースに押し込むことができます。そのプロセスで、コーナ・タイプ、リード長、最小間隔などいくつかの特
性を指定できます。

必要に応じて、次の特性を調整することができます。

コーナ・タイプ：マイタ、直角、カーブから選択

：終端リードに接続されている最後の2つのセグメントの描画方向（右回りまたは左回り）

最小間隔：パラレル・トレースのセグメント間の最小間隔
マイタ・コーナのカットオフ率 (%)：コーナ・タイプMiteredの必要なカットオフ率
カーブ半径：コーナ・タイプCurveの必要なカーブ半径
リード長：開始／終了セグメントの長さ

伝送ラインを長さを保ちながらより小さなスペースに押し込む手順：

Edit > Transmission Line > Squeeze Transmission Line Keeping Lengthを選択します。表示されたダイアログ・ボックスで、必要に応じてオプションを設定し、1.
Applyをクリックします。
基準位置を入力するように促すプロンプトが表示されます。伝送ラインの一端にあるピンをクリックすると、オフセット位置を入力するように促すプロンプトが2.
表示されます。
ポインタを伝送ラインのもう一端の方向に移動します。伝送ラインのゴースト・イメージが希望どおりの場合は、クリックして変更した伝送ラインをドローイング3.
します。

経路、トレース、ワイヤの編集

このセクションで取り上げるトピックは以下のとおりです。

トレースの経路への変換
経路のトレースへの変換
既存の経路／トレース／ワイヤの属性の変更
ワイヤの伸張
ワイヤのトレースへの変換

トレースの経路への変換
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変換が一方向であるトレースの伝送ライン・エレメントへの変換と違って、経路をトレースに戻すことができます。以下の手順に従って、トレースを経
路に変えます。

目的のトレースを選択します。1.
Edit > Path/Trace/Wire > Convet Trace to Pathを選択します。2.

経路のトレースへの変換

変換が一方向であるトレースの伝送ライン・エレメントへの変換と違って、以下のようにトレースを経路に戻すことができます。

目的の経路を選択します。1.
Edit > Path/Trace > Convet Path ｔｏ Traceを選択します。2.

既存の経路／トレース／ワイヤの属性の変更

目的のトレース／経路／ワイヤを選択します。1.
Edit > Path/Trace/Wire > Path/Trace/Wireを選択します。Ｐａｔｈダイアログ・ボックスが表示されます。2.

Corner Type：Mitered、SquareまたはCurveを選択します。
Width：幅を指定します（レイアウト単位）。
Mitered Corner Cutoff Ratio (%)：カットオフの%を設定します。数が大きいほど、カットオフされるコーナの部分が多くなります。
Curve Radius：カーブ半径を指定します。
該当するフィールドに入力し、OKをクリックします。3.

ワイヤの伸張

エッジ（2つの頂点の間のセグメント）の伸張により、既存のワイヤの形状を変更することができます。

Edit > Move > Move Edgeを選択します。1.
伸張するエッジを1回クリックします。カーソルを動かすとゴースト・イメージが移動／変化し、形状がどのようにドローイングし直されるか示されます。2.
再度クリックして、新しい形状を定義します。3.

ワイヤのトレースへの変換

コンポーネントの間隔が意図的な場合は、ワイヤをトレースに変換できます。

ワイヤを選択し、Edit > Path/Trace/Wire > Edit Path/Trace/Wireを選択します。1.
表示されたダイアログ・ボックスで、必要に応じて特性を変更し、OKをクリックします。2.

ヒント
トレースは幅があるため、トレースに変換するワイヤにベンドがある場合は、その頂点の一部の最短セグメントを
3 × w/4より短くすることはできません。ここで、wはトレースの幅です（Path Widthで指定）。

コンポーネント・テキストの編集

デフォルトでは、コンポーネントをレイアウトに配置すると、そのインスタンス名（一意のID）が一緒にsilk_screenレイヤに自動的に配置されます（コン
ポーネント名はsilk_screen2レイヤに配置されます。デフォルトでは、このレイヤは非表示です）。インスタンス名が自動的に割り当てられますが、各イ
ンスタンスに対して一意のIDを維持していればインスタンス名を変更できます。

与えられたコンポーネントのインスタンス名を変更するには、次のいずれかの方法を使用します。
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スクリーン上のエディタを使用して変更する
Component Parametersダイアログ・ボックスで変更する（コンポーネントをダブルクリックするか、Edit > Component > Edit Component Parametersを選択す
る）

コンポーネントのテキスト属性（フォントおよびサイズ）を変更する手順：

コンポーネントを選択し、Edit > Component > Component Text Attributesを選択します。1.
属性を必要に応じて変更し、OKをクリックします。2.

ブール論理演算の使用法

Layoutウィンドウで、2つのレイヤの内容を比較した結果の多角形を、挿入先レイヤに挿入できます。実際に、挿入元レイヤの選択した材料が、論理
ルールに従って挿入先レイヤにコピーされます。

このセクションで説明する論理演算では、以下の手順を実行します。

挿入元レイヤと挿入先レイヤが保護されていないことを確認します (Options > Layers)。1.
Edit > Boolean Logicalコマンドを選択します。2.
表示されたダイアログ・ボックスで、ドロップダウン・リストを使用して、2つの挿入元レイヤ、実行する演算、挿入先レイヤを指定します。DIFF以外は、最初に3.
どの挿入元レイヤを識別するかは問題ではありません。「Edit > Boolean Logical > DIFF」を参照してください。

論理演算を選択した形状に適用するか、2つの挿入元レイヤ上のすべての形状に適用するか選択します。4.
Selected Shapesを選択した場合は、2つの挿入元レイヤのオブジェクトを最低1個はそれぞれ選択する必要があります。
階層全体にわたるブール演算では、インスタンスが選択されると、そこにあるオブジェクトもすべて選択されます。
元の形状を削除するかどうかを選択します。5.
階層デザインでは、デザインのトップ・レベルにある形状だけが削除されます。
トレースはデザインからは削除されませんが、ブール演算結果を作成するのに使用されます。
OKをクリックして、形状に対して選択した演算を実行します。6.

ヒント
ブール演算から形状を除外するには、形状を選択し、そのPropertiesダイアログ・ボックスをオープンし (Edit >
Properties)、Customタブで次のプロパティを追加します。
Name=DB_NO_BOOL, Value= 1, Value Type= Integer

Edit > Boolean Logical > DIFF

DIFFを使用して、最初の挿入元レイヤで選択したすべてのもののコピーである多角形を1個以上、同じx, y位置にある2番目の挿入元レイヤで選択し
た材料を取り除いて（挿入先レイヤに）作成します。実際に、システムは最初の挿入元レイヤで選択した材料をコピーし、そこから2番目の挿入元レイ
ヤで選択した材料を取り除きます。

次の各例では、挿入先レイヤの結果が右側に、挿入元レイヤと並んで示されています。このようなことはプログラムでは起こりません。プログラムで
は、挿入先レイヤのオブジェクトは、挿入元レイヤと同じx,y位置に現れます。

例1

この例では、condレイヤが最初の挿入元レイヤとして指定されています。プログラムはまず、そのレイヤの長方形をコピーします。次に（実際に）、
cond2レイヤ（2番目の挿入元レイヤ）の円がそこから取り除かれます。結果として、次のような多角形ができます。
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例2

個の例では、cond2レイヤが最初に指定されています。システムはまず、そのレイヤの円をコピーします。次に（実際に）、condレイヤの長方形がそ
れらの円から取り除かれます。cond2レイヤの最上部にある2個の円の各部だけが挿入先レイヤに現れます。そのレイヤのその他のものはすべて、
condレイヤの長方形によって定義される境界内にあります。

DIFFオプションの実際の応用例は、レイヤにホールを作成することです。この手順は以下のとおりです。

すべての形状をCondレイヤに配置します。1.
すべてのホールをHoleレイヤに配置します。2.
Edit > Boolean Logical > DIFFを選択します。3.
Booleanダイアログ・ボックスで、左から右に移動して、次のメニュー選択を実行します：Cond、DIFF、Hole、Cond。4.
Apply ToセクションのAll Shapesを選択します。5.
Delete Originalボタンを選択します。6.
OKボタンをクリックします。7.

Edit > Boolean Logical > AND

ANDを使用して、両方の挿入元レイヤの同じx,y位置にある選択したものだけのコピーである多角形を1個以上（挿入先レイヤに）作成します。システ
ムは、1つの挿入元レイヤだけに現れている材料を削除します。次の例では、挿入先レイヤには、condレイヤの長方形によって定義される境界内に
あるcond2レイヤの円の各部だけが含まれています。最上層の円の上部は、condレイヤに何もない領域にあるので、挿入先レイヤに現れていませ
ん。

Edit > Boolean Logical > OR

ORを使用して、いずれかの挿入元レイヤで選択したすべてのもののコピーをマージした多角形を1個以上（挿入先レイヤに）作成します。次の例で
は、挿入先レイヤ（1つにマージされた多角形）に、ｃｏｎｄレイヤの長方形とcond2レイヤの円がすべて含まれています。これには、cond2レイヤの最上
部にある2個の円の各部がcondレイヤの長方形によって定義される境界の外にあるにも関わらず、それら2個の円が含まれます。

Edit > Boolean Logical > XOR

ＸＯＲを使用して、1つだけの挿入元レイヤのx,y位置に現れている選択したすべてのもののコピーをマージした多角形を1個以上（挿入先レイヤに）作
成します。両方の挿入元レイヤに現れているものはすべて、実際には削除されます。

次の例の挿入先レイヤは、condレイヤの長方形によって定義される境界の外にあるcond2レイヤの最上部にある2個の円の各部が多角形に含まれ
ていること以外は、最初のDIFFの例と同じです。これらはcond2レイヤだけに現れるため、多角形に含まれています。
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クリアランスの作成

Edit > Create Clearanceを選択し、Create Clearanceダイアログを使用して、複数のマスク・レイヤ上のグランド・プレーンと形状の間のクリアランスを
定義します。

Layoutウィンドウで、異なるレイヤ上にある形状に関して、Edit > Create Clearanceを選択します。1.

注記
形状をアウトラインとして表示するには、LayersメニューからEditを選択し、Shape Displayドロップダウン・メニュー
からOutlineを選択します。

Select Planesダイアログに、グランド・プレーンの形状を選択するように促すプロンプトが表示されます。Ctrlを押したまま、複数のオブジェクトを選択します。2.
OKをクリックして続行すると、Create Clearanceメニューが表示されます。1つのオブジェクトも強調表示されなかった場合は、エラー・ダイアログが表示されま
す。

Create Clearanceメニューで、矢印ボタンを使ってClearance Layersを選択し、ラジオ・ボタンを使ってApply toする形状を選択し、Clearance Valueをレイアウト3.
単位で入力します。OKをクリックします。

結果として表示されるレイアウトには、選択したクリアランス値が反映されます。4.
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デザイン同期
スケマティック情報とレイアウト情報が同じデザイン・ファイルに入っているので、デザインのスケマティック表現とレイアウト表現について言及しま
す。ADSは、任意のデザインの等価表現を保持できます。一方の表現に変更を加え、もう一方の表現をその表現と同期させて、両者が等価になるよ
うにすることができます。同期コマンド (Generate/Update) の発行元の表現は、ソース表現と呼ばれます。また、ソース表現と一致するように自動的
に変更される表現は、ターゲット表現となります。

重要
Design Syncは、最大2個のノードに接続されているコンポーネントに対応します。場合によっては、キャパシタまた
は抵抗がマイクロストリップと並列に接続されていることもよくあります。正確なレイアウトを実現するには、こうした
ケースを無視する必要があります。ノードに接続されているコンポーネントが3つ以上ある場合は、それらのコンポー
ネントをオフにするか、コンポーネントを選択してEdit > Component > Edit Component Artworkをクリックし、Artwork
TypeをNull Artworkに設定します。

Layoutメニュー（Schematicウィンドウ）の各種コマンドを使って、スケマティックからレイアウトを作成したり、期待される方法で作成されなかったコン
ポーネントに対する手法をトラブルシューティング／変更することができます。同期プロセスは双方向なので、レイアウトからスケマティックを作成す
るための同等のコマンド・セットがSchamaticメニュー（Layoutウィンドウ）にもあります。

同期プロセス

2つの表現を同期させると、プログラムはソース表現の各コンポーネントを調べて、ターゲット表現の等価コンポーネントを変更または作成します。全
自動同期プロセスまたは増分同期プロセスが可能です。すべてのスケマティック・コンポーネントのアートワークが存在する場合は、接続されている
すべてのコンポーネントのレイアウトを一度に作成できます。ただし、コンポーネントにアートワークが関連付けられていない場合（genericアートワー
ク・プレースホルダで表される）、またはレイアウトに接合接触によって接続されていないコンポーネントがある場合は（通常はRFデザイン）、レイアウ
トを増分的に作成できます。レイアウトを増分的に作成するには、コンポーネントを一度に1つずつ、または一度に1グループずつ対話的に配置して、
トレースを使用して接続します。さらに、デュアル相互接続されたコンポーネントを挿入モード中に他方の表現に自動的に配置できる、デュアル配置



Advanced Design Systemドキュメント

51

モードもあります。

このプロセスは双方向ですが、この章の最初の部分では、スケマティックからレイアウトを作成するという観点からこのプロセスを説明します。他の
方面でのこのプロセスの使用に関する詳細については、「スケマティックの作成（レイアウト方式のデザイン）」のセクションで説明しています。

一般に、レイアウトを作成する前に以下の規定の確認を行えば、レイアウトの作成がうまく行く可能性がはるかに高くなります。

アートワークのないスケマティック・コンポーネントを識別し、アートワークを作成／割り当てる
スケマティックTジャンクション・コンポーネントが必要に応じて使用されていることを確認する
スケマティック・ステップまたはテーパー・コンポーネントが必要に応じて使用されていることを確認する
スケマティック・コンポーネントが正しく方向付けられていることを確認する
次のプリファレンスを設定する：ポート／グランド・サイズ、汎用アートワークのレイヤ、ワイヤ延長、コンポーネント・テキスト、コンポーネント・テキストのサイ
ズ／フォント

ヒント
いつでもLayoutウィンドウまたはSchematicウィンドウでアイテムを選択し、他方の表現の等価アイテムを強調表
示することができます。Layout（またはSchematic） ＞ Show Equivalent Componentを選択します。アイテムをクリ
ックします。他方の表現の対応するアイテムが強調表示されます。

同期モード

同期には完全同期と増分同期があり、スケマティックとレイアウトとの間で実行できます。

作成 更新 コンポーネントの配置

開始コンポーネントに接続されているすべてのアクティ
ブ・コンポーネント（アートワークのないアクティブ・コンポ
ーネントを含む）を配置します。

変更されたコンポーネントを配
置して、以前に作成したデザイ
ンを更新します。

他方の表現に対応するものがないアイテムを配置しま
す。

位置ステータスが固定のコンポーネントは移動されませ
ん。

位置ステータスが固定のコンポ
ーネントは移動されません。

"Current Rep only" コンポーネント配置モードを使用し
ます。

他方の表現に配置されていないコンポーネントが強調
表示されます。

  「ワイヤ・ガイド」は、他方の表現の接続状態を示してい
ます。

どのコンポーネントも開始ポイントとして使用でき、位
置、向きの指定が可能です。

  "Options > Variables"; コマンドを使用して、変数／サブ
ストレート・リファレンス用のデフォルト分解能のパスをオ
ーバライドします。

階層デザインの処理

階層デザインを処理する場合、階層デザインの最低レベルを表すサブ回路から始めて、上述のチェックリストを確認し、特定のサブ回路のレイアウト
を作成するのが最良の方法です。満足の行く結果が得られたら、階層の次のレベルに移り、このプロセスを繰り返します。すべてのサブ回路の処理
が終わったら、トップ・レベルのデザインに対してこのプロセスを繰り返します。

ハイレベル・デザインに定義されている変数またはインスタンスを参照するパラメータを1つ以上有するサブ回路のアートワークを作成する場合は、
階層内のトップ・デザイン、あるいはトップ・デザインからそのサブ回路まで階層を下へとたどるパス（インスタンス名による）を識別する必要がありま
す。トップ・デザインからのパスは、パラメトリック・サブ回路のVAR、サブストレートまたはパラメータの間のあいまいさを解決できるだけの深さがなけ
ればなりません。

実際の変数値の位置を指定するには、Options > Variblesを選択します。
Top Design in Hierachy：サブ回路が属する階層内のトップ・レベルのデザインの名前を入力します（またはブラウザを使用します）。
Representation：レイアウトだけのデザインを処理する場合は、Layoutだけを選択します。
Component Path (Instance Name) to Variable Values：次の指針に従って、適切なパスを決定してください。

変数がトップ・デザインのVARアイテムで宣言されている場合は、このフィールドは空白にしておきます。
変数がトップ・デザインから階層をずっと下ったところにあるVARアイテムで宣言されている場合は、現在のデザインを検出するために挿入する必要のあるイ
ンスタンス名（トップ・デザインに表示）で始まり、その後に現在のデザインを検出するために挿入する必要のある次のインスタンスの名前などが続くパスを指
定します。インスタンス名はピリオドで必ず区切ってください（例：X1.X2）。
式にパラメータ値を使用するパラメータ・サブ回路のアートワークを作成するには、フル・パス名を指定してあいまいさを回避する必要があります。
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アートワークのないコンポーネントの識別

レイアウトを作成する前に、アートワークが定義されていないコンポーネントがないか確認して、アートワークを作成するか、既存のアートワークをコ
ンポーネントに関連付ける必要があります。

アートワークのないコンポーネントを識別する手順：

Schematicウィンドウから、Layout > Show Components With No Artworkを選択します。アートワークが関連付けられていないコンポーネントがすべて強調表1.
示され、強調表示されているアイテムのアートワークを選択するか尋ねる確認ダイアログ・ボックスが表示されます。

Yesをクリックすると、アートワークのないコンポーネントのうちの1つのインスタント名が表示されたダイアログ・ボックスが表示され、アートワークの種類を選2.
択することができます。
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ヒント
後で戻って、与えられたコンポーネントのアートワークの関連付けを変更するには、コンポーネントを選択し、Edit
> Component > Edit Component Artworkを選択します。

目的のアートワークの種類と名前を選択し、Applyをクリックしてアートワークを関連付けます。3.
コンポーネントのcreate_item() 定義で指定したデフォルトのアートワークをダイアログ・ボックスに表示するには、Defaultを選択します。
別のデザイン・ファイルを指定／使用してコンポーネントのアートワークを表現するには、Fixedを選択します。
ピンだけでアートワークのないコンポーネントを作成するには、Null Artworkを選択します。

ヒント
集中定数コンポーネントでレイアウト・スペースが占有されないようにするには、Null Artworkタイプを使用します。
パッドを有する集中定数コンポーネントにするには、Lumped With Artworkコンポーネント・パレットからコンポーネ
ントを選択します。

アートワークの関連付けがすべて完了するまで、このプロセスを繰り返します。4.

スケマティックでのTジャンクションの使用法

複数の伝送ラインによってTジャンクションが形成される場合、ティー・コンポーネントの1つが必要です。

間違ったダイアグラムのように、3つのレイアウト・コンポーネントがティー・コンポーネントを使用せずに結合されている場合、それらのコンポーネント
は作成されたスケマティックではワイヤで接続されます。これらのワイヤの長さは、Generate/Updateダイアログ・ボックスからアクセスする
Preferencesダイアログの設定に基づきます。ティー・コンポーネントの使用は、レイアウトに重要であるだけでなく、相互接続された伝送ラインを正し
くシミュレーションするためにも重要です。

スケマティックでのステップ／テーパーの使用法

ステップ／テーパー・コンポーネントを使用して、伝送ラインの幅を変化させる必要があります。マイクロストリップ／ストリップラインのレイアウトの一
般的な誤りは、以下の図のように、トランジション・コンポーネントを使用せずに幅の異なる2種類の伝送ラインを接合することです。

不連続部を特定するには、2つのコンポーネントの間にテーパー・コンポーネントかステップ・コンポーネントを挿入する必要があります。

ステップ・コンポーネントによって長さが増えることはありませんが、不連続部がシミュレーションで確実に特定されます。
テーパー・コンポーネントは長さがあります。伝送ラインの幅の漸進的な変化を記述するのに使用してください。
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ギャップや終端効果など、シミュレーションで特定できる不連続部は、この他にも数多くあります。デザインに関連するコンポーネントのリストについて
は、ドキュメント『Introduction to Circuit Components』を参照してください。

スケマティック・コンポーネントの向きの確認

レイアウトを問題なく作成するには、すべてのスケマティック・コンポーネントの向きを正確に合わせる必要があります。テーパー2の向き（下側の図）
が間違っている場合、結果として作成されるレイアウトに違いがあることがわかります。

ピン1は常に小さなチック・マークによって確認されますが、Options > Preferences > Pin/TeeによってPin Numbersをオンにすることにより、ピン番号
をすべて確認できます。

プリファレンスの設定

レイアウトを作成するために制御できる設定はこの他にも数多くあります。

ポート／グランドのサイズ
汎用アートワーク、ワイヤ延長、コンポーネント・テキストをドローイングする必要のあるレイヤ
コンポーネント・テキストのフォントおよびサイズ

デザインに合わせてこれらのオプションを調整するには、次の手順に従って作成または更新します。

Schematicウィンドウから、Layout > Generate/Update Layout > Preferfencesを選択します（このダイアログ・ボックスの残りのフィールドについては、「レイア1.
ウトの作成」で説明しています。
必要に応じて、任意のオプションまたはすべてのオプションを変更し、OKをクリックします。2.

レイアウトの作成

一次検査を実行し、その結果に基づいて推奨される措置を講じたら、いつでもレイアウトを作成できます。次に示されている伝送ラインを使用して、
プロセスを説明します。



Advanced Design Systemドキュメント

56

スケマティックから自動的にレイアウトを作成する手順：

Layoutウィンドウを開き、SchematicウィンドウからLayout > Generate/Update Layoutを選択します。1.
この例では、Starting ComponetフィールドにP1（ポート1）と示されています。これを変更するには、Schematicウィンドウで別のアイテムをクリックします。
Equivalent Componentフィールドは空で、等価コンポーネントがまだ（レイアウトに）作成されていないことを示しています。さらに、スケマティック内のコンポー
ネントがすべて強調表示され、それらをすべて作成する必要があることを示します。

ヒント
Generate/Update Layoutを選択してアイテムが強調表示された場合は、そのアイテムを作成、再生、または位置
変更する必要があることを示します。

OKをクリックすると、レイアウトが作成されます（最初の図を参照）。2.
Generate/Updateダイアログ・ボックスの詳細を以下に示します。

Starting Component：プログラムはこのアイテムから開始し、アートワークを持つ相互接続されたコンポーネントがすべて作成／更新されるまで、ポート／ピン
1を通って次に接続されているコンポーネントに進みます。デザイン内のアイテムをクリックして、デザイン同期プロセスの開始ポイントとして指定します。
Equivalent Component：情報のみ。他方の表現のそのアイテムに対応するものが、このフィールドに表示されます（存在する場合）。
Status：情報のみ。



Advanced Design Systemドキュメント

57

not created：開始コンポーネントに相当するものが、まだターゲット表現に作成されていません。
positioned：開始コンポーネントがレイアウトに配置されています。

X-Coordinate, Y-Coordinate, Angle：Schematicでコンポーネントを選択し、等価アイテムが作成された場合、これらのフィールドには、等価アイテムの座標
（角度を含む）が表示されます。等価アイテムが作成されなかった場合は、デフォルト位置 (0,0) をそのまま使用してプログラムが配置できるようにするか、目
的の座標を入力します。デフォルトでは、ソース表現での回転角度が表示されます。これを受け入れるか、必要に応じて変更します。

上の例では、ピン角度は、レイアウト表現ではなく、スケマティック表現の場合です。
プログラムは、スケマティックの各コンポーネントのアートワークを作成することにより、レイアウトを作成します。スケマティックからプロセスを開始した場合、
アートワーク・コンポーネントは、与えられたX,Y位置に与えられた角度で配置されます。その後の各コンポーネントは、接続コンポーネントの角度によって決
まる角度に、そのピンに対して指定されている角度を加えた角度に配置されます。

上の例Aでは、M1の角度は0、ピン2（右側）の角度は0なので、M2はM1の右側に0度の角度で配置されます。
例Bでは、M3のピン2（上）は90度にあるので、M4は90度で接続されています。
例Cでは、M3は20度の角度で配置されているため、M4は110度 (90＋20) で配置されています。

ADSで提供されるアートワークはすべて、各ピンの角度が適切なトポロジーを作成するようにプリセットされています。ただし、より良いレイアウトを作
成するには、コンポーネントを反転／回転させなければならない場合もあります。これにより、スケマティックに影響が及ぶことはありません。

オプション
Delete equivalent components in Layout that have been deleted/deactivated in Schematic：このオプションを選択すると、デザイン同期プロセスで、どちらの表現にも表示されないタ
ーゲット表現のアイテムが自動的に削除されます。これにより、表現が現在の表現と一致するようになります。
Show status report：このオプションを選択すると、デザインの同期後にステータス・レポートが表示されます。このレポートには、変更されたアイテムの数、処理されたアイテムの数、
作成されたトレース・サブ回路の名前（自動トレース変換が指定された場合）が含まれます。
Fix starting component's position in Layout：このオプションを選択した場合、開始コンポーネントの位置が固定に設定されるため、その後の同期で自動的に変更されることはありませ
ん（ただし、手動で移動することはできます）。
Fix all components in Layout during Generate/Update：このオプションを選択すると、レイアウト（スケマティック）の既存のコンポーネントはすべて現在の位置に残ります。このオプショ
ンを選択しないと、同期プロセスによって、既存のコンポーネントが新たに配置したコンポーネントに隣接するように移動されます。このオプションは、レイアウト／スケマティックのゴー
ルを満たすためにコンポーネント位置を調整し、既存のレイアウト／スケマティックを乱すことなく他の変更を同期させたい場合に、最も有効です。

ヒント
Preferencesダイアログ・ボックスのDisplayタブを使用して（Options > Preferences）固定コンポーネントの表示
色を定義することにより、固定位置のコンポーネントをすばやく確認できます。

Preferences：目的のスケマティック／レイアウトを作成するのに役立つさまざまな設定にアクセスできます。

From Layout to Schematic
Length in X-Direction：レイアウトの等価アイテムが接合接触によって接続 されている場合、スケマティックのコンポーネントの間にドローイングされる水平ワイヤの長さ。
Length in Y-Direction：レイアウトの等価アイテムが接合接触によって接続 されている場合、スケマティックのコンポーネントの間にドローイングされる垂直ワイヤの長さ。
Component Text Font/Size：コンポーネント・テキストに適用されるフォントおよび サイズ。

Variables：レイアウトを作成するサブ回路が参照する変数の実際の値が含まれているデザイン／インスタンスを識別するのに使用します（それらの変数を含
むデザインが、階層的に関係付けられているかいないかに関わらず、サブ回路より階層の下位レベルにある場合）。
Trace Control：レイアウトのトレースを解釈するための詳細を指定するためのダイアログ・ボックスにアクセスできます。

Simulate As：次のいずれかを選択します：Transmission line elements、Single transmission line element（フィールドにエレメントを指定します。デフォルトではMLIN）、Nodal connection
(short)。
Element Set：次のいずれかを選択します：Microstrip、Stripline、Printed circuit board。
Substrate References：トレースを伝送ラインとしてシミュレートする場合に参照されるサブストレート・アイテムのインスタンス名。

エレメント・セット サブストレート・リファレンス

Microstrip MSUB

Stripline SSUB

Printed circuit board PCSUB

From Schematic to Layout
Length in X-Direction： 3方接続に使用されるワイヤを接続するためのX方向の長さ。
Length in Y-Direction： 3方接続に使用されるワイヤを接続するためのY方向の長さ。
Component Text Font/Size：コンポーネント・テキストに適用されるフォントおよび サイズ。
Generic Artwork Size：スケマティック・コンポーネントにアートワークが関連付けられていない場合、レイアウトに描かれるボックスの長さ（Xはそこを通って描かれます）。
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Port/Ground Size：レウィンドウアウト表現に描かれるポート／グランド・シンボル（矢印）のサイズ。
Entry Layer：汎用アートワーク／ワイヤ延長を描くエントリ・レイヤ。

定位置に置かれていないコンポーネントの配置

定位置に置かれていないコンポーネントは、他方の表現に相当するものがないアイテムです。同期プロセス中に直列キャパシタなどのアートワーク
のないコンポーネントが検出されると、シンクロナイザは汎用アートワーク・ボックスを所定の位置に配置します。アートワークを作成／これらのコン
ポーネントに割り当てたら、以下の手順に従って、同期プロセスを再度開始したり、これらの残りのコンポーネントを1つずつ個別に他方の表現に対
話的に配置できます。

Layout > Generate/Update Layoutをもう1度選択して開始アイテムなどの最初の定位置に置かれていないアイテムを使用するか、すでにレイアウトに存在し
ている他のコンポーネントを選択する。このモードでは、ピンの接合接触によって、アートワークが自動的に配置されます。
Layout > Placements From Schem To Layoutコマンドを使用する（これはRFデザインに適した方法です）。このモードでは、アートワーク間に任意の距離を置
くことができます。

Place Components From Schem To Layoutコマンドを使用すれば、アイテムを一方の表現から他方の表現に対話的に配置 できます。この方法での
アイテムの配置は、ライブラリ／パレットからのアイテムの配置と異なることに留意することが重要です。アイテムがライブラリ／パレットから配置され
た場合、デザイン同期が再実行されるまで、等価アイテムとの関連付けは実行されません。

定位置に置かれていないアイテムを探す手順：
Layout > Show Unplaced Componentsを選択します。定位置に置かれていないコンポーネントが強調表示されます。

定位置に置かれていないコンポーネントを配置する手順：

Layout > Place Components From Schem To Layoutを選択し、強調表示されているコンポーネントの中の配置するコンポーネントをクリックします。1.
ポインタをLayoutウィンドウに移動します。接続ポイントを識別するワイヤ・ガイドに加えて、アイテムのゴースト・イメージがポインタと一緒に動きます。アイテ2.
ムの位置を決めて、クリックします。

次の図では、点線の1つがワイヤ・ガイドを表し、アートワークおよびポインタと一緒に動きます。

Design Differencesダイアログの使用法

Design Differencesダイアログ・ボックスでは、ADSスケマティックとレイアウトの間のコンポーネントをよりうまく管理できます。Design Differencesダイ
アログ・ボックスを使用することにより、デザインを選択して、デザインのスケマティックとレイアウトの違いをすばやく確認することができます。これら
の違いが確認されると、ダイアログにはアクション指向のリストが表示されるので、以下を管理できます。

Components not in layout
Components not in schematic
Parameter Differences
Nodal Mismatches

SchematicウィンドウからDesign Differencesダイアログにアクセスするには、

Layout > Place Components From Schem to Layoutを選択するか、Layout > Design Differencesを選択します。Design Differencesダイアログ・ボック
スが表示されます。

LayoutウィンドウからDesign Differencesダイアログにアクセスするには、

Schematic > Place Components From Layout to Schemを選択するか、Schematic > Design Differencesを選択します。Design Differencesダイアログ
・ボックスが表示されます。

Components not in layout
スケマティックにあってレイアウトにないコンポーネントは、Design DifferenceのComponents not in layout拡張リストに示されます。このリストのコンポ
ーネントをクリックすると、クリックしたコンポーネントが強調表示されるので、スケマティック内のそのコンポーネントをすばやく識別できます。選択す
ると、コンポーネントは配置モードになるので、カーソルをレイアウトに移動し、目的の位置でマウスをクリックすることにより、コンポーネントをレイア
ウト上に配置することができます。

マウスを右クリックした場合、ポップアップ・メニューが表示され、次のオプションが示されます。

Place Unplaced Component：上述の配置モード と類似
Delete Component：スケマティックからコンポーネントを削除する
Details：未完成のコンポーネントの詳細を表示する
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Components not in schematic
レイアウトにあってスケマティックにないコンポーネントは、Design DifferenceのComponents not in schematic拡張リストに示されます。このリストのコ
ンポーネントをクリックすると、クリックしたコンポーネントが強調表示されるので、レイアウト内のそのコンポーネントをすばやく識別できます。選択す
ると、コンポーネントは配置モードになるので、カーソルをスケマティックに移動し、目的の位置でマウスをクリックすることにより、コンポーネントをス
ケマティック上に配置することができます。

マウスを右クリックした場合、ポップアップ・メニューが表示され、次のオプションが示されます。

Place Unplaced Component：上述の配置モード と類似
Delete Component：レイアウトからコンポーネントを削除する
Details：未完成のコンポーネントの詳細を表示する

Parameter Differences
このオプションをクリックすると、レイアウトとスケマティックの両方のコンポーネントが強調表示されるので、当該コンポーネントをすばやく識別して、
パラメータの違いを補正することができます。

マウスを右クリックした場合、ポップアップ・メニューが表示され、次のオプションが示されます。

Use Schematic Value <parm name> = <value>：スケマティック値をレイアウト・コンポーネント・パラメータに割り当てる
Use Layout Value <parm name> = <value>：レイアウト値をスケマティック・コンポーネント・パラメータに割り当てる
Details：パラメータの不一致の詳細を表示する

Nodal Mismatch
このオプションをクリックすると、スケマティックとレイアウトの両方の未接続のコンポーネントが強調表示されるので、当該コンポーネントをすばやく
識別して、不一致を補正することができます。

マウスを右クリックした場合、ポップアップ・メニューが表示され、次のオプションが示されます。

Details：ノードの不一致の詳細を表示する

注記
システムの限界により、スケマティック上のアイテムを参照するレイアウト・コンポーネントは、スケマティックに関して
は同期がずれて、Design Differenceリスト（MSUB、SMT_Art、変数を参照するコンポーネントを含む）に表示されな
い可能性があります。

Auto Zoom

Component placement (not in layout or schematic)：コンポーネントをウィンドウの中心に配置し、必要に応じてズームアウトする。コンポーネントのないスケ
マティック／レイアウト・ウィンドウについては、何の変化もありません。
Parameter mismatch：パラメータが一致していないコンポーネントをスケマティック／レイアウト・ウィンドウの中心に配置し、必要に応じてズームアウトする。
Nodal mismatch：ノードが一致していないコンポーネントをスケマティック／レイアウト・ウィンドウの中心に配置し、必要に応じてズームアウトする。

Auto Update

Auto updateがアクティブの場合：デザインが編集されると、Design Differencesダイアログ・ボックスが自動的に更新されます。
Auto updateがオフの場合：Design Differencesダイアログ・ボックスのリスト内の固定アイテムがマークされます。Updateボタンをクリックして、リストから補正
済みのアイテムをクリアします。

コンポーネント位置の固定および解放

SchematicウィンドウとLayoutウィンドウ内のアイテムはすべて、それらの位置に応じて固定またはフリー状態にあります。アイテムの位置が固定さ
れている場合（ターゲット表現）、デザイン同期プロセス中にプログラムによって位置を自動的に変更することはできません。アイテムの位置がフリー
の場合、プログラムによってそのアイテムの位置を変更することもできます。関連する基本動作を理解すれば、デザインを手動で作成したり、表現を
別の表現から作成することができます。

Schematicウィンドウに手動で配置されたアイテムは固定されています。レイアウトに変更を加え、固定アイテムが含まれているスケマティックを更新した場
合、固定アイテムの位置は変わりませんが、接続を維持するために配線し直される場合があります。
デザイン同期プロセス中にSchematicウィンドウに作成されたアイテムはフリーです。ただし、スケマティックのアイテムを手動で移動した場合は、プログラム
はそのアイテムの位置を自動的に固定と見なし、その後の同期でそのアイテムの位置を変更することはありません。
Layoutウィンドウに手動でまたはデザイン同期プロセス中に配置されたアイテムはフリーなので、その状態を維持する必要があります。ただし、レイアウトに
プログラムによる位置の変更を望まないクリティカルな部分または完成した部分があることもあります。この場合は、それらのアイテムを固定と明示的に設定
することができます。Schematicウィンドウのアイテムを移動するのと違って、Layoutウィンドウのアイテムを移動してもフリー状態であることに変わりはありま
せん。
Place Components Fromコマンドで配置したアイテムは固定コンポーネントで、ターゲット表現に配置した場合もソース表現の向き角度は維持されます。
デザイン同期プロセス中にいずれかの表現に配置されたアイテムは、ソース表現で固定されている場合は、ソース表現の向き角度が維持されます。

次のコマンド（LayoutメニューとSchematicメニューに存在）を使用すれば、コマンドの発行元のウィンドウを基準にして、コンポーネントの固定状態と
フリー状態の関係を識別／変更することができます。

Show Fixed Components：固定状態にあるコンポーネントをすべて強調表示する。
Fix Component Position：デザイン同期プロセスによって、コンポーネントの位置が自動的に変更されないようにする。
Free Component Position：デザイン同期プロセスによって、コンポーネントの位置が自動的に変更されるようにする。

コンポーネントの強調表示
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Layout > Generate/Update Schematicを選択すると、デザイン同期プロセス中に作成／再生されたコンポーネントがすべて強調表示されます。この
時点では、次の条件に1つ以上適合するコンポーネントが強調表示されます。

レイアウトに等価アイテムのないスケマティック・コンポーネント。
コンポーネントが最後に同期されてから以降、1つ以上のパラメータ値が更新されたコンポーネント。
コンポーネントが階層的な場合は、最後の同期以降にサブデザインが変更されたコンポーネント。
最後の同期以降に変更されたコンポーネントに接続されているコンポーネント。
1つ以上のパラメータに変数または式を使用するコンポーネント。
コンポーネントが階層的な場合は、サブデザインの1つ以上のコンポーネントに変数または式が含まれているコンポーネント。
SMTアートワークを含むコンポーネント。

コンポーネントまたはコンポーネントのサブデザイン（階層的な場合）のパラメータに変数または式が含まれている場合、またはコンポーネントにSMT
アートワークが含まれている場合、そのコンポーネントは常にデザイン同期中に再生されます。したがって、これらのコンポーネントは常に強調表示
されます。

デュアル表現モード

スケマティックまたはレイアウトから作業しているときは、アイテムが両方の表現に同時に配置されるのが望ましい場合があります。これには、
Options > Preferences > Placementで表示されるデュアル配置モードまたは同期モードを使用します。

Single Representation (schematic OR layout)
一方の表現にアイテムを配置しても、他方の表現には何も自動的に配置されません。
Dual Representation (schematic AND layout)
一方の表現にアイテムを配置し、他方の表現用のウィンドウにポインタを移動した場合、等価コンポーネントはすでに選択されています。ポインタを必要に応
じて位置付け、クリックして配置します（同じデザインが含まれている他方の表現用のウィンドウがオープンしていない場合は、自動的にオープンされます）。
Always Design Synchronize (schematic AND layout)
各部分が配置されるたびにプログラムが両方の表現をフル同期させるため、すべての部分が完全に相互接続されます。これにはデュアル表現モードより時
間がかかります。また、接続性を維持するために、スケマティックのレイアウトが移動／変更される場合があります。

注記
2番目 (Dual) と3番目 (Always) のモードは、挿入モードで動作するように設計されています（コンポーネントの配
置中）。コンポーネントの挿入時に編集が必要な場合は、これら2つのモードはお勧めできません。

スケマティックの作成（レイアウト方式のデザイン）

レイアウトからスケマティックを作成するには、スケマティックからレイアウトを作成するのと同様の手順に従います。レイアウトを変更したら、変更さ
れたパラメータ値を同じようにスケマティックにバックアノテートできます。

レイアウト・アイテムをパレットまたはライブラリ・リストから選択し、Layoutウィンドウに配置／相互接続することができます。レイアウト・コンポーネン
トのライブラリが作成され、スケマティック・アイテムやシミュレータ・アイテムに関連付けられたら、既存のパレットまたは新しいカスタム・パレットに追
加できます。詳細については、「エレメントの作成」を参照してください。

レイアウトからスケマティックを作成する手順：

Layoutウィンドウをオープンします。1.
次の例のように、Layoutウィンドウでレイアウト・デザインを作成します（ライブラリ／パレットからアイテムを配置し、ピンを接触接続するかトレースと接続して2.
相互接続します）。

注記
サブストレート・アイテムを参照するLayoutウィンドウにアイテム（SLINなど）を配置するにはまず、Schemathicウィ
ンドウにそのサブストレート・アイテムを配置する必要があります。

Layoutウィンドウから、Schematic > Generate/Update Schematicを選択します。ダイアログ・ボックスが表示され、レイアウト内のすべてのアイテムが強調表3.
示され、それらのアイテムを他方の表現に作成、更新または移動する必要があることを示します。
デフォルトの開始コンポーネント（この例ではC1）をそのまま使用するか、レイアウト内の別のアイテム（プログラムにスケマティックを作成するための開始ポイ4.
ントとして使用させたいアイテム）をクリックします。
Preferencesをクリックし、スケマティックのアイテム間の水平間隔と垂直間隔を指定し、OKをクリックします。5.



Advanced Design Systemドキュメント

61

Schematicウィンドウの等価アイテムの位置と角度を指定し、OKをクリックします。Schematicウィンドウに等価スケマティックが表示されます。6.

注記
Schematic > Generate/Update Schematicコマンド用のMomentumレイアウト・コンポーネントを作成する場合は、
Create Layout ComponentダイアログのAdd reference pinチェック・ボックスの選択を解除する必要があります。
詳細については、『Layout Components for Momentum』のセクションを参照してください。

RF PCBのデザイン上の注意事項

多くのRF PCBアプリケーションでは、レイアウトに対話形式で取り組む必要があります。通常は、レイアウトの開始前に、スケマティックが作成／シミ
ュレートされます。Design Environmentでは、スケマティックの作成前、作成中、作成後を問わず、いつでもレイアウトを作成できます。90,000の大規
模なパーツ・ライブラリが付属しており、さまざまなパッケージ・パーツ・アウトラインやマウント・フットプリントのパーツが数多く用意されています。

レイアウト・ツールには、PCBのレイアウトに対応するように特別に設計された多数の機能があります。以下にその例を挙げます。

大規模で包括的なパーツ・ライブラリ
システム／回路レベルのシミュレーションとの完全統合
対話型配置モード
コンポーネント・パラメータの自動フォワード／バック・アノテーション
ラッツ・ネスト接続表示
レイアウト対スケマティック・チェック
トレース・ルーティング／階層化伝送ライン・シミュレーション
簡略化されたライブラリ・パーツの作成
拡張可能なBOM、パーツ・リスト、ピック・アンド・プレイス出力
オプションのGerber、DXF、IGES出力
Mentor社のボード／ハイブリッド・ステーションとの統合（オプション）

ボードの作成、システムのセットアップ

デザイン中のPCBのボードのアウトラインを描くか、インポートする必要があります。PCBボードのレイアウト用に、多くのレイヤがあらかじめ定義され
ています。シルクスクリーン層は、テキストやその他のシルクスクリーン情報を配置するために定義されています。pcb1〜9のレイヤは、トレースを使
用したトレース・ルーティング（PCB伝送ライン・コンポーネント）用の識別子です。必要に応じて、他のレイヤを使用／定義することができます。多層
PCB伝送ライン・コンポーネントには9つの導体層という制限がありますが、定義できるレイヤの数には制限はありません。

対話形式のレイアウト、手動レイアウト

コンポーネントは、デザインのどの時点でもレイアウトに配置できます。パーツをレイアウトに配置するには、スケマティックの場合と同様に、パレット
またはライブラリから選択して、ボード上に配置します。標準的なSMTパーツやその他のパッケージ・パーツのほとんどは、ライブラリ・リストから選択
されます。

パーツをボードの底面に移動したり、鏡映反転させて底に配置することができます。スケマティックを作成してPCBをデザインする場合は、各パーツ
のレイアウトに等価アイテムがあることを確認します。CAP、RESなどの理想コンポーネントに対しては、それらのコンポーネントのLumped-with
Artworkバージョンを使用してレイアウトで考慮します。

パーツをスケマティックから直接配置することもできます。その利点は、スケマティックとレイアウトの同期を維持できることです。ライブラリまたはパレ
ット・リストを使ってスケマティックにアイテムを配置し、同様の方法でレイアウトに等価アイテムを配置した場合、両者は同期されないので注意してく
ださい。レイアウトとスケマティックの同期を維持するには、Generate/Update機能を使用して一方の表現を他方の表現から自動的に作成するか、対
話形式での配置によって一方の表現を他方の表現から増分的に作成する必要があります。

自動デザイン同期

デザイン同期機能 (Generate/Update) を使用することにより、相互接続されたスケマティックからレイアウトを自動的に作成することができます。この
コマンドにより、スケマティックの各コンポーネントが取り込まれ、相互接続されたピンが接合接触するようにレイアウトに配置されます。この機能は
スケマティックで特定された伝送ラインの不連続部がすべて含まれているマイクロ波デザインには非常に有効ですが、トレースを使用する相互接続
が多いPCBのレイアウトでは、通常は満足の行く結果が得られません。ただし、後で適切な位置に移動できるコンポーネントの初期配置が得られま
す。

対話形式の配置

通常は、スケマティックからレイアウト、またはその逆にパーツを対話的に配置するのが、PCBレイアウトを作成するための最も実用的な方法です。
Place Components From Schem To Layout（またはLayout to Schem）コマンドは、一方の表現のパーツを選択して他方の表現に配置するのに使用
します。
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このコマンドでは、ソース表現のコンポーネントを選択してターゲット表現に配置するように促すプロンプトが表示されます。Schematicウィンドウから
開始した場合は、スケマティック・コンポーネントをクリックしてからカーソルをLayoutウィンドウに移動するように促すプロンプトが表示されます。パー
ツのゴースト・イメージがカーソルと一緒に移動することがわかります。パレットの矢印ボタンを使用して、パーツを回転させてから配置することができ
ます。マウスの左ボタンをクリックすると、スケマティックと同じパラメータ値を使用して、パーツが配置されます。

ワイヤ・ガイドが表示され、各コンポーネントを接続すべき場所が示されます。これらのラインは、Schematic > Show Connected Componentsコマンド
を使って再表示することができます。このコマンドでは、ソース表現を基準とする、未接続の各ピンの相互接続状態を示す接続図（ラッツ・ネスト）が
表示されます。これらのラインを削除するには、Clear Highlighed Componentsを使用します。

Schematic > Place Components From Schem To Layout（またはLayout to Schem）コマンドは、ターゲット表現に配置されていない基準表現のコンポ
ーネントをすべて強調表示します。強調表示を削除するには、Clear Highlighted Componentsコマンドを使用します。

固定パーツ配置とバックアノテーション

パーツがレイアウトに配置される場合、フリー・コンポーネントとして配置されます。すなわち、デザイン同期が実行されている場合は、最低1つのピン
が相互接続されているコンポーネントと接合接触するようにパーツの位置が変更されます。この方法はマイクロ波デザインの同期には適しています
が、通常はPCBコンポーネントには適していません。

パーツをPlace Components From Schem To Layout（またはLayout to Schem）コマンドを使って配置した場合、パーツは固定コンポーネントとして配
置されます。すなわち、デザイン同期が実行されている場合はパーツの位置は変更されません。ただし、何か他の方法で配置した場合は、フリー・コ
ンポーネントとして配置されるため、固定に設定する必要があります。レイアウトの配置コンポーネントの状態を確認するには、Schematic > Show
Fixed Componentsを選択します。これにより、各固定コンポーネントが強調表示されます。強調表示されていないコンポーネントについては、それら
のコンポーネントを選択し、Schematic > Fix Component Positionを使用して位置を固定します。

コンポーネントの配置が済んだら、プログラムのデザイン同期機能を使用して、一方の表現のパラメータの変更を他方の表現で維持することができ
ます。このため、レイアウトのキャパシタの値を変更した場合は、Layoutウィンドウからデザイン同期を実行することにより、この変更をバックアノテー
トすることができます。配置されていないコンポーネントまたは変更値があるコンポーネントがそれぞれ強調表示されます。ダイアログ・ボックスのOKま
たはApplyをクリックすると、ターゲット表現の強調表示されているパーツが更新されます。

トレース・ルーティング

接合接触だけでパーツを接続したくない場合は、トレース（またはワイヤ）をパーツに適用することができます。

レイアウトとスケマティックのノードの不一致

Tools > Check Designを使用して、Nodal mismatches (layout vs. schematic)オプションを選択することにより、デザイン・プロセス中にいつでもレイア
ウトとスケマティックを比較できます。これにより、ターゲット表現の接続をソース表現と比較するレポートが作成されます。未完成のコンポーネント、
または一方の表現の他方の表現と接続の異なるピンがレポートされます。

注記
このオプションは、スケマティックに等価アイテムがあるレイアウト・アイテムでレイアウトが構成されるデザインに有
効です。このオプションは任意形状には有効ではありません。また、デバイス抽出も実行しません。複数のエリアで
誤って接続されている複雑なレイアウトの場合、両方の表現からこのコマンドを実行することにより、不一致の原因
を簡単に特定できます。このコマンドとLayout > Show Unplaced Components、Show Equivalent Component、Show
Connected Componentsコマンド組み合わせて使用すれば、通常は、ほとんどの不一致の問題は解決できます。

トレース・シミュレーション

多くの高周波PCBデザインでは、伝送ラインの影響が重大になるため、シミュレーションで特定する必要があります。Layoutでは、トレースをシミュレ
ーション用の伝送ラインコンポーネントに明示的に変換したり、明示的に変換せずに伝送ラインとしてトレースをグローバルにシミュレートすることが
できます。詳細については、「レイアウトの作成」のセクションの「トレースの処理」を参照してください。

ミアンダ・トレース・シミュレーション

ミアンダ・コンポーネントは、MLIN電気モデルを使ってシミュレートされます。ベンドの影響を考慮するためには、トレース（ライン、ベンド、ティーに分
解可能）、またはMLIN、MBEND、MTEEを直接使用します。

レポートの作成

部品表 (BOM) またはパーツ・リスト（ピック・アンド・プレイス情報を含む）を作成するには、File > Reportsを選択します。これらのレポートの作成に
は、de_bomおよびde_parts AEL機能を使用します。レポートはカスタマイズすることもできます。詳細については、『Customization and Configuration』
ドキュメントの「Setting Layout Options」のセクションの「Pick and Place Report」を参照してください。
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PCBレイアウトのエクスポート

ほとんどのPCBレイアウトは、Gerber出力によって作成されます。Gerberは、MTOOLS Gerberトランスレータ（オプション）によってサポートされていま
す。このデザイン環境は、マスク・ファイルを経由してGerberトランスレータとインタフェースをとります。マスク・ファイルには1つ以上のレイヤを含める
ことができます。デザインのエクスポートはすべて、LayoutウィンドウでFile > Exportを選択することによって実行されます。概要については、「レイア
ウトのインポートおよびエクスポート」を参照してください。詳細については、『Importing and Exporting Designs』ドキュメントを参照してください。

パーツおよびライブラリの作成

PCBディスクリート・コンポーネントの大規模なライブラリが用意されていますが、目的のコンポーネントやそれらのレイアウト・フットプリントを見つけ
出せない場合もあります。ただし、複数の方法で新しいアイテムを定義することができます。詳細については、「エレメントの作成」を参照してくださ
い。レイアウト・オブジェクトも数多く用意されています。非電気アイテムについては、スケマティックのことを考えずにレイアウトに直接配置できます。
電気アイテムについては、レイアウトに既定義のレイアウト・オブジェクトを使用する新しいアイテムを作成したり、CAPやS2Pなどのギャップのアート
ワークが等価な理想コンポーネントを使用することができます。ギャップを指定して、レイアウト・オブジェクトを挿入することができます。

アートワーク
どのようなアイテムに対しても、アートワーク表現を作成できます。レイアウトで表現する与えられたアイテムのアートワークを定義するには、いくつ
かの方法があります。通常は、アートアークは以下のいずれかに分類されます。

固定アートワーク
AELアートワーク・マクロ

どちらのタイプのアートワークでも、多くのアートワークが提供されます。また、カスタム・アートワークを作成することもできます。

固定アートワーク

最も簡単なアートワークは固定アートワークで、100を超える固定アートワーク形状が提供されています。固定アートワークは、1つのレイアウト・オブ
ジェクトと考えることができます。これらのオブジェクトは、デザイン・ファイルに保存されます。また、接続ピンを持つ場合も持たない場合もあります。
このタイプのアートワークは通常、サイズや形状をパラメータ設定に基づいて変更しないレイアウト・アイテムに使用されます。例えば、SOT23パッケ
ージのアウトラインは、デバイスの操作パラメータに関係なく、そのパッケージを持つすべてのデバイスに対して同じです。

提供される固定アートワーク・オブジェクトについては、レイアウト・ライブラリのマニュアルを参照してください。これらの固定アートワークの1つをアイテムに関
連付ける方法の詳細については、アートワークのアイテムへの関連付けを参照してください。
独自の固定アートワークの作成方法の詳細については、固定アートワークの作成を参照してください。

AELアートワーク・マクロ

より柔軟性の高い方法は、AELアートワーク作成関数を使用してアイテムに対してアートワークを定義することです。組み込み伝送ライン・エレメント
（マイクロストリップ、ストリップラインなど）のアートワークはこの方法で定義され、200を超えるAELアートワーク・マクロが提供されています。これらの
マクロには、はんだ付けパッドやスペース・アートワークの作成関数、アートワークの非作成関数が含まれています。

AELマクロは汎用性があり、レイアウト・アートワークの形状、サイズ、接続ピンを決定するのに使用されるパラメータを受け入れます。AELマクロによ
って定義されるアイテムへの参照はそれぞれ、渡されるパラメータによって異なる可能性があります。

レイアウト専用コンポーネント用のAELマクロについては、標準AELマクロを参照してください。
AELマクロは、Circuit Componentsマニュアルに（コンポーネントとして）記載されている追加コンポーネント用に提供されています。
AELマクロは、100を超える標準的なSMTパッケージに対して提供されています。これらのマクロについては、レイアウト・ライブラリのマニュアルを参照してく
ださい。
独自のAELアートワーク・マクロの作成方法の詳細については、AELマクロを使用したアートワークの作成を参照してください。
Graphical Cell Compilerを使用したAETアートワーク・マクロの作成方法の詳細については、『Graphical Cell Compiler』マニュアルを参照してください。

特殊なタイプのアートワーク

次のような、特殊なタイプのアートワークも用意されています。スペース・アートワーク、接続アートワーク、SMTパッケージ・アートワーク。

スペース・アートワーク

スペース・アートワークとは、レイアウトにスペースまたはギャップを残すことを言います。スペース・マクロでは、実際のアートワークは作成されませ
ん。その代わり、スペース・アートワークを持つアイテムを経由して接続されているアイテムを表示するためにプログラムに指示します。レイアウトに
はギャップが作成され、スペース・アートワークを持つアイテムに接続されているアイテムが切り離されます。
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このタイプのアートワークは、シミュレーション・アイテムを表すアートワークが頻繁に変更される可能性のあるレイアウトによく使用されます。例え
ば、デザインにSパラメータ・デバイス・モデル (S2P) があり、参照Sパラメータ・ファイルをスワップアウトして各種デバイスをテストする場合がありま
す。

デバイスによってアートワーク表現が異なる場合は、このエレメントに割り当てるパッケージのアウトラインは1つもありません。ただし、スペースをア
ートワーク (SPAC) として割り当てることにより、ギャップを残して（そのサイズはアイテムの1つのパラメータです）、後でレイアウト・パッケージのアウ
トラインを挿入することができます。

組み込みアイテムの定義は、SPACをアートワークとして使用することで役立つ、シミュレーション・アイテムの最も一般的なケースに対して提供され
ています。これらには、S2Pエレメントだけではなく多くの集中定数エレメントが含まれており、Lumped Components (with artwork) およびLinear Data
File Items (with artwork) パレット／ライブラリ・グループにあります。さらに、プログラムによって提供されるパッケージ・パーツのライブラリのアイテ
ム、またはユーザ定義のレイアウト・オブジェクトを使用して、レイアウト用のスペースに挿入することができます。

接続アートワーク

接続アートワークは、スペース・アートワークの特殊なケースです。ただし、接続アートワークは、レイアウトにギャップを残すのではなく、それによっ
て相互に接続されているアイテムを単に接続します（0スペース）。つまり、接続アートワークを持つアイテムは、シミュレートされてスケマティックに組
み込まれますが、レイアウトでは無視されます。例えば、回路にアートワークを持たない寄生容量／抵抗を組み込んだ可能性があります。接続アー
トワークをこれらのアイテムに割り当てることにより、それらのアイテムがシミュレーションで考慮され、レイアウトで無視されるようにすることができま
す。

アートワークがまったく割り当てられていないアイテムではなく、接続アートワークを持つアイテムを使用して、レイアウトがスケマティックと自動的に
同期するようにすることが重要です。

スペース・アートワークを持つアイテムと同様に、接続アートワークを持つ最もよく使用されるアイテムがあらかじめ定義され、プログラムに組み込ま
れています。これらのアイテムは、Lumped-With ArtworkおよびLinear Data File Items (with artwork)パレット／ライブラリ・グループにもリストされて
います。

SMTパッケージ・アートワーク

SMTパッケージ・アートワークは、100を超えるパーツに使用可能です。これらのアートワーク・マクロは汎用性があり、パッケージの幅と長さを変更す
ることによってランド・パターンの寸法を変更できます。コンポーネント・パッケージを基準にしたランド・パターンの位置は、OFFSETパラメータを変更
することによって変更できます。使用可能なSMTパッケージ・ネットワークの詳細と例については、『Layout Library』マニュアルを参照してください。

付属のアートワーク

すべてのマイクロストリップ／ストリップライン・コンポーネントおよびその他多くのコンポーネントに対して、デフォルトのアートワークが存在していま
す。多くのコンポーネント・ライブラリに対しても、アートワークが存在しています。このアートワークは、AELアートワーク・マクロ形式です。

デフォルトのアートワークは、多くのオプション・ライブラリに対しても存在しています。このアートワークは通常、固定パーツのアウトライン形式です。
パッケージ・パーツ・ライブラリの場合は、コンポーネントのフットプリントまたはアウトラインです。他のパーツの場合は、実際のパーツ形状です。

他のパーツに対するデフォルトのアートワークはありません。これらのコンポーネントをレイアウトに含めるには、要件に固有のアートワークを持つ特
殊な等価コンポーネントを作成する必要があります。詳細については、カスタム・アートワークを参照してください。

カスタム・アートワーク

デザインのカスタム・アートワークは、シミュレーション・モデルの前または後に作成できます。アートワークが何を表しているかに応じて、AEL関数を
使用してアートワークを作成するか、一定の形状をドローインしてアートワークを作成します。これらの方法を使用したアートワークの作成方法を説
明するため、2つの例を示します。

作成するレイアウトのタイプに応じて、固定アートワーク・コンポーネントのライブラリ、パラメータ化アートワーク・マクロまたは両者の組合わせとし
て、アートワークを作成できます。一部のレイアウトについては、キャパシタが一連の固定の不連続キャパシタンス値を持つため、固有のキャパシタ
ンス値ごとに固定のレイアウトを作成した方がよい場合もあります。他のレイアウトでは、キャパシタンスは一定の範囲の値を取ることができます。ア
ートワーク・マクロとして実装されている場合は、マクロはパラメータ値を受け入れ、形状の寸法を調整して、対応するアートワークを作成することが
できます。マイクロストリップ伝送ライン (MLIN) は、AELマクロとして最適に実装されているコンポーネントのもう1つの例です。これは、ラインの幅と
長さがマクロに渡され（デザインに対して設定されている長さの単位を使用）、マクロによってそれを表すのに使用される長方形のサイズが制御され
るためです。

アートワークを持つ新しいアイテムの作成を簡素化するため、AEL関数と固定アートワークのライブラリが用意されています。AEL関数には、以下が
含まれます。レイアウトにスペース／ギャップを生成するための関数（これにより、アートワークを後で挿入できます）、パッド配置用のマクロ（2/3/4ピ
ン・コンポーネント用）、さまざまなタイプのPCBパッドを作成するためのルーチン、スペース／接続／パッド・アートワークを持つ既定義のよく使用さ
れるコンポーネントのセット、アイテム間の電気的な接続を容易にする方法。固定ライブラリには、大規模なSMTライブラリを含め、最も一般的なパッ
ケージ・パーツのアウトラインのアートワークも含まれています（付属の固定/AELマクロ・アートワーク・アイテムをリストするには、File > Design
Parametersを選択し、各アートワーク・タイプに対応するドロップダウン・リストを表示します）。
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レイアウト・オブジェクトの作成

レイアウト・オブジェクトを作成する手順：

レイアウト・オブジェクトに対しては、Layoutウィンドウをオープンして、オブジェクトを表す形状をドローイングします。1.
接続ポイントまたは接続ピンを追加することもできます（スペース・アートワークを参照）。
アートワークをドローイングしたら、レイアウト・オブジェクトの場合はLayoutウィンドウで、スケマティック・オブジェクトの場合はSchematicウィンドウから、File >2.
Design Parametersを選択します。
スケマティックに含める場合は、アートワーク・タイプとしてFixedを選択します。それ以外の場合は、No t Synchronizedを選択します。3.
Nameフィールドに、現在オープンしているデザイン・ファイルの名前を（拡張子.dsnを付けずに）入力します。4.
アイテムの保存先のライブラリの名前を入力します（すでに存在している場合は、名前を選択します）。5.
SimulationフィールドのModelリストから、Not Simulatedを選択します。6.
Layout Objectボックスをチェックし、OKをクリックします。7.
デザインを保存します。8.

ピン／ポートのアートワークへの追加

作成したアートワーク・アイテムは、電気的に接続されるため、ピンを追加する必要があります。ピンは、トレース、ワイヤ、多角形または別のアイテ
ムのピンを接続可能な電気的な接続ポイントを表します。ポート（ポイント・ポート）をレイアウトに配置し、このレイアウトを別のレイアウトにインスタン
スとして配置した場合、単一のx,y点に対応するピンが表示されます。

エッジ・ポートとエリア・ポートをレイアウトに配置することも可能です。これらは、レイアウトを別のレイアウトにインスタンスとして配置した場合は、エ
ッジ・ピンとエリア・ピンになります。エッジ・ポートとエリア・ポートは、単一の（ポイント）ポートと常に関連付ける必要があります。ポイント・ポートは、
デザイン同期の使用時に、自動接続が実行される場所を定義します。コンポーネントへの単一の電気的な接続を表す複数の接続ポイントが必要な
場合は、複数のエッジ・ピンまたはエリア・ピンを使用することをお勧めしますが、NPPORTも有効です。エッジ・ポートおよびエリア・ポートの詳細につ
いては、レイアウトの作成のセクションのエッジ・ポートとエリア・ポートの指定を参照してください。

NPPORTを使用すれば、単一の電気ポートを表す物理的な接続ポイントを複数配置できます。同じ番号のNPPORTに接続すると、接続が作成されま
す。どのコンポーネントもNPPORTを、必要な数だけ使用できます。単一の接続を表す各NPPORTは、同じポート番号を共有します。NPPORTを使用
する場合の唯一の特異な要件は、一連のポートの1つが優先ポートであることです。優先ポート（PORTコンポーネント）は、デザイン同期機能が接続
に使用する接続ポイントです。NPPORTはNPPORTアイテムを使用して作成され、優先ポートは標準ポート・アイテムを使用して作成されます。優先
ポートは、同じポート番号を共有する一連の複数のポートの中に1つだけ使用できます。

AELを使用してアートワークを作成する場合は、同じ概念が適用されます。唯一の違いは、ポートがde_define_npport()とde_define_port()または
de_draw_npport() とde_draw_port() AEL関数を使用して作成されることです。

固定アートワークの作成

この例のアートワークは、チップ・コンデンサの取付け用パッドを表す固定パターンです。サブ回路に対する唯一のパラメータは、C（公称キャパシタ
ンス）です。損失を考慮するために、抵抗をスケマティックに追加します。式を使用して、公称キャパシタンスから抵抗を計算します。

以下のスケマティックは、シミュレーション・モデルを示しています。
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チップ・コンデンサの固定アートワークを作成する手順：

Layoutウィンドウをオープンします。1.
アートワークのエントリ・レイヤを選択します（Insert > Entry Layerを選択します）。2.
グリッドを表示することもできます（View > Zoom Inを選択します）。3.
コンデンサ・パッドを表す形状をドローイングします。デザインに適した寸法およびレイヤを選択してください。4.

ポートをアートワークに追加します。ポートの向きによって、デザイン同期の実行時のコンポーネントのアートワークへの接続方法が決まります。ノード1の座5.
標が0,0に設定された左側の長方形の左側に、ポート1を配置します。ポート1は、アートワークの方向を指す矢印のように見えます。
ポート1を配置し、右側の長方形の方向を指すように回転させます。6.
コンデンサを同期中に配置した場合は、接続アイテムがコンデンサの配置角度と同じ角度で、コンデンサの右側と左側に配置されます。
デザインを保存します。7.

エッジ・ポートとエリア・ポートの使用法

エッジ・ポートまたはエリア・ポートを関連付けるポートを配置済みであることを確認します。1.
エッジ・ポートを配置するポリラインまたは円弧を追加します。これは通常、何か他の多角形、長方形、縁または経路のエッジに沿って表示されます。2.
または
エリア・ポートを配置する多角形、長方形、円または経路を追加します。エリア・ポートが必要な多角形、長方形、円または経路がアートワークにすでに存在し
ている場合は、他に追加する必要はありません。
Edit > Edge/Area Portメニューを使用します。ポリライン、円弧、多角形、長方形、円または経路を選択し、それに対応付けるポート番号を選択します。OKを3.
クリックします。ポート番号と対応付けられているオブジェクトが、デフォルトではライトブルーのアウトラインで強調表示されます。

レイアウト内の形状を選択すると、オブジェクトが対応付けられているポートに応じて、ダイアログのPort Numberの値が変わります。ポートと対応付
けられていないオブジェクトには、Port Number値としてNot a portと表示されます。複数のポートと対応付けられているオブジェクトには、Port
Number値としてMultipleと表示されます。この例では、左側のオブジェクトが選択され、Port Number 1と対応付けられています。

Select Portダイアログでは、特定のポートにすでに対応付けられている形状をすべて選択できます。この例では、Port Number 2が選択され、Applyボ
タンがクリックされています。これにより、強調表示された形状が選択されています。
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AELマクロを使用したアートワークの作成

この例のアートワークは、薄膜 (MMIC) キャパシタを作成するために、AEL関数を使用して生成されたプログラマブル・アートワークです。キャパシタ
の領域は、回路に渡されたパラメータから計算されます。回路を作成してからAEL関数を作成するか、AEL関数を作成してから回路を作成することが
できます。アートワーク関数が完成したら、回路と関連付ける必要があります（アートワークのアイテムへの関連付け）。

注記
以下のAEL関数を使用してピンを作成することができます。de_draw_port()（シミュレータ単位を使用）、
de_define_port()（ユーザ単位を使用）、de_define_edge_area_port()。これらの関数の詳細については、『AEL』のマニュ
アルを参照してください。

以下のスケマティックは、シミュレーション・モデルを示しています。

アートワーク関数を作成する手順：

任意のテキスト・エディタを使用して、AELファイルにマクロ関数を作成します（ファイルには必ず拡張子.aelを使用します）。AEL関数の構造の詳細について1.
は、『AEL』のマニュアルを参照してください。
以下の注釈付きの例は、薄膜コンデンサ (TFC)、tfc.aelの場合です。

----------------------------------------------------------------------------
/* MIMCAP

21MMIC
  
1)1  
2)4  
3)22

*/
//load("stdart");      // make sure we have standard definitions
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// define technology parameters, all in MKS
decl lpad, lab, lpost, wpost, vu, lol, cpua;
lab = 6e-6;           // length of air bridge
lpost = 6e-6;         // length of post/via
wpost = 10e-6;        // width of post/via
vu = 0.5e-6;          // via undersize
lpad = 4e-6;          // bottom plate pad length
lol = 2e-6;           // bottom plate overlap
cpua = 300e-6;        // capacitance per unit area
// actual artwork generation function
defun mimart(c, ar)
{
decl c_mks, netu, wcap, lcap;
decl lbot, wvia, w, l;

netu = mks_factor(5); //get length conversion factor from mks
c_mks = c*mks_factor(4); // get capacitance in farads
lcap = sqrt(c_mks/cpua*ar)/netu; // get length in meters
wcap = lcap/ar; // get width in network units

// compute some useful values
lbot=(2.0*lol+lpad)/netu+lcap;// compute length of bottom plate
wvia = (wpost-2.0*vu)/netu;   // compute width of via
w = (2.0*lol)/netu + wcap; // compute overall width
l = (lab+lpost)/netu + lbot;// compute overall length

// draw lower plate and output contact
de_set_layer(1);                      // set the first metal layer
de_draw_rect(0.0, -w/2.0, lbot, w/2.0);
de_draw_rect(l-lpost/netu, -wpost/netu/2.0, l, wpost/netu/2.0);

// cut via hole
de_set_layer(4);                 // set via (dielectric) layer
de_draw_rect(l-(lpost-vu)/netu, -wvia/2.0, l-vu/netu, wvia/2.0);

// draw air bridge metal
de_set_layer(2);// set the second metal layer
de_draw_rect((lpad+lol)/netu, -wcap/2.0, lbot-lol/netu,wcap/2.0);
de_draw_rect(lbot-lol/netu, -wpost/netu/2.0, l, wpost/netu/2.0);

// add ports
de_draw_port(0.0, 0.0, -90.0);
de_draw_port(l, 0.0, 0.0);
}
----------------------------------------------------------------------------

ファイルをプロジェクトのnetworksディレクトリに保存します。2.

このアートワークをサブ回路と関連付ける手順：

回路デザインをオープンし、File > Design Parametersを選択します。1.
Generalタブから、シンボル名としてSYM_Cを選択します（これがスケマティックを表すシンボルとなります）。2.
シミュレーション・モデルをSubnetworkに設定します。3.
アートワーク・タイプとしてAEL Macroを選択します。4.
Artwork Nameフィールドに、作成した関数の名前を入力します。この例では、mimartです。これは、例では以下の行によって定義されています。5.

defun mimart(c, ar)

Parametersタブから、アートワーク関数に定義されているように、パラメータCとARを作成します。どちらのパラメータもNetlistedに設定する必要があります。こ6.
れらのパラメータを最適化可能とすることもできます。

以下の図は、C=20およびAR=1のレイアウトのMMICコンデンサを示しています。

関数を最初から記述するのではなく、以下の1つ以上のファイルからAELマクロ・コードをコピーして、独自のAELファイルで変更するのが有用な場合
もあります。
destdart.ael：Design Parametersダイアログ・ボックスから使用可能なアートワーク・マクロ（$HPEESOF_DIR/de/aelに存在）
ckt_linear_art.ael：回路シミュレータの既存のアートワーク（$HPEESOF_DIR/circuit/aelに存在）

.aelファイルをプロジェクトのnetworksディレクトリ以外のディレクトリに移動する場合は、『Customization and Configuration』マニュアルの
Customization ExamplesのセクションのCreating Custom Librariesを参照してください。
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アートワークのアイテムへの関連付け

アートワークをアイテムに関連付ける場合は、以下のいずれかのアートワーク・タイプを選択します。

Synchronized（同期）
Fixed（固定）
AEL Macro（AELマクロ）
None（なし）

適切なアートワーク・タイプの選択

以下のセクションでは、各種アートワーク・タイプの使用法を説明します。

同期アートワーク

回路を作成して保存すると、Artwork Typeなどのいくつかのデフォルトを使用して（File > Design Parametersで変更可能）、デザイン定義が自動的に
作成されます。デフォルトでは、アートワーク・タイプはSynchronizedになります。レイアウトにパラメータ化されたコンポーネントが含まれている場合
や、レイアウトがパラメータを変更した場合に再生成する必要のあるサブ回路の場合は、同期アートワークが最適なアートワーク・タイプです。同期
アートワークをアートワーク・タイプとして選択した場合は、生成されるアートワークは、スケマティック内の各コンポーネントに対して定義されている
デフォルトのアートワークをベースとします。さらに、デザイン同期プロセスが実行されている場合は、サブ回路参照のパラメータに対する変更がチェ
ックされ、それらの変更に基づいてレイアウトが自動的に再生成されます。

固定アートワーク

レイアウトが固定形状から構成される場合は、Fixedアートワークが適切なアートワープ・タイプです。レイアウト・アートワークは、スケマティックと同じ
デザイン・ファイルにある場合も、異なるファイルにある場合もあります。

固定アートワークをアイテムと関連付ける手順：

目的のデザインから、File > Design Parametersを選択します。1.
Artwork Typeドロップダウン・リストから、Fixedを選択します。2.
Artwork Nameフィールドで、アートワークがあるデザイン・ファイルの名前を選択するか、入力します。これは、付属のアートワークでもカスタム・アートワーク3.
でも可能です。.dsn拡張子を付けずに、デザイン・ファイル名だけで、フル・パスを含める必要はありません。ファイルは、プロジェクトのnetworksディレクトリ
か、（サーチ・パスに基づいて）プログラムによって自動的にロードされるファイルがあるディレクトリに常駐します。詳細については、『Customization and
Configuration』マニュアルのCustomization ExamplesのセクションのCreating Custom Librariesを参照してください。
必要に応じて他のデザイン定義特性を変更し、OKをクリックします。4.

AELマクロ・アートワーク

変更される可能性のあるパラメータに基づいてアートワークを生成する場合は、AEL Macroアートワークが適切なアートワーク・タイプです。

AELマクロ・アートワークをアイテムと関連付ける手順：

目的のデザインから、File > Design Parametersを選択します。1.
Generalタブから、アートワーク・タイプとしてAEL Macroを選択します。2.
Artwork Nameフィールドで、関数の名前を選択するか、入力します。これは、AELファイルの名前ではなく、AELアートワーク作成関数の名前です（defun AEL3.
関数で指定）。
この関数は、プログラムによってロードされるAELファイル内になければなりません。プロジェクトのnetworksディレクトリ内のすべてのAELファイルが自動的に
ロードされます。（サーチ・パスに基づいた）他のディレクトリからのファイルのロードの詳細については、『Customization and Configuration』マニュアルの
Customization ExamplesのセクションのCreating Custom Librariesを参照してください。
Parametersタブから、マクロが使用するパラメータのリストを入力するか、値のタイプなどの該当する特性を割り当てます。パラメータを定義する場合は、以下4.
の指針に注意してください。

アートワーク・パラメータは、マクロによって使用されるのと同じ順番で定義する必要があります。また、他のパラメータの前にリストする必要があります。タイプはNot Netlistedです。

寸法を定義するすべてのパラメータに、パラメータ・タイプとしてLengthが割り当てられます。デフォルト値と一緒に単位を定義しないと、指定した値はメートルと読み取られます。この
サブ回路のインスタンスをスケマティックに配置した場合は、指定したデフォルト値は、メートルからSchematicウィンドウに対して設定されている現在のLengthの単位に変換されます。
Layerパラメータは、アートワークをドローイングするレイヤ番号で、整数でなければなりません。

ヒント
パラメータのリストをすばやく指定するには、Copy Parameters Fromをクリックし、必要なパラメータに類似する
パラメータを持つコンポーネントを選択し、パラメータのリストとそれらの特性を必要に応じて変更します。

該当するパラメータ・タイプを選択することもできます。この選択により、サブ回路の配置時にパラメータの編集に使用できる選択肢が決まります。5.
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以下の例は、cpad2マクロに基づいたValue TypeとParameter Typeの設定を示しています。

AELマクロ・アートワークがSMTパッケージ・アートワークの場合：

Design Parametersダイアログ・ボックスで、Artwork TypeをAEL Macroに設定し、適切なアートワーク名 (smtart_<part_name>) を選択します。1.
Parametersセクションに、2つのパラメータSMTPADとOFFSETを定義します。2.

SMTPADパラメータに対しては、Parameter TypeをStringに設定し、デフォルト値を適切なSMTPADインスタンス名（例えば、PAD1）に設定します。Not netlisetedオプションを選択しま
す。
OFFSETパラメータに対しては、タイプをRealに設定し、デフォルト値を0に設定します。

None

生成されるアートワークがない場合、またはスケマティックをレイアウト・オブジェクトと同期させるのに使用されるアートワークがない場合は、アート
ワーク・タイプとしてNoneを選択します。

デフォルトのアートワーク割り当てのオーバライド

与えられたすべてのコンポーネントのデフォルトのアートワーク割り当てをオーバライドできます。

与えられたコンポーネントのアートワークを変更する手順：

コンポーネントを選択し、Edit > Component > Edit Component Artworkを選択します。1.
以下のいずれかのアートワーク・タイプを選択します。2.

Default：コンポーネントのcreate_item定義で指定したアートワークを使用します。アートワーク・タイプとアートワーク関数名が表示されます。
Fixed：いずれかの付属の固定アートワークまたはカスタム固定アートワーク。Artwork Nameドロップダウン・リストからアートワークがあるデザイン・ファイル
の名前を選択または入力するか、ブラウザを使用して選択します。
Null Artwork：（X軸がボックスを通る）ジェネリック・ボックスをドローイングします。

このコンポーネントに対してApplyをクリックし、他のコンポーネントを選択します。必要に応じてこの操作を繰り返します。1.
完了したら、OKをクリックします。2.

レイアウトのインポートとエクスポート
Advanced Design Systemのインポート／エクスポート・トランスレータは、柔軟な構成が可能です。各トランスレータには、トランスレータの機能を制
御する関連オプション・ファイルがあります。デフォルト・オプション・ファイルは、プログラムに付属しています。特に指定しない限り、自動的に使用さ
れます。

このセクションでは、レイアウトのインポート／エクスポート方法について説明します。

注記
使用可能なフォーマットおよび関連するオプションの概要の詳細については、『Importing and Exporting Designs』マ
ニュアルのAvailable File Formatsを参照してください。

レイアウトのインポート

以下の手順に従って、レイアウトをインポートします。

Layoutウィンドウで、File > Importコマンドを選択します。Importダイアログ・ボックスが表示されます。1.
Importダイアログ・ボックスから、目的のフォーマットを選択します。2.
Select Fileをクリックし、ファイル名を選択し、OKをクリックします。3.
オプションまたはレイヤ属性を定義します。4.
OKをクリックします。ファイルがプログラムに変換されます。1個以上のデザイン・ファイルを作成できます。5.
すべてのトランスレータに対して、1個以上のデザインを作成できます。IGESまたはGDSIIのトップ・レベルのデザインがLayoutウィンドウに表示されます（どの
トランスレータを使用しても、スケマティックは作成されません）。

注記
変換中に発生したエラーまたは警告は、writegds.log (GDSII)、writeigs.log (IGES)、writeegs.log (EGS) などの
write<translator>.logファイルに書き込まれます。
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変換済みレイアウトのオープンおよび表示

Mainウィンドウのデザイン・ツリーか、LayoutウィンドウのFileメニューを使用して、インポートしたレイアウトをオープンします。

変換済みレイアウトの保存

変換済みデザインを明示的に保存する必要があります。変換済みデザインは、自動的に保存されません。以下の手順に従って、1つ以上の変換済
みデザイン（階層デザインの変換中に作成された個々のデザイン）を保存します。
Mainウィンドウで、File > Save All Designsコマンドを選択します。

変換済みレイアウトの階層のリスト

Layoutウィンドウで、Tools > Hierarchyコマンドを選択します。

レイアウトのエクスポート

このセクションでは、レイアウトのエクスポート方法について説明します。使用可能なフォーマットおよび関連するオプションの概要の詳細について
は、『Importing and Exporting Designs』マニュアルのAvailable File Formatsを参照してください。

レイアウトの変換準備

レイアウトの変換準備は、以下の一部またはすべての手順から構成されます。

レイアウトが存在する階層を削除します（フラットにします）。形状のマージなど、階層のすべてのレベルに影響を及ぼす変更を行う場合は、これは不可欠で
す。
レイアウトの回路コンポーネントのグラフィック表現を構成する形状を編集します。最も一般的な編集手順は以下のとおりです。

同じレイヤ上にある、接触しているグラフィック形状をマージします（レイアウトがグラフィックスだけで構成されるように、コンポーネント間の境界を取り除くため）。
プロセス・オフセットを適用します。
反転イメージを作成します。
色を変更します。

レイアウトを時々編集して、色の配合を逆にします（例えば、白を黒に置き換えます）。

レイヤの表示／配列を変更します。

使用する手順は、変換のタイプ、完成したファイルに何を含めるべきかによって決まります。

インスタンスをフラットにすることによる、階層／接続の除去

コンポーネントをフラットにする場合は、レイアウトの各コンポーネントを一連の関連のない形状に変えます。コンポーネントのグループ分けが崩れ、
形状がシミュレーションで電気エンティティとして動作しません。以下の手順に従います。

Layoutウィンドウで、File > Generate Artworkを選択します。1.
プログラムによって新しいデザイン名を入力するように促すプロンプトが表示されたら、所望の名前を入力してOKをクリックします。2.

階層が除去され、すべてのプリミティブがコピーされたトップ・レベルのレイアウトのアイコン内に含まれます。

プロセス・オフセットの追加

一方のレイヤがプロセス・オフセットを持つこと以外はほとんど同じ2つのレイヤが必要な場合もあります。プロセス・オフセットは、製造許容値を補正
するために、オブジェクトのすべての寸法に加算／すべての寸法から減算される一定量のスペース（幅）です。プロセス・オフセットは、他のオブジェ
クトと重なり合う／他のオブジェクトの下に横たわるオブジェクトを作成したり、実際に重なり合う量を決定するのに使用します。オブジェクトがポリラ
インまたは円弧の場合は、オブジェクトにプロセス・オフセットを使用できるだけの幅が必要です。さらに、プロセス・オフセットをこれらのプリミティブと
一緒に用いた場合は、幅だけが影響を受けます。プロセス・オフセットによって、ポリラインや円弧の終点が変わることはありません。レイアウトにプ
ロセス・オフセットを作成するには、1つのレイヤの形状を空白のレイヤにコピーし、新しいレイヤ上の形状をマージし、マージした形状を大型化（また
は小型化）します。

新しいレイヤへの形状のコピー

形状をレイヤから別のレイヤにコピーする手順：

形状のコピー先のレイヤが存在していない場合は、Options > Layersを選択してレイヤ・エディタを表示し、必要なレイヤを追加します。1.
Layoutウィンドウで、コピーする形状を選択します。2.
Edit > Copy/Paste > Copy to Layerを選択します。3.
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Copy to Layerダイアログ・ボックスで、挿入先レイヤを選択し、OKをクリックします。4.

注記
プログラムは、選択した形状のコピーを、挿入先レイヤの挿入元レイヤに配置されているのとまったく同じ位置に
配置します。このため、コピーした形状は確認することはできません。OKをクリックすると、コピーが挿入先レイヤ
に配置されます。形状のコピー先のレイヤを追加選択する場合にだけ、Applyをクリックします。

形状のマージ

マージによって、同じレイヤ上にある接触している形状がすべて、結合形状に置き換えられます。この手順は、負の値のプロセス・オフセットを実行
する前に特に必要ですが、階層の除去に続けて行う必要があります（インスタンスをフラットにすることによる、階層／接続の除去を参照）。

形状をマージする手順：

マージする形状を選択します。1.
Edit > Mergeを選択します。2.

形状のサイズ変更

形状の外形寸法を増減することができます。これは、製造プロセスの補正に必要な場合があります。

形状のサイズを変更する手順：

サイズ変更する形状を選択します。1.
Edit > Scale/Oversize > Oversizeを選択します。2.
Oversizeダイアログ・ボックスで、選択した形状に追加／選択した形状から削除する分量を入力します（レイアウト単位）。正の数を入力すると形状のサイズ3.
が大きくなります。負の数を入力するとサイズが小さくなります。
OKをクリックします。4.

レイヤの反転イメージの作成

以下の手順に従って、グランド・プレーンまたははんだ付けマスクを作成して、形状間に領域を挿入することができます。

必要な形状を空白のレイヤにコピーします。1.
形状の上に長方形（グランド・プレーンを表す）を配置します。2.
Edit > Create Clearanceを選択します。3.
プロンプトが表示されたら、グランド・プレーンを表す長方形を選択し、OKをクリックします。4.
表示されたCreate Clearanceダイアログ・ボックスに、グランド・プレーンのクリアランス（または、はんだ付けマスクを作成する場合は、最終形状に追加するオ5.
フセット）を入力します。
形状を選択してOKをクリックします。6.
形状を選択して削除し、グランド・プレーン／はんだ付けマスクはそのままにします。7.

レイアウトの変換

レイアウトをエクスポートする手順：

Layoutウィンドウで、File > Exportコマンドを選択します。Exportダイアログ・ボックスが表示されます。1.
Exportダイアログ・ボックスから、目的のフォーマットを選択します。2.
一度に1つのフォーマットしか指定できません。選択したフォーマットによって、変換に使用できるオプションが決まります。オプションによってプログラム・トラン
スレータが制御されます。
必要に応じて、ファイル名を指定します。ファイル名を指定しない場合は、変換済みデザインの名前が使用されます。ファイル拡張子を指定する必要はありま3.
せん。
プリファレンスまたはレイヤ属性を定義します（どちらもOptionsメニューを使用）。4.
デザインのエクスポートに使用するGDSIIレイヤ番号またはIGESレイヤ番号を指定するには、Options > Layersを選択してレイヤ・エディタにアクセスします。
有効なGDSIIレイヤ番号は0〜255です。
変換プロセスを開始するには、OKをクリックします。経路を指定しない場合は、ファイルは現在のプロジェクト・ディレクトリに書き込まれます。5.
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