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ドル番号を受付にお伝えください。 

また、計測レスポンスセンタでは、OS (HP-UX,Solaris,Windows) に関するご質問は承っ

ておりませんので予めご了承ください。 

 

E-mail は登録制になっております。未登録の場合は、上記アドレスに空のメールを送信

すると登録方法のメールが自動送信されて来ますのでそちらをご参照ください。 

 

計測レスポンスセンタへの FAX でのご質問は、本手順書の ８－２節８－２節８－２節８－２節    、 

「計測レスポンスセンタ サポート依頼 FAX シート」 
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第 1 章 トピックスと手順の概要                       

    
１－１ IC-CAP 2002 のトピックス 
     
     ■ コンピュータ／ＯＳ 
 
 ◇ Windows NT/2000 のサポート 
 
     ■ 新しいモデルの追加 
 
 ◇ MEXTRAM 504 Extraction Module 
     今までの MEXTRAM 503 モデルに加え、MEXTRAM 504 モデルが新たに追加に 
    なります。 
 
 ◇ BSIM4 Extraction Moduleのアップデート 
    今までの BSIM4 モデルに加え、モデルが BSIM4 RFモデルが新たに追加になります。 
 
     ■ 新しい測定器ドライバ 
 
 ◇ ネットワーク・アナライザ PNA/ENA のサポート 
    以下のAgilentハイパフォーマンス・ネットワーク・アナライザ(PNA)に対す 
       る新しいドライバが追加されています。 
 
           Agilent E8356A 300 kHz - 3 GHzパフォーマンス・ネットワーク・アナライザ 
           Agilent E8357A 300 kHz - 6 GHzパフォーマンス・ネットワーク・アナライザ 
           Agilent E8358A 300 kHz - 9 GHzパフォーマンス・ネットワーク・アナライザ 
           Agilent E8364A 45 MHz - 50 GHzパフォーマンス・ネットワーク・アナライザ 
 
    また、以下のエコノミー・ネットワーク・アナライザも本リリースではサポートされます。 
 
           Agilent E8801A 300 kHz - 3 GHzパフォーマンス・ネットワーク・アナライザ 
           Agilent E8802A 300 kHz - 6 GHzパフォーマンス・ネットワーク・アナライザ 
           Agilent E8803A 300 kHz - 9 GHzパフォーマンス・ネットワーク・アナライザ 
 
     ■ IC-CAP 2002 のコードワード（ライセンス） 
 
     IC-CAP 2002 を実行するために新たなライセンスは必要ありません。現在ご使用中の 

IC-CAP 2001 用のライセンスをそのまま IC-CAP 2002 でご使用頂けます。また、IC-CAP 2002 
 用のライセンスでも IC-CAP 2001 をご使用頂けます。 
 なお、IC-CAP 2001 以前のバージョンをお使いの場合は、ご面倒でも IC-CAP 2002 用の 
 ライセンスを弊社までご請求お願い致します。 
 
   ■ IC-CAP 2002 の新機能 

IC-CAP の新機能に関しましては、以下のＵＲＬをご参照ください。 
 
http://eesof.tm.agilent.com/products/85190a-bj.html 
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１－２ インストール／アップデートの流れ 
 
 インストール／アップデートの流れを図に示します 
    
    
    

インストール前の準備 
（ディスク容量の確認など）    

     ↓    
IC-CAP 2002 用のライセンスの確認    

     ↓    
古いバージョンの削除／保存    

     ↓    
IC-CAP 2002 のインストール    

     ↓    
GPIB(HP-IB) の設定    

     ↓    
コードワード(ライセンス)の設定    

     ↓    
プリンタの登録    

     ↓      
IC-CAP 2002 の動作確認    

     ↓    
測定器の動作確認    
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第 2 章 IC-CAP インストール前の準備          

 
２－１ 必要なハードウェア 
 
 IC-CAP 2002 のプログラムサイズは 約425MByte です。 
 （ IC-CAP 2001 のプログラムサイズは約400Mbyte でした。） 
 以下は、IC-CAP 2002 で必要なハードウエアの概要です。 
 
      ■ 64 MByte 以上のメモリ(RAM)      （推奨 512 MByte 以上） 
      ■ 1 GByte 以上のハードディスク  （推奨 2 GByte 以上） 
      ■ 200 MByte 以上のスワップサイズ     （推奨  500 MByte 以上）  
 
 (1) メモリサイズ（RAM）の確認 
 
  ＃  dmesg 
 
 (2) スワップサイズの確認 
 
      ■ HP-UX の場合 
 
                 ＃  swapinfo   
 
      ■ SUN の場合 
 
  ＃  dmesg 
 
        (3) ディスクのフリーエリアの確認 
 
      ■ HP-UX の場合 
 
  ＃  bdf 
 
      ■ SUN の場合 
 
  ＃  df -k 
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２－２ IC-CAP と UNIX のバージョン対応 
 
                    IC-CAP と UNIX OS のバージョンの対応表 
 

プラットフォーム OS バージョン 
HP Workstation HP-UX 10.20 

HP-UX 11.0 
SUN Workstation Solaris 2.7 

Solaris 2.8 
   
 (1) UNIX のバージョンの確認 
 
   ＃  uname  -srv 
 
  
 
２－３ CD-ROM の確認 
 
 UNIX 版は１枚の CD-ROM （P/N:85190-10050）の中に HP, SUN 両方のプログラムデータが 

入っています。また、この中に英語版オンラインマニュアルも入っています。 
  

Windows 版も１枚の CD-ROM （P/N:85190-10049）の中にプログラムデータが入っています。 
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第 3 章 IC-CAP 2002 のインストール            

 
３－１ インストール作業の概要 
 
 この章では、IC-CAP 2002 のインストール方法を説明します。 
 この章の作業はすべてスーパユーザ（root）で行ってください。 
 IC-CAP 2002 をすべてインストールするために必要なファイルサイズは425MByte です。 
 ハードディスクのフリーエリアをご確認ください。（ IC-CAP 2001 のファイルサイズは 
 400 MByte でした。） 
 

 
◆ まとめ ◆ 

◆ IC-CAP 2002 のファイルサイズは425MByteです (IC-CAP 2001 は 400MByte でした) 
◆ インストールスクリプト icinstall を実行してインストールを行います。 
 

 
 
 
   有効なコードワードがある      
 
 
           
 
    ファイルのバックアップ 
 
 
    古い IC-CAP を削除する 
 
 
     CD-ROM をマウントする 
 
 
    CD-ROM の中に移動する 
 
 
     icinstall を実行する 
 
 
   ファイルセットを選択する 
 
 
   インストール先を定義する 
 
 
     GPIB（HP-IB）の設定 
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３－２ アップデート前の準備 
 
 (1) ライセンスファイルを保存します。 
 
      ＃ cp  /agilent/iccap2001/licenses/license.lic  /tmp   
 

(2) 日付を正しくあわせます。 
 

＃ date 
 

(3) ライセンス管理デーモンが動作している場合は、それを停止します。 
 

＃ ps –ef | grep lmgrd （PID の確認） 
＃ kill  ＜lmgrdのPID＞ （停止） 

 
        (4)  IC-CAP 2001 のプログラムを消去します。 
 
        ＃  rm  -rf  /agilent/iccap2001 
 
      ＜注意＞ ハードディスクに余裕がある場合は、IC-CAP 2002 の動作確認を完了し、 

ユーザファイルを完全に移行した後、 
   IC-CAP 2001 を削除されることをお勧めします。
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３－３ IC-CAP 2002 のインストール 
 
(１) CD-ROM のマウント 

 
CD-ROM をマウントする前に、CD-ROM をマウントする UNIX のディレクトリを作成します。 
すでに存在する場合は、新しく作成する必要はありません。 
 

＃  mkdir  /cdrom  
 
次に、CD-ROM をマウントします。使用する CD-ROM は HP-UX, Solaris ともに、「IC-CAP Rel
ease 2002 UNIX Program CD HP-UX10.20,11.0 SunOS 5.7,5.8」(Part No.85190-10050) です。 
 
****注意注意注意注意**** Solaris OSSolaris OSSolaris OSSolaris OS の場合は通常、CD-ROM を挿入すると自動的にマウントされます。自動的
にマウントされた場合は、CD-ROM のマウントコマンドを実行する必要はありません。次のステ
ップに進んでください。 
 
マウントコマンドは通常、以下のようになります。ただし、システムの構成によっては CD-ROM
のデバイスファイル名が異なる場合があります。また、mount コマンドにパスが通っていない場
合は、フルパスでコマンドを入力する必要があります。これらの場合はシステム管理者にご相談
ください。 
 

■ HP-UX 10.20 の例 
 
＃ mount /dev/dsk/c0t2d0 /cdrom 
 

■ HP-UX 11.0 の例 
 
＃ mount –rF cdfs /dev/dsk/c0t0d0 /cdrom 
 

■ Solaris OS の例 
 
＃ mount –F hsfs –r /dev/dsk/c0t6d0s0 /cdrom 

 
マウントが正しく行えたかどうか、確認します。 
 

■ HP-UX の場合 
 
＃ ls /cdrom 
 

■ Solaris OS の場合 
 
＃ ls /cdrom/cdrom0 
 

  ＜HP-UX の場合の表示例＞ 
 
   HP700     INSTALL     PDF      SUN 

 
CD-ROM の中のファイル／ディレクトリ名が表示されます。このように、１枚の CD-ROM の中に
HP700 (HP 700シリーズ)、SUN (Solaris OS）のプログラムが入っています。 
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(２) icinstall スクリプトファイルの実行 

 
CD-ROM のマウントが正常に行えたならば、icinstall スクリプトファイルを実行して 
IC-CAP 2002 のインストールを開始します。 
 

■ HP-UX の場合 
 

＃  cd  /cdrom/INSTALL (CD-ROM の中に移動してください) 
＃  ./ICINSTALL*  (HP-UX の場合、ICINSTALL の後ろの 

 アスタリスク ”*” を忘れないでください） 
■ Solaris の場合 
 

＃  cd  /cdrom/cdrom0/INSTALL （CD-ROM の中に移動してください。） 
＃  ./icinstall 
 

上記コマンドを実行すると、インストールが始まります。 
 
 
 
以下、以下、以下、以下、icinstalicinstalicinstalicinstalllll    スクリプト実行時の作業を示します。スクリプト実行時の作業を示します。スクリプト実行時の作業を示します。スクリプト実行時の作業を示します。    
 
 

◆ icinstall スクリプトの中断 ◆ 
 
icinstall スクリプトファイルの中断は、CTRL＋C (CTRL キーを押しながら C キーを
押す）コマンドをご利用ください。 
 
 
 
 
Which OS version of the ICCAP 2002 executables do you want to install ? 

1) SunOS 5.7, 5.8  /  Solaris 7, 8  
2) HP-UX 10.x, 11  

 
the default input [1] ? 1 
 
コンピュータの種類と OS のバージョンを選択します。 
該当する数字を入力してください。 
 
 
Do you want to install ICCAP executables for SunOS 5.7, 5.8 ...  [y] ?  
 
選択したコンピュータと OS のバージョンが正しいかどうか確認します。 
正しければそのまま [Return] を押してください。 
正しくない場合は“ｎ”を入力してください。 
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icinstall               6.10.300.1              2002年10月30日 (水) 16時05分05秒 JST  
 
 
 
INSTALLATION COMMANDS:  
 
[i]nstall        installation from media  
[q]uit          Quit installation program 
 
icinstall> i 
 
“ｉ”を入力して作業を続けます。終了したい場合は“ｑ”を入力します。 
 
 
CONFIGURE COMMANDS:  
 
[f]ull installation of Agilent EEsof product files 
[c]ustom installation 
<cr> Return to previous menu  
 
[icinstall] config> f 
 
インストールするファイルセットを定義します。 
 
 [f]ull installation  全てのファイルセットをインストール 
 [c]ustom installation  ファイルセットを選択してインストール 
 <cr> Return to previous menu 前のメニューに戻ります。 

(Return キーを押します） 
 
 
上記メニューの選択は、メニューの最初の文字を入力します。 
ここでは、full installation について説明します。 
 
通常は、full installation でインストールを行ってください。 
ここでは、“ｆ”を入力してください。 
 
 
Full installation 
 
 
Current Configuration : 
 
   File set                                           approx. size  
=================================================================== 
 Agilent EEsof SunOS 5.7, 5.8 ...   ICCAP core files    85 
 Agilent EEsof ICCAP example files                              105 
 Agilent EEsof ICCAP help files                                 251 
------------------------------------------------------------------- 
 Total:                                                         441 MB 
 
Do you want to use the configuration shown above [y] ? y 
 



 12

 
トータルの使用ディスク容量が表示されます。よければ“ｙ”を押してください。 
 
 
Input target <install_directory> {enter full path name} ? /agilent/iccap2002 
 
インストールするディレクトリ名を入力します。 
 
 
 Do you want to create a  /agilent/iccap2002  directory now [y] ? y 
 
もし、入力したディレクトリが存在しない場合は、作成するかどうかをたずねてきます。すでに
存在する場合はこの質問はありません。 
よろしければ、“ｙ”を入力してください。 
 
 
ファイルシステム      kbytes 使用済み 使用可能 capacity  マウント先 
/dev/dsk/c1t1d0s7    29115311      10 28824148     1%    /agilent 
 
 
Do you want to use this file system  [y] ? 
 
入力したディレクトリの容量が表示されます。十分空き容量があるかどうか確認してください。 
よろしければ“ｙ”を入力してください。 
 
 
Loading Agilent EEsof SunOS 5.7, 5.8 ...  ICCAP executables from ...   
/cdrom/iccap61/SUN/EXEC.cpio.Z 
Loading ICCAP example files from ...      
/cdrom/iccap61/SUN/EXAMPLES.cpio.Z 
Loading ICCAP help files from ...         
/cdrom/iccap61/SUN/HELP.cpio.Z 
 

 インストールが始まります。CD-ROM の読み込み速度にもよりますが、約２０分程かかります。 
 
 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
 
NOTE:  Licenses for IC-CAP 5.x are not forward compatable with  
       IC-CAP 2002.  You must contact Agilent Technologies Business  
       Support Center to request updated IC-CAP licenses  
       for your supported products. 
 
       Business Support Center: 
          Phone: 1-800-507-6274 
          Web: http://www.agilent.com/eesof-eda 
                  --> Technical Support -> Request Codewords 
 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
 
ファイルセットのインストールが終了すると、上記メッセージが表示されます。 
IC-CAP 2002 のライセンスは、IC-CAP 5.x のライセンスと互換性がありません(IC-CAP 2001 とは互換性
があります)。現在 IC-CAP 5.x をご利用になられている場合は、新たなライセンスを請求する必要があり
ます。詳細は、巻末のライセンスの請求方法をご覧ください。 
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For additional information related to this installation see the file:  
   /usr/tmp/icinstall1113.log 
 
最後に、インストールログファイルについて表示されます。 
インストール結果の詳細につきましては、こちらのファイルをご参照ください。 
 
 
インストールが終了したら、ルートディレクトリに移動し CD-ROM をアンマウントします。 
 

■ HP-UX の場合 
 

＃  cd  / 
＃  umount /cdrom 
 

■ Solaris の場合 
 

＃  cd  / 
＃  eject cdrom 

 
 
念のため、ログ（記録）ファイルを見てみます。 
 
 ＃  more  /usr/tmp/icinstall18571.log （上記の例） 
 
 ＜表示例＞ 
 

      This log file contains information related the the installation of ICCAP 2002.  
Much of the following information is verbose in nature and can be ignored.  An exampl
e of a error  that can be ignored is:   
 
 Begin installation : 
2002年10月30日 (水) 16時05分05秒 JST 
 ln -s  /cdrom/iccap61/SUN/EXEC*  tmp1113.Z   
 zcat tmp1113.Z | cpio  -imcudB   
152160 ブロック 
 ln -s  /cdrom/iccap61/SUN/EXAMPLES*  tmp1113.Z   
 zcat tmp1113.Z | cpio  -imcudB   
204310 ブロック 
 ln -s  /cdrom/iccap61/SUN/HELP*  tmp1113.Z   
 zcat tmp1113.Z | cpio  -imcudB   
466590 ブロック 
 
 End  installation : 
2002年10月30日 (水) 16時08分23秒 JST 
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(３) インストールされたファイルを確認します。 
 
 ＃  ls   /agilent/iccap2002 
 
    次の、１１個のディレクトリが確認できます。 
 
 ael  Application Extension Language：プログラム言語用ディレクトリ 

  config  各種設定ファイルが入っているディレクトリ 
  etc  その他設定ファイル 
  frame  オンラインマニュアル・ビュアーが入っているディレクトリ 
  licenses  ライセンス管理を行うディレクトリ 
  src  ユーザ定義のプログラムを作成するディレクトリ 
  bin  実行形式のプログラム(IC-CAP 本体など)が入っているディレクトリ 
  doc  オンラインマニュアルのデータが入っているディレクトリ 
  examples  サンプルファイル（XXX.mdl ファイル）が入っているディレクトリ 
  lib  各種ライブラリ／設定ファイルなどが入っているディレクトリ 
  msgs  各種メッセージが入っているディレクトリ 
  include  各種ヘッダファイルが入っています。 
 
 
３－４ GPIB (HP-IB)カードの設定 
 

HP-UX 10.20 の場合は、GPIB(SICL)ドライバのインストールを行います。 
これは、GPIB カードを使用する場合/ LAN-GPIB Gateway を使用する場合、どちらも必要です。
簡単な設定ガイドが、「第７章 付録 /７－１節 GPIB(SICL)のインストール」に記載されていま
すので、ご参照ください。Installation and Customization Guide(英語) の 134 ページ以降に
は、GPIB カードの設定方法が記載されています。GPIB カードの細かい設定が必要な場合はこち
らもご覧ください。 
 
古いバージョンの IC-CAP から IC-CAP 2002 にアップデートした場合は、SICL ドライバソフト
ウエアのバージョンアップが必要な場合があります。念のため、GPIB(SICL)ドライバのインスト
ール作業をしておくことをお勧めいたします。 
 
HP-UX 11.0 の場合は、OS が GPIB カードをサポートしていません。ただし LAN/GPIB Gateway
は使用できます。この場合は、ドライバのインストールは必要ありません。 
 
Solaris OS で、NI社の GPIB カードをご利用になる場合は、GPIB カードの説明書をご覧になり、
インストール作業を終了させてください。Agilent LAN-GPIB Gateway を使用する場合は、ドラ
イバのインストール作業は必要ありません。 
 

 
 



 15

第４章 ライセンス（FLXElm）の設定 

 
４－１ ライセンス設定の概要 
 
ソフトウエアのインストールが終了したら、ライセンスの設定を行います。 
 
IC-CAP 2001 からのアップデートの場合は、コードワードの有効期限がまだ過ぎていなければ、同じコー
ドワードを IC-CAP 2002 でも引き続きご利用になることができます。今回新たにコードワードを請求する
必要はありません。 
 
IC-CAP 5.x 以前のコードワードは（ノードロック、ネットワークライセンスのいずれであっても）使用で
きません。この場合は、IC-CAP 2002 用のコードワードを、弊社コードワードセンタまでご請求ください。
コードワードの請求方法については、「８－１節・コードワード発行依頼の方法」をご覧ください。 
 
FLEXlm とは、アメリカ合衆国 Globetrotter Software 社が開発したライセンス管理ソフトウエアの名称
です。 
 

 
＜前提条件＞ 

① LAN（ネットワーク）が正常に動作していること（ping 命令で確認）。 
② コンピュータの時間が正確にあっていること（date 命令で確認）。 
 

 
 
 下記は、本章の流れをあらわしたものです。    
 
 
     FLEXlm の概念説明 
 
 
   ライセンスファイルの編集 
 
 
         ライセンスサーバでの設定 
 
 
       複数ライセンスサーバでの設定 
 
 
       ライセンスクライアントでの設定 
 
      
      頻度の多いご質問 
 
 
   代表的なシステム構成例 
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４－２ FLEXlm の概念 
 
FLEXlm はライセンスを管理するソフトウエアです。IC-CAP 5.x 以降、および ADS で使用されています。
FLEXlm とは、アメリカ合衆国 GLOBEtrotter Software 社が開発したライセンス管理ソフトウエアの名称
です。 

 
    ① FLEXlm のライセンスの形態（種類） 
 
 ライセンスの形態（種類）は、「ノードロックライセンス」、「ネットワーク（フロー 

ティング）ライセンス」および「両者の混在型」の３種類があります。以下にそれぞれの 
説明を簡単に行います。 

 基本的な設定方法は「ノードロックライセンス」でも「ネットワーク（フローティング） 
ライセンス」でも同じです。 

 
 □ ノードロックライセンス 
 
  ある限定されたコンピュータでのみアプリケーションソフトを実行できます。 
 
 □ ネットワーク（フローティング）ライセンス 
 
  ユーザが定義した任意のコンピュータでアプリケーションソフトを実行できます。 
  ただし、ライセンスサーバは限定されたコンピュータになります。また、同時に 

実行できるアプリケーションソフトの数（本数）は、取得したライセンスの本数 
までになります。 

 
 □ 両者の混在型 
 
  上記の混在型です。 
 
    ②  FLEXlm で使用されるプログラム／ファイル 
 
 次に、FLEXlm で使用されるプログラム／ファイルを簡単に説明します。 
 FLEXlm では、「ライセンス管理デーモン」、「ベンダデーモン」と「ライセンスファイル」 

の３つが使用されています。以下にそれぞれの説明を簡単に行います。 
 
 □ ライセンス管理デーモン（ lmgrd ） 
 
  ライセンス管理デーモン（lmgrd）は実行形式のプログラムです。 

 ベンダデーモン(agileesof)と協力してライセンスを管理します。lmgrd はライセンス 
 サーバでは必ず実行させなければならないプログラムです。 

  同一のコンピュータで、複数の lmgrd を実行することも可能です（ただし、 
  それぞれのポート番号を変更させる必要があります）。よって、EEsof EDA 製品以外 
  のソフトウエアが  FLEXlm を使用していても問題はありません。 
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 □  ベンダデーモン（ agileesof ） 
 

ベンダデーモン（agileesof）は実行形式のプログラムです。ライセンス管理デーモン
（lmgrd)と協力してライセンスを管理します。agileesof はライセンスサーバでは必ず
実行させなければならないプログラムです。 
 
同一のコンピュータで、複数の agileesof を実行することはできません。ベンダデーモ
ン名（agileesof）は使用するアプリケーションソフトで異なりますが、IC-CAP 2001 以
降, ADS 2002 以降は、ベンダデーモン名はすべて agileesof です。 
 
そのため、IC-CAP 2001 以降と ADS 2002 以降を、別々のライセンスデーモンを用いて
同一のコンピュータで実行することは（ベンダデーモン名が同じため）行えません。 
このような場合は、それぞれのライセンスファイル（ license.lic ）を１つにまとめ
たライセンスファイルとして新たに再発行する必要があります。 

 
 □ ライセンスファイル（ license.lic ） 
 

ライセンスファイル（ license.lic ）はテキストファイルです。 
vi エディタで編集したり、プリンタに出力することができます。 
ライセンスファイル（ license.lic ）は、環境変数 LM_LICENSE_FILE でその場所
（ディレクトリ名）およびファイル名を指定する必要があります。 
ライセンスファイル（ license.lic ）の例を示します。 
（下記の例は、ノードロックとネットワークライセンスの混在型の例です） 
 
 
SERVER iccapsvr 19710512  1700 
 
DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof ¥ 
/agilent/iccap2002/licenses/options/local.options 
 
INCREMENT iccap_environment agileesof 6.0 29-apr-2003 1 4969C91B6F09 ¥ 
        VENDOR_STRING=s=2008302740 7B859AB4 
INCREMENT lcrz_driver agileesof 6.0 29-apr-2003 4 5AF2D41FEF59 ¥ 
        VENDOR_STRING=s=2008302740 
 

 
    ③ ライセンスサーバとライセンスクライアント 
 
 FLEXlm では、「ライセンスサーバ」と「ライセンスクライアント」の２種類が存在します。 
 
 □  ライセンスサーバ 
 
  ライセンスサーバとは、前述した license.lic ファイルの中の SERVER の行で指定 

 されたコンピュータのことです。ライセンスサーバでは、前述した lmgrd と  
 agileesof を実行する必要があります。 

  もし、SERVER の行が複数個（正確には奇数個）あれば、それぞれのコンピュータで  
 lmgrd と agileesof を実行する必要があります（複数ライセンスサーバと呼びます）。 
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 □  ライセンスクライアント 
 
  ライセンスクライアントとは、前述した license.lic ファイルの中の SERVER の行 

 で指定されていないコンピュータのことです。ライセンスクライアントでは、前述し 
 た lmgrd と agileesof を実行してはいけません。 

 
 
４－３ コンピュータ ID の確認の方法 
 
FLEXlm はライセンスを管理するソフトウエアです。IC-CAP 5.x 以降、および ADS で使用されてい
 ライセンスを取得するためには、コンピュータ ID を確認しなければなりません。 
コンピュータ ID を確認する UNIX の命令は次のとおりです。 
 

■ HP の場合 
 
� コンピュータのボード上の ID は次の命令で確認できます。 

 
 ＃  uname  -i   （こちらをお勧めします） 
 
 ＜実行例＞ 
 

2019710512  （１０桁の１０進数です） 
 

または 
 

� LAN ボードのリンクレベルアドレス（LLA）は次の命令で確認できます。 
 
 ＃ /etc/lanscan  （こちらはお勧めしません） 
 
＜実行例＞ 
 
 
Hardware Station        Dev Hardware Net-Interface   NM  Encapsulation      Mjr 
Path     Address        lu  State    NameUnit State  ID  Methods            Num 
2.0.2    0x080009490BE7 0   UP       lan0     UP     4   ETHER IEEE8023     52 
        (ﾘﾝｸﾚﾍﾞﾙｱﾄﾞﾚｽ) 
 
現在ご使用中のライセンスファイル（license.lic）の SERVER 行に LAN ボードのリ
ンクレベルアドレス（LLA）が記入されている場合は、弊社までお問い合わせくださ
い。新しいライセンスファイルを発行いたします。 

 
 

■ SUN の場合 
 

＃  hostid 
 
＜実行例＞ 
 
80004fad  （８桁の１６進数です） 
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４－４  ライセンス（license.lic）の編集 
 
ライセンスファイル（license.lic）を編集します。 
すべてのライセンスサーバ、クライアントで同一のライセンスファイル（license.lic）を使用します。 
必要であればライセンスファイル（license.lic）を、以下の内容に従って編集(変更)してください。 
ライセンスファイル（license.dat）の例を示します。 
 
 SERVER iccapsvr 19710512  1700 
 
 DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof  ¥ 

/agilent/iccap2002/licenses/options/local.options（１行で記入） 
 

INCREMENT iccap_environment agileesof 6.0 29-apr-2003 20 4969C91B6F09 ¥ 
VENDOR_STRING=s=2008302740  HOSTID=7B859AB4 

INCREMENT lcrz_driver agileesof 6.0 29-apr-2003 20 5AF2D41FEF59 ¥ 
VENDOR_STRING=s=2008302740 

  
 
 

                             参考：行末の￥マークについて 
 
ライセンスファイルの行末に ￥ マークが付いていますが、これは次の行に記述が続くこと 
をあらわしています。通常はこの ￥ マークを付けたまま使用しても問題はありませんが、 
一部の OS では、￥マークを使った記述が認識されない場合があります。 
そのときは、￥マークを削除し、改行をいれないで１行で記述してください。 
また、￥マークは日本語環境での表示で、英語環境では＼（逆スラッシュ）で表示されます。 

 
 
以下に、各行の説明を行います。 
 

■ SERVER 行 
 
ライセンスサーバのコンピュータを定義している行です。ここに記載されている 
コンピュータ上で lmgrd と agileesof を実行する必要があります。 
SERVER の行が複数台（正確には奇数台）の場合は、複数ライセンスサーバです。 
SERVER 行の文法、例および各項目の説明は次のとおりです。 
 
＜文法＞  SERVER <ホスト名> <コンピュータ ID> <TCP ポート番号> 
 
＜例＞    SERVER  iccapsvr  77B44494  1705 
 
 
ホスト名ホスト名ホスト名ホスト名    コンピュータのホスト名です。UNIX の hostname 命令で確認できます。 

ホスト名はコードワードの中に符号化されて入っていませんので、ユーザ
が任意に指定できます。ホスト名が  unknown の場合や、間違っている場
合は、正しい（現在実際に定義されている）ホスト名に書き換えてくださ
い。 
 
 

コンピュータコンピュータコンピュータコンピュータ IDIDIDID    コンピュータの ID 番号です。UNIX の uname -i または /etc/lanscan (H
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P-UX)、hostid(SUN)命令で確認できます。 
コンピュータ ID 番号はコードワードの中に符号化されて入ってますの
で、ユーザが変更できません。 
SUN の場合、hostid 命令で表示されるコンピュータ ID 番号は 16 進数で
すので、表示された値がそのまま SERVER 行に記入されます。 
一方、HP-UX の uname  -i 命令で表示されるコンピュータ ID 番号は 10
進数です。そのため、10 進数を 16 進数に変換した値が SERVER 行に記入
されています。 
 
＜例＞ uname  -i の実行結果が 2008302740 のとき、SERVER 行には 77B
44494 (１６進数に変換された値)と記入されています。 
 
16 進数に変換する最も簡単な方法は、Microsoft 社の Windows OS の電卓
を使用することです。手順を簡単にご紹介します。 
[アクセサリ]の中の[電卓]を選択すると電卓が起動します。電卓起動後、
[電卓の種類]メニューから[関数電卓]を選択します。 
uname -i の実行結果を 10 進数で入力した後、電卓上の[○１６進]を選択
すると 16 進数に変換されます。 
 
コンピュータ ID 番号が間違えて記入されている場合はこのままでは動作
しませんので、お手数ですが弊社コードワードセンタにご連絡ください。
新しいライセンスファイルをお送りします。 
 
 

TCP TCP TCP TCP ポート番号ポート番号ポート番号ポート番号    LAN の TCP ポート番号です。TCP ポート番号はコードワードの中に符号化
されて入っていませんので、ユーザが任意に指定できます。 
 
通常は、コードワード送付時に既に記入されている TCP ポート番号 1700
で問題無く動作しますが、もし、別のプロセスがこの番号をすでに使用し
ていた場合は、変更しなければなりません。 
 
また、すでに別の FLEXlm が動作している場合もやはり変更しなければな
りません。 
 
 

SERVER SERVER SERVER SERVER の行数の行数の行数の行数    SERVER の行が複数台（正確には奇数台）の場合は、複数ライセンスサー
バです。 
例えば、三台の構成の場合は、最初から、プライマリサーバ・ファースト
バックアップ・セカンドバックアップサーバの順に呼ばれます。 
このうち少なくとも２台以上少なくとも２台以上少なくとも２台以上少なくとも２台以上が正常に動作している必要があります。 
 
 ライセンス 

サーバ合計数 
動作している必要のある
最低ライセンスサーバ数 

 

 1 1  
 3 2  

    

 5 3  
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■ DAEMON 行 
 
ベンダデーモン（agileesof）のパスと名前を定義する行です。また、オプションファイルのパス
と名前も定義できますが、オプションファイルを使用しない場合は省略できます。 
 
DAEMON 行の文法、例および各項目の説明は次のとおりです。 
 
＜文法＞  DAEMON   <ベンダデーモン名>   <ベンダデーモンのパスと名前>   [オプションファイルのパスと名前 ] 
 
＜例＞  DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof ¥ 

/agilent/iccap2002/licenses/options/local.options 
 
 
 
ベンダデーモン名ベンダデーモン名ベンダデーモン名ベンダデーモン名    ベンダデーモンの名前です。変更できません。 

IC-CAP 2001 以降、ADS 2002 以降は、agileesof です。 
 
 

ベンダデーモンのベンダデーモンのベンダデーモンのベンダデーモンの    
パスとファイルパスとファイルパスとファイルパスとファイル名名名名    

ベンダデーモンのフルパスとプログラム名です。 
パス（ディレクトリ名）は変更できますが、ファイル名(agileesof)
は変更できません。 
    
必ず正確なパスを記入してください必ず正確なパスを記入してください必ず正確なパスを記入してください必ず正確なパスを記入してください。 
 
 

オプションファイルのオプションファイルのオプションファイルのオプションファイルの
パスとファイル名パスとファイル名パスとファイル名パスとファイル名    

オプションファイルのパスとファイル名です。 
オプションファイル（local.options など）は、テキストファイルで
FLEXlm の様々な設定を行うことができます。 
オプションは特に設定する必要はありませんので、ここは省略しても
かまいません。 
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■ INCREMENT 行 
 
使用できる製品名などを定義する行です。この行のすべての項目は変更することはできません。 
INCREMENT 行の文法、例および各項目の説明は次のとおりです。 
 
＜文法＞ INCREMENT <製品名> <ベンダデーモン名> <バージョン> <有効期限> <ライセンス数> <コードワード> \ 

  <VENDORSTRING=s=サーバＩＤ> [HOSTID=ノードロックＩＤ ] 
 
＜例＞   INCREMENT iccap_environment agileesof 6.0 29-apr-2003 20 4969C91B6F09 ¥ 

VENDOR_STRING=s=2008302740   HOSTID=7B859AB4 (これはﾉｰﾄﾞﾛｯｸﾗｲｾﾝｽの例です） 
 
 
製品名製品名製品名製品名    使用できる製品名です。変更できません。 

 
 

ベンダデーモン名ベンダデーモン名ベンダデーモン名ベンダデーモン名    ベンダデーモン名です。変更できません。 
 
 

バージョンバージョンバージョンバージョン    バージョンです。変更できません。 
 
 

有効期限有効期限有効期限有効期限    コードワードの有効期限です。変更できません。 
 
 

ライセンス数ライセンス数ライセンス数ライセンス数    ライセンスの本数です。変更できません。 
 
 

コードワードコードワードコードワードコードワード    暗号化されたコードワードです。変更できません。 
 
コードワードの部分は 16 進数(0 から 9 の数字と A から F の英文字)で
すので、英文字のＯ(オー)やＩ(アイ)は使用されていません。 
このコードワードの中に、コンピュータＩＤ番号や有効期限、ライセ
ンス数などが符号化されて入っています。 
 
 

サーバサーバサーバサーバ IDIDIDID    プライマリライセンスサーバのコンピュータ ID が 「VENDORSTRING=s
=サーバ ID」の書式で記入されています。変更できません。 
 
１０進数で記入されている場合もあります。(HP-UX の場合のみ） 
 
 

ノードロックノードロックノードロックノードロック IDIDIDID    ノードロック用のコンピュータ ID が「HOSTID=ノードロック ID」の書
式で記入されています。変更できません。 
 
ライセンスの種類（形態）によってここにコンピュータ ID 番号がある
場合とない場合があります。 
 
ここに、コンピュータＩＤ番号が記入されているときは「ノードロッノードロッノードロッノードロッ
クライセンスクライセンスクライセンスクライセンス」です。 
ここがない場合は、「ネットワークライセンスネットワークライセンスネットワークライセンスネットワークライセンス」です。 
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         ■ ライセンスファイル（license.lic）のまとめ ■ 
 

①. SERVER 行のホスト名を正しい名前に変更してください。 
②. SERVER 行の TCP ポート番号を、場合によっては変更してください。 
③. DAEMON 行のパスを正しいパスに変更してください。 
④. 上記以外は変更してはいけません。 
⑤. ノードロックライセンス」と「ネットワークライセンス」の見分けかたは、 

INCREMENT 行の最後にコンピュータＩＤ番号が記入されているかどうかで判断
できます。 

 
 
 
 

 
         ■ ライセンスファイル（license.lic）の中で、変更できる部分 ■ 
 
下記の         の４個所のみをユーザが変更できます。それ以外を変更すると動作しません。 
逆にいえば、これらはライセンスの中に符号化されて入ってはいないということです。 
 
 SERVER  iccapsvr  19710512  1700 
 
 DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof  ¥ 

         /agilent/iccap2002/licenses/options/local.options 
 
 INCREMENT iccap_enviroment agileesof 6.0 25-Mar-2002 1 4CA1113153869C9918D1 ¥ 
      VENDOR_STRING=s=2008302740  HOSTID=7B859AB4  
 INCREMENT iccap_enviroment agileesof 6.0 25-Mar-2002 3 258ADE85538619710512 ¥ 
      VENDOR_STRING=s=2008302740 
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４－５ ライセンスサーバの起動 
 
ライセンスファイル（license.lic）の SERVER の行で指定されているすべてのコンピュータで以下の設定
を行います。複数サーバの場合も各サーバ毎に行ってください。 
 
作業はスーパユーザ（root）で行ってください。 
 
(１) HP コンピュータの場合は、LAN のデバイスファイルのパーミッションモードを変更します。  

 
＃ chmod  777  /dev/lan0  （ＨＰコンピュータでは必ず実行ＨＰコンピュータでは必ず実行ＨＰコンピュータでは必ず実行ＨＰコンピュータでは必ず実行） 

 
 

(２) ライセンスファイル（license.lic）を編集します。詳細は「5-4 ライセンスファイル 
（license.lic）の編集」の項目をご覧ください。すべてのライセンスサーバ、クライアントで
同一（同じ内容）のライセンスファイル（license.lic）を使用します。編集する内容は次の通
りです。 

 
  ① SERVER 行のホスト名を正しい値に変更してください。 
  ② SERVER 行の TCP ポート番号を、場合によっては変更してください。 
  ③ DAEMON 行のパスを正しいパスに変更してください。 
  ④ 上記以外は変更できません（変更すると動作しません）。 
 
       編集は次のように行います。 
 
  ＃  cd  /agilent/iccap2002/licenses 
  ＃  vi  license.lic 
 
 編集後、ライセンスファイル（license.lic）のパーミッションモードを変更します。 
 ライセンスファイル（license.lic）は一般ユーザにも read 権が必要です。  
 
  ＃  chmod  644  license.lic 
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(３) ライセンス管理デーモン（lmgrd）を起動します。 

以下の命令を一行で入力してください。 
 
＃ /agilent/iccap2002/licenses/bin/lmgrd -c /agilent/iccap2002/licenses/license.lic 

      >  /agilent/iccap2002/licenses/flex.log & 
 
＜文法説明＞ 
 
 /agilent/iccap2002/licenses/bin/lmgrd   lmgrd の起動 

-c /agilent/iccap2002/licenses/license.lic  ライセンスファイルの指定 
> /agilent/iccap2002/licenses/flex.log  ログファイルの指定 

 
 

(４) FLEXlm の２つのデーモン（lmgrd と agileesof）が動作しているかどうか確認します。 
ベンダデーモン agileesof は、lmgrd 起動時に（license.lic ファイルを参照して）自動的に
起動されます。 
 
 
＃  ps  -ef  |  grep  lmgrd 
 

＜実行結果例＞ 
  

root 185 1 0 May 12 ? 0:16 /agilent/iccap2002/licenses/bin/lmgrd -c  /agilent/iccap2002/lic .... 
 
＃  ps  -ef  |  grep  agileesof 
 

＜実行結果例＞ 
 
root 186 185 0 May 12 ? 0:21 agileesof -T iccapsvr 3 -c /agilent/iccap2002/licenses/vendors..... 
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(５) ログファイル flex.log の内容を確認します。 
 
＃  more  /agilent/iccap2002/licenses/flex.log 
 
＜flex.log ファイルの例＞ 
(この例は意図的に license.lic ファイルの vbic_bjtvbic_bjtvbic_bjtvbic_bjtの行の記述を間違えて記入してあります） 
 
 
22:38:52 (lmgrd) ----------------------------------------------- 
22:38:52 (lmgrd)   Please Note: 
22:38:52 (lmgrd) 
22:38:52 (lmgrd)   This log is intended for debug purposes only. 
22:38:52 (lmgrd)   There are many details in licensing policies 
22:38:52 (lmgrd)   一部省略一部省略一部省略一部省略    
22:38:52 (lmgrd) ----------------------------------------------- 
22:38:52 (lmgrd) 
22:38:52 (lmgrd) 
22:38:52 (lmgrd) lmgrd running as root: 
22:38:52 (lmgrd)        This is a potential security problem 
22:38:52 (lmgrd)        And is not recommended 
22:38:52 (lmgrd) FLEXlm (v7.2h) started on iccapsvr (hp 9000/780) (7/25/2002) 

 (FLEXlm (FLEXlm (FLEXlm (FLEXlm のバージョンがのバージョンがのバージョンがのバージョンが 7.2h 7.2h 7.2h 7.2h    であることが確認できますであることが確認できますであることが確認できますであることが確認できます)))) 
22:38:52 (lmgrd) FLEXlm Copyright 1988-2001, Globetrotter Software, Inc. 
22:38:52 (lmgrd) US Patents 5,390,297 and 5,671,412. 
22:38:52 (lmgrd) World Wide Web:  http://www.globetrotter.com 
22:38:52 (lmgrd) License file(s): license.lic 
  ((((ライセンスファイルは上記のファイルを使用します）ライセンスファイルは上記のファイルを使用します）ライセンスファイルは上記のファイルを使用します）ライセンスファイルは上記のファイルを使用します）    
22:38:52 (lmgrd) lmgrd tcp-port 1705 
  ((((TCPTCPTCPTCP ポート番号ポート番号ポート番号ポート番号 1705  1705  1705  1705 がががが lmgrd  lmgrd  lmgrd  lmgrd で使用されました）で使用されました）で使用されました）で使用されました）    
22:38:52 (lmgrd) Starting vendor daemons ...  （ベンダデーモンを起動中）（ベンダデーモンを起動中）（ベンダデーモンを起動中）（ベンダデーモンを起動中） 
22:38:52 (lmgrd) Started agileesof (internet tcp_port 4114 pid 23413) 
  ((((ベンダデーモンベンダデーモンベンダデーモンベンダデーモン agileesof  agileesof  agileesof  agileesof が起動しました）が起動しました）が起動しました）が起動しました） 
22:38:52 (agileesof) FLEXlm version 7.2h 
22:38:52 (agileesof) Invalid license key (inconsistent encryption code for "vbic_bjt") 
  ((((上の行は上の行は上の行は上の行は  "  "  "  "vbic_bjtvbic_bjtvbic_bjtvbic_bjt"  "  "  "  の行が間違えているというメッセの行が間違えているというメッセの行が間違えているというメッセの行が間違えているというメッセージですージですージですージです))))    
22:38:52 (agileesof)CANNOT OPEN options file: "/agilent/licenses/options/agileesof.options" 
  ((((オプションファイルが無い場合のエラーです。無視して結構ですオプションファイルが無い場合のエラーです。無視して結構ですオプションファイルが無い場合のエラーです。無視して結構ですオプションファイルが無い場合のエラーです。無視して結構です)))) 
22:38:53 (agileesof) Server started on iccapsvr for: 
22:38:53 (agileesof) a_si_tft   ac_driver       analysis 
22:38:53 (agileesof) curtice_statz_fet dc_driver        gummel_poon_bjt 
22:38:53 (agileesof) hf_ucb_mos3        hp_eebjt2       hp_eefet3_eehemt1 
22:38:53 (agileesof) hp_eemos1  hp_root_diode   hp_root_fet_hemt 
22:38:53 (agileesof) hp_root_mos        iccap_environment lcrz_driver 
22:38:53 (agileesof) noise_driver       p_si_tft        philips_mextram_bjt 
22:38:53 (agileesof) philips_mos_model_9 pulsed_sys_driver statistical_modeling 
22:38:53 (agileesof) statistical_modeling_lite time_domain_driver ucb_bsim1_bsim2 
22:38:53 (agileesof) ucb_bsim3  ucb_bsim4       ucb_mos2_mos3 
22:38:53 (agileesof) vbic_bjt 
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＜flex.log ファイルの例のつづき＞ 
 
以下の例は、IC-CAP 2002 を起動し、シミュレーションを実行したときに flex.log ファイル
に記入される内容の例です。“OUT”は使用開始をあらわしています。 
使用される製品名と、ユーザ名、ホスト名が記録されています。 
 
17:19:43 (agileesof) OUT: iccap_environment ユーザ名@ホスト名  （（（（ICICICIC----CAP CAP CAP CAP を起動）を起動）を起動）を起動）    
17:20:16 (agileesof) OUT: analysis ユーザ名@ホスト名     （シミュレーションを実行）（シミュレーションを実行）（シミュレーションを実行）（シミュレーションを実行） 

17:20:54 (agileesof) OUT: gummel_poon_bjt ユーザ名@ホスト名   （（（（BJT BJT BJT BJT の抽出を実行）の抽出を実行）の抽出を実行）の抽出を実行） 

 
以下の例は、IC-CAP 2002 を終了したときに flex.log ファイルに記入される内容の例です。 
“IN”は終了をあらわしています。 
 
17:21:24 (agileesof) IN: iccap_environment ユーザ名@ホスト名  (used: 1:41) 

17:21:24 (agileesof) IN: analysis ユーザ名@ホスト名  (used: 1:08) 

17:21:24 (agileesof) IN: gummel_poon_bjt ユーザ名@ホスト名  (used: 0:30) 

 
以下の例は、FLEXlm の lmgrd デーモンを停止したときに flex.log ファイルに記入される内
容の例です。 
 
15:29:27 (lmgrd) daemon shutdown requested 
15:29:27 (lmgrd) lmgrd will now shut down all the vendor daemons 
15:29:27 (lmgrd) Shutting down hpeesofd 
15:29:27 (agileesof) daemon shutdown requested - shutting down 
 
＜参考＞ UNIX の tail 命令に－ｆオプションを使えば、flex.log ファイルに内容が記入 

  される毎にその内容が表示できます。tail 命令の終了は CTRL＋C です。 
 
 ＄  tail  -f  flex.log 
 
 

 
IC-CAP が正常に起動しないときは、flex.log ファイルをご確認ください。 
このファイルの中にさまざまなヒントが記録されています。 
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正常に動作した場合は、前記のように使用することのできるライセンスリストが表示されていま
す。ライセンスが間違っている場合や、デーモンが正常に動作しなかった場合は、エラーメッセ
ージが記入されます。 
 
flex.log ファイルは必ず確認してください。 
 
 
＜参考＞＜参考＞＜参考＞＜参考＞ 前ページの 'flex.log' ファイルの例では、license.lic ファイルの vbic_bjtvbic_bjtvbic_bjtvbic_bjt     の行
の入力が間違えていたため、エラーが記録されています。このような場合は、license.lic フ
ァイルに正しく記入し、lmreread  命令（後述）を実行して再認識させてください。 
 
 
＜注意＞＜注意＞＜注意＞＜注意＞ 必ず、flex.log ファイルの内容をご確認ください。FLEXlm が正常に動作しなかった
場合の対策のヒントが発見できます。 
    
＜flex.log ファイルの中のエラーメッセージの例＞ 
 
 
■ agileesof デーモンが見つからない  → license.lic ファイルの DAEMON 行を 

 間違えて記入している。 
 

■ ライセンスサーバが見つからない    → license.lic ファイルの SERVER 行の 
 ホスト名を間違えて記入している。 
 

■ ネットワーク上に同一のポート番号がある → license.lic ファイルの SERVER 
    行の TCP ポート番号を変更する。 

 
＜注意＞＜注意＞＜注意＞＜注意＞ lmgrd  デーモンが正常に実行し、flex.log ファイルにエラーメッセージなどを記
入するまで３分程かかる場合があります。 
 
＜注意＞＜注意＞＜注意＞＜注意＞ ユーザが IC-CAP を使用する毎にその使用状況が flex.log ファイルに自動的に記入
されます。よって flex.log ファイルのファイルサイズはどんどん大きくなっていきます。 
flex.log ファイルのファイルサイズがあまりに大きくなった場合は、必要に応じて消去しても
かまいません。ただし UNIX の touch 命令で新たに flex.log ファイルを作成してください。 
 
  ＃  rm  flex.log 
  ＃  touch  flex.log 

 
 

 
IC-CAP が正常に起動しないときは、flex.log ファイルをご確認ください。 
このファイルの中にさまざまなヒントが記録されています。 
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４－６ FLEXlm のユーティリティの使い方 
 
このユーティリティは、/agilent/iccap2002/licenses/bin ディレクトリの下にあります。 
ここで説明するユーティリティは次の通りです。 
 
 

lmstatlmstatlmstatlmstat    有効なライセンスの表示と、現在使用されているライセンスの表示が行
えます。 
 

lmrereadlmrereadlmrereadlmreread    ライセンスファイル（license.lic）を再度読み込ませるときに使用しま
す。 license.lic ファイルを変更したときは必ず実行してください。 
 

lmdownlmdownlmdownlmdown    FLEXlm のデーモン（lmgrd と agileesof）を停止するときに使用しま
す。 
 

 
 
次の命令は、ユーティリティではありませんが、FLEXlm のバージョンを表示できます。 
 
 

lmgrdlmgrdlmgrdlmgrd    FLEXlm の本体プログラムです。FLEXlm のバージョンを表示することが
できます。 
 

 
 
まず、以下の例のように環境変数を追加した後、ユーティリティを実行します。 
 
◇ B シェル（/bin/sh）または、Kシェル（/bin/ksh）の場合 
 
 ＄ LM_LICENSE_FILE=/agilent/iccap2002/licenses/license.lic 
 ＄ export  LM_LICENSE_FILE 
 ＄  env  |  grep  LM_LICENSE_FILE （確認） 
 

◇ C シェル（/bin/csh）の場合 
 
 ％ setenv  LM_LICENSE_FILE  /agilent/iccap2002/licenses/license.lic 
 ％  env  |  grep  LM_LICENSE_FILE （確認） 

 
＜注意＞＜注意＞＜注意＞＜注意＞ 以下のユーティリティは、必ず上記の環境変数 LM_LICENSE_FILE を正確に定義した
うえで実行してください。正確に環境変数が定義できていない状態では、以下のユーティリテ正確に環境変数が定義できていない状態では、以下のユーティリテ正確に環境変数が定義できていない状態では、以下のユーティリテ正確に環境変数が定義できていない状態では、以下のユーティリテ
ィは正常に動作しませんィは正常に動作しませんィは正常に動作しませんィは正常に動作しません。間違った結果を返すときがあります。 
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■ lmstat 命令 
 
何本ライセンスを使用できるかを 'lmstat' 命令で確認することができます。 
FLEXlm 実行直後は、この命令を実行し、ライセンスが有効であることを必ずご確認ください。 
また、この命令で、現在どのユーザが IC-CAP を使用しているかを確認することもできます。 
 
'lmstat' 命令の実行（一般ユーザでも実行できます） 
 
＄  /agilent/iccap2002/licenses/bin/lmutil  lmstat  -a 
 
＜実行結果の例＞ 
 
lmutil - Copyright (C) 1989-2000 Globetrotter Software, Inc. 
Flexible License Manager status on Wed 10/30/2002 22:15 
 
License server status: 1705@iccapsvr 
    License file(s) on iccapsvr: /agilent/iccap2002/licenses/license.lic: 
 
  iccapsvr: license server UP (MASTER) v7.2 ((((ライセンスサーバホスト・ライセンスサーバホスト・ライセンスサーバホスト・ライセンスサーバホスト・lmgrd lmgrd lmgrd lmgrd バージョンバージョンバージョンバージョン)))) 
 
Vendor daemon status (on iccapsvr): 
 
 agileesof: UP v7.2 ((((ベンダデーモンベンダデーモンベンダデーモンベンダデーモン agileesof  agileesof  agileesof  agileesof のバージョンのバージョンのバージョンのバージョン)))) 
 
Feature usage info: ((((以下のライセンスが使用可能です以下のライセンスが使用可能です以下のライセンスが使用可能です以下のライセンスが使用可能です)))) 
 
Users of ac_driver:  (Total of 20 licenses available) (ac_driver (ac_driver (ac_driver (ac_driver はははは 20  20  20  20 ライセンス可能ライセンス可能ライセンス可能ライセンス可能)))) 
 
Users of analysis:  (Total of 20 licenses available)        (analysis (analysis (analysis (analysis はははは 20  20  20  20 ライセンス可能ライセンス可能ライセンス可能ライセンス可能)))) 
 
Users of curtice_statz_fet:  (Total of 20 licenses available) 
 
Users of dc_driver:  (Total of 20 licenses available) 
 
Users of iccap_environment:  (Total of 20 licenses available) 
 
  "iccap_environment" v6.0, vendor: agileesof (iccap_environment (iccap_environment (iccap_environment (iccap_environment は使用中は使用中は使用中は使用中)))) 
 floating license    ((((下記ユーザが下記ユーザが下記ユーザが下記ユーザが iccap_environment  iccap_environment  iccap_environment  iccap_environment を使用中を使用中を使用中を使用中)))) 
 
    iccapuser edahost1 192.168.0.10 (v6.000) (edahost1/1705 102), start Wed 10/16 14:03 
 ((((ユーザ名：ユーザ名：ユーザ名：ユーザ名：iccapuser iccapuser iccapuser iccapuser が、ホスト名：が、ホスト名：が、ホスト名：が、ホスト名：edahost1 edahost1 edahost1 edahost1 からライセンスを使用中からライセンスを使用中からライセンスを使用中からライセンスを使用中))))    
Users of lcrz_driver:  (Total of 20 licenses available) 
 
Users of noise_driver:  (Total of 20 licenses available) 
 
Users of ucb_bsim4:  (Total of 20 licenses available) 
 
Users of ucb_mos2_mos3:  (Total of 20 licenses available) 
 
Users of vbic_bjt:   (vbic_bjt (vbic_bjt (vbic_bjt (vbic_bjt はコードワード入力間違いのため使用できませんはコードワード入力間違いのため使用できませんはコードワード入力間違いのため使用できませんはコードワード入力間違いのため使用できません!!)!!)!!)!!) 
 
 

 
 ■ lmreread 命令（スーパユーザで実行してください） 
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   'license.lic' ファイルを変更・修正したときは、’lmreread’ 命令を実行し、 
  再認識させる必要があります。 
  （前述した vbic_bjt の記入間違いは、license.lic ファイルを正しく修正した後、 
     この命令を実行します。） 
 
     'lmreread' 命令の実行 
 
  ＃ /agilent/iccap2002/licenses/bin/lmutil  lmreread  
 
 ■ lmdown 命令（スーパユーザで実行してください） 
 
     FLEXlm のデーモンを止めるときに使用します。 
     FLEXlm のデーモンを再起動するときは、lmgrd を直接起動します。 
 
     'lmdown' 命令の実行 
 
  ＃ /agilent/iccap2002/licenses/bin/lmutil  lmdown  
 
 ■  lmgrd 命令（一般ユーザでも実行できます） 
 
  FLEXlm のバージョンも確認できます。 
  ‘lmgrd’ 命令で、FLEXlm のバージョンを確認するには、-v オプションを付けます。 
 
  ＄  /agilent/iccap2002/licenses/bin/lmgrd  -v 
 
  ＜実行結果例：Ver.4.1 の例＞ 
 
  lmgrd v4.1 - Copyright 1988-1994, Globetrotter Software, Inc. 
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４－７ FLEXlm ライセンスサーバ(lmgrd)の自動起動 
 
UNIX 起動時に自動的にデーモンを実行できるように設定します。 
設定後、UNIX をリブートし、デーモンが実行されているかどうかを確認します。 
 
(１) HP-UX 10.20, 11.0 の場合 

 
1. はじめに 

 
この節では、HP-UX で起動時に FLEXlm ライセンスデーモン(lmgrd)を自動起動する手順に
ついて起動ファイルの作成法を記載します。以下に簡単に順序と内容を説明します。 
 
□ 実行スクリプトファイルの編集 
（/sbin/init.d ディレクトリに存在し、実際に実行されるファイル） 
 

□ コンフィグレーション・スクリプトファイルの作成 
 
（/etc/rc.config.d ディレクトリに存在し、実行スクリプトファイルからよばれる構
成定義用ファイル） 
 

□ Start and Kill ファイルのシンボリックリンクの作成 
 
（/sbin/rc1.d ディレクトリに存在し、HP-UX 起動時および終了時に実行される順番を
定義する。通常、実行スクリプトファイルとシンボリックリンクする。） 
 

2. 実行スクリプトファイルの編集 
 
実行スクリプトファイルは、/sbin/init.d ディレクトリに作成します。 
実行スクリプトファイル名を hpeesof とした場合の実行スクリプトファイルの作成手順を
以下に記載します。 
 
1) /sbin/init.d/template ファイルのコピー 

 
まず元になるファイルからコピーします。 
 
＃  cp  /sbin/init.d/template  /sbin/init.d/hpeesof 
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2) /sbin/init.d/hpeesof ファイルの編集 
 
コピーした /sbin/init.d/hpeesof ファイルの下記の部分を編集します(少し複雑で
す)。基本的には次の項目を設定します。 
 
□ HP-UX 起動/終了時に表示するメッセージ 
('start_msg' および 'stop_msg' の部分) 
 

□ HP-UX 起動/終了時に参照するコンフィグレーション・スクリプトファイルの指定 
('start' および 'stop' の前半の部分) 
 

□ HP-UX 起動および終了時に実行するプログラムの指定 
('start' および 'stop' の後半の部分) 

 
＃  vi /sbin/init.d/hpeesof 
 
 
下記の、    で囲んだ部分を編集してください。太文字太文字太文字太文字は説明です 
 
 

(前半省略) 
 
'start_msg') {{{{■■■■    起動に表示するメッセージの定義の部分起動に表示するメッセージの定義の部分起動に表示するメッセージの定義の部分起動に表示するメッセージの定義の部分    ■■■■}}}} 
# Emit a _short_ message relating to running this script with 
# the "start" argument; this message appears as part of the .. 
echo "Starting the Agilent EEsof EDA FLEXlm daemon .." 
{{{{この上の行が起動時のメッセージです。記入してくださいこの上の行が起動時のメッセージです。記入してくださいこの上の行が起動時のメッセージです。記入してくださいこの上の行が起動時のメッセージです。記入してください}}}}    
;; 
 
'stop_msg') {{{{■■■■    終了時に表示するメッセージの部分終了時に表示するメッセージの部分終了時に表示するメッセージの部分終了時に表示するメッセージの部分    ■■■■}}}} 
# Emit a _short_ message relating to running this script with 
# the "stop" argument; this message appears as part of the .. 
echo "Stopping the Agilent EEsof EDA FLEXlm daemon .." 
{{{{この上の行が停止時のメッセージです。必要なら記入してくださいこの上の行が停止時のメッセージです。必要なら記入してくださいこの上の行が停止時のメッセージです。必要なら記入してくださいこの上の行が停止時のメッセージです。必要なら記入してください}}}}    
;; 
 
'start') {{{{■■■■    起動時に実行される部分の定義起動時に実行される部分の定義起動時に実行される部分の定義起動時に実行される部分の定義    ■■■■}}}}    
 
{{{{この下の部分で、コンフィグレーション・スクリプトファイルの存在を確この下の部分で、コンフィグレーション・スクリプトファイルの存在を確この下の部分で、コンフィグレーション・スクリプトファイルの存在を確この下の部分で、コンフィグレーション・スクリプトファイルの存在を確
認し、存在すればその内容を実行します。存在しなければ、エラーメッセ認し、存在すればその内容を実行します。存在しなければ、エラーメッセ認し、存在すればその内容を実行します。存在しなければ、エラーメッセ認し、存在すればその内容を実行します。存在しなければ、エラーメッセ
ージを表示します。コンフィグレーション・スクリプトファイルのファイージを表示します。コンフィグレーション・スクリプトファイルのファイージを表示します。コンフィグレーション・スクリプトファイルのファイージを表示します。コンフィグレーション・スクリプトファイルのファイ
ル名を定義しル名を定義しル名を定義しル名を定義してください。ただし、このファイルはこの時点ではまだ作成てください。ただし、このファイルはこの時点ではまだ作成てください。ただし、このファイルはこの時点ではまだ作成てください。ただし、このファイルはこの時点ではまだ作成
していませんしていませんしていませんしていません}}}} 
# source the system configuration variables 
if [ -f /etc/rc.config.d/hpeesof ] ; then {{{{設定ファイル名の確認設定ファイル名の確認設定ファイル名の確認設定ファイル名の確認}}}} 
        .  /etc/rc.config.d/hpeesof  {{{{設定ファイルの読み込み設定ファイルの読み込み設定ファイルの読み込み設定ファイルの読み込み}}}} 
else {{{{この下の行はエラーメッセージですこの下の行はエラーメッセージですこの下の行はエラーメッセージですこの下の行はエラーメッセージです}}}} 
echo "ERROR: /etc/rc.config.d/hpeesof defaults file MISSING" 
fi 
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{{{{この下の部分では、コンフィグレーション・スクリプトファイル中で定義この下の部分では、コンフィグレーション・スクリプトファイル中で定義この下の部分では、コンフィグレーション・スクリプトファイル中で定義この下の部分では、コンフィグレーション・スクリプトファイル中で定義
した環境変数がもし１以外に設定されていた場合、表示用のフラグを設定した環境変数がもし１以外に設定されていた場合、表示用のフラグを設定した環境変数がもし１以外に設定されていた場合、表示用のフラグを設定した環境変数がもし１以外に設定されていた場合、表示用のフラグを設定
します。ただし、このファイルおよび環境変数は、この時点ではまだ作成します。ただし、このファイルおよび環境変数は、この時点ではまだ作成します。ただし、このファイルおよび環境変数は、この時点ではまだ作成します。ただし、このファイルおよび環境変数は、この時点ではまだ作成
していませんしていませんしていませんしていません}}}}    
# Check to see if this script is allowed to run...  
if [ "$START_HPEESOF" != 1 ]; then  {{{{１以外ならば下の行を実行１以外ならば下の行を実行１以外ならば下の行を実行１以外ならば下の行を実行}}}}    
rval=2 {{{{２は２は２は２は N/A  N/A  N/A  N/A の意味。変更しなの意味。変更しなの意味。変更しなの意味。変更しないいいい}}}}    
else {{{{１ならば下の行を実行１ならば下の行を実行１ならば下の行を実行１ならば下の行を実行}}}}    
    
{{{{この下の部分のは、コンフィグレーション・スクリプトファイル中で定義この下の部分のは、コンフィグレーション・スクリプトファイル中で定義この下の部分のは、コンフィグレーション・スクリプトファイル中で定義この下の部分のは、コンフィグレーション・スクリプトファイル中で定義
した環境変数がもし１に設定されていた場合に実行される部分です。コロした環境変数がもし１に設定されていた場合に実行される部分です。コロした環境変数がもし１に設定されていた場合に実行される部分です。コロした環境変数がもし１に設定されていた場合に実行される部分です。コロ
ンンンン( : )( : )( : )( : )を削除し、その部分にデーモンを起動するを削除し、その部分にデーモンを起動するを削除し、その部分にデーモンを起動するを削除し、その部分にデーモンを起動する UNIX UNIX UNIX UNIX のコマンドを記入のコマンドを記入のコマンドを記入のコマンドを記入
しますしますしますします}}}}    
# Execute the commands to start your subsystem 
LIC_DIR=/agilent/iccap2002/licenses 
export LIC_DIR 
$LIC_DIR/bin/lmgrd  -c  $LIC_DIR/license.dat  >  $LIC_DIR/flex.log & 
sleep 5  {正常に動作するまで５秒待つ} 
fi 
;; 
 
'stop')  {{{{■■■■    終了時に実行される部分の定義終了時に実行される部分の定義終了時に実行される部分の定義終了時に実行される部分の定義    ■■■■}}}} 
 
{{{{この下の部分では、この下の部分では、この下の部分では、この下の部分では、HPHPHPHP----UX UX UX UX 終了時の定義が行われています。終了時の定義が行われています。終了時の定義が行われています。終了時の定義が行われています。    
本来でしたら、起動しているデーモンを正常終了させるための手続きを定義するので本来でしたら、起動しているデーモンを正常終了させるための手続きを定義するので本来でしたら、起動しているデーモンを正常終了させるための手続きを定義するので本来でしたら、起動しているデーモンを正常終了させるための手続きを定義するので
すが、今回の場合、特に必要ありませんすが、今回の場合、特に必要ありませんすが、今回の場合、特に必要ありませんすが、今回の場合、特に必要ありません}}}} 
# source the system configuration variables 
if [ -f /etc/rc.config ] ; then {{{{変更する必要はありません変更する必要はありません変更する必要はありません変更する必要はありません}}}} 
 . /etc/rc.config   {{{{変更する必要はありません変更する必要はありません変更する必要はありません変更する必要はありません}}}} 
else 
 echo "ERROR: /etc/rc.config defaults file MISSING" 
fi 
 
# Check to see if this script is allowed to run... 
if [ "$CONTROL_VARIABLE" != 1 ]; then 
 rval=2  {{{{変更する必要はありません変更する必要はありません変更する必要はありません変更する必要はありません}}}} 
else 
:  {{{{本来ならば、本来ならば、本来ならば、本来ならば、ここのコロンここのコロンここのコロンここのコロン( : )( : )( : )( : )を削除し、終了用のプログラムを記入します。を削除し、終了用のプログラムを記入します。を削除し、終了用のプログラムを記入します。を削除し、終了用のプログラムを記入します。}}}} 
# Execute the commands to stop your subsystem 
fi 
;; 

(後半省略) 
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3) 最後に、/sbin/init.d/hpeesof ファイルの実行権などを設定します。 
 
＃  chmod  555  /sbin/init.d/hpeesof 
＃  chown  bin  /sbin/init.d/hpeesof 
＃  chgrp  bin  /sbin/init.d/hpeesof 
 
 

3. コンフィグレーション・スクリプトファイルの作成 
 
コンフィグレーションファイルは/etc/rc.config.d ディレクトリに作成します。 
ファイル名は、実行スクリプトで指定したファイル名（通常は実行スクリプトファイルと
同じファイル名）とし、実行スクリプトファイルで指定した環境変数を設定します。 
上記実行スクリプトファイル hpeesof の場合のコンフィグレーションファイルの作成法を、
以下に記載します。 
 
1) 以下のように、新しくファイルを作成します。 

ファイル名は通常実行スクリプトファイル名と同一にします。 
 
＃  vi /etc/rc.config.d/hpeesof 
 

2) 作成したファイルに次のように記入します。 
定義する環境変数は、実行スクリプトファイル中で指定したものと同一の名前で定義
します。 
 
追加内容 
 
# Agilent EEsof EDA IC-CAP 2002 configuration 
# 
# START_HPEESOF:   Set to 1 to start Agilent EEsof EDA IC-CAP 2002 
#                  FLEXlm daemon 
# 
START_HPEESOF=1 
 
＜参考＞追加する内容は、/etc/rc.config.d の他のファイルを 

   ご参照ください。これらのファイルは実際にシステムで 
   使用されているファイルですので、内容を変更しないで 
   ください。 
 
   /etc/rc.config.d/lp  プリンタスプーラの例 
   /etc/rc.config.d/ncs  NCS の例 
   /etc/rc.config.d/nfsconf  NFS の例 

 
3) 最後に、/etc/rc.config.d/hpeesof ファイルの実行権などを設定します。 

 
＃  chmod  444  /etc/rc.config.d/hpeesof 
＃  chown  bin  /etc/rc.config.d/hpeesof 
＃  chgrp  bin  /etc/rc.config.d/hpeesof 
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4. Start and Kill ファイルのシンボリックリンクの作成 
 
最後に Start リンクファイルと Kill リンクファイルを作成します。 
起動したい RUN (INIT)レベルに合わせて、作成するディレクトリを決定します。 
RUN レベルがＮ（Ｎは整数）で起動したい場合は、/sbin/rcN.d ディレクトリに Start 用
のシンボリックリンク・ファイルを作成します。 
一方、Kill 用は、/sbin/rc(N-1).d ディレクトリにシンボリックリンク・ファイルを作成
します。 
 
＜例＞ RUN レベル３で起動する場合 
Start リンクファイルは /sbin/rc３.d ディレクトリに作成 
Kill リンクファイルは /sbin/rc２.d ディレクトリに作成 

 
次に、シンボリックリンク・ファイルのファイル名を決定します。 
シンボリックリンク・ファイルのファイル名の命名規則は下記の通りです。 
 

           Example: /sbin/rc2.d/S060cron 
             ↑  ↑↑ ↑ 
                            ①  ②③ ④ 
 
 ①  Run level number of sequencer directory 
 ②  Sequencing type of sequencer link name      
 S = start link 
 K = kill link 
 ③  Sequence number 
 ３桁の数字で若い順に実行されます。 
 ④  Script name 
 実行スクリプト名です。 

 
 
＜ここまでのまとめ＞ 
 
 □ RUN レベルによってディレクトリが異なります。 

  □ ファイル名がＳで始まれば Start,   Ｋで始まれば Kill を意味します。 
  □ その次の３桁の数字が実行の順番です。 
  □ 最後に実行スクリプト名を定義します。 

 
 
以下のように、新しくファイルを作成します。 
 
1) Start リンク・ファイルの作成法 

 
上記 hpeesof を RUN レベルが３のときに起動させる場合の Start リンク・ファイル
の作成法を以下に記載します。 
この場合、RUN レベルが３より小さい状態から３以上になったときにに起動されます。 
通常は下記のように定義してください。 
 
＃  ln  -s  /sbin/init.d/hpeesof  /sbin/rc3.d/S900hpeesof 
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2) Kill リンク・ファイルの作成法 
 
上記の場合の hpeesof の Kill リンク・ファイルの作成法を以下に記載します。 
この場合、RUN レベルが３以上の状態から２以下になったときに起動されます。 
Kill スクリプトが実行スクリプトの中にない場合には、Kill リンク・ファイルを作
成する必要はありません。 
ですから、今回の場合は作成する必要はありませんが参考のために記載します。 
 
＜注意＞以下の例は参考です。今回は作成する必要はありません。 
 
＃ ln  -s  /sbin/init.d/hpeesof  /sbin/rc2.d/K100hpeesof 

 
 
(２) Solaris 2.7, 2.8 の場合 

 
/etc/rc3.d ディレクトリの下に Shpeesof という名前のファイルを作成し、そのファイルに次
のように記入し、パーミッションモードなどを変更します。 
 
以下の手順は概略です。 
 

＃  cd  /etc/rc3.d 
＃  vi  Shpeesof 

 
＜記入例＞ 
 

  if  [  -f  /agilent/iccap2002/licenses/bin/lmgrd  ] ;  then 
     LIC_DIR=/agilent/iccap2002/licenses 
     export  LIC_DIR 
     $LIC_DIR/bin/lmgrd  -c  $LIC_DIR/license.dat > $LIC_DIR/flex.log & 
     echo  “Starting Agilent EEsof EDA FLEXlm license daemon ...” 
     sleep  5 {{{{デーモンが正常に実行するまで５秒待ちますデーモンが正常に実行するまで５秒待ちますデーモンが正常に実行するまで５秒待ちますデーモンが正常に実行するまで５秒待ちます}}}} 
  fi 

 
記入後、パーミッションモードなどを変更します。 
 
 ＃  chmod  755   Shpeesof 

  ＃  chown  root  Shpeesof 
  ＃  chgrp  sys   Shpeesof 
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４－８ マルチプル(複数)ライセンスサーバでの設定 
 
下記のように、ライセンスファイル（license.lic）の SERVER 行が複数行（正確には奇数行）ある場合は、
各サーバごとに前述した「ライセンスサーバの設定」を行ってください。 
この設定をマルチプル（複数）ライセンスサーバと呼びます。 
 

  SERVER icsvr1   77B44494  1700 
  SERVER icsvr2   19710512  1700 
  SERVER icsvr3   2144BB68  1700 
   
  DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof  ¥ 
         /agilent/iccap2002/licenses/options/local.options 

 
 
 
また、マルチプル（複数）ライセンスサーバの場合、下記の表に示すように動作しているライセンスサー
バの最低台数が定められています。 
 
 

ライセンス 
サーバ合計数 

動作している必要のある最
低ライセンスサーバ数 

1 1 
3 2 
5 3 
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４－９ ライセンスクライアントでの設定 
 
ライセンスクライアントの場合は、FLEXlm のデーモン（lmgrd と agileesof）を実行する必要はありませ
ん。クライアントで FLEXlm ライセンスデーモン(lmgrd) は起動しないでください。 
 
ライセンスクライアントでは、ユーザ毎の環境変数の設定のみで IC-CAP 2002 を起動することができます。
環境変数の設定については、「第５章 ユーザ環境の設定と動作確認」をご参照ください。 
 
 
クライアントのライセンスの設定にポート番号ではなく、ライセンスファイルを指定する場合は、サーバ
と同じライセンスファイルが、クライアントにからも見える必要があります。クライアント上に、ライセ
ンスファイルが無い場合は、ライセンスファイルを IC-CAP のインストールされたディレクトリの licens
es ディレクトリのコピーしておいてください。 
 
 

 
□ライセンスクライアントでのまとめ□ 

 
  ライセンスクライアントでは FLEXlm のデーモン（ lmgrd と agileesof ）を 
実行する必要はありません。 
また、'license.lic' ファイルは、ライセンスサーバで使用しているのと同じ 
ものを用います（変更してはいけません）。 
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４－10 FLEXlm：頻度の多いご質問とその回答 (FAQ) 
 
Ｑ１Ｑ１Ｑ１Ｑ１ ライセンスファイル（ライセンスファイル（ライセンスファイル（ライセンスファイル（license.license.license.license.liclicliclic）の）の）の）の SERVER  SERVER  SERVER  SERVER 行と行と行と行と INCREMENT  INCREMENT  INCREMENT  INCREMENT 行のコンピュータＩＤ番号行のコンピュータＩＤ番号行のコンピュータＩＤ番号行のコンピュータＩＤ番号    

が、が、が、が、uname uname uname uname ----i i i i 命令の結果と異なる（ＨＰコンピュータの場合）命令の結果と異なる（ＨＰコンピュータの場合）命令の結果と異なる（ＨＰコンピュータの場合）命令の結果と異なる（ＨＰコンピュータの場合）    
 

HP-UX の uname -i 命令は、１０進数で表示されます。一方、SERVER 行と INCREMENT 行のコン
ピュータ ID 番号は１６進数で記入されています。ただし、 INCREMENT 行の “VENDOR_STRING=s=コ
ンピュータ ID 番号" は１０進数で記入されています。 
 
＜例＞uname  -i の実行結果が 2008302740 のとき、 SERVER 行および INCREMENT 行に、 
77B44494 (１６進数に変換された値)と記入されます。 
 
 SERVER iccapsvr 77B44494  1700 

INCREMENT iccap_environment agileesof 6.100 25-Mar-2002 1 4CA1113153869C9918D1 ¥ 
VENDOR_STRING=s=2008302740  HOSTID=77B44494 

 
Ｑ２Ｑ２Ｑ２Ｑ２ ノードロックとネットワークライセンスの見分けかたノードロックとネットワークライセンスの見分けかたノードロックとネットワークライセンスの見分けかたノードロックとネットワークライセンスの見分けかた    
 

ノードロックライセンスとネットワークライセンスを見分けるためには、ライセンスファイル（l
icense.lic）を参照します。以下の例のように、license.lic ファイルの INCREMENT 行中に“HO
STID=コンピュータ ID 番号”が記入されていれば、それはノードロックライセンスです。記入さ
れていなければ、ネットワークライセンスです。 
“VENDOR_STRING=s=コンピュータ ID 番号”は両者とも共通です。言い換えれば、INCREMENT 行に“H
OSTID=コンピュータＩＤ番号”が記入されているということは、そのコンピュータのみに限定さ
れたライセンスであると言うことができます。 
 
◇ ノードロックライセンスの例 

 
INCREMENT iccap_environment agileesof 6.1 25-Mar-2002 1 4CA1113153869C9918D1 ¥ 

VENDOR_STRING=s=2008302740 HOSTID=7B859AB4 
         ↑↑↑↑コンピュータＩＤ番号がある場合はノードロックコンピュータＩＤ番号がある場合はノードロックコンピュータＩＤ番号がある場合はノードロックコンピュータＩＤ番号がある場合はノードロック 

 
◇ ネットワークライセンスの例 

 
INCREMENT iccap_environment agileesof 6.1 25-Mar-2002 5 4CA1113153869C9918D1 ¥ 

VENDOR_STRING=s=2008302740 
 
Ｑ３Ｑ３Ｑ３Ｑ３    ノードロックとネットワークライセンス混在型のライセンスファイルの例ノードロックとネットワークライセンス混在型のライセンスファイルの例ノードロックとネットワークライセンス混在型のライセンスファイルの例ノードロックとネットワークライセンス混在型のライセンスファイルの例    

 
ノードロックとネットワークライセンス混在型のライセンスファイルの例は次のようになり 
ます。以下の例は、製品名 iccap_environment がノードロックで、製品名 diode_lib がノードロッ
クとネットワークライセンスで提供できます。同一の製品名がノードロックとネットワークライ同一の製品名がノードロックとネットワークライ同一の製品名がノードロックとネットワークライ同一の製品名がノードロックとネットワークライ
センスに別れている場合、必ずノードロックライセンスの方を行の上（始め）の方に記入しセンスに別れている場合、必ずノードロックライセンスの方を行の上（始め）の方に記入しセンスに別れている場合、必ずノードロックライセンスの方を行の上（始め）の方に記入しセンスに別れている場合、必ずノードロックライセンスの方を行の上（始め）の方に記入し    
てくださいてくださいてくださいてください。さもないと、ネットワークライセンスの方が先に提供されてしまいます。 
    
INCREMENT analysis  agileesof 6.1 25-Mar-2002 1 19710512AC78B9678EED ¥ 
VENDOR_STRING=s=2008302740 HOSTID=7B859AB4 ((((製品名製品名製品名製品名    analysisanalysisanalysisanalysis    のノードロックライセンスの方が先のノードロックライセンスの方が先のノードロックライセンスの方が先のノードロックライセンスの方が先)))) 
INCREMENT analysis  hpeesofd 7.000 25-Mar-98 2 19710512AC78B9678EED ¥ 
VENDOR_STRING=s=2008302740                 ((((製品名製品名製品名製品名 analysis  analysis  analysis  analysis のネットワークライセンスの方が後のネットワークライセンスの方が後のネットワークライセンスの方が後のネットワークライセンスの方が後)))) 
INCREMENT schematic hpeesofd 7.000 25-Mar-98 1 4CA1113153869C9918D1 ¥ 
VENDOR_STRING=s=2008302740 HOSTID=7B859AB4 ((((製品名製品名製品名製品名    iccap_enviccap_enviccap_enviccap_env… … … … はノードロックライセンスのみはノードロックライセンスのみはノードロックライセンスのみはノードロックライセンスのみ))))    
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Ｑ４Ｑ４Ｑ４Ｑ４    ノードロックライセンスを別のライセンスサーバから提供する方法ノードロックライセンスを別のライセンスサーバから提供する方法ノードロックライセンスを別のライセンスサーバから提供する方法ノードロックライセンスを別のライセンスサーバから提供する方法 
 

FLEXlm のライセンスサーバであるコンピュータＡから、ノードロックライセンスを別のコンピュ
ータＢに提供することができます。 
以下の例は、ライセンスサーバ：77B44494 から、ノードロックライセンスを 7829B7FF に提供で
きるライセンスファイル（license.lic）の例です。 
 
 ライセンスサーバ（供給側）  2008302740（１０進数）＝ 77B44494（１６進数） 
ノードロックの受取側     2015999999（１０進数）＝ 7829B7FF（１６進数） 
 
SERVER iccapsvr 77B44494  1700 
    ↑ライセンスサーバはこのコンピュータ↑ライセンスサーバはこのコンピュータ↑ライセンスサーバはこのコンピュータ↑ライセンスサーバはこのコンピュータ    
INCREMENT schematic hpeesofd 7.000 25-Mar-98 1 4CA1113153869C9918D1 ¥ 
VENDOR_STRING=s=2008302740 HOSTID=7829B7FF 

                                        ↑ノードロックライセンスはこのコンピュータに対して有効↑ノードロックライセンスはこのコンピュータに対して有効↑ノードロックライセンスはこのコンピュータに対して有効↑ノードロックライセンスはこのコンピュータに対して有効    
 

Ｑ５Ｑ５Ｑ５Ｑ５    複数の複数の複数の複数の lmgrd  lmgrd  lmgrd  lmgrd を同時に起動する方法を同時に起動する方法を同時に起動する方法を同時に起動する方法 
 
FLEXlm では、１台のコンピュータ上で複数の lmgrd デーモンを同時に起動することができます。 
ただし、その場合、TCP ポート番号をそれぞれ異なった値に設定する必要があります。 
 
ただし、ベンダデーモン agileesof は、１台のコンピュータ上で１つしか実行できませんので注
意してください。 
 
＜ライセンスファイルの例：サーバが同一でベンダデーモンが異なる例＞ 
 

□ license.dat ファイル１つめ 
 
SERVER iccapsvr 77B44494  1700 
DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof 
INCREMENT iccap_environment agileesof 6.1 25-Mar-2002 1 4CA1113153869C9918D1 ¥ 
VENDOR_STRING=s=2008302740 HOSTID=77B44494 

  
□ license.dat ファイル２つめ 
 
SERVER iccapsvr 77B44494  1705 
DAEMON  wind  /usr/local/flexlm/licenses/vendors/wind 
INCREMENT comp wind 3.51 25-Mar-98 3 4CA1113153869C9918D1 “s=2008302740" 77B44494 

 
 
もし、同一のコンピュータ上で、同一のベンダデーモン agileesof を複数起動しなければならな
いときは、弊社までお問い合わせください。新しいライセンスファイル（license.lic）をお送り
します。ADS 2002 以降は IC-CAP 2002 と同一のベンダデーモン agileesof を使用しています。 
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Ｑ６Ｑ６Ｑ６Ｑ６    複数のライセンスファイル（複数のライセンスファイル（複数のライセンスファイル（複数のライセンスファイル（ license. license. license. license.liclicliclic    ）のマージ（結合））のマージ（結合））のマージ（結合））のマージ（結合） 

 
複数のライセンスファイル（license.lic）を１つのファイルにまとめることもできます。 
ただし、それぞれのライセンスファイルが以下の条件の両方を同時に満たしていなければなりません。 
 
(１) それぞれのライセンスファイルの SERVER 行の行数が完全に一致すること。 
(２) ライセンスファイルの  SERVER 行のコンピュータ ID 番号が完全に一致すること 
 
以下に、IC-CAP 2002 と ADS 1.5 のマージされたライセンスの例を示します。 
 

SERVER iccapsvr 080001971512 1700 
DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof 
DAEMON hpeesofd /ads15/licenses/vendors/hpeesofd 
INCREMENT iccap_environment agileesof 6.1 25-Mar-2002 4 4CA1113153869C91 ¥ 

VENDOR STRING=s=080001971512 
INCREMENT schematic hpeesofd 1.500 12-May-2002 3 5CA7773153869C991 ¥ 
“s=080001971512” 

 
以下に、まとめることのできないできないできないできないライセンスファイルの例を示します。 
 
(１) SERVER 行の行数行数行数行数が異なる例 

 
□ license.lic ファイル１つめ 
 
SERVER icsvr1 77B44494  1700 
 

□ license.lic ファイル２つめ 
 
SERVER icsvr1 77B44494  1700 
SERVER icsvr2 8578AA43  1700 
SERVER icsvr3 908AE590  1700 

 
(２) SERVER 行のコンピュータＩＤ番号コンピュータＩＤ番号コンピュータＩＤ番号コンピュータＩＤ番号が異なる例 

 
同一のコンピュータ(ホスト名が同じ)であるが、uname -i と /etc/lanscan で発行され
ている例 
□ license.lic ファイル１つめ（uname -i で発行） 
 
SERVER icsvr1 77B44494  1700 
 

□ license.lic ファイル２つめ（/etc/lanscan で発行） 
 
SERVER icsvr1 080001971512  1700 
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Ｑ７Ｑ７Ｑ７Ｑ７    複数のライセンスファイル（複数のライセンスファイル（複数のライセンスファイル（複数のライセンスファイル（ license. license. license. license.liclicliclic    ）を参照する方法）を参照する方法）を参照する方法）を参照する方法 
 
環境変数 LM_LICENSE_FILE を使ってライセンスファイル（license.lic）を指定する必要があり
ます。通常は次のようになります。 
 
◇ Ｂシェル（/bin/sh）または、Ｋシェル（/bin/ksh）の場合 

 
＄ LM_LICENSE_FILE=/agilent/iccap2002/licenses/license.lic 
＄ export  LM_LICENSE_FILE 
＄  env  |  grep  LM_LICENSE_FILE （確認） 
 

◇ Ｃシェル（/bin/csh）の場合 
 
 ％ setenv LM_LICENSE_FILE /agilent/iccap2002/licenses/license.lic 

％ env  |  grep  LM_LICENSE_FILE （確認） 
 
FLEXlm では、複数のライセンスファイル(license.lic)にまたがってライセンスを提供すること
ができます。その例は次のようになります(ＢシェルまたはＫシェルの場合のみを記述します） 
 

＄ LM_LICENSE_FILE=/iccap2002/licenses/license.lic:/ads15/licenses/license.lic 
＄ export  LM_LICENSE_FILE              ↑ コロンで区切る 

 
上記のように、２つのライセンスファイルをコロン( : )で区切って定義します。 
この場合、最初（左側）に定義したライセンスファイルの方が先に使用されますので、ノードロこの場合、最初（左側）に定義したライセンスファイルの方が先に使用されますので、ノードロこの場合、最初（左側）に定義したライセンスファイルの方が先に使用されますので、ノードロこの場合、最初（左側）に定義したライセンスファイルの方が先に使用されますので、ノードロ
ックライセンスのライセンスファイルの方を最初（左側）に定義してくださいックライセンスのライセンスファイルの方を最初（左側）に定義してくださいックライセンスのライセンスファイルの方を最初（左側）に定義してくださいックライセンスのライセンスファイルの方を最初（左側）に定義してください。 
    
前記の例では、同一のコンピュータに IC-CAP 2002 と ADS 1.5 がインストールされている例な
ので、２つのライセンスファイルがローカルディスク上に存在していました。 
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前述とは異なり、例えば IC-CAP 2002 がコンピュータにインストールされていている場合で、ロ
ーカルディスクのライセンス以外にも別の IC-CAP 2002 のライセンスファイルを参照するために
は、次の２つの方法が考えられます。 
 
＜方法１＞もう一つのライセンスファイルを自分のコンピュータにコピーし、適当な 

ディレクトリまたはファイル名を付ける。 
 
元々ある IC-CAP 2002 のライセンスファイル(license.lic）の他に、もう一つの別
のライセンスファイルを持ってきて（コピーして）、そのライセンスファイル名を 
license2.lic とします。 
 
＄ LM_LICENSE_FILE=/iccap2002/licenses/license.lic：/iccap2002/licenses/license2.lic 
＄ export LM_LICENSE_FILE          ↑ コロンで区切る 

 
＜方法２＞もう一つのライセンスファイルを自分のコンピュータにコピーしないで、ネット 

ワークを経由して参照する。 
 
そのライセンスファイルをそれぞれのコンピュータに置いたままの状態で次のように
定義します。ネットワークを経由して参照する場合の文法は “TCP ポート番号＠ホ
スト名”です。 
 
＄ LM_LICENSE_FILE=/iccap2002/licenses/license.lic：1705@icsvr2 
＄ export  LM_LICENSE_FILE         ↑ コロンで区切る 
 
上記の例では、まず最初に、自分のコンピュータ上の license.lic ファイルを検索
します。そしてその後、ホスト名“icsvr2”のコンピュータ上で FLEXlm が動作して
いて、その TCP ポート番号が 1705 であれば、直接ホスト名 icsvr2 に TCP ポート
番号 1705 を使って通信を行います。 
この場合、ファイルではなくライセンスサーバのホスト名と TCP ポート番号を通じ
てライセンス情報を取得しています。「間接的にライセンスファイル(license.lic)
を参照している」とも 表現できます。 
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Ｑ９Ｑ９Ｑ９Ｑ９    すでに動作しているシステムにライセンスを追加する方法すでに動作しているシステムにライセンスを追加する方法すでに動作しているシステムにライセンスを追加する方法すでに動作しているシステムにライセンスを追加する方法    
 

現在動作しているシステムに、ライセンスを追加する場合は、まずライセンスファイル（license.
lic）のマージ(結合)を考えます。結合できる場合は、次の手順を実行してください。 
 
□ １つ目の(すでに持っている)ライセンスファイル 
 
SERVER icsvr 2008302740 1700 
DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof 
INCREMENT iccap_environment agileesof 6.0 29-apr-2003 20 4969C91B6F09 ¥ 
        VENDOR_STRING=s=2014460207 
INCREMENT lcrz_driver agileesof 6.0 29-apr-2003 20 5AF2D41FEF59 ¥ 
        VENDOR_STRING=s=2014460207 
INCREMENT noise_driver agileesof 6.0 29-apr-2003 20 5C6B2D026D71 ¥ 
        VENDOR_STRING=s=2014460207 
INCREMENT p_si_tft agileesof 6.0 29-apr-2003 20 F30201092DDB ¥ 
        VENDOR_STRING=s=2014460207 
 

□ ２つ目の(今回追加する)ライセンスファイル：（ philips_mextram_bjt ）を１本追加購入 
 
SERVER icsvr 2008302740 1700 
DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof 
INCREMENT philips_mextram_bjt agileesof 6.0 29-apr-2003 20 ¥ 
        F7F733C4DAB7 VENDOR_STRING=s=2014460207 
 

ライセンスファイルの結合は、以下のように新たに購入した INCREMENT の行のみを追加します。 
 
□ 結合したライセンスファイル 
 
SERVER icsvr 2008302740 1700 
DAEMON agileesof /agilent/iccap2002/licenses/vendors/agileesof 
INCREMENT iccap_environment agileesof 6.0 29-apr-2003 20 4969C91B6F09 ¥ 
        VENDOR_STRING=s=2014460207 
INCREMENT lcrz_driver agileesof 6.0 29-apr-2003 20 5AF2D41FEF59 ¥ 
        VENDOR_STRING=s=2014460207 
INCREMENT noise_driver agileesof 6.0 29-apr-2003 20 5C6B2D026D71 ¥ 
        VENDOR_STRING=s=2014460207 
INCREMENT p_si_tft agileesof 6.0 29-apr-2003 20 F30201092DDB ¥ 
        VENDOR_STRING=s=2014460207 
INCREMENT philips_mextram_bjt agileesof 6.0 29-apr-2003 20 ¥       ((((追加分追加分追加分追加分)))) 
        F7F733C4DAB7 VENDOR_STRING=s=2014460207 
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Ｑ１０Ｑ１０Ｑ１０Ｑ１０    ICICICIC----CAP CAP CAP CAP を実行するとを実行するとを実行するとを実行すると Security warning  Security warning  Security warning  Security warning が表示されるが表示されるが表示されるが表示される    
    

基本的に、ライセンスは１８ヶ月で有効期限切れになります。 
下記のような Warning メッセージが表示される場合は、弊社までご連絡ください。 
新しいライセンスをお送りします。 
 
＜期限切れ約２週間前頃から表示されるメッセージ例＞ 
 
Security warning: license for 製品名 will expire in Ｘ day(s) 
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Ｑ１１Ｑ１１Ｑ１１Ｑ１１    lmgrd, agileesof lmgrd, agileesof lmgrd, agileesof lmgrd, agileesof とととと    アプリケーションソフトの関係（ライセンスの授受）アプリケーションソフトの関係（ライセンスの授受）アプリケーションソフトの関係（ライセンスの授受）アプリケーションソフトの関係（ライセンスの授受） 
 

lmgrd, agileesof とアプリケーションソフトの関係および、ライセンスの受け渡し手順を説明
します。以下の手順でライセンスの授受が行われます。この手順のなかで、どれか１つでも正常
に動作しない場合は、ライセンスが正常に提供できません。言い換えれば、もしアプリケーショ
ンソフトが正常に動作しない場合は、以下の各項目をご確認ください。 
 
① ライセンスファイル（license.lic）を見つける。 

 
環境変数  LM_LICENSE_FILE で指定されたライセンスファイル(license.lic)を検索します。
ですから、環境変数 LM_LICENSE_FILE でライセンスファイルを正確に指定する必要があり
ます。環境変数は、UNIX の env 命令で環境変数の確認ができます。 
 

② ライセンスファイル（license.lic）の中の、SERVER 行のホスト名と TCP ポート番号を入手する。 
 
発見したライセンスファイル（license.lic）を一般ユーザでオープンする必要があります
ので、一般ユーザでも READ の権利があることが条件です。また、SERVER 行のホスト名と T
CP ポート番号は正しく設定されていることは言うまでもありません。 
 

③ 入手したホスト名と TCP ポート番号を使って、ライセンス管理デーモン lmgrd にコンタ ク
トする。lmgrd と通信する内容は、「ベンダデーモン agileesof と話がしたい」 
 
ここで始めて通信が行われます。ネットワークが正常に動作していていることが最低限の 
条件です。 
 

□ 入手したホスト名で ping 命令が通じることをご確認ください。 
□ 定義されている TCP ポート番号がそのネットワーク上で使用されていないことも条
件の一つです。 

□ NIS や DNS を使用しているときは、NIS や DNS が正常に起動していることをご確
認ください。 

 
lmgrd と通信する内容は、「ベンダデーモン agileesof と話がしたい」という内容です。 
つまり、lmgrd は直接ライセンスを提供しているわけではないと言うことです。 
もちろん、lmgrd が正常に動作していることが条件です。 
 

④ lmgrd は、ベンダデーモン agileesof のホスト名と TCP ポート番号を調べ、その結果を返す。 
 

⑤ lmgrd から教えられた、ベンダデーモン agileesof のホスト名と TCP ポート番号から、ag
ileesof にコンタクトする。agileesof と通信する内容は、「ライセンスをください」 
 
agileesof と通信する内容は、「ライセンスをください」という内容です。つまり、agilee
sof がライセンスの管理を行っていると言うことです。また、lmgrd が agileesof にライ
センス要求を出すのではなく、アプリケーションソフトから直接 agileesof にライセンス
要求を出すという点もご記憶ください。もちろん、agileesof が正常に動作していることが
条件です。 
 

⑥ ベンダデーモン agileesof はアプリケーションソフトからのライセンス要求により、使用
可能なライセンスを調べ、もし可能であればアプリケーションソフトに直接与える。 
 
使用可能なライセンスがあることが条件です。 
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lmgrdlmgrdlmgrdlmgrd agileesofagileesofagileesofagileesof

IC-CAPIC-CAPIC-CAPIC-CAP

② license.lic の中の SERVER の行に記載されて
　 いるホスト名と TCPポート番号を入手する。

① ライセンスファイル license.lic を見つける

③ 入手したホスト名と TCPポート番号によりサーバの lmgrd に
　 コンタクトし、ベンダデーモン agileesof と通信したいと伝える

④ ベンダデーモンのホスト名と
    TCPポート番号を調べその結果を返す

⑤ ベンダデーモンに
　 ライセンス要求を送る

⑥ ライセンスの空きを調べ
　 その結果を返す

 
 
 
上図は、前ページで説明したライセンスの受け渡し手順を図であらわしたものです。 
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４－11 IC-CAP 2002 のライセンスの対応 
 

IC-CAP 2002 (Ver.6.1)と、ライセンスの対応は以下のようになっています。 
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 51

第５章 ユーザ環境の設定と動作確認                       

 
５－１ ユーザ設定と動作確認の概要 
 
この章では、IC-CAP の動作確認について説明します。また、プリンタ・プロッタの設定や、測定器の確認
も行います。プリンタ・プロッタは既にUNIX で設定されていることを前提としています。また、GPIB(HP-
IB)も正常に動作していることを前提としています。 
 
 
   プリンタ／プロッタの設定 
 
 
      各ユーザ毎の設定 
 
 
              IC-CAP の動作確認 
 
 
             プリンタの動作確認 
 
 
       オンラインマニュアルの動作確認 
 
      
          プリンタの動作確認 
 
 
      測定器の動作確認 
 
 
       IC-CAP が動作しないときの対策 
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５－２ プリンタ・プロッタの設定 
 
(１) プリンタ／プロッタの設定方法 

 
IC-CAP 2002 でのプリンタ／プロッタの設定方法を説明します。 
IC-CAP 2002 では、プリンタ／プロッタの設定は、eehcopy.setupeehcopy.setupeehcopy.setupeehcopy.setup ファイルを編集します。 
 
 

 
＜前提条件＞ 

プリンタ／プロッタは既に UNIX で設定／登録されていることを前提としています。 
次の命令を実行し、プリンタにテキストファイルが正常に出力できることをご確認 
ください。また、使用するプリンタ／プロッタの論理名をご確認ください。 
詳細は、「８章 付録」をご参照ください。 
 
  lp  -d ﾌﾟﾘﾝﾀ論理名  /etc/group 
 
 
IC-CAP 2002 でサポートしているプリンタ／プロッタは次のようになります。 
 

プリンタ ： ポストスクリプト または HP-GL/2 の機能があるもの 
プロッタ ： HP 社製でシリアルインターフェイスの機能があるもの 

 
プリンタ／プロッタの設定は、eehcopy.setupeehcopy.setupeehcopy.setupeehcopy.setup ファイルを編集します。 
 
＃ vi  /agilent/iccap2002/config/eehcopy.setup 
 
次のように、使用しているプリンタ／プロッタにあわせて論理名を変更します。 
 
■ ポストスクリプトプリンタの場合の例（プリンタの論理名が hpps の場合） 

 
      □ HP の場合 
 
  ps:  PS  A 
          lp  -dhpps  -onb  $(OUTPUTFILE); echo  "File Printed" 
          ↑ 
     ポストスクリプトプリンタの論理名 
 
      □ SUN の場合 
 
  ps:  PS  A 
          lpr  -Phpps  $(OUTPUTFILE); echo  "File Printed" 
           ↑ 
     ポストスクリプトプリンタの論理名 
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 ■ プロッタまたは、HP-GL 対応のプリンタ場合の例（プロッタの論理名が hp7550a の場合） 
 
      □ HP の場合 
 
  hpplot:  HP7550 A 
          lp  -dhp7550a  -onb  $(OUTPUTFILE); echo  "File Printed" 
           ↑ 
     プロッタの論理名 
 
      □ SUN の場合 
 
  hpplot:  HP7550 A 
                   lpr  -Php7550a  .... $(OUTPUTFILE); echo  "File Printed" 
    ↑ 
             プロッタの論理名 
 
 ■ HP-GL/2 対応 プリンタの場合の例（プリンタの論理名が hpgl2 の場合） 
 
      □ HP の場合 
 
  HPLJIII:  HPGL2 A 
          echo "途中省略 tmp;lp  -dhpgl2  -onb  $$.tmp;rm  $$.tmp 
                  ↑ 
          プリンタの論理名 
 
      □ SUN の場合 
 
  HPLJIII:  HPGL2 A 
          echo "途中省略 ｜ lpr  -Phpgl2   
                     ↑ 
             プリンタの論理名 
 

＜参考：lp, lpr 命令のオプション説明＞ 
 

lp  -d プリンタ論理名 ：出力プリンタの指定（ＨＰコンピュータ） 
lpr -P プリンタ論理名 ：出力プリンタの指定（ＳＵＮコンピュータ） 

 
 
   ＜参考：バナーを出力しない方法＞ 
 
  バナー（ユーザ名などが印刷された最初に出てくる余分な紙）を、出力しない 
  ようにするためには、lp 命令に -onb オプションを付けます。 
 
  ＜例＞ lp  -dlj4pj  -onb ..... 
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(２) eehcopy.setup ファイルの補足説明 
 
eehcopy.setup ファイルの中は、次の３つの [大カッコ] の部分に分類することができます。 
 
 [GRAPHICS] IC-CAP からの画像（グラフ）データの出力の定義 

  [TEXT]  IC-CAP からのテキスト（数値リスト）の出力の定義 
  [SCREEN]  IC-CAP 2002 では使用できません（ハードコピー）。 

 
実際のプリンタ／プロッタ出力の定義は、次の２行で構成されています。（２行で１組になりま
す）。[GRAPHICS] の場合は、以下のようなフォーマットになっています。 

 
 
 File > Printer Setup...File > Printer Setup...File > Printer Setup...File > Printer Setup...  
 メニューで表示される フォーマット  用紙 
   
   ps:  PS  A 
   lp  -dps  $(OUTOUTFILE); echo “File printed” 
 
 UNIX から出力するための命令                プリンタ論理名 
 

 
もし、プリンタ論理名が hpps というポストスクリプトプリンタに出力したいときには、次のよ
うに変更します（File/Printer SetupFile/Printer SetupFile/Printer SetupFile/Printer Setup メニューでの表示は psprinter とします） 
 

                     File > Printer SetupFile > Printer SetupFile > Printer SetupFile > Printer Setup メニューでの表示 
 
 psprinter:  PS  A 
 lp  -dhpps  $(OUTOUTFILE); echo “File printed” 
 
                          プリンタ論理名 

 
 
IC-CAP 2002 には、以下のフォーマットが用意されています。 
 
フォーマットフォーマットフォーマットフォーマット    詳細詳細詳細詳細    用紙用紙用紙用紙(US ANSI)(US ANSI)(US ANSI)(US ANSI)    用紙用紙用紙用紙(Metric ISO)(Metric ISO)(Metric ISO)(Metric ISO)    
PS Postscript A なし 
HP7440 Colorpro A A4 
HP7470 2-pen, manual feed A A4 
HP7475 6-pen, manual feed A,B A4,A3 
HP7550 8-pen, auto feed A,B A4,A3 
HP7570 Draft Pro C,D A2,A1 
HP7575 Draft Pro DXL/EXL A,B,C,D A4,A3,A2,A1 
HP7576 Draft Pro DXL/EXL A,B,C,D,E A4,A3,A2,A1,A0 
HP7580 8-pen, manual feed A,B,C,D A4,A3,A2,A1,A0 
HP7585 8-pen, sheet feed A,B,C,D,E A4,A3,A2,A1,A0 
HP7586 8-pen, sheet feed A,B,C,D,E A4,A3,A2,A1,A0 
HP7595 Draftmaster A,B,C,D,E A4,A3,A2,A1,A0 
HP7596 Draftmaster A,B,C,D,E A4,A3,A2,A1,A0 
HPGL2 LaserJet III 全て 全て 
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(３) PCL プリンタへの画像（グラフ）データの出力 
 
IC-CAP 2002 では、PCL フォーマットがサポートされていません。HP-GL と PostScript フォ
ーマットのみ対応しています。 
 
PCL フォーマットのプリンタをお使いの方は、次に示す Ghostscript と呼ばれるフォーマット
変換ソフトウエア(GNU ソフトウェア・IC-CAP 2002 に標準収録) を使用して PostScript から
PCL に変換し、出力できます。 
（IC-CAP 2002 → PostScriptﾌｫｰﾏｯﾄ→ Ghostscriptﾌﾟﾛｸﾞﾗﾑ→ PCLﾌｫｰﾏｯﾄ→ PCL プリンタ） 
 
 
****注意注意注意注意**** ghostscript についての詳細は、$ICCAP_ROOT/lib/ghostscript/doc ディレクトリに
収録されている文書をご参照ください。 
 
 
以下のように eehcopy.setup ファイルの中を変更してください。 
 
 

 
pcl: PS A 
gs -q -sDEVICE=ljet4 –r300 -I$ICCAP_ROOT/lib/ghostscript -dNOPAUSE -sOutputFile 
=¥|"lp -dlj4pj -onb -oraw" - < $(OUTPUTFILE)  
 
           プリンタ論理名          PCL 出力 

 
 
-sDEVICE=ljet4 の ljet4 の部分が、フォーマット形式になります。 
用意されているフォーマットは以下のようになります。 
 
laserjetlaserjetlaserjetlaserjet    generic Laserjet printergeneric Laserjet printergeneric Laserjet printergeneric Laserjet printer    

ljet2pljet2pljet2pljet2p    LaserJet 2PLaserJet 2PLaserJet 2PLaserJet 2P    

ljet3ljet3ljet3ljet3    LaserJet 3LaserJet 3LaserJet 3LaserJet 3    

ljet4ljet4ljet4ljet4    LaserLaserLaserLaserJet 4Jet 4Jet 4Jet 4    

ljetplusljetplusljetplusljetplus    LaserJet PlusLaserJet PlusLaserJet PlusLaserJet Plus    

lj250lj250lj250lj250    DEC LJ250DEC LJ250DEC LJ250DEC LJ250    

deskjetdeskjetdeskjetdeskjet    generic DeskJet printergeneric DeskJet printergeneric DeskJet printergeneric DeskJet printer    

cdj500cdj500cdj500cdj500    DeskJet 500CDeskJet 500CDeskJet 500CDeskJet 500C    

cdj550cdj550cdj550cdj550    DeskJet 550CDeskJet 550CDeskJet 550CDeskJet 550C    

pjxl300pjxl300pjxl300pjxl300    PaintJet XL300PaintJet XL300PaintJet XL300PaintJet XL300    

declj250declj250declj250declj250    DEC LJ250 (lj250DEC LJ250 (lj250DEC LJ250 (lj250DEC LJ250 (lj250とは別物とは別物とは別物とは別物))))    
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(４) eehcopy.setup ファイルの例 
 
eehcopy.setup ファイルの例を示します。 
以下の例は、HP LJ4PJ プリンタ（PCL と HP-GL をサポート）に画像（グラフ）とテキスト
（数値リスト）を出力する例です。 
ここで、プリンタ論理名は lj4pj、HP-GL 出力用のオプションは -ohpgl2、PCL 出力用のオプ
ションは -oraw（ 今回はGhostscript 経由）、バナーなしのオプションは -onb です。 
 
 
[GRAPHICS] 
 
lj4pj_HPGL: HP7550 A 
 lp -dlj4pj -ohpgl2 -onb  $(OUTPUTFILE); echo "File plotted" 
 
lj4pj_PCL: PS A 
       gs -q -sDEVICE=ljet4 –r300 -I$ICCAP_ROOT/lib/ghostscript -dNOPAUSE –sOutpu
tFile=¥|"lp -dlj4pj -onb -oraw" - < $(OUTPUTFILE) 
 
[TEXT] 
lp: 
         lp -dlj4pj -onb $(OUTPUTFILE); echo "Text File printed" 
 
 
 

 上記の設定で、File > Printer SetupFile > Printer SetupFile > Printer SetupFile > Printer Setup メニュー（後述）での表示は、lj4pj_HPGL（HP-GL 用） 
 および lj4pj_PCL（PCL 用）になります。 
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(５) プリンタ/プロッタが動作しないときの対策 
 
1) まず、UNIX でプリンタの設定を行ってください。 

 
2) UNIX では動作しますか？ 

 
UNIX でプリンタが動作するかどうか確認します。 
 
HP の場合 ＃ lp   -dプリンタ論理名 /etc/group 
 
SUN の場合 ＃ lpr  -Pプリンタ論理名  /etc/group 

 
 

3) プリンタ/プロッタの論理名は正しいですか？ 
 
プリンタ/プロッタの論理名を確認します。 
 
＃ lpstat  -t 

 
4) スケジューラは動作していますか？ 

 
前述した lpstat -t 命令を実行し、スケジューラが動作しているかどうか確認します。 
 

5) プリンタ/プロッタは出力可能になっていますか？ 
 
前述した lpstat -t 命令を実行し、該当するプリンタ/プロッタの論理名が出力可能かど
うか確認します。 
 

6) 今までは動作していましたか？ または、今回が初めてのご使用ですか？ 
 
□ 今まで動作していた場合は、何か変更したところはありますか（ケーブルなど）。 
 

□ 初めての場合は、正しいケーブルを使用していますか。 
(シリアルケーブルには“クロス”と“ストレート”がありますが、プリンタ/プロッタ
の接続には“クロス”を用います) 
 

□ 接続する場所（コネクタ）は正しいですか。 
(HP7550 プロッタには、RS-232C のコネクタとして ”COMPUTER/MODEM” と “TERMINAL” 
の２つがありますが、コンピュータから出力する場合は、”COMPUTER/MODEM” にケーブ
ルを接続します) 
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５－３ 各ユーザ毎のシステムファイルの編集 
 
IC-CAP を使用するユーザ毎にソフトウェアのパスと環境変数の設定をします。 
 
追加するパスは、$ICCAP_ROOT/bin ($ICCAP_ROOT は IC-CAP 2002 がインストールされているディレクト
リ)です。環境変数は、ICCAP_ROOT と、LM_LICENSE_FILE です。 
 
環境変数の説明を行います。 
 
 ICCAP_ROOT IC-CAP 2002 がインストールされているディレクトリを指定。 
   通常は /agilent/iccap2002 です。 
 
 LM_LICENSE_FILE license.lic ファイルの場所をフルパスで指定。 
   通常は /agilent/iccap2002/licenses/license.lic です。 
 
上記の環境変数とパスを、各ユーザのフォームディレクトリのファイルに追加します。 
使用しているシェルの種類によって、追加するファイル名と文法が異なります。 
 

■ B または K シェルの場合 
 
各ユーザのホームディレクトリにある .profile ファイルに追加します。 
 
＄  vi  .profile 
 
追加内容の例 
（IC-CAP 2002 がインストールされているディレクトリを /agilent/iccap2002 とします） 
 
ICCAP_ROOT=/agilent/iccap2002 
LM_LICENSE_FILE=/agilent/iccap2002/licenses/license.lic 
export  ICCAP_ROOT LM_LICENSE_FILE 
PATH=$ICCAP_ROOT/bin:$PATH 
export  PATH 
 

■ C シェルの場合 
 
各ユーザのホームディレクトリにある .cshrc ファイルに追加します。 
 
％  vi  .cshrc 
 
追加内容の例 
（IC-CAP 2002 がインストールされているディレクトリを /agilent/iccap2002 とします） 
 
setenv  ICCAP_ROOT  /agilent/iccap2002 
setenv  LM_LICENSE_FILE  /agilent/iccap2002/licenses/license.lic 
set path＝($ICCAP_ROOT/bin  $path) 
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■ デスクトップ環境に CDE を使用している場合 
 
デスクトップ環境に CDE を使用している場合は、各ユーザのホームディレクトリにある.dtprofi
le ファイルに変更を加え、さらに前述したファイル（.profile または .cshrc）にパスと環境変
数を追加します。 
 
＄  vi .dtprofile 
 
 変更内容（ .dtprofile ファイルの最後） 
 
# 
# If $HOME/.profile (.login) has been edited as described above, uncomment 
#  the following line. 
# （もし .profile か .login ﾌｧｲﾙを変更したら下の＃を消してください） 
DTSOURCEPROFILE=true 
↑ 
先頭の＃を取る。 
 
前述の .profile または .cshrc ファイルへのパスと環境変数の追加はデスクトップ環境の種類
にかかわらず、必ず行ってください。 
 
 
 

 
 
 
＜参考：パスと環境変数の確認方法は？＞ 
 
現在設定されているパスと環境変数を確認する UNIX の命令は env 命令です。 
 
＄  env  |  grep  iccap2002  [Return] 
 
 
＜実行例＞ ICCAP_ROOT=/agilent/iccap2002 

LM_LICENSE_FILE=/agilent/iccap2002/licenses/license.lic 
PATH=/agilent/iccap2002/bin:/usr/bin:/...... 
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５－４ 動作確認 
 
(１) IC-CAP を実行できるユーザアカウントでログインします。 

（正確には、IC-CAP が実行できるパスと環境変数が設定されているユーザです。） 
 

(２) IC-CAP を実行します。 
 
＄  iccap 
 
＜参考＞もし、正常に IC-CAP が起動できない場合は、「５－６節 IC-CAP 2002 が動作しない
ときの対策」項をご覧ください。 
 
正常であれば、IC-CAP を実行したウインドに次のように表示されます。 
Version 2002 であることが確認できます。 
 
IC-CAP Copyright (c) 1990-2002 Agilent Technologies 

Version 2002 610.300 Jun 24 2002 
 
次のようなウインドが現れます。このウインドのことを、Status Status Status Status ウインドと呼びます。 
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(３) 次にウインドが現れます。このウインドのことを、MainMainMainMain    ウインドと呼びます。 
 
MainMainMainMain ウインドの右端の Help > About...Help > About...Help > About...Help > About...    メニューを選択すると IC-CAP のバージョンが確認
できます。バージョンが 2002 になっていることをご確認ください。 

 

   
   
(４) サンプルファイルを読み込みます。 

Main ウインドウの左端の File > Examples...File > Examples...File > Examples...File > Examples...    メニューを選択します。 
ダイアログボックスウインドが現れますので、/agilent/iccap2002/examples/model_files/bjt
ディレクトリの bjt_npn.mdl ファイルを選択します。次のような大きなウインドが現れます。 
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(５) DUT 名 dc の中の、① fgummel セットアップを選択します。 
その後、② plots タブを選択すると下記のようなウインドになります。 
ここで ③ Display All を選択すると２つのグラフのウインドが現れます。 
 
 ① fgummel の選択     ③ Display All の選択 ② plots タブの選択 
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(６) グラフのウインドウ（２つのうちどちらでもかまいません）の File > Printer Setup ...File > Printer Setup ...File > Printer Setup ...File > Printer Setup ...メニ
ューを選択します。ここで、① Graphics を選択し、② Printer を選択し、③ eehcopy.setup
 ファイルの中で定義した名前を選択します。[OK] を選択し終了します。 

 
  ① Graphics ② Printer ③ eehcopy.setup ファイルの中で定義した名前 
 

     
  
 
 
(７) グラフのウインドの File > Print File > Print File > Print File > Print メニューを選択します。プリンタに出力されます。 

先ほどの File > Printer Setup ...File > Printer Setup ...File > Printer Setup ...File > Printer Setup ...メニューは出力先の設定だけで、今回の File > Print File > Print File > Print File > Print 
メニューではじめてプリンタに出力されます。 
 
 

(８) オンラインマニュアルを表示します。 
IC-CAP の Main ウインドの右端の Help > ManualsHelp > ManualsHelp > ManualsHelp > Manuals    メニューを選択します。 
オンラインマニュアルのウインドが表示されます。 
 
 

(９) ここで、BSIM3 のマニュアルページを開いてみます。 
現在は User’s Guide のページが開いていますので、オンラインマニュアルのウインドの右側か
ら「Nonlinear Device Models」を選択すると Nonlinear Device Models のページが開きます。
ここで、Chapter 5. BSIM3 Characterization を選択すると BSIM3 のマニュアルページが開き
ます。 
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(１０) この、BSIM3 Characterization のページをプリンタに出力してみます。 
いま開いた BSIM3 Characterization のページのウインドの左端の File > Print ...File > Print ...File > Print ...File > Print ...    メニュ
ーを選択します。 
 
下のようなウインドがあらわれます。ここで、①Printer Name の欄にポストスクリプトプリンポストスクリプトプリンポストスクリプトプリンポストスクリプトプリン
タタタタのプリンタ論理名を記入し、②[Print] ボタンを押すとプリンタに出力されます。 
 

オンラインマニュアルから出力できるのは、ポストスクリプトプリンタのみです。 
   

       

 
 
 ② [Print] ボタン ① PSプリンタの論理名を記入 
 

(１１) IC-CAP を終了します。 
 
Main ウインドの File > Exit...File > Exit...File > Exit...File > Exit...    メニューを選択します。（セーブする必要はありませんので、
そのまま終了してください。） 
ホームディレクトリに次の３つのファイルが作成されます。 
 

＄  cd 
＄  ls  -a 

.icconfig 各ユーザごとの設定ファイル 
   .icdebug  デバッグ用ファイル 
   .icerrlog エラーメッセージ用記録ファイル  
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５－５ 測定器の設定 
 

＜前提条件＞ 
z HP-UX 10.20 (GPIBカード,LAN/GPIB Gateway), Solaris 2.7/2.8(GPIBカード)をご利用の場合、 

GPIB (HP-IB) は UNIX で設定されていることを前提としています。HP-UX 10.20 の場合は、 
「７－１節 GPIB（SICL）のインストール」をご参照ください。 

z LAN/GPIB Gateway をご利用の場合は、LAN/GPIB のネットワーク設定が終了している必要がありま
す。こちら詳細は、LAN/GPIB 付属のマニュアルをご覧ください。 

z HP-UX 11.0, Solaris 2.7/2.8 で LAN/GPIB Gateway を使用する場合は、ドライバのインストール
は必要ありません 

 
(１) IC-CAP を起動し、Main ウインドウから Tools > Hardware Setup...Tools > Hardware Setup...Tools > Hardware Setup...Tools > Hardware Setup... メニューを選択します。 

 
(２) 下図のウインドウが現れます。このウインドウのことを Hardware Setup ウインドウと呼びま

す。Hardware Setup ウインドウの HP-IB Interface の欄に、GPIB(HP-IB) の論理名が登録さ
れていなければ、① [Add Interface.[Add Interface.[Add Interface.[Add Interface...]..]..]..] を選択し、登録し、②確認します。 
 
一般的な GPIB(HP-IB) の論理名（デバイスファイル名）を示します。 
HP-UX の場合 UNIX の dmesg 命令（スーパユーザで実行）確認できます。 

◇ HP-UX 10.20 の場合  Interface 名の例 → hpib 
◇ SUN の場合   Interface 名の例 → /dev/gpib0 
◇ LAN/GPIB Gateway の場合 Interface 名の例 → lan[192.168.0.15]:hpib 

 
LAN/GPIB Gateway の場合は、「lan[<LAN/HPIB GW の IPアドレス>]:hpib」となります。 
 
     ②登録された HP-IB 論理名の確認 ①[Add Interface...][Add Interface...][Add Interface...][Add Interface...] を選択し登録 
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(３) GPIB(HP-IB) の論理名の登録が終了したら、GP-IB(HP-IB) が正常に動作するかどうかを確認し
ます。接続しているすべての測定器の電源を投入し、Hardware Setup ウインドウの 
Instruments > FindInstruments > FindInstruments > FindInstruments > Find    メニューを選択します。Hardware Setup ウインドの Status の部分に、
現在接続されている測定器の HP-IB アドレスが表示されます。 
 

＜参考＞ この作業は、GPIB(HP-IB) が正常に動作するかどうかの確認です。 
   IC-CAP に測定器を登録する作業ではありません。 
   もし、GPIB(HP-IB) が正常に動作しないようであれば、一度 IC-CAP を 
   終了し、再度確認を行ってください。 
 

   
 
(４) GPIB(HP-IB) が正常に動作することを確認したら、測定器の登録を行います。 

Hardware Setup ウインドの右側の、①[Rebuild][Rebuild][Rebuild][Rebuild] を選択します。 
IC-CAP は、自動的に GPIB(HP-IB) に接続されている測定器を検索し、 Instrument List の欄
に発見した測定器を②表示／登録します。 

 
  ①[Rebuild][Rebuild][Rebuild][Rebuild] を選択  ②発見した測定器を表示 
 

    
 
(５) IC-CAP を終了します。 Main ウインドの File > Exit...File > Exit...File > Exit...File > Exit...    メニューを選択します。 
 登録した内容が、ファイルにセーブされます。セーブされるファイル名は次のとうりです。 

 
   $HOME/.icconfig 

 
＜注意＞この設定は、各ユーザ毎に行ってください。 
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＜参考＞ 測定器の HP-IB アドレス について説明します。 
 
 

◇ HP-IB アドレスは、０から３０の範囲で設定できます。 
 
◇ 各機器のアドレスは、それぞれ異なっていなければなりません。 
 
◇ アドレスが重複していると動作しません。 
 
◇ コンピュータにも HP-IB のアドレス（通常２１）が存在します。 
 
◇ 機器の設定によっては、出力のみの（トークオンリー）モードや入力のみの（リスンオンリ

ー）モードにすることができますが、この場合はコンピュータからは制御できません。 
 
◇ 機器によっては、HP-IB アドレスを２つ持っているものもあります(HP8510,HP8753 など) 
 
◇ ＨＰ社の各機器の工場出荷時の HP-IB アドレスを示します。 
   
  コンピュータ    ２１ 
  ＤＣ測定器（HP4142B など）  １７ 
  ＣＶ測定器（HP4284A など）  １７ 
  ＡＣ測定器（HP8510C など）  １６と１７ 
 
◇ ネットワークアナライザの HP-IB アドレスについて説明します。 
 
  工場出荷時の HP-IB アドレスは、ＤＣ測定器と重複していますのでご注意ください。 
  
  HP8510 は HP-IB アドレスを２つ持っています。（工場出荷時のHP-IB アドレス） 
  本体アドレス（ADDRESS of 8510)  １６ 
  システムバスアドレス（SYSTEM BUS）  １７ 
 
  HP8753 は HP-IB アドレスを２つ持っています。（工場出荷時のHP-IB アドレス） 
  本体アドレス    １６ 
  ディスプレイアドレス   １７ 
   
  本体アドレスとディスプレイアドレスの関係を示します。 

 
本体アドレス  ディスプレイアドレス 
    偶数   本体アドレス＋１ 
    奇数   本体アドレス－１ 
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５－６ IC-CAP 2002 が動作しないときの対策 
 
IC-CAP 2002 が起動しない場合の原因と対策を説明します。 
また、IC-CAP は起動したが、シミュレータなどが動作しない場合についても説明します。 
 
� 基本的な前提条件 

 
＜前提条件＞ 

① LAN（ネットワーク）が正常に動作していること。 
② コンピュータの時間が正確にあっていること。 

 
 
① LAN（ネットワーク）が正常に動作していること 
 
IC-CAP 2002 では、コンピュータをノードロックライセンスで使用していても、LAN（ネットワー
ク）の設定が必要です。これは IC-CAP 5.0 から導入されたライセンス管理ソフト(FLEXlm)がＬ
ＡＮを使用（アクセス）しているからです。 
まず、UNIX の hostname 命令で自分自身のホスト名を確認し、次に ping 命令で確認します。 
 
    ＜例＞ ＃  hostname  （ホスト名の確認） 

＃  ping  自分自身のホスト名  
 
もし、ping 命令でエラーが出るようであれば、LAN の設定が正常ではないことがわかります。 
また、HP コンピュータであれば、landiag 命令で LAN の状態（Status）を確認できます。 
 
  landiag 命令の実行 →  lan （と入力） →  display （と入力） 
 
ここで、Current State または、Operation Status の項目が active または up になっていれば
「基本的な物理的な LAN の設定」が正常に行われていることがわかります。 
一方、Current State または、Operation Status の項目が failure または down になっていた
ら「基本的な物理的な LAN の設定」が正常ではないということです。LAN のコネクターなどをご
確認ください。 
 

② コンピュータの時間が正確にあっていること 
 
UNIX の date 命令で現在コンピュータに設定されている時間を確認します。 
 

＃  date 
 
コンピュータの内蔵時計は電池でバックアップされています。電池の寿命は通常約３年から５年
程ですので、ご購入後３年以上経過したコンピュータは、電池交換をお勧めします。 
 
IC-CAP 5.0 から導入されたライセンス管理ソフト（FLEXlm）では、現在コンピュータに設定され
ている時間よりも 24 時間以上先の日付（時間）のファイル／ディレクトリがハードディスクに
存在すると、ライセンスを正常に供給できませんのでご注意ください。 
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� IC-CAP が全く起動しない（パスおよび環境変数） 

 
① IC-CAP を起動したとき、次のようなエラーメッセージが表示され、IC-CAP の画面が全く表示さ
れず、IC-CAP が立ち上がらないときがあります。 
 

＄ iccap [Return] （IC-CAP を起動） 
iccap:  not found ←ポイント  

 
これは、IC-CAP のパスが正確に設定されていないために発生するエラーです。 
 

② また、次のようなエラーメッセージが表示され、IC-CAP が立ち上がらないときがあります。 
 

＄  iccap  [Return] （IC-CAP を起動） 
/agilent/iccap2002/bin/iccap : /opt/iccap/bin/eedaemon:  not found.  

          ↑ ポイント 
 
これは、IC-CAP の環境変数 ICCAP_ROOT が正確に設定されていないために発生するエラーです。 
 

③ また、IC-CAP/Status ウインドウの下段 Warnings/Errors に、次のようなエラーメッセージが表
示され、IC-CAP が立ち上がらないときがあります。 
 
License Error: unable to locate the specified license file 
LM_LICENSE_FILE = /agilent/iccap2002/licenses:/agilent/iccap2002/licenses/license.dat 
Security violation: cannot find license file ←ポイント←ポイント←ポイント←ポイント 

  
!!!!IC-CAP has exited. 
    But information was recently posted to the status window. 
      ==> Please close this window after reviewing the messages. 
 
 
これは、IC-CAP の環境変数 LM_LICENSE_FILE が正確に設定されていないために発生するエラー
です。（上記のエラーはライセンスファイルが見つからないために発生しています。） 
 
 

 
IC-CAP 2002 を正常に実行するためには、次のパスおよび環境変数が正確に定義さ
れていることが前提条件です。 
 
パス(PATH) /agilent/iccap2002/bin 
環境変数  ICCAP_ROOT=/agilent/iccap2002 
  LM_LICENSE_FILE=/agilent/iccap2002/licenses/license.lic 
 

 
現在設定されているパスと環境変数を確認する UNIX の命令は次のようになります。 
 

＄  env  |  grep  iccap  [Return] 
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＜実行例＞ ICCAP_ROOT=/agilent/iccap2002 
LM_LICENSE_FILE=/agilent/iccap2002/licenses/license.lic 
PATH=/agilent/iccap2002/bin:/usr/bin:/...... 

 
もし、env 命令でパスと環境変数が正しく設定されていないことが確認できたら、 
.profile, .cshrc, .login, .dtprofile ファイルなどを確認し、それらのファイルを正しく編集
した後いったんログアウトし、再度 IC-CAP を起動してください。 
 
 

� IC-CAP が全く起動しない（ライセンスエラー） 
 
IC-CAP を起動したとき、IC-CAP/Status ウインドウの下段 Warnings/Errors に、次のようなエラー
メッセージが表示され、IC-CAP が立ち上がらないときがあります。 
 

License Error: No such feature exists  ←ポイント←ポイント←ポイント←ポイント 
Feature:       iccap_environment 
License path:  /agilent/iccap2002/licenses/license.lic:/agilent/iccap2002/licenses/ - 
   *.lic:/agilent/iccap2002/licenses/license.dat 
FLEXlm error:  -5,357 ←ポイント←ポイント←ポイント←ポイント 
For further information, refer to the FLEXlm End User Manual, 
available at "www.globetrotter.com". 
        Checkout of "iccap_environment" 6.000 failed ←ポイント←ポイント←ポイント←ポイント 
        License file location: /agilent/iccap2002/licenses/license.lic:/agilent/iccap2002/lice
nses:/agilent/iccap2002/licenses/license.dat 

  
!!!!IC-CAP has exited. 
    But information was recently posted to the status window. 
    ==> Please close this window after reviewing the messages. 
 

これは、IC-CAP のライセンスが正確に設定されていないために発生するエラーです。 
上記のエラーはライセンスファイル（license.lic）の中の製品名 iccap_environment のライセンス
が正確に供給されていないために発生しています。 
 
 INCREMENT iccap_enviroment  agileesof 6.1 25-Mar-2002 1 4CA1113153869C9918D1 ¥ 

VENDOR_STRING=s=2008302740  HOSTID=7B859AB4  
 
製品名 iccap_environment は、IC-CAP の本体プログラム（HP85199A）のライセンスです。 
このエラーの場合は、まず、lmutil 命令に lmstat -a オプションを付けて実行し、 
製品名 iccap_environment のライセンスが有効であるかどうかを確認します。 
 

＄  /agilent/iccap2002/licenses/bin/lmutil  lmstat  -a 
 
そして、ログ（記録）ファイル flex.log も確認します。 
 

＄  more  /agilent/iccap2002/licenses/flex.log 
 
通常は、この flex.log ファイルの中にさまざまなヒントが記録されています。 
詳細は「４章 ライセンス（FLEXlm）の設定」をご覧ください。 
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� IC-CAP は起動するがシミュレーション／抽出／測定などでライセンスエラーが発生する 

 
シミュレーション／抽出／測定などを実行したとき、次のようなエラーメッセージが表示されるとき
があります。 
 

License Error: No such feature exists (-5,116) ←ポイント 
Checkout of "hp_root_diode" 6.0 failed  ←ポイント 
Security violation: FLEXlm license registration failed ←ポイント 

 
これは、ライセンスが正確に設定されていないために発生するエラーです。 
上記のエラーはライセンスファイル（license.dat）の中の製品名 hp_root_diode のライセンスが正
確に供給されていないために発生しています。 
 
 INCREMENT hp_root_diode agileesof 6.1 25-Mar-2002 1 4CA1113153869C9918D1 ¥ 

VENDOR_STRING=s=2008302740  HOSTID=7B859AB4 
 
製品名 hp_root_diode は、IC-CAP のモジュール（HP85195A）のライセンスです。 
このエラーの場合は、まず、lmutil 命令に lmstat -a オプションを付けて実行し、製品名 hp_root
_diode のライセンスが有効であるかどうかを確認します。 
 

＄  /agilent/iccap2002/licenses/bin/lmutil  lmstat  -a 
 
そして、ログ（記録）ファイル flex.log も確認します。 
 

＄  more  /agilent/iccap2002/licenses/flex.log 
 
通常は、この flex.log ファイルの中にさまざまなヒントが記録されています。 
詳細は「４章 ライセンス（FLEXlm）の設定」をご覧ください。 
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第６章 IC-CAP 環境のカスタマイズ 

 
６－１ IC-CAP で使用されるシステム環境変数 
 
環境変数の設定は、IC-CAP の実行の章で述べたように、.profile や .cshrc で行います。この節では環
境変数に設定できる変数の内容を説明いたします。 
 
 
下記の表は、IC-CAP で通常使用される環境変数の一覧です。 
 

環境変数名環境変数名環境変数名環境変数名    標準値標準値標準値標準値((((何も設定しない時の値何も設定しない時の値何も設定しない時の値何も設定しない時の値))))    説明説明説明説明    
ICCAP_ROOT ¥opt¥iccap IC-CAP 2002 がインストールされているフォルダ名を

表します。この値は、IC-CAP が実行される上でよく使

われている値です。標準値はインストール時、レジスト

リに記述されます。 
LM_LICENSE_FILE $ICCAP_ROOT¥licenses¥license.lic FLEXlm ライセンスソフトウェアで、ライセンスファイル

の設置場所を指定するために使われます。ただし、AG

ILEESOF_LICENSE_FILE が設定された場合は、そちら

の方が優先的に使用されます。 
ICCAP_OPEN_DIR なし ユーザ・コンパイル・ライブラリを設置したフォルダを指

定します。詳細は、“IC-CAP User’s Manual” の cha

pter 8 “Creating C Language Functions in IC-CA

P” をご覧ください。 
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６－２ IC-CAP の設定ファイルについて 
 
IC-CAP はいくつかの設定ファイルによって、使用環境が設定されています。これらのファイルは特定の順
番で読み込まれ、IC-CAP の利用環境を構築します。それぞれのファイルには、変数が記述されており、こ
の値はユーザが変更することができます。IC-CAP の設定ファイルの変数は、以下の書式で記述されていま
す。 
 
 <変数>=<値> 
 
<変数> は設定変数の名前を、<値> は変数に代入される文字列を表しています。値にはフォルダ名・パ
ス・数値など、設定する変数に応じて様々な値が入ります。例えば、以下のように記述します。 
 
 ICCAP_EXAMPLE_DIRECTORY={$ICCAP_ROOT}¥examples 
 
上記例で $ICCAP_ROOT は環境変数の値を表し、IC-CAP がインストールされているフォルダ (通常は、/Ag
ilent/iccap2002 フォルダ) をさしていることになります。 
 
 
(１) 設定変数を変更するには 

 
設定ファイルは優先順位があり、変数はユーザの設定が優先して反映されるよう構造になってい
ます。独自の設定がされていない場合には、標準の値が用いられます。 
設定変数は、以下のファイル順に検索されます。この中で最初に見つかった設定が、実際に IC-
CAP の使用環境に反映されます。 
 
 
1. 作業中のディレクトリ 

 
設定変数は、そのプロジェクトのみで有効になります。ユーザ・システムで設定された内
容よりも優先されます。 
 

2. ユーザ毎の設定 = $HOME 
 
設定変数は、そのユーザの全てのプロジェクトについて有効になります。そのユーザのホ
ームディレクトリに設定します。 
 

3. IC-CAP のインストールディレクトリ = $ICCAP_ROOT¥config 
 
ここには、標準の設定ファイルがあり、全てのユーザ・プロジェクトで通常使われる環境
が設定されています。 
この設定ファイルは、編集せずに初期状態のまま使用することを強くお勧めします。 
 
 

(２) 設定ファイルの記述法 
 
IC-CAP 設定ファイルは、設定変数やコメントが記述されたテキストファイルです。 
以下の仕様で機能しますので、ご注意ください。 
 
z 行頭が“#”で始まる行は、コメント行を表します。設定読み込み時には無視されます。 
z 空行は読み込み時には無視されます。 
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z 設定式の“=”の左右のスペースは無視されます。 
z 値に何も設定されていない式は、値が無い変数として IC-CAP で有効になります。 
 
システム環境変数を参照する場合は、$name の書式になります。また、IC-CAP の設定変数を参
照する場合は、%name となります。これらは IC-CAP が読み込むときに、それぞれの変数と置き
換えられます。 
 
また、環境変数や設定変数は、中括弧“{ }”で囲まれている場合があります。中括弧は、それ
で囲まれている部分が、各変数である事を明示的に指示します。IC-CAP が読み込む時点では
“{ }”の記号は、値の中には残りません。 
 
 

(３) 設定変数の書式 
 
IC-CAP の設定変数名は、1～31 文字までのアルファベット・数字・アンダースコア(_) で構成
されます。アルファベットは、大文字・小文字の区別はありません。31 文字より長い変数名を
記述した場合は、読み込み時に、31 文字で切られます。設定ファイルで以下のように記述され
た場合は、 
 

  <変数>=<値> 
 
変数名 <変数> に、<値> という値が設定されます。 
 
設定変数では、他の設定変数を参照する事ができます。他の設定変数の参照部分は、文字の先頭
が、$ か % で始まっており、また、中括弧“{ }”で囲まれている場合もあります。 
 
 ICCAP_MODEL_DIRECTORY = %ICCAP_EXAMPLE_DIRECTORY/model_files 
 
上記例では、ICCAP_MODEL_DIRECTORY という変数に、%ICCAP_EXAMPLE_DIRECTORY¥model_files 
という値が設定されます。ここで、%ICCAP_EXAMPLE_DIRECTORY は、IC-CAP が起動した時に設
定される IC-CAP の設定変数です。 
 
 
 
 
 

設定変数設定変数設定変数設定変数    詳細詳細詳細詳細    
$name 設定変数の値は、システムの環境変数“name”に置き換えられます。 
%name 設定変数の値は、IC-CAP 設定変数“name”に置き換えられます。 
 
 
IC-CAP の設定変数の値は次の例のように、数値・文字列・ファイル名・ディレクトリ名を持ち
ます。 
 
 API_TOOLBAR_BITMAP_WIDTH = 24 
 API_RESOURCE_LIBRARY = simframe;simframe1 
 API_AEL_DIR = {$ICCAP_ROOT}/ael/api 
 
****注意注意注意注意**** プロジェクトフォルダ以外にあるファイル名を指定する場合は、ファイル名だけでは
ファイルが見つかりませんのでフルパスとファイル名を確実に記述するようにご注意ください。 
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IC-CAP 設定変数には、パスを記述するものがあります。パスは複数のディレクトリのリストを
指します。この場合、それぞれのディレクトリは以下のようにコロン(:)で区切ります。 
 
 variable = directory:directory: .... 
 
このような変数は、サーチ・パスやロード・パスとして使用され、記述する順序が非常に重要に
なります。サーチ・パスとして使用されている場合は、サーチ対象物が見つかるまで順に処理が
行われますので、パスリストのより前にあるものが有効になります。ロード・パスとして使用さ
れている場合は、リストを前から順に最後まで実行しますので、後ろに記述されているものが有
効に働きます。 
 
 
IC-CAP 標準の設定変数の説明にはその変数が取ることのできる値の形式が記述されていますの
で、必ずご確認ください。値の形式には、数値の範囲で指定するものや特定の文字列(YES,NO な
ど)しか受付けないものなど、値が限定されている場合があります。 
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(４) 使用できる設定ファイルについて 
 
IC-CAP の環境は、各設定ファイルに記述された変数名決定されます。設定ファイルのもっとも
基本的ファイルは、eesof.cfg ファイルになります。IC-CAP への設定の効果は、ファイルの設
置場所に影響を受けます。例えば、eesof 設定は、以下のファイルを順に読み込み IC-CAP に反
映されます。 
 
z IC-CAP のインストールされたディレクトリ $ICCAP_ROOT/config の eesof.cfg ファイル 
z ホームディレクトリ下に設置された、.eesof ファイル 
z プロジェクト・ディレクトリに設置された、.eesof ファイル 
 
****注意注意注意注意**** {$ICCAP_ROOT}/config ディレクトリに設置されている、ファイル名が.cfg で終わるフ
ァイルをホームディレクトリなどのローカルディレクトリに設置する場合は、名前を変更して保
存する必要があります。例えば“iccap.cfg”→“.iccap”のように、先頭にピリオド(.) を加
え、最後の .cfg を削除してください。$HOME/iccap.cfg ファイルを作成してもその設定は有
効にはなりません。 
 
 
前章でも解説したように、ホームディレクトリの設定内容は、IC-CAP のインストールされたデ
ィレクトリの設定よりも優先され、プロジェクト直下の設定は、ホームディレクトリの設定内容
よりも優先されます。つまり、サーチ・パスが プロジェクトディレクトリ・ホームディレクト
リ・PC 単位の設定ディレクトリ・IC-CAP にインストールされた標準ディレクトリの順になって
いることになります。 
 
設定ファイル内で同じ設定変数名が定義された場合は、一番最後に設定されたものが有効になり
ます。例えば、以下のような記述が同じ設定ファイルにあった場合は、 
 
 MY_VAR1 = entrya 
 MY_VAR1 = entryb 
 
MY_VAR1 設定変数は、常に entryb という値が設定されます。 
 
IC-CAP で使用される基本的な設定ファイルのファイル名は、設定内容別に以下の表のようにな
ります。 
 

設定内容設定内容設定内容設定内容    設定ファイル名設定ファイル名設定ファイル名設定ファイル名    
グラフィカル・ユーザ・インタフェース iccap, eesof , eecolor 
グラフ・プロット eesof, eecolor 
ハードコピー eesof, eehcopy, eehcopy.setup 

eehcopy2.setup, eehcopy.setup.hp700, 
eehcopy.setup.sun4x 

オンライン・ヘルプ eesofhelp 
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(５) 特殊な IC-CAP 設定ファイル 
 
次のファイル(eecolor, eecolor2, ICcap5, eefill, eehcopy.setup ファイル群)は、他の設定
ファイルとは異なる記述方式になっています。ファイルの記述法が違う以外は、他の設定ファイ
ルと異なる点はありません。 
 
1. 色の定義 

 
IC-CAP のデザイン環境のウインドウ内の表示できる色の定義とプロッタの使用色は、下記
の二つのファイルによって設定されています。この設定を変更することにより、デザイン
環境を好みの色に設定することができます。 
 
z eecolor , eecolor2 ファイル 

 
初期インストール時は、{$ICCAP_ROOT}/config/eecolor.cfg ファイルが使用される
ように設定されています。ただし、eesof.cfg ファイルの設定を変更することにより、
読み込むファイルを別のファイルに変更することができます。eesof.cfg は例えば、
ホームディレクトリに .eesof ファイルがある場合はそちらの内容が優先されます。
どのファイルの記述が現在有効になっているかに、ご注意ください。 
 

z ICcap5 ファイル 
 
初期インストール時は、{$ICCAP_ROOT}/lib/iccap/ICcap5 ファイルが使用されます。 

 
 
eecolor , eecolor2 eecolor , eecolor2 eecolor , eecolor2 eecolor , eecolor2 ファイルの詳細ファイルの詳細ファイルの詳細ファイルの詳細    
 
これらのファイルの設定は、IC-CAP 設定ファイルの記述 <変数名>=<値> とは異なる書式
になっています。表示色設定では、一行に三つの項目があります。 
 
z RGB で表された色の定義 
z 色の名前 
z プロッタのペン番号 
 
eecolor , eecolor2 ファイル内では、次のような書式になっています。 
 
Field #1              Field #2Field #1              Field #2Field #1              Field #2Field #1              Field #2        Filed #3Filed #3Filed #3Filed #3    
Red Green Blue   :    表示色名       :  ペン番号 
 
実際の設定を例にすると、以下のようになります。 
 
R     G     B         X11 R     G     B         X11 R     G     B         X11 R     G     B         X11 色名色名色名色名                    プロッタペン番号プロッタペン番号プロッタペン番号プロッタペン番号    
0     0     0    :    black          :  1 
255   0     0    :    ren            :  2 
0     255   0    :    green          :  3 
0     0     255  :    blue           :  4 
255   255   255  :    white          :  5 
128   64    0    :    salmon         :  6 
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色は一番目か二番目のフィールドで決定されます。一番目のフィールドには、色を RGB 毎
に数値で表して設定できます。数値は、0～255 までの整数が指定できます。PC(Windows) 
の場合は、RGB での指定しか使用できません。 
 
UNIX の場合は二番目のフィールドに、X ウインドウの RGB Color Database から色名で指
定することもできます。X ウインドウの RGB Color Database は、/usr/lib/X11/rgb.txt 
や /usr/openwin/lib/rgb.txt などにありますので、そちらをご参照ください。二つのフ
ィールドが両方とも指定されている場合は、一番目の RGB 指定の値が優先され、二番目の
色名は無視されます。 
 
三番目のフィールドは、HPGL プリンタへの印刷時に使用するプロッタのペン番号が入りま
す。このフィールドには、同じ番号を何度でも入れる事ができます。 
 
eecolor.cfg ファイルのサンプルは以下のようになります。 
 
# 
# ============================================================= 
# EEsof Color Definition File: 
# ============================================================= 
#   R   G   B  :  Color Name  :  Plotter Pen # 
#  --- --- ---    ----------     ------------- 
#   0   0   0  :    black     :       1 
#  255  0   0  :    red       :       2 
#   0  255  0  :    greeen    :       3 
#   0   0  255 :    blue      :       4 
#  255 255  0  :    yellow    :       5 
#  255  0  255 :    magenta   :       6 
#   0  255 255 :    cyan      :       7 
#  255 255 255 :    white     :       8 
# 
#  For Unix X Windows systems either RGB values or standard     
#  X Color Names, or both, may be specified for color entries.  
#  For Windows95/NT only RGB values are supported. 
#  Note, if both RGB and Color Name values are specified, 
#  the RGB  values take precedence. 
# ============================================================= 
# 
  0   0   0  : black                    : 1 
255   0   0  : red                      : 2 
255 255   0  : yellow                   : 3 
  0 255   0  : green                    : 4 
  0 255 255  : cyan                     : 5 
  0   0 255  : blue                     : 6 
255   0 255  : magenta                  : 7 
192 192 192  : gray                     : 1 
255 255 255  : white                    : 1 
135 206 250  : LightSkyBlue             : 2 
184 184 184   : gray72                   : 1 
199 199 199   : gray78                   : 1 
205 106 106  : IndianRed1               : 5 
205  99  99  : IndianRed2               : 5 
205  85  85  : IndianRed3               : 5 
202 225 255  : LightSteelBlue1          : 4 
188 210 238  : LightSteelBlue2          : 4 
162 181 205  : LightSteelBlue3          : 4 
154 255 154  : PaleGreen1               : 1 
154 238 144  : PaleGreen2               : 1 
124 205 124  : PaleGreen3               : 1 
255 236 139  : LightGoldenrod1          : 8 
238 220 130  : LightGoldenrod2          : 8 
205 190 112  : LightGoldenrod3          : 8 
255 255 255  : white    : 1 
  0   0   0  : black    : 1 
  0   0   0  : black    : 1 
 



 79

後述の IC-CAP 設定中で色の割り当てをする場合は、このファイルに登録された色の番号
を使用します。色の番号は 0 番から設定順に登録されます。 
例えば、色番号 0 を指定した場合は、上記例では最初(25 行目)に設定された 「0 0 0 : b
lack : 1」になりますので、画面上では黒、プロット時にはペン番号 1 番が使用されます。 
 
eecolor.cfg ファイルが見つからない場合や、eesof.cfg ファイルで HPEESOF_COLOR が設
定されていない場合は、以下の 10 色の設定が IC-CAP で自動的に行われます。 
 
1=black     2=red       3=yellow   4=green   5=cyan 
6=blue      7=magenta   8=gray     9=white   10=middium blue 
 
 
ICcap5 ICcap5 ICcap5 ICcap5 ファイルの詳細ファイルの詳細ファイルの詳細ファイルの詳細    
 
$ICCAP_ROOT/lib/iccap/cust_color にカスタマイズされたサンプルファイルが収録されて
います。これらのファイルは、ウインドウ色が赤・黄・緑・青・白黒になるように設定さ
れています。ファイルは、 
 
z ICcap5.blue 
z ICcap5.bw 
z ICcap5.green 
z ICcap5.red 
z ICcap5.yellow 
 
の五つに収録されています。これらのうち一つのファイルを使用し、.iccap ファイルに記
述を一部行います。使用方法は、サンプル設定ファイルの ICcap5.<色> をホームディレク
トリに ICcap5 というファイル名でコピーし、.iccap に ICCAP_COLOR_SCHEME=<色> の書
式の一行を加えます。 
 
<例> cp $ICCAP_ROOT/lib/iccap/cust_color/ICcap5.red $HOME/ICcap5 
 
ファイルをコピーした後、既にホームディレクトリに $HOME/.iccap ファイルが存在すれ
ば次の一行を加えます。なければ、ファイルを作成してください。 
 
<例> ICCAP_COLOR_SCHEME=red 
 
更に、設定変更を行いたい場合は、先程コピーしたホームディレクトリの ICcap5 ファイ
ルを編集してください。 
 
メニュー・背景の色などは、ICcap5 ファイルにより設定されます。また、アイコン・inpu
t,output,plot 部分は、.iccap ファイル中の ICCAP_COLOR_SCHEME の値で設定されます。 
 

2. ディスプレイの解像度が小さい時の設定 
 
$ICCAP_ROOT/iccap/lib/cust_size ディレクトリには、ディスプレイの解像度が 1280x102
4 より小さいときの設定サンプルファイルがあります。 
 
ファイル名は、ICcap5.1024, ICcap5.800, .iccap.1024, .iccap800 の四つで、それぞれ 
1024x768 , 800x600 の解像度に対応しています。ただし、これらは設定の一例ですのでい
くつか不便な点もありますので、その点はご了承ください。 
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使用法は、設定ファイルの .iccap.<size> と ICcap5.<size> を、拡張子を外してホーム
ディレクトリにコピーすることによって設定が有効になります。例えば、以下のコマンド
を使用します。 
 
 cd $ICCAP_ROOT/lib/iccap/cust_color 
 cp .iccap.1024 $HOME/.iccap 
 cp ICcap5.1024 $HOME/ICcap5 
 
また、既にカスタマイズ用ファイルを作成している場合は、以下のようにファイルに追加
することもできます。 
 
 cat iccap.1024 >> $HOME/.iccap 
 
 

3. IC-CAP の詳細設定 
 
$ICCAP_ROOT/lib/iccap/cust_advanced ディレクトリには、より詳細な IC-CAP の設定の
サンプルファイルが収録されています。これらのファイルには、IC-CAP のウインドウ枠の
幅や、フォントの設定を行う設定変数が記述されています。 
 
ここには以下のファイルがあります。 
 
z ICcap5.adv 
z eecolor.cfg.adv 
z .eesof.adv 
z .iccap.adv 
 
IC-CAP の標準色設定ファイルは以下のファイルです。 
 
z $ICCAP_ROOT/lib/iccap/ICcap5 
z $ICCAP_ROOT/config/eecolor.cfg 
 
設定変数のないようについては、次節の変数一覧をご参照ください。 
 
ICcap5 ファイル設定をユーザが変更する場合は、ICcap5 ファイルを $HOME ディレクトリ
にコピーし、修正を加えてください。eecolor.cfg を変更したい場合は任意の場所に eeco
lor.cfg ファイルを作成したあと、$HOME ディレクトリの $HOME/.eesof ファイル中の EE
SOF_COLOR 変数を変更する事によって、作成した eecolor.cfg ファイルを読み込むように
してください。 
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(６) 設定ファイルの記述 
 
この節では、IC-CAP 設定ファイルに記述できる項目について説明いたします。 
 
1. iccap.cfg ファイルの記述 

 
このファイルには、サンプルファイルやライブラリのパスなどの情報を設定することがで
きます。初期ファイルは、$ICCAP_ROOT/config ディレクトリにあります。 
 
最初の表では、初期の iccap.cfg に記述されている項目を説明いたします。 
 
二つ目の表では、iccap.cfg に上記の他に拡張設定として設定できる項目を説明いたしま
す。拡張項目のサンプルは、iccap.adv ファイル内に記述されています。必要に応じてこ
のファイル内の項目を iccap.cfg ファイルに追加してください。iccap.adv ファイルは、
$ICCAP_ROOT/iccap/lib/cust_advanced ディレクトリにあります。 
 
 
iccap.cfg iccap.cfg iccap.cfg iccap.cfg ファイル内の記述されている設定ファイル内の記述されている設定ファイル内の記述されている設定ファイル内の記述されている設定    
 

変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル    値値値値    

FONT_FILE_NAME 

プロット時のフォントのパスとファイル名 
例: FONT_FILE_NAME={$ICCAP_ROOT}¥config¥usascii 

ファイル 

ICCAP_EXAMPLE_DIRECTORY 

サンプルファイルのパス名。メインウインドウで、FILE > ExamplesFILE > ExamplesFILE > ExamplesFILE > Examples メニュ
ーを選択したときに開かれます。 
例: ICCAP_EXAMPLE_DIRECTORY={$ICCAP_ROOT}¥examples 

ディレクトリ 

ICSTAT_EXAMPLE_DIRECTORY 

Statistics のサンプルファイルのパス名。Statistics ウインドウで、FILE FILE FILE FILE 
> Examples> Examples> Examples> Examples メニューを選択したときに開かれます。 
例: ICSTAT_EXAMPLE_DIRECTORY={$ICCAP_ROOT}¥examples¥icstat 

ディレクトリ 

ICCAP_MODEL_DIRECTORY 

モデルライブラリファイルのパス名。 
例: ICCAP_MODEL_DIRECTORY=%ICCAP_EXAMPLE_DIRECTORY 

ディレクトリ 

USERSIMFILE 

ユーザ・シミュレータ・ファイルのパスとファイル名。 
例: USERSIMFILE={$ICCAP_ROOT}¥iccap¥lib¥usersimulators 

ファイル 

INSTRALIASFILE 

インストルメント・エアリアス・ファイルのパスとファイル名。 
例: INSTRALIASFILE={$ICCAP_ROOT}¥iccap¥lib¥instraliases 

ファイル 
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変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル    値値値値    

ICCAP_FUNCTION_BROWSE_DATA 

ファンクション・ブラウザに表示されているヘルプ・ファイルのパスとファ
イル名。 
例: ICCAP_FUNCTION_BROWSE_DATA={$ICCAP_ROOT}¥iccap¥lib¥functions.hlp 

ファイル 

PULSECFG 

パルス・ドライバ設定ファイルのパスとファイル名。 
例: PULSECFG={$ICCAP_ROOT}¥iccap¥lib¥hp85124.cfg 

ファイル 

PULSECAL 

パルス・ドライバの校正設定ファイルのパスとファイル名。 
例: PULSECAL={$ICCAP_ROOT}¥iccap¥lib¥hp85124.cal 

ファイル 

ICCAP_CPP_PATH 

CPP のパスとファイル名 
例: ICCAP_CPP_PATH={$ICCAP_PLATFORM_DIR}¥cpp 

ファイル 

DRAW_PAGE_DEFAULT_MAGNIFICATION 

描画画面の倍率の標準値の設定。(数字が小さいほど文字が大きくなりま
す。) 
例: DRAW_PAGE_DEFAULT_MAGNIFICATION=1.8 

正の実数値 

DOUBLE_CLICKS_TIME_OUT 

二回目のボタンクリックが有効になるまでの時間。(数値が大きいほどゆっく
りクリックする必要があります。) 
例: DOUBLE_CLICKS_TIME_OUT=500 

ミリ秒 

ICCAP_LICENSE_TIMEOUT 

取得したライセンスを自動的に解放するまでの時間。無効 ( =0) に設定した
場合は、手動でライセンスの解放をするか、IC-CAP を終了させる必要があり
ます。 
例: ICCAP_LICENSE_TIMEOUT=300 (標準値) 

秒 

300 より大きい値か、

自動解放を無効にする

場合は 0 を設定。 

ICCAP_NUM_RECENT_FILES 

最近使ったファイルのヒストリに記録されるファイル数。 
例: ICCAP_NUM_RECENT_FILES=5 (標準値) 

正の整数 

ICCAP_MAX_RECENT_CHARS 

最近使ったファイルメニューのファイル名表示文字数。 
例: ICCAP_MAX_RECENT_CHARS=40 (標準値) 

正の整数 
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iccap.adv iccap.adv iccap.adv iccap.adv ファイル内の記述されている設定ファイル内の記述されている設定ファイル内の記述されている設定ファイル内の記述されている設定    
 
以下の設定は iccap.adv ファイルにテンプレートが記述されています。設定を有効にした
いときは、iccap.cfg ファイル内に必要な変数を追加してください。 
 
 

変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル    値値値値    

ICCAP_ICON_SIZE 

ツールバー・アイコンの大きさ。IC-CAP の初期状態は SMALL 設定です。 
例: ICCAP_ICON_SIZE=LARGE 

LARGE または 

SMALL 

ICCAP_MAIN_PAGE_COLOR 

メイン・ウインドウの背景色。 
例: ICCAP_MAIN_PAGE_COLOR=9 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_MEAS_PAGE_COLOR 

測定ウインドウの背景色。 
例: ICCAP_MEAS_PAGE_COLOR=10 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_PLOT_PAGE_COLOR 

プロット・ウインドウの背景色。 
例: ICCAP_PLOT_PAGE_COLOR=11 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_ICON_BG_COLOR 

モデルシンボル・アイコンの背景色 
例: ICCAP_ICON_BG_COLOR=12 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_ICON_FG_COLOR 

モデルシンボル・アイコンの前景色 
例: ICCAP_ICON_FG_COLOR=16 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_ICON_EDIT_BG_COLOR 

メインウインドウのモデルシンボル・アイコンのラベルの背景色。 
例: ICCAP_ICON_EDIT_BG_COLOR=29 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_ICON_EDIT_FG_COLOR 

メインウインドウのモデルシンボル・アイコンのラベルの前景色 
例: ICCAP_ICON_EDIT_FG_COLOR=30 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_ICON_EDIT_HI_COLOR 

メインウインドウのモデルシンボル・アイコンの選択時のハイライト色。 
例: ICCAP_ICON_EDIT_HI_COLOR=31 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_INPUT_BG_COLOR 

Input タイルの背景色。 
例: ICCAP_INPUT_BG_COLOR=13 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 
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変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル    値値値値    

ICCAP_OUT_BG_COLOR 

Output タイルの背景色。 
例: ICCAP_OUT_BG_COLOR=14 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_PLOT_BG_COLOR 

プロット・ウインドウの背景色。 
例: ICCAP_PLOT_BG_COLOR=15 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_SELECT_COLOR 

モデルウインドウ・アイコンを囲むボックスの選択時のハイライト色。 
例: ICCAP_SELECT_COLOR=17 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_SELECT_COLOR 

Input, Output, Plot タイルの選択時のハイライト色。 
例: ICCAP_TILE_SELECT_COLOR=18 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_BORDER_COLOR 

Input, Output, Plot タイルの境界線色。 
例: ICCAP_TILE_BORDER_COLOR=19 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_TITLE_BG_COLOR 

Input, Output, Plot タイルのラベルの背景色。 
例: ICCAP_TILE_TITLE_BG_COLOR=20 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_TITLE_FG_COLOR 

Input, Output, Plot タイルのラベルの前景色。 
例: ICCAP_TILE_TITLE_FG_COLOR=21 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_TITLE_EDIT_BG_COLOR 

Input, Output, Plot 名の背景色。 
例: ICCAP_TILE_TITLE_EDIT_BG_COLOR=23 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_TITLE_EDIT_FG_COLOR 

Input, Output, Plot 名の前景色 
例: ICCAP_TILE_TITLE_EDIT_FG_COLOR=22 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_TITLE_EDIT_HI_COLOR 

Input, Output, Plot 名編集時のハイライト色 
例: ICCAP_TILE_TITLE_EDIT_HI_COLOR=24 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_LINE_FG_COLOR 

Input, Output, Plot のラインアイテムのテキスト前景色 
例: ICCAP_TILE_LINE_EDIT_FG_COLOR=25 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_LINE_EDIT_FG_COLOR 

ラインアイテム内のテキストの前景色 
例: ICCAP_TILE_LINE_EDIT_FG_COLOR=26 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 
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変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル    値値値値    

ICCAP_TILE_LINE_EDIT_BG_COLOR 

ラインアイテム内のテキストの背景色 
例: ICCAP_TILE_LINE_EDIT_BG_COLOR=26 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICCAP_TILE_LINE_EDIT_HI_COLOR 

ラインアイテム内のテキスト選択時のハイライト色 
例: ICCAP_TILE_LINE_EDIT_HI_COLOR=26 

有効な色番号 

(eecolor.cfg で定義さ

れている色) 

ICSTATUS_WINDOW_TO_TOP 

ステータス・ウインドウのポップアップの設定。On の場合は、新しいメッセ
ージが表示されるときは常に自動的にウインドウが画面の最前面に表示され
ます。Off の場合は、最前面には表示されません。 
例: ICSTATUS_WINDOW_TO_TOP=1 

0 = Off 

1 = On 

BACKUP_FILES_WHEN_ASKED 

File > Save as を選択した時のファイルバックアップの挙動設定。 
YES の場合は、確認なしに常にファイルのバックアップをとります。 
NO の場合は、バックアップを作らずに保存されるか、バックアップをとるか
どうか確認ウインドウが現れます。 
ASK の場合は、上書きしてよいか確認ウインドウが現れ、ファイルのバック
アップも作られます。 
例: BACKUP_FILES_WHEN_ASKED=ASK 

YES, NO, ASK のいす

れか 

OVERWRITE_FILES_WHEN_ASKED 

セーブ時に、上書きしてもよいかどうかの確認の設定。 
YES の場合は、確認なしで常に上書きします。 
NO の場合は、上書き保存ができません。他の名前で保存するか、既にあるフ
ァイルを消去する必要があります。 
ASK の場合は、上書きしてもよいか確認ウインドウが現れます。 
例: OVERWRITE_FILES_WHEN_ASKED=ASK 

YES, NO, ASK のいず

れか 
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2. ウインドウのサイズや表示位置の設定 
 
この節では、iccap.cfg に変数を追加することで、ウインドウの標準のサイズや表示位置
の設定を行う方法について説明いたします。 
 
下記の項目は、表で示した変数名の最後に加えることができます。 
 
z _X : X 方向(左右方向)の位置を表します。(0 の場合は画面左端になります) 
z _Y : Y 方向(上下方向)の位置を表します。(0 の場合は画面上端になります) 
z _WIDTH  : ウインドウの幅をピクセル数で表します。 
z _HEIGHT : ウインドウの高さをピクセル数で表します。 
z _MIN_WIDTH  : ウインドウの幅の下限をピクセル数で表します。 
z _MIN_HEIGHT : ウインドウの高さの下限をピクセル数で表します。 
 
下記が設定例になります。 
 
HARDWARE_WINDOW_X=75 
HARDWARE_WINDOW_Y=5 
HARDWARE_WINDOW_WIDTH=950 
HARDWARE_WINDOW_HEIGHT=700 
HARDWARE_WINDOW_MIN_WIDTH=690 
HARDWARE_WINDOW_MIN_HEIGHT=540 
 
 
ウインドウの大きさと表示位置の設定ウインドウの大きさと表示位置の設定ウインドウの大きさと表示位置の設定ウインドウの大きさと表示位置の設定    
 

変数名変数名変数名変数名    詳細詳細詳細詳細    

HARDWARE_WINDOW ハードウェア・マネージャ・ウインドウ 

MODEL_WINDOW モデルファイルの内容が表示されるウインドウ 

STATUS_WINDOW ステータス・警告・エラーが表示されるウインドウ 

SIMDEB_WINDOW シミュレーション・デバッガ・ウインドウ 

SYSVAR_WINDOW System Variables ウインドウ 

DETACH_SETUP_WINDOW DUT/Setup からセットアップを選択し、Detach ボタンをクリックし

たときに分離表示されるウインドウ 

DETACH_MACRO_WINDOW Select Macro リストボックスからマクロを選択し、Detach ボタンを

クリックしたときに分離表示されるウインドウ 

DETACH_VARIABLE_WINDOW Tools > System Variables を選択し、Detach ボタンをクリックし

たときに分離表示されるウインドウ 

DETACH_PARAM_WINDOW Model Parameters フォルダで Detach ボタンをクリックしたときに

現れるウインドウ 

ICSTAT_MAIN_WINDOW Statistics メイン・ウインドウ (Statistical Analysis ウインドウ) 
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変数名変数名変数名変数名    詳細詳細詳細詳細    

ICSTAT_ANALYSIS_WINDOW Analysis メニューから Analysis Data を選択したときに現れるウ

インドウ 

ICSTAT_SUMMARY_WINDOW 統計データが表示される Statistics ウインドウ 

ICSTAT_BOUNDARY_WINDOW boundary analysis データが表示される Statistics ウインドウ 

ICSTAT_RESIDUAL_WINDOW residual correlation データが表示されるウインドウ 

ICSTAT_FACTOR_WINDOW それぞれの要素から支配的パラメータの一覧が表示される Statis

tics ウインドウ。また、factor group データ 

 
 

3. eehcopy.cfg の設定 
 
このファイルは、ハードコピーに関する設定を行います。 
eehcopy.cfg ファイルは、$ICCAP_ROOT/config ディレクトリにあります。 
 

変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル    値値値値    

EEHCOPY_GRAPHICS_SELECTION 

Graphics モード選択時の Printer/Plotter Setup ダイアログで、印刷先の
チェックの標準値を設定します。 
例: EEHCOPY_GRAPHICS_SELECTION=1 

0 = print to file 

1 = print to printer 

EEHCOPY_GRAPHICS_TARGET 

グラフィック印刷時の標準のプリンタ名を設定します。 
例: EEHCOPY_GRAPHICS_TARGET=AppleLw 

eehcopy.setup ファイ

設定したプリンタ名のう

ちのいずれか 

EEHCOPY_GRAPHICS_FORMAT 

device format 欄で自動的に選択されるフォーマットを設定します。 
例: EEHCOPY_GRAPHICS_FORMAT=PS 

PS, HP7440, HP7474, 

HP7475, HP7550,  

HP7570, HP7575,  

HP7576, HP7580,  

HP7580, HP7585,  

HP7586, HP7595,  

HP7596, HPGL2 の 

いずれか 

EEHCOPY_GRAPHICS_SIZE 

Paper Size 欄で自動的に選択される紙のサイズを設定します。 
例: EEHCOPY_GRAPHICS_SIZE=A 

A, B, C, D, E 

A4, A3, A2, A1, A0 

のいずれか 

EEHCOPY_TEXT_SELECTION 

Text モード選択時の Printer/Plotter Setup ダイアログで、印刷先のチェ
ックの標準値を設定します。 
例: EEHCOPY_TEXT_SELECTION=1 

0 = print to file 

1 = print to printer 

EEHCOPY_TEXT_TARGET 

テキスト印刷時の標準のプリンタ名を設定します。 
例: EEHCOPY_TEXT_TARGET=lp 

eehcopy.setup ファイ

設定したプリンタ名のう

ちのいずれか 
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EEHCOPY_SCREEN_SELECTION 

Screen Dump モード選択時の Printer/Plotter Setup ダイアログで、印刷先
のチェックの標準値を設定します。 
例: EEHCOPY_SCREEN_SELECTION=1 

0 = print to file 

1 = print to printer 

EEHCOPY_SCREEN_TARGET 

スクリーン印刷時の標準のプリンタ名を設定します。 
例: EEHCOPY_SCREEN_TARGET=xps 

eehcopy.setup ファイ

設定したプリンタ名のう

ちのいずれか 

EEHCOPY_SCALE_SELECTION 

Scale Mode の標準のモードを設定します。 
例: EEHCOPY_SCALE_SELECTION=0 

0 = best fit 

1 = scaled 

EEHCOPY_SCALE_FACTOR 

Scale Mode で scaled が選ばれたときの、Scale Factor の標準値を指定。 
例: EEHCOPY_SCALE_FACTOR=1.000000 

0.0 より大きい、正の数

字 

EEHCOPY_MASKCUT_MODE 

Hewlett-Packard 社のプロッタ使用時のみ有効です。マスクカットモードの
有効・無効を指定します。 
例: EEHCOPY_MASKCUT_MODE=0 

0 = off 

1 = on 

EEHCOPY_DRAFT_MODE 

fill mode を指定します。 
例: EEHCOPY_DRAFT_MODE=0 

0 = Postscript fill ptt

erns 

1 = gray scaled fill pa

tterns 

EEHCOPY_PEN_FORCE 

マスクカット時のペン圧を指定します。 
例: EEHCOPY_PEN_FORCE 

0 = 標準 

1 = 15 グラム 

2 = 24 グラム 

3 = 30 グラム 

4 = 36 グラム 

5 = 45 グラム 

6 = 51 グラム 

7 = 57 グラム 

8 = 66 グラム 

EEHCOPY_PEN_VELOCITY 

マスクカット時のペン速度を cm/s で指定します。 
例: EEHCOPY_PEN_VELOCITY=0 

0 より大きい数字か、

標準速度の場合は 0 
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4. eehelp.cfg の設定 
 
このファイルは、オンラインヘルプの文書ファイルの位置を設定するのに使用されます。e
ehelp.cfg ファイルは、$ICCAP_ROOT/config に設置されています。 
 
 
eehelp.cfg eehelp.cfg eehelp.cfg eehelp.cfg ファイルの設定ファイルの設定ファイルの設定ファイルの設定    
 

変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル    値値値値    

VIEWER_MSG 

FrameViewer 起動時に表示されるメッセージ。 
例: VIEWER_MSG=Starting FrameViewer.On-line help available in appro
x.2 minutes. 

任意の英語の文章 

VIEWER_BUSY 

FrameViewer 起動が遅くなる時に表示されるメッセージ。 
例: VIEWER_BUSY=FrameViewer is busy.Please wait. 

任意の英語の文章 

EEHELP_VIEWER_STARTUP 

FrameViewer の状態を設定。TRUE の場合は、HELP Server 起動時に FrameVi
ewer も起動される。FALSE の場合は、ユーザが最初のヘルプを表示させると
きに FrameViewer が起動。インストール時は TRUE に設定されています。 
例: EEHELP_VIEWER_STARTUP=TRUE 

TRUE または 

FALSE 

VIEWERBIN 

 
例: VIEWERBIN=viewer 

viewer 

VIEWERBIN_ARGS 

 
例: VIEWERBIN_ARGS=-run_in_fg -server 

–run_in_fg –server 

APPLICATION_NAMES 

$ICCAP_ROOT/doc にあるインデックスファイルを指定します。IC-CAP のイン
デックスファイルには、hsiccap_index と hsbsim4_index があり、インデッ
クスファイルは、各ユーザインタフェースに対応した Frame Help ファイル
をマッピングしています。 
例: APPLICATION_NAMES=iccap;bsim4 

iccap 

bsim4 

TOPLEVEL_DOC 

オンラインヘルプのトップページファイルのあるディレクトリを指定しま
す。 
例: TOPLEVEL_DOC=$ICCAP_ROOT¥doc 

ディレクトリ 
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5. eesof.cfg の設定 
 
この設定ファイルは、IC-CAP 設定においてもっとも基本的な設定を行います。いくつかの
重要な設定変数がここで指定されますので、ご注意ください。eesof.cfg ファイルは、$IC
CAP_ROOT/config ディレクトリに設置されています。 
 
    
eesof.cfg eesof.cfg eesof.cfg eesof.cfg ファイルの設定ファイルの設定ファイルの設定ファイルの設定    
 

変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル    値値値値    

EESOF_LM_LICNESE_FILE 

FLEXlm ライセンスシステムのライセンスファイル license.lic ファイルの
パスとファイル名を指定します。 
例: EESOF_LM_LICENSE_FILE={$ICCAP_ROOT}/licenses/license.lic 

ファイル 

EESOF_COLOR 

eecolor 設定ファイルのパスとファイル名を指定します。 
例: $EESOF_COLOR={$ICCAP_ROOT}/config/eecolor.cfg 

ファイル 

EESOF_FILL 

eefill 設定ファイルのパスとファイル名を指定します。 
例: EESOF_FILL={$ICCAP_ROOT}/config/hpeefill.cfg 

ファイル 

EESOF_BUFFER 

グラフィックデータのバッファ容量を設定します。 
例: EESOF_BUFFER=5000 

Byte (0～500K) 

EESOF_FONT_FILE 

フォントインデックス・ファイルを設置しているパスを指定します。 
例: EESOF_FONT_FILE={$ICCAP_ROOT}/config 

ディレクトリ 

EESOF_OCCIDENTAL_FILE 

ヨーロッパ言語フォントの設定ファイルのパスを指定します。(現在はまだ使
用できませんが、予約変数となっています。) 
例: EESOF_OCCIDENTAL_FILE={$ICCAP_ROOT}/config/hersh.oc 

ファイル 

EESOF_ORIENTAL_FILE 

アジア言語フォントの設定ファイルのパスを指定します。(現在はまだ使用で
きませんが、予約変数となっています。) 
例: EESOF_ORIENTAL_FILE={$ICCAP_ROOT}/config/hersh.or 

ファイル 
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変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル変数名・詳細・設定サンプル    値値値値    

EESOF_EEHCOPY_FILE 

ハードコピー設定ファイル .eehcopy の設置場所を選択肢より指定。 
例: EESOF_EEHCOPY_FILE 

system, home, cwd 

のうちいずれか。(cwd

はワークディレクトリ) 

EESOF_EEHCOPY_SETUP 

plot,text,screen dump 各印刷モードの設定ファイルの位置を指定。 
例: EESOF_EEHCOPY_SETUP={$ICCAP_ROOT}/config/eehcopy.setup 

ファイル 

HPEESOF_LANGUAGE 

IC-CAP で使用する言語を設定します 
例: HPEESOF_LANGUAGE=english 

言語名 
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第７章 付録                         

 
７－１ GPIB (SICL)のインストール 
 
(１) SICL のインストールについて 

 
この節では、Agilent Standard Instrument Control Library(SICL) のインストール方法につ
いてご説明いたします。SICL は HP-UX 10.20 において、GPIB インタフェースを使用する場合
に必要になります(HP-UX 11.0, Solaris では必要ありません)。 
 
SICL バージョン 
z G.03.00 for HP-UX 10.20 
 
対応する GPIB インタフェース 
z Agilent E2070A/B, E2071C/D, E2078A for GPIB (HP-UX 10.20 のみ) 
z HP Model 745I Built-in GPIB 
z HP Model V743 Built-in GPIB 
z Agilent E2050A LAN/GPIB 

 
****注意注意注意注意**** Agilent E2050A LAN/GPIB は、HP-UX 11.0 や Solaris 2.7,2.8 でもご利用になるこ
とができます。IC-CAP 5.3 以降、IC-CAP 内にドライバが内蔵されていますので、ここでドラ
イバをインストールする必要はありません。 
 
 
HP-UX 10.20 へ SICL をインストールする場合は次の手順に進んでください。 
 
 

(２) SICL のインストール作業 (HP-UX 10.20 のみ必要) 
 
SICL の depot ファイルを作成します。 
 
1. 作業用ディレクトリを作成するディレクトリに移動します。ここでは /tmp を使用します。 

 
cd /tmp 
 

2. 作業用ディレクトリを作成します。 
 
mkdir /tmp/mydepot 
 

3. 作業用ディレクトリに移動します。 
 
cd /tmp/mydepot 
 

4. SICL 本体を展開します。 
 
zcat $ICCAP_ROOT/lib/iccap/sicl.10.20.tar.Z | tar xvf - 
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HP-UX software distributor(SD) install program を用いて、SICL をインストールします。 
 
****注意注意注意注意**** インストール終了後、swinstall プログラムによって、ワークステーションの再起動
(リブート)が行われますので、あらかじめご了承ください。 
 
1. スーパーユーザ(root)でログインします。 

 
2. HP-UX software distributor program (swinstall) を起動します。 

 
3. Specify Source ダイアログが表示されますので、以下のように選択・入力します。 

 
z Source Depot Type 

Local Directory を選択します。 
 

z Source Depot Path 
depot ファイルを展開したディレクトリを指定します。 
 
(例) /tmp/mydepot/SICL.G.03.00 

 
4. 入力に間違いがなければ、OK ボタンをクリックします。 
5. swinstall が、depot を読み込みます。間違っていなければ、HP I/O Libraries for HP-U

X の表示と、Revision: G.03.00 が表示されます。 
6. 全てのドライバをインストールする場合は、HP I/O Libraries を選択し、メニューから A

ctions > Mark for Install を選びます(通常はこの方法で問題ありません)。 
 
特定のドライバのみインストールしたい場合は、インストールしたファイルセットが表示
されるまでバンドル名をダブルクリックします。インストールしたファイルセットが見つ
かったら、それを選択し、Actions > Mark for Install を選択します。 
 

7. ファイルセット・バンドルの選択が終わったら、Actions > Install を選択します。 
8. 解析フェーズが始まります。Status が Ready になったら、OK ボタンを押してインストー

ルを開始します。解析に失敗したときは、Logfile ボタンで内容を確認し、対処してくだ
さい。 

9. インストールが終了すると、Status が Complete になりますので、Done をクリックして
ください。 
 
その後、コンピュータをリブートする旨のダイアログが現れた場合は、YES をクリックし
て、コンピュータをリブートします。 
 
上記ダイアログが現れない場合は、File > Exit メニューを選んで、swinstall を終了し
てください。 

 
 
以上で、SICL のインストール作業は終了です。次は、コンフィグ作業を行う必要がありますの
で、次の節に進んでください。 
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(３) SICL のコンフィグ作業 (HP-UX 10.20 のみ必要) 
 
この節では、SICL ドライバの設定を行います。SICL の設定は、I/O setup ユーティリティを用
いて行います。手順は以下のようになります。 
 
1. スーパーユーザ(root)でログインします。 

 
2. 以下のコマンドで、I/O Setup ユーティリティを起動します。 

 
/opt/sicl/bin/iosetup 
 

3. インストールされている、ドライバの一覧が表示されています。使用したいドライバ名を
選択し、Configure ボタンをクリックします。 
 
例えば、E2050A LAN/GPIB を使用したい場合は、LAN Client Interface を選択し、Config
ure ボタンをクリックします。設定画面の情報が正しければ(通常は、設定画面の各情報は
標準のままで大丈夫です)、OK ボタンをクリックします。 
 

4. GPIB インターフェースの追加が終わったら、MAIN MENU で Done... ボタンをクリックしま
す。確認ダイアログが現れるので、OK ボタンで先に進むと、カーネル情報のダイアログボ
ックスがあわられますので内容を確認します。OK ボタンで終了すると、必要な場合はカー
ネルの再構築が行われます。 
 

5. カーネルの再構築が行われた場合は、設定を有効にするためには、コンピュータの再起動
が必要となりますので、ご注意ください。 
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７－２ IC-CAP リモートシミュレーションの設定方法 
 
(１) はじめに 

 
IC-CAP のリモートシミュレーションの設定の手順を示します。 
IC-CAP は内蔵の SPICE だけでなく、外部のシミュレータ（ADS や、HSPICE など）もシミュレ
ータとして利用できます。外部のシミュレータは、IC-CAP がインストールされている（ローカ
ル）コンピュータでも、別のコンピュータでもどちらでも利用できます。 
 
ただし、いずれの場合でもその外部シミュレータのライセンス（コードワード）が必要になりま
す。リモートシミュレーションの設定の作業はスーパユーザで行ってください。なお、詳細は
「Agilent IC-CAP 2002 / User’s Guide」マニュアルの「第６章 Simulating」の章、および「A
gilent IC-CAP 2002 / Reference」マニュアルの「第３章 SPICE Simulators」「第４章 Saber
 Simulator」「第５章 MNS Simulator」「第６章 ADS Simulator」の各章ご覧ください。 
以下、次のような項目を簡単に説明します。 
 

  □ リモート・シミュレーションの概念 
          □ リモート・シミュレーションの設定 
          □ 動作確認 
 
(２) リモート・シミュレーションの概念 

 
リモート・シミュレーションの概念を示します。 
IC-CAP で入力されたネットリスト（回路情報）は、外部シミュレータ（ADS や HSPICE など）
に送られます。外部シミュレータはそのネットリストを用いてシミュレーションを行います。シ
ミュレーション終了後、外部シミュレータは IC-CAP にシミュレーション結果を返します。この
とき、ネットリストおよびシミュレーション結果の転送にはリモートファイルコピー 
（rcp）命令が、シミュレーションの実行にはリモートシェル（remsh または rsh）命令が使用
されます。また、IC-CAP で入力するネットリストは、外部シミュレータが理解できるネットリ
ストを用意する必要があります。IC-CAP で標準で用意されている外部シミュレータのネットリ
スト（正確にはモデルファイル）は、MDS（シミュレータの名前は MNS）や、HSPICE などがあり
ます。 
 
■ まとめ ■ 
 
リモートシミュレーションを行う場合は、そのシミュレータが理解できるネットリストが必要で
す。 
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(３) リモート・シミュレーションの設定 
 
リモート・シミュレーションの設定を行います。 
 
1. 外部シミュレータが、IC-CAP を実行するコンピュータと同一のコンピュータで動作する場合 

 
□ IC-CAP を実行するユーザアカウントで外部シミュレータが起動できること。 
(パスや環境変数などの設定) 
 
＜参考＞＜参考＞＜参考＞＜参考＞ ADS の場合、以下の環境変数とパスが必要です。 

 
HPEESOF_DIR=/agilent/ads2002   （環境変数） 
PATH=$HPEESOF_DIR/bin:$PATH    （パス） 

 
□ 外部シミュレータのライセンス(コードワード)が少なくとも１つ以上存在すること。 
 
＜参考＞＜参考＞＜参考＞＜参考＞    
ADS の場合、FLEXlm ライセンスサーバからライセンスを取得できる必要がありま
す。例えば以下の環境変数が設定されている必要があります。 

 
LM_LICENSE_FILE=$HPEESOF_DIR/licenses/license.lic （環境変数） 

 
リモート・シミュレーション中、外部シミュレータ(ADS)はライセンスを一つ使用しま
す。他のユーザが、既にライセンスを使っていないかどうか、ご確認ください。 
 
 

2. 外部シミュレータが、IC-CAP を実行するコンピュータと異なるコンピュータで動作する場合 
 
□ IC-CAP を実行するユーザアカウントと同一のユーザアカウント名、ユーザ ID とグル
ープ ID が、外部シミュレータのコンピュータに存在すること。 
 
＜例＞＜例＞＜例＞＜例＞ 

IC-CAP を icuser というユーザアカウント名で実行している場合、外部シミュレ
ータが存在するコンピュータにも icuser というユーザアカウントを作成し、さら
に両者のユーザ ID とグループ ID を一致させます。 

 
□ IC-CAP を実行するユーザアカウントから、外部シミュレータのコンピュータにパスワ
ードなしでログインできること。 
 
＜設定＞＜設定＞＜設定＞＜設定＞  
相手のコンピュータのホームディレクトリに .rhosts ファイルを作成し、そのフ
ァイルの中に、自分のホスト名とユーザアカウント名を記入します。 

    
＜例＞＜例＞＜例＞＜例＞ 
IC-CAP を icuser というユーザアカウント名で実行している場合、外部シミュレ
ータが存在するコンピュータの icuser というユーザアカウントのホームディレク
トリに .rhosts ファイルを作成し、自分(ICCAP が存在するコンピュータ)のホス
ト名とユーザアカウント名を記入します。 
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外部シミュレータが存在するコンピュータ(リモートマシン)での作業の例 
 

＄  vi  /users/icuser/.rhosts 
 
＜記入内容＞＜記入内容＞＜記入内容＞＜記入内容＞    

<ローカルマシンのホスト名> <ユーザ名> 
 
＜記入例＞＜記入例＞＜記入例＞＜記入例＞    

iclocalhost icuser 
 
＜動作確認＞＜動作確認＞＜動作確認＞＜動作確認＞    
相手のコンピュータにパスワードなしで以下の命令を実行できることを確認してく
ださい。 
 
① リモートシェル命令を実行し、相手のコンピュータで設定されている時刻を
読みます。このとき表示される時刻は相手のコンピュータのものです。 
 

＄ remsh  相手のホスト名 date （ＨＰの場合） 
％ rsh    相手のホスト名 date （ＳＵＮの場合） 
 

② 相手のコンピュータに rlogin します。 
 

＄ rlogin  相手のホスト名 
 
 

□ 外部シミュレータを実行するユーザアカウントで外部シミュレータが起動できること。 
 
＜参考＞＜参考＞＜参考＞＜参考＞ 
リモートシェルで呼び出し時に、正しく外部シミュレータが動作する必要がありま
す。ADS を利用する場合、IC-CAP 2002 の中に専用のスクリプトファイル(hpeeso
fsim_start)と実行ファイル(hpeesofsim_front)が含まれていますので、リモート
ホスト側にも IC-CAP 2002 をインストールしてこれを利用します。 
このスクリプトファイルは環境変数の設定が必要です。この作業はリモートホスト
側で行います。リモートホスト側に、ADS 2002 が /agilent/ads2002 に IC-CAP 
2002 が /agilent/iccap2002 にインストールされているとすると以下の作業を行
ってください。 
 

＄  vi  /agilent/iccap2002/bin/hpeesofsim_start 
 
このファイル中に、以下の環境変数の設定を記入します。HPEESOF_DIR の設定例
の記述がコメントアウトされて存在しますので、その付近に記入します。 
 

HPEESOF_DIR=/agilent/ads2002 
export HPEESOF_DIR 
ICCAP_ROOT=/agilent/iccap2002 
export ICCAP_ROOT 
LM_LICENSE_FILE=/agilent/ads2002/licenses/license.lic 
expot LM_LICENSE_FILE 
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□ 外部シミュレータのライセンス(コードワード)が少なくとも１つ以上存在すること。 
 
＜参考＞＜参考＞＜参考＞＜参考＞ 
ADS の場合は、リモートホストで呼び出された外部シミュレータもライセンスが必
要になります。リモートホストでライセンスが取得可能かどうかもう一度ご確認く
ださい。 
 
 

3. 以上のリモートホスト側での設定を行った後、ローカルホスト側での、IC-CAP での設定を
行います。 
 
次の IC-CAP のファイルを編集し、内容を変更します。 
 
＃ vi  /agilent/iccap2002/lib/iccap/usersimulators 

 
＜変更内容＞＜変更内容＞＜変更内容＞＜変更内容＞    
外部シミュレータが、ADS の場合は以下の書式になります。 
 
hpsimrem  hpeesofsim  <simulator path>  “<remote host>”  CAN_PIPE 
 
呼び出すリモートホストのホスト名が、icremotehost の場合は以下の例のようになり
ます。 
 
hpsimrem  hpeesofsim  $ICCAP_ROOT/bin/hpeesofsim_start  “icremotehost”  CAN_PIPE 
 
三番目のフィールドが、外部シミュレータのフルパスです。 
四番目のフィールドが、リモートホストのホスト名になります。 
 
 

4. リモートシミュレーションの実行 
 
従来通り、Select Simulator (必要なら Model Variables) で、外部シミュレータ名(先程
の記入例では hpsimrem) を選択しておけば、リモートマシンの hpeesofsim を用いてシミ
ュレーションが実行されます。 
 
 
****注意注意注意注意**** ADS を利用する場合は、ADS の Status Windows がローカルコンピュータ側に表
示されます。IC-CAP 2002 を起動したものと異なるコンピュータを利用する場合は、 
xhost <remote host> 命令でウインドウを開く許可を与えておく必要があります。 
 
 
****参考参考参考参考**** 他のホストへ ADS リモートシミュレーションを実行した場合、リモートホスト側
の ADS のライセンスのリリースを IC-CAP 2002 を起動したコンピュータから自発的に行
うことができません。IC-CAP を起動したままの場合、自動的にリリースされるのに約二時
間後かかります。この場合、ローカルマシンの IC-CAP 2002 を一旦終了させると、直ちに
リモートホスト側の ADS のライセンスもリリースされます。 
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７－３ カーネルパラメータの確認、および変更方法 (HP-UX のみ) 
 
 
 [1] はじめに 
  
  HP-UX 使用時に sam (System Administration Program) を使って 
  現在のカーネルパラメータの値を確認したり、変更する方法を 
  説明します。 
 
 
 [2] カネールパラメータの確認、変更方法 
 
  (1) スーパーユーザ(root)でログインします。 
          (X11-window または、VUE を使用した方が便利です）  
 
  (2) sam を起動します。 
 
   ＃  sam 
 
          sam が立ち上がり System Administration Maneger 画面が表示 
      されます。 
 
  (3) マウスを使って 
 
   Kernel Configuration->  
 
          を選択します。 
 
  (4) マウスを使って、［Open］を選択します。 
 
  (5) マウスを使って 
 
   Configurable Parameters  
 
          を選択します。 
 
  (6) マウスを使って、[Open］を選択します。 
          Kernel Configuration 画面が表示されます。 
          ここで、それぞれのパラメータの意味は次のようになります。 
 
      maxdsiz HP-UX 上で動く各プロセス（プログラム）が保有 
    できるデータ領域の最大サイズ（上限）を決めます。 
 
      maxssiz HP-UX 上で動く各プロセスが保有できるスタック 
    領域の最大サイズを決めます。 
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      maxtsiz HP-UX 上で動く各プロセスが保有できるコード 
    領域の最大サイズを決めます。 
 
      maxuprc 各ログインユーザ毎に同時に実行できるプロセス数 
    の最大数を決めます。 
 
      nproc システム上で同時に実行できるプロセス数の 
    最大数を決めます。 
 
      maxswapchunks HP-UX 上で使用できるスワップの最大サイズ 
     の係数を決めます。 
 
  (7) 必要であればパラメータを変更します。 
             変更したいパラメータをマウスで選択します。 
 
  (8) ウインド左上部の［Actions］をマウスで選択します。 
          プルダウン メニューが現れますので、[Modyfy Configurable  
      Parameter...] を選択します。 
 
  (9)  Modify Configurable Parametre 画面が表示されます。 
            Formula/Value: に数値を入力します。 
 
  (10) マウスで［OK］を選択します。  
 
  (11) パラメータを変更した場合は、カーネルを新しく作り直します。 
            Kernel Configuration 画面で、ウインド左上部の 
      ［Actions］をマウスで選択します。 
           プルダウン メニューが現れますので、[Create a New Kernel]  
       を選択します。 
       HP-UX のリブートが行われますので注意してください。 
  
  (12) sam を終了するには、Kernel Configuration 画面から、 
       ウインド左上部の［List］をマウスで選択します。 
           プルダウン メニューが現れますので、[Exit] を選択します。 
           System Administration Maneger 画面に戻ります。 
 
  (13) System Administration Maneger 画面から、マウスを使って 
      ［Exit SAM］を選択すると、sam を終了します。 
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第８章 コードワード発行依頼と計測レスポンスセンタのご利用案内 

 
８－１ コードワード発行依頼の方法 
 
「Agilent EEsof EDA コードワード発行依頼 FAX シート」に必要事項を正確に記入し、FAX でお送りくだ
さい。 以下、ご記入の際に必要な情報の取得法・ご注意・記入法を示します。 
 
[１] ソフトウェアの情報 

 
 記入例 

シリアルナンバ (S/N) S/N 71512 *1)*1)*1)*1) 
製品名 IC-CAP 2002 製品名またはモデル番号 
モデル番号 85190A (IC-CAP Modeling Suite) 

ソフトウェアのバージョン IC-CAP 2002 
ライセンスの形態 ノードロック, フローティングライセンス 

*1)*1)*1)*1) コードワードが印刷されている紙等を参考にしてください 
 

[２] コンピュータの情報 
 
パラメータの種類 使用 OS コマンド 例 

Windows なし HP Vectra XA モデル名 
HP-UX 
SUN OS 

uname -m HP9000/755 
SUN SPARC Station 
10 

Windows 
(ノードロックのみ) 

ハードウェアキーに記載  *1)*1)*1)*1) FLEXID=8-5E700060D92A 

HP-UX /etc/uname -i 2014460207 

コンピュータ ID 
 

Sun OS /bin/hostid 544158c4 
HP-UX /etc/lanscan 0x080009490BE7 LAN ID (LLA) 
Solaris 2.7/2.8 ifconfig hme0 8:0:20:12:67:ca 

Windows Windows 版手順書参照 edahost1 ホスト名 *2)*2)*2)*2) 
HP-UX 
SUN OS 

Hostname edahost2 

 
*1)*1)*1)*1) ＰＣの場合はハードウェアキー番号をご記入ください。 
*2)*2)*2)*2) 製品バージョンとライセンス形態によって、必要でない場合もあります。 
 

コードワードが記載されている紙がございましたら、必ず一緒に FAX でお送りくださ
い。また、“license.lic, license.dat” ファイルも必ず一緒に FAX でお送りください。 
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[３] ご記入にあたってのお願い 
 
1) 文字は大きくはっきりとご記入下さい。特に、数字・アルファベットは、はっきりご記入

下さい。アルファベットは筆記体をご使用にならないで下さい。また、数字とアルファベ
ットの区別や、アルファベットの大文字と小文字の区別を明確にお願いします。 
 

紛らわしい文字の例 
数字の０(ゼロ)と、アルファベットのО(オー) 
大文字のＣと、小文字のｃ 
小文字のｌ(Ｌ)と、小文字のｅ(Ｅ) 

 
2) 黒色のペン、または鉛筆を使ってご記入下さい。青色のペンはご使用にならないで下さい。 

 
3) 会社名は略称ではなく、正式名を(日本語、英語とも)ご記入下さい。 

 
会社名の書き方 

良い例 アジレント・テクノロジー 株式会社 
Agilent Technologies Japan, Ltd. 

悪い例 アジレント（株） 
Agilent 

 
4) お名前はフルネームでご記入下さい。 

 
5) ファイルおよび UNIX の命令の実行結果をプリンタに出力したり、ファイルに出力する例

は次のとおりです。 
 

ファイル・プリンタへの出力例 (HP-UX) 
ファイル→プリンタへ出力 $ lp /iccap2001/licenses/license.dat 
UNIX 命令の実行結果→プリンタへ出力 $ /etc/lanscan | lp 
UNIX 命令の実行結果→ファイルへ出力 $ /etc/lanscan > /tmp/FILENAME 
 

6) FAX で送信する場合、紙の周囲に書かれている文字が欠けることがあります。できれば、
紙の周囲(上下左右) 3cm には、何も記入しないで下さい。特に、プリント出力された UNI
X の命令の実行結果などを FAX で送信する場合はご注意下さい。 
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Agilent EEsof EDA Agilent EEsof EDA Agilent EEsof EDA Agilent EEsof EDA     ライセンス（コードワード）発行依頼シートライセンス（コードワード）発行依頼シートライセンス（コードワード）発行依頼シートライセンス（コードワード）発行依頼シート    

アジレント・テクノロジー（株）ｻﾎﾟｰﾄ業務ｾﾝﾀアジレント・テクノロジー（株）ｻﾎﾟｰﾄ業務ｾﾝﾀアジレント・テクノロジー（株）ｻﾎﾟｰﾄ業務ｾﾝﾀアジレント・テクノロジー（株）ｻﾎﾟｰﾄ業務ｾﾝﾀ    契約業務ｸ契約業務ｸ契約業務ｸ契約業務ｸﾞﾙｰﾌﾟﾞﾙｰﾌﾟﾞﾙｰﾌﾟﾞﾙｰﾌﾟ  EDA  EDA  EDA  EDA ｺｰﾄﾞﾜｰﾄﾞ発行受付行ｺｰﾄﾞﾜｰﾄﾞ発行受付行ｺｰﾄﾞﾜｰﾄﾞ発行受付行ｺｰﾄﾞﾜｰﾄﾞ発行受付行      

FAX FAX FAX FAX ０１２０－８０２－０１６０１２０－８０２－０１６０１２０－８０２－０１６０１２０－８０２－０１６      TEL       TEL       TEL       TEL ０１２０－８０２－８７１０１２０－８０２－８７１０１２０－８０２－８７１０１２０－８０２－８７１            

 E E E E----MAILMAILMAILMAIL：：：：    japan_codeword@agilent.comjapan_codeword@agilent.comjapan_codeword@agilent.comjapan_codeword@agilent.com              

 ◇E-mail でご依頼の場合は、上記ｱﾄﾞﾚｽまで、 

   お客様のシステムハンドル、会社名、お名前 をお知らせ下さい。 

   メール専用フォーマットをお送り致します。 

FAX 送信枚数 

  （本表紙を含む）                枚 

 ◇ＦＡＸでご依頼の場合は、本シートに必要事項をご記入の上、 

  上記ＦＡＸ番号までお送り下さい。 

  ※各ﾗｲｾﾝｽｻｰﾊﾞごとに別々の用紙でご依頼下さい各ﾗｲｾﾝｽｻｰﾊﾞごとに別々の用紙でご依頼下さい各ﾗｲｾﾝｽｻｰﾊﾞごとに別々の用紙でご依頼下さい各ﾗｲｾﾝｽｻｰﾊﾞごとに別々の用紙でご依頼下さい。 

 送信日          月         日 

   

 ①①①①    ｼｽﾃﾑﾊﾝﾄﾞﾙをご記入下さい。ｼｽﾃﾑﾊﾝﾄﾞﾙをご記入下さい。ｼｽﾃﾑﾊﾝﾄﾞﾙをご記入下さい。ｼｽﾃﾑﾊﾝﾄﾞﾙをご記入下さい。※この番号は、通常発送伝票左上のＳ／Ｈ～に記載されております。 

 

             ｼｽﾃﾑﾊﾝﾄﾞﾙ番号ｼｽﾃﾑﾊﾝﾄﾞﾙ番号ｼｽﾃﾑﾊﾝﾄﾞﾙ番号ｼｽﾃﾑﾊﾝﾄﾞﾙ番号                                                                                                                                                                                                                        

 ②②②②今回ご依頼の、すべてのｺﾝﾋﾟｭｰﾀの情今回ご依頼の、すべてのｺﾝﾋﾟｭｰﾀの情今回ご依頼の、すべてのｺﾝﾋﾟｭｰﾀの情今回ご依頼の、すべてのｺﾝﾋﾟｭｰﾀの情報をご記入下さい。報をご記入下さい。報をご記入下さい。報をご記入下さい。     

 ■すべてのライセンスサーバの情報をご記入下さい。  

 ■すべてのノードロックライセンスクライアントの情報をご記入下さい。 

 ※ネットワークライセンスのクライアントの場合は、記入不要です。 

   

  コンピュータ ID 
（PC の場合はハードウェアキー番号） 

ホスト名 
 

備考 

 ライセンス・サーバライセンス・サーバライセンス・サーバライセンス・サーバ     

 ノードロック・クライアント  

 ノードロック・クライアント  

 ノードロック・クライアント  

 ノードロック・クライアント  
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会社名：                                                                        

   

 ご所属：                                                                        

   

 お名前：                                                  

 

電子メール アドレス：                                                          

   

 電話番号：                    内線（            ）  FAX：                         

   

 ﾗｲｾﾝｽの送付手段   □ 電子メール  □ FAX    

   

 必要な製品とバージョン    

製品名              バージョン                

  

 現在のﾗｲｾﾝｽの有効期限       年      月      日   

  

 ＊備考欄＊備考欄＊備考欄＊備考欄    ＊＊＊＊ (マシン変更内容詳細/ご質問等がございましたら、ご記入下さい） 
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８－２ 計測レスポンスセンタ・テクニカルサポート依頼 FAX シートの使い方 
 
[１] レスポンスセンタへお問合せの際は、お客様のシステムハンドル番号を必ずお知らせください。

システムハンドル番号がわからない場合は、受付できない可能性があります。 
 

[２] 「計測レスポンスセンタ  テクニカルサポート依頼 FAX シート」に必要事項と、継続質問の場
合は受付番号(CALL ID：例=3012345)を記入してください。 
 

[３] 離席されている場合が多いときは、時間指定していただくと便利です。 
 

[４] FAX シートご記入いただくときに、次の問題確認項目を参考にしていただくとより早い回答を行
なうことができます。 
 
1) 何をしようとしていましたか。 
2) どうなるはずだ、またはどうなって欲しいと考えていますか。 
3) 何が起きていますか。 
4) どんなエラーメッセージ、エラー番号が出ていますか。 

� そのエラーメッセージはＵＮＩＸですか、それともソフトウェアですか。 
� そのエラーメッセージはどこに表示されていますか。 
データベースで検索するため、エラーメッセージは正確にお知らせください。 

5) この問題はいつから発生していますか。 
6) この問題はときどき発生しますか、または必ず発生しますか。 
7) ときどき発生するときは、どんなときに発生しますか。 
8) 今までは正常に動作していましたか、または今回が初めてのご使用ですか。 
9) 問題発生前に、何か変更なさいましたか。（ハードウェア、ソフトウェア、設定など） 
10) すでに何かの問題解決の手を打たれましたか。その結果はどうでしたか。 

 
[５] 参考 

1) システムハンドル（システムＩＤ）番号とは？ 
お客様ごとに割り当てられた、お客様固有の番号。ユーザＩＤ番号のこと。 
計測レスポンスセンタにご質問されるときに、必ず受付にお伝えください。 
システムハンドル番号を伝え忘れた場合、契約をされていないお客様として扱われる場合
があります。（銀行の暗証番号のようなものです。） 
この場合、計測レスポンスセンタからの連絡は保証されませんので、必ずシステムハンド
ル番号を受付にお伝えください。 
(システムハンドル番号の例：８１２３－７１５１２) 

2) CALL ID (受付番号) とは？ 
ご質問ごとに割り当てられる番号。 
計測レスポンスセンタにご質問をいただいたときに、ご質問ごとに CALL ID(受付番号)を
発行します。 
(CALL ID の例：3012345) 
 

3) システム名、バージョン 
システム名、バージョンは正確にお伝えください。 
(システム名の例：ＭＤＳ(85150B)，ＩＣ－ＣＡＰ(85190A)) 
コンピュータ名と UNIX のバージョンは、次のコマンドで確認できます。 

# uname –a 
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８－３ 計測レスポンスセンタを有効にご利用いただくために 
 

 
計測レスポンスセンタをより有効にご利用いただくために、 

お客様にお願いしたいことをまとめてみました 

 
[１] より早くご回答をするためにお願いしたいこと 

 
1) お客様のシステムハンドル番号は正確にお伝えください。 

アジレント・テクノロジーでは、お客様のシステムハンドル番号をデータベース化してお
ります。よりスムーズなご回答のために、ご質問受付時にお客様のシステムハンドル番号
をお伺いしております。 
システムハンドル番号を伝え忘れた場合、契約をされていないお客様として扱われるとき
があります。 
 

2) 製品名は正確にお伝えください。 
計測レスポンスセンタ受付では、１か月に約数千件のご質問を承っております。 
製品名を正確にお伝えいただけませんと、間違った担当者（エンジニアグループ）にご質
問が回り、ご回答が遅れる場合があります。そのため、ご質問の製品名は正確にお伝えく
ださい。 
(製品名の例：ADS,IC-CAP) 
 

3) 同姓（同じお名前）の方が複数人いらっしゃるときは、フルネームでお願いします。 
 

[２] より正確なご回答をするためにお願いしたいこと 
 
1) エラーメッセージは正確にお伝えください。 

計測レスポンスセンタでは、世界中からよせられたご質問をデータベース化しております。
エンジニアはこのデータベースを参照し、既に解決した問題であれば迅速にお客様のご質
問に対応することができます。データベースの検索は、エラーメッセージなどのキーワー
ドで行ないますので、正確にエラーメッセージをお伝えください。 
 

2) UNIX と製品のバージョンは正確にお伝えください。 
HP-UX の場合、バージョンは小数以下２桁まであります。 

良い例：ＨＰ－ＵＸ ９．０５，ＭＤＳ Ｂ．０５．０２ 
悪い例：ＨＰ－ＵＸ ９．０，ＭＤＳ Ｂ．０５ 

バージョンを正確にお伝えいただけませんと、正確なご回答ができない場合があります。 
 

[３] １回のお電話でご質問を解決するためにお願いしたいこと 
 
1) ＦＡＸをご活用ください。 

図（システムの構成、回路図、グラフ）などは、 FAX をご活用いただくとご質問内容がよ
り正確にエンジニアに伝わります。また、エラーメッセージなども FAX でお送りいただく
と、データベースの検索がよりスムーズに行なえます。 
 

2) 離席されている場合が多いときは、お電話の時間指定をしてください。 
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[４] その他、お願いしたいこと 
 
1) 受付番号(CALL ID)は控えておいてください。 

計測レスポンスセンタにご質問をいただいたときに、CALL ID を発行しております。この 
CALL ID はご質問ごとに割り当てられる番号ですので、控えておいてください。お客様か
らのご質問はすべてデータベース化され、保存されますので、再度ご質問されるときは CA
LL ID を受付にお伝えください。 
 

2) 計測レスポンスセンタ契約の更新は、１年ごとになります。ご契約いただいた計測レスポ
ンスセンタサービスは、１年ごとの更新となります。 
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EEsof EDAEEsof EDAEEsof EDAEEsof EDA    テクニカルサポート依頼テクニカルサポート依頼テクニカルサポート依頼テクニカルサポート依頼    ＦＡＸシートＦＡＸシートＦＡＸシートＦＡＸシート 
計測計測レスポンスセンタ  E-mail: edasupport@jpn.agilent.com 

ＦＡＸ：０１２０－８９０－１１９      ＴＥＬ：０１２０－５６０－１１９ 
 

文字(特に数字とアルファベット)は大きくはっきりとご記入ください。 
 
CALL ID(受付番号)    
 
システムハンドル(必ずご記入ください)    日付    
 
会社名            
 
ご所属            
 
お名前(フルネーム) <漢字>    <ひらがな>     
 
電話      内線    
 
ＦＡＸ    E-Mail        
 
製品名     バージョン・リビジョン     
 
コンピュータモデル名    OS バージョン     
 
お問い合わせ内容（エラーメッセ－ジが表示されている場合は、必ずご記入ください 
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