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ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
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in the hope that it will be useful,but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details. You should have received a copy of the
GNU Lesser General Public License along with this library; if not, write to the Free
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
unRAR copyright: The decompression engine for RAR archives was developed using source
code of unRAR program.All copyrights to original unRAR code are owned by Alexander
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General Public License as published by the Free Software Foundation; either version 2.1 of
the License, or (at your option) any later version. This library is distributed in the hope
that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
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General Public License for more details. You should have received a copy of the GNU
Lesser General Public License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA Permission is
hereby granted to use or copy this program under the terms of the GNU LGPL, provided
that the Copyright, this License, and the Availability of the original version is retained on
all copies.User documentation of any code that uses this code or any modified version of
this code must cite the Copyright, this License, the Availability note, and "Used by
permission." Permission to modify the code and to distribute modified code is granted,
provided the Copyright, this License, and the Availability note are retained, and a notice
that the code was modified is included. AMD Availability:
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UMFPACK Copyright: UMFPACK Copyright © 1995-2006 by Timothy A. Davis. All Rights
Reserved. UMFPACK License: Your use or distribution of UMFPACK or any modified version
of UMFPACK implies that you agree to this License. This library is free software; you can
redistribute it and/or modify it under the terms of the GNU Lesser General Public License
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as published by the Free Software Foundation; either version 2.1 of the License, or (at
your option) any later version. This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies. User documentation of any
code that uses this code or any modified version of this code must cite the Copyright, this
License, the Availability note, and "Used by permission." Permission to modify the code
and to distribute modified code is granted, provided the Copyright, this License, and the
Availability note are retained, and a notice that the code was modified is included.
UMFPACK Availability: http://www.cise.ufl.edu/research/sparse/umfpack  UMFPACK
(including versions 2.2.1 and earlier, in FORTRAN) is available at
http://www.cise.ufl.edu/research/sparse . MA38 is available in the Harwell Subroutine
Library. This version of UMFPACK includes a modified form of COLAMD Version 2.0,
originally released on Jan. 31, 2000, also available at
http://www.cise.ufl.edu/research/sparse . COLAMD V2.0 is also incorporated as a built-in
function in MATLAB version 6.1, by The MathWorks, Inc. http://www.mathworks.com .
COLAMD V1.0 appears as a column-preordering in SuperLU (SuperLU is available at
http://www.netlib.org ). UMFPACK v4.0 is a built-in routine in MATLAB 6.5. UMFPACK v4.3
is a built-in routine in MATLAB 7.1.

Qt Version 4.5.1 - Qt Notice: The Qt code was modified. Used by permission. Qt copyright:
Qt Version 4.5.1, Copyright (c) 2009 by Nokia Corporation. All Rights Reserved. Qt
License: Your use or distribution of Qt or any modified version of Qt implies that you agree
to this License. This library is free software; you can redistribute it and/or modify it under
the
terms of the GNU Lesser General Public License as published by the Free Software
Foundation; either version 2.1 of the License, or (at your option) any later version. This
library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies.User
documentation of any code that uses this code or any modified version of this code must
cite the Copyright, this License, the Availability note, and "Used by permission."
Permission to modify the code and to distribute modified code is granted, provided the
Copyright, this License, and the Availability note are retained, and a notice that the code
was modified is included. Qt Availability: http://www.qtsoftware.com/downloads  Patches
Applied to Qt can be found in the installation at:
$HPEESOF_DIR/prod/licenses/thirdparty/qt/patches. You may also contact Brian
Buchanan at Agilent Inc. at brian_buchanan@agilent.com for more information.

Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file
names and directory names. The business entity formerly known as "HP EEsof" is now part
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of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and
to maintain backward compatibility for our customers, we did not change all the names
and labels that contain "HP" or "HPEESOF" references.

Warranty The material contained in this document is provided "as is", and is subject to
being changed, without notice, in future editions. Further, to the maximum extent
permitted by applicable law, Agilent disclaims all warranties, either express or implied,
with regard to this documentation and any information contained herein, including but not
limited to the implied warranties of merchantability and fitness for a particular purpose.
Agilent shall not be liable for errors or for incidental or consequential damages in
connection with the furnishing, use, or performance of this document or of any
information contained herein. Should Agilent and the user have a separate written
agreement with warranty terms covering the material in this document that conflict with
these terms, the warranty terms in the separate agreement shall control.

Technology Licenses The hardware and/or software described in this document are
furnished under a license and may be used or copied only in accordance with the terms of
such license. Portions of this product include the SystemC software licensed under Open
Source terms, which are available for download at http://systemc.org/ . This software is
redistributed by Agilent. The Contributors of the SystemC software provide this software
"as is" and offer no warranty of any kind, express or implied, including without limitation
warranties or conditions or title and non-infringement, and implied warranties or
conditions merchantability and fitness for a particular purpose. Contributors shall not be
liable for any damages of any kind including without limitation direct, indirect, special,
incidental and consequential damages, such as lost profits. Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily
provided to end user customers. Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212
(Computer Software) and, for the Department of Defense, DFARS 252.227-7015
(Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial
Computer Software or Computer Software Documentation).

http://systemc.org/
http://systemc.org/
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 Introducing the Smith Chart Utility 
The Smith Chart Utility provides full Smith Chart capabilities, synthesis of matching
networks, enabling impedance matching and plotting of constant Gain / Q / VSWR / Noise
circles. The Smith Chart Utility is accessed from the Schematic window Tools or
DesignGuide menus.

The Smith Chart Utility documentation includes these sections:

The Step-by-Step Example describes how to design the single frequency impedance
matching network.

Using SmartComponents (dgfilter) answers many common questions relating to
Utility use.

Smith Chart Drawing Area (smithchartutil) explains how to manipulate the Smith
Chart.

Smith Chart Network Area (smithchartutil) explains how to analyze network data.

  

 Step-by-Step Example
The step-by-step example takes you through the through the design and analysis of a
single frequency impedance matching network. After completing this example, you should
have a basic understanding of the Utility and be ready to begin using the tool. Follow
these steps to begin:

Setting Up the Design Environment

Designing and Analyzing a Network

Note
You should already be familiar with the basic features of Advanced Design System. For help with
ADS basic features, refer to the Schematic Capture and Layout (usrguide) documentation.

  

 Setting Up the Design Environment
Before you can use the Smith Chart Utility, you must set up the design environment by
using these steps:

Setting DesignGuide Preferences

Opening a Project

Opening a Schematic Window
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Opening the Smith Chart Utility

Displaying the SmartComponent Palette

  

 Setting DesignGuide Preferences

All DesignGuides can be accessed through either cascading menus or dialog boxes. You
can configure your preferred method in the ADS Main window or from the Schematic
window.

To configure access through menus or dialog boxes:

From the Main or Schematic window, choose DesignGuide > Preferences .1.
In the DesignGuide Menu Style group box, choose either Use a selection dialog2.
box or Use cascade menus .

Close and restart the program for your preference changes to take effect.3.

Note
On PC systems, Windows resource issues might limit the use of cascading menus. When multiple windows
are open, your system could become destabilized. Therefore, the dialog box menu style might be best for
these situations.

The ADS Main window DesignGuide menu contains these choices:

DesignGuide Developer Studio > Start DesignGuide Studio is only available on this
menu if you have installed the DesignGuide Developer Studio to open the initial Developer
Studio dialog box.

DesignGuide Developer Studio > Developer Studio Documentation is only available
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on this menu if you have installed the DesignGuide Developer Studio to open the
DesignGuide Developer Studio documentation.

Note
Another way to access the DesignGuide Developer Studio documentation is by selecting Help > Topics and
Index > DesignGuides > DesignGuide Developer Studio from any ADS program window.

Add DesignGuide opens a directory browser in which you can add a DesignGuide to your
installation. This is primarily intended for use with DesignGuides that are custom-built
through the Developer Studio.

List/Remove DesignGuide opens a list of your installed DesignGuides. Select any that
you would like to uninstall and choose the Remove button.

Preferences opens a dialog box that enables you to:

Disable the DesignGuide menu commands (all except Preferences) in the Main
window by unchecking this box. In the Schematic and Layout windows, the complete
DesignGuide menu and all of its commands are removed if this box is unchecked.
Select your preferred interface method, either cascading menus or dialog boxes.

  

 Opening a Project

The ADS design environment is set up within a project.

To create a new project:

From the ADS Main window, choose File > New Project or click Create a New1.
Project on the toolbar.

In the dialog, define the location of the project and assign a project name.2.

  

 Opening a Schematic Window

A new schematic design is needed to contain the lowpass component for this example.

To open a Schematic window:

From the ADS Main window, choose Window > __ New Schematic or click New1.
Schematic Window on the toolbar. A new Schematic window appears.



Advanced Design System 2009 Update 1 - Smith Chart Utility

10

Note
Depending on how your ADS preferences are set, a Schematic window can appear automatically
when you create or open a project.

In the Schematic window, choose File > New Design to create a design named2.
SmithChartExample .

  

 Opening the Smith Chart Utility

The Smith Chart Utility is accessed from the Tools menu or the DesignGuide menu in the
Schematic window.

To open the Smith Chart Utility:

In the Schematic window, choose Tools > Smith Chart . The Control window opens.1.
Or, you can choose one of these paths from the DesignGuide menu:

DesignGuide > Amplifier > Tools > Smith Chart Utility
DesignGuide > Filter > Smith Chart
DesignGuide > Mixers > Tools > Smith Chart Utility
DesignGuide > Oscillator > Tools > Smith Chart
Note: Expand the list under Tools by clicking the + sign.

  

 Using the Control Window

All Utility features are available from the Control window. The Control window houses
menus, a toolbar, and SmartComponent manipulation controls. The menus and toolbar
buttons perform the basic functions of design, delete, and display the SmartComponent
palette. The window can be placed anywhere on the screen. Explore the window menus as
well to familiarize yourself with the basic Utility capabilities.

The pull down lists at the top of the utility window are designed to help you navigate
multiple schematic windows and SmartComponents. You can use the Current Schematic
drop-down list box to select any of the currently opened schematic windows. This field is
updated any time Smith Chart Utility window is selected. You can use the
SmartComponent drop-down list box to select any of the SmartComponents on the
currently selected schematic window.
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 Using the Control Window 
When you choose the DA_SmithChartMatch1 SmartComponent from the SmartComponent
drop-down list box, the following dialog is displayed:

This dialog allows you to update the selected SmartComponent with the changes made
using the Smith Chart utility, or conversely, update the Smith Chart Utility with the
parameters of the SmartComponent. Selecting another component from the dropdown list
will update the Smith Chart with the parameters of that component.

To close the Control window:

Choose File > Exit Utility from the Control window menubar. (You can also close the
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window by clicking the x at the top of the window.)
Continue the step-by-step example by Designing and Analyzing a Network.

  

 Designing and Analyzing a Network
Load and source matching networks for amplifiers can be designed easily using the Smith
Chart. Using the Utility follows a normal design flow procedure:

Select a component needed for your design from the component palette (Displaying
the SmartComponent Palette) and place the component in your design (Placing
Example Component in the Design).

Provide specifications (Changing SmartComponent Parameters).

Design and analyze the component (Designing the Amplifier Using the Smith Chart).

Note
Before starting this section of the step-by-step example, confirm your setup (Setting Up the Design
Environment).

  

 Displaying the SmartComponent Palette

The program contains a SmartComponent palette, Smith Chart Matching Networks , that
provides quick and easy access to the SmartComponents. A blue accent in the upper-left
corner of a palette button indicates the component is a SmartComponent.

You can display the SmartComponent palettes in one of these ways:

By clicking Component Palette on the Control window toolbar
By choosing View > Palette from the Control window menu
By selecting the Smith Chart Matching palette from the Component Palette drop-
down list box in the Schematic window toolbar (directly above the palette).
Continue the example by selecting the Smith Chart Matching palette. The palette
displays in the Schematic window.

  

 Placing Example Component in the Design

To place a SmartComponent in the design:
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Click DA_SmithChartMatch on the component palette to select the component.1.

Click within the schematic window to place the component.2.
You can change the orientation of the SmartComponent before placement by
choosing from the Insert > Component > Component Orientation commands or
by selecting Rotate by -90 repeatedly from the schematic toolbar.
The place component mode remains active until you choose End Command from
the schematic toolbar.

Note
When a SmartComponent is placed initially, a temporary component is used to place and specify the
parameters for the SmartComponent. This component does not contain a subnetwork design. After the
utility has been used to design the SmartComponent, the temporary component is replaced with a
permanent component. The SmartComponent is renamed to DA_ComponentName_DesignName and an
autogenerated design is placed inside the SmartComponent's subnetwork design file. Subsequently, if the
SmartComponent parameters are edited, the utility must be used again to update the subnetwork design
file.

  

 Designing the Amplifier Using the Smith Chart

During this example, you design the load matching network for this specific amplifier
design problem:
Design a microwave transistor amplifier, operating at 3 GHz, to have an operating power
gain of 9 dB. The transistor S-parameters are:

S11 = .641 - -171.3
S12 = .057 - 16.3
S21 = 2.058 - 28.5
S22 = .572 - -95.7

  

 Changing SmartComponent Parameters

Parameters can be changed directly from the Control window.

To edit the DA_SmithChartMatch component parameters:

In the Control window, select the DA_SmithChartMatch component from the1.
SmartComponent drop-down list. This ensures all changes are referenced to this
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component.
From the Smith Chart window menu, choose View > S-Parameters . In the dialog2.
box, enter the S-parameters (magnitude and angle) for this amplifier and click Done.

  

 Displaying the Operating Power Gain Circle

To display the Operating Power Gain circle and its corresponding control box:

From the Smith Chart utility window menu, choose Circles > Bilateral > Gp to open
the Operating Power Gain dialog. Either use the slider or text box to choose a 9 dB
circle and click OK to display the chart.

  

 Set Frequency

To set operating frequency:
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Return to the Smith Chart utility main window.1.
In the Frequency/GHz field, enter 3 and click OK to continue.2.

  

 Finding Source and Load Points

For this example, we use a 50 Ohm load. The source lies on the power gain circle. First,
place the terminations onto their correct locations in the Smith Chart using the Smith
Chart Drawing Palette.

To place the source and load on the chart:

Place the source termination by clicking the drawing palette button Source1.
Termination Conjugate and then moving the crosshairs until gamma on the status
panel at the bottom of the Smith Chart shows approximately .36 - 47.5.
Highlight the source termination marker by clicking in the middle of the marker until2.
a pink box highlights the marker. The load termination does not need to be moved
since the load termination defaults to 50 Ohm.

  

 Fixing Termination Accuracy

If the source termination is not exactly .36 - 47.5 the source termination can be changed
by entering the correct values into the Gamma section of the status panel.

Make sure the source marker is highlighted before changing values. Next, use the
status panel again to conjugate the source marker (by negating the imaginary part of
the impedance) for matching purposes.
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 Drawing the Matching Network

To draw the matching network:

Select the Shorted Stub component from the drawing palette and click the end point1.
in the vicinity of Gamma .45 - 117.
Select the Line Length component from the drawing palette and select its end point2.
to be near the source marker. Fine tuning can be done by dragging both green node
markers until the end is exactly on the source marker.

  

 Analyzing Frequency Response

To analyze the frequency response:

Click the Reset button next to the Network Response plot to re-normalize the start1.
and stop frequencies.
For Type select Mag and for S-Parm select S11 . Notice that at 3 GHz the magnitude2.
of S11 is zero, implying a good matching network.
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 Previewing Matching Network

After building, the network is displayed in the Network Schematic box.
To edit the network from the display:

Click either the shorted stub or the length of line . Notice that parameter values
can be changed here. Also, you can delete the selected component here.

  

 Building the Circuit

To build a circuit into the Smith Chart SmartComponent:

Click Build ADS Circuit at the bottom left of the utility window. The result displays
in the Schematic window.
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 Examining the Matching Component Design

You can look at the details of the autogenerated design inside the SmartComponent's
subnetwork.
To examine the component's subnetwork:

Select the component DA_SmithChartMatch .1.
Click Push Into Hierarchy on the schematic toolbar to reveal the subnetwork.2.

After examining the design, click Pop Out on the schematic toolbar to close the view.3.
This completes the step-by-step example.
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 Using SmartComponents in Smith Chart
Utility
This Utility provides a single SmartComponent representing a matching network.
SmartComponents are smart sub-network designs that provide the container for
specification parameters and a schematic representation of the design when placed into a
design. The utility provides automated design and analysis for these SmartComponents.

SmartComponents can be placed, copied, edited and deleted like other components in the
Advanced Design System. The basics of placement, copying, editing and deleting are
described briefly in this section.

Note
For help with ADS basic features, refer to the Schematic Capture and Layout (usrguide) documentation.

  

 Placing and Editing SmartComponents
The components are placed in the schematic by selecting the SmartComponent from the
palette and clicking at the point where you want to place the component in the schematic.

You can display the SmartComponent palette in two ways:

Open the Smith Chart Matching Utility by selecting Tools > Smith Chart . Display the
SmartComponent palette by selecting the Palette button from the utility window
toolbar or by selecting View > Palette from the utility window menu.
Select the Smith Chart Matching palette from the Component Palette drop-down list
box in the Schematic window toolbar (directly above the palette).

  

 Placing SmartComponents

To place a SmartComponent in the design:

In the Schematic window, select the component from the SmartComponent palette.1.
Click within the design window at the location where you want to place the2.
SmartComponent.

You can change the orientation of the SmartComponent before placement by
choosing from the Insert > Component > Component Orientation commands or
by selecting Rotate by -90 repeatedly from the schematic toolbar.
The place component mode remains active until you choose End Command from
the schematic toolbar.
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 Changing Position and Orientation

A SmartComponent is moved by dragging it to any location in the Schematic window.

To change the component's orientation:

Select Edit > Advanced Rotate > Rotate Around Reference from the Schematic1.
window or select Rotate Items from the toolbar.
Click the SmartComponent you want to use.2.
Rotate the component. The rotate mode remains active until you select End3.
Command from the toolbar.

  

 Editing SmartComponents

Specifications of the SmartComponent are entered directly on the Smith Chart Utility
Control window. You can also modify the specifications in one of these ways:

Click the SmartComponent parameters in the schematic window and change them
(see The DA_SmithChartMatch Component (dgfilter).)

Double-click the SmartComponent to open a dialog box containing all parameters.

 

 The DA_SmithChartMatch Component

The SmartComponent design (schematic) can be viewed by pushing into the
SmartComponent's subnetwork. See Examining the Matching Component Design
(smithchartutil).

A SmartComponent subnetwork is empty until the design is generated (see the note in the
section Placing and Editing SmartComponents (dgfilter)).
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 Copying SmartComponents
SmartComponents can be copied within a design, to another design, or to another
Schematic window.

  

 Copying Within a Design

To copy a SmartComponent to the same design:

Click the SmartComponent to be copied.1.
Select Edit > Copy and then Edit > Paste from the schematic window.2.
Click where you want the copy placed.3.

  

 Copying Between Designs or Schematic Windows

To copy a SmartComponent to another design:

Click the SmartComponent to be copied.1.
Select Edit > Copy from the Schematic window.2.
Display the design or schematic window you want to copy the SmartComponent to.3.
Select Edit > Paste to copy the SmartComponent to the design.4.
Click where you want the component placed.5.

  

 Copying a SmartComponent as a Unique Design

Initially, all copied SmartComponents refer to the same SmartComponent design. When
the Smith Chart Utility is used to perform a design operation, the Utility transforms each
copied SmartComponent into a unique SmartComponent design. A design operation is
accomplished from the Utility Control Window.

  

 Deleting SmartComponents
SmartComponents can be deleted from a design like other components, but completely
removing a SmartComponent's files requires the actions described here.

  

 Deleting from Current Design
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A SmartComponent can be deleted from a design in one of these ways:

By selecting the component and pressing the Delete key,
By selecting Delete from the toolbar,
By selecting Edit > Delete from the schematic window.

Note
This procedure does not remove the SmartComponent files from the project directory. To delete files
from the project directory, see Deleting from Current Project (dgfilter).

  

 Deleting from Current Project

To delete a SmartComponent and all associated files from your project:

In the Schematic window, select the SmartComponent.1.
In the utility window, select Tools > Delete SmartComponent. or on the toolbar,2.
click Delete . This deletes the SmartComponent from the current design and
removes all of its files from your project. The SmartComponent delete mode remains
active until you select End Command from the schematic toolbar.

  

 Deleting Manually Using File System

You can use your computer's file system to delete a SmartComponent by deleting the
appropriate files in the network subdirectory of a project. Delete files that start with DA_
or SA_ , contain the SmartComponent title, and end with . ael, .atf, or .dsn .

  

 Using SmartComponents as Standalone Components
After SmartComponents are designed and tested, they can be used as standalone
components. The Matching Utility is not needed to use them in new designs unless you
wish to modify or analyze them. When using the SmartComponent in a design, however,
the power supply pins (Vdd, Vcc, Vp, Vm) must be connected to a DC voltage source
whose voltage level corresponds the parameter setting.

  

 Using an Existing SmartComponent Within the Same Project

To use an existing SmartComponent within the same project:

Open the Component Library window by selecting Insert > Component >1.
Component Library from the Schematic window or Display Component Library
List on the toolbar.
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Select the project name under All > Sub-networks in the Libraries list at the left of2.
the Component Library window. Available components are listed in the Components
list at the right of the Component Library window.
Select the SmartComponent in the Components list.3.
Place the SmartComponent into your design by clicking in the Schematic window at4.
the location you wish it placed.The insert mode remains active until you click End
Command.

  

 Using an Existing SmartComponent in Any Project

A library of predesigned reusable SmartComponents can be created by placing the
reusable SmartComponents in a project. This project can be included in any project and
its SmartComponents can be accessed using the Component Library.

To use an existing SmartComponent in any project:

Select File > Include/Remove Projects from the main ADS window.1.
Select the project that contains the SmartComponent from list in the Include &2.
Remove window.
Click Include to include the project in the hierarchy and click OK.3.
Open the Component Library window by selecting Insert > Component >4.
Component Library from the Schematic window or Display Component Library
List from the toolbar.
Select the included project name under All > Sub-networks in the Libraries list at5.
the left of the Component Library window. Available components are listed in the
Components list at the right of the Component Library window.
Select the SmartComponent in the Components list.6.
Place the SmartComponent into your design by clicking in the Schematic window at7.
the location you where you want to place the component. The insert mode remains
active until you click End Command.
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 Smith Chart Drawing Area
The Smith Chart Drawing Area is the central focus of the Smith Chart Utility. In this area
the full functionality of a Smith Chart can be utilized. Gain, VSWR, Q, and Stability circles
can be plotted easily by simply entering S-parameters and then choosing the
corresponding menu items. Noise circles can also be plotted in a similar manner. Complex
impedance matching is also done in this area by using any of the available passive
elements.

To view a SmartComponent, select the SmartComponent from the SmartComponent drop-
down list box in the upper right corner of the utility window. Changes made in the Smith
Chart Utility affect the selected SmartComponent.
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 Circle Options
The Smith Chart itself consists of four sets of circles of constant value: resistance (R),
reactance (X), conductance (G), and susceptance (B). Using the check boxes at the top of
the dialog, these circles can be toggled on and off. The actual circles plotted are controlled
using the bottom portion of the dialog. Selecting Circles > Options in the Smith Chart
utility window opens the dialog box.

  

 Circle Colors
Circle colors can be changed on the Smith Chart by choosing Circles > Colors in the
Smith Chart utility window.
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 Components
Twelve components are available to be used on the Smith Chart for matching purposes.

Source Conjugate Termination. Complex point to match to.

Load Conjugate. Complex point to match from.

Series Inductor. Snaps to constant resistance circles.

Shunt Inductor. Snaps to constant conductance circles.

Series Capacitor. Snaps to constant resistance circles.

Shunt Capacitor. Snaps to constant conductance circles.
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Series Resistor. Snaps to constant reactance circles.

Shunt Resistor. Snaps to constant susceptance circles.

Transformer. Snaps to constant Q circles.

Line Length. Snaps to circles of constant reflection coefficient magnitude.

Shorted Stub. Snaps to constant conductance circles.

Open Stub. Snaps to constant conductance circles.

  

 Network Termination Definitions
The source and load terminations can be defined as equivalent circuits. To access the
Network Terminations dialog box, select Define Source/Load Network Terminations in the
Smith Chart Utility window.

Network terminations can be input using lumped components networks, complex
impedances, and S-parameter files. Usage for these input types is:

Lumped Component. Choices include Resistive, Series RL, Series RC, Parallel RL,
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Parallel RC, Series RLC, Parallel RLC, where R = resistance, L = inductance, and C =
capacitance. Component values must be specified by the user.
Complex Impedance. The impedance is interpreted as frequency independent,
expressed in the form 50 + j × 10 ohms. This input approach is useful for
narrowband matching. If the true impedance varies significantly with frequency,
better accuracy can be obtained by specifying the termination using an S-parameter
file or manually entering the data using the spreadsheet data entry capability.
S-Parameter File. Any termination can be represented using a file in Touchstone,
Citifile or ADS .ds format representing S-parameter data. The impedance can be
specified in S, Z, or Y parameters. For details on data file format and creating these
files from simulation datasets, refer to Working with Data Files (cktsim) in the Circuit
Simulation documentation. You can click the Browse button to launch a window to
select the file.
Manual Data Entry. The complex impedance (specified as an impedance, admittance,
or reflection coefficient) can be entered as a function of frequency manually. When
the source or load impedance is specified as Manual Entry, the Edit button can be
used to open a spreadsheet that is useful for entering frequency/impedance pairs.

Interpret as Input/Output Impedance. These options are available for three cases of
source and load impedance: complex load, S-parameter file, and Manual entry. Use
the Interpret as Input Impedance option to specify that the value you have entered is
of impedance looking into the device (S-parameters of the measured device, for
instance). Use the Interpret as Output Impedance option to specify that the value
you've entered is of impedance looking out from the device (impedance you want to
see).

  

 Scattering and Noise Parameters
Scattering and noise parameters are an easy way to describe the characteristics of
amplifiers and other devices. For a given set of parameters, constant parameter circles
can be plotted on the Smith Chart. These constant parameter circles can be used to create
matching networks that solve specific design problems.
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The Scattering Parameters dialog box can be opened by choosing View > S-Parameters
from the Smith Chart utility window menu. S-parameters are entered as a magnitude and
phase (in degrees).

The Noise Parameters dialog box can be opened by choosing View > N-Parameters from
the Smith Chart utility window menu. Four noise parameters are entered here: magnitude
and phase of the optimal source reflection coefficient (GammaOpt), the minimum noise
figure (FMin), and the normalized effective noise resistance (Rn).

  

 Constant Circles
Constant circles are a locus of points on the Smith Chart that refer to a certain value. For
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example, a constant gain circle would be all the points that refer to a certain gain. Nine
circles can be plotted on the Smith Chart. These circles can be divided into three
dependencies.

No Dependence. Circles of constant Q can be manipulated on the Smith Chart without
entering any external data.
Scattering Parameters Dependence. Stability (input and output), VSWR, unilateral
(Gs and Gl), and bilateral (Ga and Gp) circles all require valid S-parameter data.
Noise Parameters Dependence. Constant noise circles require a valid input of noise
data.
All circles are either manipulated by entering in a value or by using the slider.
Clicking OK closes the dialog box but keeps the circle plotted while Hide/Show
toggles, displaying the circle on the Smith Chart.

  

 Status Panel
The status panel shows point data for the Smith Chart. You can view Z, Y, and Gamma
(reflection coefficient) values for any point clicked on the Smith Chart. More exact values
can also be entered by selecting the appropriate edit text box and changing the values.
Only the current highlighted node is affected by changes made in the status panel.
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The Lock Source Impedance and Lock Load Impedance check boxes are located above the
status panel. Checking either box makes the corresponding node uneditable.

  

 Importing External Data
The Smith Chart Utility supports three data types for importation: ADS datasets,
Touchstone, and Citifiles. To open the data import dialog box, choose File > Import Data
File from the utility window. Imported data can only be applied to S-parameter data for
the device.
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Browse. Choose a file from one of the available file types to import (Dataset,
Touchstone, Citifile).
Frequency. After importing, the S-parameters can be viewed by scrolling through
their frequencies.
OK. Closes the dialog box after applying the selected S-parameters.
Cancel. Closes the dialog box without applying the selected S-parameters.
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 Smith Chart Network Area
The Smith Chart Network Area is a quick and easy reference for viewing your matching
network and seeing its performance with the given data. A real-time frequency response is
plotted for each change made on the Smith Chart. A network schematic is displayed,
showing a preview before the SmartComponent is built.

  

 Network Response
The Network Response (frequency response) area can plot both the magnitude and phase
of the S-parameters of the drawn network from the Smith Chart.

Start Freq. Starting frequency point (in Hz) from the left edge of the graph. Default is
0 Hz.
Stop Freq. Stopping frequency point (in Hz) at the right edge of the graph. Default is
twice the Smith Chart frequency.
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Max. Maximum value at the top edge of the graph. Default is 1 for magnitude
response and 180 for phase response.
Min. Minimum value at bottom edge of the graph. Default is 0 for magnitude
response and -180 for phase response.
Type. Chooses plot type, either magnitude or phase.
Trace1. Chooses which S-parameter to plot in blue.
Trace2. Chooses which S-parameter to plot in red.
Reset. Resets the graph to default values.
The view in the frequency response can be changed by either replacing the edge
values with values you want or by clicking and dragging a box inside the graph area.

  

 Network Schematic
The Network Schematic area displays a preview of what the SmartComponent looks like
after building the circuit. Also, in this area component parameter values can be changed
or components can be deleted from the network.

Delete Selected Component. Deletes the selected component from the schematic and
removes its corresponding trail from the Smith Chart area.
Set Defaults. Choose default values for Q, loss, and characteristic impedance.
Zo. The characteristic impedance of the microstrip elements (shorted stub, series
stub, and length of line).
Value. The component's value (e.g., Ohms, Farads, etc.).
Loss. Displays either a component's loss in dB/m or in Q.
Any changes made to the schematic area are reflected on the drawing in the Smith
Chart area (see Changes in Component Parameters Reflect on Chart).
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