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 Computing Radiation Patterns
This section describes how to calculate the radiation fields. It also provides general
information about the antenna characteristics that can be derived based on the radiation
fields.

Note
In the Momentum RF mode, radiation patterns, and antenna characteristics are not available.

 

 About Radiation Patterns

After calculating currents on the circuit, you can compute the electromagnetic fields. They
can be expressed in the spherical coordinate system attached to your circuit. The electric
and magnetic fields contain terms that vary as 1/r, and 1/r2. It can be shown that the
terms that vary as 1/r 2, and 1/r 3 are associated with the energy storage around the
circuit. They are called the reactive field or near-field components. The terms having a 1/r
dependence become dominant at large distances and represent the power radiated by the
circuit. These terms are called far field components (Eff, Hff).  

In a layout, there is a fixed coordinate system such that the monitor screen lies in the XY-
plane. The X-axis is horizontal, the Y-axis is vertical, and the Z-axis is normal to the
screen.

Note
 In the direction parallel to the substrate (theta = 90 degrees), parallel plate modes or surface wave
modes, that vary as 1/sqrt(r), are also present. Although the modes dominate in this direction, they are
not considered to be part of the far-fields.

The radiated power is a function of the angular position and the radial distance from the
circuit. The variation of power density with angular position is determined by the type and
design of the circuit. It can be graphically represented as a radiation pattern.

The far-fields can only be computed at those frequencies that were calculated during a
simulation. The far-fields will be computed for a specific frequency and for a specific
excitation state. They will be computed in all directions (theta, phi) in the open half space
above and/or below the circuit. Besides the far-fields, derived radiation pattern quantities
such as gain and axial ratio are computed.

Note
 It is possible to calculate far-fields for some designs that have a top or bottom layer that is not defined as
open space.

 

 About Antenna Characteristics

Based on the far fields, you can derive polarization and other antenna characteristics such
as gain and radiated power.

 

 Polarization

The far-field can be decomposed in several ways. You can work with the basic
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decomposition in ( , ). However, with linear polarized antennas, it is sometimes more
convenient to decompose the far-fields into (Eco, Ecross) which is a decomposition based

on an antenna measurement set-up. For circular polarized antennas, a decomposition into
left and right hand polarized field components (Elhp, Erhp) is most appropriate. Below you

can find how the different components are related to each other.

 is the characteristic impedance of the open half sphere under consideration.

The fields can be normalized with respect to:

 

 Circular Polarization

The following figures displays the left hand and right hand circular polarized field
components are derived.

Using these equation, you can calculate the circular polarization axial ratio (ARcp). The

axial ratio describes how well the antenna is circular polarized. If its amplitude equals one,
the fields are perfectly circularly polarized. It becomes infinite when the fields are linearly
polarized.
 

 Linear Polarization

Below, the equations to decompose the far-fields into a co and cross polarized field are

given (  is the co polarization angle). 

Using these equations, you can calculate  the linear polarization axial ratio (ARlp). This

value illustrates how well the antenna is linearly polarized. It equals to one when perfect
linear polarization is observed and becomes infinite for a perfect circular polarized
antenna.

Note
  Eco is defined as colinear and Ecross implies a component orthogonal to Eco. For a perfect linear
polarized antenna, Ecross is zero and the axial ratio AR=1. If Ecross = Eco you no longer have linear
polarization but circular polarization, resulting in AR = infinity.
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 Radiation Intensity

The radiation intensity in a certain direction, in watts per sterad ian, is given by:

  For a certain direction, the radiation intensity will be maximal and equals:

 

 Radiated Power

  The total power radiated by the antenna, in Watts, is calculated from the free space far-
field E and H components (Eff, Hff) integrating the radiation intensity over the open half

space(s):

Note
The power going into the surface wave is not taken into account in this calculation.

 

 Effective Angle

 This parameter is the solid angle through which all power emanating from the antenna
would flow if the maximum radiation intensity is constant for all angles over the beam
area. It is measured in steradians and is represented by:

 

 Directivity

 Directivity calculates the radiation intensity in a certain direction versus the radiated
power. Directivity is dimensionless and  calculated by using the following equation:

Directivity indicates the best you could get out of the antenna. In reality, there will be loss
mechanisms in the antenna (see Gain) and the feed network is never perfectly matched.
The maximum directivity is given by:

 

 Gain

 Gain looks at radiation intensity in a certain direction versus the power injected into the
antenna. The gain of the antenna is calculated as:
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where Pinj is the real power, in watts, injected into the circuit. The injected power, or net

input power, equals to the (incident - reflected) power at the port(s). Consequently, the
impact of mismatch is not included in this definition of Gain. For a good antenna, a large
part of the injected power is radiated, the rest will be lost. The loss is due to the presence
of lossy materials (either the conductors or the dielectrics used) or gets trapped into the
surface wave that propagates cylindrically along the substrate plane.

The injected power is calculated from the S-parameters and the excitation sources
(Thevenin sources) at the ports as specified by the user. In case of a 1-port antenna, the
excitation source specified by the user doesn't really matter since both Directivity and
Gain are normalized values. For a multi-port antenna, the exact source excitation setup at
each port is really important. That is where the far field excitation utility available from the
knowledge center (search for Far Field Computations from AC/HB Analysis of Antennas
Plus Circuitry) is very relevant.

The maximum gain is given by:

 

 Efficiency

 The efficiency is given by:

 

 Effective Area

   The effective area, in square meters, of the antenna circuit is given by:

 

 Calculating Far Fields

 To calculate far fields:

Choose EM > Post-Processing > Far Field to open the Far Field Computation1.
Setup dialog box.

Select a frequency from the Select Frequency list. The list contains all the2.
frequencies that were calculated during the ongoing simulation. Far fields will be
calculated at the selected frequency.
Select a port from the Available Ports list to apply a steering circuit (based on the3.
Thevenin equivalent) to the port and inject energy into your circuit. You can apply a
steering circuit to any port.

In the Port Excitation fields, enter amplitude (in volts) and phase (in degrees)
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of the voltage of the steering circuit of that is applied to the port.
In the Port Impedance fields, enter the real and imaginary components of the
impedance of the steering circuit that is applied to the port.

Note
You may want to terminate all ports so that the ports that are not used to inject energy into
the circuit do not cause reflections. For these ports, set the Port Excitation voltage to zero,
and set the Port Impedance to the characteristic impedance of the port.

If you want the display tool to open and display results automatically, enable Open4.
display when computation completed.
Click Compute to compute the radiation pattern. After computation, the far-fields5.
and derived antenna parameters will be stored in a dataset with the name you
specified. An f will be appended to the dataset name. The __f indicates that the
dataset contains radiation pattern data. The dataset is stored in the / data directory
of the current workspace.

 

 Planar (Vertical) Cut

For a planar cut, the angle phi ( Cut Angle ), which is relative to the X-axis, is kept
constant. The angle theta, which is relative to the z-axis, is swept to create a planar cut.
Theta is swept from 0 to 360 degrees. This produces a view that is perpendicular to the
circuit layout plane.
 

Note
In layout, there is a fixed coordinate system such that the monitor screen lies in the XYplane. The X-axis
is horizontal, the Y-axis is vertical, and the Z-axis is normal to the screen. To choose which plane is
probed for a radiation pattern, the cut angle must be specified. For example, if the circuit is rotated by 90
degrees, the cut angle must also be changed by 90 degrees if you wish to obtain the same radiation
pattern from one orientation to the next.

  

 

 Conical Cut

For a conical cut, the angle theta, which is relative to the z-axis, is kept constant. Phi,
which is relative to the x-axis, is swept to create a conical cut. Phi is swept from 0 to 360
degrees. This produces a view that is parallel to the circuit layout plane.
 

  

 Viewing Far Fields

 After the far fields computations are performed, data is saved depending on the display
tool. The following types of displays are used:

2D Data Display: all data is stored in a single dataset with the name you specified
with _f.ds appended. The _f indicates that the dataset contains radiation pattern
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data. The dataset is stored in the /data directory of the current workspace.

3D Visualization: the far-fields and derived antenna parameters will be stored in
respectively proj.fff and proj.ant in the mom_dsn/<design_name> directory of your
workspace.

 

 Viewing Far Fields in 3D Visualization

 When 3D Visualization is selected as Visualization Type for viewing the far-field results,
the 3D Visualization Tool is automatically displayed when the computation is finished. Two
windows are displayed, a Geometry window and a Far Field window. The Far Field Window
and associated properties tab is only shown if radiation results are available. The radiation
results are for a single frequency, shown on the properties tab, and using the excitation
state as specified in the Radiation Pattern Control dialog box before computation. A new
Visualization window can be opened when far fields are calculated at another frequency.

Note
The Solution Setup and Plot Properties tabs have no association with the Far Field window. They apply
to the surface current visualization on the Geometry window.

Select the Plot type:

E = sqrt(mag(E Theta)2 + mag(E Phi)2)
E Theta
E Phi
E Left
E Right
E Co
E Cross
Circular Axial Ratio
Linear Axial Ratio

If you want the data normalized to a value of one, enable Normalize. For Circular and
Linear Axial Ratio choices, set the Minimum dB. Also set the Polarization Angle for E
Co, E Cross, and Linear Axial Ratio. By default, a logarithmic scale is used to display the
plot. If you want to use a linear scale, disable Log scale. Set the minimum magnitude
that you want to display, in dB.

 Click Antenna Parameters to view gain, directivity, radiated power, maximum E-field,
and direction of maximum radiation.
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The data is based on the frequency and excitation state as specified in the Radiation
Pattern Control dialog. The parameters include:

Radiated power, in watts
Effective angle, in degrees
Directivity, in dB
Gain, in dB
Maximum radiation intensity, in watts per steradian
Direction of maximum radiation intensity, theta and phi, both in degrees
E_theta, magnitude in Volt and phase in degrees in direction of maximum radiation
E_phi, magnitude in Volt and phase in degrees in direction of maximum radiation
E_x, magnitude in Volt and phase in degrees in direction of maximum radiation
E_y, magnitude in Volt and phase in degrees in direction of maximum radiation
E_z, magnitude in Volt and phase in degrees in direction of maximum radiation

 Displaying Far Field Cut

In the Visualization window, click the Far Field Cut tab to view far field cut in data
display. Select the Enable option to specify Theta and Phi values, as shown in the
following figure:

To view data display, click Display Cut in Data Display, as shown in the following figure:
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 Exporting Far Field Data

 ASCII file with 3D Far Field Data

If 3D Visualization is selected in the Radiation Pattern dialog, the normalized electric  far-
field components for the complete hemisphere are saved in ASCII format in the file <
workspace_dir>/mom_dsn/<design_name>/proj.fff. The data is saved in the following
format:

#Frequency <f> GHz           // loop over frequencies

#Excitation # <i>            // loop over excitation states

#----------------

#Begin cut                   // loop over phi

<theta_0> <phi_0> <real(E_theta)> <imag(E_theta)> <real(E_phi)> <imag(E_phi)>  // loop over

<theta> for <phi_0>

<theta_1> <phi_0> <real(E_theta)> <imag(E_theta)> <real(E_phi)> <imag(E_phi)>

:

<theta_n> <phi_0> <real(E_theta)> <imag(E_theta)> <real(E_phi)> <imag(E_phi)>

#End cut

#Begin cut

<theta_0> <phi_1> <real(E_theta)> <imag(E_theta)> <real(E_phi)> <imag(E_phi)>  // loop over

<theta> for <phi_1>

<theta_1> <phi_1> <real(E_theta)> <imag(E_theta)> <real(E_phi)> <imag(E_phi)>

:

<theta_n> <phi_1> <real(E_theta)> <imag(E_theta)> <real(E_phi)> <imag(E_phi)>

#End cut

:

:

#Begin cut

<theta_0> <phi_n> <real(E_theta)> <imag(E_theta)> <real(E_phi)> <imag(E_phi)>  // loop over

<theta> for <phi_n>

<theta_1> <phi_n> <real(E_theta)> <imag(E_theta)> <real(E_phi)> <imag(E_phi)>

:

<theta_n> <phi_n> <real(E_theta)> <imag(E_theta)> <real(E_phi)> <imag(E_phi)>

#End cut

In the proj.fff file, E_theta and E_phi represent the theta and phi components,
respectively, of the far-field values of the electric field. Note that the fields are described
in the spherical co-ordinate system (r, theta, phi) and are normalized. The normalization
constant for the fields can be derived from the values found in the proj.ant file and
equals:

 ASCII file with Antenna Characteristics

The proj.ant file, stored in the same directory, contains the antenna characteristics. The
data is saved in the following format:

Excitation <i>                  // For Momentum, a single excitation state is specified in the

Radiation Pattern Control dialog, consequently <i> is always 1.

Frequency <f> GHz               // For Momentum, a single frequency is selected in the

Radiation Pattern Control dialog

Maximum radiation intensity <U> // in Watts/steradian

Angle of U_max <theta> <phi>    // both in deg

E_theta_max <mag(E_theta_max)> ; E_phi_max <mag(E_phi_max)>

E_theta_max <real(E_theta_max)> <imag(E_theta_max)>

E_phi_max <real(E_phi_max)> <imag(E_phi_max)>

Ex_max <real(Ex_max)> <imag(Ex_max)>

Ey_max <real(Ey_max)> <imag(Ey_max)>

Ez_max <real(Ez_max)> <imag(Ez_max)>

Power radiated <i> <prad>       // in Watts

Effective angle <eff_angle_st> steradians <eff_angle_deg> degrees

Directivity <dir> dB            // in dB (10*log10)

Gain <gain> dB                  // in dB (10*log10)

The maximum electric field components (E_theta_max, E_phi_max, etc.) are those found
at the angular position where the radiation intensity is maximal. They are all in volts.
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 Dataset file with 2D Cut Far Field Data

 Specific information about the data available in the far-field dataset is given in this
section.

 

Variable Description

 THETA The swept parameter of a planar cut. When THETA is swept, PHI is at a fixed
angle specified in the Cut Angle field and is not returned to the dataset.

 PHI The swept parameter of a conical cut. When PHI is swept, THETA is at a fixed
angle specified in the Cut Angle field and is not returned to the dataset.

 Etheta and Ephi Absolute field strength (in volts) of the theta and phi electric far-field
components.

 Htheta and Hphi Absolute field strength (in amperes) of the theta and phi magnetic far-field
components.

 Elhp and Erhp Normalized field strength of respectively left-hand and right-hand circular
polarized electric far-field component.

 ARcp Axial ratio, derived from left-hand and right-hand circular polarized far-field
components.

 Eco and Ecross Normalized field strength of co and cross polarized electric far-field components.

 ARlp Linear polarization axial ratio, derived from co and cross polarized far-field
components.

 Gain, Directivity,
Efficiency, EffectiveArea

Gain, Directivity, Efficiency (in percent), Effective area (in m2).

 Power Radiation intensity (in watts/steradian).

Note
The normalized far-field components (Elhp, Erhp, Eco, and Ecross) are normalized with respect to

.
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 Performing SI/PI Analysis
The SI/PI Analyzer feature assists in setting up SI or PI EM and circuit simulations. This
feature consists of two parts:

Setup wizard: The setup wizard guides you through the process of creating a new cell
that contains only selected nets (physical interconnects) to be analyzed. The output
of the setup wizard is a cell that is ready for EM analysis.

Analysis guide: The analysis guide assists in setting up typical SI or PI circuit
simulation testbench. In this release, you can create Power Distribution Network
(PDN) analysis. The output of the analysis guide is a circuit schematic, ready to be
simulated, a data display template that captures relevant output figures. In addition,
the analysis guide supports Momentum current visualization based on the results.

This section provides information about the following topics:

Setting up SI and PI Analyzer (em)
Using SI and PI Analyzer (em)
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 Setting up SI/PI Analyzer
The SI/PI Analyzer Setup wizard guides you through the process of creating a new
hierarchical cell that contains only selected nets (physical interconnects) and components
to be analyzed. All the objects that were not selected are removed from the output cell
created by the wizard. You can use the hierarchical cell for circuit and EM simulations. The
structures to be modeled by the Momentum EM simulator are grouped in a sub cell. Any
components mounted on the interconnects are in the top level cell. The following figure
displays the design of a hierarchical cell:

This cell will be used to illustrate how the power distribution network can be setup for
analysis.

 Using the SI/PI Analyzer Setup

Open the layout view of the cell you want to analyze.1.

Note
The example workspace used in this section is present at the following location:
$EESOFHOME\examples\Momentum\HighSpeedDigital\PDN_example_wrk.7zap.

Enable Physical Connectivity Engine (PCE).2.
Select Tools > SI/PI Analyzer > Setup to open the Setup wizard.3.
A message box appears stating that SI/PI Analyzer Setup will modify the current cell4.
and its descendants, as shown in the following figure:

#* Click Yes to work in the
existing cell. Note that the cell is modified, for example unselected objects are
removed from the cell.

Click No to create a new cell. A copy of the current cell is saved under a new
name and values in the current cell are not changed, as shown in the following
figure:

The Introduction screen is displayed that outlines the steps in the wizard, as shown5.
in the following figure:
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Click Next to display the Flatten the Design Hierarchy screen.6.
Specify the options for flattening the design hierarchy (applies to cells with7.
components only). For more information, see Flattening the Design Hierarchy.
Click Next to display the Nets screen.8.
Select the nets to modeled by EM. For more information, see Selecting Nets.9.
Click Next to display the Pins screen.10.
Inspect the pins connected to the selected nets. For more information, see Analyzing11.
Pins.
Click Next to display the Components screen.12.
Inspect the components connecting the selected nets (applies to cells with13.
components only). For more information, see Inspecting Components.
Click Next to display the EM Simulation Setup screen.14.
Specify the EM simulation setup. For more information, see Specifying EM Simulation15.
Setup.
Click Next to display the Summary screen.16.
The Summary screen provides information about the library, cell, EM setup, and pins,17.
as shown in the following figure:
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Click Finish to create the output cells.18.

A message box appears stating the completion of the cells:19.

Click OK to open the SI/PI Analyzer analysis guide.20.
This creates two new cells as displayed in the following figure:21.

The top level PDN_VDD_VSS cell has a schematic, layout, and symbol view. This cell22.
contains all component instances and an instance of the sub cell that bundles
everything modeled by EM:
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The sub level cell PDN_VDD_VSS_em cell has a layout, symbol, emSetup, and emModel
view. Everything is properly connected, the schematics used named connections, and are
ready to be used in circuit and EM simulations.

 Flattening the Design Hierarchy

Using the Setup wizard, the Flatten the Design Hierarchy screen is displayed only when
the instances of other cells are found in the current cell. You need to select all the
instances that must be modeled by the EM simulation. Do not select cells with other
components, such as schematic model cells SMDs. You must provide models for these
cells in a schematic view of the component cells.

Warning
SI/PI setup wizard adds a top level pin per inst pins of the components that you do not select here at the
same location or layer of the inst pins so that other models such as schematic model can be connected
later. Make sure that the layer of such component pins are correctly mapped in the substrate. Otherwise,
having such top level pins are causing EM simulation errors later as these pins are not mapped in the
substrate layers.

In the following figure, the PDN_signal cell contains a power net, a ground net, and two
signal nets from a differential trace. This cell is modeled by EM. The other cells are
instances of surface mounted device (SMD) components.

Click Commit to flatten the selected cells. This step is irreversible and modifies the
current cell for the first time.

 Selecting Nets



EM Simulation

20

In the Nets screen, you need to specify the nets you want to analyze. The nets, extracted
by the Physical Connectivity Engine, are shown in a table. Each net has a type and a
name. The default net type is Signal. Other choices are Power or Ground. The net type
facilitates sorting or filtering the nets. The default PCE net names start with N__. Double-
click the net name to specify the required name. The new name is stored in the cell and
automatically updated in the table. Multiple PCE nets given the same name will be
considered as one net in the SI/PI analyzer. The following figure displays the Nets screen
in the SI/ PI Analyzer Setup wizard.

All selected nets are saved in the output cell. However, the nets that are not selected are
excluded from the analysis. In the Nets screen, you can perform the following tasks:

Setting the Selection From Layout: You can select all nets in the table based on
the selection made in the layout by clicking Set the Selection From Layout. The
layout is scanned for all selected shapes and pins. The corresponding net is selected
in the table.

Filtering: You can display the required nets in table based on type or name from the
Filter list. Regular expressions are also supported while filtering the nets.

Selecting Nets: You can hide the nets that are not selected int he Nets screen by
selecting the Hide unchecked Nets option. You can also highlight selected nets in
the layout window by selecting the Highlight selected nets in layout option.

Renaming the nets, setting the appropriate net type and removing selection from the
signal nets generates the following screen.
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 Analyzing Pins

The Pins screen enables you to analyze the pins that are connected to the selected nets,
as shown in the following figure:

In the Pins screen, you can perform the following tasks:

Grouping pins automatically: You can select pins in the table and create groups
automatically for selected pins by selecting Auto Group. Pins on a same net and a
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same layer will become a group.

Removing pins from a group: You can remove grouped pins by selecting the
required group and click UnGroup.

Grouping Pins: You can select the required pins and create a group by selecting
Group. Grouping is possible for pins on a same net only.

Filtering: You can display the required nets in table based on type or name from the
Filter list. Regular expressions are also supported while filtering the nets.

Selecting Nets: You can hide the nets that are not selected int he Nets screen by
selecting the Hide unchecked Nets option. You can also highlight selected nets in
the layout window by selecting the Highlight selected nets in layout option.

 Inspecting Components

The Inspecting Components screen displays all the components connecting the selected
nets. Components with pins on nets that are not selected are not included in the output
cells.

 Specifying EM Simulation Setup

The EM Simulation Setup screen allows you to specify the EM Setup used for generating
an EM model. You can select the required view from the EM Setup list box. In the
absence of existing views, a new EM Setup view named emSetup is created.
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Click Edit to open the EM Setup window to define the required EM simulation settings.

In the EM Simulation Setup screen, you can define frequency by opening the EM Setup
window. You can also override or extend the frequency plan specified in the EM Setup
window by using the following options:

Override frequency plan of EM Setup
Extend frequency plan of EM Setup

In the EM Simulation Setup screen, specify a fundamental frequency and a number of
harmonics and click Set Frequency Plan. You can also specify additional frequencies by
double-clicking <New Frequency >.
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 Using SI and PI Analyzer
Using the SI/PI analyzer, you can perform the following types of analysis:

Power Distribution Network(PDN) Analysis: The PDN analysis enables you to:
Extract PDN impedance.
Visualize current distribution with SMD components (if any) in 3D Visualizer.

Signal Path Analysis: The signal path analysis enables you to extract signal path
characteristics, such as R, L, G, and C characteristic impedance.

Before performing the analysis, set up SI/PI Analyzer. For more information, see Setting
up SI and PI Analyzer (em).

 Opening SI/PI Analyzer

To open the SI/PI Analyzer window:

Open the layout view of the cell you want to analyze.1.
Enable Physical Connectivity Engine (PCE).2.
Select Tools > SI/PI Analyzer > Analysis. The SI/PI Analyzer window is3.
displayed, as shown in the following figure:

The SI/PI Analyzer window displays a list of analysis that you have created. In this
window:

A grey ( ) icon indicates that the analysis is not performed yet or finished with an
error.
A green ( ) icon indicates that the analysis is finished successfully.

 Defining Power Distribution Network Analysis

To define a PDN analysis, select Analysis > New analysis > PDN impedance in the
SI/PI Analyzer window. You can also double-click the item displayed as <new...> to
create an analysis for PDN. The Power Distribution Network Extraction window is
displayed, as shown in the following figure:
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In the Power Distribution Network Extraction window, you can specify:

On or off capability of calculating currents flowing in the PDN including SMDs (if any).
Models for Voltage Regulator Module (VRM) and Load.
Connections between VRM/Load models and DUT.

 Editing the PDN Analysis Setup

Using the Power Distribution Network Extraction window, you can perform the following
tasks:

Calculating current distribution: You can calculate current distribution by
selecting the Calculate current distribution check box.

Selecting a VRM and Load: In the VRM or Load frame, you can:
Select a source or load model: Click Browse to select a source or load model to
use. Note that only frequency domain model can be used.
Restore models: Click Default to restore a default model.
Add a new source or load: Click Add to include a new source or load into the
analysis.
Delete a source or load: Click Remove to delete a source or load from the
analysis.

Measuring Impedance: To calculate the impedance of a power distribution
network, you need to monitor the current that flows a load and voltage between
power pin and ground pin. You need to provide the following values in Impedance
Measurement:

Load value: Specify a load model which you want to make measurement of your
impedance in the Load field.
Power pin value: Specify a pin number which should connect to the power nets
in the Power pin field.
Ground pin value: Specify a pin number which should connect to the ground
nets in the Ground pin field.

Specifying Pin connections: You can specify the following connections between
your model that is being analyzed and a source or load in Pin Connections:

You can terminate unconnected pins in a model by using the icons in the
Termination section. You can also drag and drop unconnected pins to end a
connection.
You can view instances of source/load and termination are shown with these
pins in the top pane.
You can view unconnected pins of your model that are analyzed in the bottom
pane.
You can generate a connection between pins of your model and source/loads by
using the drag and drop operation.

 Creating a Power Distribution Network Analysis

To analyze a PDN:

Select Analysis > New analysis > PDN impedance or double-click the item1.
displayed as <new...> to open the Power Distribution Network Extraction
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window.
Select the Calculate current distribution check box.2.
Click Browse to select a source model.3.
Click Browse to select a load model.4.
In Impedance Measurement, specify the following values:5.

Select a load model from the Load drop-down list.
Select a pin number from the Power pin drop-down list.
Select a ground pin number from the Ground pin drop-down list.

In Pin Connections, generate a connection between pins of your model and6.
source/loads by dragging pins from unconnected pins and drop on the required pin in
the upper pane.
Click OK to create a test bench schematic for the PDN analysis.7.

 Defining Signal Path Analysis

To define a Signal Path analysis, select Analysis > New analysis > Signal Path
characteristics in the SI/PI Analyzer window. You can also double-click the item
displayed as <new...> in Signal Path to create an analysis for signal path. The Signal
Path Extraction window is displayed, as shown in the following figure:

The Signal Path Extraction window allows you to specify the:

Number of paths you want to analyze.
Connections between S-parameter terms and your DUT.

 Editing the Signal Path Analysis

You can perform the following tasks for the Signal Path Extraction window:

Specifying Lines: You can specify number of lines (paths) to analyze. Click Add or
Remove to increase or decrease the number of lines, respectively.
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Specifying pin connections: You can specify the following connections between
your model that is being analyzed and S-parameter terms in Pin Connections:

Terminate unconnected pins in a model by using the icons in the Termination
section. You can also drag and drop unconnected pins to end a connection.
View instances of S-parameter terms and termination are shown with these pins
in the top pane.
View unconnected pins of your model that are analyzed in the bottom pane.
Generate a connection between pins of your model and S-parameter terms by
using the drag and drop operation.

 Creating a Signal Path Analysis

To analyze a signal path:

Select Analysis > New analysis > Signal Path or double-click the item displayed1.
as <new...> in the SI/PI Analyzer window to create an analysis for signal path:

Type the required number of lines or click Add in the Lines frame.2.
In Pin Connections, generate a connection between pins of your model and3.
source/loads by dragging pins from the unconnected pins section and drop on the
required pin in the upper pane.
Click OK to create test bench schematic for the PDN analysis.4.

 Performing Analysis

After creating an analysis, you can view it in the Analysis tree. By default, an analysis
appears with a gray icon  next to the analysis name, which means that the analysis has
not been performed yet. If the analysis is successful, this icon is green  in color.
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To perform an analysis:

Select the required analysis for performing simulations.1.
Choose Simulation > Run or click the Analysis button to initiate simulations.2.
Circuit simulations including EM co-simulation are performed sequentially.

 Viewing results

After successfully completing your analysis, you can view the analysis result in the Data
Display window. You can also view the current distribution in the 3D Visualizer, if current
distribution calculation is specified. However, this feature is applicable for a PDN analysis
only.

To view analysis results in the Data Display window:

Select an analysis with green icon in the SI/PI Analyzer window.1.

Click Data Display ( ) to display results in the Data Display window. The2.
following figure displays results of a PDN analysis:

The following figure displays results of a signal path analysis:

To view the current distribution in the 3D Visualizer (PDN analysis only):

Select a PDN analysis with green icon.1.
Select Show Current Distribution menu in the context menu.2.
In the 3D visualizer, select the Solution Setup tab.3.
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Select Extracted Excitation in the top drop-down combo box.4.
Select a state in the States list.5.
Select a frequency that you want to display.6.
The following figure displays an analysis in 3D Visualizer:7.

 Example

The following example describes how to optimize decoupling capacitor values. It also
describes how to view the current distribution after the optimization.

Create a PDN analysis and setup it correctly.1.
Generate a test bench schematic from the above analysis.2.
Save the test bench schematic with a different name by selecting File > Save as in3.
the Schematic window.
Place the optimizer and goals on the schematic and specify the settings accordingly.4.
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Setup parameters of decoupling capacitor for optimization. Select Simulate >5.
Simulation Variable Setup to open the Simulation Variables Setup dialog box,
as shown in the following figure:

Click the Optimize icon to optimize the decoupling capacitors and update optimized6.
values to the schematic when optimization is finished.

Open the SI/PI analyzer and copy the original PDN analysis with a different name and7.
edit it to make sure Calculate current distribution is selected.
Perform a simulation for the new PDN analysis. This PDN analysis is done with the8.
optimized decoupling capacitor values.
Select Show Current Distribution to show current distribution with optimized9.
decoupling capacitors.
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 EM Simulation Overview
ADS 2011 provides the EM simulation tools that you need for designing and evaluating
modern communications systems products. It provides a unified interface for Momentum
and FEM simulators. These are electromagnetic simulators that compute S-parameters for
general planar circuits, including microstrip, slotline, stripline, coplanar waveguide, and
other topologies.

The new use model for EM simulations provides the following advantages:

Single EM Setup window that replaces the tasks performed by multiple dialog boxes.
Unified use model for Momentum, Momentum RF, and FEM.
Job manager provides improved ease-of-use for monitoring multiple local, remote,
queued, or distributed simulations.
EM models are fully compatible with the new dynamic model selection.
EM Simulation toolbar provides shortcuts to frequently used menus.
Generates reusable EM setups that offer the following benefits:

Creates easy to save and restore EM setups.
Reduces the efforts to define EM settings.
Simplifies the simulation process.
Ensures easier, faster, and accessible EM simulations.

In the earlier versions, you had to open multiple dialog boxes to configure settings for an
EM simulation. However, with ADS 2011, you can use the EM Setup window to specify
multiple settings by using a single interface. The following figure highlights this difference.

 Getting Started with an EM Simulation

ADS 2011 includes a new EM menu that enables you to perform various tasks such as
simulating a circuit, configuring a simulation, and adding a box or waveguide. Using the
EM menu, you can perform the following tasks:

Performing simulations: Choose EM> Simulate to perform an EM simulation. You
can also press F7 to start the simulation process.

Configuring a Simulation Setup: Choose EM> Simulation Setup... to open the
EM Setup window. You can also press F6 to open the EM Setup window. The EM
Setup window enables you to define frequency and output plan, configure engine
options, generate ports and EM model. For more information, see Setting up EM
Simulations (em).

Modifying the Output Dataset name: Choose EM> Choose Output Dataset to
change the name of the dataset that is used to store the EM S-Parameter results.

Stopping a simulation: To end a simulation before it is finished, choose EM> Stop
and Release Simulator. You can use this option option to release your simulation
license.

Clearing the Momentum Mesh: Choose EM> Clear the Momentum Mesh to
remove the momentum mesh.

Viewing the recent simulations: You can view the latest EM simulations from the
current EM Setup by selecting the EM> Show Most Recent option.

Creating/editing Layout components: You can create, edit, or select a parameter
by using the Layout Component Parameters dialog box. Select EM>
Components> Parameters to open this dialog box.

Viewing the results: You can view and analyze, S-parameters, currents, far-fields,
antenna parameters, and transmission line data by choosing EM> Post-Processing
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> Visualization. For more information, refer to Visualizing 3D View before EM
Simulations (em).

Adding or deleting a box or waveguide: You can specify a box or waveguide
around the substrate by selecting EM> Box - Waveguide. You can select the
required options for adding or deleting a box or waveguide. For more information,
refer to Adding Boxes, Waveguides, and Symmetry Planes (em).

Defining radiation patterns: You can compute the electromagnetic fields by
choosing EM> Post-Processing> Far Field. For more information, refer to
Computing Radiation Patterns (em).

Adding and deleting FEM symmetry planes: You can add an FEM symmetry plane
by selecting EM> FEM Symmetry Plane> Add Symmetry Plane.For more
information, refer to Adding Boxes, Waveguides, and Symmetry Planes (em).

 Related Videos

You might find the following online video useful in understanding the topics covered on
this page:

 ADS 2011 Momentum and FEM User Interface

 Process for Simulating a Design

Perform the following process for creating and simulating a design:

Creating a physical design: You can start with the physical dimensions of a planar
design, such as a patch antenna or the traces on a multilayer printed circuit board.
There are three ways to enter a design into Advanced Design System:

Convert a schematic into a physical layout.
Draw the design using Layout.
Import a layout from another simulator or design system. ADS can import files
in various types of formats.
For information on converting schematics or drawing in Layout, refer the
Schematic Capture and Layout documentation. For information on importing
designs, refer to the Importing and Exporting Designs documentation.

Selecting an EM simulator: From the EM Setup dialog box, you can select the
required simulator: Momentum Microwave, Momentum RF, and FEM. For more
information, see Selecting an EM Simulator (em).

Defining the substrate: A substrate is the media where a circuit resides. Using the
EM Setup dialog box, you can assign predefined substrates. For more information,
refer to Assigning Substrate (em).

Assigning port properties: Ports enable you to inject energy into a circuit, which is
necessary in order to analyze the behavior of your circuit. You apply ports to a circuit
when you create the circuit, and then assign port properties. There are several
different types of ports that you can use in your circuit, depending on your
application. For more information, refer to Generating Ports (em).

Defining the Frequency and Output Plan: You can set up multiple frequency
plans for a simulation. For each plan, a solution can be found for a single frequency
point or over a frequency range. You can define the output plans. For more
information, refer to Defining the Frequency and Output Plan (em).

Setting Simulation Options: You set up a simulation by specifying the parameters
of preprocessor, substrates, and mesh. You can specify a variety of mesh parameters
to customize the mesh to your design. For more information, refer to Defining
Simulation Options (em).

Simulating the circuit: After completing the setup, you can run an EM simulation.
Choose the Simulate option to perform an EM simulation. You can also press F7 to
start the simulation process.

Note
Specify only valid data in the EM Setup window. If you copy the EM Setup file from one library to another
library, all the information is not copied. For example, you must define the substrate in the new library.
Similarly, if a layout does not have the pins referenced in the original layout, the pins are not be visible
and all the ports are invalid.

 

http://youtu.be/DN5wBhviSBo
http://youtu.be/DN5wBhviSBo
http://youtu.be/DN5wBhviSBo
http://youtu.be/DN5wBhviSBo
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 Setting up EM Simulations
ADS 2011 simplifies the overall process of setting up EM simulations. The new EM usability
provides a user-friendly EM Setup window for defining Momentum and FEM simulations.
Using the EM Setup window, you can specify the settings for your EM simulation from a
single interface. You can assign substrates, configure ports, define frequency and output
plans, specify local, remote or distributed setup options, and customize the EM data name
generated during a simulation.

This section provides the following information about setting up EM simulations:

Overview (em)
Viewing Layout Information (em)
Assigning Substrate (em)
Generating Ports (em)
Defining the Frequency and Output Plan (em)
Defining Simulation Options (em)

Overriding Substrate Definition for Momentum (em)
Defining Preprocessor Settings (em)
Defining Mesh Settings for Momentum (em)
Defining Mesh Settings for FEM (em)
Defining Expert Options for Momentum (em)
Defining Simulation Settings (em)

Specifying Simulation Resources (em)
Generating EM Model and Symbol (em)
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 Overview
ADS 2011 provides an improved EM Simulation usability. It is now easier to create and
use EM models for arbitrary parts of a layout by designers who are not EM experts. ADS
2011 provides a new EM GUI, EM Setup window, which provides a single interface to
control all EM setup related features. It provides a:

Unified EM interface to reduce maintenance efforts.
User-friendly interface for defining Momentum and FEM simulations.

 Using the EM Setup Window

To open the EM Setup window, choose EM > Simulation Setup. The EM Setup window
enables you to define simulator options such as substrate, ports, and frequency plan. The
following figure displays an EM Setup window:

The following sections describe the EM Setup window:

Specifying Simulation Settings
Selecting a Simulator
Viewing Setup Overview
Performing Tasks
Simulating a Design

 Specifying Simulation Settings

In the EM Setup window, options required for specifying simulation settings are listed in
the left pane. You can select the required option to open the settings in the right pane of
the EM Setup window. You can specify settings for the following options:

Layout: You can view information about the workspace, library, cell, and view by
selecting Layout. For more information, refer Viewing Layout Information (em).

Substrate: You can open a predefined substrate file from ADS by selecting
Substrate. For more information, refer Assigning Substrate (em).

Ports: You can refresh layout pins information, create, delete, and resequence ports,
and search the required S-parameter ports or layout pins by selecting Ports. For
more information, refer to Generating Ports (em).

Frequency Plan: You can add or remove frequency plans for your EM simulations by
selecting Frequency Plan. For more information, see Defining the Frequency and
Output Plan (em).

Output Plan: You can specify the data display settings for your EM simulations by
selecting Output Plan. For more information, see Defining the Frequency and Output
Plan (em).
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Options: You can define the preprocessor, mesh, simulation, and expert settings by
selecting Options. For more information, see Defining Simulation Options (em).

Resources: You can specify the local, remote, and third party settings by selecting
Resources. For more information, see Specifying Simulation Resources (em)

Model/Symbol: You can generate an EM model and symbol by selecting
Model/Symbol. For more information, see Generating EM Model and Symbol (em).

Notes: You can add comments to your EM Setup window by selecting Notes.

 Selecting a Simulator

In the EM setup window, you can select one of the following types of EM simulators:

Momentum Microwave
Momentum RF
FEM

For more information, see Selecting an EM Simulator.

 Viewing Setup Overview

You can view a summary of the EM simulation options in the Setup Overview section of
the EM Setup window.

 Performing Tasks

You can perform the following tasks by using the menus and toolbar options present in the
EM Setup window:

 

 Saving Simulation Settings

Click Save ( ) in the EM Setup window to save the settings specified for your EM
simulation. You can also use the following commands from the File menu for saving an EM
setup:

The Save command enables you to save changes to an existing design. If you choose
Save in an untitled window, the Save Design As dialog box appears.
The Save As command enables you to save an existing EM setup with a new name.
You can change the Library name, cell name, and view name. Type represents the
type of cell to identify whether it is a EM setup, schematic, layout or symbol view.
You cannot change the cell Type.

The Save a Copy As command enables you to save a copy of an existing EM setup
with a new cell name in new library and in new view. Select File > Save a Copy As
to provide the required library name, cell name, and view.

Note
To reuse the saved EM setup, select File > Open > EM Setup View in the ADS Main window. Select the
required EM Setup view in the Open Cell View dialog box. You can also open an existing EM setup by using
the EM toolbar.
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 Importing Files

To import another file in the EM Setup window:

Choose File > Import or click the Import icon ( ) to open the Import EM1.
Setup dialog box, as shown in the following figure:

Specify the file name or click Browse to open the required file. For more information,2.
see Opening an EM Setup View.
Select the required sections from the Select sections list. You can also select all the3.
sections by clicking Check all.
Click Import.4.

 Opening an EM Setup View

To open an EM setup view, perform the following the steps:

Start ADS and open an existing workspace.1.
From the ADS Main window, choose File > Open > EM Setup View to open the2.
Specify EM Cell View dialog box.
Select EM Setup View from the Type drop-down list.3.

If you want to open a built-in ADS design (read-only), check the Show ADS4.
Libraries checkbox to display the list of all libraries under Library.
Under Library, select the Library name where the view exists.5.
Under Cell, select the cell name.6.
Under View, select the required EM setup view name.7.
Click OK to open the selected EM setup view.8.

 Opening the 3D Preview window

Choose Tools > 3D EM Preview or click the 3D EM Preview icon ( ) to preview your
simulation.
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 Opening the Layout window

Choose Tools > Open Layout Window or click the Open Layout Window icon ( ) to
display a layout window.

 Simulating a Design

You can save the current settings and start the simulation process by clicking the

Simulate button or click ( ) to simulate an EM simulation. You can also press F7 to
start the EM simulation. If you have specified invalid EM settings, an error message is
displayed.

 Selecting an EM Simulator

You can use the following types of EM simulators:

Momentum Microwave
Momentum RF
FEM

The following sections describe these simulators.

 Momentum Simulator Basics

Momentum provides the simulation tools you need to evaluate and design modern
communications systems products. Momentum is an electromagnetic simulator that
computes S-parameters for general planar circuits, including microstrip, slotline, stripline,
coplanar waveguide, and other topologies. Vias and airbridges connect topologies between
layers, so you can simulate multilayer RF/microwave printed circuit boards, hybrids,
multichip modules, and integrated circuits. Momentum gives you a complete tool set to
predict the performance of high-frequency circuit boards, antennas, and ICs.

Momentum provides two types of simulation modes: Momentum Microwave and
Momentum RF. The Microwave mode uses full-wave formulation, while the RF mode uses
a quasi-static formulation. In the quasi-static formulation, Momentum RF provides
accurate electromagnetic simulation performance at RF frequencies. At higher frequencies,
as radiation effects increase, the accuracy of the Momentum RF models declines smoothly
with increased frequency. Momentum RF addresses the need for faster, more stable
simulations down to DC, while conserving computer resources.

Momentum enables you to:

Simulate when a circuit model range is exceeded or the model does not exist.
Identify parasitic coupling between components.
Perform analysis and verification of design automation of circuit performance.
Visualize current flow and three dimensional displays of far-field radiation.

 Selecting the Momentum Simulation Mode

From the EM Setup dialog box, you can choose the required simulation mode. In each
case, the menu label in the EM Setup dialog box changes to the current mode. You can
choose a simulation mode based on your application. Each mode has its advantages. In
addition to specifically RF applications, Momentum RF can simulate microwave circuits.
The following graph identifies which mode is best suited for various applications.

Some applications can benefit from using either mode depending on your requirements.
As your requirements change, you can quickly switch modes to simulate the same physical
design. As an example, you may want to begin simulating microwave applications using
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Momentum RF for quick, initial design and optimization iterations, then switch to
Momentum Microwave to include radiation effects for final design and optimization.
Momentum RF is an efficient mode for a circuit that is electrically small, geometrically
complex, and does not radiate.

 Locating Examples

Examples of designs that are simulated using Momentum and Momentum RF can be found
in the Examples directory.
To open an example:

From the ADS Main window, choose File > Open > Example.1.
In the Choose an Archived Example to open dialog box, select Momentum.2.
Select the required example directory.3.
Click OK.4.

 FEM Simulator Basics

The FEM simulator provides a complete solution for electromagnetic simulation of
arbitrarily-shaped, passive three-dimensional structures. An FEM simulator provides the
best price/performance, 3D EM simulator on the market, with a full 3D electromagnetic
field solver, and fully automated meshing and convergence capabilities for modeling
arbitrary 3D shapes such as bond wires and finite dielectric substrates. Along with
Momentum, FEM provides RF and microwave engineers access to some of the most
comprehensive EM simulation tools in the industry.

By combining fast solution times, efficient memory usage, and powerful display
capabilities, FEM Simulator for ADS delivers leading price/performance solution to complex
high-frequency problems. FEM Simulator for ADS users need very little background in
electromagnetic field theory in order to operate and achieve accurate, and meaningful
solutions.

 Major Features and Benefits

The FEM simulator provides:

Conductors, resistors, isotropic dielectrics, isotropic linear magnetic material
modeling that allow a wide range of application coverage.
An unlimited number of ports, which enables simulating multi-I/O design applications
such as packages.
Electric and magnetic fields modeling, enabling visualization of EM fields in a design.
Absorbing boundary condition (free space), enabling antenna modeling.
Full-wave, EM-accuracy for first-pass design success.
Antenna parameters (gain, directivity, polarization, and so on), to enable better
insight into antenna design.
FEM Simulator/ADS integration providing an integrated approach to EM/Circuit
design.

 Application Areas

The FEM simulator supports the following applications:

Microstrip, stripline, CPW elements such as filters, couplers, and spiral inductors
Multilayer structures
Ceramic filters
Adapters/transitions
Antennas
Couplers
Power splitters/combiners

 Using the EM Toolbar

You can also use the EM toolbar to perform EM simulations. The EM toolbar provides
shortcuts to the frequently-used menus. It is present in the Layout window, as shown
highlighted in the following figure:
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You can perform the following tasks by using the EM toolbar:

Starting an EM simulation: Click Start EM Simulation ( ) to initiate the
simulation process.

Stopping an EM simulation: Click Stop EM Simulation ( ) to stop an EM
simulation and release the license.

Opening the EM Setup window: Click EM Simulation Setup ( ) to display the
EM Setup window.

Opening the substrate editor window: Click Substrate Editor ( ) to open the
substrate editor window.

Opening the 3D Preview window: Click 3D EM Preview ( ) to preview an EM
simulation.

Opening the 3D Viewer window: Click Visualization ( ) to open the 3D Viewer
and load the simulation results of the current EM setup.

Calculating far fields: Click Far Field ( ) to calculate far fields from the
simulation results of the current EM setup.
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 Generating Ports
To determine how an EM model can interconnect with the other components in a
schematic, you need to configure ports for the EM model generation. Using the EM Setup
window, you can improve the use model of the port setup process. You can refresh layout
pins information, create, delete, sequence ports, and search the required S-parameter
ports or layout pins. It provides the following benefits:

Provides easier editing or viewing capability.
Provides flexible S-parameter port setup capability.
Assists in setting up S-parameter ports.

Note
The port definitions are stored with the layout. Therefore, it is recommended to enable the Save all
designs when simulation starts preference from the main window of PDE.

 Assigning a Layout Pin to the S-parameter Port

Momentum and FEM generate N-port S-parameter models for your circuit. The S-
parameter Ports define the input/output locations where current can be injected and/or
measured and/or exchanged. They are also required to connect the physical structure with
other electrical circuit components in an EM/circuit co-simulation.

Each port consists of two terminals,  terminal (signal) and  terminal (reference). The
port current flows from the _ terminal into the circuit and leaves the circuit via the -
terminal. The port voltage is defined as the difference of the electric scalar potential
between the two terminals:

Vp = V(r+) - V(r-)

Note
The scalar potential V(r) at infinity is zero.

S-parameters model the difference in voltage between the + and - terminal only. One
never knows the absolute voltage of the reference terminal(s). On a schematic, an N-port
S-parameter model can have either N+1 or 2N terminals. The two are equivalent because
you don't know the absolute voltage at any of the N reference terminals. It doesn't matter
if you short them all together or not. In case of 2N terminals, only the voltage difference
will be applied to the S-parameter model.

While the + terminal is always explicitly defined, the - terminal can be defined in the
following ways:

When there is an infinite ground plane, the - terminal is implicitly located in the
infinite ground plane closest to the + terminal.
In the absence of an infinite ground plane, the - terminal needs to be explicitly
defined somewhere close to the + terminal.
For Momentum, when there is no - terminal and no infinite ground plane, the port
voltage is defined as the value of the electric scalar potential at the + terminal: Vp =
V(r+). You can rewrite this as follows:

Vp = V(r+) -- V (at infinity)

Therefore, you can consider infinity as the location of the implicit - terminal for this case.
For FEM, - terminals need to be define in all cases in absence of an infinite ground.

Ports are defined in a two-step process. First, layout pins are added to the circuit layout.
These pins define the places where current can enter or leave the circuit. Then, using the
EM Port Editor, you specify how the layout pins are used to define the S-parameter ports
of the EM simulation.

To assign a layout pin to the S-parameter port:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Ports in the left pane of the EM Setup window, as shown in the following2.
figure:
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Select a pin row in Layout Pins. For example, P2 row is selected in the following3.
figure:

Drag the pin from Layout Pins and drop it on the  or  terminal of the required4.
port in S-parameter Ports. For example, P2 is dragged and dropped on the -
terminal of Port1 in the following figure:

A message box is displayed if your target pin is already used by other ports.5.
Click Delete Ports and Continue in the message box.6.

Note
You can drag and drop multiple layout pins and connect with a S-parameter port.

 Setting up Ports



EM Simulation

42

Using the EM Setup window, you can edit, view, and set up ports and layout pins in an EM
simulation. Select Ports in the left pane of the EM Setup window. The following figure is
displayed:

This window consists of two panels S-parameter Ports and Layout Pins. You can use
the toolbar options to perform various tasks in these panels.

 Using the Toolbar Options

You can use various toolbar options to create new ports, refresh layout pins, or delete
selected ports. You can perform the following tasks by using the options available on the
toolbar:

Refreshing layout pins and S-parameter ports information: Click Refresh pins

and ports ( ) to update the list of pins and ports with the latest information in
the Layout window.

Automatically creating new ports: Click Auto-create new ports ( ) to
automatically generate one port per pin in the S-parameter Ports. You can edit the
port list as per your requirements.

.

Creating new ports: To manually create a new port, click Create New Port ( )
in the Ports toolbar. Then, select the required layout pins in Layout Pins and drag and
drop them on the positive or negative terminal of the port to make connection.

Note
There must be an unconnected pin in the layout pins to create a new port.

Note
You can also select and drag the required pin and connect it with a port in the S-parameter Port
view.

Deleting ports: To delete the selected ports in S-Parameter Ports, click Delete

selected items ( ) in the Ports toolbar.
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Note
The port number will always be retained in sequence.

Resequencing ports: Click Resequence Ports ( ) to open the Reorder Port
Numbers window.

From the Reorder Port Numbers window, select the required port and click the Up
and Down keys to change the ports sequence according to your requirements.

Expanding S-parameter ports tree: To display the detailed information about

each port in S-Parameter Ports, click Expand S-parameter Ports tree ( ).

Collapsing S-parameter ports tree: To hide the details of ports in S-Parameter
Ports, click Collapse S-parameter Ports tree ( ).

Searching the required information: For easy filtering and sorting commands,
click Toggle Search Filter On/Off ( ). Type the required string in the Search
text box. In the Layout Pins panel, you can also right-click any required field and
select Set texts to filter. This option picks up the text of current item in Layout Pins
and sets it in the filter, as shown in the following figure:

 Defining S-parameter Ports

In S-parameter Ports, you can view the  and  pins, which represent the plus and
minus terminals of a port. The name besides the plus and minus pins specifies the pin
name that is connecting to these terminals. For example, if you have assigned P3 for plus
and P4 for minus, it is equivalent to the following figure:

Note
You can assign any number of pins to the plus and minus terminal. However, if you do not assign any pin,
it is shown as Gnd, which means that the implicit value is ground.

 Physical Port Setup

You can connect the ports of an EM model to other circuit components in a schematic. To
make a relevant physical connection, it is important that the physical dimensions of the S-
parameter ports and the layout pins to which the ports are connected are electrically
small.

For S-parameter ports, the physical distance between the plus and minus pins must be
smaller than 1/10 of the wavelength at the highest frequency.
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For layout pins, the length of the edge (layout pins at an edge of the structure) or the
diameter of the area (layout pins inside the structure) must be smaller than 1/10 of the
wavelength at the highest frequency.

The physical port setup restrictions stem from circuit theory that stipulates that all
physical dimensions are electrically small so that no phase delays are present in the
circuit. Failing to comply with the physical port setup restrictions, generates unphysical
circuit S-parameters.

Note
To comply with the physical port setup, S-parameter ports for circuits with no infinite ground plane in the
substrate should always be defined between two explicit layout pins.

In the S-parameter Ports panel, you can perform the following tasks:

Viewing S-parameter Ports
Editing the S-parameter Ports Properties
Selecting the S-Parameter Ports Title Fields

 Viewing S-parameter Ports

You can view the list of S-parameter port numbers and terminals in the S-parameter Ports
panel of the EM Setup window, as shown in the following figure:

The following table describes the S-parameter Ports fields:

Field Description

Name Specifies the name of the first positive pin added. You cannot edit a port name.

Number Specifies the s-parameter port number.

Ref Impedance [ Ohm] Specifies the reference impedance value in ohms.

Calibration Allows you to set the following types of calibration:

TML
TML (zero length)
SMD
DeltaGap
None

Ref Offset [ mil] Specifies the Ref Offset value (shown in layout units).

See Also
Selecting the Calibration Type

 

 Editing the S-parameter Ports Properties

To modify values in the Ref Impedance, Calibration, and Ref Offset columns:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Ports in the left pane of the EM Setup window.2.
Click once in the required field in the S-parameter Ports panel, as shown in the3.
following figure:

http://edocs.soco.agilent.com/display/ads2011/Selecting+the+Calibration+Type
http://edocs.soco.agilent.com/display/ads2011/Selecting+the+Calibration+Type
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Specify the required values in the editable field.4.

You can also copy the value of an S-parameter Ports field and paste it on multiple fields.
This enables you to update multiple S-parameter Ports fields. To copy values:

Edit the required S-parameter Ports field.1.
Right-click and copy the value that you have edited in the field.2.

Select the fields for updating the copied value.3.
Right-click and paste the value on the selected fields, as shown in the following4.
figure:

 Selecting the S-Parameter Ports Title Fields

You can select the required heading fields in S-parameter Ports by performing the
following steps:

Right-click the title bar and then select View Option. This opens the View Option1.
dialog box, as shown in the following figure:

Select the required fields.2.
Click OK.3.

 Using Layout Pins

In the Layout Pins panel, you can perform the following tasks:

Viewing Layout Pins
Creating Ports with Selected Layout Pin
Selecting the Layout Pins Title Fields
Hiding Layout Pins
Selecting Layout Pins

 Viewing Layout Pins

You can view the list of layout pins and terminals in the EM Setup window, as shown
highlighted in the following figure:
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The following table describes the Layout Pins fields:

Field Description

Name Specifies the layout pin name.

Connected To Specifies the connecting terminal name.

Layer Num Specifies the layer number.

Layer Specifies the layer name.

Purpose Num Specifies the purpose number.

Purpose Specifies the purpose.

X [ mm] Specifies the X axis value (shown in layout units).

Y [ mm] Specifies the Y axis value (shown in layout units).

Net Name Specifies the Net name.

Number Specifies the number.

Pin Type Specifies the type of pin used in the design.

 Creating Ports with Selected Layout Pin

In the Layout pins panel, you can create port in the following ways:

Creating a port with selected pins: Right-click the required layout pin and select
Create Ports. It creates a port with the selected layout pin.

Creating a port with clustering pins: Right-click the required layout pin and select
Create a Port with clustering pins. It creates a port with all selected layout pins
for the plus pin of a S-parameter port.

 Selecting the Layout Pins Title Fields

You can select the required heading fields in Layout Pins by performing the following
steps:

Right-click the title bar and select View Option. This opens the View Option dialog1.
box, as shown in the following figure:

Note
The Tool-related parameters such as Name (from Tool) are available only when the pins are
imported through Allegro DFI. Otherwise, these parameters are shown as N/A, if you try to select in
the View Option dialog box.

Select the required fields.2.
Click OK.3.

You cannot edit the layout pin properties, as these are read-only fields.

 Hiding Layout Pins
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You can hide the layout pins that are connected to S-parameter Ports by selecting the
Hide connected layout pins check box. The layout pins that are connected with S-
parameter Ports are hidden in the Layout Pins panel. For example, if all layout pins are
connected to S-parameter ports, no layout pins are displayed in the layout pins panel.

The following figure highlights the Hide connected layout pins check box:

 Selecting Layout Pins

You can specify how pins are selected in a layout. You can choose one of the following
options:

Auto select: Selects pin(s) automatically.
Auto center: Selects pin(s) from the center.
Auto zoom: Increases the layout window zoom to the selected pin(s).

The following figure displays these options:
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 Specifying Simulation Resources
You can run EM simulations on a local or remote machine, or take advantage of a third
party load balancing and queuing system such as LSF, Sun Grid Engine, and PBS
Professional. You can choose one of the following simulation modes:

Setting up Local and Remote Simulation
Setting up Third Party (Distributed) Simulation

 Setting up Local and Remote Simulation

In the EM Setup window, you can specify the following setup options for local or remote
simulations:

The capability to start and stop the Job Manager: Click Start to initiate the Job
Manager window and click Stop to close the Job Manager process. For more
information, see Using the Job Manager (em).

Specifying a simulation directory: You can either specify a directory or use the shared
directory for storing simulation data:

Selecting Shared local displays the path of the local directory.
Selecting Specify allows you to type a new directory. If you select Auto-create
subdirectory per job, sub-directories are created automatically.

Specifying the number of threads: You can specify the number of threads used in the
local simulation:

Auto: The number of threads are chosen depending upon the number of cores of
the machine.
Limit to: Allows you to specify the number of threads. This number can be:

N: This would limit the threads to the N or #Cores of machine whichever is
smaller.
#Cores - N: This would free N Cores of the machine. The threads would
limit to #Cores - N. In the auto mode, the value of n is equal to 0.

Specifying the process priority: You can choose the Normal, Below Normal, or Idle
types of process priority. This maps to the nice number under Linux/Unix and process
priority under windows.

Specifying queue simulation: If you select Queue simulation, your simulation will
be put on a queue and must be started from the Queue Manager.

Queue name: Specify a queue name.
Auto-start queue after submission: Selecting this option starts the simulation
automatically you submit the changes.

 Specifying the Local/Remote Setup Options

To specify the host settings for a local or remote simulation:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Resources in the left pane of the EM Setup window.2.
Select ADS (Local/Remote).3.

Specify the simulation directory.4.
Specify the number of threads.5.
Choose the process priority from the drop-down list.6.
Select Queue simulation to queue your simulation.7.
Provide a queue name.8.
If you want the queue to start automatically, select Auto-start queue after9.
submission.

 Setting up Third Party (Distributed) Simulation

If you want to use a third party workload management system, such as LSF, PBS
Professional, and Sun Grid Engine, you can use the Distributed mode. In the distributed
mode, you have access to the third party workload/queue management system to submit
an EM simulation to a cluster of machines.

Before using the distributed mode, you need to set up a connection between your personal
machine and the target machine that you want to use as submit host to the workload
management system. The submit host is the one machine that will add and monitor
simulation jobs given to the workload management system on behalf of your ADS session.

The submit host can be your local machine or can be a remote machine. To create this
connection with the submit host you must first make the Job Manager aware of the
workload management system on the submit host by adding the necessary configuration
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settings of the workload management system to the startup environment of the PVM
deamon on the submit host.

On a Linux or a Solaris submit host add the necessary environment variables or source the
required configuration script for your system into the PVM boot script (em)
~/.eesofpvmprofile. On a Windows based submit host make sure the workload
management system can be used by all users from a Windows command window. Refer to
the documentation of your workload management environment for details on these
configuration requirements. Next, ensure that the connection settings for the submit host
are properly configured in the Job Manager Preferences (em).

Note
For the distributed simulation with a third party workload management system where the local machine is
a valid submit host, you do not need to define any formal PVM cluster configuration. A local PVM deamon
will start and provide the submit and monitor capabilities with the workload management system.

To run simulations, the distributed mode assumes that the third party workload
management system has been preconfigured to run ADS related tasks from the user
command line environment on the submit host and on the execution hosts (the machines
that will run the EM simulation) of the workload management system.

The distributed mode assumes that the third party workload management system has
been preconfigured to run ADS related tasks from the command line environment. For
setting up the third party workload management system refer to the documentation for
your particular environment. You can find information for the supported workload
management systems at the following location:

LSF: http://www.platform.com
PBS Professional: http://www.pbsgridworks.com/Default.aspx
Sun Gridengine: http://gridengine.sunsource.net/

Make sure that the execution environment has the essential variables such as
HPEESOF_DIR, PATH and ADS license settings are correctly defined on the hosts in the
workload management system. For further details about the ADS configuration, refer to
the ADS installation guide.

On Linux or Solaris machines, you can also add a ksh script .adsrc with the appropriate
ADS environment settings inside your home directory on the cluster machines. The
~/.adsrc file is picked up by the simulation scripts just before a simulation starts.

 Third Party (Distributed) Setup Options

In the EM Setup window, you can specify the following setup options for the distributed
mode:

The capability to start and stop the Job Manager: Click Start to initiate the Job
Manager window and click Stop to close the Job Manager process. For more
information, see Using the Job Manager (em).

Specifying a submit host: Choose the required submit host (this can also be the local
machine, as the submission host) for distributed simulation. Click Refresh to retrieve
the list again.

Specifying a submit queue: Choose the required submit queue on the selected submit
host for distributed simulation. Click Refresh to retrieve the list again.

Specifying parallel jobs for frequency sweep: Allows to specify the number of
frequency points that will be calculated in parallel. It controls how the frequency
sweep is distributed over the cluster. If it is equal to 1, it specifies a normal
momentum simulation. If the value is greater than 1, you need a momentum turbo
license and this is only supported between a cluster of Linux machines.

Specifying a simulation directory: You need to define the remote simulation directory
on the submit host for your distributed simulations. It sets the directory on the
remote computer holding the EM files while the simulation is running. If the host
mode is remote but the host is set to the local machine, the remote directory should
be set to Shared local.

Note
For the distributed simulation with a third party workload management system it is very important that
this directory is visible to all cluster hosts in exactly the same way. Make sure mount points are identical.

Specifying the number of threads: You can specify the number of threads used in the
distributed simulation.

Specifying process priority: You can choose the process priority among the Normal,
Below Normal and Idle. This maps to the nice number on the Linux/Unix platform
and process priority on the Windows platform.

http://www.platform.com/
http://www.platform.com/
http://www.pbsgridworks.com/Default.aspx
http://www.pbsgridworks.com/Default.aspx
http://gridengine.sunsource.net/
http://gridengine.sunsource.net/
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Specifying job control settings: You can specify the following job control settings:
Submit user: Enables you to provide a user name if the local user name differs
from that on the cluster.
Email notification: Enables you to specify this option for notification purposes.
Job name: Enables you to specify a name.
Shell command at finish: Allows you to use shell commands.
Resource String: Allows you to specify a resource string.
Export env. Variables: Enables you to export environment variables.

Specifying the start time: You can configure the simulation start time by selecting the
required option from Start. You can choose either Now, At time, or After job(s)
option.

Specifying the termination time: You can configure the simulation expire time by
selecting the required option from Expire. You can choose either Never or type the
required time in the At/After text box.

 Specifying Third Party (Distributed) Setup Options

To specify the distributed mode setup options:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Resources in the left pane of the EM Setup window.2.
Select the 3rd Party (distributed) option to specify the distributed setup options.3.

Specify the simulation directory.4.
Specify the number of threads.5.
Choose the process priority from the drop-down list.6.
Specify the job control settings.7.
Select the Start option.8.
Select the Expire option.9.

 Using the Job Manager

The EM Setup window provides the capability to start and stop the Job Manager. For for
more information, refer Using the Job Manager (em). The Job Manager is automatically
started in mimimized mode when an EM Setup is being opened. Click the Start button to
restart a closed Job Manager or to restore its main window, as shown in the following
figure:

After the successful start of the Job Manager, the Simulation host list is populated with the
active hosts and those defined in the Job Manager Preferences (em). Select the desired
host where you want to launch the simulation.

To close the Job Manager, close its main window or click the Shutdown button in the EM
Setup window. Click Shutdown again if you need to bring the underlying PVM
infrastructure to a halt (a confirmation dialog box is displayed).

http://edocs.soco.agilent.com/download/attachments/152602493/job_manager_main_window.png
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 Viewing Layout Information
You can view information about the current layout in the EM Setup window. This window
provides the following information about the location of a workspace, library, cell, and
view of the current layout:

Workspace: Specifies the complete path to the location where you have saved the
workspace file.
Library: Specifies the name of the library.
Cell: Specifies the name of the cell.
View: Specifies the view that is opened for setting up the EM simulation.

Note
For detailed information about workspace, library, cell, and view, see Advanced Design System Quick Start
(adstour).

From the EM Setup window, you can also open the structure in the following window:

3D view
Layout window

 Displaying Layout Information

To display the layout information for your EM simulation:

Select EM > Simulation Setup to open the EM Setup window.1.
Select Layout in the left pane of the EM Setup window.2.

View the Workspace, Library, Cell, and View information in Input Layout.3.
Click Show in Layout Window to open the layout window.4.
Click Show in 3D View to open a 3D view for your EM simulation.5.
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 Assigning Substrate
You can define a substrate in EM simulations to describe the media where a circuit exists.
A substrate definition enables you to specify properties such as the number of layers in
the substrate, the dielectric constant, and the height of each layer for your circuit. For
example, the substrate of a multilayer circuit board consists of layers of metal traces,
insulating material, ground planes, and vias that connect traces and the air that surrounds
the board. In addition, a substrate definition enables you to specify properties such as the
number of layers in the substrate, the dielectric constant, and the height of each layer for
your circuit. You can save the substrate definitions and use with other circuits.

A substrate consists of following two layers:

Substrate Layer: This layer defines the dielectric media, ground planes, covers, air,
or other layered material.
Metallization Layers: This is the conductive layers in between the substrate layers,
which are used in conjunction with the layout layers. By mapping layout layers to
metallization layers, you can position the layout layers that your circuit is drawn on
within the substrate.

The following figure displays an example of a substrate, which contains four substrate
layers and two microstrips with a via:

 Selecting a Predefined Substrate

To open a predefined substrate:

Select EM > Simulation Setup to open the EM Setup window.1.
Select Substrate in the left pane of the EM Setup window.2.

Select an existing ADS substrate file from the drop-down list.3.
To open the Substrate window, click Open. The following figure displays a Substrate4.
window.
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 Creating a Substrate

To create a new substrate:

Select EM > Simulation Setup to open the EM Setup window.1.
Select Substrate in the left pane of the EM Setup window.2.
Click New to display the New Substrate dialog box, as shown below:3.

Select the required library from the Library drop-down list.4.
Type a name in the Substrate text box.5.
Click OK.6.

Note
For more information about substrates, see Substrates in EM Simulation (adstour).
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 Defining the Frequency and Output Plan
You can set up multiple frequency plans for a simulation. For each plan, you can specify
that a solution be found for a single frequency point or over a frequency range. You can
also select a sweep type for your frequency plan. However, the collection of frequency
plans run as a single simulation. You can also specify the data display settings for your EM
simulations by using the EM Setup Window.

 Setting up Frequency Plans

To add a new frequency plan, you need to specify the following parameters in the EM
Setup window:

Column Description

Type Specifies the type of frequency:

Adaptive: It is the preferred sweep type. It uses a fast and accurate method of comparing
sampled S-parameter data points to a rational fitting model. The value entered in the Sample
Points Limit field is the maximum number of samples used in an attempt to achieve
convergence. The solutions from the final attempt will be saved. If convergence is achieved
using fewer samples, the solutions are saved and the simulation will end.
Linear: It simulates over a frequency range, selecting the frequency points to be simulated in
linear increments based on the step size you specify. Type the start and the stop frequencies
in the Start and Stop fields, and select frequency units for each. Enter the step size in the
Step field, and select units.
Log:It simulates over a frequency range, selecting the frequency points to be simulated in
logarithmic increments. Type the start and the stop frequencies in the Start and Stop fields,
and select frequency units for each. Enter the number of frequency points to be simulated per
decade of frequency in the Points/Decade field, and select units.
Single: It simulates at a single frequency point. Type the value in the Frequency field and
select the units.

Fstart Specifies the frequency start value. You can specify the value in Hz, KHz, MHz, GHz, or THz units.

Fstop Specifies the frequency stop value. You can specify the value in Hz, KHz, MHz, GHz, or THz units.

Npts Specifies the number of frequencies to simulate. For Adaptive this is the maximun number of
samples to use.

Step Specifies the step value. You can specify the value in Hz, KHz, MHz, GHz, or THz units.

Enabled Allows you to enable the frequency plan.

 Adding a Frequency Plan

To add a frequency plan:

Choose EM> Simulation Setup to display the EM Setup window.1.
Select Frequency Plan in the left pane of the EM Setup window.2.

To add a new frequency plan, click Add.3.
Select a sweep from the Type column.4.
Specify the frequency start value in the Fstart column.5.
Specify the frequency stop value in the Fstop column.6.
Specify the value of N points in the Npts column.7.
Specify the step value in the Step column.8.
Select the check box in the Enabled column to enable the frequency plan.9.
Repeat the preceding steps to insert additional frequency plans.10.

Note
In a simulation, the frequency plans are executed in the order they appear in this list with the
exception that the Adaptive sweep only starts if all others have been executed

 Removing a Frequency Plan

To delete a frequency plan:

Choose EM> Simulation Setup.1.
Select Frequency Plan in the EM Setup window.2.
Select the required frequency plan.3.
Click Remove.4.

 Defining the Output Plan

You can specify a dataset for storing results by using the EM Setup window. You can
perform the tasks described in this section.

 Selecting Output Dataset

When you run an EM simulation, the results are stored in a dataset. This dataset is then
used by Data Display for viewing results. You can select the name and location of the
dataset you want to use for a simulation. The default value is the cell name. Datasets are
stored in a workspace or data subdirectory. You can also select a dataset name from the
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existing dataset file names. When using an existing name, new results overwrite existing
contents. This means that you should provide unique names for the datasets that will be
generated from different cells in the same workspace directory.

 Specifying a Dataset

To select an output dataset:

Select EM > Simulation Setup to display the EM Setup window.1.
Select Output Plan in the left pane of the EM Setup window.2.
Click Edit. The Choose Output Dataset dialog box is displayed.3.

You can also select EM > Choose Output Dataset to open the Choose Output Dataset dialog box.

Type a name for the dataset where you want simulation data to be saved.4.

You can also click Browse to view the existing dataset names in the current5.
workspace, as shown in the following figure:

Select the required dataset and click OK.6.
The Append text specified in simulation setup check box is selected by default.7.
Click OK.8.

 Customizing the Dataset Naming Convention

You can customize the naming convention of the dataset generated during a simulation by
adding a prefix or suffix to the data name. To generate the dataset with the required
naming convention, you can select Appending text to the dataset name. You can
select one of the following options for customizing the data name in Append text to the
name:

View name: Select the View name option in the From the layout view section to
add text from the layout view.
Adding simulation type: Select Simulation type include the type of simulator in the
dataset name by selecting Simulation Type.
Adding simulation options: Select Simulation options in the From the simulation
setup view section to add text from the simulation setup view.
Adding user-defined text: You can add a suffix to the dataset name in the This text
field.

 Specifying Data Display Settings

You can select options to open data display after completing the simulation process.

Open data display when simulation completes: Automatically opens the data display
window on the completion of a simulation.

You can also insert a template in a new or empty data display by using one of the
following options:

Auto-select based on number of ports: Selects a template automatically based on the
number of ports.
User-defined file: Enables you to specify a template. You can also perform the
following steps to select the required template:

Click Browse to open the Data Display Insert Template window, as shown in the1.
following figure:
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By default, the Momentum Product option is selected in the left pane of the Data2.
Display Insert Template window.
Select the required template.3.
Click OK.4.

 Saving and Using Files from Previous Simulation

You can select the following options for reusing files and saving current simulation
settings:

Reuse files from previous simulation: Allows you to use the files that were used
during previous simulations.
For momentum simulations, you can use the Save currents post-processing
option. It allows you to save the current settings for post processing.
For FEM simulations, you can select an option from the Save fields for list.

 Creating an Output Plan

To create an output plan:

Choose EM> Simulation Setup to display the EM Setup window.1.
Select Output Plan in the left pane of the EM Setup window.2.

The default dataset name is displayed. To specify a new dataset, click Edit. For more3.
information, see Selecting Output Dataset.
Select an option for appending text to the dataset name.4.
Select Open data display when simulation completes, if you want to open the5.
data display window automatically.
Specify the template to be used for displaying the data in Template. You can also6.
click Browse to select the required template.
Select Reuse files from previous simulation if you want to use the previous7.
simulation files.
Select Save currents for post-processing.8.
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 Defining Simulation Options
You can specify engine-specific options such as, substrate overrides, preprocessor, and
mesh for EM simulations. In this section, you will learn:

Creating Simulation Options Set
Specifying Simulation Options

 Creating Simulation Options Set

You can either use a predefined set of simulation options or or create a new set in
Simulation Options of the EM Setup window. You can perform the following operations
to edit the list of simulation sets:

Creating a copy of the option set: You can create a copy of the predefined simulation
set by clicking Copy as. Specify a name for the copied option. You can now define
new simulation options in this set.

Renaming an option set: You can change the name of your simulation set by clicking
Rename.

Removing an option set: You can delete a simulation set by clicking Remove. After
you remove a simulation set, the simulation set value changes to Default in the
drop-down list.

To create a new set of simulation options:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Options in the left pane of the EM Setup window, as shown in the following2.
figure:

Click Create a copy.3.
Specify a name for the copied option.4.
Define new simulation options in the EM Setup window.5.

 Specifying Simulation Options

You can specify preprocessor, mesh, and simulation settings by using the Simulation
Options dialog box. It consists of the following tabs:

Description
Substrate
Preprocessor
Mesh
Simulation
Expert

In the Description tab, you can add information about the simulation options. The
following sections provide information about the other tabs available in the EM Setup
window:

Overriding Substrate Definition for Momentum (em)
Overriding Substrate Definition for FEM (em)
Defining Preprocessor Settings (em)
Defining Mesh Settings for Momentum (em)
Defining Mesh Settings for FEM (em)
Defining Simulation Settings (em)
Defining Expert Options for Momentum (em)

 Defining Expert Options for Momentum

You can define advanced settings for your Momentum simulation by using the Expert tab.

To specify the expert options:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Momentum as the EM simulator.2.
Select Options in the left pane of the EM Setup window.3.
Select the Expert tab.4.
Click Add to insert a new row.5.
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Specify a value in the Key field.6.
Specify a value in the Value field.7.

The expert options are distinct from the Momentum configuration variables which provide an alternative
approach to influence the EM Simulator. See Customizing the ADS Environment (custom).

 Available Expert Options

Mesh, processing object overlap (em)
 Defining Mesh Settings for FEM

An FEM simulation mesh is a part of the entire 3D problem domain, which is divided into a
set of tetrahedra (or cells). The pattern of cells is based on the geometry of a layout and
optionally, user-defined parameters, so each layout has a unique mesh calculated for it.
The mesh is then applied to the geometry to compute the electric fields within each cell. It
also helps to identify any coupling effects in the layout during simulation. From these
calculations, S-parameters are then calculated for the layout.

The FEM simulator implements an adaptive meshing algorithm, where an initial mesh is
generated and the electric fields (and S-parameters) are computed on that initial mesh for
a single frequency or multiple frequencies broadband refinement  are used. An error
estimate is generated for each tetrahedron. The tetrahedra with the largest estimated
errors is refined to create a mesh where the electric fields (and S-parameters) are
computed. The S-parameters from consecutive meshes are compared. If the S-
parameters do not change significantly, then electric fields (and S-parameters) are
computed for all the requested frequencies. If the S-parameters do change significantly,
then new error estimates are computed, a new mesh is generated and new electric fields
(and S-parameters) are computed.

 Specifying Mesh Settings for FEM

To define FEM mesh settings using the EM Setup window:

Select EM > Simulation Setup to open the EM Setup window.1.
Select the FEM simulator.2.
Select Options in the left pane of the EM Setup window.3.
Click the Mesh tab, as shown in the following figure:4.

In the Mesh tab, you can specify the following settings:

Specifying Stop Criterium Settings
Specifying Refinement Settings
Specifying Initial Mesh Settings
Specifying Advanced Settings

 Specifying Stop Criterium Settings

http://edocs.soco.agilent.com/display/ads2011/Copy+of+Performing+FEM+Broadband+Refinement
http://edocs.soco.agilent.com/display/ads2011/Copy+of+Performing+FEM+Broadband+Refinement
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Using the Stop criterium tab, you can specify delta error and adaptive phase values. The
following figure displays the stop criterium options:

The following table describes the stop criterium options:

Option Description

Delta Error Global Delta S-parameter sets a value that is applied to all S-parameters in the solution.
Enter a value in the Delta Error field. It is the allowable change in the magnitude of the
vector difference for all S-parameters for at least the number of consecutive refinement
passes specified in the field "Consecutive passes of delta error required".

Consecutive
passes of delta
error required

Specify the required number of consecutive passes with a delta error smaller than or
equal to the value specified in the field "Delta Error".

Minimum number
of adaptive passes

Enter the minimum number of refinement passes. The number of refinement passes is at
least this number even if the convergence criterium based on the delta error is met with
less refinement passes. If you have concerns about convergence, you can increase this
value, otherwise, use the default value of 2.

Maximum number
of adaptive passes

Enter the maximum number of passes to be attempted. If the number of refinement
passes entered is reached before the delta error criterium is met, the refinement process
ends, based upon this limit. Typically, a value between 10 and 20 is recommended.

 Specifying Refinement Settings

Using the Refinement tab, you can control the frequencies at which the mesh will be
adaptively refined. The following figure displays the Refinement tab options:

The following table describes the Refinement tab options:

Option Description

Maximum
frequency

The refinement frequency will be the highest frequency found in the frequency plan.

Chosen
automatically after
initial pass

Refinement frequencies are chosen by the solver. This strategy is recommended when
you are not aware about the important characteristics that can occur in your frequency,
but you know the frequency transitions are not extremely sharp (i.e. are not high Q
resonances).

Chosen
automatically after
each pass

Refinement frequencies are not fixed, but can vary from level to level. This is an
automated option and tends to generate accurate results, but it also tends to result in
the longest simulation times. This strategy is recommended:

For structures with high Q resonances.
During final analysis of a structure where accuracy is preferred over fast
simulations.

Manual Selection Refinement frequencies are specified manually.

Performing FEM Broadband Refinement

 Specifying Initial Mesh Settings

Using the Initial mesh tab settings you can control how the initial mesh is generated.
The following figure displays the initial mesh options:

The following table describes the Initial mesh tab options:

http://edocs.soco.agilent.com/display/ads2011/Copy_of_Performing_FEM_Broadband_Refinement
http://edocs.soco.agilent.com/display/ads2011/Copy_of_Performing_FEM_Broadband_Refinement
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Option Description

Use Initial
Target mesh
size

Provides an initial denser mesh. If used, no edge in the initial mesh will be longer than the
given length. If you click Automatically Determine, the initial target mesh size is determined
automatically. The length is computed based on the frequency plan available when the request
is made.

Automatic
Conductor
Mesh

When automatic conductor meshing is selected, the mesher estimates where mesh lengths
need to be reduced to improve the accuracy and convergence speed of the simulation. The
algorithm to produce this mesh is based on the DC connectivity of geometry with ports. Only
parts electrically connected to a port are affected. For those parts the edge and vertex mesh is
set. The length of the edge and vertex mesh is based on the estimated width assuming the
structure being excited starts with a strip-like construction. The mesh process will report the
estimated width in the simulation output window.

Conductor
edge mesh
length

Specifies a target mesh size of all edges that belong to the geometry of a conductor. Edges do
not necessarily have to be straight lines. A value of 0 means that no initial conductor edge
mesh length is applied.

Conductor
vertex mesh
length

Specifies a target mesh size for all vertices that belong to the geometry of a conductor. A value
of 0 means that no initial conductor vertex mesh length is applied.

Number of
bondwire
segments

Enables you to specify the number of bondwire segments.

 Specifying Advanced Settings

Using the Advanced tab, you can specify the target mesh growth, initial mesh size,  and
automatic conductor mesh settings. The following figure displays the advanced options:

The following table describes advanced options:

Option Description

Target Mesh
Growth

Specifies the percentage by which each adaptive mesh grows relative to the previous mesh.

Use Initial
Mesh Size

Enables you to set a minimum length of edges in the initial mesh. During mesh refinement,
the individual length of edges in the mesh can be shortened where deemed necessary by the
adaptive refinement process. If you click Automatically Determined, a value is
automatically calculated based on the requested frequencies and geometric size. Using this
option, you can restrict the meshing process to a more limited set of possible solutions. It is
advised to only use this option when the initial mesh is unreasonably dense in some areas
due to some combination of geometric features triggering that behavior.

Merge Objects
with Same
Material

This option controls if two objects that have the same material properties may be merged
prior to meshing. This option can be used to reduce the number of tetrahedrons generated.
Object merging is applied only when the objects also have the same mesh priority.

Automatic
conductor
mesh setting
Edge meshing

This option is used when automatic meshing is applied. It determines the length of the edge
mesh in relation to the estimated width of the conductor.

Automatic
conductor
mesh setting:
Vertex
meshing

This option is used when automatic meshing is applied. It determines the length of the vertex
mesh in relation to the estimated width of the conductor.

Advanced meshing controls should only be changed in case of meshing problems.

 Defining Mesh Settings for Momentum

In the Momentum solution approach, any electromagnetic configuration of a 3D design
can be represented without loss of generality as a voltage/current distribution on its
surfaces. This continuous distribution is approximated by a finite number of unknowns
using a mesh. This mesh is a grid-like pattern of triangular and/or quadrilateral cells
tessellating all surfaces.

In an S-parameter simulation, coupling effects between cells are being calculated using
the Green function database. The currents passing through mesh edges are then derived
from mesh cell voltages to match the calculated coupling effects. From these results, S-
parameters are calculated for the circuit.

The quality of the mesh determines the quality of a solution. The cells need to be small
enough in order to capture real world spatial variations of the current/voltage distribution.
However, covering low-variability regions with larger cells is necessary to keep the
problem size within reasonable limits.

The default configuration of the mesh generator produces suitable meshes in the vast
majority of situations. When desired, this configuration can be adjusted through a number
user-adjustable parameters. The default parameters are used automatically. The mesh is
normally computed as part of the simulation process; no specific user intervention is
required. It is also possible to explicitly preview the mesh without simulating in order to
assess its quality.
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In this section, you will learn about:

Defining a Mesh
Defining Global Mesh Parameters
Specifying Layer-specific Mesh Options
Specifying Shape-specific Mesh Options
Adjusting Mesh Density
Effect of Mesh Reduction on Simulation Accuracy
Setting the Width of the Edge Mesh
About the Transmission Line Mesh
Processing Object Overlap
Guidelines for Meshing

 Defining a Mesh

You can define mesh parameters for the following areas:

Entire circuit
Objects on a layout layer
Shape of an object

Note
It is not necessary to specify parameters for all levels. For example, you can specify mesh parameters for
a single object and use default values for the rest of the circuit.

 Defining Global Mesh Parameters

Global mesh parameters affect the entire circuit. To set up global parameters:

Select EM> Simulation Setup to open the EM Setup window.1.
Select Momentum as the EM simulator.2.
Select Options in the left pane of the EM Setup window.3.
Select the Mesh tab. By default, the Global parameters are displayed.4.
Specify the mesh frequency. You can select one of the following options:5.

Select Highest Simulation Frequency. Set the value of the mesh frequency to
the highest frequency that will be simulated. For more information, refer to
Adjusting Mesh Density.
Type the mesh frequency in the Mesh Frequency field and select the units. The
wavelength of this frequency is used to determine the density of the mesh.

Specify the mesh density. You can select one of the following options:6.
Specify the Maximum Cellsize value and select the units.
Enter Number of Cells per Wavelength. This value will also be used to
determine the density of the mesh. For more information, refer to Adjusting
Mesh Density.

Enable Edge Mesh to add a relatively dense mesh along the edges of objects. Due to7.
the flow of current along the edges of objects, the edge mesh can improve the
accuracy and speed of a simulation. An edge mesh will similarly be created on thick
conductor side walls. You can select one of the following options:

If you want the edge mesh to be sized automatically, select Auto-determine
Edge Width.
To specify the edge width, select Edge Width and select the units. For more
information about the edge mesh, refer to About the Edge Mesh.

Note
An edge mesh that is specified with a width larger than the cell size set by the
wavelength/number_of_cells_wavelength, will be ignored. This is because such edge meshes
would be very inefficient. However, if these edge mesh values must be used, you can
decrease the number_of_cells_wavelength, which is specified in the Number of Cells per
Wavelength field.

Enable Transmission Line Mesh to specify the number of cells along the width of a8.
geometry. This option is most useful for circuits with straight-line geometry.
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Enter the number of cells that the width will be divided into in the Number of Cells9.
Wide field. This will be the total number of cells along the width of the circuit. For
more information about the transmission mesh, refer to About the Transmission Line
Mesh.
Enable Mesh reduction to obtain an optimal mesh with fewer small cells and an10.
improved memory usage and simulation time.
Enable Thin layer overlap extraction to extract objects for the following situations:11.

Two objects on different layers overlap.
The objects are separated with a thin substrate layer.
If this is enabled, the geometry will be altered to produce a more accurate
model for the overlap region. The Normal setting is recommended for most
layouts. The Aggressive setting is only recommended when tiny overlap
differences are expected to lead to significant result variations as this option will
considerably increase the problem size. For more information, refer to
Processing Object Overlap.

Note
This should always be enabled for modeling thin layer capacitors.

 Specifying Layer-specific Mesh Options

You can use the Layer Specific tab to define the mesh options for a specific layer. Perform
the following steps:

Select EM> Simulation Setup to open the EM Setup window.1.
Select Momentum as the EM simulator.2.
Select Options in the EM Setup window.3.
Select the Mesh tab to display the mesh options for Momentum.4.
Select the Layer Specific subtab to specify settings at the layer level, as shown in5.
the following figure:
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Select a value from the Mesh Density drop-down list in the required layer.6.
Select a value from the Edge Mesh Width drop-down list in the required layer.7.
Select a value from the Transmission Line Mesh Width drop-down list in the8.
required layer.

 Specifying Shape-specific Mesh Options

You can customize the selected shape by using the Shape Specific tab. Perform the
following steps:

Choose EM> Simulation Setup to open the EM Setup window.1.
Select Momentum as the EM simulator.2.
Select Options in the left pane of the EM Setup window.3.
Select the Mesh tab to display the mesh options for Momentum.4.
Select the Shape Specific subtab to specify settings at the shape level, as shown5.
below.

Note
To enable the shape-specific options, you need to select a shape in the layout before specifying the
options.

Enable the Override Layer Specific Mesh Density section. You can select one of6.
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the following options:
Select Maximum Cellsize. Set the maximum value of the mesh density that
will be simulated. For more information, refer to Adjusting Mesh Density.
Type the number of cells per wavelength in the Cells/Wavelength text box.

Enable Override Layer Specific Edge Mesh. You can select one of the following7.
options:

No Edge Mesh
Auto-determine Edge Width
Use Edge Width

Enable the Override Layer Specific Transmission Line Mesh section. You can8.
select one of the following options:

No Transmission Line Mesh
Cells in Width

 Adjusting Mesh Density

A minimal mesh density is guaranteed by enforcing all cells to be smaller than a certain
maximum cell size limit. When this maximum cell size is not stated explicitly, it is
calculated from the mesh frequency and the number of cells per wavelength. The cells
need to be small enough in order to capture real world spatial variations of the
longitudinal current distribution. The spatial extent of waves is shortest at the highest
frequency. Consider wave phenomena to be described by a sinusoid of a certain
wavelength. Each mesh cell is able to approximate only the portion of the sinusoid it
covers with a linear function. The accuracy of this piecewise linear fit improves as the
number of cells per wavelength increases. For example, if you use 30 cells per
wavelength, the maximum deviation between the sinusoid and the linear approximation is
about 1 percent.

Increasing either the mesh frequency or the number of cells per wavelength makes the
mesh denser. When a denser mesh is desired, it is generally better to increase the
number of cells per wavelength than the mesh frequency. The optimal value for the mesh
frequency is the highest simulation frequency that will be eventually used. In fact, an
increase of the mesh frequency may trigger a recalculation or extension of the Green's
functions database.

Note
Only the maximal cell size is enforced and not the minimal cell size. A polygon with N sides can be
tessellated with no less than N-2 triangles (or half as many quadrilaterals). This imposes a minimal cell
size dependent on the level of detail of the geometry.

Sometimes the geometric detail is much smaller than a fraction of the wavelength (typically when
including integrated circuits in the simulation). In this case it is advised to choose an explicit maximal cell
size not larger than four times the regular trace width. Otherwise the mesh may contain cells with a very
large aspect ratio that cannot properly model the actual current flow.

 Effect of Mesh Reduction on Simulation Accuracy

Mesh reduction is a technology that aims at removing mesh complexity originating from
the meshing of geometrically complex shapes. In a normal situation, you specify the mesh
density (the number of cells per wavelength) that needs to be used in the simulation in
order to obtain a specific accuracy. However, due to geometrical constraints, the mesher
can be forced to use more cells than strictly needed by the wavelength criterion. In this
case, the mesh introduces "redundant" degrees of freedom in the solution process
("redundant" with respect to the electromagnetic behavior). Mesh reduction is a
technology that automatically removes these redundant degrees of freedom, prior to the
solution of the problem. Hence, it should have a negligible impact on the accuracy of the
results.

Warning
Mesh reduction currently ignores layer or shape specific mesh density settings. Disable mesh reduction if
you have other than global mesh settings.

 About the Edge Mesh

The edge mesh feature automatically creates a relatively dense mesh pattern of small
cells along the edges of metal or slots, and a less dense mesh pattern of a few large cells
in all other areas of the geometry. Because most of the current flow occurs along the
edges of slots or metals, the edge mesh provides an efficient solution with greater
accuracy.

Use the edge mesh to improve simulation accuracy when solving circuits where the
modeling of current flow in any edge area is a critical part of the solution. This includes
circuits where the characteristic impedance, or the propagation constant are critical for
determining the electrical model, circuits in which close proximity coupling occurs, or
circuits where edge currents dominate the circuit behavior. The following applications use
the edge mesh:

Tightly coupled lines
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Patch antennas
Resonant circuits
Delay lines
Hairpin filters

Note
Edge mesh is available at all levels of meshing: global, layout layer, and object meshing.

 

 Setting the Width of the Edge Mesh

When using an edge mesh, choose Auto-determine Edge Width to let Momentum
determine an appropriate width. Alternatively, enter an explicit width. To this end you can
use Insert > Measure... to measure distances on the layout.

 About the Transmission Line Mesh

Use the transmission line mesh when you want to explicitly specify the number of cells in
the direction perpendicular to the current flow. This has no effect on the mesh density in
the direction of the current flow.

This setting can be used to improve the accuracy of a simulation with a coarse mesh
density. For example, the simulation results for a single transmission line with one or two
cells across its width will be equal. If you have coupled lines, the results will differ.

 Combining the Edge and Transmission Line Meshes

Both transmission line mesh and edge mesh can be used together. The total number of
cells wide will be the total number of transmission line cells plus edge cells. The minimum
value permitted when using this combination is 3.

The edge and transmission line mesh settings affect the transverse current distribution.
The accuracy of transverse current approximations improves as the number of cells
specified using edge mesh and transmission line mesh increases.

The plot below illustrates the hairpin example simulated with and without and edge mesh.
Although the simulation that includes the edge mesh takes more time, the results are
closer to the actual measured results of the filter.
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 Processing Object Overlap

The parameter Thin layer overlap extraction should be used in designs that have thin
layers in-between overlapping objects. It is possible that mesh cells are generated that
cross the overlap region and this is not desirable.
Typical situations where this is important are:

Parallel plate capacitor: The charge will be accumulated where the plates overlap.
Just next to that overlap area, charge will be much lower. As charge is assumed to be
uniformly distributed on a mesh cell, when such cell crosses the plate overlap area,
the charge will be spread out too much, resulting in a less accurate capacitance
extraction.
Transmission line above a finite ground plane: The return current in the ground plane
will concentrate just under the transmission line at higher frequencies. Large mesh
cells under the transmission line do not allow to describe that return current flow
accurately. The overlap extraction provides a way to force a mesh that follows the
shape of the transmission line allowing a more accurate approximation of the return
current flow.

As an example, consider two layers, one above the other, and close together. They carry a
large charge density where they overlap, which increases proportionally to 1/distance. If
there is no metal above the layers, the charge density is nearly zero where there is no
overlap, and the change is very rapid-nearly a step-at the point of overlap.
 

If no overlap extraction is performed, the mesher can create cells that will cross the
border of the overlap. In the actual circuit, this cell would have a partially high charge
density area where the overlap is present, and a partially low charge density area where
there is no overlap. However, Momentum simulates cells with a constant charge density,
and approximating the strongly-varying charge in the cell with a constant is not an
adequate representation. Thus, by enabling thin layer extraction, no cells will be created
that cross an overlap region.

All possible overlaps are being imprinted when using the Aggressive setting. This can
lead to a very dense mesh. Therefore, when using the Normal option, some rules are in
place that determine whether any particular overlap instance is sufficiently important to
warrant imprinting. To this end, every pair of overlapping shapes is analyzed. Only direct
overlap (not shielded by a third shape) is being considered. Both shapes take turns being
the aggressor and the victim. However, it needs to be decided whether or not to imprint
the boundary of the aggressor onto the victim, as shown in the following figure:
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The following analysis determines whether the overlap should be imprinted:

Capacitive overlap
Relevance: To determine whether this is a relevant capacitive overlap region,
the width of the overlap must be large in comparison to the distance between
the planes containing both shapes. The parameter
oe_capacitor_width_threshold determines the threshold for the ratio between
the overlap width and the effective z-plane distance. The effective z-plane
distance is the z-plane distance divided by the relative static permittivity.
Above this threshold, capacitive overlap is considered to be relevant.
Accuracy: Edges of a relevant capacitive overlap region are imprinted according
to an accuracy specification. The parameter oe_capacitor_accuracy determines
the threshold for the ratio between the effective maximal cell size of the victim
and the effective overlap width. Above this threshold, edges of relevant
capacitive overlap regions are imprinted.
The effective maximal cell size is the maximal cell size decreased with the z-
plane distance times oe_maximal_cell_size_height_shrink_factor.
Likewise, the effective overlap width is the overlap width increased with the z-
plane distance times oe_overlap_width_height_grow_factor.

Inductive overlap
Relevance: Only sufficiently long boundaries are considered for inductive
overlap. The length of the boundary must exceed inductor_length_threshold
times the minimal wavelength.
In addition, the ratio of the overlap width to the aggressor width must exceed
oe_inductor_width_threshold.
Accuracy: Edges of a relevant inductive overlap region are imprinted according
to an accuracy specification. The parameter oe_inductor_accuracy determines
the threshold for the ratio between the effective maximal cell size of the victim
and the effective overlap width. Above this threshold, edges of relevant
inductive overlap regions are imprinted.

When an edge is being imprinted, it is allowed to snap to existing geometry if the snap
distance is small enough to uphold the specified accuracy. This snap distance is
additionally limited to oe_maximal_overlap_width_change times the overlap width.

The final Boolean parameter oe_pedantic can be used to impose the most strict overlap
extraction rules. When enabled, it forces all other parameter values to zero. The
Aggressive overlap extraction setting has been implemented in practice by forcing
oe_pedantic to ON.

You can set all parameters by selecting Options > Expert  in the EM Setup window.
When unset, corresponding momentum.cfg configuration variables are consulted for default
values. Finally, built-in default values are being used. These values guarantee proper
overlap extraction across a wide range of designs.

The following table summarizes all overlap extraction related parameters. Note that all
numerical parameters are dimensionless quantities.

Options > Expert key in EM Setup
(highest priority)

$HOME/hpeesof/config/momentum.cfg variable name permissible
values

built-
in
default
value

oe_capacitor_width_threshold MOM_MESHER_OVERLAP_EXTRACTION_DEFAULT_CAPACITOR_WIDTH_THRESHOLD not negative 15

oe_capacitor_accuracy MOM_MESHER_OVERLAP_EXTRACTION_DEFAULT_CAPACITOR_ACCURACY not negative 0.05

oe_inductor_length_threshold MOM_MESHER_OVERLAP_EXTRACTION_DEFAULT_INDUCTOR_LENGTH_THRESHOLD not negative 0.1

oe_inductor_width_threshold MOM_MESHER_OVERLAP_EXTRACTION_DEFAULT_INDUCTOR_WIDTH_THRESHOLD not negative 0.5

oe_inductor_accuracy MOM_MESHER_OVERLAP_EXTRACTION_DEFAULT_INDUCTOR_ACCURACY not negative 0.5

oe_maximal_cell_size_height_shrink_factor

MOM_MESHER_OVERLAP_EXTRACTION_DEFAULT_HEIGHT_SHRINK_FACTOR not negative 0.88

oe_overlap_width_height_grow_factor MOM_MESHER_OVERLAP_EXTRACTION_DEFAULT_HEIGHT_GROW_FACTOR not negative 0.88

oe_maximal_overlap_width_change

MOM_MESHER_OVERLAP_EXTRACTION_DEFAULT_MAXIMAL_OVERLAP_WIDTH_CHANGE not negative 0.5

oe_pedantic EMPREP_PEDANTIC_OVERLAP_EXTRACTION ON or OFF OFF

 Guidelines for Meshing
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The default mesh will provide an adequate and accurate answer for many circuit
applications. For most other circuit applications, the using the global mesh parameters will
be all that is needed to provide greater accuracy. In a few special cases, you may need to
use the layer or primitive mesh controls.

For applications such as highly accurate discontinuity modeling or for geometries that
have tightly coupled lines, the default mesh may not be dense enough in particular areas
to provide enough accuracy. In such cases, edge mesh should be used or the mesh
density must be increased. For example, noise floor and dynamic range are typically small
numbers. In some cases, geometry solutions may show a low value of S21, like -60 dB,
using a dense mesh. Such values are different for a default mesh, which may result in -40
dB for the same circuit.

In any design, you can use any combination of the four types of mesh control. In general,
greater mesh density provides better accuracy. However, a greater density increases the
computation time (more cells to solve). You can refer to the following guidelines:

Meshing Thin Layers: Thin layers must be meshed so that the mesh cells are entirely
within or entirely outside of the overlapping area. If the mesh cells and object
boundaries are not aligned correctly, the simulation data may be less accurate.

Meshing Thin Lines: When the geometry has narrow lines, like thin transmission
paths in a spiral, it may be difficult to have a mesh that is more than one cell across
the width if the default global mesh is used. If needed, use Edge Mesh or
Transmission Line Mesh to capture the current distribution across the line.

Meshing Slots: Slots should be meshed exactly the same as strips-there is no
difference. For example, the edge mesh can be used for slots because the current
distribution is basically the same, that is, it is concentrated on the edges of a slot.

Adjusting the Mesh Density of Curved Objects: Vias or other curved objects, when
drawn in a layout, have a default value for the number of facets used to draw the
object, based on the command Options > Preferences > Entry/Edit > Arc/Circle
Resolution (degrees). If the value is small, a relatively large number of facets are
used to draw the circle, and this can result in more triangular cells created the curved
areas during the mesh process. To change the number of facets for all arcs and
circles, use the command shown above. To change them for a single object, select
the object, then choose Edit > Modify > Arc/Circle Resolution. Then, increase the
number of degrees for the radius, as required, to reduce the number of triangles.
However, this alters the geometry of a circuit.

 Defining Preprocessor Settings

The EM Preprocessor prepares a layout for electromagnetic simulation. It converts a given
layout into a new layout by applying the specified transformations. In this section, you will
learn about:

EM Simulation Transformations Overview
Describing the Preprocessor Parameters
Guidelines for Defining Preprocessor Settings
Specifying the Preprocessor Settings

 EM Simulation Transformations Overview

The duration of an EM simulation with a conformal mesh is dependent on the number of
edges in the mesh. This relation is superlinear. If the number of edges increases, the
simulation time increases more than proportionally. Reducing the complexity of the mesh
improves performance, especially for larger designs. Besides the complexity of the mesh,
the quality of the mesh is also important. A mesh containing triangles with acute angles
can lead to a reduced accuracy of the solution or even cause numerical issues while
solving.

Using the preprocessor settings, you can define the following optional transformations that
can alter the input layout geometry to improve the quality and complexity reduction of a
generated mesh:

Layout healing: Layout healing merges vertices and edges in close proximity. It
corrects numerical issues in the layout that obstruct the creation of a high-quality
conformal mesh. Layout healing:

Closes unintentional gaps between adjacent shapes that are frequently created
by layout generators and import or export processes, as shown in the following
figure:
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Ensures that stacked vias have only one joint boundary instead of two nearly
identical boundaries, as shown in the following figure:

Eliminates acute angles, as shown in the following figure:

Defining snap distance: Within the same substrate layer, the vertices and edges
that are closer together than the snap distance distance are merged. The
distances for layout healing are calculated using the L ∞ metric. In this metric,
the distance between two points is the largest absolute difference between both
horizontal and between both vertical components. Any set of points equidistant
to a given point is an axis-aligned square. Distances calculated using the L ∞
metric always amount to a fraction between 1/√2 and 1 of the Euclidean
distance.

The layout healing algorithm starts from an empty layout and inserts all edges
of all polygons and polylines one by one. The stack of substrate layers is
processed from top to bottom. Within one substrate layer, longer edges are
inserted before shorter edges. Newly inserted edges merge with already present
features on the same substrate layer within the snap distance. You can define
automatic snap distance that enables the preprocessor to automatically provide
a snap distance. Layout healing is enabled in this mode by default.

Merge shapes touching each other where possible: This EM transformation
merge the shapes that are touching each other in the design. In this type of
transformation, shared edges in the are not preserved. The following figure displays
an example of such transformation:

Layout simplification: This EM transformation replaces polygons by nearly identical
polygons with less vertices. The main purpose is to generate a conformal mesh
containing minimum number of edges. Layout simplification also creates higher
quality meshes as it removes many small segments.

Note
Layout healing and simplification can be applied in isolation or together.

 Describing the Preprocessor Parameters
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The following table describes the preprocessor parameters:

Option Description

Heal the layout This option enables the layout healing feature. It merges the vertices and edges closer
than an automatically determined or a user-specified snap distance. Detailed information
about the algorithm is in the section dedicated to layout healing. It is recommended to
specify automatic snap distance setting healing. If an aggressive healing approach is
required, choose a value between 1-10% of the width of the smallest trace or the tightest
clearance.

Merge shapes
touching each
other where
possible

This option controls whether edges shared between adjacent shapes need to be preserved
in the result.

Simplify the
Layout

This option toggles the usage of the layout simplification feature. In this section, you can
specify the following parameters:

Constraints (upper limits):
Upper displacement limit (layout simplification): This value is around one third
of the width of the smallest trace in the layout.
Upper shrinkage/growth limit (layout simplification): The reasonable values
are in the range of 5 to 15%. For specific requirements, such as via
simplification, the values up to 30-50% can be acceptable (this reduces circles
to squares or triangles).

Use different constraints for vias: You may need to simplify the vias more than the
rest of the layout. You can specify a different set of constraints for vias:
Displacement and Shrinkage/growth limit.

Save
Preprocessor
Messages as a
DRC Result

This option enables you to display the location-bound information and warning messages
in the layout using the DRC Results Viewer. The name of the DRC Result and the ADS layer
where errors are shown can be configured.

 Guidelines for Defining Preprocessor Settings

While defining the preprocessor parameters, you can refer the following guidelines:

Layout healing can change the layout topology. Therefore, the healing algorithm is
designed to make small changes to the layout topology. It is important to keep the
snap distance below the minimal clearance between different layout nets, otherwise
short circuits might appear. The snap distance must also be smaller than the width of
thin layout traces, otherwise these traces will disappear.

Specify a snap distance at least 10 times smaller than the minimal clearance and
trace width.

Whenever layout healing performs an actual layout change, a warning is displayed in
the status window. The details of the change are written to the DRC Result or the
layout processing report (dependent on the setup option Save preprocessor
messages as a DRC Result). Refer the DRC result or the layout processing report to
verify these changes.

Do not use layout healing as a polygon simplification tool. It is recommended to
avoid choosing a large snap distance. For this purpose, the layout simplification
feature provides a better and safe alternative.

 Specifying the Preprocessor Settings

To specify preprocessor settings:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Options in the EM Setup window.2.
Click the Preprocessor tab.3.

Note
You can view a graphical representation of the available optional transformations by clicking Show
Visual Aid.

Select Heal the layout and specify the required settings.4.
Select Merge shapes touching each other where possible to preserve the edges5.
shared between adjacent shapes.
Select Simplify the layout to generate a conformal mesh containing minimum6.
number of edges. Specify the required settings.
Select Generate and replace shapes on derived layers to enable the processing7.
of derived layers.
Select Save Preprocessor Messages as a DRC Result to display the location-8.
bound information and warning messages. Specify the required settings.

 Defining Simulation Settings

You can define the simulation settings for both Momentum and FEM. The simulation
process combines the Green functions that were calculated for the substrate of a circuit
and mesh information that was calculated for the circuit and solves for currents in the
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circuit. Using these current calculations, S-parameters are then calculated for the circuit.

This section provides information about the following topics:

Defining Simulation Settings for Momentum
Defining Simulation Settings for FEM

 Defining Simulation Settings for Momentum

You can select the matrix solver used by Momentum during a simulation. Momentum
provides the following matrix solvers:

Auto-select: If you select the Auto-select solver, Momentum automatically selects
the most appropriate matrix solver. It is the default matrix solver selection option.

Direct Dense: If you select Direct dense, Momentum selects the direct dense
matrix solver for a simulation. This implies that the matrix is stored in a dense matrix
format (requiring order N2 memory) and solved using a direct matrix factorization
technique (requiring order N3 computer time). The direct dense matrix solver
guarantees to provide a solution using a predetermined number of operations. The
main disadvantage is that the computer time it requires scales qubic with the matrix
size N, yielding larger simulation times for large problem sizes.

Iterative Dense: If you select Iterative dense, Momentum selects the iterative
dense matrix solver for a simulation. This implies that the matrix is stored in a dense
matrix format (requiring order N2 memory) and solved using an iterative matrix solve
technology (requiring order N2 computer time). The computer time scales quadratic
with the matrix size N, yielding faster simulation times for large problem sizes when
compared to the direct dense matrix solver. The main disadvantage is that the
iterative solver does not guarantee to converge fast. The iterative solver monitors its
convergence rate and automatically switches to the Direct dense matrix solver
when it observes that the convergence stagnates or the convergence rate is too slow.

Direct Compressed matrix solver: When selecting Direct compressed,
Momentum selects the direct compressed matrix solver to be used in the simulation.
This implies that the matrix is stored in a compressed matrix format (requiring order
NlogN memory) and solved using a direct compressed matrix factorization technique
(requiring order (NlogN)1.5 computer time). The direct compressed matrix solver
guarantees to always provide a solution using a predetermined number of operations.
Moreover, the computer time it requires scales linear-logarithmic with the matrix size
N, making it the preferred matrix solver for large problem sizes.

 Specifying Simulation Settings for Momentum

To set the simulation options for Momentum:

Select EM > Simulation Setup to open the EM Setup window.1.
Select Momentum RF or Momentum Microwave as the EM simulator.2.
Choose Options in the left pane of the EM Setup window.3.
Select the Simulation tab, as shown in the following figure.4.

Select the matrix solver from the Matrix solver method drop-down list.5.
Enable or disable the Port Solver option as per your requirements.6.

 Defining Simulation Settings for FEM

You can select the following types of matrix solver methods for FEM:

Direct:When selecting Direct, the FEM Simulator chooses the direct sparse matrix
solver to be used in the simulation.

Iterative: When selecting Iterative, FEM Simulator chooses the iterative sparse
matrix solver to be used in the simulation. There is a choice between two iterative
solvers. The default iterative solver is multithreaded and yields better performance,
particularly for larger designs. The legacy iterative solver (single-threaded) is also
available, as this solver typically requires less memory (up to a factor 2).

The following simulation settings are available when clicking the Advanced button

The selection of the legacy iterative solver.

Maximum Number of Iterations: Specify the maximum number of iterations
allowed during the iterative solve process. This value is increased to achieve a lower
absolute tolerance. Typically a value 500 is sufficient.
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Tolerance iterative solver: Specify the absolute error tolerance that the solver
process must reach to achieve convergence. A typical value would be 1.0e-5. You
may need to increase the Maximum Number of Iterations if you significantly decrease
the tolerance.

 Specifying Simulation Settings for FEM

To set the simulation options for FEM:

Select EM > Simulation Setup to open the EM Setup window.1.
Select FEM as the EM simulator.2.
Choose Options in the left pane of the EM Setup window.3.
Select the Simulation tab.4.
Select a matrix solver from the Matrix solver method drop-down list.5.
Select the Advanced tab to specify advanced simulation settings for FEM, as shown6.
in the following figure:

Specify the Maximum Number of Iterations value.7.
Specify the Tolerance iterative solver value.8.
Select the Use Legacy Iterative Solver option to use the single-threaded iterative9.
solver. Deselect the option to use the multi-threaded iterative solver.

 Overriding Substrate Definition for FEM

You can override the substrate definition at the global or layer-specific level. You can also
specify advanced substrate options for FEM simulations.

This section provides information about the following topics:

Specifying Global Options
Specifying Layer-specific Options
Specifying Advanced Options

 Specifying Global Options

To specify physical model settings globally:

Choose EM> Simulation Setup to open the EM Setup window.1.
Select FEM as the EM simulator.2.
Select Options in the left pane of the EM Setup window.3.
Select the Physical Model tab.4.
Ensure that the Global subtab is displayed, as shown in the following figure:5.

Select a value from the Model Type for Metals drop-down list.6.
Type a value in the Substrate Lateral Extension text box and select a unit.7.
Type a value in the Substrate Vertical Extension text box and select a unit.8.
Select a value from the Substrate wall boundary drop-down list.9.
Select Merge adjacent layers with same material properties.10.

 Specifying Layer-specific Options

To define substrate overrides for a specific layer:

Choose EM> Simulation Setup to display the EM Setup window.1.
Select FEM as the simulator.2.
Select Options in the left pane of the EM Setup window.3.
Select the Physical Model tab to display the substrate options that you can specify4.
for FEM.
Select the Layer Specific subtab to override substrate at the layer level.5.

Select a value from the Model Type for Metals drop-down list in the required layer.6.

 Specifying Advanced Options

Choose EM> Simulation Setup. The EM Setup window is displayed.1.
Select FEM in the Simulator section.2.
Select Options in the EM Setup window.3.
Select the Physical Model tab.4.
Select the Advanced subtab to specify advance options for your FEM simulation.5.

Type a value in the Port Lateral Scale text box.6.
Type a value in the Port Vertical Scale text box.7.
Type a value in the Finite (ground) plane detection factor text box.8.

The Advanced options are used to determine the port surface for calibrated (TML) ports



EM Simulation

73

that are on the bounding box of the geometry.

In the following example, a port has a positive pin on a strip with width W and a negative
pin on a strip or plane that is wider than W and is a vertical distance H below the positive
pin:

The port surface consists of a vertical extension from a distance 'Port VERTICAL scale x H'
above the positive pin until the same distance below the negative pin.
The horizontal extension has a distance span of 'Port LATERAL scale x W' at both sides of
the smallest strip.
The scaling factors are 0 are larger, which means that the minimal port surface is the box
with dimension W x H.
If the scaling factors are large, the port surface can be cropped by the bounding box of
the geometry.

In many occasions, one of the pins, typically the negative or ground pin, is on a strip or
plane that is much wider than the strip on which the other pin, typically the positive pin,
lies.
In such situations, it is normally desired to have this plane as a border of the port surface.
The parameter 'Finite (ground) plane detection factor', is abbreviated to 'f'.
If the widest strip/plane spans a distance of at least f x W at both sides of the smallest
strip, the widest strip/plane is a border of the port surface. This factor does not take care
of the polarity of the pins.
If the positive pin is on the widest strip/plane, the positive pin is on a border of the port
surface. Hence, the brackets around 'ground' in the name of the parameter.
 Overriding Substrate Definition for Momentum

You can either choose the options specified in the substrate or override the substrate
definition. You can override the substrate definition specified earlier by applying the
substrate overrides either globally or on selected layers.

This section provides information about the following topics:

Specifying Global Modeling Options
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Specifying Layer-specific Modeling Options

 Specifying Global Modeling Options

Using the Global tab, you can override the substrate definition on all the layers in a
design. The Global tab enables you to specify the modeling type for thick conductors and
vias. To identify the conductive areas of a layout layer, you can define the model type for
current. The current flow at the surface is modeled depending on the simulation model
chosen. You can choose the following modeling options:

 2D Distributed

You can specify this value for both thick conductor and vias simulation models. For a 2D
distributed value,a distributed model for an object is created based on the surface mesh.
At the vertical side walls, the vertical component of the current is modeled only, using
vertical oriented rooftop functions. Hence, the modeled current distribution of the vertical
component varies both in the cross-section and in the vertical direction (2D current
distribution).

 3D Distributed

You can specify this value for both thick conductor and vias simulation models. For a 3D
distributed value, a distributed model for an object is created based on its surface mesh.
At the vertical side walls, both the horizontal and vertical components of the current are
modeled, using horizontal and vertical oriented rooftop functions. This yields a complete
3D current modeling of the objects.

 Lumped and Wire via model options

A lumped element network represents the via connection. The actual via mesh is ignored
and a single lumped branch, connecting the largest bottom and top cell covering the via
object (or touching in case of an open polyline via), models the via connection.

From ADS 2011.10 release onwards, you can use new options that provide more meshing
flexibility for handling the via structures during the simulation. These options are active
only if you select either the Lumped or the Wire via model. These options enable advanced
via layout simplification and can be chosen for faster simulation of layouts with a large
number of vias. The following figure displays the lumped and wire via options:

The following table describes the new options:

Option Description

Remove the via
outline

Disabling the Remove the via outline option includes via outline in the mesh, which
generates an accurate modeling of the via current flow. If you enable this option, the via
outline is ignored during meshing, which results in a mesh with fewer cells around the via
connections.

Remove pads
not connected
to a trace

Disabling the Remove pads not connected to a trace option includes the via pads in the
mesh, which generates an accurate modeling of the via current flow. If you enable Remove
pads not connected to a trace, the via pads (not connected to a trace) are ignored during
meshing, which results in a mesh with fewer cells.

Remove
antipads within
radius

Disabling the Remove antipads within radius option includes the via antipads (clearances
in the ground plane) in the mesh, which generates accurate modeling of the ground plane
current flow. If you enable Remove antipads within radius, the via antipads within a
radius smaller than the specified number of via radii is ignored during meshing, which results
in a mesh with fewer cells.

Remove
thermal reliefs
within radius

Disabling the Remove thermal reliefs within radius option includes the via thermal
reliefs in the mesh, which generates accurate modeling of the via current flow. If you enable
Remove thermal reliefs within radius, the via thermal reliefs within a radius smaller than
the specified number of via radii is ignored during meshing, which results in a mesh with
fewer cells.

If you convert a project from an older ADS version, the wire vias options are disabled, by default.
Therefore, results are same in the original project and the converted workspace.

 Guidelines for Lumped and Wire Via Models

The lumped and wire via models are subject to the following restrictions:

Vias that are strictly partially connecting to a pad, trace, or plane cannot be
simulated using a lumped or wire model. You can use the 3D Distributed model for
simulation.
Via shapes where center is outside the shape uses the 3D Distributed model for
simulation.
Via outlines can only be removed from the mesh if they stay clear of other outlines.
No current can flow in a lumped or wire via stub having an unconnected end. For
example, if an outer pad is removed, current cannot flow in a lumped or wire via.
Such vias are automatically discarded.
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 Defining Engine-specific Modeling Options

To specify physical model definition globally:

Choose EM> Simulation Setup to open the EM Setup window.1.
Select Options in the left pane of the EM Setup window.2.
Click the Physical Model tab.3.
Ensure that the Global tab is displayed, as shown in the following figure:4.

Select a value from the Thick Conductor drop-down list.5.
Select a value from the Via drop-down list.6.
Select the required lumped and wire via model options.7.

 Specifying Layer-specific Modeling Options

To specify physical model definition for a specific layer:

Select EM> Simulation Setup to open EM Setup window.1.
Select Options in the left pane of the EM Setup window.2.
Click the Physical Model tab.3.
Click the Layer Specific tab, as shown in the following figure.4.

Select a value from the Model Type for Currents Thick Conductor drop-down list5.
in the required layer.
Select a value from the Model Type for Via drop-down list in the required layer.6.
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 Selecting the Calibration Type
You should select the calibration type based on the type of circuit component you want to
connect to the port in the schematic. You can select TML and TML (zero length) calibration
only for the S-parameter ports that have associated layout pins located at an edge of the
structure. You can select SMD and Delta gap only for S-parameters ports that have two
associated layout pins located at the edges of a gap in the structure. For S-parameter
ports which have at least one associated layout pin inside the structure, None is the only
option that can be selected as calibration type. Depending on your circuit component, you
can select the following types of calibration:

TML: Connects a transmission line component.
TML(zero length): Connects a lumped component.
SMD: Connects a 2-pin SMD component (model includes parasitics).
Delta gap: Connects a 2-pin SMD component (model does not include parasitics).
None: If none of the available calibration types is valid for the connecting
component, specify None.

 Selecting TML Calibration

If you select the TML calibration, Momentum automatically adds a transmission line feed
line to the port. A source is added at the end of the feed line to excite the structure. The
parasitic effect of the feed line and the open-end at the end of the feed line are
automatically removed from the simulated S-parameters. In case the feed line overlaps
with another object in the layout, the port calibration type will be changed to 'TML (Zero
Length)'. A warning message will be issued indicating the change.

Within an FEM simulation, the TML calibration results in a waveguide port definition. FEM
will only interpret TML ports when they are at the boundary of the simulation domain, if
not the FEM simulator will automatically translate the TML port to a non-calibrated port
and issue a warning.

 Selecting TML (Zero Length) Calibration

If you select the TML (zero length) calibration, Momentum directly adds a source at the
port to excite the structure. The parasitic effect of the open-end at the port is
automatically removed from the simulated S-parameters.

Note
For FEM, a TML (Zero Length) calibration is the same as a TML calibration line.

 Selecting SMD Calibration

If you select the SMD calibration, Momentum automatically adds two feed lines to the two
layout pins of the port. A source is added over the delta-gap connecting the two feed
lines. The parasitic effect of the feed lines is automatically removed from the simulated S-
parameters. SMD calibration should be used for connecting with a 2-pin SMD component
whose model includes parasitics.

Note
While performing an FEM simulation, the SMD ports are treated as uncalibrated sheet ports and the
reference offset specification is ignored. This means that in the FEM simulation model, the gap between
the pins of the SMD port will contribute to an inductive effect in the resulting S-parameter model, unlike
Momentum.

 Selecting Delta Gap Calibration

if you select the Delta gap calibration, Momentum automatically adds two feed lines to the
two layout pins of the port. A source is added over the delta-gap connecting the two feed
lines. The parasitic effect of the feed lines is not removed from the simulated S-
parameters. You should use Delta gap calibration for connecting with a 2-pin SMD
component whose model does not include parasitics.
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Note
While performing an FEM simulation, the Delta Gap ports are treated as uncalibrated sheet ports. The
inductive effect of the gap between the pins of the Delta Gap port is included in the resulting S-parameter
model, and this setup therefore behaves the same way as the Momentum Delta Gap source.

 Selecting the Reference Offset

The calibrated ports enable you to shift the location of the reference lines used for the S-
parameters. You can select the following types of reference offsets:

Specifying a positive reference offset: Shifts the reference planes in the direction
towards the circuit, as shown in the following figure:

Specifying a negative reference offset: Shifts the reference planes in the direction
away from the circuit, as shown in the following figure:

 Why Use Reference Offsets?

The need to adjust the position of ports in a layout is analogous to the need to eliminate
the effect of probes when measuring hardware prototypes. When hardware prototypes are
measured, probes are connected to the input and output leads of the Device Under Test
(DUT). These probes feed energy to the DUT, and measure the response of the circuit.
However, the measured response characterizes the entire setup, that is, the DUT plus the
probes. This is an unwanted effect. The final measurements should reflect the
characteristics of the DUT alone. The characteristics of the probes are well known, so
measurement labs can mathematically eliminate the effects of the probes, and present the
correct measurements of the DUT.

There are significant resemblances between this hardware measurement process and the
way Momentum and FEM operate. In the case of Momentum and FEM, the probes are
replaced by ports, which, during simulation, will feed energy to the circuit and measure its
response. The port feeding scheme also has its own, unwanted effect: low-order mode
mismatch at the port boundary, although this is eliminated by the calibration process.

However, for a calibration process, it is necessary that the fundamental mode is
characterized accurately. This can only be accomplished when the distance between the
port boundary and the first discontinuity is sufficiently large, that is, there exists a feed
line that is long enough to provide this distance.

As a basic example, consider a line width that varies abruptly in some part of your circuit,
as shown in the following figure:

You need to characterize only the variation of the step-in-width itself, as shown in the
following figure:

As mentioned previously, it takes a little distance for the fundamental mode to settle,
which means that this short structure might not yield the accuracy that you expect from
the simulation. In this case, allow for some feed line length, as shown in the following
figure:

Now, the simulation will yield accurate results, but the results will also contain the extra
line lengths. To resolved this issue, use reference offsets. Although, the circuit has been
calculated with the long lines, reference offset shifting allows you to produce the S-
parameters as if the short structure had been simulated instead, as shown in the following
figure:

The effect of the extra feed lines is mathematically eliminated from the S-parameter
solution. This process of adding or subtracting line length is generally referred to as de-
embedding. During the solution process, the impedance and propagation constant has
been calculated for the ports, based on their physical location in the circuit. When you
know the impedance, propagation constant, and the distance of de-embedding, you can
cancel out the extra lengths of line from the S-parameter results, by compensating for the
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loss and phase shifts of those lines. The net result is a set of S-parameters, calculated as
if the extra line lengths were not there.

 De-embedding Considerations

It is possible to de-embed up to the discontinuity itself. However, make sure that you do
not shift the reference offset beyond the first discontinuity. This would yield incorrect
simulation results, as there is another line width beyond that discontinuity, which means
that there is another set of impedance and propagation values that applies there.

Note
You can de-embed away from the circuit, by placing reference offsets beyond the edges of the layout. This
enables you to simulate the effect of a long feed line that was not drawn in the simulated structure.

 S-parameter Port Grouping

The calibration process automatically groups S-parameter ports with terminals attached to
layout pins that share a common reference plane. The following figure displays a grouped
port:

 Momentum Source for Port with TML Calibration

In Momentum, there are two different lumped sources used in the TML calibration process
to feed the circuits with calibration lines: a grounded source and a floating source. The
grounded source works well for low frequencies, however at higher frequencies, when the
port-ground distance becomes electrically large, this source provides less accurate results
due to unwanted substrate coupling in the calibration process. The floating source works
well at higher frequencies (unwanted substrate coupling is reduced), however it fails at
low frequencies because the capacitive internal impedance of the source blocks the flow of
the low frequency currents. The default behavior in Momentum is an automatic switching
between these two sources, depending on the frequency range of the simulation.

The source type can be explicitly controlled using the following environment variable:
MOM3D_USE_SOURCETYPE=0 (grounded, low frequency calibration source)
MOM3D_USE_SOURCETYPE=1 (floating, high frequency calibration source)

This variable can be set in either of these locations:
$HPEESOF_DIR/custom/config/momentum.cfg
$HOME/hpeesof/config/momentum.cfg
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 Generating EM Model and Symbol
An EM Model is used by a circuit simulator to model a component by using the S-
parameters generated by an EM simulation. The EM-based S-parameters can be
precomputed or you can generate them while running the circuit simulation. An EM Model
caches the S-parameters to improve circuit simulation performance. For more information
about how to use an EM model, see Using an EM Model (em).

A symbol is used to represent the component in a schematic. Symbols are stored in
symbol views and must be created before they can be used. For more information on
symbols, refer to Working with Symbols (usrguide).

You can generate an EM model and symbol by using the EM Setup window.

 Generating an EM Model

To create an EM model:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Model/Symbol in the left pane of the EM Setup window.2.

Type a name for the EM model.3.

The default name for an EM Model is emModel. It is recommended to use the default name unless
you are using model polymorphism.

Do not select Include S-Parameter data only, if you want to store all EM4.
simulation files with the EM model. For example, all log files are stored in the EM
model directory. It will also allow you to perform post-processing operations on the
EM Model in case you specified to save the currents (Momentum) or fields (FEM) in
the Output plan tab.
Select Create EM model when simulation is launched to create an EM model5.
after the simulation process.
To generate an EM model immediately, click Create Now.6.

Note
If the Create Now button is labeled Update Now, then the EM Model already exists for this cell.

The following figure displays an EM model:

You can also generate an EM model by selecting EM > Component > Create EM Model
and Symbol. To know more about an EM Model, refer to Using an EM Model (em).

 Customizing the EM Model Naming Convention

You can customize the naming convention of the EM model generated during a simulation
by adding a prefix or suffix to the data name. To generate the EM model with the required
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naming convention, you need to specify the following parameters in the EM Setup dialog
box:

Specifying the EM model name: You can specify the EM model name in the Name
field.
Appending customized text to the EM model name: If you want to include customized
text with the EM model name, select Append text to the name. You can customize
the data name as follows:

Adding text from the layout view: Select the View name option in the From
the layout view section to add text from the layout view.
Adding text from the simulation setup view: Select View name in the From the
simulation setup view section to add text from the simulation setup view. You
can also include the type of simulator in the EM model name by selecting
Simulation Type.
Adding user-defined text: You can add a suffix to the EM model name in the
This text field.

To customize the EM model name:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Model/Symbol in the left pane of the EM Setup window.2.
Specify the EM model name in the Name field.3.
Select Append text to the name, as shown in the following figure:4.

Select View name in the From the layout view section.5.
Select View name in the From the simulation setup view section.6.
Select Simulation Type.7.
Add a suffix to the EM model name in the This text field.8.

 

 Generating Symbols

A symbol is used to represent the component in a schematic. Symbols are stored in
symbol views and must be created before they can be used.

The symbol created can either be a black box or a layout look-alike symbol.

A layout look-alike symbol for which the symbol shape is a scaled copy of the layout.

A black box symbol with a generic rectangular shape.

A symbol pin will be created for each layout pin. The name and number of the symbol pin
gets copied from the layout pin. Optionally, an extra reference pin can be added.

Note
The symbol pins netlist versus ascending pin number. An EM Model does the same, refer to Using an EM
Model (em).

 Scaling of the Layout Look-alike Symbol

You can scale the look-alike symbol in the following ways:

Setting the minimal pin-pin distance in schematic units: One schematic unit
corresponds with the size of most standard two port components such as resistors,
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capacitors, and inductors. Setting the minimal pin-pin distance to one schematic unit
(1 inch) ensures that a component with a given symbol size will fit between two pins.

Setting the maximum pin-pin distance in schematic units: The following figure
illustrates the scaling when the maximal pin-pin distance is set to be equal to one
schematic unit (1 inch).

Mapping the layout unit dimensions to the schematic unit dimensions (recommended
when combining different components in the same schematic page).

When you combine different layout components on a single schematic, a fixed, absolute
scaling factor is the most appropriate choice to ensure that the relative sizes of the layout
components are preserved.

 Adding a Reference Pin

Using the Add Reference Pin check box, you can enable or disable the addition of an extra
reference pin during layout component creation. This "extra" pin is used by EM to provide
a reference voltage for all other pins in the layout and enables you to model ground
effects (e.g., ground bounce, imperfect ground connections, etc.). In the absence of an
explicit Reference Pin, this reference voltage is zero what corresponds with connecting the
Reference Pin to the absolute ground (GROUND component) which gets netlisted as node
0.

The Add Reference Pin selection is only available for the layout look-alike symbol
selection. When selecting black box this option gets enabled (grayed out). Because black
box uses standard symbols, a reference pin will appear in all schematic black box
representations. This can cause problems if you are creating a structure with finite ground
planes and wish to use them in the schematic. In this case, the layout look-alike symbol
with Add Reference Pin disabled is a better choice.
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This option should also be disabled for components intended to be used with the
Schematic > Generate/Update command. This extra pin will cause pin mismatch errors
during design synchronization.

 Creating a Symbol

To create a symbol:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Model/Symbol in the in the left pane of the EM Setup window.2.
In the Symbol section, specify a name for the symbol.3.
Select the symbol type.4.
Specify the symbol size.5.
Select Add reference pin.6.

Click Create Symbol when simulation is launched to create a symbol after the7.
simulation process.
To generate a symbol immediately, click Create Now. The following figure displays a8.
layout look-alike symbol:

Note
If the Create Now button is labeled as Update Now, then a symbol with the given name already
exists. Clicking Update Now updates that symbol from the layout.

There are three other ways to create or update a layout look-alike symbol:

In the layout window, choose EM > Component > Create EM Model and Symbol.

In the EM Setup window, on the Model/Symbol screen, select Update Symbol
when simulation is launched. When this option is selected, every time you run an
EM simulation using this EM Setup, the layout look-alike symbol will be created (or
updated if it already exists).

Using following AEL function:

momSymbol_createLayoutLookAlikeSymbol

(

 layoutContext,       // source context, must be of layout type

 symbolName,          // symbol view name

 symbolSizeType,      // used to determine the scaling factor

                      //  0: minimum pin pair distance becomes <symbolSize> inch

                      //  1: maximum pin pair distance becomes <symbolSize> inch

                      //  2: 1 layout unit becomes <symbolSize> inch

 symbolSize,          // symbolSize in inch!

 addRefPin,           // TRUE|FALSE, add explicit reference pin

 warnOffFlag,         // TRUE|FALSE, no warning/error dialogs will be shown when TRUE

 stopEarlyIfBad       // TRUE|FASLE, early return in case of errors when TRUE

)

There might be some visual differences in between the look-alike symbol you create and
the output displayed in the Layout. These differences are described below:

Look-alike symbol generation in ADS 2011 does not translate the EM simulation
specific layout objects: Box, Waveguide and FEM Symmetry Plane. They are special
layout objects with no equivalent for the schematic environment. You can manually
add a graphical representation to the symbol with the symbol editor if you need to
see these objects in your schematics.

In multi-technology structures, the mapped layers in the top level technology are
used to display features of instances that use a nested technology. Mapped layers do
not automatically take the display properties of the underlying technologies and can
give a very different visual impression. Access the Layer Display Properties of the top
level technology and update the colors of the mapped layers.

The symbol generation flattens the hierarchy and scales shapes. This can distort or
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drop small features.

The background color of Layout and Schematic windows are usually different. This
can change the visual impression of objects on layers that use a fill pattern and/or
transparency.

Layout pins on different layers on the same position are shifted away from each-
other in the symbol because pins are not layer based in the schematic environment.
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 Running EM Simulations
The simulation process generates a mesh for the circuit and solves E-fields in the circuit.
Using these electric field calculations, S-parameters are calculated for the circuit. The
mesh electric field is then refined and new electric fields and S-parameters are computed.
Before running a simulation, the following criteria must be met:

A substrate definition must be specified for the circuit.
The circuit must include at least one port.
The mesh is automatically calculated when you simulate.
A simulation frequency plan must be specified.

If any one of the above criteria is not met, an error is generated if you try to run a
simulation.

 Starting an EM Simulation

To start a simulation:

Choose EM > Simulation Setup.1.
In the EM Setup window:2.

Verify that at least one frequency plan appears in the Frequency Plans list.
Check that the Process Mode, Solution Files, and Data Display options are set to
your specifications.
Check whether the simulation mode is set to local machine.

Click Simulate in the EM Setup window or press F7. A data display opens3.
automatically to display the results.

 Viewing Simulation Status

When you start a simulation, new job entry is created in the Job manager. For more
information, refer to the Using the Job Manager (em) document. If the simulation has to
wait in a Job Manager queue, the new entry in main Job Manager window is displayed. You
can double-click this entry to open a detailed log window. If the simulation does not need
to wait, the log window is immediately displayed, which displays the simulation status and
simulation messages. Messages usually refer to any errors found, the percent of
completion (refer to Understanding the "% Covered" Status Message) and simulation
completion. If you close the log window and want to reopen it, double-click the job entry
in the main Job Manager window. To open this window from a layout window, choose
Window > Simulation Status.

To indicate progress, a progress bar appears at the bottom of the log window, if the
number of unknowns in the simulation is greater than 500; otherwise, only the
frequencies are displayed. If a simulation fails due to setup related issues, partial data is
saved and a message appears in the log window.

 Understanding the "% Covered" Status Message

This message is generated when running Adaptive sweep types. It indicates the
percentage of the total simulation frequency range that has been accurately modeled by
rational functions. When an Adaptive sweep starts, the AFS process attempts to represent
all S-parameters with a number of rational functions. New sample points are selected
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adaptively (by minimizing global error criteria). If the frequency range is too large, the
frequency range will be split into sections. If the fitting model is accurate and stable within
a subrange, the "% covered" message will be updated. Thus, the message indicates the
percentage of the total simulation frequency range that has been accurately modeled by
rational functions.

 Stopping an EM Simulation

To stop an EM simulation, choose EM > Stop and Release Simulator. Alternatively, the
simulation can be stopped using Job > Stop/Cancel Job in the Using the Job Manager
(em).

 Viewing the Simulation Summary

As a simulation progresses, you can view solution statistics. Some of the information
returned includes time to solve, the resources required, mesh information, and any
messages that were displayed in the status window.

Choose EM > Show Most Recent and select one of the following option to view the
required data:

Momentum Mesh
S-Param Simulation Summary
Mesh Generation Summary
Geometry Preproc Report
Substrate Generation Summary

The following example shows a (partial) summary displayed when using the Momentum
Microwave simulation mode.

Clicking Refresh updates the statistics for a simulation. However, this option is applicable
only for local and remote EMX simulations.
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 Viewing Simulation Summary
During a simulation process, you can view the statistics of momentum mesh, S
parameter, substrate, mesh, and geometry statistics. The simulation summary includes
time to solve, the resources required, cell information, and any messages that were
displayed in the status window. You can view the following types of summary for an EM
simulation:

Momentum mesh
S-param simulation summary
Mesh generation summary
Geometry preproc summary
Substrate generation summary

 

 Viewing Momentum Mesh

You can view the momentum mesh by selecting EM > Show Most Recent > Momentum
Mesh. The mesh view is selected in the circuit, as
shown in the following figure:

You cannot view FEM mesh.

 Clearing a Mesh

You can delete the view of the mesh from the circuit. Clearing a mesh only deletes the
view from the Layout window; it does not erase mesh calculations.

To remove the mesh from the display:

1. Choose EM > Clear Momentum Mesh.
2. If you want to redisplay the mesh, choose Edit > Undo. Otherwise, you have to
compute the mesh again.

You cannot delete the mesh view of an FEM simulator.

 

 Viewing S-param Simulation Summary

You can view the S parameter simulation summary by selecting EM > Show Most
Recent > S-Param Simulation Summary. The EM Simulation Summary window is
displayed. The following example displays a summary window for the Momentum
microwave simulation mode.
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In the EM Simulation Summary window, you can view information about the matrix size
after mesh reduction and the statistics for quasi-static calculations. The user time and
elapsed time values are listed as separate entries in the Summary window. The elapsed
time represents the overall time taken for completing the simulation, while user time only
presents the time taken by the CPU to complete the calculations. Therefore, if the CPU
exclusively works only on the simulation, the user time and elapsed time values are equal.

If the mesh computation process is successful, you can view the following mesh statistics:

The number of rectangular cells in the structure
The number of quadrangular cells in the structure
The number of triangular cells
The number of via cells
The number of edge currents
Simulation setup information

For an FEM simulation, you can view information about the frequency, meshing time, and
simulation time. The following figure displays the S-param summary for an FEM
simulation:

 

 Viewing Mesh Generation Summary
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You can view the generated mesh statistics by selecting EM > Show Most Recent >
Mesh Generation Summary. The Mesh Summary window is displayed. The following
example displays the summary window for the Momentum microwave simulation mode.

In the Mesh Summary window, you can view the following mesh statistics:

Number of Quadrilateral cells
Number of triangular cells
Number of via cells
Number of edge currents
Computer resources used and time to solve
User Time and Elapsed Time

 

 Viewing Geometry Preproc Summary

You can view the layout processing report by selecting EM > Show Most Recent >
Geometry Preproc Summary. The Layout Processing Report window is displayed.
The following example displays a summary window for the Momentum microwave
simulation mode:

This summary window provides information about the minimum snap distance used for
layout healing and frequency of mesh generation.

 

 Viewing Substrate Generation Summary

You can view the substrate summary by selecting EM > Show Most Recent > Substrate
Generation Summary. This displays the Substrate Summary window. The following
example displays a summary window for the Momentum microwave simulation mode:
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This summary window provides information about the process size, user time, and elapsed
time.

The FEM simulator does not provide any substrate summary information.
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 Viewing 3D Simulations
Using the EM visualization feature, you can view and analyze the following types of
simulation data:

S-parameters
Currents
far-fields
Antenna parameters
Transmission line data

 Starting an EM Visualization

Before using the visualization feature, you should complete the simulation process. After
simulating your design, choose EM > Post-Processing > Visualization to open the

Visualization window. You can also open this window by clicking Visualization  in the
EM toolbar. The following figure displays a Visualization window:

The Visualization window controls the display of the individual mask layers, substrates,
and port boundaries. In the Visualization window, the left pane contains the basic controls
for the view in the docking widget.

This section provides information about the following topics:

Visualizing 3D View before EM Simulations (em)
Visualizing Momentum Simulations (em)
Visualizing FEM Simulations (em)
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 Visualizing 3D View before EM Simulation
Before simulating a design, you can validate your three dimensional design in the 3D
Preview window. The representation seen in the 3D Preview window consists of the same
definition that will be used in the EM simulator. If a view is incorrect in the Preview
window, it is essential to redesign before attempting a simulation. The following figure
displays a 3D Preview window:

The key benefits of this visual confirmation are:

Correct Substrate Set Up: The substrate information within ADS is defined by using
the Substrate menu options, which help you to define the height of each substrate
and assign the corresponding layers. The Previewer window enables you to validate
that correct height and mappings are specified for your design.

Correct Bondwire and Dielectric Brick Placement: Bondwires, which are described in
the schematic window of ADS, are mapped to the ADS layout and incorporated into
the overall FEM design for simulation. Dielectric bricks are defined as part of the
substrate definition. Since these portions of the design are difficult to see in layout,
you can use the Previewer window to validate the location and design of bondwires.

You can create the following types of 3D views:

Layout View: Select View > 3D View > All to generate a 3D view of the layout
without any EM pre-processing. This is the fastest way to generate a 3D view. You do
not to create an EM Setup view for generating the 3D view from layout. The first
substrate found in the library will be used.

Momentum Simulator View: Click the 3D EM Preview icon  from the EM
toolbar, EM menu, or EM Setup window with Momentum specified as simulator type
to generate a 3D view that displays the design in 3D as seen by Momentum,
including any specified pre-processing operations.

FEM Simulator View: Click the 3D EM Preview icon  from the EM toolbar, EM
menu, or EM Setup window with FEM specified as simulator type to generate a 3D
view that displays the design in 3D as seen by FEM, including any specified pre-
processing operations.

 Validating Your Geometry Visually

You can validate a geometry by opening the 3D Preview window in a layout. Before
reviewing your design, you need to start the previewer regularly, as it does not
synchronize with the current ADS layout.

Note
It is recommended that you do not keep more than one instance of the previewer open at a time. It will
not interfere with the data, however, it may be confusing and cause an unnecessary error.

The previewer window contains a dockable widget that controls the display of the
individual mask layers, substrates, and port boundaries. Upon startup, a dockable widget
is docked on the left-hand side of the previewer, as shown in the following figure:
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 Navigating in the 3D Environment

You can perform the following tasks in the 3D Preview window:

Rotating the view: You can rotate a design around its current origin by holding

down the main mouse button and moving it around the screen. Click Orbit ( ) on
the toolbar or choose Window > Orbit to rotate a view.

Modifying the zoom settings: You can increase or decrease the zoom settings on a
design by moving the mouse up or down on the image respectively. Click Zoom (

) on the toolbar or select Window > Zoom to modify zoom settings.

Moving the design: You can move the design around on the screen by holding

down the main mouse button and moving it around the screen. Click Pan ( ) on
the toolbar or select Window > Pan to move a design.

Opening the standard view: You can change the view of a design to the standard

view settings. Click Zoom to Extents ( ) on the toolbar or select Window >
Zoom to Extents to open the standard view for your design.

Modifying the zoom settings of a specific area: You can zoom to a specific area
of your design by placing a box around the desired view. Click Zoom to Window (

) from the toolbar or select Window > Zoom to Window to change the zoom
settings.

Changing Views: You can open your design in various types of standard views by

clicking Front ( ), Back ( ), Top         ( ), Bottom ( ), Left-side ( 

), Right-side ( ), and Isometric ( ). You can also access these views from
the View menu.

Querying the design: You can click an object edge or vertex to display the location
and object name in the status bar, which is located in the lower right hand section of
the window. In addition, the object is highlighted and the object is automatically
selected in the Object and Material tabs in the Docking widget. Visually, a solid dot is
placed if the selected location is on a vertex and a hollow dot is placed if the selected

location is on an edge. Click Query ( ) or select Tools > Query to run a query.

 Specifying Material and Object Settings

In the 3D Preview window, you can control the material and object settings by using the
Properties window. Click  to separate the Properties window from the 3D Preview
window. To include the Properties dialog box, double-click the Properties title bar. The
following figure displays the Properties window:
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In the Properties window, you can:

Select the required material and object.
Control the visibility and shading settings for all the materials and objects.
Modify the color settings for a material or object.
Restore the color settings for a material or object.
Control the transparency settings.

The following sections provide information about how to select and highlight materials and
objects.

 Selecting Materials and Objects

You can select and highlight individual objects by using one of the following methods:

Selection on the screen: Objects can be selected graphically using the mouse. If the
previewer is in Query mode, an object can be selected by clicking on any line or
vertex of the object. Once selected, the object lines are highlighted. The object is
also selected in the material and object list and the coordinates of the selection point
are displayed in the lower right area of the status bar.

Selection from the material or object list: Objects can be selected from either the
material or object list box. Once selected, the object lines are highlighted.

 Controlling the Visibility and Shading of Selected Objects and Materials

After selecting an object or material, you can control the visibility and shading by using
the Materials and Objects tab, respectively. You can select the Visibility and Shading
fields associated with a material and object to control the visibility and shading, as shown
in the following figure:

It is also possible to control the visibility and shading for the substrate and mask layers.
Within the Materials portion, each material and object has separate toggles for visibility
and shading. By setting these controls appropriately, you can control the visibility and
shading for all the objects that share this substrate or mask.
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 Controlling the Visibility and Shading of All Objects and Materials

You can control the visibility and shading of all the objects and materials by using the All
and None buttons, as shown below:

In the Visible area:

Click All to apply visibility to all the objects and materials.
Click None to make all the objects and materials invisible.

In the Shaded area:

Click All to apply shading to all the objects and materials.
Click None to remove shading from all the objects and materials.

To set the transparency level for objects and materials, specify the transparency level on
the range of 0 to 100 percentage.

 Selecting Color

You can select, change colors, and highlight specific areas in your design. For example, to
highlight the free space:

Click the check boxes associated with "Free_Space" from the 3D object tree.1.

Click Color to open the Select Color dialog box.2.

Select a color and click OK.3.
You can revert the original color by clicking Restore.4.

 Customizing the Simulation View

Measuring distances: You can measure the distance between a reference point and
the current query point. The query point is updated after every mouse selection using
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the query command. The reference point remains fixed until it is explicitly updated
using the Move Current Point to Reference. Select Tools > Measure to open the
Measure dialog box:

Z-Scaling: You can change the geometry dimension of a model in the z-direction
using a sliding scale between 1 and 10. If you
move the dimension value of the slide bar up, the model is expanded in the z-
direction. Select Tools > Z Scale to open the z-scale dialog box.

Cutting Plane: This feature enables you to slice through your design in the YZ, XZ,
and XY planes. The check boxes associated with each slide bar activate the cut. It
allows you to flip the cut and to show the plane as it moves through the design.
Selecting Tools > Cut Plane opens the Cut Plane window, as shown below:

Viewing 3D Connectivity: You can select the required object and choose Tools >
View 3D Connectivity.

Viewing Object Statistics: You can view detailed information about the 2D and 3D
object parameters such as substrate layer, mask, and top statistics.
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 Setting Up the Viewer on External X Window Displays

On Unix/Linux Systems, it is common practice to use a local machine as a display and do
the actual processing on another machine. The display from the original machine is
typically mapped back to the local display using the following command:

export DISPLAY=machine:0.0

In the 3D Previewer window, you need to set an additional environment variable,
HOOPS_PICTURE. This environment variable is set to the same value as the display
variable with the addition of X11/ prior to the machine name. Using the above example,
the HOOPS_PICTURE variable is set to the following values:

export HOOPS_PICTURE=X11/machine:0.0
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 Visualizing Momentum Simulations
You can view and analyze the following type of data for Momentum simulations:

S-parameters
Currents
far-fields
Antenna parameters
Transmission line data

 Starting Momentum Visualization

You must complete the simulation process to view data for a Momentum design. If you
have already simulated a design, you can start the Visualization feature directly to view
the existing data. Select EM > Post-Processing > Visualization to open the Agilent
Momentum Visualization window. You can also open this window by clicking

Visualization ( ) in the EM toolbar.

To visualize Momentum simulations:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Momentum RF or Momentum Microwave in the EM Setup window.2.
Specify the required settings in the EM Setup window for a layout, substrate, port,3.
frequency plan, output plan, options, resources and model or symbol.
Click Simulate in the EM Setup window to simulate your design.4.
Select EM > Post-Processing > Visualization to open the Agilent Momentum5.
Visualization window, as shown in the following figure:

The Agilent Momentum Visualization window appears similar to the EM Previewer window.
The initial window layout is similar to that of EM Previewer. The left side contains the basic
controls for the view in the docking widget. However, the Agilent Momentum Visualization
window includes the following modifications:

EM Port surfaces are no longer displayed.
Object shading is removed.
A shaded current plot for Port 1 at the lowest frequency is displayed.
In addition to the Properties tab, Solution Setup and Plot Properties tabs are added
for controlling the view.

In the Agilent Momentum Visualization window, the Properties tab provides the same
functionality as the EM Previewer properties tab. However, in the Agilent Momentum
Visualization window, you can also display mesh by selecting the Mesh Visible check box
in the Properties tab, as shown in the following figure:

Note
For more information about the Properties tab, refer to Visualizing 3D View before EM Simulations (em).

You can plot the field quantities by using the Plot Properties and Solution Setup tabs.
The Solution Setup tab controls the excitations for the visualization, while the Plot
Properties tab controls the visual display of the excitation.
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 Controlling Visualization Excitations

The Solution Setup tab is used to select the current excitation for the plots. All the plots
automatically reflect the current solution configuration once it is selected. By selecting
either a port or frequency, the excitation is changed and the plots are automatically
updated.

In the Agilent Momentum Visualization window, select the Solution Setup tab
present at the bottom of the window. In this tab:

Define the port excitation value from the drop-down list in the Port Setup region.
You can either select Single Mode Excitation for ports to be excited individually or
Multiple Mode Excitation.
View the frequency changes in the Frequency region. After the port or frequency
selection is changed, the plots are automatically updated using the new
configuration.

The following figure displays a Solution Setup tab:

 Plotting Properties

The Plot Properties tab enables you to control the three basic plots, as well as, the
animation settings. This tab is used to set up plots within the visualization tool. The
visualization tool plots J, which is the current calculated within the Momentum solvers, as
shown in the following figure:
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Using the Plot Properties tab, you can create the following types of plots:

Shaded Plot
Arrow Plot
Contour Plot

 Displaying a Shaded Plot

Displaying the shaded current plot is controlled by using the check box next to the plot
name. When it is selected, the plot is visible. Within the plot there are some basic
controls:

Log Scale - This controls whether the scaling and color representation uses a
logarithmic scale or a linear one.
Transparency - This controls the transparency of the shaded plot.

 Displaying an Arrow Plot

After selecting the Arrow tab, select Enable to display the arrow plot. You can control the
following properties of an arrow plot:

Scaling arrows: You can select the Scale check box to control whether the arrows
are scaled, based on the relative magnitude of the current density through out the
design. When it is selected, the arrows will be scaled, making the lower current
density areas have smaller arrows. If it is not selected, all the arrows are displayed
with the same size. However, their size can still be changed by changing the arrow
size.

Using a logarithmic scale: You can select the Log Scale check box to control whether
the scaling and color representation use a logarithmic scale or a linear one. If scaling
is not enabled, only the color weighting is affected.

Specifying arrow size: You can specify the relative size of the arrow in Arrow Size.
Remember that if the arrows are not scaled, the default size of the arrows appear to
be larger than when the arrows are scaled.

 Displaying a Contour Plot

After selecting the Contour tab, select Enable to display the contour plot. You can control
the following properties of a contour plot:

Using a logarithmic scale: You can select the Log Scale check box to control whether
the scaling and color representation use a logarithmic scale or a linear one. If scaling
is not enabled, only the color weighting is affected.

Specifying the number of divisions: You can specify the number of divisions in the
Divisions combo box.

 Modifying Plot Options

You can modify the plots by using the options menu in the Plot Properties tab. The options
menu displays the color key for the plot and can also be used to change the Minimum and



EM Simulation

100

Maximum values that are being plotted. The color used for the plot can also be specified
from the Options dialog box.

System Min and System Max: The system minimum and maximum values represent the
minimum values for all the plots that are currently being drawn. However, in order to
keep scale consistently , maximum and minimum values are not changed when the
Solution Setup is modified. The maximum and minimum values are displayed as System
Max and System Min. If the user wishes to use these values instead, he can use them by
selecting the Restore Max and Min button.

Similarly, the user can modify the maximum and minimum values that are used for
displaying the data by typing in new values. These will not be changed as the Solution
Setup is modified.

X and Y Arrow Density control the density of arrows within a sensor. They have no effect
on Object Surface Sensors.

 Animating Momentum Fields

You can animate Momentum fields by selecting Animate at the bottom of the Plot
Properties tab. You can also change the phase by sliding the Phase Bar, as shown in the
following figure:

You can control the following animation options of arrow, shaded, and contour plots:

Determine the display update time: Specify a value in the Display Update text box
to determine the minimal time required between display updates in milliseconds.
Since some updates may take longer than this setting, this value is only a minimum
number and not an absolute one.

Determine the Phase Increment value: Specify a value in the Phase Increment text
box to control the number of degrees added to the current phase when an update
occurs.

 Plotting Momentum Mesh

When a solution has been loaded, the momentum mesh can be displayed by checking the
Mesh Visible box on the Properties Tab. The displayed mesh is the one which is used to
display the field. This will most likely be more detailed than the one seen in the Layout
View, which is the reduced mesh that is used in the Momentum solution computation.
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 Visualizing FEM Simulations
You can view and analyze the following type of data for FEM simulations:

E Fields
Far-fields
Antenna parameters
Transmission line data

 Starting FEM Visualization

You must complete the simulation process to view data for your FEM design. If you have
already simulated a design, start the Visualization feature directly to view the existing
data. Select EM > Post-Processing > Visualization to open the Agilent FEM

Visualization window. You can also open this window by clicking Visualization ( ) in
the EM toolbar.

To visualize FEM simulations:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select FEM in the EM Setup window.2.
Specify the required settings in the EM Setup window for a layout, substrate, port,3.
frequency plan, output plan, options, resources and model or symbol.
Click Simulate in the EM Setup window to simulate your design.4.
Select EM > Post-Processing > Visualization.5.

The Agilent FEM Visualization window appears similar to the EM Previewer window. The
initial window layout is similar to that of an EM Previewer. The left side contains the basic
controls for the view in the docking widget. However, the Agilent FEM Visualization
window includes the following modifications:

EM Port surfaces are no longer displayed.
Object shading is removed.
A shaded current plot for Port 1 at the lowest frequency is displayed.
In addition to the Properties tab, Solution Setup and Plot Properties tabs are added
for controlling the view.

The Properties tab provides the same functionality as the Previewer properties tab.
However, in the Agilent FEM Visualization window, you can specify the type of mesh:
Surface or Volume Mesh, as shown in the following figure:

Note
For more information about the Properties tab, refer Visualizing 3D View before EM Simulations (em).

You can display the field quantities by using the Plot Properties and Solution Setup tabs.
The Solution Setup tab controls the excitations for the visualization, while the Plot
Properties tab controls the visual display of the excitation.
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 Controlling Visualization Excitations

The Solution Setup tab is used to select the current excitation for the plots. All the plots
automatically reflect the current solution configuration once it is selected. By selecting
either a port or frequency, the excitation is changed and the plots are automatically
updated.

In the Agilent FEM Visualization window, select the Solution Setup tab present at the
bottom of the window. In this tab:

Define the port excitation value from the drop-down list in the Port Setup region.
You can either select Single Mode Excitation for ports to be excited individually or
Multiple Mode Excitation.

View the frequency changes in the Frequency region. After the port or frequency
selection is changed, the plots are automatically updated using the new
configuration.

The following figure displays a Solution Setup tab:

 Setting up Plots

In the Visualization window, click the Plot Properties tab to select fields, field sensors,
basic plots, and animation settings. The following figure displays the Plot Properties tab:
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 Selecting Field Types

You can select the required field quantity ( E, H, or J) to plot as well as the Vector
component. All the field quantities are represented as steady state sinusoidal waves, so
the field plots will be done at a specified phase. If you want to include the total field
magnitude, select the Plot Magnitude check box.

 Displaying Maximum Field Locations

You can view maximum field locations by clicking the Displaying Maximum Field
Locations button in Plot Properties. This opens the Maximum E Field Locations window.
This window provides information about the E field locations and their values. If you select
a particular frequency, it is highlighted in the Advanced Visualization window. The
following figure displays the Maximum Field Locations window:
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The following figure displays the highlighted frequency in the Advanced Visualization
window:

 Enabling Field Sensors

All the plots are displayed on surfaces. By default, surfaces that are connected to Ports are
automatically created and listed in the Sensor Frame.

The Field Sensors region consists of two columns, Show and Enable. The Show check box
allows you to display the triangular regions where the field quantities are plotted. The
Enable check box allows you to plot the field quantities on that Sensor. The fields that are
plotted are determined by the field plotting choices, Shaded, Arrow or Contour.

You can add new sensors by clicking the Add button. There are three different options for
adding new sensors:
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Object Plane: You can select a shaded object by clicking on a face. If no object is
currently shaded, you should first select an object edge to shade the surface. When
an object plane is selected, a plane is defined through the entire design region. In
this case, the plane will extend beyond the object definition.

Three Point Plane: You can select three points that determine plane.
add_plane2.gif

Object Surface: You can select a shaded object by clicking on a face. If no object is
currently shaded, you must first select an object edge to shade the surface. Only the
surface of the object is used. Unlike the object plane mode, the surface does not
have to be planar. A second option also allows you to select all shaded objects.

Using the Edit button, you can rename a plane or move it within the design area. Object
Surfaces cannot be moved since they are assigned to a specific object and not a location.
You cannot rename or delete predefined planes.

 Plotting Properties

Using the Plot Properties tab, you can create the following types of plots:

Shaded Plot
Arrow Plot
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Contour Plot
Volume plot

 Displaying a Shaded Plot

The shaded plot allows you to plot the magnitude of the field quantity on the sensor
surface, as shown in the following figure:

Displaying the shaded current plot is controlled by using the check box next to the plot
name. When it is selected, the plot is visible. Within the plot there are some basic
controls:

Log Scale: This controls whether the scaling and color representation uses a
logarithmic scale or a linear one.
Transparency: This controls the transparency of the shaded plot.

 Displaying an Arrow Plot

The arrow plot allows you to plot the quantity on the sensor surface, as shown in the
following figure:

After selecting the Arrow tab, select Enable to display the arrow plot. You can control the
following properties of an arrow plot:

Scaling arrows: You can select the Scale check box to control whether the arrows
are scaled, based on the relative magnitude of the current density through out the
design. When it is selected, the arrows will be scaled, making the lower current
density areas have smaller arrows. If it is not selected, all the arrows are displayed
with the same size. However, their size can still be changed by changing the arrow
size.

Using a logarithmic scale: You can select the Log Scale check box to control whether
the scaling and color representation use a logarithmic scale or a linear one. If scaling
is not enabled, only the color weighting is affected.
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Specifying arrow size: You can specify the relative size of the arrow in Arrow Size.
Remember that if the arrows are not scaled, the default size of the arrows appear to
be larger than when the arrows are scaled.

 Displaying a Contour Plot

The contour plot allows you to plot the magnitude of the field quantity on the sensor
surface, as shown in the following figure:

After selecting the Contour tab, select Enable to display the contour plot. You can control
the following properties of a contour plot:

Using a logarithmic scale: You can select the Log Scale check box to control whether
the scaling and color representation use a logarithmic scale or a linear one. If scaling
is not enabled, only the color weighting is affected.

Specifying the number of divisions: You can specify the number of divisions in the
Divisions combo box.

 Displaying a Volume Plot

The volume plot enables you to scale and specify arrow size, as shown in the following
figure:

 Specifying Plot Options

You can modify the plots by using the options menu. The options menu displays the color
key for the plot and can also be used to change the Minimum and Maximum values that
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are being plotted. The color used for the plot can also be specified from the Options dialog
box.

System Min and System Max: The system minimum and maximum values represent the
minimum values for all the plots that are currently being drawn. However, in order to
keep scale consistently, the maximum and minimum values are not changed when the
Solution Setup is modified. The maximum and minimum values are displayed as System
Max and System Min. If you want to use these values instead, click the Restore Max and
Min button.

Similarly, you can modify the maximum and minimum values that are used for displaying
the data by typing in new values. These will not be changed as the Solution Setup is
modified.

X and Y Arrow Density control the density of arrows within a sensor. They have no effect
on Object Surface Sensors.

 Plotting Boundary Conditions

Use the Boundary Conditions tab in the plotting regions to plot the boundary surfaces. By
selecting the Boundaries Visible box, you can pick the boundary surfaces that are visible
on the screen. The unassigned surfaces are those which are on the surface of objects, but
do not have any boundary conditions assigned to them.

 Plotting 3D Mesh

When a solution is loaded, a third column, Mesh, becomes available in the Properties tab.
By selecting the Mesh column check box, the mesh inside the material or individual object
can now be seen. In some cases, there may not be any mesh inside the object if the
object was not assigned any tetrahedral. Flat objects, by definition, do not have any
tetrahedral assigned to them.

 Shaded Mesh

The surface mesh of the objects can be drawn by selecting the Surface Check box in the
Mesh box at the bottom of the Properties Tab. Once selected, the volume mesh can also
be selected.

 Animating FEM Fields
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You can animate the FEM fields by selecting the Animate box at the bottom of the Plot
Properties Tab. If the Plot Magnitude button is selected, the animation option is not
available. X and Y Arrow Density control the density of arrows within a sensor. They have
no effect on Object Surface Sensors. You can also change the phase by sliding the Phase
Bar, as shown in the following figure:

You can control the following animation options of arrow, shaded, and contour plots:

Determine the display update time: Specify a value in the Display Update text box
to determine the minimal time required between display updates in milliseconds.
Since some updates may take longer than this setting, this value is only a minimum
number and not an absolute one.

Determine the Phase Increment value: Specify a value in the Phase Increment text
box to control the number of degrees added to the current phase when an update
occurs.
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 Using Advanced Model Composer
You can use the Advanced Model Composer (AMC) feature to create multidimensional,
parametrized, passive planar models for arbitrary-shaped, and user-defined parametrized
layout components on custom substrates. You can add these models to a schematic or to
a design kit. AMC combines the capabilities of the Model Composer tool with the generality
of layout components. Also, Advanced Model Composer can now generate a scalable EM
model based on FEM simulations.

Note
 Advanced Model Composer and Momentum licenses are required to generate parametrized models for
user-defined layout components. Once a model is generated, you do not need any license for using the
model in a schematic environment.

You can also use the Model Composer (modcomp) feature to create multidimensional,
parametrized, and passive planar models for standard interconnect components. For
example, you can use the feature to create opens, stubs, bends, and tees on custom
substrates. Advanced Model Composer and Model Composer rely on a unique EM-based
modeling method to provide EM accuracy at traditional circuit simulation speed. Models
are generated in a model generation step and added to the model database associated
with the layout component. The generated models consist of .pml extension. AMC
provides the following features:

AMC provides an option for populating the model database of a Layout component
before. Typically, the model database of a Layout component is updated with
Momentum simulation data on-the-fly, while using the Layout component in a
schematic.

AMC uses an adaptive rational/polynomial curve fitting algorithm, which is a
multidimensional version of the Momentum Adaptive Frequency Sampling (AFS)
algorithm. The .rat (=RATional) files generated by Momentum AFS algorithm contain
information about the rational fitting model of single Momentum simulations. There
can be multiple .rat files in the model database for a single layout component.

The AMC algorithms combine multiple .rat files into one global .pml (Passive Model
Library) file. This file contains the multidimensional rational/polynomial model that is
used to represent the S-data in the user-defined parameter/design space.

Note
Multiple .rat files that build up a .pml can be deleted. However, deleting the files is not necessary as
these .rat files can be used in a future AMC model generation.

  

 

 Creating AMC Models

The process of using an AMC model is as follows:

Create a model and monitor the model generation progress.1.
Use the model in the schematic environment.2.
Add the model to a standard ADS design kit (optional).3.

To access AMC:

From an ADS Layout window, choose EM > Component > Advanced Model1.
Composer > Create Model. The Advanced Model Composer dialog box is
displayed, as shown in the following:
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Specify a sweep type for each layout parameter. You can choose one of the following2.
options:

Constant Value: Specifies that a layout parameter consists of a fixed value.  You
should specify a sweep type for each layout parameter. 
Discrete List: This value contains a set of discrete values. When you use the
component on a schematic, you can set the parameter to any value in this list.
Continuous Range: This value is used to create a model covering a specific
range with minimum and maximum values. When the component is used in a
schematic, you can then select any value in this range.
While there is no hard-coded limit to the number of continuous parameters, we
recommend not using more that two continuous parameters. For more
information, see Troubleshooting.

Click OK to open an information window where you can view the Parameter Sweep3.
plan and general information about the model generation process.

Click OK in this information window to start the model generation process.
A new ADS session is launched in the background to build the model.

Note
You can continue to use this ADS session for other activity (depending on memory
availability). Or, you can exit this ADS session without affecting the model generation process.

You can also view the model generation process. After the model generation process4.
is complete, the parametrized model is automatically stored in the model database
associated with this Layout component.  The associated Layout component with its
parametrized electrical model can be added to a schematic like any other ADS
component.

Note
There is an important distinction between the use of Layout components and components generated
with AMC.

If you use the Layout components directly in the schematic environment, the Momentum engine
generates an EM model as part of the EM circuit cosimulation.

When using AMC components, the parametrized EM model is generated before using the
components in the schematic environment. Therefore, running Momentum is not required during the
circuit simulation.

 

 Viewing and Controlling the Model Generation Progress

You can view and control the model generation progress from any ADS session. Type the
Component name or click Browse to locate the required component. The default location is
under the $HOME/hpeesof/amc/components directory, the name of the model is the same
as the name of the layout component.

To view the model generation progress, choose EM > Component > Advanced Model
Composer > Status/Control. The Advanced Model Composer Status/Control dialog
box is displayed, as shown in the following figure:
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The Advanced Model Composer Status/Control dialog box:

Describes the status of the model generation.
Displays any error messages or warnings.
Enables you to stop the model generation.

 Troubleshooting

You may face problems while trying to generate an AMC model due to the following
factors:

Substrate
Maximum frequency
Layout parameters

Due to these factors, the higher-order modes are excited, the Momentum simulator
produces non physical results, and the AMC modeling process cannot converge.

In such cases, you can refer the following guidelines:

Limit the frequency range.
Limit parameter ranges (for example, limit width).
Check units (for example, m instead of μm).
Limit the number of continuously varying parameters. The maximum is two per
component, for practical reasons. Consider that the modeler uses about 5 to 10
Momentum simulations for each continuously varying parameter. This means:

One continuous parameter would require 5 to 10 simulations.
Two continuous parameters, 25 to 100 simulations.
Three continuous parameters would require 125 to 1000 simulations.
Four continuous parameters would require 625 to 10,000 simulations.

Use constant values and discrete lists. Often, the line width of the metallization is
limited and varies in a discrete way based on a given technology or application. If
such cases, use discrete parameter lists that correspond to real world limitations.
Replace a single model definition (with widely varying ranges) by multiple models of
the same layout component. Each model should be valid in a subset of the original
parameter space.
Perform a worst case analysis of the library specifications,  such as check the
combination of max frequency, max width, and substrate. Ensure that no higher
order modes occur. Momentum can be used to see if the simulation results (S-data)
are accurate.

 A typical workaround is to use discrete lists and limit ranges. With wider ranges and more
continuously varying parameters, longer modeling times and more Momentum simulations
are required. (Carefully consider the parameter ranges and ensure that all values are
physically possible.)

AMC is designed for the modeling of components that are small compared to the
wavelength.  While modeling structures with resonances, the simulation time required to
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generate the model can increase.  The increase occurs because Momentum simulations
must be performed to get a converged model. Also,  each Momentum simulation require
more frequency points.

Note
 If the mesh density is set too low, mesh noise in the simulated models can influence the model
generation process. The convergence of model generation is not reached within a reasonable number of
samples. In this case, increase the mesh density.

Simulate the component in the extremes of the parameter ranges before starting the tool. It ensures that
the Momentum model generation process for the selected simulation control options completes
successfully.

 

 AMC Model Generation Technique

AMC provides a method to build multidimensional parametrized analytical models for
passive planar components. It produces highly accurate analytical models, which is used
by all ADS circuit simulators. Model generation is based on EM simulation techniques,
providing EM accuracy and generality at traditional circuit simulation speed.

The model generation technique, referred to as Multidimensional Adaptive Parameter
Sampling (MAPS), selects a minimum number of EM simulations. It builds a global
analytical fitting model for the scattering parameters of general planar structures as a
function of the geometrical parameters and of the frequency, with a predefined accuracy.
Data points are selected efficiently and model complexity is automatically adapted. The
algorithm consists of an adaptive modeling loop and an adaptive sample selection loop
described in the following sections.

  

 Adaptive Model Building Algorithm

The scattering parameters S are represented by a weighted sum of multidimensional
orthonormal polynomials (multinomials) Pm. The multinomials only depend on the

multidimensional coordinates  in the parameter space R, while the weights Cm only

depend on the frequency f:

 (1-1)

The weights Cm are calculated by fitting the 1-1 equation on a set of D data points

(with d=1, ..., D). The number of multinomials in the sum is adaptively increased until the
error function:

 (1-2)

is lower than a given threshold (which is function of the desired accuracy of the model) in
all the data points. For numerical stability and efficiency reasons orthonormal multinomials

are used, that is, the multinomials  meet the condition:

 (1-3)

  

 Adaptive Data Selecting Algorithm

The modeling process starts with an initial set of data points. New data points are selected
adaptively in such a way that a predefined accuracy Δ for the models is guaranteed. The
process of selecting data points and building models in an adaptive way is often called
reflective exploration. Reflective exploration is useful when the process that provides the
data is costly, which is the case for full-wave electromagnetic (EM) simulators. Reflective
exploration requires reflective functions that are used to select a new data point. The
reflective function used in the MAPS algorithm is the difference between two different
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models (different order M in equation (1-1)). A new data point is selected near the
maximum of the reflective function. When the magnitude of the reflective function
becomes smaller than Δ over the whole parameter space, no new data point is selected.

If one of the scattering parameters has a local minimum or maximum in the parameter
space, it is important to have at least one data point in the close vicinity. Therefore, if
there is no data point close to a local maximum or minimum of , the local
extremum is selected as a new data point. For resonant structures, the power loss has
local maxima at the resonance frequencies. Again, to get an accurate approximation, a
good knowledge of these local maxima is important.

The scattering parameters of a linear, time-invariant, passive circuit satisfy certain
physical conditions. If the model fails these physical conditions, it cannot accurately model
the scattering parameters. The physical conditions act as additional reflective functions: if
they are not satisfied, a new data point is chosen where the criteria are violated the most.

The algorithm flowchart is shown in the following figure:
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 Using EMPro 3D Components in ADS
You can import EMPro default 3D library components and parametrized 3D Components in
ADS. This section provides information about how to use the EMPro 3D components in
ADS 2011.

 Using EMPro Default 3D Components in ADS

The default 3D library components are provided as part of the EMPro installation. EMPro
provides the following types of default library components:

Basic Shapes: Block, SolderBall, Cylinder
Span: Basic shapes that span a substrate layer.
Arrays: NxM arrays of basic shapes
Span Arrays: NxM arrays of spanning shapes
Array Outlines: 2(N-1)+2(M-1) basic shapes that form the outline of the array.
Span Array Outline: 2(N-1)+2(M-1) spanning shapes that form the outline of the
array.

Note
For more information about the default 3D library components provided by EMPro, see EMPro Default 3D
Library (emprocomps).

 Installing EMPro Design Kit in ADS

Before installing the EMPro design kit containing 3D library components in ADS 2011:

Get the latest version of the design kit.1.
The ADS license emds_3d_param is required for 3D preview and EM simulation of2.
the EMPro default 3D Components. This license is free; but without it the 3D
components are silently ignored. You can install the design kit, insert the 3D default
components into designs, and perform 3D Preview and EM operations. However, 3D
components are excluded from the operations without any warning or indication of
any kind.
3D components include a 2D footprint that is visible in the ADS layout window, and,3.
additionally, a full 3D model that is used in 3D operations. These components do not
include a Schematic symbol or representation, and are not directly supported by ADS
circuit simulation.

 Importing EMPro Default 3D Library Components in ADS 2011

To install EMPro default 3D library components in ADS:

Select DesignKits > Unzip DesignKit from the ADS Main window.1.
Browse to the location of the default component design kit, which is the EMPro 20112.
installation directory under
data\ADS_integration_\EMProDefault3D_DesignKit_ADS2011.zip.
Select a directory to unzip the design kit.3.

For more information on installing design kits, refer to Design Kit Installation and Setup in
Working with Upgraded PDKs in ADS 2011 (oaqkref).

 Adding the EMPro Default 3D Library to an Existing Workspace in ADS 2011

Select DesignKits > Manage Libraries from the ADS Main window.1.
Click Add Library Definition File to select the lib.defs file of the library you want to2.
add in the workspace.
Click Yes. The library is added to your current workspace.3.
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To use EMPro default 3D library components:

Ensure that you have a license for the Agilent FEM Simulator.1.
Install the design kit: EMProDefault3D_DesignKit_ADS2011.2.
Select DesignKits > Manage Favorite Design Kits from the ADS Main window.3.
The design kit is displayed in the Manage Favorite Design Kits window, as shown in
the following figure:

Create a design and open the Layout window.4.
From the Library drop-down list, select the library containing the 3D components.5.
The palette changes displaying a single component. Click the component and drag it
on the Layout window. The parameter window of the component is displayed, as
shown in the following figure:

Customize the layout layers (optional).6.
In a Layout window, insert the 2D shapes, ADS layout components, and any other7.
required objects.
Specify the substrate (such as, layer properties, thickness, and expansion model).8.

Note
Only substrate layers that are mapped to layout layers are visible to EM.

Insert one or more 3D components, picking them from the palette or the component9.
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library. Assign parameter values. The layout is now ready for 3D EM Preview.
Select EM > 3D EM Preview to see a preview of the layout.10.

Select the required values of the parameters and apply the settings. Single-clicking a
parameter provides a description of the parameters use. A description of the parameters
used in this example are provided in the following list:

Layer: Specifies the physically mapped layer that is used to define the final z-
position of the 3D component.
PlaceCustomComponentOnTop: Set this parameter to Yes to place the 3D
Component on top of the physically mapped layer selected by the Layer parameter.
Layer2: Specifies the layer that is used to display the first cross-section. This layer
can be physically mapped. The main intent is to provide guidance about the final
positioning of the component with respect to other elements present in ADS Layout.
Layer3: Specifies the layer that is used to display the second cross section. This
layer can be physically mapped. The main intent is to provide guidance about the
final positioning of the component with respect to other elements present in ADS
Layout.
package_height: Specifies the EMPro generated parameter. Changing this
parameter is reflected in the final 3D geometry that can be verified in the 3D Viewer.

 Inserting Design Kit Components into ADS Layouts

After installing the design kit, insert 3D components in ADS layouts by performing the
following steps:

Select EMProDefault3D Library Components in the Layout window to install the 3D1.
Component palette, as shown in the following figure:

Select a 3D Component from the palette to insert into the Layout. All 3D Component2.
names begin with EMPro_LIBS3D.

 Setting Parameter Values for the 3D Components: Example
EMPro_LIBS3D_Block

Parameter values for the 3D Components are set in the same way as other ADS Layout
components. The 3D Components, however, have some parameter values that cannot be
modified: Desc3D and DesignKitName. These values are fixed at the time of the design
kit creation. They appear in the ADS Edit Parameter dialog enclosed in parenthesis.
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All 3D Components have two layer parameters: Layer and Layer2. Layer specifies the
layout layer on which the component either:

spans, if the component is a spanning component (with 'Span' in its name).
is placed on the top of, if the value of the parameter PlaceCustomComponentOnTop
is set to yes.
is placed on the bottom of, if the value of the parameter
PlaceCustomComponentOnTop is set to no.

Note
The value of the parameter PlaceCustomComponentOnTop is relevant only if the associated
layout layer is specified for an EM simulation as having a Thick model, with up or down expansion.

The parameter Layer specifies the layout layer that the block is placed on the bottom
because it is not a spanning component ('Span' is not in its name). The layout layer
"cond" is defined with a Thick, expansion up model, and the value of its parameter
PlaceCustomComponentOnTop is set to no.

The parameter Layer2 is used to specify the layout layer for drawing the 2D footprint or
mark-up of the component. By default, it is set to the layout layer named "default" which,
by convention, is not mapped to a substrate layer. This means that the 2D markup
appears in the ADS layout window (if visibility is turned on for the layer "default").
Therefore, provides a visual indication of the location of 3D component relative to the
other layout elements. However, the 2D shape does not contribute to the analysis of the
2D or 3D component. The value of Layer2 can be set to a layout layer that is mapped to a
substrate layer, but in such cases it is included in the 2D and 3D analysis.

All 3D components consists of a parameter material. A material is a property defined in
EMPro, which is used in EM calculations, and is stored with the 3D component model. The
design kit configures a long list of available materials that can be selected for this
parameter value.

In addition to these common parameters, each component has a unique set of parameters
that are used to specify its shape. For example, the EMPro_LIBS3D_Block component has
parameters depth, height, and width for specifying its dimensions.

 Establishing Compatibility: Substrate Definition and Layer Mapping

Before performing EM simulations, the substrate has to be defined and its layers mapped
to layout layers. The substrate should be consistent with the 3D component parameter
values. Open the window to specify the substrate definition and layer mapping by
selecting the layout menu: EM > Substrate.

All layout layers that are used as values for a 3D Component Layer parameter must be
mapped to a substrate layer. The layout layers "cond", "pcvia1", and "cond2" are all
mapped to substrate layers. The layout layers can be used as values for the 3D
components Layer parameter.

 Special Considerations for 3D Operations

First, there must be at least one 2D object on each layer that a 3D component either
spans or has been placed on. In the absence of an object, the ADS 3D Preview and EM
layout processor is not able to access the 3D Component model. You should ensure that



EM Simulation

120

there is some 2D shape on the 3D Component Layer. You can put a markup on the same
layer as the 3D object.  It sets the value of the Layer2 parameter to the value of the Layer
parameter.

 Troubleshooting Hints

If you have inserted one or more 3D components into your layout, but do not see any
3D components in the 3D Preview, then most likely you do not have the necessary
codeword (emds_3d_param).
If you have inserted a 3D component and changed some parameters that affect the
dimensions of the object, but see in the Preview window the object with the default
dimensions, then there is a problem with the regeneration of the 3D object. (If any
type of a problem is encountered when the component is regenerated, the default
object will appear in the viewer.) It is caused by an invalid configuration, a corrupt
database, or some other problem of that nature. About the only thing to try is to re-
start ADS and try using the 3D components in a new design, and/or re-installing the
design kit, and/or re-installing ADS.
If you insert one or more 3D components into your layout, an error might be
displayed after selecting a 3D Preview. It is likely that you have placed a 3D
component on a layer that does not have any 2D shapes on it. The solution to this
problem it to either specify the Layer2 parameter to be the same as its Layer value
(effectively inserting the shape of the 2D markup on the layer that the 3D model was
placed on), or insert some 2D shape on any layer that has only 3D Components on it.
If you see 3D components extending outside the bounding box in a 3D Preview
window, then you will need to auto-extend the boundary so that the 3D components
are fully contained in the bounding box.

 EMPro Default 3D Library Components Summary

 Basic and Span

 Arrays and Span Arrays
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 Array and Span Array outlines

 Parameterization of Components

 Basic Shape Drawing - Block

 Basic Shape Drawing - SolderBall

 Basic Shape Drawing - Cylinder
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 Array and Array Outline Drawing

 Using Parametrized EMPro 3D Components in ADS

Before using the parametrized EMPro 3D components in ADS 2011, you need to convert
the design kits generated with EMPro by using the de_convert_3D_component() tool
available in ADS 2011. To use parametrized EMPro 3D components in ADS 2011:

Close all open workspaces in ADS 2011.1.
If a 3D component is contained in a zip file, extract the file by using any regular2.
unzip program.

Note
Do not select DesignKits > Unzip DesignKit from the ADS Main window.

From the ADS Main window select Tools > Command Line.3.
Enter the command de_convert_3D_component().4.
Click Apply.5.
An information message is displayed asking you to select a directory of the unzipped6.
3D components. Click OK.
Select a directory in the Convert EMPro 3D Component dialog box.7.
Click Choose. Once a design kit is converted, you can use it both in ADS2011 and8.
older versions of ADS. However, you should not add components to a kit that already
has been converted.

To use EMPro 3D library components in ADS 2011:

Ensure that you have a license for the Agilent FEM Simulator.1.
Click DesignKits > Manage Favorite Design Kits from the ADS Main window.2.
Click Add Library Definition File and select the lib.defs file. You will receive a3.
prompt if you want to add it to the current workspace.
Click Yes. The design kit is added to your current workspace.4.

Create a new design and open the Layout window.5.
From the Library drop-down list, select the library containing the 3D components.6.
The palette will change showing a single component. Click the component and drag it
on the Layout window. The parameter window of the component is displayed, as
shown below:
Select EM > 3D EM Preview to see a preview of the layout.7.

Select the required values of the parameters and apply the settings. Single-clicking a
parameter will give a description of the parameters use. For reference, a description of the
parameters used in this example are repeated below:

Layer: Specifies the physically mapped layer that will be used to define the final z-
position of the 3D Component
PlaceCustomComponentOnTop: Set this parameter to Yes to place the 3D
Component on top of the physically mapped layer selected by the Layer parameter.
Layer2: Specifies the layer that is used to display the first cross-section. This layer
may or may not be physically mapped. The main intent is to provide guidance about
the final positioning of the component with respect to other elements present in ADS
Layout.
Layer3: Specifies the layer that is used to display the second cross-section. This
layer may or may not be physically mapped. The main intent is to provide guidance
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about the final positioning of the component with respect to other elements present
in ADS Layout.
package_height: Specifies the EMPro generated parameter. Changing this
parameter will be reflected in the final 3D geometry that can be verified in the 3D
Viewer.
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 Using the Job Manager
You can manage non-interactive processing jobs by using the Job Manager window. A new
managed job is automatically created for various time-consuming operations. These
operations currently include physical EM simulations and 3D model generations. The Job
Manager window provides a user interface to show the job status and messages, and
allows you to cancel running jobs. However, its scope is currently limited to physical EM
simulation-related jobs.

The Job Manager consists of an internal queuing concept. According to this concept, jobs
submitted with the same queue name run sequentially. Queues can be suspended and
resumed. Note that this internal queuing system is complimentary to the queuing system
of distributed job management systems such as Platform LSF and Sun Grid Engine. For
circuit simulation job management, refer Circuit Remote Simulation (cktsim).

Besides running locally, physical EM simulation setups can be configured to run on a
remote host or a submission host for a distributed cluster. The Job Manager maintains a
PVM  cluster of hosts ready to accept jobs, and dynamically adds hosts to the cluster as
needed. Complete cluster host configuration and management capabilities are provided
inside the Job Manager user interface.

 Starting the Job Manager

A Job Manager window is automatically displayed in the background when an EM Setup is
opened or a physical EM simulation is started. It can be brought to the front by clicking

 icon on the task bar.

Alternatively, you can display the Job Manager window by using the EM Setup window.
Perform the following steps:

Select EM > Simulation Setup to open the EM Setup window.1.
Select Resources in the left pane of the EM Setup window.2.
Click the Start button in Job Manager, as shown highlighted in the following figure:3.

The Job Manager main window is displayed, which lists a summary of all jobs created4.
since the Job Manager was launched:

http://en.wikipedia.org/wiki/Parallel_Virtual_Machine
http://en.wikipedia.org/wiki/Parallel_Virtual_Machine
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Warning
The Job Manager window closes automatically if the main window is closed. If active jobs are still
pending, a message box is displayed asking for confirmation. After confirmation, these jobs will be
canceled without cleaning up their working directories. All status and logging information is
discarded at exit. If you just want to hide the main window, minimize it instead of closing it.

Double-click a job entry to view detailed log messages.5.

Note
This log window is immediately displayed when newly created jobs do not need to wait in the internal
queuing system. Select View > Show Main Window to open the main window from here. Newly created
jobs that have to wait in a Job Manager queue will open the main window and highlight their summary
line.

 Job Progression

All jobs progress through the following states:

Creating a new job: A new job is created and the following job configuration1.
information is displayed in the topmost part of the detailed log window.

ADS Workspace::Design: Specifies the workspace and design being
simulated.
Simulator: Specifies the simulator Momentum or FEM used for simulation.
Input/output directory: Specifies the directory used for containing input files
and output files.
Working directory: Specifies the host directory where the job will perform the
main task. This can be the same directory as the input/output directory.

Queuing... or Queuing (queue suspended): After a job is created, it needs to wait2.
until earlier jobs in the same Job Manager queue are complete.
Connecting with the remote host: The remote host is not yet part of the PVM3.
cluster and is currently being dynamically added to the cluster.
Preparing Files: This preparation step consists of the following stages:4.

The input/output directory and working directory are locked to prevent double
usage. The lockfile is an empty directory named .simlock.
Local preparation work is performed in the input/output directory.
The contents of the input/output directory are copied to the working directory.

Performing the main task: The job is inside its main task. In the Local/remote5.
mode, the status displays Running. For the Distributed mode, the following third-
party cluster submission and status tracking is performed:

http://edocs.soco.agilent.com/download/attachments/152619688/job_manager_main_window.png


EM Simulation

126

Submitting to cluster
Cluster response: submitted.
In response to choosing Job > Query Status:
Requesting status update
Cluster response: created/submitted/pending/running/suspended/ended
or Cluster did not answer

Waiting: This step allows dying processes and network disk operations to settle.6.
Retrieving results: The contents of the working directory are copied back to the7.
input/output directory.
Processing results: The final datasets are installed in this step.8.
Cleaning up: The working directory is cleaned up (only if this is not also the9.
input/output directory). The .simlock lockfile is removed from the input/output
directory.
Done10.

 Managing Jobs

You can control the following operations using the Job menu, which is available from the
Main window and log window:

Stopping or Canceling a  Job: You can immediately cancel a job and perform the
necessary cleanup operations by selecting Job> Stop/Cancel.

Querying Status: You can query a status update for jobs submitted to a third-party
distributed cluster system by selecting Job> Query Status. The updated status will
be shown in the status line. If the status indicates that the simulation is done, all
results will be automatically fetched, available datasets are installed, and the remote
working directory is cleaned up.

Retrieving Intermediate Results: You can synchronize the remote working
directory to the input/output directory and install currently available datasets by
selecting Job>Fetch Intermediate Results. This option is applicable only to jobs
submitted to a third-party distributed cluster system.

Note
It is not necessary to use Job > Fetch Intermediate Results at the end of a distributed
simulation. Use Job > Query Status instead, which additionally cleans up the remote working
directory and notifies other tools of the completion of the simulation.

Deleting logs: You can completely remove a job from the Job Manager by selecting
Job > Delete Log in the main window.

Warning
When using Job > Delete Log on a running job, a message box is displayed asking for confirmation.
After confirmation, this job will be canceled without cleaning up its working directory. To avoid this, use
Job > Stop/Cancel Job and delete the job only after the status has changed to Done.

The Job Manager provides a simple queuing system where jobs submitted with the same
queue name run sequentially. The queue name is specified in the EM Setup (em). For
complex queue management, use a dedicated job management tool such as Platform LSF
and Sun Grid Engine.
Job manager queues can be suspended and resumed by selecting a queued job in the
main menu and choosing Queue > Suspend Queue or Queue > Resume Queue.

Note
It is not possible to suspend a queued job once the job has started. Still, Queue > Suspend Queue can
be used to suspend execution of subsequent queued jobs.
After a queue completes, it will automatically enter a suspended state. Use Resources > Simulation
Resources > Auto-start queue after submission in the EM Setup if you want to automatically (re)start
the queue when submitting a new simulation.

  

 Managing Hosts

Select View > Hosts from the main Job Manager window to display the status of all hosts
in the PVM cluster. This window will also automatically pop up whenever hosts are
dynamically being added to the cluster.
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One line is displayed for each running host in the cluster. The architecture and speed of
each host are shown as well. The speed can be configured using the custom sp=value
eesofpvm option and is currently used for display purposes only.
See Setting up Remote Hosts for host configuration information.

Select or type a host name and click Add host to cluster to manually add a new host to
the cluster. This will bring up a password prompt if authentication is required. If the
operation fails, information about the failure is shown in the status bar.
To remove hosts from the cluster, select one or more entries in the Active hosts table
and click Remove selected host(s) from cluster. Attempts to remove the local host
from the cluster are ignored.

 

 Setting Preferences

The Job Manager is an improved version of the former EEsofPVM Simulation Console.
Complete cluster host configuration and management capabilities are now provided inside
the Job Manager user interface. The Legacy setups using a cluster configuration file and
environment variables are still supported but deprecated. This support may be removed in
a future release.

The Job Manager now automatically uses secure shell (SSH) to connect to other
hosts. If it still needs to run some other third party remote shell tool for a legacy
setup, the environment variable EESOFPVM_RSH_NOAUTO=<any nonempty string> is
now additionally required besides the existing EESOFPVM_RSH variable.

When migrating to the new GUI-based configuration, it is advised to remove all old
eesofpvm configuration settings:

If coexistence with ADS 2009 (Update 1) is not necessary, remove the cluster
configuration file at <home directory>/hpeesof/config/pvmhost_cfg.txt

and/or the path specified by the <home directory>
/hpeesof/config/hpeesof.cfg variable EESOFPVMHOSTFILE (and remove this
variable).
However, if ADS 2009 (Update 1) coexistence is required, the legacy eesofpvm
host file can still be obscured to the Job Manager by overriding the hpeesof.cfg
variable EESOFPVMHOSTFILE with an additional variable
EESOFPVMHOSTFILE:371=/nonexistent. The number 371 is the internal Job
Manager version number as shown when choosing Help > About EEsof Job
Manager from the main window.
If coexistence with ADS 2009 (Update 1) is not necessary, eliminate all
environment variables containing EESOFPVM in the name from the Windows
environment or Unix init scripts (e.g. ~/.bashrc or ~/.kshrc) and the
~/.eesofpvmprofile file. The only environment variable that does not lose its
relevance is EESOFPVM_TMP, the directory where the PVM daemon displays its
configuration and writes logging information.

Choose Settings > Preferences from the Main window or the hosts window to open the
Preferences dialog box.
These preferences are saved in <home directory>/hpeesof/config/simsys.cfg, which
can be distributed towards other users if they all use the same remote simulation hosts.

http://edocs.soco.agilent.com/download/attachments/152619688/job_manager_hosts.png
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 Specifying Startup/Shutdown Configuration

The Job Manager runs as a task of the PVM cluster it controls. The PVM infrastructure
needs to start before the Job Manager starts, and can be allowed to continue running after
the Job Manager has exited. To accommodate different requirements, several
startup/shutdown options are available. Refer to the following recommended settings:

Start the eesofpvm backend when ADS starts: When selected, the PVM
infrastructure will silently start when ADS is started. This reduces the response time
to start the first simulation (at much lower cost). It is selected by default.

Close EEsof Job Manager when ADS exits: When selected, the Job Manager will
exit when ADS exits. A confirmation message box will appear when there are
unfinished jobs. It is selected by default.

Shut down the eesofpvm backend when both ADS and EEsof Job Manager
have exited: When selected, the PVM infrastructure will be stopped when both ADS
and EEsof Job Manager have exited. It is selected by default.

Shut down the eesofpvm backend when EEsof Job Manager exits: When
selected, the PVM infrastructure will be stopped when the EEsof Job Manager exits.
This check box can be partially selected, which displays a message box asking for
your confirmation. It is not selected by default.

Use separate eesofpvm backends for different combination of
user/host/$DISPLAY/$HPEESOF_DIR: When selected , all internal files that are
shared between different executables of the same PVM session will get a suffix to
separate different PVM sessions from one another. This prohibits conflicts between
different PVM sessions running on the same system. The suffix consists of eight
lowercase letters and/or digits. It is selected by default.

If the presence of a legacy PVM cluster configuration is detected (if EESOFPVMHOSTFILE is
defined or $HOME/hpeesof/config/pvmhost_cfg.txt exists), the default settings will be
different in order to mimic the original behavior:

http://edocs.soco.agilent.com/download/attachments/152619688/job_manager_preferences.png
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Preference name Normal default
(recommended)

Legacy default

Start the eesofpvm backend when ADS starts Selected Not selected

Close EEsof Job Manager when ADS exits Selected Not selected

Shut down the eesofpvm backend when both ADS and
EEsof Job Manager have exited

Selected Not selected

Shut down the eesofpvm backend when EEsof Job
Manager exits

Not selected partially selected =
prompt

Use separate eesofpvm backends for different
combinations of user/host/$DISPLAY/$HPEESOF_DIR

Selected Not selected

Default remote ADS installation directory Use the local
$HPEESOF_DIR variable

As defined in the
eesofpvm cluster
configuration file

 Setting up Remote Hosts

The EM Setup (em) window allows you to configure jobs to run on a remote host or a
distributed cluster.

Note
The configuration and operation of a third party distributed cluster happens completely outside the Job
Manager. The Job Manager only communicates with a submit host having access to the distributed cluster.
The requirements and configuration of a submit host are identical to those of any other remote host as far
as the Job Manager is concerned.

 Requirements for Running Jobs

In order to run jobs on a remote host you need the following:

A compatible ADS installation on the remote host. Compatibility is only guaranteed if
the versions of the local and remote ADS installations are identical.
An account on the remote host accessible over secure shell (SSH). An SSH service is
available on all contemporary Unix-like systems. Setting up SSH on Windows is
described. Passwordless SSH operation is supported but not required.
A read/write file system location on the remote host that can temporarily support the
working directory of a job.

 Configuring a Remote Host

To configure a remote host, add a configuration line to the Host specific overrides:

Specify the following fields:

Hostname: This is the DNS name of the remote host or its dotted IP address. If you
want to limit the configuration to a specific ADS version, add :version and optionally
additionally .revision after the host name. The current values for version and revision
are shown on the first line of the dialog shown when choosing Help > About EEsof
Job Manager from the main window: EEsof Job Manager (version.revision).

ADS installation directory: This is the path to the main ADS installation directory.

Working directory: The remote working directory is generally specified in the EM
Setup (em). The working directory entered in the Job Manager preferences is used as
base directory to complete relative path specifications. However, if you append
:force to the end of the path, the directory specified in the EM Setup is always
ignored and the path preference is used exactly as specified.
Environment variables specified as $VAR, ${VAR} or %VAR% are expanded on the
remote host.
Use ${VAR:local} or %VAR:local% to expand environment variables on the local
host.
Escape a literal $ as $$ and a literal % as %%.
The following local variables have a special meaning:

${HOSTNAME:local}: the local hostname
${PWD:local}: the input/output directory
${SESSION:local}: an identifier unique to each PVM cluster instance
(a string of eight lowercase letters and digits if Use separate eesofpvm backends
for different combinations of user/host/$DISPLAY/$HPEESOF_DIR is selected,
otherwise default)
${TAG:local}: a M012345678901 identifier for the job that is unique within the
Job Manager session
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In case you want to avoid all directory conflicts, a good choice would be

%USERPROFILE%\Jobs\%SESSION:local%\%TAG:local%:force

for remote Windows hosts and

/var/tmp/$USER/jobs/${SESSION:local}/${TAG:local}:force

for remote Linux hosts.

Additional eesofpvm options: Enter a list of space separated name=value options
for PVM.

lo=username specifies an alternate login name to use.
dx=<path to eesofpvmd> specifies an alternate path to the eesofpvmd
executable or script.
For further options, consult the PVM documentation .

If the entries for ADS installation directory or Working directory are empty, the specified
defaults are used. These defaults can be used to avoid redundant configuration
repetitions. Each name specified in Default additional eesofpvm options is only overridden
if the same name is specified in the Host specific overrides.

 Mode of Operation

The Job Manager window dynamically adds remote hosts to the PVM cluster as required or
requested. A host is added as follows:

A secure shell (SSH) connection is initiated to the remote host.1.
The local host prompts for passwords.2.
The SSH connection is now established.3.
(Only on Unix remote hosts) The Korn shell script file ~/.eesofpvmprofile is sourced4.
if it exists. This file can be used to set additional environment variables. A typical use
case is extending the PATH and LD_LIBRARY_PATH environment variables to ensure
accessibility of the tools required to control a third party job management framework.
The PVM daemon is started on the remote host. The choice between 32-bit and 64-5.
bit executables is automatic (64-bit executables are used whenever possible). The
command used to start the PVM daemon is <ADS installation directory>
/pvm3/bin/auto_eesofpvmd.exe.
The remote PVM daemon contacts the local PVM daemon over a dedicated TCP/IP6.
connection. The remote host is now part of the PVM cluster and remains in the
cluster until this connection is closed.
The SSH connection is closed. The remote PVM daemon keeps running.7.

Note
In case of remote simulation issues, check your firewall configuration at both ends (try disabling it
temporarily to check if there is an issue). Several executables in the ADS installation directory open
outbound and/or inbound TCP/IP connections. The ports are always in the operating system's dynamic
TCP/IP port range, except for SSH which uses port 22. On Windows versions prior to Windows Vista, the
dynamic port range is 1025-65535. Windows Vista and later versions use the range 49152-65535. On
Linux the dynamic port range is 32768-61000. Adjust the firewall rules to allow connections from/to these
ports.

 Setting up an SSH server on Windows

The free software package Copssh  can be used to deploy a SSH server on a Windows
host. A version of this package is provided in the <ADS installation directory>
\pvm3\tools\Copssh directory. Install the package using the suggested settings
(administrator privileges are required). Do not attempt to change the autogenerated
password for the SvcCOPSSH user (remembering this password is also not necessary).

Follow these steps for each user:

Log on as a user having administrative privileges (possibly but not necessarily the1.
user to be activated).
Launch Start > Copssh > 01. Activate a user.2.

Enter the name of an existing user on the host. The short %USERNAME% login
name is required, not a first and last name. This name will be the login name for
SSH. If the user name exists inside a Windows domain, prefix the user name
with the domain name and a backslash (these items are not part of the login
name for SSH).
Use /bin/bash as command shell
Select Remove copssh home directory if it exists.
Do not select Create keys for public key authentication.
Select Create link to user's real home directory.

Click Next. An acknowledgment message is displayed.3.
Click OK.4.
Browse to the required directory C:\Program Files\ICW\home/username (C:\Program

5.

http://www.netlib.org/pvm3/book/pvm-book.html
http://www.netlib.org/pvm3/book/pvm-book.html
http://www.itefix.no/i2/copssh
http://www.itefix.no/i2/copssh


EM Simulation

131

Files (x86)\ICW\home/username on a 64-bit system).
Open the file .bashrc with a text editor. It is important to use an editor that upholds6.
end-of-line conventions (do not use Notepad). A suitable editor is Notepad++ , which
is provided as <ADS installation directory>\pvm3\tools\Notepad++\notepad++.exe.
At the end of the .bashrc file, add an empty line followed by the following lines:7.

export EESOFPVM_TMP="$USERPROFILE\\PVM"

export HOME="$USERPROFILE"

cd

Note
Make sure that the file ends again with an empty line.

Save the .bashrc file and exit the editor.8.
Log on as the user to be activated and open a command prompt (Start > Run >9.
cmd.exe)
Execute mkdir "%USERPROFILE%\PVM" in the command prompt.10.
Close the command prompt.11.
The user account is now accessible through ssh.12.

You can verify correct operation by using the shell login command ssh <user>@

<hostname> from a Unix terminal or from a Windows command prompt (choose Start >
Run > cmd.exe, then first type cd <ADS installation directory>\tools\bin <return>). Log
on over SSH and run <ADS installation directory>/pvm3/bin/auto_eesofpvmd.exe (replace
all backslashes by forward slashes). If the output ends with a short string resembling
either 7f000001:d789 or /tmp/eesofpvmtmp025108.0, configuration was successful (the
exact (hexa)decimal digits can be different). Otherwise an error message indicating the
problem is shown (messages about an unreadable file pvmhost_cfg.txt are normal and
can be safely ignored).

Note
When accessing a Windows host remotely, network shares are generally not available as drive letters.
When referring to remote network drives, use the UNC name (<double backslash> <hostname>
<backslash> <sharename>) instead of the drive letter.

The Copssh installer assigns some special rights to the administrative SvcCOPSSH user in
order to support passwordless operation. However, when the host is part of a Windows
domain, the domain's security policy is often configured to periodically reject these rights
to all users, rendering Copssh unusable. Typically Copssh appears to be working after
installation, but all SSH logins fail the next day (as a result of the domain's security policy
being applied overnight).

To permanently fix this issue:

Make sure you are logged in as a user in the Administrators group.1.
Move the file C:\Program Files\ICW\etc\sshd_config (C:\Program Files

2.

(x86)\ICW\etc\sshd_config on a 64-bit system) to a writeable location, such as the
Desktop.
Open the moved file with a text editor. It is important to use an editor that upholds3.
end-of-line conventions (do not use Notepad). A suitable editor is Notepad++ , which
is provided as <ADS installation directory>\pvm3\tools\Notepad++\notepad++.exe.
Find the following line of text:4.

#PubkeyAuthentication yes

Change this line into (be sure to remove the pound sign):5.

PubkeyAuthentication no

Save sshd_config and exit the text editor.6.
Move sshd_config back to its original position.7.
Open the Services control panel (As privileged user, choose Start > Run >8.
services.msc).
Double-click the entry for Openssh SSHD.9.
Stop the service.10.
In the Log On tab, change Log on as: to use Local System Account instead of the11.
SvcCOPSSH user.
Click Apply.12.
Go back to the General tab and start the service.13.

After this fix, you cannot connect to the remote machine without specifying the password,
yet normal password-based operation work again. If you plan to use password-based
operation, this fix can be applied up-front (without running into the issue first).

 Passwordless SSH Operation

SSH can be configured to use public key authentication without the need to enter a

http://notepad-plus-plus.org/
http://notepad-plus-plus.org/
http://notepad-plus-plus.org/
http://notepad-plus-plus.org/
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password. In this mode of authentication, the local host presents a private key that must
match a public key known to the remote host. Perform the following steps:

Generate the public/private key pair on the local host (the one that runs the Job1.
Manager)

On Windows, open a command prompt (Start > Run > cmd.exe) and type cd1.
<ADS installation directory>\tools\bin <return>.
On Unix, open a terminal.
Type ssh-keygen -t dsa <return>. Just hit the return key when prompted for2.
the file location and the passphrase.
Remember the location of the public key which is displayed.3.

Copy the public key id_dsa.pub from the local host to the remote host.2.
On the remote host, check for the existence of the .ssh directory and create it if3.
missing. This directory must have read/write rights for the targeted user, and no
rights assigned to anyone else.
On Windows, the .ssh directory is C:\Program Files\ICW\home/username/.ssh (
C:\Program Files (x86)\ICW\home/username/.ssh on a 64-bit system).
On Unix, the .ssh directory is ~/.ssh.
On the remote host, append the contents of id_dsa.pub to <.ssh directory>4.
/authorized_keys. This file must not be writeable by other users than the targeted
user.
If the authorized_keys file did not yet exist, just rename id_dsa.pub to
authorized_keys instead of creating an empty file and appending.

The configuration is now complete. If passwordless operation does not appear to work in
the Job Manager, verify operation using the shell login command ssh <user>@

<hostname> from a Unix terminal or from a Windows command prompt (choose Start >
Run > cmd.exe, then first type cd <ADS installation directory>\tools\bin <return>).

Warning
On Windows remote machines, network shares on the remote machine may refuse operation in
passwordless mode because the user is not authenticated to the Windows domain.

 Specifying Configuration Files and Environment Variables

 Specifying Job Manager Preferences

The Job Manager preferences are stored as <name>=<value> lines in the file
<home directory>/hpeesof/config/simsys.cfg. These settings override those in the file
<ADS installation directory>/custom/config/simsys.cfg, which in its turn overrides
settings in the file <ADS installation directory>/config/simsys.cfg. The file
<ADS installation directory>/custom/config/simsys.cfg can be used for site-wide
deployment of Job Manager preferences. Note however that the Job Manager GUI will
always incrementally save preference changes to the file <home directory>
/hpeesof/config/simsys.cfg.

The preferences are mapped to the simsys.cfg file as follows:

Preference name Variable name in simsys.cfg Acceptable values

Start the eesofpvm backend when ADS starts ADS_STARTS_EESOFPVM TRUE or FALSE

Close EEsof Job Manager when ADS exits ADS_STOPS_JOBMANAGER TRUE or FALSE

Shut down the eesofpvm backend when both
ADS and EEsof Job Manager have exited

STOP_ORPHAN_EESOFPVM TRUE or FALSE

Shut down the eesofpvm backend when EEsof
Job Manager exits

JOBMANAGER_STOPS_EESOFPVM TRUE, FALSE or ASK

Use separate eesofpvm backends for different
combinations of
user/host/$DISPLAY/$HPEESOF_DIR

SEGREGATE_EESOFPVM_SESSIONS TRUE or FALSE

Use the local $HPEESOF_DIR variable DEFAULT_HPEESOF_DIR <local> (include the
angular brackets)

As defined in the eesofpvm cluster
configuration file

DEFAULT_HPEESOF_DIR empty

User defined: DEFAULT_HPEESOF_DIR string

Default working directory: DEFAULT_WORKING_DIRECTORY string

Default additional eesofpvm options: DEFAULT_EESOFPVM_OPTIONS string

Host specific overrides (one entry per
override)

HOST_CONFIG_<unimportant
unique suffix>

<Hostname>|<ADS
installation directory>|
<Working directory>|
<Additional eesofpvm
options>

 Running PVM Boot Script

When a Unix host is added to the PVM cluster, the optional Korn shell script file
~/.eesofpvmprofile is sourced before the PVM daemon is started on the host. This file



EM Simulation

133

can be used to set additional environment variables. A typical use case is extending the
PATH and LD_LIBRARY_PATH environment variables to ensure accessibility of the tools
required to control a third party job management framework.

 Specifying Environment Variables

The optional environment variable EESOFPVM_TMP indicates the directory in which the PVM
daemon advertises its configuration and writes logging information. You can specify the
following settings:

Windows: the environment variable TEMP, or if this is unset, C:\TEMP
Unix: /tmp

 Specifying Legacy Settings

The following settings are deprecated but supported for legacy setups:

The PVM cluster configuration file: this is by default <home directory>
/hpeesof/config/pvmhost_cfg.txt. Its path can be overridden by the
<home directory>/hpeesof/config/hpeesof.cfg variable EESOFPVMHOSTFILE.

The environment variable EESOFPVM_RSH pointing to a remote shell executable. This
variable now additionally requires EESOFPVM_RSH_NOAUTO=<any nonempty string> to
be set in order to be recognized.
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 Adding Boxes, Waveguides, and
Symmetry Planes
While specifying the substrate definition of a circuit, only the vertical dimension of the
substrate and not the horizontal dimension are defined. This extends the substrate layers
to infinity in the horizontal direction. For many circuit designs this is not relevant and does
not affect the simulation. However, there may be instances where you want to introduce
horizontal boundaries. For these instances, you can use boxes or waveguides.

Boxes and waveguides enable you to specify substrate boundaries in the horizontal
direction. A box enables you to set boundaries on four sides of the substrate. A waveguide
enables you to set boundaries on two sides.

More specifically, for a box, you define four perpendicular vertical planes of perfect metal
as the horizontal boundaries of the substrate. These four vertical planes, or walls, form a
rectangle, if you are looking at the circuit from the top, along the z-axis. A box can be
used only where the top and bottom layers in the substrate definition are groundplanes or
impedance termination. Thus, the four vertical metal walls, plus the top and bottom
groundplanes result in a box, hence the name (the walls are the sides, and the top and
bottom ground planes are lid and base of the box).

A waveguide is similar, although for a waveguide you specify only two parallel walls. The
substrate is therefore only bounded in the horizontal direction perpendicular to these
walls. In the horizontal direction parallel to these walls, the substrate still extends to
infinity. The top and bottom layers of the substrate must also be defined as groundplanes.
The two sidewalls in combination and the top and bottom covers form a waveguide.

 

 Adding a Box

  A box defines the boundaries on four sides of the circuit substrate. Either one box or one
waveguide can be applied to a circuit at a time. A box can be applied to a circuit only if
the top and bottom layers of the substrate definition are defined as ground planes or
impedance termination. The walls of the box are perfect metal. The ground planes can be
defined either as perfect metals or a losse metal.

Adding a box to the circuit enables you to analyze the effects of enclosing the circuit in
metal, for example, to identify box resonance. Box resonance can have a significant effect
on S-parameters in a small band centered around the box resonance frequency. When a
simulation is performed, the resonance frequencies will be noted in the status window
when the circuit is simulated, along with the frequency bands where no smooth S-
parameters can be calculated.

During a simulation, all current directions on the sidewalls of the box are taken into
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account.

Note
Calibrated ports in the circuit (i.e., Single, Differential, Coplanar and Common mode ports) must be
located on and perpendicular to the box edge, or an error will occur. Internal (uncalibrated) ports may be
placed anywhere in the circuit and point in any direction.

To add a box:

Choose EM > Box-Waveguide > Add Box.1.
Position the mouse and click to define a corner of the box. Move the mouse to the2.
diagonal corner and click once in the layout window.

You can also add a box by performing the following steps:

Choose EM > Box-Waveguide > Add Box.1.
From the Layout menu bar choose Insert > Coordinate Entry to open the2.
Coordinate Entry dialog box.
Specify a value in the Coordinate Entry X and Coordinate Entry Y fields to specify3.
a corner of the box.
Click Apply.4.

 

 Editing a Box

  Once the box is applied, you cannot change its dimensions. If you want to change the
size, you must delete the current box and add a new one.

 

 Deleting a Box

To delete a box, choose EM > Box-Waveguide > Delete Box.

 

 Viewing Layout Layer Settings of a Box

  The box is defined as a layout layer named momentum_box. You may review the layout
layer settings, but it is a protected layer, so you should not change the settings of this
layer.
To view the box layer specifications:

Choose Options > Layers.1.
Select momentum_box from the Layers list. The layer settings are displayed. For2.
more information on these parameters, refer to Schematic Capture and Layout
(usrguide).

 

 Adding a Waveguide

  A waveguide defines the boundaries on two, parallel sides of the circuit substrate. Either
one box or one waveguide can be applied to a circuit at a time. A waveguide can be
applied to a circuit only if the top and bottom layers of the substrate definition are defined
as ground planes or impedance termination. The walls of the waveguide are perfect metal.
The ground planes can be defined either as perfect metals or metal with loss.

During a simulation, all current directions on the sidewalls of the waveguide are taken into
account.
To add a waveguide:

Choose EM > Box-Waveguide > Add Waveguide. This opens the Add Waveguide1.
message window, as shown in the following figure:

Select the direction of the waveguide. To insert the waveguide parallel to the x-axis,2.
click X-axis. To insert the waveguide parallel to the y-axis, click Y-axis.
Position the mouse and click to define one wall of the waveguide. Move the mouse to3.
the position of a point on the second wall and click once in the layout window.

You can also add a waveguide by performing the following steps:
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Choose EM > Box-Waveguide > Add Waveguide.1.
Select the direction of the waveguide. To insert the waveguide parallel to the x-axis,2.
click X-axis. To insert the waveguide parallel to the y-axis, click Y-axis.
Choose Insert > Coordinate Entry in the layout.3.
Specify a value for the Coordinate Entry X and Coordinate Entry Y fields to4.
specify a point on the edge of the substrate.
Click Apply.5.
Enter the coordinates of a point on the second, parallel edge of the substrate and6.
click Apply.

These boundaries specify the edges of the substrate and the width of the waveguide.

 

 Editing a Waveguide

  Once the waveguide is applied, you cannot change its dimensions. If you want to change
the size, you must delete the current waveguide and add a new one.

 

 Deleting a Waveguide

  To delete a waveguide,

Select EM > Box-Waveguide > Delete Waveguide.1.
Click Yes in the message window to remove the waveguide from the layout.2.

 

 Viewing Layout Layer Settings of a Waveguide

  The waveguide is defined as a layout layer named momentum_box. You may review the
layout layer settings, but it is a protected layer, so you should not change the settings of
this layer.

To view the waveguide layer specifications:

Choose Options > Layers.1.
Select momentum_box from the Layers list. The layer settings are displayed. For2.
more information on these parameters, refer to Schematic Capture and Layout
(usrguide).

 

 About Boxes and Waveguides

You may need to simulate a circuit in a box or waveguide in the following situations:

The actual circuit is enclosed in a metal box: Circuits are often encased in metal
enclosures. By adding a box to your design, the metal sidewalls that are present in
the real structure may be included in the simulation. This is useful is you suspect that
the presence of these sidewalls will have an immediate effect on the behavior of the
circuit. For example, "broad-coupled filters" are placed in metal enclosures (a box)
and the sidewalls can have an significant influence on the filter characteristics.

The nearby metal sidewalls may affect circuit performance: You may want to use a
box or waveguide because metal sidewalls are present in the real structure and there
may be an effect from these sidewalls on the characteristics of the circuit. This can be
a parasitic, unwanted effect. If the effects of the sidewalls were not taken into
account while designing the circuit, you can verify any effect that the sidewalls may
have on your circuit. In most cases, when the sidewalls are not too close to the
actual circuit, the effect of the sidewalls on the simulation results will be marginal.
There is, however a specific, significant condition, which is unique for structures with
sidewalls.

The box may resonate: A resonating box is a physical effect where, under the
condition of certain frequency and box size combination, the box actually starts
resonating at a certain frequency. Because a box resonance has a significant effect
on S-parameters in a (small) band centered around the box resonance frequency
which cannot be represented by a smooth function, no smooth adaptive S-
parameters will be available in this frequency band. When simulating such a circuit,
Momentum will inform you of these box resonance frequencies, of the frequency
bands where there will not be smooth S-parameters available and of the quality
factor (a measure for the sharpness of the box resonance, depending on the losses).
In the case of waveguide, the effect is the excitation of a waveguide mode. If your
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circuit will be positioned near sidewalls, you may want to add a waveguide to
determine whether they have an effect on the performance of the circuit.

The propagating modes may be present: You may have a situation where there are
no metal sidewalls in the structure, but the substrate definition is bounded by other
material (for example, you have a finite-size substrate where the dielectric material
abruptly ends, so you have a dielectric-air transition). Although Momentum boxes
and waveguides are defined as perfect metals and not dielectric material, you may
decide that defining a metallic enclosure in the simulated circuit may be more
representative of the real structure than using no enclosure.

 Adding Absorbing Layers under a Cover

 You may want to model your box or waveguide as having absorbing layers between the
covers and the layout. You can use a substrate interface layer, define its thickness, and its
absorbing properties using ε and µ (make sure that ε and µ are accurate specifications for
this layer). Adding absorbing layers to a box would have an effect on any box resonances
that would occur by producing a weaker resonance, that is, the quality factor of the box
resonances would lower significantly.

 

 Boxes, Waveguides, and Radiation Patterns

 If you have a structure enclosed in a box or waveguide and you want to calculate
radiation patterns for it after the simulation, you need to set the top and bottom planes to
values between 376 and 378. There are also other considerations.

 Adding a Symmetry Plane

A symmetry plane defines the boundary on one side of the circuit substrate. Only one box,
or one waveguide, or one symmetry plane can be applied to a circuit at a time. When a
symmetry plane is defined, the simulation results will be equivalent to the results of a
larger circuit that would be created by mirroring the circuit about the symmetry plane. For
symmetric circuits, this enables faster simulations that require less memory because only
half the actual structure needs to be simulated.

To add a symmetry plane:

Choose EM > FEM Symmetry Plane > Add Symmetry Plane.1.
Select the direction of the symmetry plane. To insert the symmetry plane parallel to2.
the x-axis, click X-axis. To insert the symmetry plane parallel to the y-axis, click Y-
axis.
Insert the symmetry plane using one of the following two methods:3.

Position the mouse and click to define the location of the symmetry plane.
From the Layout menu bar choose Insert > Coordinate Entry and use the
Coordinate Entry X and Coordinate Entry Y fields to specify a point on the edge
of the substrate.

Click Apply.4.

This boundary specifies the edge of the substrate where the plane of symmetry will be
applied.

 Editing a Symmetry Plane

Once the symmetry plane is applied, you cannot change its location. If you want to
change the location or orientation, you must delete the current symmetry plane and add a
new one.

 Deleting a Symmetry Plane

To delete a symmetry plane:

Choose EM > FEM Symmetry Plane> Delete Symmetry Plane. The symmetry1.
plane is removed from the layout.
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 Defining Component Parameters
You can define parameters for a component in a layout that enable you to sweep, tune, or
optimize geometrical (shape) variations of planar layout objects. You can specify the
following parameters for a component:

Dimensions such as lengths, widths, gaps, spacing, or diameters.
Interdependent layout modifications such as length and width varying
simultaneously.
Unconventional layout modifications such as varying port locations.

Note
There is a limit of 100 layout parameters per component.

There are two ways to create a parameterized layout:

Using nominal/perturbed designs
Using subnetwork parameters

These approaches are mutually exclusive and you cannot combine them when defining
parameters for a single component. Nominal/perturbed parameters can be defined when
the layout is flattened and contains only ports and primitive artwork shapes (such as
polygons, rectangles, and circles). When a combination of existing (built-in or custom
defined) layout components and any other type of artwork primitives are used, the layout
is hierarchical and only subnetwork parameters can be used.

 

 Using Nominal/Perturbed Designs

To define a parameter you need to provide a separate design to show the program how an
incremental change in that parameter value affects your original layout. The original
layout is referred to as the nominal design and the new layout is called a perturbed design
. The program will guide you through this process. When you add a new parameter a
separate design containing a copy of the nominal design is created. You should make your
changes in this design by applying perturbations as specified in the Edit/View perturbation
dialog. The modified copy is then saved as the perturbed design. You need to define a
separate perturbed design for each parameter.

Select EM > Component > Parameters to open the Design Parameters dialog box.1.

Type a parameter name in the Name text box.2.
Ensure Nominal/Perturbed is selected in the Type drop-down list.3.
Type a nominal value and select a unit from the drop-down list.4.
Type a perturbed value.5.
Click Add to add the parameter or Edit/View Perturbation to display the Edit/View6.
Perturbation dialog box where you can specify a Linear Stretch, Radial Stretch, or
Rotation perturbation for the specified parameter.

The following section describes these values.

 Linear Stretch

Specifying a linear stretch for a parameter enables you to move a single selected vertex
point or a group of selected vertex points linearly using a deltaX, deltaY specification.
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 Radial Stretch

Specifying a radial stretch for a parameter enables you to move a single selected vertex
point or a group of selected vertex points radially by specifying the centerX, centerY
coordinates of the center point and a factor. The following illustration shows the effect of
the factor on the selected vertex points.

 

 Rotation

Specifying a rotation for a parameter enables you to move a single selected vertex point
or a group of selected vertex points by rotating over a specified angle around a center
point specified by the coordinates centerX and centerY.
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 Using Subnetwork Design

A parameterized layout can be set up using a combination of several built-in components.
You can define a subnetwork for hierarchical components only.

To specify subnetwork parameters for the layout component:

Select EM > Component > Parameters to open the Design Parameters dialog box.1.

Type a parameter name in the Name text box.2.
Select Subnetwork in the Type drop-down list.3.
Type a default value and select a unit from the drop-down list.4.
Click Add to add the parameter.5.

Once a subnetwork parameter is defined, it can be used to set the parameters values of
one or more component instances used in the layout.

Caution
Only the top-level design parameters can be used to set the lower level instance parameters. The use of
any other variable is prohibited.
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 Performing Momentum Circuit
Excitation
You can use the Momentum Circuit Excitation AEL addon to run an AC or Harmonic
Balance simulation on a schematic that contains an EM Model and any other circuit
elements, such as SMDs. The voltages at all pins of the EM Model are stored. Also, the
voltage isvused to compute the surface current distribution (and optionally the far field)
based on this extracted excitation.

 Enabling the Momentum Circuit Excitation AEL Addon

To enable the Momentum Circuit Excitation AEL Addon:

Select Tools > Manage ADS AEL Addons in the ADS Main window.1.
Select the Enabled check box for Momentum Circuit Excitation, as shown in the2.
following figure:

Click Close.3.

 Creating EM Models

You can create an EM Model by using an EM setup. While creating the EM model, do not
select the Include S-Parameter data only check box. Selecting this check box, includes
not only the S-Parameter data, but also the required data for EM visualization. If you
select this check box, instances with such setup are not taken up by subsequent
processes.

Note
The Momentum Circuit Excitation AEL Addon currently supports only Momentum RF and Momentum
Microwave as simulators for EM Models.

For more information, refer Generating EM Model and Symbol (em).

Note
Only frequencies calculated by Momentum can be shown in the EM visualization. If you want to see
surface currents and/or far field at explicit frequencies, add such frequencies in your EM Setup frequency
plan.

 Creating Circuits for AC/HB

Momentum Circuit Excitation works for circuits with single or multiple EM Models and a
AC/Harmonic Balance simulation controller. Parameter sweep is also available. The
following figure displays an example of a circuit with AC simulation controller:
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For creating circuits for AC/HB, choose an EM Model view explicitly for the required
instances. Only such instances are available for EM visualization. The excitation voltages
for each instance for EM visualization is interpolated or extrapolated based on available
frequencies of the AC/Harmonic Balance simulation.

Note
Currently AC and Harmonic balance simulation are supported.

 Running AC/HB Simulation

Select Momentum > Circuit Excitation in the schematic window. The Circuit1.
Excitation dialog box is displayed, as shown in the following figure:

Click Run AC/HB Simulation to start circuit simulation and post processing.2.

Note
If you have included an optimization controller in your circuit and want to run optimization, select
the Optimization check box. However, if you have selected Enable Optimization Cockpit in the
optimization controller, optimization flow might not work properly from this tool. To avoid this issue,
you can disable this option. In the schematic, double-click Optimization controller, select the
Parameters tab, and remove selection from Enable Optimization Cockpit.

A message box stating that Compute excitation is all finished is displayed.3.

 Viewing Results

To view surface currents:

Select an instance from the Instance drop-down list.1.
Click Open Visualization.2.
In the EM Visualization window, select the Solution Setup tab.3.
Select Extracted Excitation.4.

Note
It is recommended to reset the maximum amplitude for plots after selecting Extracted Excitation
because it has largely different maximum amplitude than Single Mode Excitation. To reset
maximum amplitude for each plots type, click Options > Restore System Max/Min.

Select a state and frequency for displaying the results.5.
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Note
If you swept parameters by parameter sweep, each of these simulation becomes a State.

To view far fields:

Select an instance in the Instance drop-down combo box.1.
Select the Far Field (uW mode only) check box and select a frequency.2.
Click Open Visualization to view results, as shown in the following figure:3.
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 Designing a Microstrip Line
In this section, you will be introduced to the concept of setting up EM simulation for a
Microstrip Line design. You will use default settings and a simple circuit to create a
Microstrip Line design with step in width.

For designing a Microstrip Line component, you will perform the following tasks:

Draw a simple Microstrip Line design with step in width as a schematic.
Generate a corresponding layout.
Create a simple substrate.
Define a mesh.
Perform an EM simulation using both Momentum and FEM.
Analyze the results.

The schematic representation of the Microstrip Line design is displayed below:

The layout representation of the Microstrip Line design is displayed below:

 Drawing the Circuit

To start the process of designing a Microstrip Line component, you need to draw the
circuit by:

Creating a new workspace.
Adding Microstrip components to the schematic.
Converting the schematic to a layout.

 Creating a New Workspace

To create a new workspace:

From the ADS Main window, choose File > New > Workspace to display New1.
Workspace Wizard.
Click Next.2.
In the Workspace Name field, type step1.3.
Enter a path in Create In. Click Browse to select the location.4.
Click Next.5.
Under Add Libraries, select the libraries to be included in the Workspace, as shown6.
in the following figure:

Click Next.7.
Under Library Name, enter a unique library name.8.
Click Next.9.
Under Technology, choose ADS Standard: length unit - mil.10.
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Click Finish.11.

For more information about a workspace, refer Using Workspace (adstour).

 Adding Microstrip Line components to the Schematic

To create a new schematic:

Choose File > New > Schematic.1.
Create a new schematic step_1 in library step_1_lib.2.

For more information about a schematic, refer to Creating a New Schematic (adstour).

After creating a schematic, select a component and place it in the Schematic window.

 Placing Components in a Schematic

To select and place components in a Schematic window:

Click the Palette drop-down list.1.
Select TLines-Microstrip from the list.2.

Click MLin in the Microstrip Transmission Lines palette.3.

Move the crosshairs to the Schematic window and click once to place the component.4.
A schematic representation of the component is placed in the Schematic window.
Move the cursor to place the crosshairs directly on the right pin of the first5.
component, and then click once to place the second component.

 Canceling Commands

If you continue to click without ending the current command, you will add another

component with each click. To cancel a command, click the arrow button ( ). You can
also end a command by pressing the Escape key.

 Editing Component Parameters

This section describes how to change the width of one of the strips to create a Microstrip
Line step in width transmission line.

To edit components:

Click twice on the second component that you placed. The Libra Microstrip Line dialog1.
box opens.
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In the Select Parameter field, select the W to specify the width. When the field to2.
the right shows the value of the width, change the value in this field to 35 mil.
Click Apply.3.
Click OK.4.

Note
If a parameter for a component is displayed in the Schematic window, you can also edit that
parameter by clicking the value and entering a new value.

Verify that the width of component on the left is set to 25 mil.5.

 Adding Pins to the Circuit

To complete the circuit, you must add pins, one at the beginning of the Microstrip Line
component step in width and one at the end. This section describes how to add pins to the
circuit.

To add pins:

Click Pin ( ) in the menu bar.1.
Move the cursor over the Schematic window and note the orientation of the ghost2.
icon of the pin.
Click Rotate to rotate the port to the necessary orientation.3.
Move the cursor over the open pin on the left side of the left component, then click4.
once.
To insert a second port, change the orientation appropriately, move the cursor over5.
the open pin on the right side of the right component, then click once.

Click  to cancel the current command. Your schematic displays a Microstrip Line6.
step in width. The width of the first part of the line is 25 mil, and it increases to a
width of 35 mil. The overall length is 200 mil, as shown in the following figure:

Note
Diamond-shaped pins indicate that pins are not connected. You need to select and move
components to form complete connections.

 Saving a Design

To save your design, choose File > Save.

 Generating a Layout

Since EM simulations require a circuit in the layout format, it gives you the option of
drawing your circuits either as schematics or as layouts.
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Note
If you choose to draw in a Schematic window, footprints of the components you use must also be available
in Layout. Components that are available in Layout include transmission lines and lumped components
with artwork.

To covert the Microstrip Line design with step in width schematic:

In the Schematic window, choose Layout > Generate/Update Layout. The1.
Generate/Update Layout dialog box appears. It is not necessary to edit fields.
Click OK. The Layout Generation message appears indicating that the conversion is2.
complete.
Click OK.3.
A Layout window appears, which displays a layout representation of the schematic.4.
This window may be hidden by the Schematic window, so you may need to move
some windows to locate the Layout window.
From the Layout window, choose File > Save. You now have a layout and a5.
schematic as part of your library step_1.

 Creating a Simple Substrate

A substrate is required as part of your planar circuit. The substrate describes the media
where the circuit exists. An example of a substrate is the substrate of a multilayer circuit
board, which consists of:

Layers of metal traces
Layers of insulating material between the traces
Ground planes
Vias connecting traces on different layers
Air surrounding the circuit board

In ADS 2011, substrates are part of the Technology dialog box used for a library. For the
Microstrip Line design having step in width example, a substrate having the following
layers is used:

Ground plane
Dielectric(insulation), such as Alumina
Metal layer for the Microstrip Line component
Air layer above the Microstrip component

 Defining the EM Setup

In the EM Setup window, you can specify settings for running a successful EM simulation.
If you do not provide correct information, an invalid symbol ( ) appears against the
options in the left pane of the EM Setup window.

To specify the EM simulation settings:

Choose EM > Simulation Setup to open the EM Setup window.1.

Select Substrate in the left pane of the EM Setup window.2.
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Select Frequency Plan and add the frequency range for simulation. By default, an3.
adaptive frequency plan from 0 Ghz to 10 Ghz is added. The EM setup becomes valid
on adding the frequency plan. For more information, refer to Defining the Frequency
and Output Plan (em).

Note
At this stage, if you want to start the simulation, click the Simulate button at the bottom of EM
Setup window.

Select Layout to gather information about the Layout for which this EM setup is4.
prepared. For more information, refer to Viewing Layout Information (em).
Select Substrate to display the substrate used for the simulation. For more5.
information, refer to Assigning Substrate (em).
Select Ports to gather information about the ports being generated from the pins6.
defined in the layout. EM simulations need ports to inject energy into system. For
more information, refer to Generating Ports (em).
Select Output plan to specify a name for the EM dataset.7.
Select Options to specify mesh, preprocessor, and solver options. For more8.
information, refer to Defining Simulation Options (em).
Select Resources to specify computer resources options. For more information, refer9.
to Specifying Simulation Resources (em).
Select Model/Symbol to generate an EM model and symbol. For more information,10.
refer to Generating EM Model and Symbol (em).
Select Note to add any specific note about the simulation.11.
Save the EM settings by selecting File > Save.12.
Click Simulate in the EM Setup window to start the EEsof Job manager and EEsof13.
Job log window for the currently running momentum simulation.
After the simulation is complete, the Data Display window opens automatically:14.

 Viewing Results

Load S11 plot on the Data Display window, as shown in the following figure:

 Switching Simulation Engines

For changing the mode of simulation to FEM, open the EM Setup window and select FEM.
Once the mode is changed to FEM, the EM setup remains valid for the FEM simulator.

Note
Selecting the FEM simulator changes the dataset name in Output plan to step1_fem.

Clicking Simulate in the EM Setup window launches the EEsof Log window for the FEM
simulation. After completion of the FEM simulation, a data display window is displayed:
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S11 plot for FEM is shown below:

 Comparing Momentum and FEM Results

Load the plots from both Momentum and FEM and compare the results. Comparison plots
are shown below:
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 Using an EM Model
An EM Model is used by a circuit simulator to model a component by using the S-
parameters generated by an EM simulation. The EM-based S-parameters can be
precomputed or you can generate them while running the circuit simulation. An EM Model
caches the S-parameters to improve performance. EM Models are compatible with
Dynamic Model Selection, which enables you to switch between two different models for
the same cell. For example, a faster, schematic-based representation, and an accurate
EM-based representation.

Note
In ADS 2009 Update 1 and earlier, a Layout Component is used instead of an EM Model. For more
information, refer Difference between Layout Components and EM Models.

While working with multiple libraries, you need to ensure correct references are build
between multiple libraries. The EM Model generation while running the circuit simulation
requires that the library of the testbench schematic references the technology from the
library where the cell to be modeled by EM is defined. For example, a cell to be modeled
by EM is defined in library1_lib, and this cell is instantiated in a schematic testbench
defined in library2_lib. Then it is required that library2_lib references the technology
definition of library1_lib. Otherwise, the EM model generation will fail because the
substrate is not known in library2_lib.

 Creating an EM Model

To create an EM model:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Model/Symbol in the left pane of the EM Setup window.2.
Click Create EM model when simulation is launched to create an EM model after3.
the simulation process.
To generate an EM model immediately, click Create Now. The following figure4.
displays an EM model:

Note
If this button is labeled Update Now, the EM Model already exists for this cell.

The default name for an EM Model is emModel. It is recommended to use the default
name. You can also create an EM Model by using the following methods:

In the layout window, choose EM > Component > Create EM Model and Symbol.
In the EM Setup window, select Model/Symbol in the left pane. If you select
Update EM Model when simulation is launched, the EM Model will be created (or
updated if it already exists) whenever you run an EM simulation.

 Using an EM Model Window
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When an EM Model is created from an EM Setup window, all the settings specified in the
EM setup window are copied to the EM Model. Later, during a circuit simulation, if the EM
Model needs to run an EM simulation to generate on-demand S-parameters, this copy of
the settings is used to launch the EM simulation.

The EM Model window consists of four tabs: Simulation Setup, Database, Interpolation,
and Options. The following sections describe the tasks that you can perform using these
tabs.

 Viewing Simulation Setup Summary

You can view a summary of your EM simulation setup in the Simulation Setup tab. This
tab provides information about the type of simulator, layout, substrate, ports defined for
your simulation, frequency and output plans, simulation options and resources, and EM
model and symbol information.

You can view the EM setup details and modify the setup by clicking Edit.

Note
When you change the value of a simulation option that affects the EM simulation results, the system
deletes all the EM results cached in the EM Model. For more information, refer Using the EM Model
Database.

 Viewing Database

You can view the available data by using the Database tab. This tab provides information
about the database name, L1, L2, and S values. You can also remove databases from the
list by clicking Delete or Delete All. The following figure displays the Database tab:
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 Specifying Interpolation Options

You can specify the interpolation parameters in the Interpolation tab. This tab provides
information about the cell parameters, interpolation delta, and resolution values, as shown
in the following figure:

Specify appropriate units. In the absence of a unit name, MKS units are assumed.

 Specifying Frequency Options

You can specify the frequency options in the Options tab. You can select values for the
extrapolation mode and enforce passivity, as shown in the following figure:
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You can specify the following values for the extrapolation mode:

Linear (default): A linear extrapolation scheme is used for both magnitude and
phase. By default, passivity of the S-parameter model is enforced during
extrapolation.
Constant: The S-parameters at the lowest or highest available frequency are used.
Exponential e-damping: A mixed extrapolation scheme is used. S-parameters at kept
constant during extrapolation towards low frequencies. Towards high frequencies, S-
parameters are e-damped in magnitude and linearly extrapolated versus phase.

The passivity of the S-parameter model can be enforced. You can enable or disable
passivity enforcement through the Enforce Passivity parameter. You can specify the
following values for enforce passivity:

Only when extrapolating: S-parameter model passivity is enforced only during
frequency domain extrapolation.
Always: S-parameter model passivity is enforced at all frequencies.
Never: S-parameter model passivity is not enforced.

 Updating an EM Model

If you create an EM Model from an EM Setup and then change some settings in the EM
Setup, the changes are not updated in the EM Model because it contains a copy of the EM
setup. To copy the modified EM Setup to the EM Model:

Choose EM > Simulation Setup to open the EM Setup window.1.
Select Model/Symbol in the left pane of the EM Setup window.2.
Click Update Now in the EM Model panel.3.

Note
If this button is labeled as Create Now, then the EM Model does not exist for that cell.

When you update an EM Model and this causes the EM Model setup to change in a way
that affects the EM simulation results, the system deletes all the cached EM results. See
The EM Model database for more information.

You can also update an EM Model by using the following methods:

In the layout window, choose EM > Component > Create EM Model and Symbol.
In the EM Setup window, on the Model/Symbol page, check Update EM Model
when simulation is launched. With this checked, every time you run an EM
simulation using this EM Setup, the EM Model will be updated (or created if it doesn’t
exist).
Using an EM Model for circuit simulation.
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 Using an EM Model for Circuit Simulation

 Default View used by a Circuit Simulation

By default, the Schematic view is used by ADS circuit simulation before a view named
emModel. Therefore, if you insert an instance of a cell that has an EM Model view named
emModel, there are two possibilities:

If the cell has no view named schematic, then the EM Model view named emModel is
used for circuit simulation.
If the cell has a view named schematic, the EM Model view is not used for circuit
simulation. Instead, the view named schematic is used.

You can change the default behavior by using Dynamic Model Selection. For more
information, refer Dynamic Model Selection (cktsim).

To find the view that is used for a particular instance during circuit simulation, open the
top-level schematic and choose Simulate > Hierarchy Explorer. In the Hierarchy
Explorer dialog box, find the instance name in the Instance column. Then search in the
View for Simulation column to find the view that will be used for circuit simulation. If
the view for simulation is not emModel, you need to specify the system to use emModel.

 Specifying an EM Model for Circuit Simulation

To specify the view to be used for a circuit simulation:

Select the instance on the schematic.1.
Click the Choose View for Simulation toolbar button, immediately to the left of the2.
Simulate toolbar button. This dialog box lists all the views available for circuit-
simulation for the cell associated with this instance.
Select the view named emModel.3.
Click OK. The circuit simulator will now use the view named emModel for this4.
instance.

Note that the view name emModel is now displayed on the instance. This is a quick way to
tell whether a specific view has been chosen for an instance. You can use the Hierarchy
Explorer (choose Simulate > Hierarchy Explorer in the top-level schematic) to verify
that this change has taken effect.

If you specify emModel in the Choose View for Simulation dialog box, but the Hierarchy
Explorer shows that emModel is not the view that is used for circuit simulation, the top-
level schematic is using a hierarchy policy that has the Honor instance specializations
option selected.

 The EM Model Netlist for Circuit Simulation

When an EM Model is chosen for simulation, this view will be netlisted as part of the
simulation netlist. The S-parameter port definition contains the necessary information
about the connectivity between (symbol/layout) pins and the S-parameter ports. The
header of the EM Model lists all pins, sorted versus ascending pin number.

In case multiple pins are connected to either the plus or minus terminal of the S-
parameter port, the required transformers will be added to the EM Model netlist so that
the proper common and/or differential mode is applied to the S-parameter model.

 Using the EM Model Database

To improve circuit simulation performance, each EM Model maintains a database of the EM
simulation results. When a circuit simulator requests S-parameters from the EM Model, an
EM simulation is performed only when the S-parameters are not available in the database.
If an EM simulation is performed, the results are added to the database.

Any change that affects the EM simulation results causes an EM Model database to
become out of date. Examples of this type of changes are:

EM Model simulation setup changes: For example, changing the mesh density.
Changes to the cell parameter set: Adding a parameter to the cell or deleting a
parameter from the cell.
Substrate changes: For example, changing the thickness of a metal layer in the
substrate.
Layout changes: For example, adding shapes or components to the layout.

The EM model automatically detects changes to the EM Model and changes to the cell
parameter set. When such a change is detected, the EM Model automatically deletes its
database. However, other changes are not automatically detected. If you make such a
change, you should open the EM Model, access the Database tab and click Delete All.
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 Specifying EM Model Options

To specify the EM Model options:

Choose File> Open> EM Model.1.
Select the required EM Model, as shown in the following figure:2.

Click OK. The selected EM Model is displayed.3.
Select the Interpolation tab in the EM Model window.4.
Select Use Interpolation.5.
Specify a value for the Interpolation Delta field for the required cell parameter.6.
Specify a value for the Resolution field.7.

Select the Options tab in the EM Model window.8.
Select a value from the Extrapolation Mode drop-down list.9.
Select a value from the Enforce Passivity drop-down list.10.

 Difference between Layout Components and EM Models

In ADS 2009 Update 1 and earlier versions, you used a special type of component called a
layout component. A layout component consists of the following features:

Symbol: A symbol is a layout look-alike symbol.

Model: In a circuit simulation, you can model a layout component by:
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A schematic
EM-based S-parameters
File-based S-parameters

In ADS 2011, these features are still available, but due to the cell and view structure of
libraries, they are separated into two distinct features:

Symbol views: The system provides a command to generate a layout look-alike
symbol.
Dynamic Model Selection: You can specify which model to use for a circuit simulation:

A schematic view
A layout view
An EM Model view provides a model that uses EM-based S-parameters
File-based models can be implemented by creating a schematic view and
inserting one or more Data components on it

Note
There is an AEL addon to create a schematic view with SNP component and ports. For more
information and download, see here

 EM Model Options

In ADS 2009 Update 1 and earlier, many EM simulation options (such as substrate name,
frequency plan, and mesh density) are specified as parameters of each instance of the
layout component. In ADS 2011, these parameters are no longer instance parameters.
Instead, they are options of the EM Model. This leads to some differences in behavior.

To illustrate the differences, assume that you want to change the mesh density from 20
cells per wavelength to 30 cells per wavelength. First, assume that you want to make this
change globally, that is, you want all instances of this component to use 30 cells per
wavelength. In ADS 2009 Update 1 and earlier, you need to find every instance of the
component, double-click it, and change the mesh density to 30. If you miss an instance,
that instance will continue to use 20 cells per wavelength while all the other instances use
30. In ADS 2011, you simply go to the EM Model view and change the mesh density to 30.
All instances that use this EM Model for circuit simulation will use the new value of 30.

As a second example, assume you want to change the mesh density from 20 to 30, but
you want that change to apply only to instance A of the component. You want instance B
to continue to use the old value of 20. In ADS 2009 Update 1 and earlier, you simply go to
instance A, double-click it, and change the mesh density to 30. In ADS 2011, an EM Model
has only one value for the mesh density. To use two different values, you need two
separate EM Models. To do this, open the EM Model and choose File > Save As to create
a second EM Model named emModel2. In this second version of the EM Model, which is a
copy of the first, change the mesh density to 30. Then, back on the schematic, select
instance A, click the Choose View for Simulation toolbar button, and set the view to
emModel2.

 Sweeping Substrate Name and Mesh Density

To support sweeps over a substrate name, you can add Substrate as a cell parameter of
the string type. For more information about how to define a parameter, see Defining
Parameters (usrguide). You can also use an example for illustrating the sweeping
substrate name by performing the following steps:

Select File > Open > Examples. The Choose an Archived Example to open dialog1.
box is displayed.
Double-click Momentum and then open emcktcosim.2.
Select Sweep_Substrate_Parameters_wrk.7zap.3.
Click Open.4.

Similarly, for Momentum only, you can define MeshDensity as a cell parameter of the
integer type to support sweeps over the mesh density.

http://edocs.soco.agilent.com/display/eesofkc/Be_successful_with_SnP_components._Add-On_Utility_that_helps_in_easy_simulation_setup_for_SnP_components._-_ADS_2011
http://edocs.soco.agilent.com/display/eesofkc/Be_successful_with_SnP_components._Add-On_Utility_that_helps_in_easy_simulation_setup_for_SnP_components._-_ADS_2011


EM Simulation

157

 Using EM Simulators
Using FEM (em)
Using Momentum (em)
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 Using FEM
An FEM simulator provides a complete solution for electromagnetic simulation of
arbitrarily-shaped and passive three-dimensional structures. FEM simulators create full 3D
EM simulation an attractive option for designers working with RF circuits, MMICs, PC
boards, modules, and Signal Integrity applications. It provides the best
price/performance, 3D EM simulator on the market, with a full 3D electromagnetic field
solver, and fully automated meshing and convergence capabilities for modeling arbitrary
3D shapes such as bond wires and finite dielectric substrates. Along with Momentum, FEM
simulators provide RF and microwave engineers access to some of the most
comprehensive EM simulation tools in the industry.

Developed with the designer of high-frequency/high-speed circuits in mind, FEM Simulator
offers a powerful finite-element EM simulator that solves a wide array of applications with
impressive accuracy and speed.

By combining fast solution times, efficient memory usage, and powerful display
capabilities, FEM Simulator for ADS delivers leading price/performance solution to complex
high-frequency problems. FEM Simulator for ADS users need very little background in
electromagnetic field theory in order to operate and achieve accurate, and meaningful
solutions.

 Major Features and Benefits

FEM Simulator comes with a list of impressive features. These key technological enablers
demonstrate the advantages of full 3D EM design and verification which include:

Conductors, resistors, isotropic dielectrics, isotropic linear magnetic material
modeling that allow a wide range of application coverage.
An unlimited number of ports, which enables simulating multi-I/O design applications
such as packages.
Electric and magnetic fields modeling, enabling visualization of EM fields in a design.
Absorbing boundary condition (free space), enabling antenna modeling.
Full-wave, EM-accuracy for first-pass design success.
Antenna parameters (gain, directivity, polarization, and so on), to enable better
insight into antenna design.
FEM Simulator/ADS integration providing an integrated approach to EM/Circuit
design.

 

 Application Areas

EM modeling tools are known for their great accuracy. FEM Simulator redefines this term
with broad application coverage, including the following:

Microstrip, stripline, CPW elements (filters, couplers, spiral inductors, via holes, air
bridges, meander lines...)
Multilayer structures
Ceramic filters
Adapters/transitions
Antennas
Couplers
Power splitters/combiners

 

 Visualization and Display of Results

The visualization and animation capabilities in FEM Simulator enable you to evaluate
simulation results thoroughly.

To aid in analyzing your designs, EM field animation and dynamic rotation of structures
can be performed simultaneously. Choose from shaded plots, contour lines, or vectors. 3D
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far-field plots illustrate beam shapes in both azimuth and elevation on a single plot. To aid
in analyzing your designs, EM field animation and dynamic rotation of structures can be
performed simultaneously. Choose from shaded plots, contour lines, or vectors. 3D far-
field plots illustrate beam shapes in both azimuth and elevation on a single plot.

 

 FEM Simulator Overview

   FEM commands are available from the Layout window. The following steps describe a
typical process for creating and simulating a design with FEM Simulator:

Create a physical design: You start with the physical dimensions of a planar1.
design, such as a patch antenna or the traces on a multilayer printed circuit board.
There are three ways to enter a design into Advanced Design System:

Convert a schematic into a physical layout
Draw the design using Layout
Import a layout from another simulator or design system. Advanced Design
System can import files in a variety of formats.
For information on converting schematics or drawing in Layout, see Schematic
Capture and Layout (usrguide) documentation. For information on importing
designs, see Importing and Exporting Designs (trans) documentation.

Define the substrate characteristics: A substrate (em) is the media upon which2.
the circuit resides. For example, a multilayer PC board consists of various layers of
metal, insulating or dielectric material, and ground planes. Other designs may include
covers, or they may be open and radiate into air. A complete substrate definition is
required in order to simulate a design. The substrate definition includes the number
of layers in the substrate and the composition of each layer. This is also where you
position the layers of your physical design within the substrate, and specify the
material characteristics of these layers.
Assign port properties: Ports (em) enable you to inject energy into a circuit, which3.
is necessary in order to analyze the behavior of your circuit. You apply ports to a
circuit when you create the circuit, and then assign port properties in FEM Simulator.
There are several different types of ports that you can use in your circuit, depending
on your application.
Add a box or a waveguide: These elements enable you to specify boundaries on4.
substrates along the horizontal plane. Without a box or waveguide, the substrate is
treated as being infinitely long in the horizontal direction. This treatment is
acceptable for many designs, but there may be instances where a boundaries need to
be taken into account during the simulation process. A box specifies the boundaries
as four perpendicular, vertical walls that make a box around the substrate. A
waveguide specifies two vertical walls that cut two sides of the substrate. For more
information, see Adding Boxes, Waveguides, and Symmetry Planes (em).
Set Simulation Options: A mesh is a pattern of tetrrahedra that is applied to a5.
design in order to break down (discretize) the design into small cells. A mesh is
required in order to simulate the design effectively. You can specify a variety of mesh
parameters to customize the mesh to your design, or use default values and let FEM
Simulator generate an optimal mesh automatically.
Simulate the circuit: You set up a simulation by specifying the parameters of a6.
frequency plan, such as the frequency range of the simulation and the sweep type.
When the setup is complete, you run the simulation. The simulation process uses the
mesh pattern, and the electric fields in the design are calculated. S-parameters are
then computed based on the electric fields. If the Adaptive Frequency Sample sweep
type is chosen, a fast, accurate simulation is generated, based on a rational fit
model.
View the results: The data from an FEM simulation is saved as S-parameters or as7.
fields. Use the Data Display or Visualization to view S-parameters and far-field
radiation patterns. For more information, see Viewing 3D Simulations (em).
Radiation patterns: Once the electric fields on the circuit are known, the8.
electromagnetic fields can be computed. They can be expressed in the spherical
coordinate system attached to your circuit. For more information on radiation
patterns, see Computing Radiation Patterns (em)
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 Using Momentum
Momentum is a part of Advanced Design System and gives you the simulation tools you
need to evaluate and design modern communications systems products. Momentum is an
electromagnetic simulator that computes S-parameters for general planar circuits,
including microstrip, slotline, stripline, coplanar waveguide, and other topologies. Vias and
airbridges connect topologies between layers that enable you to simulate multilayer
RF/microwave printed circuit boards, hybrids, multichip modules, and integrated circuits.
Momentum provides a complete tool set to predict the performance of high-frequency
circuit boards, antennas, and ICs.

Momentum Optimization extends Momentum capability to a true design automation tool.
The Momentum Optimization process varies geometry parameters automatically to help
you achieve the optimal structure that meets the circuit or device performance goals. By
using (parameterized) layout components you can also perform Momentum optimizations
from the schematic page.

Momentum Visualization is an option that gives users a 3-dimensional perspective of
simulation results, enabling you to view and animate current flow in conductors and slots,
and view both 2D and 3D representations of far-field radiation patterns.

 Momentum Major Benefits

Momentum enables you to:

Simulate when a circuit model range is exceeded or the model does not exist.
Identify parasitic coupling between components.
Go beyond simple analysis and verification to design automation of circuit
performance.
Visualize current flow and 3-dimensional displays of far-field radiation

 Momentum Major Features

Key features of Momentum include:

An electromagnetic simulator based on the Method of Moments.
Adaptive frequency sampling for fast, accurate, simulation results.
Optimization tools that alter geometric dimensions of a design to achieve
performance specifications.
Comprehensive data display tools for viewing results.
Equation and expression capability for performing calculations on simulated data.
Full integration in the ADS circuit simulation environment allowing EM/Circuit co-
simulation and co-optimization.

 Momentum Overview

Perform the following steps for creating and simulating a design with Momentum:

Choose Momentum or Momentum RF mode: Momentum can operate in two1.
simulation modes: microwave or RF. You can select the mode based on your design
goals. Use Momentum (microwave) mode for designs requiring full-wave
electromagnetic simulations that include microwave radiation effects. Use Momentum
RF mode for designs that are geometrically complex, electrically small, and do not
radiate. You might also choose Momentum RF mode for quick simulations on new
microwave models that can ignore radiation effects, and to conserve computer
resources. 
Create a physical design: You start with the physical dimensions of a planar2.
design, such as a patch antenna or the traces on a multilayer printed circuit board.
There are three ways to enter a design into Advanced Design System:

Convert a schematic into a physical layout
Draw the design using Layout
Import a layout from another simulator or design system: Advanced Design
System can import files in a variety of formats.
For information on converting schematics or drawing in Layout, see Schematic
Capture and Layout (usrguide) documentation. For information on importing
designs, see Importing and Exporting Designs (trans) documentation.

Define the substrate characteristics: A substrate (em) is the media upon which3.
the circuit resides. For example, a multilayer PC board consists of various layers of
metal, insulating or dielectric material, and ground planes. Other designs may include
covers, or they may be open and radiate into air. A complete substrate definition is
required in order to simulate a design. The substrate definition includes the number
of layers in the substrate and the composition of each layer. This is also where you
position the layers of your physical design within the substrate, and specify the
material characteristics of these layers.
Assign port properties: Ports (em) enable you to inject energy into a circuit, which4.
is necessary in order to analyze the behavior of your circuit. You apply ports to a
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circuit when you create the circuit, and then assign port properties in FEM Simulator.
There are several different types of ports that you can use in your circuit, depending
on your application.
Add a box or a waveguide: These elements enable you to specify boundaries on5.
substrates along the horizontal plane. Without a box or waveguide, the substrate is
treated as being infinitely long in the horizontal direction. This treatment is
acceptable for many designs, but there may be instances where a boundaries need to
be taken into account during the simulation process. A box specifies the boundaries
as four perpendicular, vertical walls that make a box around the substrate. A
waveguide specifies two vertical walls that cut two sides of the substrate. For more
information, see Adding Boxes, Waveguides, and Symmetry Planes (em).
Set Simulation Options: A mesh is a pattern of tetrrahedra that is applied to a6.
design in order to break down (discretize) the design into small cells. A mesh is
required in order to simulate the design effectively. You can specify a variety of mesh
parameters to customize the mesh to your design, or use default values and let FEM
Simulator generate an optimal mesh automatically.
Simulate the circuit: You set up a simulation by specifying the parameters of a7.
frequency plan, such as the frequency range of the simulation and the sweep type.
When the setup is complete, you run the simulation. The simulation process uses the
mesh pattern, and the electric fields in the design are calculated. S-parameters are
then computed based on the electric fields. If the Adaptive Frequency Sample sweep
type is chosen, a fast, accurate simulation is generated, based on a rational fit
model.
View the results: The data from an FEM simulation is saved as S-parameters or as8.
fields. Use the Data Display or Visualization to view S-parameters and far-field
radiation patterns. For more information, see Viewing 3D Simulations (em).
Radiation patterns: Once the electric fields on the circuit are known, the9.
electromagnetic fields can be computed. They can be expressed in the spherical
coordinate system attached to your circuit. For more information on radiation
patterns, see Computing Radiation Patterns (em).

 

 About the Simulation Modes

An RF simulation mode to Momentum's existing microwave mode in ADS version 1.5. The
microwave mode is called Momentum; the RF mode is called Momentum RF. Momentum
RF provides accurate electromagnetic simulation performance at RF frequencies. At higher
frequencies, as radiation effects increase, the accuracy of the Momentum RF models
declines smoothly with increased frequency. Momentum RF addresses the need for faster,
more stable simulations down to DC, while conserving computer resources. Typical RF
applications include RF components and circuits on chips, modules, and boards, as well as
digital and analog RF interconnects and packages.

When compared to the Momentum mode, the Momentum RF mode uses new technologies
enabling it to simulate physical designs at RF frequencies with several useful benefits. The
RF mode is based on quasi-static electromagnetic functions enabling faster simulation of
designs. Momentum RF has the same use-model as Momentum in ADS, and works with
Momentum Visualization and Optimization.

 Selecting the Correct Mode

 Selecting the Momentum Simulation Mode

From the EM Setup window, you can choose the required simulation mode. In each case,
the menu label in the EM Setup dialog box changes to the current mode. You can choose a
simulation mode based on your application. Each mode has its advantages. In addition to
specifically RF applications, Momentum RF can simulate microwave circuits. The following
graph identifies which mode is best suited for various applications.

Some applications can benefit from using either mode depending on your requirements.
As your requirements change, you can quickly switch modes to simulate the same physical
design. As an example, you may want to begin simulating microwave applications using
Momentum RF for quick, initial design and optimization iterations, then switch to
Momentum Microwave to include radiation effects for final design and optimization.
Momentum RF is an efficient mode for a circuit that is electrically small, geometrically
complex, and does not radiate.

In each case, the menu label in the Layout window changes to the current mode.

Deciding which mode to use depends on your application. Each mode has its advantages.
In addition to specifically RF applications, Momentum RF can simulate microwave circuits.
The following graph identifies which mode is best suited for various applications. As you
can see, some applications can benefit from using either mode depending on your
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requirements. As your requirements change, you can quickly switch modes to simulate the
same physical design. As an example, you may want to begin simulating microwave
applications using Momentum RF for quick, initial design and optimization iterations, then
switch to Momentum to include radiation effects for final design and optimization.

 Choose the mode that matches the application.

Momentum RF is usually the more efficient mode when a circuit

is electrically small
is geometrically complex
does not radiate

For descriptions about electrically small and geometrically complex circuits, see Matching
the Simulation Mode to Circuit Characteristics (em).

Note
For infinite ground planes with a loss conductivity specification, the MW mode of Momentum incorporates
the HF losses in ground planes, however, the RF mode of Momentum will make an abstraction of these HF
losses.

 

 Locating Examples

Examples of designs that are simulated using Momentum and Momentum RF can be found
in the Examples directory.
To open an example:

From the ADS Main window, choose File > Open > Example.1.
In the Choose an Archived Example to open dialog box, select Momentum.2.
Select the required example directory.3.
Click OK.4.

See Also
Theory of Operation for Momentum

http://edocs.soco.agilent.com/display/ads2011/Copy+of+Theory+of+Operation+for+Momentum
http://edocs.soco.agilent.com/display/ads2011/Copy+of+Theory+of+Operation+for+Momentum
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