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 About Netlist Translator for SPICE and
Spectre
Spectre is an EDA ( Electronic Design Automation) tool produced by Cadence Design
Systems, Inc. The Simulation Program with Integrated Circuit Emphasis (SPICE) was
developed at University of California Berkeley and has been commercialized and modified
by a large number of vendors. It has also been adopted and modified by electronics
companies for their own in-house use. Spectre and SPICE are used by engineers
throughout the world for simulating circuits of all types. Many designers and companies
have large investments in existing subcircuits or device models described by Spectre and
SPICE netlists that they want to use with the Advanced Design System (ADS) from Agilent
Technologies.

 

 Advanced Design System

 Advanced Design System has been developed specifically to simulate the entire
communications signal path. This unique solution integrates the widest variety of proven
RF, DSP, and electromagnetic design tools into a single, flexible environment. Building on
years of expertise developing new technologies for our EDA tools, such as Series IV and
MDS, Advanced Design System provides a broad range of high-performance capability.
This makes it easy to explore design ideas and model the electrical and physical design of
the best candidates.

  

 Netlist Translator

Providing the ability to simulate a Spectre or SPICE netlist in ADS is a fundamental
purpose of the Netlist Translator. The Netlist Translator is an ADS tool that enables you to
import netlists into schematics and/or netlists for use with the ADS simulator.

Since Spectre, SPICE, and ADS simulators use different simulator technology, there may
be incompatibilities between your original file and the resultant ADS file that the translator
is unable to resolve. The incompatibilities may show up as import errors,  simulation
errors or differences in simulation results.

Every attempt has been made to record these inconsistencies in the translator  log file,
nettrans.log. Detailed information in this documentation will help you identify and
understand these limitations.

  

 Major Benefits

The Netlist Translator enables you to perform the following:

Generate an ADS schematic from a Spectre or SPICE Netlist for use in circuit design
and simulation.

Generate an ADS netlist from a Spectre or SPICE Netlist for use in simulations.

Translate model files to incorporate them into ADS Design Kits.

  

 Major Features
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Key features of the Netlist Translator include the following:

Automatic ADS design generation that includes circuit schematic, required model
definitions and circuit equations or a reference to an equivalent ADS netlist to be
used directly in simulation.

Translation of component and model parameters to equivalent ADS parameters. In
some cases this requires additional equations if the parameters do not translate
directly. Parameters that cannot be translated are listed in the translator log file,
nettrans.log.

The NetlistInclude component can directly read a Spectre file. For more information
see NetlistInclude (ccsim).

 

 Supported SPICE and Spectre Dialects

The Netlist Translator supports several SPICE dialects that are widespread throughout the
electronics industry. The following table lists the five main dialects supported by the
translator.

 Supported SPICE and Spectre Dialects

Name Manufacturer Version

Spice2 UC Berkeley 2G6 (1981)

Spice3 UC Berkeley 3F3 (1993)

PSpice Cadence 9.9.2 (August 2001)

HSpice Avanti/Meta Software v2003.3 (March 2001)

Spectre Cadence IC 5.1.41, Open Access 5.1.41, and Open Access 5.2.51

Note
For translation purposes, Spice2 and Spice3 are almost identical and are referenced in this documentation
as Spice2/3.

 General Process   

The main objective of using the Netlist Translator is to import your Spectre or SPICE
netlist into ADS. This enables you to simulate your design using the powerful tools
provided by ADS. The following figure shows a simplified task flow for using the Netlist
Translator.
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 Simplified Task Flow  

 

 What's in this Documentation

The goal of this documentation is to help you get started, provide relevant examples that
teach you how to use the software, assist you in analyzing your translation and show you
where you can get more information as you need it.

Importing a Netlist File (netlist) provides detailed instructions on using the Netlist
Translator's user interface to import a netlist file into an ADS schematic or to an ADS
netlist. Several example Spectre and SPICE netlists are used to help you understand
and practice using the translator.

Advanced Methods for Importing Files (netlist) provides detailed instructions for
advanced users who want to understand how to use the command line options that
are available within the Netlist Translator. Additional information is provided to help
with customizing components and other unique situations.

Simulating the Translated Netlist (netlist) provides general information on setting up,
performing and analyzing a  simulation using Advanced Design System. References
to more detailed information are also provided in this section.

Comparing Results (netlist) provides information on  comparing the output of your
translation to your original netlist file. This section points out some specific details to
look for when comparing your results.

Troubleshooting (netlist) provides helpful information on debugging imported designs
and includes information on error and warning messages. Some known problems are
described and solutions are included where available.

Translating a Device (netlist) provides detailed  device translation information for
individual components.

Translating a Model (netlist) provides detailed model translation information for
individual models.
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User Defined Models and Parameter Mapping Rules (netlist) provides information on
adding your own unique models to ADS.

Translating Commands and Functions (netlist) provides information on the various
commands and functions supported by the Netlist Translator.

 About Design Translation and Verification  

Design translation can be a very complicated process. It is important to understand that it
is rarely, if ever, a push-button utility. Before starting a translation, you should become
familiar with all parts of your design and be prepared to spend adequate time to ensure
that all parts are translated correctly. After the initial translation is complete, additional
work may be required to understand model differences. Verification and debugging the
translated design may involve breaking a complex design down into smaller pieces to test
simulation of small circuits before attempting to simulate a large design.

The support staff at Agilent Technologies can assist you in this process, but should not be
expected to perform a complete translation and simulation. Please plan your work
accordingly, allowing sufficient time in your schedule to use this tool as it is intended − as
a tool to assist in the transfer of design information from one system to another.
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 Advanced Methods for Importing Files
This section describes the procedures for  Importing files into Advanced Design System
using the Netlist Translator from the command line. The methods described in this section
are for advanced users who want to have the ability to manipulate their netlist within a
translation.

Performing your translation via the command line provides you with more flexibility in the
process and more control over the output. Some of the advantages of translating your
Spectre or Spice file from the command line are listed below:

It enables you to check for errors midway through the translation.
It enables you to modify the intermediate file before the schematic is created
It enables you to do batch processing with multiple files.
It gives you access to advanced command line options not supported by the user
interface.

The output of a Netlist Translator command line translation can be either an IFF file that is
used to create an ADS Schematic or an ADS Netlist.

 Understanding the Import Operation   

This section describes how the  Netlist Translator software works when performing an
import operation. It may be helpful to understand these steps if you plan on importing
your designs using the Netlist Translator from the command line.

When the Netlist Translator performs an import, the software runs an executable program
called  nettrans. The nettrans program reads the file and then writes either an IFF file,
spice. iff , or an ADS netlist,  spice.net , depending on the connection method defined
when setting the import options. If an IFF file is created, Advanced Design System reads
the IFF file and creates a schematic. If an ADS netlist is created, it is stored in ADS netlist
format and placed in a pre-specified directory. Any errors that occur during the translation
are written to a file called nettrans.log . This file records any components that could not
be translated due to issues such as unrecognized syntax or incompatible models.

Running the nettrans program from the command line enables you to modify the contents
of the spice.iff file before importing the file into Advanced Design System. Once you are
comfortable with the output of the nettrans program, you can simply perform an IFF
import into ADS. The IFF importer loads the spice.iff file, generates the schematic and
writes any error messages or warnings to a log file called  ifftolib.log. Alternatively, you
could convert the output of the nettrans program to an ADS Netlist. For information on
how the import options are controlled from the command line, refer to Executing the
Nettrans Command.

For information on how the import options are controlled from the user interface, refer to
Setting the Import Options (netlist).

For information on how the import options are controlled from the command line, refer to
Executing the Nettrans Command.

Import Options shows the different import options available when using the Netlist
Translator. Depending on your needs, you can choose between the various options for
optimum translation results.
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 Import Options  

With all methods of translation, you should compare your results against your original
netlist if the size of the file permits. Once you are comfortable with your translation into
ADS, place the appropriate stimulus and simulator control elements and simulate your
design as described in Simulating the Translated Netlist (netlist).

  

 Importing a File from the Command Line   

This section describes the details of setting up and operating the Netlist Translator from
the  command line.

Note
It is recommended that only advanced users attempt to import files from the command line since it
requires knowledge of setting  environment variables and working in a UNIX shell or DOS window.

 Setting up the Nettrans Command   

To set up the  nettrans program for use from the command line:

 For Windows platforms:   

Open an MSDOS shell.1.
Set your $HPEESOF_DIR  environment variable to your ADS installation directory. For2.
example,
set HPEESOF_DIR= <ADS_install_dir>
Set your PATH environment variable to include the $HPEESOF_DIR\bin directory. For3.
example,
set path=C:\AdvDesSys\bin;%path%
Set the appropriate library path for your operating system. For example,4.
set shlib_path=$shlib_path:$HPEESOF_DIR\lib\win

 For UNIX platforms:   

Set your $HPEESOF_DIR  environment variable to your ADS installation directory. For1.
example, if using the Korn shell enter:
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export HPEESOF_DIR= <ADS_install_dir>

Set your PATH environment variable to include the $HPEESOF_DIR/bin directory. For2.
example, if using the Korn shell enter:

export PATH=$HPEESOF_DIR/bin:$PATH
Set the appropriate library path for your operating system. For example, if using the3.
Korn shell.

For HP-UX operating systems (i.e. HP-UX 11 and 11i), enter the following:
SHLIB_PATH=$SHLIB_PATH:$HPEESOF_DIR/lib/hpux11

For SUN operating systems (i.e. Solaris 8 and 9), enter the following:
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$HPEESOF_DIR/lib/sun58

For Linux operating systems, enter the following:
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$HPEESOF_DIR/lib/linux_x86

 Executing the Nettrans Command   

The  nettrans command uses the following general syntax:

nettrans input_filename output_filename -{s2|s3|p|h|pl} -{g|u|w} [-l]

[-n]

For Spectre use the pl parameter followed by spectre . The following is command syntax
specific to Spectre:

nettrans input_filename output_filename -pl spectre -{g|u|w} {-bc} [-l]

[-n] {-ip}

Simply entering nettrans at the command line with no parameters displays a detailed
nettrans usage message. Entering the nettrans -v command displays the translator
version, while entering nettrans -adv displays the syntax for the advanced options. The
following table displays a listing of all parameters and definitions used by the nettrans
command.

 Parameter Definitions for nettrans
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Parameter Definition

input_filename The name of the SPICE or Spectre source file to read in.

output_filename The name of the IFF or netlist file to write.

Input file type Definition

-s2 Berkeley SPICE (2g6)

-s3 Berkeley SPICE (3c, 3e, 3f)

-p PSpice

-h HSpice

-pl < dialect > Generic (use for translating Spectre netlists, -pl spectre )

Output options Definition

-g Create ADS netlist

-u Create schematic w/o wires (uses named connections)

-w Create schematic w/wires (not recommended on large circuits)
(Available from command line only.)

Other options Definition

-l First line is not a comment (used for library files or model include files)

-n Do not perform any name mapping for conflict avoidance

-v Return the version of the Netlist Translator

-adv View advanced options

Advanced
options

Definition (available from command line only)

-w Create schematic w/wires (not recommended on large circuits)

-k Create subcircuits for models at top level (used for library files or model include files)

-pp Preserve Spectre subcircuit parameters.

-ps Prefix string to be added to appropriate variables, model names, and subcircuit names in an
ADS netlist.
This is required to support a unique name space for design kit creation.

-sc Suppress comments

-se Suppress ADS subcircuit equations from being moved from the parameter list when
translating Spectre netlists.

-si < include_file
>

Suppress Spectre components contained in include_file .
The full path must be specified.

-sw Suppress warnings to log file.

-wrap < int > Line length at which to perform line wrapping (must be greater than 10, default=80).

-m < mapfile > Mapping file for user-defined components

-models Read HSpice Model Library and output one file per .LIB/.END pair. Suppresses nested .LIB
statements. output_filename should be a file extension only.
ex: nettrans mix025.l net -h -g -models
-pl dialect: Pass in the dialect to be parsed by Perl
-u2: Create schematic w/o wires (uses named connections)
Named Connections are read from log file so custom
symbols can be used. If connections are not made,
load ael file spcUtil.ael and run ael macro
spctoiff_connect_pins("wireLabels.log");

-u2 Create schematic w/o wires (use named connections). Named Connections are read from
log file so custom symbols can be used. If connections are not made, load ael file spcutil.ael
and run ael macro spctoiff_connect_pins("wireLabels.log") . The spcutil.ael file can be found
under $HPEESOF_DIR/links/spice/spcutil.ael .

-bc Generate netlist syntax that is backward compatible to ADS.

-ip <
include_path >

Specify paths (separated by a comma ',') of included netlist files.

Enter the appropriate nettrans command from the command line to translate your Spectre
file. Once the nettrans command is complete you can view the output.

 Additional Options Information  

 Using the -n Option  
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If the -n option is used, names are not mapped to the lower case. If case mixing was used
in the file, the variable, instance and model names will not be converted to lower case. For
more information on case sensitivity and name mapping, refer to Understanding
Capitalization (netlist).

 Using the -pp Option

 
ADS does not directly support parameter default values that reference values of other
parameters passed into the subcircuit. This option will introduce logic in the translated
netlist to manage reference values. See Example Spectre Subcircuit with Referenced
Parameter Value (netlist) for an example using the -pp option.

 Using the -se Option  

Without this option, any Spectre parameters that reference a previous parameter in the
subcircuit list will be pulled out of the subcircuit list and treated as an ordinary equation in
the subcircuit. This option allows you to keep these parameters in place. Some manually
editing is required to allow the netlist to simulate without errors.

 Using the -si Option  

The -si <include_file> option will translate a Spectre netlist with only a portion of the
netlist outputted.
The information in the include file is used by the translator for model type resolution and
other post processing needs. The contents of that file will not be output in the translated
ADS netlist.

 Using the -models Option  

An HSpice library or model file can consist of hundreds of models, defined within a .LIB
section. Each .LIB section defines one model , which may consist of a complete subcircuit.
If this library file is referenced by a SPICE circuit file, only the libraries that are used will
be translated. However, the user may want to translate the complete model library to a
set of ADS netlist files. The -models option is available for this purpose.

To translate the complete model library in a file called mix025.l, invoke the translator from
a shell command line as shown in the following example.

nettrans mix025.l net -h -g -models

The HSpice file is read and, for every .LIB section found in the library file, one ADS netlist
file is output. The name of the library which is specified in the .LIB statement becomes the
name of the ADS netlist file. An extension is given on the command line when the
translator is invoked, and this is appended to the file name. In this case, the file extension
is net. A library designated by .LIB resistor will be translated to an ADS netlist file called
resistor.net.

 Using the -u2 Option  

When the -u option is used, connections in a schematic are made by naming nodes. This is
done by placing a node name on each pin. The translator makes these connections by
reading a configuration file that contains pin locations for all the element symbols that the
translator uses. Subcircuit symbols are plain boxes with the appropriate number of leads
and pins on them.

If you have defined a custom symbol for any element, and the pins are not in the location
expected by the translator, some of the pins may not be named. Unconnected pins show
up as red diamonds in the schematic. This will most likely happen when a custom library
part exists in ADS and is referred to in a file. The translator does not create the subcircuit
but is expected to connect to it.
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When the correct pin information is not available to the translator in the spctoiff.cfg file
perform the following steps:

Use the -u2 option from the command line as shown in the following example.1.
nettrans source_file .sp output_file .iff -h -u2

The translator will output the IFF file output file_ .iff and another file named
wireLabels.log.
Import the IFF file from the user interface (refer to, Importing an IFF File).2.
This will create a schematic with no connections. To complete the connections, make
sure the component placement is satisfactory. There should be sufficient room
between each component to display the parameters and the node names.
Save all designs in which you made changes.3.
Make sure the file wireLabels.log is in your workspace directory and enter the4.
following commands on the AEL command line:

load(strcat (HPEESOF_DIR, "links/spice/spcutil.ael"));

spctoiff_connect_pins("wireLabels.log")

When the macro has finished running, the pins will all be labeled with node names and all
connections will be made as specified in the Spectre file.

 Using the -ip Option  

The -ip < include_file > option enables you to specify either an absolute or relative path to
a file that is included in a Spectre netlist. You can specify multiple paths separated by
commas ( , ).

 Example  

The test_ip.scs file:

library  test.cap_mim

section typ

 parameters cap_mim_scale=1

 include cap_mim.ckt

endsection

endlibrary

The included cap_mim.ckt file:

inline subckt cap_mim\(TOP BOT B\)

 parameters c=0 BPCap=0 BPArea=0 BPPerim=0

 cap_mim TOP BOT capacitor c=cap_mim4_scale\*c

 cp BOT B capacitor c=BPCap

ends cap_mim

Given the Spectre netlist files test_ip.scs_ and cap_mim.ckt_ above, if you run the
nettrans command with the options shown below:

nettrans test_ip.scs test_ip.net -pl spectre -g -ip <path1> <path2>

nettrans will search for the file cap_mim.ckt in the following order:

present working directory1.
<path1>2.
<path2>3.

If you have a file in one or more of the above locations, then the first occurrence of the
file cap_mim.ckt will be used.

The resulting ADS netlist test_ip.net would be created as follows:
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;library  test.cap_mim

#ifdef typ

cap_mim_scale=1

inline define cap_mim \( TOP BOT B\)

parameters  c=0 BPCap=0 BPArea=0 BPPerim=0

C:cap_mim TOP BOT C=cap_mim_scale\*c

C:cp BOT B C=BPCap

end cap_mim

#endif

;endlibrary

 Checking the Netlist Translator Version Number  

To determine the version of the Netlist Translator that you are running perform the
following steps: 

Open a UNIX or DOS shell.1.
Ensure your environment variables are set correctly. For more information on setting2.
environment variables, refer to Setting up the Nettrans Command.
Enter the following command:3.

nettrans -v

The Netlist Translator displays the version number.

Netlist Translator, version <version_number>

Where <version_number> is the actual version number of the translator.

Note
ADS Netlist Translator version 170. xxx or higher is required to translate Spectre files.

  

 Viewing the Translation Log

The Spectre or SPICE to IFF translation log (see Example Translation Log File
(nettrans.log)) contains important information about the netlist translation, including any  
error or warning messages recorded during the import operation. The translation log can
be viewed using any ASCII text editor. To view the translation log file, open your text
editor and load nettrans.log.

If your log file displays any error or warning messages generated by the translator, refer
to Troubleshooting (connectmui). Using a combination of the information in the log file
and the information provided in the troubleshooting section, edit your translated netlist
and save the new netlist with your corrections.

Since the translation log is an ASCII based text file, you can easily save the file with a new
name using the File > Save As command for future reference.

SPICE to IFF translation log
Input format: PSpice
Input filename: ex1.sp
Output format: ADS Netlist file
Output filename: ex1.net
Special options:
Processing first line as comment.
Begin translation at Thu May 30 10:16:00 2002
Creating netlist.
Reading item definition file "spctoiff.cfg"
Translation completed at Thu May 30 10:16:03 2002.

Note The netlist to IFF translation log file (nettrans.log) is over-written each time a new translation is
performed. To avoid over-writing the log file, save it with a new file name.

  



Netlist Translator for SPICE and Spectre

19

 Importing an IFF File

This section describes how to import Intermediate File Format ( IFF) files, created by the
nettrans command, into Advanced Design System. The IFF importer loads the  spice.iff
file, generates the new ADS Schematic and writes any error messages or warnings to a
log file called  ifftolib.log .
The Intermediate File Format (IFF) is an ASCII file that contains a simple, line-oriented
command structure with a fairly rich set of constructs. The format is machine- and
application-independent, thus simplifying design data transfer. For more information on
Importing an IFF file, refer to Importing and Exporting Designs (trans).

  

 Accessing the Import Dialog

To import your IFF file,

Open a schematic design in a workspace.1.
Click File > Import... from the schematic window. The Import dialog box appears.2.

  

 Specifying the File Name

In the Import dialog box, choose the type of file to import, specify the filename, and
supply other basic information needed by the translator.

In the Import dialog box that appears, Select the IFF file format from the File Type1.
drop-down list.
Click More Options to define options for the imported file. The More Options dialog2.
box appears.

Note
The program translators are controlled by translator options files. A system-wide options file exists
for each translator. These files can be found in the $HPEESOF_DIR/config directory. The default
system file is automatically read when you click More Options in the Import dialog box (unless a
local options file already exists in the current workspace directory). When you make changes in the
More Options dialog box and click OK, a local copy of the options file is written to the current
workspace directory.

Click Browse to specify the path and file name of the file you want to import.3.
Double-click as needed to locate the directory containing the schematic. By default,4.
all files are listed that have the file suffix appropriate for the chosen file format.
Select the schemaatic design you want to import and click OK. You are returned to5.
the Import dialog box and the selected filename appears in the field labeled Import
File Name (Source).
Where applicable, type a new name for your imported design in the New Design6.
Name (Destination) field.

Note
For certain file types, the translator uses the existing file name to determine the new design name.

Click OK to import the design and dismiss the Import dialog box.7.

  

 Setting the Import Options

In the Import dialog box, click More Options to define the IFF import options. The Import
IFF Options dialog box appears.
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Note
The Import IFF Options dialog box that appears is dependent upon where you execute the IFF import from
(i.e ADS Main , Layout or Schematic window).

Set the Import Options:

Ensure the Remove IFF File After Import option is deselected. When selected, the IFF1.
file is removed once it has been successfully imported. The default option is
deselected.
Set the Log verbose messages as desired. When this option is selected, all translation2.
information is recorded in the ifftolib.log file resulting in step-by-step description of
what happened internally during your translation. This option is primarily intended to
be used as a diagnostics tool. The default mode for this option is deselected. Note
that error and warning messages will always appear in your status window regardless
of this selection.
Ensure the Synchronize ports to symbol using node name option is deselected. This3.
option resets the symbol pin numbers to match port numbers based on the node
name of the schematic port. By default, symbol pin numbers are matched to
schematic port numbers based on the port's instance name.
Check the Use layouts from libraries instead of building local copies from IFF file4.
check box. When this option is selected, library elements that already exist in the
system libraries are not recreated for the imported file. Instead, these elements are
read from the local libraries; if an element does not exist in a local library, then it is
newly created. This option is deselected as the default, and all elements are
created/recreated in the local workspace.
Specify a library name for a component that needs to be created. The Default Library5.
Name for Library Parts field is used for specifying the default library name. When the
IFF file does not specify a library name for a component that needs to be created, the
library name specified in this field is used. The IFF files that are created by the
nettrans program specify the library SPICE INPUT, so the library name in this field
will not change the outcome of the import.

Note
The Default Library Name For Library Parts field is identical to the field of the same name in the
Export IFF Options dialog box. Changes made to this field will modify the contents of the field in the
Export IFF Options dialog box.

Accept the default Trace setting within the Trace Handling field. This field is normally6.
used to enable you to select how you want layout traces interpreted during a
translation. Because the Netlist Translator does not support layout import and export,
this field is not used.
Click OK to save your settings or Cancel to retain the default settings. You are7.
returned to the Import dialog box and the selected filename appears in the field
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labeled Import File Name (Source) .
Click OK to import the IFF file into ADS. The IFF Importer performs the automatic8.
translation of your IFF file into an ADS Netlist.

 About Component Libraries  

A component library in ADS consists of a collection of component definitions. Each
primitive component has an associated component name, symbol and predefined
component parameters that include relevant physical and electrical characteristics.

The IFF translator can be used as the initial step in creating an ADS component library;
however, this topic is outside of the scope of this manual. Creating an ADS component
library using IFF requires specialized tools and training. If you are interested in learning
more about this topic, contact Agilent EEsof-EDA's Solution Services.

 Adding the NetlistInclude Component  

In Advanced Design System, you can insert a saved netlist file into an ADS simulation via
an include statement by using the  NetlistInclude component. The NetlistInclude
component is used to link the netlist that was translated into an ADS netlist, to the ADS
schematic capture environment at the time of simulation.

The NetlistInclude component enables you to accomplish the following:

Add parameter definitions, equations, and special sub-circuits from your design to
the Advanced Design System schematic.
Initialize technology dependent model parameters or variables in a file that can then
be automatically inserted into the ADS netlist.
Allow sectional includes to handle corner case analysis.
You can use a NetlistInclude in the following placements:
In the top level of hierarchy, if the included file contains subcircuit definitions (it can
contain an entire model library)
In any circuit, if the included file contains only variables and/or model cards
A NetlistInclude component referencing a file containing subcircuit definitions cannot
be placed on a schematic that is not at the top level of hierarchy, unless you do the
manual steps defined below.

 Manual Translation and Placement of a NetlistInclude Component  

Note
For ADS 2004A and ADS 2003C, these steps are only necessary when doing manual translation and
placement of the NetlistInclude component. When using the user interface for a translation to an ADS
netlist, the ITEM_NOSUBNET_HEADER_EX field is set by the translator.

Suppose you have a top level design that includes a component abc and a DC simulation
component. If the subcircuit named abc contains a NetlistInclude component that
references a file with a subcircuit xyz , the resultant netlist would look like the following:

define abc (in out)

define xyz (input output)

parameters R1

R:R1 input output R=R1

end xyz

end abc

abc:x1 _net1 0

DC: DC1

In ADS, the nested define statements ( xyz defined within the definition of abc ) would
cause an error such as the following when simulated:

Error detected by HPEESOFSIM during netlist parsing.

       In file 'netlist.log' at, or just before, line 7.
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               Syntax error in component call:

               define xyz (input output)

^

To avoid this situation, you must manually modify the AEL item definition for the
subcircuit. Discussion of item definitions is beyond the scope of this manual. Please refer
to the Advanced Design System AEL manual.

If you have a basic understanding of the item definition, you can proceed to modify the
Extra item attribute, which is field 15 in the create_item() function. To find this function,
go to the networks subdirectory of your workspace directory and edit the ael file that has
the same name as the design ( abc in this example). This field needs to be set to
ITEM_NOSUBNET_HEADER_EX. This tells the ADS netlister not to put the define and end
statements around the contents of the subcircuit. This will cause another problem in that
abc will not be defined at all now. To avoid this situation, abc should be defined in your
original Spectre netlist.

Note
If it is at all possible, avoid placing a NetlistInclude component that references a file containing one or
more subcircuits anywhere other than the top level of your design hierarchy.

 Placing a NetlistInclude Component  

If you imported your netlist using the command line, you will need to insert a
NetlistInclude component in your new schematic.

To place a NetlistInclude component in an ADS schematic:

Select the Data Items component palette from the ADS schematic window.1.
Click the NetlistInclude component to place the component on the schematic. An2.
instance is attached to your cursor. Place the component instance on the schematic
as desired (click to place).
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 The NetlistInclude Component  

You can continue to place component instances or choose the Cancel Command And3.

Return To Select Mode icon to proceed with the next step. 
To edit the netlist specifications choose Edit > Component > Edit Component4.
Parameters or click the NetlistInclude component on the schematic.

A dialog box appears, enabling you to specify the parameters of the file to
include. See the table Parameter Definitions for the NetlistInclude Component
for a description of each parameter.

Note
You can also click the line to be changed directly in the schematic instance and edit as desired.

 Parameter Definitions for the NetlistInclude Component

NetlistInclude
Parameter

Description

IncludePath= Specifies the space-delimited search path for included files.

IncludeFiles= Specifies the list of files to include.

UsePreprocessor= Specify "yes" to use a #include directive, or "no" to copy the full text of the file
(default is "yes").

 Using a Custom Component  

If you have created a  custom component in Advanced Design System that you want the
system to use in place of the default ADS component when it imports a Spectre netlist,
you must create a translation table in the Import Netlist Options dialog box that specifies
which custom component to use.

 Creating a Translation Table  

A  translation table is simply a two column table that does the following:

Specifies a standard ADS component (left-hand column) and the custom ADS
component (right-hand column) used to replace it
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Specifies the standard ADS component parameters (left-hand column) and the
custom ADS component parameters (right-hand column) used to replace them
To create the translation table perform the following steps:

Begin your normal import operation. See Importing a Netlist File Using the User1.
Interface (netlist).
When you are Defining Netlist Options (netlist) using the  Import Netlist Options2.
dialog box, enter the translation table in the  Element Replacement Table field.

Refer to the Example Translation Table for an example of how to format the information in
the Element Replacement Table field.

 Example Translation Table  

# Standard ADS Component

# +Standard ADS Component Parameter

R

+R

+Tnom

Custom ADS Component

Custom ADS Component Parameter

MYR

Res

T

Comment Character - The system recognizes the pound sign ( # ) as a comment
character. Note that the first two lines in Example Translation Table are comments used to
describe the elements of the table.

Component - Both the standard ADS component ( R ) and the custom ADS component (
MYR ) are given in line 3 of Example Translation Table. On import, any time the translator
would normally place the R component in ADS, the system will place a MYR component
instead.

Note
The component name ( R ) in the left-hand column is not the Spectre name. It is the ADS component that
would be placed if the table were not used. Performing the import first, without the mapping, will allow
you to see the name of the component to be replaced.

Component Parameters - Component parameter mappings are listed one per line
following the component name. Each parameter line starts with the + character. List only
the parameters that are unique to the custom component. It is not necessary to list the
parameter names on the custom component that are the same as the ADS component;
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the translation automatically matches the correct parameters.

The only limitation on import is that new items have a similar symbol to the replaced
component so that the placement and wiring of the schematic work correctly. This means
that the custom symbol should be approximately the same size as the default component,
and the pins must be in the exact location on the two symbols. If the pins are not in the
same location, the -u2 option must be used. For more information on the -u2 option, refer
to Executing the Nettrans Command.

To access the component mapping functionality while running the translator from the
command line, use the -m option. You create the file from scratch or modify the spice.map
file that is created in the workspace directory when an import is performed from the user
interface. For more information on using the -m option, refer to Executing the Nettrans
Command.

 Example Netlist Translation  

The following shows an example comparison of how the system might translate a SPICE
netlist to an ADS netlist with or without the custom component defined in Example
Translation Table.

Using the Example  Spice Netlist in Netlist Comparison, if no custom component was
defined, the translator would generate the ADS Netlist (without mapping). Using the
translation table in Example Translation Table, the resultant ADS netlist would appear as
in the ADS Netlist (using a translation table) in Netlist Comparison.

 Netlist Comparison

SPICE Netlist ADS Netlist(without a mapping) ADS Netlist (using a translation table)

R1 1 2 50 Tnom=27 R:r1 n1 n2 R=50 Tnom=27 MYR:r1 n1 n2 Res=50 T=27

Note If your file contains functions that are not Advanced Design System functions, refer to Using Non-
ADS Functions.

 Modifying the Translator Configuration File  

The translator configuration file, spctoiff.cfg , is a file that is used when the translator
creates a schematic. It is stored in $HPEESOF_DIR/config. This file contains pin locations
and sizes for the symbols of all the components that the translator knows how to
translate.

Since the Netlist Translator runs as a separate process from ADS (see Understanding the
Import Operation), the translator cannot determine this information on the fly.
Periodically, symbols will be updated but the translator configuration file will not be
updated at the same time. In this case, you can manually modify the file if needed to
avoid overlapping components in the schematic.

The file consists of a block of information for each component. The first component in the
file is the Capacitor (C).

C 2 0 -0.625 0 .625 1.5 -3.25 0 0

There are four lines that start with C. The C is followed by an integer number which
indicates the number of pins on the component. This is followed by an integer number
that indicates the rotation in degrees of the component.

The next four fields define the * bounding box* of the symbol, calculated with the default
settings for parameter visibility. If you choose to make all parameters visible while editing
the schematic or if you make the font of the parameters larger than default, you may
need to increase the size of the bounding box, or spread your components out on the
schematic.
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The final two coordinates on the first line are ignored.

The following two lines are the pin information.

0 0 180 Pin 1 is located at 0,0 on the symbol (the origin) and rotated to 180 degrees.

1 0 0 Pin 2 is located at 1,0 on the symbol and placed at 0 rotation.

In the rare case that this file needs to be modified, usually only the bounding box
information would have to be modified. If there seems to be a problem with the file, you
can request an updated file from Agilent EEsof-EDA Customer Support, or you can make a
few simple changes yourself if it is needed urgently.

The file can be modified for your installation by a system administrator. For individual use,
a copy of the file can be placed in the user's $HOME/hpeesof/config directory. The file
located in the user's directory will take precedence over the system file. For command line
execution or batch processing, the file can also be placed in the directory where the
translator is running.

The bounding box of a symbol is the technical term for the rectangular space
occupied by a symbol on the schematic. The four coordinates given are the upper left
corner and the lower right corner, when the origin of the component is placed at 0,0
on the schematic. The origin of the component is the position that is tied to the
mouse when the drag image is visible. Where you click the mouse to place a
component becomes the location where the origin of the component is placed. This
hot-spot is usually pin 1.

 Importing an HSpice File from Cadence after Parasitic Extraction  

 HSpice files output from Cadence have been observed to have syntax errors that will not
be corrected by the translator. Some of these syntax errors need to be corrected manually
before importing or they will cause the ADS simulation to fail. Others may be corrected
after the translation and before simulation.

Make the following changes to your ADS netlist or schematic before starting the import:

Expressions are usually enclosed in single quotes. Occasionally, expressions have
been observed to be enclosed in double quotes, which are not valid. This must be
corrected before the file can be translated or the translator will drop part of the
expression.

Make the following changes to your ADS netlist or schematic after the import has
completed:

Values have been observed with non-matching pairs of parentheses. These will be
passed through the translator but cause the simulator to fail. This can be fixed prior
to translation or prior to simulation.

Files have been observed with multiple declarations of the same variable. All will pass
through the translator but cause an error in the simulator. Parameters should be
declared only one time. Remove the extra parameters and re-simulate.

Subcircuit calls have been seen with parameters that were not declared on the
subcircuit when it was defined. Again, the translator will not check for this error but
the simulator will halt with an error. Remove the extra parameters and resimulate.

  

 Using Non-ADS Functions

If your file contains  functions such as gauss() or pwr() or any other function that is not
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a built-in ADS function, the simulator will give an Unresolved reference error.

Look for the function in the supplied function file:

$HPEESOF_DIR/links/spice/spicefunction.net (for SPICE functions)

The function can be copied into the ADS netlist, placed in the schematic, or the whole file
can be included by entering the following line in the ADS netlist:

#include "< path >/spicefunctions.net" (for SPICE functions)

Replace < path > with the correct location for your system.

For Spectre translations you do not need to do anything special. Any functions that are
listed in the spectrefunc.rul file will automatically be substituted into the new ADS netlist
after translation.
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 Comparing Results
This section provides information on how to  compare your translated design output
results with your original netlist. Once you have translated, verified and simulated your
netlist, compare your ADS results with your original version.

   

 Comparing the Schematic 

For wired or unwired import options, compare your translated ADS Schematic with your
original netlist. For a small design, you can visually verify connections by matching node
numbers. For information on nodes flagged with red diamonds, refer to Checking for
Unconnected Nodes (netlist).

To compare a larger schematic with the original netlist, first generate an ADS netlist. To
generate an ADS netlist from a schematic without starting a simulation:

Open the ADS command line from the Main window.1.
Choose Tools > Command Line.
Enter the following command in the Command field:2.

 de_netlist();

After applying this command, the netlist is stored in a file called netlist.log in the
current workspace directory.
Proceed to the next section for instructions on how to compare the translated ADS3.
netlist to the original netlist.

 

 Comparing the Netlist

You can compare your translated ADS netlist to your original netlist to verify that nodes
were connected correctly and parameters were translated correctly. If you performed your
translation from the command line and selected the -g option to create an ADS  netlist,
you can easily view and compare your translated netlist with your original netlist.

Since Spectre, SPICE, and ADS netlists are ASCII based text files, they can be viewed
using any ASCII text editor. To view the original netlist, open a text editor and load the
file defined as input_filename in the nettrans command. To view the translated ADS
netlist, open a text editor and load the file netlist.log or the file defined as output_filename
in the nettrans command.

You can now compare your original netlist to the translated ADS netlist noting the
differences between Spectre and ADS.

  

 Comparing Original and ADS Netlists

You can now compare your original  netlist to the translated ADS netlist noting the
differences between the original and ADS. SPICE Netlist vs. Translated ADS Netlist shows
an example comparison of a simple SPICE netlist translation. The comparison is the same
for Spectre.

 SPICE Netlist vs. Translated ADS Netlist
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# Original SPICE Netlist Translated ADS Netlist

1 BJT Curve Tracer Example ; BJT Curve Tracer Example

2 .param vce=0 ibb=0 vce=0

ibb=0

3 V1 3 0 VCE V_Source:v1 n3 0 Vdc=vce Vac=0

4 I1 0 10 IBB I1 0 10 IBB

5 Q1 3 10 0 BJTM1 bjtm1:q1 n3 n10 0 Area=1 Region=1 Mode=1

6 .model bjtm1 NPN model bjtm1 BJT NPN=1 PNP=0 RbModel=1 Tnom=27

7 .end

Note
The numbers in the left hand column of SPICE Netlist vs. Translated ADS Netlist coincide with the
numbers in the descriptions below. Each number references a line or group of lines in the adjacent netlist.

Here are some details you might notice in the translated netlist in SPICE Netlist vs.
Translated ADS Netlist:

There is a semi-colon preceding the first line in the translated netlist. The translator1.
inserted the comment character even though there was no comment character in the
SPICE file. This is because the SPICE simulator always considers the first line of a
SPICE file to be a comment. To override this behavior in the translator, deactivate
the First line is a comment check box in the Import dialog or use the -l command line
option.
The .param keyword in the SPICE netlist indicates the beginning of a parameter list.2.
Each of the parameters defined are written separately in the ADS netlist.
Components are indicated by a component designator (i.e. V_Source) followed by a3.
colon and then a unique item name (i.e. v1).
If a component references a model (bjtm1), the unique model name will be listed4.
first, instead of a component designator (V_Source).
The .model keyword in SPICE indicates the beginning of a model. The translator5.
converts the SPICE model to an equivalent ADS model.
The .end (end of circuit) command has no equivalent in the ADS netlist file. The6.
translator stops reading after encountering the .end command.

Now that you have compared your translated netlist to the original SPICE netlist and made
some observations, you can view the translation log (nettrans.log) to help understand
some other reasons the translated netlist appears as it does. For information on reviewing
the nettrans.log file, refer to Viewing the Translation Log (netlist)

  

 Comparing Models and Devices

Compare each of your translated models and devices with those in your original netlist.
Model parameters are not always defined consistently for every simulator. There are
differences between ADS, Spectre and SPICE. Additionally, each simulator may use
different equations in their model calculations. These inconsistencies may lead to
differences in simulation results for translated models.

If you have verified that the model parameters have translated as you expected by using
the information in Translating a Device (netlist) and Translating a Model (netlist), and your
simulation results are not what you expect, please contact Agilent EEsof-EDA Customer
Support for the latest information on model compatibilities. You may be asked to submit
your archived workspace to help resolve the issue.

For information on troubleshooting your translation, refer to Troubleshooting
(connectmui).

 

 Comparing ADS Results to Hspice
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Hspice uses different values for the physical constants k and q. This can subtly affect
some of the temperature scaling code. It can make small differences in kT/q, which is part
of the equation for a forward biased diode.

Format Boltzmann's Constant k Electron Charge q

ADS Codata-86 1.380 658 0 x10-23 1.602 177 33 x10-19

Spice2, Spice3, Spectre 1.380 622 6 x 10-23 1.602 191 8 x10-19

Hspice 1.380 620 0 x 10-23 1.602 120 0 x 10-19

Codata-98 1.380 650 3 x 10-23 1.602 176 462 x 10-19

Care must be exercised when comparing the currents flowing through reverse-biased PN
junctions. A diode with Is=1x10-14 should have a current of -1x 10-14 at -5V; instead it
will show -5 x10-12. This is because ADS/Hspice adds a small conductance of size gmin
(nominally 1x 10-12 S) in parallel with every reverse biased PN junction to aid
convergence. Thus if these currents are compared, all that is being compared is gmin and
not the reverse-biased diode results.
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 Importing a Netlist File
This section describes the procedures for importing Spectre or SPICE netlist files into ADS
using the Netlist Translator. Performing a translation via the Netlist Translator enables you
to easily define the translation criteria and translate your netlist file. You have the option
of generating either an ADS Schematic or an ADS Netlist plus an ADS Schematic with a
NetlistInclude (ccsim) component depending on your selections.

If you have a relatively simple netlist file and need only a schematic, the ADS Schematic
option is recommended. However, if you have a large or  complex netlist source file or you
are just more comfortable viewing a netlist version, the ADS Netlist plus an ADS
Schematic with a NetlistInclude component option enables you to review the netlist. This
makes it easy to compare your files line by line for debugging purposes. The netlist
version also provides much faster processing.

    

 Importing a Netlist File Using the Netlist Translator

 Importing a netlist file to an ADS Schematic or an ADS Netlist with a NetlistInclude
component using the Netlist Translator can be broken down into the following steps.

Accessing the Import Dialog1.
Specifying the File Name2.
Setting the Import Options3.
Choosing the Translated Output Format4.
Defining Netlist Options5.
Examining the Output6.
Using the NetlistInclude Component7.

Note
Steps 5 and 7 above are necessary only if you want to import to an ADS Netlist with a NetlistInclude
component.

 Creating a Simple Spectre Example  

The following simple RCL-Diode circuit will be will be referred to periodically to help you
understand the import process. If you like, you can create the sample Spectre file shown
in Sample Spectre File (ex1.scs). You can create this file in your workspace directory using
any ASCII text editor. Type the following text into a file.

 Sample Spectre File (ex1.scs) 

*R, C, L & Diode Example
L1 (net1 net2) inductor l=1n
R1 (net2 net3) resistor r=1K
C1 (net3 net4) capacitor c=1p
D1 (net4 net5) pdiode l=3e-4 w=2.5e-4 area=1
model pdiode diode is=1.8e-5 rs=1.43 n=1.22

Save this file as ex1.scs in your current workspace directory then close the file. You can
now use ex1.scs as an example the first time you attempt to perform an import operation.

 Creating a Simple SPICE Example  

Create the sample  SPICE file shown in Sample SPICE File (ex1.sp). You can create this
file in your workspace directory using any ASCII text editor. This, and other simple SPICE
files, will be referred to periodically to help with you understand the import process. Type
the following text into a file.

 Sample SPICE File (ex1.sp)  
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*SIMPLE RTL INVERTER
VCC 4 0 5
VIN 1 0 PULSE 0 50 2NS 2NS 2NS 30NS
RB 1 2 10K
Q1 3 2 0 MODQ1
RC 3 4 1K
.MODEL MODQ1 NPN BF=20 RB=100 TF=.1NS CJC=2PF
.DC VIN 0 5 0.1
.TRAN 1NS 100NS
.END

Save this file as ex1.sp in your current workspace directory then close the file. You can
now use ex1.sp as an example the first time you attempt to perform an import operation.

 Accessing the Import Dialog

You can import files through ADS Main or Schematic window. The  Import dialog box is
accessed from the File pull-down menu.

Open a workspace in ADS before importing your design. Working in workspace1.
directories enables the translator to organize design files in the standard ADS file
structure.
Click File > New > Workspace... to create a new workspace or File > Open >2.
Workspace to open an existing workspace.

Note
The import option will not be active in the File menu unless you open a workspace.

For more information on working in workspace directories, refer to Using Workspace
(adstour).
Click File > Close All to close any open designs before invoking the import3.
procedure. This will remove any active designs from memory.
Click File > Import to access the import dialog and import your design from the ADS4.
Main or Schematic window.

   

 Specifying the File Name

In the Import dialog box, choose the type of file to import, specify the filename and supply
other basic information needed by the translator.

In the Import dialog box, select Netlist File from the File Type drop-down list if it isn't1.
already displayed.
To specify the path and filename of the file you want to import, click Browse in the2.
Import dialog box. The Import File Selection dialog box appears.
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Navigate to the directory containing your source file in the Directories field, then click3.
the file in the Files field. Alternatively, you can enter the full path and file name in the
Selection field.
After selecting the design to import, ex1.sp for this example, click OK. You are4.
returned to the Import dialog box and the selected filename appears in the field
labeled Import File Name (Source).
Click More Options to define the preferred import method. The Import Netlist5.
Options dialog box appears.

    

 Setting the Import Options

    

 Selecting the Dialect

In the Import Netlist Options dialog box, select the appropriate netlist dialect from the
Input Netlist Dialect drop-down list.
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If you are unsure of the source of the netlist file, you may be able to tell from the  syntax
of in-line  comments shown in Recognizing Netlist Variations.

 Recognizing Netlist Variations

SPICE Dialect In line comment syntax

Spice 2G In line comments not allowed

Spice 3 In line comments not allowed

PSpice ;

HSpice $

Spectre //

Note
For HSpice, the `$' must be preceded by a space or a comma if it is not the first non-blank character
because the $ is allowed within node or element names.

You may also be able to match syntax with the device table or model levels in the model
tables. For more information on device and model tables, refer to Translating a Device
(netlist) and Translating a Model (netlist).
   

 First line is a comment

To make sure the first line of a source file is recognized as a comment line and ignored,
the  First line is a comment checkbox must be selected. This is not necessary if the line
already begins with a comment character.

The First line is a comment option is available because some simulators will always ignore
the first line regardless of the first character.

Use the default value for the ex1.sp example.

  

 Suppress name mapping

When the translator changes the name of a node or a component to comply with ADS
rules, this is referred to as name mapping. Name mapping is limited to all names being
changed to lowercase, as well as replacement of an illegal character with an underscore.
For more information on name mapping, refer to Using Valid ADS Characters.

Select the Suppress name mapping checkbox to activate or deactivate this option.
Activating this option enables you to override any name mapping introduced by the
translator.

Note
See Understanding Capitalization for cautionary information on name mapping.

Use the default value for the ex1.sp example.   

 Choosing the Translated Output Format

In the Import Netlist Options dialog box, there are 2  import methods available in the
Translated Output Format field: ADS Schematic (with named connections) or ADS Netlist.
See Translated Output Format Descriptions for format descriptions.

Note
A third option, Wires, is available through the command line only. See Translated Output Format
Descriptions for more information.

 Translated Output Format Descriptions  
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ADS Schematic (with named connections) This translation method writes an
intermediate file in the Intermediate File Format (see Importing an IFF File (netlist)).
After the IFF file is created, it is read by ADS and the schematic is created. For
detailed information on how this works, refer to Understanding the Import Operation
(netlist). Components are placed in a square array and  Named Connections are used
to place the correct node name on each pin. Pins with the same node name are
connected. This translation is faster than the Wires option that tries to connect all the
pins with wires.

ADS Netlist An  ADS netlist is written to the workspace directory and a simple
schematic is created. The schematic contains only a  NetlistInclude component that
references the ADS netlist file. When an ADS simulation is run, the simulator
automatically reads the new netlist. This saves a lot of time on very large circuits
both in translation time and simulation time, since the schematic creation and
traversal are both skipped. For information on Netlist Options, refer to Defining
Netlist Options. For information on  editing the netlist, refer to Viewing and Editing
the Netlist.

Wires (Available from command line only) This translation method also writes an
intermediate file in the IFF format. After the IFF file is created, it is read by ADS and
the schematic is created. For detailed information on how this works, refer to
Understanding the Import Operation (netlist). Components are placed and  wired
with a special algorithm. The larger the file is, the slower this will be. This method
should only be used on very small circuits.

 Import Methods

Method Advantage Disadvantage When to Use

ADS Schematic (with
named connections)

Fast, easy to read Can be difficult to tell which
components are connected
together

Default--use in most
cases

ADS Netlist Allows large circuits to be
modular

Cannot edit the components
of the netlist through UI

Large netlists that do
not require editing
through UI

Wires (available from
command line only)

For small circuits, easy to tell
which components are
connected together

Slow, messy for large circuits Small netlists  

  

Caution
It is highly recommended that the ADS Netlist option be used when translating large netlist file. In
addition to taking many hours to create a schematic from a 20,000 line netlist, a schematic of that size is
practically uneditable.

For the purpose of the ex1.sp example, select the Named Connections method and click
OK in the Import Netlist Options dialog box. You are returned to the Import dialog box.
Click OK to begin the translation.

 Examining the Output

This section describes some of the information to look for during and after your translation
to help you determine whether your translation is complete or not.

   

  Viewing the Status Window

While the translator is running, a  Status window appears and displays messages about
the translation as it progresses (see Example Status Window Contents). When the
translation is complete, the Status window displays the message, Translation completed,
along with date and time done.



Netlist Translator for SPICE and Spectre

36

 Example Status Window Contents

|Netlist Translator (*) 370.501 Nov 17 2010

IFF translation log

Input format: HSPICE

Input filename: C:\users\default\MyWorkspace_wrk\ex1.sp

Output format: IFF file

Output filename: spice.iff

Special options:

Processing first line as comment.

Begin translation at Fri Nov 19 12:49:00 2010

Creating schematic with named connections.

Reading item definition file "C:\agilent\ADS2011_01/config\spctoiff.cfg"

Translation completed at Fri Nov 19 12:49:00 2010.

========================================================================

End of Spice Translation Log file, beginning of IFF Translation Log File

========================================================================

Beginning IFF import

Processing IFF file: C:\users\default\MyWorkspace_wrk\spice.iff

IFF import complete

Warnings:  1

The Status window reports information such as the input file format, the input file name
and the output format. The output format for Advanced Design System is the IFF file in
this case. The translation start time is also displayed.

After the translation is complete, check to see if there were any error or warning
messages reported. If any errors or warnings are displayed in the Status window, refer to
Troubleshooting (connectmui) for information on unexpected results from the Netlist
Translator and how to fix the problem.

 Viewing the Schematic   

Open a new schematic window and then open the ex1 design to view the schematic. For
more information on schematic windows, refer to Program Basics (usrguide).

 ADS Schematic Window with Translated ex1 

Before simulating your design in ADS, you will need to place  simulation control blocks
from one of the simulation palettes in the schematic window. You may also need to place
an instance of an imported design in a new schematic. For more information on setting up
your simulation, refer to Simulating the Translated Netlist (netlist).
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 Defining Netlist Options

If you selected ADS Netlist in Choosing the Translated Output Format, the Optional
Directory Location area of the Import Netlist Options dialog is activated.

Specify the component name (use all lower case), number of pins and an output1.
directory in each of the respective fields, according to the guidelines below.

Directory to Store Netlist To specify the path of the  directory you want to store your
netlist in, click Browse. The Netlist Directory Selection dialog appears. If you do not
choose a directory to store your netlist, it will default to your current workspace
directory. In this case, the netlist has been stored in the default workspace directory
within a folder named netlists. 

Element Replacement Table If you created a  custom component in Advanced Design
System that you want the system to use when it imports a netlist in place of the
default ADS component, see Using a Custom Component (netlist) for instructions on
completing this field.

Once all options are entered, click OK. You are returned to the Import dialog box.1.
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Click OK on the Import dialog box. The following informational dialog appears:2.

The informational dialog informs you that you have selected an ADS netlist import
and that you will need to select a subcircuit from your netlist to be the top level
circuit that will used for the simulation.
Click OK on the informational dialog to select the subcircuit. The following dialog3.
appears:

All of the existing subcircuits with their pin counts are listed.

Note
Only the subcircuits from the Spectre or SPICE netlist that you entered in the Import dialog are listed. If
you want to use a subcircuit that is contained in an include file, you have to manually add that after the
import process is complete.

Select the subcircuit to use as the top level subcircuit and click OK to start the translation.

The Netlist Translator performs the automatic translation of your source file into an ADS



Netlist Translator for SPICE and Spectre

39

Netlist plus an ADS Schematic with a NetlistInclude component (see ADS Schematic
Window with NetlistInclude Component.).

 ADS Schematic Window with NetlistInclude Component  

  

 Viewing and Editing the Netlist

If you selected ADS Netlist in Choosing the Translated Output Format, the Netlist
Translator creates an ADS netlist and places it in the workspace directory. The ADS netlist
is in the form filename .net, where filename is the component name you specified in the
Import Netlist Options dialog box.

To  view and edit the netlist, open the ADS text editor from the Main window, Tools >
Text Editor . You can also view the netlist from a command shell or with any ASCII text
editor. Translated ADS Netlist (ex1.net) displays the translated ADS Netlist, ex1.net , of
the example file, ex1.sp.

 Translated ADS Netlist (ex1.net)

; *SIMPLE RTL INVERTER
V_Source:vcc n4 0 Vdc=5 Vac=0
V_Source:vin n1 0
V_Tran=pulse(time,0,50,2e-09,2e-09,2e-09,3e-08)
Vdc=0 Vac=0
R:rb n1 n2 R=10k
modq1:q1 n3 n2 0 Area=1 Region=1 Mode=1
R:rc n3 n4 R=1k
model modq1 BJT NPN=1 PNP=0 Bf=20 Tf=.1n Cjc=2p Rb=100 RbModel=1
SweepPlan:Plan1 Start=0 Stop=5 Step=0.1
DC:DC1 SweepPlan="Plan1" SweepVar="vin.Vdc" UseSweepPlan=yes
Tran:Tran1 StopTime=100n StartTime=0 MaxTimeStep=1n

Once you have your netlist displayed, verify that the translated netlist and the original
netlist have the same parameters. For more information on parameter mapping in devices
and models, refer to Translating a Device (netlist) and Translating a Model (netlist).

 Using Imported Designs in ADS   
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This section provides additional information that can help you prepare for simulating your
imported designs in ADS. Depending on your specific needs and the way your translation
was performed, you may be required to perform these steps before your design can be
simulated. For information on simulating your design, refer to Simulating the Translated
Netlist (netlist).

 Checking for Unconnected Nodes  

   
If the log file reported any components that could not be translated, there will be open
connectors which show up as red diamonds on the pins in the schematic. Pins that have a
red diamond when the schematic is complete are not connected to any other pins. To
check for unconnected nodes on a large schematic where the red diamonds are hard to
see:

From the schematic window, click Options > Check Representation. The Check1.
Representation dialog box is displayed.
Ensure the Unconnected pins check box is active and then click OK. A Check2.
Representation Report is displayed that will list all unconnected pins. Note that the
components with unconnected pins are highlighted on the schematic.
In the Check Representation Report, click Print to save the report to a file. Click OK3.
to clear the dialog.
To clear the highlighted components on the schematic, choose Layout > Clear4.
Highlighted > Components.
If a pin is not connected, it may be because the component it was connected to was
not included in the original file. More likely, the translation of that component failed
because of a syntax error or there is no equivalent ADS component. In this case, you
should manually place a component and connect them using the Insert > Node Name
command.

A message will be written to the translation log file (nettrans.log) in the case of any
failures. For more information on the translation log, refer to Viewing the Translation Log
(netlist).

Note
There is no visible indication of unconnected nodes in the output ADS Netlist, so the log file must be
checked for the names of un-translated components.

  

 Including Models and Subcircuits

This section describes how to include models and subcircuits in an existing design using
example files. To start with, create the two example files shown in Transmission Line
Subcircuit (tline.sp) Netlist and Transmission Line Inverter (inverter.sp) Netlist. Save each
of the files in the workspace directory that was used for store the example  SPICE netlist
(ex1.sp) in Accessing the Import Dialog.

The two new example SPICE files make up a simple transmission line inverter. The first
SPICE netlist (tline.sp) is a subcircuit.

 

 Transmission Line Subcircuit (tline.sp) Netlist
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*TRANSMISSION-LINE SUBCIRCUIT

.SUBCKT TLINE 1 3

T1 1 2 3 4 Z0=50 TD=1.5NS

T2 2 0 4 0 Z0=100 TD=1NS

.ENDS TLINE

.END

The next SPICE netlist (inverter.sp) includes additional components that complete the
transmission line inverter design.

 

 Transmission Line Inverter (inverter.sp) Netlist

*TRANSMISSION-LINE INVERTER

V1 1 0 PULSE 0 1 0 0.1NS 0.1NS 20NS 40NS

R1 1 2 50

R2 4 0 50

Import both the new SPICE files individually using the information in Importing a Netlist
File Using the User Interface. These two files should be imported by choosing the options
PSpice in _Input Netlist Dialect and ADS Schematic (with named connections) in
Translated Output Format. Remember to close all designs before starting each import.
Save the designs as inverter and tline respectively.

Open the design inverter. Notice that there are unconnected points in the schematic
indicating that something is missing from the file. In some cases, this is caused by
components that could not be translated (see Checking for Unconnected Nodes). In this
case, however, the original SPICE file (saved as inverter) did not contain the
required transmission line component. So the tline subcircuit will be used to complete the
circuit.

 

 Including a Subcircuit

A SPICE netlist may contain one or more subcircuit definitions. A subcircuit in the SPICE
file becomes a reusable component in the ADS schematic. To use a subcircuit, you can
place an instance of it in a new or existing design.

To browse for a component and include it in your design:

From the schematic window, choose Insert > Component > Component Library1.

or click the Display Component Library List button  on the toolbar. The
Component Library/Schematic dialog box is displayed.
In the Libraries field, scroll down in the list and locate either the Spice Netlists library2.
or the Sub-networks library.
Click either the Spice Netlists library or the Sub-networks library in the Libraries field3.
to see the list of subcircuits that can be placed as components.
In the Components field, click on the required component to use (tline in this4.
example) and move the cursor back into the schematic window.
Click to place the component in the schematic.5.

Click the _End Command_icon  from the tool bar to stop placing instances of the6.
component.

If the name of the subcircuit is known, it can be placed in the schematic by typing the
name directly into the Component History drop-down list box as illustrated below, without
looking it up.
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When the name of the subcircuit is entered in the component history box, the case must
match exactly with the design name in ADS. The subcircuit name will be in lower case
unless the Suppress name mapping option in the Import Netlist Options dialog box was
checked. For more information on capitalization and name mapping, refer to
Understanding Capitalization and Suppress name mapping:

Note
If the SPICE netlist contains a set of models outside of any subcircuit block, the models will be placed in a
separate top level design that has the same name as the SPICE file. To use these models, copy them into
the design that references them. Optionally, a design with models only can be placed as a subcircuit within
another design, but all of the models have to be edited to have global scope. To do this, select a model,
open the edit parameter dialog, click the Component Options button and change Scope to Global .

  

 Example Spectre Subcircuit with Referenced Parameter Value

The following example illustrates a translation of a Spectre subcircuit into an ADS netlist.
The Spectre subcircuit contains two parameters with default values. The value of the
second parameter, r2, refers to the first parameter, r1. (The value of r1 could either be
the default value or a specified value when the subcircuit is called from an instance
component.)

ADS does not directly support parameter default values that reference values of other
parameters passed into the subcircuit. Using the backward compatible option (-bc), the
Netlist Translator manages this by placing extra variables (in this example, ADS_r2_1,
ADS_r2_2, and UNDEF) and an equation(s) within the netlist to calculate the correct value
of the contingent parameter (in this example, r2 ). Without the -bc option, ADS will read
the subckt statement with parameter referencing in Spectre syntax. Thus the subckt
header is wrapped with the lines simulator lang=spectre and simulator lang=ads.

Note
Tnom is added by default to resistor component to match Spectre simulation results. This is done only
when no Tnom parameter is set.

Note
This is only available through the command line. Use the -pp (preserve parameter) option.

  

 Spectre subcircuit

subckt myexample (t1 t2 s)

parameters r1=1 r2=r1

R0 (t1 net1) resistor r=r1

R1 (net1 t2) resistor r=r2

ends myexample

  

 ADS subcircuit-translated in backward compatibility mode (using -bc option)

define myexample (t1 t2 s)

parameters r1=1 r2="UNDEF"

ADS_r2_0=r1

ADS_r2_1=if (r2 == "UNDEF") then ADS_r2_0 else r2 endif
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R:R0 t1 net1 R=r1 Tnom=27

R:R1 net1 t2 R=ADS_r2_1 Tnom=27

end myexample

 

 ADS subcircuit-translated in default mode (without using -bc option)

simulator lang=spectre

subckt myexample (t1 t2 s)

parameters r1=1 r2=r1

simulator lang=ads

R:R0 t1 net1 R=r1 Tnom=27

R:R1 net1 t2 R=r2 Tnom=27

end myexample

  

 Connecting a Component

This section describes how to set pin number preferences and assign node names in order
to  connect a subcircuit to a design. After placing the instance of the Transmission-Line
Inverter subcircuit in the last example, you can use the ADS Node Names to connect the
subcircuit pins to the rest of the circuit. You may need to turn the pin number visibility on
to help identify the proper pins when naming nodes.

To set the  Pin Numbers schematic preference in order to see the pin numbers:

From the schematic window, choose Options > Preferences. The Preferences for1.
Schematic dialog box is displayed.

Select the Pin/Tee tab.2.
Click the Pin Numbers check box in the Visibility (on/off) section to activate the pin3.
number visibility.
Click OK to save the settings and close the dialog box.4.
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 Defining the Node Names

To define the  node names to connect the subcircuit:

Choose the Insert > Wire/Pin Label menu selection or click the Insert Wire/Pin1.

Label icon in the tool bar.  The Wire/Pin Label dialog box appears.

Enter n2 in the Node Name field but DO NOT click Done. An instance of n2 is2.
attached to your cursor.
Drag your cursor onto the schematic and click pin 1 of the subcircuit symbol.3.
In the Node Name dialog box, change the node name to n4. Again, DO NOT click4.
Done. Drag your cursor onto the schematic and click pin 2 of the subcircuit symbol.
Save your new design as tline_inv.5.

This completes the circuit. Your combined inverter and tline should now appear similar to
the tline_inv schematic design shown in Translated Schematic with Subcircuit (tline_inv).
This design is used in the simulation example in Simulating the Translated Netlist (netlist).

 Translated Schematic with Subcircuit ( tline_inv )  
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 Adding an Existing Library

Follow the steps below to add an existing library into the workspace:

Start ADS and open or create a workspace.1.
From ADS Main window, choose File > Manage Libraries... to open the Manage2.
Libraries dialog box.

Click Add Library to open the Add Library dialog box.3.

Click Browse... and select the library to be added in workspace. The valid library4.
name is displayed automatically under Name.
Select the desired mode from the Mode drop-down list.5.
Click OK to add the library.6.

For more details about Using Libraries, see Using Libraries (adstour).

  

 Using the NetlistInclude Component

If you selected ADS Netlist in Choosing the Translated Output Format, your translated
schematic will contain a  NetlistInclude component. This section describes how you can
view and modify the NetlistInclude component and then use the component within another
design.

The NetlistInclude component in this section is created by modifying and translating a
previous example SPICE Netlist into an ADS Netlist with a NetlistInclude component. The
newly translated design is then used to show how you can place an instance of your
NetlistInclude component into another design and then simulate the design.
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To setup and translate your example SPICE Netlist into an ADS Netlist with a
NetlistInclude component:

Close any open designs. Click File > Close All.1.
If it's not already opened, open your workspace that you created in Importing a2.
Netlist File Using the Netlist Translator. Click File > Open > Workspace.
From the ADS Main window, click Options > Text Editor to open the ADS text3.
editor.
In the text editor, click File > Open and open the file tline.sp that you created in4.
Transmission Line Subcircuit (tline.sp) Netlist in Including Models and Subcircuits.
Click File > Save As to save the file with a new name, tline2.sp.5.
Edit the new file to change the subckt name to TLINE2 as shown in the following6.
table, then re-save and close the new file.
*TRANSMISSION-LINE SUBCIRCUIT

.SUBCKT TLINE2 1 3

T1 1 2 3 4 Z0=50 TD=1.5NS

T2 2 0 4 0 Z0=100 TD=1NS

.ENDS TLINE

.END

From a blank schematic window, import the new file tline2.sp . In the Import Netlist7.
Options dialog box, select PSPICE as the Spice Dialect and ADS Netlist as the
Connection Method For Schematic. If you need more information on importing a
SPICE file, refer to Importing a Netlist File Using the Netlist Translator.

Click OK to exit the Import Netlist Options dialog box.8.
In the Import dialog box, click OK to translate the netlist. An information dialog9.
appears that informs you to select a subcircuit that exists within the netlist.

Select the tline with 2 pins from the Netlist Subcircuit List dialog box and then click10.
OK.
Once your translation is complete, ADS displays a schematic window with the tline2
that contains two ports and a NetlistInclude component similar to the one in the
following illustration.
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 Design Containing Two Ports and a NetlistInclude Component  

Note that the File parameter in the NetlistInclude component is called tline2.net. The11.
translated file tline2.net is now in the workspace directory and looks like the netlist in
the following table. You can use the ADS text editor to open and view the ADS
Netlist.

 Translated Transmission Line Subcircuit (tline2.net) Netlist

; *TRANSMISSION-LINE SUBCIRCUIT

define tline2 (n1 n3)

TLIN4:t1 n1 n2 n3 n4 Z=50 E=(1.5e-09)*360 F=1

TLIN4:t2 n2 0 n4 0 Z=100 E=(1e-09)*360 F=1

end tline

To view the design details of your NetlistInclude component:

From the schematic window, click File > Design Parameters. The  Design1.
Parameters dialog box appears. The General tab is displayed by default.
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The Cell and Description fields display the current cell and schematic name by
default.
The Component Instance Name field default is X. The text in this field is used as
a prefix in building a unique name (ID) for every item. This prefix becomes part
of the annotation displayed with the symbol representing the parametric
subnetwork when you place it in a design.
The Library field displays the name of the library that the design is owned by.
This might be something like Spice Netlists. For more information, refer to
Including Models and Subcircuits.

Click the Parameters tab. The Parameters tab does not apply to this particular2.
example; however, you may find it helpful to understand the function of this dialog
box for future reference.
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When you import a SPICE file containing a subcircuit with parameters to an ADS
schematic, you can use this tab to view or edit the parameter details. Each
parameter is listed in the Select Parameter field and has characteristics that
determine how it is handled when the network is reused. These include the
Parameter Name , the Value Type assigned to the parameter, the Default Value , and
optional control attributes. Default values are listed only if they were specified in the
SPICE file.
For more information on subcircuit parameters, refer to ".SUBCKT".
Click OK to continue.3.

To add an instance of your imported design:

Open the schematic tline_inv that was created as a result of Including Models and1.
Subcircuits and shown in Translated Schematic with Subcircuit (tline_inv).
Save the tline_inv file as tline_inv2 using the File > Save As command.2.
In the tline2_inv schematic design, delete the tline component.3.
In this example, tline2 is the imported design with the NetlistInclude component. An4.
instance of this component can be placed in your tline_inv2 design by entering the
name tline2 in the component history box. This attaches an instance of the
component to your cursor that you can now click into place. Place the instance of
tline2 in an appropriate location on the tline_inv2 schematic.

Connect the appropriate circuitry to the new subcircuit by naming pin 1 n2 and pin 25.
n4 . For more information on naming nodes, refer to Defining the Node Names.
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This completes the circuit. This circuit can now be simulated using the example6.
shown in Simulating the Translated Netlist (netlist).
ADVANCED OPTIONS7.

You may  create your own symbol by drawing it in the symbol view ( View >
Create/Edit Schematic Symbol ) and changing the Symbol Name in the
Design Parameters dialog to the name of the design, tline2 in this example.
Save the AEL file from the Design Parameters dialog and the design file from the
File menu. A new symbol will not automatically appear in the design in which it
is used. For the new symbol to appear in your design, replace the instance of
tline2 in your test circuit.

For additional information about the NetlistInclude component, refer to Adding the
NetlistInclude Component (netlist).

 Understanding Import Details

  
This section describes some of the unique details of the translation process that should be
understood before attempting to translate a design.

 Using Valid ADS Characters   

The  legal character set for Advanced Design System names is alphanumeric _ + - = ^ '
@ # & $ %. Legal characters other than alphanumeric and underscore require special
handling. Any string using special characters in ADS must be enclosed by quotes. This is
handled by the translator.

Note
Do not insert extra quotes in your file. Additionally, $ and % are not allowed in subcircuit names since
these become invalid design and file names.

If the translator encounters an illegal character (any character not listed above), the
illegal character is replaced with an underscore and a warning message is written to the
log file.

 Understanding Capitalization   

Like Spectre, ADS is a case sensitive system, so Abc and ABC represent two different
designs, components, etc. If the Suppress name mapping option is not selected in the
Import Netlist Options dialog, the translator converts all node names, element and model
names, variable names and subcircuit names to lower case. Conversion to all lower case
can cause a problem if the design being imported references an existing ADS design that
has a mixed case name or a name that is all capitals. In addition, this can case a problem
if two or more items are referenced within the Spectre netlist use case to differentiate
between them, for example, two components named RS and rs.

Refer to Suppress name mapping: for information on toggling the Suppress name
mapping option. For more information on the command line option, refer to Importing a
File from the Command Line (netlist). If this option is used, the names in the file must use
consistent capitalization; for example, every time Abc is used, it must be capitalized the
same.

 

 Using Unique Names

The Spectre and SPICE simulators are less restrictive than ADS with regards to  unique
names. Model names must be different than device names and the translator modifies the
device name to help provide uniqueness.
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The only other restriction is that a subcircuit cannot override the name of a built-in
component. The translator does not check for this at this time, since the library of parts is
always growing and the translator is run as a separate process from ADS.

On UNIX, this should not be an issue because component names in ADS typically
begin with a capital letter, and any subcircuit name that is output by the translator
will be in lower case. The exception would be if the Suppress name mapping option
were turned ON. For more information on the Suppress name mapping option, refer
to Suppress name mapping:.

On a PC, this may present a problem in ADS because design names follow a case-
insensitive rule (for this one particular case). Because design names become file
names and the file system is case-insensitive, a subcircuit could potentially attempt
to override a built-in component.
If there is a situation where the name of the subcircuit is the same as the name of an
existing ADS component, the name of the subcircuit will be changed in the schematic
created by the translator. This will not be the case if the netlist option is used, which
will lead to an error during simulation. The user is responsible for unique names in
this situation.

 

 Using Global Nodes

 Global nodes are node names which, when used at any level of the hierarchy in the
circuit, will be connected to the same node. In Spectre, you declare a global node in the
following manner in a definition statement (the first node is always assumed to be
ground):

global gnd VCC1 VCC2

or

gnd! VCC1! VCC2!

Berkeley SPICE does not support global nodes and HSpice and PSpice have different
implementations. In HSpice, a global node in a definition statement is declared as:

.global VCC1 VCC2

In PSpice, it is just defined when used by putting $G_ in front of the node name:

$G_VCC1 $G_VCC2

Global nodes are translated in the style of PSpice except that instead of special characters
at the beginning, an exclamation point is appended to the node name when it is used. In
the example above, the node names become VCC1! and VCC2!. Additionally, this must be
quoted since the exclamation point is a special character to ADS, so it becomes "VCC1!"
and "VCC2!".
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 MOSFET Models
The following information describes how the various MOSFET models from SPICE and
Spectre are translated to the corresponding ADS models.

 SPICE Models

All Mosfet devices in SPICE reference a model by its instance name. Each Mosfet model in
SPICE has a keyword NMOS or PMOS, as well as a Level parameter.

The NMOS/PMOS keyword is used to determine what device to place in the schematic,
MOSFET_NMOS or MOSFET_PMOS. The Level is used to determine which model is placed
and what value is set for Idsmod.

In the ADS netlist, the model is always called MOSFET, with the appropriate keywords
NMOS and PMOS set to [0|1], and the parameter Idsmod set as specified in the following
table.

The only exception to this is the Mosfet device which refers to an HSpice Level 50 model,
the Phillips MOS9 model. In this case, the device placed in the schematic will be
MM9_NMOS or MM9_PMOS and the model will be MOS_Model9_Process. The netlist
component is called MOS9. For both the MM9_NMOS and the MM9_PMOS, the translator
sets the parameter Type=2 to indicate that it is a process-based model.

 SPICE Level Parameters Mapping Table (MOSFET)

Spice2/3
Level

PSpice
Level

HSpice
Level

ADS Schematic
Model

ADS Netlist
Idsmod

ADS BSIM3 Version

1 1 1 LEVEL1_Model 1  

2 2 2 LEVEL2_Model 2  

3 3 3 LEVEL3_Model 3  

4 4 13, 28 BSIM1_Model 4  

5 - 39 BSIM2_Model 5  

 7  BSIM3_Model 8 3.1

  49, 53 BSIM3_Model 8 legal BSIM3 Versions are: 3.0,
3.1, 3.2, 3.21, and 3.22

 Dependence Parameters

There are certain model parameters listed in the BSIM Models that reference additional
parameters. These additional parameters are denoted in parenthesis using the letters L, W
and/or P. As an example, the Dwg (L,W, P) parameter in the BSIM3 Model defines four
separate parameters:

Dwg: Coefficient of Weff's gate dependence
LDwg: Length dependence of Dwg
WDwg: Width dependence of Dwg
PDwg: Cross dependence of Dwg

Each letter indicates a sensitivity parameter that exists in HSpice and ADS. These
parameters are length(L), Width(W) and Cross(P). Refer to your HSpice and ADS
component documentation for details.

 HSpice Automatic Model Selection

Automatic Model Selection, also known as binning, is an HSpice feature that allows for the
definition of a library of Mosfets over a range of lengths and widths. The following netlist
fragment is an example of automatic model selection in HSpice. It is currently used only
for Mosfets. Notice that the model name is a root name plus an extension, separated by a
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period (that is: NCHAN.2). Also note the special model parameters, LMIN, LMAX, WMIN
and WMAX. They are used only for automatic model selection.

.OPTION WL

M1 1 2 3 4 NCHAN 10 2

M2 1 2 3 4 NCHAN 10 3

$$$$$$$ FOR CHANNEL LENGTH SELECTION

.MODEL NCHAN.2 NMOS LEVEL=2 VTO=2.0 UO=800 TOX=500

\+NSUB=1E15

+ RD=10 RS=10 CAPOP=5

+ LMIN=1 LMAX=2.5 WMIN=2 WMAX=15

.MODEL NCHAN.3 NMOS LEVEL=2 VTO=2.2 UO=800 TOX=500

\+NSUB=1E15

+ RD=10 RS=10 CAPOP=5

+ LMIN=2.5 LMAX=3.5 WMIN=2 WMAX=15

The ADS equivalent of this functionality is provided by a component called BinModel. Since
ADS component names cannot include a period, the models are renamed nchanx2 and
nchanx3. Then a BinModel component is placed, which lists the models by name, as well
as listing the special length and width parameter ranges, as defined by LMIN, LMAX,
WMIN and WMAX. The name of the BinModel component is the same as the root name of
the models, in this case nchan. The ranges of all models with the same root name will be
recorded on one BinModel component as shownin the following figure.

 The ADS BinModel Component

Also note that the Mosfet devices that are placed in the schematic do not refer to the
Mosfet models as they normally would. Instead they refer to the BinModel. During
simulation, the length and width specified on the device are sent to the BinModel and
checked against the ranges specified for each model, to determine which model to use. If
the length and width on the device fall within the range of the length and width on more
than one model, the first one that matches is used.

 Spectre Models   

All Mosfet devices in Spectre reference a model by its instance name. Each Mosfet model
in Spectre has a name value pair type=[n|p].
The type value pair keyword is used to determine what device to place in the schematic,
MOSFET_NMOS or MOSFET_PMOS. The Level is used to determine which model is placed
and what value is set for Idsmod.

In the ADS netlist, the model is always called MOSFET, with the appropriate keywords
NMOS and PMOS set to [0|1], and the parameter Idsmod set as specified in the following
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table.

The only exception to this is the Mosfet device which refers to the Phillips MOS902 model.
In this case, the device placed in the schematic will be MM9_NMOS or MM9_PMOS and the
model will be MOS_Model9_Process. The netlist component is called MOS9. For both the
MM9_NMOS and the MM9_PMOS, the translator sets the parameter Type=2 to indicate
that it is a process-based model.

 Spectre Level Parameters Mapping (MOSFET)

Spectre Model Supported ADS Schematic Model ADS Netlist Idsmod ADS BSIM3 Version

mos0 NO Not Translated   

mos1 YES LEVEL1_Model 1  

mos15 NO Not Translated   

mos2 YES LEVEL 2_Model 2  

mos3 YES LEVEL3_Model 3  

mos30 NO Not Translated   

mos3002 NO Not Translated   

mos705 NO Not Translated   

mos902 YES MOS_Model9_Process N/A  

mos903 NO Not Translated   

bsim3v3 YES BSIM3_Model 8 3.22

b3soi-pd YES BSIM3SOI_Model   

 Dependence Parameters

There are certain model parameters listed in the BSIM Models that reference additional
parameters. These additional parameters are denoted in parenthesis using the letters L, W
and/or P. As an example, the Dwg (L,W, P) parameter in the BSIM3 Model defines four
separate parameters:

Dwg: Coefficient of Weff's gate dependence.
LDwg: Length dependence of Dwg.
WDwg: Width dependence of Dwg.
PDwg: Cross dependence of Dwg.

Each letter indicates a sensitivity parameter that exists in Spectre and ADS. These
parameters are length(L), Width(W) and Cross(P). Refer to your Spectre and ADS
component documentation for details.

The following MOSFET models are translated in ADS:

LEVEL1 Model-LEVEL 1 MOSFET Model (netlist)
LEVEL2 Model-LEVEL 2 MOSFET Model (netlist)
LEVEL3 Model-LEVEL 3 MOSFET Model (netlist)
BSIM1 Model-BSIM1 MOSFET Model (netlist)
BSIM2 Model-BSIM2 MOSFET Model (netlist)
BSIM3 Model-BSIM3 MOSFET Model (netlist)
BSIM4 Model-BSIM4 MOSFET Model (netlist)
BSIM3SOI Model- BSIM3SOI Model (netlist)
MOS Model9 Process-Philips MOS Model 9 (Process Based) (netlist)

 Binning Process   

In order for ADS to translate the binning process, each binning definition is translated as a
separate model.

 Binning Example   
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The following is an example Spectre binning statement for a bsim model:

model ModelName ModelType {

  1: <model parameters> lmin=2 lmax=4 wmin=1 wmax=2

  2: <model parameters> lmin=1 lmax=2 wmin=2 wmax=4

  3: <model parameters> lmin=2 lmax=4 wmin=4 wmax=6

}

The Netlist Translator separates each binning reference into an ADS model. The example
would result in three models with the names ModelName_1, ModelName_2, and
ModelName_3. The models are then tied together by creating an ADS "BinModel"
component and configuring the appropriate min/max values.
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 Simulating the Translated Netlist
Once your netlist is successfully translated into Advanced Design System, you can  
simulate your new circuit in ADS. This section discusses some of the details involved in
circuit simulation and provides references to other sources. The example used in this
section refers to the Transmission-Line Inverter design created in Including Models and
Subcircuits (netlist).

 

 Example SPICE Design

The following two example SPICE files make up a simple transmission line inverter. The
first SPICE netlist (tline.sp) is a subcircuit.

*TRANSMISSION-LINE SUBCIRCUIT
.SUBCKT TLINE 1 3
T1 1 2 3 4 Z0=50 TD=1.5NS
T2 2 0 4 0 Z0=100 TD=1NS
.ENDS TLINE
.END

The next SPICE netlist (inverter.sp) includes additional components that complete the
transmission line inverter design.

*TRANSMISSION-LINE INVERTER
V1 1 0 PULSE 0 1 0 0.1NS 0.1NS 20NS 40NS
R1 1 2 50
R2 4 0 50

The resultant file from the import process is called tline_inv. See Importing a Netlist File
(netlist) for more information.

Note
Although tline_inv is a design translated from SPICE netlists, the simulation steps and concepts described
in this section are directly applicable to Spectre imported designs.

 

 Setting Up and Performing a Simulation

Setting up and performing a simulation in Advanced Design System requires several
steps:

Opening the Schematic1.
Adding Simulation Components2.
Running the Simulation3.
Displaying the Results4.

  

 Opening the Schematic

To open an existing schematic design:

Choose File > Open... in the ADS Schematic window. The Open Cell View dialog box1.
is displayed. You can use this dialog box to select the Library you wish to simulate.
Choose the appropriate Library, Cell, and View from the Open Cell View dialog2.
box.(For this example the tline_inv file created in Importing a Netlist File (netlist) will
be used.)
Click OK to include the schematic in the ADS Schematic window.3.
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For more information on opening designs, refer to, "Opening an Existing Design"  in
Schematic Capture and Layout (usrguide).

 Adding Simulation Components  

After translating your netlist into ADS, you may need to add stimulus or  simulation
control components to your library. In the schematic window containing the library you
want to simulate, select the appropriate simulation control elements from the component
palette.
To add a simulation component to the tline_inv example:

Select the Simulation - Transient from the component palette. An instance of the1.
TRANSIENT component is attached to your cursor (see The ADS Simulation-Transient
Component).
Using your mouse, locate the component to an appropriate area on the schematic2.
and click to place the component.
Click and edit the values of the StopTime and MaxTimeStep Tran parameters. For this3.
example as follows:

StopTime=40 nsec
MaxTimeStep=.10 nsec

 

 The ADS Simulation-Transient Component

For more information on using the Transient/Convolution Simulation component, refer to
Transient and Convolution Simulation (cktsimtrans).

  

 Running the Simulation

Once you have added all of the necessary simulation components to your design, execute
the simulation.
To run the  simulation, choose Simulate > Simulate from the menu selection or click the

Simulate button in the toolbar. 

  

 Simulation/Synthesis Message Window

The  Simulation/Synthesis Message window appears whenever a simulator is launched and
displays messages about the status of the current process, as well as warning messages.
The window contains two information panels:

Simulation/Synthesis Messages
Status/Summary

 

 Simulation/Synthesis Messages

The Simulation/Synthesis Messages portion of the window displays detailed messages

file:/pages/createpage.action?spaceKey=ads2011&amp;title=Managing+Workspace+and+Designs&amp;linkCreation=true&amp;fromPageId=132421087
file:/pages/createpage.action?spaceKey=ads2011&amp;title=Managing+Workspace+and+Designs&amp;linkCreation=true&amp;fromPageId=132421087
file:/pages/createpage.action?spaceKey=ads2011&amp;title=Managing+Workspace+and+Designs&amp;linkCreation=true&amp;fromPageId=132421087
file:/pages/createpage.action?spaceKey=ads2011&amp;title=Managing+Workspace+and+Designs&amp;linkCreation=true&amp;fromPageId=132421087
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about problems encountered during a simulation or synthesis, and where possible, what
you can do to solve the problem.

Hint
Watch for a message that prompts you to click to view the source of the problem. Clicking this message
highlights the component(s) (in the Schematic window) causing the problem.

 

 Status/Summary

The Status/Summary portion of the window displays a Simulation finished message,
statistics such as how long the simulation or synthesis took, and the system resources
used.

  

 Viewing Simulation Status and Error Messages

When the simulation/synthesis is finished, you can save the displayed information to file
or you can send it directly to the printer.

To save the currently displayed information to file with a default filename:

Choose File > Save and click OK. The default filename consists of the simulation process
number (from the title bar of the window), with a prefix of the string sessloghpeesofsim
and a file extension of .txt. The file is saved to the current workspace directory.

To save the currently displayed information to a file with a different filename:

Choose File > Save As. Supply a filename and click OK. The file is saved to the current
workspace directory.

Note
If you have changed workspaces during the current session, the file may be written to the initial
workspace opened in this session.

To send the information directly to the printer:
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If needed, choose File > Print Setup to establish the desired setup and click OK.1.
Choose File > Print. The displayed information is sent to the printer. For details on2.
print setup, refer to Printing and Plotting (usrguide) in the "Schematic Capture and
Layout".

For more information on performing a simulation, refer to Simulation Basics (cktsim) in
Using Circuit Simulators.

 Displaying the Results   

After your simulation is complete, ADS automatically opens a Data Display window so that
you can view your simulation results. You can also open a  Data Display window to see the
results of a simulation analysis by choosing Window > New Data Display from the ADS
Main or Schematic window. After a Data Display window is open, you can select an
independent swept variable, select dependent measurements, scale the data, and add
captions to your graph. Then you can print or plot the graph.

To view the results of the simulation in a plotted Data Display:

Choose the Rectangular Plot icon to drag and drop the plot frame in the Data Display1.

window. 
The Plot Traces & Attributes dialog box appears.

Select the dataset to display from the Datasets and Equations drop-down list (2.
tline_inv for this example).
To define the traces for display on your plot, individually double-click the data ( netin3.
, netout and vsource for this example) to add each item to the Traces field.
Alternatively, you can select each item and then click Add.
Click OK in the Plot Traces & Attributes dialog box. The graph is displayed in the Data4.
Display window. Click View > View All in the Data Display window to enlarge the
plot to fit the display window.



Netlist Translator for SPICE and Spectre

60

 

 Transmission-Line Inverter Simulation Results

The preceeding illustration displays the simulation results for the Transmission-Line
Inverter ( tline_inv ).

  

 Analyzing and Comparing the Results

It is important to understand the results of your  simulation to ensure that what you are
looking at is not a result of your netlist translation, but rather the results of your circuit
design. You can analyze your data by using the various tools available in the ADS Data
Display, including a variety of plots, formats, markers and equations. For more
information on working with data displays, refer to Data Display Basics (data).

After you understand your results, you can compare your ADS simulation results to your
original HSpice simulation results. Ideally, you would like to compare your Spectre
simulation data against your ADS simulation data using the same data file format;
however, this is not always possible. There are two suggested methods that can be used
to compare your simulation results:

Visually compare your ADS Data Display output to the visual display output you have1.
available in your simulator tool. If you have the ability to output your data to an
MDIF , Citifile or Touchstone file format, you can use the Data File Tool (cktsim) to
convert your data to an ADS Dataset and view it in the ADS Data Display.
If your Spectre simulation results are in ASCII text format, you can convert your ADS2.
dataset to MDIF , Citifile or Touchstone file format (ASCII text) and compare the
data.
For more information on the different file formats, refer to Converting to an ADS
Dataset.
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Note
Remember that  Spectre and HSpice simulators use different simulator technology from the ADS
simulator; therefore, there may be incompatibilities between your file and the resultant ADS file that the
translator was unable to accommodate. Refer to Troubleshooting (connectmui) for more information.

 Converting to an ADS Dataset  

Ideally, you would like to compare your simulation data against your ADS simulation data
in the same data display format. One method of viewing your simulation data in an ADS
Data Display is to convert your HSpice simulation data into a common file format that ADS
has the ability to read. Once your data is in an accessible format, you can convert it to an
ADS Dataset using the following table.

 Data File Tool Supported File Types  

File Type File
Extension

Description

ICCAP .ds Device under test (DUT), model (MDL), and setup (SET) files from the Agilent IC-
CAP program. These files can contain Measured, Simulated, and/or Transformed
data.

Touchstone
File

.s*p Touchstone data files are analog/RF circuit component data files that contain small-
signal G-, H-, S-, Y-, or Z-network parameters described by frequency-dependent
linear network parameters for 1-, 2-, 3-, or 4-port components. The 2-port
component files can also contain frequency-dependent noise parameters. For more
detailed information on the Touchstone file format, refer to Touchstone SnP Format
(cktsim).

Citifile .citi The Common Instrumentation Transfer and Interchange file __ (CITIfile) format is a
standardized data format that is used for exchanging data between different
computers and instruments. For more detailed information on the CITIfile format,
refer to CITIfile Data Format (cktsim).

MDIF .p2d, .s2d,
.t2d

Measurement Data Interchange Format (MDIF) files are component data files for the
.p2d, .s2d, and .t2d files.

For more information on the file formats listed above, refer to Working with Data Files
(cktsim).

To use the Data File Tool to create an ADS dataset:

From the ADS Schematic window, choose Tools > Data File Tool. The1.
dftool/mainWindow dialog box appears.
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In the Data File Tool dialog box, click Read data file into dataset.2.
Under File format to read , click the appropriate file format (i.e. Touchstone , MDIF,3.
Citifile, or ICCAP ).
Under Input file name , click Browse to navigate file paths and select your Spectre4.
simulation result file.
In the Dataset Name field, enter the name of the HSpice dataset.5.
When all of the above settings are entered, click the Read File button.6.

For more information on reading files using the Data File Tool, refer to Reading and
Writing Data Files (cktsim).
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 Translating a Device
This section provides device translation tables for each of the devices supported by the
Netlist Translator.

BJT Device (netlist)
Bxxxxxxx (netlist)
Capacitor Device (netlist)
Cxxxxxxx (netlist)
Diode Device (netlist)
Dxxxxxxx (netlist)
Exxxxxxx (netlist)
Fxxxxxxx (netlist)
Gxxxxxxx (netlist)
Hxxxxxxx (netlist)
Independent Current Source (Isource) (netlist)
Independent Voltage Source (Vsource) (netlist)
Inductor Device (netlist)
Ixxxxxxx (netlist)
JFET Device (netlist)
Jxxxxxxx (netlist)
Kxxxxxxx (netlist)
Linear Current-Controlled Current Source (cccs) (netlist)
Linear Current-Controlled Voltage Source (ccvs) (netlist)
Linear Voltage-Controlled Current Source (vccs) (netlist)
Linear Voltage-Controlled Voltage Source (vcvs) (netlist)
Lxxxxxxx (netlist)
MOSFET Device (netlist)
Mutual Inductors (netlist)
Mxxxxxxx (netlist)
Oxxxxxxx (netlist)
Polynomial Current-Controlled Current Source (pcccs) (netlist)
Polynomial Current-Controlled Voltage Source (pccvs) (netlist)
Polynomial Voltage-Controlled Current Source (pvccs) (netlist)
Polynomial Voltage-Controlled Voltage Source (pvcvs) (netlist)
Qxxxxxxx (netlist)
Resistor Device (netlist)
Rxxxxxxx (netlist)
Subcircuit Reference (netlist)
Sxxxxxxx (netlist)
Txxxxxxx (netlist)
Uxxxxxxx (netlist)
Vxxxxxxx (netlist)
Xxxxxxxx (netlist)
Zxxxxxxx (netlist)

 

 Recognizing Device Identifiers

Each SPICE device is distinguished by the  first letter in it's device name. The following
table describes the device type associated with each letter of the alphabet.

 SPICE Device Table



Netlist Translator for SPICE and Spectre

64

Device Spice2 Spice3 PSpice HSpice ADS Translation

Axxxxx     Not translated

Bxxxxx  dep source gaasfet  N type GaAsFET

Cxxxxx capacitor capacitor capacitor capacitor Capacitor

Dxxxxx diode diode diode diode Diode

Exxxxx vcvs vcvs vcvs vcvs Voltage-Controlled Voltage Source

Fxxxxx cccs cccs cccs cccs Current-Controlled Current Source

Gxxxxx vccs vccs vccs vccs Voltage-Controlled Current Source

Hxxxxx ccvs ccvs ccvs ccvs Current-Controlled Voltage Source

Ixxxxx current current current current I_Source (ADS Netlist)

Jxxxxx jfet jfet jfet jfet,mesfet N or P type JFET

Kxxxxx mutual mutual mutual mutual Mutual Inductor

Lxxxxx inductor inductor inductor inductor Inductor

Mxxxxx mosfet mosfet mosfet mosfet N or P type MOSFET, also with substrate

Nxxxxx   digital  Not translated

Oxxxxx  lossy tline digital  Ideal Physical Transmission Line

Pxxxxx     Not translated

Qxxxxx bjt bjt bjt bjt NPN/PNP BJT, VBIC

Rxxxxx resistor resistor resistor resistor Resistor

Sxxxxx  vc switch vc switch  Translated to ADS sub-circuit (spice_vswitch)

Txxxxx tran line tran line tran line tran line Ideal 4-Terminal Transmission Line

Uxxxxx  rc line digital src lossy tline 2 Ideal Transformers, 1 Ideal DRC

Vxxxxx voltage voltage voltage voltage V_Source (ADS Netlist)

Wxxxxx  ic switch ic switch  Not translated

Xxxxxx subcircuit subcircuit subcircuit subcircuit subcircuit

Yxxxxx     Not translated

Zxxxxx  mesfet   N or P type MESFET

  

 Documentation Conventions

To help you interpret the ADS and Spectre syntax given for a device, the following table
describes the  conventions used in this documentation.

 Device Table Conventions

Description Example

Keywords, parameter names and other literals are in bold. poly

Parameters and names that are replaced with values by the user and are translated are in italics. n1

Optional items are enclosed in square brackets. [ic=x]

A choice between two or more items is displayed in square brackets separated by vertical bars. [off | on]

Repeated optional items are enclosed in square brackets followed by an Asterisk. [cn]*

Many parameters consist of name=value pairs; the left side is a keyword (literal text), the right
side is typically a number, expression or variable (exceptions are noted).

ic=x

Simple keywords and values must appear in the given order, but name=value pairs may occur in
any order.

 

 Example:  

ctank2 n1 n2 capacitor c0 [ cn ]* [ic= x ] [tc1= y ] [tc2= z ] [ off | on ] [param= value
]*

 Notes  

The example above is a capacitor with the name: ctank2
The capacitor has two nodes: n1 and n2



Netlist Translator for SPICE and Spectre

65

The capacitor has a required keyword: capacitor
The keyword is followed by a required value: c0
The required value may be optionally followed by any number of values: [ cn ]*
There are three stated optional name=value pairs which may appear in any order:
[ic= x ] [tc1= y ] [tc2= z ]
There is one set of optional keywords of which one may appear but not both:

[ off | on ]

There other name=value pairs which may appear in any order: [param= value ]*

Note
When translating to the ADS Simulator, the node names, values and right hand sides of
name=value pairs remain the same; however, the keywords may change to their ADS Simulator
equivalents.

  

 Using Parameter Mapping Tables to Understand a Translation

Device  parameter information is organized in tables with the ADS parameter, unit, and
default value in the three left-hand columns of the table. The parameter translation
information is described in the three right- hand columns.

The parameters that are not translated are included in the tables. The parameters under
Parameters not in Spectre Model are parameters that are supported in ADS and are not
supported in Spectre. The parameters under Parameters not in ADS Model are parameters
that are supported in Spectre and are not translated to ADS.

Refer to Introduction to Circuit Components (ccsim) for an alphabetical listing of ADS
supported devices and a detailed description of their parameters and default values.

 

 Device Tables for Spectre

This section provides individual device translation information for each specific  device
supported by the Netlist Translator. The following is a list of supported devices:

Resistor Device (netlist)
Capacitor Device (netlist)
Inductor Device (netlist)
Mutual Inductors (netlist)
Diode Device (netlist)
BJT Device (netlist)
MOSFET Device (netlist)
JFET Device (netlist)
Subcircuit Reference (netlist)

 Controlled Sources  

In Spectre-compatibility mode (default), all controlled sources are translated into Spectre
netlist syntax. Therefore, a controlled source in a Spectre netlist will be wrapped by
simulator lang=spectre and simulator lang=ads in the ADS netlist. For example, given
the following Spectre netlist fragment:

f001r002 (98 194 ) cccs probe=v002 gain=0.013357

the information above would be translated into the following ADS netlist fragment:
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simulator lang=spectre

f001r002 _node98 _node194 cccs probe=v002 gain=0.013357

simulator lang=ads

In backward-compatibility mode (-bc option), all controlled sources are translated into
ADS netlist syntax.
The device information for controlled sources in backward-compatibility mode (-bc option)

Linear Voltage-Controlled Voltage Source (vcvs) (netlist)
Linear Voltage-Controlled Current Source (vccs) (netlist)
Polynomial Voltage-Controlled Voltage Source (pvcvs) (netlist)
Polynomial Voltage-Controlled Current Source (pvccs) (netlist)
Linear Current-Controlled Current Source (cccs) (netlist)
Linear Current-Controlled Voltage Source (ccvs) (netlist)
Polynomial Current-Controlled Current Source (pcccs) (netlist)
Polynomial Current-Controlled Voltage Source (pccvs) (netlist)

 

 Independent Sources

Independent Current Source (Isource) (netlist)
Independent Voltage Source (Vsource) (netlist)
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 BJT Device
The Spectre BJT device is translated as one of the following:

a nonlinear NPN or PNP BJT device
a nonlinear NPN or PNP BJT device with substrate
an NPN device

For information on the BJT model, refer to BJT_Model (Bipolar Transistor Model) (ccnld).

 

 Example Spectre Command Line:

q1 (vcc net3 minus) npn_mod region=fwd area=1 m=1

 

 Spectre Netlist Syntax:

name nc nb ne [ ns ] ** mname ** [param= value ]*

 

 ADS Netlist Syntax:

BJT[4]:
mname : qid nc nb ne [ ns ] [param= value ]*

VBIC:
mname : qid nc nb ne ns [param= value ]*

 

 ADS Schematic Symbols:

 

 Instance Parameters:
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For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

 BJT Parameter Mapping 

ADS Name Unit Default Spectre Name Unit Default

Area  1.0 area  1.0

Region  0 (off) region  fwd

NPN   (see type model parameter)   

PNP   (see type model parameter)   

_M  1 m  1

Parameters not in Spectre Model    

Temp † °C 25    

Mode  on    

Noise  on    

   Parameters not in ADS Model

   trise °C 0.0

† Temp = trise + temp ("temp" is an ADS global variable)

 VBIC Parameter Mapping 

ADS Name Unit Default Spectre Name Unit Default

Scale  1 area  1

Region  on region  fwd

NPN  yes (see type model parameter)   

PNP  no (see type model parameter)   

_M  1 m  1

Parameters not in Spectre Model    

Temp † °C 25    

Mode  nonlinear    

Noise  on    

   Parameters not in ADS Model

   trise °C 0.0

† Temp = trise + temp ("temp" is an ADS global variable)

 

 Comments:

The referenced BJT_Model:Bipolar Transistor Model (netlist) is read to determine
which device to use:

NPN keyword indicates BJT_NPN or BJT4_NPN
PNP keyword indicates BJT_PNP or BJT4_PNP

If SCALE is specified, Value = Value * scale.

If trise is provided, Temp = trise + temp ( temp is an ADS global variable).
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 Bxxxxxxx
Semiconductor  GaAsFET Device: This device is translated as a nonlinear N-type GaAsFET
device. For information on the GaAsFET model, refer to GaAsFET and JFET Models for
SPICE (netlist).

 Example SPICE Command Line:

b1 1 2 3 Bmodel 2

 SPICE dialect and netlist syntax:

Spice2/3:|Non-linear dependent source - not translated|
PSpice: b id ** nd ** ng ** ns ** mname [ AREA ]
HSpice: Does not exist

 ADS Netlist Syntax:

mname :b id ** nd ** ng ** ns Area= area

 

 ADS Schematic Symbols:

 Instance Parameters:

bid = GaAsFET element name
mname = Model name
nd = Drain node
ng = Gate node
ns = Source node
area = Area factor
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 Capacitor Device 
The Spectre capacitor device is translated as an ADS capacitor device. For information on
the capacitor model, refer to C_Model (Capacitor Model) (ccsim).

 

 Example Spectre Command Line:

Without model referenced:
c1 (1 0) capacitor c=2.5u w=2u l=2.5u tc1=1e-8

With model referenced:
c1 (1 0) proc_cap c=2.5u w=2u l=2.5u tc1=1e-8

 

 Spectre Netlist Syntax:

Without model referenced:
name n1 n2 mname [param= value ]*
With model referenced:
name n1 n2 capacitor [param= value ]*

 

 ADS Netlist Syntax:

Without model referenced:
C: cid n1 n2 C= value [param= value ]*
With model referenced:
mname : cid n1 n2 [param= value ]*

 

 ADS Schematic Symbol:

 

 Instance Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist)

 Capacitor Parameter Mapping 
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ADS Name Unit Default Spectre Name Unit Default

C F  c F  

TC1 1/°C  tc1 1/°C 0.0

TC2 1/°C 2  tc2 1/°C 2 0.0

InitCond V 0.0 ic V 0.0

Length m  l m  

Width m  w m  

_M  1 m  1

Parameters not in Spectre Model    

Temp † °C 25    

Tnom °C     

wBv W infinity    

Model      

   Parameters not in ADS Model

   trise °C 0.0

   scale  1

†  Temp = trise + temp ("temp" is an ADS global variable)

 Comments:  

The value of C cannot be an expression that changes during the simulation.

If trise is provided, Temp = trise + temp ( temp is an ADS global variable).
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 Cxxxxxxx
Capacitor: This device is translated as a  capacitor. For information on the capacitor
model, refer to C_Model:Capacitor Model (netlist).

 Example SPICE Command Line:

c1 1 2 1pF

 SPICE dialect and netlist syntax:

Spice2/3: c id n1 n2 [ value mname ] [ l= l ] [ w= w ] [ ic= ic ]
PSpice: c id n1 n2 [ mname ] value [ ic= ic ]
HSpice: c id n1 n2 [ mname ] [ c= ] value [[ tc1= ] tc1 [[ tc2= ] tc2 ]] + [
scale=scale] [ic=ic] [m=mult] [w=w] [l=l] [dtemp=dtemp]

 ADS Netlist Syntax:

Without model referenced:

C:cid n1 n2 C=value [_M=mult]

With model referenced:

mname_:cid n1 n2 [C=value] [Length=l] [Width=w] [InitCond=ic]
+ [TC1=tc1] [TC2=tc2] [Temp=temp+(dtemp)] [M=_mult]

 

 ADS Schematic Symbol:

 Instance Parameters:

cid = Capacitor element name
mname = Model name
n1 = Positive node
n2 = Negative node
value = Capacitance in farads
l = Length in meters
w = Width in meters
ic = The optional initial condition (time-zero) value of capacitor voltage (in
volts). The initial condition (if any) applies only if the UIC option is specified on
the .TRAN control line.
tc1 = Temperature coefficient per degrees celsius.
tc2 = Temperature coefficient per degrees celsius squared.
scale = Element scale factor.
mult = Multiplier used to simulate multiple parallel devices.
dtemp = Element temperature difference with respect to circuit temperature.

 

 Comments:

HSpice: If the value of C is an expression which is a function of node voltages or
independent variables, then the component is a dependent capacitor. In ADS, the
component is represented by a Symbolically Defined Device (SDD).
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If one of the SDD parameters uses a variable containing node voltages, the translator
needs to look up the node voltages on the resultant SDD to convert them to the correct
ADS syntax and update the variable expression. For instance, the node voltage described
as v(nodeX) in HSpice must be converted to _v1, if the first pair of nodes on the SDD is
(node1, 0).

For translation purposes of this special case, the SDD and the variable used by it are
expected to be defined in the same subcircuit, with the variable being used by only one
SDD. If the variable were defined globally or used by different SDDs, the node voltage
variables (_v1, etc.) might not match up correctly. For example, in the case described
above one SDD might have (nodeX,0) as the first pair of nodes (_v1), while another SDD
might have (nodeX,0) as the 2nd pair of nodes (_v2). The translator would not be able to
replace v(nodeX) in the variable expression to define both SDDs correctly at the same
time.

If this SDD is not found in the same subcircuit as the variable expression, a warning
message will be written to the log file nettrans.log. Also, the expression will not be
converted automatically, and it will have to be fixed manually before simulation is
attempted.

If SCALE is specified, Value=Value*scale

If dtemp is provided, Temp=temp+dtemp

Translator Limitations: Functionality is available in ADS but not yet supported by the
Netlist Translator. Workarounds are provided below.

HSpice:

1) Nonlinear capacitor cid n1 n2 poly c0 c1 c2...

This is supported by ADS as a component called NonlinC. The ADS Netlist Syntax should
be:

NonlinC:cid n1 n2 coef=list(c0 c1 c2...) [ic=ic]

2) cid n1 n2 c='equation' ctype=[0|1]

This syntax requires a Symbolically Defined Device (SDD) in ADS if ctype=0. This is not
currently handled by the translator. Please contact customer support for assistance in
writing the SDD to represent the voltage across the capacitor.

The Netlist Translator fails to recognize the capacitor model in the following syntax:

c1 1 2 cmodel

The translator assumes that it is a variable name for the capacitance value. To correct
your imported schematic, manually move the model name to the parameter Model. To
correct the ADS Netlist, use the following netlist syntax:

cmodel:c1 1 2 [param=value]*
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 Diode Device
The Spectre diode device is translated as an ADS diode device. For information on the
diode model, refer to Diode Model (PN-Junction Diode Model). (ccnld)

 

 Example Spectre Command Line:

d0 (dp dn) pdiode l=3e-4 w=2.5e-4 area=1

 

 Spectre Netlist Syntax:

name n1 n2 mname [param= value ]*

 

 ADS Netlist Syntax:

mname : did node1 node2 [param= value ]*

 

 ADS Schematic Symbol:

 

 Instance Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist)

 Diode Parameter Mapping 
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ADS Name Unit Default Spectre Name Unit Default

Area  1 area   

Periph  0 perim   

Length m  l m 1e-6

Width m  w m 1e-6

Region  on region  on

_M  1 m  1

Parameters not in Spectre Model    

Temp † °C 25    

Mode  nonlinear    

Noise  yes    

Gd Siemens     

Cd F     

   Parameters not in ADS Model

   trise °C  

   scale  1

† Temp = trise + temp ("temp" is an ADS global variable)

 Comments:  

If trise is provided, Temp = trise + temp ( temp is an ADS global variable).
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 Dxxxxxxx
Semiconductor Diode: This device is translated as a nonlinear  diode device. For
information on the diode model, refer to BJT_Model:Bipolar Transistor Model (netlist).

 Example SPICE Command Line:

d1 1 2 Dmodel 2 OFF

 SPICE dialect and netlist syntax:

Spice2/3: d id n1 n2 mname [ area ] [ off ] [ ic= vd ] [ temp= temp ]

PSpice: d id n1 n2 mname [ AREA ]

HSpice: d id n1 n2 mname [[ AREA= area ] [ PJ= periph ]] [ W= wval L= lval
]] + [ off ] [ dtemp= dtemp ] [ m= mult ] [ ic= vd ]
[ pj= x ] [ wp= x ] [ lp= x ] + [ wm= x ] [ lm= x ]

OR

d id n1 n2 mname [ area [ periph ]] [ OFF ] [ IC= vd ] [ M= val ]

 

 ADS Netlist Syntax:

mname : d id node1 node2 [[ Area= area ] [ Periph= periph ]| +
[Width=wval] [Length=lval]] [ Temp= temp| [ temp +dtemp ]\ ] [ _M= mult ]

 

 ADS Schematic Symbol:

 

 Instance Parameters:

Did = Diode element name
mname = Model name
n1 = Positive node
n2 = Negative node
area = Area factor. If area is not specified and W and L are, area is calculated
as lval*wval.
periph = Scaling factor that affects the sidewall. If PJ or periph is not specified,
and W and L are, Periph is calculated as 2*(wval + lval).
Width = Geometric width of diode junction (meters).
Length = Geometric length of diode junction (meters).
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 Exxxxxxx
Linear  Voltage-Controlled Voltage Source: This device is translated as a Symbolically
Defined Device. For information on SDD's, refer to Using a Symbolically Defined Device
(netlist).

 Example SPICE Command Line:

e1 1 2 3 4 2.0

 SPICE dialect and netlist syntax:

Spice2/3:

e id n1 n2 cn1 cn2 value

PSpice:

e id n1 n2 cn1 cn2 value
eid n1 n2 poly(1) cn1 cn2 value
nonlinear: eid n1 n2 poly(n)...

HSpice:

e id n1 n2 cn1 cn2 value
eid n1 n2 poly(1) cn1 cn2 value
nonlinear: eid n1 n2 poly(n)...

 ADS Netlist Syntax:

SDD:e id cn1 cn2 n1 n2 I[1,0]=0 F[2,0]=_v2-( value *_v1)

 ADS Schematic Symbol:  

eid = Source element name
n1= Positive Node
n2 = Negative Node
cn1 = Positive Controlling Node
cn2 = Negative Controlling Node
value = Voltage gain
poly() = Polynomial function

 

 Comments:

The following syntax extensions are not supported by the translator. If these keywords or
parameters are found, component translation will fail and a warning message will be
written to the translation log file.

PSpice:

TABLE, LAPLACE, FREQ, CHEBYSHEV

HSpice Keywords:
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PWL, AND, NAND, OR, NOR, DELAY, OPAMP, TRANSFORMER

HSpice Parameters:

MAX, MIN, SCALE, TC1, TC2, ABS, DELTA, IC, NPDELAY
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 Fxxxxxxx
Linear  Current-Controlled Current Source: This device is translated as a Symbolically
Defined Device. For information on SDD's, refer to Using a Symbolically Defined Device
(netlist).

 Example SPICE Command Line:

f1 vout 0 vname 0.05

 SPICE dialect and netlist syntax:

Spice2/3:

f id n1 n2 sourceName value

PSpice:

f id n1 n2 sourceName value

HSpice:

f id n1 n2 sourceName value

 ADS Netlist Syntax:

SDD:f id n1 n2 I[1,0]= value *_c1 C[1]="sourceName"

 

 ADS Schematic Symbol:

fid = Source element name
n1 = Positive Node
n2 = Negative Node
value = Transconductance (in mhos).
sourceName = Name of controlling source

 

 Comments:

The following syntax extensions are not supported by the translator. If these keywords or
parameters are found, component translation will fail and a warning message will be
written to the translation log file.

HSpice Keywords:

PWL, AND, NAND, OR, NOR, DELAY

HSpice Parameters:

MAX, MIN, SCALE, M, TC1, TC2, ABS, DELTA, IC, NPDELAY
  



Netlist Translator for SPICE and Spectre

80

 Gxxxxxxx
Linear  Voltage-Controlled Current Source: This device is translated as a Symbolically
Defined Device. For information on SDD's, refer to Using a Symbolically Defined Device
(netlist).

 Example SPICE Command Line:

g1 1 2 3 4 .1mMho

 SPICE dialect and netlist syntax:

Spice2/3:

g id n1 n2 cn1 cn2 value

PSpice:

g id n1 n2 cn1 cn2 value

HSpice:

g id n1 n2 cn1 cn2 value

 ADS Netlist Syntax:

SDD:g id cn1 cn2 n1 n2 I[1,0]=0 F[2,0]=_v2-( value *_v1)

 

 ADS Schematic Symbol:

 Instance Parameters:

gid = Source element name
n1 = Positive Node
n2 = Negative Node
cn1 = Positive Controlling Node
cn2 = Negative Controlling Node
value = Transconductance (in mhos).
poly() = Polynomial function

 

 Comments:

The following syntax extensions are not supported by the translator. If these keywords or
parameters are found, component translation will fail and a warning message will be
written to the translation log file.

PSpice

TABLE, LAPLACE, FREQ, CHEBYSHEV

HSpice Keywords:
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PWL, AND, NAND, OR, NOR, DELAY, VCR, VCCAP

HSpice Parameters:

MAX, MIN, SCALE, M, TC1, TC2, ABS, DELTA, SMOOTH, IC, NPDELAY
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 Hxxxxxxx
Linear  Current-Controlled Voltage Source: This device is translated as a Symbolically
Defined Device. For information on SDD's, refer to Using a Symbolically Defined Device
(netlist).

 Example SPICE Command Line:

h1 vout 0 vname 0.05

 SPICE dialect and netlist syntax:

Spice2/3:

h id n1 n2 sourceName value

PSpice:

h id n1 n2 sourceName value

HSpice:

h id n1 n2 sourceName value

 ADS Netlist Syntax:

SDD:h id n1 n2 F[1,0]=-( value *_c1)+_v1 C[1]=" sourceName "

 

 ADS Schematic Symbol:

 Instance Parameters:

gid = Source element name
n1 = Positive Node
n2 = Negative Node
value = Transconductance (in mhos).
sourceName = Name of controlling source
poly() = Polynomial function

 

 Comments:

The following syntax extensions are not supported by the translator. If these keywords or
parameters are found, component translation will fail and a warning message will be
written to the translation log file.

HSpice Keywords:

PWL, NPWL, PPWL, AND, NAND, OR, NOR, DELAY

HSpice Parameters:
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MAX, MIN, SCALE, TC1, TC2, ABS, DELTA, IC, NPDELAY
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 Independent Current Source (Isource)
The Spectre Isource device is translated as either an I_Source (ADS Netlist) or an
ItUserDef (ADS Schematic).

 

 Example Spectre Command Line:

i1 (in 0) isource dc=0 type=pulse delay=10n val0=0 val1=500u

period=450n rise=1n fall=1n width=200n

 

 Spectre Netlist Syntax:

name sink src isource [param= value ]*

 

 Example ADS Command Line:

I_Source:i1 in 0 Idc=0 I_Tran=pulse(time,0,500u,10n,1n,1n,200n,450n)

 

 ADS Netlist Syntax:

I_Source:iid n+ n- Idc=dcval lac=polar(mag,phase) I_Tran=tranfunc
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 Independent Voltage Source (Vsource)
The Spectre Vsource device is translated as either an V_Source (ADS Netlist) or an
VtUserDef (ADS Schematic).

 

 Example Spectre Command Line:

vpulse1 (1 0) vsource type=pulse val0=0 val1=5 period=100n rise=10n

fall=10n width=40n

Alternate example:

vpwl1 (1 0) vsource type=pwl wave=[1n 0 1.1n 2 1.5n 0.5 2n 3 5n 5]
pwlperiod=5n

 

 Spectre Netlist Syntax:

name sink src vsource [param= value ]*

 

 Example ADS Command Line:

V_Source:vpulse1 _node1 0 Vdc=1

V_Tran=pulse(time,0,5,0,10n,10n,40n,100n)

 

 ADS Netlist Syntax:

V_Source:vid n+ n- Vdc=dcval Vac=polar(mag,phase) V_Tran=tranfunc

Alternate example:

V_Source:vpwl1 _node1 0 Vdc=1

V_Tran=pwl(5n,1n,0,1.1n,2,1.5n,0.5,2n,3,5n,5)
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 Inductor Device
The Spectre mutual_inductor device is translated as an ADS mutual inductor.

 

 Example Spectre Command Line:

Without model referenced:
l33 (0 net29) inductor l=10e-9 r=1 m=1

With model referenced:
l33 (0 net29) ind l=6e-9 r=1 tc1=1e-12 tc2=1e-12 tnom=25

 

 Spectre Netlist Syntax:

Without model referenced:
name n1 n2 inductor [param= value ]*
With model referenced:
name n1 n2 mname [param= value ]*

 

 ADS Netlist Syntax:

L: lid n1 n2 L= value

 

 ADS Schematic Symbol:

 

 Instance Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist)

  Inductor Parameter Mapping
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ADS Name Unit Default Spectre Name Unit Default

L H 0.0 l H 0.0

R ohms 0.0 r ohms 0.0

InitCond A 0.0 ic A 0.0

Noise  yes isnoisy  yes

_M  1 m  1

Parameters not in Spectre Model    

Temp † °C 25    

Tnom °C     

TC1 1/°C     

TC2 1/°C 2     

   Parameters not in ADS Model

   trise °C 0.0

† Temp = trise + temp ("temp" is an ADS global variable)

 

 Comments:

If SCALE is specified, Value = Value * scale.

If trise is provided, Temp = trise + temp ( temp is an ADS global variable).
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 Ixxxxxxx
Independent  Current Source: This device is translated as either an I_Source (ADS Netlist)
or an ItUserDef (ADS Schematic).

 Example SPICE Command Line:

i1 1 2 DC 6

i2 2 3 AC 1 90

i3 3 0 PULSE(-1 1 2NS 2NS 2NS 50NS 100NS)

i4 3 0 SIN(0 1 100MEG 1NS 1E10)

i5 3 0 EXP(-4 -1 2NS 30NS 60NS 40NS)

i6 7 5 PWL(0 -7 10NS -7 11NS -3 17NS -3 18NS -7 50NS -7)

i7 12 0 SFFM(0 1M 20K 5 1K)

 SPICE dialect and netlist syntax:

Spice2/3:

i id n+ n- [[ dc ] dcval ] [ ac [ mag [ phase ]]] [ tranfunc ]

PSpice:

i id n+ n- [[ dc ] dcval ] [ ac [ mag [ phase ]]] [ tranfunc ]

HSpice:

i id n+ n- [[ dc ] dcval ] [ ac [ mag [ phase ]]] [ tranfunc ]

 ADS Netlist Syntax:

I_Source:i*id n+ n- *Idc=*dcval *lac=polar(mag,phase)
*I_Tran=*tranfunc

 

 ADS Schematic Symbol:

 Instance Parameters:

iid = GaAsFET element name
n+ = Positive node
n- = Negative node
dcval = The dc current
mag, phase = The magnitude and phase of the ac current.
tranfunc = Transient Source Functions. There are several built in ADS functions that
mimic the SPICE transient source functions listed below.

SPICE Advanced Design System
EXP() exp_pulse(time, low, high, tdelay1, tau1, tdelay2, tau2)
PULSE() pulse(time, low, high, delay, rise, fall, width, period)
PWL() pwl(time, t1, x1,..., tn, xn)
SFFM() sffm(time, offset, amplitude, carrier_freq, mod_index, signal_freq)
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SIN() damped_sin(time, offset, amplitude, freq, delay, damping)

HSpice
PU() pulse(time, low, high, delay, rise, fall, width, period)
AM() Not translated.
PL() Not translated.

 

 Comments:

HSpice:
HSpice multiplier on Current sources - This is implemented by making an expression out
of the given current value. Example:

HSpice: i1 n1 n2 500ua m=10
ADS: eqn0=(500ua)*(10)
I_Source: i1 n1 n2 Idc=500ua*10

Unsupported HSpice transient functions - AM, PL

Unsupported HSpice syntax extensions -

Data driven PWL source

Repeat and Time Delay specifications in PWL transient function (R=repeat, TD=delay)

PSpice:
Unsupported PSpice syntax extensions

STIMULUS
corner points, TIME_SCALE_FACTOR, VALUE_SCALE_FACTOR
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 JFET Device
The Spectre JFET device is translated as either a nonlinear N-type or a nonlinear P-type
JFET device. For information on the JFET model, refer to JFET_Model (Junction FET Model)
(ccnld).

 Example Spectre Command Line:  

jk1 (net1 net2 0) jmod area=1

 Spectre Netlist Syntax:  

name nd ng ns [ nb ] mname [param= value ]*

 ADS Netlist Syntax:  

vcvs:name p n ps ns [param= value ]*

 ADS Schematic Symbol:  

 Instance Parameters:  

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

 JFET Model Parameter Mapping 
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ADS Name Unit Default Spectre Name Unit Default

Length m  l m  

Width m  w m  

Ad m 2  ad m 2  

As m 2  as m 2  

Pd m  pd m  

Ps m  ps m  

Nrd   nrd m/m  

Nrs   nrs m/m  

Region  on region  triode

_M  1 m  1

Parameters not in Spectre Model    

Temp † °C 25    

NMOS  yes    

PMOS  no    

Mode  1    

Noise  yes    

   Parameters not in ADS Model

   trise °C 0.0

   ld m  

   ls m  

   degradation  no

† Temp = trise + temp ("temp" is an ADS global variable)

 Comments:  

The referenced JFET_Model:Junction Field Effect Transistor Model (netlist) model is
read to determine which JFET device to use:

PJF keyword indicates JFET_PFET
NJF keyword indicates JFET_NFET

The 4-port JFET is not available in ADS. The device will be skipped.

If SCALE is specified, Value = Value * scale.

If trise is provided, Temp = trise + temp ( temp is an ADS global variable).

The following syntax bay be ambiguous to the translator if the referenced model is
not in the translated files:

Jid nd ng ns var1 var2

The translator is unable to determine which of the following should be used:

Jid nd ng ns na modelname

or

Jid nd ng ns modelname area

Since the 4 port device is not available anyway, it will assume that modelname and area
are specified. A warning message will be reported in the log file.
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 Jxxxxxxx
Semiconductor  JFET Device: This device is translated as either a nonlinear N-type or a
nonlinear P-type JFET device. For information on the JFET model, refer to
JFET_Model:Junction Field Effect Transistor Model (netlist).

 Example SPICE Command Line:

j1 1 2 3 Jmodel 2 OFF IC=0.6, 5.0

 SPICE dialect and netlist syntax:

Spice2/3:

j id nd ng ns mname [ area ] [ off ] [ ic= vds , vgs ] [ temp= x ]

PSpice:

j id nd ng ns mname [ area ]

HSpice:

j id nd ng ns [ nb ] mname [ area w= w l= l ] [ off ] [ m= mult ]

 ADS Netlist Syntax

mname :j id nd ng ns [ Area= area ] [ Temp=temp +dtemp ] [ Region= 0]

 ADS Schematic Symbol:  

 Instance Parameters:

jid = JFET element name
mname = Model name
nd = Drain node
ng = Gate node
ns = Source node
nb = optional bulk node - not supported.
area = Area factor
off = Initial condition on the device for dc analysis. Translates to Region=0.
mult = Multiplier used to simulate multiple parallel devices.
temp = Temperature at which the device is to operate.

 

 Comments:

The referenced JFET_Model:Junction Field Effect Transistor Model (netlist) is read to
determine which JFET device to use:

PJF keyword indicates JFET_PFET
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NJF keyword indicates JFET_NFET

The 4-port JFET is not available in ADS. The device will be skipped.

If SCALE is specified, Value=Value*scale

If dtemp is provided, Temp=temp+dtemp

The following syntax bay be ambiguous to the translator if the referenced model is not in
the translated files:

Jid nd ng ns var1 var2

The translator is unable to determine which of the following should be used:

Jid nd ng ns na modelname

or:

Jid nd ng ns modelname area

Since the 4 port device is not available anyway, it will assume that modelname and area
are specified. A warning message will be reported in the log file.
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 Kxxxxxxx
Coupled (Mutual)  Inductors: This device is translated as a mutual inductor.

 Example SPICE Command Line:

k1 L1 L2 .5

L1 1 3 10

L2 2 4 20

 SPICE dialect and netlist syntax:

Spice2/3:

k id lid1 lid2 value

PSpice:

k id lid1 lid2 * value

HSpice:

k id lid1 lid2 [ K= ] value

 ADS Netlist Syntax:

Mutual:k id K= value Inductor1=" lid1 " Inductor2=" lid2 "

 ADS Schematic Symbol:  

 Instance Parameters:

kid = Mutual inductors element name
lid1 = Name of the first coupled inductor.
lid2 = Name of the second coupled inductor.
value = The coefficient of coupling, K, which must be greater than 0 and less than or
equal to 1.

 

 Comments:

The ADS Schematic symbol for an individual inductor uses a slash on the wire near pin 1
as opposed to the standard dot used in SPICE. Note that the MUTIND on the left is the
symbol placed when the K is read. The example on the right is an illustration of the
referenced inductors.

For value, HSpice and ADS allows a coefficient of coupling between -1 and 1.

PSpice supports a mutual inductor syntax that allows any number of inductors to be
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coupled together with the same coupling coefficient. This needs to be converted to a
set of mutual inductors representing every possible combination of inductors from the
list. The translator does not support this at this time.

Unsupported Syntax and Parameters

PSpice:

kid lid1 coupling value model [size]
kid T1name T2name Cm=cval Lm=1val

HSpice:

HSpice model syntax
HSpice MAG parameter
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 Linear Current-Controlled Current Source (cccs)
The Spectre cccs device is translated as an ADS Symbolically-Defined Device (SDD).

 

 Example Spectre Command Line:

Cs1 n1 n2 cccs probe=v002 gain=0.013357

 

 Spectre Netlist Syntax:

name p n cccs [param= value ]*

 

 ADS CCCS (SDD):

SDD:Cs1 n2 n1 C[1]="v002" I[1,0]=-1*0.013357*_c1

Note
The netlist syntax for ADS is valid only when using the backward-compatibility option (-bc option). The
order of nodes is reversed because Spectre components list the output node pair first, followed by the
input node pairs.
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 Linear Current-Controlled Voltage Source (ccvs)
The Spectre ccvs device is translated as an ADS Symbolically-Defined Device (SDD).

 

 Example Spectre Command Line:

f001r002 ( 1 2 ) ccvs probe=v002 gain=0.013357

 

 Spectre Netlist Syntax:

name p n ccvs [param= value ]*

 

 ADS CCVS (SDD):

SDD:f001r002 _node2 _node1 C[1]="v002" F[1,0]=(_v1)-(0.013357*_c1)

Note
The netlist syntax for ADS is valid only when using the backward-compatibility option (-bc option). The
order of nodes is reversed because Spectre components list the output node pair first, followed by the
input node pairs.
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 Linear Voltage-Controlled Current Source (vccs)
The Spectre vccs device is translated as an ADS VCCS device.

 

 Example Spectre Command Line:

v1 (1 0 2 3) vccs gm=-1 m=2

 

 Spectre Netlist Syntax:

name sink arc ps ns vccs __ [param= value ]*

 

 ADS Netlist Syntax:

VCCS: name node1 node2 node3 node4 [param= value ]*

Note
The netlist syntax for ADS is valid only when using the backward-compatibility option (-bc option). The
order of nodes is reversed because Spectre components list the output node pair first, followed by the
input node pairs.

 

 ADS Schematic Symbol:

 

 Instance Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist)

 Linear VCCS Parameter Mapping 

ADS Name Unit Default Spectre Name Unit Default

G Siemens 0.0 gm Siemens 0.0

Parameters not in Spectre Model    

R1 Ohms 0.0 (Infinity)    

R2 Ohms 0.0 (Infinity)    

F Hz 0.0 (Infinity)    

   Parameters not in ADS Model

   m  1
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 Linear Voltage-Controlled Voltage Source (vcvs)
The Spectre vcvs device is translated as an ADS VCVS device.

 

 Example Spectre Command Line:

e1 (out1 0 pos neg) vcvs gain=10

 

 Spectre Netlist Syntax:

name p n ps ns vcvs [param= value ]*

 

 ADS Netlist Syntax:

VCVS: name node1 node2 node3 node4 [param= value ]*

Note
The netlist syntax for ADS is valid only when using the backward-compatibility option (-bc option). The
order of nodes is reversed because Spectre components list the output node pair first, followed by the
input node pairs.

 

 ADS Schematic Symbol:

 

 Instance Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist)

  Linear VCVS Parameter Mapping

ADS Name Unit Default Spectre Name Unit Default

G V/V 0.0 gain V/V 0.0

Parameters not in Spectre Model    

R1 Ohms 0.0 (Infinity)    

R2 Ohms 0.0    

F Hz 0.0 (Infinity)    

   Parameters not in ADS Model

   m  1
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 Lxxxxxxx
 Inductor: This device is translated as an inductor.

 Example SPICE Command Line:

{{l1 1 2 1pH IC=15mA

 SPICE dialect and netlist syntax

Spice2/3:

l id n1 n2 value [ ic= icamp ]

PSpice:

l id n1 n2 value [ ic= icamp ]

HSpice:

l id n1 n2 [ l= value ] [[ tc1= ] tc1 [[ tc2= ] tc2 ]] [ scale= scale ]

 ADS Netlist Syntax:

L:l id n1 n2 L= value

 ADS Schematic Symbol:  

 Instance Parameters:

lid = Inductor element name
n1 = Positive node
n2 = Negative node
value = The inductance in Henries
ic = The initial (time-zero) value of inductor current (in Amps)
tc1 = First order temperature coefficient
tc2 = Second order temperature coefficient
scale = Element scale factor. Default=1.0.
mult = Multiplier used to simulate multiple parallel devices. Default=1.0
dtemp = Element and circuit temperature difference. Default=0.0
R = Resistance in ohms of the inductor element.
equation = The inductor value can be described as a function of any node voltages,
branch currents, and any independent variables such as TIME, frequency (HERTZ), or
temperature (TEMPER). The type of variable L depends upon is indicated by the parameter
"LTYPE". Most commonly L depends upon I(Lxxx), which is assumed with the default of
LTYPE=0 as explained below.
LTYPE = If inductance L is a function of I(Lxxx), set LTYPE to 0. Otherwise, set LTYPE to
1. The inductance flux is calculated differently depending on the value of LTYPE. LTYPE
must be set properly to provide correct simulation results. Defining L as a function of
multiple variables is not recommended. Default=0.
poly() = Polynomial function

 

 Comments:
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If SCALE is specified, Value=Value*scale

Unsupported Syntax and Parameters

PSpice:

PSpice Inductor model is supported by ADS but not translated yet.
lid n1 n2 [mname] value

HSpice:

Nonlinear inductor lid n1 n2 poly l0 l1 l2...
This is supported by ADS as a component called NonlinL.

The ADS Netlist Syntax should be:

NonlinL:lid n1 n2 coef=list(l0 l1 l2...) [ic=ic]
lid n1 n2 L=`equation' ltype=[0|1] [R=val]

This syntax requires a Symbolically Defined Device (SDD) in ADS if ltype=0. This is not
currently handled by the translator. Please contact customer support for assistance in
writing the SDD to represent the current through the inductor.
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 MOSFET Device
The Spectre MOSFET device is translated as either a nonlinear N-type or a nonlinear P-
type MOSFET device. For information on MOSFET models, refer to MOSFET Models
(netlist).

 Example Spectre Command Line:  

nch1 (1 2 0 0) nchmod1 l=2u w=15u ad=60p as=37.5p pd=23u ps=6u

 Spectre Netlist Syntax:  

name nd ng ns nb mname [param= value ]*

 ADS Netlist Syntax:  

mname :m id nd ng ns nb [param= value ]*

 

 ADS Schematic Symbol:

 Instance Parameters:  

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

 Level 1 MOSFET Parameter Mapping  
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ADS Name Unit Default Spectre Name Unit Default

Length m  l m  

Width m  w m  

Ad m2  ad m2  

As m2  as m2  

Pd m  pd m  

Ps m  ps m  

Nrd   nrd m/m  

Nrs   nrs m/m  

Region  on region  triode

_M  1 m  1

Parameters not in Spectre Model    

Temp † °C 25    

NMOS  yes    

PMOS  no    

Mode  1    

Noise  yes    

   Parameters not in ADS Model

   trise °C 0.0

   ld m  

   ls m  

   degradation  no

† Temp = trise + temp ("temp" is an ADS global variable)

 BSIM3v3 Parameter Mapping 

ADS Name Unit Default Spectre Name Unit Default

Length m  l m  

Width m  w m  

Ad m2  ad m2  

As m2  as m2  

Pd m  pd m  

Ps m  ps m  

Nrd   nrd m/m  

Nrs   nrs m/m  

Region  fwd region  triode

Nqsmod   nqsmod   

_M  1 m  1

Parameters not in Spectre Model    

Geo  1    

NMOS  yes    

PMOS  no    

Mode  1    

Noise  yes    

Temp † °C 25    

   Parameters not in ADS Model

   trise °C  

† Temp = trise + temp ("temp" is an ADS global variable)
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 BSIM4 Parameter Mapping

ADS Name Unit Default Spectre Name Unit Default

Length m  l m  

Width m  w m  

Nf  1.0 nf  1.0

Sa m 0.0 sa m 0.0

Sb m 0.0 sb m 0.0

Sd m 0.0 sd m 0.0

Min  0 min  0

Ad m2  ad m2  

As m2  as m2  

Pd m  pd m  

Ps m  ps m  

Nrd  1.0 nrd   

Nrs  1.0 nrs   

Rbdb   rbdb   

Rbsb   rbsb   

Rbpb   rbpb   

Rbpd   rbpd   

Trnqsmod   trnqsmod   

Acnqsmod   acnqsmod   

Rbodymod   rbodymod   

Rgatemod   rgatemod   

Geomod   geomod   

Rgeomod   rgeomod   

_M  1 m  1

Trise K 0 trise K  

 Model9 MOSFET Parameter Mapping 

ADS Name Unit Default Spectre Name Unit Default

Length m 1e−4 l m 1.0×scale

Width m 1e−4 w m 1.0×scale

Region  on region  triode

_M  1 m  1

Mult  1 mult  1

Mult  1 area  1

Parameters not in Spectre Model    

Model      

Temp † °C 25    

Ab m2 1e−12    

Ls m 1e−4    

Lg m 1e−4    

Mode  nonlinear    

 

   Parameters not in ADS Model

   mult  1

† Temp = trise + temp ("temp" is an ADS global variable)

 Comments:  

The Netlist Translator looks up the model statement referenced by the model name
on the instance line to determine which ADS MOSFET device to place. For more
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information on MOSFET Models, refer to MOSFET Models (netlist).

If trise is provided, Temp = trise + temp ( temp is an ADS global variable).
  



Netlist Translator for SPICE and Spectre

106

 Mutual Inductors
The Spectre mutual_inductor device is translated as an ADS mutual inductor.

 

 Example Spectre Command Line:

l1 (1 0) inductor

l2 (2 0) inductor

ml1 mutual_inductor coupling=1 ind1=l1 ind2=l2

 

 Spectre Netlist Syntax:

name mutual_inductor [param= value ]*

 

 ADS Netlist Syntax:

Mutual: kid K= value Inductor1=" lid1 " Inductor2=" lid2 "

 

 ADS Schematic Symbol:

 

 Instance Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist)

 Mutual Inductors Parameter Mapping 

ADS Name Unit Default Spectre Name Unit Default

K   coupling  0.0

Inductor1   ind1   

Inductor2   ind2   

Parameters not in Spectre Model    

M H     

 Comments:  

The ADS Schematic symbol for an individual inductor uses a slash on the wire near
pin 1 as opposed to the standard dot used in Spectre.

ADS Schematic Symbol: Note that the MUTIND on the left is the symbol placed when
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the K is read. The example on the right is an illustration of the referenced inductors.

ADS allows a coefficient of coupling between -1 and 1.
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 Mxxxxxxx
Semiconductor  MOSFET Device: This device is translated as either a nonlinear N-type or a
nonlinear P-type MOSFET device.

 Example SPICE Command Line:

m1 1 2 3 4 Mmodel L=10U W=5U AD=100P AS=100P PD=40U NRD=1 nrs=1

 SPICE dialect and netlist syntax:

Spice2/3:

m id nd ng ns nb mname [ l= l ] [ w= w ] [ ad= ad ] [ as= as ]
+ [pd=pd] [ps=ps] [nrd=nrd] [nrs=nrs] [off]
+ [ic=vds, vgs, vbs] [temp=temp]

PSpice:

m id nd ng ns nb mname [ l= l ] [ w= w ] [ ad= ad ] [ as= as ]
+ [pd=pd ] [ps=ps] [nrd=nrd] [nrs=nrs] [nrg=nrg]
+ [nrb=nrb] [m=mult]

HSpice:

m id nd ng ns nb mname [[ l= ] l ] [[ w= ] w ] [ ad= ad ] [ as= as ]
+ [pd=pd] [ps=ps] [nrd=nrd] [nrs=nrs] [*off_]
+ [rdc=rdc] [rsc=rsc] [ic=vds, vgs, vbs]
+ [m=mult] [dtemp=dtemp] [geo=geo] [nqsmod=nqsmod]

 ADS Netlist Syntax:

mname :m id nd ng ns nb [ Length= l ] [ Width= w ] [ Ad= ad ] [ As= as ] [
Pd= pd ] [ Ps= ps ]

 ADS Schematic Symbol:  

 Instance Parameters:

mid = MOSFET element name
mname = Model name
nd = Drain node
ng = Gate node
ns = Source node
nb = Bulk (substrate) node
l, w = Channel length and width in meters.
ad, as = Area of the drain and source diffusions, in square meters.
pd, ps = Perimeters of the drain and source junctions, in meters.
nrd, nrs = Designate the equivalent number of squares of the drain and source
diffusions; these values multiply the sheet resistance (RSH) specified on the
.MODEL control line for an accurate representation of the parasitic series drain
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and source resistance of each transistor.
off = Indicates an initial condition on the device for ac analysis.
Translates to Region=0.
temp = The temperature at which this device is to operate.
dtemp = Element and circuit temperature difference. Default=0.0
mult = Multiplier used to simulate multiple parallel devices.
geo = Source/drain sharing selector
nqsmod = Non-quasi static model selector

 

 Comments:

The Netlist Translator looks up the model statement referenced by the model name on the
instance line to determine which ADS MOSFET device to place. For more information on
MOSFET Models, refer to MOSFET Models (netlist).
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 Oxxxxxxx
 Lossy Transmission Lines: This device and model pair is translated as an ideal physical
transmission line.

 Example SPICE Command Line:  

o1 1 0 3 0 Omodel
.model Omodel LTRA L=9.19e-9 C=3.65e-12 LEN=1 R=0 G=0

 SPICE dialect and netlist syntax:  

Spice3:

o id n1 n2 n3 n4 mname

PSpice:

Does not exist

HSpice:

Does not exist

 ADS Netlist Syntax:  

TL:o id Z= sqrt(l/c) L= len V= 1/(c0*sqrt(l*c)) R= r G= g F= 0

 ADS Schematic Symbol:  

 

 Instance Parameters:

oid = TL element name
mname = Model name
n1, n2 = Nodes at port 1
n3, n4 = Nodes at port 2

 

 Comments:

Parameters are read from the LTRA model statement, but no corresponding model is
created in ADS. If no model is found, these defaults values are used:

Z=50Ohm L=1 V=1 R=0 G=0

For the schematic version, the TL component is not supported so the TLIN4 is used. TLIN4
does not support the R and G parameters so they are ignored. The following equations are
used for TLIN4:

Z=sqrt(l/c) F=1 E=len/sqrt(l*c)*360
c0 = speed of light in free space. This is an ADS mathematical constant.
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 Polynomial Current-Controlled Current Source
(pcccs)
The Spectre pcccs device is translated as an ADS Symbolically-Defined Device (SDD). Only
the single input pcccs device is supported by the Spectre netlist translator.

 

 Example Spectre Command Line:

evc_pcccs (1 2) pcccs gain=0.9 m=3 coeffs=[0 0 0 0 oppdvcr] probe=v002

 

 Spectre Netlist Syntax:

name p n pcccs [param= value ]*

 

 ADS PCCCS (SDD):

SDD:evc_pcccs _node2 _node1 I[1,0]=-1*eval_poly(list(0,0,0,0,oppdvcr),

_c1,0) _M=3 C[1]="v002"

Note
The netlist syntax for ADS is valid only when using the backward-compatibility option (-bc option). The
order of nodes is reversed because Spectre components list the output node pair first, followed by the
input node pairs.
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 Polynomial Current-Controlled Voltage Source
(pccvs)
The Spectre pccvs device is translated as an ADS Symbolically-Defined Device (SDD).
Only the single input pccvs device is supported by the Spectre netlist translator.

 

 Example Spectre Command Line:

evc_pccvs (1 2 ) pccvs gain=0.9 m=3 coeffs=[0 0 0 0 oppdvcr] probe=v002

 

 Spectre Netlist Syntax:

name p n pccvs [param= value ]*

 

 ADS PCCVS (SDD):

SDD:evc_pccvs _node2 _node1 I[1,0]=eval_poly(list(0,0,0,0,oppdvcr),

_c1,0) _M=3 C[1]="v002"

Note
The netlist syntax for ADS is valid only when using the backward-compatibility option (-bc option). The
order of nodes is reversed because Spectre components list the output node pair first, followed by the
input node pairs.

  



Netlist Translator for SPICE and Spectre

114

 Polynomial Voltage-Controlled Current Source
(pvccs)
The Spectre pvccs device is translated as an ADS NonlinVCCS device.

 

 Example Spectre Command Line:

v2 (net1 0 net2 0) pvccs coeffs=[0 -2e-3 -10e-3] gain=2 m=1

 

 Spectre Netlist Syntax:

name sink arc ps1 ns1 ... pvccs coeffs=[ ... ] [param= value ]*

 

 ADS Netlist Syntax:

VCCS_Z: name node1 node2 node3 node4 [param= value ]*

Note
The netlist syntax for ADS is valid only when using the backward-compatibility option (-bc option). The
order of nodes is reversed because Spectre components list the output node pair first, followed by the
input node pairs.

 

 ADS Schematic Symbol:

 

 Instance Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist)

 Non-Linear VCCS Parameter Mapping  

ADS Name Unit Default Spectre Name Unit Default

Coeff=[...\]]   coeffs=[...\]]   

   Parameters not in ADS Model

   gain  1

   m  1
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 Polynomial Voltage-Controlled Voltage Source
(pvcvs)
The Spectre pvcvs device is translated as an ADS NonlinVCVS device.

 

 Example Spectre Command Line:

v1 (p 0 c1 0) pvcvs coeffs=[0 0 0 0.1 1 1] gain=1

 

 Spectre Netlist Syntax:

name p n ps1 ns1 ... pvcvs coeffs=[ ... ] [param= value ]*

 

 ADS Netlist Syntax:

VCVS_Z: name node1 node2 node3 node4 [param= value ]*

Note
The netlist syntax for ADS is valid only when using the backward-compatibility option (-bc option). The
order of nodes is reversed because Spectre components list the output node pair first, followed by the
input node pairs.

 

 ADS Schematic Symbol:

 Instance Parameters:  

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

 Non-Linear VCVS Parameter Mapping  

ADS Name Unit Default Spectre Name Unit Default

Coeff=[...\]   coeffs=[...\]   

   Parameters not in ADS Model

   gain  1

   m  1
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 Qxxxxxxx
Semiconductor  BJT Device. This device is translated as one of the following:

a nonlinear NPN or PNP BJT device
a nonlinear NPN or PNP BJT device with substrate
a NPN or PNP VBIC (Vertical Bipolar Inter-Company) device

For information on the BJT model, refer to BJT_Model:Bipolar Transistor Model (netlist).
For information on the VBIC model, refer to VBIC_Model:VBIC Model (netlist).

Note
For HSpice, if the referenced model has Level=4, the appropriate VBIC device is placed.

 Example SPICE Command Line:

q1 1 2 3 Qmodel 2 OFF IC=0.6, 5.0}}

q2 1 2 3 4 Qmodel2 1.0

 SPICE dialect and netlist syntax:

Spice2/3:

qid nc nb ne [ns] mname[ area ] [OFF] [ IC= vbe, vce ] [ TEMP=temp ]

PSpice:

qid nc nb ne [ ns ] mname[area]

HSpice:

qid nc nb ne [ ns ] mname [[AREA=] area ] [ AREAB= area]
+ [AREAC=area] [OFF] [[IC=vbe, vce] | [VBC=vbc [VCE=vce]]]
+ [M=mult] [DTEMP=temp]

 ADS Netlist Syntax:

BJT[4] mname: qid nc nb ne [ns] [Area=area] [Temp=temp+dtemp]
+ [Region=0] [_M=mult]

VBIC mname : qid nc nb ne ns [scale=area]

 ADS Schematic Symbols:  
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 Instance Parameters:

qid = BJT element name
mname = Model name
nc = Collector node
nb = Base node
ne = Emitter node
ns = Substrate node
area = Area factor (default=1)
off = Indicates an initial condition on the device for dc analysis.
Translates to Region=0
mult = Multiplier used to simulate multiple parallel devices.
temp = The temperature at which this device is to operate.

 Comments:  

The referenced BJT_Model:Bipolar Transistor Model (netlist) or VBIC_Model:VBIC Model
(netlist) is read to determine which device to use:

NPN keyword indicates BJT_NPN, BJT4_NPN or VBIC_NPN
PNP keyword indicates BJT_PNP, BJT4_PNP or VBIC_PNP

If SCALE is specified, Value=Value*scale

If dtemp is provided, Temp=temp+dtemp
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 Resistor Device
The Spectre resistor device is translated as an ADS resistor device. For information on the
resistor model, refer to R_Model (Resistor Model) (ccsim).

 

 Example Spectre Command Line:

Without model referenced:
r1 (1 2) resistor r=1.2k m=2

With model referenced:
r1 (1 2) resmod l=8u w=1u

 

 Spectre Netlist Syntax:

Without model referenced:
name n1 n2 resistor [param= value ]*
With model referenced:
name n1 n2 mname [param= value ]*

 ADS Netlist Syntax:  

R: rid n1 n2 R= value [param= value ]*

 ADS Schematic Symbol:  

 Instance Parameters:  

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist)

 Resistor Parameter Mapping  
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ADS Name Unit Default Spectre Name Unit Default

R ohms 50 r ihms  

TC1 1/°C 0.0 tc1 1/°C 0.0

TC2 1/°C2 0.0 tc2 1/°C2 0.0

Noise  yes isnoisy  yes

Length m  l m  

Width m  w m  

_M  1 m  1

Parameters not in Spectre Model    

Temp † °C 25    

Tnom °C 25    

wPmax W infinity    

wImax A infinity    

Model      

Secured      

   Parameters not in ADS Model

   trise °C 0.0

   resform  yes

   scale  1

†  Temp = trise + temp ("temp" is an ADS global variable)

 

 Comments:

The value of R may be positive or negative but not zero in the netlist.
The value of R cannot be an expression that changes during the simulation.
If SCALE is specified, Value = Value * scale .
If trise is provided, Temp = trise + temp ( temp is an ADS global variable).
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 Rxxxxxxx
 Resistor: This device is translated as a resistor device. For information on the resistor
model, refer to R_Model:Resistor Model (netlist).

 Example SPICE Command Line:

r1 1 2 1k

 SPICE dialect and netlist syntax:

Spice2/3:

rid n1 n2 [value] [mname] [l=l ] [w=w ] [ temp=temp ]

PSpice:

rid n1 n2 [ mname ] value [ tc= tc1 [, tc2 ]]

HSpice:

rid n1 n2 [mname] [r=]value [[tc1=]tc1 [[tc2=]tc2]]
+ [scale=s] [m=mult] [ac=ac] [dtemp=dtemp] [l=l] [w=w] [c=c]

 ADS Netlist Syntax:

R:rid n1 n2 R=value [TC1=tc1] [TC2=tc2 ] [_M=mult]

 ADS Schematic Symbol:  

 Instance Parameters:

rid = Resistor element name
mname = Model name. Use this name in elements to reference the model.
n1, n2 = Element nodes
value = Resistance value (in ohms). Reff=R*SCALE/M.
tc1 = First order temperature coefficient for resistor.
tc2 = Second order temperature coefficient for resistor.
scale = Element scale factor for resistance and capacitance. Default=1.0.
mult = Multiplier that simulates parallel resistors. For example, to represent two
*parallel instances of a resistor, set M=2 to multiply the number of resistors by
2. Default=1.0.
dtemp = Temperature difference between the element and the circuit.
Default=0.0
l = Resistor length. Default=0.0, if L is not specified in the model.
w = Resistor width. Default=0.0, if W is not specified in the model.
SHRINK is a model parameter.
Wscaled=W*SHRINK*SCALE(option)
dw = Width narrowing due to etching in specified units.
dl = Length narrowing due to etching in specified units.

 Comments:  

If SCALE is specified, Value=Value*scale.

In the netlist, as in ADS, the value of R may be positive or negative but not zero.
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HSpice:
If the value of R is an expression which is a function of node voltages or independent
variables, then the component is a dependent resistor. In ADS, the component is
represented by a Symbolically Defined Device (SDD).

If one of the SDD parameters uses a variable containing node voltages, the translator
needs to look up the node voltages on the resultant SDD to convert them to the correct
ADS syntax and update the variable expression. For instance, the node voltage described
as v(nodeX) in HSpice must be converted to _v1, if the first pair of nodes on the SDD is
(node1, 0).

For translation purposes of this special case, the SDD and the variable used by it are
expected to be defined in the same subcircuit, with the variable being used by only one
SDD. If the variable were defined globally or used by different SDDs, the node voltage
variables (_v1, etc.) might not match up correctly. For example, in the case described
above one SDD might have (nodeX,0) as the first pair of nodes (_v1), while another SDD
might have (nodeX,0) as the 2nd pair of nodes (_v2). The translator would not be able to
replace v(nodeX) in the variable expression to define both SDDs correctly at the same
time.

If this SDD is not found in the same subcircuit as the variable expression, a warning
message will be written to the log file nettrans.log. Also, the expression will not be
converted automatically, and it will have to be fixed manually before simulation is
attempted.

If dtemp is provided, Temp=temp+dtemp

The Netlist Translator fails to recognize the resistor model in the following syntax:

r1 1 2 rmodel

The translator assumes that it is a variable name for the resistor value. To correct your
imported schematic, manually move the model name to the parameter Model. To correct
the ADS Netlist, use the following netlist syntax:

rmodel:r1 1 2 [param=value]*
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 Subcircuit Reference 
 This device is translated as an instance of a subnetwork. For information on the
parametric subnetwork command, refer to subckt, ends (netlist).

 

 Example Spectre Netlist:

inline subckt indline \(in out gnd\)

parameters

\+ hoverw=pmsxt/pw}}

\+ fhwl=1/\(\(1/hoverw\)\+2.42-\(0.44\*hoverw\)\+1-hoverw\)\*\*6\)

\+ fhwg = d1==\(2\*pi\(\)\)\*log\(\(8\*hoverw\)\+\(0.25/hoverw\)\)

\+ fhw = \(hoverw==1\)\*fhwl\+\(hoverw>=1\)\*fhwg

rsxout subout gnd resistor r=prsx\*2 tc1=trsub trise=dtemp

ends indline

 

 ADS Netlist Syntax:

SUBNAME:x id [n1*] [ name =value*] [ M= _mult ]

xid = Subnetwork element name

n1* = Node names

subname = Specifies the name of the subnetwork.

name = Parameter name or subcircuit definition.

value = A parameter value passed to the subnetwork.

mult = Multiplier used to simulate multiple parallel devices.

 

 Comments:

The ADS netlist format does not support subcircuits containing parameters that reference
each other. In ADS 2005A, these are supported in Spectre syntax. Thus wrappers will be
added as shown in Example Spectre Subcircuit with Referenced Parameter Value. (netlist)
With the -bc option (i.e. backward compatibility mode), any Spectre subcircuit equations
that reference each other are moved from the subcircuit parameter list and are listed as
subcircuit equations. In addition, a warning message will be generated as follows:

The subcircuit "ckt_name" contained parameters that reference each

other. In order to maintain compatibility with ADS, these have been

moved off the subcircuit parameters list and are treated as circuit

equations.Component instances that reference this subcircuit will not

be able to directly override these values.

 

 Device Tables for SPICE

This section provides individual device translation information for each specific  device
supported by the Netlist Translator. Supported devices are listed here.
Bxxxxxxx (netlist)

Cxxxxxxx (netlist)

Dxxxxxxx (netlist)

Exxxxxxx (netlist)
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Fxxxxxxx (netlist)

Gxxxxxxx (netlist)

Hxxxxxxx (netlist)

Ixxxxxxx (netlist)

Jxxxxxxx (netlist)

Kxxxxxxx (netlist)

Lxxxxxxx (netlist)

Mxxxxxxx (netlist)

Oxxxxxxx (netlist)

Qxxxxxxx (netlist)

Rxxxxxxx (netlist)

Txxxxxxx (netlist)

Uxxxxxxx (netlist)

Vxxxxxxx (netlist)

Xxxxxxxx (netlist)

Zxxxxxxx (netlist)

For information on unsupported devices, refer to Unsupported Devices (netlist).



Netlist Translator for SPICE and Spectre

124

 Sxxxxxxx
Voltage-controlled Switch. This device is translated as an ADS sub-circuit named
spice_vswitch.

 Example SPICE Command Line:

s1 nv1 nv2 nc1 nc2 switchmodel

.model switchmodel VSWITCH [ROFF=1MEG] [RON=1] [VOFF=0V] [VON=1V]

 SPICE Dialect and Netlist Syntax

Spice2/3:

Sid n1 n2 n3 n4 modelName

.model modelName VSWITCH [param= value]

PSpice:

Sid n1 n2 n3 n4 modelName

.model modelName VSWITCH [param= value]

 ADS Netlist Syntax:

spice_vswitch:Sid n1 n2 n3 n4 [param= value]

 ADS Schematic Symbol:

 Comments:

To use the translated component, you must specify the include file
$HPEESOF_DIR/links/spice/spicefunctions.net where $HPEESOF_DIR points to your ADS
installation directory.
This can be done by either of the two methods (refer Advanced Methods for Importing
Files):

Refer the file spicefunctions.net using the ADS NetlistInclude component.1.
Include the line #include "<path>/spicefunctions.net" at the top of the translated2.
netlist, where <path> is the absolute path of the file spicefunctions.net. The
component will fail to simulate, if #include is not added.

  

file:/display/ads2009U1/Advanced+Methods+for+Importing+Files
file:/display/ads2009U1/Advanced+Methods+for+Importing+Files
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 Txxxxxxx
 Transmission Lines (Lossless): This device is translated as an ideal 4-terminal
transmission line.

 Example SPICE Command Line:

t1 1 0 2 0 z0=50 TD=10ns IC=1mv, 1ma, .2mv, .6ma

t2 1 0 2 0 z0=50 F=1.7GHz NL=0.3

t3 1 0 2 0 z0=50 F=1.2GHz

 SPICE dialect and netlist syntax:

Spice2/3:

tid n1 n2 n3 n4 Z0=zval[[TD=tval ] | [F=fval[ NL=nval]]]
+ [IC=v1, i1, v2, i2]

PSpice:

tid n1 n2 n3 n4 [ model ] Z0=zval[[ TD=tval ] | [F=fval[ NL= nval ]]]
+ [IC=v1, i1, v2, i2]

HSpice:

tid n1 n2 n3 n4 [ model ] Z0=zval [[ TD=tval [L= l ]] |
+ [F=fval [NL=nval]]] [IC=v1, i1, v2, i2]

 ADS Netlist Syntax:

If TD is given:

TLIN4: tid n1 n2 n3 n4 Z=zval F=1 E=tval*360

If F is given:

TLIN4: tid n1 n2 n3 n4 Z=zval F=fval E=nval*360

 ADS Schematic Symbol:  

 Instance Parameters:

tid = TL element name
n1, n2 = Nodes at port 1
n3, n4 = Nodes at port 2
zval = Characteristic impedance
tval, fval = Length of line may be expressed in either of two forms. The
transmission delay (TD) may be specified directly or frequency (F) may be given
together with NL.
nval = Normalized electrical length of the transmission line with respect to the
wavelength in the line frequency. If F is specified but NL is omitted, 0.25 is
assumed.
v1, i1, v2, i2 = The voltage and current at each of the transmission line ports.
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Ignored translation.

 

 Comments:

PSpice:

Optional lossy format: n1 n2 n3 n4 LEN=len R=r L=l G=g C=c

R and G are not supported for the schematic version. For the netlist version, the
alternate component TL will be used so these values are handled properly.

ADS Netlist Syntax:

TL:tid n1 n2 n3 n4 Z=sqrt(l/c) L=len V=1/(c0*sqrt(l*c)) R=r G=g F=0

If a model reference is used, the model is read and parameters are used on the
device as needed. No model is placed and unused parameters are discarded.

HSpice:

Optional syntax: tid n1 n2 n3 n4 Z=zval l=len

translates as: TLIN4:tid n1 n2 n3 n4 z=zval F=1 E=(len/c0)*360

c0 = speed of light in free space. This is an ADS mathematical constant.
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 Uxxxxxxx
 Uniform Distributed RC Lines (Lossy): This device is translated as two ideal transformers
and one ideal distributed RC line.

 Example SPICE Command Line:

u1 1 2 3 URCmodel L=50u N=6

.model URCmodel URC RPERL=rperl CPERL=cperl

 SPICE dialect and netlist syntax:

Spice2/3:

uid nin nout nref mname L=len N=lumps

PSpice:

Does not exist

HSpice:

Not supported

 ADS Netlist Syntax:

RCLIN:uid nin nout L=len R=rperl C=cperl

OR If node 3 is not ground:

tf:tf1 nin nref net1 0
RCLIN:uid net1 net2 L=len R=rperl C=cperl
tf:tf2 net2 0 nout nref

 ADS Schematic Symbol:  

 Instance Parameters:

uid = Element name
nin, nout = The two element nodes the RC line connects
nref = Node to which the capacitance is connected.
net1, net2 = Nodes inserted to connect RCLIN to transformers.
L = Length of the RC line in meters.
lumps = The number of lumped segments to use in modeling the RC line.
rperl = Resistance per unit length in Ohm/m (default=1000).
cperl = Capacitance per unit length in F/m (default=1.0e-15).
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 Comments:

N is ignored in translation.

Model parameters are read off the URC model, but no model is placed. Unused parameters
are discarded. If the referenced model is not found, the default values specified above are
used.

If node 3 is not ground, the transformers are added to float the RCLIN.
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 Vxxxxxxx
 Independent Voltage Source: This device is translated as either a V_Source (ADS Netlist)
or a VtUserDef (ADS Schematic).

 Example SPICE Command Line:

v1 1 2 DC 6

v2 2 3 6 AC 1 90

v3 3 0 PULSE(-1 1 2NS 2NS 2NS 50NS 100NS)

v4 3 0 SIN(0 1 100MEG 1NS 1E10)

v5 3 0 EXP(-4 -1 2NS 30NS 60NS 40NS)

v6 7 5 PWL(0 -7 10NS -7 11NS -3 17NS -3 18NS -7 50NS -7)

v7 12 0 SFFM(0 1M 20K 5 1K)

Spice2/3:

vid n+ n- [[ dc ]dcval] [ac [mag [phase]]] [tranfunc]

PSpice:

vid n+ n- [[dc] dcval] [ac [mag [phase ]]] [tranfunc]

HSpice:

vid n+ n- [[dc] dcval ] [ ac [mag [ phase ]]] [tranfunc]

 ADS Netlist Syntax:

V_Source:v id n+ n- Vdc=dcval Vac=polar(mag,phase) V_Tran=tranfunc

 ADS Schematic Symbol:

 

 Instance Parameters:

vid = Element name. Note that leading bold letter is included in the device name.
n+ = Positive node
n- = Negative node
dcval = The dc voltage
mag, phase = The magnitude and phase of the ac voltage.
tranfunc = Transient Source Functions. There are several built in ADS functions that
mimic the SPICE transient source functions listed below.

SPICE Advanced Design System

EXP() exp_pulse(time, low, high, tdelay1, tau1, tdelay2, tau2)
PULSE()pulse(time, low, high, delay, rise, fall, width, period)
PWL()pwl(time, t1, x1,..., tn, xn)
SFFM()sffm(time, offset, amplitude, carrier_freq, mod_index, signal_freq)
SIN()damped_sin(time, offset, amplitude, freq, delay, damping)
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HSpice

PU()pulse(time, low, high, delay, rise, fall, width, period)
AM()Not translated.
PL()Not translated.

 

 Comments:

HSpice:

HSpice multiplier on Voltage sources - This is implemented by making an
expression out of the given voltage value. Example:

HSpice: v1 n1 n2 500uv m=10
ADS: eqn0=(500uv)*(10)
V_Source: v1 n1 n2 Vdc=500uv*10

Unsupported HSpice transient functions - AM, PL

Unsupported HSpice syntax extensions -

Data driven PWL source
Repeat and Time Delay specifications in PWL transient function (R=repeat,
TD=delay)

PSpice:

Unsupported PSpice syntax extensions

STIMULUS

corner points, TIME_SCALE_FACTOR, VALUE_SCALE_FACTOR
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 Xxxxxxxx
 Subcircuit Reference: This device is translated as an instance of a subnetwork. For
information on the parametric subnetwork command, refer to ".SUBCKT"].

 Example SPICE Command Line:

x1 2 4 17 31 opamp

 SPICE dialect and netlist syntax:

Spice2/3:

xid [n1*] subname

PSpice:

xid [n1*] subname[ OPTIONAL: interface node = default value ]
+ [PARAMS: name=value*] [TEXT: name=textvalue]

HSpice:

xid [n1*] subname [ name=value * ] [m=mult]

 ADS Netlist Syntax:

SUBNAME:xid [n1*] [name=value*] [ _M=mult]

 Instance Parameters:

xid = Subnetwork element name
n1* = Node names
subname = Specifies the name of the subnetwork.
name = Parameter name or subcircuit definition.
value = A parameter value passed to the subnetwork.
mult = Multiplier used to simulate multiple parallel devices.

 

 Comments:

PSpice:

OPTIONAL and TEXT parameters are ignored by the translator.
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 Zxxxxxxx
Semiconductor  MESFET Device: This device is translated as a nonlinear N-type GaAsFET
device. For information on the GaAsFET model, refer to Statz_Model:Statz (Raytheon)
GaAsFET Model (netlist).

 Example SPICE Command Line:

z1 1 2 3 Zmodel 2 OFF IC=0.6, 5.0

 SPICE dialect and netlist syntax:

Spice2/3:

zid nd ng ns mname [ area ] [ OFF ] [ IC=vds, vgs]

PSpice:

Does not exist.

HSpice:

Does not exist.

 ADS Netlist Syntax:

mname : zid nd ng nd Area=area Region=0

 ADS Schematic Symbol:  

 Instance Parameters:

zid = GaAsFET element name
mname = Model name
nd = Drain node
ng = Gate node
ns = Source node
area = Area factor
OFF = Indicates an initial condition on the device for dc analysis. Translates to Region=0.
ic=vds, vgs = The initial condition specification intended for use with the UIC option on
the .TRAN control line. Not translated.

  

 Unsupported Devices

The following devices are not supported:

Axxxxxxx
Nxxxxxxx
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Pxxxxxxx
Sxxxxxxx
Wxxxxxxx
Yxxxxxxx

The following additional information provides a suggested action for your translation, each
of which requires using a Symbolically Defined Device (SDD). For information on SDD's,
refer to Using a Symbolically Defined Device.

 

 Non-Linear Dependent Source (SPICE 3 only):

Bxxxxxxx N+ N- I=expression V=expression

Suggested Action

Insert an SDD to replace the unmapped element. Assign the appropriate wire
labels to the SDD so you can maintain connectivity of the circuit. Insert the
equation I=expression or V=expression into the correct current or voltage port
definition.

 

 Voltage Controlled Switch (SPICE 3 only):

Sxxxxxxx N+ N- NC+ NC- mname [ON] [OFF]

Suggested Action

Insert an SDD to replace the unmapped element. Assign the appropriate wire
labels to the SDD so you can maintain connectivity of the circuit.

 

 Current Controlled Switch (SPICE 3 only):

Wxxxxxxx N+ N- VNAM mname [ON] [OFF]

Suggested Action

Insert an SDD to replace the unmapped element. Assign the appropriate wire
labels to the SDD so you can maintain connectivity of the circuit.

 

 Using a Symbolically Defined Device

The  symbolically-defined device (SDD) enables you to create equation based, user-
defined, nonlinear components in ADS. The SDD is a multi-port device which is defined by
specifying algebraic relationships that relate the port voltages, currents, and their
derivatives, plus currents from certain other devices.

Controlled sources from SPICE are modeled in ADS using the symbolically-defined device.
The SDD allows a voltage or current source to be constructed whose output can be
described as an arbitrary combination of a number of controlling voltages or currents.

; e voltage controlled voltage source

SDD:name nc1p nc1n nc2p nc2n outp outn \

I\[1,0\]=0 I\[2,0\]=0 F\[3,0\]=_v3-\(output_voltage\(_v1, _v2\)\)
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; g voltage controlled current source

SDD:name nc1p nc1n nc2p nc2n outp outn \

I\[1,0\]=0 I\[2,0\]=0 I\[3,0\]=\(output_current\(_v1, _v2\)\)

; h current controlled voltage source

SDD:name outp outn C\[1\]=current1 C\[2\]=current2 \

F\[1,0\]=_v1-\(output_voltage\(_c1, _c2\)\)

; f current controlled current source

SDD:name outp outn C\[1\]=current1 C\[2\]=current2 \

I\[1,0\]=\(output_current\(_c1, _c2\)\)

The voltage controlled sources have 2(n+1) nodes, where n is the number of controls. The
controlling voltage nodes are listed first in pairs (nc1p nc1n) at ports 1 through n, then
the output node pair (outp outn) at port n+1. The controlling voltages have symbolic
names like _v1. Each controlling voltage must have a current equation written for it
(I[1,0]=0) so that no current flows between the controlling nodes through the SDD.

The current controlled sources have only 2 output nodes at port 1, while the name of the
sources used to measure the controlling currents are specified using C[1]="ivs1". The
controlling currents have symbolic names like _c1.

Current sources are written as a simple expression for the current at the output port. This
expression is in SI units and is written in terms of the controls:

I[3,0]=_v1*1e-3+_v2*2e-3

A voltage source must have an implicit expression for the voltage at the output port such
that F[3,0]=_v3-vout, where vout is the desired output voltage:

F[3,0]=_v3-(_v1*2+_v1*v2)

Controlled sources in SPICE may be linear or nonlinear and there may be one or more
controlling voltages or currents. The general form of a controlled source is:

?id node1 node2 [poly(dim)] [sourcename | nodecp nodecn]*
+ value [value]*

The source has two nodes with the same polarity convention as the dependent sources.
The method of specifying controls depends on whether the source is voltage controlled or
current controlled. Current-controlled sources give the name of a source through which
the current is measured; voltage-controlled sources provide two nodes with which to
measure a differential voltage. The simple linear form for all four types:

eid n+ n- nc+ nc- value ; vout = value * vcon
fid n+ n- vname value ; iout = value * icon
gid n+ n- nc+ nc- value ; iout = value * vcon
hid n+ n- vname value ; vout = value * icon

A nonlinear source may be created whose output is a polynomial function of its control:

eid n+ n- nc+ nc- v0 v1 v2 v3 ... [ic=]

The polynomial is interpreted as:

vout =v0+v1* vcon +v2* v2
con +...

unless only a single value is given, in which case it reverts to a linear behavior:

vout =v0* vcon

SPICE allows controlled sources with more than one control. When there is more than one
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control. the poly keyword must be used to identify the number of controls. The dimension
refers to the number of controlling sources, not the order of the polynomial.

eid n+ n- poly(dim) [ nc+ nc- ]* values ... [ic=]

Coefficients for a polynomial of dimension two are interpreted as:
vout =v0

+v1*vcon1+v2*vcon2

+v3*v2
con1+v4*vcon1*vcon2+v5*v2

con2

+v6*v_3
con1+v7*v2

con1*vcon2+v8*vcon1*v
2
con2+v9*v3

con2
+...

Coefficients for a polynomial of dimension three are interpreted as:
vout=v0

+v1*vcon1+v2*vcon2+v3*vcon3

+v4*v2
con1+v5*vcon1*vcon2+v6*vcon1*vcon3+v7*v2

con2+v8*vcon2*vcon3+v9*v2
con3

+v10*v3
con1+v11*v2

con1*vcon2+v12*v2
con1*vcon3+v13*vcon1*v2

con2+v14*vcon1*vcon2*v

con3

+v15*vcon1*v2
con3+v16*v3

con2+v17*v2
con2*vcon3+v18*vcon2*v2

con3+v19*v3
con3*

+v20*v4
con1+...

The SPICE syntax provides no simple way to specify just a couple of the individual terms.
If only the v14 term is needed, v0 through v13 must still be specified with zeros.

Initial conditions here are used to provide a guess at what the controlling values will be so
the output of the dependent source can be evaluated; the initial values do not actually
influence the controlling values. Enough initial conditions must be provided to match the
dimensionality of the source.

Several translation examples for SPICE are presented below.

 

 Example1

SPICE Netlist:

* linear vcvs

e01 vout 0 vc1p vc1n 0.05

ADS Netlist:

SDD:e01 vc1p vc1n vout 0 I[1,0]=0 F[2,0]=_v2-(0.05*_v1)

 Example 2

SPICE Netlist:

* linear cccs

f01 vout 0 vname 0.05
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ADS Netlist:

SDD:f01 vout 0 C[1]=vname I[1,0]=0.05*_c1

 Example 3

SPICE Netlist:

* linear vccs

g01 vout 0 vc1p vc1n 0.05

ADS Netlist:

SDD:g01 vc1p vc1n vout 0 I[1,0]=0 I[2,0]=0.05*_v1

 Example 4

SPICE Netlist:

* linear ccvs

h01 vout 0 vname 0.05

ADS Netlist:

SDD:h01 vout 0 C[1]=vname I[1,0]=0 F[1,0]=_v1-(0.05*_c1)

 Example 5

SPICE Netlist:

* one input polynomial vcvs

* vout=0.5+0.1*vc1+0.01*vc1^2+0.001*vc1^3

e02 vout 0 nc1p nc1n 0.5 0.1 0.01 0.001

ADS Netlist:

SDD:e02 nc1p nc1n vout 0 I[1,0]=0 \

F[2,0]=_v2-(0.5+0.1*_v1+0.01*_v1^2+0.001*_v1^3)

 Example 6

SPICE Netlist:

* two input polynomial cccs

* iout=0.0+0.2*i1+0.3*i2+0.01*i1^2+0.02*i1*i2+0.03*i2^2

f02 vout 0 poly(2) vname1 vname2 0.0 0.2 0.3 0.01 0.02 0.03

ADS Netlist:



Netlist Translator for SPICE and Spectre

137

SDD:f02 vout 0 C[1]=vname1 C[2]=vname2 \

I[1,0]=0.0+0.2*_c1+0.3*_c2+0.01*_c1^2+0.02*_c1*_c2+0.03*_c2^2

 Example 7

SPICE Netlist:

* three input polynomial vccs

* iout=0.1*vc1+0.2*vc2+0.3*vc3

g02 vout 0 poly(3) vc1p vc1n vc2p vc2n vc3p vc3n

+ 0 0.1 0.2 0.3

ADS Netlist:

SDD:g02 vc1p vc1n vc2p vc2n vc3p vc3n vout 0 \

I[1,0]=0 I[2,0]=0 I[3,0]=0 \

F[4,0]=_v4-(0+0.1*_v1+0.2*_v2+0.3*_v3)

For more information, refer to Custom Modeling with Symbolically-Defined Devices
(modbuild).
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 Troubleshooting Netlist Translator for
SPICE and Spectre  
This section provides information on possible  translation failures from the Netlist
Translator and how to resolve issues that arise.

When an error occurs during a translation, an error message is written to the  nettrans.log
file. Sometimes, when potential problems are found or the translator makes a change that
the user needs to be informed of, warning messages are also written to the nettrans.log
file.

 Debugging Imported Designs  

Since no two design environments or simulators are alike, there may be problems that
arise in the translation. Here are few tips for debugging the translation.

Read the log files. The log files are ASCII text files that contain valuable translation1.
information.

The nettrans.log file will always be present unless the translation completely
failed. Running in a read-only directory might cause this problem. This file will
list any components that could not be translated. Unrecognized syntax or
incompatible models are the most likely causes of this problem.
The ifftolib.log file will be present if a schematic output was requested. This file
lists problems encountered during creation of the schematic. For a summary of
the import process, refer to Understanding the Import Operation (netlist).

Choose the netlist output option. Since the netlist to netlist translation gives you an2.
output file that is human-readable, it is very easy to compare line by line with the
source netlist. Even if you desire a schematic eventually, this method can be used to
debug the translation. For information on netlist comparison, refer to Comparing the
Netlist (netlist).
Output the netlist from ADS. First open the command line window from the ADS Main3.
window.

Choose Options > Command Line.

Enter the command  de_netlist();

This will create a file called  netlist.log in the workspace directory. This is the
information that goes to the simulator.
If you are using a NetlistInclude component, the #include statement will be visible.
To flatten that and show the actual contents of the file, find the  NetlistInclude
component in the schematic and set its last parameter NetlistDebugMode=0.
Regenerate the netlist from the ADS command line.
The translator can be run manually from the command line using the nettrans4.
command. For detailed instructions on using the nettrans command, refer to
Importing a File from the Command Line (netlist).
When debugging a very large file, the best thing to do is to break the file down into5.
smaller pieces. Subcircuits and include files can be imported one at a time; however,
you should import the lowest level of hierarchy first so the referenced design is
created before it is used.
If the imported design appears to be syntactically correct and contains the correct
data, but simulation results are not as expected, contact Agilent-EEsof-EDA customer
support for the latest information on model compatibility.

  

 Error Messages  
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Invalid subckt line < number >, < line text >.

The translator has encountered a subckt line with unrecognized syntax. Correct the
problem and rerun the translator.

Failed opening netlist file < name >.

The file specified by < name > was not found, or could not be opened. Verify that the file
exists, and then check file and directory permissions.

Failed opening output file < name >.

The file specified by < name > could not be opened for write. Check file and directory
permissions. Make sure you are not running ADS from a read-only directory.

Failed opening logfile nettrans.log.

The file nettrans.log could not be opened. Verify that the file exists, and then check file
and directory permissions.

Fatal error in position ports ( ). OR
Node < name > missing from memory.

These are errors internal to the translator. Have your system administrator contact Agilent
Technologies technical support at eesof_support@agilent.com . In Canada and the United
States, you can also call 1-800-473-3763. Elsewhere, contact your local Agilent
Technologies sales office.

Recursive subckt reference found in network < name >.

A reference to subcircuit < name > was found in the subcircuit definition of the same
name. A subcircuit cannot be placed within itself.

Failed memory allocation.

Not enough memory to complete the translation; the file is very large, or has many
subcircuits. Separate the file into several smaller files and translate them individually. If
needed, run the translation on a different machine

Found unmatched end of subckt at line <linenum>

An ends command was found but no subckt line corresponds to it. Correct the file and re-
run the translation.

Invalid equation <eqn>

The translator failed parsing the equation while checking for reserved words or invalid
characters. A complex equation may need to be broken down into simpler equations that
reference each other if no obvious errors are visible.

 Warning Messages 

ADS Netlist Translator could not find a definition for < instance name >. A valid
definition for < instance name > is required.

This warning is issued when the model/sub-circuit definition is not found. It might be that
the definition is in the included file (if any).

Item mapping file < name > not found.
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The item mapping file specified by < name > was not found, or could not be opened.
Verify that the file exists, and then check the file and directory permissions.

Failed attempting to convert node voltage syntax for < varname >.
Variable reference not found.

For information on this warning message, refer to the comments under Capacitor Device
(netlist) or Resistor Device (netlist).

Failed opening include or library file < name >, line < number >.

The file specified by < name > was not found, or could not be opened. Verify that the file
exists, and then check the file and directory permissions.

Failed processing line < number >, < text >.

Encountered syntax that cannot be translated. For more information on device, model and
Command Line syntax, refer to Translating a Device (netlist), Translating a Model (netlist)
and Translating Commands and Functions (netlist).

Skipping unsupported capacitor syntax PWL, line < number >.

Optional PWL syntax # capacitor was encountered and cannot be translated. See capacitor
description Capacitor Device (netlist).

Skipping unsupported inductor syntax PWL, line < number >.

Optional PWL syntax for inductor was encountered and cannot be translated. See inductor
description Inductor Device (netlist).

Skipping unsupported source syntax < name >, line < number >.

Encountered source syntax that cannot be translated. See source descriptions Polynomial
Voltage-Controlled Current Source (pvccs) (netlist), and Linear Voltage-Controlled Voltage
Source (vcvs) (netlist).

Skipping unsupported < name > syntax, line < number >.

Encountered syntax for item < name > that cannot be translated. For more information
on device, model and Command Line syntax, refer to Translating a Device (netlist),
Translating a Model (netlist) and Translating Commands and Functions (netlist).

Skipping unsupported 4-port JFET device < name >, line < number >.

Specified JFET is not available in ADS. See JFET description JFET Device (netlist).

Skipping unsupported model type < name >, line < number >.

Specified model is not available in ADS. See model descriptions Translating a Model
(netlist).

Skipping unsupported statement < name >, line < number >.

Spectre < name > statement is unrecognized or unsupported. See control line
descriptions Translating Commands and Functions (netlist).

Skipping unrecognized element type: line < number >, < name >.

Element type is not one of supported elements for the selected Spectre type. For
information on supported devices, refer to Translating a Device (netlist).
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Skipping unsupported element < name >.

Encountered element < name > that cannot be translated. For information on supported
devices, refer to Translating a Device (netlist).

Invalid level < name > - skipping model < name >, line < number >.

Encountered unexpected level value for model < name >. See model descriptions in the
Translating a Model (netlist).

Invalid library syntax - missing library name, line < number >.

See library syntax in the control lines section of library (netlist).

Model < mname > for device < name > in circuit < circuitname > not found.

Model referenced by device < name > is not found in the netlist. Check the names. Make
sure the model is present globally or in the specified circuit. The model may exist or be
added later in ADS but the translator will still generate a warning. If a model is not
present in the file, the translator may not have enough information to place the proper
device (ex: NPN vs. PNP). You may need to correct the schematic or netlist before
simulating.

Referenced circuit < name > not found.

A circuit was used that has not been defined. Make sure the circuit is defined in the file or
ADS.

Schematic not created for subcircuit <name> with no translated components.
A design will not be created if there is nothing to put in it. Look for a message regarding
untranslated components.

Appended <?>_ to <item> due to a conflict with a reserved word.

A partial list of Advanced Design System reserved words is listed in Partial Listing of ADS
Reserved Words (connectmui). The full list is much longer. If the translator finds a node,
element or variable name that is the same as a reserved word, the name is appended with
an _n, _e or _v respectively.

 Partial Listing of ADS Reserved Words

abs db e ln mag nf value

c0 deg exp ln10 max step y

cos delay i log min v z

For more information on ADS reserved words, refer to Reserved Names and Name Spaces
(cktsim).

Caution
The subcircuit "ckt_name" contained parameters that reference each other. In order to maintain
compatibility with ADS, these have been moved off the subcircuit parameters list and are treated as circuit
equations. Component instances that reference this subcircuit will not be able to directly override these
values.

The subcircuit ckt_name contains parameters that reference each other. The ADS netlist
format does not support this syntax. Any subcircuit equations that reference each other
are moved from the subcircuit parameter list and they are listed as subcircuit equations.
Component instances that reference this subcircuit will no be able to directly override
these values.
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 Known Problems

Problem ADS simulation results do not match my original simulation.
Model differences exist between all simulators due to different default parameters and
different equations. ADS models are usually implemented exactly as specified in the
Berkeley model. Differences that occur between ADS and other simulators are beyond our
control since the equations for these simulators are not published.

Problem I have a very large netlist with a number of included files.
If your set of files seems too large to be handled in one translation, the included files can
be imported first. Design files will be created for all subcircuits. Close all designs before
doing the next import. If a referenced design has already been imported, you can ignore
the warnings from the translator and ADS that say the referenced design cannot be found.

Problem Symbol and pin topology on subcircuits is hard-coded for schematic imports.

If a file contains references to a custom subcircuit, the pins will not be connected properly
if the symbol is not the standard nport symbol supplied in the design environment. This is
only a problem for importing to a schematic (wired or unwired). A work-around is
available for the method that uses named connections (unwired). For more information on
working around the unwired method, refer to Using the -u2 Option (netlist). For more
information on using Named Connections , see Defining Netlist Options (netlist).

Problem Symbols in schematic overlap each other.

If symbol pins overlap, there can be problems with pins being left unconnected. This
shows up as red diamonds on the pins in the schematic. For information on correcting this
situation, refer to the following sections:

Checking for Unconnected Nodes (netlist)

Using the -u2 Option (netlist).

Modifying the Translator Configuration File (netlist).

Problem Statistical blocks of the form below, are not supported by the Netlist Translator
prior to ADS 2005A. With the backward compatibility mode (-bc option), this block will be
commented out.

statistics {

mismatch {

}

}

Problem Expressions of the form below are translated straight across and are not
supported by ADS prior to 2005A:

| r=(p1 ? p2+1 : p3+1)

| c=(p1==p2)

Note
Expressions of the form, c=(p1==p2), can be translated to run in ADS releases prior to 2005A by using the
"-pp -bc" option. This is supported for Spectre only.

Problem Statistical parameters of the form %x are not translated to the ADS "stat"
format.

Problem Numeric pin names of the subcircuit and component instances in the input
netlist are prefixed with _node in the output netlist after the netlist translation.
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Since _node is a reserved word for the un-named node in the ADS, you cannot
connect this node to any other node using named connection(Wire/pin label).
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 User Defined Models and Parameter
Mapping Rules
 

 User Defined Models

Spectre functions are single line expressions, all arguments are real and can be defined at
the top level only. Only functions of the type "real" are supported. The following example
shows how Spectre Functions are translated into their ADS equivalent.

Spectre Netlist syntax:

real myfunc ( [real arg1, ... real argn] {

 return <expr of arg1..argn>

}

ADS Netlist syntax:

myfunc(arg1, ... argn)=<expr of arg1..argn>

Note
This document refers to source dialect to indicate a generic modelling dialect. The rules and examples
relate to any modelling dialect, including Spectre.

The Spectre mapping rules reside in a  file called spectre.rul . The file can be edited or
copied for your customizing needs. Customizing can consist of modifying the mapping
rules for existing model translations or adding new models to the translation portfolio.

   

 OpenTranslator Mapping Rules

 

 Type   

This refers to the type of entry in the map file. This is necessary because some spice
dialects can have the same InputName for components and models. This distinguishes
those cases from each other.

The following are possible entries:

element
Indicates this entry is a component type.
model
Indicates this entry is a model type.

 Input Name   

This is the identifier that source dialect uses to indicate the type of component.

 Output Name  

This is the reference used to indicate the type of ADS component. This is a comma
delimited list to support the mapping of many names. This is useful, for example, if you
need to map to a different name depending upon if you are generating IFF versus Netlist
output.
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 Pin Mapping  

The pin mapping is straight forward. Each pin has a comma delimiter and groups have a
semi-colon delimiter. The following is an example:

|1,2;2,1|

Here source dialect pin #1 maps to ADS pin #2 and source dialect pin #2 maps to ADS
pin #1

 Parameter Mapping  

Parameters are mapped in the order of source dialect parameter, ADS parameter, then
source dialect default value. If the source dialect and ADS names are the same, only list
the source dialect name. If the source dialect and ADS default values are the same, do not
list the source dialect default value. The following is an example:

|c, C, 0.0|

Here "c" is the source dialect parameter name, "C" is the ADS parameter name (case
sensitive), and the default is set to 0.0.

 Multiple Parameters Mapping to a Single ADS Parameter

 
If there are multiple parameters that map to the same ADS parameter name, they will be
separated with a tilde. The following is the general rule:

|X[~Y ~Z],[W],[value];...|

The following is an example:

|R,,50;W~Width,Width,;...|

Here the source dialect parameter "R" maps to ADS parameter "R" and it will use the
default value of 50. Note that only list the source dialect name is listed since ADS uses the
same name. In the second case, either "W" or "Width" can be the source dialect
parameter and they both map to the ADS parameter "Width". Note that the default value
is not specified since source dialect and ADS use the same value.

  

 Perl Callbacks

There are two entries for Perl callbacks. The first is the Perl file and the second is the Perl
routine to be called.

The order of the callbacks are as follows:

Component name1.
Pin operations2.
Parameter name3.
Model operations4.
Last Chance5.

The order of the callbacks is the same as the order of the map rule structure with the
addition of the two callbacks, Model operations and Last Chance.
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 Component name

The Component name callback will map source dialect component names to the
appropriate ADS name. This is necessary to support either Netlist output or IFF output
from the translator.

 

 Pin operations

The Pin operations callback can handle more sophisticated pin manipulation than just
straight pin mappings. For example, some BJT devices require either three or four pins
depending upon the configuration.

 

 Parameter name

The Parameter name callback will translate the source dialect parameter names to ADS
names that are listed in the rules file.

 

 Model operations

The Model operations callback handles cases where more model processing is needed that
just a straight across mapping.

 

 Last Chance

The Last Chance callback is user configurable and is the last called in the sequence of
callbacks.

 

 Perl Callback Syntax

The following is the rule syntax for callbacks:

| filename , callback ; [ filename ,] callback ;...|

Note
Any entry that does not have filename listed is assumed to be a callback in the last known filename.

The following is an example:

|bsim.pl,model_mapping;,param_mapping|

Here, at the appropriate time during post processing the Perl code will call bsim.pl to
source the perl file and then call the routine model_mapping.
The next routine that will be called is param_mapping and it is assumed to be in the same
file.

The following paths will be searched to locate the Perl files:

.
$HOME/hpeesof/links/spice/perl/ dialect
$HPEESOF_DIR/links/spice/perl/ dialect
../perl/ dialect
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Where dialect could be anything you want to call it; dialect will be set from the command
line argument -pl <dialect>.

Note
The continuation character \ can be used at any time to keep the line from getting excessively long.

The comment character # can be used at the beginning of any line.
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 Translating a Model
This section provides  model translation information for each of the models supported by
the Netlist Translator. The following are the supported ADS models:

Advanced Curtice2 Model-Advanced Curtice-Quadratic GaAsFET (netlist)
BJT Model-Bipolar Transistor Model (netlist)
BSIM1 Model-BSIM1 MOSFET Model (netlist)
BSIM2 Model-BSIM2 MOSFET Model (netlist)
BSIM3 Model-BSIM3 MOSFET Model (netlist)
BSIM3SOI Model- BSIM3SOI Model (netlist)
BSIM4 Model-BSIM4 MOSFET Model (netlist)
C Model-Capacitor Model (netlist)
Diode Model-PN-Junction Diode Model (netlist)
HICUM Model-HICUM Bipolar Transistor Model (netlist)
JFET Model-Junction Field Effect Transistor Model (netlist)
LEVEL1 Model-LEVEL 1 MOSFET Model (netlist)
LEVEL2 Model-LEVEL 2 MOSFET Model (netlist)
LEVEL3 Model-LEVEL 3 MOSFET Model (netlist)
L Model-Inductor Model (netlist)
Mextram 504 Model-Mextram 504 Model (netlist)
Mextram Model-Mextram Model (netlist)
MOS Model9 Process-Philips MOS Model 9 (Process Based) (netlist)
R Model-Resistor Model (netlist)
Statz Model-Statz (Raytheon) GaAsFET Model (netlist)
STBJT Model-STBJT Model (netlist)
TOM Model-Triquint Scalable Nonlinear GaAsFET Model (netlist)
VBIC Model-VBIC Model (netlist)

 

 Using Parameter Mapping Tables to Understand a Translation

Model  parameter information is organized in tables with the ADS parameter, default
value, and unit in the three left-hand columns of the table. The Berkeley SPICE 2 & 3,
PSpice, HSpice, and Spectre parameter translation information is described in the right-
hand columns. In some cases where ADS does not translate a particular dialect, the
column for that dialect has been removed.

The parameters that are not translated are not always included in the tables. For detailed
parameter information for a specific SPICE or Spectre model, refer to the appropriate
vendor's documentation for that specific model.

For each SPICE or Spectre parameter in the Model Parameter table, the following
conventions apply:

An "x" indicates that the SPICE or Spectre default value and units are the same as
ADS. Any deviations are listed explicitly.
A "-" indicates the parameter does not exist in that particular dialect.
Extra parameter names listed are aliases and are converted to the proper name in
ADS by the translator.

ADS Model Parameters that are not listed are not supported by any SPICE or Spectre
dialects and will use standard ADS defaults. For an alphabetical listing of ADS supported
models and a detailed description of their parameters and default values, refer to
Introduction to Circuit Components (ccsim).
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 R, C, L and Diode Models for Spectre

This section contains detailed parameter information for the Resistor (R), Capacitor (C),
Inductor (I), and Diode models:

R_Model:Resistor Model (netlist)

L_Model:Inductor Model (netlist)

C_Model:Capacitor Model (netlist)

Diode_Model:PN-Junction Diode Model (netlist)
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 Advanced_Curtice2_Model:Advanced Curtice-
Quadratic GaAsFET
The PSpice Level 1 GASFET and HSpice Level 3, SAT 0 JFET or MESFET models are
translated to the ADS  Advanced_Curtice2_Model. For translation information on the
GaAsFET device, refer to Gxxxxxxx (netlist).

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

PSpice: .model GNOM GASFET Level=1 [param=value]

HSpice: .model Jmodel NJF level=3 sat=0 [param=value]

 

 SPICE Dialect and Netlist Syntax:

PSpice: .model mname GASFET LEVEL=1 [param= value]*

HSpice: .model mname NJF | PJF LEVEL=3 SAT=0 [param= value]*

 

 ADS Netlist Syntax:

model mname Advanced_Curtice2_Model NFET=[0|1] PFET=[0|1] [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
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ADS Default Unit PSpice HSpice

Idsmod 1  Level=1 Level=3 SAT=0

Vto −2 V -2.5 x

Beta 1e-4 A/V2 0.1 x

Lambda 0.0 1/V x x

Alpha 2.0 1/V x x

Tau 0.0 sec x -

Ucrit 0  - x

Vgexp 2  - x

Gamds -0.01  - Gamma (def=0)

Vtotc 0.0 V/°C x -

Betatce 0.0 %/°C x x

Cgs 0.0 F x x

Cgd 0.0 F x x

Fc 0.5  x x

Rd 0.0 ohms x x

Rg 0.0 ohms x x

Rs 0.0 ohms x x

Cds 0.0 F x -

Vbi 0.85 V 1.0 V 1.0 V

Is 1e-14 A x x

Xti 3.0  0 0

Eg 1.11 eV x x

N 1.0  x x
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 BJT_Model:Bipolar Transistor Model
The SPICE  Q and Spectre  bjt models are translated to the ADS NPN or PNP BJT_Model.
For translation information on the BJT device, refer to Qxxxxxxx (netlist) for SPICE or BJT
Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model Qmodel1 NPN bf=100

 

 Example Spectre Command Line:

model npn\_mod bjt type=npn is=10e-13 bf=200 va=58.8 ikf=5.63e-3 ...

 

 SPICE and Spectre Dialect and Netlist Syntax:

Spice2/3: .model mname NPN | PNP [param= value]*

PSpice: .model mname NPN | PNP [param= value]*

HSpice: .model mname NPN | PNP [param= value]*

Spectre: model mname bjt type= [ npn | pnp ] [param= value]*

 

 ADS Netlist Syntax:

model mname BJT NPN= [ 0 | 1 ] PNP= [ 0 1 ] [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
 

 BJT_Model Parameter Mapping
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ADS Default Unit Spice2/3 PSpice HSpice Spectre

NPN YES  NPN NPN NPN type npn

PNP NO  NPN NPN NPN type npn

Is 1.0E-16 A x x x x

Bf 100 A/A x x BFM x

Nf 1.0  x x x x

Vaf infinity V x VA VA, VBF x

Ikf infinity A x IK IK, JBF x

Ise † 0.0 A x C2 C2, JLE x

Ne 1.5  x x NE, NLE x

Br 1.0 A/A x x BRM x

Nr 1.0  x x x x

Var infinity V x VB VB, VRB, BV x

Ikr infinity A x x JBR x

Isc † 0.0 A x C4 C4, JLC x

Nc 2.0  2.0 x x x

Rb 0.0 Ohms x x x x

Irb infinity A x x JRB, IOB x

Rbm 0.0 Ohms x x x rbm

Re 0.0 Ohms x x x x

Rc 0.0 Ohms x x x x

Imax  A x x EXPLI 1e15 imax 1000 A

Cje 0.0 F x x x x

Vje 0.75 V x PE PE x

Mje 1/3  x ME ME x

Cjc 0.0 F x x x x

Vjc 0.75 V x PC PC x

Mjc 1/3  x MC MC x

Xcjc 1.0  x x CDIS x

Cjs 0.0 F x CCS CCS, CSUB x

Vjs 0.75 V x PS PSUB x

Mjs 0.0  x MS ESUB x

Fc 0.5  x x x x

Xtf 0.0  x x x x

Tf 0.0 sec x x x x

Vtf infinity V x x x x

Itf 0.0 A x x JTF x

Ptf 0.0 degrees x x x x

Tr 0.0 sec x x x x

Kf 0.0  x x x x

Af 1.0  x x x x

Kb 0.0  - - x x

Fb 1.0 Hz - - x bnoisefc 1.0 Hz

Iss 0.0 A - x x x

Ns 1.0  - x x x

Nk 0.5  - x NKF -

Ffe 1.0  - - x -
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Lateral for struct = vertical,
default = yesfor struct
= lateral, default = no

 - - SUBS(+1 ->0 or
no, -1 -> 1 or
yes)

structfor type = npn,
default = verticalfor type
= pnp, default = lateral

RbModel MDS  ////// Translator sets to Libra in
schematic, 1 in netlist /////

rbmod spice

Tnom  °C 27 - TREF tnom Set by options 25°C

Trise 0.0 °C - - - trise 0.0°C

Tlev 0  - - Default=1 x

Tlevc 0  - - Default=1 x

Eg 1.11 eV x x x x

EgAlpha 7.04E-4 V/°C - - GAP1 gap1 7.02E-4 V/°C

EgBeta 1108 K - - GAP2 x

Tbf1 0.0 1/°C - - x x

Tbf2 0.0 1/°C 2 - - x x

Tbr1 0.0 1/°C - - x x

Tbr2 0.0 1/°C 2 - - x x

Tcbc 0.0 1/°C - - CTC ctc 0.0 1/°C

Tcbe 0.0 1/°C - - CTE cte 0.0 1/°C

Tccs 0.0 1/°C - - CTS cts 0.0 1/°C

Tikf1 0.0 1/°C - - x x

Tikf2 0.0 1/°C 2 - - x x

Tikr1 0.0 1/°C - - x x

Tikr2 0.0 1/°C 2 - - x x

Tirb1 0.0 1/°C - - x x

Tirb2 0.0 1/°C 2 - - x x

Tis1 0.0 1/°C - - x x

Tis2 0.0 1/°C 2 - - x x

Tisc1 0.0 1/°C - - x x

Tisc2 0.0 1/°C 2 - - x x

Tise1 0.0 1/°C - - x x

Tise2 0.0 1/°C 2 - - x x

Tiss1 0.0 1/°C - - x x

Tiss2 0.0 1/°C 2 - - x x

Titf1 0.0 1/°C - - x x

Titf2 0.0 1/°C 2 - - x x

Tmjc1 0.0 1/°C - - x x

Tmjc2 0.0 1/°C 2 - - x x

Tmje1 0.0 1/°C - - x x

Tmje2 0.0 1/°C 2 - - x x

Tmjs1 0.0 1/°C - - x x

Tmjs2 0.0 1/°C 2 - - x x

Tnc1 0.0 1/°C - - x x

Tnc2 0.0 1/°C 2 - - x x

Tne1 0.0 1/°C - - x x

Tne2 0.0 1/°C 2 - - x x

Tnf1 0.0 1/°C - - x x

Tnf2 0.0 1/°C 2 - - x x
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Tnr1 0.0 1/°C - - x x

Tnr2 0.0 1/°C 2 - - x x

Tns1 0.0 1/°C - - x x

Tns2 0.0 1/°C 2 - - x x

Trb1 0.0 1/°C - - TRB x

Trb2 0.0 1/°C 2 - - x x

Trc1 0.0 1/°C - - TRC x

Trc2 0.0 1/°C 2 - - x x

Tre1 0.0 1/°C - - TRE x

Tre2 0.0 1/°C 2 - - x x

Trm1 0.0 1/°C - - x x

Trm2 0.0 1/°C 2 - - x x

Ttf1 0.0 1/°C - - x x

Ttf2 0.0 1/°C 2 - - x x

Ttr1 0.0 1/°C - - x x

Ttr2 0.0 1/°C 2 - - x x

Tvaf1 0.0 1/°C - - x x

Tvaf2 0.0 1/°C 2 - - x x

Tvar1 0.0 1/°C - - x x

Tvar2 0.0 1/°C2 - - x x

Tvjc 0.0 1/°C - - x x

Tvje 0.0 1/°C - - x x

Tvjs 0.0 1/°C - - x x

Xtb 0.0  x x TB, TCB x

Xti 3.0  x PT x x

wVsubfwd infinity V - - - vsubfwd 0.2 V

wBvsub infinity V - - - bvsub infinity V

wBvbe infinity V - - - bvbe infinity V

wBvbc infinity V - - - bvbc infinity V

wVbcfwd infinity V - - - vbcfwd 0.2 V

wIbmax infinity A - - - imax 1e3 A

wIcmax infinity A - - - imax1 imax A

Imelt Imax A - - - imax A

 

 SPICE Comments:

If HSpice does not set options.dcap=1, then the translator sets the ADS Fc model
parameter to zero. This affects forward bias capacitance of the pn junctions.
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 BSIM1_Model:BSIM1 MOSFET Model
The SPICE  BSIM1 MOSFET model is translated to the ADS MOSFET BSIM1_Model. For
translation information on the MOSFET device, refer to Mxxxxxxx (netlist).

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model nch nmos level=13 rsh=0 js=0 ...

 

 SPICE Dialect and Netlist Syntax:

Spice2/3: .model mname NMOS|PMOS LEVEL=4 [param= value]*

PSpice: .model mname NMOS|PMOS LEVEL=4 [param= value]*

HSpice: .model mname NMOS|PMOS LEVEL=13 [param= value]*

 

 ADS Netlist Syntax:

model mname MOSFET NMOS=[0|1]PMOS=[0|1]Idsmod=4 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

ADS Default Unit Spice2/3 PSpice HSpice

Idsmod 4  Level=4 Level=4 Level=13, 28

Rsh 0.0 ohms/sq x x Level 13 only

RSHM

Js 0.0 A/m^ x x Level 13 only

IJS

Temp 25 °C x x -

Muz 600 cm2 x x x
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/Vsec

Dl 0.0  x x XL, LDEL

Dw 0.0  x x XW, WDEL

Vdd 5.0 V x x -

Vfb (L,W) −0.3 V x x VFB0

Phi (L,W) 0.6 V x x PHI0 (0.7)

K1 (L,W) 0.5 √ V x x x

K2 (L,W) 0.0  x x x

Eta (L,W) 0.0  x x ETA0

U0 (L,W) 670.0 1/V x x U00 (0.0 1/V)

U1 (L,W) 0.0 µm/V x x x

X2mz
(L,W)

0.0 cm2/V2 x x X2M

X2e (L,W) -0.07 1/V x x x

X3e (L,W) 0.0 1/V x x x

X2u0 (L,W) 0.0 1/V2 x x x

X2u1 (L,W) 0.0 µm/V2 x x x

X3u1 (L,W) 0.0 µm/V2 x x x

Mus (L,W) 1082 cm2/Vs x x Level 13 only

X2ms
(L,W)

0.0 cm2/V2 s x x Level 13 only

X3ms
(L,W)

0.0 cm2/V2 s x x x

N0 (L,W) 0.5  x x x

Nb (L,W) 0.0 1/V x x NB0

Nd (L,W) 0.0 1/V x x ND0

Tox 1e-7 µ m x x TOXM

Cj 0.0 F/m2 x x Level 13 only

CJM

Mj 0.5  x x Level 13 only

MJ0

Cjsw 0.0 F/m x x Level 13 only

CJW

Mjsw 0.33  x x Level 13 only

MJW

Pb 0.8 V x x Level 13 only

PJ

Pbsw 1.0 V x (Def
PB)

x Pjw, Php

Cgso 0.0 F/m x x CGSOM
(1.5e-9)

Cgdo 0.0 F/m x x CGDOM
(1.5e-9)

Cgbo 0.0 F/m x x CGBOM
(2.0e-10)

Xpart 1.0  x x x

Kf 0.0  - x -

Af 1.0  - x -

Rg 0 ohms - x -

N 1.0  - x -
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 Comments:

Tox > 1 is in angstroms in HSpice. Translator will convert it to um.
ADS does not support NRD, RDC, NRS or RSC MOSFET parameters. If RD or RS are not
given, they will be calculated as follows:
RD=NRD*RSH+RDC
RS=NRS*RSH+RSC
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 BSIM2_Model:BSIM2 MOSFET Model
The SPICE  BSIM2 MOSFET model is translated to the ADS MOSFET BSIM2_Model. For
translation information on the MOSFET device, refer to Mxxxxxxx (netlist).

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model nch nmos level=39 rsh=0 js=0

 

 SPICE Dialect and Netlist Syntax:

Spice2/3: .model mname NMOS|PMOS LEVEL=5 [param= value]*

PSpice: Does not exist

HSpice: .model mname NMOS | PMOS LEVEL=39 [param= value]*

 

 ADS Netlist Syntax:

model mname MOSFET NMOS=[0|1] PMOS=[0|1] Idsmod=5 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

ADS Default Unit Spice2/3 HSpice

Idsmod 5  Level=5 Level=39

Rsh 0.0  x x

Js 0.0 A/m2 x x

Mu0 600 cm2/V-s x Def=400

Dl 0.0 µm x x

Dw 0.0 µm x x

Vdd 5.0 V x x

Vgg 5.0 V x x
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Vbb -5.0 V x x

Temp 25 oC x -

Tox 1e-7 µm x x

Cj 5.0 F/m2 x Def=0

Mj 0.5  x x

Cjsw 0.0 F/m x x

Mjsw 0.33  x x

Pb 0.8 V x x

Pbsw 1.0 V x Def=PB

Cgso 0.0 F/m x x

Cgdo 0.0 F/m x x

Cgbo 0.0  x x

Xpart 1.0  x -

Vfb (L, W) -0.1 V x Def=-0.3

Phi (L, W) 0.6 V x Def=0.8

K1 (L, W) 0.5 √ V x x

K2 (L, W) 0.0  x x

Eta0 (L, W) 0.08  x Def=0

Ua0 (L, W) 670.0 1/V x Def=0

U10 (L, W) 0.0 µ m/V x x

Mu0b (L, W) 0.0 cm2/V2s x x

Etab (L, W) -0.07 1/V x Def=0

Uab (L, W) 0.0 1/V2 x x

U1b (L, W) 0.0 µ m/V2 x x

U1d (L, W) 0.0 µ m/V2 x x

Mus0 (L, W) 600.0 cm2/Vs x x

Musb (L, W) 0.0 cm2/V2s x x

N0 (L, W) 0.5  x x

Nb (L, W) 1.0 1/V x x

Nd ((L, W) 0.0 1/V x x

Mu20 (L, W) 0.0  x x

Mu2b (L, W) 0.0 1/V x x

Mu2g (L, W) 0.0 1/V x x

Mu30 (L, W) 0.0 cm2/V2s x x

Mu3b (L, W) 0.0 cm2/V3s x x

Mu3g (L, W) 0.0 cm2/V3s x x

Mu40 (L, W) 0.0 cm2/v3s x x

Mu4b (L, W) 0.0 cm2/v4s x x

Mu4g (L, W) 0.0 cm2/v4s x x

Ub0 (L, W) 0.0 1/V2 x x

Ubb (L, W) 0.0 1/V3 x x

Vof0 (L, W) 0.0 V x x

Vofb (L, W) 0.0 1/V x x

Vofd (L, W) 0.0 1/V x x

Ai0 (L, W) 0.0  x x

Aib (L, W) 0.0 1/V x x

Bi0 (L, W) 0.0 V x x

Bib (L, W) 0.0  x x

Vghigh (L, W) 0.0 V x x

Vglow (L, W) -0.15 V x Def=0
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 Comments:

Tox > 1 is in angstroms in HSpice. Translator will convert it to um.
For HSpice and ADS, most parameters have associated width and length sensitivity
parameters. Consult your HSpice documentation or refer to Introduction to Circuit
Components (ccsim) for more information.
ADS does not support NRD, RDC, NRS or RSC MOSFET parameters. If RD or RS are not
given, they will be calculated as follows:
RD=NRD*RSH+RDC
RS=NRS*RSH+RSC
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 BSIM3_Model:BSIM3 MOSFET Model
The SPICE   BSIM3 and Spectre MOSFET models are translated to the ADS MOSFET
BSIM3_Model. For translation information on the MOSFET device, refer to Mxxxxxxx
(netlist) for SPICE and MOSFET Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model nch nmos level=7 rg=0 rsh=0 ...

 

 Example Spectre Command Line:  

model pchmod bsim3v3 type=p ...

 

 SPICE Dialect and Netlist Syntax:

Spice2/3: Does not exist

PSpice: .model mname NMOS|PMOS LEVEL=7 [param= value]*

HSpice: .model mname NMOS|PMOS LEVEL=49 [param= value]*

Spectre: model mname bsim3v3 type=[N|P] [param= value]*

 

 ADS Netlist Syntax:

model mname MOSFET NMOS=[0|1] PMOS=[0|1] Idsmod=8 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

ADS Default Units Spice2/3 PSpice HSpice Spectre

NMOS YES  - - - type=n
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PMOS NO  - - - type=n

Idsmod 8  - Level=7 Level=49, 53 -

Version 3.24  - x x version 3.1

Mobmod 1  - x x x

Capmod 1  - Def=2 3
Level 53 def=3

capmod 2

Noimod 1  - x x x

Paramchk 0  - x x paramchk 1

Binunit 1  - x x x

Rg 0  - x - -

Rsh 0.0 Ohms/sqr - x x x

Nj 1.0  - x N -

Xti 3.0  - - x x

Js 0.0 A/m2 - 1e-4 A/m2 x js A/m2

Jsw 0.0 A/m2 - x x jsw 0 A/m

Lint 0.0 m - x x x

Ll 0.0  - x x ll 0 m

Lln 1.0  - x x x

Lw 0.0 m - x x x

Lwn 1.0  - x x x

Lwl 0.0 m2 - x x x

wint 0.0 m - x x x

Wl 0.0 m - x x x

Wln 1.0  - x x x

Ww 0.0 m - x x x

Wwn 1.0  - x x x

Wwl 0.0  - x x wwl 0 m2

Tnom 25 °C - 27 - tnom °C

Tox 1.0e-7 m - 1.5e-8 m 1.5e-8 m tox 1.5e-8 m

Cj 0.0 F/m2 - 5e-4 5.79e-4 cj 5.0e-4 F/m2

Mj 0.5  - x x x

Cjsw 0.0 F/m - 5.0e-10 x cjsw 5.0e-10 F/m

Mjsw 1/3  - x x mjsw 0.33

Pb 0.8 V - 1.0 PHIB 1.0 pb 1.0 V

Pbsw 1.0 V - x x x

Cjswg Cjsw F/m - - CJGATE x

mjswg 1/3  - - .33 x

Pbswg Pbsw V - - PHP x

Cgso 0.0 F/m - x 2.07188e-10 x

Cgdo 0.0 F/m - x 2.07188e-10 x

Cgbo 0.0 F/m - x x cgbo 2*Dwc*Cox F/m

Xpart 1.0  - x 1
Level 53 def=0

xpart 0.0

Dwg 0.0 m/V - x x x

Dwb 0.0 m/V1/2 - x x x

Nch 1.7e17 1/cm3 - - x nch 1.7e17 cm-3

Nsub 0.0 1/cm3 - - 6.0e16 nsub 6e16 cm-3

Ngate 0.0 1/cm3 - x x ngate infinity cm

Gamma1  V(1/2) - x x gamma1 (sqrt(V))

Gamma2 0.0 V(1/2) - x x gamma2 (sqrt(V))

Xt 1.55e-7 m -   x
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Vbm (Vbb) -5.0 V -   vbm -3.0 V

Vbx  V -   x

Xj 0.0 m - x 1.5e-7 xj 0.15e-6 m

U0 670.0 cm2/V*s - x x x

Vth0 0.7 V - NMOS=0.7
PMOS=-0.7

x vtho V

K1 0.5 V(1/2) - x x k1 0.5 sqrt(V)

K2 0.0  - x 0.0186 k2 -0.0186

K3 80.0  - x x x

K3b 0.0 1/V - x x x

W0 2.5e-6 m - - x x

Nlx 1.74e-7 m - x x x

Dvt0 2.2  - x x x

Dvt1 0.53  - x x x

Dvt2 -0.032 1/V - x - x

Dvt0w 0.0  - x x x

Dvt1w 5.3e6  - x x x

Dvt2w -0.032 1/V - x x x

Ua 2.25e-9 m/V - x x  

Ub 5.87e-19 (m/V)2 - x x x

Uc -0.0465 m/V2 - x -4.65e-11 uc -4.65e-11 m/V2

Delta 0.0 V - x 0.01 delta 0.01 V

Rdsw 0.0 Ohms*µm - x x x

Prwg 0.0 1/V - x x x

Prwb 0.0 1/V(1/2) - x x x

Wr 1.0  - - x x

Vsat 8.0e4 m/s - x x x

A0 1.0  - x x x

Keta -0.047 1/V - x x x

Ags 0.0 1/V - x x ags 0 F/m2*V

A1 0.0 1/V - x x a1 0

A2 1.0  - x x x

B0 0.0 m - x x x

B1 0.0 m - x x x

Alpha0 0.0 m/V - x x x

Beta0 30.0 m/V - x x beta0 30 1/V

Voff -0.08 V - x x x

Nfactor 1.0  - x x x

Cdsc 2.4e-4 F/m2 - x x x

Cdscb 0.0 F/(V*m2) - x x x

Cdscd 0.0 F/(V*m2) - x x x

Cit 0.0 F/m2 - x x cit 0 F

Eta0 0.08  - x x x

Etab -0.07  - x x etab -0.07 1/V

Dsub Drout  - x x x

Drout 0.56  - x x x

Pclm 1.3  - - x x

Pdiblc1 0.39  - x x x

Pdiblc2 0.0086  - x x x

Pdiblcb 0.0 1/V - x x x

Pscbe1 4.24e8 V/m - x x x
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Pscbe2 1.0e-5 m/V - x x x

Pvag 0.0  - x x x

Ute -1.5  - x x x

At 3.3e4 m/s - x x x

Ua1 4.31e-9 m/V - x x x

Ub1 -7.61e-18 (m/V)2 - x x x

Uc1 -0.056 1/V - x -5.69e-11 uc1 -5.5e-11 m/v2

Kt1 -0.11 V - x x x

Kt1l 0.0 V*m - x x x

Kt2 0.022  - x x x

Prt 0.0 Ohms*µm - x x prt 0 Ohm

Cgsl 0.0 F/m - x x x

Cgdl 0.0 F/m - - x x

Ckappa 0.6 F/m - x x ckappa 0.6

Cf  F/m - x x x

Clc 0.1e-6 m - x x clc 1e-7 m

Cle 0.6  - x x x

Dlc Lint m - x x x

Dwc Wint m - x x x

Vfbcv -1.0 V - x x vfbcv -1

Toxm Tox m - - x x

Vfb -0.3 V - - x vfb -1

Noff 1.0  - - x x

Voffcv 0.0 V - - x 0

ljth 0.1  - - x x

Alpha1 0.0 1/V - - x x

Acde 1.0 m/V - - x acde 1 1/V

Moin 15.0 V(1/2) - - x moin 15 1/V

Tpb 0.0 V/K - - x tpb 0 V/C

Tpbsw 0.0 V/K - - x tpbsw 0 V/C

Tpbswg 0.0 V/K - - x tpbswg 0 V/C

Tcj 0.0 1/K - - x tcj 0 1/C

Tcjsw 0.0 V/K - - x tcjsw 0 1/C

Tcjswg 0.0 1/K - - x tcjswg 0 1/C

Llc L1  - - x llc ll m

Lwc Lw  - - x lwc lw m

Lwlc Lwl  - - x lwlc lwl m2

Wlc Wl  - - x wlc wl m

Wwc Ww  - - x wwc ww m

Wwlc Wwl  - - x wwlc wwl m2

Elm 5.0  - x x x

Nlev -1  - - x -

Gdsnoi 1.0  - - x -

Kf 0.0  - x x x

Af 1.0  - x x x

Ef 1.0  - x x x

Em 4.1e7 V/m - 4.1e-7 x x

Noia 1.0e20 A - x x x

Noib 5.0e4  - x x x

Noic 1.4e-12  - x x x

Imax 10 A - - - imax 1 A

Acm -1  - - 10 -
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Hdif 0.0 m - - x x

Ldif 0.0 m - - x x

Wmlt 1.0  - - x -

Xw 0.0 m - - x x

Rdc 0.0 Ohms - - x x

Rsc 0.0 Ohms - - x x

B3qmod 0  - - See comments -

Calcacm 0  - - x -

Xl 0.0 m - - x x

Is 1.0e-14 A - - x x

Rd 0.0 Ohm - - x x

Rs 0.0 Ohm - - x x

Flkmod 0  - - - x

Tlev 0  - - x x

Tlevc 0  - - x x

Eg 1.16 eV - - x eg 1.12452 V

Gap1 7.02e-4 V/°C - - 7.04e-4 x

Gap2 1108.0 K - - x gap2 1108 C

Cta 0.0 1/°C - - x x

Ctp 0.0 1/°C - - x x

Pta 0.0 1/°C - - x pta 0 V/C

Ptp 0.0 1/°C - - x ptp 0 V/C

Trd 0.0 1/°C - - x x

Trs 0.0 1/°C - - x x

 

 Comments:

The binning parameters Wmin, Wmax, Lmin and Lmax have been added to the model.
They are not used by the simulator; they are supported solely for making models self-
documenting. To perform binning, the ADS BinModel must be used. The translator
automatically sets up the BinModel and moves these parameters to that BinModel.
Therefore, the translator does not set these parameters on the BSIM3 model, just the
BinModel.

Hspice only: If Level=49 and Capmod=0, the translator sets B3qmod=1 to turn on a
special Hspice compatibility mode. Otherwise, the default value of B3qmod=0.
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 BSIM3SOI_Model: BSIM3SOI_Model
The Spectre B3SOI-PD model is translated to the ADS MOSFET BSIM3SOI_Model. For
translation information on the MOSFET device, refer to MOSFET Device (netlist) for
Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example Spectre Command Line:

model b3s b3soipd type=n vtho=0.5 ...

 

 Spectre Netlist Syntax:

model mname b3soipd type=[N|P] [param= value]*

 

 Example ADS Command Line:

model b3s BSIM3SOI NMOS=yes Vtho=0.5 ...

 

 ADS Netlist Syntax:

model mname BSIM3SOI NMOS=[0|1] PMOS=[0|1] [param= value ]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

ADS Default Units Spectre

NMOS YES  type=n

PMOS NO  type=n

Capmod 2  capmod 2

Mobmod 1  x

Noimod 1  x

Shmod 0  x

Ddmod 0  -

Igmod 0  x

Paramchk 0  paramchk 1
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Binunit 1  x

Version 2.0  Version 2.2

Tox 1.0e-8 m tox

Cdsc 2.4e-4 F/m2 x

Cdscb 0.0 F/(V*m2) x

Cdscd 0.0 F/(V*m2) x

Cit 1.0 F/m2 cit 0 F

Nfactor 0.0  1

Vsat 8.0e4 m/s x

At 3.3e4 m/s x

A0 1.0  x

Ags 0.0 1/V ags 0 F/m2*V

A1 0.0 1/V a1 0

A2 1.0  x

Keta -0.6 1/V x

Nsub 6.0e16 1/cm3 nsub 6e16 cm-3

Nch 1.7e17 1/cm3 nch 1.7e17 cm-3

Ngate 0.0 1/cm3 ngate infinity cm^

Gamma1  V(1/2) gamma1 (sqrt(V))

Gamma2  V(1/2) gamma2 (sqrt(V))

Vbx  V x

Vbm -3.0 V vbm -3.0 V

Xt 1.55e-7 m x

K1 0.5 V(1/2) k1 0.5 sqrt(V)

Kt1 -0.11 V x

Kt1l 0.0 V*m x

Kt2 0.022  x

K2 0.0  k2 -0.0186

K3 0.0  x

K3b 0.0 1/V x

W0 2.5e-6 m x

Nlx 1.74e-7 m x

Dvt0 2.2  x

Dvt1 0.53  x

Dvt2 -0.032 1/V x

Dvt0w 0.0  x

Dvt1w 5.3e6  x

Dvt2w -0.032 1/V x

Drout 0.56  x

Dsub Drout  x

Vth0 NMOS=0.7
PMOS=-0.7

V vtho V

Ua 2.25e-9 m/V x

Ua1 4.31e-9 m/V x

Ub 5.87e-19 (m/V)2 x

Ub1 -7.61e-18 (m/V)2 x

Uc -0.0465 1/V uc -4.65e-11 m/V2

Uc1 -0.056 1/V uc1 -5.5e-11 m/v2

U0 NMOS=
0.067
PMOS=
0.025

m2/(V*s) x
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Ute -1.5  x

Voff -0.08 V x

Tnom 25.0 °C tnom °C

Trise    

Cgso  F/m x

Cgdo  F/m x

Xpart 0.0  xpart 0.0

Delta 0.01 V delta 0.01 V

Rsh 0.0 Ohms/sqr x

Rdsw 0.0 Ohms*µmWr x

Prwg 0.0 1/V x

Prwb 0.0 1/V(1/2) x

Prt 0.0 Ohms*µm prt 0 Ohm

Eta0 0.08  x

Etab -0.07 1/V etab -0.07 1/V

Pclm 1.3  x

Pdiblc1 0.39  x

Pdiblc2 0.086  8.6e-3

Pdiblcb 0.0 1/V x

Pvag 0.0  x

Tbox 3.0e-7 m x

Tsi 1.0e-7 m x

Xj Tsi m xj 0.15e-6 m

Rth0 0.0 Ohms x

Cth0 0.0 F cth0 (F)

Ngidl 1.2 V x

Agidl 0.0 1/Ohm agidl 0

Bgidl 0.0 V/m x

Ndiode 1.0  x

Xbjt 1.0  xbjt 2

Xdif 1.0  xdif 2

Xrec 1.0  xrec 20

Xtun 0.0  x

Pbswg 0.7 V x

Mjswg 0.5  x

Cjswg 1.0e-10 F/m x

Lint 0.0 m x

Ll 0.0 m ll 0 m

Lln 1.0  x

Lw 0.0 m x

Lwn 1.0  x

Lwl 0.0 m x

Wr 1.0  x

Wint 0.0 m x

Dwg 0.0 m/V x

Dwb 0.0 m/V1/2 x

Wl 0.0 m x

Wln 1.0  x

Ww 0.0 m x

Wwn 1.0  x

Wwl 0.0 m wwl 0 m2

B0 0.0 m x
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B1 0.0 m x

Cgsl 0.0 F/m x

Cgdl 0.0 F/m x

Ckappa 0.6 F/m ckappa 0.6

Cf  F/m x

Clc 0.1e-7 m clc 1e-7 m

Cle 0.0  x

Dwc Wint m x

Dlc Lint m x

Alpha0 0.0 m/V x

Noia NMOS=
1.0e20 PMOS=
9.9e18

A x

Noib NMOS=
5.0e4 PMOS=
2.4e3

 x

Noic NMOS=
1.4e-12 PMOS=
1.4e-12

 x

Em 4.1e7 V/m x

Ef 1.0  x

Af 1.0  x

Kf 0.0  x

Noif 1.0  x

K1w1 0.0 m x

K1w2 0.0 m x

Ketas 0.0 V x

Dwbc 0.0 m x

Beta0 0.0 1/V beta0 0 1/V

Beta1 0.0  x

Beta2 0.1 V beta2 0 V

Vdsatii0 0.9 V x

Tii 0.0  x

Lii 0.0  x

Sii0 0.5 1/V x

Sii1 0.1 1/V x

Sii2 0.1 1/V sii2 0.0 1/V

Siid 0.1 1/V siid 0 1/V

Fbjtii 0.0  x

Esatii 1.0e7 V/m x

Ntun 10.0  x

Nrecf0 2.0  x

Nrecr0 10.0  x

Isbjt 1.0e-6 A/m2 isbjt 1e-6 A

Isdif 0.0 A/m2 isdif 0 A

Isrec 1.0e-5 A/m2 isrec 1e-5 A

Istun 0.0 A/m2 istun 0 A

Ln 2.0e-6 m x

Vrec0 0.0 V x

Vtun0 0.0 V x

Nbjt 1.0  x

Lbjt0 0.2e-6 m x

Ldif0 1.0  x
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Vabjt 10.0 V x

Aely 0.0 V/m aely 0V

Ahli 0.0  x

Rbody 0.0 Ohm/m2 rbody 0F

Rbsh 0.0 Ohm/m2 rbsh 0 Ohm

Cgeo 0.0 F/m x

Tt 1.0e-12  tt 1e-12 s

Ndif -1.0  1

Vsdfb  V vsdfb (F/m)

Vsdth  V vsdth

Csdmin  F x

Asd 0.3  x

Csdesw 0.0 F/m csdesw 0

Ntrecf 0.0  x

Ntrecr 0.0  x

Dlcb Lint m x

Fbody 1.0  x

Tcjswg 0.0 1/K x

Tpbswg 0.0 V/K x

Acde 1.0 m/V -

Moin 15.0 V1/2 -

Delvt 0.0 V x

Kb1 1.0  x

Dlbg 0.0 m x

Toxqm Tox m x

Wth0 0.0 m wth0 0.0 mm

Rhalo 1.0e15 Ohms x

Ntox 1.0  x

Toxref 2.5e-9 m x

Ebg 1.2 V x

Nevb 3.0 V x

Alphagb1 0.35  x

Betagb1 0.03  x

Vgb1 300.0  x

Necb 1.0  x

Alphagb2 0.43  x

Betagb2 0.05  x

Vgb2 17.0  x

Voxh 5.0 V x

Deltavox 0.005 V x

Gmin 1.0e-20  -
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 BSIM4_Model:BSIM4 MOSFET Model
The SPICE  BSIM4 MOSFET model is translated to the ADS MOSFET BSIM4_Model. For
translation information on the MOSFET device, refer to Mxxxxxxx (netlist).

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model nch nmos LEVEL=54...

 

 SPICE Dialect and Netlist Syntax:

Spice2/3: Does not exist

Spectre: model mname bsim4 [param=value]*

HSpice: .model mname NMOS|PMOS LEVEL=54 [param= value]*

 

 ADS Netlist Syntax:

model mname BSIM4 [parameter= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

 

 BSIM4_Model Parameters

ADS Default Units PSpice HSpice Spectre

Capmod 2  x x x

Diomod 1  x x x

Rdsmod 0  x x 1

Trnqsmod 0  x x x
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Acnqsmod 0  x x x

Mobmod 1  x x x

Rbodymod 0  x x x

Rgatemod 0  x x x

Permod 1  x x x

Geomod 0  x x x

Fnoimod 1  x x x

Tnoimod 0  x x x

Igcmod 0  x x x

Igbmod 0  x x 1

Tempmod † 0  x x x

Paramchk 1  x x x

Binunit 1  x x x

Version 4.30  x 4.10 4.21

Toxe 3.0e-9 m x x x

Toxp TOXE  x x x

Toxm TOXE  x x x

Toxref 3.0e-9 m x x x

Dtox 0.0 m x x x

Epsrox 3.9 Si02 x x x

Cdsc 2.4e-4 F/(V*m2 ) x x x

Cdscb 0.0 F/(V*m2 ) x x x

Cdscd 0.0 F/(Vm*2 ) x x x

Cit 0.0 F/(Vm *2 ) x x x

Nfactor 1  x x x

Xj 1.5e-7 m x x x

Vsat 8.0e-4 m/s x x x

At 3.3e-4 m/s x x x

A0 1  x x x

Ags 0.0 V-1 x x x

A1 0.0 V-1 x x x

A2 1  x x x

Keta -0.047 V-1 x x x

Nsub 6.0e16 cm-3 x x x

Ndep 1.7e17 cm-3 x x x

Nsd 1.0e20 cm-3 x x x

Phin 0.0 V x x x

Ngate 0.0 cm-3 x 1 x

Gamma1 calculated V(1/2) x x x

Gamma2 calculated V(1/2) x x x

Vbx calculated V x x x

Vbm -3.0 V x x x

Xt 1.55e-7 m x x x

K1 0.53 V(1/2) x 0.5 x

Kt1 -0.11 V(1/2) x x x

Kt1l 0.0 V*m x x x
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Kt2 0.022  x x x

K2 -0.0186  x x x

K3 80  x x x

K3b 0.0 V-1 x x x

W0 2.5e-6 m x x x

Dvtp0 0.0 m x x x

Dvpt1 0.0 V-1 x x x

Lpe0 1.74e-7 m x x x

Lpeb 0.0 m x x x

Dvt0 2.2  x x x

Dvt1 0.53  x x x

Dvt2 -0.032 V-1 x x x

Dvt0w 0  x x x

Dvt1w 5.3e6 m-1 x x x

Dvt2w -0.032 V-1 x x x

Drout 0.56  x x x

Dsub Drout  x x x

Vth0 0.7 V (NMOS) x x x

Vtho -0.7 V (PMOS) x x x

Ua 1.0e-9 for MOBMOD=0 and 1; 1.0e-
15 for MOBMOD=2

m/V x x x

Ua1 1.0e-9 m/V x x 4.31e-9

Ub 1.0e-19 (m/V)2 x x x

Ub1 -1.0e-18 (m/V)2 x x -7.61e-18

Uc -0.0465 V-1 for MOBMOD=1; -
0.0465e-9 m/V2 for MOBMOD=0
and 2

V-1 and m/V2 x x x

Uc1 -0.056 V-1 for MOBMOD=1; -
0.056e-9 m/V2 for MOBMOD=0 and
2

V-1 and m/V2 x x x

U0 0.067 for NMOS; 0.025 for PMOS m2 /(V*s) x x x

Eu 1.67 (NMOS); 1.0(PMOS)  x x x

Ute -1.5  x x x

Voff -0.08 V x x x

Minv 0  x x x

Voffl 0.0 V*m x x x

Tnom 25 °C x 27 27

Trise 0.0 °K - - x

Cgso calculated F/m x x x

Cgdo calculated F/m x x x

Cgbo 0.0 F/m x x x

Xpart 0  x 1 x

Delta 0.01 V x x x

Rsh 0.0 ohmsV-1 and
m/V2

x x x

Rdsw 200.0 ohms × µmWr x x x

Rdswmin 0.0 ohms × µmWr x x x

Rsw 100.0 ohms × µmWr x x x
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Rdw 100.0 ohms × µmWr x x x

Rdwmin 0.0 ohms × µmWr x x x

Rswmin 0.0 ohms × µmWr x x x

Prwg 1.0 V-1 x x x

Prwb 0.0 V(-1/2) x x x

Prt 0.0 ohms × µmWr x x x

Eta0 0.08  x x x

Etab -0.07 V-1 x x x

Pclm 1.3  x x x

Pdiblc1 0.39  x x x

Pdiblc2 0.0086  x x x

Pdiblcb 0.0 V-1 x x x

Fprout 0.0 V/m(1/2) x x x

Pdits 0.0 V-1 x x x

Pditsl 0.0 m-1 x x x

Pditsd 0.0 V-1 x x x

Pscbe1 4.24e-8 V/m x x x

Pscbe2 1.0e-5 m/V x x x

Pvag 0  x x x

Jss 1.0e-4 A/m2 x x x

Jsws 0.0 A/m x x x

Jswgs 0.0 A/m x x x

Pbs 1.0 V x x x

Njs 1.0  x x x

Xtis 3.0  x x x

Mjs 0.5  x x x

Pbsws 1.0 V x x x

Mjsws 0.33  x x x

Pbswgs Pbsws V x x x

Mjswgs Mjsws  x x x

Cjs 5.0e-4 F/m2 x x x

Cjsws 5.0e-10 F/m x x x

Cjswgs Cjsws F/m x x x

Jsd Jss A/m2 x x x

Jswd Jsws A/m x x x

Jswgd Jswgs A/m x x x

Pbd Pbs V x x x

Njd 1  x x x

Xtid Xtis  x x x

Mjd Mjs  x x x

Pbswd Pbsws V x x x

Mjswd Mjsws  x x x

Pbswgd Pbsws V x x x

Mjswgd Mjswgs  x x x

Cjd Cjs F/m2 x x x

Cjswd Cjsws F/m x x x
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Cjswgd Cjsws F/m x x x

Vfbcv -1.0 V x x x

Vfb -1.0 V x x x

Tpb 0.0 V/K x x x

Tcj 0.0 K-1 x x x

Tpbsw 0.0 V/K x x x

Tcjsw 0.0 K-1 x x x

Tpbswg 0.0 V/K x x x

Tcjswg 0.0 K-1 x x x

Acde 1.0 m/V x x x

Moin 15  x x x

Noff 1  x x x

Voffcv 0.0 V x x x

Dmcg 0.0 m x x x

Dmci Dmcg m x x x

Dmdg 0.0 m x x x

Dmcgt 0.0 m x x x

Xgw 0.0 m x x x

Xgl 0.0 m x x x

Rshg 0.1 Ohms2 x x x

Ngcon 1  x x x

Xrcrg1 12  x x x

Xrcrg2 1  x x x

Xw 0.0 m x x x

Xl 0.0 m x x x

Lambda † 0.0 m3/V*s x x x

Vtl † 2.0e5 m/s x x x

Lc † 5.0e-9 m x x x

Xn † 3.0  x x x

Lint 0.0 m x x x

Ll 0.0 m x x x

Llc Ll m x x x

Lln 1  x x x

Lw 0.0 m x x x

Lwc Lw m x x x

Lwn 1  x x x

Lwl 0.0 m x x x

Lwlc Lwl m x x x

Lmin 0.0 m x x x

Lmax 1.0 m x x x

Wr 1  x x x

Wint 0.0 m x x x

Dwg 0.0 m/V x x x

Dwb 0.0 m/V(1/2) x x x

Wl 0.0 m x x x

Wlc Wl m x x x

Wln 1  x x x
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Ww 0.0 m x x x

Wwc Ww m x x x

Wwn 1  x x x

Wwl 0.0 m x x x

Wwlc Wwl m x x x

Wmin 0.0 m x x x

Wmax 1.0 m x x x

B0 0.0 m x x x

B1 0.0 m x x x

Cgsl 0.0 F/m x x x

Cgdl 0.0 F/m x x x

Ckappas 0.6 V x x x

Ckappad Ckappas V x x x

Cf calculated F/m x x x

Clc 1.0e-7 m x x x

Cle 0.6  x x x

Dwc Wint m x x x

Dlc Lint m x x x

Dlcig Lint m x x x

Dwj Dwc (in CVmodel)  x x x

Alpha0 0.0 A*m/V x x x

Alpha1 0.0 A/V x x x

Beta0 30.0 V x x x

Agidl 0.0 ohms-1 x x x

Bgidl 2.3e9 V/m x x x

Cgidl 0.5 V3 x x x

Egidl 0.8 V x x x

Aigc 0.43 (NMOS) and 0.31 (PMOS) (F s 2/g)0.5m-
1V-1

x x 0.054 (NMOS) and
0.31 (PMOS)

Bigc 0.054 (NMOS) and 0.24 (PMOS) (F s 2/g)0.5m-
1V-1

x x x

Cigc 0.075(NMOS) and 0.03(PMOS) V-1 x x x

Aigsd 0.43(NMOS) and (0.31PMOS) (F s 2/g)0.5m-1 x x x

Bigsd 0.054(NMOS) and 0.024(PMOS) (F s 2/g)0.5m-
1V-1

x x x

Cigsd 0.075(NMOS) and 0.03(PMOS) V-1 x x x

Aigbacc 0.43 (F s 2/g)0.5m-1 x x x

Bigbacc 0.054 (F s 2/g)0.5m-
1V-1

x x x

Cigbacc 0.075 V-1 x x x

Aigbinv 0.35 (F s 2/g)0.5m-1 x x x

Bigbinv 0.03 (F s 2/g)0.5m-
1V-1

x x x

Cigbinv 0.006 V-1 x x x

Nigc 1  x x x

Nigbinv 3  x x x

Nigbacc 1  x x x

Ntox 1  x x x

Eigbinv 1.1 V x x x
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Pigcd 1  x x x

Poxedge 1  x x x

ljthdfwd ljthsfwd  x x x

ljthsfwd 0.1 A x x x

ljthdrev ljthsrev A x x x

ljthsrev 0.1 A x x x

Xjbvd Xjbvs  x x x

Xjbvs 1.0  x x x

Bvd Bvs V x x x

Bvs 10.0 V x x x

Gbmin 1.0e-12 ohms-1 x x x

Rbdb 50.0 ohms x x x

Rbpb 50.0 ohms x x x

Rbsb 50.0 ohms x x x

Rbps 50.0 ohms x x x

Rbpd 50.0 ohms x x x

Llambda † 0.0  x x x

Lvtl † 0.0  x x x

Lxn † 0.0  x x x

Wlambda † 0.0  x x x

Wvtl † 0.0  x x x

Wxn † 0.0  x x x

Plambda † 0.0  x x x

Pvtl † 0.0  x x x

Pxn † 0.0  x x x

Saref † 1.0e-6 m x x x

Sbref † 1.0e-6 m x x x

Wlod † 0.0 m x x x

Ku0 † 0.0 m x x x

Kvsat † 0.0 m x x x

Kvth0 † 0.0 V*m x x x

Tku0 † 0.0  x x x

Llodku0 † 0.0  x x x

Wlodku0 † 0.0  x x x

Llodvth † 0.0  x x x

Wlodvth † 0.0  x x x

Lku0 † 0.0  x x x

Wku0 † 0.0  x x x

Pku0 † 0.0  x x x

Lkvth0 † 0.0  x x x

Wkvth0 † 0.0  x x x

Pkvth0 † 0.0  x x x

Stk2 † 0.0 m x x x

Lodk2 † 1.0  x x x

Steta0 † 0.0 m x x x

Lodeta0 † 1.0  x x x

Noia 6.25e41 for NMOS; 6.188e40 for
PMOS

(eV)-1S1-EFm-
3

x x x
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Noib 3.125e26 for NMOS; 1.5e25 for
NMOS

(eV)-1S1-EFm-
3

x x x

Noic 8.75e9 (eV)-1S1_EFm x x x

Tnoia 1.5  x x x

Tnoib 3.5  x x x

Rnoia † 0.577  x x x

Rnoib † 0.37  x x x

Ntnoi 1  x x x

Em 4.1e7 V/m x x x

Ef 1  x x x

Af 1  x x x

Kf 0.0  x x x

Ud 1.00E+14 m-2 x x x

Ud1 0 m-2 x x x

Up 0 m-2 x x x

Lp 1.00E-8 m x x x

Tvoff 0 K-1 x x x

Tvfbsdoff 0 K-1 x x x

Lud 0     

Lud1 0     

Lup 0     

L1p 0     

Ltvoff 0  x x x

Ltvbsdoff 0  x x x

Wud 0     

Wud1 0     

Wup 0     

Wip 0     

Wtvoff 0  x x x

Wtvfbsdoff 0  x x x

Pud 0     

Pud1 0     

Pup 0     

P1p 0     

Ptvoff 0  x x x

Ptvfbsdoff 0  x x x

Rbps0 50 ohm x x x

Rbps1 0  x x x

Rbpsw 0  x x x

Rbpsnf 0  x x x

Rbpd0 50 ohm x x x

Rbpd1 0     

Rbpdw 0  x x x

Rbpdnf 0  x x x

Rbpbx0 100 ohm x x x

Rbpbx1 0     

Rbpbxw 0  x x x

Rbpbxnf 0  x x x

Rbpby0 100 ohm x x x
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Rbpby1 0  x x x

Rbpbyw 0  x x x

Rbpbynf 0  x x x

Rbsbx0 100 ohm x x x

Rbsby0 100 ohm x x x

Rbdbx0 100 ohm x x x

Rbdby0 100 ohm x x x

Rbsdbx1 0  x x x

Rbsdbxw 0  x x x

Rbsdbxnf 0  x x x

Rbsdby1 0  x x x

Rbsdbyw 0  x x x

Rbsdbynf 0  x x x

Wpemod 0  x x x

Web 0  x x x

Wec 0  x x x

Ktvh0we 0  x x x

K2we 0  x x x

Ku0we 0  x x x

Scref 1.00E-6 m x x x

Lkvth0we 0  x x x

Lk2we 0  x x x

Lku0we 0  x x x

Wkvth0we 0  x x x

Wk2we 0     

Wku0we 0  x x x

Pkvth0we 0  x x x

Pk2we 0  x x x

Pku0we 0  x x x

† These parameters are new for BSIM4.3.0 which has recently been released. The translation for these
parameters has not been verified in other simulators, since the updates for other simulators containing the
latest parameters were not available at release time. Please refer to the SPICE/Spectre simulator
documentation to determine the appropriate translation for these parameters.

Note The default value of the Version parameter for each simulator changes for each vendor's specific
version. Generally this will be the latest release of the BSIM4 model in that version.
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 C_Model:Capacitor Model
The SPICE C and Spectre capacitor models are translated to the ADS C_Model. For
translation information on the capacitor device, refer to the Cxxxxxxx (netlist) for SPICE
and the Capacitor Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model Cmodel1 c CJ=5e-5

 

 Example Spectre Command Line:

model proc\_cap capacitor c=2u tc1=1.2e-8 tnom=25 w=4u l=4u cjsw=2.4e-10

 

 SPICE and Spectre Dialect and Netlist Syntax:

Spice2/3: .model mname c [param= value]*

PSpice: .model mname cap [param= value]*

HSpice: .model mname c [param= value]*

Spectre: model mname capacitor [param= value]*

 

 ADS Netlist Syntax:

model mname C_Model [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
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ADS Default Unit Spice2/3 PSpice HSpice Spectre

C 1e-12
(1 pF)

F C CAP CAP (0 F) c 0.0 F

Cj 0.0 F/m2 x - COX (see comment) cj 0.0 F/m2

Cjsw 0.0 F/m x - CAPSW cjsw 0.0 F/m

Length  m - - x l 0.0 m

Width  m DEFW=1e-6 - x w 0.0 m

Narrow 0.0 m x - DEL etch 0.0 m

Coeffs list(0,0,...) 1/V, 1/V2, ... - - - coeffs [0 0 ...]

Tnom 25 °C - - TREF (°C) tnom set by options °C

Trise 0.0 °C - - - trise 0.0°C

TC1 0.0 1/°C - (0°C-1) x tc1 0.0 1/°C

TC2 0.0 1/°C2 - (0°C-2) x tc2 0.0 1/°C2

Scale 1  - - - scalec 1

 

 SPICE Comments:

If the Cj parameter is not given, it will be calculated by the translator using the di and
thick parameters. ADS does not have di or thick parameters.
If cox is non-zero, Cj=cox. Otherwise, Cj=cj_eqn which is calculated as follows:

If the Scale parameter is given, the capacitance is set to value * scale .
When the referenced model is not present in the netlist, the netlist translator fails to
recognize the resistor model in the following syntax:
c1 1 2 cmodel
The translator assumes that it is a variable name for the capacitance value. To correct
your imported schematic, manually move the model name to the parameter Model. To
correct the ADS Netlist, use the following netlist syntax:
cmodel:c1 1 2 [param=value]*
To prevent the problem, ensure that the netlist translator has access to a model
statement so it can verify that "cmodel" is a model. This can be a dummy statement
without parameters such as the following:
.model cmodel C
or a .INC reference to an include file with the model available.
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 Diode_Model:PN-Junction Diode Model
The SPICE  D and Spectre diode models are translated to the ADS Diode_Model. For
translation information on the diode device, refer to Dxxxxxxx (netlist) for SPICE and
Diode Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model Dmodel d is=10e-15

 

 Example Spectre Command Line:

model pdiode diode is=1.8e-8 rs=1.43 n=1.22 nz=2.31 ...

 

 SPICE and Spectre Dialect and Netlist Syntax:

Spice2/3: .model mname d [param= value]*

PSpice: .model mname d [param= value]*

HSpice: .model mname d LEVEL=[1|3] [param= value]*

Spectre: model mname diode [param= value]*

 

 ADS Netlist Syntax:

model mname Diode [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

ADS Default Unit Spice2/3 PSpice HSpice Spectre

Level 1  - - x level 1

Is 1e-14 A x x JS is 10e-14 A

Rs 0.0 ohms x x x rs 0.0 ohms

N 1.0  x x x n 1.0

Tt 0.0 sec x x x tt 0.0 sec
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Cjo 0.0 F x x CJ, CJA cjo 0.0 F

Vj 1.0 V x x PB, PHI, PHA
(0.8 V)

vj 1.0 V
pb

M 0.5  x x MJ, EXA m 0.5

Fc 0.5  x x x fc 0.5

Imax 1.0 A - - EXPLI (0 amp/m2) imax 1.0 A

Isr 0.0 A - x - -

Nr 2.0  - x - -

Ikf infinity (0) A - x IK, JBF A/m2 ik infinity A

Ikr 0.0 A - - JBR -

IkModel   - 1 2 -

Bv infinity (0) V x x VB, VAR, VRB bv infinity V

Ibv 0.001 A x 1e-10 IB ibv 0.001 A

Nbv 1.0  - x N nz 1.0

Ibvl 0.0 A - x - -

Nbvl 1.0  - x - -

Kf 0.0  x x x kf 0.0

Af 1.0  x x x af 1.0

Ffe 1.0  - - ISP -

Jsw 0.0 A - - CJP isw 0.0 A

Cjsw 0.9 F - - Cjp cjsw 0.0 F

Msw 0.33  - - EXP, MJSW mjsw 0.33

Vjsw 1.0 V - - PHP vjsw 1.0 V

Fcsw 0.5  - - FCS fc 0.5

Area 1.0  - - x area 1

Periph 0  - - PJ perim 0

Width  m - - W -

Length  m - - L -

Dwl   - - XW -

Shrink   - - x -

Tnom 25 °C x T_measured TREF tnom set by options °C

Trise 0.0 °C - - - trise 0.0°C

Tlev 0  - - x tlev 0

Tlevc 0  - - x tlevc 0

Xti 3.0  x x x xti 3.0

Pt 3.0  - - - x

Eg 1.11 eV x x 1.11 eV if
TLEV=0,1
1.16 eV if
TLEV=2

eg 1.11 eV

EgAlpha 7.02e-4 V/°K - - GAP1 gap1 7.02e-4 V/°K

EgBeta 1108 K - - GAP2 gap2 1108 K

Tcjo 0.0 1/°C - - CTA cta 0.0 1/°C

Tcjsw 0.0 1/°C - - CTP ctp 0.0 1/°C

Ttt1  1/°C - - x -

Ttt2  1/°C2 - - x -

Tm1 0.0 1/°C - - x -

Tm2  1/°C2 - - x -

Tvj  1/°C - - TPB pta 0.0 V/°C

Tvjsw  1/°C - - Tphb ptp 0.0 V/°C

Trs  1/°C - - x trs 0.0 1/°C

Tbv 0.0 1/°C - - TCV tbv1 0.0 1/°C

wBv 0.0 V - - - bvj infinity V
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 Spectre Comments

If Eg is not given and Tlev is 0, 1, or not given, Spectre uses a proprietary model for
temperature effects. Under these conditions the simulation results for Spectre will deviate
from ADS as the simulation temperature varies from Tnom. In this case the model cards
will need to be extracted for accurate simulation.

 

 BJT, HICUM, Mextram, VBIC, and STBJT Models for Spectre

This section contains detailed parameter information for the BJT models:

BJT_Model:Bipolar Transistor Model (netlist)

HICUM_Model:HICUM Bipolar Transistor Model (netlist)

Mextram_Model:Mextram Model (netlist)

Mextram_504_Model:Mextram 504 Model (netlist)

VBIC_Model:VBIC Model (netlist)

STBJT_Model: STBJT Model (netlist)
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 HICUM_Model:HICUM Bipolar Transistor Model
The SPICE  Q and Spectre models are translated to the ADS NPN or PNP BJT_Model. For
translation information on the BJT device, refer to Qxxxxxxx (netlist) for SPICE and BJT
Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

model hicum NPN level=8

 

 Example Spectre Command Line:

model npnm bht type=npn

 

 SPICE and Spectre Dialect and Netlist Syntax:

Spice2/3: Does not exist.

PSpice: Does not exist.

HSpice: .model mname NPN | PNP LEVEL=8 [param= value]*

Spectre: model mname bht type= [ npn | pnp ] [param= value]*

 

 ADS Netlist Syntax:

model mname HICUM NPN= [ 0 | 1 ] PNP= [ 0 | 1 ] [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

ADS Default Unit Spice2/3 PSpice HSpice Spectre

NPN YES  NPN NPN NPN type npn

PNP NO  NPN NPN NPN type npn
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C10 2.0e-30  - - 3.76e-32 c10 1.0e-28

Qp0 2.0e-14  - - 2.78e-14 qp0 25.0e-15

Ich 1.0e-20 A - - 2.09e-02 ich infinity A

Hfe 1.0  - - 1.0 x

Hfc 1.0  - - 1.0 x

Hjei 1.0  - - 0.0x x

Hjci 1.0  - - 1.0 x

Mcf 1.0  - - 1.0x x

Alit 0.0  - - 0.45 x

Cjei0 0.0 F - - 8.11e-15 x

Vdei 0.9 V - - 0.95 x

Zei 0.5  - - 0.5 x

Aljei 2.5  - - 1.8 aljei 2.4

Cjci0 0.0 F - - 1.16e-15 cjci0 2.0e-15 F

Vdci 0.7 V - - 0.8 x

Zci 0.4  - - 0.333 x

Vptci 1.0e3 V - - 416 vptci infinity V

T0 5.0e-12 sec - - 4.75e-12 t0 8.0e-12 sec

Dt0h 0.0 sec - - 2.1e-12 dt0h 2.0e-12 sec

Tbvl 0.0 sec - - 40e-12 tbvl 4.0e-12 sec

Tef0 0.0 sec - - 1.8e-12 tef0 1.0e-12 sec

Gtfe 1.0  - - 1.4 x

Thcs 0.0 sec - - 3.0e-11 thcs 30.0e-12 sec

Alhc 0.1  - - 0.75 alhc 0.7

Fthc 0.0  - - 0.6 fthc 0.6

Alqf 0.0  - - 0.225 x

Rci0 150.1 Ohm - - 127.8 rci0 150.0 Ohm

Vlim 0.5 V - - 0.7 vlim 0.4 V

Vpt 3.0 V - - 5.0 x

Vces 0.1 V - - 0.1 x

Tr 0.0 sec - - 1.0e-9 x

Ibeis 1.0e-18 A - - 1.16e-20 ibeis 0.0 A

Mbei 1.0  - - 1.015 mbei 1.002

Ireis 0.0 A - - 1.16e-6 x

Mrei 2.0  - - 2.0 x

Ibcis 1.0e-16 A - - 1.16e-20 ibcis 0.0 A

Mbci 1.0  - - 1.015 mbci 1.5

Favl 0.0 1/V - - 1.186 x

Qavl 0.0  - - 1.11e-14 x

Rbi0 0.0 Ohm - - 0 x

Fdqr0 0.0  - - 0.0 fdqr0 0.2

Fgeo 0.6557  - - 0.73 x

Fqi 1.0  - - 0.9055 fqi 0.75

Fcrbi 0.0  - - 0.0 fcrbi 0.2

Latb 0.0  - - 3.765 x

Latl 0.0  - - 0.342 x

Cjep0 0.0 F - - 2.07e-15x x

Vdep 0.9 V - - 1.05 x

Zep 0.5  - - 0.4 x

Aljep 2.5  - - 2.4 aljep 2.0

Ibeps 0.0 A - - 3.72e-21 x

Mbep 1.0  - - 1.105 mbep 1.002

Ireps 0.0 A - - 1e-30 x
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Mrep 2.0  - - 2.0 x

Ibets 0.0 A - - 0 x

Abet 40.0  - - 0.0x abet 1.0

Cjcx0 0.0 F - - 5.393e-15 x

Vdcx 0.7 V - - 0.7 x

Zcx 0.4  - - 0.333 x

Vptcx 1.0e20 V - - 100 vptcx infinity V

Ccox 0.0 F - - 2.97e-15 x

Fbc 0.0  - - 0.1526 fbc 0.7

Ibcxs 0.0 A - - 4.39e-20 x

Mbcx 1.0  - - 1.03 mbcx 1.5

Ceox 0.0 F - - 1.13e-15 x

Rbx 0.0 Ohm - - 0 x

Re 0.0 Ohm - - 0 x

Rcx 0.0 Ohm - - 0 x

Itss 0.0 A - - 0.0 x

Msf 1.0  - - 0.0 x

Msr 1.0  - - 1.0 x

Iscs 0.0 A - - 0.0 x

Msc 1.0  - - 0.0 x

Tsf 0.0  - - 0.0 x

Cjs0 0.0 F - - 3.64e-14 x

Vds 0.6 V - - 0.6 x

Zs 0.5  - - 0.447 x

Vpts 1.0e20 V - - 1000 vpts infinity V

Rsu 0.0 Ohm - - x x

Csu 0.0 F - - 0 x

Kf 0.0  - - 1.43e-8 x

Af 2.0  - - 2.0 x

Krbi 1.0  - - 1.17 x

Vgb 1.17 V - - 1.17 x

Alb 5.0e-3 1/K - - 6.3e-3 x

Zetaci 0.0  - - 1.6 zetaci 1.6

Alvs 0.0 1/K - - 1e-3 alvs 1.0e-3 1/K

Alt0 0.0 1/K - - 0 x

Kt0 0.0 1/K - - 0 kt0 0.0

Alces 0.0 1/K - - 0.4e-3 alces 0.4e-3 1/K

Zetarbi 0.0  - - 0.588 zetarbi 1.0

Zetarbx 0.0  - - 0.2060 zetarbx 0.3

Zetarcx 0.0  - - 0.2330 zetarcx 0.3

Zetare 0.0  - - 0 zetare 0.3

Alfav 0.0 1/K - - 8.25e-5 x

Alqav 0.0 1/K - - 1.96e-4 x

Tnom ckt temp C - - 0 tnom Set by options °C

Trise 0.0 °C - - - trise 0.0°C

Rth 0.0 Ohm - - 0 rth 0.0 K/W

Cth 0.0 F - - 0 cth 0.0 J/K
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 JFET_Model:Junction Field Effect Transistor Model
The SPICE J and Spectre jfet models are translated to the ADS  JFET_Model. For
translation information on the JFET device, refer to Jxxxxxxx (netlist) for SPICE or JFET
Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model Jmodel1 NJF Vto=-2.0

 

 Example Spectre Command Line:

model jmod jfet beta=9e-5 lambda=0 type=n

 

 SPICE and Spectre Dialect and Netlist Syntax:

Spice2/3: .model mname NJF|PJF [param= value]*

PSpice: .model mname NJF|PJF [param= value]*

HSpice: .model mname NJF|PJF LEVEL=1 [param= value]*

Spectre model mname jfet type= [ n | p ] ** [param= value]*

 

 ADS Netlist Syntax:

model mname JFET NFET=[0|1] PFET=[0|1] [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
 

 JFET_Model Parameters
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ADS Default Unit Spice2/3 PSpice HSpice Spectre

NFET yes     type n (NFET)

PFET no     type n (NFET)

     Level=1  

Vto −2.0 V x x x vto -2.0 V

Beta 1e-4 A/V2 x x x beta 1e-4 A/V2

Lambda 0.0 1/V x x x lambda 0.0 Ohms

Rd 0.0 ohms x x x rd 0.0 Ohms

Rs 0.0 ohms x x x rs 0.0 Ohms

Is 1e-14 A x x x is 1e-14 A

Cgs 0.0 F x x x cgs 0.0 F

Cgd 0.0 F x x x cgd 0.0 F

Pb 1.0 V x x 0.8 V pb 1.0 V

Fc 0.5  x x x fc 0.5

Tnom 25 °C x T_measured - tnom Set by defaults °C

      trise † 0.0 °C

Kf 0.0  x x x kf 0.0

Af 1.0  x x x af 1.0

Imax 1.6 A - - - imax 1.0 A

N 1.0  - x x n 1.0

Isr 0.0 A - x - -

Nr 2.0  - x - -

Alpha 0.0 1/V - x - ai 0.0 1/V

Vk 0.0 V - x - bi 0.0 V

M 0.5  - x MJ -

Vtotc 0.0 V/°C - x TVC tcv 0.0 1/°C

Betatce 0.0 %/°C - x - -

Xti 3.0  - x 0.0 -

wBvgs infinity V    bvj infinity V

wBvgd infinity V    bvj infinity V

† See Temp instance parameter
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 LEVEL1_Model:LEVEL 1 MOSFET Model
The SPICE and Spectre Level 1 MOSFET models are translated to the ADS MOSFET
LEVEL1_Model. For translation information on the MOSFET device, refer to Mxxxxxxx
(netlist) for SPICE or MOSFET Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model nch nmos level=1 vto=0 kp=2e-5 ...

 

 Example Spectre Command Line:

model nchmod1 mos1 vto=0.78 gamma=0.56 kp=0.8675e-4 ...

 

 SPICE/Spectre Dialect and Netlist Syntax:

Spice2/3: .model mname NMOS|PMOS LEVEL=1 [param= value]*

PSpice: .model mname NMOS|PMOS LEVEL=1 [param= value]*

HSpice: .model mname NMOS|PMOS LEVEL=1 [param= value]*

Spectre: model mname mos1 type= [n|p] [param= value]*

 

 ADS Netlist Syntax:

model mname MOSFET NMOS=[0|1] PMOS=[0|1] Idsmod=1 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
 

 LEVEL1_Model Parameters
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ADS Default Unit Spice2/3 PSpice HSpice Spectre

Idsmod 1  Level=1 Level=1 Level=1 -

NMOS yes     type † n \(NMOS)

PMOS no     type † n \(NMOS)

Capmod 1     capmod bsim

Vto 0.0 V x x VT x

Kp 2e-5 A/m2 x x BET, BETA kp 2.0718e-5 A/V2

Gamma 0.0 √ V x x .5276 x

Phi 0.6 V x x .576 V phi 0.7 V

Lambda 0.0 1/V x x LAM, LA x

Rd 0.0 ohms x x - x

Rs 0.0 ohms x x - x

Cbd 0.0 F x x - x

Cbs 0.0 F x x - x

Is 1e-14 A x x - x

Pb 0.8 V x x - x

Cgso 0.0 F/m x x - x

Cgdo 0.0 F/m x x - x

Cgbo 0.0 F/m x x - x

Rsh 0.0 ohms/sq. x x - x

Cj 0.0 F/m2 x x - x

Mj 0.5  x x - x

Cjsw 0.0 F/m x x - x

Mjsw 0.33  Spice3 \(0.50) x - x

Js 0.0 A/m2 x x - 0.0

Tox 1e-7 m x x x x

Nsub 0.0 1/cm3 x x DNB, NB
\(1e15)

nsub1.13e16 1/cm3

Nss 0.0 1/Cm2 x x - x

Tpg 1  x x - x

Ld 0.0 m x x DLAT, LATD x

Uo 600.0 Cm2 /\(VxS) x x x x

Kf 0.0  x x - x

Af 1.0  x x - x

Fc 0.5  x x - x

N 1.0  - x - x

Imax 10.0 A - - - 1 A

wBvsub infinite V - - - bvj infinite V

wBvg infinite V - - - vbox 1e9 x tox V

Temp †† 25 °C - - - -

Rg 0.0 ohms - - - -

Rds infinity ohms - - - -

Tt 0.0 sec - x - -

Ffe 1.0  - - - -

wVsubfwd infinity  - - - -

wBvds infinite  - - - -

wIdsmax infinite  - - - -
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wPmax infinite  - - - -

† If type = nmos then NMOS = yes and PMOS = no; if type = pmos then NMOS = no and PMOS = yes ††

Temp = trise + temp ("temp" is an ADS global variable)

 

 Comments:

ADS does not support NRD, RDC, NRS or RSC MOSFET parameters. If RD or RS are not
given, they will be calculated as follows:
RD=NRD*RSH+RDC
RS=NRS*RSH+RSC
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 LEVEL2_Model:LEVEL 2 MOSFET Model
The SPICE and Spectre  Level 2 MOSFET models are translated to the ADS MOSFET
LEVEL2_Model. For translation information on the MOSFET device, refer to Mxxxxxxx
(netlist) for SPICE or MOSFET Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model nch nmos level=2 vto=0 kp=2e-5 ...

 

 Example Spectre Command Line:

model nch2 mos2 type=n vto=0.66 lambda=0.018 gamma=0.6 ...

 

 SPICE/Spectre Dialect and Netlist Syntax:

Spice2/3: .model mname NMOS|PMOS LEVEL=2 [param= value]*

PSpice: .model mname NMOS|PMOS LEVEL=2 [param= value]*

HSpice: .model mname NMOS|PMOS LEVEL=2 [param= value]*

Spectre: model mname mos2 type= [ n | p ] [param= value]*

 

 ADS Netlist Syntax:

model mname MOSFET NMOS=[0|1]PMOS=[0|1]Idsmod=2 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
 

 LEVEL2_Model Parameters
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ADS Default Unit Spice2/3 PSpice HSpice Spectre

NMOS yes     type † n \(NMOS)

PMOS no     type † n \(NMOS)

Idsmod 2  Level=2 Level=2 Level=2 -

Capmod 1  - - - capmod bsim

Vto 0.0 V x x VT vto 0 V

Kp 2e-5 A/V2 x x BET, BETA kp 2.0718e-5 A/V2

Gamma 0.0 √ V x x \(.5276) gamma 0 √ V

Phi 0.6 V x x \(.576) phi 0.7 V

Lambda 0.0 1/V x x LAM, LA lambda 0 1/V

Rd 0.0 ohms x x - rd 0 Ohm

Rs 0.0 ohms x x - rs 0 Ohm

Cbd 0.0 F x x - cbd 0 F

Cbs 0.0 F x x - cbs 0 F

Is 1e-14 A x x - is 1e-14 A

Pb 0.8 V x x - pb 0.8 V

Cgso 0.0 F/m x x - cgso 0 F/m

Cgdo 0.0 F/m x x - cgdo 0 F/m

Cgbo 0.0 F/m x x - cgbo 0 F/m

Rsh 0.0 ohms/sq x x - rsh 0 Ohm/sqr

Cj 0.0 F/m2 x x - cj 0 F/m2

Mj 0.5  x x - mj 1/2

Cjsw 0.0 F/m x x - cjsw 0 F/m

Mjsw 0.33  x x - mjsw 1/3

Js 0.0 A/m2 x x - js \(A/m2 )

Tox 1e-7 m x x x tox 1e-7 m

Nsub   x x DNB, NB \(1e15) nsub 1.13e16 cm-3

Nss 0.0 1/Cm2 x x - nss 0 cm-2

Nfs 0.0 1/Cm2 x x DFS, NF, DNF nfs 0 cm-2

Tpg 1  x x - tpg \+1

Xj 0.0 m x x x xj 0 m

Ld 0.0 m x x DLAT, LATD ld 0 m

Uo 600.0 Cm2 /\(V×s) x x UB, UBO uo 600 cm2 /V\s

Ucrit 1e4 V/Cm x x x ucrit 0 V/cm

Uexp 0.0  x x F2 uexp 0

Vmax 0.0 m/s x x VMX, VSAT vmax infinity m/s

Neff 1.0  x x - neff 1

Xqc 1.0  - x - xqc 0

Kf 0.0  x x - kf 0

Af 1.0  x x - af 1

Fc 0.5  x x - fc 0.5

Delta 0.0  x x x delta 0

Rg 0.0 ohms - x - -

Rds infinity ohms - x -  

Tnom  C - - - tnom \(C)

Trise  C - - - trise 0 C
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N 1.0  - x - n 1

Tt 0.0 sec - x -  

Ffe   - - -  

Imax   - - - imax 1 A

wVsubfwd   - - -  

wBvsub   - - -  

wBvg   - - -  

wBvds   - - -  

wIdsmax   - - -  

wPmax   - - -  

Acm   - - -  

Hdif      hdif 0 m

Ldif      ldif 0 m

Wmlt       

Xw       

Rdc      rdc 0 Ohm

Rsc      rsc 0 Ohm

† If type = nmos then NMOS = yes and PMOS = no; if type = pmos then NMOS = no and PMOS = yes ††

Temp = trise + temp ("temp" is an ADS global variable)

 

 Comments:

ADS does not support NRD, RDC, NRS or RSC MOSFET parameters. If RD or RS are not
given, they will be calculated as follows:
RD=NRD*RSH+RDC
RS=NRS*RSH+RSC
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 LEVEL3_Model:LEVEL 3 MOSFET Model
The SPICE and Spectre  Level 3 MOSFET models are translated to the ADS MOSFET
LEVEL3_Model. For translation information on the MOSFET device, refer to Mxxxxxxx
(netlist) for SPICE or MOSFET Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model nch nmos level=3 vto=0 kp=2e-5 ...

 

 Example Spectre Command Line:

model pchmos3 mos3 type=p vto=-0.83 gamma=0.4511

 

 SPICE Dialect and Netlist Syntax:

Spice2/3: .model mname NMOS|PMOS LEVEL=3 [param= value]*

PSpice: .model mname NMOS|PMOS LEVEL=3 [param= value]*

HSpice: .model mname NMOS|PMOS LEVEL=3 [param= value]*

Spectre: model mname mos3 type= [n|p] [param= value]*

 

 ADS Netlist Syntax:

model mname MOSFET NMOS=[0|1]PMOS=[0|1]Idsmod=3 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
 

 LEVEL3_Model Parameters
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ADS Default Unit Spice2/3 PSpice HSpice Spectre

NMOS yes     type † n (NMOS)

PMOS no     type † n (NMOS)

Idsmod 3  Level=3 Level=3 Level=3 -

Capmod 1     capmod bsim

Vto 0.0 V x x VT vto 0 V

Kp 2e-5 A/V2 x x BET, BETA kp 2.0718e-5 A/V2

Gamma 0.0 √ V x x (.5276) gamma 0

Phi 0.6 V x x (.576) phi 0.7 V

Rd 0.0 ohms x x - rd 0 Ohm

Rs 0.0 ohms x x - rs 0 Ohm

Cbd 0.0 F x x - cbd 0 F

Cbs 0.0 F x x - cbs 0 F

Is 1e-14 A x x - is 1e-14 A

Pb 0.8 V x x - pb 0.8 V

Cgso 0.0 F/m x x - cgso 0 F/m

Cgdo 0.0 F/m x x - cgdo 0 F/m

Cgbo 0.0 F/m x x - cgbo 0 F/m

Rsh 0.0 ohms/sq x x - rsh 0 Ohm/sqr

Cj 0.0 F/m2 x x - cj 0 F/m2

Mj 0.5  x x - mj 1/2

Cjsw 0.0 F/m x x - cjsw 0 F/m

Mjsw 0.33  x x - mjsw 1/3

Js 0.0 A/m2 x x - js (A/m2 )

Tox 1e-7 m x x x tox 1e-7 m

Nsub   x x DNB, NB (1e15) nsub 1.13e16 cm-

3

Nss 0.0 1/cm2 x x - nss 0 cm-2

Nfs 0.0 1/cm2 x x DFS, NF, DNF nfs 0 cm-2

Tpg 1  x x - tpg 1.0

Xj 0.0 m x x x xj 0 m

Ld 0.0 m x x DLAT, LATD ld 0 m

Uo 600.0 cm2 /(V×s) x x UB, UBO\(PMOS
def=250)

uo 600 cm2/Vs

Vmax 0.0 m/s x x VMX vmax infinity m/s

Xqc 1.0  - x - xqc 0

Nlev      -

Gdsnoi 1     -

Kf 0.0  x x - kf 0

Af 1.0  x x - af 1

Fc 0.5  x x - fc 0.5

Delta 0.0  x x x delta 0

Theta 0.0 1/V x x x theta 0 1/V

Eta 0.0  x x x eta 0 1/V

Kappa 0.2  x x x kappa 0.2

Rg 0.0 ohms - x - -

Rds infinity ohms - x - -
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Tnom      tnom \(C)

Trise      trise 0 C

N 1.0  - x - n 1

Tt 0.0 sec - x - -

Ffe      -

Imax      imax 1 A

wVsubfwd      -

wBvsub      -

wBvg      -

wBvds      -

wIdsmax      -

wPmax      -

Acm      -

Hdif      hdif 0 m

Ldif      ldif 0 m

Wmlt       

Xw      xw 0 m

Rdc      rdc 0 Ohm

Rsc      rsc 0 Ohm

† If type = nmos then NMOS = yes and PMOS = no; if type = pmos then NMOS = no and PMOS = yes ††

Temp = trise + temp ("temp" is an ADS global variable)

 

 Comments:

ADS does not support NRD, RDC, NRS or RSC MOSFET parameters. If RD or RS are not
given, they will be calculated as follows:
RD=NRD*RSH+RDC
RS=NRS*RSH+RSC
The simulation results using the ADS MOSFET LEVEL3_Model match the Spice3 model (UC
Berkeley Spice 3F5) but not the Spectre or Hspice model.
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 LEVEL1_Model:LEVEL 1 MOSFET Model
The SPICE and Spectre Level 1 MOSFET models are translated to the ADS MOSFET
LEVEL1_Model. For translation information on the MOSFET device, refer to Mxxxxxxx
(netlist) for SPICE or MOSFET Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model nch nmos level=1 vto=0 kp=2e-5 ...

 

 Example Spectre Command Line:

model nchmod1 mos1 vto=0.78 gamma=0.56 kp=0.8675e-4 ...

 

 SPICE/Spectre Dialect and Netlist Syntax:

Spice2/3: .model mname NMOS|PMOS LEVEL=1 [param= value]*

PSpice: .model mname NMOS|PMOS LEVEL=1 [param= value]*

HSpice: .model mname NMOS|PMOS LEVEL=1 [param= value]*

Spectre: model mname mos1 type= [ n | p ] [param= value]*

 

 ADS Netlist Syntax:

model mname MOSFET NMOS=[0|1] PMOS=[0|1] Idsmod=1 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
 

 LEVEL1_Model Parameters

ADS Default Unit Spice2/3 PSpice HSpice Spectre

Idsmod 1  Level=1 Level=1 Level=1 -

NMOS yes     type † n \(NMOS)

PMOS no     type † n \(NMOS)
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Capmod 1     capmod bsim

Vto 0.0 V x x VT x

Kp 2e-5 A/m2 x x BET, BETA kp 2.0718e-5 A/V2

Gamma 0.0 √ V x x .5276 x

Phi 0.6 V x x .576 V phi 0.7 V

Lambda 0.0 1/V x x LAM, LA x

Rd 0.0 ohms x x - x

Rs 0.0 ohms x x - x

Cbd 0.0 F x x - x

Cbs 0.0 F x x - x

Is 1e-14 A x x - x

Pb 0.8 V x x - x

Cgso 0.0 F/m x x - x

Cgdo 0.0 F/m x x - x

Cgbo 0.0 F/m x x - x

Rsh 0.0 ohms/sq. x x - x

Cj 0.0 F/m2 x x - x

Mj 0.5  x x - x

Cjsw 0.0 F/m x x - x

Mjsw 0.33  Spice3 \(0.50) x - x

Js 0.0 A/m2 x x - 0.0

Tox 1e-7 m x x x x

Nsub 0.0 1/cm3 x x DNB, NB \(1e15) nsub1.13e16 1/cm3

Nss 0.0 1/Cm2 x x - x

Tpg 1  x x - x

Ld 0.0 m x x DLAT, LATD x

Uo 600.0 Cm2 /\(VxS) x x x x

Kf 0.0  x x - x

Af 1.0  x x - x

Fc 0.5  x x - x

N 1.0  - x - x

Imax 10.0 A - - - 1 A

wBvsub infinite V - - - bvj infinite V

wBvg infinite V - - - vbox 1e9 x tox V

Temp †† 25 °C - - - -

Rg 0.0 ohms - - - -

Rds infinity ohms - - - -

Tt 0.0 sec - x - -

Ffe 1.0  - - - -

wVsubfwd infinity  - - - -

wBvds infinite  - - - -

wIdsmax infinite  - - - -

wPmax infinite  - - - -

† If type = nmos then NMOS = yes and PMOS = no; if type = pmos then NMOS = no and PMOS = yes ††^

Temp = trise \+ temp \("temp" is an ADS global variable)

 

 Comments:
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ADS does not support NRD, RDC, NRS or RSC MOSFET parameters. If RD or RS are not
given, they will be calculated as follows:
RD=NRD*RSH+RDC
RS=NRS*RSH+RSC
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 Mextram_504_Model:Mextram 504 Model
The Spectre bjt504 model is translated to the ADS NPN or PNP MEXTRAM 504 Model. For
translation information on the BJT device, refer to BJT Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example Spectre Command Line:

model mext504 bjt504 type=npn level=6 tref=25 dta=0 exmod=1 ...

 

 Spectre Netlist Syntax:

Spectre: model mname bjt504 type= [npn|pnp] [param= value]*

 

 Example ADS Command Line:

model mext504 MextramBJT504 NPN=yes Level=6 Tref=25 dta=0 Exmod=1 ...

 

 ADS Netlist Syntax:

model mname MextramBJT504 NPN=[0|1] PNP=[0|1] Release=504 [param= value ]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

ADS Default Unit Spectre

NPN YES  type npn

PNP NO  type npn

LEVEL 6  x

MULT 1.0  x

Tref 25.0 C x

DTA 0.0  x

Exmod 1  x

Exaval 0  x
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Is 22.0e-18 A x

Bf 215.0  x

Xibi 0.0  x

Ibf 2.75e-15 A x

Vlf 0.5 V x

Ik 0.1 A x

Bri 7.0  x

Ibr 1.0e-15 A x

Vlr 0.2 V x

   x

Xert 0.63  x

Ver 2.5 V x

Vef 44.0 V x

Mlf 2.0  x

Wavl 1.1e-6 gMeters x

Vavl 3.0 V x

Sfh 0.3  x

Re 5.0 ohms x

Rbc 23 ohms x

Rbv 18 ohms x

Rcc 12 ohms x

Rcv 150 ohms x

SCRcv 1250 ohms x

Ihc 4e-3 A x

axi 0.3  x

Cje 73e-15 farads x

Vde 0.95 V x

pe 0.4  x

XCje 0.4  x

Cbe0 0.0  x

Cjc 78e-15 F x

Vdc 0.68 V x

pc 0.5  x

Xp 0.35  x

mc 0.5  x

XCjc 32e-3  x

Cbc0 0  x

mt 1  x

te 2e-12 s x

tb 4.2e-12 s x

tepi 41e-12 s x

tr 520e-12 s x

dEg 0 Elec. V x

Xrec 0 V x

Aqb0 0.3  x

Ae 0  x

Ab 1  x

Aepi 2.5  x

Aex 0.62  x

Ac 2.0  x

dVgbf 0.05 V x

dVgbr 0.045 V x
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Vgb 1.17 V x

Vgj 1.15 V x

dVgte 0.05 V x

Af 2  x

Kf 2e-11  x

Kfn 2e-11  x

Iss 4.8e-18 A x

Iks 2.5e-4 A x

Cjs 3.15e-13 F x

Vds 0.62 V x

ps 0.34  x

Vgs 1.2 V x

As 1.58  x

Rth 300  -

Cth 3e-9  -
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 Mextram_Model:Mextram Model
The Spectre bjt503 model is translated to the ADS NPN or PNP MEXTRAM 503 Model. For
translation information on the BJT device, refer to BJT Device (netlist) for Spectre.

Note
The translator does not support the Mextram 503 model for SPICE.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example Spectre Command Line:

model \_mext503 bjt503 ab=895.0e-3 ac=673.9e-3

 

 Spectre Netlist Syntax:

Spectre: model mname bjt503 type= [npn|pnp] [param= value]*

 

 Example ADS Command Line:

model \_mext503 MextramBJT Ab=895.0e-3 Ac=673.9e-3 ...

 

 ADS Netlist Syntax:

model mname MextramBJT NPN= [0|1] PNP= [0|1] Release=503 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

ADS Default Unit Spice2/3 PSpice HSpice Spectre

NPN YES  - - - type npn

PNP NO  - - - type npn

Release 503  - - - -

Exmod 1  - - - x

Exphi 1  - - - exphi 1
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Exavl 0  - - - x

Is 5.0e-17 A/m2 - - - x

Bf 140.0  - - - x

Xibi 0  - - - x

Ibf 2.0e-14 A/m2 - - - x

Vlf 0.5 V - - - x

Ik 1.5e-2 A/m2 - - - x

Bri 16.0  - - - x

Ibr 8.0e-15 A/m2 - - - x

Vlr 0.5 V - - - x

Xext 0.5  - - - x

Qb0 1.2e-12  - - - x

Eta 4.0  - - - x

Avl 50  - - - x

Efi 0.7  - - - x

Ihc 3.0e-3 A/m2 - - - x

Rcc 25.0 Ohms/m2 - - - x

Rcv 750.0 Ohms/m2 - - - x

Scrcv 1000.0 Ohms/m2 - - - x

Sfh 0.6  - - - x

Rbc 50.0 Ohms/m2 - - - x

Rbv 100.0 Ohms/m2 - - - x

Re 2.0 Ohms/m2 - - - x

Taune 3.0e-10 S - - - x

Mtau 1.18 S - - - x

Cje 2.5e-13 F/m2 - - - x

Vde 0.9 V - - - x

Pe 0.33  - - - x

Xcje 0.5  - - - x

Cjc 1.3e-13 F/m2 - - - x

Vdc 0.6 V - - - x

Pc 0.4  - - - x

Xp 0.2  - - - x

Mc 0.5  - - - x

Xcjc 0.1  - - - x

Tref 25 °C - - - x

Dta 0.0 °C - - - x

Vge 1.01 eV - - - x

Vgb 1.18 eV - - - x

Vgc 1.205 eV - - - x

Vgj 1.1 eV - - - x

Vi 0.04 V - - - x

Na 3.0e+17  - - - x

Er 2.0e-3  - - - x

Ab 1.35  - - - x

Aepi 2.15  - - - x

Aex 1.0  - - - x

Ac 0.4  - - - x

Kf 2.0e-16  - - - x

Kfn 2.0e-16  - - - x

Af 1.0  - - - x
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Iss 6.0e-16 A/m2 - - - x

Iks 5.0e-6 A/m2 - - - x

Cjs 1.0e-12 F/m2 - - - x

Vds 0.5 V - - - x

Ps 0.33  - - - x

Vgs 1.15 V - - - x

As 2.15  - - - x
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 MOS_Model9_Process: Philips MOS Model 9 (Process
Based)
The SPICE MOS9 and Spectre  mos902 model are translated to the ADS MOSFET
MOS_Model9_Process. For translation information on the MOSFET device, refer to MOSFET
Device (netlist).

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model nch nmos level=50 ler=1e-6 wer=10e-6 ...

 

 Example Spectre Command Line:

model mos9pch mos902 ler=0.93e-6 wer=20e-6 ...

 

 SPICE and Spectre Dialect and Netlist Syntax:

Spice2/3: Not available

PSpice: Not available

HSpice: .model mname NMOS|PMOS LEVEL=50 [param= value]*

Spectre model mname mos902 type=[p|n] [param= value]*

 

 ADS Netlist Syntax:

model mname MOSFET NMOS=[0|1] PMOS=[0|1] Type=2 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

All parameter names for this model are the same between HSpice and ADS except for the
addition of Type=2 to indicate the process level model. However, while the parameter
names are the same, most default values are different. Additionally, HSpice supports
different default values between the NMOS and PMOS implementations.
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The ADS defaults are from an earlier version of the Phillips model. This should not affect
the translation because the translator will fill in the proper HSpice defaults. Consult your
HSpice documentation for the HSpice defaults if needed. All defaults supplied by the
translator are from HSpice V99.2.

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).

ADS Default Unit Spectre

NMOS† yes  type n

PMOS no  type n

Type 2  

Ler 1e−4 m ler 2.5e−6 m

Wer 1e−4 m wer 25e−6 m

Lvar 0.0 m lvar 0.3e−6 m

Lap 0.0 m lap 0.1e−6 m

Wvar 0.0 m wvar 3e−6 m

Wot 0.0 m wot 1e−6 m

Tr 300.15 °C tr set by option °C
tref

Vtor 0.87505 V vtor 0.8 V

Stvto 0.0 V/K stvto 0.01 V/K

Slvto 0.0 V×m slvto 0.5e−6 V×m

Sl2vto 0.0 V×m2 x

Swvto 0.0 Vm swvto 5e−6 Vm

Kor 0.74368 √V kor 0.5 V

Slko 0.0 √(V×m) slko 1e−6 V×m

Swko 0.0 √V swko 10e−6 V×m

Kr 0.55237 √V kr 0.1 V

Slk 0.0 √(V×m) slk 0.5e−6 V×m

Swk 0.0 √(V×m) swk 5e−6 V×m

Phibr 0.65 V x

Vsbxr 0.63304 V vsbxr 0.9 V

Slvsbx 0.0 V×m slvsbx 0.5e−6 V×m

Swvsbx 0.0 V×m swvsbx 5e−6 V×m

Betaq 0.12069
e−3

A/V2 betaq 0.1e−3 A/V2

Etabet 0.0  etabet 0.5

Thelr 0.99507
e−1

1/V thelr 0.05 1/V

Stthelr 0.0 1/(V×K) stthelr 3e−3 1/(V×K)

Slthe1r 0.0 m/V slthelr 50e−9 m/V

Stlthe1 0.0 m/(V×K) stlthel 5e−9 m/(V×K)

Swthe1 0.0 m/V swthe1 1e−6 m/V

Wdog 0.0 m x

Fthe1 0.0  x

The2r 0.43225
e−1

√V the2r 17e−3 1/V

Stthe2r 0.0 √(V/K) stthe2r 0.1e−3 1/(V×K)

Slthe2r 0.0 m/√V slthe2r 5e−9 m/V

Stlthe2 0.0 m/√(V/K) stlthe2 0.5e−9 m/(V×K)

Swthe2 0.0 m/√V swthe2 0.1e−6 m/V

The3r 0.0 1/V the3r 37e−3 1/V
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Stthe3r 0.0 1/V/K stthe3r 0.1e−3 1/(V×K)

Slthe3r 0.0 m/V slthe3r 5e−9 m/V

Stlthe3 0.0 m/V/K
m/(V×K)?

stlthe3 0.5e−9 m/(V×K)

Swthe3 0.0 m/V swthe3 0.1e−6 m/V

Gam1r 0.38096
e−2

V(1-Etads) gam1r 40e−3 V(1-etads)

Slgam1 0.0 V(1-Etads)

×m
slgam1 0.1e−6 V(1-etads)

×m

Swgam1 0.0 V(1-Etads)

×m
swgam1 1e−6 V(1-etads)

×m

Etadsr 0.6  x

Alpr 0.1e−1  alpr 4e−3

Etaalp 0.0  etaalp 0.5

Slalp 0.0 m(Etaalp) slalp 0.14e−3 m(etaalp)

Swalp 0.0 m swalp 0.1e−6 m

Vpr 0.67876e1 V vpr 0.25 V

Gamoor 0.29702
e−4

 gamoor 1.1e−3

Slgamoo 0.0 m2 slgamoo 10e−15 m2

Etagamr 2.0  x

Mor 0.44  mor 0.3

Stmo 0.0 1/K stmo 0.01 1/K

Slmo 0.0 √m slmo 1.4e−3 √m

Etamr 2.0  x

Zet1r 2.0153  zet1r 0.7

Etazet 0.0  etazet 0.5

Slzet1 0.0 m(Etazet) slzet1 0.14e−6 m(etazet)

Vsbtr 0.61268e1 V vsbtr 99 V

Slvsbt 0.0 m×V slvsbt 10e−6 m×V

A1r 0.20348e2  a1r 22

Sta1 0.0 1/K sta1 0.1 1/K

Sla1 0.0 m Sla1 10e−6 m

Swa1 0.0 m swa1 0.1e−3 m

A2r 0.33932e2 V a2r 33 V

Sla2 0.0 m×V sla2 10e−6 m×V

Swa2 0.0 m×V swa2 0.1e−3 m×V

A3r 0.10078e1  a3r 0.6

Sla3 0.0 m sla3 1e−6 m

Swa3 0.0 m swa3 10e−6 m

Tox 1e−6 m tox 20e−9 m

Col 0.0 F/m col 50e−12 F/m

Ntr 0.0 J ntr 21e−21 J

Nfr 0.0 V2 nfr 16e−12 V2

Nfar 7.15e22 1/(V×m) -

Nfbr 2.16e7 1/(V×m2) -

Nfcr 0.0 1/V -

Vr 0.0 V -

Jsgbr 1e−14 A/m2 -

Jsdbr 1e−14 A/m2 -

Jsgsr 1e−14 A/m -

Jsdsr 1e−14 A/m -

Jsggr 1e−14 A/m -
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Jsdgr 1e−14 A/m -

Cjbr 0.0 F/m2 -

Cjsr 0.0 F/m -

Cjgr 0.0 F/m -

Vdbr 0.8 V -

Vdsr 0.8 V -

Vdgr 0.8 V -

Pb 0.5  -

Ps 0.5  -

Pg 0.5  -

Nb 1.0  -

Ns 1.0  -

Ng 1.0  -

Tnom  °C tnom set by option °C

-   dta 0.0 K

Trise 0.0 °C trise 0.0 K

 

 GaAsFET and JFET Models for SPICE

The following information describes how the various  GaAsFET models from SPICE are
translated to the corresponding ADS models.

All GaAsFET devices in SPICE reference a model by its instance name. GaAsFET models in
SPICE have a keyword

NMF | PMF for Spice3,
GASFET for PSpice and
NJF | PJF for HSpice.

PSpice and HSpice also use a  Level parameter to help identify the appropriate model to
select. ADS uses the  Idsmod parameter to identify the model to use. The SPICE Level is
used by the Netlist Translator to determine what value to set for Idsmod and which model
to place. Both the Level and Idsmod parameters are listed where available.

Spice3 MESFET Mapping Table displays Spice3 MESFET device and model information and
the corresponding device and model information for schematics and netlists in ADS.
 
 

 Spice3 MESFET Mapping Table

Format Device Model ADS Idsmod

Spice3 Netlist Zxxxxxxx NMF PMF -

ADS Schematic GaAsFET Statz Model-Statz (Raytheon) GaAsFET Model (netlist) Idsmod = 3

ADS Netlist - GaAs Idsmod = 3

PSpice GaAsFET Mapping Table displays the initial and translated devices, models and
Idsmod values for each of the individual formats listed for the PSpice GaAsFET. PSpice
level parameter values are also listed.
  

 PSpice GaAsFET Mapping Table
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PSpice
Level

Format Device Model ADS
Idsmod

All PSpice Netlist Bxxxxxxx GASFET -

Level = 1 ADS
Schematic

GaAsFET Advanced_Curtice2_Model:Advanced Curtice-Quadratic
GaAsFET

Idsmod =1

ADS Netlist - GaAs

Level = 2 ADS
Schematic

GaAsFET Statz_Model:Statz (Raytheon) GaAsFET Model Idsmod = 3

ADS Netlist - GaAs

Level = 3 ADS
Schematic

TOM TOM_Model:Triquint Scalable Nonlinear GaAsFET Model Idsmod = 7

ADS Netlist - GaAs

Level = 4 Not translated.

Level = 5 Not translated.

HSpice JFET & GaAsFET Mapping Table displays the device, model and Idsmod (where
used) for each of the individual formats listed for the HSpice JFET and GaASFET. The
HSpice level parameters and SAT parameters are also listed where appropriate.
  

 HSpice JFET & GaAsFET Mapping Table

HSpice
Level

Format Device Model ADS
Idsmod

All HSpice
Netlist

Jxxxxxxx NJF | PJF -

Level = 1 ADS
Schematic

JFET_NFET or
JFET_PFET

JFET_Model:Junction Field Effect Transistor Model -

ADS Netlist - JFET

Level = 2 Not translated.

Level = 3SAT
= 0

ADS
Schematic

GaAsFET Advanced_Curtice2_Model:Advanced Curtice-
Quadratic GaAsFET

Idsmod =1

ADS Netlist - GaAs

Level = 3SAT
= 2

ADS
Schematic

GaAsFET Statz_Model:Statz (Raytheon) GaAsFET Model Idsmod =
3

ADS Netlist - GaAs

Level = 3SAT
= 1,3

Not translated.

Note
HSpice uses the additional SAT (saturation factor) parameter to determine the appropriate model. The
combination of the Level and SAT parameters determine the model used.

 

file:chs/pdf_print_view/netlist/Advanced Curtice2 Model-Advanced Curtice-Quadratic GaAsFET#AdvCirModel
file:chs/pdf_print_view/netlist/Advanced Curtice2 Model-Advanced Curtice-Quadratic GaAsFET#AdvCirModel
file:chs/pdf_print_view/netlist/Statz Model-Statz (Raytheon) GaAsFET Model#1143871
file:chs/pdf_print_view/netlist/TOM Model-Triquint Scalable Nonlinear GaAsFET Model#1144228
file:chs/pdf_print_view/netlist/JFET Model-Junction Field Effect Transistor Model#1144500
file:chs/pdf_print_view/netlist/Advanced Curtice2 Model-Advanced Curtice-Quadratic GaAsFET#AdvCirModel
file:chs/pdf_print_view/netlist/Advanced Curtice2 Model-Advanced Curtice-Quadratic GaAsFET#AdvCirModel
file:chs/pdf_print_view/netlist/Statz Model-Statz (Raytheon) GaAsFET Model#1143871
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 R_Model:Resistor Model
The  SPICE R and Spectre resistor models are translated to the ADS R_Model. For
translation information on the resistor device, refer to the Rxxxxxxx (netlist) for SPICE
and the Resistor Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model Rmodel1 r RSH=0.0

 

 Example Spectre Command Line:

model resmod resistor rsh=150 l=2u w=2u etch=0.05u tc1=0.1 tnom=27 kf=1

 

 SPICE and Spectre Dialect and Netlist Syntax:

Spice2/3: .model mname r [param= value]*

PSpice: .model mname res [param= value]*

HSpice: .model mname r [param= value]*

Spectre: model mname resistor [param= value]*

 

 ADS Netlist Syntax:

model mname R_Model [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
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ADS Default Unit Spice2/3 PSpice HSpice Spectre

R 0 ohms - x x r infinity ohms

Rsh 0.0 ohms/sq x - x rsh infinity ohms/sq

Length 0.0 m - - x l infinity m

Width 0.0 m DEFW=1e-6 - x w 1e-6 m

Narrow 0.0 m x - - -

Tnom 25 °C 27 °C 27 °C x tnom set by options °C

TC1 0.0 1/°C x (0°C-1) x tc1 0.0 1/°C

TC2 0.0 1/°C2 x (0°C-1) x tc2 0.0 1/°C2

wPmax infinite W - - - -

wImax infinite A - - - -

Trise 0.0 °C - - - trise 0.0°C

Scale 1.0  - - - scaler 1.0

Dw 0.0 m - - x etch 0.0 m

Dl 0.0 m - - x etchl 0.0 m

Kf 0.0  - - - kf 0.0

Af 2.0  - - - af 2.0

Wdexp 0.0  - - - wdexp 1.0

Ldexp 0.0  - - - ldexp 1.0

Weexp 0.0  - - - weexp 0.0

Leexp 0.0  - - - leexp 0.0

Fexp 1.0  - - - fexp 1.0

Coeffs list(0,0,...) 1/V, 1/V2, ... - - - coeffs [0 0 ...]

 

 SPICE Comments:

When the referenced model is not present in the netlist, the netlist translator fails to
recognize the resistor model in the following syntax:
r1 1 2 rmodel
The translator assumes that it is a variable name for the resistor value. To correct your
imported schematic, manually move the model name to the parameter Model. To correct
the ADS Netlist, use the following netlist syntax:

rmodel:r1 1 2 \[param=value\]\*

To prevent the problem, ensure that the netlist translator has access to a model
statement so it can verify that "rmodel" is a model. This can be a dummy statement
without parameters such as the following:

.model rmodel R

or a .INC reference to an include file with the model available.
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 Statz_Model:Statz (Raytheon) GaAsFET Model
The PSpice Level 2 GASFET and HSpice Level 3, SAT2 JFET or MESFET models are
translated to the ADS  Statz_Model. For translation information on the GaAsFET device,
refer to Zxxxxxxx (netlist). For translation information on the JFET device, refer to JFET
Device (netlist).

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

Spice2/3: .model Zmodel NMF VTO=2.- BETA=-1.0e-3...

PSpice: .model GNOM GASFET LEVEL=2 [param=value]...

HSpice: .model Jmodel NJF LEVEL=3 SAT=2 CAPOP=1...

 

 SPICE Dialect and Netlist Syntax:

Spice2/3: .model mname NMF|PMF [param= value]*

PSpice: .model mname GASFET LEVEL=2 [param= value]*

HSpice: .model mname NJF|PJF LEVEL=3 SAT=2 [param= value]*

 

 ADS Netlist Syntax:

model mname GaAs NFET=[0|1] PFET=[0|1] Idsmod=3 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
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ADS Default Unit Spice2/3 PSpice HSpice

Idsmod 3  - Level=2 Level=3, SAT=2

Vto −2 V x -2.5 x

Beta 1e-4 A/V2 x 0.1 x

Lambda 0.0 1/V x x x

Alpha 2.0 1/V x x x

B 0.3 1/V x x -

Vbi 0.85 V - 1.0 1.0

Tau 0.0 sec - x -

Betatce 0.0 %/°C - x x

Cgs 0.0 F x x x

Cgd 0.0 F x x x

Vmax 0.5 V - x -

Fc 0.5  x x x

Rd 0.0 ohms x x x

Rg 0.0 ohms - x x

Rs 0.0 ohms x x x

Cds 0 F - x -

Is 1e-14 A - x x

Xti 3.0  - 0.0 0.0

N 1  - x x

Eg 1.11 eV - x 1.16

Vtotc 0.0 V/°C - - TVC
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 STBJT_Model: STBJT Model
The Spectre bjtst model is translated to the ADS NPN or PNP STBJT Model. For translation
information on the BJT device, refer to BJT Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example Spectre Command Line:

model \_stj1 bjtst type=npn is=1e-16 isn=1e-12 ...

 

 Spectre Netlist Syntax:

Spectre: model mname bjtst type= [ npn | pnp ] [param= value]*

 

 Example ADS Command Line:

model stj1\_bjtst STBJT Af=1 NPN=yes Is=1e-16 Isn=1e-12 ...

 

 ADS Netlist Syntax:

model mname STBJT NPN= [ 0 | 1 ] PNP= [ 0 | 1 ] [param= value]*

 

 ADS Schematic Symbol:

ADS Default Unit Spectre

Type 1  x

Tmeas 25.0 °C x

Is 1.0e-16 A x

Isn Is A x

Bf 100.0  x

Nf 1.0  x

Br 1.0  x

Nr 1.0  x

Isf Is/Bf A x

Nbf Nf  x

Isr Isn/Br A x

Nbr Nr  x

Ise 0.0 A x
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Ne 2.0  x

Isc 0.0 A x

Nc 1.5  x

Vaf infinity V x

Var infinity V x

Enp 2.0  x

Rp 1.0e-3  x

Rw 0  x

Vjj 0.8 V x

Vrp 1.0e-9 V x

Bvc infinity V x

Mf 0.0  x

Fa 0.95  x

Avc 1.0  x

Bve infinity V x

Mr 0.0  x

Fb 0.95 Hertz x

Ave 1.0  x

Rb 0.0 Ohm x

Irb infinity A x

Rbm 0 Ohm x

Re 0.0 Ohm x

Rc 0.0 Ohm x

Rcs 0.0 Ohm x

Cje 0.0 F x

Vje 0.75 V x

Mje 0.33  x

Fc 0.5  x

Cjc 0.0 F x

Vjc 0.75 V x

Mjc 0.33  x

Xjbc 1.0  x

Cjs 0.0 F x

Vjs 0.75 V x

Mjs 0.33  x

Xjbs 1.0  x

Vert 0  x

Subsn 0  x

Tf 0.0 S x

Xtf 0.0  x

Vtf infinity V x

Itf infinity A x

Ptf 0.0 Deg. x

Tfcc 0  x

Tr 0.0 S x

Kf 0.0  x

Af 1.0  x

Eg 1.11 V x

Xti 3.0  x

Xtb 0.0  x

Trb1 0.0 deg- Kelvin x

Trb2 0.0  x

Trbm1 0.0  x
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Trbm2 0.0  x

Tre1 0.0 deg- Kelvin x

Tre2 0.0  x

Trc1 0.0 deg- Kelvin x

Trc2 0.0  x

Trcs1 0.0 deg- Kelvin x

Trcs2 0.0  x

Ikf infinity A x

Ikr infinity A x

Gmin 1e-12  x

 

 MOSFET Models

The following information describes how the various  MOSFET models from SPICE and
Spectre are translated to the corresponding ADS models.

 

 SPICE Models

All Mosfet devices in SPICE reference a model by its instance name. Each Mosfet model in
SPICE has a keyword NMOS or PMOS, as well as a Level parameter.
The NMOS/PMOS keyword is used to determine what device to place in the schematic,
MOSFET_NMOS or MOSFET_PMOS. The  Level is used to determine which model is placed
and what value is set for  Idsmod .
In the ADS netlist, the model is always called MOSFET, with the appropriate keywords
NMOS and PMOS set to [0|1], and the parameter Idsmod set as specified in SPICE Level
Parameters Mapping Table (MOSFET).

The only exception to this is the Mosfet device which refers to an HSpice Level 50 model,
the Phillips MOS9 model. In this case, the device placed in the schematic will be
MM9_NMOS or MM9_PMOS and the model will be MOS_Model9_Process. The netlist
component is called MOS9. For both the MM9_NMOS and the MM9_PMOS, the translator
sets the parameter Type=2 to indicate that it is a process-based model.

Spice2/3
Level

PSpice
Level

HSpice
Level

ADS Schematic
Model

ADS Netlist
Idsmod

ADS BSIM3 Version

1 1 1 LEVEL1_Model 1  

2 2 2 LEVEL2_Model 2  

3 3 3 LEVEL3_Model 3  

4 4 13, 28 BSIM1_Model 4  

5 - 39 BSIM2_Model 5  

 7  BSIM3_Model 8 3.1

  49, 53 BSIM3_Model 8 legal BSIM3 Versions
are:
3.0, 3.1, 3.2, 3.21, and
3.22

  

 Dependence Parameters

There are certain model parameters listed in the BSIM Models that reference additional
parameters. These additional parameters are denoted in parenthesis using the letters L, W
and/or P. As an example, the Dwg (L,W, P) parameter in the BSIM3 Model defines four
separate parameters;

Dwg: Coefficient of Weff's gate dependence.1.
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LDwg: Length dependence of Dwg.2.
WDwg: Width dependence of Dwg.3.
PDwg: Cross dependence of Dwg.4.

Each letter indicates a sensitivity parameter that exists in HSpice and ADS. These
parameters are length(L), Width(W) and Cross(P). Refer to your HSpice and ADS
component documentation for details.

 

 HSpice Automatic Model Selection

Automatic Model Selection, also known as  binning , is an HSpice feature that allows for
the definition of a library of Mosfets over a range of lengths and widths. The following
netlist fragment is an example of automatic model selection in HSpice. It is currently used
only for Mosfets. Notice that the model name is a root name plus an extension, separated
by a period (that is: NCHAN.2). Also note the special model parameters, LMIN, LMAX,
WMIN and WMAX. They are used only for automatic model selection.
.OPTION WL
M1 1 2 3 4 NCHAN 10 2
M2 1 2 3 4 NCHAN 10 3
$$$$$$$ FOR CHANNEL LENGTH SELECTION
.MODEL NCHAN.2 NMOS LEVEL=2 VTO=2.0 UO=800 TOX=500
+NSUB=1E15
+ RD=10 RS=10 CAPOP=5
+ LMIN=1 LMAX=2.5 WMIN=2 WMAX=15
.MODEL NCHAN.3 NMOS LEVEL=2 VTO=2.2 UO=800 TOX=500
+NSUB=1E15
+ RD=10 RS=10 CAPOP=5
+ LMIN=2.5 LMAX=3.5 WMIN=2 WMAX=15
The ADS equivalent of this functionality is provided by a component called  BinModel .
Since ADS component names cannot include a period, the models are renamed nchanx2
and nchanx3. Then a BinModel component is placed, which lists the models by name, as
well as listing the special length and width parameter ranges, as defined by LMIN, LMAX,
WMIN and WMAX. The name of the BinModel component is the same as the root name of
the models, in this case nchan. The ranges of all models with the same root name will be
recorded on one BinModel component as shown in The ADS BinModel Component.
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 The ADS BinModel Component

Also note that the Mosfet devices that are placed in the schematic do not refer to the
Mosfet models as they normally would. Instead they refer to the BinModel. During
simulation, the length and width specified on the device are sent to the BinModel and
checked against the ranges specified for each model, to determine which model to use. If
the length and width on the device fall within the range of the length and width on more
than one model, the first one that matches is used.

 

 Spectre Models

All Mosfet devices in Spectre reference a model by its instance name. Each Mosfet model
in Spectre has a name value pair type= [ n | p ].

The type value pair keyword is used to determine what device to place in the schematic,
MOSFET_NMOS or MOSFET_PMOS. The  Level is used to determine which model is placed
and what value is set for  Idsmod.

In the ADS netlist, the model is always called MOSFET, with the appropriate keywords
NMOS and PMOS set to [0|1], and the parameter Idsmod set as specified in Spectre Level
Parameters Mapping (MOSFET).

The only exception to this is the Mosfet device which refers to the Phillips MOS902 model.
In this case, the device placed in the schematic will be MM9_NMOS or MM9_PMOS and the
model will be MOS_Model9_Process. The netlist component is called MOS9. For both the
MM9_NMOS and the MM9_PMOS, the translator sets the parameter Type=2 to indicate
that it is a process-based model.

Spectre Model Supported ADS Schematic Model ADS Netlist Idsmod ADS BSIM3 Version

mos0 NO Not Translated   

mos1 YES LEVEL1_Model 1  

mos15 NO Not Translated  

mos2 YES LEVEL 2_Model 2  

mos3 YES LEVEL3_Model 3  

mos30 NO Not Translated   

mos3002 NO Not Translated   

mos705 NO Not Translated   

mos902 YES MOS_Model9_Process N/A  

mos903 NO Not Translated   

bsim3v3 YES BSIM3_Model 8 3.22

b3soi-pd YES BSIM3SOI_Model   

  

 Dependence Parameters

There are certain model parameters listed in the BSIM Models that reference additional
parameters. These additional parameters are denoted in parenthesis using the letters L, W
and/or P. As an example, the Dwg (L,W, P) parameter in the BSIM3 Model defines four
separate parameters;

Dwg: Coefficient of Weff's gate dependence.1.
LDwg: Length dependence of Dwg.2.
WDwg: Width dependence of Dwg.3.
PDwg: Cross dependence of Dwg.4.

Each letter indicates a sensitivity parameter that exists in Spectre and ADS. These
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parameters are length(L), Width(W) and Cross(P). Refer to your Spectre and ADS
component documentation for details.

The following MOSFET models are translated in ADS:

LEVEL1_Model:LEVEL 1 MOSFET Model (netlist)

LEVEL2_Model:LEVEL 2 MOSFET Model (netlist)

LEVEL3_Model:LEVEL 3 MOSFET Model (netlist)

BSIM1_Model:BSIM1 MOSFET Model (netlist)

BSIM2_Model:BSIM2 MOSFET Model (netlist)

BSIM3_Model:BSIM3 MOSFET Model (netlist)

BSIM4_Model:BSIM4 MOSFET Model (netlist)

BSIM3SOI_Model: BSIM3SOI_Model (netlist)

MOS_Model9_Process: Philips MOS Model 9 (Process Based) (netlist)

 

 Binning Process

In order for ADS to translate the binning process, each binning definition is translated as a
separate model.

 

 Binning Example

The following is an example Spectre binning statement for a bsim model:

model ModelName ModelType {

     1: <model parameters> lmin=2 lmax=4 wmin=1 wmax=2

     2: <model parameters> lmin=1 lmax=2 wmin=2 wmax=4

     3: <model parameters> lmin=2 lmax=4 wmin=4 wmax=6

  }

The Netlist Translator separates each binning reference into an ADS model. The example
would result in three models with the names ModelName_1, ModelName_2, and
ModelName_3. The models are then tied together by creating an ADS "BinModel"
component and configuring the appropriate min/max values.
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 TOM_Model:Triquint Scalable Nonlinear GaAsFET
Model
The PSpice Level 3 GASFET model is translated to the ADS  TOM_Model. For translation
information on the GaAsFET device, refer to Bxxxxxxx (netlist).

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model Bmodel GASFET level=3

 

 SPICE Dialect and Netlist Syntax:

Spice2/3: Does not exist

PSpice: .model mname GASFET LEVEL=3 [param= value]*

HSpice: Does not exist

 

 ADS Netlist Syntax:

model mname TOM_Model NFET=[0|1] PFET=[0|1] Idsmod=7 [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
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ADS Default Unit PSpice

Idsmod 7  Level=3

Vto −2 V -2.5 V

Alpha 2.0 1/V x

Beta 1e-4 A/V2 0.1

Q 2.0  x

Tau 0.0 sec x

Vtotc 0.0 V/°C x

Betatce 0.0 %/°C x

Cgs 0.0 F x

Cgd 0.0 F x

Vbi 0.85 V 1.0

Vmax - V 0.5

Fc 0.5  x

M 0.5  x

Is 1e-14 A x

N 1.0  x

Eg 1.11 eV x

Xti 3.0  0.0

Rg 0.0 ohms x

Rd 0.0 ohms x

Rs 0.0 ohms x

Trg1 0 1/°C x

Trd1 0 1/°C x

Trs1 0 1/°C x

Cds 0.0 F x
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 VBIC_Model:VBIC Model
The HSpice  VBIC (Vertical Bipolar Inter-Company) and Spectre  vbic models are
translated to the ADS VBIC_Model. For translation information on the BJT device, refer to
Qxxxxxxx (netlist) for SPICE or BJT Device (netlist) for Spectre.

For more information on the ADS model, place the model in a schematic and choose Edit
> Component > Edit Component Parameters to view the model parameters. You can
also click Help in the component editor dialog box for additional information.

 

 Example SPICE Command Line:

.model Qmodel1 NPN Level=4

 

 Example Spectre Command Line:

model vbic_mod vbic type=npn

 

 SPICE and Spectre Dialect and Netlist Syntax:

Spice2/3: Does not exist

PSpice: Does not exist

HSpice: .model mname NPN|PNP Level=4 [param= value]*

Spectre: model mname vbic type= [ npn|pnp ] [param= value]*

 

 ADS Netlist Syntax:

model mname VBIC NPN=[0|1] PNP=[0|1] [param= value]*

 

 ADS Schematic Symbol:

 

 Model Parameters:

For information on parameter format, refer to Using Parameter Mapping Tables to
Understand a Translation (netlist).
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 VBIC_Model Parameter Mapping

ADS Default Unit Spice2/3 PSpice HSpice Spectre

NPN YES  NPN NPN NPN type npn

PNP NO  NPN NPN NPN type npn

- - - - - Level=4 -

Tnom 25 °C - - TREF (27 °C) tnom set by options °C

Trise 0.0 °C - - - trise 0.0°C

Rcx †, †† 0.0 ohms - - 1e-1 x

Rci †, †† 0.0 ohms - - 1e-1 x

Vo † 0.0 V - - V0 x

Gamm † 0.0  - - x gamm 0.0 V

Hrcf 1.0  - - x x

Rbx †, †† 0.0 ohms - - 1e-1 x

Rbi †, †† 0.0 ohms - - 1e-1 x

Re †, †† 0.0 ohms - - 1e-1 x

Rs †, †† 0.0 ohms - - 1e-1 x

Rbp †, †† 0.0 ohms - - 1e-1 x

Is †, ††† 1e-16 A - - x is 10e-16 A

Nf † 1.0  - - x x

Nr † 1.0  - - x x

Fc 0.9  - - x x

Cbeo ††† 0.0 F - - x x

Cje †, ††† 0.0 F - - x x

Pe † 0.75  - - x pe 0.75 V

Me 0.33  - - x x

Aje −0.5  - - 1e-1 x

Cbco ††† 0.0 F - - CBC0 x

Cjc †, ††† 0.0 F - - x x

Qco ††† 0.0 C - - QC0 x

Cjep †, ††† 0.0 F - - x x

Pc † 0.75  - - x x

Mc 0.33  - - x x

Ajc −0.5  - - x x

Cjcp †, ††† 0.0 F - - x x

Ps † 0.75  - - x x

Ms 0.33  - - x x

Ajs −0.5  - - x x

Ibei †, ††† 1e-18 A - - x x

Wbe 1.0  - - x x

Nei 1.0  - - x x

Iben †,††† 0.0 A - - 1e-15 x

Nen 2.0  - - x x

Ibci †, ††† 1e-16 A - - x x

Nci 1.0  - - x x

Ibcn †, ††† 0.0 A - - 1e-15 x

Ncn 2.0  - - x x

Isp †, ††† 0.0 A - - 1e-16 A x
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Wsp 1.0  - - x x

Nfp 1.0  - - x x

Ibeip †, ††† 0.0 A - - x x

Ibenp †, ††† 0.0 A - - x x

Ibcip †, ††† 0.0 A - - x x

Ncip 1.0  - - x x

Ibcnp †, ††† 0.0 A - - x x

Avc1 0.0 1/V - - x avc1 0.0

Avc2 † 0.0 1/V - - x avc2 0.0

Ncnp 2.0  - - x x

Vef 0.0 (same as infinity) V - - x vef infinity V

Ver 0.0 (same as infinity) V - - x ver infinity V

Ikf ††† 0.0 (same as infinity) A - - 2e-3 ikf infinity A

Ikr ††† 0.0 (same as infinity) A - - 2e-4 ikr infinity A

Ikp ††† 0.0 (same as infinity) A - - 2e-4 ikp infinity A

Tf 0.0 sec - - 1e-11 x

Qtf 0.0  - - x x

Xtf 0.0  - - x x

Vtf 0.0  - - x x

Itf 0.0  - - 1e-3 x

Tr 0.0 sec - - 1e-11 x

Td 0.0 sec - - x x

Kfn 0.0  - - x x

Afn 1.0  - - x x

Bfn 1.0  - - x x

Xre 0.0  - - 1 x

Xrb 0.0  - - 1 x

Xrc 0.0  - - 1 x

Xrs 0.0  - - 1 x

Xvo 0.0  - - XV0 x

Ea 1.12 eV - - x ea 1.12 V

Eaie 1.12 eV - - x eaie 1.12 V

Eaic 1.12 eV - - x eaic 1.12 V

Eais 1.12 eV - - x eais 1.12 V

Eane 1.12 eV - - x eane 1.12 V

Eanc 1.12 eV - - x eanc 1.12 V

Eans 1.12 eV - - x eans 1.12 V

Xis 3.0  - - x xis 3.0 V

Xii 3.0  - - x xii 3.0 V

Xin 3.0  - - x xin 3.0 V

Tnf 0.0  - - 0 1/K tnf 0.0 V

Tavc 0.0  - - 0 1/K tavc 0.0 V

Rth †† 0.0 ohms - - 0 K/W x

Cth ††† 0.0 F - - 0 J/K x

Imax 1.0 A - - - x

wVsubfwd infinity V - - - vsubfwd 0.2 V

wBvsub infinity V - - - bvsub infinity V

wBvbe infinity V - - - bvbe infinity V
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wBvbc infinity V - - - bvbc infinity V

wVbcfwd infinity V - - - vbcfwd 0.2 V

wIcmax infinity A - - - imax1 imax A

† This parameter value varies with temperature based on model Tnom and device Temp.
†† This parameter value scales inversely with the device parameter Scale.
††† This parameter value scales directly with the device parameter Scale.
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 Translating Commands and Functions
This section provides information on translating individual  commands, functions, and the
binning process from Spectre and SPICE to Advanced Design System.

 

 Commands, Functions, and Binning for Spectre

The following table displays a list of commands and functions that are supported by the
Netlist Translator.

Command / Function Description

ends End of Subcircuit

check Ignored by ADS

include Include File

info Ignored by ADS

library Library File

parameters Parameter

subckt, ends Subcircuit

Other Functions Function Mapping in the spectrefunc.rul File

If the translator reads a command that is not recognized or supported, the translation log
file will include a warning such as:

WARNING: Skipping unsupported statement.ALTER, line 10.

 

 alter and altergroup

The  ADS simulator does not have a comparable command. Translation will terminate
when this line is found. Everything before it will be translated. Everything after it will be
ignored.

 

 check

All check statements will be ignored by the Netlist Translator.

 

 ends

See subckt, ends.

 

 include

This  line identifies another Spectre file that needs to be read by the translator. The
contents are integrated directly into the translated design as appropriate.

 Spectre Netlist Syntax:

include file_name

 ADS Netlist Syntax:
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There is no ADS syntax since the referenced file is read and the contents are processed as
part of the parent file.

 ADS Schematic Symbol:

There is no ADS symbol since the referenced file is read and the contents are processed as
part of the parent file.

 Parameters:

name = Legal file name including file extension.

 

 Comments:

The include statement is used in Spectre to insert the contents of another file. In ADS,
separate include statements are not created.
Instead, the collection of files are processed as if they were one long file. All circuits
defined in an include statement are read by the translator,
but a schematic will only be created for those that are referenced in the design hierarchy.

To force creation of all schematics for all subcircuits in an include file, import the include
file separately. Note that the top line of an include file may not be a comment line, so to
read it as a stand-alone file, insert a comment line or a blank line as line 1, if the existing
line 1 has information that needs to be processed. Alternately, you may uncheck the box
in the import dialog options page to indicate that the first line is not a comment (refer to
Setting the Import Options (netlist)), or use the command line argument -l (refer to
Executing the Nettrans Command (netlist)) to deselect the First line is a comment option.

For tips on debugging the translation of a large set of nested include files, refer to
Troubleshooting (connectmui).

 

 info

All info statements will be ignored by the Netlist Translator.

 

 library

This  line indicates that another Spectre file is to be read by the translator. The contents
are integrated directly into the translated design as appropriate.

 Spectre Netlist Syntax:

library library_name
section section_name_
<statements>
endsection [section_name]
section [another_name]
<statements>
endsection [another_name]
library library_name

 ADS Netlist Syntax:

No ADS netlist syntax because the contents are just read and processed like the
include file.
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 ADS Schematic Symbol:

No ADS Schematic Symbol because the contents are just read and processed
like the include file.

 Parameters:

entryname = Name of library within specified file
filename = Legal file name including extension.
dirpath = Optional path to library file. There is no space between dirpath and
filename when dirpath is given.

 

 Comments:

The library statement is used in Spectre to insert the contents of another file. In ADS,
separate include statements are not created. Instead, the collection of files are processed
as if they were one long file. All circuits defined in a library statement are read by the
translator, but a schematic will only be created for those that are referenced in the design
hierarchy.

To force creation of all schematics for all subcircuits in a library file, import the library file
separately. Note that the top line of a library file may not be a comment line, so to read it
as a stand-alone file, insert a comment line or a blank line as line 1, if the existing line 1
has information that needs to be processed. Alternately, you may uncheck the box in the
import dialog options page to indicate that the first line is not a comment (refer to Setting
the Import Options (netlist)), or use the command line argument -l (refer to Executing the
Nettrans Command (netlist)) to deselect the First line is a comment option.

For a description of the -models command, refer to Executing the Nettrans Command
(netlist). This command can be used to read a model file and create a separate ADS netlist
file for each model.

Not supported:

The ADS translator does not automatically read nom.lib and it does not use the search
path. All libraries must be specified explicitly with a full path if the library file is not in the
working directory. If the file nom.lib is needed, an include statement should be added to
the main source file to instruct the translator to read that file.

The .OPTIONS SEARCH statement is not supported by the translator. All library paths
must be explicitly specified.

 

 parameters

This line is translated as a name=value  parameter.

 Spectre Syntax:

parameter name=value

 ADS Netlist Syntax:

name=value

 ADS Schematic Symbol:  
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 Parameters:

name = Parameter name
value = Parameter value

  

 subckt, ends

This line is translated as a parametric  subnetwork.

Note
The keyword inline is optional in the syntax below. If the keyword exists in the Spectre input, it will be
translated in the ADS netlist.

inline subckt subname ( node1...nodeN )
parameters name=value
end subname

inline define subname ( n1... )
parameters name=value
end subname

 ADS Schematic Symbol:  

 Parameters:

subname = Subnetwork name
n1* = Node names
name = Parameter name
value = Parameter default value
ends = Spectre subcircuit definitions must end with an ends statement.

 Comments:  

For more information on defining subcircuit parameters, refer to Using the NetlistInclude
Component (netlist).

 

 Other Functions

Functions such as log10(x) and ln(x) are mapped in the spectrefunc.rul file. Any function
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that requires mapping into the equivalent ADS function is entered into this file. For more
information about function mapping, see User Defined Models and Parameter Mapping
Rules (netlist).

 

 Commands and Functions for SPICE

Command / Function Description

.ALIASES and .ENDALIASES Aliases and Endaliases

alter and altergroup Alternate

.END End of Circuit

.ENDL End of Library

.ENDS or .EOM End of Subcircuit

.IC Initial Bias Point Condition

.INC[LUDE] Include File

.LIB, .ENDLIB Library File

.MACRO, .ENDM Macro

.MODEL Model

.NODESET Set the Approximate Node Voltage for the Bias Point

.NOISE Noise Analysis

.OP Bias Point

parameters Analysis Options

parameters Parameter

subckt, ends Subcircuit

.TEMP Temperature

.TRAN Transient Analysis

.FUNC User-defined function (PSpice only)

If the translator reads a command that is not recognized or supported, the translation log
file will include a warning such as:

WARNING: Skipping unsupported statement.ALTER, line 10.

 

 .ALIASES and .ENDALIASES

This command block is recognized but not translated. Everything between the  .ALIASES
and .ENDALIASES lines is ignored.

 

 .ALTER

The  ADS simulator does not have a comparable command. Translation will terminate
when this line is found. Everything before it will be translated. Everything after it will be
ignored.

 

 .DCVOLT

The  .DCVOLT statement is processed exactly the same as a .IC statement. For more
information, refer to .IC.
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 .END

All processing stops when a .END statement is encountered. Comments and any other
information following the .END statement are discarded.

 

 .ENDL

See .LIB, .ENDLIB.

 

 .ENDS or .EOM

See subckt, ends or .MACRO, .ENDM.

 

 .IC

This line is translated as an  initial condition control element. It sets the initial conditions
for a transient simulation.

 Example SPICE Command Line:

.IC V(11)=5 V(4)=-5 V(2)=2.2

 SPICE Netlist Syntax:

.ic v(node)=val[v(node)=val ]*]

 ADS Netlist Syntax:

InitCond:instanceNameNodeName[1]=nodeV[1]=val
NodeName[2]=node V[2]=val

 

 ADS Schematic Symbol:

 Parameters:

node = Node number
val = Voltage at the specified node.
instanceName = Unique component name. This is not provided by SPICE so it is
automatically generated by the translator.
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 Comments:

The following PSpice syntax variations are not translated:

.IC V(inPlus,inMinus)=1e-3

.IC I(L1)=2uAmp

 

 .INC[LUDE]

This  line identifies another SPICE file that needs to be read by the translator. The
contents are integrated directly into the translated design as appropriate.

 Example SPICE Command Line:

.INC vars.inc

 SPICE Netlist Syntax:

.INC name

 ADS Netlist Syntax:

There is no ADS syntax since the referenced file is read and the contents are
processed as part of the parent file.

 ADS Schematic Symbol:

There is no ADS symbol since the referenced file is read and the contents are
processed as part of the parent file.

 Parameters

name = Legal file name including file extension.

 Comments:  

The .INC statement is used in SPICE to insert the contents of another file. In ADS,
separate include statements are not created. Instead, the collection of files are processed
as if they were one long file. All circuits defined in a .INC statement are read by the
translator, but a schematic will only be created for those that are referenced in the design
hierarchy.

To force creation of all schematics for all subcircuits in an include file, import the include
file separately. Note that the top line of an include file may not be a comment line, so to
read it as a stand-alone file, insert a comment line or a blank line as line 1, if the existing
line 1 has information that needs to be processed. Alternately, you may uncheck the box
in the import dialog options page to indicate that the first line is not a comment (refer to
Setting the Import Options (netlist)), or use the command line argument -l (refer to
Executing the Nettrans Command (netlist)) to deselect the First line is a comment option.

For tips on debugging the translation of a large set of nested include files, refer to
Troubleshooting (connectmui).

 

 .LIB, .ENDLIB

This  line indicates that another SPICE file is to be read by the translator. The contents are
integrated directly into the translated design as appropriate.

 Example SPICE Command Line:
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PSpice: .LIB linear.lib
HSpice library call: .LIB 'file1' mos8
HSpice library definition: .LIB mos8

 SPICE Dialect and Netlist Syntax

Spice2/3: Not supported
PSpice: .LIB name
HSpice library call: .LIB '<dirpath>filename' entryname
HSpice library definition: .LIB entryname

 ADS Netlist Syntax:

No ADS netlist syntax because the contents are just read and processed like the
include file.

 ADS Schematic Symbol:

No ADS Schematic Symbol because the contents are just read and processed
like the include file.

 Parameters:

entryname = Name of library within specified file
filename = Legal file name including extension.
dirpath = Optional path to library file. There is no space between dirpath and
filename when dirpath is given.

 

 Comments:

The .LIB statement is used in SPICE to insert the contents of another file. In ADS,
separate include statements are not created. Instead, the collection of files are processed
as if they were one long file. All circuits defined in a .LIB statement are read by the
translator, but a schematic will only be created for those that are referenced in the design
hierarchy.

To force creation of all schematics for all subcircuits in a library file, import the library file
separately. Note that the top line of a library file may not be a comment line, so to read it
as a stand-alone file, insert a comment line or a blank line as line 1, if the existing line 1
has information that needs to be processed. Alternately, you may uncheck the box in the
import dialog options page to indicate that the first line is not a comment (refer to Setting
the Import Options (netlist)), or use the command line argument -l (refer to Executing the
Nettrans Command (netlist)) to deselect the First line is a comment option.

For a description of the -models command, refer to Executing the Nettrans Command
(netlist). This command can be used to read an HSpice model file and create a separate
ADS netlist file for each model.

Not supported:

PSpice has a master library file nom.lib that is used by default in PSpice if no library is
specified. It also has a LIBPATH variable in a file called msim.ini. This search path is used
in PSpice if the library is not in the working directory. The ADS translator does not
automatically read nom.lib and it does not use the search path. All libraries must be
specified explicitly with a full path if the library file is not in the working directory. If the
file nom.lib is needed, an include statement should be added to the main SPICE file to
instruct the translator to read that file.

The HSpice .OPTIONS SEARCH statement is not supported by the translator. All library
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paths must be explicitly specified.

 

 .MACRO, .ENDM

The  .MACRO statement is processed exactly the same as a .SUBCKT statement. For more
information, refer to subckt, ends.

 

 .MODEL

A .MODEL statement is translated to a corresponding model if a compatible model exists
in ADS. For translation details of specific models, refer to Translating a Model (netlist).

 Example SPICE Command Line:

.MODEL dmodel D is=1e-14

 SPICE Netlist Syntax:

.model name type [param = value* ]

 ADS Netlist Syntax:

model name type [param = value* ]

 ADS Schematic Symbol:  

 .NODESET  

This line is translated as a  NodeSet control element.

 Example SPICE Command Line:

.NODESET V(12)=4.5 V(4)=2.23

 SPICE Netlist Syntax:

.nodeset v( node )=val[v(node)=val ]*

 ADS Netlist Syntax:

NodeSet:instanceNameNodeName[1]=nodeV[1]=val
[NodeName[2]=node V[2]=val]

 

 ADS Schematic Symbol:
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 Parameters:

node = Node name
val = Voltage at the specified node.
instanceName = Unique component name. This is not provided by SPICE so it is
automatically generated by the translator.

Unsupported syntax:
HSpice .NODESET V(5:SETX)=3.5V

 .NOISE  

This line is translated as a  noise stimulus control element.

 Example SPICE Command Line:

.NOISE V(\5) VIN DEC 10 1KHz 100MHz

 SPICE Netlist Syntax:

Spice2/3: .NOISE v( out )<,ref> srcname [dec | oct | lin] numpoints fstart
fstop [ pts_out ]
PSpice: .NOISE v(out, <,ref>) name=value
HSpice: .NOISE v(out) srcname numpoints

 ADS Netlist Syntax:

AC:cmp99 SweepVar="freq" SweepPlan="freqstim" CalcNoise=yes\
NoiseNode="out"
SweepPlan:freqstim Start=fstart Stop=fstop [Dec=ptsperdec | Oct=
ptsperoct/log(2) | Lin=numpoints]

 ADS Schematic Symbol:  

 Parameters:

dec = Sweep by decades
oct = Sweep by octaves
lin = Linear sweep
numpoints = Integer number of points in the sweep. If sweeptype is dec or oct,
then this is the number of points per decade or octave.
fstart = Start frequency
fstop = Stop frequency
poi = List of points

 Comments:  

HSpice has extended syntax formats that are not supported by the translator. All extra
keywords and values are ignored.
The srcname allows SPICE to compute the output noise referred back to an input node:
this usage is ignored by the translator. The optional pts_out parameter causes a printed
output to occur for one of every pts_out frequency points; this is also ignored by the
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translator.

 

 .OP

This  line is translated as a DC analysis control.

 

.OP

 

.OP

DC:cmp1

 ADS Schematic Symbol:  

 Parameters:

None. Any optional parameters are ignored.

 

 Comments:

The .OP function in SPICE invokes the simulator to calculate the DC operating point of the
circuit. It is sometimes placed in a netlist just to perform the simplest possible analysis to
verify that a dc solution can be found. In ADS, this is accomplished with a simple dc
analysis with no parameters.

 

 .OPTIONS

The only options currently translated are used to set other values on specific components.

 Example SPICE Command Line:

.OPTIONS TNOM=25 DCAP=1 WL

 SPICE Netlist Syntax:

.OPTIONS [option name]* [option_name=value]*

 Parameters:  

tnom = Default nominal temperature. Used for models if TNOM is not specified.
ADS does not have a global TNOM parameter. If TNOM is specified on the
.OPTIONS statement, the value is copied to all models if the nominal
temperature is not specified directly on the model. Nominal temperature
parameters are as follows:

BSIM1, BSIM2........Temp
MOS_Model9...........Tr
All others......................Tnom or Tref
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dcap = Controls the forward bias capacitance of the diode. ADS does not have
an equivalent global parameter, so this is used by the translator to set Fc on the
BJT model and Fc and Fcsw on the Diode model. If DCAP is not set to 1,
(.OPTIONS DCAP=1), Fc and Fcsw will be set to 0 on the Diode and BJT models.

wl = If values without parameter names are given for Mosfet length and width
parameters, the first is assumed to be length. If the wl parameter is present
with no value, or the value is set to 1, the order is reversed.

The following parameters are default values for mosfets. If no value is given on
a mosfet device for a certain parameter, the SPICE simulator uses the default
given here. However, the value of the MOSFET ACM parameter affects the
recognition of these values. There is no global ADS equivalent for these
parameters and they are not currently translated.

defl = Default value for l
defw = Default value for w
defad = Default value for ad
defas = Default value for as
defnrd = Default value for nrd
defnrs = Default value for nrs
defpd = Default value for pd

The following SPICE tolerances have counterparts in ADS on the Options control
element but are not set by the translator. They can be set manually after
translation.

SPICE ADS

pivtol PivAbsThresh
pivrel PivotRelThresh
vntol V_AbsTol
abstol I_AvsTol
reltol V_RelTol

 

 Comments:

For large RFIC designs, the I_RelTol and V_RelTol should be set to a larger value than the
default 1e-6. 1e-3 is a better start value and is the default value for SPICE based
simulators. The translator will not set a default value for these.

 

 .PARAM

This line is translated as a name=value  parameter.

 Example SPICE Command Line:

.PARAM name=value

 SPICE Dialect and Netlist Syntax:

Spice2/3: .PARAM name=value
PSpice: .PARAM name=value (expressions must be in curly brackets)
HSpice: .PARAM name=value (expressions must be in single quotes)

 ADS Netlist Syntax:
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name=value

 ADS Schematic Symbol:  

 Parameters:

name = Parameter name
value = Parameter value

 

 .SUBCKT

ENDS

This line is translated as a parametric  subnetwork.

 Example SPICE Command Line:

.SUBCKT OPAMP 1 2 3 4

.ENDS

 SPICE Dialect and Netlist Syntax:

Spice2/3:

.SUBCKTsubname [ n1*]

.ENDS [subname]

PSpice:

.SUBCKT subname[n1*] [OPTIONAL:interface node = default value ]
[PARAMS: name=value*] [TEXT: name=textvalue]
.ENDS

HSpice:

.SUBCKT subname[ n1* ] [name=value*]

.ENDS

 ADS Netlist Syntax

define subname (n1...)
parameters name=value
end subname

 ADS Schematic Symbol:  
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 Parameters:

subname = Subnetwork name
n1* = Node names
name = Parameter name
value = Parameter default value
.ENDS = SPICE subcircuit definitions must end with a .ENDS statement.

 

 Comments:

Spice 3:

Subcircuits may be nested in the SPICE file; however, ADS does not allow this. The
translator handles this by writing each subcircuit definition separately in order of
occurrence. Line by line comparison with the original netlist will be harder in this case
since the lines will not match up directly.

PSpice:

OPTIONAL and TEXT parameters are ignored by the translator.
For more information on defining subcircuit parameters, refer to Using the NetlistInclude
Component (netlist).

 

 .TEMP

Note
The translator does not currently translate the TEMP statement. Temp enables you to maintain control
over this setting at the highest level of your design.

To set the simulation temperature, place an OPTIONS element in the highest level of your
schematic design, or use an Options statement in the netlist as shown below in ADS
Netlist Syntax.

 Example SPICE Command Line:

.TEMP 25

 SPICE Netlist Syntax:

.TEMP _tempval

 ADS Netlist Syntax:

Options:options1 Temp\=tempval
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 ADS Schematic Symbol:  

 Parameters:

tempval = Temperature in degrees Celsius.

 Comments:

 .TRAN  

This line is  translated as a transient analysis control element.

 Example SPICE Command Line:

.TRAN 1nS 1000nS 500nS 1nS

 SPICE Dialect and Netlist Syntax:

Spice2/3:
.TRAN tstep tstop [tstart[tmax]] [uic]

PSpice:
.TRAN[/op] tstep tstop [tstart [tmax]] [SKIPBP]

HSpice: .TRAN var1 START= tstart STOP= tstop STEP= tstep
OR .TRAN tstep tstop [tstep2 tstop2 ...] [START=tstart] [UIC]
OR .TRAN DATA=dataname

 ADS Netlist Syntax:

Tran:Tran1 StopTime=tstop MaxTimeStep=tmax [StartTime=tstart ]

 ADS Schematic Symbol:  

 Parameters:

tstep = Time step between output points.
tstop = Final time.
tstart = Initial time, assumed zero if omitted.
tmax = Maximum step size between simulation points.
var1 = Voltage or current source (ignored).

 Comments:  
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.tran is used to perform a time-domain transient analysis.

Optional UIC keyword is ignored by the translator.
MaxTimeStep is calculated by the translator as the smallest of tstep, (tstop-tstart/50 *
tmax)

PSpice optional /OP and SKIPBP are ignored by the translator.

HSpice tstep and tstop are ignored for n>1. SWEEP, SWEEP MONTE, OPTIMIZER and
DATA keywords are ignored by the translator.

 .FUNC  

This is supported for PSpice only.

 PSpice Netlist Format:

.FUNC a(b,c) {b+c}

 ADS Netlist Format:

a(b,c)=b+c

The .FUNC statement in PSpice is used to define a single line user-defined function. This
will be imported as shown above.
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