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 Introduction
The IC-CAP Modeling System is part of Agilent EEsof EDA's high-frequency electronic
design automation (EDA) solutions. Agilent EEsof EDA offers a full array of design tools
that streamline and strengthen the engineering process. These tools include powerful
system and circuit simulators, 2.5-D and 3-D electromagnetic simulators, device modeling
systems, and physical design tools.

 The IC-CAP Modeling System
The IC-CAP Modeling System is used to measure semiconductor device and circuit
modeling characteristics and analyze the resulting data.

To use IC-CAP, you will require the following:

A workstation
Instruments that perform DC, Capacitance, AC, and Time-Domain measurements
A test fixture
A test device
The IC-CAP software

The following figure shows the IC-CAP global configuration.

 IC-CAP Global Configuration
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 The IC-CAP System Architecture
The IC-CAP system centers around a data storage area containing device and circuit
characteristics. Initially, these characteristics are obtained from measurements or
simulations. After gathering your data, you can perform a variety of operations on the
data, including mathematical transformation, extraction, optimization, analysis, or archival
to a file or a data base. The analysis features available in IC-CAP allow detailed study of
the characteristics and the data can be saved for future use.

Mathematical transformations are used to extend the available set of characteristics, while
extractions and optimizations provide feedback to the model in order to obtain agreement
between measured and simulated data.

The following figure illustrates the IC-CAP system architecture.

 IC-CAP System Architecture
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 System Functional Areas
The four main functional areas of the IC-CAP system are:

Modeling
Hardware Management
Function List
System Utilities and Operations

The following figure shows the general organization of the IC-CAP system.

 General Organization of the IC-CAP System
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Modeling is the key functional area. You use this function to:

Test devices and circuits using predefined models
Modify existing models by editing
Create new models by describing their physical and electrical characteristics
Create macros to automate measurement and extraction processes
Create the DUTs contained in a model by describing their physical and electrical
characteristics
Define test circuits and modify parameters for individual DUTs
Create Setups for a particular DUT by defining:

The connection of a device or circuit to the test instruments
The inputs and outputs of the device or circuit
The transformations of the outputs used to calculate parameter values or
additional data
The characteristics of the plots used to display the results of your tests

The hardware management function is used to create and modify the GPIB configuration
of the test instruments. The function list is used to view the available characterization
functions. These functions include mathematical transformations, model parameter
extractions, and special analysis functions, such as optimization. System utilities are used
to create and modify the global configuration. Operations include simulator selection and
directory specification.
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 General Operating Procedures
IC-CAP provides a complete set of procedures for characterizing devices and circuits. Each
of these procedures can be executed from easily accessed menus or programmed into IC-
CAP macros. The system can be used for routine operations with a minimum of training.
The general procedure for characterizing a device consists of the steps described here and
shown in the following figure.

 Installation

Install the device in a test fixture. The instruments must be connected to the computer
and IC-CAP via the GPIB bus.

 Load an Existing Model or Create a New Model

Load an existing model from the Model List after starting the program or create a new
model by modifying an existing model or by starting with a blank template.

 Measure or Create Device Characteristics

Execute IC-CAP's Measure command to measure or create device characteristics. The
program takes control of the measuring instruments and executes their functions. The
instruments connected to the test fixture generate source signals at the input nodes of the
test device. Then the response signals are recorded by the instruments connected to the
output nodes of the device. The responses are recorded by the instruments and the
measured data are loaded into the IC-CAP database.

 Extract Model Parameter Data from the Measured Data

Execute IC-CAP's Extract command to calculate the parameters that control the electrical
behavior of the device from the measured output data.

 Simulate

Send the circuit definition and the extracted parameters to the simulator. The simulator
generates a simulated data set for comparison with the measured data set.

 Optimize

Optimize the parameters to achieve the best possible fit between measured and simulated
data.

 Results

Display or print results in graphic or tabular reports.

 General Functionality of the IC-CAP System
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 IC-CAP Terminology
The following table lists the terms used throughout the documentation to describe the
basic parts of the IC-CAP system.
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Term Description

Model Complete instructions for characterizing a device, including a description of the device,
measured and simulated data, and functions that are performed on the data.

Model Parameters Parameters that govern the behavior of the device, and whose values are common to all
devices being measured for a particular characterization.

DUT (Device
Under Test)

A particular configuration of the device being measured and the hardware being used to
perform the measurements.

Test Circuit Additional circuitry that is connected between the device being measured and the
hardware being used on a particular DUT.

DUT Parameters Parameters that govern the behavior of the device, and whose values may be different for
each DUT.

Circuit A description of the device, in SPICE deck format.

Setup Instructions for performing a measurement or simulation on a DUT. A setup contains
definitions of stimuli, responses, mathematical transformations, extractions, and graphical
or tabular reports.

Measurement The application of a set of stimuli to an actual device to obtain a set of responses that are
used in the characterization process.

Input The definition of a stimulus in a measurement or simulation. Input includes the array of
data that results from this definition.

Output The definition of a response in a measurement or simulation. Output includes the arrays of
data that result from performing those operations.

Extraction The calculation of the parameters that control the device behavior, typically from
measured data, but sometimes from simulated data or data sheet values.

Transform The definition of a function that is performed on IC-CAP data to create a new set of data or
calculate parameter values. Transform includes the arrays of data that result from
performing the function.

Simulation The calculation of a set of data from a mathematical model of the device.

Optimization The iterative adjustment of parameter values in order to achieve the best possible
agreement between measured and simulated data.

Plot Instructions for generating and displaying IC-CAP data, either in graphical or tabular
format.

Macro A group of IC-CAP functions combined into a single operation.

 Graphic User Interface - Menu Descriptions
See Menu Descriptions (intro)

 Miscellaneous Information
See Miscellaneous (intro)
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 Using the IC-CAP Interface
 Main Window

 File Menu

  New   Creates a blank, untitled model file and displays a symbol for it in the work area of the Main
window. Highlight the text below the symbol and type the desired name for the new model.
Double-click to open the Model window.

  Open   Enables you to open an existing model file.

  Examples   Enables you to quickly open a model file in the examples directory

  Edit   Opens the selected Model window (select the model symbol, then the command).

  Auto
Execute

  Runs the AutoExecute macro in the selected model if it is declared or opens the selected
Model window if AutoExecute in not declared.

  Save As   Enables you to save one or more of the models currently in memory.

  Change
 Directory

  Enables you to change the directory to which data will be saved during the current session.

  <File
Names>

  Contains list of most recently loaded files.

  Exit   Exits IC-CAP. The Save As dialog box appears enabling you to save any models currently in
memory before exiting.

 Edit Menu

  Undo   Undoes the most recent Cut, Copy, or Paste command.

  Cut   Cuts the selected model to a buffer from which it can be pasted. This enables you to load and
view another model by the same name-without overwriting the first one-and choose between
them, pasting the one you cut if desired.

  Copy   Copies the selected model to a buffer from which it can be pasted. By copying and pasting, you
can have one or more copies of a given model open at the same time.

  Paste   Pastes the contents of the buffer.  When pasting a model you cut, the same name is retained. 
When pasting a model you copied, an underscore (_) character is appended to the name, as well
as a numerical indicator, which is automatically incremented.

  Delete
 (No
 Undo)

  Deletes the selected model from the work area.

 Tools Menu
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System
Variables

Displays the System Variables window for setting values for global (system) variables. You
can create user-defined variables by typing names and values here. You can also type names
and values of supplied variables here, or click the System Variables button and use the
dialog box to select variables, view descriptions, and set values. Note that the names of
supplied variables are reserved and cannot be used for variables you create.

Print The Print button enables you to save the currently displayed variables table to file. You are
prompted for a filename. The file is saved to the current work directory with a default .asc
extension.

File Open-Enables you to open a previously saved Variables Table file (.vat). Change
directories as needed, select the desired file, and click OK. 
Save As-Enables you to save a variables table to file. Change directories as needed,
type the desired name in the Selection field, and click OK. 
Close-Closes the variables window.

Edit Undo-Undoes the previous copy or paste 
Copy-Copies the currently defined global variables enabling you to paste them in the
Model window at the Model, DUT, or Setup level. 
Paste-Enables you to paste variables copied at the Model, DUT, or Setup level to the
global level.

  System GUI
Items

  Displays the System GUI Items window. For details, see Creating Graphic User Interfaces
(prog).

  Simulation
Debugger

  Displays the Simulation Debugger Window.

  Stop
Simulator

  Stops any currently running piped simulator. The command is most useful when using the
ADS simulator with the Root model to ensure correct simulations can be made after changing
directories to test other models, and to allow model regeneration.

  License
Status

  Displays a window with dynamically updated license information:
 

The codewords currently in use 
The codewords currently available  To release a specific license, select it and click
Release.

  Hardware
Setup

  Displays the Hardware Setup Window.

  Statistics   Launches the Statistics program, if licensed.

  Select
Simulator

  Enables you to change the default simulator after startup. Note: this selection is overriden
by a SIMULATOR variable. For detailis, refer to Selecting a Simulator (sim).

  Functions   Displays the Function Browser dialog box for reviewing available functions.

  Plot Options   Displays the Plot Options dialog box, which enables you to define trace options, plot options,
and text annotation.

  Options    

       File
Debug

  Toggles the debugging facility on and off. When on, messages are recorded in the file
.icdebug.

       Screen
Debug

  Toggles the debugging facility on and off. When on, messages are displayed in the IC-CAP
Status window.

       View GUI
Pages

  If toggled on, the GUI Items page will be shown in Model windows when the window is first
opened.

       Status
 Window  to
 Top

  If toggled on, the Status window pops to the front of the screen anytime new messages are
displayed in it.

     
 Diagnostics

  Executes internal diagnostics.
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 Windows Menu

The Windows menu provides a quick method of bringing a different window to the
foreground. All currently open windows, including those that are minimized, are listed on
the menu. Individual models are listed on the Model window submenu. Choose the desired
window and it is displayed in front of all other IC-CAP windows.

 Hardware Setup Window
The Instrument Setup window enables you to define interface filenames, active
instruments, instrument addresses, and unit names to be used in Setups.This window can
also be used to control a particular instrument manually.

 File Menu

The File menu allows you to perform basic file management commands as well as exit the
Hardware Setup window.

  Open   Enables you to load an instrument configuration from a previously saved file.

  Save   Enables you to save the current instrument configuration to a file of your choosing (the
default filename is .icconfig).

  Close
 Window

  Closes the Hardware Setup window.

 Tools Menu

This set of commands provides basic GPIB capabilities to communicate with the
instruments on the bus. These may be useful for debugging an instrument driver or
manually setting an instrument to a certain state that is not supported by IC-CAP. The
Status panel displays continuously updated information about GPIB activity.

The Tools menu offers the following choices:
 

Interface
Address
Send/Receive
Settings
Macros
Serial Poll

 Interface
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  Status   Provides the current GPIB bus status.

 
Change

  Closes the current interface file and opens a new one.

  Lock   Provides exclusive access to the bus.

  Unlock   Releases the I-O Lock on the bus.

  Reset   Resets all the instruments on the bus using the Interface Clear command.

 Address

  Set   Sets the address to which certain commands apply. Some of these commands are:
 

Send String 
Receive String  
Serial Poll 
Address > Listen 
Address > Talk  
Address > Check   NOTE: Use the command Address > Set first to set a target GPIB
address on which to perform various communications such as "Send String" or "Receive
String."

  Who  Are
 You?

  Polls all addresses other than those at which the CPU is configured. Provides a list of all
instruments attached to the bus and powered on, along with their addresses.

  Check   Polls active address for any response.

  Listen   Sets the instrument at the active address to the Listen state.

  Talk   Sets the instrument at the active address to the Talker state.

 Send/Receive

  Send String   Prompts for a string that will be sent to the instrument at the active address. Carriage
return and line feed characters can be included using "\r" and "\n", respectively.

  Receive String   Sets CPU to Listen status and the active address to talk status, and collects data from
the active address until an EOI is received. Usually used with Send String. The result is
also placed in the HPIB_READ_STRING system variable if you have defined it.

  Receive PEL
String

  Same as Receive String, but skips the Talk/Listen setup which should be done using the
Send Byte command. The result is also placed in the HPIB_READ_STRING system
variable if you have defined it.

  Display String   Displays data most recently read by the CPU via a Read String operation.

 
Send/Read/Display

  Lets you send a command to the instrument at the active address and receive a
response from the instrument. The response is displayed in the Status panel. The result is
also placed in the HPIB_READ_STRING system variable if you have defined it.

  Send Byte   Sends one command byte specified as a decimal integer. For example, use 63 to send
UNLISTEN.

 Settings

 
Timeout

  Specifies the timeout value in seconds. Specifying 0 (zero) disables the use of timeout, which is
not recommended.

 Macros
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  Specify   Prompts you for the name of an GPIB Analyzer macro file.

 
Execute

  Executes commands contained in the GPIB Analyzer macro file. For the syntax of commands, refer
to GPIB Analyzer (meas).

 Serial Poll

Polls the active address and displays the status byte in decimal form.

 Instrument Menu

The Instruments menu offers a variety of instrument operations to assist you in making
measurements.

  Find   Queries the GPIB bus for instruments.

  Display   Displays a list of found instruments on the GPIB bus.

  Usage   Displays a list of currently active instruments.

  Zero
 Sources

  Forces zero to all the found instruments.

  Self Test   Causes the execution of self tests on instruments currently connected to the system, powered
up, and listed in the Instrument List.

 View Menu

The View menu allows you to toggle on and off the screen debugger and the toolbar.

  Screen
 Debug

  Enables you to toggle on and off the low-level debugging facility that produces detailed debug
messages on each GPIB transaction.

  Toolbar   Enables you to toggle the toolbar on and off.

 Windows Menu

The Windows menu provides a quick method of bringing a different window to the
foreground. All currently open windows, including those that are minimized, are listed on
the menu. Individual models are listed on the Model window submenu. Choose the desired
window and it is displayed in front of all other IC-CAP windows.

 Model Window

 File Menu
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  Open   Enables you to open parts of a model file previously saved with the Save As command
in the Model window (see Opening Parts of a Model File (intro)).

  Save As   Enables you to save parts of a model file (see Opening Parts of a Model File (intro)).

  Printer Setup   Opens the Print Setup dialog box (see Printing and Plotting (intro)).

  Import Data    

     Active Setup   Enables you to import an ASCII-based MDM data file, of a pre-determined format, to
the selected setup.

     All  Setups  in
 Active  DUT

  Enables you to import an ASCII-based MDM data file, of a pre-determined format, to
all setups in the selected DUT.

       All DUTs in
Model

  Enables you to import an ASCII-based MDM data file, of a pre-determined format, to
all setups in all DUTs of the current model.

  Export Data    

       Active Setup   Enables you to export an ASCII-based MDM (.mdm) or Dataset (.ds) data file, of a
pre-determined format representing the selected setup.

       All Setups in
Active DUT

  Enables you to export an ASCII-based MDM (.mdm) or Dataset (.ds) data file, of a
pre-determined format representing all setups in the active DUT.

       All DUTs in
Model

  Enables you to export an ASCII-based MDM (.mdm) or Dataset (.ds) data file, of a
pre-determined format representing all DUTs in the model.

       Extracted Deck   Enables you to export the circuit block in a SPICE deck format.

       Write Model
MDIF

  Writes the Parameters table to a file in MDIF format, which can be read by ADS or
Series IV.

  Close   Closes the Model window, but the model file remains in memory. To re-open a model,
double-click the icon in the Main window.

Related Topics:

Introduction (intro)

 Edit Menu

  Undo   Undoes the last Cut, Copy, or Paste action.

  Text   Applies to text in the model parts DUTs, Circuit, and Macros.

       Cut   Cuts selected text.

       Copy   Copies selected text.

       Paste   Pastes copied or cut text to other textual model parts.

       Find   Enables you to find text.

       Replace   Enables you to find and replace text.

       Goto  Line   Enables you to highlight selected line number.

  Cut Setup   Enables you to cut a variety of model parts for pasting within other parts of that same
model or to another model.

  Copy  Setup   Enables you to copy a variety of model parts for pasting within other parts of that same
model or to another model.

  Paste   Enables you to paste a variety of model parts you cut or copied. You can paste within
the model that you cut or copied from or to another model.

  Delete  Setup
(No  Undo)

  Enables you to delete a variety of model parts.

 Measure Menu
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  Active  Setup   Performs a measurement for the active setup.

  Active DUT   Performs a measurement for all setups in the active DUT

 Extract Menu

  Active  Setup   Performs all extraction transforms for the active setup.

  Active DUT   Performs all extraction transforms for all setups in the active DUT.

 Simulate Menu

  Active  Setup   Simulates the active setup.

  Active DUT   Simulates all setups in the active DUT.

 Optimize Menu

  Active  Setup   Performs all optimization transforms for the active setup

  Active DUT   Performs all optimization transforms for all setups in the active DUT

 Data Menu

  Plots    

       Display All    

             In  Active
 Setup

  Displays all currently defined plots for the active setup.

             In Active DUT   Displays all currently defined plots for the active DUT.

             in Model   Displays all currently defined plots for the current model.

       Close All    

             In Active Setup   Closes all displayed plots for the active setup.

             In Active DUT   Closes all displayed plots for the active DUT.

             in Model   Closes all displayed plots for the current model.

  Clear Data    

       Measured   Clears all measured data In Active Setup , In Active DUT , or In Model .

       Simulated   Clears all simulated data In Active Setup , In Active DUT , or In Model .

       Both   Clears both measured and simulated data In Active Setup , In Active DUT , or In
Model .

 Tools Menu
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  Simulation
Debugger

  Displays the Simulation Debugger Window.

  Stop
Simulator

  Stops any currently running piped simulator. The command is most useful when using the
ADS simulator with the Root model to ensure correct simulations can be made after changing
directories to test other models, and to allow model regeneration.

  Organize
Model

  Displays a window that enables you to add, delete, reorder, and rename DUTs, Macros, and
Variables in the model. Selecting the Organize DUT button on the window displays a window
that enables you to add, delete, reorder, and rename Setups and Variables. Selecting the
Organize Setup button on that window displays a window that enables you to add, delete,
reorder, and rename Inputs, Outputs, Transforms, Plots, and Variables.

  Refresh
Last
Dataset...

  Re-exports the current data to the last exported dataset (.ds).

  Plot
Optimizer

  Displays the Plot Optimizer window.

  Plot
Options

  Displays the Plot Options dialog box, which enables you to define trace options, plot options,
and text annotation.

  Hardware
 Setup

  Displays the Hardware Setup Window.

 Macros Menu

  Execute   Enables you to execute any macro available in the model regardless of the visible folder.

 Windows Menu

The Windows menu provides a quick method of bringing a different window to the
foreground. All currently open windows, including those that are minimized, are listed on
the menu. Individual models are listed on the Model window submenu. Choose the desired
window and it is displayed in front of all other IC-CAP windows.

 Plot Window

 File Menu

  Print   Opens the Print dialog box which enables you to print to the specified printer, a file, or copy
to the Windows clipboard.

  Save
Image...

  Enables you to save the current plot configuration to a file of your choosing.

  Printer
Setup...

  Opens the Print Setup dialog box (see Printing and Plotting (intro)).

  Close   Closes the Plot window.

 Options Menu
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  Replot   Refreshes the plot.

  Update
Annotation

  Updates the plots annotation.

  Edit Definition...   Displays the Plot Editor.

  View Data...   Displays the plot's data file.

  Copy to
Clipboard

  Copies a plot image to the Windows clipboard.

  Rescale   Zooms in to the selected area of a plot.

  Set scale   Sets the Manual rescale dialog box to the plot's current scaling values.

  Autoscale   Turns the autoscale mode on or off. When turned on, the graph automatically rescales as
data changes. The status appears in the graph's title.

  Manual rescale   Displays the Manual rescale dialog box which enables you to fully describe all three axes
of XY plots in terms of minimum value, maximum value, number of major divisions, and
number of minor divisions.

  Draw Diag Line   Draws a diagonal line connecting two clicked points and its slope, with both X and Y axis
intercepts. If you do not click two points first, erases the diagonal line.

  Copy to
Variables

  Copies the X and Y values of a rescale rectangle to system variables. Four variables
(X_LOW, X_HIGH, Y_LOW, and Y_HIGH) are reserved for this purpose.

  Error    

       Show
Relative Error

  Toggles the MAX and RMS relative errors in the footer area on or off.

       Show
Absolute Error

  Toggles the MAX and RMS absolute errors in the footer area on or off.

       Select Whole
Plot

  All the points in the measured/simulated datasets will be used to calculate the error.

       Select Error
Region

  Identifies the selected region as the error region. A green box that delimits the error
calculation replaces the white box.

  Plot Options   Displays the Plot Options dialog box, which enables you to define trace options, plot
options, and text annotation.

  Session Settings    

       Area Tools   Toggles the graph's area tools on or off.

       Legend   Toggles the graph's legend on or off.

       Text
Annotation

  Toggles the graph's text annotation on or off.

       Title   Toggles the graph's title on or off.

       Header   Toggles the header on or off.

       Footer   Toggles the footer on or off.

       Exchange
Black-White

  Reverses the black and white settings for the graph's grid, text, and background.

       Color   Toggles color on or off for the traces and markers. When Color is off, the traces and
markers are the same color as the graph's grid and text.

       Reset to
Saved Options

  Resets the current session settings back to the saved Plot Options. This menu pick is not
available from Scatter, Histogram, or CDF plots that were opened by the Statistic Package.

       Save
Current Settings

  Saves the current session's settings as the saved Plot Options. This menu pick is not
available from Scatter, Histogram, or CDF plots that were opened by the Statistic Package.

 Optimizer Menu
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  Open Optimizer...   Opens the Plot Optimizer window.

  Enable/Disable Plot   Enables or disables the Plot window. Enabling the plot window synchronizes
it with the Plot Optimizer window.

  Global Region    

       Reset   Deletes all existing global trace regions on the plot and defines a new
global trace region.

       Add   Adds a global trace region without deleting existing global trace regions.

       Delete All   Deletes all global trace regions.

  Autoconfigure and Enable   Automatically enables and configures the inputs in a Plot window.

  Disable All Traces   Disables all inputs in a Plot window.

 trace    

       Set as Both Target and    
 Simulated

  Configures the selected trace with its measured data set as Target and its
simulated data set as Simulated.

       Set as Target vs.   Configures the selected trace as Target.

       Set as Simulated vs.   Configures the selected trace as Simulated.

       Disable   Disables the selected trace.

       Trace Optimizer Region    

             Reset   Deletes all existing trace optimizer regions for the selected trace and
defines a new trace optimizer region.

             Add   Adds a trace optimizer region for the selected trace without deleting
existing trace optimizer regions.

             Delete All   Deletes all trace optimizer regions for the selected trace.

 Windows Menu

The Windows menu provides a quick method of bringing a different window to the
foreground. All currently open windows, including those that are minimized, are listed on
the menu. Individual models are listed on the Model window submenu. Choose the desired
window and it is displayed in front of all other IC-CAP windows.

 Multiplot Window

 File Menu

  Print   Opens the Print dialog box which enables you to print to the specified printer, a file, or copy
to the Windows clipboard.

  Save
Image...

  Enables you to save the current plot configuration to a file of your choosing.

  Printer
Setup...

  Opens the Print Setup dialog box (see Printing and Plotting (intro)).

  Close   Closes the Plot window.

 Options Menu
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  Replot   Refreshes the plot.

  Update Annotation   Updates the plots annotation.

  Copy to Clipboard   Copies a plot image to the Windows clipboard.

  Autoscale   Turns the autoscale mode on or off. When turned on, the graph automatically rescales
as data changes. The status appears in the graph's title.

  Error    

       Show Relative
Error

  Toggles the MAX and RMS relative errors in the footer area on or off.

       Show Absolute
Error

  Toggles the MAX and RMS absolute errors in the footer area on or off.

       Select Whole
Plot

  All the points in the measured/simulated datasets will be used to calculate the error.

       Select Error
Region

  Identifies the selected region as the error region. A green box that delimits the error
calculation replaces the white box.

  Plot Options   Displays the Plot Options dialog box, which enables you to define trace options, plot
options, and text annotation.

  Session Settings    

       Area Tools   Toggles the graph's area tools on or off.

       Legend   Toggles the graph's legend on or off.

       Text
Annotation

  Toggles the graph's text annotation on or off.

       Title   Toggles the graph's title on or off.

       Header   Toggles the header on or off.

       Footer   Toggles the footer on or off.

       Exchange
Black-White

  Reverses the black and white settings for the graph's grid, text, and background.

       Color   Toggles color on or off for the traces and markers. When Color is off, the traces and
markers are the same color as the graph's grid and text.

       Reset to Saved
Options

  Resets the current session settings back to the saved Plot Options.

       Save Current
Settings

  Saves the current session's settings as the saved Plot Options.

 Optimizer Menu
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  Open Optimizer...   Opens the Plot Optimizer window.

  Enable/Disable Plot   Enables or disables the Plot window. Enabling the plot window synchronizes
it with the Plot Optimizer window.

  Global Region    

       Reset   Deletes all existing global trace regions on the plot and defines a new
global trace region.

       Add   Adds a global trace region without deleting existing global trace regions.

       Delete All   Deletes all global trace regions.

  Autoconfigure and Enable   Automatically enables and configures the inputs in a Plot window.

  Disable All Traces   Disables all inputs in a Plot window.

 trace    

       Set as Both Target and    
 Simulated

  Configures the selected trace with its measured data set as Target and its
simulated data set as Simulated.

       Set as Target vs.   Configures the selected trace as Target.

       Set as Simulated vs.   Configures the selected trace as Simulated.

       Disable   Disables the selected trace.

       Trace Optimizer Region    

             Reset   Deletes all existing trace optimizer regions for the selected trace and
defines a new trace optimizer region.

             Add   Adds a trace optimizer region for the selected trace without deleting
existing trace optimizer regions.

             Delete All   Deletes all trace optimizer regions for the selected trace.

 Plots Menu

  Select Plot   Displays a list of available plots. The plot you choose becomes the selected
plot.

  Unselect All   Unselects the currently selected plot.

  Zoom Plot   Displays a list of available plots. The plot you choose is displayed in zoom
format.

  Full Page Plot   Displays a list of available plots. The plot you choose is displayed in full page
format.

  Undo Zoom   Resets the Multiplot window to the default format.

  Selected Plot Menu    

         Reset to Saved Options   Resets the Plot Options to the last saved options.

         Plot Options   Displays the Plot Options dialog box, which enables you to define trace
options, plot options, and text annotation.

         Optimizer  

                 Open Optimizer   Opens the Plot Optimizer window.

                 Enable/Disable
Plot

  Enables or disables the Plot window. Enabling the plot window synchronizes
it with the Plot Optimizer window.

                 Global Region    

                       Reset   Deletes all existing global trace regions on the plot and defines a new global
trace region.

                       Add   Adds a global trace region without deleting existing global trace regions.

                       Delete All   Deletes all global trace regions.

                 Autoconfigure and   Automatically enables and configures the inputs in a Plot window.
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Enable

                 Disable All Traces   Disables all inputs in a Plot window.

                  trace    

                       Set as Both
Target and                    
 Simulated

  Configures the selected trace with its measured data set as Target and its
simulated data set as Simulated.

                       Set as Target
vs.

  Configures the selected trace as Target.

                       Set as
Simulated vs.

  Configures the selected trace as Simulated.

                       Disable   Disables the selected trace.

                     Trace Optimizer
Region

   

                             Reset   Deletes all existing trace optimizer regions for the selected trace and defines
a new trace optimizer region.

                             Add   Adds a trace optimizer region for the selected trace without deleting existing
trace optimizer regions.

                           Delete All   Deletes all trace optimizer regions for the selected trace.

         Scaling  

                 Replot   Refreshes the plot.

                 Rescale   Zooms in to the selected area of a plot.

                 Set scale   Sets the Manual rescale dialog box to the plot's current scaling values.

                 Autoscale   Turns the autoscale mode on or off. When turned on, the graph
automatically rescales as data changes. The status appears in the graph's
title.

                 Manual rescale   Displays the Manual rescale dialog box which enables you to fully describe
all three axes of XY plots in terms of minimum value, maximum value,
number of major divisions, and number of minor divisions.

         Graphic   Updates the plots annotation.

                 Draw Diag Line   Draws a diagonal line connecting two clicked points and its slope, with both
X and Y axis intercepts. If you do not click two points first, erases the
diagonal line.

                 Copy to Variables   Copies the X and Y values of a rescale rectangle to system variables. Four
variables (X_LOW, X_HIGH, Y_LOW, and Y_HIGH) are reserved for this
purpose.

                 Area Tools   Toggles the graph's area tools on or off.

                 Legend   Toggles the graph's legend on or off.

                 Text Annotation   Toggles the graph's text annotation on or off.

                 Title   Toggles the graph's title on or off.

                 Header   Toggles the header on or off.

                 Footer   Toggles the footer on or off.

         Error    

                 Show Relative
Error

  Toggles the MAX and RMS relative errors in the footer area on or off.

                 Show Absolute
Error

  Toggles the MAX and RMS absolute errors in the footer area on or off.

                 Select Whole Plot   All the points in the measured/simulated datasets will be used to calculate
the error.
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                 Select Error
Region

  Identifies the selected region as the error region. A green box that delimits
the error calculation replaces the white box.

 Windows Menu

The Windows menu provides a quick method of bringing a different window to the
foreground. All currently open windows, including those that are minimized, are listed on
the menu. Individual models are listed on the Model window submenu. Choose the desired
window and it is displayed in front of all other IC-CAP windows.

 Plot Optimizer Window

 File Menu

  Open...   Enables you to open an existing plot optimizer file.

  Save As...   Enables you to save the current plot optimizer configuration to a file of your choosing.

  Clear Plot
Optimizer

  Disables all traces and regions in the plots, disables all open plots, and clears the
Parameters table.

  Reset Option
Table

  Resets all options in the Options table to the default values.

  Close   Closes the Plot Optimizer window.

 Plots Menu

  Enable All   Enables all open Plot windows in a model file.

  Disable
All

  Disables all open Plot windows in a model file.

 Simulate

  Simulate
All

  Simulates all enabled traces.

 Optimize

  Run
Optimization

  Performs an optimization of the enabled traces.

  Tune Fast...   Opens a tuner window which enables you to adjust the parameter values. You can see the
effects in a plot as you vary parameter values using the tuner. Recalculates constantly as a
slider is moved. While the tuner window is open, you can change the Min and Max values.

  Tune Slow...   Opens a tuner window which enables you to adjust the parameter values. Recalculates only
when a slider is released. You can see the effects in a plot as you vary parameter values using
the tuner. While the tuner window is open, you can change the Min and Max values. It's best to
use Tune Slow when the time per calculation is slow (about one second or more).

 Tools
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  Store Parameters   Stores values in the Parameters table for later recall.

  Recall Parameters   Recalls the values stored in the Parameters table.

  Undo Optim   After running an optimization, restores the parameters to their previous state.

  AutoSet Min and Max   Automatically sets the parameter values.

  Reset Min and Max   Restores the parameter values to their default values.

 Windows

The Windows menu provides a quick method of bringing a different window to the
foreground. All currently open windows, including those that are minimized, are listed on
the menu. Individual models are listed on the Model window submenu. Choose the desired
window and it is displayed in front of all other IC-CAP windows.

 Simulation Debugger Window
The Simulation Debugger window displays the circuit input deck and the results of the
simulation in text form. To display data, open the Simulation Debugger window and then
run a simulation (either from the DUT or Setup level). The data is displayed in the Input,
Output, and Command File regions, however, the Command File region is used only with
the Saber simulator and displays the Saber commands generated from the IC-CAP Setup.

For debugging, edit the data in the Input editor, then run a simulation from the debugger
to test the changes. To run a simulation from the debugger, use the Manual Simulation
command on the File Menu. If the changes are successful, change the circuit definition to
reflect your changes.

Note
After running a simulation using the SPICE3 simulator, the Output region of the debugger displays the
message ".print card ignored since rawfile was produced." To display the output of the simulation in text
form, issue the Manual Simulation command.

 File Menu

  Manual
 Simulation

  Executes a simulation using the circuit deck in the Input field of the debugger. The Debugger
Input field is not linked to the Model Circuit Definition editor or Input and Output setups, so
edits made in the field have no effect on IC-CAP and are irrelevant to a simulation run from a
DUT or Setup. To make changes permanent, make them in the Model Circuit Definition editor.

  Save Input
File

  Provides a dialog box for specifying a filename for saving the contents of the Input editor to a
file.

  Save
 Command
 File

  Provides a dialog box for specifying a filename for saving the contents of the Command editor
to a file.

  Save Output
File

  Provides a dialog box for specifying a filename for saving the contents of the Output editor to
a file.

  Close   Closes the Simulation Debugger window.

 Windows Menu

The Windows menu provides a quick method of bringing a different window to the
foreground. All currently open windows, including those that are minimized, are listed on
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the menu. Individual models are listed on the Model window submenu. Choose the desired
window and it is displayed in front of all other IC-CAP windows.
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 Miscellaneous
 Clearing Data from Memory
The Clear command allows you to clear from memory the data for the current setup. You
can clear measured data, simulated data, or both. This command is useful when you have
already measured all setups of a DUT, or all DUTs that make up the model, and need to
make a change to one setup. You can clear the measured data for that setup and re-
measure that setup.
 

 Tuning Parameters
By including the TUNER statement in a PEL macro, you can tune parameters during macro
execution. To tune parameters once the dialog box appears: 

Position the pointer over the slider associated with the parameter you want to tune. 1.
Press the left mouse button and drag the slider in the desired direction. Notice the2.
plot is dynamically updated as you change values. 
To close the dialog box and return control to the macro, click OK; to abort the3.
macro, click Cancel.
 

 Cut and Copy Selections

When you cut and copy model parts at the DUT and Setup levels, you are prompted to
choose between the DUT or Setup (depending on which is active) and a model part
available in the active folder. For example, in the Measure/Simulate folder, you can
choose to cut or copy the Setup itself or selected Inputs and/or Outputs. Likewise, in the
Test Circuit folder, you can choose to cut or copy the DUT itself or the Test Circuit.
 

Select the appropriate option and click OK.
 

 Adding an Interface Name
To add an interface name to the list, click Add Interface. In the dialog box that appears,
supply the interface filename. An interface card by that name should have been previously
installed. When you choose OK, the existence of a card by that name is verified.

For information about installing and configuring an interface card, see Check the
Supported Instrument Interfaces for Windows installations (winstall) or Check the
Supported Instrument Interfaces for UNIX installations (uinstall).

 Deleting an Interface Name
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To delete an interface filename from the list, select the interface name and click Delete
Interface.

 Creating the List of Active Instruments

The Instrument List potentially displays all instruments attached to the GPIB bus. Once on
the list, you can configure each instrument to set the address and assign unit names. You
can create this list automatically or manually.
 

To create the Instrument List automatically:
 
Click Rebuild. This clears the current Instrument List, polls all available GPIB
addresses. and creates a complete list of instruments connected to the GPIB bus,
providing they are powered up.
 
To Create the Instrument List Manually:
 
Select the instrument name and click Add to List. This enables you to create a list of
instruments that are not necessarily currently powered up or connected to the bus.

 Deleting an Instrument from the Instrument List

To delete an individual instrument from the list, select it and click Delete. You can delete
an instrument any time, regardless of its power status.

Note
To save instrument options before deleting instruments from the list, with the Instrument Options folder
active, choose File > Save As. Select Instrument Options (.iot), set the path and filename as desired,
and click OK.

 Deleting All Instruments from the List

To delete all instruments from the Instrument List, click Delete All. A confirmation dialog
box appears to confirm this operation because all instrument options will also be removed.

Note
To save instrument options before deleting instruments from the list, with the Instrument Options folder
active, choose File > Save As. Select Instrument Options (.iot), set the path and filename as desired,
and click OK.

 

 Configuring an Instrument

To define the GPIB bus address of an instrument in the Instrument List, as well as assign
unit names, select that instrument and click Configure.

 Interface
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Reflects the names of any interface files added in the Hardware Setup window. Select one
to change its address and assign units.

 Instrument Address

 
Enables you to set the address of an instrument on the GPIB.

 Unit Table

 
Contains default unit names for an instrument. Edit these names as needed.

Note
After assigning unit names here, specify those same names for the inputs and outputs (in the
Measure/Simulate folder) as needed.
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 Program Basics
This section covers the basic concepts and skills you need in order to work successfully
with the program.

To install the program, follow the instructions in Windows Installation (winstall) or UNIX
Installation (uinstall).

 Documentation Conventions
The IC-CAP documentation uses consistent visual cues, standard text formats, and special
terminology so that you can locate and interpret information easily. The following table
lists these documentation conventions.

 Documentation Conventions

Type style Used for

Italic New terms, directory names, filenames.

ALL
CAPITALS

Acronyms.

Initial
Capitals

Names of keys on your keyboard (such as, Esc, Back Space, or Return), menu items, command
names, dialog names and options.

Bold Menu names, command names, items from a list, filenames or project names that you select
when following a procedure.

 Making Selections with the Mouse
The mouse is used to make selections and to open and close program windows.

To select an item, move the mouse pointer to the item, then click (press and release)
the left mouse button.
To select a command from a menu:

Move the mouse pointer to the command and double-click (two clicks in rapid
succession) the left mouse button.
Move the mouse pointer to the command and press, but do not release, the left
mouse button. Drag (slide) the pointer to the command and then release.

To cancel a menu, click anywhere outside the menu. (Or, you can press F10 or Esc.)
To display the x- and y-axis values of a particular point on a data trace, move the
mouse pointer to the point and click the middle mouse button.
To display a list of available choices for a field, move the mouse pointer over the list
pointer at the right end of the field, then click the left mouse button.

 Working with Windows
A window contains an application, such as a model, or an information dialog box. The
following figure shows the parts of the IC-CAP Main window.

 An Example IC-CAP Window
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You can move, resize, and arrange windows for best usage of the screen. For details on
window management, refer to your operating system documentation.

 Working with Menus and Commands
You carry out an action by choosing a command. Program commands are listed on menus
on the window menu bar. The following table lists menu conventions.

 Menu Conventions

Menu Convention Description

Dimmed command name The command is not available now.

Ellipsis points (...) displayed after a
command name

Opens a dialog box for completing information needed to carry
out the command.

A triangle (>) at the right side of the menu
command

Opens a sub menu for the command.

 Using the Tearoff Menu

Pull-down menus can be separated from the menu bar and placed anywhere on your
desktop. To tear off a menu, click the dashed line at the top of the menu and drag the
menu to a new desktop location.

 Using the Toolbar

Frequently-used commands are available as buttons on the toolbar in each design window.
When you move the mouse pointer over a button, a balloon displays a label identifying the
function of that button. The following figure shows the toolbar in the IC-CAP Main window.

 IC-CAP Main Window Toolbar
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 Working with Dialog Boxes
The program uses a dialog box to display messages or to request information needed to
carry out a command. The following figure shows an example dialog box.

 An Example Dialog Box
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 Providing Dialog Box Information

 List Box

Contains the available choices. If there are more choices than can fit in the list box, you
can use the scroll bars to access more choices. Click the item you want to select.

 Text Box

Enter the required information in the fields or edit information currently entered. One field
has the keyboard focus (where keystrokes appear). This field is identified by a highlighted
border and a blinking input cursor that looks like an I-beam.

 Drop-down List

Opens after you click the triangular symbol at the end of a bar-like button. Click the item
you want to select.

 Command and Option Buttons

Initiate immediate action when selected. By default, the choice that has a darker border is
active. To choose the default, press Enter or click OK.
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To implement the selections made in a dialog box:

To make changes in a dialog box, provide the information required, then choose OK
to complete the command and close the dialog box.
To make changes, but keep the dialog box open, choose Apply.
To close a dialog box without completing the command, choose Cancel.

 Prompts

A prompt dialog box requires information to carry out the current command. You must
make a choice and close the dialog box before you can take any other action in the
program.

 Error Messages

An error dialog box opens after an operation in which one or more errors have occurred.
All errors resulting from a particular operation are displayed in one box. You must clear
the error dialog box before you can continue with IC-CAP operations. All error messages
generated during a particular session are written to a file in your home directory named
.icerrlog. The .icerrlog file is cleared each time IC-CAP is run.

 Table and Text Editors
A table editor is used to display and edit groups of information.

The keyboard focus field is identified by a highlighted border and a blinking input cursor.
Normally the input cursor looks like an I-beam. To change the location of the keyboard
focus or reposition the input cursor within a field, click in the field.

The number of visible rows in a list or table is specified by system variables. Changing a
window size does not affect a list or table size. Refer to the section on System Variables
for details on changing variables.

The following table lists keystrokes that you can use while editing fields in a table or text
editor. Some keystrokes may not be available on all keyboards. IC-CAP Editor Select and
Copy Mouse Operations lists the mouse operations used to select and copy text. All
selections described are primary selections unless noted otherwise.

 Table and Text Editor Keystrokes
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Keystroke Action

Right Arrow Move forward one character

Left Arrow Move back one character

Down Arrow Move to next line or field

Up Arrow Move to previous line or field

Home Move to beginning of line

End Move to end of line

Backspace Delete previous character

Shift Backspace Delete previous word

Delete Delete selected text

Shift Delete Char Delete next word

Tab Move to next field

Return Begin a new line

 Using the Pop up Menu as a Shortcut

A pop-up menu, available in table and text editors, enables access to many common
commands with a minimum of mouse movement.

 IC-CAP Editor Select and Copy Mouse Operations

Operation Action

Click left button Move insertion and destination cursors

Double click left button Select word

Triple click left button Select line

Quad click left button Select entire editor

Drag left button Select to end of drag

Shift click left button Extend selection

Shift drag left button Extend selection to end of drag

Click middle button Copy selection to new location

Drag middle button Select (secondary) to end of drag and copy to destination cursor

Operations for copying and pasting text to and from terminal windows are platform-
dependent. For details, refer to your workstation's documentation.

 Using Help
Help messages are available for each IC-CAP window. Window level help is displayed when
you click Help in the top menu bar of a specific window.
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From the Help menu, you can access this information:

What Is New... Displays important differences between the PC and UNIX version of IC-CAP.

Topics and
Index...

Displays the main contents for the online documentation. Clicking a listed section opens
the file for that section.

Agilent EEsof
Web Resources

Displays telephone, fax, and e-mail numbers for accessing Agilent EEsof Worldwide
Customer Support.

License
Information

Displays the environment/license variables and machine information, all licenses found in
the license.lic file, all license servers serving Agilent EEsof licenses on your network, and
the current status of all installed licenses.

About IC-CAP... Displays version and copyright information.

You can display a Help message for a specific dialog box by clicking the Help button in the
dialog box.

 Starting the Program
You can start IC-CAP from any directory. However, after you have saved modified model
files, you may find that starting the program from the directory that contains your model
files simplifies archiving operations.

To start the program:

Change to the working directory.1.
At the system prompt, type iccap and press Enter.2.

The IC-CAP Main window and the IC-CAP Status window open.
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The IC-CAP/Status window displays messages about the program activity and
Warnings/Errors messages. In the IC-CAP/Status window, you can open and close output
and error log files, and interrupt a process. The icons allow you to interrupt a process (the
red stop sign), clear the output log files (the one with the "O"), and clear the error log
files (the one with the "E"). The slider along the Status window's right side enables you to
adjust the relative sizes of the Output and Warnings/Errors panes.

 IC-CAP/Status window
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To start the program and, at the same time, open a specific model file:

Change to the working directory.1.
At the system prompt, type iccap < model filename > and press Enter.2.
Problem: When using the hpeesofsim simulator with the IC-CAP Optimizer, the
message Not a typewriter is reported to the status window. The message is caused
by a call to stty -tostop in the hpeesofsim_start script ( /bin/bootscript.sh ). This
start-up script must be accessed before starting hpeesofsim. The message appears if
hpeesofsim_start is customized by defining a different HPEESOF_DIR, or if it is used
for a remote simulation. This message is benign, and can be ignored, or fixed if
desired.
Workaround: If the message is bothersome, it can be fixed by editing the file
HPEESOF_DIR/bin/bootscript.sh. Change stty -tostop to
ttymsg = "tty"
if [ ! "$ttymsg" = "not a tty" ]; then
stty -tostop
fi

The IC-CAP Main window and the IC-CAP Status window open. The IC-CAP Main window
displays an icon of the model and the Model window opens.

If the Model window does not open, you can open it by double-clicking on the
Model icon.

Note
You can load a model and start a macro when you start the program. At the system prompt, type: iccap
<model_filename> <macro_name>. For details, refer to Autostart Macros (prog).

 Opening a Model File
If you do not load a model file when you start the program, you can open the model file
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from the IC-CAP Main window.

To open a model file from the IC-CAP Main window:

To open an empty model template, choose File > New.
To open a model in the current directory, choose File > Open.
To open a model provided with the program, choose File > Examples.

A directory dialog box is used when data is being written to or read from a file. Initially,
the dialog box displays the files in the directory from which you started the session.
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Note
On the PC, hidden and system folders do not appear in the Directory dialog box. If you can't see a
directory, just change its attributes so it's not a hidden or a system file.

When you select Examples, double-click the model_files directory in the dialog box to
display the directories of the models that are provided with the program (see following
table). Double-click a directory to see a list of models. Double-click a model to select and
open that model.

 Example Directory Model Files
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 Example Model Files



IC-CAP 2011.01 - Introduction and Basics

45

$ICCAP_ROOT/examples/model_files/bjt:

HPEEbjt2.mdl bjt_npn.mdl hpsimnpn.mdl

bjt_ft.mdl bjt_pnp.mdl hpsimvbic.mdl

bjt_ncehf.mdl hpsimbjt_nsehf.mdl mnsnpn.mdl

bjt_nhf.mdl hpsimbjt_nhf.mdl mxt3t_npn.mdl

spectre_ncehf.mdl spectrenpn.mdl vbicsdd.inc

mxt4t_npn.mdl mxt504_npn.mdl sabernpn.mdl

vbic_npn.mdl   

$ICCAP_ROOT/examples/model_files/diode:

HPDiode.mdl
juncap.mdl
pn_diode.mdl
pn_test.mac

$ICCAP_ROOT/examples/model_files/ecl:

ECLgate.mdl
ECLornor.mdl

$ICCAP_ROOT/examples/model_files/hemt:
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HPEEhemt1.mdl

$ICCAP_ROOT/examples/model_files/mesfet:

CGaas1.mdl
CGaashfax.mdl
UCBGaas.mdl
CGaas2.mdl
HPEEfet3.mdl
UGaashf.mdl
CGaashf.mdl
HPRootFet.mdl
hpsimHPEEfet3.mdl

$ICCAP_ROOT/examples/model_files/misc:

54120.demo.mdl
lc.mdl
plot_doc.mac
TRLCAL.mdl
npnwpnp.mdl
sabercirc.mdl
hp54750.mdl
sys110_verify.mdl
sys_test.mdl
sys_testrf.mdl

$ICCAP_ROOT/examples/model_files/mosfet:

mm9.mdl
hpmos28.mdl
mm9_demo.mdl
HPRootMos.mdl
hnmos28.mdl
pmos3.mdl
sabernmos.mdl
hnmos6.mdl
pmos2.mdl
nmos2.mdl
nmos3.mdl

$ICCAP_ROOT/examples/model_files/mosfet/bsim3:

BSIM3_DC_CV_Extract.mdl
BSIM3_DC_CV_Measure.mdl
BSIM3_RF_Extract.mdl
Whats_New.mdl
BSIM3_RF_Measure.mdl

$ICCAP_ROOT/examples/model_files/mosfet/bsim3/tutorial:
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BSIM3_AC_Noise_Tutorial.mdl
BSIM3_CV_Tutorial.mdl
BSIM3_DC_Tutorial.mdl
BSIM3_Temp_Tutorial.mdl

$ICCAP_ROOT/examples/model_files/mosfet/bsim3/utilities:

BSIM3_DC_CV_Finetune.mdl

$ICCAP_ROOT/examples/model_files/mosfet/bsim4:

BSIM4_DC_CV_Extract.mdl
BSIM4_DC_CV_Measure.mdl
BSIM4_RF_Extract.mdl|
Whats_New.mdl
BSIM4_RF_Measure.mdl

$ICCAP_ROOT/examples/model_files/mosfet/bsim4/tutorial:

BSIM4_DC_CV_Tutorial.mdl

$ICCAP_ROOT/examples/model_files/mosfet/bsim4/utilities:

BSIM4_DC_CV_Finetune.mdl

$ICCAP_ROOT/examples/model_files/noise:

noise_simu.mdl

$ICCAP_ROOT/examples/model_files/noise/1_f_toolkit:

bjt_1f_noise.mdl
mos_1f_noise.mdl

$ICCAP_ROOT/examples/model_files/opamp:

mnsopamp.mdl
opamp.mdl

$ICCAP_ROOT/examples/model_files/pulse:

bjt_ncehfp.mdl
opver_k46.mdl
opver_k48a.mdl|
cal_8510_p.mdl
opver_k49.mdl
opver_85124P.mdl|
opver_k48b.mdl



IC-CAP 2011.01 - Introduction and Basics

48

$ICCAP_ROOT/examples/model_files/statistics/load_data:

bsim3_1.mdl bsim3_4.mdl bsim3_7.mdl

bsim3_10.mdl bsim3_40.mdl bsim3_70.mdl

bsim3_11.mdl bsim3_41.mdl bsim3_71.mdl

bsim3_12.mdl bsim3_42.mdl bsim3_72.mdl

bsim3_13.mdl bsim3_43.mdl bsim3_73.mdl

bsim3_14.mdl bsim3_44.mdl bsim3_74.mdl

bsim3_15.mdl bsim3_45.mdl bsim3_75.mdl

bsim3_16.mdl bsim3_46.mdl bsim3_76.mdl

bsim3_17.mdl bsim3_47.mdl bsim3_77.mdl

bsim3_18.mdl bsim3_48.mdl bsim3_78.mdl

bsim3_19.mdl bsim3_49.mdl bsim3_79.mdl

bsim3_2.mdl bsim3_5.mdl bsim3_8.mdl

bsim3_20.mdl bsim3_50.mdl bsim3_80.mdl

bsim3_21.mdl bsim3_51.mdl bsim3_81.mdl

bsim3_22.mdl bsim3_52.mdl bsim3_82.mdl

bsim3_23.mdl bsim3_53.mdl bsim3_83.mdl

bsim3_24.mdl bsim3_54.mdl bsim3_84.mdl

bsim3_25.mdl bsim3_55.mdl bsim3_85.mdl

bsim3_26.mdl bsim3_56.mdl bsim3_86.mdl

bsim3_27.mdl bsim3_57.mdl bsim3_87.mdl

bsim3_30.mdl bsim3_58.mdl bsim3_88.mdl

bsim3_31.mdl bsim3_59.mdl bsim3_89.mdl

bsim3_32.mdl bsim3_6.mdl bsim3_9.mdl

bsim3_33.mdl bsim3_60.mdl bsim3_90.mdl

bsim3_34.mdl bsim3_61.mdl bsim3_91.mdl

bsim3_35.mdl bsim3_62.mdl bsim3_92.mdl

bsim3_36.mdl bsim3_63.mdl bsim3_93.mdl

bsim3_37.mdl bsim3_64.mdl bsim3_94.mdl

bsim3_38.mdl bsim3_65.mdl bsim3_95.mdl

bsim3_39.mdl bsim3_66.mdl bsim3_96.mdl

bsim3_28.mdl bsim3_67.mdl bsim3_97.mdl

bsim3_29.mdl bsim3_68.mdl bsim3_98.mdl

bsim3_3.mdl bsim3_69.mdl load_stat_data.mdl

Note
Additional examples are located in $ICCAP_ROOT/examples/demo_features which contains examples that
answer questions IC-CAP users ask most often. For information about the demos, open the README.mdl
file in the /demo_features directory.

 IC-CAP File Extensions
Each file type has a unique file extension that is added to the filename automatically. The
following table lists these file extensions.
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 IC-CAP File Extensions

Extension File Type

.cir Circuit

.dps DUT Parameters

.ds Dataset

.dut DUT

.hdw Hardware

.inp Input

.iot Instrument Options

.mac Macro

.mdl Model

.mdm Data Manager

.mps Model Parameters

.out Output

.plt Plot

.pop Plot Optimizer

.set Setup

.tci Test Circuit

.vat Variables Table

.xfm Transform

 Changing Directories
When you load an example model, the directory path for the model icon in the IC-CAP
Main window points to the installation directory. You can redirect the path to your working
directory before saving the model data.

To change directory paths:

Select File > Change Directories.1.
Edit the selected path by typing a new name in the Selection field or by browsing the2.
Directories list to the new directory.

Note
The path for IC-CAP model files cannot contain any folder names that use a space. For example,
C:\Model Files\IC-CAP 2004. If a model file is saved in a folder name with spaces, you will not be
able to open the model file. You will have to move the model file to a folder name that does not use
a space.
On the PC, hidden and system folders do not appear in the Directory dialog box. If you can't see a
directory, just change its attributes so it's not a hidden or a system file.

Choose OK to set the selected path.3.
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 The Model Window Folders
The Model window contains sets of folders where you can view and edit the Model, DUTs,
and Setups. This example describes each folder briefly. The folders are described in detail
in the following sections.

 Setting System Variables
Variables can be defined at the top level (system) or at the Model, DUT, and Setup levels.
You can define as many variables as you need and use these variables for other functions,
such as extractions.

A set of predefined variables are supplied with the program. If you want to alter behavior
of IC-CAP defaults and/or define new default behavior, you can set a system variable.
Also, you can set a system variable to function as a toolbox for miscellaneous control
parameters and save the set as a file so you can reuse it for different models.



IC-CAP 2011.01 - Introduction and Basics

51

Note
For details on predefined system variables, refer to Variables (prog).

To view system variables:

In the IC-CAP Main window, select Tools.1.
Select System Variables.2.
The System Variables window opens. Click System Variables to view predefined3.
variables.

In the dialog box, select a Variable Type from the Variable Types list. Then select a4.
Variable in the Variables list.
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The selected variable and value appears in the Variable and Value fields. If5.
appropriate, edit the Value field.
Click Apply to add the variable to the System Variables list.6.

When you have added all the system variables, click OK to close the dialog box.7.

 Saving Model Data
You can save IC-CAP information at several levels. For example, in the Model window:
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The parameter set can be saved before extractions are performed and restored if the
extracted values are unacceptable.
An entire setup can be saved for future restoration in order to make temporary
changes to information such as input voltages.
An output can be saved if you want to attempt another measurement but are not
sure if the results will be improved.
A snapshot of an entire model, or of all open models, can be made and used as a
general-purpose backup.

Note
The path for IC-CAP model files cannot contain any folder names that use a space. For example, do
not save to C:\Model Files\IC-CAP 2006. If you include a space in a folder name, you will not be able
to load the model file. You will have to move the model file to a folder name that does not use a
space.

To save model data from the Model window:

Select Save. 1.
Choose from the save options: save the entire model file, the active DUT, the active2.
setup, or the active plot, and save without the measured/simulated data.

In the File Name field, type a unique filename and choose OK.3.

To save model data from the IC-CAP Main window:

Select Save. 1.
Select the open models you want to save.2.
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In the File Name field, enter a unique filename and click OK.3.

Note
If a file was saved previously by that name, an information dialog box opens.

To replace the existing model by that name, choose Yes.

To avoid replacing the existing model by that name, choose No and enter a unique file name. Or use
the Save As command to save the model to different name.

You can use the same name as the supplied file, as long as you save the model to a different
directory. For details on changing directory paths, refer to Changing Directories.

 Tools
The Tools menu in the IC-CAP Main window provides access to a variety of features and
options.

 System Variables

Displays a window for viewing global (system) variables. For details, refer to Setting
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System Variables and Variables (prog).

 System GUI Items

Displays the System GUI Items window. For details, refer to Creating Graphic User
Interfaces (prog).

 Simulation Debugger

Displays the Simulation Debugger window. For details, refer to Using the Simulation
Debugger (sim).

 Stop Simulator

Stops any currently running piped simulator. The command is most useful when using the
ADS simulator with the Root model to ensure correct simulations can be made after
changing directories to test other models, and to allow model regeneration.

 License Status

Displays a window with dynamically updated license information:

The codewords currently in use
The codewords currently available

To release a specific license, select it and click Release.

 Hardware Setup

Displays the Hardware Setup window. For details, refer to Configuring the System (meas).

 Statistics

Launches the IC-CAP Statistics program, if licensed. IC-CAP Statistics provides tools for
identifying and analyzing the inter-relationships between device model parameters and
electrical test data. For details, refer to Statistical Analysis (stat).

 Select Simulator

Displays a dialog for changing the default simulator after startup.
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Note that this selection is overridden by a SIMULATOR variable. For details, refer to
Selecting a Simulator (sim).

 Functions

Displays the Function Browser dialog box for reviewing available functions. For details,
refer to Using Transforms and Functions (prog).
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 Plot Options

Displays the Plot Options dialog box for defining trace options, plot options, and text
annotation. For details, refer to Setting Plot Options (intro).
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 Options

Displays the following options:

File Debug-Toggles the debugging facility on and off. When on, messages are
recorded in the file .icdebug.
Screen Debug-Toggles the debugging facility on and off. When on, messages are
displayed in the IC-CAP Status window.
View GUI Pages-Toggles displaying the GUI Items page on and off. When on, you will
see a GUI Items page at the Model level, DUT level, and Setup level.
Status Window to Top-If toggled on, the Status window pops to the front of the
screen anytime new messages are displayed in it.
Diagnostics-Executes internal diagnostics.
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 Aborting an Operation
You can interrupt an IC-CAP activity from the Status window. The operations that can be
aborted are: Measurement, Simulation, Macro Execution, Transform Execution, and
Optimization. IC-CAP control is returned to you.

If you abort a measurement while an internal system sweep is in progress, the
measurement in IC-CAP is aborted, but the instrument continues to step through its
sweep values until the sweep is completed. If another IC-CAP measurement using this
instrument is attempted before the sweep is completed, IC-CAP waits until the sweep is
done before performing the measurement.

After an optimization is aborted, an optimization summary is printed before control is
returned.

To abort an IC-CAP activity:

In the IC-CAP/Status window, click the Interrupt IC-CAP Activity button.

Alternatively, you can select the menu item, Interrupt > IC-CAP Activity.

 

 Exit IC-CAP
To exit IC-CAP, select File > Exit in the IC-CAP Main window. This opens the Save As
dialog box to give you an opportunity to save changes to models before exiting the
program. Click on the Exit button to automatically close all open windows and terminate
the program.
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 An Example IC-CAP Session
Using the IC-CAP Modeling System, you can characterize a device by following this general
procedure:

Start the IC-CAP program and load the model file into memory.1.
Measure the device characteristics.2.
View the measured data.3.
Perform a simulation.4.
Extract the model parameters from the measured data.5.
Simulate with extracted parameters.6.
Compare measured data and simulated data.7.
Optimize model parameters as needed.8.
Measure the remaining devices.9.

Note
Your IC-CAP installation may not be identical to the system described. Depending on the options of your
IC-CAP product, you may not be able to perform some portions of this demonstration. In such cases, an
error message describes the missing codeword or license. For more information, refer to the installation
procedures or consult your system administrator.

IC-CAP supplies various model extractions in model files which you can load and work with
immediately. This section provides an example of a typical IC-CAP session, using a
supplied model file.

 Starting IC-CAP
To start the program for the first time:

Change to the working directory.1.
At the system prompt, type iccap and press Enter.2.

or

Navigate to Start > Programs > IC-CAP <version number>.

The IC-CAP Main window and IC-CAP Status window open.
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 Opening a Model File

In the IC-CAP Main window, choose File > Examples or click Examples icon 1.
on the toolbar. The File Open dialog box displays the directories of model file
examples.
The model_files directory is located in your IC-CAP installation directory under the
IC-CAP installation path\ICCAP_2010_08\examples\model_files.
Double-click model_files directory to view the categories of the models that are2.
provided with the program.
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Double-click the mosfet directory. Select nmos2.mdl and click Open to open the3.
example nmos2.mdl model file. An icon of the model file is displayed in the IC-CAP
Main window and the Model window opens.
The nmos2.mdl example extracts the parameters for Level 2 N-channel UCB
MOSFET transistor.
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3.

 Viewing the Circuit Description
The Circuit description defines the device topology and parameters to be extracted.

To view the default values of the parameters and circuit definition, click Circuit tab in
Model window.

The circuit definition begins with the Options definition (.OPTION). The definition lists the
device to be measured, the device nodes, the name of the model card that contains the
model parameters used by the device, and the device parameters.

 Circuit Options Definition
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The next section is the model card definition (.MODEL). The definition lists the name of the
model card, the model type, and the contents of the model card. The contents of the
model card consists of the parameters that are to be extracted (model parameters) and
their assigned initial values.

 Circuit Model Definition

 Defining Model Parameters
The Model Parameters displays the current parameter values. These parameters are
common to all DUTs for that model and are used in a simulation. When a new model is
read, these values are set to the defaults defined in the circuit. The values change after
extractions and optimization are performed.

To view and define the model parameters, click Model Parameters tab in the Model
window.
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The Parameters table contains the same names as those specified in the MODEL definition
of the Circuit. However, by editing the table, the values can be set independently of those
in the circuit definition and can be specified as a real number or an equation. In addition,
you can set limits by entering minimum and maximum values for each parameter.
Parameter values that are outside their limits are clamped to their minimum or maximum
values.

After editing the defaults, click Memory Store All to store the current set of parameter
values in a temporary buffer or Memory Recall All option to recall these values anytime
during the IC-CAP session. If you prefer, you can also restore the default values by
clicking Reset All.

Note
The values stored using Memory Store All option are not saved in the model file and are lost when the
IC-CAP session ends.

 Defining Model Variables
Model Variables can be defined at the top, system, or at the Model, DUT and Setup
levels. You can define as many variables as required and use these variables for functions,
such as extractions. Model variables can be accessed by any of the components of a
model, including the DUTs and setups, while DUT and Setup variables (such as inputs or
outputs) can be accessed only by the components of that setup. The Model Variables
contains the names and values of all variables that are global to the model.

A useful example of a variable defined at the model level is the compliance limit for
measurements. Typically, compliance values are defined for each input in a setup.
You can refer all of the compliance values in a model to one variable defined at the model
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level by creating a compliance variable for the model. This compliance variable can be
modified to change the compliance values for all inputs in the model.

To view the current values of the model variables, click Model Variables tab in the Model

window. To view system defaults from the Model Variables folder, click the 
button.

 Defining a New Variable

To define a new variable:

Type the variable name in the first empty Name field row.1.
Press Tab to move the cursor to the Value field. Type a value for the variable.2.
Press Enter to accept the value and open a new row.3.

Do not attempt to enter an expression when editing model variables. Expressions in variables are
not evaluated when the variables are referenced. If a variable is used in a numeric expression, enter
a single number only.
Do not enter the name of a variable table variable into the value field. The value of the variable is
not evaluated when the variable is referenced.

 Defining DUT Options
IC-CAP models usually contain several DUTs. DUTs contain groups of setups that have a
similar physical connection to the device. Each DUT contains its own DUT parameter set
and test circuit. If two setups require differences in either of these areas, you must define
a different DUT for each. Before you can measure a device, you must make any needed
changes to the DUT options. The DUT-Setup tab displays the DUTs and setups in the
model. You can define DUT options through Test Circuit, DUT Parameters, and DUT
Variables.

To view the DUT options and make a device active, click DUTs-Setups tab in Model
window. Then, select the DUT (for example, large). You can view the setup list by
expanding the DUT.
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 Accelerator Pop-Up Menus

In the DUT/Setup tree structure, you can view pop-up menus which allow you to perform
actions on DUTs and Setups easily. To view the menus, right-click with your mouse
pointer over a DUT or Setup name. The menus for a DUT and a Setup are different. The
commands available in the menus enable you to perform selected actions that are allowed
for the DUT/Setup. These are the same actions that are available in the Model window's
main menu bar and folders. The pop-up menus save time by enabling you to perform an
action on a DUT or Setup while avoiding the time required to display the folder contents in
the work area.

As you work through this example, try also using these pop-up menus to perform the
actions. The contents displayed in the Model window's work area depends on the
DUT/Setup folder currently displayed in the work area, and which pop-up menu item you
right-click on. When you right-click on a DUT or Setup, it is selected just as if you left-
clicked on it. For a DUT or Setup folder displayed in the work area, if you perform an
action from the pop-up menu normally associated with a different folder, the associated
folder is not displayed in the work area. If a folder is currently shown, and you right-click
on a different DUT or Setup, the current folder closes so there is no inconsistency between
the selected DUT or Setup and the work area.

 Defining a DUT Test Circuit

You can use the Test Circuit tab to attach additional circuitry between the device or
circuit being modeled and the measurement hardware. For example, an OpAmp may need
to be connected in different configurations for different measurements. For complete
information on defining Test Circuits, refer to Simulating (sim).
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 Defining DUT Parameters

You can edit the values of parameters that change from one DUT to another (such as,
channel length and width for a MOSFET). In addition, you can set limits by defining
minimum and maximum values for each parameter. If a parameter value is outside its
limits, it will be clamped to its minimum or maximum value. After editing the values, you
can temporarily store the current set of parameter values ( Memory Store All ), recall
stored parameter values ( Memory Recall All ), apply the changes to the circuit definition
( Update Circuit ), reset the default values specified in the circuit definition ( Reset All
).

To view the DUT parameters, click DUT Parameters. The Import Text option allows you
to reuse a circuit text file.

 Defining DUT Variables

The DUT Variables tab contains the names and values of all variables that are global to

the DUT. To view system defaults from the DUT Variables, click the  button.

To view the DUT variables, click DUT Variables.
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 Defining Setup Options
You can define setup options from the DUT-Setup panel. A setup contains definitions for
inputs, outputs, instrument options, measuring and simulating, and results.

To view and edit a setup, select a setup from the DUT-Setup panel.

To detach the setup window for convenient editing, click Detach below the DUT/Setup tree.

The Measure/Simulate window allows you to define the inputs and outputs for a particular
setup.
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 Viewing or Editing Input or Output

Setup input and output data are listed in a table (sometimes called a tile ). You can edit
input and output in one of the following two methods:

Method 1 - Edit directly in the table. Click or double-click a field and type the new
data.

Method 2 - Use the Input or Output Editor. To open the Input or Output Editor, first
select the table and then click Edit. Edit the fields and click OK.
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Output parameters can be derived from Measured data, Simulated data, or Both.

To view the raw data for an input or output, select one or more tables then click View.
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Note
You can enable the Input/Output Finder mode in the Measure/Simulate folder. The Input/Output Finder
mode adds an area that lists the Setup's inputs and outputs. When enabled, you can quickly bring data
into view by selecting one or more of the inputs and outputs in the list.

To enable the mode for a Setup, open the Setup Variables folder. Enter the variable name
SHOW_INPUT_OUTPUT_FINDER in the Name field, then enter yes, true, or a non-zero integer in the Value
field. If you change the variable's setting after opening the Model, you must close (File > Close), then
reopen, the Model window for the new setting to take effect.

 Viewing or Editing Instrument Options

The Instrument Options table is available after the hardware has been set up.

To edit instrument options, select the Instrument Options folder.

For details on Hardware Setup, refer to Configuring Hardware and Performing
Measurements (meas).

 Defining Setup Variables

The Setup Variables tab contains the names and values of all the variables that are
global to a Setup.

To view the Setup variables, click Setup Variables tab in the Model window.

 Measuring the Device
The measurement on the devices provides sufficient information for extracting a full set of
model parameters. To avoid errors, measuring devices, and extracting parameters must
be performed in a specified order.
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Note
For detailed procedures on measurement order, refer to the tutorial for your model.

To initiate the measurement using the active setup, select the setup and click

Measure Setup icon .
To initiate the measurement using all setups in the active DUT, select the DUT and
choose Active DUT from Measure menu in the Model window.

 Performing a Simulation
You can determine the accuracy of current parameter values by performing a simulation
and comparing the results to the measured data.

To perform a simulation on the active setup, select the setup and click Simulate

Setup icon .
To perform a simulation on all setups in the active DUT, select the DUT and choose
Active DUT from Simulate menu in the Model window.

 Extracting Model Parameters
Agreement between two sets of data is not always good prior to extraction. IC-CAP
modules provide standard device extractions, as well as macros for performing an
extraction. If the model you are using does not have macros available, you can set the
criteria in the Transforms folder.

 Viewing or Editing Transforms

You can choose from a large variety of functions to use for extracting model parameters in
a Transform.

To view or edit transforms:

Select a setup.1.
Choose the Transform as extract under the Extract/Optimize.2.

Click Browse to view the Function list.3.
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Select a Function from the Functions list and click Select.4.

 Setting Initial Values Using a Macro

The initial values of the process-dependent parameters for the extraction are entered
using a macro.

To run a macro:

Click Macros tab in Model window.1.

Choose init_parameters from the Select Macro list and click Execute.2.

You can also execute the macros from the Model window's main menu. Click Macros > Execute
and then select the macro you want to run.

Enter the initial values in the series of prompts.3.
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3.

 Performing an Extraction

You can extract all extraction transforms in the active setup or extract all setups in the
active DUT.

To perform an extraction on all extraction transforms in the active setup, select the

setup and click Extract Setup .
To perform an extraction on all extraction transforms in all setups in the active DUT,
select the DUT and choose Active DUT from Extract menu in the Model window.

When you extract all the setups in an active DUT, the extractions are performed in the
left-to-right order listed in the setup. This order is usually critical to proper extraction
performance.

Note
For detailed procedure on extraction order, refer to the tutorial for your model.

Typically, extractions are completed instantly. The newly extracted model parameter
values are listed in the IC-CAP Status window and are placed in Model Parameters.

 Simulating with Extracted Parameters
After extracting the model parameters, you can perform a simulation with the extracted
parameters and compare the results to the measured data.

To perform a simulation:

On an active setup, select the setup and click Simulate Setup icon .
On all the setups in the active DUT, select Active DUT from Simulate menu in the
Model window.

Repeat the simulation procedure for each DUT in a model. You can observe the differences
in output that result from changes to various model parameters. For example, change the
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value of one or more parameters. Then, run a simulation and view the changes in the plot.

 Optimizing the Model Parameters
To achieve greater accuracy, you can optimize the model parameters. This optional step
obtains the best possible fit between measured and simulated data by altering the
parameter values iteratively until the difference between the data sets is minimized. Since
repeated simulations are required, optimization is more time-consuming than an
extraction.

To perform an optimization:

Select a setup (for example, idvg).1.
Select the Transform as optimize under the Extract/Optimize tab.2.
Define the Inputs, Parameters, and Options for the selected Transform. For more3.
details on these Transform parameters, refer to Using Transforms and Functions
(prog).

To perform an optimization on an active setup, select the setup and click Optimize4.

Setup icon .
To perform an optimization on all setups in an active DUT, select Active DUT from5.
Optimize menu in the Model window.

 Measuring the Remaining Devices
To complete the characterization, you must measure the remaining devices by repeating
these steps for the other DUTs present in the model.

To measure:

All the setups in a DUT with multiple setups, select Active DUT from Measure menu
in the Model window.

A setup in a DUT, click Measure DUT icon  on the Model window toolbar.
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 Viewing the Results
Click Plots tab in the Setup window to view the results of the measured data. The Plot
Finder lists the plots available for a Setup. If there are multiple plots, select a plot you
want to view. You can view multiple plots by pressing the Ctrl key while selecting the plot
names in the list.

To view the measured data, click View.

 Editing the Data Table Setup

You can edit the setup for the data table through one of the following two methods:

Method 1 - Edit directly in the table. Click or double-click a field and type the new1.
data.



IC-CAP 2011.01 - Introduction and Basics

78

1.

Method 2 - Use the Plot Editor. To open the Plot Editor, select a table and then2.
click Edit (or double-click on the table) to open the Plot Editor. Make changes in the
respective fields and click OK.

For a complete description of the Plot Editor fields, refer to Printing and Plotting (intro). To
view the plot, click Display Plot or Display All. The IC-CAP/Plot window opens. The
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following figure shows examples of results.

 Examples of Displayed Results

You can define display options by selecting Options in the Plot window. For more details,
refer to Printing and Plotting (intro).
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 Saving the Model
When the characterization process is complete, you can save the model to a file.

To save the model to a file:

Select Save. 1.
You can save a model into various file types. Choose the File Type to save the model2.
to a specific file type.

Type a unique name (such as, mybjt_npn.mdl) in the File Name field.3.
Click OK to save.4.

 Exiting IC-CAP
To exit IC-CAP, select File > Exit in the IC-CAP Main window. This opens the Save As
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dialog box to give you an opportunity to save changes to models before exiting the
program. Click on the Exit button to automatically close all open windows and terminate
the program.
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 Creating and Modifying Models
In IC-CAP, all of the information required to characterize a particular device or circuit is
contained in a model. With a variety of model configurations available, you can easily
create new models by copying and/or modifying existing models. The changes may be
structural (such as the addition or removal of setups) or may involve modification of table
values only.

Note
Before starting this section, you must configure the necessary source and measuring instruments for the
IC-CAP system. For information on configuring the system, refer to Customization and Configuration
(custom).

 Model Components
The IC-CAP model components are shown in the following figure. A model consists of
these components:

Circuit - Description of the circuit used to represent the actual device.
Model Parameters - Values used in simulating the circuit.
Model Variables - User-defined variables that are global to a model.
DUTs - Representations of different physical devices or measurement configurations.
Macros - Combinations of the available menu functions used to create complex
operations.

 IC-CAP Model Components

 DUTs and Setups

Each DUT contains:

Test Circuit - Description of the circuit used in a particular DUT.
DUT Parameters - Values for parameters specific to a DUT.
DUT Variables - User-defined variables that apply only to a DUT.
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Setups - Define measurements and simulations for a DUT.

Each setup contains:

Inputs - A definition of the input stimuli.
Outputs - A definition of the types of responses to monitor.
Transforms - Specifications for different data manipulations, such as mathematical
functions and extractions.
Plots - Data display, in a variety of formats.
Setup Variables - User-defined variables that apply only to a setup.
Instrument Options - Instrument options control the state of the hardware for a
setup.

 Defining Model Components
When you create an IC-CAP model, you must define the components. You can create a
new model and then describe its physical and electrical characteristics or you can load and
modify an existing model. Some components, such as user-defined variables and test
circuitry, are optional.

The general procedure for creating a model is:

Add a model to the work area.
Define variables that are global to the model.
Define the device or circuit to be characterized.
View and modify the parameter values to be used in the simulations.
Add new (or modify existing) DUTs.

If necessary, define a test circuit.
Edit device parameters specific to the DUT
Define variables that are global to the DUT.
Add new (or modify existing) setups.

For each setup, define the following:
Inputs to the device or circuit.
Outputs to monitor.
Variables global to the setup.
Values of instrument options for all instruments used in a setup.
Transforms, including mathematical functions and extractions.
Plots that specify graphical and tabular formats for the data.

Note
For an example, see Creating a New Model.

 Adding a Model to the Work Area
You can add a model to the work area in one of two ways:

Open an empty template
Open an existing model
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To open an empty template:

In the IC-CAP/Main window, click Create Model on the toolbar. 1.

An icon representing a new untitled model appears in the IC-CAP/Main
window.

To open the Model window, double-click the model icon.2.

To open an existing model:

In the IC-CAP/Main window:1.

Click Open to open a model in the current directory 

Click Examples to open a model provided with the program 
In the dialog box, double-click model_files to see the list of model directories, or2.
double-click demo_features to see the list of demonstration directories.
Double-click on a directory name, then click on a model name in the Files list to3.
select a model file.
Choose OK to accept the selection and close the dialog box.4.

An icon of the model file displays in the IC-CAP/Main window and the Model
window opens. If the model displays as an icon only, double-click the icon
to open the Model window.

 Renaming a Model in the Work Area
Click to highlight the model name in the work area.1.
Retype a new name and press Enter.2.

 Saving Model Files
Before modifying a new model, you can save the model file to different name.

To save model data from the IC-CAP/Main window:

Select a model icon in the IC-CAP/Main window, then select Save As. 1.
Select the open models you want to save.2.



IC-CAP 2011.01 - Introduction and Basics

85

In the File Name field, enter a unique filename and click OK. The new model name3.
appears in the directory list.

If a file was saved previously by that name, an information dialog box
opens.

To replace the existing model by that name, choose Yes.
To avoid replacing the existing model by that name, choose No and
enter a new file name to save the model to different name.

You can use the same name as the supplied file, as long as you save the
model to a different directory. For details on changing directory paths, refer
to Changing Directories (intro).

 Copying Parts of a Model
You can create a set of models, or parts of a model, that are similar to each other by
using the Copy command. You can copy any part of the model that you can select. For
example:

To copy the circuit definition, parameter set, or variable table, open the Circuit,
Model Parameters, or Model Variables tab.
To copy an entire DUT, select the DUT.
To copy an entire setup, select the Setup.
To copy an input, output, transform, or other table in a setup, select the table (by
clicking on the outside ruling) or tab.

After copying, you can place the copied parts into the new model and modify the copied
parts.
To copy parts of an existing model:

Open the model and select the parts you want to copy.1.

Select Edit > Copy [part type] or click Copy on the toolbar. 2.
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To place the copied parts in the new model:

Place the cursor in the folder where you want to put the copied parts.1.

Select Edit > Paste [part type] or click Paste on the toolbar. 2.

Note
To copy an entire DUT or Setup in a model, right-click on the DUT or Setup you want to copy to
view the pop-up menu, then select Edit > Copy. To paste a Setup into another DUT, right-click on
the DUT, then select Edit > Paste. To paste a copied DUT into another model use the directions in
the procedure above.

 Specifying the Circuit Definition
The circuit definition specifies the parameters to be extracted and the representation of
the model in the simulator. The parameter values act as defaults in IC-CAP. In the
supplied model files, these values are usually set to SPICE defaults. However, you may
want to specify values for the devices or circuits that you plan to characterize, since
extractions and optimizations run faster if starting parameter values are closer to the final
values. For a complete description of the types of circuits that can be defined, refer to
Simulating (sim).

 Example

The example circuit is a supplied model, nmos2.mdl, that extracts parameters for the
Level 2 N-channel UCB MOSFET transistor.

.OPTIONS ucb

M1 1=D 2=G 3=S 4=B MOSMOD L=2u W=3u AD=9p PD=12u AS=9p PS=12u

.MODEL MOSMOD NMOS

+ LEVEL = 2

+ UO = 600

+ VTO = 0

+ NFS = 0

+ TOX = 100n

+ NSUB = 1e15

+ UCRIT = 10.00K

+ UEXP = 0

+ VMAX = 1MEG

+ RS = 0

+ RD = 0

+ XJ = 0

+ LD = 0

+ DELTA = 0

+ NEFF = 1.00

+ NSS = 0

+ CGSO = 0

+ CGDO = 0

+ CGBO = 0

+ CBD = 0

+ CBS = 0

+ CJ = 0

+ MJ = 0.5

+ CJSW = 0
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+ MJSW = 0.33

+ IS = 1.0E-14

+ PB = 0.8

+ FC = 0.5

The circuit definition begins with the Options definition (.OPTION). The definition lists the
device to be measured, the device nodes, the name of the model card that contains the
model parameters used by the device, and the device parameters. In the example:

The first item identifies the device to be measured, M1. The character M indicates
that the device is a MOSFET.
Next, the device nodes are identified (1 = drain, 2  =  gate, 3  =  source, 4  =  bulk
(substrate).
The next item, MOSMOD, is the name of the model card that contains the model
parameters used by the M1 device.
The remaining items in the Options definition specify device parameters. For real
devices, refer to the design specification for the values of device parameters.

The next section is the model card definition (.MODEL). The definition lists the name of
the model card, the model type, and the contents of the model card. The contents of the
model card consists of the parameters that are to be extracted (model parameters) and
their assigned initial values. In the example:

The name of the model card is identified (MOSMOD), then the model type N-channel
(NMOS).
The remaining lines are the contents of the model card. These consist of the
parameters that are to be extracted (model parameters) and their assigned initial
values. The leading + indicates that each parameter follows the preceding just as if
all the parameters had been entered on a single line.

To specify the circuit definition:
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In the Model window, click Circuit to open the folder.1.

Edit the existing values by selecting the value and typing over it.2.
When you move the mouse pointer out of the window, the new circuit description is3.
parsed automatically. This parse only occurs after a change has been made to the
contents of the circuit description.

Syntax errors are reported in the IC-CAP/Status window and must be corrected. For
example, if the wrong type of simulator is selected and syntax errors result from the
parse, you must parse the circuit after the correct simulator is specified.

To parse the circuit definition manually, click Parse.

Note
You can copy the circuit definition from an existing model. Open the model you want to copy. Open the
Circuit folder. Select Edit > Copy Circuit. In the new model, select Edit > Paste Circuit.

 Advanced Netlist Features

In order to populate the Model Parameter Set and properly netlist the circuit at simulation
time, IC-CAP must 'Parse' the entered circuit to identify external nodes, the model name,
and all the parameters. IC-CAP can parse general spice syntax, Agilent ADS Simulator
syntax, SABER syntax and SPECTRE syntax. The parser used is dependent on the
template name used in usersimulators or optional open parser interface parsing module.
See Linking a Simulator to IC-CAP (sim).

If using a keyword or netlist syntax that is beyond the scope of the parser built into IC-
CAP, it will be unable to properly read the netlist syntax and will issue a parsing error
even though the netlist could be sent to the simulator being used and the simulator would
accept it. It is possible to send parts of your netlist directly to the simulator by 'hiding'
them from the IC-CAP parser with the keyword #echo. Any text following the keyword
#echo will be ignored and copied to the output netlist unaltered apart from three
keywords to be discussed later. Suppose the newer .PARAM HSPICE keyword is not
recognized by the general spice parser in IC-CAP, this line can still be sent to HSPICE
using #echo

 Example

#echo .PARAM xyx=4
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In addition, to #echo, three keywords may be used behind a #echo line to create
parameters and one keyword may be used to substitute the text value of a named
variable from a variable table if it exists. When using these keywords, the keywords are
substuted with the parameter value from the parameter table or variable value from a
variable table before the netlist is sent to the simulator. The three keywords that create
parameters are $mpar, $dpar, and $xpar and the keyword that can substitute text from
a variable if it already exists is $var. The syntax is the same for all and includes a
parameter/variable name and default value assignment We can extend the previous
example to use $mpar.

 Example

#echo .PARAM xyx=$mpar(xyx=4)

When IC-CAP reads this line it will send everything after the #echo to the simulator
except the $mpar(xyz=4) portion. That portion will be completely substituted with the
value of the model parameter xyz which will be created as a result of the $mpar keyword.
If the user had set the model parameter xyz to 12, then when the netlist is created for
simulation, the simulator would see:

 Example When Simulated

.PARAM xyz=12

The difference between $mpar, $dpar, and $xpar is as follows:

$mpar If used in the model circuit, these parameters are created in the Model
Parameters table of the model. If used in a DUT level Test Circuit, they are treated as
device parameters that will appear in Device Parameters of that DUT only.
$dpar If used in the model circuit, these parameters will appear in all DUT Device
Parameter tables. Apart from that they will be treated as regular parameters. If used
in a DUT level Test Circuit, they will act just like $mpar parameters and will appear
in that DUT only.
$xpar These parameters behave like $dpar described above, with one key
difference. When IC-CAP netlists the device instance line for the simulation, $xpar
parameters will be netlisted along with this line to be passed to the model or circuit
to be simulated. Consider the simple diode circuit:

 Example

D1  1 = A  2 = C  DIODE AREA=1

.MODEL DIODE D IS = 1E-14 N = 1.0

When simulated, the above netlist will be sent to spice2 as:

 Example When Simulated
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Simulation Input File

.options

+ TNOM = 27

.MODEL diode D

+ IS = 1.001E-014

+ N = 0.9997

DCKT 1 2 diode

+ AREA = 1.1

* START SOURCES

VAGRO 1 0 DC 0

VCGRO 2 0 DC 0

* END SOURCES

.DC VAGRO 0.3 1 0.025

.PRINT DC I(VAGRO)

.END

Notice that the values in the Model Parameter page for IS, N, and AREA differ from those
specified in the netlist-- when simulating IC-CAP always uses the values from the Model
Parameters and Device Parameters tables. The lines of the netlist up until the DCKT line
are taken from the Test Circuit and Model Circuit with only the device name and nodes
and parameter values being substituted for the current simulation. However, the DCKT
line is completely fabricated based on the D1 line provided in the netlist. To understand
the difference between $xpar and $dpar consider the netlist below when compared with
the example above.

 Example

#echo $xpar(AREA=1)

#echo * This is a comment referencing $xpar(AREA2=1)

#echo * this is just a comment noting that unused device parameter ex=$dpar(ex=12)

D1  1 = A  2 = C  DIODE

.MODEL DIODE D IS = 1E-14 N = 1.0

Here we do not specify AREA on the D1 line, but we want IC-CAP to treat AREA in the
same way so we use $xpar. By contrast we create a $dpar parameter for the parameter
ex. Observe how ex and AREA are treated differently when netlisted for the simulator:

 Example When Simulated

Simulation Input File

.options

+ TNOM = 27

* This is a comment referencing

* this is just a comment noting that unused device parameter ex=13

.MODEL diode D

+ IS = 1.001E-014

+ N = 0.9997

DCKT 1 2 diode

+ AREA = 1

+ AREA2 = 1

* START SOURCES

VAGRO 1 0 DC 0

VCGRO 2 0 DC 0

* END SOURCES
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.DC VAGRO 0.3 1 0.025

.PRINT DC I(VAGRO)

.END

AREA and AREA2 are netlisted with the DCKT line like the previous example. This is
because $xpar was used which specifies that such parameters are to be netlisted on the
instance line. The parameter ex in contrast is defined using $dpar() which only has the
simple substitution effect of placing the current value from the device parameter table
(13) in its place of the text behind the #echo. Not only is the $xpar netlisted with the
instance line, it is not substituted in the #echo line that defines it (see the #echo for
$xpar(AREA2=1)). In fact, if no other text is specified behind the #echo apart from the
$xpar specification, the #echo line is not sent to the netlist at all (see the #echo line that
defines $xpar(AREA=1)).

Finally, $var differs from the previously discussed 3 keywords in three ways. First it will
not create a variable-- it will only do the substitution if the variable is found. If no variable
is found it will instead use the default value specified. Secondly, the substitution is always
text (or string) based. That is a variable having a numeric value is never treated as a
number so PARAMETER_PRECISION or WORKING_PRECISION will have on effect on this
substition. The value part of the $var(name=value) may be specified with quotes
$var(myvar="default value"). Finally, the variable is searched from the setup being
simulated so it is possible to have each setup provide a different string substitution if each
setup has the same variable defined with different values.

 Example

#echo include "$var(path="/users/icuser/mycir.va")"

 Implementing Macro Models

Macro modeling provides a powerful method for defining and simulating new models in IC-
CAP. The approach is particularly useful when a complex topology is required. There are
several ways to create macromodels. For example, enter the model in the form of a circuit
definition and include any model component that is supported by SPICE. Another method
is to enter new model equations using the dependent voltage and current sources,
although the equations for these sources are limited to polynomial functions.

 Specifying Model Parameters
The Model Parameters folder displays the current parameter values. These parameters are
common to all DUTs for that model and are used in a simulation. When a new model is
read, these values are set to the defaults defined in the circuit. The values change after
extractions and optimization are performed.

To view the model parameters, select the Model Parameters folder.
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The Parameters table contains the same parameters as those specified in the MODEL
definition of the Circuit. However, by editing the table, the parameter values can be set
independently and can be specified as a real number or an equation. In addition, you can
set limits by entering minimum and maximum values for each parameter. Parameter
values that are outside their limits are clamped to their minimum or maximum values.

Note
The value fields can be set either to an actual number or to functions of other data available in IC-CAP.
For example, if you enter RS as the value for the RD parameter, this parameter is always equal to the RS
parameter.

To edit the model parameters:

In the Model window, select Model Parameters.1.
Edit the parameter value fields and select an action from the following:2.

To temporarily store the current set of parameter values, click Memory Store
All.
To recall stored parameter values, click Memory Recall All.
To reset the default values specified in the circuit definition, click Reset All.

Note
You can copy a current set of parameter values from an existing model. Open the model you want to
copy. Select the Model Parameters folder. Select Edit > Copy Parameter Set. In the new model,
select Edit > Paste Parameter Set.

 Setting Model Variables
Variables can be defined at the IC-CAP system level or at the model, DUT and setup
levels. You can define as many variables as you need and use these variables for other
functions, such as extractions.

The Model Variables folder contains the names and values of all variables that are global
to the model.

Note
Do not attempt to enter an expression when editing model variables. Expressions in variables are not
evaluated when the variables are referenced. If a variable is used in a numeric expression, enter a single
number only.

Do not enter the name of a system variable into the value field. The value of the system variable is not
evaluated when the variable is referenced.
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To view or edit the model variables:

In the Model window, select Model Variables.1.

Edit the model variable fields by selecting the value and typing over it.2.

Note
To view system defaults from the Model Variables folder, select the  button.

To specify new model variables:

In the Model window, select Model Variables.1.
Enter the names and values for all model variables:2.

Click the first empty row in the Name field and type a name for the variable.
Press Tab to move to the Value field. Type a value for the variable.
Press Enter to accept the value and open another row.

Note
You can copy the model variables from an existing model. Open the model you want to copy. Select the
Model Variables folder. Select Edit > Copy Variable Table. In the new model, select Edit > Paste
Variable Table.

 Finding Model Parameters or Variables
Use the search box on the Model Parameters and Model Variables folders to find
subgroups of parameters and variables. In addition, you can save any subgroup to a name
for easy retrieval using the search box.

 Using the Search Rules

In the search box, special characters are: *, <space>, and <comma>.

Handling rules:

* means zero or more characters. An implied * will apply to the last cluster of letters.1.
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<space> delimits clusters of letters but the implied * remains2.
',' delimits clusters and terminates the implied *3.
[] is used for searching all elements in a ICCAP_ARRAY4.

Example Description Heading Rule

ABC ABC* (implied trailing *) 1

ABC
(trailing space)

ABC* (implied trailing *) 2

ABC DEF ABC* and DEF* (implied * for both) 1,2

ABC* DEF ABC* and DEF* (implied * on DEF) 1

ABC, ABC (no more implied *) 3

ABC,DEF ABC and DEF* (implied * on DEF) 1,3

ABC*, DEF ABC* and DEF* (implied * on DEF) 1

*AB *AB* (implied trailing *) 1

AB[] all elements in ICCAP_ARRAY AB 4

AB[1][] all elements in ICCAP_ARRAY AB[1] 4

Refresh button in variable page:
If a new variable is added to the current search results, the newly added variable will
remain in current search results until the Refresh button is selected.

For example, insert a variable not begin with character e. In this example, length remains
visible until the Refresh button is selected.

 Creating Parameter Groups

Use parameter groups to select parameters.
MDL file specific groups

Standard Groups:

All Parameters includes all parameters in the current level.
Ungrouped includes parameters in All Parameters that are not included in other
groups.

User Defined Groups:
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Use the keyword PARAMGROUP_ to define a parameter group. Specify the parameters in
the value column, using <space> as the delimiter. Group name can be nested in the Value
column. If there are no user defined groups, the list will not be displayed in the Model
Parameters folder.
For example, define a variable that begins with the keyword PARAMGROUP_ as shown
below.

Then the parameters included in the Value column are displayed together in the Model
Parameters folder as shown below.

If you specify a group name in Value column.

It is displayed it in the Model Parameters folder as shown below.
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Builtin Groups
The user defined groups for parameters can also be defined in a configuration file.
Format of the file:

[] is used to specify technology name.
# at the beginning means this line is a comment.
\ at the end of a line means the following line is also included in current group.
device. means the group is defined for the device level, no prefix means for the
model level.
A empty line will be ignored.

For example,

Steps for configuration:

Specifying file location in iccap.cfg.1.
For example:
ICCAP_BUILTIN_GROUPS_TEXT={$ICCAP_ROOT}/config/builtin_groups.txt

Select the technology name in the variable table.2.
For example:
BUILTIN_TECHNOLOGY_NAME=BSIM3

 Creating Variable Groups

Variable groups are used for selecting variables.

Standard Groups:
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All Variables includes all variables in current level.
System Variables includes all system variables defined in the current level.
User Variables includes variables in All Variables that are not included in other
groups.
Parameter Groupings includes variables that begin with keyword PARAMGROUP_.
Variable Groupings includes variables that begin with keyword VARGROUP_.

User Defined Groups:
A variable group can be defined in the Model Variables folder with the keyword
VARGROUP_. Specify the variables in the Value column, using <space> as delimiter.
Group name can be nested in the Value column.

For example, define a variable that begins with the keyword VARGROUP_ as shown below.

Then the variables included in the Value column are displayed together in the Model
Variables folder.

 Defining DUT Options
IC-CAP models usually contain several DUTs. DUTs contain groups of setups that have a
similar physical connection to the device. In addition to setups, each DUT contains its own
variables, parameters and test circuit. If two setups require differences in either of these
areas, you must define different DUTs for each.
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Before you can measure a device, you must make any needed changes to the DUT
options.

To view the DUT options and make a device active, select the DUTs-Setups folder. Then
select the DUT.

 Adding a DUT

To add a DUT:

In the DUTs-Setups folder, click Add.1.

In the dialog box that opens, select Add New DUT.2.
In the Enter New DUT Name field, type a name for the new DUT and click OK.3.
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See also: Organizing DUTs

 Deleting a DUT

To delete a DUT:

In the DUTs-Setups folder, select the DUT you want to delete.1.

Select Edit > Cut DUT, or click Cut on the toolbar.2.

Note
You can also delete a DUT by right-clicking on the DUT to view its pop-up menu. Then select Edit >
Cut.

See also: Organizing DUTs

 Organizing DUTs

To move a DUT in the list:

Select Tools > Organize Model from the Model window to display the following1.
dialog box:
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From this dialog box, select one or more DUTs.1.

Above the selected DUT(s), click the move up  icon to move the selected DUT(s)2.

up in the list, or click the move down  icon to move the selected DUT(s) down in
the list. Each click moves the selected DUT(s) one position.

To add a DUT:

Choose where you want to add the DUT in the list:1.
Select a DUT if you want to add a DUT after that position.
Do not select a DUT if you want to add a DUT to the first position.

Click the plus  icon.2.
A new DUT named Untitled is added. Type the desired name in the Item Name field3.
then select the Enter key.

To delete DUTs:

Select one or more DUTs.1.

Click the delete  icon.2.

To apply you changes and leave the dialog box open, select the Apply button.

To apply your changes and close the dialog box, select the OK button.

To close the dialog box without making changes, click the Cancel button.

See also: Organizing DUTs and Setups (intro)

 Specifying a Test Circuit

Typically, the test circuit is empty. However, you can use the Test Circuit folder to attach
additional circuitry between the device or circuit being modeled and the measurement
hardware. For example, an OpAmp model may need to be connected in different
configurations for different measurements.

When a test circuit is defined for a DUT, the parameters in the test circuit appear in the
DUT parameters folder. For complete information on defining Test Circuits, refer to
Simulating (sim).

To specify a test circuit:

In the DUTs-Setups folder, select the DUT. Then select Test Circuit.1.
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Edit the existing test circuit by typing over the existing values or enter new test2.
circuit data in the window.

Note
You can copy a test circuit from an existing model. Open the model and select the DUT you want to copy.
Select the Test Circuit folder. Select Edit > Copy DUT/Test Circuit. In the selection dialog box, choose
Selected Test Circuit. Then select Edit > Copy. In the new Model window, select the Test Circuit folder.
Select Edit > Paste Test Circuit.

 Defining DUT Parameters

The DUT parameters may take on different values in each DUT. For example, the DC
characterization of the MOSFET requires measurements on three DUTs ( large, narrow,
and short). Each of these DUTs have different specifications for channel length (L) and
width (W). You can specify these different values in the DUT Parameters folder. In
addition, you can set limits by defining minimum and maximum values for each
parameter. If a parameter value is outside its limits, it will be clamped to its minimum or
maximum value.

To specify DUT parameters:

In the DUTs-Setups folder, select the DUT. Then select DUT Parameters.1.

Select the Param Name Value field and edit the DUT parameters for the device2.
being measured.
Optionally, select the Param Name Min field and set minimum values for the DUT
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3.
parameters.
Optionally, select the Param Name Max field and set maximum values for the DUT4.
parameters.
Select an action from the following:5.

To temporarily store the current set of parameter values, click Memory Store
All.
To recall stored parameter values, click Memory Recall All.
To reset the default values specified in the circuit definition, click Reset All.

Note
You can copy DUT parameters from an existing model. Open the model and select the DUT you want to
copy. Select the DUT Parameters folder. Select Edit > Copy DUT/Device Parameter Set. In the
selection dialog box, choose Selected Device Parameter Set. In the new Model window, select the DUT
Parameters folder. Select Edit > Paste Device Parameter Set.

 Defining DUT Variables

You can define variables that are accessible only to the DUT or its components in the DUT
Variables folder. After you have defined the variables, you can reuse these definitions by
applying the Import and Export commands.

To specify new DUT variables:

In the DUTs-Setups folder, select the DUT. Then select DUT Variables.1.

Enter the names and values for all DUT variables:2.
Click the first empty row in the Name field and type a name for the variable.
Press Tab to move to the Value field. Type a value for the variable.
Press Enter to accept the value and open another row.

Note
To view system defaults from the DUT Variables folder, select the   button.

Note
You can copy DUT variables from an existing model. Open the model and select the DUT you want to copy.
Select the DUT Variables folder. Select Edit > Copy DUT/ Variable Table. In the selection dialog box,
choose Selected Variable Table. In the new Model window, select the DUT Variables folder. Select Edit
> Paste Variable Table.

 Defining Setup Options
You can define setup options from the DUTs-Setups folder. A setup contains folders for
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defining measurement and simulation options, instrument options, setup variables,
transforms, and results.

The combination of setup options you specify depends on the following:

Measurement or simulation to perform. For example, to perform the measurement
and simulation, you can specify four input voltages and one output current.
Extractions or data manipulations required for characterization. For example, to
extract values for specific model parameters and optimize the parameter values to
achieve the best possible fit between measured and simulated data, you can add a
transform that performs the extraction and a transform that performs the
optimization.
Desired data presentation. For example, to view the data, and compare the
measured and simulated results, you can add a plot to the setup.

 Adding a New Setup

To add a new setup to a DUT:

In the DUTs-Setups folder, select the DUT then click Add.1.

In the dialog box:2.
Select Add New Setup to DUT [selected].
In the Enter New Setup Name field, type a name for the new setup.

Click OK. The new setup is added to the DUT.3.
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See Also: Organizing Setups

 Organizing Setups

To move a Setup:

In the DUTs-Setups folder, select the DUT then click Organize to display the1.
following dialog box:

Note
You can also access this dialog box by first selecting Tools > Organize Model from the Model
window, then select the Organize DUT button.

In the dialog box, select one or more Setups.2.

Above the selected Setup(s), click the move up  icon to move the selected3.

Setup(s) up in the list, or click the move down  icon to move the selected
Setup(s) down in the list. Each click moves the selected Setup(s) one position.

To add a Setup:

Choose where you want to add the Setup in the list:1.
Select a Setup if you want to add a Setup after that position.
Do not select a Setup if you want to add a Setup to the first position.

Click the plus  icon.2.
A new Setup named Untitled is added. Type the desired name in the Item Name field3.
then select the Enter key.
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To delete a Setup:

Select one or more Setups.1.

Click the delete  icon.2.

To apply you changes and leave the dialog box open, select the Apply button.

To apply your changes and close the dialog box, select the OK button.

To close the dialog box without making changes, click the Cancel button.

See also: Organizing DUTs and Setups (intro)

 Specifying Measurement and Simulation Options

You can specify measurement and simulation options either by adding new inputs and
outputs or by modifying existing values.
To add inputs:

In the DUTs-Setups folder, select the setup. Then select Measure/Simulate.1.

Click New Input to open the Input Editor.2.

In the Input field, enter a name for the new input.3.
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Click OK to add the input to the Measure/Simulate folder.4.

To add outputs:

Click New Output to open the Output Editor.1.

In the Output field, enter a name for the new output.2.
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Click OK to add the output to the Measure/Simulate folder.3.

To edit inputs and outputs:

In the DUTs-Setups folder, select the setup. Then select Measure/Simulate.1.

In the Measure/Simulate folder, select the Input or Output you want to modify.2.

Click Edit to open the Input or Output Editor.3.

Select the field you want to modify and edit the existing data.4.
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Click OK.5.

Note
Alternatively, you can edit directly in the table by selecting the field and typing the new values.

 Defining Setup Variables

You can define any variables that are globally available to the setup.

To add or modify setup variables:

In the DUTs-Setups folder, select the setup. Then select Setup Variables.1.

Enter the names and values for all setup variables:2.
Click the first empty row in the Name field and type a name for the variable.
Press Tab to move to the Value field. Type a value for the variable.
Press Enter to accept the value and open another row.

Note
To view system defaults from the Setup Variables folder, select the  button.

Note
You can copy setup variables from an existing model. Open the model and select the setup you want to
copy. Select the Setup Variables folder. Select Edit > Copy Setup/Variable Table. In the selection
dialog box, choose Selected Variable Table. In the new Model window, select the Setup Variables
folder. Select Edit > Paste Variable Table.

 Defining Transform Options
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You can define transform options by adding new functions or by modifying existing
functions.
To add functions to a new setup:

In the DUTs-Setups folder, select the setup. Then select Extract/Optimize.1.

Click New...2.

In the dialog box, enter a name for the new transform in the Transform Name field.3.

Click OK to add the transform to the list.4.

Select Browse to see the transforms provided with the program.5.

Choose a Function Group and a Function from the lists.6.
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Choose Select to assign the selected function to the transform.7.

To edit functions:

In the DUTs-Setups folder, select the setup. Then select Extract/Optimize.1.
Select the function you want to modify. Edit the values in the table by selecting the2.
field and typing the new value.

To add results to a new setup:

In the DUTs-Setups folder, select the setup. Then select Plots.1.
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Click New to open the Plots Editor.2.

In the Plot field, enter a name for the new plot and complete the values as required.3.

Click OK to add the plot to the setup.4.
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To edit plots:

In the DUTs-Setups folder, select the setup. Then select Plots.1.
Select the plot you want to modify.2.
Click Edit to open the Plots Editor.3.

Edit the values you want to change and click OK.4.

Note
Alternatively, you can edit directly in the table by selecting the field and typing the new values.

 Adding a Macro to the Model
After defining a model, you can define several macros to help organize the
characterization procedure. Macros allow any of the available IC-CAP menu operations to
be combined and executed as a single operation. IC-CAP features a powerful macro
language which is described in detail in Creating and Running Macros (prog).
To define a macro:

In the Model window, select Macros.1.
Click New.2.

At the prompt, type a macro name and choose OK.3.

The new name appears in the macro list.
To define the macro, type the program directly into the window.4.
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 Creating a New Model
The example in this section describes the procedure for defining a portion of the MOSFET
model. The MOSFET model supplied with IC-CAP contains a variety of DUTs and Setups for
characterizing the DC and Capacitance behavior of the device over a range of geometries.
The model is described in UCB MOS Level 2 and 3 Characterization (mosfet). Several
alterations have been made to the supplied model in order to illustrate advanced features,
such as user-defined variables and test circuitry.

Note
These instructions assume that the necessary source and measuring instruments are already configured to
the IC-CAP system. If this is not the case, refer to Customization and Configuration (custom).

Add a New Model to the Work Area

In the IC-CAP/Main window, select File > New. An icon representing a new untitled1.
model appears in the IC-CAP/Main window.
Double-click the model icon to open the Model window.2.

Save the Model File

Select File > Save As.1.
In the dialog box, enter the design name, nmos2, and choose OK.2.

Define Model Variables

In the Model window, select Model Variables.1.
Click the first empty row in the Name field and type the variable name, Compliance.2.
Press Tab to move to the Value field. Type the variable value, 20m.3.

Specify the Circuit Definition

In the Model window, select Circuit.1.
Enter the circuit description. For the nmos2 model, the circuit is:2.

.OPTIONS ucb

M1 1=D 2=G 3=S 4=B MOSMOD L=2u W=3u

+ AD=9p PD=12u AS=9p PS=12u

.MODEL MOSCAP NMOS

+ LEVEL = 2.000
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+ UO = 600

+ VTO = 0

+ NFS = 0

+ TOX = 100n

+ NSUB = 1E15

+ UCRIT = 10.0K

+ UEXP = 0

+ VMAX = 0

+ RS = 0

+ RD = 0

+ XJ = 0

+ LD = 0

+ DELTA = 0

+ NEFF = 1.00

+ NSS = 0

+ CGSO = 0

+ CGDO = 0

+ CGBO = 0

+ CBD = 0

+ CBS = 0

+ CJ = 0

+ MJ = 0.5

+ CJSW = 0

+ MJSW = 0.33

+ IS = 1.0e-14

+ PB = 0.8

+ FC = 0.5

The new circuit definition is parsed automatically when you click outside the
window.

 View Model Parameters

When a new model is read, parameter values are set to the defaults defined in the MODEL
definition of the Circuit. To view the model parameters, select the Model Parameters
folder. For this example, no changes are made to the model parameters.

 Add a DUT

The MOSFET model contains three DUTs for DC characterization and two DUTs for
Capacitance characterization. The procedure creates the DC DUT large.

In the Model window, select DUTs-Setups.1.
Click Add.2.
In the dialog box, click Add New DUT.3.
In the Enter New Dut Name field, type the DUT name, large.4.
Click OK.5.

 View DUT Variables

To view the model parameters, select the DUT name large, then select the DUT
Variables folder. For this example, no changes are made to the DUT Variables.

 Specify DUT Parameters
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The DC characterization of the MOSFET requires measurements on three DUTs. Each of
these DUTs have different specifications for L and W. For the example, specify geometry
parameters for the large device.

Select DUT Parameters.1.
Select the Param Name Value field and edit the DUT parameters for the device2.
being measured. The DUT parameters are:

L - 50.00u

W - 50.00u

AD - 150.0p

PD - 106.0u

AS - 150.0p

PS - 106.0u

 Specify a Test Circuit

A test circuit is usually not used with a MOSFET, but this example defines one. You can
use a test circuit if you have a large amount of probe resistance that you do not want
included in the model parameters. In this case, you can define a test circuit that has an
additional resistor connected between each of the internal device nodes and the external
nodes that are connected to the sources.

The example test circuit definition contains the following information:

Line 1 contains the mandatory term    .SUBCKT, which is required if a circuit contains
more than one device (in this case, a transistor and four resistors). Line 1 also
includes the arbitrary name of the test circuit and the identities of the four device
nodes. The four device nodes are numbered as in the Model Circuit Definition (1 = C,
2 = B, 3 = E, 4 = S); however, alternate names can be used. If you do not assign a
name to each node number, the system assigns the node number as the node name.
Line 2 identifies the device (Q1), the internal nodes of the transistor (11, 12, 13, and
14), the name of the model (npn), and the AREA parameter. The model name must
be entered precisely as it appears in the model icon.
Lines 3 through 6 specify the four resistors that represent the additional resistance at
each node. Each resistor is connected from an external Test Circuit node to the
corresponding internal device node.
Line 7 indicates the end of the    .SUBCKT definition.

To define a test circuit:

In the DUT window, select Test Circuit.1.
In the test circuit window, type the test circuit data:2.

.SUBCKT large 1=D 2=G 3=S 4=B

M1 11 12 13 14 nmos2 L=50u W=50u

RDX 11 1 5.0

RGX 12 2 5.0

RSX 13 3 5.0

RBX 14 4 5.0

.ENDS
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When a Test Circuit is defined for a DUT, the parameters in the Test Circuit appear in the
DUT parameters folder and are editable.

 Add a Setup

In the Model window, select DUTs-Setups.1.
Click Add.2.
In the dialog box, click Add New Setup to Dut large.3.
In the Enter New Setup Name field, type the setup name, idvg.4.
Click OK.5.

 Specify Setup Components

To perform the measurement and simulation, four input voltages and one output current
are specified. In the case of the idvg setup for the large DUT of the MOSFET, the drain
current, id, of the device, is monitored as a function of the gate voltage, vg, and the
substrate (bulk) voltage, vb. The drain voltage, vd, and the source voltage, vs, are held
constant.

For each of the components added to the setup, fill in a table of information that defines
the desired behavior. This example presents only a small subset of the available
capabilities possible in a setup. To edit a setup:

In the DUT-Setups window, select large/idvg.1.
Select Setup Variables and define any variables you want to apply to the setup.2.
Select Measure/Simulate.3.
Click New Input to open the Input Editor.4.
In the Input field, enter the new input name, vg.5.
Complete the value entries as shown below:6.
Mode Voltage

+ Node G

- Node GROUND

Unit SMU2

Compliance 10.00u

Sweep Type Linear

Sweep Order 1

Start 0.000

Stop 5.000

# of Points 21

Step Size 250.0m

The value in the Compliance field is a reference to the global compliance
variable that was defined for the setup variables.

Click OK to add the input to the Measure/Simulate folder.7.
Add the input vb. Complete the value entries as shown below:8.
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Mode Voltage

+ Node B

- Node GROUND

Unit SMU4

Compliance 1.000m

Sweep Type Linear

Sweep
Order

2

Start 0.000

Stop -3.000

# of Points 3

Step Size -1.500

The value in the Compliance field is a reference to the global compliance
variable that was defined for the setup variables.

Add the inputs that remain constant, vd and vs, by completing the value entries as9.
shown below:
 Input vd Input vs

Mode V V

+ Node D S

- Node GROUND GROUND

Unit SMU1 SMU3

Compliance 100.0m 100.0m

Sweep Type CON CON

Value 100.0m 0.000

When you change the Sweep Type from LIN to CON the fields at the
bottom of the table used to specify a linear sweep are replaced by a single
Value field. Similarly, a change in the Mode alters the structure of the
upper portion of the table.

Add the output id by completing the value entries as shown below:10.
Mode I

To Node D

From
Node

GROUND

Unit SMU1

Type B

When you change the Mode to I, the names of the node fields of the table
change accordingly.

 Add Transforms

When the measurement has been made, values for the model parameters that control the
large DUT behavior are extracted, and, optionally, the parameter values are optimized to
achieve the best possible fit between measured and simulated data.
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To accomplish this, you add a transform that performs the extraction and a transform that
performs the optimization.

In the setup window, select Extract/Optimize.1.

In the Function field, click Browse. Select the Function Group MOS
Level2 and the Function MOSDC_lev2_lin_large.

In the list of transforms, select extract. Complete the values as shown
below:

Gate V vg

Bulk V vb

Drain
V

vd

Drain I id.m

In the list of transforms, select optimize.2.

For Inputs, complete the values as shown below:

Target id.m  

Simulated id.s  

Weight 1.000 1.000

For Parameters, complete the values as shown below

Name Min Max

VTO 0.000 10.00

NSUB 1.000T 1.000E+18

UO 100.0 1.000K

UEXP 0.000 1.000

 1.000f 1.000MEG

For Options, complete the values as shown below:
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Y Lower Bnd 0.000 Rank 1 Flag Yes

Y Upper Bnd 0.000 Param Delta 1.000m

X Lower Bnd 0.000 Param Print A

X Upper Bnd 0.000 Error Print A

Comb Filter 1 Sens Print 1

RMS error 10.00m Normal Sens Yes

Max error 10.00m Optim Mode L

Abs Err Flag Yes Rand Std
Dev

300.0m

Param Tol 1.000m Rand Reward 500.0m

Function Tol 1.000m Rand Penalty 500.0m

Max Evals 50 Rand Seed 0

Extract Flag No Rand Iters 25

The tables adjust depending on the functions selected.

Finally, in order to view the data and compare the measured and simulated results, add a
plot to the setup.

In the setup window, select Plots. Define the idvsvg plot as shown below:1.
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The plot table adjusts according to the value of the Report Type field.

Select Instrument Options to enter the instrument options values. Instruments2.
used in each setup are determined from the instrument unit names specified in the
Unit fields of the Input and Output tables.

Usually only one DC measurement instrument is used in this setup. When using the HP
4141, the window looks similar to the following figure.

 Instrument Options for HP 4141

 Add a Macro

You can add a macro to simplify simulations. The example for the MOSFET defines a
macro that performs all of the DC simulations together. This macro calls the Simulate
function for the large, narrow, and short DUTs.

To define a macro:

In the Model window, select Macros.1.
Click New.2.

At the prompt, type the macro name, dc_simu.3.

Click OK. The new name appears in the macro list.4.
To define the macro, type the program directly into the window.5.

menu_func("large", "Simulate")

menu_func("narrow", "Simulate")

menu_func("lshort", "Simulate")

To execute the macro, click Execute. 
When you execute this macro, all three DC DUTs (large, narrow, and short)
are simulated.
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Note
You can also execute macros from the Model window's Macro menu. Click on Macros > Execute, the click
on the macro you want to execute. This is useful if you want to execute a macro, and you do not have the
Macro folder open.

 Create Other DUTs and Setups

You can create other DUTs and setups by repeating the example procedure. Or, you can
build a complete model by copying portions of the supplied model and then modifying any
parts of the new setup that needs to be changed to achieve the desired behavior. For the
MOSFET model, you can copy the entire large DUT to two new DUTs named narrow and
short. In the short DUT, the idvg setup can be copied to a new Setup named idvd. After
making the necessary modifications, you have the complete set of DUTs and setups
necessary for DC MOSFET characterization. For details, refer to Copying Parts of a Model.



IC-CAP 2011.01 - Introduction and Basics

122

 DUT or Setup Editing
Models usually contain several DUTs. DUTs contain groups of Setups that have a similar
physical connection to the device. If two Setups require different parameters or different
test circuits, they must belong to different DUTs.

See also: Defining DUT Variables (intro).

 

 Adding a DUT or a Setup
To add a DUT to a model:

With the model file open, click the Add button at the bottom of the DUT/Setup panel.1.
In the dialog box that appears, select Add New DUT.2.
Enter a name for the new DUT and click OK. The new DUT appears at the bottom of3.
the DUT/Setup panel.

To add a Setup to a DUT:

With the model file open, and the appropriate DUT selected, click the Add button at1.
the bottom of the DUT/Setup panel.
In the dialog box that appears, select Add New Setup.2.
Enter a name for the new Setup and click OK. The new Setup appears for that DUT.3.
The new Setup appears below any existing setup(s).

See Organizing DUTs and Setups for an alternate way to add DUTs and Setups to a model.

 Deleting a DUT or a Setup
To delete a DUT:

Select the DUT you want to delete.1.
Choose Edit > Cut and a dialog box appears.2.
Select the DUT option and click OK.3.

To delete a Setup:

Select the setup you want to delete.1.
Choose Edit > Cut and a dialog box appears.2.
Select the Setup option and click OK.3.

See Organizing DUTs and Setups for an alternate way to delete DUTs or Setups from a
model.

 Copying/Pasting a DUT or Setup
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To copy and paste a DUT:

Select the DUT you want to copy.1.
Choose Edit > Copy and a dialog box appears.2.
Select the DUT option and click OK.3.
Choose Edit > Paste and the copied DUT is added after any existing DUTs.4.
Rename the DUT/Setups as needed (see Renaming a DUT or Setup).5.

To copy and paste a setup:

Select the setup you want to copy.1.
Choose Edit > Copy and a dialog box appears.2.
Select the Setup option and click OK.3.
Select the DUT you want to copy the setup to and choose Edit > Paste Setup. The4.
copied setup is added below any existing setups of that DUT.
Rename the setup as needed (see Renaming a DUT or Setup).5.

 Renaming a DUT or Setup
When you paste a DUT or Setup, the copy retains the name of the original, plus an
underscore and a number (automatically incremented).
To rename a DUT or Setup:

Select the DUT or setup you want to rename.1.
Click the Rename button and a dialog box appears.2.
Type a new name for the DUT or setup and click OK. The name is updated3.
immediately.

See also: Organizing DUTs and Setups

 Organizing DUTs and Setups
Selecting Tools > Organize Model from a Model window displays the following dialog
box:
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This dialog box enables you to move, add, delete, or rename DUTs, macros, and variables.

To move an item:

Select one or more items:1.

Above the selected items, click the move up  icon to move the items up in the list,2.

or click the move down  icon to move the items down in the list. Each click moves
the selected items one position.

To add an item:

Choose where you want to add the item in the list:1.
Select an item if you want to add an item after that position.
Do not select an item if you want to add an item to the first position.

Click the plus  icon.
A new item named Untitled is added. Type the desired name in the Item Name field
then select the Enter key.

To delete an item:

Select one or more items:1.

Click the delete  icon.2.

To display a dialog box that enables you to move, add, delete, or rename a DUT's setups
and variables:

Select a DUT.1.
Click the Organize DUT button. This displays the following dialog box, which2.
functions in the same manner as the previous dialog box.
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Note
You can also display this dialog box by selecting a DUT in the model file, then clicking the Organize
button at the bottom of the DUT/Setup panel.

To display a dialog box that enables you to move, add, delete, or rename a Setup's inputs,
outputs, transforms, plots, and variables:

Select a Setup.1.
Click the Organize Setup button. This displays the following dialog box, which2.
functions the same as the previous dialog box.

Note
You can also display this dialog box by selecting a Setup in the model file, then clicking the Organize
button at the bottom of the DUT/Setup panel.

To apply you changes and leave the dialog box open, select the Apply button.

To apply your changes and close the dialog box, select the OK button.
To close the dialog box without making changes, click the Cancel button.

 Defining a Test Circuit for a DUT
To define a test circuit:

Select the DUT for which you want to define a test circuit.1.
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Create the definition by typing in the text area or by importing an existing text file.2.
When the file is complete, choose Parse.3.

Note
When you import text, the file is automatically parsed.

 Defining DUT Parameters
To define parameters for a specific DUT:

Select the DUT and click to open the DUT Parameters folder.1.
Click once to activate the text field of a parameter you want to change.2.
Position the cursor as necessary, click again and use the backspace key to erase3.
existing values and retype, or double click to highlight and retype the entire entry.

Tips:

Use Detach to keep the parameters visible and editable, while viewing other parts of
the model. When you are done, close the detached window and any changes made
there are reflected in the Model window.
Use Memory Store All to temporarily store the parameter set prior to extraction; use
Memory Recall All to retrieve them if the extracted values are unacceptable.
Use Reset All to overwrite DUT parameter values with circuit parameter values.
Use Update Circuit to overwrite circuit parameter values with DUT values.

 Setup Editing
Setups contain information for performing specific measurements and simulations on a
DUT. The individual components of a Setup are:

Inputs
Outputs
Extraction/Optimization Specifications (Transforms)
Plots
Variables
Instrument Options

See also: Assigning Values to Setup Variables and Organizing DUTs and Setups
 

 Input/Output Editing
The inputs and outputs of a Setup define the various currents, voltages, etc. you want to
monitor with respect to the associated DUT.
To add a new input or output:

Click New Input or New Output.1.
Fill in all fields as necessary and click OK.2.
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To delete an input or output:

Select the input or output.1.
Right click and select Cut. The selected input/output is deleted.2.

To edit an input or output:

Double-click the input or output or select it and click the Edit button in the1.
Measure/Simulate folder or use the on-screen editor.
Make all the necessary changes in the dialog box and click OK.2.

Alternatively, you can edit an input or output directly using the on-screen editor.

See also: Organizing DUTs and Setups
 

 Variables
Several variable names are reserved by IC-CAP and cannot be assigned as user-defined
variables. You can assign values to reserved variables and define your own variables at
several different levels (variables at lower levels inherit their values from variables above
them):

Global
DUT level
Model level
Setup level

You define global variables through the IC-CAP Main window. These variables apply to all
Models, DUTs, and Setups unless you explicitly set the variables differently at the Model,
DUT, or Setup level.
You define Model, DUT, and Setup variables through the Model window:

Model variables apply to all DUTs and Setups of that Model unless you explicitly set
the variables differently for individual DUTs and/or Setups.
DUT variables apply to all Setups of that DUT unless you explicitly set the variables
differently for individual Setups.
Setup variables apply only to that Setup.

 Assigning Values

 Assigning Values to Global Variables

To assign values to global variables:

In the Main window, choose Tools > System Variables and the Variables
window appears.

To create user-defined variables:
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Type the names and values in the fields provided. Additional fields appear as
you specify values.

To assign values to supplied variables:

Type their names and values in the System Variables window or click System
Variables and a dialog box appears.
Select the appropriate category and the variables in that category are displayed.
Click to select a variable and a description of that variable is displayed.
Type the appropriate value in the Value field and click Apply. The variable name and
its value appear in the Variables window.
Continue assigning variable values as needed. When you are finished, click OK.

 Assigning Values to Model Variables

To define variables at the model level:

Click to open the Model Variables folder.

To create user-defined variables:

Type the names and values in the fields provided. Additional fields appear as
you specify values.

To assign values to supplied variables:

Type their names and values in the System Variables window or click System
Variables and a dialog box appears.
Select the desired Variable Type and a list of variables of that type appears.
Select the variable. A description is displayed.
Enter the desired value for that variable and click Apply.
Continue defining variables in this manner, clicking Apply to effect each change.
When you are through defining variables, click OK.

 Assigning Values to DUT Variables

To define variables for a DUT:

Click to open the DUT Variables folder.

To create user-defined variables:

Type the names and values in the fields provided. Additional fields appear as
you specify values.

To assign values to supplied variables:

Type their names and values in the System Variables window or click System
Variables and a dialog box appears.
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Select the desired Variable Type and a list of variables of that type appears.
Select the variable. A description is displayed.
Enter the desired value for that variable and click Apply.
Continue defining variables in this manner, clicking Apply to effect each change.
When you are through defining variables, click OK.

 Assigning Values to Setup Variables

To define Setup variables:

Click to open the Setup Variables folder.

To create user-defined variables:

Type the names and values in the fields provided. Additional fields appear as
you specify values.

To assign values to supplied variables:

Type their names and values in the System Variables window or click System
Variables and a dialog box appears.
Select the desired Variable Type and a list of variables of that type appears.
Select the variable. A description is displayed.
Enter the desired value for that variable and click Apply.
Continue defining variables in this manner, clicking Apply to effect each change.
When you are through defining variables, click OK.

See also: Organizing DUTs and Setups

 Creating User-defined Variables

To create user-defined variables:

Select Tools > System Variables in the Main window if you are creating global1.
variables, otherwise click to open the Model, DUT, or Setup Variables folder, as
desired.
In the System Variables window that appears, type the names and values in the2.
fields provided. Additional fields appear as you specify values.

 Defining Instrument Options
The Instrument Options table is available once you specify the unit names (from the
Hardware Setup configuration dialog) in the Inputs and Outputs, as needed. Once you
define your instrument options, you can save them to file and read in this file anytime as
needed.
To save instrument options:

With the Instrument Options folder active, choose File > Save As.1.
In the dialog box that appears, select Instrument Options (.iot).2.
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If desired, choose another directory by typing or using the Browser.3.
Provide a filename (the extension is appended automatically) and click OK.4.

To read a file containing previously saved instrument options:

With the Instrument Options folder active, choose File > Open.1.
In the dialog box that appears, select Instrument Options (.iot).2.
If desired, choose another directory by typing or using the Browser.3.
Provide a filename (the extension is appended automatically) and click OK.4.
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 Circuit Modeling
Circuit modeling is a natural extension of single device modeling. With IC-CAP's flexible
structure, it is as easy to measure and characterize a multicomponent circuit as a single
device. This section provides details for performing circuit modeling; typical applications
are also provided to use as a guide for meeting specific circuit modeling requirements.

 Definition of an IC-CAP Circuit
IC-CAP defines a circuit as any connection of two or more components. Previous sections
have dealt primarily with single devices such as bipolar, GaAs or MOS transistors. An IC-
CAP circuit can be a simple two-resistor voltage divider or a complex operational amplifier
or A/D converter.

The circuit, like a single device, is specified in the Circuit folder of the model window using
SPICE compatible circuit definition syntax. All circuit decks in IC-CAP begin with the
.SUBCKT subcircuit definition and end with the .ENDS statement. Circuit modeling allows
more accurate solutions to many single device modeling requirements and expands the
level of systems modeling possible.

 IC-CAP Circuit Modeling Operations
With IC-CAP, every type of characterization operation performed on a single component
can also be performed on a circuit. IC-CAP allows easy measurement of circuit
characteristics, extraction and optimization of model parameters, and simulation of the
circuit's performance. Measurement and simulation operations use the same setup
information as single components. Extraction and optimization operations enable more
options for methods of obtaining model parameters. These operations can be performed
on the circuit as a whole or on any sub-component of the circuit. This is explained in the
section, Circuit Parameter Extraction.

 Defining a Circuit
The process of defining a circuit in IC-CAP is similar to defining a single device. The main
difference is the interconnection of the components and the use of subcircuit lines to
define the circuit block. For detailed information on defining circuits, refer to SPICE
Simulators (sim), SPECTRE Simulator (sim), or Saber Simulator (sim)).

 Supported Circuit Components

Circuits in IC-CAP support the standard components that can be simulated with SPICE:

Passive elements  R, L, C, Transmission lines
Semiconductors  Bipolar, MOS, GaAs, JFET, Diode
Sources  V, I, VCVS, VCIS, ICVS, ICIS

The syntax for defining a circuit in IC-CAP is similar to a SPICE simulation input deck.
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Each line contains a component, its node numbers, value, and (if applicable) an associated
model name reference. Proper specification and use of these components is critical to the
success of circuit simulation and parameter extraction.

In general, independent voltage sources are specified as inputs within a given setup. This
allows you to specify their values and use them in additional numerical or graphic
analysis. Some of the differences between SPICE and IC-CAP circuit definitions are listed.

The .OPTIONS statement (if used) must be the first line in the circuit description. All
options must be on one line (no continuation).
The next line of the circuit is .SUBCKT.
A TITLE specification is automatically generated by IC-CAP and should not be
included in the circuit definition.
The last line of the circuit is .ENDS
An .END statement is automatically generated by IC-CAP and should not be included
in the circuit definition.

The following figure shows an example circuit description. This circuit defines the input
section of an ECL OR/NOR logic gate. (ECL OR/NOR Schematic Diagram shows the
schematic.) This circuit is referenced several times in this section. You can create it using
the circuit editor or read it from the file $ICCAP_ROOT/data/ECLornor.mdl.

 Circuit Description for an ECL OR/NOR Logic Gate

.SUBCKT ECLORNOR  1=IN1 2=IN2 3=OR 4=NOR

+ 5=VCC 6=VEE 7=VREF

* ECL OR/NOR LOGIC GATE

Q1   4  1  8  NPN1

Q2   4  2  8  NPN1

Q0   3  7  8  NPN2

.MODEL NPN1 NPN

+ IS = 2E-14  NF = 0.998  BF = 120

+ RB = 225  CJC = 300p  TF = 20p

.MODEL NPN2 NPN

+ IS = 4E-14  NF = 0.998  BF = 120

+ RB = 110  CJC = 530p  TF = 18p

RL1  5  4  300

RL0  5  3  300

RIEE 8  6  1.2K

.ENDS

When you enter the circuit description in the Circuit folder of the model window, moving
the mouse out of the Circuit folder automatically causes the circuit to be parsed, that is,
the specified circuit elements are read and entries are created for them in Model
Parameters. When they are added initially, they assume the value specified in the circuit
description. To change a value subsequently, you must change it in Model Parameters. To
change all entries in Model Parameters to the values in the circuit description, choose
Reset.

Note the difference in the Parameters table parameter names for a transistor in a circuit.
In a single transistor circuit, the model parameter names of the transistor are the entries
in the Parameters table. In a multi-component circuit the transistor's model parameters
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must be associated with a specific model, so the parameters take on a prefix of that
model's name. Thus, the forward Beta model parameter BF for a model named NPN1 is
listed in the Parameter Editor as NPN1.BF. In the example above, transistors Q1 and Q2
both use the NPN1 model, while transistor Q0 uses the NPN2 model.

 Circuit Measurement
The process of measuring a circuit in IC-CAP is identical to measuring a single device. The
circuit stimuli and responses are specified in the input and output tables, respectively, of
the Measure/Simulate folder. You can perform a measurement by clicking Measure in the
Measure/Simulate folder the DUT or Setup levels. In performing measurements on
circuits, there are several additional items not found in single component measurement.

 Multiple Instrument Names

In measuring a single component, it is common to use only one DC source and
measurement instrument because only four terminals are involved. The typical circuit can
have more than four terminals and require several DC source and measurement
instruments. Any number of instruments of the same or similar type can be connected to
the circuit under test as long as they are entered in Hardware Setup. When using multiple
instruments, each of their units must have a unique name.

 Isolating Circuit Elements for Measurement and Extraction

The characterization of a circuit may require the measurement and modeling of several
sub-circuit elements. The accuracy of the sub-circuit model generated is dependent upon
how well that circuitry can be isolated from the rest of the overall circuit.

Examine the simplified schematic of the input to an ECL OR/NOR gate in the following
figure. The input stage of this circuit is a differential amplifier with a collector resistor in
each leg and a resistor for a current source. It is possible to characterize the individual
transistors in this circuit by selectively biasing only the terminals that make it active and
that keep other parts of the circuit in an off or latent state. In this case, biasing IN1, VCC,
and VEE turns on the circuit that contains RL1, Q1, and RIEE. These components have
now been isolated so that their model parameters can be extracted. This type of selective
measurement allows characterization of individual or small groups of sub-circuit elements.

 ECL OR/NOR Schematic Diagram
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 Circuit Parameter Extraction
Circuit parameter extraction is identical to single component parameter extraction through
the use of Transforms. However, because circuits are custom in nature, most of the
extraction routines must also be custom designed. With the availability of the Program
function and optimize transforms, this is simple and quick to evaluate and execute. The
critical factor in a successful circuit level parameter extraction is the ability to make a
measurement and subsequent extraction involving only the dominant component
parameters.

For a full model extraction of a single component, you will attain more accuracy if that
device is available without any additional components connected to it. For most functional
block level circuits however, a subset of the transistor model parameters is usually
sufficient for studying circuit behavior.

 Extracting Transistor Parameters Using Library Functions

In the explanation of a selective measurement on a sub-portion of a circuit in the previous
section, Q1 and its neighboring resistors were isolated in the ECL logic gate. The forward
active model parameters can be extracted from this measurement using the model
extraction functions in the function list or by setting up a custom optimization. To access
the functions, add transforms that use them to a setup that contains the measurement. It
is possible to use the provided transistor extraction functions to obtain model parameters
for devices connected into a larger circuit.

Because all models in a circuit have model parameters in the Parameters table with the
model's name as a prefix, IC-CAP must be told which model to use with the extraction
transforms. This is easily done by setting a variable in the model level variable table.
Enter a variable in the table called EXTR_MODEL and set its value to the name of the
transistor whose parameters are being extracted. When the extraction transforms are
executed, IC-CAP refers to the correct Parameters table entry as it writes the extracted
value back to the table. For example, to use a function list transform on the model NPN1
mentioned above, add the following to the model level variable table:

EXTR_MODEL NPN1
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Each time another transistor is used for an extraction, place its name in the value field. A
more efficient method of extracting individual transistor models is to create an individual
setup for each device. The variable table at the setup level can then include the
EXTR_MODEL entry, keeping the transistor extraction local to that setup. This can also be
done in an analogous way at the DUT level.

It is sometimes necessary to specify the particular DUT in a circuit that should be used in
an extraction routine. For example, in a circuit that contains two MOSFETs there are two
different sets of geometry parameters (L and W). For the extraction to work correctly, the
EXTR_DUT variable must be set to the name of the transistor with the correct geometry
parameters. Therefore, to characterize transistor M1, which uses model NMOS1, add the
following to the model level variable table:

EXTR_DUT M1
EXTR_MODEL NMOS1

Situations where EXTR_DUT must be set can also arise when test circuits are defined. In
this case, DUT parameters that normally appear without a prefix in the DUT Parameters
table will include the transistor name from the Test Circuit as a prefix. For the extractions
to use these parameters, EXTR_DUT must be set to the transistor name that is used in the
test circuit.

 Extracting Parameters Through Optimization

It is not always possible to adequately isolate a circuit component before using a standard
extraction function. In these cases it is still possible to extract model parameters by using
the optimize function. As with any extraction function, successful use of the optimizer
requires that the parameters being optimized have a dominant effect over the simulation
of the measured characteristics. Refer to Optimizing (sim), for more information regarding
optimization.

In the OR/NOR gate shown in ECL OR/NOR Schematic Diagram, it is possible to use the
optimizer to extract the values of NPN1.IS, NPN1.NF, NPN1.BF and RIEE. The following
sequence of operations describes how to accomplish this.

Make an Ic and Ib versus V measurement between the NOR, IN1 and VEE terminals.1.
Connect the VEE, VREF and IN2 terminals to constant voltage sources of 0V.1.
This keeps the base-emitter diodes of Q2 and Q0 in an off state. Disconnect VCC
from the circuit.
Connect the NOR terminal to a voltage of approximately 1.0V.2.
Sweep the voltage on the IN1 terminal so that the measured currents at the3.
NOR (collector) terminal are in the 1nA to 1μA range.

Set up an optimization transform that optimizes the values of NPN1.IS, NPN1.NF, and2.
NPN1.BF over the measured current. At low currents, RIEE has a minimal affect on
the I-V relationship.

The target data is the measured Ic and Ib currents. The simulated data comes
from the simulation of these currents.
The Parameters table contains NPN1.IS, NPN1.NF and NPN1.BF

Change the sweep voltage on the IN1 terminal so that the measured current at the3.
NOR terminal is in the 10μA to 1mA range.
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The measured current should deviate from an exponential function due to the
debiasing effect from RIEE.

Set up an optimization transform that optimizes the value of RIEE over the measured4.
current.

The target data is the measured Ic current. The simulated data comes from the
simulation of this current.
The Parameters table contains only the circuit element RIEE.

After each of these measurements and optimizations has been executed, the Model
Parameters table is updated with the extracted values of these elements.

 Circuit Simulation
Circuit simulation is performed identically to single device simulation. The circuit usually
has more inputs and outputs defined than a single device. In addition, the simulated
circuit can use independent or controlled voltage and current sources that are defined
within the Circuit Editor. When IC-CAP simulates a circuit, it first builds a complete SPICE
deck from the circuit description and the setup table. The source names are built from the
source type (V or I) and the nodes to which they are connected. Use of the simulation
debugger can improve efficiency in performing successful simulations. Knowledge of how
IC-CAP interacts with the SPICE simulators gives you more control over the options
available for circuit simulation. For more information, refer to SPICE Simulators (sim).

One of the advantages of simulating circuits through IC-CAP is the increased levels of
analysis available. IC-CAP allows a sweep of more parameters than with a stand-alone
SPICE simulator. For example, it is possible to simulate a circuit's behavior over bias
conditions, component values and temperature in the same simulation. Once a simulation
is complete, you may further analyze the stimulus and response data with IC-CAP's
numerical and graphic capabilities. The two-port simulation features enable you to study
the high-frequency characteristics of a circuit using any of the S, H, Y, or Z 2-port
parameters.

 Design Optimization

Designing a circuit usually follows a path of defining a block level functional description,
translating it into discrete circuit components, then optimizing those components for the
required performance. This last stage can be simplified with the IC-CAP system. It is
possible to specify the desired performance from a circuit and then let the IC-CAP
optimizer find the best component and model parameters to satisfy it. The following is an
overview of how to do this.

Enter a circuit with a first order estimate of the required parameters and component1.
values.
Create a setup with the inputs and outputs that simulate the desired region of2.
performance.
Simulate the circuit to create a set(s) of output data.3.
Copy the simulated data into the measured data set(s) in the outputs.4.

Type the letter S in the Type field and press Return.1.
Type the letter B in the same field to replace the letter S.2.
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Save the desired outputs to files using the Write to File menu choice on each output.5.
Edit the files using any editor. Scan down the file to find the type MEAS data section.6.
This is where the measured data begins. Edit the output values, replacing them with
the desired performance values for the circuit. Save the file when done.
Read the file (and thus the new data) back into the outputs in IC-CAP using the Read7.
from file command on the desired outputs.
Set up an optimization transform to find the required parameter and component8.
values that best match the new measured data.

This type of design optimization can save many hours of iteration in fine-tuning high-
performance circuit designs.

 Test Circuits
When measuring a single device or a complex circuit you often require additional
components for biasing, setting operating points, or tuning the high-frequency
performance characteristics. Even when no additional components are required, there may
still be some parasitic elements introduced by the connections of the device to the
instrumentation. Examples of this are DC resistance in probe-to-wafer contacts,
inductances in IC package bond wires, and the shunt resistances in the bias ports of
network analyzers. The Test Circuit in IC-CAP allows you to include these elements when
performing a simulation or optimization without including them in the main circuit
description or device model.

 Syntax

A circuit editor is available for each DUT. To access it, select Edit in the DUT Circuit folder.
This produces a window that has both the DUT Parameters table and the test circuit
editor. The mechanics of using this editor are the same as using the circuit editor.

The test circuit adds another level of circuit hierarchy to the overall system being
measured and modeled. It is implemented through a circuit description that uses the
SPICE subcircuit syntax. The example test circuit shown in the following figure adds a
capacitor and resistor to the outputs of the ECL logic gate described earlier.

 Test Circuit for an ECL Logic Gate

* Resistive / Capacitive circuits to

* simulate the effect of gate loading

.SUBCKT gateload 1=IN1  2=IN2  3=OR

+ 4=NOR  5=VCC  6=VEE  7=VREF

Xornor 1 2 3 4 5 6 7 ECLornor

Cor  3 0 1p

Ror  3 0 10MEG

Cnor 4 0 1p

Rnor 4 0 10MEG

.ENDS

This test circuit is added to the SPICE circuit deck each time a simulation is called or when
an optimization that uses a SPICE simulation is performed. It does not modify the original
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model description in any way. The values of the elements in the test circuit can be
modified in the DUT Model Parameters.

 Hierarchical Modeling
The previous test circuit section on illustrated one way to include hierarchy in an overall
circuit description. The test circuit, however, is at the highest level of hierarchy in an IC-
CAP circuit. It is also possible to build a complete circuit by combining smaller circuit or
transistor models into one subcircuit definition. This way, you can update the models of
smaller subcircuits or individual components and have these changes automatically
propagate into all circuits that use it.

 Circuits Built from Sub-models

The ECL logic gate defined in ECL OR/NOR Schematic Diagram uses two sizes of NPN
transistors. Each transistor has a separate .MODEL card associated with it. These
transistor model definitions can be removed from the logic gate circuit and reference other
models currently active in IC-CAP. When a simulation is performed, IC-CAP includes these
device models in the circuit definition.

To use external models, the models that you want to include must be in the IC-CAP model
list. In the circuit definition that uses these model references, remove the .MODEL card.
The model name used for the transistors should then be the same as the names in the IC-
CAP model list. To use this technique for the ECL logic gate, read in models for the NPN1
and NPN2 transistors into IC-CAP. Then delete the two model cards in the logic gate
circuit. The resulting model list and circuit description are shown in the following 2 figures.

This approach provides flexibility. It allows you to keep a standard library of device models
to include in larger circuits requiring accurate device models. This allows you to quickly
cut-and-paste different component models into circuits and compare performance. It also
greatly reduces the size of the circuit definition that needs to be maintained.

 Model List Window for Hierarchical Circuit Definition

 Hierarchical Circuit Description for ECL OR/NOR Logic Gate

.SUBCKT ECLORNOR  1=IN1 2=IN2 3=OR 4=NOR

+ 5=VCC 6=VEE 7=VREF

* ECL OR/NOR LOGIC GATE

Q1   4  1  8  NPN1

Q2   4  2  8  NPN1

Q0   3  7  8  NPN2
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RL1  5  4  300

RL0  5  3  300

RIEE 8  6  1.2K

.ENDS

 Functional Circuit Blocks
Previous sections in this topic provided different aspects of the use of IC-CAP for modeling
complete functional circuits. This section provides detailed examples of circuit models and
custom model extractions you can create. These examples are provided to stimulate ideas
for using IC-CAP to meet specific circuit modeling requirements.

 Types of Circuits in IC-CAP

The types of circuits for measurement and simulation with IC-CAP are unlimited. Anything
that can be simulated on a stand-alone SPICE simulator can be simulated with IC-CAP. In
fact, any type of system that can be measured with the IC-CAP library of instruments can
be characterized.

With the variety of components supported by SPICE, IC-CAP can be used to both
characterize and design circuit modules. Classical examples of both single device and
functional circuit modeling problems that are easily solved with IC-CAP are included.

 Modeling the Reverse Active Region of an NPN Transistor

One of the constant sources of error in modeling the performance of a reverse active NPN
transistor is the parasitic PNP formed by the base, collector, and substrate of the
integrated structure. (This was briefly described in PNP Transistors (bipolar)) A simple
solution to modeling this region of operation is to use the complete functional circuit
displayed in the following figure.

 NPN Transistor with Parasitic PNP

Model file npnwpnp.mdl is included as an example of solving this problem. It has a single
DUT/Setup that measure and model the reverse active operation of an NPN transistor.

The previous figure shows that the emitter of the PNP steals current from the base
terminal of the NPN. The single dominant parameter that models this PNP current flow is
the saturation current IS. (Modeling the transistor at this point assumes that the DC NPN
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parameters have already been obtained using another model file. The bjt_npn.mdl model
file has a complete set of DUTs and setups to perform this. For more information, refer to
Bipolar Transistor Characterization (bipolar).)

The rgummel setup then uses an optimize function to simultaneously extract the reverse
active NPN parameters BR, IKR, ISC, and NC and the PNP parameter IS. The optimization
proceeds by simulating the compound device, which is represented as a 2-transistor
circuit, and numerically adjusting these model parameters.

The plot in the following figure is of reverse beta versus emitter current. It includes the
simulation of the single transistor reverse model and measurement and simulation of the
2-transistor compound structure. The result of this extraction is a near perfect agreement
between measured and simulated data. Also examine the resulting magnitudes of both IS
(large enough to not be negligible) and BR (much higher than for a single device
extraction). This example shows the improvement you can attain in using a full circuit
description to model an integrated device structure.

 Reverse Beta versus Ie for Single NPN and Compound NPN-PNP Structure

 Modeling an Operational Amplifier

The operational amplifier is included with IC-CAP as an example of how to do relatively
complex macro modeling. It illustrates the simplification of a complex circuit to the
necessary and sufficient components that enable it to be accurately represented. This
model includes a Program transform that extracts model parameters from data sheet
specifications of its performance. The inputs to this transform could also be measurements
of the opamp's electrical characteristics. This same Program transform has also been
converted into a standard IC-CAP function by writing it in the C programming language (in
the userc.c module) and compiling and linking it into the system. The circuit chosen
follows the model developed by Boyle, Cohn, Pederson, and Solomon [1]. This circuit
model is in the opamp.mdl example file.

 Opamp Macro Model
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The stages in this opamp model are: non-linear differential input, intermediate linear gain,
and output driver. These enable most of the possible operating regions of the complete
circuit to be adequately simulated.

The input stage contains transistors Q1 and Q2 connected as a differential amplifier,
biased with a fixed current source (see figure above). Q1 and Q2 provide both differential
mode (DM) and common mode (CM) characteristics. Passive components in the input
stage provide slew rate effects (C2, Ce, Re1, Re2), 0dB frequency control (Rc1, Rc2), DM
excess phase (C1), and CM input resistance (R1).

The intermediate gain stage provides linear amplification through voltage controlled
current sources Ga, and Gb, which model the differential gain of the opamp. Capacitor C2
controls the dominant pole. CM gain is modeled with the voltage controlled source that
has the coefficient Gcm.

In the output stage, AC and DC output resistances are modeled with Ro1 and Ro2. Output
drive voltage is supplied through diodes D1 and D2 and voltage controlled voltage source
(Gc*v6*Rc). The independent voltage sources in series with diodes D3 and D4 clamp the
opamp under conditions that would force the output voltage to one of the supply rails.

The development of this opamp model uses the concepts of simplification and buildup to
reduce the number of active and passive components. For example, to maintain non-linear
effects the input stage has been simplified to two transistors, and an independent current
source has been substituted for the usual bias circuitry. In the interstage amplifier,
buildup is used to emulate a circuit characteristic through alternate circuitry. The stage is
modeled by two voltage controlled current sources and a capacitor for compensation.
These techniques take a piece-by-piece approach to the development of a model. They
can be applied to virtually any circuit or subcell.

 Opamp Circuit Model

The following figure shows the macro model that represents the full opamp circuit,
followed by circuit elements in order from the input to the output stage. Opamp Circuit
Diagram shows the complete opamp model circuit definition used in this example.

 Opamp Circuit Definition

.SUBCKT OPAMP_1 2 = VINP 3 = VINN

+ 4 = VEE 6 = VOUT 7 = VCC

Q1 10 2 12 NPN1

Q2 11 3 13 NPN2

.MODEL NPN1 NPN IS = 8.0E\-16 BF = 111.7

.MODEL NPN2 NPN IS = 8.31E\-16 BF = 143.6

RC1 7 10 5305

RC2 7 11 5305

C1 10 11 5.46p

RE1 12 14 2712

RE2 13 14 2712

RE 14 0 9.872m

CE 14 0 2.41p

RP 7 4 15.36K
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GCM 0 15 14 0 6.28n

GA 15 0 10 11 188.6u

R2 15 0 l23.4K

C2 15 16 30P

GB 16 0 15 0 247.5

RO2 16 0 42.87

D1 16 17 DMOD1

D2 17 16 DMOD1

.MODEL DMOD1 D IS = 8.0E\-16

RC 17 0 0.02129m

GC 0 17 6 0 46964.0

RO1 16 6 32.13

D3 6 18 DMOD2

D4 19 6 DMOD2

.MODEL DMOD2 D IS = 8.0E\-16

VC 7 18 1.803

VE 19 4 2.303

IEE 14 4 20.26u

.ENDS

 Opamp Circuit Diagram
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 Inputs to the Opamp Macro Extraction

Inputs to the opamp model extraction describe its electrical performance. These
characteristics can be measured on actual devices or obtained from data sheet
specifications. Due to the flexibility of the origin of the inputs, you can experiment with
the opamp's performance as it relates to the model elements that control it. The following
table lists the inputs to the opamp extraction.

 opamp Extraction Inputs

Input Name Contents

Slew Rate + positive-going slew rate

Slew Rate- negative-going slew rate

Bias Current average input base bias current

Bias Offset input bias offset current

Volt Offset input offset voltage

Av(DM) open loop differential mode voltage gain

BW unity gain bandwidth (Av(DM) * f(-3dB))

Excess Phase excess phase at f(0dB) due to 2nd pole

CMRR (dB) common mode rejection ratio

Rout low-frequency output resistance

Rout-ac high-frequency output resistance

Isc+ positive short circuit current

Isc- negative short circuit current

Vout_max+ positive output voltage where opamp clamps Iout

Vout_min- negative output voltage where opamp clamps Iout

Power Diss quiescent state power dissipation

Vcc supply positive supply voltage

Vee supply negative supply voltage

Nom. Q.IS nominal transistor and diode saturation current

R2 differential gain setting resistor

Comp. Cap. compensation capacitance

Temp.(C) temperature for macro extraction and input specification

Inputs PNP? flag to switch the inputs to PNP transistors

Debug? flag to turn on debug output during extraction

 Extraction Equations for the Opamp Macro Model

The inputs to the macro model extraction described are used by the set of equations
shown in the following figure to produce the model parameters. These equations are
programmed into the userc.c module exactly as shown.

Because of the simplicity of the equations, they can also be entered into a Program
transform using the Parameter Extraction Language. This allows experimentation with
model extraction techniques before coding the final extraction in C and linking it to IC-
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CAP. This has been done with the opamp macro model to provide a typical example of
writing custom model extractions.

 C Coded Opamp Extraction Equations

 Bias Circuitry

The opamp model, fully defined and model parameters extracted, can now be used as a
functional circuit block. This requires that the opamp be biased with external supply
voltages and circuit configuring components. This was demonstrated previously through
the use of a test circuit. The test circuit implemented forms an inverting amplifier using an
input and feedback resistor with the opamp. This results in a complete functional circuit
whose performance can be studied in more detail. The test circuit definition and the
resulting equivalent circuit are shown in the following 2 figures.

 Test Circuit Definition to Form an Inverting Amplifier

* Inverting Amplifier

.SUBCKT  inv_amp 1 2 3 4 6 7

X1  2 3 4 6 7  opamp_1

Rf    6  2  10K

Rin   2  1  2K

Rgnd  3  0  1.0m

.ENDS

 Equivalent Schematic of Opamp in Inverting Amplifier
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The plot in the following figure illustrates how this functional circuit can be studied. The
opamp circuit has been simulated with the compensation capacitance used as one of the
sweep parameters. The AC voltage gain is plotted versus frequency with steps of different
values of C2. The diagonal line is the break point between process limitations and circuit
limitations. To increase frequency response, the internal capacitor on the chip (nominal
30pF) would have to be reduced. To force earlier roll-off, more external capacitance can
be added. This analysis indicates the range of gain-bandwidth product available for
different values of capacitance. Similar analyses can be performed for any area of this
circuit's operation.

 AC Opamp Response vs C2 Capacitance

 References
G.R. Boyle, B.M. Cohn, D.O.Pederson, J.E. Solomon. Macromodeling of Integrated1.
Circuit Operational Amplifiers, IEEE Journal of Solid-State Circuits, Vol. SC-9, No. 6,
December 1974.
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 Printing and Plotting
This section contains procedures for definition and creation of graphic displays and textual
reports and describes printing and plotting from IC-CAP.

You can send output to printers and plotters as well as to a file in a variety of formats.
When printing to a file, the format of the file is determined by the current output device
and the file is saved in the current project directory.

You can connect any output device that is supported by your operating system. To
connect additional printers and plotters, and select a default printer, choose the
appropriate method for your platform:

WindowsXP-Start menu > Settings > Printers
UNIX-Choose File > Print Setup

The basic Print commands are summarized next:

Use the Print command to print the contents of the current window
Use the Print Setup command to establish a default printing configuration, although
you can modify it at the time of printing

 Creating an IC-CAP Plot
This section contains procedures for definition and creation of graphic displays and textual
reports. The MOSFET model supplied with IC-CAP, nmos2, contains a variety of plotted
data sets and is used as the example in this section.

A plot is a graphical representation of data that gives a quick view of measured and
simulated data, making it easier to spot any differences between the two. Using IC-CAP's
plot analysis features, you can identify a data point or slope of a curve easily.

If you need to get raw data in the form of numbers rather than a graph, you can view
such data in a list form that can be sent to a printer.

The general procedure for creating a plot is:

Open the setup and add a plot.
Assign a data set to a graph axis.
Specify a report type and an axis type.
Put in a header and footer if necessary.
Open a plot window.
Rescale the plot if necessary.
Analyze the plot.
Print a hardcopy of the plot.

Note
The term data set means either Input, Output, or Transform, as used in Creating and Running
Macros (prog).
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Because the print methods vary significantly between UNIX and the PC, this section
describes printing from these platforms separately. See the appropriate section for
your platform:
Printing from UNIX
Printing from the PC

 

 Adding a New Plot

The first step in creating a plot is to add a plot.

To create a new plot:

In the DUTs-Setups folder, select the setup.1.

Then select Plots.2.
Click New.3.
In the Plot Editor, enter a name for the new plot.4.
Select one of the Report Types from the drop-down list.5.

The required fields change to reflect the selected report type. Fill in the necessary6.
fields for the selected report type. For details, see Defining a Plot for Specific Data
and Defining Axis Types and Data Sets.

Note
You can specify an alternate name for a plot legend by adding two exclamation marks ( !! ) followed
by the alternate name after the real data item. For example, the following statements label the X
data as vin and the Y data as calc_a :
X Data : /a/really/really_long_path/vin !! vin

Y Data 0 : (a + complicated)*expression !! calc_a
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Click Plot Options to define plot options. See Setting Plot Options.7.
Click OK. The new plot is added to the Plots folder.8.

 Defining a Plot for Specific Data

The following 8 tables list definitions for plot data types. Certain plot characteristics can be
set with system variables. When a variable applies to a specific plot type, the variable is
listed in the table for that type. Variables that apply to any plot are listed in Plot
Characteristics Variables.

 Defining a Plot for XY Data
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Data
Type

Definition

X Data: The Input name

Y Data 0: The Output name (or expression that is a function of the outputs)

Y Data 1-
7:

Names of additional outputs sharing the same scale as Y0

Header: Annotation that appears above the graph

Footer: Annotation that appears below the graph

X Axis
Type:

X Axis Type (Linear, Log 10, and dB) †

Y Axis
Type:

Y Axis Type (Linear, Log 10, and dB) †

Y2 Axis
Type:

Additional Y axis type used for showing another data set with a different magnitude or domain.
For example, use the Y axis for gain and the Y2 axis for phase.

Y2 Data: The name of a data set to display with a different scale.

† dB axis type represents 20 × log10(x), not 10 × log10(\x).

 Defining a Plot for Real/Imaginary Data

Data Type Definition

Sweep Data: The Input data set name

RI Data 0: The Output data set name or expression that is a function of the outputs

RI Data 1-7: Additional data sets or expressions

Header: Annotation that appears above the graph

Footer: Annotation that appears below the graph
 Defining a Polar Chart

Data Type Definition

Sweep Data: The Input data set name

Polar Data 0: The Output data set name or expression that is a function of the outputs

Polar Data 1-
7:

Additional data sets or expressions

Header: Annotation that appears above the graph

Footer: Annotation that appears below the graph
 Defining a Smith Plot

Data Type Definition

Sweep Data: The Input data set name

Smith Data 0: The Output data set name or expression that is a function of the outputs

Smith Data 1-
7:

Additional data sets or expressions

Header: Annotation that appears above the graph

Footer: Annotation that appears below the graph

A histogram depicts either the frequency or the relative frequency of data distribution.
Typically a histogram is used to identify both the ranges around which most of the data
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converges and the outliers of the data set. In a histogram, the X-axis displays the value
ranges while the Y-axis plots the frequency or relative frequency for each range. A
histogram is used for the visualization of data for a single variable.

 Defining a Histogram

Data Type Definition

Data-set: The Input data set name

Header: Annotation that appears above the graph

Footer: Annotation that appears below the graph

Variables for setting Plot
Characteristics

 

HISTOGRAM_NUM_BINS Number of bins in the histogram plot. Default is 10.

HISTOGRAM_NORMALIZATION Can be set to either TRUE or FALSE. Setting it to TRUE will normalize the
histogram. Default is FALSE.
NOTE: definition of the histogram normalization:
Assume
Variable X indicated the width of the histogram bin,
Variable n indicated the number of the histogram bins.
Variable Yi indicated the number of samples for the histogram bin with

index of i Variable normalize_Yi indicated the normalized number of

samples for the histogram bin with index of i Then we have,

HISTOGRAM_GAUSSIAN_FIT Can be set to either TRUE or FALSE. Setting it to TRUE will draw the
Gaussian curve fitted to the histogram. Default is TRUE.

A cumulative density plot depicts either the cumulative frequency or the cumulative
relative frequency of data distribution. Typically a cumulative density plot is used to track
variations between contemporaneous observations by highlighting changes in mean levels.
In a cumulative density plot the X-axis displays the value ranges while the Y-axis plots the
cumulative frequency or cumulative relative frequency for each range.

 Defining a CDF Plot

Data Type Definition

Data-set: The name of an Input data set

Header: Annotation that appears above the graph

Footer: Annotation that appears below the graph

Variable for setting Plot
Characteristics

CDF_ERROR_FIT Can be set to TRUE or FALSE. TRUE will draw the Gaussian curve fitted to
the Cumulative plot. Default is TRUE.
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A scatter plot depicts the distribution of pairs of values on a rectangular, 2-dimensional
plane. A scatter plot is the most effective method of analyzing the correlation between two
variables. Values for one variable are tracked on the X-axis while values for the other
variable are tracked on the Y-axis.

 Defining a Scatter Plot

Data Type Definition

X Data: The X-axis parameter name

Y Data: The Y-axis parameter name

Header: Annotation that appears above the graph

Footer: Annotation that appears below the graph

X Axis Type: X Axis Type (Linear, Log 10, and DB)

Y Axis Type: Y Axis Type (Linear, Log 10, and DB)

Variable for setting Plot
Characteristics

 

SCATTER_CONTOURS Can be set to either TRUE or FALSE. Setting it to TRUE will draw the
contours. Default is TRUE.

SCATTER_NUM_SEGMENTS Number of segments used in drawing the contours of the plot. Default is
1500. Using a larger number results in an accurate contour, but takes
more time.

 Defining a Multiplot Studio

Variable Definition

# of Plots Number of plots displayed in the Multiplot. The number can be from 1 to 100.
The default is 4.

Plot 1 - 100: Name of each plot.

# of GUIs: Number of GUI regions. The number can be 0 to 8. The default is 0.

GUI 1 - 8: Name of each GUI region.

GUI 1- 8 Location: Location on the Multiplot display for each GUI region. The location can be
upper left (UL), upper right (UR), upper (U), left (L), right (R), bottom left
(BL), bottom right (BR), or bottom (B).

Orientation: Orientation of the Multiplot. The orientation can be vertical (V) or horizontal
(H). The default is horizontal.

Plots Per Row: Number of plots in each row. If the number is 0, the plots will be arranged so
that the number of rows and columns are equal if possible (squared layout).
The default is 0.

Variable for setting Plot
Characteristics

 

DYNAMIC_MULTIPLOT_MODE Sets the location where the manual scaling setting is saved for a Multiplot. If
set to FALSE, the manual scaling setting for each subplot in a Multiplot is
saved with the Multiplot, allowing different scaling to be saved for the same
plot if opened as a single plot or on one or more Multiplot. If set to TRUE, the
manual scaling setting for each subplot in a Mulitplot is saved with the
subplot. In this mode, no matter where the plot is opened (as a single plot or
on one or more Multiplots), it will use the same scaling information. However,
if the same subplot appears on multiple Multiplots, or in multiple positions of
the same Multiplot, then the settings for only the last subplot closed is saved.
Default is FALSE.
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 Plot Characteristics Variables

Variable Definition

ANNOTATE_AUTO Sets a flag to enable or disable automatic annotation update upon
data changes. Default is No.

ANNOTATE_CSET Sets a Starbase character set to be used for annotation texts.
Default value is determined by /usr/lib/starbase/defaults.

ANNOTATE_FILE Sets a file name from which a plot reads in an annotation text.
Default is no file to read.

ANNOTATE_MACRO Sets a macro name that is executed by a Plot for generating an
annotation text. Default is no macro to execute.

CHECK_PLOT_MATCH Lets IC-CAP check if a given XY pair belongs to the same Setup. If
No, potentially mismatched XY pair can be shown in a tabular format
with Display Data. Default is Yes.

DASH_DOT Sets the number of data points at which a simulated line changes
from a dashed to a dotted line. Used in Plot. Default value is 32.

FIX_PLOT_SIZE If Yes, Plot windows open using the size specified by GWINDX and
GWINDY. If No, they open using the last displayed size. Default is
No.

GWINDX Sets the initial Plot window horizontal size in 1/100mm †. Used in
Plot. Default value is 12500.

GWINDY Sets the initial Plot window vertical size in 1/100mm †. Used in Plot.
Default value is 9000.

IGNORE_PLOT_LOC If Yes, Plot windows open using the X windows system configuration.
If No, they open using the last displayed location. Default is No.

MINLOG Can be set to a real value. Defines the value to be used in a LOG
plot, if data point value is zero or negative. Default is 10e-18.

OFFSCREEN_PLOT_LINE_ WIDTH Sets the line thickness used when drawing a plot to an HPGL file or
HPGL printer. OFFSCREEN_PLOT_TRACE_LINE_WIDTH will override
this value for the traces on a plot. Default is 0.

OFFSCREEN_PLOT_TRACE_LINE_WIDTH Sets the line thickness used when drawing the traces of a plot to an
HPGL file or HPGL printer. Default is 0.

PLOT_LINE_WIDTH Sets the line thickness used when drawing a plot.
PLOT_TRACE_LINE_WIDTH will override this value for the traces on
a plot. Default is 1.

PLOT_TRACE_LINE Sets whether trace line is drawn or not. If defined as Yes, the trace
lines are drawn. If defined as No, the trace lines will not be drawn,
and instead markers will be drawn. Default is Yes.

PLOT_TRACE_LINE_WIDTH Sets the line thickness used when drawing the traces of a plot.
PLOT_TRACE_LINE_WIDTH will override this value for the traces on
a plot. Default is 1.

RETAIN_PLOT When Yes and Auto Scale is off, plot is not erased when updated to
allow overlay of curves if the X server has backing store capability.
Default is No.

RI_GRAPH_SYMMETRY When defined as Yes, the plot title is displayed. If defined as No, the
plot title is not displayed. Default is Yes.

SHOW_GRID When No, plot eliminates XY grids and leaves tics. Default is Yes.

USE_PLOT_LOOKUP Lets IC-CAP perform auto-lookup of X data from each Y data.
Another way to disable auto-lookup is to use an arbitrary expression
for an X data. Default is Yes.
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† On-screen size differs depending on screen dpi calculated with OS-reported screen
width/height.

 Editing a Plot

To edit an existing plot definition:

Open the Plot Editor:1.
From the plot window, click Options > Edit Definition or right click on the plot
then choose Edit Definition.
From the DUTs-Setups folder, select the setup. Then select Plots. Now double-
click the plot table you want to edit or select the plot table and click Edit.
Alternatively, you can edit directly in the plot table. See Table and Text Editors.

Change the fields as needed and click OK. The plot definition is updated.2.

Notes:

If the plot window is open when you click OK, the plot window closes then
immediately reopens with the new definition. The exception is if you were editing the
definition of a sub-plot in a Multiplot window. In that case, the Multiplot window
refreshes with the updated definition. If the selected plot was also displayed in a
single plot, the single plot closes and does not reopen.
In a Multiplot window, if you right click on a plot to open the Plot Editor and change
the plot's name, when you click OK the plot disappears from the Multiplot window.

Tips:

Use Display Plot to view the plot window for an individual, selected plot.
Use Display All to view plot windows for all defined plots.
Use Close All to close all open plot windows.
For all plots except Multiplot, use View to see data in a tabular format.

 Defining Axis Types and Data Sets

In the example definition, both X axis and Y axis are defined as LINEAR. You can change
this type to either LOG10 or DB. Although the example does not need to have a log Y axis,
try changing it:

Select the example plot, idvsvg. Click Edit.1.
In the Y Axis Type field, toggle to LOG10 and click OK.2.
Click Display Plot to view the graph. The graph idvsvg is updated with a logarithmic3.
Y axis.

Note
The XY GRAPH is not a convenient means for viewing complex numbers. If you want to make a
graph with complex numbers, use either the RI GRAPH or the POLAR GRAPH. These graphs take one
sweep data set, such as frequency, and generate a Real/Imaginary graph or a Polar graph.

 Y2 Data
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Another Y axis, called Y2 data, is available for XY GRAPH. The Y2 data axis is useful for
showing another data set with a different magnitude or domain. For example, in a gain
and phase versus frequency graph you can use the Y axis for gain and the Y2 axis for
phase. The Y2 axis always requires one or more Y data sets because a slope of a Diag Line
is derived from the left axis values.

The program assumes that Y2 data shares the same setup with the X data, so the
program never looks up the Y2 data and always draws against the X data in the plot
definition.

 Expression

An expression can be entered into the data set fields described above, just like any other
fields where an expression is allowed. For example, you can enter a natural log of id as
log(id) in the Y Data 0 field. The calculated data set belongs to the setup where this plot
definition exists.

Note
A scalar value is expanded to an array of the constant value so that it shows up as a straight line on a
graph. For more information on functions, refer to Using Transforms and Functions (prog).

 Multiple X Data

IC-CAP allows plots to have multiple XY pairs in a single graph by looking up the same X
data name in another setup. This is useful when comparing multiple XY pairs with different
X ranges.

 Auto Lookup

Each Y data set is examined for its corresponding X data set. This feature, called Auto
Lookup, takes the X data name from the plot definition and searches this name in the
setup that has this particular Y data in question. If there is no such X data in that setup,
then the X data in this plot definition is used.

For example, the next definition draws two different sets of id vs vg curves based on large
and short setups so that one set represents id vs vg of nmos2/large/idvg setup while the
other set shows that of nmos2/short/idvg. The Y data names do not have to be the same.
This feature supports all the report types.

 Id vs Vg #1

Report Type XY GRAPH}

X Data /nmos2/large/idvg/vg

Y Data 0 /nmos2/large/idvg/id

Y Data 1 /nmos2/short/idvg/id

If this plot exists in the nmos2/large/idvg setup, then the next definition is good enough
to show the same curves. In both cases, the number of data points and points per curve
may vary among Y data sets because each Y data is shown against its corresponding X
data from their home setup.
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 Id vs Vg #2

Report Type XY GRAPH

X Data vg

Y Data 0 id

Y Data 1 nmos2/short/idvg/id

The tabular report drops each Y data set that does not share the X data of the plot
definition, because representing multiple, possibly independent X and Y data pairs in a
simple 2-dimensional table is difficult.

For example, the plot definition in the second table shows the vg and id of
nmos2/large/idvg setup only. When you must show all data sets that do not share the
same X data, set the system variable CHECK_PLOT_MATCH to No.

 Calculated Data

If an expression is entered into a plot definition, then the calculated result belongs to the
setup where the plot definition exists. Therefore, when using a transform, you must
calculate data within its home setup.

For example, the next definition based on the previous example gives the wrong curves
for Y Data 1 because the id in the short setup is drawn against vg in the large setup. If the
data size does not match between the X and Y data sets, the program issues an error
message.

 Calculated Id

Report Type XY GRAPH

X Data vg

Y Data 0 id

Y Data 1 nmos2/short/idvg/id*2

 Disabling Lookup

You can disable the Auto Lookup so that all the Y data are drawn against the same X data
even if these Y data sets do not belong to the same setup with the X data. To turn off the
Auto Lookup set the system variable USE_PLOT_LOOKUP to No.

 Displaying Raw Data

You can view the raw data for an input, output, transform, or plot (except Multiplot) by
selecting it and clicking View (in their respective folders). The data format displays the
data point number, data index, and the real and imaginary part of the data.

Point shows the number of sweep data point starting from 0 (zero).
Index represents a pair of subscripts for a matrix data, such as S-parameters. These
are in row, column format.
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The actual data points for an input, output, or transform are shown in real and imaginary
format represented in the header by R and I.

The data format for plots follows the report type of the plot itself. When the report type is
XY GRAPH only the real part of the data is displayed.

Pnt/cv shows two digits, as discussed in Marking a Point.
M indicates measured data and S indicates simulated data.
C denotes common data that is shared between measurements and simulations (for
example, an Input).

The tabular data of a plot shows the Y data that belongs to the setup of this plot. Foreign
Y data is not displayed because of the different X data. See Y2 Data.

 Displaying Plots

You can open a plot window to view your measured and simulated data (see the following
figures). The currently-defined graphs are listed in the Plots folder in each setup. You can
open one or more plot windows at a time and each display appears in a separate window.
For all plots except Multiplot, you can view the same data at the same time on a graph
and in a tabular format.

Measured data is displayed as a solid line; simulated data is displayed as small squares by
default. Plots are automatically updated each time a measurement or simulation is
performed. After an extraction and subsequent simulation, you can view the plots for
agreement between measured and simulated data.

To view the plot window:
For an individual, selected plot, click Display Plot
For all plots defined in a setup, click Display All

To see data in a tabular format for all plots except Multiplot, click View. 
To close all open plot windows, click Close All. 

Note
Alternatively, you can display a plot by selecting a plot definition and clicking the right mouse
button. Then choose an option from the menu.
If you want to display or close plots while a different folder is open, use the tool bar buttons at the
top of the Model window: Display Plots (Setup), Close Plots (Setup), Display Plots (DUT), Close Plots
(DUT).

 Area Tools

To display Area Tools, choose Options > Area Tools or right click then choose Graphic >
Area Tools. The following figure shows a Plot window with Area Tools displayed.

 Example Plot Window



IC-CAP 2011.01 - Introduction and Basics

157

The PO (Plot Optimizer) area tool performs the same function as the Optimizer >
Enable/Disable Plot menu pick. When enabled, the PO area tool is blue and the plot has a
blue border. For additional information about the Plot Optimizer, see Using the Plot
Optimizer (sim).

The A (Autoscale) area tool performs the same function as the Options > Autoscale menu
pick. See Scaling.

The E (Error) area tool performs the same function as the Options > Error menu pick. See
Defining and Displaying Errors.

The X (X Axis Type) area tool enables you to toggle through the available X axis types
from the plot window. To view the current selection, position and hold the cursor over the
area.

The Y (Y Axis Type) area tool enables you to toggle through the available Y axis types
from the plot window. To view the current selection, position and hold the cursor over the
area.

The Y2 (Y2 Axis Type) area tool enables you to toggle through the available Y axis types
from the plot window. This area tool is only shown when a Y2 trace is present.

Multiplot windows also have a Zoom area tool. The Zoom area tool enlarges the selected
plot. A red border indicated which plot is selected. When Zoom is enabled, you can change
which plot is enlarged simply by clicking on a different plot. In addition, the Plots menu
enables you to zoom in or display a full page plot. Example Zoomed Multiplot Window
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shows a 2 plot Multiplot window with Zoom enabled.

 Example Multiplot Window

 Example Zoomed Multiplot Window

 Scaling

 Autoscale

Autoscale can be toggled on and off by either:

Choosing Options > Autoscale
Right clicking on the plot then choosing Scaling > Autoscale
Clicking the plot's A area tool.

If a check mark is before the Autoscale menu item or the plot's A area tool is orange,
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Autoscale is on. When Autoscale is on, the axes will autoscale so all data is visible. When
Autoscale is off, the state of this menu item is saved to .mdl files. For example, if you
save a plot (or a model containing the plot) with Autoscale turned off, the plot retains the
setting, and opens in the Autoscale OFF state the next time the plot is opened.

Axes scaling is controlled by settings you choose in the Manual Rescale dialog box
(Options > Manual Rescale). If you have a new plot, or a plot that has never had the
scaling modified, turning Autoscale off locks the current settings in place. Any future
toggling of Autoscale ON/OFF will switch between full scale, and this remembered setting.
The remembered setting can be further modified by using the Options > Manual Rescale
or Options > Set Scale menu choices.

 Rescale

You can zoom into a selected area of a plot by drawing a box around a portion of the plot,
then either:

Choose Options > Rescale
Right click on the plot and choose Scaling > Rescale
Click the A area tool
In a Multiplot window, select a plot then choose Plots > Selected Plot Menu > Scaling
> Rescale

Also, you can pan across the plot by selecting a single point on the plot then choose
Rescale. The plot moves so the selected point is at the display's center. When Autoscale is
on, the rescaling is temporary. The next replot restores the plot to full Autoscale.
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 Set Scale

The Options > Set Scale menu item is a shortcut to establish Manual Rescale settings. You
can also access this menu item by right clicking on the plot then choosing Scale > Set
scale or from a Multiplot window by first selecting a plot then choosing Plots > Selected
Plot Menu > Scaling > Set scale. Whether you are in autoscale mode or had performed a
Rescale to zoom in on a region of the plot, choosing Options > Set Scale sets the Manual
Rescale dialog box to the plot's current scaling values (e.g., X min, X max, Y min, Y max,
etc.).

 

 Manual Rescale

The Manual rescale dialog box enables you to fully describe all three axes of XY plots in
terms of minimum value, maximum value, number of major divisions, and number of
minor divisions. You can access this dialog box by choosing Options > Manual rescale or
right clicking on the plot then choosing Scaling > Manual rescale. In a Multiplot window,
you can access this dialog by selecting a plot then choosing Plots > Selected Plot Menu >
Scaling > Rescale.
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In addition

You may leave any of the three axes autoscaled if you like.
You may scale the real and imaginary axes of RI plots as well. RI, Smith, and Polar
plots can be centered around a specified point with a specified radius displayed.
You may specify the number of major and minor divisions for RI and Polar plots, but
not for Smith plots.

Histogram and cumulative density plots permit scaling of the X axis and scatter plots
permit scaling of the X and Y axes. Some requests may be denied due to algorithmic
constraints, and in this case, the closest match is made updating the dialog with the
actual values used. For example, LOG scaled axes are forced to the next decade, and the
number of major and minor divisions are ignored. The number of major divisions in polar
plots must be even.

Manual Rescale enables you to set the minimum to a specific value, such as .123, without
rounding the value up or down. While this gives you much greater control, it can cause
some problems with numbers overwriting each other, usually on the X axis. However, LOG
scaled axes will still round up or down to the nearest decade.

Any settings established using Manual Rescale, the associated iccap_func command, or
Options > Set Scale are saved with the plot in the .mdl file. To establish settings, choose
OK or Apply. (OK also dismisses the dialog box.) To see what a plot looks like before
establishing the current settings, choose Preview. To restore settings to the previously
established ones, choose Reset or Cancel. To dismiss the dialog box, choose Cancel.
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The settings in this dialog box update dynamically whenever a plot's scale changes. Scales
change dynamically for various reasons, including when a simulation changes an
autoscaled limit, or the Options > Rescale menu item is chosen. Updated settings do not
change your established settings until you choose OK, Apply, or Options > Set Scale.
Dynamic updating is convenient when you want to establish new settings.

Manual Rescale is fully controllable through PEL. To rescale a plot, use the iccap_func
command for Plot:

iccap_func("Plot","<keyword>")

The allowed keywords include:

Scale Plot
Scale RI Plot
Scale Plot Preview
Scale RI Plot Preview

Note
The keywords Scale RI Plot Preview and Scale Plot Preview function in the same way as Scale RI Plot
and Scale Plot, but the scaling will be lost on the next Replot command.

When the iccap_func command is used as shown above, prompts appear for the
operator to enter required values for the parameters that describe the plot's scaling
values. For additional information, see Scale Plot/Scale Plot Preview (prog) or Scale
RI Plot/Scale RI Plot Preview (prog).

 Marking a Point

You can identify the nearest data point on the graph and show its X and Y values and data
point number by marking a point.

To mark a data point:

Click the Left mouse button on the graph.
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To erase the circle that marks the point:

Click the Left mouse button in the graph window, but on the outside of the
graph itself. This erases the circle that marks the point, as well as its data
values.

The data point number has two digits separated by a slash. The number on the left of the
slash represents the primary sweep point number (sweep order 1), and the number on the
right shows the secondary sweep point number (sweep order 2). A data point on Y2 axis
can not be identified.

 Drawing a Diagonal Line

You can draw a diagonal line connecting two clicked points and its slope, with both X and
Y axis intercepts.

To draw a diagonal line:

Click and drag the Left mouse button from one point on a curve to a different point1.
forming a rectangle.
Choose Options > Draw Diag Line (or from a Multiplot window, choose Plots >2.
Selected Plot Menu > Graphic > Draw Diag Line).
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Note
To erase the diagonal line, select Options > Draw Diag Line, without going through the mouse clicks
forming the rectangle.

 Setting Variables

When a rescale rectangle is shown on a plot, its X and Y values can be copied to system
variables. Four variables (X_LOW, X_HIGH, Y_LOW, and Y_HIGH) are reserved for this
purpose. You can use this feature when setting X and Y limits for optimization by
specifying these variables in the Optimizer Options Table.

To perform Set Variables define these system variables at any level. Only the1.
variables of interest must be defined.
With the left mouse, click and drag on a plot to form a rectangle.2.
Choose Options > Copy to Variables (or press C on the keyboard). From a3.
Multiplot window, choose Plots > Selected Plot Menu > Graphic > Copy to
Variable.

Note
When a Multiplot includes plots from different setups, choosing Copy to Variable updates the
variables in the setup where the single plot was initially defined and does NOT update the variables
in the setup for the Multiplot.
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Note
The data values are taken directly from the plot. Therefore, you may need to transform those values
to another form when they are used in the Optimizer Options Table. For example, if the optimization
target is log(ic) and the plot shows ic versus ve with LOG10 Y axis type, the Y Bound in Optimization
should be log(Y_LOW) and log(Y_HIGH).

 Defining and Displaying Errors

You can display a plot's relative or absolute error based on either the entire plot or a
selected region. The Error menu is only active when the Y2 trace is not occupied by
another trace. In addition, only one trace of type Both can be present and if 2 traces are
present, one must be of type Measured and the other of type Simulated or calculated. To
view the Error menu, choose Options > Error or right click on the plot then choose Error.
The Error menu contains the following choices:

Show Relative Error toggles the MAX and RMS relative errors in the footer area on or
off.
Show Absolute Error toggles the MAX and RMS absolute errors in the footer area on
or off.
Select Whole Plot uses all points in the measured/simulated datasets to calculate the
error.
Select Error Region uses only the points within a defined region to calculate the error.
To define a region, click and drag on the plot to form a box. When Select Error
Region is selected, a green box that delimits the error calculation replaces the white
box.

Note
A simulated/calculated data trace usually varies during tuning/simulation. Therefore once a region is
selected, only a fixed number of measured points inside the green box are used to calculate the
error terms.

If Area Tools are enabled, you can click on the plot's E area tool to toggle between
displaying relative error, absolute error, or not displaying any error. The E area tool
is green if error calculation is enabled. To enable Area Tools, choose Options > Area
Tools.

 

 Setting Plot Options

Using the Plot Options dialog box, you can define trace options, plot options, text
annotation, and for Multiplots, specify a PEL callback to run whenever the selected plot
changes.

The Plot Options dialog box can be opened from the:

Main window, Tools menu
Model window, Tools menu
Plot Editor dialog box
Plot window, Options menu or right click menu (except from Scatter, Histogram, or
CDF plots that were opened by the Statistic Package)
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If the Plot Options dialog box is opened from the Plot Editor dialog box or from a plot
window, a Preview button is displayed between the OK and Cancel buttons. To apply the
current settings to the plot without closing the Plot Options dialog box, choose the Preview
button.

To apply the current settings and close the dialog box, choose the OK button.

To discard all changes and close the dialog, choose the Cancel button.

To save the current settings to a file for later use, choose the Save button. The Save Plot
Options dialog box appears. Enter a file name with a .pot extension and choose a file
location.

To load previously saved plot option settings, choose the Load button. The Open Plot
Options File dialog box appears. Locate the saved file then choose Open.

 Trace Options

The Trace Options tab enables you to define trace colors and symbol shapes for all plots
except Scatter, Histogram, and CDF plots. If you select Automatic, the default IC-CAP
settings is used. If you select a specific color, an asterisk  is display next to the color to
indicate that it is not the default color.

You can also define the line types for Measured and Simulated Data. Default is a special
selection, it will use the settings on plot options tab.
Take Measured Data for an example, if you choose Default, it will use Measured Trace
setting in plot options tab as current selection for that Y data only, if you choose
something other than Default, that Y data will use that setting for measured data.
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 Plot Options

The Plot Options tab enables you to define Data Representation, Layout and Background,
and Text Font. However, for Scatter, Histogram, and CDF plots, the Data Representation
section is not available.
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 Text Annotation

The Text Annotation tab enables you to add annotation text to document information such
as date, lot number, simulation parameters, and so on. You can either directly enter text
annotation or you can specify a PEL macro (see Annotating a Plot Using a PEL Macro).
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 Advanced

The Advanced tab enables you to specify a PEL callback (macro or transform) to run
whenever the selected plot in a Multiplot changes. Note that reselecting the same plot will
not invoke the callback.

To specify a PEL callback, unselect Automatic then type in the callback path and name.
Using a relative path, the callback is found relative to the Multiplot. Therefore, the path for
macros is ../../MacroName and for transforms is ./TransformName. This is true regardless
of where you open Plot Options. For example, if you open Plot Options from the Model
window, the relative path for a macro is still ../../MacroName.
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The callback passes 3 arguments to the PEL function that are received by calling linput 3
times at the beginning of the callback. The first linput receives the name of the Multiplot
where the selection is occurring. The second linput receives the new slot number selected
(according to the entries on the plot definition, i.e., Plot 0 will be slot 0, Plot 2 will be slot
2, and so on). The third linput receives the old, no longer selected, plot number. A slot
number of -2 indicates that no plots were selected.

 Example Plot Selection Callback

linput "plot?",plot

linput "slot?", slot

linput "oldSlot?", oldSlot

print "newSlot=";slot;" oldSlot=";oldSlot;" Plot: ";plot

 Restrictions

This callback can only identify when the selection changes. Currently no mechanism
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exists that can detect when a plot is clicked on again, reselecting the same plot.
Calling iccap_func() with "Select Plot" is not allowed during the selection callback and
doing so will have no effect. Selection can occur just prior to displaying a right click
menu or at the start of a click and drag. Changing the selection at these moments
would be problematic, and allowing selection changes for some selections but not
others can be equally problematic, so it is not allowed.
Deleting the invoking Multiplot or the plot that is being selected is not allowed during
the selection callback.
You can modify Multiplot entries during a callback, but any call to Replot will do
nothing during the callback. This is because changing a graph between selection and
display of the right mouse menu can lead to problems.
In general you should not change the Multiplot, its selection, or any of the child plots
during a selection callback. The purpose of the callback is to allow an embedded GUI
to change states in reaction to the selected plot.

 Multiplot Layout

The Layout tab enables you to define the layout and background settings for a Mulitplot.

 Setting Other Plot Characteristics

You can enable or disable several other plot characteristics that are available on the Plot
window's Options > Session Settings menu. Although IC-CAP only retains these settings
during the current session, you can save the current setting to Plot Options, or you can
reset your settings back to the saved Plot Options.

Area Tools turns the graph's area tools on or off.
Legend turns the graph's legend on or off.
Text Annotation turns the graph's text annotation on or off.
Title turns the graph's title on or off.
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Header turns the graph's header on or off.
Footer turns the graph's footer on or off.
Exchange Black-White reverses the black and white settings for the graph's grid,
text, and background.
Color turns color on or off for the traces and markers. When Color is off, the traces
and markers are the same color as the graph's grid and text.
Reset to Saved Options resets the current session settings back to the saved Plot
Options. This menu pick is not available from Scatter, Histogram, or CDF plots that
were opened by the Statistic Package.
Save Current Settings saves the current session's settings as the saved Plot Options.
This menu pick is not available from Scatter, Histogram, or CDF plots that were
opened by the Statistic Package. However, for these plots you can open the Plot
Options dialog box from the IC-CAP/Main window to save the settings.

 Saving a Plot Image

You can save an image of a plot with its current characteristics and size.

To save a plot image:

Select File > Save Image.1.
In the Plot Image File Name dialog box, set the location where you want to save the2.
file.
Enter the file name in the form of filename.ext where ext is gif, jpg or png.3.

Note
You can save plots in various formats in Plot windows, by using the File > Save Image menu item.
This feature uses ImageMagick's "Convert" program. See Help > About IC-CAP for more
information. Agilent Technologies officially supports the .GIF, .JPG and .PNG formats, though .EPS,
.PS, .HTML, .TIF, and other formats are available.

Select OK or Save. There may be some delay while IC-CAP processes the image.4.

Note
On Windows, you can copy a plot image to the Windows clipboard, paste it into another applications
(such as Microsoft Paint), then save it in the other application. To copy a plot image to the Windows
clipboard, select Options > Copy to Clipboard or press Ctrl_C on the keyboard.

 Annotating a Plot Using a PEL Macro

Each plot can read a text file and display this text next to its graph. The text area is 40
characters by 25 lines maximum for the USASCII character set (see ANNOTATE_CSET in
the section Annotation Variables).

To add annotation text to a plot:

Create a Macro program to generate an annotation text.1.
Assign appropriate values to annotation system variables.2.
Open a plot window.3.
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 Annotation Variables

The variables that control the annotation in a plot can be defined at any level, providing
flexibility and programming capability. These variables are:

ANNOTATE_MACRO. This variables sets a macro name which is executed by a plot for
generating annotation text. If this variable is undefined or blank, then no program is
executed. A model name may precede a macro name to locate a macro in another
model (for example, /npn/legend).
ANNOTATE_FILE. This variable sets a file from which a plot reads in annotation text.
When this variable is undefined or blank, a plot does not read a file to update its
annotation.
ANNOTATE_AUTO. When this variable is either Y or Yes, then a plot updates its
annotation whenever its datasets are updated, for example, when measured or
simulated. Otherwise, the annotation is updated when a plot window is opened or its
menu choice Update Annotation is selected.
ANNOTATE_CSET. This is an optional variable to specify a character set for the text.
A 16-bit character code is possible by giving a value like jpn, korean, or chinese-t
when NLIO (Native Language I/O) is installed. If this variable is undefined or blank, a
default character set (usascii as set in $ICCAP_ROOT/config) is used.

 Annotation Example

The annotation example shows how to use the annotation text from the example plot used
in this section. The following table shows variable values for this example, except
ANNOTATE_FILE, which is defined in the legend macro program.

 System Variables for Annotation
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Variable Value

ANNOTATE_MACRO legend

ANNOTATE_FILE  

ANNOTATE_AUTO No

ANNOTATE_CSET  

The legend macro program is shown in the following figure. This macro sets the
ANNOTATE_FILE variable and writes text into this file. Later, a plot reads this file
automatically for its annotation.

 A Macro Program for Annotation

! Plot annotation generation program

!

file_name = system$("echo $HOME/.icplotnotes")

ANNOTATE_FILE = file_name

x = system("rm " & file_name)

!

printer is file_name

!

print "BIPOLAR DC CHARACTERIZATION"

print

print "Date: "; system$("date +%D")

print "Operator: "; system$("logname")

print "Transistor Type = "; POLARITY

!

printer is CRT

 Advanced Annotation

 Annotation for Each Plot

Multiple plots in a single setup share the same annotation macro and text file. To have
different annotation for each plot in a single setup, create a macro program that generates
texts and opens each plot in turn. In this case ANNOTATE_MACRO should be blank.

 16-bit Code Annotation

If you have installed NLIO for 16-bit character code such as Japanese, plots can display
these native languages by assigning an appropriate character set to ANNOTATE_CSET. A
macro program can include these 16-bit characters in a string and print them out into a
file. However, you need to use an external text editor such vi in an hpterm window to
input such characters. To edit a macro program with vi, add a new macro program in IC-
CAP, write it out to a file, edit this file with vi, and then read it back into IC-CAP. IC-CAP
can show you these 16-bit characters in a Macro Editor if a 16-bit code font is assigned.
For example, for Japanese font, execute the program with the option shown below. Be
sure to specify jpn for ANNOTATE_CSET in this case.

iccap -xrm "iccap*XmText.?*FontList: jpn.8x18"

 Printing from UNIX
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Printing and plotting from IC-CAP on UNIX is accomplished by establishing the desired
print setup and then choosing File > Print. The Print Setup and related dialog boxes
enable you to:

Select a printer/plotter other than the default
Install additional printers or plotters
Set the print resolution (dpi)
Scale the output

When you select a printer/plotter, you can also change the following default
printer/plotter-specific options:

Page Size
Source (Paper Tray)
Duplexing (Double-sided)
Orientation (Portrait or Landscape)
Color (Black and White or Color)

When you choose File > Print, you can select from the following additional options:

Choose to send output to a printer/plotter or print to file
Scale the output to fit to the page
Select a file format (if printing to file)
Specify the number of copies

Your print setup is saved in $HOME/.Xprinterdefaults. If you do not have a local copy of
this file, or the file. Xpdefaults (from a previous release), the default file is read from the
$HPEESOF_DIR/xprinter directory. When you change your print setup, the changes are
saved (as new defaults) to $HOME/.Xprinterdefaults.

Note
If you do have a file. Xpdefaults (from a previous release), the settings of this file are copied to the new
filename to serve as the starting point for your print setup. Both files are valid, depending on which
release of IC-CAP you are using. The old file is maintained for running an earlier version of IC-CAP, but the
new file is used when you run IC-CAP 2006 (or later).

 Setting Up a Printer

The Print Setup dialog box enables you to setup and manage your printer options. To
access the Print Setup dialog box,

Choose File > Print Setup. The Print Setup dialog box appears.1.
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For detailed information on using the Print Setup dialog box, refer to the following table.

 Using the Print Setup Dialog box
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Option Description

Printer Use this section of the Print Setup dialog box to define and manage your printers.

  Name: Select a printer from the Name drop-down list. If the printer you want to use is not
available in the list, click the Printer Management button. For more information, refer
to Managing Printers.

  Printer Management If you want to add, replace, or remove a printer, click the Printer Management button
to access the Printer Management dialog box. For more information, refer to Managing
Printers.

  Model Info: This section displays the selected printer model information.

  Resolution (dpi): This option enables you to set the print quality (resolution) in dots per inch (dpi).

  Scale Factor (%): This option enables you to set a scaling factor that defines the percentage of normal
size by which to enlarge or reduce the document on the page. Default is 100%.

Paper Use this section of the Print Setup dialog box to define the paper settings.

  Size: Use the Size drop-down menu to select the paper size. Default is Letter.
 
Note that paper sizes can vary depending on the paper manufacturer. If you own a
printer that provides a specific paper size that you are not familiar with, consult your
printer manual for information on the paper size options available. The more common
American paper sizes are listed below in inches (Width vs. Height).
 
Letter = 8.50" (W) x 11.00" (H)
Executive = 7.25" (W) x 10.55" (H)
Legal = 8.50" (W) x 14.00" (H)
Tabloid = 17.00" (W) x 11.00" (H)
Ledger = 11.00" (W) x 17.00" (H)
 
Consult the International Organization for Standardization (ISO) for standard A through
D-sizes as well as RA and SRA-sizes.

  Source: Use the Source drop-down menu to select the tray that has the paper you want to use.
Default is the Upper tray.

  Duplexing: The Duplexing drop-down menu enables you to print on both sides of the paper. The
options available are:
- None - No duplexing, the document will only print on one side of the paper.
- Flip on Short Edge - This option prints on both sides of each sheet and flips the page
along the short edge of the paper.
- Flip on Long Edge - This option prints on both sides of each sheet of paper and flips
the page along the long edge of the paper.
The default Duplexing option is None.

Orientation Use this section of the Print Setup dialog box to define the orientation of your printed
page.

  Portrait Click this option if you want your output printed in portrait orientation mode. Portrait is
taller than it is wide when you view the text right-side up. Default is activated.

  Landscape Click this option if you want your output printed in landscape orientation mode.
Landscape is wider than it is tall when you view the text right-side up. Default is
deactivated.

Color Use this section of the Print Setup dialog box to define your color settings.

  Black and White Click this option if you want your output in black and white. Default is activated unless
the system detects support for color printer. If this is the case, the system will default
to the color option.

  Color Click this option if you want your output in color. Default is deactivated unless the
system detects support for color printer. If this is the case, the system will default to
the color option.
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 Managing Printers

The Printer Management dialog box enables you to manage an individual printer or group
of printers. To access the Printer Management dialog box,

Choose File > Print Setup. The Print Setup dialog box appears.1.
Click the Printer Management button in the Print Setup dialog box. The Printer2.
Managemen t dialog box appears.

For detailed information on using the Printer Management dialog box, refer to the
following table.

 Using the Printer Management Dialog Box
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Options Description

Installed
Printers

The Installed Printers field displays a list of all currently installed printers.

Printer
Drivers

Use the Printer Drivers drop-down list to select a printer driver.

Defined
Ports

Use the Defined Ports drop-down menu to select a defined port.

Ports To define a new printer port and/or replace or remove an existing printer port, click the Ports
button to access the Ports dialog box. For more information on the Ports dialog box, refer to
Defining Printer Ports.

Add To install a new printer, select a printer driver and a defined port, then click the Add button. The
new printer appears in the Installed Printers list.

Replace To replace an existing printer, click the printer you want to replace in the Installed Printers list.
Then select a new printer driver and a new defined port. Click the Replace button to replace the
printer. The new printer appears in place of the old printer in the Installed Printers list.

Remove To remove an existing printer or group of printers, click the printer(s) you want to remove in the
Installed Printers list and then click the remove button.
A confirmation dialog box appears asking if you really want to remove the printer. Click OK to
confirm or Cancel to abort the removal process. If you click OK, the printer(s) no longer appears
in the Installed Printers list.

Help Click the Help button to access the online context sensitive help.

Close Click the Close button to dismiss the Printer Management dialog box and accept the changes.
Settings will be saved upon exit.

 Defining Printer Ports

The Ports dialog box enables you to define new printer ports and/or replace or remove
existing printer ports. To access the Ports dialog box,

Choose File > Print Setup. The Print Setup dialog box appears.1.
Click the Printer Management button. The Printer Management dialog box appears.2.
Click the Ports button. The Ports dialog box appears.3.

For detailed information on using the Ports dialog box, refer to the following table.

 Using the Ports Dialog Box
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Option Description

Ports The Ports field displays a list of ports. Port names can be any names you choose with the
exception of FILE: which is a reserved port name.

Edit Port The Edit Port field is used to enter a new port. After you have entered the port definition,
click the Add/Replace button.

Add/Replace Click the Add/Replace button to update the Ports list with contents of Edit Port field.

Remove If you want to remove a port from the Ports list, click the port name in the Ports list to
activate the Remove button. Click the Remove button to remove the selected port.

Import from
Spooler

Click the Import from Spooler button to generate a list of ports (based on your printcap file).

Note that this third party utility is NOT guaranteed to operate on currently supported
platforms.

Help Click the Help button to access the online context sensitive help.

Close Click the Close button to dismiss the Ports dialog box and accept the changes. Settings will
be saved upon exit.

 Printing to a Printer, Plotter, or File

The Print dialog box enables you to output your information to a supported printer,
plotter, or specified file. To access the Print dialog box,

Choose File > Print. The Print dialog box appears.1.

For detailed information on using the Print dialog box, refer to the following table.

 Using the Print Dialog Box



IC-CAP 2011.01 - Introduction and Basics

181

Option Description

Printer The Printer options in the Print dialog box enable you to define a printer and the output
characteristics.

  Name: Select a printer from the Name drop-down list. If the printer you want to use is not
available in the list, click the Cancel button and access the Print Setup dialog box.

  Model Info: This section displays the printer model information.

  Status: This section displays information on the printer status. If the printer is ready to print, the
Status will display Ready.

  Properties Click the Properties button to view or set additional options used in the Print Setup dialog
box. For more information, refer to Setting Up a Printer.

  Fit to Page Activate the Fit to Page option if you want your output to be automatically scaled to fit on
the page.

  Print to File Activate the Fit to Page option if you want your output to be directed to a file.
When this option is selected, the Number of Copies feature is deactivated and the Print to
File feature is activated.
When this option is deactivated, the Number of Copies feature is activated and the Print
to File feature is deactivated.

Copies This section is used to set the number of copies to print.

  Number of Copies Use this feature to specify the number of copies to print. If Print to File is selected, this
feature is deactivated.

Print to File This section is used to define the type of file you want to send your output to.

  File Format: Use this feature to specify the file format to save your output to.
After you have selected your file format, click OK in the Print dialog box. A Print to File
dialog box will appear enabling you to define the path and name of the file. For more
information on the Print to File dialog box, refer to Printing to a File.
If the Print to File radio button is deselected, this feature is deactivated.

OK Click the OK button to accept the settings and send your output to the selected printer or
file, depending on how you have set your options. Settings will be saved upon exit.

Cancel Click the Cancel button to dismiss the Print dialog box. Settings will not be saved upon
exit.

Help Click the Help button to access the online context sensitive help.

 Printing to a File

The Print to File dialog box enables you to define a destination path and file name and
then output your information to the specified file. To use the Print to File dialog box,

Choose File > Print. The Print dialog box appears.1.
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Select the Print to File option in the Printer section of the Print dialog box. Notice that2.
when you select the Print to File option, the Print to File section is activated enabling
you to select a file format.
Use the File Format drop-down list to select the desired file format. Options include3.
JPEG, GIF, PDF, Bitmap, and HP-GL/2.
Click OK in the Print dialog box. The Print to File dialog box appears.4.

Enter the file name for your output in the Selection field.5.
Click the OK button to output the file.6.

 Printing from the PC
This section describes some of the actual printing features available on the PC. For
information on basics (such as adding a printer), refer to your Windows documentation.

Printing from IC-CAP on the PC is accomplished by establishing the desired print setup and
then choosing File > Print. Listed below are some of the more common options you can
set through the Print Setup and related dialog boxes:

Note
The options available vary based on the printer/printer driver you select.

Printer (select any installed printer)
Paper size and source
Orientation
Number of copies
Single- or two-sided printing
Scaling

When you choose File > Print, you can select from the following additional options:
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 Establishing a Print Setup

To establish a print setup:

Choose File > Print Setup.1.
Select the desired printer from the drop-down list.2.

Change any of the options here as desired, or click Properties to set additional3.
options, such as Scaling. Note that the appearance of the Properties dialog box varies
depending on the selected printer.
Change any other options as desired and click OK to dismiss the Properties dialog4.
box.
Click OK in the Print Setup dialog box and you are ready to print.5.

 Basic Printing

To send the entire contents of the window to the printer:

Choose File > Print and a dialog box appears.1.
Change any print options as needed, and click OK.2.

 Automating Print Functionality
The following print functionality can be automated via PEL:
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Print to the following supported file types:
hpgl2
black and white postscript
emf for the PC only

Display the File > Print dialog box, which enables the user to select a printer and to
request a printout.

Starting with IC-CAP 2004, you can no longer send a print file to the printer from PEL
without user intervention. You can not create print files other than the ones listed above.
For example, you can not create a color postscript file formatted for a color printer. To
generate that type of file, you must use the File > Print dialog boxes.

Also, the semantics of the Print Via Server command have changed slightly with IC-CAP
2004. In previous releases, if a printer was setup as the default, issuing a Print Via Server
command would print the file with no user intervention. Now, the Print Via Server
command always displays the print dialog box requiring user intervention. See the
following examples.

 ! Displays dialog box as though File > Print menu had been

! selected. You cannot anticipate the dialog with

! optional arguments, it will always come up.

iccap_func\("myPlot","Print Via Server"\)

! following line creates an HPGL2 file

iccap_func\("myPlot","Dump Via Server","Y","hpglfile.hgl", "HPGL2"\)

! following line creates a black & white postscript file

iccap_func\("myPlot","Dump Via Server","Y","psfile.ps","PS"\)

! following line creates a .emf file on PC only

iccap_func\("myPlot","Dump Via Server","Y","emffile.emf", "EMF"\)

! Note, the following form of the command worked in

! previous releases of IC\-CAP but is no longer supported.

iccap_func\("myPlot","Dump Via Server","N"\)

! Displays dialog box as though the Print button had been

! pressed on a tabular data window

iccap_func\("myOutput","Print Via Server"\)

For additional information, see Dump Via Server (prog) and Print Via Server (prog).
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 Macros
The following topics are covered under Macros:

Introduction and Basics
Creating and Running a Macro
Saving Macros
Macro Features
Adding a Macro to the Model

 Introduction and Basics
This section contains procedures for creating, editing, and using macros. Macros can
provide a powerful tool for automating routine or repetitive procedures by increasing the
efficiency of your operations. Macros, consisting of short programs or scripts that execute
IC-CAP commands in a predetermined sequence, automate routine test procedures so that
the execution of a single command measures, extracts, simulates, optimizes, plots, and
reports on the characteristics of the tested device or circuit.

Macros are simply a way to automate routine operations or to simplify complex
operations. For example, you can create a macro to do the following:

Measure all four setups of the dc DUT in the npn model.
Run extractions, simulation and optimization.
Display all plots in a model.

In addition to these routine tasks, you can perform more sophisticated operations, such
as:

Writing data to an external data base.
Making choices and branches, based on the value of data sets, parameters or
variables.

Pre-defined macros are provided for each model and you can execute macros manually or
automatically upon IC-CAP startup. Macros are easy to write-the facilities for creating,
editing, and running macros are available in the Macros folder. Each model can have any
number of macros, as the example in the next section demonstrates.

 Creating and Running Macros
Refer Creating and Running a Macro (prog) for further details.

 Saving Macros
Refer Saving Macros (prog)

 Macro Features
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Refer Macro Features (prog)

 Adding a Macro to the Model
Refer Adding a Macro to the Model (intro)
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 Transforms
 Creating and Running a Transform
A transform is a framework for mathematical or logical functions that operate on data.
Extraction and optimization are accomplished through the use of transforms. A transform
can operate on any combination of data sets, parameters, and variables. These inputs are
used to calculate either a new data set or new values for parameters and variables.
Transforms are created for Setups, since they typically operate on data from a particular
Setup.

To create and run a transform:

Open the Model window and select the desired Setup.1.
Click the Extract/Optimize tab and note the list of existing transforms.2.
Click New and provide a name for the new transform in the dialog box that appears.3.
Click OK and the new transform name is added to the list.4.
Select an existing function from the Browser, or type Program2 or Program in the5.
Function field, and press Enter to create your own.
Fill in the argument fields displayed for a selected function, or type the desired text if6.
creating your own.
To run the transform, click Execute.7.

Related Topics:

Using Transforms and Functions (prog)
Creating and Running Macros (prog)
Parameter Extraction Language (prog)

 Creating a Function
To create a new function:

Click the Extract/Optimize tab.1.
Select the transform for which you want to create a function.2.
Type Program2 or Program in the Function field and press Enter. The window changes3.
to display a scrollable text field.
Type the desired text.4.

Note
When you create a function within the user interface, you use a BASIC-like language referred to as
Parameter Extraction Language (PEL). You can also create functions outside IC-CAP using C language.

 Selecting an Existing Function
To choose a function from the Browser:

Select the transform for which you want to assign a function and click the Browse1.
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button.
In the dialog box that appears, select the appropriate Function Group to display a list2.
of available functions in that group.
Select a Function and a brief description is displayed.3.
Click Select and the dialog box disappears and the function name appears in the4.
Function field.
Where applicable, assign appropriate values or edit as needed.5.

Related Topics:

Using Transforms and Functions (prog)
Creating and Running Macros (prog)
Parameter Extraction Language (prog)

 Saving Transforms
By default, transforms are saved when you save the model file. But you can explicitly save
a transform at any time and specify another directory, if desired.

To save transforms:

With any of the transforms in the Extract/Optimize folder selected, choose File >1.
Save As.
Select the Transform option.2.
Select the transform name from the drop-down list.3.
If desired, change the path using the Browser.4.
If desired, supply a different filename in the File Name field.5.
Click OK.6.

Related Topics:

Using Transforms and Functions (prog)
Creating and Running Macros (prog)
Parameter Extraction Language (prog)
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 File and Data Management
The directory containing the example model files is protected to preserve an original copy
of each model file. The typical method of modifying a model file is to use the Save As
command and save a copy of it to another directory. You will probably want to create one
or more directories, in any terminal window, for storing your model files and data.

Quick access to the example model files is provided with the File > Examples command in
the Main window. When you want to open a model file other than one from the examples
directory, by default, the path in the dialog box is set to the directory from which you
started the program. Double-click to get to the desired directory.

Note
A symbol displayed in the Main window represents a model file currently in memory. If you close a Model
window using File > Close, the file remains in memory and can be reopened by double-clicking the
symbol.

 

 Opening Files
To open a file:

Choose File > Open and a dialog box appears. By default, the path in the Filter field1.
is set to the directory from which you started the program and the filter is set to
*.ext where ext is an extension specific to the task you are performing. (For
example, *.mdl for model files, *.hdw for hardware configuration files, etc.). All files
in the current directory with that extension are displayed.
 
Adjust the path as needed. You can type in the Filter field and then click the Filter2.
button or use the mouse to navigate the list of Directories.

Note
The path for IC-CAP model files cannot contain any folder names that use a space. For example,
C:\Model Files\IC-CAP 2004. If a model file is saved in a folder name with spaces, you will not be
able to open the model file. You will have to move the model file to a folder name that does not use
a space.

To choose a file from the Files list box, double-click it or click once and choose OK.3.
(Tip: If you click once, you will see the selected filename reflected in the Selection
field.)

Note
If loading a model file, once it is loaded, a symbol with the model name is displayed in the work
area. Double-click the symbol to open the Model window.

 

 Opening Parts of a Model File
The File > Open command in the Model window enables you to open a file (previously
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saved using File > Save As in the Model window) that contains some portion of a model.
To open a file containing a portion of a model:

If you want to replace some portion of the current model file with a portion of1.
another file, select the item you want to replace.
Choose File > Open in the Model window.2.
Select the appropriate file type and click Browse to view the files of that type in the3.
directory you specify.

Note
The path for IC-CAP model files cannot contain any folder names that use a space. For example,
C:\Model Files\IC-CAP 2004. If a model file is saved in a folder name with spaces, you will not be
able to load the model file. You will have to move the model file to a folder name that does not use
a space.

Select a file and click OK.4.
For Model Parameters and DUT Parameters, select Replace Parameter Set or Read5.
Values Only and click OK.

Replace Parameter Set replaces all Value, Min, and Max values with the ones in
the selected file. If the selected file does not include Min and Max ranges (e.g.,
when reading pre-IC-CAP 2004 parameter set files), the existing Min and Max
ranges are deleted.
Read Values Only replaces parameter Values while maintaining existing Min and
Max ranges if possible. If the new Value is outside the existing range, Min or
Max is extended to include the new Value and a warning is displayed in the
Status window.

For all other Model folders, select the Replace option to use the specified file as a6.
replacement and click OK. To add the specified file, make sure the option is turned
off and click OK.
 

 Saving Files
To specify a directory and a filename:

Choose File > Save As and a dialog box appears.1.
Double-click in the Directories list box to locate the desired directory.2.
To save to an existing file, select that filename from the Files list box and click OK.3.
To save to another name, type that name in the Selection field and click OK.
Where applicable, click OK to dismiss the previous dialog box.4.

 

 Saving a Model File
From the Save As dialog box in the Main window:

Select all models you want to save to one model file.1.
Accept the default status of saving the file with the measured and simulated data, or2.
enable the option to save without it.
Adjust the path and filename as needed, and click Apply.3.
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Hint: To avoid typing a lengthy path change, use the Browser.

Note
The path for IC-CAP model files cannot contain any folder names that use a space. For example, do
not save to C:\Model Files\IC-CAP 2004. If you include a space in a folder name, you will not be able
to load the model file. You will have to move the model file to a folder name that does not use a
space.

Continue saving as needed, clicking Apply to effect each change.4.
Click OK to dismiss the dialog box.5.

Note
You can also save a model file from the Model Window if you want to save all components to one
file.

 

 Saving Parts of a Model File
When you choose File > Save As in a Model window, you can choose which part of the
model to save to file: DUT, setup, input, output, transform, plot, macro, variable table,
parameter set, circuit description, or instrument options.

Select the option representing the portion of the file you want to save. (Where1.
applicable, select the option from the drop-down list.)
Accept the default status of saving the file with the measured and simulated data, or2.
enable the option to save without it.
Adjust the path and filename as needed.3.

Hint: To avoid typing a lengthy path change, use the Browser.

Note
The path for IC-CAP model files cannot contain any folder names that use a space. For example, do
not save to C:\Model Files\IC-CAP 2004. If you include a space in a folder name, you will not be able
to load the model file. You will have to move the model file to a folder name that does not use a
space.

Click OK to effect the save and dismiss the dialog box.4.

 

 Changing Default Directory
By default, model files and data will be saved to the directory from which you started the
program.
To change the directory:

Choose File > Change Directory. By default, the path in the Filter field is set to the1.
directory from which you started the program.
Adjust the path as needed. You can type in the Filter field and then click the Filter2.
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button or use the mouse to navigate the list of Directories.
When the Selection field reflects the desired directory, click OK.3.

 

 Importing Data into a Single Setup
Select the DUT and setup.1.
Select File > Import Data and choose Active Setup.2.

Alternatively, you can select Measure/Simulate and click Import Data.
Enter the name of the file directly into the field corresponding to the setup, by typing3.
in or by using the File Browser.
Select a fill data type.4.

Measured if available, otherwise Simulated: Outputs of type M or B receive
mdm data in their measured array. Outputs of type S receive mdm data in their
simulated array.
Measured only: Outputs of type M or B receive data in their measured array.
Outputs of type S do not receive any data.
Simulated if available, otherwise Measured: Outputs of type S or B receive
mdm data in their simulated array. Outputs of type M receive mdm data in their
measured array.
Simulated only: Outputs of type S or B receive mdm data in their simulated
array. Outputs of type M do not receive any data.

Click OK. The data is now imported into the outputs of the setup.5.

 

 Importing Data into All Setups in an Active DUT or All
DUTs in the Model

Select the DUT.1.
Select File > Import Data and choose one of the following:2.

All Setups in Active DUT
All DUTs in Model
The dialog box that appears has three columns (DUT, Setup, Data
Filename) and a Fill Data Type selection area.

Specify a filename for each setup. You can type the path and filename directly in the3.
Filename field, or use the Browser to select it.
Click Apply each time you specify a filename for a setup.4.
Select a fill data type.5.

Measured if available, otherwise Simulated: Outputs of type M or B receive
mdm data in their measured array. Outputs of type S receive mdm data in their
simulated array.
Measured only: Outputs of type M or B receive data in their measured array.
Outputs of type S do not receive any data.
Simulated if available, otherwise Measured: Outputs of type S or B receive
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mdm data in their simulated array. Outputs of type M receive mdm data in their
measured array.
Simulated only: Outputs of type S or B receive mdm data in their simulated
array. Outputs of type M do not receive any data.

Click OK.6.

Tips

To view the header of an MDM data file, select the Setup cell in the dialog box, enter
the corresponding MDM filename, then click View.
To create the inputs and outputs for a new setup from the header of an MDM file,
first create a new setup, select the setup name in the dialog box, enter the
corresponding MDM filename, and click Create.

See Also

Importing Data into a Single Setup
MDM Data (data)
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