NOTICE: This document contains references to Agilent
Technologies. Agilent’s former Test and Measurement
business has become Keysight Technologies. For more
Information, goto  www.keysight.com.

KEYSIGHT

TECHNOLOGIES




IC-CAP 2011.01 - Target Modeling

~i.% Agilent Technologies
' IC-CAP 2010.08
July 2010

Target Modeling

This is the default Notice page



IC-CAP 2011.01 - Target Modeling

© Agilent Technologies, Inc. 2000-2010

3501 Stevens Creek Blvd., Santa Clara, CA 95052 USA

No part of this documentation may be reproduced in any form or by any means (including
electronic storage and retrieval or translation into a foreign language) without prior
agreement and written consent from Agilent Technologies, Inc. as governed by United
States and international copyright laws.

Acknowledgments

UNIX ® is a registered trademark of the Open Group.

MS-DOS ®, Windows ®, and MS Windows ® are U.S. registered trademarks of Microsoft
Corporation.

Pentium ® is a U.S. registered trademark of Intel Corporation.

PostScript® is a trademark of Adobe Systems Incorporated.

Java™ is a U.S. trademark of Sun Microsystems, Inc.

Mentor Graphics is a trademark of Mentor Graphics Corporation in the U.S. and other
countries.

Qt Version 4.5

Qt Notice

The Qt code was modified. Used by permission.

Qt Copyright

Qt Version 4.5, Copyright (c) 2009 by Nokia Corporation. All Rights Reserved.

Qt License Your use or distribution of Qt or any modified version of Qt implies that you
agree to this License. This library is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License as published by the Free
Software Foundation; either version 2.1 of the License, or (at your option) any later
version. This library is distributed in the hope that it will be useful, but WITHOUT ANY
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details. You
should have received a copy of the GNU Lesser General Public License along with this
library; if not, write to the Free Software Foundation, Inc., 51 Franklin St, Fifth Floor,
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Graphic User Interface for Target
Modeling

The Target Modeling toolkit's GUI uses two windows:

« The control GUI to manage data, simulations, and plots.
« Plots/multiplots as the main objects to perform the target modeling.

The control module is an IC-CAP .mdl file, which manages the OTM objects and handles
templates necessary for PCM simulation, report generation, and so on.

Control code and data are separated-control code is found inside the model
Target_Modeling and data is stored inside data files using the naming convention
OTM_Data_ (ProjectName).

The data files contain simulation setups, plots and multiplots, methods (plot optimizers,
extractions), as well as user specific extensions. All relevant information regarding one
project is stored in a single model file.

The control module contains 4 tabs: Data, Diagrams, Reports, and Options. The following
figure shows the Target Modeling GUI.

Target Control GUI

5% Target_Modeling:1

File Diagrams Report  Options  Tools  Help

Data Diagrams | Report | Options |

Data
= ) PCM Data
= [ 90nm
# 42+ fwvailable Outputs
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I+ Al
i L-Scale We=5u
# L-Scale W=250n
2 L-Scale W= 180n
# W-Seale L=Su
# == Conductance
| [ @ Transconductance
| = fi# 1ccap DUTs-Setups
| & A ntype_large
[~ ntype_short

OTM Object | OTM_exarmple

Using the Data tab, you can manage PCM as well as device data. PCM data format is read
from files formatted as a table containing the following details:

The first n rows of the table are the KEYWORD rows. Keywords can be:

« TYPE with
o ID=Identification
o IP=Instance parameters
o PCM=PCM parameters
+« NAME with
o Fixed Values for:
« DevicelD
= Name
o Denominators for:
« Instance Parameters (IP)
= PCM values (PCM)
o SUBSET: specifies in detail the PCM values. Allowed names are mean, min, max.
These identifiers are used to add statistical data.
e« TEMP: Temperature of the PCM value

In the file, each column is separated by a comma (, ). This enables you to import the file
into table calculation programs like MS Excel.
5



IC-CAP 2011.01 - Target Modeling

A further rule for the rows NAME and TEMP is that if a cell does not contain a name, the
value of the previous one is used. For example, T=25°C is used as a temperature for all
PCM values as long as no other value is specified. Following is an extract from such a PCM

data file.

A B | C [ D E [ F G H [

1 |TYPE__NID IP
_ 2 |[NAME  DevicelD Mame Length  “Wyidth  AD AS FD Ps
3 |SUBSET
4 |TEMP

i 0 M_w5000u_ 9.00E-08 5.00E-06 S.00E-14 9.00E-14 1.18E-06 1.18E06 1
B 1 W_W5000u_ 1.30E.07 500E-06 1.30E-13 1.30E-13 1.26E-06 1.26E-06 1
7 2 MN_W&E000u_ 160E-07 500E-06 160E-13 1.60E-13 1.32E06 1.32E06 1
g 3 N_W5000u_ 250E-07 5.00E-06 250E-13 2.50E-13 1.50E-06 150E-06 1
9 4 N_W 5000u_ 8.00E-07 5.00E-06 6.00E-13 8.00E-13 260E-06 2B0E-06 1
10 5 N_W5000u_ 1.00E-06 5.00E-06 1.00E-12 1.00E-12 3.00E-06 3.00E-06 1
11 6 M_W 5000u_ 5.00E-06 5.00E-06 500E-12 5.00E-12 1.10E-05 110E05 1
12 7 N_WY 5.000u_ 1.00E-05 5.00E-06 1.00E-11 1.00E-11 210E05 210E05 1
13 8 nN_W180.0n_ 1.30E-07 1.80E-07 1.30E-13 1.30E-13 1.26E06 1.26E06 1
14 9 M_WW180.0n_ 2.50E-07 1.80E-07 250E-13 2.50E-13 1.50E06 1.50E06 1
15 10 N_WW 180.0n_ 8.00E-07 1.80E-07 5.00E-13 S.00E-13 260E06 260E06 1
=N 11 N_W 180.0n_ 5.00E-06 1.80E-07 500E-12 5.00E-12 1.10E-05 1.10E05 1
17 12 N_W 180.0n_ 1.00E-05 1.80E-07 1.00E-11 1.00E-11 210BE05 210E05 1
18 13 N_W 250.0n_ 1.30E-07 2.50E-07 1.30E-13 1.30E-13 1.26E06 1.26E06 1
15 14 MN_W 2580.0n_ 2.80E-07 2.50E-07 250E-13 2.80E-13 1.80E-06 1.50E06 1
© Note

Default content for empty cells depends on cell type:

e An empty cell inside the NAME row leads to an error message. For example, if the cell following AD
is empty, you will get the error message Instance Parameter Name AD is defined twice. In this case,
the name of the previous cell is used and double definitions are not enabled.

e An empty data value cell is assumed to have the value of zero.

The goal is to create an easy way to import data from different sources that are not in the
IC-CAP data format. Using this comma separated value ( .csv ) format, any data format
can be used with only minor changes. Those changes can be made using a table
calculation program like MS Excel or similar programs.

The Diagrams tab enables you to open plots-single plots can be opened from the left side
and multiplots from the right side of this tab.

On the Report tab, you can create customized reports of the projects.
The Options tab enables you to select the simulator and circuits.

« Back to Target Modeling (target)

Using the Target Modeling Tool

To better understand the tasks and to easily try the features, an examples directory is
provided. This directory is located in
$ICCAP_ROOT\examples\model_files\target_modeling\examples. It contains the
BSIM4_NMOS_example and the BSIM4_NMOS_from_scratch directory, which contains a
few subdirectories and specific example files that will enable you to try all aspects of
Target Modeling.

The iv_data directory contains a .dut, .mdl, .mdm, and .set file. Another directory,
model_parameters, contains an .mps file. The simulation_template_configuration directory
includes the SinglePoint.csv and Vth_GM.csv simulation templates. The pcm_data_files
directory includes 3 example PCM files.

To create a new project, open $ICCAP_ROOT\examples\model
files\target_modeling\TargetModeling.mdl. Double choose Target_Modeling to open the
Target Modeling GUI, then choose File > New from the menu. The Create New Data Model
window opens prompting you to enter a name for the new data model. Standard naming
convention applies and every new model begins with the prefix OTM_, but you can
overwrite this setting.

!y |Caution
Do not rename the data model file as it is displayed in the main window after creation: It will be unusable!

Next, select a Simulation Model from the list on the left side of this window. Once you've
selected a model, the right side of this window lists the available simulators (see the
6
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following figure).

Startup Wizard to create a new data model

M Create New Data Model

Mame of Model 0T |

Simulation Maodel Simulator
BSIM3 ADS
BSIM4 HSPICE
PSP Spectie
BSIMS013
BSIMS014

Circuit

(@ Default circuit is not available

¢~ Default circuit iz not available

c | ]

Model Parameter Set

o Default from circuit
¢ Import |C-CAP .mps farmat
¢ mport IC-CAF . cir format [specify simulator]

¢ |mport .model in text file [specify smulator]

=
| ]
Create Cancel

Select a simulator then select if you would like to use the default NMOS or PMOS circuit
from the respective Modeling Package. This selection is only available after you select a
simulator. If you would like to select another circuit, you can browse to the location where
the circuit is located.

Next, select the model parameter set. You can use the default model parameter set

included in the circuit or import one in IC-CAP .mps or .cir format. For example, import

the example model parameter set from
$ICCAP_ROOT\examples\model_files\target_modeling\examples\BSIM4_NMOS_from_scratch\model_parameters.

You can also import a model parameter set in the form of a text file. This could be a
library file containing only one .model statement. In this case, select the simulator of
origin for the model file. For example, this selection gives you the flexibility to generate a
model for a new technology based on an existing model card. You can check if the used
model obtains adequate results for, let's say, reduced gate dimensions.

« Back to Target Modeling (target)

PCM Data

After creating a new project, the Target Modeling window shows two entries on the Data
tab.

Data l Diagrams ] Report ] Options ]

Data

I PCM Data
fE® ICCAP DUTs Setups

For the first step, right click PCM Data and choose New PCM Table. The New PCM DUT
dialog box appears prompting you for the name of the new PCM DUT and the location of
the data file, which needs to be in comma separated value ( .csv ) format as previously
explained.

See
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$ICCAP_ROOT\examples\model_files\target_modeling\examples\BSIM4_NMOS_from_scratch\pcm_data_files
for example PCM data files.

After choosing OK, a new PCM table is inserted below PCM Data on the Data tab. Now,
right click this new entry to:

o Delete PCM Table

o Derive a Subset or Device Data

« Re-import data for this PCM table by selecting the desired data files. This routine
checks the data file format and reports any errors.

« Open a Device Info table showing the names and some parameters of the devices
read in from the .csv table.

D Note
Derive device data is available only after adding and configuring a Simulation Template, defining at
least one working condition.

Now, the Data tab contains the information for the PCM below the named PCM in the form
of a tree structure. The branches are:

« Available Outputs

The available outputs are read in from the PCM data file - they represent
your PCM data.

e Simulation Templates
A configured Simulation Template is required to simulate PCM data and to
derive device data. Therefore, it is recommended to add and configure a
Simulation Template first.

o All

The All branch contains device data as specified inside the .csv file just read
in. The Device Info table shows the devices configured for this PCM set.

Simulation Templates

From imported PCM data, two kinds of diagrams can be generated using predefined
simulation templates:

« PCM values versus Instance Parameters (L, W,..) or temperatures
Those plots are generated by configuring Simulation Templates.
« I-V like diagrams with only a few measured points but full simulation

Those plots are based on the configuration of the Simulation Templates
plus the subset configuration done while deriving device data.

Possible kinds of diagrams
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I-¥ like diagrams
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PCM values versus Instance P aram eter

Two types of simulation templates are implemented for the BSIM3, BSIM4, and PSP
models:

« Single Point current
o Vth(Iref,gm), max(gm), gm(Vth+offset)

Two similar templates for the BSIMSOI3 and BSIMSOI4 models are implemented (for
floating body SOI):

« Single Point current
o Vth(Iref,gm), max(gm), gm(Vth+offset)

Additional templates can be added using the Target_Modeling file.

A support document named "Simulation Templates for Target Modeling" describes how to
implement a user defined model.

The following figures show the two different types in more detail:

MOS single point simulations for I/V-diagrams

A IX
[]

] Current
in one bias point

O

» V

MOS threshold voltage related simulation Vth
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2! 'L

@F * NF*WI/L

Vt(gm) £ Vt0-VD/2

» Vg
Vt(Iref) /vto

MOS threshold voltage related simulation conductance

4 gm max(gm)

Gm(Vt+Xx)

Vt(Iref)
I| »\/g

Now that PCM data has been read in and subsets have been created (if desired), the next
step is to configure the simulation templates.

© Note
Although you can create subsets, you cannot create device data until at least one simulation template is
configured.

Right click the Simulation Templates entry below the PCM Data set you just created, then
choose Add Template. The Simulation Templates dialog box appears. Select a template
defined for the model and simulator, then choose OK. The selected simulation template is
inserted into the PCM data tree. Right click this template then choose Configure Template.
This opens the Simulation Assignment window to let you assign specific parameters as
well as inputs and outputs for this simulation configuration. See the following figure for
details.

Simulation Assignment

10
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M Simulation Assignment - Sim_PCM_90nm_MOS_Single_Point |:|@|g|

Inztance Parameters
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A number of parameters are available for the model chosen. You can change the allocation
of the parameter to any other parameter of this set or you can enter a specific value by
selecting no allocation ( - ) from the drop down list. In this case, the column named
Default is highlighted and you can enter a value for the selected parameter. If no
parameter value was specified, the default value defined in the circuit is used.

The next step is to add input values for the simulation sources. In templates for single-
point simulations, the values entered are the simulation values for the exact points
(values of VD, VG, VS, and VB) given.

Single Point Current
Inputs Outputs

WD VG V5 VB D IG 15 B

e fe @B o TR | R | B | P
i e o o ([TTINEY | FCY | P | B
me o o o [0 | BT | MY | P

T71 717

You can add more points (lines) or you can delete points by choosing the appropriate
button at the bottom of the Simulation Assignment window. Mark the lines you would like
to delete by selecting the check box in front of the line(s).

In Vth simulations for example, enter the start, stop, and step values for VG, then enter
the rest of the voltages for swept simulations.

11
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Wth{lref.gm]. max(gm]. gm{Wth+offset)

Inputs Outputs Parameter
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As shown in the figure above, the first order sweep VG can only be entered into the first
row. The following rows are grayed out for VG sweep - you can only enter VD, VB, and VS.

The following plot shows the simulation of part of our example PCM data using the settings
from the figure above. The plot shows the value of VTLIN vs. device length (on a
logarithmic x-axis) for a subset of devices using a width of 5 um and a temperature of
25°C.

M |og VTLIN:16
File Options Optimizer Windows Help

VTLIN PO
880 T IIIIIII: T IIIIIII: T T T TTTTT k

8

TEO|--

OO0 -

[:1] 1 111111 I: 1 111111 I: 1 L1 1111l
1E-8 1E7 1E8 1E5 | X
Length [LOG] Y

Now choose the outputs from the drop-down list. Enter parameters to the right of the
outputs. For example, if you are interested in the value for g, at the point (Vth + x),

oo

abs(VTLIN.m) abs(VTLIN.g) spread [E-3]

enter the x-value into the applicable column named x. For Vth(I ) simulations, you have
to assign a value for I ¢ into the specified column labeled IDREF. If you would like to
extract Vth(Ip,.¢) and g, in one step, the I ¢ value is valid for both simulations. For
different values of I ¢, use an additional line and enter different values as desired into

the I f column.

You can also Export or Import settings from this window to use in other simulations.

From the directory
$ICCAP_ROOT\examples\model_files\target_modeling\examples\BSIM4_NMOS_from_scratch\simulation_template_configuration,
you can import one of the simulation templates provided: SinglePoint.csv or Vth_GM.csv

Derive Subset

To derive a subset from all devices, right click the All branch (or the PCM tree top) then
choose Derive Subset. In the Prompt Dialog, enter the name of the new subset. You can
derive subsets based on preferred criteria selected in the Select Criteria window. See the
following figure.

Selections for a subset

12
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Select Criteria

Configuration of the Plots

Hohwiz:

Constant Parameter for Annotation:

Temperature Selection

Aveailable Temperatures:

125.0

[ whidth ~|

Help

| Mext > | Cancel |

You can configure plots for the new subset based on different selectable X-Axis
parameters as well as annotation parameters and temperatures, if available.

After selecting the subset criteria and choosing OK, a window opens showing the devices
that are included in the subset. You can select one or more devices from this window.
Choose OK and the new subset is inserted into the tree.

Derive Device Data

To derive device data, right click a PCM table or a subset then choose Derive Device Data.
The Device Simulation Wizard window opens. Enter a name for the simulation and choose
an available simulation template from the list, then choose Next.

Device Simulation Wizard

M Device Simulation Wizard

Enter a Simulation Mame

Pleaze enter a unigue name:

Simulation T emplates

OS5 14 Curve

Help

| Mest > | Cancel |

The Device Simulation Wizard window now displays items you can include in this device
simulation task. Choose one item from the list then click the right arrow to assign this
item to the IV-Curve section. To remove an item from this simulation, simply select the

item then click the left arrow.

Assignment of predefined simulations

13
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M Device Simulation Wizard |Z|E|E|
Select PCM Data Paints

[
43
Single Paint cument (1] 1 curve
ILIM 10M

IOFF

L[]

Help <Back| Mext > | Cancel |

See MOS single point simulations for I/V-diagrams and MOS threshold voltage related
simulation Vth for a graphical explanation of Single Point or Vth related items.

When you're done assigning data points, choose Next to enter simulation conditions. See
Device Simulation Wizard .

Enter the sweep order as well as the conditions for the first order sweep. The values for
the second order sweep come from the PCM data values - they cannot be changed in this
window.

First and second sweep order entries and their relationship to the plot

Fe gtoe Ogheie ndes e

1 =1 000 g e, TG00 Ak =] underlying 2. sweep:
T T 5
- Flwd =18V

vd =01V

é.
E.

Simulation assignment and related outputs at a predefined parameter value, IDREF
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VTLIN @ IDREF * WIL ; vd=0.1V

VTSAT@ IDREF * WIL ; vd = 1.8V

M Simulation Assignment - Sim_PCM_90nm_MOS_Vith_Gm
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In the example shown, the value of IDREF is identical for the determination of VTLIN and
VTSAT. However, it is possible to have different IDREF values. Simply enter the required
values into the proper field.

© Note
The value of IDREF is multiplied by W/L for each transistor.

Single Point Currents

©
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Relationship between inputs and outputs and their representation in the form of single
measurements

Device Simulation Wizard

15
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M Device Simulation Wizard M id_vg:3
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Entering Simulation Conditions (left) and resulting ID-VG diagram (right, shown for two
different temperatures). The squares show actually measured points.

Again, choose Next and you are prompted to select devices to include in this simulation
setup. After choosing the devices, choose Finish and the simulation setup is added to the
tree of PCM data using a specific symbol.

+ m W-Scale L=bu
+ &= Conductance
+ 5 Transconductance
- 5 MOS5_1
AR N_W5 000u_L90.00n

ICCAP DUTs-Setups

Right click ICCAP DUTs-Setups to display a menu that enables you to create a new DUT,
edit an .md/ data file, or import an .md/ or .dut file. Choose Edit Data MDL to display the
model file in edit mode. Since you can define everything inside this .mdl/ file, you must be
careful to create a functional model. The following figure shows the generated IC-CAP
model file.

DUTs-Setups | Circuit | Model Parameters | Model Variables | Macros |

Select DUT/Setup
- MP
ultiplats
Feparts Instruments
= PCM_frie
Al
Al _all
= Sim_PCk_frie_MOS5_Single_Paint
All
= Sim_PCH_frie_MOS_Vth_Gm
All
DEVICE_frie_DUT

Measure / Simulate  Instrument Options

After creating a new DUT, you can import .mdm files by right clicking and choosing
Import.mdm. An Import Wizard is opened and you are prompted to enter a name for the
DUT as well as the name and path of the .mdm file to be imported. See the following
figure for an example .mdm file provided for import.

Measurement Import Wizard
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B Measurement Import Wizard

Choose Mame and File

Please enter a unigue name:
MDA 1

Choose the File you want to use
|del_filesx’talget_modelingx’examplesJBSIhM_NMl]S_ffom_scratch.f’iv_datax’test.mdm l:l

| Mext > | Eancel|

After entering the information, choose Next and you get a warning to check nodes,
dimensions, and simulation settings. Choose Finish to import data into the setup and open
the IC-CAP model file for editing.

s Back to Target Modeling (target)

Diagrams

Use the Diagrams tab to define plots - Single Diagrams on the left and Multiplots on the
right. The Multiplots column is empty until you add a New Multiplot using the Diagrams
menu or the icon.

Data  Disgrams | Report | Options |
Single Diagrams Multiplots
=1 [ PCM Data
=] 90nem
o B Al
+ |2 L-Scale WeSu
+ [ L-Scale W=250n
+ E L-Scale W=130n
+ lﬁ W-Scale L=Su
+ £ Conductance
+ &= Transconductance

When you add a new multiplot, you are prompted to enter a nhame. To configure a new or
existing multiplot, first select the multiplot, then select the plots on the left side of the tab
and click the arrow to add the plots to the selected multiplot.

Data Diagrams | Report | Options |

Single Diagrams Mulbiplots
=l PCM Data + By LScale_w5u
- [ 90nm = By LScale W2G0n
+ @ Al = By LScale W180n
+ |2 LSeale w5 = By WScale L5u
+|# L-Seale w=250n = By Device Simulation

+ |£ L-Scale W=180n
+ m Ww-Scale L=Su

+ &= Conductance

+ &= Transconductance

Another method to configure a multiplot is to right click a plot on the left and choose
Copy, then right click on the desired subfolder on the right and choose Paste.

If you would like to change the arrangement of the plots, click the Move Up and Move
Down icons (yellow arrows) or right click a multiplot and choose Move Up or Move Down.

After the plots are configured, you can open single plots by double clicking on the plot or
select the plot then choose Diagrams > Display Single Plots from the menu or choose the
Display Plots in Single Diagrams icon. You can open more than one single plot if you select
multiple plots while pressing and holding Shift or Ctrl on your keyboard.
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You can open multiplots by double clicking on the multiplot or select the multiplot then
choose Diagrams > Display Multiplots or choose the Display Plots in Multiplots icon.

The Display Plots in Single Diagrams icon is shown on the left and the Display Plots in
Multiplots icon is shown on the right.
28]

2 b B

Data Diagrams |

Single Diagrams IMultiplots
= [l PCM Data + By LScale_WwS5u
- S0nm + Wy LScale_W2E0n

R + By LScale_Ww180n
+ [ L-ScalewaSu + By whcale_L5u

+ | L-Soale W=250n + By Device_Simulation
+ |£ L-ScaleW=190n

+ |£ W-Scale L=5u

+ £ Conductance

+ &= Transconductance

Click the + sign in front of one of the PCM data entries to open the tree of single
diagrams. You can then open the underlying plots by double clicking on them. However in
the example above, if you open the Conductance or Transconductance diagram tree, the
plots below that folder are separated by devices. Therefore, before you can open the
plots, you must first open the device folders.

Multiplot for Lscale_W5u for a Target modeling project

M | Scale W5u:8

File Options Optimizer Plots Windows Help
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You can also open a single plot in a mulitplot by clicking the _ sign in front of the multiplot
to open the tree, then double click one of the single plots. See the following figure.
- T Device_Simulation
id_vd
id_vd
id_vg
id_vg
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To get information regarding the origin of a plot, right click on the plot then choose Show
Origin. A dialog box similar to the following appears.

E fTarget_Modeling

Reference of plok{s):

PCM Dakaf90nmjL-Scale W=5ujlog_TON

To reconfigure plots, right click a plot then choose Edit. This enables you to change axis
settings and so on for selected plot.

After you open a single or multiplot, you can use all the features of an IC-CAP plot window
like the plot optimizer, tuner, and so on. Click the PO-field inside the plot to enable
changes in the optimizer area.

e Back to Target Modeling (target)

Report

Use this tab to create reports for the project. Choose Report > Configure to open the
Configuration of Report window. In this window you can enter a headline and comments
to be entered into the report, as well as the path for the report to be stored. Moreover,
you can choose to include the plot legend in the report and to set the plot size for the
report.

For a new project, the Report Structure field on the Report tab is empty. Choose Report >

Set Report Structure to Default to set the report structure to a predefined setup. This
enters a default structure that you can adapt to your needs.

Default report structure

Data ] Diagrams Report |0pt|ons|

Single Diagrams Report Structure
= ) PCM Data = [ PCM Data
- [ 90nm = 90nm
+ LEAII + 1 Device Info
+ [ L-Scale W=5u = 1 &l
#- [ L-Scale wW=250n ¥ [ LScalews=5u
#- [ L-Scale w=180n ¥ [ LScalews=250n
+ |2 W-Scale L=5u # [ LScale'w=150n
+ & Conductance + [ w-Secale L=5u
+ £ Transconductance + [ Conductance
ICCAP DUT =-Setups + 3 Transconductance
+ Multiplats

To adjust the default structure, use the right mouse button to change the order, delete,
rename, and add subsets or new folders to the structure.

When finished, choose Report > Generate Report. The report process starts and the
results are stored as .HTML files at the selected location. You can use any web browser to
view the files.

e Back to Target Modeling (target)
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Options

Use this tab to change which simulator is used with the project. The default simulator was
selected when you created the data model.

To change which simulator or the circuit is used, choose Options > Change Simulator and
Circuit. Select one of the available simulators as well as the circuit desired. After selecting
a simulator or circuit, a window opens enabling you to check the model parameters used
by the imported circuit.

Carefully check if the used circuit parameters match your needs. No checking routine is
implemented since one of the goals of this toolkit is to provide flexibility to use other
models or circuits without being bound to defaults.

If you would like to use a different simulator than those currently defined, edit the
Target_Modeling.mdl file and setup the new simulator by adding it to the transform
Configuration/Options/Define Simulators. A ReadMe section at the top of the transform
contains instructions on how to modify it and add your own simulator.

O Note
When editing the data model file, use File > RefreshTree from the menu or the appropriate icon 7 | for

the changes to take place. After you edit the Target Model file, close the GUI then reopen to get the
changes into the GUI.

Adding Your Own Simulation Templates

How to implement a user defined simulation template is described in the "Simulation
Templates for Target Modeling" support document. This procedure requires you being very
familiar with IC-CAP because model files have to be edited. There is no automatic error
check available, since you have all the capability that IC-CAP provides.

e Back to Target Modeling (target)
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